Willkommen

WipeFile
WipeFile
Dateien schnell und sicher löschen

Für Anregungen, Verbesserungs- und Erweiterungsvorschläge schreiben Sie bitte eine E-Mail an: info@gaijin.at.

Die neueste Version dieses Programms ist unter www.gaijin.at verfügbar.

Mit WipeFile können Sie Dateien und ganze Verzeichnisse schnell und sicher löschen. Dazu überschreibt WipeFile die Dateien vor dem Löschen, um eine Wiederherstellung zu verhindern.

Die wichtigsten der insgesamt 14 Löschmethoden bzw. Löschstandards sind

  • US Navy Standard "NAVSO P-5239-26 - MFM" und US Navy Standard "NAVSO P-5239-26 - RLL"
  • US Department of Defense "DoD 5220.22-M" und US Air Force "AFSSI5020"
  • Standard der North Atlantic Treaty Organization (NATO-Standard)
  • Peter Gutmann Secure Deletion

WipeFile kann auch auf einem USB-Stick betrieben werden.

Copyright © 2004-2008 Werner Rumpeltesz
E-Mail: | info@gaijin.at
Website: | www.gaijin.at


Lizenz und Haftung

Das Programm "WipeFile" und alle Programmteile, sowie die Dokumentation, sind nach dem österreichischen Urheberrechtsgesetz geschützt.

Durch die Verwendung des Programms stimmen Sie diesem Lizenzvertrag zu.

Pflichten und Einschränkungen

Das Programm darf, außer in den gesetzlich festgelegten Fällen, nicht dekompiliert oder disassembliert werden.

Weiters darf das Programm nicht verkauft, oder sonst, kostenlos oder gegen ein Entgelt weitergegeben, oder in irgendeiner Weise veröffentlicht werden. Dies gilt speziell für die Veröffentlichung im Internet, auf sog. Heft-CDs oder anderen Software-Sammlungen.

Zuwiderhandlungen können strafrechtlich und zivilrechtlich verfolgt werden.

Benutzungsrechte

Das Programm darf kostenlos für private und kommerzielle Zwecke genutzt werden. Die Anzahl der Installationen und der Benutzer ist nicht limitiert.

Alle anderen Rechte, einschließlich des Veröffentlichungsrechts, bleiben beim Autor.

Es besteht kein Recht auf Support oder sonstige Hilfestellung seitens des Autors.

Haftungsausschluss

Die Verwendung des Programms erfolgt auf eigene Verantwortung. Der Autor übernimmt keine Haftung für die Richtigkeit und Funktionsfähigkeit des Programms. Der Autor haftet weder für direkte, noch für indirekte Schäden, die durch das Programm oder einen Programmteil entstehen. Dies umfasst vor allem, aber nicht ausschließlich, Schäden an der Hardware, am Betriebssystem oder an anderen Programmen, sowie die Beeinträchtigung des Geschäftsbetriebes.

Ausnahmen

Die Erteilung einer Ausnahme von den Bestimmungen dieses Lizenzvertrages erfordert eine ausdrückliche und schriftliche (elektronische) Genehmigung des Autors.

Bei Fragen senden Sie bitte eine E-Mail an: info@gaijin.at


Updates

Legende:

[+] Neues oder ergänztes Feature
[*] Geändertes oder entferntes Feature
[-] Behobener Fehler

Version 2.1:
[+] Die Datei- und Verzeichnisliste kann jetzt sortiert werden.
[+] Die Zeitstempel (MAC-Zeiten) der Dateien und Verzeichnisse werden nun auf den 01.01.1980 geändert.
[+] Eine holländische Sprachdatei wurde hinzugefügt.
[+] Eine italienische Sprachdatei wurde hinzugefügt.
[+] Eine japanische Sprachdatei wurde hinzugefügt.
[+] Eine russische Sprachdatei wurde hinzugefügt.
[+] Eine spanische Sprachdatei wurde hinzugefügt.
[+] Nach dem Überschreiben einer Datei wird deren Länge jetzt auf Null gesetzt.
[+] Professional: Die Zeitstempel (MAC-Zeiten) von Dateien und Verzeichnissen können jetzt optional auf ein zufälliges Datum geändert werden.
[+] WipeFile kann jetzt in das Kontext-Menü und das Menü "Senden an" des Explorers integriert werden.
[-] Unterverzeichnisse konnten nicht immer gelöscht werden.

Version 2.0:
[+] Dateien können nun auf die Programmverknüpfung gezogen werden. Dadurch werden diese in die Liste der zu löschenden Dateien übernommen.
[+] Eine französische Sprachdatei wurde hinzugefügt.
[+] Es wurden drei neue Löschmethoden hinzugefügt. Somit stehen insgesamt 14 verschiedene Methoden zur Verfügung, um eine Datei zu überschreiben.
[+] Neben der Änderung der Befehlszeilenparameter können nun meherere Datei- und Verzeichnisnamen - auch mit Wildcards - angegeben werden.
[+] Professional: Die ausgewählten Verzeichnisse und Dateien können, gemeinsam mit der Löschmethode, abgespeichert und zu einem späteren Zeitpunkt wieder geladen werden.
[+] WipeFile unterstützt jetzt auch Wildcards (Platzhalter) in Dateinamen.
[*] WipeFile unterstützt jetzt auch sehr große Dateien (mit mehreren Gigabyte).
[!] WipeFile wurde komplett überarbeitet, was auch diverse Änderungen in der Bedienung betrifft. Bitte lesen Sie die Hilfedatei sorgfältig.


Allgemeines

Der Löschvorgang

Jede Datei wird mit der eingestellten Methode ein oder mehrmals überschrieben. Anschließend wird der Dateiname auf eine zufällige Zahlen- und Buchstabenkombination (in der selben Länge wie der Originalname) geändert und schließlich gelöscht.

Ordner werden nur dann gelöscht, wenn sie keine Dateien mehr enthalten. Ordnernamen werden vor dem Löschen ebenfalls auf einen zufälligen Wert umbenannt.

Verwendungshinweise

WipeFile überschreibt lediglich die Daten in den angegebenen Dateien selbst, nicht jedoch den File-Slack. Weiters können Inhalte der überschriebnen Datei noch in Auslagerungsdateien oder temporären Dateien enthalten sein, die vom Betriebssystem oder einem anderen Porgramm dort abgelegt wurden.

WipeFile ist nicht zum Entfernen von hoch sensiblen Daten von Datenträgern geeignet, da in diesem Fall aus Sicherheitsgründen der gesamte Datenträger überschrieben werden sollte. Dies wäre etwa bei geheimen militärischen Daten oder bei Firmengeheimnissen erforderlich.

Verarbeitung von Dateien und Verzeichnissen

Achtung: Bei der Angabe der Platzhalter "*.*" bzw. "*" werden alle Dateien und Unterverzeichnissen gelöscht. Wird als Dateimaske beispielsweise "*.txt" verwendet, werden nur die Textdateien im betreffenden Ordner, nicht jedoch in den Unterordnern gelöscht.

Sind beim Löschen einer Datei oder eines Verzeichnisses Fehler aufgetreten (z.B. wenn eine Datei vom Betriebssystem oder einem anderen Programm gesperrt wurde), wird der entsprechende Eintrag nicht aus der Dateiliste von WipeFile entfernt.


Löschmethoden

WipeFile - Einfach

Der Inhalt der Datei wird einmal mit einem festgelegten Text überschrieben.

Zero

Der Inhalt der Datei wird einmal mit 0x00 überschrieben.

Random

Der Inhalt der Datei wird einmal mit Zufallszahlen überschrieben.

Random & Zero

Der Inhalt der Datei wird einmal mit Zufallszahlen und danach mit 0x00 überschrieben.

Zero & Random

Der Inhalt der Datei wird mit 0x00 und anschließend mit Zufallszahlen überschrieben.

WipeFile - Standard

Der Inhalt der Datei wird mit 0x00 und anschließend mit einem festgelegten Text überschrieben.

MS Cipher

Der Inhalt der Datei wird mit 0x00, 0x80 und 0xFF überschrieben.
Dies entspricht der Löschmethode des Konsolenbefehls "cipher /W".

USN-MFM

Der Inhalt der Datei wird mit 0xFF, 0xBFFFFFFF und Zufallszahlen überschrieben.
Dies entspricht der Löschmethode des Standards "NAVSO P-5239-26 - MFM" der US Navy.

USN-RLL

Der Inhalt der Datei wird mit 0xFF, 0x27FFFFFF und Zufallszahlen überschrieben.
Dies entspricht der Löschmethode des Standards "NAVSO P-5239-26 - RLL" der US Navy.

DoD / USAF

Der Inhalt der Datei wird mit 0x00, 0xFF und Zufallszahlen überschrieben.
Dies entspricht der Löschmethode des Standards des US Department of Defense "DoD 5220.22-M" und der US Air Force "AFSSI5020".

Bit Toggle

Der Inhalt der Datei wird zweimal, jeweils mit 0x00 und 0xFF, überschrieben.

WipeFile - Sicher

Der Inhalt der Datei wird einmal mit 0x00, danach mit 0x80, sowie mit 0xFF überschrieben. Anschließend werden die Daten mit einem festgelegten Text überschrieben.

NATO

Der Inhalt der Datei wird dreimal, jeweils mit 0x00 und 0xFF, überschrieben. Anschließend werden die Daten mit Zufallszahlen überschrieben.
Dies entspricht der Löschmethode des Standards der North Atlantic Treaty Organization (NATO).

Peter Gutmann

Der Inhalt der Datei wird in insgesamt 35 Schritten mit Zufallszahlen und festgelegten Werten überschrieben.


Befehlszeilenparameter

Befehlszeilenparameter können mit einem Schrägstrich, einem Bindestrich oder mit zwei aufeinander folgenden Bindestrichen eingeleitet werden.

Hat ein Parameter einen zusätzlichen Wert, muss dieser mit einem Doppelpunkt oder einem Gleichzeichen vom Parameter getrennt werden.

Werden mehrere Dateien in der Befehlszeile übergeben, gelten die Parameter für alle Dateien.

Bei der Schreibweise der Parameter wird die Groß- und Kleinschreibung nicht beachtet.

/S
Die Warnmeldung vor dem Wipen der Dateien wird nicht angezeigt.
/M:Methode
Die angegebene Methode wird unabhängig von der letzten Einstellung vorausgewählt.
Verfügbare Löschmethoden sind:
WFL
WipeFile - Einfach
Z
Zero
R
Random
RZ
Random & Zero
ZR
Zero & Random
WFD
WipeFile - Standard
MSC
MS Cipher
MFM
USN-MFM
RLL
USN-RLL
DOD
DoD / USAF
BT
Bit Toggle
WFS
WipeFile - Sicher
NATO
NATO-Standard
GP
Peter Gutmann
/NOGUI
Es wird keine Benutzeroberfläche angezeigt.

Um Dateien ohne Anzeige der Benutzeroberfläche zu Wipen, muss der Paramter /NOGUI angegeben werden. Zusätzlich muss mindestens eine Datei bzw. ein Verzeichnis angegeben werden.

Bei den Datei- und Verzeichnisnamen werden auch Platzhalter unterstützt. Dadurch können beispielsweise nur Dateien mit einer bestimmten Dateierweiterung gelöscht werden.

Beachten Sie bitte, dass das Überschreiben von vielen Dateien oder von Großen Dateien mitunter längere Zeit in Anspruch nehmen kannt.

Beispiele

WipeFile.exe /M:WFL /NOGUI "D:\Test\*.*"
Die Benutzeroberfläche wird nicht angezeigt und als Löschmethode wird "WipeFile - Einfach" verwendet.
Alle Dateien, Verzeichnisse und Unterverzeichnisse von "D:\Test" werden gelöscht. Das (leere) Verzeichnis "D:\Test" bleibt jedoch erhalten.

WipeFile.exe /M:WFL /NOGUI "D:\Test"
Alle Dateien, Verzeichnisse und Unterverzeichnisse von "D:\Test" werden gelöscht. Das Verzeichnis "D:\Test" wird ebenfalls entfernt.

WipeFile.exe /M:WFL /NOGUI "D:\Test\*.doc"
Alle Word-Dokumente im Verzeichnis "D:\Test" und dessen Unterverzeichnissen, werden gelöscht.


Professional

Ist für WipeFile eine gültige Lizenzdatei vorhanden, stehen die folgenden Funktionen zur Verfügung:

Vorlagen

Über das Menü "Datei" > "Vorlage speichern" können die ausgewählten Verzeichnisse und Dateien, sowie die Löschmethode gesichert werden.

Zu einem späteren Zeitpunkt können die Einstellungen über "Datei" > "Vorlage laden" wieder hergestellt werden.

Einstellungen

In den Einstellungen kann festgelegt werden, dass die Zeitstempel (MAC-Zeiten) von Dateien und Verzeichnissen auf eine zufällige Zeit gesetzt werden. Ansonsten werden die MAC-Zeiten auf den 01.01.1980 gesetzt.