Einleitung

UltraSearch - Einleitung

Navigation: »Keine übergeordneten Themen verfügbar«

UltraSearch - Einleitung

UltraSearch sucht Dateien und Ordner auf lokalen NTFS-Laufwerken und liefert die Resultate innerhalb von Sekunden.

Dank der innovativen Nutzung der MFT (Master File Table) von NTFS-Partitionen erreicht UltraSearch sehr hohe Geschwindigkeiten, ohne das System durch die Erstellung und Aktualisierung einer Index-Datei zu belasten. Zur Indizierung wird ausschließlich der systeminterne Arbeitsspeicher verwendet. UltraSearch erkennt auch NTFS-Hardlinks.

Sie können einen Dateinamen, ein Muster wie *.exe oder einen Regulären Ausdruck angeben und sehen die Suchergebnisse binnen Sekunden. Auch die Suche nach bestimmten Dateitypen wie z.B. "Office Dateien" oder die Suche nach Datei-Inhalten ist möglich. Zu jeder gefundenen Datei werden weitere Informationen wie Größe, Dateidatum oder Dateiattribute angezeigt.

Ordner, Dateien und Dateitypen können von einer Suche ausgeschlossen werden. Die Suchergebnisse können nach verschiedenen Kriterien sortiert, gedruckt oder als Excel-, Text-, CSV-, HTML- oder RTF-Datei exportiert werden.

Speichern Sie zuletzt verwendete Suchmuster und wählen Sie diese aus einer Liste aus. Über einen Eintrag im Kontextmenü kann UltraSearch aus dem Windows Explorer heraus gestartet werden. So können Sie schnell das aktuelle Verzeichnis durchsuchen. Die Ergebnisliste von UltraSearch bietet ebenfalls ein Kontextmenü, über das bekannte Dateioperationen wie "Öffnen", "Kopieren" oder "Verschieben" zur Verfügung stehen.

Nutzen Sie UltraSearch flexibel als portable ZIP-Version.


Installation

Installation

Um UltraSearch zu installieren, führen Sie das Installationsprogramm aus und folgen den Anweisungen. Unterstützt werden alle Windows Betriebssysteme von Windows Vista bis Windows 10, inklusive der 64Bit Versionen. Das Installationsprogramm kopiert alle notwendigen Dateien auf die Festplatte und legt eine neue Programmgruppe im Startmenü an. Sie können UltraSearch in der Systemsteuerung unter "Software" wieder deinstallieren.

Portable Installation

Zusätzlich zum Installationsprogramm wird auch eine ZIP-Datei mit UltraSearch zur Verfügung gestellt, die ihre Einstellungen lokal speichert und so beispielsweise von einem USB-Stick aus verwendet werden kann.


Schnellstart

Schnellstart

Nach der Installation kann UltraSearch über das Windows Start-Menü, die Verknüpfung auf dem Desktop oder das Kontextmenü eines Ordners oder Laufwerks gestartet werden.

Im Folgenden werden die wichtigsten Elemente des Hauptfensters erläutert:

1.Menüleiste: Die Menüleiste stellt die grundsätzlichen Funktionen von UltraSearch zur Verfügung. Nähere Informationen finden Sie hier.

2.Suchfeld: Im Suchfeld kann das gewünschte Suchmuster eingegeben werden, um nach Datei- oder Ordnernamen zu suchen. Nähere Informationen finden Sie hier.

3.Dateitypenauswahl: In diesem Feld kann die Suche auf gewünschte Dateigruppen oder Dateiendungen eingeschränkt werden. Nähere Informationen finde Sie hier.

4.Dateiinhalts-Suche: Mit Hilfe dieses Feldes kann nach Dateien gesucht werden, die einen bestimmten textuellen Inhalt besitzen. Nähere Informationen finden Sie hier.

5.Optionen-Symbolleiste: Die Optionen-Symbolleiste stellt die wichtigsten Suchoptionen zur Verfügung.

6.Laufwerksübersicht: Die Laufwerksübersicht zeigt alle aktuell selektierten Laufwerke und Pfade, die als Startpunkt für die Suche dienen. Ein Klick auf die Dropdown-Schaltfläche oder auf die Übersicht selbst öffnet eine erweiterte Ansicht der verfügbaren Laufwerke. Diese ermöglicht das An- und Abwählen von Laufwerken und Pfaden, die in die Dateisuche mit einbezogen werden.

7.Suchergebnisliste: In der Ergebnisliste werden alle Suchergebnisse, die den angegebenen Suchmustern entsprechen, aufgelistet. Durch einen Rechtsklick auf die Kopfzeile können unterschiedliche Spalten ein- und ausgeblendet werden.

8.Statusleiste: Die Statusleiste informiert über die Anzahl der Suchergebnisse und zeigt zusätzlich Informationen über ausgewählte Elemente an. Hier wird ebenfalls angezeigt, ob der Ausschlussfilter aktiv ist.

9.Dateivorschau: Die Dateivorschau zeigt detaillierte Informationen sowie eine Miniaturansicht des momentan in den Suchergebnissen ausgewählten Elements an. Unter "Ansicht > Dateivorschau anzeigen" kann die Vorschau ein- oder ausgeblendet werden.


Was ist neu ?

Was ist neu ?

Version 2.2 : (06 Nov 2018)

Neue Features

·Der Datei-Inhalt wird nun in einem Vorschaufenster auf der rechten Seite angezeigt.

·Pfade und Laufwerke können jetzt an die Laufwerksübersicht gepinnt werden.

·Eine neue Schaltfläche zum Anhalten einer laufenden Suche wurde hinzugefügt.

·Die Sprache lässt sich jetzt über die Benutzeroberfläche unter "Ansicht -> Sprache" ändern.

·Die Benutzeroberfläche bietet nun eine Schaltfläche "Löschen", über die alle eingegebenen Suchkriterien entfernt werden können.

·Eine Option zur Verwendung von regulären Ausdrücken wurde hinzugefügt.

·Über die Option "Umlaute und Akzente ignorieren" kann festgelegt werden, ob Umlaute und Akzente bei der Suche berücksichtigt werden sollen.

·Das Durchsuchen von Unterordnern lässt sich über eine neue Option ein- und ausschalten.

·Die Suchhistorie lässt sich nun löschen.

·Die Schriftgröße der Ergebnisliste lässt sich in den Optionen einstellen.

·Eine Option zur Auswahl aller Laufwerke wurde zum Kontextmenü der Laufwerksübersicht hinzugefügt.

·Bei einer Suche im Hintergrund wird der Nutzer nun über ein Benachrichtigungsfenster informiert, wenn die Suche abgeschlossen ist.

·Mit Bitlocker verschlüsselte Laufwerke werden jetzt unterstützt.

·Die TreeSize Dateisuche lässt sich jetzt über "Erweiterte Suche" starten (falls installiert).

Verbesserungen

·Das Einlesen der Master File Table (MFT) wurde beschleunigt.

·Die Laufwerksübersicht wurde überarbeitet. Laufwerke lassen sich über zusätzliche Checkboxen schneller an- oder abwählen.

·Die Suchergebnisse werden in vielen Fällen schon während des Einlesens der MFT angezeigt.

·Ist die Option ''Mit Windows starten" aktiviert, wird beim Start von UltraSearch nun nicht mehr die Benutzerkontensteuerung angezeigt.

·Windows XP und Windows Server 2003 werden nicht länger unterstützt.

Bugfixes

·Die Nachricht "Netzlaufwerke werden nicht unterstützt" wurde in einigen Fällen fälschlicherweise angezeigt.

·Die Sortierung der Spalte "Dateiversion" funktioniert nun korrekt.

·Die Laufwerksinformationen in der Laufwerksübersicht wurden nicht aktualisiert. Dieses Problem wurde behoben.

·Ein Fehler beim Update oder einer Deinstallation bei laufender Anwendung wurde behoben.

·Weitere kleine Korrekturen und Verbesserungen.

Version 2.1.2 : (19 Jul 2016)

·Die Laufwerksübersicht lässt sich nun auch über einen Rechtsklick ausklappen.

·Bugfix: Auf die Möglichkeit, die Laufwerksübersicht auszuklappen, wird nun deutlicher hingewiesen.

·Bugfix: Das Durchsuchen von virtuellen Laufwerken führte in einigen Fällen zu einem Fehler. Dieses Problem wurde behoben.

·Bugfix: Ein kleinerer Fehler beim Minimieren von UltraSearch in den Infobereich mittels Tastenkürzel wurde behoben.

·Bugfix: Weitere kleine Korrekturen und Verbesserungen sind eingeflossen.

Version 2.1.1 : (01 Jul 2016)

·Bugfix: Ein Fehler beim Starten von UltraSearch wurde behoben.

·Bugfix: Die Option "Ergebnisse immer sortieren" wurde nach einem Neustart des Programms nicht berücksichtigt. Dieses Problem wurde behoben.

·Bugix: Der Aufruf von UltraSearch mittels Kommandozeilenparameter lieferte in einigen Fällen falsche Ergebnisse. Dies wurde behoben.

·Bugfix: Die Werte der Spalte "Dateiversion" wurden erst bei Selektion einer Zeile berechnet. Dieser Fehler wurde behoben.

·Bugfix: Bei einem Programm-Update wurden einige Einstellungen zurückgesetzt. Dies ist nun nicht mehr der Fall.

·Die Symbole des Ausschlussfilters und der Dateigruppen wurden aktualisiert.

Version 2.1 : (20 Jun 2016)

·UltraSearch unterstützt nun die Suche nach Datei-Inhalten.

·Die Laufwerksübersicht wurde komplett überarbeitet. Sie befindet sich nun nicht mehr unter der Ergebnisliste, sondern als Auswahlbox oberhalb der Ergebnisliste.

·Über die neue Laufwerksübersicht lässt sich nun auch in einzelnen Ordnern suchen und nicht mehr ausschließlich auf kompletten Laufwerken.

·Über die neue "Dateitypenauswahl" kann jetzt auch nach bestimmten Dateigruppen- oder Typen (z.B. "Office-Dateien", "Video-Dateien") gesucht werden. Die Gruppen können unter "Suche > Dateigruppen..." angepasst werden.

·UltraSearch unterstützt jetzt Kommandozeilen-Parameter, diese starten UltraSearch mit definierten Suchparametern.

·Die Symbole wurden überarbeitet und an Windows 10 angepasst.

·Die Suchergebnisse werden nun noch schneller angezeigt.

·Die Option "Suchmuster vervollständigen" wurde durch die Option "Suchmuster vorschlagen" ersetzt. Diese blendet eine Dropdown-Liste unterhalb des Suchfeldes mit Suchvorschlägen (basierend auf den zuletzt verwendeten Suchmustern) ein.

·Unter "Optionen > Dateisystemänderungen einbeziehen" kann die automatische Aktualisierung des MFT-Index im Arbeitsspeicher nun deaktiviert werden.

·Beim Export großer Ergebnislisten wird nun ein Fortschrittsbalken angezeigt.

·Ein neuer Menüpunkt mit Informationen zur erweiterten Suche mit TreeSize (Durchsuchen von Netzlaufwerken, Finden von doppelten Dateien u.v.m.) wurde hinzugefügt.

·Der Menüpunkt "Optionen-Symbolleiste" wurde in "Symbolleisten" umbenannt. Der Menüpunkt "Anzeigen" in dessen Untermenü heisst nun "Optionen-Symbolleiste".

·Der Werbebanner wurde entfernt.

·Bugfix: Ein Fehler beim Sortieren der Suchergebnisse während einer Suche wurde behoben.

·Bugfix: Bei aktivierter Option "Benutzerkontensteuerungs-Warnung überspringen" startete UltraSearch nicht, wenn das Programm in einen anderen Ordner verschoben oder umbenannt wurde. Dieser Fehler ist nun behoben.

·Bugfix: Bei der Suche nach Dateipfaden, die mit einem Punkt enden, wurden falsche Ergebnisse aufgelistet. Dieses Problem wurde behoben.

·Bugfix: Vom Ausschlussfilter wurden in einigen Fällen falsche Dateien von den Ergebnissen ausgeschlossen. Dieser Fehler wurde behoben.

·Bugfix: Die Vorschau der ausgeschlossenen Dateien im Ausschlussfilter zeigt nun auch den Ausschluss versteckter Dateien an.

·Bugfix: Zahlreiche weitere kleine Korrekturen und Verbesserungen sind eingeflossen.

Version 2.0.3 : (23 Mär 2015)

·Die Suchgeschwindigkeit wurde für bestimmte Suchmuster erhöht.

·Beim Export der Suchergebnisse in eine Excel-Datei wird nun der Datei-Autor eingetragen.

·Bugfix: Beim Entfernen eines Wechseldatenträgers kam es vereinzelt zum Absturz von UltraSearch. Dieses Problem wurde behoben.

·Bugfix: Bei einigen Laufwerken kam es während des Einlesens der MFT (Master File Table) zu Fehlern. Dies ist nun nicht mehr der Fall.

·Bugfix: In einige Fällen wurde der Fortschrittsbalken nicht angezeigt. Dies wurde behoben.

·Bugfix: Weitere kleine Korrekturen und Verbesserungen sind eingeflossen.

Version 2.0.2 : (02 Mär 2015)

·Laufwerke mit einer Sektorgröße von 4K werden jetzt unterstützt.

·Bugfix: Weitere kleine Korrekturen und Verbesserungen sind eingeflossen.

Version 2.0.1 : (12 Feb 2015)

·Beim Öffnen einer Datei oder eines Ordners über den Eintrag 'Übergeordneten Ordner öffnen' wird die in UltraSearch selektierte Datei nun auch im Windows Explorer selektiert.

·Bugfix: Bei einigen Laufwerken kam es während des Einlesens der MFT (Master File Table) zu Fehlern. Dies ist nun nicht mehr der Fall.

·Bugfix: Änderungen am Dateisystem führten in einigen Fällen zu Fehlern. Dies wurde behoben.

·Bugfix: Zahlreiche weitere Korrekturen und Verbesserungen sind eingeflossen.

Version 2.0 : (18 Dez 2014)

·Ein komplett überarbeiteter Scan-Mechanismus zum Auslesen der MFT (Master File Table) wurde implementiert.

·Ein neuer Suchalgorithmus zur schnelleren Suche wurde implementiert.

·Der Arbeitsspeicherverbrauch wurde stark reduziert.

·Die Geschwindigkeit beim Sortieren der Suchergebnisse wurde stark erhöht.

·Der neue Scan-Mechanismus findet jetzt immer auch NTFS-Hardlinks. Die Option zum De-/Aktivieren von NTFS-Hardlinks wurde daher entfernt.

·Eine neue Optionen-Symbolleiste wurde hinzugefügt, die es dem Nutzer erlaubt, schnell zwischen Datei- und Ordnersuche zu wechseln und den Ausschlussfilter zu de-/aktivieren.

·Neben dem Eingabefeld existiert nun eine Schaltfläche, über die der Nutzer komfortabel einen zu durchsuchenden Ordner auswählen kann.

·Eine Option zum Verbergen und Zurücksetzen der Optionen-Symbolleiste wurde hinzugefügt.

·Die Option "Automatische Sortierung" wurde in "Ergebnisse immer sortieren" umbenannt.

·Die Option "Ergebnisse immer sortieren" wird nun auch nach einem Neustart von UltraSearch berücksichtigt.

·Das Drücken der F3-Taste markiert nun das eingegebene Suchmuster und ermöglicht dem Nutzer die direkte Eingabe eines neuen Suchmusters.

·Die Reihenfolge der Spalten in der Laufwerksübersicht kann nun mittels Drag&Drop geändert werden.

·Das Scrollen der zuletzt verwendeten Suchmuster wurde deaktiviert.

·Es werden nun nur noch die 15 zuletzt verwendeten Suchmuster gespeichert.

·Den Menüs wurden Symbole hinuzgefügt.

·Bugfix: Bei einer Aktualisierung der Suche während einer bereits laufende Suche fehlten in einigen Fällen Suchergebnisse. Dieser Fehler ist nun behoben.

·Bugfix: Beim Start von UltraSearch über das Kontexmenü wird nun das Suchfeld korrekt markiert, so dass der Nutzer direkt ein Suchmuster angeben kann.

·Bugfix: Die Option "Suchmuster vervollständigen" funktioniert nun richtig.

·Bugfix: Deaktivierte Spalten bleiben jetzt auch nach einem Neustart von UltraSearch ausgeblendet.

·Bugfix: Änderungen am Dateisystem werden nun richtig erfasst.

·Bugfix: Ein Programmfehler, der in seltenen Fällen zum Absturz von UltraSearch während der Suche führte wurde behoben.

·Bugfix: Zahlreiche weitere Korrekturen und Verbesserungen sind eingeflossen.

Version 1.8.1 : (07 Okt 2013)

·Der Fehler "Duplikate sind nicht erlaubt" beim Start von UltraSearch wurde behoben.

·Zugriffsverletzungen während der Suche treten nun nicht mehr auf.

·Der Fehler "Cannot focus a disabled or invisible window" beim Öffnen des Ausschlussfilters wurde behoben.

·Beim Starten von UltraSeach via Kontextmenü wurde irrtümlicherweise ein Leerzeichen in das Suchmuster eingefügt. Dieser Fehler ist nun behoben.

·Das Werbebanner wird nicht länger angezeigt, wenn TreeSize Professional oder Personal installiert sind.

·Die Einstellungen der portablen Version werden nun richtig gespeichert.

·Bugfix: Weitere kleine Korrekturen und Verbesserungen sind eingeflossen.

Version 1.8 : (06 Aug 2013)

·64bit: UltraSearch ist jetzt auch als native 64-Bit-Version erhältlich. Dadurch lassen sich auch große Laufwerke problemlos ohne Restriktionen durch den Arbeitsspeicher untersuchen.

·Suchmuster speichern: Die 100 zuletzt verwendeten Suchmuster können jetzt gespeichert und aus einer Dropdown-Liste ausgewählt werden.

·Suchmuster automatisch vorschlagen: Bei Eingabe eines Suchmusters können jetzt auf Wunsch passende zuletzt verwendete Suchmuster in einer Liste vorgeschlagen werden.

·Suchmuster automatisch vervollständigen: Bei Eingabe eines Suchmusters kann dieses auf Wunsch automatisch durch ein passendes Muster aus der Auswahl der verwendeten Suchmuster vervollständigt werden.

·Benutzerkontensteuerungs-Warnung verbergen: Über eine Option kann die Benutzerkontensteuerungs-Warnung beim Start von UltraSearch abgeschaltet werden.

·Erweitertes Kontextmenü: Über einen Kontextmenü-Eintrag des Windows Explorers kann UltraSearch nun bequem von jedem Ort aus gestartet werden.

·Verbesserte Datumsanzeige: Die Datums- und Uhrzeit-Anzeige für die Spalten "Letzte Änderung", "Letzter Zugriff" und "Erstellt am" kann nun genauer angepasst werden.

·Überarbeitete Menüstruktur: Ein neuer Eintrag "Suche", der alle suchspezifischen Optionen beinhaltet, wurde zur Menüleiste hinzugefügt.

·Neuer Kontextmenüeintrag "Vollständigen Pfad in die Zwischenablage kopieren": Über das Kontextmenü der Ergebnisliste lässt sich nun der vollständige Pfad zu den selektierten Ergebnissen in die Zwischenablage kopieren.

·Neue Spalte "Dateiversion": Über eine neue Spalte "Dateiversion" lassen sich die Versionsnummern von EXE-, DLL-, SYS- und MUI-Dateien sowie vieler anderer Dateitypen anzeigen.

·Bugfix: Einige Fehler in der Excel-Export-Komponente wurden behoben.

·Bugfix: Zahlreiche kleinere Fehler wurden behoben.

Version 1.7.1 : (25 Okt 2012)

·Bugfix: Die Meldung "Sie haben UltraSearch mit eingeschränkten Nutzerrechten gestartet. Bitte starten sie UltraSearch mit Administratorrechten neu" wurde in einigen Fällen fälschlicherweise angezeigt.

·Bugfix: Der Fehler "Cannot focus a disabled or invisible window" beim Starten von UltraSearch wurde behoben.

·Bugfix: Beim Start von UltraSearch über die Option 'Mit Windows starten' enthielt die Laufwerksliste unter Umständen keine Laufwerke.

·Bugfix: Einige weitere Fehler wurden behoben.

Version 1.7 : (09 Okt 2012)

·Ein neuer Enumerator wurde implementiert, mit dem UltraSearch in der Lage ist, NTFS Hardlinks zu finden. Die Suche nach NTFS Hardlinks kann über das "Optionen"-Menü aktiviert werden.

·Reguläre Ausdrücke werden unterstützt. Hinweis: Um eine Suche mittels regulärem Ausdruck durchzuführen, muss dieser mit / umschlossen werden (/Ausdruck/).

·Ein Live-Update des internen Indexes wurde realisiert. Dadurch muss der Index bei Änderungen auf der Festplatte nicht mehr neu eingelesen werden.

·Der alte Ausschlussfilter wurde durch den aus TreeSize Free V2.7 bekannten PatternManager ersetzt. Auszuschließende Muster können dadurch präziser formuliert werden.

·Eine neue Option "Mit Windows starten" wurde hinzugefügt: UltraSearch startet damit nach dem Windows-Start automatisch im Infobereich.

·Eine neue Option "Desktop-Verknüpfung" wurde hinzugefügt. Über die erstellte Verknüpfung lässt sich UltraSearch ohne Bestätigung der Benutzerkontensteuerung starten (ab Windows Vista).

·Eine neue Option "Kontextmenü-Eintrag" wurde implementiert; über diese kann UltraSearch zum Kontextmenü von Ordnern und Laufwerken hinzugefügt werden, um diese zu durchsuchen.

·Ein neuer Menüpunkt "Sortieren nach" wurde implementiert, über den sich die Suchergebnisse nach ausgewählten Kriterien ("Name", "Pfad", "Größe" etc.) sortieren lassen.

·Eine neue Spalte "Hardlinks" wurde hinzugefügt, die Auskunft über die Anzahl an Hardlinks einer Datei gibt.

·Die neuen Kommandozeilenparameter /MINIMIZED und /TRAY können verwendet werden, um UltraSearch minimiert in der Taskleiste oder im Infobereich zu starten.

·Einen neue Option "Aktualisiere Ergebnisse" (F5) wurde hinzugefügt.

·Der Fortschrittsbalken zeigt nun bereits den Fortschritt beim Erstellen des Indexes an.

·Der Speicherverbrauch wurde reduziert, diverse Geschwindigkeitsverbesserungen bei der Suche wurden implementiert.

·Bei Nutzung des Ausschlussfilters wird nun die Anzahl der ausgeschlossenen Dateien und Ordner in der Statusleiste angezeigt.

·Das Sucheingabefeld wurde vergrößert und passt sich nun automatisch der Größe des UltraSearch-Fensters an.

·Bei der Suche nach einem Dateipfad wird nun automatisch das zu durchsuchende Laufwerk ausgewählt.

·Die Benutzeroberfläche wird nun bei einer Skalierung von 125 % oder 150 % korrekt dargestellt.

·Der Excel-Export wurde überarbeitet.

·Setup: Eine neue Option zum Hinzufügen von UltraSearch zum Kontextmenü wurde in das Setup integriert.

·Setup: Eine neue Option "UltraSearch mit Windows starten" wurde zum Setup hinzugefügt.

·Bugfix: Bei der portablen Version von UltraSearch wird nicht länger ein leerer Ordner im Benutzerverzeichnis erzeugt.

·Bugfix: Der Nutzer bekommt jetzt einen Hinweis, wenn er UltraSearch nicht als Administrator startet.

·Bugfix: Ein Fehler beim CSV-Export wurde behoben, bei dem ein falsches Listentrennzeichen verwendet wurde.

·Bugfix: Bei der kombinierten Suche nach einem Dateipfad und einem Dateinamen werden nun die richtigen Suchergebnisse angezeigt.

·Bugfix: Das Flackern bei Änderung der Fenstergröße wurde minimiert.

·Bugfix: Beim Start von UltraSearch liegt der Fokus nun im Eingabefeld, so dass ein Suchbegriff ohne zusätzlichen Klick direkt eingegeben werden kann.

·Bugfix: Die Fensterposition von UltraSearch wird nun gespeichert, wenn UltraSearch über das Symbol im Infobereich beendet wird.

·Bugfix: In einigen Fällen startete die Benutzerkontensteuerung minimiert. Dies ist nun behoben.

·Bugfix: Zahlreiche weitere Fehler wurden behoben.

Version 1.6.1 : (09 Jan 2012)

·Ein Fehler beim Herunterfahren des Betriebssystems wurde behoben.

·Bugfix: Einige Kontextmenü-Einträge waren nach der Installation nicht direkt verfügbar.

·Bugfix: Bei der Deinstallation werden nun alle Kontextmenü-Einträge von UltraSearch gelöscht.

·Bugfix: Weitere kleine Korrekturen und Verbesserungen sind eingeflossen.

Version 1.6 : (25 Nov 2011)

·UltraSearch kann nun über das Kontextmenü des Windows Explorers gestartet werden, um in dem aktuellen Verzeichnis eine Suche zu starten.

·Mit den neuen Optionen "Verzeichnisse einbeziehen" und "Dateien einbeziehen" kann nun entschieden werden, ob nach Dateien, nach Ordnern oder nach beidem gesucht werden soll.

·UltraSearch kann nun über ein konfigurierbares Tastenkürzel minimiert und erneut in den Vordergrund gebracht werden ("Optionen > UltraSearch Tastenkürzel").

·Verbesserung in der Suche: Bei Auswahl mehrerer Laufwerke werden Ergebnisse schon nach Durchsuchung des ersten Laufwerkes angezeigt.

·Das Menü "Ansicht" wurde um den Menüpunkt "Automatische Sortierung" erweitert, welcher die Ergebnisse einer neuen Suche automatisch nach den zuletzt festgelegten Sortierungskriterien ordnet.

·Das Menü "Optionen" wurde um den Menüpunkt "Bei Doppelklick minimieren" erweitert, um UltraSearch zu minimieren, wenn ein Verzeichnis in der Ergebnisliste mittels Doppelklick geöffnet wird.

·Das Tastenkürzel Strg+A selektiert alle Laufwerke in der Laufwerksübersicht, wenn diese fokussiert ist.

·Durch Rechtsklick in der Laufwerksliste kann auf die neue Option "Alle markieren" zugegriffen werden, mit deren Hilfe alle Laufwerke ausgewählt werden.

·Eine neue Option zur automatischen Auswahl neu hinzugefügter Laufwerke wurde unter "Optionen" hinzugefügt.

·Verbesserte Sortierung der Ergebnisse: Bei Sortierung nach "Name" werden Dateien und Ordner nun getrennt voneinander aufgelistet.

·Die Werbung für TreeSize Professional wird nicht mehr eingeblendet, wenn dieses schon auf dem System installiert ist.

·Bugfix: Bei mehrmaligem Starten von UltraSearch wird die Windows Benutzerkontensteuerung nur beim ersten Start aktiv.

Version 1.5 : (18 Aug 2011)

·Das Menü "Ansicht" wurde um den Menü-Punkt "Laufwerksübersicht" zum Ein-/Ausblenden der Laufwerksübersicht erweitert.

·UltraSearch kann im Hintergrund arbeiten und dabei zum Icon im Infobereich minimiert werden.

·Die Geschwindigkeit bei der Suche wurde gesteigert.

·Wird bei arbeitender UltraSearch - Instanz eine weitere Instanz gestartet, so wird die erste Instanz mit ihren Ergebnissen in den Vordergrund gebracht.

·Für das spezielle Suchmuster "*." ist ein Verfahren für die Suche implementiert worden, so dass nun Dateien ohne Erweiterung gefunden werden.

·Während des Löschens von Verzeichnissen oder Dateien können Sie diese nun durch Tippen der Umschalttaste (SHIFT) direkt vom Laufwerk löschen, ohne sie im Papierkorb abzulegen.

·Wenn ein USB Speicher Stick vom System entfernt, so wird er nun auch aus der Laufwerksübersicht entfernt.

·Die Hinweise zur Bedienung wurden verbessert.

·Dateien oder Verzeichnisse können nun direkt in der Ergebnisliste umbenannt werden.

·Die Anzahl an Dateien auf dem System, die von UltraSearch gehandhabt werden kann, wurde auf über 12,5 Millionen erhöht.

·Der von UltraSearch verwendete interne Index wird in regelmäßigen Zeitabständen aktualisiert.

·Wenn mehr als ein Eintrag in der Ergebnisliste selektiert ist, wird die Anzahl an selektierten Einträgen in der Statuszeile angezeigt.

·Einige Hinweise zur Bedienung werden nun als "Tooltips" angezeigt.

·Das Kontextmenü der Ergebnisliste wurde um den Menüeintrag "Vollständigen Pfad in die Zwischenablage kopieren" erweitert.

·Bugfix: In einigen Fällen kam die Suche in UltraSearch in einen Zustand in dem UltraSearch nichts Weiteres tat als "Suche ..." anzuzeigen.

·Bugfix: Wenn die Nachfrage beim Löschen eines Eintrags aus der Ergebnisliste verneint wurde, so wurde der Eintrag bisher in der Ergebnisliste nicht mehr angezeigt. Nach der nächsten Aktualisierung des internen Index wurde der Eintrag wieder angezeigt.

·Bugfix: Die Aktualisierung des internen Index (F5) führte in einigen Fällen zu fehlenden Ergebnissen.

·Bugfix: Die mehrfache Aktualisierung des internen Index über F5 führte zu einer wachsenden Verzögerung bis die Ergebnisse angezeigt wurden.

·Bugfix: Wird die Auswahl eines Laufwerks beendet, während die Verzeichnisdaten geladen werden, so wird nun der Ladevorgang sofort beendet.

·Bugfix: UltraSearch hatte bisher eine Verbindung zu externen Laufwerken offen gehalten.

·Bugfix: In einigen Fällen wurde der Ausschlussfilter als aktiv dargestellt, obwohl er nicht ausgewählt war.

·Bugfix: Für einige Systemdateien wurde in der Spalte Pfad der Dateiname angegeben.

Version 1.4.1 : (04 Okt 2010)

·Gesteigerte Geschwindigkeit bei aktiviertem Ausschlussfilter.

·Gesteigerte Geschwindigkeit beim Sortieren nach Name.

·Bugfix: Einige kleinere Korrekturen und Verbesserungen sind eingeflossen.

Version 1.4 : (22 Sep 2010)

·Es ist jetzt möglich Verzeichnisse in die Suche einzubeziehen.

·Mit Hilfe eines Filters können Verzeichnisse, Dateien und Dateitypen bei der Suche ignoriert werden.

·Das Hauptmenü wurde hinzugefügt (Datei, Bearbeiten, Suche, Ansicht und Hilfe).

·Die Größeneinheit der Suchergebnisse kann jetzt geändert werden.

·Die Liste der Suchergebnisse kann nun auch im HTML- und RTF-Format gespeichert werden, indem das entsprechende Format im Speichern-Dialog ausgewählt wird.

·Die Uhrzeit in den Datumsspalten kann ein- und ausgeblendet werden.

·Es wurden die Spalten Attribute, Erstellungsdatum und Dateityp hinzugefügt.

·NTFS formatierte Wechseldatenträger (z.B. USB Sticks) können jetzt auch durchsucht werden.

·Im Hilfemenü kann jetzt geprüft werden, ob bereits neuere Versionen verfügbar sind.

·Die meisten Elemente besitzen Hinweise, welche in der Statuszeile am unteren Rand abgelesen werden können.

·Bugfix: Wurde ein Laufwerk nach angestoßener Suche abgewählt, konnte es in seltenen Fällen passieren, dass keine Suchergebnisse angezeigt wurden.

·Bugfix: Waren nur wenige Suchergebnisse vorhanden, wurde nach einem Doppelklick in den freien Bereich der letzte Suchtreffer ausgeführt.

·Bugfix: Die Statuszeile rutschte über die Laufwerksliste, wenn deren Größe verändert wurde.

·Bugfix: Ein Fehlermeldung konnte erscheinen, wenn eine Datei im Papierkorb gelöscht werden sollte.

·Windows 2000 wird nicht länger unterstützt.

Version 1.3 Beta : (03 Mai 2010)

·Drucken, Speichern und Kopieren der Suchergebnisse jetzt möglich.

·Drag&Drop Operationen werden nun unterstützt.

·Neues Suchmuster wird unterstützt: Um ausschließlich nach einer bestimmten Datei zu suchen, kann der Name in Anführungszeichen gesetzt werden.

·Neue Tastaturkürzel: Strg+C (Kopieren), Strg+X (Ausschneiden) und Entf (Löschen)

·Suchmuster kann bei Programmstart als Parameter übergeben werden.

·Manuelles aktualisieren der Dateisysteminformationen möglich.

·Bugfix: Ergebnisliste wird nach einer Löschoperation nicht mehr komplett neugeladen.

·Bugfix: Scroll Position und Sortierung wir nach einer Löschoperation beibehalten.

Version 1.2.1 Beta : (11 Feb 2010)

·UltraSearch hat den Logo-Test "Kompatibel mit Windows 7" Logo Test bestanden.

·Verbesserung der Suchgeschwindigkeit für einige Suchmuster.

·Die Suchergebnisse können jetzt als Text und CSV Datei exportiert werden.

·Der Pfad wird jetzt ohne Dateinamen angezeigt.

·Bugfix: Es konnte vorkommen, dass einige Dateien doppelt angezeigt wurden.

·Bugfix: Beim erstmaligen Start von UltraSearch wurde kein Laufwerk ausgewählt.

·Bugfix: In seltenen Fällen wurde Laufwerk C:\ zweimal angezeigt.

·Bugfix: Die Ergebnisliste enthielt in einigen Fällen leere Einträge.

·Bugfix: UltraSearch stürzte in einigen Fällen bei erstmaligem Starten ab.

·Bugfix: Eine Warnung wird angezeigt, wenn der Benutzer nicht über genügend Rechte verfügt.

·Bugfix: Die Sortierung der Spalte "Letzte Änderung" war fehlerhaft.

·Bugfix: Bei Pfaden die länger als 255 Zeichen waren, wurde eine Fehlermeldung angezeigt.

·Bugfix: Einige kleinere Verbesserungen sind eingeflossen.

Version 1.2 Beta : (15 Dez 2009)

·Erste offizielle Veröffentlichung.


F.A.Q. - Häufig gestellte Fragen

F.A.Q. - Häufig gestellte Fragen

·Allgemein

·Knowledge Base


Allgemein

F.A.Q. - Allgemein

Navigation: F.A.Q. - Häufig gestellte Fragen >

F.A.Q. - Allgemein
F: Wie kann ich Netzlaufwerke durchsuchen?
A: Um Dateien und Ordner auf Ihrer Festplatte schnell finden zu können, greift UltraSearch direkt auf die MFT (Master File Table) der lokalen NTFS Partitionen zu. Daher können Netzlaufwerke leider nicht durchsucht werden. Wenn Sie eine netzwerkfähige Suchfunktion benötigen, könnte Ihnen unser Festplattenmanager TreeSize weiterhelfen. Die TreeSize-Dateisuche ist noch vielseitiger als UltraSearch und durchsucht neben NTFS-Laufwerken auch FAT32-Laufwerke, ganze Server oder komplette Netzwerke. Außerdem bietet sie verschiedene voreingestellte Suchen, unter anderem nach temporären oder doppelten Dateien, und kann gefundene Daten verschieben oder löschen.
F: Warum wird mir mein USB-Stick / meine SD-Karte nicht in der Laufwerksübersicht von UltraSearch angezeigt?
A: Der USB-Stick / die SD-Karte muss NTFS-formatiert, um mit UltraSearch durchsucht werden zu können. Fat32 oder anders formatierte Laufwerke können nicht durchsucht werden. Das Dateisystem Ihres Laufwerkes können Sie über einen Rechtsklick auf das Laufwerk unter 'Eigenschaften > Allgemein' einsehen. Falls Ihr Laufwerk nicht NTFS-formatiert ist, können Sie z.B. Ihre Daten zunächst anderweitig sichern, das Laufwerk in das NTFS-Dateisystem formatieren und anschließend die gesicherten Daten zurück auf das Laufwerk kopieren. Anschließend können Sie das Laufwerk mit UltraSearch durchsuchen.
Hinweis: Bitte beachten Sie, dass manche Digitalkameras oder Fernseher NTFS-formatierte USB-Sticks oder SD-Karten nicht erkennen!
F: Warum ist die Suche nach Dateiinhalten so langsam? Kann man dies beschleunigen?
A: Die Suche nach Dateiinhalten kann sehr langsam sein, da der gesamte Inhalt einer Datei analysiert werden muss. Um die Dateiinhaltssuche zu beschleunigen, sollte die Suche zusätzlich durch andere Suchkriterien wie "Dateiname" oder "Dateityp" eingeschränkt werden.
F: Warum erscheint die Fehlermeldung "Das Pfadformat wird nicht unterstützt."?
A: UltraSearch unterstützt keine relativen Pfade in der Laufwerksübersicht. Angegebene Pfade müssen sich eindeutig auf ein Laufwerk beziehen z.B. "C:\Users\Default\Downloads" anstatt "Downloads".
F: Warum wird beim Starten von UltraSearch die Benutzerkontensteuerung angezeigt?
A: Um Dateien und Ordner auf Ihrer Festplatte schnell zu finden, greift UltraSearch direkt auf die MFT (Master File Table) der lokalen NTFS Partitionen zu. Hierfür werden Administratorenrechte benötigt. Aus diesem Grund wird beim Starten der Anwendung die Benutzerkontensteuerung (UAC) angezeigt. Sie können diese Meldung unterdrücken, indem Sie unter "Optionen" den Menüpunkt "Benutzerkontensteuerungs-Warnung überspringen" aktivieren.


Knowledge Base

Navigation: F.A.Q. - Häufig gestellte Fragen >

Knowledge Base

Falls Sie in dieser Hilfe nicht fündig geworden sind, können Sie über dieses Suchfeld die Knowledge Base auf unserer Webseite durchsuchen.
Beim Klick auf "Suchen" wird die entsprechende Seite in Ihrem standard Web-Browser geöffnet.

Bitte beachten Sie: Für diese Suche ist eine Internetverbindung erforderlich und die Ausführung von JavaScript muss in Ihrem Browser aktiviert sein!


Menü

UltraSearch - Menü

UltraSearch - Menü

Datei

Liste speichern...

Speichert die Ergebnisse der zuletzt durchgeführten Suche.

Liste in die Zwischenablage kopieren

Kopiert die Suchergebnisse in die Zwischenablage. Ist mehr als ein Eintrag selektiert, werden nur die selektierten Einträge gespeichert.

Liste drucken

Druckt die aktuellen Suchergebnisse.

Drucker einrichten...

Öffnet die Druckereinstellungen.

Beenden

Beendet das Programm oder minimiert es in den Infobereich (abhängig von den Einstellungen).

Bearbeiten

Kopieren

Kopiert die selektierten Elemente in die Zwischenablage.

Ausschneiden

Schneidet die ausgewählten Elemente aus und kopiert sie in die Zwischenablage.

Alles Auswählen

Selektiert alle Einträge der Ergebnisliste.

Auswahl umkehren

Invertiert die aktuelle Auswahl in der Ergebnisliste.

Ansicht

Werte in Bytes

Alle Größenangaben erfolgen in Bytes.

Werte in KB

Alle Größenangaben erfolgen in Kilobytes.

Werte in MB

Alle Größenangaben erfolgen in Megabytes.

Werte in GB

Alle Größenangaben erfolgen in Gigabytes.

Automatische Einheiten

Wählt die nächstliegende, passende Größeneinheit selbstständig aus.

Datums-/Zeitformat

Erlaubt das Festlegen des Datumsformates, das für Datumswerte verwendet wird.

Schriftgröße

Erlaubt das Einstellen der Schriftgröße in der rgebnisliste.

Sprache

Wechselt die Sprache der Benutzeroberfläche.

Optionen-Symbolleiste

Zeigt die Optionen-Symbolleiste an.

Datei-Vorschau

Aktiviert die Datei-Vorschau neben der Ergebnisliste.

Suche

Aktualisiere Ergebnisse

Aktualisiert die Ergebnisliste.

MFT neu einlesen

Liest Informationen über das Dateisystem aus der MFT erneut ein.

Dateien einbeziehen

Gibt an, ob nach Dateien gesucht werden soll.

Ordner einbeziehen

Gibt an, ob nach Ordnern gesucht werden soll.

Ausschlussfilter...

Öffnet die Ausschlussfilter-Optionen.

Unterordner einbeziehen

Erlaubt die Suche in allen Unterordnern des angegebenen Suchpfades.

RegEx verwenden

Eingegebene Suchmuster werden als Reguläre Ausdrücke behandelt.

Umlaute und Akzente ignorieren

Umlaute und Akzente im Suchmuster werden nicht berücksichtigt.

Optionen

Dateigruppen konfigurieren...

Öffnet die Dateigruppen-Optionen.

Suchfeld

Legt das Verhalten des Suchfeldes fest:

Zuletzt verwendete Muster speichern: Ist diese Option aktiviert, werden die zuletzt verwendeten Suchmuster gespeichert. Die Suchmuster können über die Dropdown-Liste des Suchfeldes ausgewählt werden.

Anmerkung: Ein Suchmuster wird erst durch Betätigung der Eingabetaste oder bei Verlassen des Suchfeldes gespeichert.

Suchmuster vorschlagen: Ist diese Option aktiviert, werden bei Eingabe eines Suchmusters passende Suchmuster auf Basis vorheriger Suchen eingeblendet (Hinweis: "Zuletzt verwendete Muster speichern" muss aktiviert sein, um diese Option zu nutzen).

Explorer Kontextmenü

Bietet verschiedene Erweiterungen für das Kontextmenü des Windows Explorers an:

UltraSearch starten: Ist diese Option aktiviert, kann UltraSearch über das Kontextmenü des Windows Explorers gestartet werden.

Mit UltraSearch durchsuchen: Ist diese Option aktiviert, kann UltraSearch über das Kontextmenü des Windows Explorers gestartet werden und durchsucht automatisch den aktuellen Ordner.

Benutzerkontensteuerungs-Warnung überspringen

Ist diese Option aktiviert, wird die Benutzerkontensteuerungs-Warnung beim Start nicht mehr angezeigt.

Mit Windows starten

Startet UltraSearch beim Systemstart automatisch im Infobereich.

In den Infobereich minimieren

Ist diese Option aktiviert, wird UltraSearch beim Schließen des Programms in den Infobereich minimiert. Beim Klick auf das entsprechende Symbol, wird UltraSearch erneut geöffnet.

Bei Doppelklick minimieren

Minimiert UltraSearch, wenn ein Ordner in der Ergebnisliste mittels Doppelklick geöffnet wird.

Neue Laufwerke automatisch auswählen

Gibt an, ob neu hinzugefügte Laufwerke automatisch aktiviert werden sollen.

UltraSearch Tastenkürzel

Wählt einen Tastenkürzel aus, mit dem UltraSearch minimiert und erneut in den Vordergrund gebracht werden kann.

Dateisystemänderungen einbeziehen

Ist diese Option aktiviert, werden Dateiänderungen bei einer neuen Suche automatisch einbezogen.

Sortieren nach

Name

Ordnet die Suchergebnisse nach "Name" an.

Pfad

Ordnet die Suchergebnisse nach "Pfad" an.

Größe

Ordnet die Suchergebnisse nach "Größe" an.

Letzte Änderung

Ordnet die Suchergebnisse nach "Letzte Änderung" an.

Letzter Zugriff

Ordnet die Suchergebnisse nach "Letzter Zugriff" an.

Erstellt am

Ordnet die Suchergebnisse nach "Erstellt am" an.

Typ

Ordnet die Suchergebnisse nach "Typ" an.

Attribute

Ordnet die Suchergebnisse nach "Attribute" an.

Hardlinks

Ordnet die Suchergebnisse nach "Hardlinks" an. (Siehe: Hinweise zu NTFS)

Dateiversion

Ordnet die Suchergebnisse nach "Dateiversion" an.

Aufsteigend

Ordnet die Suchergebnisse in aufsteigender Reihenfolge an.

Absteigend

Ordnet die Suchergebnisse in absteigender Reihenfolge an.

Ergebnisse immer sortieren

Die aktuelle Sortierung wird beibehalten, wenn eine neue Suche gestartet wird (langsamer).

Hilfe

Hilfe

Öffnet die Hilfedatei von UltraSearch.

Auf Update überprüfen ...

Prüft, ob eine neuere Version von UltraSearch verfügbar ist.

Info...

Liefert Informationen über UltraSearch.

Erweiterte Suche

Lernen Sie mehr über TreeSize

Öffnet die TreeSize-Website mit allgemeinen Informationen zum Produkt TreeSize.

Netzlaufwerke mit TreeSize durchsuchen

Öffnet die Website zur TreeSize-Dateisuche mit näheren Informationen über die Dateisuche auf Netzlaufwerken mit TreeSize.

Dateibesitzer mit TreeSize finden

Öffnet die Website zur benutzerdefinierten TreeSize-Dateisuche mit näheren Informationen über die Suche nach Dateibesitzern mit TreeSize.

Doppelte Dateien mit TreeSize finden

Öffnet die Websize zur TreeSize-Duplikatsuche mit näheren Informationen über die Suche nach doppelten Dateien mit TreeSize.

Kostenlose TreeSize Demo-Version herunterladen

Öffnet die Website zum Download der kostenlosen TreeSize Demo-Version.


Laufwerksübersicht

Laufwerksübersicht

Zu durchsuchende Pfade

Die ausklappbare Laufwerksübersicht ermöglicht die Auswahl der zu durchsuchenden Laufwerke und Pfade.

Im eingeklappten Zustand werden alle gültigen Pfade angezeigt, die aktuell für die Suche ausgewählt wurden. Zusätzliche Pfade können mit Hilfe des Plus-Symbols hinzugefügt werden. Pfade, die in der Übersicht angezeigt werden, können zudem mit einem einfachen Klick editiert werden, was das schnelle Anpassen eines Pfades ohne vorheriges Ausklappen der Leiste ermöglicht.

Im ausgeklappten Zustand zeigt die Laufwerksübersicht eine Liste aller verfügbaren sowie bisher verwendeten Suchpfade. Verwenden Sie die Checkboxen der einzelnen Laufwerke, um auszuwählen, welche Laufwerke und Ordner UltraSearch durchsuchen soll. Einzelne Pfade können durch Klick auf die Pinspalte an die Laufwerksliste angepinnt werden, um diese dauerhaft in der Laufwerksliste zu speichern.

Mit den darunter liegenden Schaltflächen können zusätzliche lokale Pfade von NTFS-Laufwerken hinzugefügt werden. Die linke Schaltfläche erlaubt dabei die Eingabe des Pfades über die Tastatur, die rechte öffnet einen Dialog mit einem Verzeichnis-Browser.

Tipp: Für die Suche in Netzwerken oder Domänen, empfehlen wir den Einsatz von TreeSize. Eine kostenlose Demo-Version können Sie hier herunterladen.


Dateisuche

Dateisuche

Um eine Suche auszuführen, ist die Eingabe eines Suchmusters erforderlich. Es kann sowohl nach bestimmten Datei- oder Ordnernamen, als auch nach bestimmten Dateitypen oder Dateien mit bestimmtem textuellen Inhalt gesucht werden.

1. Suche nach Datei- oder Ordnernamen:

Im Suchfeld kann nach gewünschten Datei- oder Ordnernamen gesucht werden:

·Die Platzhalter "*" oder "?" können verwendet werden.

·Für ein exaktes Muster können Anführungszeichen (") verwendet werden.

· Reguläre Ausdrücke werden unterstützt.

·Es können mehrere Suchmuster eingegeben werden. Diese müssen mit Semikolon (;) getrennt werden.

·Ist unter "Optionen > Suchfeld" die Option "Zuletzt verwendete Suchmuster speichern" aktiviert, können über die Dropdown-Liste vorherige Sucheingaben ausgewählt werden.

·Ist unter "Optionen > Suchfeld" zusätzlich die Option "Suchmuster vorschlagen" aktiviert, werden bei Eingabe eines Suchmuster passende Suchmuster auf Basis vorheriger Suchen eingeblendet.

Die folgende Tabelle zeigt einige Beispiele:

readme oder *readme* | Suche nach Dateien, deren Name das Wort "readme" enthält. Beispiele: readme.txt, readmeV2.docx, 1_readmeV2.txt
readme* | Suche nach Dateien, deren Name mit dem Wort "readme" beginnt. Beispiele: readme.txt, readmeV2.docx.
*readme | Suche nach Dateien, dere Name mit dem Wort "readme" endet. Beispiele: readme.txt, V2_readme.txt
"readme.txt" | Suche nach Dateien, die "readme.txt" heissen. Beispiele: readme.txt
rea?me | Suche nach Dateinamen, die mit "rea" beginnen, und auf "me" enden, und dazwischen genau ein beliebiges Zeichen beinhalten. Beispiele: readme.txt, reasme.txt, rea1me.txt
readme; prog; | Suche nach Dateien, deren Name das Wort "readme" oder "prog" enthält. Beispiele: readme.txt, readmeV2.log, programming.xlsx
"readme.txt"; logfile; | Suche nach Dateien, die "readme.txt" heissen oder deren name das Wort "logfile" beinhaltet. Beispiele: readme.txt, logfile.log, mylogfile.docx

Beispiele und nähere Informationen zu regulären Ausdrücken finden Sie hier.

Falls die Option "Ordner einbeziehen" aktiv ist, sucht UltraSearch auch nach Ordnern, die dem eingegebenem Suchmuster entsprechen.

2. Suche nach Dateitypen oder - gruppen

Mittels der Dateitypenauswahl kann die Suche zusätzlich zur Eingabe eines Suchmusters auf bestimmte Dateitypen oder -gruppen beschränkt werden. Diese können entweder aus der Dropdown-Liste ausgewählt oder manuell eingegeben werden.

·Die Dateigruppen, die in der Dropdown-Liste angezeigt werden, lassen sich unter "Optionen > Dateigruppen konfigurieren..." festlegen.

·Es können mehrere Dateitypen und -gruppen eingegeben werden. Diese müssen mit Semikolon (;) getrennt werden.

·Folgende Syntax ist für einzelne Dateitypen erlaubt: *.txt oder .txt oder txt .

Die folgende Tabelle zeigt einige Beispiele:

Auswahl: "Text Dateien" | Suche nach Textdateien, deren Name dem im Suchfeld angegebenen Suchmuster entspricht. Beispiele: readme.txt, logfile.log, readme.nfo
Audio-Dateien; Video-Dateien; | Suche nach Audio- und Video-Dateien, deren Name dem im Suchfeld angegebenen Suchmuster entspricht. Beispiele: film.mkv, audio.mp3
txt | Suche nach Dateien mit der Dateiendung "txt", deren Name dem im Suchfeld angegebenen Suchmuster entspricht. Beispiele: readme.txt, text.txt
txt; docx; | Suche nach Dateien mit der Dateiendung "txt" oder "docx", deren Name dem im Suchfeld angegebenen Suchmuster entspricht. Beispiele: readme.txt, readme.docx
Text Dateien; docx; xlsx; | Suche nach Text Dateien oder Dateien mit der Endung "docx" oder "xlsx", deren Name dem im Suchfeld angegebenen Suchmuster entspricht. Beispiele: readme.txt, logfile.log, readme.docx, rec.xlsx

3. Suche nach Dateiinhalt

Die Dateiinhalts-Suche bietet zusätzlich zur Suche nach Dateinamen oder Dateitypen die Möglichkeit, Dateien auch nach einem bestimmten Inhalt zu durchsuchen. UltraSearch erlaubt es, den textuellen Inhalt einer Datei zu analysieren, und nach bestimmten Suchwörtern zu durchsuchen. Falls diese gefunden werden, wird die entsprechende Datei als Suchergebnis angezeigt. Diese Art der Suche ist nicht nur für reine Textdateien möglich, sondern auch für komplexere Formate wie PDF, Microsoft Excel oder Microsoft Word.

Anmerkung: Die Suche nach Dateiinhalten kann sehr langsam sein, da der gesamte Inhalt einer Datei analysiert werden muss. Es wird daher dringend empfohlen, die Dateiinhaltssuche mit anderen Suchkriterien zu kombinieren um die Suche zu beschleunigen!

Reine Textdateien und IFilter

UltraSearch kann reine Textdateien sehr schnell nach einem bestimmten Suchbegriff durchsuchen, indem es diese auf Dateisystemebene durchläuft und analysiert. Dabei werden alle gängigen Zeichenkodierungen wie ASCII, Unicode oder UTF-8 unterstützt.

Um darüber hinaus auch komplexe Dateitypen, wie Microsoft Word, Excel, oder PowerPoint durchsuchen zu können, nutzt UltraSearch das sogenannte IFilter Interface, welches vom Betriebssystem bereitgestellt wird. Auch Drittanbieter-Anwendungen können eigene Behandlungsroutinen zur Verfügung stellen, mit denen bestimmte Dateiformate ausgelesen werden können. Viele Dateiformate, wie beispielsweise die üblichen Office-Formate, werden bereits durch eigene Routinen des Betriebssystems behandelt.

Andere Formate, wie zum Beispiel PDF, können mit Hilfe von Filtern ausgelesen werden, die während der Installation eines PDF-Betrachters automatisch registriert werden. Diese stehen dann auch für die Benutzung in UltraSearch zur Verfügung.

Groß- und Kleinschreibung

Bei allen Sucharten (der Suche nach Dateinamen, Dateitypen oder Dateiinhalten) werden eventuelle Unterschiede bei der Groß- und Kleinschreibung ignoriert. Die Suche ist "case insensitiv". UltraSearch verwendet dazu die entsprechende Zeichensatztabelle, welche durch die aktuellen Regionaleinstellungen definiert wird.


Dateigruppen

Dateigruppen

Die Dateitypen, die in der Dateitypenauswahl zur Verfügung stehen, können unter "Optionen > Dateigruppen konfigurieren..." festgelegt werden.

Eine neue Gruppe hinzufügen

1.Legen Sie den Namen der neuen Gruppe (zum Beispiel "Textdateien") im Textfeld "Gruppendefinitionen" fest.

2.Klicken Sie auf "Neue Gruppe".

3.Klicken Sie in das Textfeld im Bereich "Zugeordnete Dateitypen" und definieren Sie die gewünschten Dateitypen, die dieser Gruppe angehören sollen (bspw. "*.txt).

4.Klicken Sie auf "Hinzufügen".

5.Wiederholen Sie die Schritte 3 und 4, bis alle gewünschten Dateitypen hinzugefügt wurden.

6.Klicken Sie auf "Ok", um die Änderungen zu speichern.

Einen Dateityp einer existierenden Gruppe hinzufügen/entfernen/editieren

1.Klicken Sie auf die gewünschte Gruppe in der oberen Liste.

2.Fügen Sie einen neuen Dateityp hinzu, indem Sie die Schritte 4 und 5, wie oben beschrieben, befolgen
oder
benutzen Sie die Schaltfläche "Löschen", um einen existierenden Dateityp aus der Liste zu entfernen
oder
klicken Sie mit der rechten Maustaste auf einen existierenden Dateityp und wählen Sie "Muster bearbeiten", um die Definition eines Dateityps zu bearbeiten.

3.Klicken Sie auf "Ok", um die Änderungen zu speichern.

Titel oder Beschreibung einer existierenden Gruppe ändern

Klicken Sie mit der rechten Maustaste auf die gewünschte Gruppe und wählen Sie entweder "Titel bearbeiten" oder "Beschreibung ändern".

Exportieren/Importieren einer Liste von Dateitypen

Sie können die für eine Gruppe definierten Dateitypen in eine Text-, CSV-, oder XML-Datei exportieren, indem Sie mit der rechten Maustaste in die untere Liste klicken und auf die Schaltfläche "Export" klicken. Auf die gleiche Weise kann auch eine bestehende Definition importiert werden.


Ausschlussfilter

Ausschlussfilter

Über den Ausschlussfilter können Ordner, Dateien oder Dateitypen von den Suchergebnissen ausgeschlossen werden. Ein solcher Filter wird wie ein Suchmuster definiert.

Der Ausschlussfilter-Dialog kann über das Menü "Suche > Ausschlussfilter..." oder den entsprechenden Eintrag in der Optionen-Symbolleiste geöffnet werden.

Einen Filter definieren

Um einen neuen Filter zu definieren, befolgen Sie bitte folgende Schritte:

1.Klicken Sie auf "Hinzufügen". Für den neuen Filter wird ein Eintrag in der Filter-Liste erzeugt.

2.Nun können Sie in der Spalte "Muster" einen Ausschlussfilter definieren. Sie können entweder ein einfaches Platzhalter-Muster wie "*.exe", einen regulären Ausdruck wie ".+\.exe$" oder ein Muster, das auf den gesamten Namen wie zum Beispiel "notepad.exe" prüft, verwenden. Ein Ausschlussfilter mit dem Muster "*.exe" sorgt beispielsweise dafür, dass UltraSearch sämtliche Dateien mit der Dateiendung ".exe" von der Suche ausschließt. Dadurch werden Dateien dieses Typs weder in den Suchergebnissen berücksichtigt, noch aufgelistet. Bitte stellen Sie sicher, dass der zu Ihrem Muster passende Typ in der gleichnamigen Spalte ausgewählt wurde.

3.Über die Spalte "Vergleichen mit" legen Sie fest, gegen welche Datei- oder Ordnereigenschaft das Muster geprüft wird. Muster können entweder gegen Datei- oder Ordnernamen, absolute Pfade, Name des direkten übergeordneten Ordners oder Name eines beliebigen übergeordneten Ordners geprüft werden. Mit Hilfe des Attributs "Absoluter Pfad" lassen sich beispielsweise Ordner, die einem bestimmten Muster wie "Program Files" entsprechen, vom Scan ausschließen. Das Attribut "Datei- oder Ordnername" sollten Sie dann verwenden, wenn Sie einen bestimmten Dateityp ein- oder ausschließen wollen.

Platzhalter, die zum Bau von Namensmustern für Dateien verwendet werden können:

* | Ersetzt kein oder beliebig viele alphanumerische Zeichen.
? | Ersetzt genau ein alphanumerisches Zeichen.

Muster dürfen nicht nur Namen von Dateien oder Ordnern enthalten, sondern auch ganze Pfade. Es können mehrere Suchmuster mit Semikolon getrennt werden. Um einen exakten Vergleich (also ohne Platzhalter) zu erzwingen, wählen Sie bitte "Gesamter Name" in der Spalte "Typ" für dieses Muster aus. Reguläre Ausdrücke können ebenfalls als Suchmuster verwendet werden indem Sie in der Spalte "Typ" "RegEx" auswählen.

Nachfolgende Tabelle veranschaulicht die unterschiedlichen Arten von Mustern anhand von Beispielen:

Muster | Vergleichen mit | Typ | Ergebnis
*.doc | Datei- oder Ordnername | Platzhalter | Ausschluss aller Dateien mit der Endung ".doc".
*\Windows\System32\*.exe | Absoluter Pfad | Platzhalter | Ausschluss aller Anwendungen (Dateien mit der Endung ".exe") unter dem Pfad "Windows\System32".
"Neues Textdokument.txt" | Datei- oder Ordnername | Gesamter Name | Ausschluss aller Dateien mit dem Namen "Neues Textdokument.txt".
C:\\([a-z]*\\){2,4}[^\\]*\.[^\\]*$ | Absoluter Pfad | RegEx | Ausschluss aller Dateien auf Laufwerk C: mit einer Verzeichnistiefe von mindestens 2 und höchstens 4.

Wählen Sie einen definierten Ausschlussfilter aus und klicken Sie auf "Vorschau...", um eine Explorer-Ansicht zu öffnen, die anzeigt, welche Dateien und Ordner durch diesen Filter von der Suche ausgeschlossen werden. Ausgeschlossene Ordner und Dateien werde in rot angezeigt, grün dargestellte Dateien und Ordner werden weiterhin in der Suche berücksichtigt.

Über die Schaltfläche "Standardfilter hinzufügen" werden vordefinierte Filter zum Ausschluss von speziellen Systemordnern (wie z.B. dem Papierkorb) erstellt.


Hinweise zu NTFS

Hinweise zu NTFS

Hardlinks

Ein Hardlink ist ein Verzeichniseintrag in der MFT (Master File Table) von NTFS Partitionen. Jede Datei weist mindestens einen Hardlink auf. Auf NTFS-Datenträgern kann jede Datei mehrere Hardlinks besitze und daher in mehreren Verzeichnissen (oder im selben Verzeichnis mit verschiedenen Namen) angezeigt werden. Da alle diese Verbindungen auf dieselbe Datei verweisen, können Programme einen beliebigen Hardlink öffnen und die Datei ändern. Eine Datei wird nur dann aus dem Dateisystem gelöscht, wenn alle Hardlinks zu dieser Datei gelöscht wurden. Bitte beachten Sie auch, dass sich alle Hardlinks auf eine Datei die gleichen Zugriffsberechtigungen teilen.

Existiert mehr als ein Eintrag für eine Datei, so muss beim Berechnen des belegten Speicherplatzes diese Datei lediglich einmal berücksichtigt werden, egal wie viele Hardlinks existieren. UltraSearch ist in der Lage, die Anzahl der Hardlinks die auf eine Datei verweisen zu identifizieren. Die Anzahl der Hardlinks, die auf eine Datei verweisen, wird in der Spalte Hardlinks angezeigt.


Reguläre Ausdrücke

Reguläre Ausdrücke

Reguläre Ausdrücke beschreiben Muster in Zeichenketten und werden u.a. dazu benutzt, um festzustellen, ob in einem Text, dem Suchtext, ein vorgegebenes Zeichenmuster vorkommt oder nicht. In UltraSearch können Reguläre Ausdrücke dazu benutzt werden, bestimmte Dateien und/oder Ordner zu finden, die den mittels Regulärer Ausdrücke festgelegten Kriterien entsprechen.

Die folgende Tabelle zeigt einige Beispiele:

Ausdruck | Syntax | Beschreibung | Beispiel
Beliebiges Zeichen | . | Entspricht einem beliebigen Zeichen mit Ausnahme des Zeilenumbruchs. | a.o findet "aro" in "around" und "abo" in "about", jedoch nicht "acro" in "across".
0 (null) oder mehr | * | Findet 0 (null) oder mehr Vorkommen des vorangehenden Ausdrucks und ergibt somit alle möglichen Übereinstimmungen. | *b findet "b" in "bat" und "ab" in "about". e.*e findet das Wort "enterprise".
Eine oder mehr | + | Findet mindestens ein Vorkommen des vorhergehenden Ausdrucks. | ac+ findet Wörter mit dem Buchstaben "a" und mindestens einer Instanz von "c", z. B. "race" und "ace". a.+s findet das Wort "access".
Wortanfang | < | Findet nur dann eine Übereinstimmung, wenn das Wort an dieser Textstelle beginnt. | <in findet Wörter wie "inside" und "into", die mit den Buchstaben "in" anfangen.
Wortende | > | Gibt eine Übereinstimmung nur zurück, wenn das Wort an dieser Textstelle endet. | ss> findet Wörter wie "across" und "loss", die mit den Buchstaben "ss" enden.
Ein beliebiges Zeichen in der Menge | [] | Findet eines der Zeichen, die in [] enthalten sind. Geben Sie zum Festlegen eines Bereichs von Zeichen das Start- und das Endzeichen durch einen Bindestrich (-) getrennt ein, wie in [a-z]. | be[n-t] findet "bet" in "between", "ben" in "beneath" und "bes" in "beside", jedoch nicht "bel" in "below".
Ein beliebiges, nicht in der Menge enthaltenes Zeichen | [^...] | Findet ein beliebiges Zeichen, das nicht im Satz von Zeichen nach ^ enthalten ist. | be[^n-t] findet "bef" in "before", "beh" in "behind" und "bel" in "below", jedoch nicht "ben" in "beneath".
Or | | | Findet entweder den Ausdruck vor oder nach dem Symbol OR (|). Wird meistens in einer Gruppe verwendet. | (sponge|mud) bath findet "sponge bath" und "mud bath".
Escape | \ | Findet das Zeichen, das dem umgekehrten Schrägstrich (\) als Literal folgt. Damit können Sie Zeichen wie { und ^ suchen, die in der Notation für reguläre Ausdrücke verwendet werden. | \^ sucht nach dem Zeichen ^.
Markierter Ausdruck | {} | Findet den Text, der mit dem in Klammern stehenden Ausdruck übereinstimmt. | zo{1} findet "zo1" in "Alonzo1" und "Gonzo1", jedoch nicht "zo" in "zone".
n Mal wiederholen. | ^n | Entspricht n Instanzen des vorhergehenden Ausdrucks. | [0-9]^4 findet alle Zeichenfolgen mit 4 Ziffern.
Gruppierung | () | Ermöglicht es Ihnen, einen Satz von Ausdrücken zu gruppieren. Wenn Sie in einer Suche nach zwei verschiedenen Ausdrücken suchen möchten, können Sie diese mit dem Gruppierungsausdruck kombinieren. | Wenn Sie nach [a-z][1-3] oder [1-10][a-z] suchen möchten, würden Sie diese Ausdrücke wie folgt kombinieren: ([a-z][1-3]) | ([1-10][a-z]).

Weitere Beispiele:

[0-9] oder /\d | Findet alle Dateien/Ordner, die mindesten eine Ziffer im Namen enthalten.
a|b | Findet alle Dateien/Ordner, die "a" oder "b" im Namen enthalten.
(?=.*a)(?=.*b) | Findet alle Dateien/Ordner, die mindestens sowohl ein "a" als auch ein "b" enthalten.
((?=.*help)|(?=.*online))(?=.*readme) | Findet alle Dateien/Ordner, die die Wörter "help" und "readme" oder "online" und "readme" beinhalten.
[^(A-Za-z)] | Findet alle Dateien/Ordner, die mindestens ein Zeichen enthalten, das kein Buchstabe ist.
^E[0-9]{7}$ | Findet alle Dateien/Ordner, die mit einem "E" beginnen an das sich genau sieben Ziffern anschließen.
C:\\Windows\\[^\\]*\.[^\\]*$ | Findet alle Dateien/Ordner, deren direkter übergeordneter Ordner C:\Windows ist.
[A-Za-z]:\\([^\\]+\\){2,4}[^\\]+$ | Findet alle Dateien/Ordner mit einer Verzeichnistiefe von mindestens 2 und höchstens 4.
[^\x00-\x7F] | Findet alle Dateien/Ordner mit ungültigen ASCII-Zeichen (nur 7Bit ASCII erlaubt).
[^\P{C}] | Findet alle Dateien/Ordner mit nicht-druckbaren Unicode-Zeichen.
[\xA0] | Findet alle Dateien/Ordner mit dem non-breakable-Space Zeichen (Unicode NOBR, U+00A0)
[~,\",#,%,&,\*,\:,<,>,\?,\/,\\,{,|,}] | Findet alle Dateien und Ordner, die in ihrem Namen Zeichen enthalten, die auf einem SharePoint Server nicht erlaubt sind.

Mehr Informationen zu regulären Ausdrücken sowie Beispiele finden Sie hier.

Eine Liste spezieller Zeichen, die innerhalb Regulärer Ausdrücke benutzt werden können finden Sie hier.

Zur weiteren Hilfe beim Bilden Regulärer Ausdrücke können folgende Tools verwendet werden:

http://gskinner.com/RegExr/ (online)

http://regexpal.com/ (online)

http://sourceforge.net/projects/regexpeditor/ (download)

http://sourceforge.net/projects/regextester/ (download)

http://sourceforge.net/projects/regaxe/ (download)


Kommandozeilen-Parameter

Kommandozeilen-Parameter

Kommandozeilen-Parameter

UltraSearch unterstützt Kommandozeilen-Parameter, mit denen sich UltraSearch mit definierten Suchparametern starten lässt. Mehrere Suchparameter werden mit Leerzeichen getrennt.

Suchparameter (Pfade oder Dateinamen), die bereits Leerzeichen beinhalten, müssen mit Anführungszeichen (") umschlossen werden.

Die allgemeine Syntax für Kommandozeilen-Parameter lautet wie folgt:

UltraSearch.exe Such-Pfad(e) Dateiname(n) Dateityp(en)

Beispiele:

ultrasearch.exe "C:\Windows" "readme.txt" | Startet UltraSearch mit der Suche nach allen Dateien, deren Name "readme.txt" beinhaltet im Verzeichniszweig "C:\Windows".
ultrasearch.exe "C:\Windows" """readme.txt""" | Startet UltraSearch mit der Suche nach allen Dateien mit dem exakten Namen "readme.txt" im Verzeichniszweig "C:\Windows".
ultrasearch.exe "C:\Windows" "*.txt" | Startet UltraSearch mit der Suche nach allen Dateien mit der Dateiendung ".txt" im Verzeichniszweig "C:\Windows".
ultrasearch.exe "C:\Windows\readme.txt" | Startet UltraSearch mit der Suche nach der Datei mit dem Namen "readme.txt" im Ordner "C:\Windows".
ultrasearch.exe "C:\Windows" "C:\Program Files" "readme.txt" "logfile.log" | Startet UltraSearch mit der Suche nach Dateien, deren Name "readme.txt" oder "logfile.log" beinhaltet in den Verzeichniszweigen "C:\Windows" und "C:\Program Files".
ultrasearch.exe /minimized | Startet UltraSearch minimiert in der Taskleiste von Windows.
ultrasearch.exe /maximized | Startet UltraSearch als maximiertes Fenster.
ultrasearch.exe /tray | Startet UltraSearch minimiert im Infobereich von Windows.


Copyright & Contact

Copyright & Contact

Copyright © 2018 Joachim Marder e.K.

JAM Software GmbH
Am Wissenschaftspark 26
54296 Trier

FAX: | +49-651-145653-29
WWW: | https://www.jam-software.de
Support: | https://www.jam-software.de/customers/contact.php
E-Mail: | ultrasearch@jam-software.de
Handelsregister: | HRB: 4920 beim Amtsgericht Wittlich
Umsatzsteuer ID: | DE234825349
Geschäftsführer: | Joachim Marder