AllDup Dokumentation

Über AllDup

  • Produktbeschreibung
  • Systemanforderungen
  • Wichtige Hinweise
  • Weitere Produkte

Hauptfenster

  • Quellordner
  • Suchmethode
  • Suchoptionen
  • Archivdateien
  • Datenbank
  • Filter
    • Dateifilter
    • Ordnerfilter
    • Systemvariablen
  • Dateivorschau
  • Profile
  • Suchergebnisse
  • Optionen
  • Internet Update

Suchergebnis

  • Suchergebnis
  • Menüleiste / Symbolleiste
  • Kontextmenüs
  • Dateimanager
  • Tastaturkürzel

Sonstiges

  • Kommandozeile
  • Platzhalter für Text
  • Platzhalter für Datum und Uhrzeit
  • Geschwindigkeitsvergleich


AllDup

Duplikate suchen und entfernen

AllDup ist Freeware und hilft Ihnen dabei Ihre Festplatten, Speichermedien, Netzwerkordner oder auch nur einzelne Verzeichnisse nach doppelten Dateien zu durchsuchen und diese gezielt zu löschen.

Die Suche kann hierbei durch Kombination der folgenden Kriterien durchgeführt werden: Dateiname, Dateiendung, Dateigröße, Dateiinhalt, Änderungsdatum, Erstellungsdatum, Dateiattribute.

Zusätzlich können Sie auch nach ähnlichen Dateinamen, ähnlichen Bildern oder ähnlichen Musikdateien suchen. Des weiteren können Sie nach Video- und Musikdateien mit einer gleich langen Tonspur suchen oder Ihre Festplatte nach Hardlinks durchsuchen.

AllDup Features

  • Durchsuchen von Archiven mit den folgenden Dateiendungen: 7Z, ARJ, CAB, CB7, CBR, CBT, CBZ, EPUB, GZ, ISO, LZH, LHA, NRG, RAR, TAR, ZIP
  • Ignorieren der ID3-Tags beim Vergleichen von MP3-Dateien
  • Suche nach ähnlichen Bildern
  • Doppelte Dateien in den Windows Papierkorb verschieben
  • Übersichtliche Darstellung der doppelten Dateien in einer Liste unterteilt in Gruppen
  • Vorschau von Bild-, Text-, Sound-, Video- und Internetdateien direkt im Programm
  • Die Liste mit den doppelten Dateien in eine Textdatei oder Excel-Tabelle exportieren
  • Finde Video- und Musikdateien bei welchen die Tonspur die gleiche oder fast gleiche Länge aufweist
  • Schneller Suchalgorithmus
  • Diverse Filtermöglichkeiten um bestimmte Ordner oder Dateien von der Suche auszuschließen
  • Keine Einschränkungen bei der Anzahl der zu durchsuchenden Datenmenge
  • Internet Update zum automatischen Aktualisieren der Software
  • Auflistung von allen Dateien welche keine Duplikate besitzen
  • Ignorieren der Exif-Daten beim Vergleichen von JPG/JPEG-Dateien
  • Hilfedatei mit Beschreibung von allen Funktionen
  • Kostenlose Nutzung für Privatanwender und Firmen
  • Die Liste mit den doppelten Dateien speichern und wieder herstellen
  • Doppelte Dateien permanent löschen
  • Doppelte Dateien in einen Backupordner verschieben
  • Ausführliche Protokolldatei von alle Vorgängen
  • Doppelte Dateien löschen und Verknüpfungen erstellen
  • Die Suche nach Duplikaten kann direkt im Windows Explorer über das Kontextmenü für Ordner gestartet werden
  • Diverse Befehle um Dateien nach bestimmten Kriterien in der Liste automatisch auszuwählen
  • Doppelte Dateien löschen und Hardlinks erstellen
  • Festplatten, Speichermedien, Netzwerkordner und Verzeichnisse können gemeinsam durchsucht werden
  • Ignorieren der Metadaten beim Vergleich von FLAC-Dateien


AllDup Systemanforderungen

AllDup ist kompatibel mit allen Versionen der folgenden Betriebssysteme (32/64-Bit):

Workstation:
  • Microsoft Windows 11
  • Microsoft Windows 10
  • Microsoft Windows 8
  • Microsoft Windows 7
  • Microsoft Windows Vista*
  • Microsoft Windows XP*

Server:
  • Microsoft Windows Server 2022
  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008*
  • Microsoft Windows Server 2003*

* Verwenden Sie bitte die AllDup Portable Edition wenn Sie AllDup mit diesen älteren Betriebssystemen von Windows nutzen möchten. Die Setupdatei von AllDup kann erst ab Windows 7 / Server 2012 installiert werden.


Wichtiger Hinweis

Das Löschen, Verschieben oder Umbenennen von Dateien kann dazu führen, dass sich Windows oder Programme nicht mehr starten lassen! Sie sollten nur dann Dateien löschen, verschieben oder umbenennen, wenn Sie sich absolut sicher sind, dass diese nicht für den Betrieb von Windows oder anderen Programmen benötigt werden.

Bitte haben Sie dafür Verständnis, dass wir Ihnen zu Fragen, welche Dateien gelöscht werden dürfen, keine individuelle Hilfestellung geben können.


Andere Softwareprodukte

AllSync - Datensychronisation und Datensicherung

AllSync

Datensicherung & Ordnersynchronisation

AllSync ist die professionelle Lösung für Ihre Ordnersynchronisation und Datensicherung auf Einzelrechnern, Laptops oder im kompletten Netzwerk. Das Programm umfasst Synchronisation, Aktualisierung, Vervielfältigung, Archivierung und Datensicherung von Dateien und Verzeichnissen unter Windows.


Quellordner

Mit der Quellordnerliste können Sie festlegen, welche Laufwerke und Ordner nach Dateiduplikaten durchsucht werden sollen. Sie aktivieren einen Quellordner für die Suche indem Sie das Kontrollkästchen vor dem Ordnerpfad aktivieren.

Unterordner ausschließen
Wenn Sie bei einem Quellordner das Kontrollkästchen in der Spalte Unterordner durchsuchen deaktivieren, dann werden alle Unterordner in diesem Quellordner von der Suche ausgeschlossen.

Dateischutz
Wenn Sie bei einem Quellordner das Kontrollkästchen in der Spalte Dateischutz aktivieren, dann kann AllDup keine Dateien innerhalb dieses Quellordners löschen, verschieben oder umbenennen. Der Dateischutz kann später bei Bedarf im Suchergebnis über den Menüpunkt Dateischutz in der Menüleiste geändert werden.

Ordner hinzufügen
Sie können einen neuen Ordner zu der Quellordnerliste hinzufügen, indem Sie in der Symbolleiste auf die Schaltfläche Quellordner klicken, in der Quellordnerliste mit der rechten Maustaste das Kontextmenü aufrufen, in der Quellordnerliste rechts oben auf die Schaltfläche + klicken oder Sie ziehen mit der Maus einen Ordner aus dem Windows Explorer in die Quellordnerliste hinein.

Quellordner bearbeiten
Wenn Sie mit der rechten Maustaste auf einen Quellordner klicken, dann wird Ihnen ein Menü mit verschiedenen Befehlen angezeigt, wie z.B. Bearbeiten, Löschen, Öffnen...

Vergleichsmethode

  • Vergleiche Dateien aus allen Quellordnern
  • Vergleiche nur Dateien welche sich in dem gleichen Quellordner befinden
  • Vergleiche nur Dateien aus unterschiedlichen Quellordnern
  • Vergleiche nur Dateien welche sich in dem gleichen Quell- und Unterordner befinden

Optionen

Keine Ordner (NTFS-Abzweigungspunkte) durchsuchen, welche auf den Inhalt anderer Ordner verweisen
NTFS-Abzweigungspunkte sind leere Ordner welche auf den Inhalt eines anderen Ordners verweisen. Mit dieser Option können Sie verhindern, dass solche Ordner durchsucht und bearbeitet werden. Diese Option ist standardmäßig aktiviert. Wenn Sie diese Option deaktivieren, dann sollten Sie zuvor überprüfen, dass durch die Abzweigungspunkte keine Endlosschleife entsteht und keine Daten doppelt bearbeitet werden.

Windows 64-Bit Dateisystemweiterleitung deaktivieren
Diese Option ermöglicht es AllDup die korrekte Anzahl von Systemdateien bei einer 64bit-Version von Windows zu ermitteln.


Suchmethode

Folgende Suchmethoden stehen Ihnen für die Suche nach doppelten Dateien zur Auswahl:
  • Finde Dateiduplikate anhand von Dateieigenschaften
  • Finde ähnliche Dateinamen
  • Finde ähnliche Bilder
  • Finde ähnliche Musik
  • Finde Video- und Musikdateien anhand der Tonspurlänge
  • Finde Hardlinks

Finde Dateiduplikate anhand von Dateieigenschaften

Folgende Dateieigenschaften stehen zur Auswahl:
  • Dateiname
    Findet Dateien mit dem gleichen Namen (ohne Endung)
  • Dateiendung
    Findet Dateien mit der gleichen Endung
  • Dateigröße
    Findet Dateien mit der gleichen Größe
  • Dateiinhalt
    Findet Dateien mit gleichen oder einem ähnlichen Inhalt
  • Änderungsdatum
    Findet Dateien mit dem gleichen Änderungsdatum
  • Erstellungsdatum
    Findet Dateien mit dem gleichen Erstellungsdatum
  • Dateiattribute
    Findet Dateien mit den gleichen Attributen
Uhrzeit ignorieren
Mit dieser Option wird bei dem Suchkriterium Änderungsdatum und Erstellungsdatum nur das Datum ohne die Uhrzeit beim Vergleich verwendet.

Sekunden ignorieren
Mit dieser Option werden bei dem Suchkriterium Änderungsdatum und Erstellungsdatum die Sekunden bei der Uhrzeit ignoriert.

Optionen

Keine Hardlinks inhaltlich vergleichen
Mit dieser Option werden bei dem Suchkriterium Dateiinhalt und Ähnliche Bilder keine Dateien und deren Hardlinks inhaltlich verglichen, da der Inhalt solcher Dateien exakt gleich ist.

Finde Video- und Musikdateien anhand der Tonspurlänge

Mit dieser Suchmethode können Sie nach Video- und Musikdateien suchen, welche eine gleich lange Tonspur besitzen. Hierbei wird immer die Länge der ersten Tonspur verglichen. Es werden alle Video- und Audiodateien mit den folgenden Dateiendungen unterstützt:

Audio: AAC, AC3, AIFF, APE, AU, DTS, FLAC, M4A, MP2, MP3, OGG, WAV, WMA
Video: ASF, AVI, OGV, M2TS, M4V, MKV, MOV, MP4, MPG, WEBM, WMV

Zeitunterschied ignorieren
Mit dieser Option haben Sie die Möglichkeit Mediadateien mit einer fast gleich langen Tonspur zu finden indem Sie einen maximalen Zeitunterschied festlegen.

Vergleiche nur Dateien mit den gleichen Eigenschaften
  • Dateiname
    Mit dieser Option werden nur Dateien mit dem gleichen Namen verglichen.
  • Dateiendung
    Mit dieser Option werden nur Dateien mit der gleichen Endung verglichen.


Suchmethode 'Dateiname'

Vergleichsmethode

  • Vergleiche alle Zeichen eines Dateinamen
  • Vergleiche nur Zeichen am Anfang eines Dateinamen
    Mit dieser Option wird nur eine bestimmte Anzahl von Zeichen am Anfang des Dateinamen verglichen.
  • Vergleiche nur Zeichen am Ende eines Dateinamen
    Mit dieser Option wird nur eine bestimmte Anzahl von Zeichen am Ende des Dateinamen verglichen.
  • Ignoriere Zeichen am Ende eines Dateinamen
    Mit dieser Option wird eine bestimmte Anzahl von Zeichen am Ende des Dateinamen ignoriert.

Ignoriere folgende Zeichen im Dateinamen

Mit dieser Option werden die angegebenen Zeichen aus den zu vergleichenden Dateinamen ignoriert. Wenn Sie z.B. das Minuszeichen (-) angeben, dann werden die Dateinamen "Test-01" und "Test01" als Duplikate erkannt.

Ignoriere folgende Texte im Dateinamen

Mit dieser Option werden die angegebenen Textmuster aus den zu vergleichenden Dateinamen ignoriert. Sie können mehrere Textmuster angeben welche mit dem Schrägstrichzeichen (/) getrennt werden müssen. Wenn Sie z.B. das Textmuster "001/002" angeben, dann werden die Dateinamen "Test001" und "Test002" als Duplikate erkannt.


Suchmethode 'Dateiinhalt'

Mit dieser Suchmethode können Dateien welche die gleiche Dateigröße besitzen inhaltlich verglichen werden.

Vergleichsmethoden

  • Byte für Byte
  • Prüfsumme MD5 (128-Bit)
  • Prüfsumme SHA-1 (160-Bit)
  • Prüfsumme SHA-2 (256-Bit)
  • Prüfsumme SHA-2 (384-Bit)
  • Prüfsumme SHA-2 (512-Bit)

Byte für Byte

Mit dieser Vergleichsmethode wird der Inhalt der zu vergleichenden Dateien Stück für Stück eingelesen und verglichen. Mit einer festgelegten Übereinstimmung von 100% wird der Dateivergleich abgebrochen, sobald ein Unterschied festgestellt wurde. Bei einer festgelegten Übereinstimmung von weniger als 100% wird immer der komplette Dateiinhalt verglichen, damit die prozentuale Übereinstimmung berechnet werden kann.
Beispiel: Bei einer festgelegten Übereinstimmung von 90% werden alle Dateien als Duplikate eingestuft, welche eine Übereinstimmung von 90% oder höher haben.

Prüfsummen

Bei der Prüfsummen-Methode wird die Datei immer komplett eingelesen und eine Prüfsumme von dem Inhalt erstellt, welche bei weiteren Dateivergleichen dann verwendet wird. Die Prüfsummen-Methode kann beim Vergleich von vielen Dateien mit der gleichen Dateigröße schneller sein als die Byte für Byte Methode.

HINWEIS: Dateien mit einer Größe von 0 Bytes werden automatisch von der Suche ausgeschlossen.

ID3-Tags von MP3-Dateien ignorieren

Mit dieser Option werden bei einem Inhaltsvergleich von MP3-Dateien die folgenden Tags ignoriert:
  • ID3v1
  • ID3v2
  • Lyrics3 v2
  • APE v2
Info: AllDup ignoriert doppelte ID3v2-Tags am Anfang einer MP3-Datei und doppelte ID3v1-Tags am Ende der Datei.

Metadaten von JPEG/CR2-Dateien ignorieren

Mit dieser Option werden nur die Bilddaten in Dateien mit den Endungen "JPEG", "JPG" und "CR2" bei einem Inhaltsvergleich verglichen.

Metadaten von FLAC-Dateien ignorieren

Mit dieser Option werden alle Metadaten von FLAC-Dateien bei einem Inhaltsvergleich ignoriert.

Vergleiche zuerst einen Datenblock am Ende der beiden Dateien

Mit dieser Option wird bei einem Inhaltsvergleich zuerst ein Datenblock am Ende der beiden Dateien verglichen. Hiermit kann der Zeitaufwand für den Inhaltsvergleich unter Umständen erheblich verringert werden.

Blockgröße des Lesepuffers

Mit dieser Option können Sie die Blockgröße für den Vergleich des Inhalts von zwei Dateien festlegen. Diese Option ermöglicht einen unterschiedlichen Inhalt am Anfang einer Datei schnell zu erkennen, ohne dass zuerst ein großer Teil der beiden Dateien eingelesen werden muss. Beim Start des Vergleichs wird ein Datenblock mit der Größe des festgelegten Startwerts von beiden Dateien eingelesen. Der Vergleich wird beendet, wenn die beiden Blöcke nicht identisch sind. Ansonsten wird die Blockgröße um die festgelegte Schrittgröße erhöht und ein weiter Vergleich durchgeführt. Die Erhöhung der Blockgröße wird bis zu dem festgelegten Maximalwert durchgeführt. Danach wird immer eine Blockgröße mit dem Maximalwert eingelesen.


Finde ähnliche Dateinamen

Vergleichsmethode

Folgende Vergleichsmethoden stehen zur Auswahl:
  • SmartMatch
  • FuzzyMatch
  • Levenshtein
  • Ratcliff-Obershelp
  • MatchDiff
  • WordMatch
  • FuzzyPercent
  • Simil
Alle Vergleichsmethoden außer WordMatch führen verschiedene Vergleiche und Berechnungen zwischen zwei Dateinamen durch um deren prozentuale Übereinstimmung zu bestimmen. Die Vergleichsmethode WordMatch splittet die Dateinamen in einzelne Wörter und berechnet anhand den unterschiedlichen Wörtern die prozentuale Übereinstimmung. Die Groß- und Kleinschreibung der Dateinamen wird bei allen Vergleichsmethoden ignoriert.

Übereinstimmung

Die Übereinstimmung in Prozent legt fest ab wann zwei unterschiedliche Dateinamen als Duplikate eingestuft werden.

Trennzeichen

Hier können Sie die Trennzeichen für die Vergleichsmethode WordMatch festlegen, anhand welchen ein Dateiname in einzelne Wörter gesplittet wird. Der Dateiname "aa_bb_cc" wird beispielsweise durch das festgelegte Trennzeichen "_" in die Wörter "aa","bb" und "cc" zerlegt. Die Standardtrennzeichen sind das Leerzeichen (" "), Komma (","), Unterstrich ("_"), Punkt ("."), Semikolon (";") und Minuszeichen ("-"). Es können beliebig viele Trennzeichen angegeben werden.

Beispiele

Nachfolgend werden Ihnen verschiedene Vergleichsbeispiele zwischen zwei Dateinamen aufgezeigt, um zu verdeutlichen welche Vergleichsmethode für Ihre Suche nach ähnlichen Dateinamen eventuell geeignet ist.
Die Dauer in der rechten Tabellenspalte zeigt den Zeitaufwand für 10.000 Vergleiche zwischen den beiden Dateinamen an.

1. Beispiel

Dateiname A: "Wolfgang Amadeus Mozart"
Dateiname B: "Wolfgang_Amadeus_Mozart"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 88,34% | 0,63s
SmartMatch | 91,30% | 0,75s
Levenshtein | 91,30% | 1,16s
Ratcliff-Obershelp | 82,61% | 1,53s
MatchDiff | 91,30% | 0,09s
WordMatch | 100,00% | 0,33s
FuzzyPercent | 56,58% | 0,33s
Simil | 83,33% | 0,01s

2. Beispiel

Dateiname A: "Wolfgang Amadeus Mozart - 001"
Dateiname B: "Wolfgang Amadeus Mozart - 002"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 96,43% | 1,41s
SmartMatch | 96,55% | 1,09s
Levenshtein | 96,55% | 1,83s
Ratcliff-Obershelp | 96,55% | 0,22s
MatchDiff | 96,55% | 0,07s
WordMatch | 75,00% | 0,50s
FuzzyPercent | 98,06% | 0,54s
Simil | 93,33% | 0,01s

3. Beispiel

Dateiname A: "001 - Wolfgang Amadeus Mozart"
Dateiname B: "002 - Wolfgang Amadeus Mozart"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 96,31% | 1,38s
SmartMatch | 96,55% | 1,00s
Levenshtein | 96,55% | 1,81s
Ratcliff-Obershelp | 96,55% | 0,60s
MatchDiff | 96,55% | 0,07s
WordMatch | 75,00% | 0,42s
FuzzyPercent | 71,84% | 0,49s
Simil | 93,33% | 0,01s

4. Beispiel

Dateiname A: "Wolfgang Amadeus Mozart"
Dateiname B: "Wolfgang Amadeus Mozart - BACKUP"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 70,97% | 1,93s
SmartMatch | 83,64% | 0,83s
Levenshtein | 71,88% | 1,59s
Ratcliff-Obershelp | 83,64% | 0,15s
MatchDiff | 71,88% | 0,05s
WordMatch | 75,00% | 0,39s
FuzzyPercent | 77,95% | 0,91s
Simil | 78,57% | 0,01s

5. Beispiel

Dateiname A: "Wolfgang - Amadeus , Mozart"
Dateiname B: "Mozart_Amadeus;Wolfgang"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 49,29% | 0,42s
SmartMatch | 32,00% | 0,53s
Levenshtein | 37,04% | 1,43s
Ratcliff-Obershelp | 32,00% | 1,88s
MatchDiff | 29,63% | 0,30s
WordMatch | 100,00% | 0,36s
FuzzyPercent | 26,32% | 0,38s
Simil | 23,08% | 0,02s

6. Beispiel

Dateiname A: "Wolfgang Amadeus Mozart"
Dateiname B: "Mozart Wolfgang Amadeus"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 70,55% | 0,65s
SmartMatch | 69,57% | 0,56s
Levenshtein | 39,13% | 1,20s
Ratcliff-Obershelp | 69,57% | 0,40s
MatchDiff | 69,57% | 0,17s
WordMatch | 100,00% | 0,34s
FuzzyPercent | 57,89% | 0,37s
Simil | 0,00% | 0,01s

7. Beispiel

Dateiname A: "Wolfgang Amadeus Mozart"
Dateiname B: "Wulfgang Amadues Mazort"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 88,54% | 0,86s
SmartMatch | 82,61% | 0,66s
Levenshtein | 78,26% | 1,23s
Ratcliff-Obershelp | 73,91% | 1,30s
MatchDiff | 82,61% | 0,26s
WordMatch | 0,00% | 0,33s
FuzzyPercent | 36,84% | 0,33s
Simil | 58,33% | 0,02s

8. Beispiel

Dateiname A: "Wolfgang Amadeus Mozart"
Dateiname B: "Ludwig van Beethoven"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 37,15% | 1,07s
SmartMatch | 32,56% | 0,75s
Levenshtein | 21,74% | 1,13s
Ratcliff-Obershelp | 27,91% | 3,68s
MatchDiff | 21,74% | 0,61s
WordMatch | 0,00% | 0,30s
FuzzyPercent | 5,26% | 0,29s
Simil | 0,00% | 0,01s

9. Beispiel

Datei A: "Beethoven"
Datei B: "nevohteeb"
Vergleichsmethode | Übereinstimmung | Dauer
FuzzyMatch | 72,22% | 0,21s
SmartMatch | 22,22% | 0,14s
Levenshtein | 33,33% | 0,25s
Ratcliff | 22,22% | 0,34s
MatchDiff | 22,22% | 0,14s
WordMatch | 0,00% | 0,15s
FuzzyPercent | 8,70% | 0,12s
Simil | 0,00% | 0,01s


Finde ähnliche Bilder

Mit dieser Suchmethode haben Sie die Möglichkeit ähnliche oder identische Bilder zu finden. Es wird hierbei von jedem Bild eine Prüfsumme erstellt welche dann für den Vergleich mit den anderen Bildern verwendet wird.
  • Vergleichsmethode
  • Hinweise
  • Bildformate
  • Übereinstimmung
  • Bildbereich
  • Vergleichsgröße
  • Prüfsumme
  • Vergleiche nur Bilder mit den gleichen Eigenschaften
  • Bildveränderungen erkennen (langsamer)
  • Test der Erkennungsrate
  • Beispiele

Vergleichsmethode

Mit den Vergleichsmethoden aHash, bHash, dHash, mHash und pHash können ähnliche oder identische Bilder gefunden werden. Wenn Sie nach exakt gleichen Bildern suchen möchten, dann müssen Sie die Vergleichsmethoden MD5 oder SHA verwenden. Eine Übersicht zu der Erkennungsrate der Vergleichsmethoden aHash, bHash, dHash, mHash und pHash erhalten Sie hier.
  • aHash
    Mit der Vergleichsmethode aHash (Average Hash) wird das Bild zuerst auf eine Größe von 8x8 oder 16x16 Pixel herunterskaliert. Das Bild wird dann in Graustufen umgewandelt und der durchschnittliche Farbwert von allen Bildpixeln berechnet. Danach wird die Prüfsumme erstellt, indem alle Bildpixel mit dem durchschnittlichen Farbwert verglichen werden.
  • bHash
    Mit der Vergleichsmethode bHash (Blockhash) wird das Bild auf eine Größe von 128x128, 256x256 oder 512x512 Pixel umgerechnet. Das Bild wird dann in eine Blockmatrix unterteilt und von jedem Block die Farbwerte aller Pixel zusammenaddiert. Danach wird der Mittelwert von allen Blöcken berechnet und die Prüfsumme erstellt. Mit den Optionen "Schnell" und "Präzise" können Sie die Genauigkeit der Berechnung beeinflussen.
  • dHash
    Mit der Vergleichsmethode dHash (Difference Hash) wird das Bild auf eine Größe von 8x8 oder 16x16 Pixel herunterskaliert. Danach wird das Bild in Graustufen umgewandelt und die Prüfsumme erstellt, indem der Unterschied der Helligkeitswerte zwischen allen benachbarten Pixeln vergleichen wird.
  • mHash
    Mit der Vergleichsmethode mHash (Median Hash) wird das Bild auf eine Größe von 8x8 oder 16x16 Pixel herunterskaliert. Das Bild wird dann in Graustufen umgewandelt und von allen Bildpixeln der mittlere Farbwert ermittelt. Danach wird die Prüfsumme berechnet, indem alle Bildpixel mit dem mittleren Farbwert verglichen werden.
  • pHash
    Mit der Vergleichsmethode pHash (Perceptual Hash) wird das Bild auf eine Größe von 32x32 Pixel herunterskaliert. Das Bild wird dann in Graustufen umgewandelt und anhand einer diskreten Cosinus-Transformation (DCT) umgewandelt. Als nächstes wird der mittlere Farbwert von allen Pixeln in einem Bildbereich (8x8) oben links im Bild ermittelt. Danach wird die Prüfsumme berechnet, indem der Farbwert von allen Pixeln aus dem Bildbereich mit dem mittleren Farbwert verglichen werden.
  • MD5, SHA
    Mit diesen Vergleichsmethoden können nur exakt gleiche Bilder gefunden werden. Folgende Prüfsummen stehen zur Auswahl:
    • MD5 (128-Bit)
    • SHA-1 (160-Bit)
    • SHA-2 (256-Bit)
    • SHA-2 (384-Bit)
    • SHA-2 (512-Bit)
Mehr Informationen zu den Vergleichsmethoden aHash, bHash, dHash, mHash und pHash erhalten Sie in den englischsprachigen Artikeln Testing different image hash functions und Detection of Duplicate Images Using Image Hash Functions.

Berechnungszeit der Prüfsummen
Wir haben mit den Vergleichsmethoden aHash, bHash, dHash, mHash und pHash den Zeitaufwand für die Erstellung einer Prüfsumme berechnet und in der folgenden Tabelle aufgelistet:
Vergleichsmethode | Vergleichsgröße | Prüfsumme | Zeitaufwand
aHash | 8x8 | 64-bit | 0,0450 ms
aHash | 16x16 | 256-bit | 0,1425 ms
bHash (Schnell) | 256x256 | 256-bit | 9,6030 ms
bHash (Präzise) | 256x256 | 256-bit | 28,4792 ms
dHash | 8x8 | 64-bit | 0,0458 ms
dHash | 16x16 | 256-bit | 0,0988 ms
mHash | 8x8 | 64-bit | 0,1435 ms
mHash | 16x16 | 256-bit | 1,1012 ms
pHash | 32x32 | 64-bit | 8,6922 ms

Hinweise

Folgende Dateien werden automatisch bei der Suche ausgeschlossen:
  • Datei mit einer Größe von 0 Bytes
  • Bilder mit einer Höhe oder Breite kleiner als die festgelegte Vergleichsgröße
  • Korrupte, ungültige oder unvollständige Bilddateien, welche nicht geladen werden können (*)
  • Bilddateien bei welchen der Lesezugriff blockiert ist (*)
(*) Hierbei wird eine Fehlermeldung im Protokoll ausgegeben.

Bildformate

Hier können Sie festlegen, welche Bildformate bei Suche überprüft werden sollen. Bilddateien mit den folgenden Dateiendungen werden unterstützt: 3FR, ARW, BMP, CR2, CRW, CUT, DCR, DIB, DNG, EMF, ERF, GIF, HDP, ICO, IFF, J2C, J2K, JP2, JPE, JPG, JPEG, JPX, JFIF, KDC, MDC, MEF, MOS, MRW, NEF, ORF, PEF, PBM, PCX, PGM, PNG, PPM, PSD, RAF, RAS, RAW, RW2, SRW, TGA, TIF, TIFF, RAS, RLE, WBMP, WEBP, WMF und X3F.

Übereinstimmung

Hier können Sie festlegen ab welchem Prozentwert zwei Bilder als gleich eingestuft werden. Der ermittelte Prozentwert zwischen zwei Bildern wird im Suchergebnis in der Spalte Übereinstimmung angezeigt. Der Prozentwert bezieht sich immer auf den Vergleich mit dem Referenzbild einer Gruppe, welches mit einer anderen Textfarbe angezeigt wird.

Bildbereich

Mit dieser Option können Sie festlegen, von welchem Bildbereich eine Prüfsumme erstellt werden soll. Folgende Optionen stehen zur Auswahl:
  1. komplettes Bild
  2. Bildbereich oben links
  3. Bildbereich oben rechts
  4. Bildbereich unten links
  5. Bildbereich unten rechts
Bei den Optionen 2, 3, 4 oder 5 können Sie zusätzlich die Größe des Bildbereichs in Pixel festlegen. Wenn Sie beispielsweise 16 Pixel festlegen, dann wird ein Bildbereich von 16x16 Pixel zum Erstellen der Prüfsumme verwendet.

Vergleichsgröße

Hiermit wird festgelegt auf welche Breite und Höhe das Bild umgerechnet werden soll bevor davon eine Prüfsumme erstellt wird. Eine kleinere Bildfläche reduziert hierbei den Zeitaufwand für die Berechnung der Prüfsumme hat aber auch den Nachteil dass mehr falsch-positive Duplikate gefunden werden können. Je größer die Bildfläche ist desto mehr Informationen stehen zur Verfügung, was dann eine genauere Trefferquote bei gleichen Bildern ergibt, aber wiederum den Zeitaufwand für die Berechnung der Prüfsumme erhöht. Eine Vergleichsgröße von 100% bedeutet dass von dem Bild in seiner Originalgröße eine Prüfsumme erstellt wird.

Prüfsumme

Hier wird die Größe der Prüfsumme in Bits angezeigt. Die Prüfsumme kann nur bei Verwendung der Vergleichsmethode bHash geändert werden.

Vergleiche nur Bilder mit den gleichen Eigenschaften

Diese Optionen werden vor der Option Bildveränderungen erkennen angewendet.
  • Dateiname
    Mit dieser Option werden nur Bilder mit dem gleichen Namen verglichen.
  • Dateiendung
    Mit dieser Option werden nur Bilder mit der gleichen Endung verglichen.
  • Höhe und Breite
    Mit dieser Option werden nur Bilder mit der exakt gleichen Breite und Höhe verglichen.
  • Bildausrichtung
    Mit dieser Option werden nur Bilder verglichen welche beide im Hochformat oder Querformat vorliegen.
  • Seitenverhältnis
    Mit dieser Option werden nur Bilder mit dem gleichen Seitenverhältnis verglichen. Die Berechnung des Seitenverhältnisses erfolgt durch die Formel "Breite geteilt durch Höhe". Bei dem Ergebnis werden dann alle bis auf eine Nachkommastelle entfernt. Eine Bildgröße von 1920x1080 ergibt somit ein Seitenverhältnis von "1,7".

Bildveränderungen erkennen (langsamer)

Mit dieser Option können verschiedene Bildveränderungen beim Vergleich zwischen zwei Bildern erkannt werden. Hierfür wird jede aktivierte Bildveränderung mit dem zu vergleichenden Bild durchgeführt und davon jeweils eine weitere Prüfsumme erstellt. Folgende Bildveränderungen können überprüft werden:
  • 90° nach rechts gedreht
  • 180° nach rechts gedreht
  • 90° nach links gedreht
  • Horizontal gespiegelt
  • 90° nach rechts gedreht und horizontal gespiegelt
  • Vertikal gespiegelt
  • 90° nach links gedreht und horizontal gespiegelt

Test der Erkennungsrate

Wir haben einen Test mit verschiedenen Vergleichsmethoden durchgeführt um die Erkennungsrate bei unterschiedlichen Bildveränderungen zu ermitteln. Hierfür wurden 29 Bildkopien von einem JPEG-Bild (1600x1200px, 606KB) erstellt und diese in Farbe, Größe und Format geändert. Bei dem Test wurden immer das original JPEG-Bild und eine geänderte Bildkopie verglichen.

Folgende Vergleichsmethoden wurden bei dem Test verwendet:
Vergleichsmethode | Vergleichsgröße | Prüfsumme
aHash¹ | 8x8 | 64-bit
aHash² | 16x16 | 256-bit
bHash¹ (Schnell) | 256x256 | 256-bit
bHash² (Präzise) | 256x256 | 256-bit
dHash | 16x16 | 256-bit
mHash | 16x16 | 256-bit
pHash | 32x32 | 64-bit

Die Prozentwerte in der folgenden Tabelle zeigen auf wie gut eine Vergleichsmethode die Veränderung der Bildkopie erkennt:
Änderung | aHash¹ | aHash² | bHash¹ | bHash² | dHash | mHash | pHash
Bild verkleinert auf 75% | 100% | 100% | 100% | 100% | 100% | 100% | 97%
Bild verkleinert auf 50% | 100% | 100% | 100% | 100% | 99% | 100% | 100%
Bild verkleinert auf 25% | 100% | 100% | 100% | 100% | 99% | 100% | 97%
Bild vergrößert auf 150% | 100% | 100% | 100% | 100% | 100% | 100% | 100%
Bild vergrößert auf 200% | 100% | 100% | 100% | 100% | 100% | 100% | 100%
Bild in Graustufen umgewandelt | 97% | 98% | 97% | 93% | 97% | 96% | 97%
Helligkeit um 30% erhöht | 95% | 99% | 100% | 99% | 98% | 97% | 91%
Helligkeit um 30% verringert | 95% | 95% | 89% | 93% | 92% | 94% | 91%
Kontrast um 30% erhöht | 100% | 99% | 95% | 96% | 96% | 96% | 94%
Kontrast um 30% verringert | 100% | 99% | 100% | 100% | 98% | 100% | 94%
JPEG-Qualität um 25% reduziert | 100% | 100% | 100% | 100% | 100% | 100% | 100%
JPEG-Qualität um 50% reduziert | 100% | 100% | 100% | 100% | 99% | 100% | 100%
JPEG-Qualität um 75% reduziert | 100% | 100% | 100% | 100% | 99% | 100% | 94%
Bild um 90° nach links gedreht | 47% | 52% | 68% | 54% | 46% | 50% | 47%
Bild um 90° nach rechts gedreht | 47% | 52% | 54% | 55% | 48% | 50% | 44%
Bild vertikal gespiegelt | 81% | 81% | 77% | 73% | 71% | 80% | 50%
Bild horizontal gespiegelt | 69% | 59% | 62% | 64% | 54% | 61% | 47%
Weißer Rahmen hinzugefügt (30px) | 84% | 82% | 68% | 61% | 86% | 82% | 88%
Schwarzer Rahmen hinzugefügt (30px) | 94% | 94% | 92% | 89% | 92% | 92% | 88%
Bildhöhe auf 80% reduziert | 100% | 100% | 100% | 100% | 100% | 100% | 100%
Bildbreite auf 80% reduziert | 100% | 100% | 100% | 100% | 99% | 100% | 100%
Umwandlung in PNG 24bit | 100% | 100% | 100% | 100% | 100% | 100% | 100%
Umwandlung in BMP 24bit | 100% | 100% | 100% | 100% | 100% | 100% | 100%
Umwandlung in GIF 256 Farben | 100% | 100% | 100% | 99% | 99% | 100% | 97%
100 Pixel vom linken Bildrand entfernt | 92% | 91% | 88% | 71% | 82% | 92% | 78%
100 Pixel vom rechten Bildrand entfernt | 97% | 92% | 86% | 86% | 85% | 90% | 91%
100 Pixel vom oberen Bildrand entfernt | 94% | 88% | 86% | 83% | 86% | 89% | 84%
100 Pixel vom unteren Bildrand entfernt | 98% | 91% | 87% | 86% | 86% | 91% | 84%
100 Pixel Bildrand entfernt | 89% | 80% | 77% | 75% | 70% | 80% | 62%

In der folgenden Tabelle erhalten Sie eine Übersicht wieviele Duplikate mit den verschiedenen Vergleichsmethoden bei dem Test gefunden wurden. Die Auswertung wurde mit einer Übereinstimmung von mindestens 70%, 80% und 90% durchgeführt.
Vergleichsmethode | 70% | 80% | 90%
aHash¹ (64-bit) | 26 | 26 | 23
aHash² (256-bit) | 26 | 26 | 22
bHash¹ (Schnell) | 25 | 23 | 18
bHash² (Präzise) | 25 | 22 | 18
dHash (256-bit) | 26 | 24 | 19
mHash (256-bit) | 26 | 26 | 22
pHash (64-bit) | 26 | 24 | 19

Beispiele

Die dargestellten Suchergebnisse wurden mit den folgenden Einstellungen erstellt:
  • Vergleichsmethode: aHash
  • Vergleichsgröße: 16x16
  • Prüfsumme: 256-bit
Alle verwendeten Bilder stammen aus der Bildersammlung Caltech101.

Verschiedene Aufnahmen der gleichen Person
similar pictures similar pictures

Aufnahmen von unterschiedlichen Motorrädern
similar pictures

Das gleiche Objekt in unterschiedlicher Pose
similar pictures

Unterschiedliche Teilaufnahme des gleichen Motivs
similar pictures

Falsch-positive Duplikate
false-positive duplicate pictures


Finde Ähnliche Musik

Mit dieser Suchmethode haben Sie die Möglichkeit Ähnliche oder identische Musikdateien zu finden, welche in den Audioformaten MP3, FLAC, WMA, WAV, OGG, APE, AAC, MKA, M4A, M4R und MP2 vorliegen. Hierbei wird von jeder Musikdatei die Tonspur analysiert und davon eine Prüfsumme erstellt welche dann für den Vergleich mit weiteren Musikdateien verwendet wird.

Folgende Dateien werden automatisch von der Suche ausgeschlossen:
  • Dateien ohne die Endung MP3, FLAC, WMA, WAV, OGG, APE, AAC, AIF, AIFF, MKA, M4A, M4R und MP2
  • Datei mit einer Größe von 0 Bytes
  • Korrupte, ungültige oder unvollständige Musikdateien (*)
  • Musikdateien bei welchen der Lesezugriff blockiert ist (*)
(*) Hierbei wird eine Fehlermeldung im Protokoll ausgegeben.

Messdauer

Hiermit wird festgelegt wie viele Sekunden am Anfang einer Musikdatei verwendet werden um die Prüfsumme zu berechnen. Für die Messdauer kann ein Wert zwischen 15 und 999 Sekunden festgelegt werden. Der Standardwert für die Messdauer ist 30 Sekunden.

Übereinstimmung

Hier können Sie festlegen ab welchem Prozentwert zwei Musikdateien als gleich eingestuft werden. Der ermittelte Prozentwert zwischen zwei Musikdateien wird im Suchergebnis in der Spalte Übereinstimmung angezeigt. Der Prozentwert bezieht sich immer auf den Vergleich mit der Referenzdatei einer Gruppe, welche mit einer anderen Textfarbe angezeigt wird.

Vergleichsmethode

Mit dieser Option wird festgelegt mit welcher Methode die Prüfsumme erstellt wird. Der Standardwert für diese Option ist 4.
  • 1 - Keine Informationen verfügbar
  • 2 - Keine Informationen verfügbar
  • 4 - Ignoriert vorhandene Stille am Anfang einer Audiodatei
  • 5 - Keine Informationen verfügbar

Vergleiche nur Dateien mit der gleichen Dateiendung

Mit dieser Option werden nur Musikdateien mit der gleichen Dateiendung verglichen.

Erkennungsrate

Wir haben verschiedene Vergleichstests durchgeführt um die Erkennungsrate für Ähnliche oder identische Musikdateien unter Verwendung von verschiedenen Einstellungen zu ermitteln. Hierfür wurde eine WAV-Datei (1411 kBits/s 16bit 44100kHz Stereo) in verschiedene andere Audioformate konvertiert. Die Audiodateien wurden alle mit Stereo-Ton konvertiert wenn nicht explizit Mono angegeben ist. Anhand den Prozentwerten in der Tabelle wird Ihnen aufgezeigt welche Einstellungen am besten dafür geeignet sind, bei einem bestimmten Audioformat ein Duplikat zu erkennen. Bei der Spalte mit den meisten höchsten Prozentwerten wurde der Text im Spaltenkopf in Klammern gesetzt.

Test 'Vergleichsmethoden'

Bei diesem Test wurden alle Dateien 4x mit einer Basisdatei verglichen wobei jedes Mal eine andere Vergleichsmethode (1, 2, 4 und 5) verwendet wurde. Die Messdauer war bei diesem Test auf den Standardwert von 30 Sekunden eingestellt.

Basisdatei: WAV 16bit 44100kHz
 | Dateigröße | 1 | 2 | [4] | 5
AAC 128kbps 44100kHz | 2,42 MB | 79% | 79% | 77% | 75%
AAC 192kbps 48000kHz | 3,12 MB | 82% | 81% | 78% | 74%
AAC 256kbps 48000kHz | 3,12 MB | 82% | 81% | 78% | 74%
AAC 48000kHz 32bit | 2,46 MB | 74% | 77% | 83% | 58%
AAC 64kbps 22050kHz mono | 0,72 MB | 73% | 72% | 73% | 68%
AAC 96kbps 22050kHz | 1,43 MB | 76% | 74% | 74% | 70%
APE 48000kHz 16bit | 15,84 MB | 87% | 86% | 92% | 71%
FLAC 22050kHz 16bit mono | 5,14 MB | 100% | 100% | 100% | 100%
FLAC 44100kHz 16bit | 16,93 MB | 100% | 100% | 100% | 100%
FLAC 48000kHz 16bit | 17,38 MB | 100% | 100% | 100% | 100%
M4A 128kbps 44100kHz | 2,42 MB | 79% | 79% | 77% | 75%
M4A 192kbps 48000kHz | 3,12 MB | 82% | 81% | 78% | 74%
M4A 256kbps 48000kHz | 3,12 MB | 82% | 81% | 78% | 74%
M4A 64kbps 22050kHz mono | 0,72 MB | 73% | 72% | 73% | 68%
M4A 96kbps 22050kHz | 1,43 MB | 76% | 74% | 74% | 70%
M4R 160kbps 44100kHz | 0,76 MB | 94% | 95% | 90% | 95%
M4R 256kbps 44100kHz | 1,21 MB | 95% | 96% | 96% | 97%
MKA 48000kHz 32bit | 4,72 MB | 82% | 80% | 83% | 68%
MP2 128kbps 44100kHz | 2,40 MB | 84% | 86% | 94% | 69%
MP2 160kbps 44100kHz | 3,00 MB | 84% | 86% | 96% | 69%
MP2 256kbps 44100kHz | 4,79 MB | 84% | 86% | 99% | 70%
MP2 64kbps 22050kHz mono | 1,20 MB | 76% | 76% | 99% | 58%
MP3 128kbps 44100kHz | 2,40 MB | 91% | 91% | 92% | 87%
MP3 192kbps 48000kHz | 3,59 MB | 96% | 95% | 96% | 96%
MP3 256kbps 48000kHz | 4,79 MB | 98% | 99% | 98% | 97%
MP3 320kbps 48000kHz | 5,99 MB | 99% | 99% | 100% | 98%
MP3 96kbps 22050kHz mono | 1,80 MB | 97% | 95% | 97% | 95%
MP3 VBR0 44100kHz | 4,24 MB | 66% | 67% | 96% | 54%
MP3 VBR1 44100kHz | 3,88 MB | 67% | 67% | 97% | 54%
MP3 VBR5 44100kHz | 2,68 MB | 65% | 66% | 90% | 53%
MP3 VBR9 44100kHz | 2,40 MB | 66% | 67% | 96% | 54%
OGG 128kbps 44100kHz | 2,17 MB | 93% | 90% | 90% | 87%
OGG 160kbps 44100kHz | 2,17 MB | 93% | 90% | 90% | 87%
OGG 240kbps 48000kHz | 3,31 MB | 96% | 94% | 95% | 94%
OGG 320kbps 48000kHz | 4,48 MB | 97% | 96% | 98% | 96%
OGG 64kbps 22050kHz mono | 1,19 MB | 94% | 93% | 93% | 93%
WAV 8bit 22050kHz mono | 3,30 MB | 99% | 100% | 93% | 98%
WMA 128kbps 44100kHz | 2,43 MB | 53% | 54% | 93% | 49%
WMA 192kbps 48000kHz | 3,64 MB | 54% | 55% | 93% | 50%
WMA 256kbps 48000kHz | 4,85 MB | 98% | 97% | 97% | 97%
WMA 384kbps 48000kHz | 4,85 MB | 98% | 97% | 97% | 97%
WMA 96kbps 22050kHz mono | 0,39 MB | 54% | 54% | 73% | 49%

Basisdatei: MP3 192kbps 48000kHz
 | Dateigröße | [1] | 2 | 4 | 5
AAC 128kbps 44100kHz | 2,42 MB | 79% | 77% | 76% | 75%
AAC 192kbps 48000kHz | 3,12 MB | 81% | 80% | 78% | 75%
AAC 256kbps 48000kHz | 3,12 MB | 81% | 80% | 78% | 75%
AAC 48000kHz 32bit | 2,46 MB | 74% | 76% | 82% | 57%
AAC 64kbps 22050kHz mono | 0,72 MB | 74% | 72% | 73% | 67%
AAC 96kbps 22050kHz | 1,43 MB | 75% | 75% | 74% | 69%
APE 48000kHz 16bit | 15,84 MB | 86% | 85% | 91% | 71%
FLAC 22050kHz 16bit mono | 5,14 MB | 96% | 95% | 96% | 96%
FLAC 44100kHz 16bit | 16,93 MB | 96% | 95% | 96% | 96%
FLAC 48000kHz 16bit | 17,38 MB | 96% | 95% | 96% | 96%
M4A 128kbps 44100kHz | 2,42 MB | 79% | 77% | 76% | 75%
M4A 192kbps 48000kHz | 3,12 MB | 81% | 80% | 78% | 75%
M4A 256kbps 48000kHz | 3,12 MB | 81% | 80% | 78% | 75%
M4A 64kbps 22050kHz mono | 0,72 MB | 74% | 72% | 73% | 67%
M4A 96kbps 22050kHz | 1,43 MB | 75% | 75% | 74% | 69%
M4R 160kbps 44100kHz | 0,76 MB | 93% | 94% | 89% | 94%
M4R 256kbps 44100kHz | 1,21 MB | 94% | 93% | 93% | 94%
MKA 48000kHz 32bit | 4,72 MB | 80% | 81% | 82% | 68%
MP2 128kbps 44100kHz | 2,40 MB | 83% | 86% | 93% | 69%
MP2 160kbps 44100kHz | 3,00 MB | 84% | 85% | 94% | 69%
MP2 256kbps 44100kHz | 4,79 MB | 84% | 85% | 96% | 69%
MP2 64kbps 22050kHz mono | 1,20 MB | 76% | 76% | 96% | 57%
MP3 128kbps 44100kHz | 2,40 MB | 91% | 90% | 89% | 86%
MP3 256kbps 48000kHz | 4,79 MB | 97% | 96% | 96% | 95%
MP3 320kbps 48000kHz | 5,99 MB | 96% | 96% | 96% | 95%
MP3 96kbps 22050kHz mono | 1,80 MB | 95% | 94% | 95% | 93%
MP3 VBR0 44100kHz | 4,24 MB | 66% | 67% | 93% | 54%
MP3 VBR1 44100kHz | 3,88 MB | 67% | 66% | 94% | 54%
MP3 VBR5 44100kHz | 2,68 MB | 65% | 66% | 90% | 53%
MP3 VBR9 44100kHz | 2,40 MB | 66% | 67% | 94% | 54%
OGG 128kbps 44100kHz | 2,17 MB | 91% | 90% | 89% | 87%
OGG 160kbps 44100kHz | 2,17 MB | 91% | 90% | 89% | 87%
OGG 240kbps 48000kHz | 3,31 MB | 94% | 92% | 93% | 91%
OGG 320kbps 48000kHz | 4,48 MB | 95% | 94% | 94% | 94%
OGG 64kbps 22050kHz mono | 1,19 MB | 93% | 92% | 91% | 93%
WAV 16bit 44100kHz | 26,41 MB | 96% | 95% | 96% | 96%
WAV 8bit 22050kHz mono | 3,30 MB | 96% | 96% | 90% | 96%
WMA 128kbps 44100kHz | 2,43 MB | 54% | 54% | 92% | 49%
WMA 192kbps 48000kHz | 3,64 MB | 54% | 55% | 92% | 50%
WMA 256kbps 48000kHz | 4,85 MB | 95% | 96% | 96% | 94%
WMA 384kbps 48000kHz | 4,85 MB | 95% | 96% | 96% | 94%
WMA 96kbps 22050kHz mono | 0,39 MB | 54% | 54% | 74% | 49%

Basisdatei: MP3 VBR0 44100kHz
 | Dateigröße | 1 | 2 | [4] | 5
AAC 128kbps 44100kHz | 2,42 MB | 66% | 64% | 77% | 52%
AAC 192kbps 48000kHz | 3,12 MB | 65% | 66% | 77% | 52%
AAC 256kbps 48000kHz | 3,12 MB | 65% | 66% | 77% | 52%
AAC 48000kHz 32bit | 2,46 MB | 78% | 77% | 84% | 63%
AAC 64kbps 22050kHz mono | 0,72 MB | 62% | 62% | 73% | 51%
AAC 96kbps 22050kHz | 1,43 MB | 62% | 62% | 75% | 52%
APE 48000kHz 16bit | 15,84 MB | 63% | 62% | 91% | 52%
FLAC 22050kHz 16bit mono | 5,14 MB | 66% | 67% | 96% | 54%
FLAC 44100kHz 16bit | 16,93 MB | 66% | 67% | 96% | 54%
FLAC 48000kHz 16bit | 17,38 MB | 66% | 67% | 96% | 54%
M4A 128kbps 44100kHz | 2,42 MB | 66% | 64% | 77% | 52%
M4A 192kbps 48000kHz | 3,12 MB | 65% | 66% | 77% | 52%
M4A 256kbps 48000kHz | 3,12 MB | 65% | 66% | 77% | 52%
M4A 64kbps 22050kHz mono | 0,72 MB | 62% | 62% | 73% | 51%
M4A 96kbps 22050kHz | 1,43 MB | 62% | 62% | 75% | 52%
M4R 160kbps 44100kHz | 0,76 MB | 66% | 68% | 91% | 54%
M4R 256kbps 44100kHz | 1,21 MB | 66% | 68% | 95% | 54%
MKA 48000kHz 32bit | 4,72 MB | 62% | 63% | 82% | 51%
MP2 128kbps 44100kHz | 2,40 MB | 72% | 73% | 92% | 57%
MP2 160kbps 44100kHz | 3,00 MB | 72% | 73% | 94% | 57%
MP2 256kbps 44100kHz | 4,79 MB | 73% | 74% | 96% | 57%
MP2 64kbps 22050kHz mono | 1,20 MB | 79% | 81% | 96% | 63%
MP3 128kbps 44100kHz | 2,40 MB | 66% | 66% | 90% | 54%
MP3 192kbps 48000kHz | 3,59 MB | 66% | 67% | 93% | 54%
MP3 256kbps 48000kHz | 4,79 MB | 66% | 68% | 95% | 54%
MP3 320kbps 48000kHz | 5,99 MB | 66% | 68% | 96% | 54%
MP3 96kbps 22050kHz mono | 1,80 MB | 66% | 67% | 94% | 54%
MP3 VBR1 44100kHz | 3,88 MB | 95% | 96% | 96% | 93%
MP3 VBR5 44100kHz | 2,68 MB | 91% | 92% | 92% | 86%
MP3 VBR9 44100kHz | 2,40 MB | 94% | 95% | 95% | 94%
OGG 128kbps 44100kHz | 2,17 MB | 65% | 67% | 90% | 53%
OGG 160kbps 44100kHz | 2,17 MB | 65% | 67% | 90% | 53%
OGG 240kbps 48000kHz | 3,31 MB | 66% | 67% | 93% | 53%
OGG 320kbps 48000kHz | 4,48 MB | 67% | 68% | 96% | 54%
OGG 64kbps 22050kHz mono | 1,19 MB | 66% | 67% | 92% | 53%
WAV 16bit 44100kHz | 26,41 MB | 66% | 67% | 96% | 54%
WAV 8bit 22050kHz mono | 3,30 MB | 66% | 68% | 93% | 54%
WMA 128kbps 44100kHz | 2,43 MB | 59% | 64% | 91% | 51%
WMA 192kbps 48000kHz | 3,64 MB | 62% | 66% | 90% | 52%
WMA 256kbps 48000kHz | 4,85 MB | 66% | 67% | 95% | 54%
WMA 384kbps 48000kHz | 4,85 MB | 66% | 67% | 95% | 54%
WMA 96kbps 22050kHz mono | 0,39 MB | 58% | 61% | 75% | 51%

Vergleichstest 'Messdauer'

Bei diesem Test wurden alle Dateien 4x mit einer Basisdatei verglichen wobei jedes Mal eine andere Messdauer (10, 30, 60 und 90 Sekunden) verwendet wurde. Die Vergleichsmethode war bei diesem Test auf 4 eingestellt.

Basisdatei: MP3 192kbps 48000kHz
 | Dateigröße | [10s] | 30s | 60s | 90s
AAC 128kbps 44100kHz | 2,42 MB | 78% | 76% | 76% | 76%
AAC 192kbps 48000kHz | 3,12 MB | 77% | 78% | 76% | 76%
AAC 256kbps 48000kHz | 3,12 MB | 77% | 78% | 76% | 76%
AAC 48000kHz 32bit | 2,46 MB | 82% | 82% | 82% | 82%
AAC 64kbps 22050kHz mono | 0,72 MB | 76% | 73% | 71% | 71%
AAC 96kbps 22050kHz | 1,43 MB | 74% | 74% | 72% | 72%
APE 48000kHz 16bit | 15,84 MB | 92% | 91% | 90% | 90%
FLAC 22050kHz 16bit mono | 5,14 MB | 96% | 96% | 96% | 96%
FLAC 44100kHz 16bit | 16,93 MB | 96% | 96% | 96% | 96%
FLAC 48000kHz 16bit | 17,38 MB | 96% | 96% | 96% | 96%
M4A 128kbps 44100kHz | 2,42 MB | 78% | 76% | 76% | 76%
M4A 192kbps 48000kHz | 3,12 MB | 77% | 78% | 76% | 76%
M4A 256kbps 48000kHz | 3,12 MB | 77% | 78% | 76% | 76%
M4A 64kbps 22050kHz mono | 0,72 MB | 76% | 73% | 71% | 71%
M4A 96kbps 22050kHz | 1,43 MB | 74% | 74% | 72% | 72%
M4R 160kbps 44100kHz | 0,76 MB | 89% | 89% | 88% | 88%
M4R 256kbps 44100kHz | 1,21 MB | 95% | 93% | 94% | 94%
MKA 48000kHz 32bit | 4,72 MB | 86% | 82% | 81% | 81%
MP2 128kbps 44100kHz | 2,40 MB | 94% | 93% | 93% | 93%
MP2 160kbps 44100kHz | 3,00 MB | 94% | 94% | 94% | 94%
MP2 256kbps 44100kHz | 4,79 MB | 95% | 96% | 96% | 96%
MP2 64kbps 22050kHz mono | 1,20 MB | 96% | 96% | 96% | 96%
MP3 128kbps 44100kHz | 2,40 MB | 91% | 89% | 89% | 89%
MP3 256kbps 48000kHz | 4,79 MB | 96% | 96% | 95% | 95%
MP3 320kbps 48000kHz | 5,99 MB | 97% | 96% | 96% | 96%
MP3 96kbps 22050kHz mono | 1,80 MB | 96% | 95% | 95% | 95%
MP3 VBR0 44100kHz | 4,24 MB | 92% | 93% | 94% | 94%
MP3 VBR1 44100kHz | 3,88 MB | 93% | 94% | 93% | 93%
MP3 VBR5 44100kHz | 2,68 MB | 87% | 90% | 91% | 91%
MP3 VBR9 44100kHz | 2,40 MB | 93% | 94% | 93% | 93%
OGG 128kbps 44100kHz | 2,17 MB | 83% | 89% | 89% | 89%
OGG 160kbps 44100kHz | 2,17 MB | 83% | 89% | 89% | 89%
OGG 240kbps 48000kHz | 3,31 MB | 94% | 93% | 94% | 94%
OGG 320kbps 48000kHz | 4,48 MB | 91% | 94% | 94% | 94%
OGG 64kbps 22050kHz mono | 1,19 MB | 87% | 91% | 92% | 92%
WAV 16bit 44100kHz | 26,41 MB | 96% | 96% | 96% | 96%
WAV 8bit 22050kHz mono | 3,30 MB | 91% | 90% | 91% | 91%
WMA 128kbps 44100kHz | 2,43 MB | 93% | 92% | 92% | 92%
WMA 192kbps 48000kHz | 3,64 MB | 93% | 92% | 92% | 92%
WMA 256kbps 48000kHz | 4,85 MB | 96% | 96% | 96% | 96%
WMA 384kbps 48000kHz | 4,85 MB | 96% | 96% | 96% | 96%
WMA 96kbps 22050kHz mono | 0,39 MB | 78% | 74% | 72% | 72%


Suchoptionen

Vor der Suche

Verwendung der Datei- und Ordnerfilter bestätigen
Mit dieser Option muss vor dem Suchvorgang die Verwendung der Datei- und Ordnerfilter bestätigt werden.

CPU-Priorität von AllDup auf Niedrig setzen
Mit dieser Option wird die CPU-priorität von AllDup während des Suchvorgangs auf Niedrig gesetzt.

Während der Suche

Dateibesitzer ermitteln (langsamer)
Mit dieser Option wird der Besitzer von jeder Datei während der Suche ermittelt und im Suchergebnis angezeigt. Wenn Sie diese Option nicht aktivieren, dann können Sie später im Suchergebnis durch Anklicken einer Datei oder durch eine Mausbewegung über die Spalte Besitzer den Dateibesitzer ermitteln und anzeigen lassen.

Anzahl der Hardlinks pro Datei ermitteln (langsamer)
Mit dieser Option wird die Anzahl der Hardlinks einer Datei während der Suche ermittelt und im Suchergebnis angezeigt. Wenn Sie diese Option nicht aktivieren, dann können Sie später im Suchergebnis durch Anklicken einer Datei oder durch eine Mausbewegung über die Spalte 'Hardlinks' die Anzahl der Hardlinks ermitteln und anzeigen lassen.

Breite und Höhe von Bilddateien ermitteln (langsamer)
Mit dieser Option wird die Breite und Höhe von Bilddateien während der Suche ermittelt und im Suchergebnis angezeigt. Wenn Sie diese Option nicht aktivieren, dann können Sie später im Suchergebnis durch Anklicken einer Datei die Breite und Höhe ermitteln und anzeigen lassen.

Dauer, Bitrate und Samplingrate von Dateien mit den folgenden Endungen ermitteln (langsamer)
Mit dieser Option wird die Dauer, Bitrate und Samplingrate von Audiodateien anhand dem Plug-In 'MediaInfo' ermittelt. Wenn Sie diese Option nicht aktivieren, dann können Sie später im Suchergebnis durch Anklicken einer Datei oder durch eine Mausbewegung über die Spalten 'Dauer', 'Bitrate' und 'Samplingrate' die Informationen ermitteln und anzeigen lassen.

Alle x Minuten die Suchstatistik der Fortschrittsanzeige protokollieren
Mit dieser Option haben Sie die Möglichkeit die angezeigte Suchstatistik der Fortschrittsanzeige für analytische Zwecke zu protokollieren.

Suche abbrechen wenn eine bestimmte Menge an Duplikaten gefunden wurden
Mit dieser Option können Sie festlegen, dass die Suche nach dem Fund einer bestimmten Menge an Duplikaten abgebrochen wird.

Nach der Suche

Alle Gruppen im Suchergebnis aufklappen
Mit dieser Option werden nach Beendigung der Suche alle Gruppen automatisch aufgeklappt.

Alle Gruppen entfernen, bei welchen die Duplikate nicht in allen Quellordnern vorhanden sind
Mit dieser Option werden nach Beendigung der Suche alle Gruppen entfernt, bei welchen die Duplikate nicht in allen Quellordnern vorhanden sind.

Nur Dateien ohne Duplikate im Suchergebnis anzeigen
Mit dieser Option werden nur Dateien ohne Duplikate im Suchergebnis angezeigt.

Dateien ohne Duplikate im Protokoll auflisten (langsamer)
Mit dieser Option werden alle Dateien ohne Duplikate in die Protokolldatei eingetragen.


Archivdateien

Archive mit den folgenden Dateiendungen durchsuchen

Mit dieser Option können Sie den Inhalt von Archivdateien nach Duplikaten durchsuchen. Es können einzelne Archivdateien mit den folgenden Dateiendungen durchsucht werden:
  • .7z
  • .arj
  • .cab
  • .cb7
  • .cbr
  • .cbt
  • .cbz
  • .epub
  • .gz
  • .iso
  • .lzh
  • .lha
  • .nrg
  • .rar
  • .tar
  • .zip

Es können gesplittete Archive mit den folgenden Dateiendungen durchsucht werden:
  • .7z.001
  • .rar (Folgedatei: .r00)
  • .part1.rar
  • .tar.001
  • .zip (Folgedatei: .z01)
  • .zip.001

Hinweise:
  • Passwortgeschützte Dateien in Archiven und passwortgeschützte Archivdateien werden bei Verwendung der Suchmethode Dateiinhalt, Ähnliche Bilder oder Ähnliche Musik automatisch gefiltert
  • Mit dem AllDup Dateimanager können nur Dateien in Archiven mit der Endung .zip und .7z gelöscht werden.

Temporäre Dateien nach dem Erstellen der Prüfsumme löschen

Mit dieser Option werden die temporär entpackten Dateien unmittelbar nach dem Erstellen der Prüfsumme gelöscht. Dies hat den Vorteil dass beim Durchsuchen von vielen Archivdateien weniger Speicherplatz zum entpacken auf der Festplatte benötigt wird.
Diese Option hat nur Auswirkungen unter den folgenden Umständen:
  • Die Suchmethode Ähnliche Bilder wird verwendet und die Option 'Erkenne Bildveränderungen' ist nicht aktiviert
  • Die Suchmethode Dateiinhalt wird verwendet und bei der Vergleichsmethode ist eine Prüfsummenmethode ausgewählt.

Passwortgeschützte Dateien protokollieren

Mit dieser Option werden passwortgeschützte Dateien aus Archiven und passwortgeschützte Archivdateien im Protokoll angezeigt.

Dateien ab der folgenden Größe nicht entpacken

Mit dieser Option können Sie festlegen, dass Dateien ab einer bestimmten Größe nicht aus der Archivdatei entpackt werden sollen. Diese Dateien werden dann bei der Suche nach dem Dateiinhalt nicht berücksichtigt und können auch nicht in der Dateivorschau im Suchergebnis angezeigt werden.


Datenbank

Hiermit können die bei der Suche nach Duplikaten erstellten Prüfsummen in eine Datenbank gespeichert werden. Dies hat den Vorteil dass die zeitintensive Berechnung der Prüfsummen bei weiteren Suchvorgängen mit den gleichen Dateien wegfällt und die Suche dadurch erheblich weniger Zeit benötigt.

Die Speicherung der Prüfsummen kann für folgenden Suchmethoden einzeln aktiviert werden:
  • Dateiinhalt
    Für jede Vergleichsmethode wird jeweils eine eigene Prüfsumme in der Datenbank gespeichert. Bei 5 Vergleichsmethoden können somit pro Datei bis zu 5 unterschiedliche Prüfsummen in der Datenbank gespeichert werden.
  • Ähnliche Bilder
    Für jede Vergleichsmethode und überprüfte Bildveränderung wird jeweils eine eigene Prüfsumme in der Datenbank gespeichert. Bei 9 Vergleichsmethoden und 7 zusätzlichen Überprüfungen auf mögliche Bildveränderungen können somit pro Bild bis zu 72 unterschiedliche Prüfsummen in der Datenbank gespeichert werden.
  • Ähnliche Musik
    Für jede Messdauer und verwendete Vergleichsmethode wird jeweils eine eigene Prüfsumme in der Datenbank gespeichert.
Hinweis: Die Datenbank kann unter Windows XP nicht verwendet werden.

Optionen

Prüfsumme neu berechnen wenn sich die Größe der Datei geändert hat
Hiermit wird die Prüfsumme einer Datei erneut berechnet wenn sich die Größe der Datei geändert hat.

Prüfsumme neu berechnen wenn das Änderungsdatum der Datei geändert wurde
Hiermit wird die Prüfsumme einer Datei erneut berechnet wenn sich das Änderungsdatum der Datei geändert hat.

Datenbank-Werkzeuge

Aufräumen
Hiermit werden alle Dateien in der Datenbank auf Ihre Existenz überprüft und die Prüfsummen von allen nicht vorhandenen Dateien gelöscht. Der Vorgang kann mit der Taste F10 abgebrochen werden.

Zurücksetzen
Hiermit werden alle Prüfsummen in der Datenbank gelöscht.

Neu
Hiermit wird die Datenbankdatei gelöscht und eine neue Datenbankdatei erstellt.


Dateifilter

Mit dem Dateifilter haben Sie die Möglichkeit bestimmte Dateien von einem Suchvorgang auszuschließen. Über die Filterarten Inklusive und Exklusive können Sie festlegen, wie die Filtertexte bei der Suche angewendet werden.

Inklusive

Hiermit werden nur solche Dateien bei der Suche berücksichtigt, welche mit einem aktivierten Filtertext übereinstimmen. Wenn Sie beispielsweise den Filtertext "*.ini" festlegen, dann werden nur Dateien mit der Endung ".ini" berücksichtigt.

Exklusive

Hiermit werden alle Dateien von der Suche ausgeschlossen, die mit einem aktivierten Filtertext übereinstimmen. Wenn Sie beispielsweise den Filtertext "*.ini" festlegen, dann werden alle Dateien mit der Endung ".ini" von der Suche ausgeschlossen.

Filterliste

Die Filterliste beinhaltet alle vorhandenen Filtertexte für Dateien. Jeder Filtertext kann über sein Kontrollkästchen für den Suchvorgang aktiviert werden. Zum Hinzufügen eines neuen Filters klicken Sie in der Symbolleiste auf die Schaltfläche Dateifilter. Ein Rechtsklick auf einen Filter in der Liste öffnet ein Kontextmenü zum Bearbeiten oder Löschen eines Filters.

Filtertexte

Der Vergleich mit dem Filtertext wird immer mit dem Namen einer Datei durchgeführt. Wenn ein Filtertext das Zeichen "\" enthält, dann wird der Vergleich mit dem kompletten Dateipfad durchgeführt. Unter Anwendung von verschiedenen Platzhaltern wie beispielsweise '*' oder '?', haben Sie die Möglichkeit mit einem Filtertext mehrere Dateien zu filtern. Es können auch Umgebungsvariablen von Windows im Filtertext verwendet werden. Sie können bei einem Filtertext mehrere Dateifilter angeben, indem Sie diese mit dem Zeichen '|' trennen.

Beispiele:
  • *.txt
  • temp.*
  • *temp.txt
  • temp??.*
  • temp.00?
  • %USERNAME%.txt
  • *\Temp\*.tmp
  • C:\Temp\*.ini
  • C:\Temp\%Username%.*
  • *.bmp|*.jpg|*.jpeg|*.png

Optionen

Platzhalter im Filter als Text behandeln
Mit dieser Option werden die Zeichen von Platzhaltern in einem Filtertext wie normaler Text behandelt.

Groß- und Kleinschreibung der Filter berücksichtigen
Mit dieser Option wird beim Vergleich eines Dateinamen mit einem Filtertext die Groß- und Kleinschreibung berücksichtigt.

Dateieigenschaften

Dateien mit 0 Byte ignorieren
Mit dieser Option werden alle Dateien mit einer Größe von 0 Bytes von der Suche ausgeschlossen.

Dateien anhand Ihrer Größe ausschließen
Mit dieser Option können Sie Dateien anhand Ihrer Größe von der Suche ausschließen.

Dateien anhand Ihrem Datum ausschließen
Mit dieser Option können Sie Dateien anhand dem Änderungs- oder Erstellungsdatum von der Suche ausschließen.


Ordnerfilter

Mit dem Ordnerfilter haben Sie die Möglichkeit bestimmte Ordner von einem Suchvorgang auszuschließen. Über die Filterarten Inklusive und Exklusive können Sie festlegen, wie die Filtertexte bei der Suche angewendet werden.

Inklusive

Hiermit werden nur solche Ordner durchsucht, welche mit einem aktivierten Filtertext übereinstimmen. Wenn Sie beispielsweise den Filtertext "Test" festlegen, dann werden nur Ordner mit dem Namen "Test" durchsucht.

Exklusive

Hiermit werden alle Ordner von der Suche ausgeschlossen, die mit einem aktivierten Filtertext übereinstimmen. Wenn Sie beispielsweise den Filtertext "Test" festlegen, dann werden alle Ordner mit dem Namen "Test" von der Suche ausgeschlossen.

Filterliste

Die Filterliste beinhaltet alle vorhandenen Filtertexte für Ordner. Jeder Filtertext kann über sein Kontrollkästchen für den Suchvorgang aktiviert werden. Zum Hinzufügen eines neuen Filters klicken Sie bitte in der Symbolleiste auf die Schaltfläche Ordnerfilter. Ein Rechtsklick auf einen Filter in der Liste öffnet ein Kontextmenü zum Bearbeiten oder Löschen eines Filters.

Filtertexte

Der Vergleich mit dem Filtertext wird immer mit dem Namen eines Ordners durchgeführt. Wenn ein Filtertext das Zeichen "\" enthält, dann wird der Vergleich mit dem kompletten Ordnerpfad durchgeführt. Unter Anwendung von verschiedenen Platzhaltern wie beispielsweise '*' oder '?', haben Sie die Möglichkeit mit einem Filtertext mehrere Ordner zu filtern. Es können auch Umgebungsvariablen von Windows im Filtertext verwendet werden. Sie können bei einem Filtertext auch mehrere Ordnerfilter angeben, indem Sie diese mit dem Zeichen '|' trennen.

Beispiele:
  • C:\Windows
  • C:\Prog*
  • temp??
  • C:\Users\%USERNAME%
  • C:\Windows|C:\Users|C:\Temp

Optionen

Platzhalter im Filter als Text behandeln
Mit dieser Option werden die Zeichen von Platzhaltern in einem Filtertext wie normaler Text behandelt.

Groß- und Kleinschreibung der Filter berücksichtigen
Mit dieser Option wird beim Vergleich eines Ordnernamens mit einem Filtertext die Groß- und Kleinschreibung berücksichtigt.

Unterordner nicht filtern
Das aktivieren dieser Option hat nur dann Auswirkungen, wenn Sie einen Ordner mit der Filterart Inklusive und dem kompletten Pfad filtern. Hierdurch werden dessen Unterordner beim Suchvorgang berücksichtigt und nicht davon ausgeschlossen.


Umgebungsvariablen

Sie können die Umgebungsvariablen von Windows bei Datei- und Ordnerfilter verwenden. Die Variablen werden vor dem Suchvorgang durch Ihren aktuellen Wert ersetzt. Der Ordner "C:\%USERNAME%" wird dann beispielsweise zu "C:\Admin".

Sie können sich die Umgebungsvariablen von Windows über ein Dos-Fenster anzeigen lassen, indem Sie dort den Befehl 'SET' eingeben. Mit 'SET /?' erhalten Sie weitere Informationen.


Dateivorschau

Hier können Sie festlegen, mit welchem Plug-In eine Datei in der Vorschau des Suchergebnisses angezeigt werden soll.
Die Dateiendungen in einer Liste können über Ihr Kontrollkästchen aktiviert und deaktiviert werden. Mit einem rechten Mausklick auf eine Liste wird Ihnen ein Kontextmenü mit folgenden Befehlen angezeigt:
  • Hinzufügen
    Hiermit können Sie eine neue Dateiendung zu der Liste hinzufügen
  • Entfernen
    Hiermit können Sie eine Dateiendung aus der Liste entfernen
  • Alle auswählen
    Hiermit werden alle Dateiendungen in der Liste ausgewählt
  • Alle abwählen
    Hiermit werden alle Dateiendungen in der Liste abgewählt
  • Standardwerte
    Hiermit werden alle Dateiendungen in der Liste entfernt und die Standard-Dateiendungen für dieses Plug-In hinzugefügt

Plug-In's

  • Windows WordPad
  • Windows Internet Explorer
  • Windows Media Player
  • Image Viewer
  • VLC Media Player
  • EXIF Viewer
  • Media Info Viewer

Plug-In: Microsoft WordPad

Mit diesem Plug-In können Sie alle Dateien anzeigen welche von Microsoft WordPad unterstützt werden oder nur Text enthalten. Dateien mit den folgenden Endungen können beispielsweise mit diesem Plug-In in der Dateivorschau angezeigt werden:

TXT, BAT, INI, LOG, CFG, DIZ, NFO, CSS, ASP, PHP, RTF, WRI, XML, INF, URL, REG, LST, EML, ERR, CSV, 1ST, VBS...

Plug-In: Windows Internet Explorer

Mit diesem Plug-In können Sie alle Dateien anzeigen welche von dem Microsoft Internet Explorer unterstützt werden. Voraussetzung für dieses Plug-In ist eine vorhandene Installation des Microsoft Internet Explorer. Dateien mit den folgenden Endungen können beispielsweise mit diesem Plug-In in der Dateivorschau angezeigt werden:

BMP, CAB, DIB, EMF, GIF, ICO, PNG, BMP, JPEG, JPG, HTM, HTML, PDF¹, DOC², DOCX², XLS², XLSX², PPT², PPS², SVG, SWF, TXT, WMF und ZIP

¹ Erfordert die Installation von einem PDF-Viewer mit Browser-Integration.
² Erfordert die Installation von Microsoft Office.

Plug-In: Windows Media Player

Mit diesem Plug-In können Sie alle Audio- und Videodateien abspielen welche von dem Windows Media Player unterstützt werden. Voraussetzung für dieses Plug-In ist eine vorhandene Installation des Windows Media Player. Dateien mit den folgenden Endungen können beispielsweise mit diesem Plug-In in der Dateivorschau abgespielt werden:

AU, AIF, AIFC, AIFF, ASF, AVI, M1V, MID, MIDI, MOV, MP4, MP3, MPEG, MPG, MP2, MPA, MPE, RMI, SND, WAV, WM, WMA, WMV ...

Plug-In: Bildbetrachter

Mit diesem Plug-In können Sie Grafikdateien mit den folgenden Dateiendungen in der Dateivorschau anzeigen:

3FR, ARW, BMP, CR2, CRW, CUT, DCR, DIB, DNG, EMF, ERF, GIF, HDP, HEIC¹, HEIF¹, ICO, IFF, J2C, J2K, JP2, JPE, JPG, JPEG, JPX, JFIF, KDC, MDC, MEF, MOS, MRW, NEF, ORF, PEF, PBM, PCX, PGM, PNG, PPM, PSD, RAF, RAS, RAW, RW2, SRW, TGA, TIF, TIFF, RAS, RLE, WBMP, WEBP, WMF und X3F.

¹ Für diese Dateitypen ist die Installation einer HEIC/HEIF Bild-Erweiterung (z.B. CopyTrans HEIC) notwendig, sofern die Dateien mit dem Windows Explorer nicht als Vorschau oder Thumbnail angezeigt werden können.

Plug-In: VLC Media Player

Mit diesem Plug-In können Sie alle Audio- und Videodateien abspielen welche von dem VLC Media Player unterstützt werden. Dateien mit den folgenden Endungen können beispielsweise mit diesem Plug-In in der Dateivorschau abgespielt werden:

3G2, 3GA, 3GP, 3GP2, 3GPP, 669, A52, AAC, AC3, ADT, ADTS, AU, AIF, AIFC, AIFF, AMR, AMV, AOB, APE, ASF, ASX, AU, AVI, BIK, CAF, DIVX, DRC, DTS, DV, DVR-MS, EVO, F4V, FLAC, FLV, GVI, GXF, IT, M1V, M2T, M2TS, M2V, M4A, M4P, M4V, MID, MKA, MKV, MLP, MOD, MOV, MP1, MP2, MP2V, MP3, MP4, MP4V, MPA, MPC, MPE, MPEG, MPEG1, MPEG2, MPEG4, MPG, MPGA, MPV2, MTS, MTV, MXF, NSV, NUV, OGA, OGG, OGM, OGV, OGX, OMA, OPUS, QCP, RA, REC, RM, RMI, RMVB, RPL, S3M, SDP, SND, SPX, THP, TOD, TP, TS, TTA, TTS, VOB, VOC, VQF, VRO, W64, WAV, WEBM, WMA, WMV, WTV, WV, XA, XESC und XM.

Voraussetzung für dieses Plug-In ist die 32-bit Version der Freeware VLC Media Player ab der Version 3. Die 32-bit Version des VLC Media Players muss entweder auf Ihrem Windowssystem installiert sein, als portable Version auf Ihrem Windowssystem vorhanden sein oder manuell in den Ordner von AllDup integriert werden.

Portable Version des VLC Media Players nutzen
Registrieren Sie die Datei axvlc.dll in dem Ordner des VLC Media Players mit dem folgenden Befehl auf Ihrem Windowssystem: regsvr32.exe axvlc.dll

VLC Media Player in den Ordner von AllDup integrieren
  1. Öffnen Sie das FTP-Archiv von der offiziellen Webseite des VLC Media Players.
  2. Klicken Sie im FTP-Archiv am Ende der Seite auf den Ordner mit der neusten Versionsnummer (z.B. "3.0.8") und danach auf den Ordner "32bit".
  3. Klicken Sie auf die ZIP-Datei (z.B. "vlc-3.0.8-win32.zip") um diese herunterzuladen.
  4. Entpacken Sie die folgenden Dateien und Ordner aus der ZIP-Datei in das Verzeichnis von AllDup:
    • Dateien: axvlc.dll, libvlc.dll, libvlccore.dll
    • Ordner: plugins
  5. Starten Sie AllDup einmalig mit Adminrechten damit die Datei axvlc.dll automatisch auf Ihrem Windowssystem registriert wird oder registrieren Sie die Datei axvlc.dll manuell mit dem folgenden Befehl auf Ihrem Windowssystem: regsvr32.exe axvlc.dll

Plug-In: EXIF Viewer

Mit diesem Plug-In können Sie die EXIF-Daten von Dateien mit den folgenden Dateiendungen in der Dateivorschau anzeigen: JPEG, JPG, TIF, TIFF, PNG, GIF und WAV. Sie können dieses Plug-In aktivieren indem Sie in der Symbolleiste 'Dateivorschau' die Schaltfläche 'EXIF Viewer' auswählen.

Plug-In: Media Info Viewer

Mit dem Plug-In MediaInfo werden Ihnen technische Informationen und Tags von Audio-, Video- und Grafikdateien in der Vorschau angezeigt. Sie können dieses Plug-In aktivieren indem Sie in der Symbolleiste 'Dateivorschau' die Schaltfläche 'Media Info Viewer' auswählen.


Profile

Mit Profilen haben Sie die Möglichkeit Ihre Sucheinstelllungen in einer Datei zu speichern und diese bei Bedarf wieder zu laden. In der Profilliste werden Ihnen alle vorhandenen Profildateien aufgelistet. Über das Rechtsklick-Kontextmenü eines Profils können Sie ein Profil laden, speichern, umbenennen oder löschen.
Beim Start von AllDup wird immer das Standardprofil von AllDup geladen. Beim Beenden von AllDup werden alle Einstellungen des Hauptfensters in dem Standardprofil gespeichert.

Neues Profil erstellen

Wenn Sie ein neues Profil erstellen, dann werden alle Einstellungen des Hauptfensters wie z.B. Quellordner und Suchmethode in dem Profil gespeichert.

Profil laden

Sie können ein Profil mit einem Doppelklick laden oder mit der rechten Maustaste auf das Profil klicken und den Befehl Profil laden auswählen. Der Name des geladenen Profils wird danach in der Titelleiste des Fensters angezeigt.

Profil speichern

Klicken Sie mit der rechten Maustaste auf das Profil und wählen Sie den Befehl Profil speichern um die aktuellen Sucheinstelllungen zu speichern. Wenn Sie die Einstellungen des Dateimanagers in einem Profil speichern möchten, dann müssen Sie zuerst das Profil laden und danach den Dateimanager verwenden.

Profil umbenennen

Klicken Sie mit der rechten Maustaste auf das Profil und wählen Sie den Befehl Profil umbenennen.

Profil löschen

Klicken Sie mit der rechten Maustaste auf das Profil und wählen Sie den Befehl Profil löschen.

Optionen

Beim Laden eines Profils keine Quellordner importieren

Mit dieser Option wird verhindert, dass die gespeicherten Quellordner aus dem Profil geladen werden.


Gespeicherte Suchergebnisse

Hier werden alle gespeicherten Suchergebnisse aufgelistet. Verwenden Sie bitte das Rechtsklick-Kontextmenü um ein Suchergebnis zu laden oder zu löschen.


Optionen

Allgemein

AllDup in das Kontextmenü des Windows Explorers integrieren
Aktivieren Sie diese Option, damit Sie über das Kontextmenü des Windows Explorers einen Suchvorgang mit einem Ordner starten können. Unter Windows 11 muss AllDup mit expliziten Adminrechten gestartet werden, damit diese Option geändert werden kann.

Unicode-Text Support
Mit dieser Option werden Daten welche Unicode-Zeichen von Sprachen wie z.B. Chinesisch, Japanisch, Koreanisch oder Russisch enthalten im Suchergebnis korrekt angezeigt.

Anzeigeformat Dateidatum
Hier können Sie festlegen, mit welchem Format ein Dateidatum im Suchergebnis angezeigt werden soll.

Speicherort der Anwendungsdaten von AllDup
Hier können Sie den Speicherort mit den Anwendungsdaten von AllDup öffnen.

Ordner für temporäre Dateien
In diesem Ordner werden temporäre Dateien erstellt, welche aus Archiven entpackt werden müssen oder welche für die Dateivorschau zwischengespeichert werden. Alle temporären Dateien welche nach dem Start der Suche erstellt wurden, werden beim Schließen des Suchergebnisses automatisch wieder gelöscht.

Benutzeroberfläche

Hier können Sie die Schrift- und Hintergrundfarbe der Benutzeroberfläche von AllDup festlegen.

Protokoll

Einträge aus der Protokolldatei löschen...
Mit dieser Option wird bei Start einer Aktionen die Protokolldatei überprüft und alle Einträge entfernt, die älter sind als die festgelegte Anzahl von Tagen.

Suchergebnis

Externes Programm für den inhaltlichen Vergleich von zwei Dateien
Hier können Sie ein externes Programm zum Vergleichen von Dateien festlegen. Zwei markierte Dateien aus dem Suchergebnis werden über die Platzhalter %1 und %2 an das externe Programm übergeben. Beispiel: C:\Windiff.exe %1 %2

%1 = "C:\Data\db.txt"
%2 = "X:\Backup\abc.txt"
%3 = C:\Data
%4 = X:\Backup
%5 = db.txt
%6 = abc.txt

Folgende Dateitypen mit Microsoft Word vergleichen
Hier können Sie verschiedene Dateiendungen angeben, welche mit der Vergleichsfunktion von Microsoft Word aufgerufen werden. Die Dateiendungen müssen jeweils mit einem Komma getrennt werden. Beispiel: doc,docx,rtf

Externes Programm zum Öffnen von Ordnern
Hier können Sie ein externes Programm zum Öffnen von Ordnern festlegen.
Beispiel: explorer.exe "%1"
Der Platzhalter %1 steht für Dateipfad und Dateiname, %2 übergibt nur den Dateipfad:
%1 = "C:\Data\db.txt"
%2 = "C:\Data\"

Externes Programm zum Öffnen von Dateien
Hier können Sie ein externes Programm zum Öffnen von Dateien festlegen.
Beispiel: C:\texteditor.exe %1
Der Platzhalter %1 wird durch alle markierten Dateien ersetzt: "Datei1" "Datei2" usw.


AllDup Internet Update

Mit dem Internet Update können Sie überprüfen, ob eine neue Version von AllDup zum Download zur Verfügung steht und diese bei Bedarf installieren.

Version

Über die Schaltfläche Prüfen wird ermittelt, ob eine neue Version zur Verfügung steht. Mit der Schaltfläche Download kann eine neue Version heruntergeladen und installiert werden. Im Protokollfenster werden Ihnen Informationen zu einer neuen Version angezeigt.

Optionen

Automatisch auf eine neue Version prüfen
Mit dieser Option wird beim Öffnen des Internet Updates automatisch auf eine neue Version geprüft.

Setupdialog beim Installieren des Updates anzeigen
Wenn diese Option nicht aktiviert ist, dann wird das Update ohne Fenster im Hintergrund installiert.

Download-Ordner
Hier können Sie festlegen, in welchem Ordner die Updatedatei der neuen Version gespeichert werden soll.

Proxy

Hier können Sie bei Bedarf die Zugangsdaten für Ihren Proxyserver festlegen.

Datenschutz

Beim Prüfen auf eine neue Version wird nur eine Textdatei von unserem Webserver heruntergeladen und ausgewertet. Es werden keine privaten Daten von Ihrem Computer über das Internet versendet.


Suchergebnis

Gruppen

Nach Beendigung der Suche werden Ihnen alle doppelten Dateien in Gruppen sortiert angezeigt. In einer Gruppe befinden sich alle Dateien welche nach der von Ihnen ausgewählten Suchmethode als Duplikate ermittelt wurden. Jede Gruppe besitzt eine Referenzdatei, welche mit einer anderen Schriftfarbe dargestellt wird. Alle anderen Dateien in dieser Gruppe sind Duplikate von dieser Referenzdatei.

Dateien und Gruppen sortieren

Sie können den Inhalt des Suchergebnisses sortieren indem Sie mit der linken oder rechten Maustaste auf einen Spaltenkopf klicken. Mit der linken Maustaste werden nur Gruppen sortiert und nicht deren Inhalt. Mit der rechten Maustaste werden die Dateien in jeder Gruppe sortiert.

Dateien auswählen

Die Dateien im Suchergebnis können über Ihr Kontrollkästchen per Mausklick aus- oder abgewählt werden oder Sie verwenden die automatischen Auswahlfunktionen welche über die Menüleiste oder die Symbolleiste aufgerufen werden können.

Dateien und Gruppen markieren

Sie können Dateien und Gruppen markieren, indem Sie die STRG-Taste halten und diese mit der linken Maustaste anklicken. Klicken Sie mit der rechten Maustaste auf die markierten Dateien oder Gruppen um ein Kontextmenü mit verschiedenen Befehlen anzuzeigen.

Dateien löschen, kopieren, verschieben oder umbenennen

Starten Sie den Dateimanager über die Menü- oder Symbolleiste um die ausgewählten Dateien zu bearbeiten. Sie können einzelne Dateien auch ohne den Dateimanager löschen, kopieren oder verschieben, indem Sie die Taste STRG halten und mit der rechten Maustaste auf eine Datei klicken.

Mausbefehle

  • Ein Klick mit der rechten Maustaste auf eine Gruppe oder eine Datei öffnet ein Kontextmenü mit verschiedenen Befehlen.
  • Das Halten der Taste STRG und ein Klick mit der rechten Maustaste auf eine Datei öffnet das Kontextmenü Dateiaktionen mit verschiedenen Befehlen.
  • Ein Klick mit der mittleren Maustaste auf eine Datei öffnet das Kontextmenü des Windows Explorers.
  • Ein Doppelklick mit der linken Maustaste auf einen Dateinamen öffnet die Datei mit ihrem verknüpften Programm.
  • Ein Doppelklick mit der linken Maustaste auf einen Dateipfad öffnet diesen mit dem Windows Explorer.

Tastaturbefehle

  • Mit der Leertaste können Sie eine markierte Datei oder den kompletten Inhalt einer Gruppe aus- und abwählen.
  • Mit der Taste F2 können Sie eine markierte Datei umbenennen.
  • Mit der Entfernen-Taste werden alle markierten Gruppen und Dateien aus dem Suchergebnis entfernt.
  • Mit der Tastenkombination STRG + Entfernen können Sie eine markierte Datei löschen.
Sie können für die verschiedenen Befehle in der Menüleiste, Symbolleiste und den Kontextmenüs Ihre eigenen Tastaturkombinationen festlegen, indem Sie in der Menüleiste unter Optionen den Menüpunkt Tastaturkürzel aufrufen.


Menüleiste / Symbolleiste

  • Suchergebnis
  • Spalten
  • Filter
  • Gruppen
  • Modus
  • Auswählen
  • Abwählen
  • Entfernen
  • Dateischutz
  • Symbolleisten
  • Optionen
Hinweis: Sie können die Schaltflächen einer Symbolleiste ein- und ausblenden indem Sie das Kontextmenü (Rechtsklick) einer Symbolleiste aufrufen.

Suchergebnis

  • Dateimanager - Ausgewählte Dateien löschen, kopieren, verschieben oder umbenennen.
  • Suchergebnis speichern
  • Speichern unter...
  • Suchergebnis exportieren
  • Suchergebnis drucken
  • Protokoll
  • Suchergebnis speichern und schließen
  • Suchergebnis speichern und AllDup beenden
  • Suchergebnis schließen
  • AllDup beenden

Spalten

Hiermit können Sie die verschiedenen Spalten im Suchergebnis ein- oder ausblenden.
  • Spalte 'Dateipfad' anzeigen
  • Spalte 'Zippfad' anzeigen
  • Spalte 'Größe' anzeigen
  • Spalte 'Änderungsdatum' anzeigen
  • Spalte 'Erstellungsdatum' anzeigen
  • Spalte 'Attribute' anzeigen
  • Spalte 'Dateibesitzer' anzeigen
  • Spalte 'Hardlinks' anzeigen
  • Spalte 'Hardlink ID' anzeigen
  • Spalte 'Übereinstimmung' anzeigen
  • Spalte 'Breite anzeigen'
  • Spalte 'Höhe' anzeigen
  • Spalte 'Dauer' anzeigen
  • Spalte 'Bitrate' anzeigen
  • Spalte 'Samplingrate' anzeigen
  • Spaltenbreite optimieren
    Optimiert die Breite von allen Spalten unter Berücksichtigung von allen sichtbaren Zeilen im Suchergebnis
  • Spaltenbreite automatisch optimieren
    Mit dieser Option wird die Spaltenbreite beim auf- und zuklappen von Gruppen automatisch optimiert
  • Spaltenbreite von allen Zeilen optimieren (langsamer)
    Mit dieser Option wird beim Optimieren der Spaltenbreite der Inhalt von allen Zeilen im Suchergebnis berücksichtigt.
  • Spaltenüberschrift beim Optimieren der Spaltenbreite ignorieren

Filter

Mit dem Anzeigefilter können Sie festlegen, welche Gruppen im Suchergebnis angezeigt werden sollen. Folgende Optionen können ausgewählt werden:
  • Gruppen ohne ausgewählte Dateien anzeigen
  • Gruppen anzeigen bei welchen alle Dateien ausgewählt sind
  • Gruppen anzeigen bei welchen manche Dateien ausgewählt sind

Gruppen

Mit den folgenden Aktionen können Sie bestimmte Gruppen auf- oder zuklappen:
  • Alle Gruppen zuklappen
  • Alle Gruppen aufklappen
  • Nur Gruppen mit ausgewählten Dateien aufklappen
  • Nur Gruppen ohne ausgewählte Dateien aufklappen
  • Nur Gruppen aufklappen, bei welchen alle Dateien ausgewählt sind
  • Nur Gruppen mit mindestens 2 nicht ausgewählten Dateien aufklappen
  • Nur Gruppen mit mehr als einer bestimmten Anzahl von Dateien aufklappen
  • Nur Gruppen aufklappen, welche Dateien mit unterschiedlichen Namen enthalten
  • Nur Gruppen aufklappen, welche Dateien mit unterschiedlichen Namen enthalten (ohne Dateiendung)

Modus

Der Bearbeitungsmodus legt fest, welche Gruppen durch die verschiedenen Aktionen von 'Auswählen', 'Abwählen' und 'Entfernen' betroffen sind. Eine der folgenden Optionen kann ausgewählt werden:
  • Alle Gruppen
  • Offene Gruppen
  • Geschlossene Gruppen
  • Gruppen ohne ausgewählte Dateien
  • Gruppen bei welchen alle Dateien ausgewählt sind
  • Gruppen bei welchen manche Dateien ausgewählt sind
  • Markierte Gruppen
  • Nicht markierte Gruppen

Auswählen

Mit den folgenden Aktionen können Sie bestimmte Dateien im Suchergebnis auswählen:
  • Alle Dateien auswählen
  • Alle Dateien markieren
  • Alle Dateien innerhalb des folgenden Ordners auswählen...
  • Alle Dateien auswählen, welche Duplikate von Dateien innerhalb des folgenden Ordners sind
  • Alle Dateien auswählen außer der ersten Datei in jeder Gruppe
  • Alle Dateien auswählen außer der letzten Datei in jeder Gruppe
  • Alle Dateien auswählen außer der neusten Datei in jeder Gruppe
  • Alle Dateien auswählen außer der ältesten Datei in jeder Gruppe
  • Nur die erste Datei in allen Gruppen auswählen
  • Nur die letzte Datei in allen Gruppen auswählen
  • Alle Dateien auswählen außer der kleinsten Datei in jeder Gruppe
  • Alle Dateien auswählen außer der größten Datei in jeder Gruppe
  • Alle Dateien auswählen außer die Datei mit dem kürzesten Namen in jeder Gruppe
  • Alle Dateien auswählen außer die Datei mit dem längsten Namen in jeder Gruppe
  • Alle Dateien auswählen außer die Datei mit dem kürzesten Pfad in jeder Gruppe
  • Alle Dateien auswählen außer die Datei mit dem längsten Pfad in jeder Gruppe
  • Dateien anhand des Namen auswählen
  • Dateien anhand des Pfades auswählen
  • Dateien anhand der Größe auswählen
  • Alle Dateien mit einer Übereinstimmung größer oder gleich einem bestimmten Prozentwert in jeder Gruppe auswählen
  • Alle Dateien mit einer Übereinstimmung kleiner oder gleich einem bestimmten Prozentwert in jeder Gruppe auswählen
  • Alle Dateien auswählen außer die Datei mit den meisten Megapixeln in jeder Gruppe
  • Alle Dateien ohne Hardlinks auswählen
  • Dateiauswahl umkehren
  • Rückgängig
    Hiermit können Sie die zuletzt durchgeführte Aus- oder Abwahlaktion rückgängig machen. Beachten Sie bitte dass beim Entfernen von Dateien aus dem Suchergebnis die Liste mit allen gespeicherten Aktionen zurückgesetzt wird!

Abwählen

Mit den folgenden Aktionen können Sie Dateien im Suchergebnis abwählen:
  • Alle Dateien abwählen
  • Alle Dateien innerhalb des folgenden Ordners abwählen...
  • Alle Dateien abwählen, welche Duplikate von Dateien innerhalb des folgenden Ordners sind
  • Dateien anhand des Namen abwählen
  • Dateien anhand des Pfades abwählen

Entfernen

Mit den folgenden Aktionen können Sie bestimmte Gruppen oder Dateien aus dem Suchergebnis entfernen:
  • Alle Gruppen mit einer bestimmten Anzahl von Dateien aus dem Suchergebnis entfernen
  • Alle Gruppen entfernen, bei welchen die Duplikate nicht in allen Quellordnern vorhanden sind
  • Alle Gruppen entfernen, bei welchen alle Dateien ausgewählt sind
  • Alle Gruppen entfernen, bei welchen einige Dateien ausgewählt sind
  • Alle Gruppen entfernen, welche nur Dateien aus Archiven enthalten
  • Entferne alle Hardlinks aus dem Suchergebnis
  • Entferne alle Gruppen welche nur Hardlinks enthalten
  • Entferne alle Gruppen welche nur Hardlinks mit der gleiche ID enthalten
  • Alle Dateien innerhalb der folgenden Ordnerstruktur aus dem Suchergebnis entfernen
  • Alle Dateien aus dem Suchergebnis entfernen, welche nicht mehr vorhanden sind
  • Alle ausgewählten Dateien aus dem Suchergebnis entfernen

Dateischutz

Hier können Sie für jeden Quellordner den Dateischutz festlegen. Ein aktiver Dateischutz verhindert dass innerhalb dieses Quellordners Dateien gelöscht, verschoben oder umbenannt werden.

Symbolleisten

Hiermit können Sie die verschiedenen Symbolleisten ein- und ausblenden.
  • Symbolleiste 'Datei'
  • Symbolleiste 'Filter'
  • Symbolleiste 'Gruppe'
  • Symbolleiste 'Suche'
  • Symbolleiste 'Auswahl'
  • Alle Symbolleisten ausblenden
  • Große Symbole verwenden

Optionen

  • Tastaturkürzel
  • Löschen bestätigen
    Mit dieser Option müssen Sie das Löschen von Dateien bestätigen.
  • Beim Beenden nachfragen ob das Suchergebnis gespeichert werden soll
  • Schrift verkleinern
  • Schrift vergrößern
  • Schriftart auswählen
    Mit diesem Befehl können Sie die Schriftart für das Suchergebnis ändern.
  • Dateiinfo-Symbole anzeigen
    Mit dieser Option werden verschiedene Symbole für Hardlinks und Dateien aus Archiven am äußersten linken Rand des Suchergebnisses angezeigt. Hiermit erhalten Sie einen schnellen Überblick ob es sich bei einer Datei um einen Hardlink handelt oder ob sich die Datei in einer Archivdatei befindet.
  • Max. Größe der Miniaturbilder in Pixel
    Hiermit können Sie die maximale Breite für die Vorschaubilder festlegen, welche beim Anklicken einer Gruppe angezeigt werden.
  • Dateieigenschaften in einer Spalte anzeigen
    Mit dieser Option werden alle Dateieigenschaften untereinander in einer einzelnen Spalte angezeigt


Kontextmenü

Datei

Dieses Kontextmenü wird Ihnen angezeigt wenn Sie in einer Gruppe mit der rechten Maustaste auf eine Datei klicken.
Tipp: Wenn Sie bei dem rechten Mausklick die STRG-Taste gedrückt halten dann wird Ihnen direkt das Untermenü mit den Dateiaktionen angezeigt.
  • Datei auswählen/abwählen
  • Dateiaktionen:
    • Datei öffnen
      Hier wird die Datei mit Ihrem verknüpften Programm geöffnet.
    • Datei öffnen mit...
    • Dateipfad öffnen
      Hiermit wird der Ordner der Datei mit dem Windows Explorer oder einem benutzerdefinierten externen Programm geöffnet.
    • Datei mit externen Programm öffnen
    • Datei kopieren...
    • Datei verschieben
    • Datei umbenennen
    • Datei löschen
      Hiermit wird die Datei auf dem Speichermedium gelöscht.
    • Datei in den Windows Papierkorb verschieben
    • Dateieigenschaften anzeigen
  • Datei aus dem Suchergebnis entfernen
  • In der Gruppe ganz nach oben verschieben
    Hiermit können Sie die Quelldatei festlegen, welche für das Erstellen von Hardlinks verwendet werden soll.
  • Alle anderen Dateien in dieser Gruppe auswählen
  • Alle Dateien mit dem gleichen Ordnerpfad auswählen
  • Alle Dateien innerhalb der Ordnerstruktur dieser Datei auswählen
    Mit diesem Befehl wird jede Datei im Suchergebnis ausgewählt, welche sich innerhalb der Ordnerstruktur dieser Datei befindet.
  • Alle Dateien mit dem gleichen Ordnerpfad abwählen
  • Alle Dateien innerhalb der Ordnerstruktur dieser Datei abwählen
    Mit diesem Befehl wird jede Datei im Suchergebnis abgewählt, welche sich innerhalb der Ordnerstruktur dieser Datei befindet.
  • Alle anderen Dateien in dieser Gruppe löschen
    Hiermit werden alle anderen Dateien in der gleichen Gruppe auf dem Speichermedium gelöscht.
  • Alle anderen Dateien in dieser Gruppe in den Windows Papierkorb verschieben
  • Filterlisten:
    • Datei zum Dateifilter hinzufügen
      Hiermit können Sie den Dateinamen zum Dateifilter hinzufügen.
    • Dateipfad zum Ordnerfilter hinzufügen
      Hiermit können Sie den Dateipfad zum Ordnerfilter hinzufügen.
  • Dateiendung zu einer Plug-In-Liste hinzufügen
    Hiermit können Sie die Dateiendung zur Liste des Plug-In "Microsoft WordPad", "Windows Internet Explorer", "Windows Media Player", "Dateibetrachter" oder "VLC Media Player" hinzufügen.
  • Dateiendung aus den Plug-In-Listen entfernen
  • In die Zwischenablage kopieren
    Hiermit können Dateiname und/oder Dateipfad in die Zwischenablage kopiert werden.
  • Windows Explorer Kontextmenü anzeigen

Markierte Dateien

Sie können mehrere Dateien markieren indem Sie die STRG-Taste halten und mit der linken Maustaste die Dateien anklicken. Verwenden Sie danach die rechte Maustaste um das folgende Kontextmenü für die markierten Dateien anzuzeigen:
  • Markierte Dateien auswählen
  • Markierte Dateien abwählen
  • 2 markierte Dateien vergleichen
  • Markierte Dateien mit externen Programm öffnen
  • Dateinamen vertauschen
  • Markierte Dateien kopieren
  • Markierte Dateien verschieben
  • Markierte Dateien löschen
  • Markierte Dateien aus dem Suchergebnis entfernen
  • In die Zwischenablage
    Hiermit können Dateiname und/oder Dateipfad von allen markierten Dateien in die Zwischenablage kopiert werden.

Gruppen

  • Gruppe auswählen/abwählen
  • Dateiauswahl umkehren
  • Markierte Gruppe(n) entfernen
  • Öffne alle Dateien aus der Gruppe mit einem externen Programm


Dateimanager

Mit dem Dateimanager können Sie die ausgewählten Dateien aus dem Suchergebnis löschen, kopieren, verschieben oder umbenennen.

  • Welche Gruppen sollen bearbeitet werden?
  • Welche Aktion soll durchgeführt werden?
  • Ordner
  • Optionen

Welche Gruppen sollen bearbeitet werden?

  • Alle Gruppen (Filter ignorieren)
  • Nur Gruppen welche durch den Filter angezeigt werden

Keine Gruppen bearbeiten bei welchen alle Dateien ausgewählt sind
Mit dieser Option wird gewährleistet, dass Sie nicht aus Versehen alle gleichen Dateien einer Gruppe löschen.

Welche Aktion soll durchgeführt werden?

  1. Dateien löschen
    Mit dieser Aktion werden die ausgewählten Dateien aus dem Suchergebnis auf Ihrem Speichermedium gelöscht und Speicherplatz freigegeben. Wenn Sie Dateien aus Archiven löschen und die zu löschende Datei die einzige Datei im Archiv ist, dann wird immer die Archivdatei gelöscht. Das Löschen von Dateien aus Archiven welche mehrere Dateien beinhalten ist nur bei Archiven mit der Endung .zip und .7z möglich.
    Mit der Option 'Sicheres löschen' wird vor dem Löschen der Dateiinhalt komplett überschrieben und die Dateigröße auf 0 gesetzt.

  2. Lokale Dateien in den Windows Papierkorb verschieben
    Mit dieser Aktion werden die ausgewählten Dateien in den Windows Papierkorb verschoben. Es wird eine Fehlermeldung angezeigt, wenn auf dem Datenträger der zu löschenden Datei kein Windows Papierkorb vorhanden ist. Mit der Option 'Datei löschen wenn kein Papierkorb vorhanden ist' wird keine Fehlermeldung angezeigt und die Datei gelöscht. Wichtige Hinweise:
    • Achten sie darauf dass der Windows Papierkorb auf dem Speichermedium der Dateien aktiviert ist
    • Der verwendete Speicherplatz für den Windows Papierkorb sollte auf 100% eingestellt sein
    • Dateien welche sich auf einem anderen Computer befinden, werden nicht in den Windows Papierkorb verschoben sondern direkt gelöscht!
    • Dateien aus Archiven können nicht in den Windows Papierkorb verschoben werden

  3. Dateien in einen Ordner kopieren
    Mit dieser Aktion können Sie die ausgewählten Dateien aus dem Suchergebnis in einen Ordner Ihrer Wahl kopieren.

  4. Dateien in einen Ordner verschieben
    Mit dieser Aktion können Sie die ausgewählten Dateien aus dem Suchergebnis in einen Ordner Ihrer Wahl verschieben.

  5. Dateien umbenennen
    Mit dieser Aktion können Sie die ausgewählten Dateien aus dem Suchergebnis umbenennen. Folgende Platzhalter können für den neuen Namen verwendet werden:
    Platzhalter | Beschreibung
    %1 | Dateiname ohne Dateiendung
    %2 | Dateiendung inklusive Punkt (z.B.: .txt)
    %YYYY | Jahr 4-stellig
    %YY | Jahr 2-stellig
    %MM | Monat
    %DD | Tag
    %HH | Stunden
    %NN | Minuten
    %SS | Sekunden
Hinweis: Die Aktionen 2, 3, 4 und 5 haben keine Auswirkungen auf ausgewählte Dateien welche sich in einer Archivdatei (Zip, Rar, usw.) befinden.

Sicherheitshinweis
Mit dieser Option wird vor dem Löschen, Verschieben oder Umbenennen der ausgewählten Dateien ein Sicherheitshinweis angezeigt.

Ordner

Hier legen Sie den Ordner fest, in welchen die Dateien kopiert oder verschoben werden.

Dateien mit Ordnerstruktur im Ordner ablegen
Mit dieser Option wird festgelegt, dass die Dateien mit Ihrer Ordnerstruktur in dem ausgewählten Ordner abgelegt werden. Wenn Sie diese Option deaktivieren, dann werden die Dateien direkt in dem Ordner abgelegt. Vorhandene Dateien werden vor dem Überschreiben umbenannt. Hierbei wird hinter dem Namen der vorhandenen Datei eine Zahlenfolge angehängt.
Beispiel: Data.txt -> Data-001.txt

Unterordner erstellen
Mit dieser Option können Sie weitere Unterordner in dem Ordner erstellen. Es können verschiedene Platzhalter für Datum und Uhrzeit und Windowsvariablen verwendet werden.

Beispiele:
Text: "Backup von" %USERNAME% "am" yyyy-mm-dd "um" hh_nn_ss
Ordnername: Backup von Anwendername am 2011-02-26 um 10_15_00

Text: "%USERNAME%\"YYYY-MM-DD HH-NN-SS
Ordnernamen: Anwendername\2011-02-26 10-15-00

Optionen

Verknüpfungen erstellen
Mit dieser Option wird nach dem Löschen oder Verschieben einer Datei an der gleichen Stelle eine Verknüpfung (.lnk) auf die erste nicht ausgewählte Datei in der gleichen Gruppe erstellt. Siehe Beispiel für Verknüpfungen.

Hardlinks erstellen
Mit dieser Option können alle ausgewählten Dateien in einer Gruppe miteinander verlinkt werden. Siehe Beispiel für Hardlinks. Dies hat den Vorteil dass der Inhalt von allen verlinkten Dateien nur einmal auf der Festplatte gespeichert ist und somit Speicherplatz gespart werden kann: wenn Sie beispielsweise 1000 inhaltlich gleiche Dateien mit einer jeweiligen Größe von 10 MB miteinander verlinken, dann werden etwas mehr als 9 GB an Speicherplatz auf der Festplatte freigegeben.

Beachten Sie bitte folgende Hinweise:
  • Es können nur Dateien welche sich auf der gleichen Partition befinden miteinander verlinkt werden.
  • Die Dateien müssen auf einer lokalen NTFS-Partition gespeichert sein.
  • Es können keine Hardlinks auf einem Netzlaufwerk erstellt werden.
  • Es können keine Hardlinks in einem virtuellen Ordner erstellt werden, der auf die Daten einer externen Quelle verweist, wie z.B. die lokale Bereitstellung von Dateien aus einer Cloud.
  • Es müssen mindestens 2 Dateien in einer Gruppe ausgewählt sein.
  • Unter Windows kann eine Datei maximal 1024 Hardlinks besitzen.
  • AllDup ermittelt von allen ausgewählten Dateien in einer Gruppe automatisch eine Quelldatei welche weniger als 1024 Hardlinks besitzt. Alle anderen ausgewählten Dateien in dieser Gruppe werden dann mit dieser Quelldatei verlinkt.
  • Sobald die Quelldatei 1024 Hardlinks aufweist wird automatisch eine weitere Quelldatei ermittelt. Dies ermöglicht Ihnen eine unbegrenzte Anzahl von Hardlinks in einer Gruppe zu erstellen.
  • Mit dem Datei-Kontextmenü-Befehl 'In der Gruppe ganz nach oben verschieben' können Sie bei Bedarf die Quelldatei zum Erstellen von Hardlinks festlegen.
  • Dateien welche schon verlinkt sind werden automatisch übersprungen. Die Anzahl der vorhandenen Hardlinks einer Datei wird anhand dem angezeigten Wert in der Spalte 'Hardlinks' überprüft. Aktivieren Sie hierfür die Suchoption Anzahl der Hardlinks pro Datei ermitteln damit die korrekte Anzahl der Hardlinks für jede Datei ermittelt wird.
  • Dateien welche sich in Archiven befinden werden automatisch übersprungen.

Dateien aus dem Suchergebnis entfernen
Die bearbeiteten Dateien werden aus dem Suchergebnis entfernt.

Gruppen mit nur einer Datei entfernen
Hiermit werden alle Gruppen mit nur einer Datei aus dem Suchergebnis entfernt.

Überprüfen ob in einer Gruppe alle Duplikate ausgewählt sind
Mit dieser Option werden zuerst alle Gruppen überprüft, ob in einer Gruppe alle Dateien ausgewählt sind.

Bei Fehlermeldungen kein Abfrage zum Abbrechen anzeigen
Mit dieser Option wird der Vorgang bei einer Fehlermeldung ohne Abbrechen-Dialog weitergeführt.

Ordner löschen, welche nach Verschieben/Löschen leer sind
Hiermit werden alle leeren Ordner gelöscht, welche zuvor Dateiduplikate enthielten.

Dateiaktionen nicht protokollieren
Mit dieser Option werden die durchgeführten Dateiaktionen nicht protokolliert.

Nach Abschluss der Aktion
Folgende Aktionen stehen Ihnen zur Auswahl:
  • Dateimanager schließen
  • AllDup beenden

Beispiel für Hardlinks

Im Suchergebnis befinden sich folgende Dateien in einer Gruppe:
  1. C:\Arbeit\hinweise.txt
  2. C:\Benutzer\bitte-lesen.txt
  3. C:\Backup\hinweise.txt
  4. C:\Mail\neue-benutzer-hinweise.txt
Alle Dateien in der Gruppe sind ausgewählt (?). Die 1. Datei wird automatisch als Quelldatei für die Erstellung der Hardlinks verwendet. Alle anderen Dateien (2-4) werden gelöscht und jeweils ein Hardlink auf die 1. Datei erstellt, wobei der Hardlink den gleichen Namen wie die gelöschte Datei besitzt.

Beispiel für Verknüpfungen

Im Suchergebnis befinden sich folgende Dateien in einer Gruppe:
  1. C:\Arbeit\hinweise.txt
  2. C:\Benutzer\bitte-lesen.txt
  3. C:\Backup\hinweise.txt
  4. C:\Mail\neue-benutzer-hinweise.txt
Die 1. Datei ist nicht ausgewählt und wird als Quelldatei für die zu erstellenden Verknüpfungen verwendet. Alle anderen Dateien (2-4) sind im Suchergebnis ausgewählt (?). Die ausgewählten Dateien werden gelöscht und an der gleichen Stelle eine Verknüpfung auf die 1. Datei erstellt wobei die Verknüpfung immer den Namen der gelöschten Datei erhält.


Tastaturkürzel

Hier können Sie für alle Befehle der Menüleiste und Symbolleiste ein Tastaturkürzel festlegen. Klicken Sie in der Liste auf eine Zeile und drücken Sie dann eine Tastenkombination um das Tastaturkürzel für diesen Befehl festzulegen. Mit der Entfernen-Taste kann ein Tastaturkürzel gelöscht werden. Mit der Tastenkombination STRG + Entfernen werden alle Tastaturkürzel gelöscht.

Tasten

Sie können die folgenden Tasten verwenden, um ein Tastaturkürzel zu erstellen:
  • STRG
  • ALT
  • Umschalttaste
  • A-Z
  • 0-9
  • F2-F12
  • Num0-Num9
  • Backspace
  • Eingabetaste
  • Einfügen

Beispiele:

  • STRG + A
  • ALT + 1
  • Umschalttaste + L
  • STRG + ALT + M
  • F2
  • Eingabetaste


Kommandozeile

Syntax

AllDup.exe -s[1-9,a,b,c] -c[0-5] -h[0-9] -f[0-7] -m[1-100] -d[0-2] -l[10-999] -a[1,2,4,5] -p:"[Profilname]" -n "[Ordner1]" "[Ordner2]" ....

Parameter

-s[1-9,a]

Mit diesem Parameter können Sie die Suchmethode festlegen:
  • 1 = Dateiname
  • 2 = Dateiendung
  • 3 = Dateigröße
  • 4 = Dateiinhalt
  • 5 = Änderungsdatum
  • 6 = Erstellungsdatum
  • 7 = Dateiattribute
  • 8 = Hardlinks
  • 9 = Ähnliche Bilder
  • a = Ähnliche Musik
  • b = Tonspur
  • c = Ähnliche Dateinamen
Die Dateieigenschaften 1 bis 7 können miteinander kombiniert werden wie beispielsweise "-s124" oder "-s36". Die Suchmethoden 8, 9, a, b und c können nur einzeln verwendet werden wie beispielsweise "-s8" oder "-sa". Dieser Parameter ist optional und muss nicht angegeben werden.

-c[0-5]

Hiermit können Sie die Vergleichsmethode für die Suchmethode Dateiinhalt festlegen.
  1. Byte für Byte
  2. MD5 (128-Bit)
  3. SHA-1 (160-Bit)
  4. SHA-2 (256-Bit)
  5. SHA-2 (384-Bit)
  6. SHA-2 (512-Bit)
Dieser Parameter ist optional und kann nur in Kombination mit dem Befehl -s4 verwendet werden.

-h[0-9]

Hiermit können Sie die Vergleichsmethode für die Suchmethode Ähnliche Bilder festlegen.
  1. aHash
  2. bHash
  3. dHash
  4. mHash
  5. pHash
  6. MD5 (128-Bit)
  7. SHA-1 (160-Bit)
  8. SHA-2 (256-Bit)
  9. SHA-2 (384-Bit)
  10. SHA-2 (512-Bit)
Dieser Parameter ist optional und kann nur in Kombination mit dem Befehl -s9 verwendet werden.

-f[0-7]

Hiermit können Sie die Vergleichsmethode für die Suchmethode Ähnliche Dateinamen festlegen.
  1. SmartMatch
  2. FuzzyMatch
  3. Levenshtein
  4. Ratcliff
  5. MatchDiff
  6. WordMatch
  7. FuzzyPercent
  8. Simil
Dieser Parameter ist optional und kann nur in Kombination mit dem Befehl -sc verwendet werden.

-m[1-100]

Hiermit können Sie die Übereinstimmung in Prozent für die Suchmethode Ähnliche Bilder oder Ähnliche Musik festlegen. Dieser Parameter ist optional und kann nur in Kombination mit dem Befehl -s9 oder -sa verwendet werden.

-d[0-4]

Hiermit können Sie die Vergleichsgröße für die Suchmethode Ähnliche Bilder festlegen.
  1. 8x8 (aHash, dHash, mHash)
  2. 16x16 (aHash, dHash, mHash)
  3. 128x128 (bHash)
  4. 256x256 (bHash)
  5. 512x512 (bHash)
Dieser Parameter ist optional und kann nur in Kombination mit dem Befehl -s9 verwendet werden.

-l[10-999]

Hiermit können Sie die Messdauer in Sekunden für die Suchmethode Ähnliche Musik festlegen. Dieser Parameter ist optional und kann nur in Kombination mit dem Befehl -sa verwendet werden.

-a[1,2,4,5]

Hiermit können Sie die Vergleichsmethode für die Suchmethode Ähnliche Musik festlegen. Dieser Parameter ist optional und kann nur in Kombination mit dem Befehl -sa verwendet werden.

-p:"[Profilname]"

Hiermit werden bei der Suche die Einstellungen des angegebenen Profils verwendet.
Dieser Parameter ist optional und muss nicht angegeben werden.

-n

Mit diesem Parameter werden die übergebenen Ordner nicht zur Quellordnerliste hinzugefügt.
Der Parameter ist optional und muss nicht angegeben werden.

"[Ordner]"

Hiermit legen Sie fest, welche Ordner durchsucht werden sollen. Es können mehrere Ordner angegeben werden. Ordnerpfade welche Leerzeichen beinhalten müssen in Anführungszeichen gesetzt werden.
Dieser Parameter ist nicht optional und muss angegeben werden.

Beispiele

AllDup.exe -s13 "C:\Arbeit"
Startet eine Suche nach gleichem Dateiname und Dateigröße in dem Ordner "C:\Arbeit".

AllDup.exe -s9 -h3 -m90 "C:\Bilder"
Startet eine Suche nach ähnlichen Bildern unter Verwendung der Prüfsumme pHash mit einer Übereinstimmung von 90% in dem Ordner "C:\Bilder".

AllDup.exe -sa -l25 -a4 -m80 "C:\Audio"
Startet eine Suche nach ähnlicher Musik in dem Ordner "C:\Audio" unter Verwendung der Vergleichsmethode Nr.4 mit einer Übereinstimmung von 80% und einer Messdauer von 25 Sekunden.

AllDup.exe -s4 -c0 "C:\Arbeit" "C:\Data"
Startet eine Suche nach Dateien mit dem gleichen Inhalt in dem Ordner "C:\Arbeit" und "C:\Data".

AllDup.exe -s14 -c3 "C:\Arbeit"
Startet eine Suche nach Dateien mit dem gleichen Namen und Inhalt in dem Ordner "C:\Arbeit".

AllDup.exe "C:\Arbeit"
Startet eine Suche in dem Ordner "C:\Arbeit" mit den aktuellen Programmeinstellungen.

AllDup.exe -p:"test" "C:\Arbeit"
Startet eine Suche in dem Ordner "C:\Arbeit" mit den Einstellungen des angegebenen Profils.

AllDup.exe C:\Arbeit "D:\Data Backup"
Startet eine Suche in den Ordnern "C:\Arbeit" und "D:\Data Backup" mit den aktuellen Programmeinstellungen.


Platzhalter für Text

Platzhalter | Beschreibung
* | Kein oder mehrere Zeichen.
? | Ein beliebiges einzelnes Zeichen.
# | Eine beliebige einzelne Ziffer (0 - 9).
[ZeichenListe] | Ein beliebiges einzelnes Zeichen in ZeichenListe.
[!ZeichenListe] | Ein beliebiges einzelnes Zeichen, das nicht in ZeichenListe enthalten ist.

Die Platzhalter können in beliebiger Reihenfolge miteinander kombiniert werden.

Die Sonderzeichen linke Klammer ([), Fragezeichen (?), das Zeichen # und das Sternchen (*) müssen in eckige Klammern gesetzt werden, um für einen Vergleich herangezogen werden zu können. Die rechte eckige Klammer (]) kann nicht innerhalb einer Gruppe zu vergleichender Zeichen verwendet werden. Sie kann jedoch außerhalb einer Gruppe als einzelnes Zeichen angegeben werden.

Sie können in ZeichenListe auch einen Bereich von Zeichen angeben, indem Sie den größten und den kleinsten Wert des Bereichs getrennt durch einen Bindestrich (-) angeben. [A-Z] führt zum Beispiel zu einer Übereinstimmung, wenn die entsprechende Zeichenposition in ZeichenListe einen Buchstaben im Bereich von A bis Z enthält. Mehrere Bereiche können Sie ohne weitere Trennzeichen nacheinander in einem Klammernpaar angeben.

Weitere wichtige Regeln für die Verwendung der Platzhalter:

  • Ein Ausrufezeichen (!) am Anfang von ZeichenListe bedeutet, dass sich eine Übereinstimmung ergibt, wenn im Text ein beliebiges Zeichen außer den Zeichen in ZeichenListe gefunden wird. Wird das Ausrufezeichen außerhalb der eckigen Klammern verwendet, so dient es als Platzhalterzeichen für sich selbst.
  • Ein Bindestrich (-) kann entweder am Anfang (nach einem Ausrufezeichen, sofern vorhanden) oder am Ende von ZeichenListe erscheinen, um als Platzhalterzeichen für sich selbst zu dienen. In jeder anderen Position dient der Bindestrich zur Kennzeichnung eines Zeichenbereichs.
  • Wenn ein Zeichenbereich festgelegt wird, dann müssen die Zeichen in aufsteigender Sortierreihenfolge (vom niedrigsten bis zum höchsten) angegeben werden. Demnach ist [A-Z] ein zulässiges Muster und [Z-A] dagegen nicht.

Beispiele:

Art der Entsprechung | Text | Entsprechung | Keine Entsprechung
Mehrere Zeichen | a*a | aa, aBa, aBBBa | aBC
 | *ab* | abc, AABB, Xab | aZb, bac
Sonderzeichen | a[*]a | a*a | aaa
Mehrere Zeichen | ab* | abcdefg, abc | cab, aab
Einzelne Zeichen | a?a | aaa, a3a, aBa | aBBBa
Einzelne Ziffern | a#a | a0a, a1a, a2a | aaa, a10a
Zeichenbereich | [a-z] | f, p, j | 2, &
Außerhalb des Bereichs | [!a-z] | 9, &, % | b, a
Keine Ziffern | [!0-9] | A, a, &, ~ | 0, 1, 9
Kombination | a[!b-m]# | An9, az0, a99 | abc, aj0


Platzhalter für Datum und Uhrzeit

Zeichen | Beschreibung
: | Zeit-Trennzeichen
/ | Datumstrennzeichen
d, dd | Tag (1 – 31, 01 - 31)
Ddd | Tag (So – Sa)
dddd | Tag (Sonntag – Samstag)
ddddd | Datum im kurzen Format
dddddd | Datum im langen Format
w | Wochentag (1 für Sonntag bis 7 für Samstag)
ww | Kalenderwoche (1 – 54)
m, mm | Monatszahl (1 – 12, 01 - 12)
mmm | Monatsnamen abgekürzt (Jan – Dez)
mmmm | Monatsnamen (Januar – Dezember)
q | Jahresquartal (1 – 4)
y | Kalendertag (1 – 366)
yy, yyyy | Jahreszahl (00 – 99, 100 - 9999)
h, hh | Stundenzahl (0 - 23, 00 - 23)
m, mm, n, nn | Minutenzahl (0 - 59, 00 - 59)
s, ss | Sekundenzahl (0 - 59, 00 - 59)
AM/PM, A/P, AMPM | 12-Stunden-Format für die Uhrzeit


Geschwindigkeitsvergleich

Hier erhalten Sie Informationen über einen Geschwindigkeitsvergleich zwischen den Suchmethoden Byte für Byte und SHA-1. Der Ordner mit den Testdateien befand sich auf einer externen USB2-Festplatte, welche mit der Software TrueCrypt verschlüsselt war. Die Tests wurden auf einem Computer mit Windows 7 x64, 8 GB RAM und einer i3-CPU durchgeführt. Für alle Tests wurden die Optionen "Exif-Daten von JPEG-Dateien ignorieren" und "Alle x Minuten die Suchstatistik der Fortschrittsanzeige protokollieren" aktiviert.

Protokoll des Tests mit der Suchmethode Byte für Byte:

Protokoll des Tests mit der Suchmethode SHA-1:

Wie erwartet ist die Suchmethode SHA-1 schneller als der Vergleich mit der Methode Byte für Byte. Der Vergleich von im RAM gespeicherten Prüfsummen reduziert erheblich die Dateizugriffe auf der Festplatte was viel Zeit spart.