Überblick

Navigation: »No topics above this level«

TreeSize Professional - Überblick

 Return to chapter overview

TreeSize Professional ist ein leistungsfähiger und vielseitiger Manager für den Festplattenplatz unter Windows 2000/XP/2003/Vista/2008. Er hilft bei der Suche nach den großen Speicherplatzverschwendern und ermöglicht die Wiedergewinnung von Megabytes an Festplattenplatz.

TreeSize Professional zeigt Ihnen für jedes Verzeichnis

· dessen Größe,
· den tatsächlich belegten Platz,
· den durch das Dateisystem verschwendeten Platz,
· Anzahl der Dateien und Ordner,
· 3D-Balken und Tortendiagramme,
· das Datum des letzten Zugriffs,
· Besitzer,
· NTFS-Kompressionsrate
· und noch vieles mehr.

Die integrierte Dateisuche hilft Ihnen bei der Suche nach überflüssigen, temporären, sehr großen oder sehr alten Dateien und ermöglicht deren anschließende Löschung oder Archivierung in einer ZIP-Datei. Die Anwendung hat eine intuitive, an den Windows Explorer angelehnte Benutzeroberfläche, arbeitet mit mehreren Hintergrundthreads und unterstützt Unicode. Sie können detaillierte Berichte und Diagramme ausdrucken, die gesammelten Daten in eine HTML-, XML- oder Textdatei speichern, oder in Excel exportieren.

Für jede Schaltfläche und jeden Menüpunkt wird eine kurze Beschreibung als Tooltip und in der Statuszeile des Fensters angezeigt. Mit F1 kann in den meisten Fällen ein zum Kontext passendes Kapitel in der Hilfe geöffnet werden. Zur Untersuchung eines Laufwerks oder Pfades kann dieses einfach in der Laufwerks-Dropdown-Box ausgewählt oder dort mit der Tastatur eingegeben werden. Gestartet wird der Untersuchungsvorgang dann durch Betätigen der Return-Taste oder durch Drücken des grünen Pfeils in der Symbolleiste.


Schnellstart

Navigation: »No topics above this level«

Schnellstart

 Return to chapter overview

1. Auf dieser Symbolleiste können Sie auswählen, welches Laufwerk Sie scannen möchten. Mit dem Pfeil rechts neben diesem Feld starten Sie den Scanvorgang. TreeSize Professional speichert die zuletzt benutzen Pfade in der Dropdown-Box für schnelleren späteren Zugriff ab.
2. Hier erhalten Sie einen Überblick über das momentan angezeigte Laufwerk. Diese und andere Symbolleisten können im Kontextmenü (Rechtsklick auf die Symbolleiste) deaktiviert werden.
3. Der Reiter "Diagramm" zeigt ein Torten- oder Balkendiagramm des aktuell ausgewählten Verzeichnisses an. Über das Kontextmenü kann eine Symbolleiste mit weiteren Optionen für Diagramme angezeigt werden.
4. Der Reiter "Details" zeigt detaillierte Informationen über Unterordner und Dateien des ausgewählten Laufwerks bzw. des Ordners an.
5. Der Reiter "Dateitypen" zeigt Informationen über die Größe, gruppiert nach Dateitypen, so dass man einen Überblick über die Dateitypen erhält, die am meisten Platz verschwenden.
6. Der Reiter "Benutzer" zeigt Informationen über die Größe, gruppiert nach Benutzern. Dies erlaubt Ihnen, herauszufinden, welcher Benutzer am meisten Platz belegt.
7. Der Reiter "Dateialter" zeigt Informationen über das Alter der gescannten Dateien an und ermöglicht eine zeitbezogene Nutzungsanalyse.
8. Der "Top 100"-Reiter listet die 100 größten Dateien des untersuchten Verzeichniszweiges auf.
9. Der Dateisystembaum des gescannten Laufwerks bzw. Ordners gibt Ihnen einen schnellen Überblick über die Größe jedes Ordners.
10. Die Laufwerksübersicht gibt einen Überblick über die lokalen Laufwerke und die verbundenen Netzwerklaufwerke. Weitere Netzwerklaufwerke können Sie einfach über das Kontextmenü hinzufügen. Ein Doppelklick startet einen Scan des ausgewählten Verzeichnisses.
11. Die Statusleiste informiert über den freien und belegten Speicherplatz, den Typ des Dateisystems, usw.
12. Der Reiter "Historie" gibt wieder, wie die Scan-Ergebnisse eines Astes sich im Laufe der Zeit verändern, und ermöglichen so eine dynamische Nutzungsanalyse über einen größeren Zeitraum.


Was ist neu?

Navigation: »No topics above this level«

Was ist neu?

 Return to chapter overview

Änderungen in V5.2.3 (31.03.2009)

· Die Kommandozeilen-Parameter /USERSLIST, /EXTENSIONSLIST und /TOPFILESLIST unterstützen jetzt das Schreiben von Excel Dateien.
· Dateisuche: Beim Berechnen von MD5-Prüfsummen zeigt die Duplikatsuche nun die Anzahl der noch ausstehenden Dateien in der Statuszeile an.
· Dateisuche: Für die Ergebnisliste der Duplikatsuche werden jetzt Anzahl und Gesamtgröße der Dateien in der Statuszeile angezeigt, und nicht mehr Anzahl und Größe der Dateigruppen.
· Dateisuche: Ist mehr als eine Datei in der Ergebnisliste selektiert, so wird nun die Anzahl und Gesamtgröße der markierten Dateien in der Statuszeile angezeigt.
· Bugfix: Dateisuche: Die Duplikatsuche ist gelegentlich beim Bestimmen der MD5-Prüfsummen eingefroren.
· Bugfix: Dateisuche: Es wurde ein Problem bei der Nutzung der Funktion "Markierte Verschieben" beseitigt, dass beim Verschieben kompletter Ordner in eine ZIP-Datei auftrat.
· Bugfix: Wurde die benutzerdefinierte Blockgröße im Optionen-Dialog zurück auf "Original" gestellt, so wurde diese Einstellung nicht auf bestehende Scans angewandt, auch nicht bei einem erneuten Scan.
· Bugfix: Ein Problem mit der Darstellung des Balkendiagramms mit vielen Verzeichnissen wurde behoben.
· Einige kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V5.2.2 (17.02.2009)

· Der Schatten des Kreisdiagramms wird jetzt ebenfalls deaktiviert, wenn der Farbverlauf im Hintergrund des Diagramms über die Symbolleiste deaktiviert wird.
· Bugfix: Für UNC-Pfade wurde die Größe und der freie Platz nicht mehr in der Laufwerksübersicht angezeigt.
· Bugfix: Die Statistik für Dateitypen und Benutzer wurde nicht mehr für virtuelle Wurzelverzeichnisse angezeigt.
· Bugfix: Wurde eine einzelne Datei per Drag&Drop vom Reiter "Details" in den Verzeichnisbaum verschoben, konnte es zu einer Fehlermeldung kommen.
· Bugfix: Beim Scrollen in einem Balkendiagramm mit sehr vielen Elementen wurde dessen Darstellung zerstört.
· Bugfix: Auf Systemen, bei denen die Windows Druckerwarteschlange deaktiviert war, kam es beim Programmstart zu einer Fehlermeldung.
· Bugfix: Das Deaktivieren der Statistik für das Dateialter wurde beim Beenden des Programms nicht gespeichert.
· Bugfix: Das Aktivieren der Option "Nur Dateien mit Erstellungsdatum innerhalb XX Tagen" (Ansicht > Optionen > Filter) führte dazu, dass auch das Erstellungsdatum von Ordnern überprüft wurde und lieferte daher unerwartete Ergebnisse.
· Einige kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V5.2 (04.02.2009)

· Dateisuche: Die Funktion "Markierte Dateien verschieben" kann nun mit Pfaden umgehen, die länger als 255 Zeichen sind. Optional kann Sie außerdem die Berechtigungen der Dateien beim Verschieben erhalten.
· Dateisuche: Die Funktion "Markierte Dateien verschieben" sowie der /MOVETO Kommandozeilen-Parameter erlauben es jetzt, die markierten Dateien einzeln an eine ausführbare Datei zu übergeben. Dies bietet Systemadministratoren sehr viele neue Möglichkeiten, manuell oder automatisch die Suchergebnisse einer TreeSize Professional Dateisuche zu verarbeiten.
· Dateisuche: Die Suchergebnisse können jetzt in eine Excel-Datei gespeichert werden. Werden mehrere Ergebnislisten gespeichert, so wird jede Liste auf einem eigenen Arbeitsblatt platziert.
· Dateisuche: Mit Hilfe einer neuen Option im Dialog "Markierte Dateien verschieben" können nun automatisch leere Ordner entfernt werden, die nach dem Verschieben der markierten Dateien übrig bleiben.
· Dateisuche: In der Liste der Suchmuster der "Benutzerdefinierten Dateisuche" ist es jetzt möglich Suchmuster zu verwenden, die auch Fragmente eines Pfades beinhalten, z.B:
"C:\Windows\*\*.exe" oder "*\Temp\*.old".
· Dateisuche: Für ZIP-Dateien, die mit der Funktion "Markierte Dateien verschieben" erstellt werden können, werden nun Unicode Datei- und Ordnernamen in der ZIP-Datei abgespeichert. ZIP-Dateien, die Unicode Namen enthalten, können nur mit Hilfe von Unicode fähigen ZIP-Programmen wie WinZip oder WinRar wieder korrekt ausgepackt werden.
· Dateisuche: Es ist jetzt möglich die Dateisuche mit vollen Administrator-Rechten zu starten. Sie finden entsprechende Menüpunkte im Windows Startmenü und im Menü "Extras" von TreeSize Professional.
· Dateisuche: Im "Datei" Menü ist es jetzt möglich, eine Ergebnisliste auszudrucken oder ihren gesamten Inhalt in die Zwischenablage zu kopieren. Verwenden Sie weiterhin das Kontextmenü der Ergebnislisten, um nur die selektierten Elemente zu kopieren.
· Dateisuche: Der Inhalt der Laufwerksübersicht kann jetzt mit Hilfe des Kontextmenüs in die Zwischenablage kopiert werden.
· Dateisuche: Der Kommandozeilen-Parameter /DATE wird jetzt auch für die Dateisuche unterstützt. Auf diese Weise können Sie automatisch das aktuelle Datum mit Uhrzeit zu Dateinamen hinzufügen lassen, die für die Parameter /SAVE oder /MOVETO (mit ZIP-Datei) angegeben wurden. /DATE verändert nur diejenigen Dateinamen, die in der Kommandozeile dahinter erscheinen.
· Die neuen Kommandozeilen-Parameter /NOHEADERS und /NOUNITS erlauben es, die Ausgabe der Kopfzeilen bzw. der Einheiten für exportierte Dateien abzuschalten. Dies kann die Weiterverarbeitung der gesammelten Daten vereinfachen.
· Eine neue Option unter Extras > Optionen > Filtern erlaubt das Ausschließen von Dateien, die als "Offline" markiert sind. "Offline" Dateien sind oftmals nicht physisch auf der untersuchten Platte enthalten oder werden nur temporär auf der lokalen Platte gecached.
· Die neue Kommandozeilen-Option /LISTSEPARATOR erlaubt es, das Listentrennzeichen festzulegen, das beim Exportieren von Text-Dateien verwendet wird.
· Die neue Kommandozeilen-Option /EXPORTDRIVELIST erlaubt es, den Inhalt der Laufwerksübersicht in eine Textdatei zu schreiben.
· Das Excel 2007 Format (Dateiendung XLSX) wird jetzt von TreeSize Professional unterstützt. Dies ermöglicht nun auch das Erstellen von Excel-Dateien mit mehr als 65000 Zeilen.
· In allen Excel-Dateien, die von TreeSize Professional gespeichert werden, sind nun Einheiten und Zahlen voneinander getrennt. Dies erleichtert das Durchführen von Berechnungen mit den Größenwerten. Beim Speichern der "Details" Liste in eine Excel-Datei werden nun nur die selektierten Einträge gespeichert, falls mehr als ein Eintrag selektiert ist.
· Alle Editoren für Suchmuster (z.B. Ansicht > Optionen > Filtern, die benutzerdefinierte Dateisuche, etc.) haben jetzt Checkboxen vor den einzelnen Suchmustern. Dies erlaubt es, einzelne Suchmuster temporär zu deaktivieren, ohne sie gleich löschen zu müssen.
· Die Professional Edition kann nun als portable Version installiert werden, z.B. auf einem USB-Stick. Die Einstellungen werden dann im Pfad der Anwendung gespeichert.
· TreeSize Professional speichert jetzt seine Einstellungen in einer XML-Datei im Profil des Benutzers, und nicht mehr in der Windows Registry.
· Kacheldiagramm: OLE Drag Unterstützung wurde zum Kacheldiagramm hinzugefügt, Drop-Unterstützung wird in der nächsten Version folgen. Dies erlaubt es, Ordner vom Kacheldiagramm an einen anderen Platz zu verschieben oder zu kopieren.
· Kacheldiagramm: Strg + und Strg - können nun zum Zoomen des Kacheldiagramms benutzt werden. Die Cursor-Tasten, Pos1, Ende, Bildá und Bildâ können zum Scrollen des vergrößerten Kacheldiagramms verwendet werden.
· Es wurde ein Kontextmenüeintrag hinzugefügt, der es erlaubt, die hinter dem Diagramm "Dateialter" liegenden Daten als Text in die Zwischenablage zu kopieren.
· Strg+X führt im Verzeichnisbaum und der "Details" Liste die "Ausschneiden" Operation des Windows Explorer aus. Das Tastaturkürzel für automatische Einheiten lautet nun Strg+U.
· Beim Speichern eines Scans in eine XML-Datei wird nun das dazugehörige Stylesheet mit zur exportierten XML-Datei kopiert und mittels eines relativen Pfades referenziert. Dies erleichtert die Verwendung der XML-Dateien auf Systemen, auf denen TreeSize Professional nicht installiert ist.
· Diverse kleinere Korrekturen und Verbesserungen sind für die Balken-, Torten- und Kacheldiagramme eingeflossen.
· Der Speicherbedarf für die Dateitypen- und Benutzer-Statistik wurde gesenkt.
· Bugfix: In der Duplikatsuche, wenn alle Einträge mit Hilfe des Kontextmenüs selektiert wurden (also auch die Dateigruppen selektiert waren), wurden die Dateigruppen ebenfalls markiert, obwohl sie eigentlich keine Checkbox hatten. Dies führte dann zu einem Fehler in der Funktion "Markierte Dateien verschieben".
· Bugfix: Es wurde ein Speicherloch geschlossen, dass unter Windows Vista auftrat, wenn ein Scan mit aktivierter Option "NTFS Alternate Data Streams und NTFS Hardlinks erkennen" durchgeführt wurde.
· Bugfix: Es ist jetzt möglich, Windows-Domänen und Servernamen in der Art \\Domain oder \\Server auf der Kommandozeile zu übergeben. Dies funktionierte bereits in der Benutzeroberfläche, verursachte jedoch einen Fehler an der Kommandozeile.
· Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V5.1.2 (21.07.2008)

· Alle Listen haben jetzt eine Schaltfläche in ihrer Symbolleiste, die das Speichern ihres Inhalts in einer Excel-Datei ermöglicht.
· Das Exportieren des Kacheldiagramms sowie des Diagramms für das Dateialter ist nun ebenfalls im Dialog "TreeSize Scan planen" möglich. Hier wurde außerdem eine Funktion zum Speichern der Kommandozeile in eine Batch-Datei zum Kontextmenü des Textfeldes hinzugefügt, das die aktuelle Kommandozeile anzeigt.
· Die kontextsensitive Hilfe über die F1 Taste funktioniert nun auch unter Windows Vista.
· Das Abfragen der Versionsinformationen aus EXE, DLL und ähnlichen Binärdateien ändert nun nicht mehr deren Datum des letzten Zugriffs.
· Dateisuche: Es ist jetzt möglich nach Dateien zu suchen, deren Pfad länger als eine vorgegebene Anzahl von Zeichen ist. Dies erlaubt es Pfade mit mehr als 255 Zeichen zu finden, die beispielsweise im Windows Explorer Probleme bereiten.
· Dateisuche: In der benutzerdefinierten Dateisuche werden auf dem Reiter "Datum" nun auch angegebene Werte im Eingabefeld "Seit" für den nächsten Start und in XML-Dateien gespeichert (Datei > Suchoptionen speichern). Bislang wurde lediglich die (daraus berechnete) obere oder untere Grenze des Intervalls gespeichert.
· Bugfix: Die bei "Seit" angegebenen Werte funktionierten nicht wie erwartet, wenn negierte Datumsfilter ("Ohne Änderung", "Ohne Zugriff" und "Nicht Erstellt") ausgewählt waren.
· Bugfix: Die Kontrollelemente zur Angabe eines Datumswertes haben den Zustand der eingebetteten Checkbox nicht immer korrekt gemeldet. Dies konnte nach einer Änderung des Check-Status zu falschen Suchergebnissen in der Dateisuche führen.

Änderungen in V5.1.1 (10.04.2008)

· TreeSize kann jetzt beim Durchsuchen oder Scannen der Festplatte mit Pfaden umgehen, die aus mehr als 255 Zeichen bestehen.
· TreeSize komprimiert bzw. dekomprimiert nun auch Dateien mittels NTFS Kompression, die als schreibgeschützt markiert sind.
· Für große Verzeichnisbäume wird das Kacheldiagramm jetzt wesentlich schneller gezeichnet.
· Die Kompatibilität mit 64Bit Systemen wurde verbessert.
· Dateisuche: Beim Speichern der Ergebnislisten wird nun auch die Sichtbarkeit und die Reihenfolge der einzelnen Spalten berücksichtigt.
· Dateisuche: Beim Verschieben von Dateien wird nun den optional erstellbaren Verknüpfungen eine Beschreibung hinzugefügt, die den neuen Pfad, den durchführenden Benutzer sowie das Datum der Operation enthält.
· Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V5.1 (04.03.2008)

· Eine Reihe von Verbesserungen beim Kacheldiagramm sind eingeflossen:
- Wenn ein Ordner keine Unterordner enthält, werden nun die in der Dateitypen-Statistik erhobenen Werte im Kacheldiagramm angezeigt.
- Durch einige grafische Verbesserungen konnte die Darstellung der Verzeichnishierarchie übersichtlicher gestaltet werden.
- Eine Legende der verwendeten Farben wurde hinzugefügt.
- Das Kacheldiagramm kann nun gezoomt und gescrollt werden.
· Durch verbessertes Multithreading werden Scans bis zu zwei Mal schneller durchgeführt.
· Das Kontextmenü des Explorer ist nun sowohl als Untermenü in den Diagrammen verfügbar, als auch für die Wurzel eines Scans.
· Wenn Sie Daten in eine Datei exportieren wollen, bietet Ihnen der Dialog "Speichern unter" nun die Möglichkeit, die neu geschaffene Datei gleich im Anschluss an die Speicherung wieder zu öffnen.
· Wenn Sie die Ergebnisliste der Statistik über Dateierweiterungen abspeichern wollen, bietet Ihnen der Dialog "Speichern unter" die Option, nur die aufgeklappten Dateigruppen zu speichern. Dieses Ergebnis entspricht dann genau der Darstellung auf dem Bildschirm.
· Die kontextsensitive Hilfe wurde verbessert. Über die Taste F1 sollten nun immer der passende Abschnitt des Online-Handbuchs angezeigt werden.
· Es wurde eine neue Spalte zur Details-Ansicht und den Export-Formaten hinzugefügt, die die Fehlermeldung anzeigt, wenn auf einen Ordner nicht zugegriffen werden konnte. Dies ist besonders für geplante Scans nützlich, die ihre Ergebnisse in eine Excel-, Text- oder HTML-Datei exportieren (Dieses Feature ist nur in der Professional-Version verfügbar).
· Wenn der Modus für gemischte Größendarstellung aktiv ist, wird nun auch in den Diagrammen eine passende Größeneinheit für die Darstellung ausgewählt.
· Man kann nun aus dem Diagramm "Historie" einzelne Werte mit Hilfe des Kontextmenüs löschen.
· Sowohl die Statistik über Nutzer als auch die über Dateierweiterungen ermöglichen es nun, mehrere Einträge auszuwählen. Dies ist insbesondere für den Export und den Druck nützlich, wenn man nur Teile der Ergebnislisten weiter verwenden möchte.
· Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Dateisuche:

· Den Ergebnislisten wurden neue Spalten für Dateiattribute, Versionsnummer binärer Dateien, Zugriffsrechte und das Erstellungsdatum hinzugefügt. Nicht alle diese Spalten sind standardmäßig aktiviert, was jedoch über das Menü "Ansicht" geändert werden kann.
· Der Dialog "Markierte Dateien verschieben" bietet nun die Möglichkeit am jeweiligen Ursprungsort der verschobenen Dateien eine Verknüpfung einzufügen, die auf den neuen Speicherort der Datei verweist.
· In der benutzerdefinierten Suche der Dateisuche finden Sie unter dem Reiter "Größe/Attribute" die Möglichkeit, nach Dateien mit NTFS Alternate Data Streams zu suchen. Sollten Alternate Data Streams gefunden werden, addiert die Dateisuche die Größe der ADS zu der ursprünglichen Dateigröße hinzu und fügt in der betreffenden Zeile ein "*" in die Spalte "Attribute" ein. Die Überprüfung auf ADS ist jedoch langsam und benötigt darüber hinaus Lesezugriff auf die zu überprüfende Datei.

Änderungen in V5.0 (23.11.2007)

· Es ist jetzt möglich, mehrere Scans unter einer virtuellen Wurzelverzeichnis zusammenzufassen. Dieses zeigt dann Gesamtwerte für alle Scans an, die zu dieser Gruppe gehören. Auf diese Weise können auch mehrere Scans für den Export und den Druck zusammengefasst werden. Sie erreichen diese Funktion im Kontextmenü des Wurzelverzeichnisses eines Scans oder über das Menü "Extras".
· Ein neuer Diagrammtyp mit dem Namen Kacheldiagramm wurde hinzugefügt. Dieser zeigt eine hierarchische Sicht auf die Dateisystemstruktur. In diesem Kacheldiagramm wird jeder Ordner als Rechteck dargestellt, in dem wiederum seine Unterordner, ebenfalls als Rechteck dargestellt, enthalten sind.
· Die Liste auf dem Reiter "Dateitypen" kann nun optional Dateitypen in Gruppen wie "Audio-Dateien", "Video-Dateien" und System-Dateien" zusammenfassen. Diese Funktion kann über eine neue Schaltfläche in der Symbolleiste oberhalb der Liste ein- und ausgeschaltet werden.
· Die Reiter "Dateitypen", "Benutzer" und "Dateialter" besitzen nun eine Funktion, mit der alle Dateien, die zum selektierten Element gehören, angezeigt werden können.
· Die Selektion der jeweils selektierten Elemente in den diversen Listen von TreeSize wird nun ähnlich wie bei Windows Vista dargestellt. Dies macht farbigen Text und die kleinen eingebetteten Balkengrafiken leichter lesbar.
· Die TreeSize Spalte für den Windows Explorer wird nun auch auf 64Bit System unterstützt. Auf 64Bit Windows Systemen wird das .Net Framework V2.0 oder höher benötigt. Leider hat ein Microsoft Mitarbeiter offiziell bestätigt, dass eine solche Explorer Erweiterung unter Windows Vista technisch nicht mehr möglich ist.
· Die Anzahl der Dezimalstellen kann nun im Menü "Ansicht" statt in den Optionen eingestellt werden.
· Die Farben des Farbverlaufs, den TreeSize Professional im Hintergrund jedes Verzeichnisses im Verzeichnisbaum anzeigen kann, können nun im Optionen-Dialog ausgewählt werden.
· Im Optionen-Dialog kann nun die maximale Anzahl von Threads eingestellt werden, die TreeSize Professional maximal zum Untersuchen eines Pfades erstellt. Wie bisher wird TreeSize aber versuchen, die Anzahl der Threads der Systembelastung anzupassen und daher auch weniger Threads als das Maximum verwenden.
· Im Optionen-Dialog können nun die Zeitintervalle verändert werden, die für die Erstellung der Statistik auf dem Reiter "Dateialter" verwendet werden.
· TreeSize Professional hat nun eine neue Option, deren Aktivierung dazu führt, dass auch Hardlinks und Alternate Data Streams bei der Berechnung des belegten Platzes berücksichtigt werden. Die führt zu noch genaueren Ergebnissen, verlangsamt allerdings auch den Scan.
· Im Menü "Ansicht" kann nun auch die Größeneinheit "Bytes" ausgewählt werden.
· Die Optionen des Excel-, Text- und HTML-Exports erlauben nun die Einstellung, ob Größeneinheiten wie "KB", "MB" or "%" zu den exportierten Werten hinzugefügt werden sollen oder nicht. Ohne die Einheiten werden auch die Tausender-Trennzeichen weggelassen, was die Weiterverarbeitung der exportierten Werte vereinfachen kann. Diese Einstellung ersetzt die Option "Datei / Export / Rohdaten verwenden" aus V4.
· Die neuen Kommandozeilen-Optionen /FILEAGESCHART und /HISTORYCHART erlauben das Speichern der Diagramme auf den Reitern "Dateialter" und "Historie".
· Die hinzugefügte Kommandozeilen-Option /TOPFILESLIST erlaubt nun das Speichern der Top 100 Dateiliste.
· Die Spalten, die bei der Funktion "Kopiere Dateiliste" verwendet werden, werden nun bestimmt durch die Einstellungen für den Text-Export im Optionen-Dialog von TreeSize Professional.
· Die ausführbare Datei wurde umbenannt in "TreeSize.exe".
· Die Unterstützung für Windows 98 und ME wurde beendet. Registrierte Kunden können sich aber weiterhin die Windows 98/ME kompatible V4 von TreeSize aus unserem Kundenbereich herunterladen.
· Ein neues, hochauflösenderes Icon wird nun verwendet.

Dateisuche:

· Eine weiterer Suchtyp "Benutzerdefiniert" wurde hinzugefügt. Dieser Suchtyp erlaubt es, die Suchkriterien frei zu definieren aus einer Kombination von Dateiname, Datum, Größe, Attribute und Besitzer. Wie bei den anderen Suchtypen kann die Ergebnisliste gedruckt oder exportiert werden.
· Jetzt können ganze Server, ganze Domänen oder sogar die gesamte Netzwerkumgebung durchsucht werden. TreeSize Professional sucht automatisch nach PCs und allen Freigaben auf diesen (inklusive versteckter Freigaben) und durchsucht alle, die es findet.
· Verbesserte Unterstützung für Multithreading, insbesondere bei der Berechnung der MD5-Prüfsummen. Dies sollte eine Beschleunigung auf Multi-Core Maschinen bewirken.
· Es ist nun möglich, einfache Listen von Pfaden ("DIR /B /S"-Format) zu importieren und zu exportieren. Dies vereinfacht die Weiterverarbeitung von Suchergebnissen und erlaubt ferner, Dateilisten in TreeSize Professional zu importieren um sie weiterzuverarbeiten.
· In einer XML-Datei gespeicherte Such-Optionen können nun der Dateisuche von TreeSize Professional an der Kommandozeile übergeben werden. Dies vereinfacht beispielsweise zeitgesteuerte Scans mit vordefinierten Such-Optionen.
· Die Funktion "Markierte Dateien verschieben" erlaubt nun das Protokollieren der durchgeführten Operationen in einer Log-Datei.
· Die Ergebnislisten der Dateisuche können nun als Ausgangspunkt für Drag&Drop-Operation verwendet werden.
· Die neue Funktion "Alle bis auf die neueste markieren" wurde dem Kontextmenü der Suche für doppelte Dateien hinzugefügt.
· Die neue Funktion "Duplikate durch Hardlinks ersetzen" im Kontextmenü der Suche für doppelte Dateien erlaubt es, alle Duplikate durch Hardlinks zu ersetzen. Auf diese Weise können alle Dateien an ihrem Platz verbleiben, belegen aber nur einmal Plattenplatz.

Änderungen in V4.3.2:

· Auf 64Bit Windows Systemen deaktiviert TreeSize für seine Threads nun die Filesystem Redirection von Windows. Diese sorgt dafür, dass einige Systemordner im Windows Verzeichnis vor 32Bit Prozessen verborgen bleiben.
· Bugfix: Die Option "Dateien ausschließen, die in den letzten XX Stunden geändert wurden" der TreeSize Dateisuche hat nicht die lokale Zeitzone berücksichtigt.
· Bugfix: Die Duplikatsuche mittels MD5-Prüfsummen hat schreibgeschützte Dateien nicht mit einbezogen.

Änderungen in V4.3.1:

· Wenn die Schaltfläche "Übergeordnetes Verzeichnis" verwendet wird, der ausgewählte Order der Ausgangspunkt des Scans und kein Laufwerk ist, so fragt TreeSize nun, ob der übergeordnete Ordner untersucht werden soll.
· Bugfix: Einige der initialen Standardwerte unter Extras / Optionen / Spalten waren in V4.3 falsch.
· Dateisuche: Die Funktion "Ergebnisse Speichern" fragt nun, ob es bereits existierende Dateien überschreiben, oder die weiteren Ergebnisse an diese anhängen soll.
· Dateisuche: Die Funktion "Ergebnisse Speichern" erzeugt nun ebenfalls Unicode Textdateien.
· Dateisuche: Bei der Suche nach doppelten Dateien wurde der Vergleich von sehr großen Dateien mit und ohne MD5-Prüfsumme verbessert.
· Bugfix: Die Dateisuche der Personal Edition hat die ausgewählten Ordner nach einem Neustart nicht korrekt wieder hergestellt.
· Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V4.3:

· Es wurde eine einfache Historie zu TreeSize hinzugefügt: Wann immer ein Pfad oder Laufwerk untersucht worden ist, merkt sich TreeSize dessen Größe (nicht aber die Größe der Unterordner) und zeigt die Entwicklung der Größe dieses Pfades in einem Diagramm auf dem neuen Reiter "Historie" an.
· XML Vergleich: Es ist nun möglich, zwei verschiedene Dateisystemstrukturen zu vergleichen. Falls die beiden Pfade nicht übereinstimmen fragt TreeSize den Benutzer nun, ob er fortfahren möchte.
· Dateisuche: Die Suche nach doppelten Dateien kann nun Dateien auch auf Basis der MD5-Prüfsumme des Dateiinhalts vergleichen. Dies ermöglicht es, echte Duplikate zu finden, die sich aber in ihrem Namen oder ihrem Datum unterscheiden. Der Nachteil dieses Verfahrens ist, dass die Berechnung der MD5-Prüfsumme signifikant länger dauert als der einfache Vergleich von Name, Datum und Größe.
· Dateisuche: Das Kontextmenü einer Datei-Gruppe in der Ergebnisliste "Doppelte Dateien" bietet nun die Möglichkeit, Dateien Byte für Byte zu vergleichen und nicht identische Dateien werden entfernt.
· Dateisuche: Alle Optionen auf dem Reiter "Anzeigeoptionen" befinden sich nun im Menü "Ansicht". So stehen diese auf allen Reitern zur Verfügung, ohne das zunächst auf den früheren Reiter "Anzeigeoptionen" gewechselt werden muss.
· Dateisuche: Für jedes Element in den Ergebnislisten wird jetzt ein langer Tooltip angezeigt, der detaillierte Informationen zu jeder Datei enthält.
· Dateisuche: Für Ordner der Art $NTUninstall*$, die standardmäßig bei der temporären Dateisuche aufgelistet werden, wird nun auch die Ordnergröße angezeigt.
· Dateisuche: Weitere Elemente wurden zum Hauptmenü hinzugefügt: Extras / Papierkorb leeren, Hilfe / F.A.Q., Hilfe / Auf Update überprüfen, Hilfe / Info.
· Dateisuche: Eine neue Option erlaubt es, Cookies mit in die Suche nach temporären Internetdateien aufzunehmen.
· Dateisuche: Wenn die markierten Dateien verschoben werden, so wird dem Pfad nun ein Prefix mit dem Laufwerk vorangestellt. Dies macht es einfacher, verschobene Dateien später wieder herzustellen, wenn mehrere Laufwerke durchsucht worden sind.
· Bugfix: Die Funktion zum Verschieben der markierten Dateien in ein anderes Verzeichnis hat gelegentlich die Pfade der verschobenen Dateien vertauscht.
· Bugfix: Es wurde eine Fehlermeldung korrigiert, die unter Windows Vista aufgetreten ist, wenn sich jemand mittels einer Remotedesktopverbindung in eine laufende Sitzung verbunden hat, auf der sich bereits ein TreeSize auf dem Bildschirm befand.

Änderungen in V4.2.2:

· Bugfix: Bei der Anzeige der Suchergebnisse der Dateisuche kam es unter Umständen zu einer Fehlermeldung.

Änderungen in V4.2.1:

· Bugfix: Gelegentlich kam es zu einer unkritischen Fehlermeldung in TreeSize, nachdem ein Ordner über das Kontextmenü gelöscht wurde.
· Dateisuche: Über eine neue Checkbox für die Suche nach doppelten Dateien kann der Benutzer nun entscheiden, ob der Exclude-Filter verwendet werden soll oder nicht.
· Dateisuche: Der Exclude-Filter akzeptiert jetzt die Platzhalter '*' und '?'.
· Bugfix: Die Suche nach Doppelten Dateien hat unter bestimmten Umständen nicht alle doppelten Dateien aufgelistet. Andere wurden in mehrere Gruppen aufgeteilt, weil sich Ihr Zeitstempel geringfügig unterschieden hat.
· XML-Import: Die Fehlerbehandlung und das Abbrechen durch den Benutzer wurden verbessert.
· Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V4.2:

· Im Optionen-Dialog (Extras / Optionen / Untersuchen) kann nun die Priorität für die Threads festgelegt werden, die die Untersuchung der Laufwerke und die Dateisuche durchführen. Die Priorität kann dabei so weit reduziert werden, dass nur ungenutzte CPU Zeit (Idle Time) genutzt wird, so dass der Einfluss einer Untersuchung mit TreeSize auf den PC oder Server minimiert wird.
· Die Symbolleiste der Top 100 Dateiliste enthält jetzt eine Schaltfläche zum Löschen der markierten Dateien.
· Die Stylesheet-Datei "Tsizepro.xsl" für die XML-Dateien wurde überarbeitet:
- Sie funktioniert jetzt unter Windows Vista mit dem Internet Explorer 7.
- Die Formatierung und die Geschwindigkeit wurde verbessert.
- Bei der Untersuchung aufgetretene Fehler werden nun durch ein kleines Ausrufezeichen vor dem Verzeichnisnamen angezeigt.
· Wenn die Option "Mountpoints und symbolischen Links folgen" aktiviert ist, folgt TreeSize nun nur noch Links, deren Ziel außerhalb des zu untersuchtenden Verzeichniszweiges liegt. Dies vermeidet zyklische Verweise und das mehrfache Zählen von Ordnern. Das Ziel eines Links wird jetzt außerdem in den langen Tooltips des Verzeichnisbaumes angezeigt.
· Im Hintergrund des Verzeichnisbaumes wird jetzt ein Balkendiagramm in Form eines Farbverlaufs angezeigt, das die Verzeichnisgröße im Vergleich zum gesamten untersuchten Verzeichnisbaum anzeigt. Wir hoffen, Sie mögen diese neue Form der Visualisierung. Falls nicht, können Sie diese in den Optionen abschalten.
· Das Kontextmenü der Liste der Dateitypen und der Benutzer verfügt jetzt über einen Menüpunkt, der es erlaubt, eine Liste der Dateien des selektierten Dateityps bzw. Benutzers in die Zwischenablage zu kopieren.
· Die Statistik der Benutzer wurde um einen Caching-Mechanismus ergänzt, der die Geschwindigkeit einer Untersuchung mit aktivierter Benutzerstatistik deutlich beschleunigt und den Datenverkehr zum Domänen-Controller reduziert.
· Der neue Kommandozeilen-Parameter /SIZEUNIT erlaubt es, die Größeneinheit (KB, MB, GB) zu setzen, die für die Formatierung von Größenangaben verwendet werden soll. Detaillierte Informationen hierzu finden Sie in der Hilfe.
· Der kleine Pfeil, der Mountpoints und symbolische Links kennzeichnet, wird nun auch in der Details Ansicht angezeigt. Versteckte und Systemdateien werden jetzt wie im Windows Explorer mit einem helleren Icon dargestellt.
· Die TreeSize Dateisuche kann jetzt über das Kontextmenü jedes Ordners im Verzeichnisbaum für das betreffende Verzeichnis gestartet werden.
· Dateisuche: Eine neue Suchart erlaubt das Suchen nach doppelten Dateien. Dateien, mit gleicher Größe, gleichem Namen und gleichem Datum werden hier gruppiert gelistet. Diese Funktion wird in den nächsten Versionen noch weiter verbessert werden.
· Dateisuche: Es ist jetzt möglich, die Such-Einstellungen in eine XML-Datei zu speichern und diese wieder zu laden.
· Dateisuche: Die Cache-Dateien des Opera Browsers werden nun ebenfalls gefunden.
· Dateisuche: Die Temporäre Dateisuche verfügt nun über eine Option, die alle Verweise in dem Ordner zuletzt verwendeter Dokumente sucht. Diese Option ist standardmäßig eingeschaltet. Obwohl Windows nur die letzten 15 Einträge im Startmenü unter Dokumente anzeigt, sind in dem Ordner "Zuletzt verwendete Dokumente" im Benutzerprofil Verknüpfungen zu allen jemals geöffneten Dokumenten vorhanden, ohne dass diese eine Zweck erfüllen.
· Dateisuche: Die Anzahl und die Größe der über die Checkboxen markierten Dateien wird jetzt in der Statusleiste angezeigt.
· Dateisuche: Der Dialog zum Speichern der Suchergebnisse verfügt jetzt über zwei neue Optionen. Die eine ermöglicht das Speichern aller Ergebnislisten (statt nur der aktiven). Die zweite erlaubt es, nur die markierten Dateien zu speichern.
· Dateisuche: Der Kommandozeilen-Parameter /MOVETO ersetzt /MOVETOZIP und erlaubt es als Ziel, zusätzlich zu einer ZIP-Datei, nun auch einen Verzeichnispfad oder den Papierkorb für die zu verschiebenden Dateien anzugeben. Detaillierte Informationen hierzu finden Sie in der Hilfe.
· Dateisuche: Wir der Menüpunkt "Zum Ausschluss-Filter hinzufügen" aus dem Kontextmenü der Ergebnislisten ausgewählt, so werden jetzt alle passenden Suchergebnisse aus den Listen entfernt.
· Dateisuche: In den Anzeigeoptionen kann nun festgelegt werden, ob für komprimierte Dateien deren normale Größe oder deren komprimierte Größe angezeigt werden soll.
· Die Unterstützung für Windows NT4 wurde eingestellt.

Änderungen in V4.1.1:

· Der Menüpunkt "Aus TreeSize entfernen (temporär)" ist nun auch im Kontextmenü der Details-Liste vorhanden. Auf diese Weise können auch mehrere Ordner auf einmal entfernt werden.
· Fehler, die während des Scans aufgetreten sind (wie z.B. Zugriff verweigert), werden nun mit in den XML-Report gespeichert.
· Wird der gerade selektierte Ordner im Verzeichnisbaum gelöscht, so wird nun automatisch der nächste, oder falls nicht vorhanden, der übergeordnete Ordner ausgewählt.
· Eine neue Checkbox auf dem Reiter "Ansicht" des Optionen Dialogs erlaubt es einzustellen, dass Icons ausschließlich auf Basis der Dateiendung bestimmt werden. Dies ist wesentlich performanter, insbesondere auf Netzwerk-Laufwerken, da Windows ansonsten viele Dateien öffnet um nachzuschauen, ob sich darin Icons befinden. Standardmäßig ist diese Option aktiviert.
· Das Diagramm auf dem Reiter "Dateialter" kann nun über eine neue Symbolleiste oder das Kontextmenü gedruckt, kopiert oder gespeichert werden.
· Unter Windows Vista gibt es im Startmenü von Windows nun eine zusätzliche Verknüpfung, die TreeSize mit vollen Administrator-Rechten startet.
· Ein neuer Menüpunkt im Menü "Tools" erlaubt es, TreeSize erneut mit vollen Administrator-Rechten zu starten.
· Die Dateisuche berücksichtigt nun die Einstellung "Mountpoints und symbolischen Links folgen" aus dem Hauptprogramm, wenn sie den Verzeichnisbaum durchsucht. Wir empfehlen, diese Option unter Windows Vista stets deaktiviert zu lassen da Windows Vista exzessiv von symbolischen Links Gebrauch macht, was somit eine große Menge doppelter Ergebnisse liefert.
· Die Kommandozeilen-Option /SEARCH:Start markiert nun automatisch alle gefundenen Dateien in der Dateisuche.
· Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V4.1:

· Die Unterstützung für Multithreading wurde verbessert, was insbesondere Netzwerk-Scans bis zu zweimal schneller macht.
· Ein neuer Reiter "Dateialter" wurde auf der rechten Seite hinzugefügt. Er zeigt die Verteilung des Alters der Dateien im gerade ausgewählten Verzeichnis an.
· Die Listen für die Dateitypen, die Benutzer und die Top-100-Dateien sowie die Ergebnislisten der Dateisuche haben nun ein Kontextmenü für die Kopfzeile. Hiermit können einzelne Spalten ein- und ausgeblendet werden. Darüberhinaus können die Spalten nun per Drag&Drop umsortiert werden. Die Einstellungen werden beim Verlassen von TreeSize gespeichert und beim nächsten Start wiederhergestellt.
· Die Liste der Dateitypen wird nun schneller gefüllt.
· Der Reiter "Details" verfügt nun auch über eine Symbolleiste, die wie üblich im Hauptmenü unter "Ansicht" / "Symbolleisten" ein- und ausgeblendet werden kann.
· Ordner, die aufgrund eines Fehlers nicht durchsucht werden konnten, werden nun durch ein kleines Ausrufezeichen im Verzeichnisbaum markiert. Die Fehlermeldung wird im Tooltip des Ordners angezeigt.
· Eine neue Option erlaubt es, neben jedem Datumswert (Letzter Zugriff, Letzte Änderung, Erstellungsdatum) zusätzlich auch die Uhrzeit anzuzeigen.
· Das Menü "Tools" verfügt jetzt über einen Menüpunkt, welcher den Konfigurationsdialog für die Systemwiederherstellung von Windows öffnet. Die Systemwiederherstellung reserviert standardmäßig 10-15% jedes Laufwerks und ist eine gute Möglichkeit, weiteren Speicherplatz auf der Festplatte zu gewinnen.
· Für die Spalte "TreeSize" im Windows Explorer kann nun die Einheit und die Anzahl der Nachkommastellen auf dem neuen Reiter "Explorer-Erweiterungen" in den Optionen konfiguriert werden. Außerdem kann diese Explorer-Erweiterung hier nun komplett deaktiviert werden.
· Der Kontextmenüeintrag "Tiefste Schachtelung finden" steht nun nicht nur für das Wurzelverzeichnis, sondern für jedes Verzeichnis zur Verfügung.
· Die Laufwerksübersicht verwendet nun eine andere Farbe zur Darstellung des freien Platzes, als in der Detailansicht für die Spalte "Prozent" verwendet wird.
· Der Inhalt der Laufwerksübersicht kann jetzt in einem CSV-kompatiblem Format in die Zwischenablage kopiert werden.
· TreeSize Professional ist jetzt kompatibel mit Windows Vista. Der Explorer von Vista kann aber leider nicht mehr durch zusätzliche Spalten erweitert werden, so dass die Spalte "TreeSize" hier nicht zur Verfügung steht.
· Dateisuche: Das Kontextmenü verfügt jetzt über einen Menüpunkt, der die selektierten Einträge mittels NTFS-Kompression komprimiert.
· Dateisuche: Auf dem Reiter "Anzeigeoptionen" können jetzt die in den Ergebnislisten sichtbaren Spalten ausgewählt werden.
· Komprimierte Dateien werden jetzt in einer anderen Farbe dargestellt, genau wie in der Hauptanwendung. Für komprimierte Dateien wird nun deren komprimierte Größe angezeigt und nicht mehr die unkomprimierte.
· Dateisuche: Die Ergebnisliste der Dateisuche zeigt nun den Grund an, warum die Datei hier gelistet wird (z.B. das passende Suchmuster, oder aber dass es sich um eine Verknüpfung ohne gültiges Ziel handelt).
· Dateisuche: Laufwerke, die mittels des Kontextmenüs aus der Laufwerksübersicht entfernt wurden, werden nun auch beim nächsten Start nicht mehr angezeigt.
· Bugfix: Der selektierte Eintrag im Verzeichnisbaum wurde nicht immer korrekt dargestellt.
· Bugfix: Die Dateisuche hat unter Umständen Einstellungen überschrieben, die kurz zuvor in der Hauptanwendung gemacht worden sind, falls die Hauptanwendung zuerst geschlossen wurde.
· Bugfix: Das temporäre Entfernen eines Ordners aus TreeSize mittels des Kontextmenüs während eines laufenden Scans konnte zu einer Fehlermeldung führen.

Änderungen in V4.0.2:

· Die Unterstützung für Multithreading wurde verbessert, was insbesondere Netzwerk-Scans bis zu zweimal schneller macht.
· Ein neuer Reiter "Dateialter" wurde der rechten Seite hinzugefügt. Er zeigt die Verteilung des Alters der Dateien im gerade ausgewählten Verzeichnis an.
· Die Listen für die Dateitypen, die Benutzer und die Top-100-Dateien sowie die Ergebnislisten der Dateisuche haben nun ein Kontextmenü für die Kopfzeile. Hiermit können einzelne Spalten ein- und ausgeblendet werden. Darüberhinaus können die Spalten nun per Drag&Drop umsortiert werden. Die Einstellungen werden beim Verlassen von TreeSize gespeichert und beim nächsten Start wiederhergestellt.
· Die Liste der Dateitypen wird nun schneller gefüllt.
· Der Reiter "Details" verfügt nun auch über eine Symbolleiste, die wie üblich im Hauptmenü unter "Ansicht" / "Symbolleisten" ein- und ausgeblendet werden kann.
· Ordner, die aufgrund eines Fehlers nicht durchsucht werden konnten, werden nun durch ein kleines Ausrufezeichen im Verzeichnisbaum markiert. Die Fehlermeldung wird im Tooltip des Ordners angezeigt.
· Eine neue Option erlaubt es, neben jedem Datumswert (Letzter Zugriff, Letzte Änderung, Erstellungsdatum) zusätzlich auch die Uhrzeit anzuzeigen.
· Das Menü "Tools" verfügt jetzt über einen Menüpunkt, welcher den Konfigurationsdialog für die Systemwiederherstellung von Windows öffnet. Die Systemwiederherstellung reserviert standardmäßig 10-15% jedes Laufwerks und ist eine gute Möglichkeit, weiteren Speicherplatz auf der Festplatte zu gewinnen.
· Für die Spalte "TreeSize" im Windows Explorer kann nun die Einheit und die Anzahl der Nachkommastellen auf dem neuen Reiter "Explorer-Erweiterungen" in den Optionen konfiguriert werden. Außerdem kann diese Explorer-Erweiterung hier nun komplett deaktiviert werden.
· Der Kontextmenüeintrag "Tiefste Schachtelung finden" steht nun nicht nur für das Wurzelverzeichnis, sondern für jedes Verzeichnis zur Verfügung.
· Die Laufwerksübersicht verwendet nun eine andere Farbe zur Darstellung des Freien Platzes als in der Details-Ansicht für die Spalte "Prozent" verwendet wird.
· Der Inhalt der Laufwerksübersicht kann jetzt in einem CSV-kompatiblem Format in die Zwischenablage kopiert werden.
· TreeSize Professional ist jetzt kompatibel mit Windows Vista. Der Explorer von Vista kann aber leider nicht mehr durch zusätzliche Spalten erweitert werden, so dass die Spalte "TreeSize" hier nicht zur Verfügung steht.
· Dateisuche: Das Kontextmenü verfügt jetzt über einen Menüpunkt, der die selektierten Einträge mittels NTFS-Kompression komprimiert.
· Dateisuche: Auf dem Reiter "Anzeigeoptionen" können jetzt die in den Ergebnislisten sichtbaren Spalten ausgewählt werden.
· Komprimierte Dateien werden jetzt in einer anderen Farbe dargestellt, genau wie in der Hauptanwendung. Für komprimierte Dateien wird nun deren komprimierte Größe angezeigt und nicht mehr die unkomprimierte.
· Dateisuche: Die Ergebnisliste der Dateisuche zeigt nun den Grund an, warum die Datei hier gelistet wird (z.B. das passende Suchmuster oder aber dass es eine Verknüpfung ohne gültiges Ziel ist).
· Dateisuche: Laufwerke, die mittels des Kontextmenüs aus der Laufwerksübersicht entfernt wurden, werden nun auch beim nächsten Start nicht mehr angezeigt.
· Bugfix: Der selektierte Eintrag im Verzeichnisbaum wurde nicht immer korrekt dargestellt.
· Bugfix: Die Dateisuche hat unter Umständen Einstellungen überschrieben, die kurz zuvor in der Hauptanwendung gemacht worden sind, falls die Hauptanwendung zuerst geschlossen wurde.
· Bugfix: Das temporäre Entfernen eines Ordners aus TreeSize Professional mittels des Kontextmenüs während eines laufenden Scans konnte zu einer Fehlermeldung führen.

Änderungen in V4.0.2:

· Die Scan-Filter (Ansicht / Optionen / Filter) sind nun Unicode-fähig.
· Bugfix: Das Laden von XML-Reports, in denen fremdsprachige Zeichen enthalten waren, konnte gelegentlich zu Problemen führen.
· Bugfix: Die Kombination der beiden Kommandozeilen-Parameter /OPEN und /EXCEL öffnete zwar die XML-Datei, aber führte keinen Excel-Export aus.
· Bugfix: Der Doppelklick auf eine Datei im Reiter "Diagramm" öffnet nun diese auch bei Ordnern, die keine Unterordner enthalten.
· Diverse kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V4.0.1:

· Bugfix: Das Hinzufügen eines UNC-Pfades zur Liste der Laufwerke in der TreeSize Professional Dateisuche schlug mit einer Fehlermeldung fehl.
· Bugfix: Das Umschalten der Sortierreihenfolge funktionierte in der Liste der Dateitypen und der Benutzer für die erste Spalte nicht.
· Bugfix: Das Öffnen bestimmter XML-Dateien schlug wegen eines internen Überlaufs fehl.
· Weitere kleine Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V4.0:

· TreeSize untersucht einen Verzeichniszweig jetzt mit mehreren Threads. Die Anzahl der Threads wird automatisch der aktuellen Systembelastung angepasst. Aufgrund der Latenz von Festplatten und Netzwerk-Laufwerken reduziert sich die erforderliche Zeit für einen Scan dadurch erheblich.
· Im neuen Fenster "Tools" / "TreeSize Scan planen" können nun bequem TreeSize Professional Scans den "Geplanten Tasks" von Windows hinzugefügt oder editiert werden.
· Das Öffnen, Speichern und Vergleichen von XML-Dateien wurde wesentlich verbessert. Diese Operationen sind nun schneller und benötigen wesentlich weniger Hauptspeicher als in der vorangegangenen Version. Der benötigte Speicherplatz der XML-Dateien wurde ebenfalls reduziert.
· Das Kontrollelement zur Darstellung des Verzeichnisbaumes wurde durch ein schnelleres ersetzt. Dies beschleunigt ganz erheblich das Untersuchen und Aufklappen von Verzeichnissen. Verbleibt die Maus längere Zeit über einem Verzeichnis im Baum, wird ein umfangreicher Tooltip mit detaillierten Informationen zu diesem Verzeichnis angezeigt.
· Die meisten Bereiche von TreeSize sind jetzt Unicode-fähig unter Windows NT/2000/XP/2003. Windows 98/ME werden nach wie vor unterstützt, jedoch mit reduzierten Unicode-Fähigkeiten.
· Der Optionen-Dialog besitzt nun eine Checkbox, mit der darüber entschieden werden kann, ob TreeSize Professional im Explorer-Kontextmenü des aktuellen Benutzers erscheinen soll.
· Eine neue Laufwerksbox in der linken unteren Ecke bietet einen schnellen Überblick über die Größe und den freien Platz der lokalen Laufwerke. Weitere Netzwerklaufwerke können mit Hilfe des Kontextmenüs hinzugefügt werden.
· Die 100 größten Dateien, die während eines Scans gefunden wurden, werden jetzt auf einem eigenen Reiter im rechten Bereich des Hauptfensters angezeigt.
· Drag&Drop Dateisystem-Operationen werden jetzt unterstützt.
· Der HTML-Export ist jetzt UTF8 kodiert und exportiert daher auch Unicode-Verzeichnisnamen korrekt.
· Die Statistik für die Dateitypen zeigt jetzt auch die Windows-Beschreibung und das entsprechende Icon an.
· In den Optionen kann nun auf dem neuen Reiter "Programmstart" festgelegt werden, was TreeSize Professional nach dem Start tun soll, wenn kein Pfad zur Untersuchung übergeben wurde. TreeSize Professional kann dann eine fixe Liste von Pfaden untersuchen, kann die Pfade untersuchen, die bei der letzten Benutzung aktiv waren, oder kann untätig bleiben, was die Standardeinstellung ist.
· Zwei neue Spalten sind für die Detail-Ansicht und alle Exporte verfügbar: "MS Office Autor" und "MS Office Letztes Speicherdatum"
· Das Kontextmenü des Verzeichnisbaumes ermöglicht nun das Erstellen eines neuen Ordners. Das Tastenkürzel für diese Operation ist "Strg+N".
· Die Prozentwerte sind nun mit einem kleinen Balkendiagramm unterlegt, das den jeweiligen Wert visualisiert.
· Es ist jetzt möglich, einzelne Dateien oder einen ganzen Verzeichniszweig mittels der in NTFS eingebauten Kompression zu komprimieren.
· Ab sofort kann unter "Ansicht" / "Optionen" / "Export" / "HTML" ein Style Sheet angegeben werden, das in exportierten HTML-Dateien verwendet wird.
· Die Breite der einzelnen Spalten in den gedruckten Berichten kann jetzt unter "Ansicht" / "Optionen" / "Spalten" / "Gedruckter Bericht" angepasst werden.
· Ein Scan, der mittels der Kommandozeilen-Parametern /OPEN geöffnet oder mit /COMPARE verglichen worden ist, kann jetzt auch wieder mit Kommandozeilen-Parametern wie /XML oder /EXCEL exportiert werden.
· Ein neuer Menüpunkt im Hilfe-Menü ermöglicht es nun, zu überprüfen, ob neuere Versionen von TreeSize Professional verfügbar sind.

Dateisuche:

· Die TreeSize Professional Dateisuche verwendet nun mehrere Threads pro Laufwerk und reduziert so die notwendige Zeit, um ein Laufwerk zu durchsuchen.
· Die Listen-Kontrollelemente wurden durch schnellere ersetzt, was gerade bei einer großen Anzahl von Ergebnissen die Performance der Suche und beim Durchführen von Operationen verbessert.
· Die selektierten Elemente einer Liste können nun mittels des Kontextmenüs in die Zwischenablage kopiert werden.
· Die Dateisuche unterstützt jetzt Unicode-Datei- und -Ordnernamen.
· Die Performance und Zuverlässigkeit der Funktion "Markierte Dateien verschieben" wurde verbessert.
· Das Verschieben der markierten Dateien in eine ZIP-Datei und das Speichern der Ergebnisse in eine Textdatei verfügen jetzt über eine Fortschrittsanzeige.
· Das Abfragen der Datei-Besitzer kann jetzt in den "Optionen für Anzeige" deaktiviert werden. Das Abfragen des Datei-Besitzers ist unter Windows eine relativ langsame Operation.


Tipps & Anmerkungen

Navigation: »No topics above this level«

Tipps & Anmerkungen

 Return to chapter overview
· Besonders auf großen Netzwerklaufwerken kann ein Scan sehr lange dauern. Sie können in diesem Fall auch Scans über Nacht mit Hilfe von zeitgesteuerten Untersuchungen der Professional Edition durchführen und die Ergebnisse beispielsweise in einer XML-Datei speichern. Diese Daten können später wieder in TreeSize Professional geladen und analysiert werden.
· Das Datum des letzten Zugriffs ist das Datum, an welchem eine Datei zuletzt benutzt oder geladen wurde. Für Programme oder DLLs ist dies zum Beispiel das Datum, an dem Sie zuletzt ausgeführt wurden, und für Grafiken das Datum, an dem sie zum letzten Mal angezeigt worden sind. Wenn also auf eine Datei seit längerer Zeit nicht zugegriffen wurde, wird diese auf Ihrem System wahrscheinlich nicht mehr benötigt. Das Datum des letzten Zugriffs kann dazu verwendet werden, überflüssige Dateien zu identifizieren.
· Verwenden Sie die TreeSize-Dateisuche, um überflüssige Dateien auf Ihren Laufwerken zu suchen.
· Im Hauptfenster unterstützt TreeSize Professional Dateisystem-Operationen mittels Drag&Drop.
· Alle Verzeichnisse, die im Verzeichnisbaum in der linken Hälfte des Fensters sichtbar sind, werden auch im gedruckten Bericht oder der exportierten Datei zu sehen sein. Sie können in den Optionen aber auch einstellen, dass stets der gesamte Verzeichnisbaum exportiert bzw. gedruckt wird.
· Die Einstellungen für Filter und Benutzerdefinierte Blockgröße in den Optionen werden beim Beenden nicht gespeichert, um bei der nächsten Benutzung von TreeSize Professional unerwartete Ergebnisse zu vermeiden.
· Verwenden Sie die CD-ROM Blockgröße, um zu sehen, wie viel Platz ein Verzeichnis auf einer CD oder DVD mit ISO-Dateisystem belegen würde.
· Im Papierkorb werden Sie nicht dieselbe Darstellung wie im Explorer sehen. Dies ist notwendig, um den tatsächlich belegten Platz und das Datum des letzten Zugriffs für die einzelnen Dateien zu bestimmen.
· Sie können alle freigegebenen Laufwerke einer Domäne scannen, indem Sie den Namen der Domäne einfach in die Laufwerksbox von TreeSize Professional eingeben.
· TreeSize Professional wird mit einer XSLT-Datei ausgeliefert, welche die Daten in einer Scan Report XML-Datei für die Darstellung in XSLT-fähigen Browser konvertiert (z.B. Firefox >V1.0 oder Internet Explorer >V5.5).
· Für die kontinuierliche Überwachung und Verwaltung großer Server empfehlen wir Ihnen unser Produkt SpaceObServer, das Laufwerke mittels eines Hintergrunddienstes einliest und seine Daten in einer SQL-Datenbank ablegt. Es benötigt wesentlich weniger Hauptspeicher und bietet deutlich flexiblere Berichtsfunktionen wie z.B. Historien. Mehr über dieses Produkt erfahren Sie unter: http://www.jam-software.de/spaceobserver /


TreeSize Spalte für den Explorer

Navigation: »No topics above this level«

TreeSize-Spalte für den Explorer

 Return to chapter overview

TreeSize Professional wird jetzt mit einer Shell-Erweiterung ausgeliefert, die dem Windows Explorer eine zusätzliche Spalte hinzufügt. Diese Spalte zeigt die Größe nicht nur für Dateien, sondern auch für Ordner an und ist dazu gedacht, sich einen schnellen Überblick zu verschaffen. Die Spalte kann im Windows Explorer unter Ansicht | Details auswählen aktiviert werden, oder über das Kontextmenü der Kopfzeile der Detail-Ansicht des Windows Explorer. Wenn Sie die Spalte im Explorer für sämtliche Ordner eingeblendet haben möchten, müssen Sie dies in den Ordneroptionen des Windows Explorer mit der Schaltfläche Für alle übernehmen konfigurieren. Diese Spalte erfordert Windows 2000 oder XP und kann in den Optionen konfiguriert oder auch komplett abgeschaltet werden. Auf 64Bit Windows Systemen wird das .Net Framework V2.0 oder höher benötigt.

Leider ist es nicht möglich, eine derartige Erweiterung für den Explorer von Windows Vista zur Verfügung zu stellen, da Microsoft hier die verwendete Erweiterungsschnittstelle entfernt hat. Microsoft hat auch offiziell bestätigt, dass eine derartige Erweiterung des Explorer unter Windows Vista nicht möglich ist.


Verschwendeter Platz

Navigation: »No topics above this level«

Verschwendeter Platz

 Return to chapter overview

Der verschwendete Platz ist der ungenutzte Platz in Festplattenblöcken, die nicht komplett gefüllt sind. Dies ist jeweils bei dem letzten (oder einzigen) Block einer Datei der Fall. Behalten Sie immer folgende Formel im Hinterkopf: Größe + verschwendeter Platz = belegter Platz. Windows 95 mit seinem Dateisystem FAT kann abhängig von der Größe der Partition sehr große Blockgrößen haben:

FAT32
Partitionsgröße | Standard-Clustergröße
01 - 08 GB | 4 KB
08 - 16 GB | 8 KB
16 - 32 GB | 16 KB
>32 GB | 32 KB

Wenn Sie beispielsweise eine Partition der Größe 32GB haben, werden darauf Blöcke der Größe 32KB verwendet. Wenn Sie dort nun 10 Dateien mit einer Größe von je 1KB speichern wollen, würden Sie dazu 10*32KB=320KB Ihres Festplattenplatzes benötigen, und 320KB - 10KB = 310KB wären verschwendeter Platz.

Um den verschwendeten Platz zu reduzieren, haben Sie folgende (nicht immer befriedigende) Möglichkeiten:

· Vermeiden Sie FAT32-Partitionen mit einer Größe von mehr als 16GB.
· Ab Windows 2000 gibt es die Möglichkeit, auf einer Partition das NTFS-Dateisystem zu verwenden. Es arbeitet normalerweise mit Blockgrößen von 512 - 4096 Bytes und speichert Daten deshalb am effizientesten von allen Windows-Dateisystemen. Zusätzlich bietet NTFS noch die Möglichkeit, einzelne Verzeichniszweige zu komprimieren.


Hinweise zu NTFS

Navigation: »No topics above this level«

Hinweise zu NTFS

 Return to chapter overview

Das Dateisystem NTFS, das unter dem Betriebssystem Windows NT und dessen Nachfolgern verwendet werden kann, bietet einige besondere Funktionen, die auch Auswirkungen auf TreeSize Professional haben. Im Folgenden werden wir einige dieser speziellen Fähigkeiten und ihre Auswirkungen auf TreeSize Professional beschreiben.

Access Control Lists (Zugriffskontrolllisten)

Unter Windows NT und seinen Nachfolgern kann ein Benutzer die Zugriffsmöglichkeiten anderer Nutzer auf seine Dateien und Ordner einschränken, indem er Benutzern oder Benutzergruppen bestimmte Rechte wie das Lesen, Schreiben, Löschen oder Ausführen von Dateien gewährt oder verweigert. Auf diesem Weg kann ein Benutzer sogar dem Administrator den Zugriff auf seine Dateien und Ordner verwehren. Wenn ein Administrator im Windows Explorer versucht, auf eine solche Datei oder einen solchen Ordner zuzugreifen, wird eine Fehlermeldung "Zugriff verweigert" angezeigt. TreeSize Professional kann solche Verzeichnisse dennoch untersuchen, wenn Sie als Administrator eingeloggt sind, oder als normaler Benutzer, der das Recht hat, Backups durchzuführen. (Diese Einstellung kann bei Windows 2000/2003 unter "Systemsteuerung" / "Verwaltung" / "Lokale Sicherheitsrichtlinie" und bei Windows in der Benutzerverwaltung verändert werden).

Dateibasierte Kompression

NTFS unterstützt die transparente Kompression einzelner Dateien. Derart komprimierte Dateien können gelesen oder geschrieben werden, ohne vorher mit einem externen Programm (de)komprimiert werden zu müssen. Die Dekompression geschieht vielmehr automatisch beim Lesen einer Datei, genauso wie die Kompression beim Schreiben.

Der Platz, den eine komprimierte Datei auf der Festplatte belegt, ist normalerweise geringer als seine eigentliche Größe. Deshalb kann bei komprimierten Verzeichnissen der von TreeSize Professional ermittelte belegte Platz wesentlich kleiner sein als die angezeigte Größe des Verzeichnisses. Der Kompressionsfaktor wird in einer eigenen Spalte der Detail-Ansicht angezeigt. Außerdem können komprimierte Dateien und Ordner in einer anderen Farbe angezeigt werden (diese Funktion kann in den Einstellungen aktiviert werden).

TreeSize Professional kann ganze Verzeichniszweige komprimieren oder dekomprimieren, indem die entsprechenden Funktionen aus dem Kontextmenü des jeweiligen Ordners ausgewählt werden.

Seit Windows 2000 beherrscht NTFS ein weiteres Konzept, das der dateibasierten Kompression ähnelt: Sparse Files. So werden sehr große Dateien genannt, die aber nur in Teilbereichen Daten enthalten. Da das Betriebssystem für die ungenutzten Teilbereiche keinen Platz auf der Festplatte reservieren muss, braucht die Datei weniger Platz auf der Festplatte, als sie eigentlich groß ist. TreeSize behandelt diese Art von Dateien ähnlich wie komprimierte Dateien und berechnet für sie ebenfalls den Kompressionsfaktor.

Reparse-Punkte: Mountpoints und symbolische Links

Seit Windows 2000 unterstützt NTFS Mountpoints und symbolische Links. Ein Mountpoint ist ein existierender Pfad, in den ein anderes Laufwerk "eingehängt" werden kann. Unterhalb dieses Mountpoints findet man dann die komplette Verzeichnisstruktur des eingehängten Laufwerks - ein Buchstabe muss dem eingehängten Laufwerk dabei nicht zugeordnet sein. Auf diese Weise lassen sich viele Laufwerke in einem einheitlichen Dateisystembaum zusammenführen. Symbolische Links funktionieren ähnlich: Hat man beispielsweise ein leeres Verzeichnis C:\Dokumente\Bilder, kann man hier einen symbolischen Link zu E:\Pics erstellen. Anwendungen werden dann den Inhalt von E:\Pics unter C:\Dokumente\Bilder sehen.

Wenn die Einstellung Mountpoints und symbolischen Links folgen aktiviert ist, berücksichtigt TreeSize Professional den Inhalt dieser Ordner beim Untersuchen von Laufwerken. Da diese aber nicht physisch auf dem untersuchten Laufwerk liegen, kann das zu irritierenden Ergebnissen führen.

Alternate Data Streams (ADS)

In einem NTFS Dateisystem besteht eine Datei aus mehreren Datenströmen (Data Streams). Ein Datenstrom beinhaltet Berechtigungsinformationen, ein anderer die eigentlichen Daten.
Zusätzlich können Dateien Alternate Data Streams (ADS) besitzen. Diese beinhalten Daten, genau wie der eigentliche Datenstrom.

Die ADS sind versteckt. Das bedeutet, dass eine Datei mit 1 Byte Daten im eigentlichen Datenstrom noch Hunderte von MB an Daten in ADS versteckt haben kann. Im Windows Explorer würde die Größe einer solchen Datei mit 1 Byte angegeben. Auch auf die Angabe der belegten Größe der Datei haben die ADS keinen Einfluss, obwohl die Datei real einen viel höheren Speicherbedarf auf der Festplatte in Anspruch nimmt.

TreeSize Professional kann ADS in Dateien erkennen und deren Größe zum belegten Speicherplatz hinzu addieren. Die Systemaufrufe zum Auswerten von ADS benötigen eine gewisse Laufzeit, die die Geschwindigkeit der Untersuchungen reduzieren, daher ist diese Option standardmäßig deaktiviert. Sie kann in den Optionen aktiviert werden. Sie können nach Dateien mit Alternate Data Streams mit Hilfe der benutzerdefinierten Dateisuche von TreeSize Professional suchen.

ADS speichern ihren Inhalt in den gleichen Blöcken wie der Main Data Stream. Das bedeutet, wenn eine Datei einen oder mehrere ADS beinhaltet, heißt das nicht automatisch, dass der belegte Speicherplatz der Datei anwächst.

Hardlinks

Ein Hardlink ist ein Verzeichniseintrag für eine Datei. Jede Datei weist mindestens einen Hardlink auf. Auf NTFS-Datenträgern kann jede Datei mehrere Hardlinks besitzen, und daher kann eine Datei in mehreren Verzeichnissen (oder im selben Verzeichnis mit verschiedenen Namen) angezeigt werden. Da alle diese Verbindungen auf dieselbe Datei verweisen, können Programme einen beliebigen Hardlink öffnen und die Datei ändern. Eine Datei wird nur dann aus dem Dateisystem gelöscht, wenn alle Hardlinks zu dieser Datei gelöscht wurden.

Existiert mehr als ein Eintrag für eine Datei, so muss beim Berechnen des belegten Speicherplatzes diese Datei lediglich einmal berücksichtigt werden, egal wie viele Hardlinks existieren. TreeSize Professional kann die Anzahl der Hardlinks bei der Speicherplatzberechnung mit einbeziehen.

Sie können in den Optionen einstellen, ob Hardlinks bei einer Untersuchung berücksichtigt werden sollen, um genauere Werte für den belegten Speicherplatz zu erhalten. Diese Option ist standardmäßig deaktiviert, da die Suche nach Hardlinks einen Scan verlangsamt.


Drucken

Navigation: »No topics above this level«

Drucken

 Return to chapter overview

TreeSize Professional bietet umfangreiche und flexible Druck-Funktionen:

Sie können einen detaillierten Bericht drucken, indem Sie im Datei-Menü Drucke Bericht auswählen oder in der Symbolleiste die Schaltfläche mit dem Druckersymbol verwenden. Der Bericht enthält die Verzeichnisstruktur des untersuchten Ordners inklusive Linien zwischen den Verzeichnissen und den Spalten, die in den Optionen für den Druck festgelegt wurden. Dort können Sie auch wählen, ob die gesamte Ordnerstruktur gedruckt werden soll oder lediglich jene Ordner, die im Verzeichnisbaum im linken Teil des Fensters von TreeSize Professional aufgeklappt sind. So können Sie auf einfache Weise den Umfang des Berichts anpassen.

Wenn die Detailansicht in der rechten Hälfte des Fensters aktiv ist, können Sie den Inhalt eines Ordners drucken, indem Sie Drucke Ordnerinhalt aus dem Datei-Menü wählen. Im Ausdruck sind alle Dateien und Unterordner enthalten, zusammen mit allen auf dem Bildschirm sichtbaren Daten. Wenn in der rechten Hälfte des Fensters ein Diagramm sichtbar ist, können Sie dieses Diagramm ausdrucken, indem Sie Drucke Diagramm aus dem Datei-Menü auswählen.

Verwenden Sie den Menüpunkt Seite einrichten, um die Ränder für den Druck einzustellen. Verwenden Sie den Menüpunkt Drucker einrichten, um einen Drucker auszuwählen und einzurichten. Mit dem Menüpunkt Titel angeben können Sie einen Titel für den Druck und Export festlegen. Standardmäßig besteht dieser aus dem Verzeichnispfad und dem Namen des Laufwerks.


F.A.Q. - Häufig gestellt Fragen

Navigation: »No topics above this level«

FAQ. - Index

 Return to chapter overview
· Allgemein / Kauf & Registrierung
· Hauptprogramm
· Drucken / Export
· Dateisuche


Allgemein / Registrierung

Navigation: F.A.Q. - Häufig gestellt Fragen >

FAQ - Allgemein, Kauf & Registrierung

 Return to chapter overview
F: Welche Betriebssysteme unterstützt TreeSize Professional?
A: Es werden momentan folgende Betriebssysteme offiziell unterstützt: Windows 2000 Professional, Windows 2000 Server, Windows XP, Windows 2003 Server, Windows Vista, inklusive der jeweiligen 64Bit Editionen. Es sollten alle verfügbaren Betriebssystem-Updates und Patches installiert sein und es wird ein Internet Explorer 6 oder höher für die XML Unterstützung benötigt.
F: Kopiert die Installation Dateien ins Windows-Verzeichnis?
A: Nein, alle Dateien von TreeSize Professional werden in den ausgewählten Installationspfad kopiert. Die ausführbare Datei Tsizepro.exe ist sogar ohne eine Installation lauffähig.

F: Unterstützt TreeSize Professional Unicode?

A: Ja, nahezu alle Teile von TreeSize unterstützen Unicode.

F: Wie kann ich TreeSize Professional bestellen? Was kostet ...?
A: Für Fragen bezüglich unserer Preise und dem Erwerb unserer Produkte besuchen Sie bitte unsere Preisliste und die Hilfe-Seite unseres Shops.
F: Welchen Unterschied gibt es zwischen der Professional Edition und der Personal Edition?
A: Die Personal Edition verfügt über die gleichen Funktionen wie die Professional Edition, mit Ausnahme der Unterstützung von Netzwerklaufwerken, Windows Server Systemen, Kommandozeilen Parameter und das Exportieren der Daten.
F: Was ist der Unterschied zwischen der Demoversion und der Vollversion?
A: Die Demoversion erlaubt es Ihnen, unsere Software vor dem Kauf für einen bestimmten Zeitraum zu testen. Die Testphase darf maximal 21 Tage betragen. Darüber hinaus gehende Benutzung der Software ist illegal und verstößt gegen geltendes Recht. Damit unsere Kunden die von uns angebotenen Softwareprodukte in vollem Umfang testen können, enthalten die Demoversionen in der Regel keine signifikanten Einschränkungen. Aber die Software wird Sie während der Testphase gelegentlich an den noch nicht vollzogenen Kauf erinnern.
F: Ich habe Ihr Produkt gekauft. Wie kann ich meine Demoversion jetzt freischalten?
A: Sie müssen sich die Vollversion in unserem Kundenbereich http://www.jam-software.de/customers/ herunterladen. Die Zugangsdaten haben Sie per E-Mail oder auf dem Lizenzschreiben erhalten. Falls Sie die Zugangsdaten nicht mehr haben, können Sie sich diese noch einmal an die E-Mail-Adresse schicken lassen, die Sie beim Kauf verwendet haben.
F: Obwohl ich die Vollversion von TreeSize Professional gekauft habe, wird immer noch "Unregistriert" im Fenstertitel angezeigt. Woran könnte das liegen?
A: Es gibt drei verschiedene Möglichkeiten, warum noch immer "UNREGISTRIERT" im Titel des Fensters erscheint:
1. Sie haben nicht die Vollversion der Software aus unserem Kundenbereich heruntergeladen
2. Sie haben versehentlich noch einmal die Demoversion installiert. (Wurden Sie nach einem Installationsschlüssel gefragt?)
3. Sie haben die Demo- und die Vollversion in verschiedene Verzeichnisse installiert, so dass sich jetzt beide Versionen auf Ihrer Festplatte befinden.

F: Wie aktualisiere ich TreeSize Professional auf die neueste Version?
A: Im Menü "Hilfe" können Sie mit mittels des Menüpunktes "Auf Update überprüfen" feststellen, ob ein Update zur Verfügung steht. Innerhalb Ihres Maintenance Zeitraums können Sie die jeweils neueste Version von TreeSize Professional in unserem Kundenbereich herunterladen. Die Login Informationen für unseren Kundenbereich wurden Ihnen nach dem Kauf per E-Mail zugesendet und sie stehen auch auf dem Lizenzdokument. Um eine vorhandene ältere Version zu aktualisieren, führen Sie einfach die Installation aus. Ihre Einstellungen bleiben dabei erhalten.
F: Warum verwenden Sie keine Aktivierungscodes, mit der man eine Demo- in einer Vollversion umwandeln kann?
A: Wir verwenden keine Aktivierungscodes, da man diese gewöhnlich sehr einfach im Internet finden kann. Wir arbeiten mit unterschiedlichen Test- und Vollversionen. Nach dem Kauf erhalten unsere Kunden einen Zugang zu unserem Kundenbereich, in dem Sie sich die Vollversion mindestens 12 Monate lang herunterladen können. Gegen Aufpreis ist auch der Versand einer CD möglich. Außerdem erhalten Sie einen Installationsschlüssel, der für die Installation benötigt wird. Beides sollte an einem sicheren Platz aufbewahrt werden. Durch eine einfache Installation der Vollversion über die Demoversion bleiben Ihre Daten und Einstellungen erhalten.

F: Ist eine Benutzerlizenz ausreichend, wenn die Software nur auf einen Computer installiert ist, aber 2 oder 3 Benutzer die Software (zu jeweils unterschiedlichen Zeiten) nutzen?

A: Grundsätzlich braucht man soviele Lizenzen, wie es Computer gibt, auf denen das Programm zeitgleich läuft. Wenn also 3 Benutzer zwar auf einem Rechner, aber zu unterschiedlichen Zeiten arbeiten, dann ist eine Lizenz ausreichend. Arbeiten sie jedoch auf unterschiedlichen PCs, dann brauchen sie auch mehrer Lizenzen.


Hauptprogramm

Navigation: F.A.Q. - Häufig gestellt Fragen >

FAQ - Hauptprogramm

 Return to chapter overview

F: Warum ist der belegte Platz, den Windows in den Eigenschaften des Laufwerks anzeigt, größer als der von TreeSize Professional angezeigte?
A: Der Windows Explorer zeigt den physisch auf dem Laufwerk belegten Platz an, während TreeSize den Platz anzeigt, den alle Dateien und Verzeichnisse zusammen unterhalb eines bestimmten Pfades belegen. Stellen Sie bitte sicher, das die Ansicht-Option "Belegter Platz" aktiviert ist, wenn Sie an dem physisch belegten Platz interessiert sind.
Durch fehlende Leserechte kann es ebenfalls dazu kommen, dass TreeSize Professional bestimme Bereiche der Festplatte nicht lesen kann, so dass deren Größe am Ende in der Summe fehlt. Die sollten TreeSize daher möglichst als Administrator starten. Aktivieren Sie "Ansicht > Optionen > Zeige Fehlermeldungen " um einen Hinweis zu erhalten, falls ein Ordner nicht geöffnet werden kann. Das Aktivieren der Einstellung "NTFS Alternate Data Streams und NTFS Hardlinks erkennen" im Optionen-Dialog kann zu noch genaueren Ergebnissen führen, verlangsamt allerdings jeden Scan etwas.
Eine andere Möglichkeit für die Abweichung kann die Verwendung von Software RAID sein, wie es beispielsweise das Windows NTFS Dateisystem bietet. RAID verteilt die Daten auf mehrere Festplatten, die im System aber wie ein einzelnes Laufwerk erscheinen. Häufig werden die Daten redundant gespeichert, so dass der Ausfall einer einzelnen Festplatte zu keinem Datenverlust führt. Allerdings benötigt das Speichern der redundanten Informationen zusätzlichen Platz auf den Festplatten.
Eine weitere Möglichkeit für die Abweichung besteht dann, wenn ein Netzwerklaufwerk lediglich mit einem Unterverzeichnis eines Serverlaufwerks verbunden ist. Der von TreeSize Professional angezeigte belegte Platz kann dann niedriger sein als der physisch auf dem Laufwerk belegte Platz, da TreeSize lediglich den über das Netzlaufwerk zur Verfügung gestellten Teilbereich des Laufwerks untersuchen kann. Über den Platz für Dateien und Verzeichnisse hinaus wird auf einem Laufwerk noch zusätzlicher Platz zum Ablegen von Verwaltungsinformationen benötigt, wie z.B. die Dateibelegungstabelle (FAT) oder der Boot Sektor. Hierfür werden üblicherweise rund 0,5 - 2% des Platzes einer Partition benötigt.
Auf Thinkpad Laptops kann die Rescue&Recovery Funktion sehr viel Platz im Ordner "RRBackup" belegen, der für andere Anwendungen nicht zugänglich ist..
F: Gibt es irgendwelche Beschränkungen in der Menge an Daten, die TreeSize Professional gleichzeitig erfassen kann?
A: Es gibt keine expliziten Beschränkungen in TreeSize Professional. Je mehr Ordner und Dateien der Dateisystembaum hat, der untersucht werden soll, desto mehr freier Speicher wird benötigt, um die gesammelten Informationen abzulegen. Der Speicherbedarf kann reduziert werden, in dem die Statistiken für Benutzer, Dateitypen oder Dateialter in den Optionen abgeschaltet werden.
F: Warum haben alle Dateien auf meiner Festplatte das gleiche Datum für den letzten Zugriff?
A: Windows aktualisiert das Datum des letzten Zugriffs jedes Mal, wenn eine Anwendung (lesend) auf eine Datei zugreift. Viele Backup-Programme und Viren-Scanner greifen regelmäßig oder täglich auf viele oder alle Teile der Festplatte zu und verändern so das Datum des letzten Zugriffs.
F: Warum bezieht TreeSize Professional nicht das Laufwerk in seine Berechnungen mit ein, das ich über die Datenträgerverwaltung von Windows in einem NTFS-Ordner bereitgestellt habe?
A: Durch Einschalten der Option "Mountpoints und symbolischen Links folgen" in den Einstellungen von TreeSize Professional können Sie festlegen, ob Mountpoints und symbolischen Links gefolgt werden soll oder diese nicht in die Berechnungen einfließen sollen.
F: Das Untersuchen von Serverlaufwerken über das Netzwerk ist sehr langsam. Kann man dies beschleunigen?
A: Das Untersuchen von Laufwerken über das Netzwerk ist normalerweise wesentlich langsamer als das Untersuchen lokaler Laufwerke, da bei Zugriffen über das Netzwerk die Bandbreite geringer und der Overhead höher ist. Serverlaufwerke sind außerdem meist wesentlich größer und enthalten mehr Dateien. Sie können die Scans aber z.B. auf dem Server selbst durchführen oder mit Hilfe der Kommandozeilen Parameter nächtliche Untersuchungen durchführen. Netzwerklaufwerke können nur mit der Professional Edition untersucht werden.
Für die kontinuierliche Überwachung und Verwaltung großer Server empfehlen wir Ihnen unser Produkt SpaceObServer, das Laufwerke mittels eines Hintergrund-Dienstes einliest und seine Daten in einer SQL-Datenbank ablegt. Es benötigt wesentlich weniger Hauptspeicher und bietet wesentlich flexiblere Berichtsfunktionen wie z.B. Historien. Mehr über dieses Produkt erfahren Sie unter: http://www.jam-software.de/spaceobserver /
F: Kann TreeSize Professional die Anzeige von Verzeichnissen unterdrücken, die eine bestimmte Größe unterschreiten?
A: Im Kontextmenü des obersten Ordners gibt es eine Funktion, mit der alle Ordner aus der Anzeige entfernen werden können, die eine bestimmte Größe unterschreiten. Zur Verwendung klicken Sie bitte mit der rechten Maustaste auf das Wurzelverzeichnis (oder verwenden Sie das Untermenü "Einblenden" aus dem Hauptmenü "Zweig"), wählen dann "Einblenden" und dann "Entferne Ordner <XX MB".
F: Kann auch der freie Platz eines Laufwerks im Tortendiagramm angezeigt werden?
A: Wenn die Wurzel des untersuchten Laufwerks ausgewählt ist, wird auch der freie Platz des Laufwerks im Tortendiagramm angezeigt, sofern die entsprechende Option im Kontextmenü des Tortendiagramms aktiviert ist.
F: Kann ich ein Netzwerklaufwerk auch untersuchen, ohne es mit einem Laufwerksbuchstaben zu verbinden?
A: Ja. In TreeSize Professional können Sie UNC-Namen der Art \\SERVERNAME\Share verwenden, um Netzwerklaufwerke anzusprechen. Geben Sie diese einfach in der Dropdown-Box in der Symbolleiste von TreeSize Professional ein. Sie können UNC-Namen auch als Kommandozeilen-Parameter verwenden.
F: Ich würde gerne jedes Mal eine bestimmte Menge von Laufwerken untersuchen, wenn TreeSize startet. Ist das möglich?
A: Sie können das Start-Verhalten von TreeSize in den Optionen festlegen. Sie können außerdem einfach eine Verknüpfung zu Tsizepro.exe auf Ihrem Desktop oder im Start-Menü erstellen und die Laufwerke durch Leerzeichen getrennt zur Kommandozeile hinzufügen. Bitte beachten Sie auch das Kapitel "Kommandozeilen-Parameter" für weitergehende Informationen.
F: Wie kann ich einen Scan auf nur einen bestimmten Benutzer einschränken?
A: Zuerst versichern Sie sich bitte, dass die Option "Statistik zu Dateibesitzern erstellen" in den Optionen von TreeSize Professional aktiviert ist. Nachdem der Scan beendet ist, klicken Sie bitte unterhalb des Reiters "Benutzer" mit der rechten Maustaste auf den betreffenden Benutzer und wählen Sie dort "Auf diesen Benutzer einschränken" aus. Sie können ferner mit Hilfe der benutzerdefinierten Dateisuche nach Dateien bestimmter Benutzer suchen.
F: Warum werden auf einem Novell Netware Laufwerk komprimierte Dateien als unkomprimierte angezeigt?
A: Prinzipiell können Sie mit TreeSize Professional auch Novell-Laufwerke untersuchen, die als Netzwerklaufwerk unter Windows erreichbar sind. Leider liefert der Netware Client für Windows keine Informationen über Kompression und Besitzer durch die normalen Windows API-Funktionen. Hierfür müssen Entwickler für Netware zusätzlich spezielle Unterstützung einbauen. Wir werden diese in einer späteren Funktion von TreeSize Professional nachliefern. Alle anderen Funktionen stehen jedoch auch auf Netware-Laufwerken uneingeschränkt zur Verfügung.
F: Gibt es die Möglichkeit einer "Silent" Installation?
A: Wenn Sie die Installationsdatei mit den Kommandozeilen Parametern /SILENT /SUPPRESSMSGBOXES und /PASSWORD=InstallKey aufrufen, wird die Software ohne irgendwelche Nachfragen mit den Standard-Werten installiert. Ersetzen Sie bitte InstallKey mit dem Installationsschlüssel, das Ihnen bei der Registrierung mitgeteilt worden ist. Die Verwendung von /VERYSILENT anstatt von /SILENT blendet auch jegliches visuelles Feedback aus. Die Option /DIR="x:\dirname" kann verwendet werden, um ein alternatives Ziel-Verzeichnis anzugeben.

F: Ist es mit TreeSize Professional möglich, nach Dateiendungen zu suchen?
A: Sie können beispielsweise in den Optionen einen Filter für einen Scan-Vorgang definieren, indem Sie Suchmuster der Art *.BMP zum Textfeld hinzufügen. Eine zweite Möglichkeit besteht darin, die Funktion "Statistik zu Dateitypen erstellen" in den Optionen zu aktivieren. Diese wird eine detaillierte Statistik für die Dateitypen in jedem Verzeichnis erstellen, und Sie werden auf dem Reiter "Dateitypen" die Möglichkeit haben, die Anzeige der Verzeichnisgrößen im Baum auf eine bestimmte Dateiendung einzuschränken. Eine dritte Möglichkeit besteht in der Verwendung der Benutzerdefinierten Dateisuche, in der eigene Suchmuster verwendet werden können. Unser Produkt SpaceObServer verfügt noch über weiter gehende und flexiblere Berichtsfunktionen.
F: Der verschwendete Platz, der von TreeSize angezeigt wird, ist bei mir extrem hoch. Wie kann ich diesen reduzieren?
A: Wahrscheinlich verwenden Sie das FAT32-Dateisystem, das durch seine großen Blöcke meist eine große Menge an verschwendetem Platz verursacht. Bitte lesen Sie das Kapitel "Verschwendeter Platz", um zu verstehen, was verschwendeter Platz ist und wie man ihn reduzieren kann.
F: Das Verzeichnis "System Volume Information" im Wurzelverzeichnis des Laufwerks belegt sehr viel Platz. Was ist seine Aufgabe?
A: Dieser Ordner gehört zur Systemwiederherstellung von Windows, Sie sollten in ihm keine Dateien manuell löschen. Die Größe kann durch die Einstellungen für die Systemwiederherstellung im "System"-Modul der Windows Systemsteuerung reduziert oder deaktiviert werden. Unter Windows Vista kann diese hier nur deaktiviert werden, eine Reduzierung muss mit Hilfe des Kommandozeilenprogramms vssadmin geschehen.
F: Wenn ich TreeSize Professional auf einem unserer PCs starte, erscheint ein Blue-Screen / startet der PC neu. Warum?
A: Eine normale Windows Anwendung wie TreeSize Professional kann keinen Blue-Screen oder eine Hard-Reset auslösen, dies können nur Treiber or die Kernkomponenten des Betriebssystems. Wahrscheinlich stimmt etwas mit dem System nicht und TreeSize Professional stößt lediglich die eigentliche Ursache des Problems an. Dies könnte beispielsweise passieren, weil TreeSize Professional auf Teile der Festplatte zugreift, auf die während des normalen Betriebs nicht zugegriffen wird, oder auf Grund der zusätzlichen Last auf dem System wegen der laufenden Untersuchung von TreeSize Professional.

F: Kann ich TreeSize Professional auch auf Cluster-Systemen installieren ?

A: Ja, Sie können TreeSize Professional auch auf einem Cluster-System installieren. Das Programm ist zwar nicht cluster-optimiert, aber das ist auch nicht unbedingt nötig. Wenn Sie für jeden Server eine Lizenz erwerben und Sie TreeSize Professional auf allen Cluster-Maschinen installieren, dann wird Ihnen zu jedem Zeitpunkt auf jedem Server TreeSize Professional zur Verfügung stehen.

F: Gibt es bekannte Probleme im Umgang mit TreeSize Professional auf einem Citrix Server?

A: TreeSize Professional läuft in einer Citrix Umgebung. Wenn TreeSize Professional auf einem Citrix Server gestartet wird ist möglicherweise kein Eintrag in der Task-Leiste sichtbar. Wird die Applikation minimiert kann man Sie nicht mehr ohne weiteres finden. Dies ist ein Problem das häufig mit Anwendungssoftware auf Citrix Servern auftritt. Das Problem kann umgangen werden indem Sie folgende Schlüssel in Ihrer Windows Registry hinzufügen:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wf shell\TWI]
"DllName"="seamls20.dll"
"NotifyEvent"="WfshellTwiNotify"
"SeamlessFlags"=dword:00000040

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wf shell\TWI\TMainForm.UnicodeClass]
"ClassName"="TMainForm.UnicodeClass"
"Type"=dword:00000041

Q: Wo speichert TreeSize Professional die Daten, die auf dem Reiter "Historie" angezeigt werden?
A: Diese Daten werden in der Datei ScanHistory.xml gespeichert, die sich in Ihrem Benutzerprofil unter Application Data\JAM Software\TreeSize Professional befindet.
F: Wenn ich unter Vista Netzwerklaufwerke untersuche wird mir für manche Unterordner der Zugriff verweigert, obwohl ich TreeSize Professional als Domänen-Administrator ausführen.
A: TreeSize Professional benutze einen internen Mechanismus von Windows um auch "gesperrte" Verzeichnisse untersuchen zu können, wenn Sie das Programm mit Administrator-Rechten ausführen. Dies gilt auch für Netzwerklaufwerke wenn Sie Domänen-Administrator sind. In Windows Vista gibt es hier ein Problem mit diesem Mechanismus, weshalb gesperrte Netzwerk-Verzeichnisse nicht untersucht werden können. Microsoft hat uns bestätigt, das es sich hier um ein Fehlverhalten von Windows Vista handelt. Die Installation des Hotfix KB950790 für Windows Vista wird das Problem beheben. Dieser Hotfix war zum Zeitpunkt der Veröffentlichung unter dem Link http://support.microsoft.com/?scid=kb%3Bde%3B950790&x=14&y=13 zu finden. Der Hotfix wird ebenfalls im Windows Vista Service Pack 2 enthalten sein.


Drucken / Export

Navigation: F.A.Q. - Häufig gestellt Fragen >

FAQ - Drucken / Export

 Return to chapter overview
F: Wie kann ich die Spalten auswählen, die in einem gedruckten Report oder einer exportierten Excel-Datei erscheinen?
A: Unter "Ansicht" / "Optionen" / "Spalten" können die gewünschten Spalten ausgewählt werden, nachdem Sie in der Dropdown-Box am oberen Rand ein Export-Medium ausgewählt haben.
F: Warum exportiert TreeSize Professional nicht die Dateinamen in meine Excel- / HTML- / Text-Dateien?
A: Die Export-Funktionen von TreeSize Professional wurden hauptsächlich erstellt, um Informationen über Verzeichnisse und deren Größe zu exportieren. Sie können aber mit Hilfe des Kontextmenüs von jedem Ordner im Baum eine Liste aller Dateien in die Zwischenablage kopieren, um sie von dort weiterzuverwenden. Eine weitere Möglichkeit ist die Verwendung des benutzerdefinierten Suchtyps der TreeSize Professional Dateisuche, die es erlaubt einige oder alle Dateien eines Verzeichniszweiges aufzulisten und diese Listen auch zu exportieren. Sie können ferner unser kostenloses Kommandozeilen-Programm FileList verwenden, welches das Erstellen einfacher Dateilisten ohne den Overhead einer Anwendung mit Benutzerschnittstelle erlaubt. Unser Produkt SpaceObServer bietet als Option das zusätzliche Exportieren der Dateien direkt aus seiner Datenbank.
Q: Wie kann ich eine Liste aller Dateien generieren, die einem bestimmten Benutzer gehören?
A: Versichern Sie sich zunächst in den Optionen, dass statistische Daten über die Benutzer gesammelt werden. Scannen Sie das Verzeichnis und warten Sie, bis die Operation abgeschlossen ist. Wählen Sie den Reiter "Benutzer" aus, klicken Sie mit der rechten Maustaste auf einen Benutzer und schränken Sie den Verzeichnisbaum links auf diesen Benutzer ein. Klicken Sie dann mit rechts auf die Wurzel des untersuchten Verzeichnisses und wählen Sie aus dem Kontextmenü "Daten exportieren" / "Kopiere Dateiliste" aus, was dann eine Weile dauern kann. Fügen Sie anschließend die Daten z.B. in eine Tabellenkalkulation ein. Um beim Exportieren eine komplette Liste aller Unterordner zu erhalten, vergewissern Sie sich bitte, dass die Option "Kompletter Baum" unter "Datei" > "Export" > "Einstellen" > "Export" selektiert ist.
Q: Wenn Ich eine exportierte CSV-Datei in MS Excel öffne, sind die Daten nicht in Spalten aufgeteilt. Wie kann man das ändern?
A: In der Windows Systemsteuerung setzen Sie bitte unter "Regionsoptionen" > "Anpassen" das Listentrennzeichen auf ein Semikolon,
F: Beim Drucken auf meinem Brother-Drucker wird das Druckbild spiegelverkehrt ausgegeben. Was kann ich tun?
A: Wechseln Sie bitte in Ihre Systemsteuerung und wählen Sie "Drucker und Faxgeräte". Klicken Sie nun auf den Brother-Drucker mit der rechten Maustaste und wählen Sie "Eigenschaften". Im Eigenschaften-Dialog klicken Sie bitte auf "Erweitert". Hier finden Sie eine Auswahl für den Druckprozessor (modprint, brprint, winprint). Wählen Sie bitte "winprint" und versuchen Sie erneut zu drucken.


Dateisuche

Navigation: F.A.Q. - Häufig gestellt Fragen >

FAQ - Dateisuche

 Return to chapter overview
F: Wie kann ich nach Dateien vom Typ XYZ suchen?
A: Die Windows Dateisuche erfüllt diese Aufgabe bereits relativ gut. TreeSize Professional wurde primär zum Auffinden alter und überflüssiger Dateien konzipiert, dennoch gibt es natürlich Möglichkeiten, bestimmte Dateitypen zu finden. Sie können beispielsweise nur die Suche nach temporären Dateien aktivieren. Dort deaktivieren Sie alle Suchmuster und fügen das gewünschte hinzu. Eine weitere Möglichkeit: Im Hauptprogramm setzen Sie in den Optionen einen Filter. Der sorgt dafür, dass beim Bestimmen der Verzeichnisgrößen nur zum Filter passende Dateien berücksichtigt werden. Das Ergebnis verschafft einen recht guten Überblick über die Verteilung dieses Dateityps, und eine Dateiliste kann in der Professional Edition ebenfalls exportiert werden. Unser Produkt SpaceObServer, das die Daten über die beobachteten Verzeichniszweige in einer SQL-Datenbank speichert, hat darüber hinaus noch schnellere und flexiblere Berichtsfunktionen.
F: Ist es möglich, gleichzeitig mehrere oder alle Dateien in den Ergebnislisten der Dateisuche zu markieren?
A: Es können, wie in anderen Anwendungen üblich, mehre Einträge mit der linken Maustaste ausgewählt werden, wenn gleichzeitig die Strg- oder Umschalttaste gedrückt wird. Durch Drücken von Strg+A werden alle Einträge der Liste markiert. Nun können mit dem Menüpunkt "Markieren" aus dem Kontextmenü alle ausgewählten Dateien markiert werden. Aufeinander folgende Einträge können übrigens auch durch mehrmaliges Drücken der Leertaste markiert werden.
F: Welche Dateien kann ich gefahrlos löschen?
A: Auf diese Frage gibt es leider keine einfache und kurze Antwort, da man einer Datei in der Regel nicht ansehen kann, woher sie kommt und welchem Zweck sie dient. Generell können temporäre Dateien und Cache-Dateien der Internet Browser fast immer gefahrlos gelöscht werden. Neben dem Löschen bietet die Dateisuche von TreeSize Professional aber auch die Möglichkeit, die markierten Dateien auf ein anderes Laufwerk oder platzsparend in eine ZIP-Datei zu verschieben, die dann archiviert werden kann. Auf diese Weise können Dateien, die vielleicht doch noch gebraucht werden, einfach wiederhergestellt werden.
F: Bietet TreeSize Professional die Möglichkeit, Dateien, die ein bestimmtes Alter überschritten haben, zu löschen? Kann dies per Skript gemacht werden?

A: Die TreeSize Professional Dateisuche kann Dateien, die ein bestimmtes Alter überschritten haben, mit Hilfe des Suchtyp "Älteste Dateien" oder des benutzerdefinierten Suchtyps finden, anzeigen und löschen. Haken Sie alle zu löschenden Dateien an (verwenden Sie Strg+A um alle Dateien zu selektieren und das Kontextmenü um diese zu markieren) und verwenden Sie die Schaltfläche "Markierte Verschieben" um die markierten Dateien beispielsweise in den Papierkorb zu verschieben. Aus Sicherheitsgründen haben wir das Löschen unter Umgehung des Papierkorbes nicht skriptfähig konzipiert, sondern nur das Verschieben der Dateien durch die Kommandozeilen-Option /MOVETO ermöglicht (nur Professional-Version). Alle Such-Optionen, die in eine XML-Datei gespeichert wurden, können an der Kommandozeile übergeben und die Suchergebnisse gespeichert werden. zum Beispiel: TreeSize.exe /SEARCH /SAVE "C:\Temp\TSP\Suchergebnisse.txt" "C:\Temp\TSP\Kein Zugriff seit 01-07-2008.xml". Die Ergebnisse können auch verschoben werden: TreeSize.EXE /SEARCH /MOVETO "C:\Temp\TST\Moved" "C:\Temp\TSP\Dateien mit Endung TMP.xml". Als Zielpfad kann auch "Papierkorb" (oder alternativ "Recycle Bin") übergeben werden.

F: Ist es möglich alle unsere 300 Workstations mit TreeSize Professional zu durchsuchen, um z.B. herauszufinden, wer PST-Dateien lokal auf seiner Workstation speichert?
A: Sie können hierfür die benutzerdefinierte Dateisuche verwenden. Die Dateisuche erlaubt das Durchsuchen einer gesamten Windows Domäne nach bestimmten Dateien wie *.pst. Geben Sie einfach \\IhrDomainName als zu durchsuchenden Pfad an. TreeSize Professional wird dann alle verfügbaren PCs in dieser Domäne enumerieren und deren Laufwerke (oder genauer: deren Public und Hidden Shares) nach zu den Suchkriterien passenden Dateien durchsuchen.
F: Unterstützt TreeSize Professional Pfade mit mehr als 255 Zeichen beim Durchsuchen der Festplatte?
A: Ja, dies geht mit der Benutzerdefinierten Dateisuche.
Q: Wie kann ich eine Suche nach doppelten Dateien über mehrere Netzwerklaufwerke ausführen?
A: Öffnen Sie die Dateisuche der Professional Edition mit Hilfe des Windows Startmenüs oder des "Dateisuche" Menüs von TreeSize Professional, auf dem Reiter "Suchoptionen" aktivieren Sie ausschließlich den Suchtyp "Doppelte Dateien", Fügen Sie die fraglichen Netzwerkpfade zur Liste der "Laufwerke und Pfade, die durchsucht werden sollen" hinzu und starten Sie die Suche. Sie können die Art und Weise wie TreeSize Professional Dateien vergleicht auf dem Reiter "Doppelte Dateien" einstellen.

Q: Wie sucht man nach Ordnern, die sowohl größer als eine gegebene Anzahl GB's als auch älter als ein gegebenes Datum sind? Ich möchte diese Dateien gern archivieren.

A: Bitte starten Sie die TreeSize Professional Dateisuche, deaktivieren alle Such-Optionen bis auf die Option "Benutzerdefinierte Suche" und legen Sie die Such-Parameter gemäß Ihren Wünschen fest.

Q: Ändert TreeSize Professional die Daten der letzten Änderung / letzten Zugriffs / Datum & Zeit-Information bei den gescannten Dateien und Ordnern?

A: Nein. TreeSize Professional verändert an diesen Daten nichts, wenn es Dateien und Ordner scannt.


Fenster & Reiter

Navigation: »No topics above this level«

Fenster & Reiter

 Return to chapter overview
· Symbolleisten
· Dateisystembaum
· Laufwerksübersicht


Symbolleisten

Navigation: Fenster & Reiter >

Symbolleisten

 Return to chapter overview

Direkt unterhalb der Menüleiste finden Sie drei Leisten mit Symbolen zum schnellen Aufruf von Funktionen. Alle Symbolleisten können im Kontextmenü (Rechtsklick auf die Symbolleiste) einzeln deaktiviert werden.

Symbolleiste "Scannen"

Die erste Symbolleiste Scannen enthält auf der linken Seite eine Dropdown-Box mit Laufwerksangaben. Hier können Sie auswählen, welches Laufwerk Sie scannen möchten. TreeSize Professional speichert die zuletzt benutzen Pfade in der Dropdown-Box für schnelleren späteren Zugriff ab.

Neben der Box finden Sie diverse Symbole zum Scannen von Verzeichnissen und Laufwerken. Diese erklären wir Ihnen hier noch einmal im Einzelnen.

Startet den Scan-Vorgang. Gescannt wird dabei das in der Dropdown-Bow links eingestellte Verzeichnis oder Laufwerk

Lässt Sie ein Verzeichnis auswählen, das untersucht werden soll

Lässt das komplette Verzeichnis erneut scannen

Ein-/Ausschalten der automatischen Aktualisierung auf Basis von Nachrichten der Windows Shell

Dieses Verzeichnis aus der Untersuchung durch TreeSize Professional entfernen

Druckt einen Bericht für den aktiven Verzeichniszweig

Wechsel zu einem übergeordneten Verzeichnis

Einstellungen für Darstellung und Verzeichnisscan vornehmen

Öffnet den Software-Dialog aus der Windows-Systemsteuerung

Blendet das Fenster zum Suchen nach Dateien ein (siehe auch Dateisuche)

Symbolleiste "Daten"

Die zweite Symbolleiste Daten enthält Symbole zur Manipulation der Ansicht der gesammelten Daten.

Klappt den Verzeichnisbaum bis zu einer bestimmten Ebene auf

Zeigt die Ordnergrösse an

Zeigt den vom Ordner belegten Plattenplatz an

Zeigt an, wieviel Prozent des übergeordneten Verzeichnisses jeder Ordner belegt

Zeigt den Platz an, den ein Ordner auf einer CD-ROM belegen würde

Zeigt die Anzahl der Dateien pro Ordner an

Sortiert die Elemente alphabetisch

Sortiert die Elemente nach ihrer Größe

Zeigt die Elemente ohne Sortierung an

Zeigt Werte in Kilobytes

Zeigt Werte in Megabytes

Zeigt Werte in Gigabytes

Verwendet eine passende Größeneinheit je nach Größe der Elemente

Symbolleiste "Übersicht"

Die dritte Symbolleiste Übersicht gibt Ihnen einen Überblick über das momentan angezeigte Laufwerk sowie dessen Belegung und Benutzung.


Dateisystembaum

Navigation: Fenster & Reiter >

Dateisystembaum

 Return to chapter overview

Der Dateisystembaum des gescannten Laufwerks bzw. Ordners erscheint in der linken Spalte von TreeSize Professional. Er gibt Ihnen einen schnellen Überblick über die Größe jedes Ordners. Sie können den Dateisystembaum wie einen Verzeichnisbaum im Windows Explorer verwenden. Wenn Sie mit der Maus auf einem Verzeichnis verweilen, wird Ihnen ein ausführlicher Tooltip mit Detail-Informationen angezeigt.

Unter Zweig | Aktualisieren können Sie sich eine aktuelle Übersicht in diesem Fenster anzeigen lassen; unter Zweig | Einblenden können Sie z.B. bestimmen, bis in welche Ebene der Baum Unterordner anzeigt. Nutzen Sie die Menüleiste und das Kontextmenü (Rechtsklick auf ein Verzeichnis), um weitere Funktionen aufzurufen (siehe Kontextmenüs).


Laufwerksübersicht

Navigation: Fenster & Reiter >

Laufwerksübersicht

 Return to chapter overview

Die Laufwerksübersicht gibt einen Überblick über die lokalen Laufwerke und die verbundenen Netzwerklaufwerke. Weitere Netzwerklaufwerke können einfach über das Kontextmenü hinzugefügt werden (nur in der Professional Edition).

Angezeigt werden hier die Größe des Laufwerks sowie freier Speicherplatz. Ein Doppelklick startet einen Scan für das ausgewählte Verzeichnis.


Diagramm

Navigation: Fenster & Reiter >

Diagramm

 Return to chapter overview

TreeSize Professional kann die Belegung der Festplatte in Form von Balken-, Torten- und Kacheldiagrammen visualisieren. Ein Diagramm zeigt jeweils die Größe der Unterordner des gerade ausgewählten Ordners an. Ein Tortendiagramm zeigt die Größe, den belegten Platz, den verschwendeten Platz etc. an, je nachdem, welche Ansicht gerade aktiv ist. Ein Balkendiagramm zeigt Größe, belegten und verschwendeten Platz eines Ordners in einem Balken an; hier gilt die Formel: Belegter Platz = Größe + verschwendeter Platz. Wenn nicht alle Balken in das Fenster von TreeSize Professional passen, wird am rechten Rand eine Bildlaufleiste eingeblendet.

Im Tortendiagramm werden kleinere Verzeichnisse zur besseren Übersicht unter "Andere" zusammengefasst. Falls das Wurzelverzeichnis eines Laufwerks angezeigt wird und sich TreeSize Professional im Ansichtsmodus "Belegter Platz" befindet, wird auch der freie Platz des Laufwerks im Tortendiagramm angezeigt. Im Kontextmenü des Tortendiagramms gibt es einen Menüpunkt, um dieses Verhalten ein- oder auszuschalten. Das Tortendiagramm zeigt den freien Platz als ein Element gleichberechtigt mit den Verzeichnissen an und berechnet den Prozentwert entsprechend (relativ zu den anderen). Daher kann sich dieser Prozentwert von dem "% Frei" Wert für das Laufwerk unterscheiden, wenn TreeSize z.B. nicht auf alle Verzeichnisse zugreifen konnte. Ein FAQ-Eintrag beschäftigt sich mit den möglichen Gründen hierfür.

Durch Klicken auf einen Balken oder einen Teil eines Tortendiagramms erhält man ausführlichere Informationen über den dazugehörigen Ordner. Ein Doppelklick macht den ausgewählten Ordner zum aktiven Ordner. Unter Ansicht | Symbolleisten können Sie die Symbolleiste für die Diagramme ein- und ausblenden, die die erweiterte Manipulation von Diagrammen erlaubt. Diese ermöglicht zum Beispiel das Speichern und Kopieren des Diagramms als Bitmap- oder JPEG-Datei, das Zoomen, das Ändern von Farben und Mustern, das Ein- und Ausblenden der Gitternetzlinien, das Umschalten zwischen 2D- und 3D-Modus etc. Sie können Muster und Farben einzelner Diagrammelemente ändern, indem Sie in der Auswahlbox eine Farbe auswählen und anschließend auf ein Diagrammelement klicken.

Ein Diagramm kann gedruckt werden, indem Sie Drucke Diagramm aus dem Datei-Menü auswählen.

 | Stellt die Belegung der Festplatte als Tortendiagramm dar.
 | Stellt die Belegung der Festplatte als Balkendiagramm dar.
 | Stellt die Belegung der Festplatte als Kacheldiagramm dar.
 | Kopiert das dargestellte Diagramm in die Zwischenablage.
Print | Druckt das dargestellte Diagramm.
Save | Speichert das dargestellte Diagramm als Grafik-Datei
View3D | Schaltet die 3D-Darstellung ein.
 | Blendet die Legende zur dargestellten Grafik ein.
VerticleGrid | Blendet vertikale Bezugslinien ein (nur bei Balkendiagrammen verfügbar).
HorizontalGrid | Blendet horizontale Bezugslinien ein (nur bei Balkendiagrammen verfügbar).
GradientView | Blendet die Gradientendarstellung im Hintergrund ein (nur bei Torten- und Balkendiagrammen verfügbar).
 | Zoomt in die Darstellung hinein (nur bei Kacheldiagrammen verfügbar).
 | Zoomt in die Darstellung hinein (nur bei Kacheldiagrammen verfügbar).
Shades | Wechselt in der Darstellung zwischen Vollfarbe und Texturfüllung der Graphen (nur bei Torten- und Balkendiagrammen verfügbar).
 | Legt den Farbwert für die aktuelle Darstellungsebene fest (nur bei Kacheldiagrammen verfügbar).
Slider | Legt den Auflösungsgrad in der Darstellung der Dateigröße fest (nur bei Kacheldiagrammen verfügbar).


Kacheldiagramme

Navigation: Fenster & Reiter > Diagramm >

Kacheldiagramme

 Return to chapter overview

Kacheldiagramme sind hierarchisch angeordnete Diagramme, die die Möglichkeit bieten, die Größe jedes Unterordners (auch über mehrere Verzeichnisebenen hinweg) im ausgewählten Verzeichnisbaum grafisch darzustellen.

Jeder Ordner wird als Rechteck dargestellt, wobei die Fläche des Rechtecks die Größe des entsprechenden Ordners wiedergibt. Die Rechtecke von Unterordnern sind innerhalb des Rechtecks ihres Elternordners angeordnet. Hat ein Ordner keine Unterordner und die Statistik für die Dateitypen war aktiv, so werden die Dateitypen als Unterelemente dieses Ordners angezeigt.

Die Farbe eines Rechtecks gibt Aufschluss über die Tiefe im Verzeichnisbaum, in der der jeweilige Ordner zu finden ist. Das Spektrum der Farbkodierung reicht von dunkelrot für die wurzelnächsten Ordner bis zu hellgelb für die Ordner in den tiefsten Verzeichnisebenen. Allerdings müssen die Rechtecke eine Mindestgröße haben, um noch angezeigt zu werden. Diese Mindestgröße können Sie über den Schieberegler rechts in der Symbolleiste der Diagramm-Ansicht einstellen. Ein zu klein gewählter Wert lässt das Diagramm unübersichtlich und schwer lesbar werden.
Wenn Sie den Mauszeiger über das Diagramm bewegen, werden Ihnen die wichtigsten Informationen über das entsprechende Verzeichnis als Tooltip angezeigt. Ein Doppelklick auf das entsprechende Rechteck bringt Sie direkt zu diesem Ordner im Verzeichnisbaum.

Natürlich können Sie auch dieselbe Export-Funktionalität für Kacheldiagramme nutzen, wie bei den Balken- oder den Tortendiagrammen (vgl. hierzu Diagramme). Mit Strg + und Strg - kann das Kacheldiagramm vergrößert oder verkleinert werden. Mit den Cursortasten, Pos1, Ende Bild Aus und Bild Ab kann im vergrößerten Kacheldiagramm gescrollt werden.


Details

Navigation: Fenster & Reiter >

Details

 Return to chapter overview

Der Reiter Details zeigt detaillierte Informationen über Unterordner und Dateien des ausgewählten Laufwerks bzw. des Ordners an.

Sie sehen eine Liste aller Objekte im gerade ausgewählten Ordner. Für jedes Objekt werden zahlreiche Details wie die Größe, der belegte Platz, der verschwendete Platz, die Anzahl der enthaltenen Objekte, der prozentuale Anteil am übergeordneten Ordner und das Datum des letzten Zugriffs und der letzten Änderung angezeigt. Sie können in den Optionen einzelne Spalten ausblenden.

Über entsprechende Symbole in der Symbolleiste Daten können Sie Anzeige bestimmter Informationen sowie Sortierung der Daten auswählen.

Nach einem Rechtsklick auf den Spaltenkopf können einzelne Spalten ein- und ausgeblendet werden.

 | Kopiert die aktuelle Liste in die Zwischenablage.
Printer | Druckt die aktuelle Liste (bzw. die ausgewählten Einträge).
Save | Speichert die aktuelle Liste (bzw. die ausgewählten Einträge) als .txt-Datei.
 | Speichert die aktuelle Liste (bzw. die ausgewählten Einträge) als Excel-Datei.
Compress | Speichert die ausgewählten Verzeichnisse in einer komprimierten Archiv-Datei.
Cancel | Löscht die ausgewählten Dateien.


Dateitypen

Navigation: Fenster & Reiter >

Dateitypen

 Return to chapter overview

Der Reiter Dateitypen zeigt Informationen über die Größe, gruppiert nach Dateitypen, so dass man einen Überblick über die Dateitypen erhält, die am meisten Platz verschwenden. Nutzen Sie die Symbolleiste Daten, um die Anzeige bestimmter Informationen sowie Sortierung der Daten auswählen. Über entsprechende Symbole am Kopf des Reiters können Sie die Dateitypen-Liste übrigens in einer Datei speichern, drucken, in die Zwischenablage kopieren oder auf demselben Reiter zusätzlich ein Diagramm anzeigen lassen. Das Aktivieren und Deaktivieren der Statistik für die Dateitypen kann in den Optionen vorgenommen werden.

In der Symbolleiste dieses Reiters finden Sie folgende Schaltflächen:

Filter | Filtert die Größenangaben im Dateisystembaum links, so dass nur noch die Größen für den gerade ausgewählten Dateityp angezeigt werden.
UnFilter | Schaltet den Filter wieder aus.
 | Zeigt eine Liste aller Dateien des gerade ausgewählten Dateityps an.
 | Kopiert den Inhalt der Liste in die Zwischenablage. Sind mehrere Elemente markiert, so werden nur die markierten Elemente kopiert.
Printer | Druckt den Inhalt der Liste. Sind mehrere Elemente markiert, so werden nur die markierten Elemente gedruckt.
Save | Speichert den Inhalt der Liste in einer Textdatei. Sind mehrere Elemente markiert, so werden nur die markierten Elemente gespeichert.
 | Speichert den Inhalt der Liste in einer Excel-Datei. Sind mehrere Elemente markiert, so werden nur die markierten Elemente gespeichert.
 | Aktiviert oder Deaktiviert ein ein kleines Balkendiagramm unterhalb der Liste.
 | Mit Hilfe dieser Schaltfläche können die Dateitypen in Gruppen wie "Audio-Dateien", "Video-Dateien" und "System-Dateien" zusammengefasst werden.


Benutzer

Navigation: Fenster & Reiter >

Benutzer

 Return to chapter overview

Der Reiter Benutzer zeigt Informationen über die Größe, gruppiert nach Benutzern. Sie haben hier einen guten Überblick darüber, welcher Benutzer in welchem Verzeichnis wie viel Platz belegt. Benutzer, die im aktuell ausgewählten Verzeichniszweig keine Dateien besitzen, werden nicht gelistet. Über entsprechende Schaltflächen am Kopf des Reiters können Sie diese Liste in einer Datei speichern, drucken, in die Zwischenablage kopieren oder auf demselben Reiter zusätzlich ein Diagramm anzeigen lassen. Das Aktivieren und Deaktivieren der Statistik für die Benutzer kann in den Optionen vorgenommen werden.

In der Symbolleiste finden Sie folgende Schaltflächen:

Filter | Filtert die Größenangaben im Dateisystembaum links, so dass nur noch die Größen für den gerade ausgewählten Benutzer angezeigt werden.
UnFilter | Schaltet den Filter wieder aus.
 | Zeigt eine Liste aller Dateien des gerade ausgewählten Benutzers an.
 | Kopiert den Inhalt der Liste in die Zwischenablage Sind mehrere Elemente markiert, so werden nur die markierten Elemente kopiert.
Printer | Druckt den Inhalt der Liste. Sind mehrere Elemente markiert, so werden nur die markierten Elemente gedruckt.
Save | Speichert den Inhalt der Liste in eine Textdatei. Sind mehrere Elemente markiert, so werden nur die markierten Elemente gespeichert.
 | Speichert den Inhalt der Liste in einer Excel-Datei.Sind mehrere Elemente markiert, so werden nur die markierten Elemente gespeichert.
 | Aktiviert oder deaktiviert ein ein kleines Balkendiagramm unterhalb der Liste.


Dateialter

Navigation: Fenster & Reiter >

Dateialter

 Return to chapter overview

Der Reiter Dateialter gibt einen Überblick über die Verteilung des Alters der untersuchten Dateien. Das Alter wird dabei auf Basis des Datum der letzten Änderung bestimmt. Die Werte für den angegebenen Zeitraum umfassen dabei nicht die anderen, jüngeren Zeiträume.
In der Symbolleiste finden Sie die aus dem Reiter Diagramm gewohnten Exportmöglichkeiten. Ferner können Sie die verwendeten Intervalle anpassen. Die Intervallgrenzen werden von TreeSize Professional immer auf Tagesgrenzen, also 0:00 Uhr, gerundet.

 | Kopiert die Dateialter-Grafik in die Zwischenablage.
Print | Druckt die Dateialter-Grafik.
Save | Speichert die Dateialter-Grafik als Grafik-Datei.
HorizontalGrid | Blendet horizontale Bezugslinien ein.
View3D | Aktiviert / Deaktiviert die 3D-Darstellung der Grafik.
Customize | Legt den Analysebereich für die Dateialteruntersuchung neu fest. Für eine Darstellung ist ein neuer Scan erforderlich.


Top 100 Dateien

Navigation: Fenster & Reiter >

Top 100 Dateien

 Return to chapter overview

Der Top 100-Reiter listet die 100 größten Dateien des untersuchten Verzeichniszweiges mit einigen Detailinformationen auf. Über entsprechende Symbole am Kopf des Reiters können Sie diese Liste in einer Datei speichern, drucken oder in die Zwischenablage kopieren.

 | Kopiert die Liste der 100 größten Dateien in die Zwischenablage.
Printer | Druckt die Liste der 100 größten Dateien.
Save | Speichert die Liste der 100 größten Dateien in einer .txt-Datei.
 | Speichert die Liste der 100 größten Dateien in einer Excel-Datei.
Cancel | Löscht die ausgewählten Dateien.


Historie

Navigation: Fenster & Reiter >

Historie

 Return to chapter overview

Im Reiter Historie wird mit Hilfe von Verlaufsdiagrammen die Größenentwicklung des gescannten Wurzelverzeichnisses visualisiert. Nach jedem Scan wird die Gesamtgröße des Wurzelverzeichnisses automatisch in einer XML-Datei im Benutzerprofil des eingeloggten Benutzers gespeichert. Diese Größen werden für diese Ansicht verwendet. Das heißt das Intervall und die Frequentierung der hier angezeigten Größen ist abhängig davon wie oft das Wurzelverzeichnis zuvor schon untersucht wurde.

Bitte beachten Sie dass nur Scans des gleichen Pfades und mit den gleichen Ausschlussfiltern in diesem Diagramm angezeigt werden, denn nur dieses haben eine gemeinsame Basis die sie vergleichbar macht.

Wenn Sie an der Größenentwicklung von beliebigen Unterordnern des gesamten Dateisystems interessiert sind, empfehlen wir den Einsatz unseres Managers für den Festplattenspeicher SpaceObServer, der die Größen des Dateisystems in einer Datenbank archiviert und somit die Größenentwicklung bis auf Dateiebene genau darstellen kann.

Die Symbolleiste beinhaltet Optionen zum Kopieren, Speichern und Drucken des angezeigten Diagramms.

 | Kopiert das Verlaufsdiagramm in die Zwischenablage.
Print | Druckt das Verlaufsdiagramm.
Save | Speichert das Verlaufsdiagramm als Grafik-Datei.
VerticleGrid | Blendet die vertikalen Bezugslinien ein und aus.
HorizontalGrid | Blendet die horizontalen Bezugslinien ein und aus.
 | Blendet Punktmarkierungen ein und aus.
View3D | Aktiviert / deaktiviert die 3D-Darstellung.
 | Legt den Wert des kleinsten Messwertes als Koordinatenursprungswert fest.


Die Menüs

Navigation: »No topics above this level«

Die Menüs

 Return to chapter overview
· Datei-Menü
· Export-Untermenü
· Zweig-Menü
· Ansicht-Menü
· Sortieren-Menü
· Dateisuche-Menü
· Extras-Menü
· Kontextmenüs


Datei-Menü

Navigation: Die Menüs >

Datei-Menü

 Return to chapter overview

Das Datei-Menü erlaubt es Ihnen, Verzeichnisse zum Untersuchen auszuwählen, untersuchte Verzeichnisse aus dem Fenster zu entfernen und die gesammelten Daten zu exportieren oder zu drucken:

Verzeichnis auswählen | Zeigt einen Dialog zum Auswählen eines Verzeichnisses an. Nach dem Bestätigen mit OK startet TreeSize Professional die Untersuchung des Verzeichnisses. Ein zu untersuchender Pfad kann auch in die Laufwerksbox in der Symbolleiste eingegeben werden.
XML-Report öffnen | Öffnet eine XML-Datei, die durch TreeSize Professional zuvor gespeichert worden ist. Auf diese Weise können Sie frühere Scan-Ergebnisse betrachten, ohne einen neuen Scan durchführen zu müssen.
Als XML-Report speichern | Speichert die gesammelten Daten des aktuellen Verzeichniszweiges in eine XML-Datei, die später wieder mit TreeSize Professional geöffnet oder zu Vergleichszwecken genutzt werden kann. TreeSize Professional wird mit einer XSLT-Datei ausgeliefert, welche die Daten einer solchen XML-Datei für die Darstellung in XSLT-fähigen Browsern konvertiert (z.B. Firefox >V1.0 oder Internet Explorer >V5.5). Bitte beachten Sie, dass die Informationen über die einzelnen Dateien nicht im XML-Report gespeichert werden, da dies die Größe zu stark erhöhen würde. Daher sind nur die Informationen für die Ordner in der XML-Datei enthalten. Falls Sie Reporting bis hinunter zur einzelnen Datei benötigen, könnte unsere datenbankgestützte Software SpaceObServer nützlich für Sie sein.
Mit XML-Report vergleichen | Lädt eine gespeicherte XML-Datei und vergleicht sie mit den aktuellen Daten durch Differenzbildung der alten Daten mit den aktuellen. Nach der Differenzbildung haben unverändert große Verzeichnisse die Größe 0. Umfangreicher gewordene Verzeichnisse haben eine positive Größe und werden in roter Farbe dargestellt. In der Größe reduzierte Verzeichnisse haben negative Werte und werden in grüner Farbe dargestellt. Da die Informationen über einzelne Dateien nicht in der XML-Datei enthalten sind, wird auf dem Reiter Details auch nicht die Größenänderung einzelner Dateien angezeigt.
Exportieren | Nur in der Professional Edition verfügbar. Siehe Kapitel Export
Titel angeben | Hier können Sie einen Titel für den gerade aktiven Verzeichniszweig angeben. Dieser Titel wird beim Exportieren oder Drucken des Verzeichniszweiges verwendet. Standardmäßig besteht der Titel aus dem Pfad des untersuchten Ordners und dem Namen des Laufwerks.
Bericht drucken | Druckt einen detaillierten Bericht für das aktive Verzeichnis (siehe Drucken)
Bericht für alle drucken | Druckt einen Bericht für alle untersuchten Laufwerke und Ordner im linken Bereich des Fensters
Diagramm drucken | Druckt das gerade angezeigte Diagramm (siehe auch Diagramme)
Ordnerinhalt drucken | Druckt eine Liste aller Objekte im gerade ausgewählten Ordner, mit Größe, Datum, etc.
Seite einrichten | Zeigt den Dialog zum Einrichten der Seite an, in dem Sie Papiergröße und Ränder für den Druck einstellen können
Drucker einrichten | Zeigt den Dialog zum Auswählen und Einrichten des Druckers
Beenden | Schließt die Anwendung


Export-Untermenü

Navigation: Die Menüs >

Export-Untermenü

 Return to chapter overview

Das Untermenü Export steht nur in der Professional Edition zur Verfügung und erlaubt den Export gesammelter Daten auf verschiedenen Wegen. Die Art der Daten (Spalten), die exportiert werden sollen, können auf dem Reiter Spalten in den Einstellungen festgelegt werden. In den Optionen können Sie bestimmen, ob alle Ordner oder nur die momentan sichtbaren Ordner exportiert werden sollen. So können Sie die Menge der exportierten Daten entweder manuell - durch das Auf- und Zuklappen von Ordnern - oder mit Hilfe des Kontextmenüs kontrollieren.

Speichern unter | Speichert die gesammelten Daten in einer Textdatei (durch Tabulatoren getrennt). Es werden wiederum nur die Verzeichnisse exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wählen Sie 'Alles einblenden' aus dem Kontextmenü, um eine komplette Liste zu erhalten.
Speichern als HTML | Speichert die Ergebnisse in einer HTML-Datei, die dann mit jedem Browser angeschaut werden kann. Es werden nur die Ergebnisse der Dateien exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wird gerade ein Diagramm angezeigt, so wird dieses im oberen Bereich der HTML-Datei eingebettet. Die HTML-Dateien sind UTF8-kodiert und geben daher auch Unicode-Zeichen korrekt wieder. In den Optionen kann für den HTML-Export eine Stylesheet-Datei angegeben werden.
Exportieren nach Excel | Exportiert die gesammelten Daten in eine MS Excel kompatible Datei. Es wird das Excel 97-2003 Format (Dateiendung XLS) und das Excel 2007 Format (Dateiendung XLSX) unterstützt.
Kopiere gesammelte Daten | Kopiert die gesammelten Daten in die Zwischenablage. Es werden nur die Verzeichnisse exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wählen Sie Alles einblenden aus dem Kontextmenü, um eine komplette Liste zu erhalten.
Als E-Mail senden | Sendet die aktuellen Daten als E-Mail über die MAPI-Schnittstelle von Windows. Dies erfordert, das MAPI korrekt konfiguriert ist, was in der Systemsteuerung unter dem Punkt Mail durchgeführt werden kann.
Einstellen | Öffnet den Optionen-Dialog, mit dem die Spalten für den Export ausgewählt werden können
Kopiere Dateiliste | Kopiert eine komplette Liste aller Dateien in dem untersuchten Ordner (und allen Unterordnern) in die Zwischenablage. Sie können diese Liste in Ihre Tabellenkalkulation einfügen oder mit einer Datenbank weiterverarbeiten. Die Spalten, die die Liste beinhaltet, werden durch die Einstellungen für den Text-Export im Optionen-Dialog bestimmt. Bitte beachten Sie, dass das Aktivieren der Spalten für Besitzer und Berechtigungen den Export-Prozess deutlich verlangsamen wird, da das Abfragen dieser Informationen unter Windows eine langsame Operation sind.


Zweig-Menü

Navigation: Die Menüs >

Zweig-Menü

 Return to chapter overview

Das Hauptmenü hat ein Menü Zweig, das alle Aktionen zusammenfasst, die auf einen kompletten Scan bzw. Zweig angewendet werden können.

Aktualisieren | Führt den Scan für das ausgewählte Verzeichnis erneut durch
Automatisch aktualisieren | Ermöglicht das Ein- und Ausschalten automatischer Updates für den ausgewählten Scan. Wenn automatische Updates eingeschaltet sind, wertet TreeSize Professional die Windows-Meldungen über Änderungen im Dateisystem aus und aktualisiert die betroffenen Ordner. Es aktualisiert die Größe eines Ordners ebenfalls, wenn dieser auf dem Reiter Details aufgelistet wird. Möchten Sie, dass sich nach Abschluss des Scans die Informationen über die Ordnergrößen nicht mehr ändern, sollten Sie die automatischen Updates deaktivieren.
Einblenden | Das Untermenü Einblenden entspricht dem im Kontextmenü.
Aus TreeSize entfernen | Entfernt den ausgewählten Scan aus der Ansicht von TreeSize Professional.


Ansicht-Menü

Navigation: Die Menüs >

Ansicht-Menü

 Return to chapter overview
Symbolleisten | Erlaubt das Ein- und Ausblenden einzelner Symbolleisten
Laufwerksübersicht | Blendet eine Liste mit lokalen und Netzwerk-Laufwerken in der linken unteren Ecke ein oder aus
Dezimalstellen | Anzahl der Dezimalstellen, die TreeSize Professional bei der Darstellung von Werten nach dem Dezimalpunkt verwenden soll.

Sie können verschiedene Arten von Ansichten innerhalb von TreeSize Professional wählen:

Größe | Zeigt die Größe eines Ordners inklusive aller Unterordner an
Belegter Platz | Zeigt an, wie viel Platz der Ordner tatsächlich auf dem Laufwerk belegt
Prozent | Zeigt den Anteil jedes Verzeichnisses an seinem übergeordneten Verzeichnis in Prozent an
Verschwendeter Platz | Zeigt den durch das Dateisystem verschwendeten Platz an, der durch das Speichern dieses Ordners verloren gegangen ist
CD-ROM Blockgröße | Zeigt an, wie viel Platz ein Ordner auf einer CD oder DVD belegen würde. Bitte beachten Sie dabei, dass auf jeder Disk noch zusätzlich einige MB für die Verzeichnisinformationen benötigt werden.
Anzahl Dateien | Zeigt die Anzahl der Dateien im jeweiligen Verzeichniszweig an

Mit den darauf folgenden Menüpunkten können Sie auswählen, was in der rechten Hälfte des Fensters angezeigt werden soll:

Diagramm | Zeigt ein Diagramm auf der rechten Seite des Fensters an
Details | Zeigt eine detaillierte Liste aller Objekte im gerade ausgewählten Ordner an. Für jedes Objekt werden zahlreiche Details wie die Größe, der belegte Platz, der verschwendete Platz, die Anzahl der enthaltenen Objekte, der prozentuale Anteil am übergeordneten Ordner und das Datum des letzten Zugriffs und der letzten Änderung angezeigt. Sie können in den Optionen einzelne Spalten ausblenden.
Dateitypen | Zeigt eine Statistik für den aktuell ausgewählten Verzeichniszweig an, die die Größe jedes Dateityps in diesem Verzeichniszweig anzeigt. Diese Statistik basiert auf der Dateiendung.
Benutzer | Zeigt eine Statistik für den aktuell ausgewählten Verzeichniszweig an, die für jeden Benutzer die summierte Größe aller Dateien umfasst, deren Besitzer er ist.
Dateialter | Zeigt die Verteilung des Alters der Dateien im gerade angewählten Verzeichnis an
Top 100 Dateien | Zeigt ein Liste der 100 größten Dateien im untersuchten Verzeichnis bzw. Laufwerk an

Die Art, in der TreeSize Professional Größenangaben darstellt, kann mit den folgenden Menüpunkten oder den entsprechenden Schaltflächen auf der Symbolleiste verändert werden.

Werte in Byte | Alle Größenangaben werden in Byte angezeigt
Werte in KB | Alle Größenangaben werden in Kilobyte angezeigt
Werte in MB | Alle Größenangaben werden in Megabyte angezeigt.
Werte in GB | Alle Größenangaben werden in Gigabyte angezeigt.
Gemischte Größenangaben | Auf Basis der Größe des anzuzeigenden Wertes wird automatisch eine passende Einheit ausgewählt.

Weiterhin können Sie im Ansicht-Menü den Einstellungen-Dialog einblenden.

Optionen

Zeigt den Dialog mit den Einstellungen von TreeSize Professional an


Sortieren-Menü

Navigation: Die Menüs >

Sortieren-Menü

 Return to chapter overview

Dieses Menü erlaubt eine Anpassung der Sortier-Einstellungen bei Listendarstellungen.

Sortieren nach Größe | Hierbei werden die größten Verzeichnisse zuerst aufgelistet
Sortieren nach Name | Hierbei werden die Verzeichnisse in alphabetischer Reihenfolge aufgelistet.
Aus | Es wird keine Sortierung durchgeführt. Dies kann nützlich sein, wenn man sehr große Verzeichnisse untersucht. So kann man sich Teilergebnisse anschauen, ohne dass Verzeichnisse ständig ihre Position wechseln.


Dateisuche

Navigation: Die Menüs >

Dateisuche

 Return to chapter overview

In diesem Menü kann die Dateisuche von TreeSize Professional für einen bestimmte Suchart oder für alle Sucharten gestartet werden. Für weitere Informationen lesen bitte im Kapitel "Dateisuche" weiter.


Extras-Menü

Navigation: Die Menüs >

Extras-Menü

 Return to chapter overview
Alle aktualisieren | Aktualisiert die Ergebnisse für alle gerade angezeigten Verzeichnisse. Dieser Vorgang kann unter Umständen längere Zeit dauern. Ein einzelnes Verzeichnis können Sie aktualisieren, indem Sie den entsprechenden Menüpunkt aus dem Kontextmenü dieses Ordners auswählen oder F5 drücken.
Alle Scans in virtuellem Wurzelverzeichnis zusammenfassen | Mit diesem Funktion ist es möglich, mehrere Scans unter einer virtuellen Wurzelverzeichnis zusammenzufassen. Dieses zeigt dann Gesamtwerte für alle Scans an, die zu dieser Gruppe gehören. Auf diese Weise können auch mehrere Scans für den Export und den Druck zusammengefasst werden. Die Zugehörigkeit zum virtuellen Wurzelverzeichnis kann auch individuell pro Scan in dessen Kontextmenü eingestellt werden.
TreeSize-Dateisuche | Zeigt das Fenster zur Dateisuche an, mit dem Sie nach alten, besonders großen oder überflüssigen temporären Dateien suchen können
TreeSize-Scan planen | Öffnet einen Dialog, der beim Planen zeitgesteuerter Untersuchungen hilft.
TreeSize als Administrator starten | Dieser Menüpunkt, der nur unter Windows Vista zur Verfügung steht, startet TreeSize erneut mit vollen Administrator-Rechten.
Software hinzufügen / entfernen | Öffnet den Dialog aus der Systemsteuerung, mit dem Software hinzugefügt oder entfernt werden kann
Papierkorb leeren | Leert den Papierkorb von Windows
Netzwerklaufwerk verbinden | Öffnet ein Fenster, das das Verbinden eines Netzwerklaufwerks mit einem Laufwerksbuchstaben erlaubt. Es können aber auch UNC-Pfade der Form \\Host\Share in die Laufwerksbox links oben eingegeben werden. (Nur in der Professional Edition)


Kontextmenüs

Navigation: Die Menüs >

Kontextmenüs

 Return to chapter overview

Dateisystembaum

Wenn Sie mit der rechten Maustaste auf ein Verzeichnis klicken, zeigt Ihnen TreeSize Professional das Kontextmenü des Explorers an. Außerdem finden Sie noch folgende Menüpunkte im TreeSize-Untermenü:

NTFS-Kompression einschalten | Komprimiert den gesamten Verzeichniszweig mit der NTFS-Kompression. TreeSize Professional aktualisiert seine statistischen Daten während der Kompression. Diese Operation kann längere Zeit in Anspruch nehmen, abhängig von der Datenmenge, die zu komprimieren ist.
Dekomprimieren | Dekomprimiert alle Dateien im ausgewählten Verzeichniszweig, für welche die NTFS-Kompression eingeschaltet ist. Diese Operation macht die obige Operation rückgängig.
Neuer Ordner | Erstellt einen neuen Ordner innerhalb des ausgewählten Ordners.
Einblenden | Siehe unten
Diesen Zweig aktualisieren | Aktualisiert nur die Daten im Verzeichniszweig unterhalb dieses Ordners. Dies ist wesentlich schneller, als das gesamte untersuchte Verzeichnis erneut einzulesen.
Diesen Ordner aktualisieren (nicht rekursiv) | Liest den Inhalt dieses Ordners erneut ein und aktualisiert die Statistiken, tut dies aber nicht rekursiv für die Unterordner.
Tiefste Schachtelung finden | Findet das Verzeichnis mit der größten Tiefe. Dies kann zum Beispiel nützlich sein, um Ordner zu identifizieren, die das Limit von Windows für Verzeichnispfade von 255 Zeichen verletzen.
Aus TreeSize entfernen (temporär) | Hiermit kann ein Verzeichnis aus dem Baum und aus den Berechnungen von TreeSize Professional entfernt werden. Das Verzeichnis wird jedoch nicht physikalisch vom Laufwerk gelöscht und erscheint daher beim nächsten Durchlauf wieder.
Mit TreeSize Dateisuche durchsuchen | Öffnet die Dateisuche von TreeSize Professional und macht den aktuellen Ordner zum aktiven Ordner für die Suche.
Kopiere Daten dieses Zweiges | Kopiert die gesammelten Daten für alle Ordner im selektierten Verzeichniszweig in die Zwischenablage.
Kopiere Dateiliste dieses Zweiges | Kopiert eine Liste aller Dateien im ausgewählten Verzeichniszweig in die Zwischenablage.
Vollständigen Pfad in Zwischenablage kopieren | Kopiert den Pfad des aktuellen Ordners als Text in die Zwischenablage.
Für den obersten Ordner wird ein anderes Kontextmenü mit besonderen Funktionen angezeigt. Es sieht folgendermaßen aus:

Öffnen | Öffnet das Verzeichnis in einem einfachen Windows Explorer Fenster.
Explorer | Öffnet das ausgewählte Verzeichnis in einem Windows Explorer Fenster mit Verzeichnisbaum auf der linken Seite.
Eigenschaften | Zeigt den Eigenschaften-Dialog des Ordners bzw. Laufwerks an.
Neuer Ordner | Erstellt einen neuen Ordner.
Windows Explorer | Hier wird das Kontextmenü des Windows Explorers für den untersuchten Pfad als Untermenü angezeigt.
Aktualisieren | Führt den Scan für das ausgewählte Verzeichnis erneut durch.
Diesen Ordner aktualisieren (nicht rekursiv) | Liest den Inhalt dieses Ordners erneut ein und aktualisiert die Statistiken, tut dies aber nicht rekursiv für die Unterordner.
Einblenden | Siehe unten
Daten exportieren | Siehe "Export-Untermenü"
Tiefste Schachtelung finden | Findet das Verzeichnis mit der größten Tiefe. Dies kann zum Beispiel nützlich sein, um Ordner zu identifizieren, die das Limit von Windows für Verzeichnispfade von 255 Zeichen verletzen.
In virtuellem Wurzelver- zeichnis zusammenfassen | Mit diesem Funktion ist es möglich, mehrere Scans unter einer virtuellen Wurzelverzeichnis zusammenzufassen. Dieses zeigt dann Gesamtwerte für alle Scans an, die zu dieser Gruppe gehören. Auf diese Weise können auch mehrere Scans für den Export und den Druck zusammengefasst werden.
Aus TreeSize entfernen | Entfernt den ausgewählten Scan aus der Ansicht von TreeSize Professional.
Mit TreeSize Dateisuche durchsuchen | Öffnet die Dateisuche von TreeSize Professional und macht den aktuellen Ordner zum aktiven Ordner für die Suche.
Immer beim starten untersuchen | Ist diese Option aktiviert, so startet TreeSize Professional hierfür beim Start einen Scan, sofern nicht andere Ordner an der Kommandozeile oder über das Explorer Kontextmenü übergeben werden.
Das Untermenü "Einblenden"
Alles einblenden | Blendet alle Verzeichnisse unterhalb dieses Ordners ein.
Bis Ebene X | Blendet alle Verzeichnisse unterhalb des aktiven Ordners bis zu einer bestimmten Tiefe (1-4) ein.
Ordner einblenden über | Blendet alle Ordner ein, die größer als die angegebene Größe sind.
Entferne Ordner <xxx MB | Entfernt alle Ordner aus der Ansicht, die kleiner als die angegebene Größe sind.
Größe festlegen | Legt die Grenzgröße für die beiden vorangegangenen Operationen fest.

Details Liste

Die Liste auf dem Reiter "Details" zeigt bei einem Rechtsklick auf ein Objekt das Kontextmenü des Windows Explorers an. Zusätzlich existiert ein Untermenü mit dem Namen "TREESIZE", das alle verfügbaren Informationen des ausgewählten Objekts anzeigt. Darin eingeschlossen sind auch die Spalten, die momentan nicht aktiviert sind. Dieses Untermenü kann außerdem dazu verwendet werden, Spalten zu aktivieren und zu deaktivieren.


Optionen

Navigation: »No topics above this level«

Optionen

 Return to chapter overview

Der Optionen-Dialog wird durch den entsprechenden Menüpunkt im Ansicht-Menü oder über die Symbolleiste aktiviert. Er erlaubt die Festlegung von Einstellungen für die Darstellung und den Untersuchungsvorgang (Scan) und besteht aus folgenden Reitern:

· Ansicht
· Scan
· Filtern
· Spalten
· Start
· Shell-Erweiterungen
· Dateialter


Reiter "Ansicht"

Navigation: Optionen >

Optionen-Dialog: Reiter "Ansicht"

 Return to chapter overview
Icons nur auf Basis der Dateiendung bestimmen | Wenn diese Option aktiviert ist, werden die Icons lediglich auf Basis der Dateiendung ausgewählt. Dies ist wesentlich schneller, insbesondere auf Netzwerklaufwerken, denn Windows öffnet viele Dateitypen um zu sehen, ob sich darin irgendwelche Icons befinden. Standardmäßig ist diese Option aktiviert.
Andere Farbe für komprimierte Dateien und Ordner | Ist diese Option aktiviert, werden komprimierte Dateien auf einem NTFS-Laufwerk in blauer Farbe angezeigt. Verzeichnisse, die nur teilweise komprimiert sind, werden dunkelblau angezeigt, Dateien und Verzeichnisse, die komplett komprimiert sind, erscheinen hellblau. Für weitere Informationen über dateibasierte Komprimierung lesen Sie bitte das Kapitel "Hinweise zu NTFS".
Lange Tooltips im Verzeichnisbaum anzeigen | Ist diese Option aktiv, so wird, nachdem die Maus eine Weile über einem Ordner im Verzeichnisbaum verweilt hat, ein Hinweisfenster eingeblendet, das sämtliche, für den Ordner verfügbare Daten anzeigt. Dies ist nützlich, um schnell an Detail-Informationen zu gelangen, ohne zuvor auf die Details-Ansicht wechseln zu müssen.
Zeige Farbverläufe als Größenindikatoren im Verzeichnisbaum | Ist diese Option aktiv, wird unterhalb jedes Ordners ein Balken in Form eines Farbverlaufs angezeigt, dessen Länge proportional zur Größe des jeweiligen Verzeichnisses ist.
Neben Datumswerten auch die Uhrzeit anzeigen | Aktivieren Sie diese Option wenn zusätzlich zum Datum auch die Uhrzeit für Zeitstempel (z.B.: Letzte Änderung, Letzter Zugriff,...) angezeigt werden soll.
Rechte Seite während des Scannens aktualisieren | Ist diese Option aktiviert, so aktualisiert TreeSize Professional die rechte Seite des Fensters von Zeit zu Zeit. Dies erlaubt es z.B., die Balkendiagramme während des Scans wachsen zu sehen. Verwenden Sie den Schieber, um das Intervall einzustellen.
Einträge in Liste zuletzt untersuchter Pfade | In der Dropdown-Box zum Auswählen der Laufwerke finden Sie eine Liste mit den zuletzt untersuchten Ordnern und Laufwerken. Hier können Sie einstellen, wie viele Einträge diese Liste maximal haben soll.
Fettdruck-Faktor | Wenn die Größe eines Verzeichnisses größer als der angegebene Wert oder Prozentsatz des gesamten untersuchten Verzeichnisses ist, dann wird der Verzeichnisname in Fettschrift dargestellt. Dies ermöglicht es Ihnen schnell, die besonders großen Verzeichnisse zu erkennen. Wenn Sie keine fett gedruckten Verzeichnisnamen wünschen, wählen Sie hier "100%" aus. Sie können diese Einstellung auch für den Report-Druck verwenden, indem Sie die darunter liegende Checkbox aktivieren.


Reiter "Scan"

Navigation: Optionen >

Optionen-Dialog: Reiter "Scan"

 Return to chapter overview

Wenn Sie Veränderungen auf der Seite Scan vornehmen, ist ein erneutes Einlesen aller aufgeführten Verzeichnisse und Laufwerke erforderlich. Es stehen folgende Einstellungen zur Auswahl:

Externen Mountpoints und symbolischen Links folgen | Diese Option entscheidet darüber, ob TreeSize Professional Mountpoints und symbolischen Links auf andere Laufwerke oder Ordner auf diesen folgen soll oder nicht. Weitere Informationen hierzu gibt es im Kapitel "Hinweise zu NTFS". Grundsätzlich wird aber keinen Links gefolgt, die in den untersuchten Verzeichnisbaum verweisen, um zirkuläre Referenzen und doppelt gezählte Verzeichnisse zu vermeiden.
NTFS Alternate Data Streams und NTFS Hardlinks erkennen | Mit dieser Option kann gesteuert werden, ob TreeSize Professional während eines Scans jede Datei darauf überprüfen soll, ob sie lediglich ein Hardlink auf eine andere Datei ist oder Alternate Data Streams (ADS) enthält. Die Ergebnisse für den Platzbedarf werden so noch genauer, ein Scan wird aber auch etwas länger dauern.
Zeige Fehlermeldungen | Hier können Sie festlegen, ob TreeSize Professional Fehlermeldungen während der Untersuchung eines Ordners oder Laufwerks anzeigen soll oder nicht. Wenn Sie beispielsweise ein Netzwerklaufwerk auf einem Windows Server untersuchen, auf dem Sie für einige Verzeichnisse keine Leserechte besitzen, wird jeweils eine Fehlermeldung angezeigt. Wenn die Untersuchung nicht durch diese Meldungen unterbrochen werden soll, deaktivieren Sie diese Option.
Statistik zu Dateitypen erstellen | Ist diese Option aktiviert, so wird pro Verzeichnis zusätzlich eine Statistik für die Dateiendungen erstellt. Die Ergebnisse können auf dem Reiter Dateitypen betrachtet werden. Außerdem können die Werte in der Verzeichnisstruktur auf der linken Seite des Fensters auf einen bestimmten Dateityp eingeschränkt werden.
Statistik zu Dateibesitzern erstellen | Ist diese Option aktiviert, so wird pro Verzeichnis zusätzlich eine Statistik für die Besitzer der Dateien erstellt. Die Ergebnisse können auf dem Reiter Benutzer betrachtet werden. Diese Option verschafft Ihnen einen guten Überblick darüber, welcher Benutzer in welchem Verzeichnis wie viel Platz belegt. Außerdem können die Werte in der Verzeichnisstruktur auf der linken Seite des Fensters auf einen bestimmten Benutzer eingeschränkt werden. Da für jede Datei beim System der Besitzer erfragt werden muss, verlangsamt das Einschalten dieser Funktion den Scan ein wenig.
Thread Priorität | Diese Option erlaubt das Festlegen der Priorität, mit denen die Threads laufen, die die Festplatte untersuchen. Die Aktivierung der Option Ungenutzte CPU-Zeit führt dazu, dass nur Prozessorzeit genutzt wird, die nicht von anderen Prozessen verwendet wird. Daher ist dies eine gute Einstellung, wenn die Auswirkungen ressourcenintensiver Threads auf den ausführenden PC oder Server minimiert werden sollen. Der Standard- und empfohlene Wert ist "Niedrigere Priorität". Die Auswahl von "Höhere Priorität" führt dazu, dass die untersuchenden Threads eine höhere Priorität haben als der Thread der Benutzeroberfläche, so dass die Benutzeroberfläche während einer laufenden Untersuchung unter Umständen nur noch zäh reagiert. Der eingestellte Wert wird auch für die TreeSize Professional Dateisuche verwendet.
Maximale Threadanzahl | TreeSize Professional passt die Anzahl der laufenden Threads automatisch der aktuellen CPU-Belastung an. Mit dieser Option kann die maximale Zahl von Threads bestimmt werden, die höchstens für einen Scan gestartet wird. Während eines Scans können bei hoher Systembelastung auch weniger als diese Maximalzahl von Threads genutzt werden.
Benutzerdefinierte Blockgröße | Verwenden Sie diese Einstellung, um sich ein Bild davon zu machen, wie Ihr Laufwerk mit einer anderen Blockgröße aussehen würde. Die Blockgröße hat Einfluss auf den belegten und den verschwendeten Platz Ihrer Verzeichnisse. Diese Option speichert TreeSize Professional nach dem Beenden nicht ab, um bei der nächsten Benutzung falsche Ergebnisse zu vermeiden.


Reiter "Filtern"

Navigation: Optionen >

Optionen-Dialog: Reiter "Filtern"

 Return to chapter overview

Der Reiter Filtern ermöglicht, bestimmte Dateien für die Scans ein- oder auszuschließen.

Dateitypen | Wenn Sie nur Informationen über bestimmte Dateitypen haben wollen, können Sie hier einen Filter angeben. Es können auch mehrere Filter durch Leerzeichen getrennt angegeben werden. Wenn Sie beispielsweise nur Informationen über Programmdateien haben wollen, geben Sie hier "*.exe *.dll" an. Wenn Sie alle Dateien mit einbeziehen möchten, geben Sie einfach "*" an. Diese Option speichert TreeSize Professional nach dem Beenden nicht ab, um bei der nächsten Benutzung falsche Ergebnisse zu vermeiden. Wenn Sie häufiger einen Scan nur für bestimmte Dateitypen durchführen, können Sie hierfür eine eigene Verknüpfung erzeugen und für diese entsprechende Kommandozeilen-Parameter festlegen.
Nur Dateien mit Erstellungsdatum innerhalb XX Tage | Diese Option bezieht nur Dateien mit in einen Scan ein, die innerhalb der angegebenen Anzahl von Tagen neu erstellt worden sind. Mit dieser Option können Sie sich einen guten Überblick über stark wachsende Verzeichnisse verschaffen. Sie wird nicht abgespeichert, um bei der nächsten Benutzung von TreeSize Professional falsche Ergebnisse zu vermeiden.
Nur Dateien mit gesetztem Archiv-Attribut einbeziehen | Diese Option ist nützlich, wenn Sie wissen wollen, wie groß ein Backup für ein bestimmtes Verzeichnis wird, das auf Basis des Archiv-Bits von Windows durchgeführt wird.
Ausschlusskriterien | Wenn bestimmte Dateien oder Verzeichnisse vom Scan ausgeschlossen werden sollen, können Sie hier ein entsprechendes Muster der Art "Windows" oder "*.tmp" hinzufügen. Alle Dateien und Verzeichnisse, die auf eines der angegebenen Muster passen, werden dann nicht in den Scan miteinbezogen.
Offline Dateien ausschließen | Durch das Aktivieren dieser Option können Offline-Dateien vom Scan ausgeschlossen werden. Offline Dateien sind oftmals nicht physisch auf dem Laufwerk präsent oder werden dort nur temporär gecached.


Reiter "Spalten / Export"

Navigation: Optionen >

Optionen-Dialog: Reiter "Spalten / Export"

 Return to chapter overview

Auf der Seite Spalten können Sie auswählen, welche Spalten sichtbar sein sollen. Dies kann separat für jedes "Ausgabe-Medium" (Detailansicht, Excel-Export, gedruckter Bericht, Textdatei etc.) festgelegt werden, indem der entsprechende Eintrag in der Auswahlbox im oberen Bereich ausgewählt wird. Die folgenden Spalten stehen zur Verfügung:

Name | Der Name der Datei oder des Ordners
Absoluter Pfad | Der absolute Pfad inklusive des Namens des Objekts.
Größe | Die Größe des Objekts
Belegt | Der Platz, den das Objekt aktuell auf der Platte belegt (siehe auch: Verschwendeter Platz und NTFS-Kompression).
Dateien | Die Anzahl der Dateien in einem Verzeichniszweig
Ordner | Die Anzahl der Unterordner in einem Verzeichniszweig
Verschwendet | Der Platz, der durch das Dateisystem verschwendet wird (siehe auch: Verschwendeter Platz)
Prozent | Der Platz, den ein Objekt relativ zu dem Ordner belegt, in dem es gespeichert ist
Letzte Änderung | Das Datum der letzten Änderung eines Objekts. TreeSize Professional berechnet das Datum der letzten Änderung und des letzten Zugriffs für Ordner exakter, als dies der Windows Explorer tut, indem es alle Dateien in allen Unterordern berücksichtigt. Daher können sich die angezeigten Werte von denen des Windows Explorers unterscheiden.
Letzter Zugriff | Das Datum, an dem zuletzt auf ein Objekt zugegriffen worden ist
Kompr. | Die Größe in Prozent, um die das Objekt durch die eingebaute Kompression des Dateisystems komprimiert werden konnte. (siehe auch: Hinweise zu NTFS).
Besitzer | Der Name des Benutzers, der für das Objekt als Besitzer eingetragen ist
CD-ROM Größe | Der Platz, den das Objekt auf einer CD oder DVD mit ISO-Dateisystem belegen würde
Aktuelles Datum | Das aktuelle Datum. Diese Spalte kann nützlich sein, wenn die gesammelten Informationen automatisiert weiterverarbeitet werden sollen, z.B. in einer Datenbank.
Attribute | Die Datei-Attribute Schreibgeschützt (R), Versteckt (H), System (S), Archiv (A)
Dateityp | Der Typ des Objekts, z.B. "Textdatei"
Verzeichnistiefe | Die Ebene, auf der sich das Objekt im Dateisystembaum befindet. Diese Spalte kann nützlich sein, wenn die gesammelten Informationen automatisiert weiter verarbeitet werden sollen, z.B. in einer Datenbank.
Erstellungsdatum | Das Datum, an dem das Objekt erstellt worden ist
Pfad (ohne Dateiname) | Der absolute Pfad des Verzeichnisses, in dem sich das Objekt befindet
Durchschn. Dateigröße | Die durchschnittliche Größe der Dateien in einem Ordner
Berechtigungen | Die Zugriffsberechtigungen für das Objekt in dem Format: Benutzername1: +/-R +/-W +/-X Benutzername2: ... wobei ein gewährtes Recht mit "+" und ein verwehrtes Recht mit "-" gekennzeichnet wird. "R" steht hierbei für Leserechte, und "W" für Schreibrechte. Bei Dateien steht "X" für das Recht, diese aufzulisten, bei Verzeichnisse für das Recht, deren Inhalt aufzuführen. Diese übersichtliche und kompakte Notation ist der UNIX-Welt entliehen.
Dateiversion | Die Versionsnummer, die in EXE, DLL, OCX und ähnlichen binären Dateien meist enthalten ist
Titel des Scans | Standardmäßig der Titel eines Scans. Er kann mit Hilfe von Titel angeben im Datei-Menü geändert werden. Dies kann beispielsweise bei der Archivierung der gesammelten Daten nützlich sein.
MS Office Autor | Für MS Office und kompatible Dateien wird in dieser Spalte der Name des Autors angezeigt, der aus den Metadaten der Datei extrahiert wird.
MS Office Letztes Speicherdatum | Für MS Office und kompatible Dateien wird in dieser Spalte das Datum der letzten Speicherung angezeigt, das aus den Metadaten der Datei extrahiert wird.
Hardlinks | Anzahl der Hardlinks auf eine Datei. Leer im falle von Ordnern.
Error | Konnte ein Verzeichnis aufgrund eines Fehlers nicht untersucht werden, so enthält diese Spalte die dazugehörige Fehlermeldung.
Anmerkung: Die Einstellungen für den Text-Export sind auch für den Export in die Zwischenablage gültig!

Die angezeigten Spalten in der Detail-Liste von TreeSize Professional können auch bequem über das Kontextmenü des Listenkopfes ausgewählt werden:

Export

Kompletter Baum | Ist diese Option aktiviert, so wird der komplette Dateisystembaum exportiert.
Nur aufgeklappte Ordner | Es werden nur die im linken Teil des Fensters aufgeklappten Teile des Dateisystembaums exportiert.
Kopfzeile | Mit dieser Option können Sie steuern, ob beim Export eine Kopfzeile mit den Namen der Spalten erzeugt werden soll.
Einheiten | Ist die Option Im Export verwenden angewählt werden Einheiten wir "KB", "MB" oder "%" zu den exportierten Daten hinzugefügt. Wählen Sie diese Option ab, wenn Sie nur die reinen Werte exportieren möchten. Schalten Sie die Option Immer Byte-Werte, wenn Sie immer reine Byte-Werte exportieren möchten, unabhängig davon, welche Einheit gerade im Hauptfenster gewählt ist. Ohne die Einheiten werden auch die Tausender-Trennzeichen weggelassen, was die Weiterverarbeitung der Werte vereinfacht.
Standard-Exportdatei | Hier können Sie einstellen, in welche Excel-Datei standardmäßig die Daten geschrieben werden sollen (Diese Option steht nur in der Professional Edition zur Vefügung).
Breite der Spalte | Diese Option steht nur für den gedruckten Bericht zur Verfügung. Sie erlaubt es, die Breite der Spalte einzustellen, die momentan in der darüberliegenden Liste selektiert ist.


Reiter "Start"

Navigation: Optionen >

Optionen-Dialog: Reiter "Start"

 Return to chapter overview

Auf dem Reiter Start kann festgelegt werden, was TreeSize Professional nach dem Start tun soll, wenn kein Pfad zur Untersuchung übergeben wurde. Es kann dann eine fixe Liste von Pfaden untersuchen, es kann die Pfade untersuchen, die bei der letzten Benutzung aktiv waren, oder es kann nichts tun, was die Standardeinstellung ist.


Reiter "Shell Erweiterungen"

Navigation: Optionen >

Optionen-Dialog: Reiter "Shell Erweiterungen"

 Return to chapter overview

Auf diesem Reiter können die Shell Erweiterungen von TreeSize Professional für den Windows Explorer konfiguriert werden.

Explorer Kontextmenü | Mit dieser Option legen Sie fest, ob TreeSize Professional im Kontextmenü für Ordner des Windows Explorers erscheinen soll. Ein Klick auf den Eintrag im Kontextmenü öffnet TreeSize Professional, das unmittelbar mit dem Untersuchen des ausgewählten Verzeichnisses beginnt.
Explorer Spalte | Verwenden Sie diese Option, um die "TreeSize"-Spalte für den Windows Explorer ein- oder auszuschalten. Diese zeigt nicht nur die Dateigrößen an, sondern auch Größe der Ordner. Wenn diese aktiviert ist, können hier die Größeneinheit und die Anzahl der Dezimalstellen konfiguriert werden. Zusätzliche Spalten werden vom Windows Vista Explorer leider nicht unterstützt.


Reiter "Dateialter"

Navigation: Optionen >

Reiter "Dateialter"

 Return to chapter overview

Dieser Reiter erlaubt es, die Intervalle zu konfigurieren, auf deren Basis die Grafik für das Dateialter erstellt wird. Die Grenze jedes Intervalls kann angepasst werden, mit der Schaltfläche "+" kann ein Intervall hinzugefügt werden, und mit der Schaltfläche '-' kann ein Intervall gelöscht werden. Mit der Checkbox oberhalb der Liste kann die Erstellung der Statistik auch komplett abgeschaltet werden, was die Speicher-Nutzung von TreeSize Professional etwas reduziert. Außerdem kann noch ausgewählt werden, ob das Dateialter auf Basis der letzten Änderung, des letzten Zugriffs oder des Erstellungsdatums jeder Datei bestimmt werden soll; Standard ist hierbei das Datum der letzten Änderung.

File Ages Tab Options_de


Dateisuche

Navigation: »No topics above this level«

Dateisuche

 Return to chapter overview
· Dateisuche-Fenster

· Dateisuche Menü

· Suchoptionen der Dateisuche

· Größte Dateien

· Ä lteste Dateien

· Temporäre Dateien

· Internet Dateien

· Doppelte Dateien

· Denutzerdefinierte Suche

· Markierte Dateien verschieben


Dateisuche-Fenster

Navigation: Dateisuche >

Dateisuche-Fenster

 Return to chapter overview

Das Fenster zur Dateisuche erlaubt es Ihnen, nach alten, besonders großen oder temporären Dateien zu suchen. Es gibt folgende Seiten im Fenster:

Größte Dateien | Diese Seite bietet die Möglichkeit, Ihre Festplatten nach besonders großen Dateien zu durchsuchen. Sie müssen eine minimale Größe in Kilobytes oder Megabytes angeben. Alle Dateien, die größer als dieser Wert sind, werden dann in der Liste aufgeführt.
Älteste Dateien | Diese Seite erlaubt es Ihnen, nach Dateien zu suchen, auf die seit einem bestimmten Datum nicht mehr zugegriffen wurde oder die seit einem bestimmten Datum nicht mehr geändert worden sind. Die Suche kann auf komplette Ordner eingeschränkt werden. Es werden dann diejenigen Ordner aufgeführt, in denen alle Dateien seit dem angegebenen Datum nicht mehr geändert bzw. geladen worden sind.
Temporäre Dateien | Diese Seite zeigt temporäre Dateien an, die vermutlich nicht mehr benötigt werden. Verwenden Sie die Schaltfläche "Konfigurieren", um die Einstellungen der temporären Dateisuche anzupassen.
Internet-Dateien | Diese Seite zeigt temporäre Internet-Dateien an. Dazu gehören zum Beispiel die Seiten und Grafiken im Cache der Browser Firefox, Netscape und Internet Explorer.
Doppelte Dateien | Diese Seite listet identische Dateien auf, die mehr als einmal auf Ihrer Festplatte vorkommen. Sie können wählen ob Duplikate anhand von gleichen Namen, Größen und Zeitpunkt des letzten Zugriffs, oder durch den Vergleich einer md5 Checksumme des Dateiinhalts erkannt werden. Der Vergleich des Datei-Inhalts liefert genauere Ergebnisse, die Suche dauert allerdings auch länger. Eine Minimalgröße beschleunigt das zusammenstellen der Liste und bewahrt Sie davor, zu viele kleine Dateien durchschauen zu müssen. Sie können ferner bestimmen, ob der Exclude-Filter verwendet werden soll oder nicht. Über das Kontextmenü können Duplikate durch Hardlinks ersetzt werden.
Benutzerdefiniert | Hier können Sie Ihre Suchkriterien frei definieren. Es kann nach Name, Datum, Dateigröße, Attributen und Besitzer gefiltert werden.
Optionen für Suche | Auf dieser Seite können die Laufwerke ausgewählt werden, auf die sich die Suche erstrecken soll, und es können die Sucharten festgelegt werden, die durchgeführt werden sollen. Es können zusätzliche Pfade oder Laufwerke mit den Schaltflächen unterhalb der Liste der Laufwerke hinzugefügt werden.

Auf der rechten Seite des Fensters stehen folgende Schaltflächen zur Verfügung:

Start

Diese Schaltfläche startet die Suche. Sie können nach dem Start bereits Teilergebnisse auf den einzelnen Seiten anschauen. Es ertönt ein kurzes akustisches Signal, wenn die Suche beendet ist.

Stop

Diese Schaltfläche hält die Suche an.

Ergebnisse speichern

Diese Schaltfläche erlaubt es, die Ergebnisse der gerade sichtbaren Suchart abzuspeichern. Die Ergebnisse werden dabei in einer Text- oder CSV-Datei gesichert. Der Dialog zum Speichern der Suchergebnisse verfügt unten über zwei Optionen. Die eine ermöglicht das Speichern aller Ergebnislisten (statt nur der aktiven). Die zweite erlaubt es, nur die markierten Dateien zu speichern. Beim Speichern werden nur die sichtbaren Spalten einbezogen.

Markierte verschieben

Diese Schaltfläche verschiebt oder löscht alle durch einen Haken markierten Dateien auf den einzelnen Seiten. Sie können auswählen, ob die markierten Dateien in den Papierkorb verschoben, komplett von der Festplatte gelöscht oder an einen beliebigen Ort im Dateisystem verschoben werden sollen. Wenn Sie die markierten Dateien zu einem bestimmten Pfad im Dateisystem verschieben, bleibt die Verzeichnisstruktur erhalten. Sie können die Dateien dann zum Beispiel in einer ZIP-Datei oder auf CD-R(W) archivieren. Optional können alle ausgeführten Operationen in eine Protokolldatei geschrieben werden.

TIPP: Sie können einfach eine aufeinander folgende Gruppe von Dateien markieren, indem Sie die Leertaste mehrmals hintereinander drücken. Es können auch mehrere Einträge mittels der Shift- und Strg-Tasten ausgewählt und dann durch den Kontextmenü-Eintrag Markieren markiert werden.

Mit dem Menü der Dateisuche kann man Sucheinstellungen speichern und laden (Menü Datei), neue Suchen starten oder abbrechen (Menü Suche) oder die angezeigten Informationen der Resultatlisten anpassen (Menü Ansicht).


Dateisuche Menü

Navigation: Dateisuche > Dateisuche-Fenster >

Dateisuche Menü

 Return to chapter overview

Datei

Suchoptionen Öffnen... | Öffnet eine zuvor gespeicherte XML-Datei mit Suchoptionen.
Suchoptionen Speichern.... | Speichert eine XML-Datei mit Suchoptionen.
Suchoptionen zurücksetzen | Setzt die aktuellen Suchoptionen zurück auf die jeweiligen Standardwerte.
Suchergebnisse speichern... | Speichert die Ergebnisse der zuletzt durchgeführten Suche.
Pfade exportieren ... | Exportiert Suchpfade in eine txt-Datei.
Pfade importieren... | Importiert Suchpfade in eine txt-Datei.
Liste in die Zwischenablage kopieren | Kopiert die momentan sichtbare Liste in die Zwischenablage. Verwenden Sie das Kontextmenü der Liste um nur die selektierten Einträge zu kopieren.
Liste drucken | Druckt die momentan sichtbare Ergebnislsite
Drucker Einreichten | Erlaubt es, den Drucker zu konfigurieren
Beenden | Beendet das Programm

Dateisuche

Suche starten | Startet die Dateisuche.
Suche anhalten | Stoppt die Dateisuche.
Markierte Dateien verschieben | Verschiebt mit Häkchen markierte Dateien an einen Platz ihrer Wahl. Jede Verschiebeaktion kann auf Wunsch in einer Log-Datei erfasst werden.

Ansicht

Sichtbare Spalten | Ermöglicht die Auswahl sichtbarer Spalten in der Ergebnisansicht. Mögliche Spalten sind :
Pfad | - der Pfad zu einer Datei
Größe | - die Dateigröße
Dateityp / zutreffende Suchoption | - der Dateityp oder andere Suchkriterien, die abgefragt wurden
Letzter Zugriff | - das Datum des letzten Zugriffs
Letzte Änderung | - das Datum der letzten Änderung
Datei-Besitzer | - User-Name des Datei-Besitzers. Hinweis : Die Suche nach dem User-Namen des Datei-Besitzers ist unter Windows eine zeitaufwendige Operation und kann abgeschaltet werden, wenn man sie nicht unbedingt benötigt.
Größenangaben | Ermöglicht die Auswahl der Größeneinheit, in der die Größenangaben angezeigt werden sollen
Bytes | - alle Größenangaben erfolgen in Bytes
KB | - alle Größenangaben erfolgen in Kilobytes
MB | - alle Größenangaben erfolgen in Megabytes
GB | - alle Größenangaben erfolgen in Gigabytes
Gemischte Größeneinheiten | - wählt die nächstliegende, passende Größeneinheit selbständig aus.
Dezimalstellen | Legt fest, wieviele Nachkommastellen angezeigt werden
0 | - es werden keine Nachkommastellen angezeigt
1 | - es wird eine Nachkommastelle angezeigt
2 | - es werden zwei Nachkommastellen angezeigt
3 | - es werden drei Nachkommastellen angezeigt
Komprimierte Dateien | Legt fest, ob die angezeigten Dateigrößen der tatsächlichen Dateigröße oder der komprimierten Dateigröße entsprechen.
Dateigröße verwenden | - verwendet die (tatsächliche) Dateigröße
Komprimierte Dateigröße verwenden (langsamer) | - verwendet die komprimierte Dateigröße
Mountpoits und symbolischen Links folgen | Diese Option entscheidet darüber, ob TreeSize Professional Mountpoints und symbolischen Links auf andere Laufwerke oder Ordner auf diesen folgen soll oder nicht. Weitere Informationen hierzu gibt es im Kapitel "Hinweise zu NTFS".
Alle Suchergebnisse markieren | Aktivieren Sie diese Option wenn Sie möchten, dass alle Suchergebnisse in den Ergebnislisten automatisch markiert werden.
Lange Tooltips in den Listen anzeigen | Aktiviert die Anzeige langer Tooltips mit ausführlichen in den Dateilisten

Extras

Papierkorb leeren | Leert den Papierkorb.
TreeSize Professional Dateisuche als Administrator starten | Startet die TreeSize Professional Dateisuche erneut mit Administrator Previlegien.

Hilfe

Hilfe für Dateisuche | Öffnet die Hilfe der Dateisuche
F.A.Q. für Dateisuche | Öffnet die F.A.Q. der Dateisuche
Auf Update überprüfen... | Prüft, ob eine neuere Version von TreeSize verfügbar ist.
Info... | Liefert Informationen über TreeSize


Optionen der Dateisuche

Navigation: Dateisuche > Dateisuche-Fenster >

Optionen der Dateisuche

 Return to chapter overview

Der Reiter Optionen für Suche erlaubt das Konfigurieren verschiedener Aspekte der Dateisuche.

Laufwerke und Pfade, die durchsucht werden sollen

Verwenden Sie die Checkboxen vor den einzelnen Laufwerken, um auszuwählen, welche Pfade die Dateisuche durchsuchen soll. Mit den darunter liegenden Schaltflächen können zusätzliche lokale und Netzwerk-Pfade hinzugefügt werden. Die erste Schaltfläche erlaubt dabei das Eingeben des Pfades über die Tastatur, der zweite öffnet einen Dialog mit einem Verzeichnis-Browser.

Sie können ganze PCs oder Server durchsuchen, indem Sie deren UNC Namen in der Art \\SERVER angeben. Sie können Ihre gesamte Domäne durch Verwendung ihres UNC-Namens durchsuchen, z.B. \\DOMAIN. Es kann sogar die gesamte Netzwerkumgebung durchsucht werden, indem diese einfach im Dialog ausgewählt wird, der nach Betätigen der Schaltfläche Pfad auswählen angezeigt wird. TreeSize Professional sucht automatisch nach PCs und allen darauf vorhandenen Freigaben (inklusive administrativen Freigaben) und führt die Suche dann auf allen gefundenen Freigaben aus.

Aktivierte Sucharten

Verwenden Sie die Checkboxen vor jedem Eintrag, um einzelne Sucharten zu aktivieren oder zu deaktivieren.

Filter für Dateien / Ordner

Die Dateisuche wurde entwickelt, um überflüssige und sehr große Dateien aufzuspüren. Einige Dateien, wie zu Beispiel Systemdateien, dürfen jedoch nicht gelöscht werden, da sie vom Betriebssystem oder darauf installierter Software benötigt werden. Dateien, von denen bekannt ist, dass sie auf dem System benötigt werden, können mit Hilfe dieser Liste gefiltert werden und erscheinen dann nicht mehr in den Ergebnislisten. Neue Einträge in dieser Liste können auch leicht mit Hilfe des Kontextmenüs der Ergebnisliste hinzugefügt werden.

Außerdem können Dateien heraus gefiltert werden, die in den letzten Stunden geändert wurden. Falls eine Datei erst kürzlich geändert wurde, besteht eine hohe Wahrscheinlichkeit, dass diese nicht überflüssig ist.

Hinweis: Diese Option wird standardmässig bei der Suche nach doppelten Dateien nicht angewendet.


Größte Dateien

Navigation: Dateisuche >

Größte Dateien

 Return to chapter overview

Dieser Zeiter bietet die Suchfunktion nach den größten Dateien in den ausgewählten Pfaden / Laufwerken. Man kann allerdings auch eine Mindestgröße (in Kilobyte oder auch Megabyte) für Dateien angeben, so müssen weniger Dateien überprüft werden. Da nur Dateien oberhalb der Mindestgröße überprüft werden, läuft die Dateisuche merklich schneller ab, als eine Überprüfung aller Dateien im angegebenen Pfad. Alle Dateien, die größer als dieser angegebene Grenzwert sind, erscheinen dann auch in der Ergebnisliste.

Suche Dateien größer als...

Definiert die Mindestgröße für eine Datei.

Wie bei allen Suchoperationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Älteste Dateien

Navigation: Dateisuche >

Älteste Dateien

 Return to chapter overview

Dieser Reiter ermöglicht es Ihnen, in den ausgewählten Pfaden / Laufwerken nach Dateien zu suchen, die seit einer gewissen Zeit nicht verändert wurden, oder auf die seit einer gewissen Zeit nicht zugegriffen wurde. Sie können die Suche auch auf ganze Ordner einschränken - Ihnen werden dann nur Ordner im Suchergebnis zurückgeliefert, bei denen alle darin gespeicherten Dateien die Auswahlkriterien erfüllen. So können Sie einfach komplette Zweige Ihres Dateisystems identifizieren, die nicht mehr in Gebrauch sind.

Suche nach Dateien [ohne Änderung / ohne Zugriff] | Wählt aus, nach welchem Typ Datei TreeSize Professional suchen soll. Auf Dateien kann regelmässig zugegriffen werden, ohne sie zu verändern.
seit | Definiert, wie lange schon die Datei sich in dem gesuchten Zustand befinden soll.
Nur komplette Verzeichnisse | Liefert als Ergebnisse nur Ordner zurück, in denen alle Dateien (einschließlich denen in den Unterordnern) das Suchkriterium erfüllen.

Wie bei allen Suchoperationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Suche nach temporären Dateien - Konfiguration

Navigation: Dateisuche >

Suche nach temporären Dateien - Konfiguration

 Return to chapter overview

Dieser Reiter ermöglicht es Ihnen nach Dateien zu suchen, die als "temporär" eingestuft wurden, da sie nicht dauerhaft gebraucht werden. Über die Schaltfläche Konfiguration können Sie die Suche nach temporären Dateien Ihren Bedürfnissen anpassen.

Muster

Die zentrale Funktion der temporären Dateisuche basiert auf dem Auffinden von Dateinamen mit typischen Mustern. Diese Muster können konfiguriert werden, nachdem die Schaltfläche Konfigurieren im oberen Teil der Suche nach temporären Dateien betätigt worden ist. Es können dann einzelne Muster editiert, gelöscht oder hinzugefügt werden. Durch die Checkboxen auf der linken Seite können einzelne Muster auch vorübergehend deaktiviert werden.

Platzhalter, die man in Mustern verwenden kann :

* | Ersetzt zwischen null und beliebig vielen alphanumerische Zeichen.
? | Ersetzt genau ein alphanumerisches Zeichen.

Dateien mit gesetztem Attribut für "temporär" einbeziehen | Anwendungen, die temporäre Dateien erstellen, können das System über diesen Umstand durch Setzen eines speziellen Attributs informieren. Ist diese Option aktiviert, fügt TreeSize Professional auch diese Dateien der Ergebnisliste hinzu.
Dateien einbeziehen, die zu keinem gültigen Benutzeraccount gehören | Wird ein Benutzerprofil unter Windows gelöscht, werden nicht automatisch alle Dateien gelöscht, die als Besitzer dieses Benutzerpofil haben, und belegen so weiterhin Plattenplatz. Durch Aktivierung dieser Option werden solche Dateien der Ergebnisliste hinzugefügt. Da für jede Datei zunächst der zugehörige Besitzer bestimmt werden muss, verlangsamt die Aktivierung dieser Option den Scan-Prozess deutlich.
Verweise ohne gültiges Ziel einbeziehen | Durch Aktivierung dieser Option überprüft TreeSize Professional .LNK und .PIF Dateien daraufhin, ob der zugehörige Zielpfad noch existiert. Ist dies nicht der Fall, so werden die entsprechenden Dateien der Ergebnisliste hinzugefügt.
Verknüpfungen zu zuletzt verwendeten Dokumenten einbeziehen | Falls diese Option aktiviert ist, wird TreeSize Professional überprüfen, ob es Verknüpfungen zum Ordner "Zuletzt verwendete Dokumente" gibt.

Bearbeiten | Ermöglicht es, ein ausgewähltes Muster aus der Musterliste zu bearbeiten.
Hinzufügen | Fügt ein neues Muster zur Musterliste hinzu.
Löschen | Löscht ein ausgewähltes Muster aus der Musterliste.

Wie bei allen Suchoperationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Suche nach Internet-Dateien

Navigation: Dateisuche >

Suche nach Internet-Dateien

 Return to chapter overview

Dieser Reiter erlaubt es Ihnen, nach Dateien zu suchen, die durch Download- oder Surfaktivitäten auf ihren Rechner gekommen sind (wie z.B. die Dateien im Cache Ihres Internet-Browsers). Die Suche nach Internet-Dateien kann auch über die Kommandozeilenoption /SEARCH:Internet erfolgen.

Cookies einschließen | Erweitert die Suche, um auch Cookies zu finden.
Alle markieren | Markiert alle gefundenen Dateien für einen Verschiebungsvorgang.

Wie bei allen Suchoperationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Doppelte Dateien

Navigation: Dateisuche >

Doppelte Dateien

 Return to chapter overview

Hier können Sie sich all die Dateien aufllisten lassen, die auf Ihrer Festplatte mehr als einmal zu finden sind. Dabei können Sie wählen, wie genau Sie auf Gleichheit der Dateien testen wollen : zum Einen kann die Kombination aus demselben Namen, derselben Dateigröße und desselben Datum der letzten Änderung abgetestet werden. Zum Anderen kann man auch auf inhaltliche Identität abprüfen lassen, indem man die MD5-Prüfsummen der fraglichen Dateien vergleicht.

Der Vergleich der Prüfsummen bringt zwar die verlässlichsten Resultate, ist aber auch bedeutend zeitintensiver in der Ausführung. Sie können aber durch ein paar einfache Maßnahmen die Dauer der Suche verringern :

· Die Angabe einer Mindestgröße für die zu überprüfenden Dateien schränkt die Anzahl der zu überprüfenden Dateien (und dadurch auch die Dauer der Suche) ein.
· Wenn möglich, aktivieren Sie die Option Scan Filter anwenden; dadurch werden alle Dateien, die dem Muster der auszuschließenden Dateien genügen, automatisch bei der Suche ignoriert.
· Aktivieren Sie die Option NTFS Hardlinks ignorieren, um eine Überprüfung der Hardlinks zu umgehen und somit Zeit zu sparen.

Das Kontext-Menü bietet die Möglichkeit, aufgefundene Datei-Dubletten durch Hardlinks zu ersetzen. Dabei werden bis auf eine Datei alle anderen identischen Dateien durch Hardlinks zu der erstgenannten Datei ersetzt. Da Hardlinks keinen nennenswerten Platz auf Ihrer Festplatte verbrauchen, wird nur der Platz für eine einzige Datei alloziert - und das spart Platz ohne Funktionalität aufzugeben.

Hinweis: Es ist nur dann möglich, Datei-Dubletten durch Hardlinks zu ersetzen, wenn der Verweis eines Hardlinks zu einer Datei auf derselben NTFS-Partition führt.

Minimalgröße in KB | Definiert die Minimalgröße von Dateien, die in der Duplikatensuche berücksichtigt werden.
Mittels MD5-Prüfsumme vergleichen (genauer) / Größe, Name und Datum vergleichen (schneller) | Legt die Art des Dateivergleiches fest: entweder werden nur Name, Größe und letztes Änderungsdatum von Dateien verglichen, oder es erfolgt ein Vergleich der MD5-Prüfsumme der betreffenden Dateien. Hinweis: Wenn der MD5-Prüfsummen Vergleiche benutzt wird, werden leere Dateien ignoriert, da es keinen Dateiinhalt gibt der verglichen werden könnet.
Scan Filter anwenden | Falls aktiviert, ignoriert die Dateisuche alle Dateien, die dem Muster der auszuschließenden Dateien gemäß Scan-Filter-Einstellungen genügen.
NTFS Hardlinks ignorieren | Falls aktiviert, ignoriert die Dateisuche die NTFS Hardlinks, was die Suchgeschwindigkeit erhöhen wird.

Wie bei allen Suchoperationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Benutzerdefinierte Suche

Navigation: Dateisuche >

Benutzerdefinierte Suche

 Return to chapter overview

Diese Reitergruppe ermöglicht es Ihnen, eine komplett benutzerdefinierte Dateisuche durchzuführen. Dabei können Sie nach

· Dateinamen

· Datei-Erstellungs-, Zugriffs-, und Änderungsdaten

· Dateigrößen, und -attributen

· Dateibesitzern

suchen.


Benutzerdefinierte Suche - Suche nach Dateinamen

Navigation: Dateisuche > Benutzerdefinierte Suche >

Benutzerdefinierte Suche - Suche nach Dateinamen

 Return to chapter overview

Hier können Sie eine Suche nach Dateinamen / Dateinamensmuster definieren.

Scan Filter anwenden | Aktiviert die Option Scan Filter anwenden. Dateien mit gewissen Namen oder Namensmustern werden von der Suche ausgenommen.
Unterordner durchsuchen | Weist die Dateisuche an, nicht nur den aktuellen Ordner, sondern auch alle Unterordner des aktuellen Ordners zu durchsuchen.

Das Listenfeld, das Text-Feld und die zwei Schaltflächen auf der rechten Seite realisieren die Dateinamensuche. Sie können hier Muster angeben, denen die gesuchten Dateie genügen müssen.

Hinzufügen | Fügt einen neuen Dateinamen oder ein neues Dateinamensmuster, nach dem gesucht werden soll, der Liste hinzu.
Entfernen | Entfernt ein ausgewähltes Muster aus der Liste der zu suchenden Muster.

Platzhalter, die zum Bau von Namensmustern für Dateien verwendet werden können:

* | Ersetzt kein oder beliebig viele alphanumerische Zeichen
? | Ersetzt genau ein alphanumerisches Zeichen

Muster dürfen nicht nur Datei-Teile enthalten (z.B. *.doc), sondern auch ganze Pfade (z.B. *\Windows\System32\*.exe oder *\Temp\*\*.old)

Wie bei allen Such-Operationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Benutzerdefinierte Suche - Suche nach Änderungs-, Zugriffs- und Erstellungsdatum

Navigation: Dateisuche > Benutzerdefinierte Suche >

Benutzerdefinierte Suche - Suche nach Änderungs-, Zugriffs- und Erstellungsdatum

 Return to chapter overview

In diesem Unterreiter können Sie eine benutzerdefinierte Suche nach Änderungs-, Zugriffs- und Erstellungsdaten von Dateien spezifizieren. Die zu durchsuchende Zeitperiode kann explizit als Zeitraum zwischen zwei bezeichneten Daten angegeben werden oder als Zeitraum mit Bezug auf das aktuelle Datum.

Ein zu durchsuchender Zeitraum kann also folgendermassen angegeben werden :

· indem man ein Datum angibt, nach dem das Ereignis stattgefunden hat (Startdatum) und ein Datum angibt, vor dem das Ereignis stattgefunden hat (Stoppdatum). Indem Sie ein Start- und ein Stoppdatum angeben, werden nur Dateien herausgefiltert, deren Änderungs- / Zugriffs- / Erstellungsdatum innerhalb dieser Grenzdaten liegt.
· indem man ein Datum angibt, nach dem das Ereignis stattgefunden hat (Startdatum); die Dateisuche wird so nur Dateien finden, deren Änderungs- / Zugriffs- / Erstellungsdatum nach diesem Grenzdatum liegt.
· indem man ein Datum angibt, vor dem das Ereignis stattgefunden hat (Stoppdatum); die Dateisuche wird so nur Dateien finden, deren Änderungs- / Zugriffs- / Erstellungsdatum vor diesem Grenzdatum liegt.
· indem Sie festlegen, seit wievielen Tagen vor dem heutigen Datum, sich das Änderungs- / Zugriffs- / Erstellungsdatum (nicht) geändert hat.

Geändert / Ohne Änderung | Sucht nach Dateien, die innerhalb / vor / nach / seit der angegebenen Zeit geändert wurden oder ohne Änderung blieben.
Zugriff / Ohne Zugriff | Sucht nach Dateien, auf die innerhalb / vor / nach / seit der angegebenen Zeit zugegriffen wurden oder die ohne Zugriff blieben.
Erstellt / Nicht erstellt | Sucht nach Dateien, die innerhalb / vor / nach / seit der angegebenen Zeit erstellt / nicht erstellt wurden.
zwischen... und.... | Grenzen für das betrachtete Zeitintervall.
seit... | Definiert eine in Tage gemessene Zeitspanne, seitdem eine Datei geändert /nicht geändert, zugegriffen / nicht zugegriffen, erstellt / nicht erstellt wurde.

Wie bei allen Suchoperationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Benutzerdefinierte Suche - Suche nach Dateigröße und -attributen

Navigation: Dateisuche > Benutzerdefinierte Suche >

Benutzerdefinierte Suche - Suche nach Dateigröße und -attributen

 Return to chapter overview

Dieser Unterreiter ermöglicht es Ihnen eine Suche nach Dateien einer gewissen Mindest- / Maximalgrösse bzw. nach Dateien mit gewissen Dateiattributen zu spezifizieren.

Minimale Größe | Legt die minimale Dateigröße für zu suchende Dateien fest. Die danebenstehende ComboBox legt die Einheitengröße für die Zahlenangabe fest.
Maximale Größe | Legt die maximale Dateigröße für zu suchende Dateien fest. Die danebenstehende ComboBox legt die Einheitengröße für die Zahlenangabe fest.
Pfad länger als: | Weist die Suchfunktion an, nach Deiten zu suchen, deren Pfad mindestens die angegebene Zahl von Zeichen lang ist.

Sie können auch nach folgenden Dateiattributen suchen :

Schreibgeschützt | Sucht nach Dateien mit dem Dateiattribut "Schreibgeschützt".
Versteckt | Sucht nach Dateien mit dem Dateiattribut "Versteckt".
System | Sucht nach Dateien mit dem Dateiattribut "System".
Archiv | Sucht nach Dateien mit dem Dateiattribut "Archiv".
Komprimiert | Sucht nach Dateien mit dem Dateiattribut "Komprimiert".
Verschlüsselt | Sucht nach Dateien mit dem Dateiattribut "Verschlüsselt".
Offline | Sucht nach Dateien mit dem Dateiattribut "Offline".
Temporär | Sucht nach Dateien mit dem Dateiattribut "Temporär".
Alternate Data Streams | Sucht nach Dateien, die NTFS Alternate Data Streams enthalten

Wie bei allen Suchoperationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Benutzerdefinierte Suche - Suche nach dem Dateibesitzer

Navigation: Dateisuche > Benutzerdefinierte Suche >

Benutzerdefinierte Suche - Suche nach dem Dateibesitzer

 Return to chapter overview

Hier können SIe eine Suche nach Dateien eines spezifischen Users definieren. Als Suchparameter giilt der Benutzername des Users, wie er auf dem System angelegt ist.

Das Listenfeld, das Text-Feld und die zwei Schaltflächen auf der rechten Seite realisieren die Dateinamensuche und die Ergebnisrepräsentation.

Hinzufügen | Fügt einen neuen Dateibesitzernamen oder ein neues Dateibenutzernamensmuster, nach dem gesucht werden soll, der Liste hinzu.
Entfernen | Entfernt ein ausgewähltes Muster aus der Liste der zu suchenden Muster.

Platzhalter, die zum Bau von Namensmustern für Dateien verwendet werden können :

* | Ersetzt kein oder beliebig viele alphanumerische Zeichen
? | Ersetzt genau ein alphanumerisches Zeichen

Wie bei allen Suchoperationen, können Sie jede, mit einem Häkchen markierte Datei aus der Ergebnisliste über die Schaltfläche Mark. Verschieben an einen anderen Punkt im Dateisystem verschieben (oder auch in den Papierkorb).


Markierte Dateien verschieben

Navigation: Dateisuche >

Markierte Dateien verschieben

 Return to chapter overview

Die Schaltfläche Mark. verschieben ermöglicht es Ihnen, alle in den Ergebnislisten ausgewählten Dateien an einen Ort Ihrer Wahl zu verschieben. Dabei merkt sich die Dateisuche von TreeSize Professional, welche Dateien markiert wurden, auch wenn Sie den Reiter wechseln.

Beim Transfer an den von Ihnen gewünschten Zielort im Dateisystem, werden alle ausgewählten Dateien unter Beibehaltung ihrer ursprünglichen relativen Position zueinander bewegt. Sie können auch die markierten Dateien in ein ZIP-Archiv oder auch in den Papierkorb verschieben. Wenn Sie es wünschen, können alle Dateibewegungen in einer Log-Datei protokolliert werden.

Tipp: Sie können ganz leicht eine ganze Gruppe von Dateien markieren, indem Sie die Leertaste gedrückt halten, oder auch mit der Shift- bzw. Ctrl-Taste Dateien blockweise anwählen und dann den entsprechenden Eintrag im Kontext-Menü auswählen.

Markierte Dateien in den Papierkorb verschieben | Verschiebt markierte Dateien direkt in den Papierkorb. Um diese Dateien endgültig zu löschen, müssen sie den Papierkorb leeren.
Lösche markierte Dateien von der Festplatte | Löscht alle markierten Dateien nach einer Sicherheitsrückfrage.
Markierte Dateien in folg. ZIP-Datei verschieben: | Verschiebt markierte Dateien in das angegebene ZIP-Archiv. Hinweis: Wenn ZIP-Dateien Unicode Datei- oder Ordnernamen enthalten, so können diese nur mit einer Unicode kompatiblem ZIP-Software (siehe "Unicode Zip-Dateien") sauber extrahiert werden.
Markierte Dateien verschieben nach: | Verschiebt markierte Dateien in den angegebenen Pfad. Optional kann an der ursprünglichen Stelle eine Verknüpfung erzeugt werden, die jeweils auf die neue Position des verschobenen Objekts zeigt. Die ursprüngliche Verzeichnisstruktur wird im Zielpfad wiederhergestellt (sofern die Ordner nicht leer sind) und bleibt somit erhalten. Optional können außerdem die Sicherheitsattribute mit kopiert werden. Geschieht dies nicht, so erben die die verschobenen Dateien ihre Sicherheitsattribute wie üblich von den übergeordneten Elementen.
Dateipfade an ausführbare Datei übergeben: | Ruft für jede markierte Datei eine frei wählbare ausführbare Datei auf und übergibt den absoluten Pfad der Datei als ersten Parameter. Bei den ausführbaren Dateien kann es sich auch um Batch, VBScript oder ähnliche Dateien handeln.
Leere Ordner nach dem Verschieben löschen | Entfernt Ordner, die aufgrund dieser Verschiebe-Operation keine Dateien oder andere Ordner mehr enthalten.
Anzahl aller markierten Objekte: | Gibt die Gesamtanzahl aller markierten Dateien an.
Gesamtgröße der markierten Dateien: | Gibt die Gesamtgröße aller markierten Dateien an.
Protokoll aller durchgeführten Operationen schreiben nach : | Erzeugt ein Protokoll mit einem Namen Ihrer Wahl in einem Verzeichnis Ihrer Wahl. Im Dateinamen können Umgebungsvariablen wie %DATE% oder %TIME% verwendet werden.

Es wird dringend dazu geraten, all Ihre Verschiebe-, Lösch- und Archivierungsaktionen protokollieren zu lassen. Ein solches Vorgehen erhöht die Sicherheit und Übersichtlichkeit Ihres Systems und erleichtert die Systemwartung.

Das von TreeSize Professional erzeugte Protokoll verzeichnet alle nötigen Details, die man braucht, um eine Wartungsaktion nachverfolgen zu können. Das Protokoll wird im txt-Format abgespeichert und sieht beispielsweise so aus :

TreeSize Professional is starting move operation on 30.11.2007 10:50.

Moving the files to: C:\Obsolete\

"C:\WINDOWS\BGInfo.bmp" => "C:\Obsolete\C\WINDOWS\BGInfo.bmp"

"C:\WINDOWS\Help\article.chm" => "C:\Obsolete\C\WINDOWS\Help\article.chm"

Finished at 30.11.2007 10:50.

Freed Space: 7407476 Bytes (7 MB)


Unicode Zip-Dateien

Navigation: Dateisuche > Markierte Dateien verschieben >

Unicode ZIP-Dateien

 Return to chapter overview

TreeSize Professional kann auch Dateien in ZIP-Archive verschieben, deren Dateiname Zeichen enthalten die nicht in der aktivierten Codepage enthalten sind (Unicode Dateinamen). Um diese Unicode kodierten ZIP-Dateien wieder korrekt zu entpacken benötigen Sie ein ZIP-Programm, dass Unicode Dateinamen dekodieren kann. Anderenfalls werden beim entpacken die Dateinamen nicht korrekt wiederhergestellt.

Hier ist eine Liste von getesteten ZIP-Programmen:

Unicode kompatibel: | Nicht Unicode kompatibel:
WinRAR (V3.8 oder höher) | Integriertes ZIP Tool von Windows (XP / Vista / Server 200X)
WinZip (V11.2 oder höher) | TUGzip (getestet mit V 3.5)
7-Zip (V4.6 oder höher) | IZArc (getestet mit V 3.81)
 | Filzip (getestet mit V 3.06)
 | WinAce (getestet mit V2.61)


Zeitgesteuerte Untersuchungen

Navigation: »No topics above this level«

Zeitgesteuerte Untersuchungen

 Return to chapter overview
· TreeSize-Scans planen
· Kommandozeilenparameter


TreeSize Scans planen

Navigation: Zeitgesteuerte Untersuchungen >

TreeSize-Scans planen

 Return to chapter overview

Zeitgesteuerte Programmausführungen unter Windows sind möglich, indem Sie den Geplanten Tasks von Windows Programmaufrufe hinzufügen. Mit Hilfe dieses Dialogs entwerfen Sie einen TreeSize-Programmaufruf mit den geeigneten Kommandozeilen-Parametern, um die von Ihnen gewünschten Aufgaben auszuführen. Diese Funktion ist nur in der Professional Edition enthalten.

Zu untersuchendes Verzeichnis | Tragen Sie hier das Verzeichnis ein, das von TreeSize Professional untersucht werden soll.
Export | In diesem Bereich können Sie zwischen den verschiedenen Export-Möglichkeiten, die TreeSize Professional unterstützt, die von Ihnen gewünschten auswählen. Die einzelnen Optionen entsprechen verschiedenen Kommandozeilen-Parametern.
Optionen | Hier können Sie Einstellungen für die Untersuchung vornehmen und weitere Verarbeitungsschritte angeben, die nach der Untersuchung ausgeführt werden sollen.
Zeitplanung | Geben Sie hier an, wann und in welchem zeitlichen Abstand Windows die von Ihnen generierte Untersuchung durchführen soll.
Kommandozeile | Hier wird der Programmaufruf mit den von Ihnen ausgewählten Kommandozeilen-Parametern angezeigt. Möchten Sie den Programmaufruf nicht den Geplanten Tasks von Windows hinzufügen, so können Sie sich den Programmaufruf hier kopieren, um ihn anderweitig zu verwenden, z.B. in einer Batch-Datei.

Der generierte Programmaufruf kann den Windows Geplanten Tasks automatisch über die Schaltfläche Task hinzufügen hinzugefügt werden.


Kommandozeilen-Parameter

Navigation: Zeitgesteuerte Untersuchungen >

Kommandozeilen-Parameter

 Return to chapter overview

Die Professional Version von TreeSize Professional akzeptiert Kommandozeilen-Parameter, die zeitgesteuerte Untersuchungen erlauben. Mit Hilfe von "TreeSize-Scans planen" aus dem Extras-Menü können Sie einfach einen Aufruf mit den unten stehenden Kommandozeilen-Parametern zusammenstellen.

Treesize.exe [/ARCHIVEBITFILESONLY] [/(BAR|PIE)CHART filename] [/COMPARE filename] [/DATE] [/EMAIL] [/EXCEL filename] [/EXPAND [level|xxMB]] [/EXTENSIONSLIST filename] [/FILEAGESCHART filename] [/FILTER pattern1;pattern2;...] [/GROUPSCANS] [/FOLLOWREPARSEPOINTS] [/HTML filename] [/HISTORYCHART filename] [/LISTSEPARATOR character] [/MOVETO (path|ZIP-file|Recycle Bin|Executable)] [/NOGUI] [/NOHEADERS] [/NOUNITS] [/OPEN] [/PRINT] [/SAVE filename] [/SEARCH[:Start|:Internet]] [/SIZEUNIT N] [/TITLE text] [/USERSLIST filename] [/XML filename] Verzeichnisse

/ARCHIVEBITFILESONLY

Diese Option wird nur solche Dateien in die Scans miteinbeziehen, bei denen das Archiv-Bit gesetzt ist. Dies kann beispielsweise genutzt werden, um die Größe von Backups zu bestimmen. In diesem Fall können Sie eine Verknüpfung zu TreeSize.exe auf dem Desktop oder im Startmenü erstellen, die automatisch mit der Berechnung der Größe des Backup beginnt:

Treesize /ARCHIVEBITFILESONLY \\Server\Backup\

/BARCHART

Speichert das Balkendiagramm des untersuchten Verzeichnisses als Bitmap, GIF oder JPEG-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Beispiel:

Treesize /CHART C:\Dokumente\chart-datei.jpg C:\

/COMPARE

Vergleicht den untersuchten Pfad mit einem gespeicherten XML-Report. Das folgende Beispiel untersucht das Laufwerk C: und vergleicht es anschließend mit einem gespeicherten XML-Report für dieses Laufwerk:

Treesize /COMPARE "C:\Temp\TSP XML\c.xml" C:\

Alternativ kann man aber auch 2 bereits gespeicherte XML-Reports z.B. "c1.xml" und "c2.xml" miteinander vergleichen, indem man das folgende Kommando benutzt :

Treesize /OPEN "C:\Temp\TSP XML\c1.xml" /COMPARE "C:\Temp\TSP XML\c2.xml"

Das /OPEN-Kommando bereitet den Vergleich der beiden Dateien vor, indem es "cl.xml" in eine normale Scan-Datei umwandelt. Die zweite Datei ("c2.xml") wird dann mit der Scan-Datei verglichen - ganz genau so, wie es auch passieren würde, wenn man "c2.xml" mit dem Ergebnis eines gerade erst erfolgten Scan vergliche.

/CREATEDPASTDAYSONLY

Diese Option wird nur solche Dateien in den Scan miteinbeziehen, die innerhalb der angegebenen Anzahl der letzten zurückliegenden Tage erstellt wurden.

Treesize /CREATEDPASTDAYSONLY 8

In diesem Beispiel werden nur Dateien in den Scan miteinbezogen, die innerhalb der letzten 8 Tage neu erstellt worden sind.

Damit korrespondiert der Parameter mit der Option "Nur Dateien mit Erstellungsdatum innerhalb: XX Tage(n)" im Optionen Dialog.

/DATE

Diese Option fügt jedem Dateinamen, in dem Ergebnisse gespeichert werden und der nach dieser Option aufgeführt wird, Datum und Uhrzeit hinzu. Dies ist besonders nützlich, wenn man regelmäßig zeitgesteuerte Untersuchungen durchführt. Wenn allen Dateinamen Datum und Uhrzeit hinzugefügt werden soll, sollte /DATE der erste Kommandozeilen Parameter sein. Das folgende Beispiel würde den Netzwerkpfad \\Host\\Share untersuchen und das Ergebnis unter einem Dateinamen der Art C:\scans\name_99-12-20_1550.xls speichern:

Treesize /DATE /EXCEL C:\scans\name.xls \\Host\Share

/EMAIL

Sendet die gesammelten Daten an die angegebene E-Mail-Adresse über die MAPI-Schnittstelle von Windows. MAPI muss daher in der Systemsteuerung passend konfiguriert sein. Es können mehrere Empfänger angegeben werden, die jeweils durch ein Semikolon oder Komma getrennt werden müssen. Beispiel:

Treesize /EMAIL sysadmin@company.com \\SERVER\C$

Sollte MAPI für Sie nicht ausreichend sein, empfehlen wir, die Daten in eine Datei schreiben zu lassen und diese anschließend mit einem Kommandozeilen Mail-Tool wie dem kostenlosen BLAT zu versenden.

/EXCEL

Exportiert die gesammelten Ergebnisse nach Excel und speichert sie unter dem angegebenen Namen ab. Existiert die Datei bereits, so wird sie geöffnet und die Ergebnisse auf einem neuen Tabellenblatt hinzugefügt. TreeSize Professional wird anschließend beendet. Beispiel:

Treesize /EXCEL C:\Dokumente\c.xls C:\

/EXCLUDE

Diese Option erlaubt die Angabe von Mustern für Dateien und Ordner, die beim Untersuchen der Platte ignoriert werden sollen. Mehrere Muster können jeweils durch ein Semikolon getrennt werden. Enthält ein Suchmuster Leerzeichen, so muss der gesamte String in Anführungszeichen gesetzt werden, so wie es im Beispiel unten zu sehen ist. Diese Kommandozeilen-Option entspricht den Ausschlusskriterien in den Optionen. Das folgende Beispiel würde Ordner und Dateien ignorieren, die auf ".001" enden sowie die den Namen "system" haben:

Treesize /EXCLUDE "*.001;system" \\Server\Users

/EXPAND

Mit diesem Parameter kann festgelegt werden, wie viele Ebenen des Verzeichnisbaumes eingeblendet werden, nachdem die Untersuchung abgeschlossen ist. Wird keine Zahl angeben, so wird der Verzeichnisbaum komplett eingeblendet. Es kann auch eine Angabe in MB gemacht werden, was dazu führt, dass alle Verzeichnisse, die größer als der angegebene Wert sind, eingeblendet werden. Bitte beachten Sie, dass sich zwischen der Zahl und der Einheit "MB" kein Leerzeichen befinden darf. Beispiele:

Treesize /EXCEL C:\Results\Allusers.xls /EXPAND 2 H:\User

Treesize /EXCEL C:\Results\C.xls /EXPAND 10MB C:\

/EXTENSIONSLIST

Diese Option schreibt die Statistik über die Verteilung der Dateitypen / Dateiendungen des untersuchten Dateisystemzweiges in eine Excel, Text- oder CSV-Datei. Das folgende Beispiel untersucht Laufwerk C: und erstellt eine Excel-Datei in C:\Temp mit der Statistik der Dateitypen auf diesem Laufwerk:

Treesize /EXTENSIONSLIST C:\Temp\C_filetypes.xls C:\

/FILEAGESCHART

Speichert das Diagramm auf dem Reiter "Dateialter" des untersuchten Verzeichnisses als Bitmap, GIF oder JPEG-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Beispiel:

Treesize /FILEAGESCHART C:\Dokumente\C_Dateialter.jpg C:\

/FILTER

Erlaubt das Setzen eines Filters, so dass nur bestimmte Dateitypen wie *.MP3 oder *.DOC in den Scan mit einbezogen werden. Es können mehrere Filter übergeben werden, die mittels Leerzeichen, Kommata oder Semikola getrennt werden müssen. Das folgende Beispiel sucht nach AVI- und MP3-Dateien im Verzeichnis "Users"direkt auf dem Server:

Treesize /EXCEL C:\Results\MediaUsers.xls /FILTER "*.mp3;*.avi" \\Server\Users

/FOLLOWREPARSEPOINTS

Das Hinzufügen dieser Option zur Kommandozeile von TreeSize Professional bewirkt, dass bei Mountpoints und symbolischen Links, die wärhrend eines Scans gefunden werden, gefolgt wird.

/GROUPSCANS

Die Angabe dieser Kommandozeilen-Option führt dazu, dass alle durchgeführten Scans unter einem virtuellen Wurzelverzeichnis zusammengefasst werden.

/HTML

Speichert die gesammelten Daten in einer HTML-Datei, welche dann mit jedem Internet-Browser angeschaut werden kann. Wird zusätzlich noch der Parameter /PIECHART oder /BARCHART angegeben, wird das entsprechende Diagramm in die resultierende HTML-Datei eingebettet. Das folgende Beispiel erzeugt einen HTML-Report für das Laufwerk C:und speichert diese im Verzeichnis D:\html:

Treesize /DATE /HTML d:\HTML\treesize.html /PIECHART d:\HTML\treesize.jpg C:\

Wenn Sie gerne mehrere Verzeichnisse oder Laufwerke untersuchen und exportieren möchten, empfehlen wir, entweder einen gesonderten Aufruf von TreeSize Professional für jedes Laufwerk / Verzeichnis, oder die Kommandozeilen-Parameter in der folgenden Art zu verwenden:

Treesize /HTML d:\html\drive_c.html /PIECHART d:\html\drive_c.jpg C:\ /HTML d:\HTML\drive_d.html /PIECHART d:\HTML\drive_d.jpg D:\

/HISTORYCHART

Speichert das Diagramm auf dem Reiter Historie des untersuchten Verzeichnisses als Bitmap, GIF oder JPEG-Datei. Der Typ der Datei wird über die Dateiendung bestimmt. Beispiel:

Treesize /HISTORYCHART C:\Dokumente\C_Historie.gif C:\

/LISTSEPARATOR

Erlaubt die Festlegung des Listentrennzeichens, das beim Exportieren von Text-Dateien verwendet wird. Standardmäßig wird der Tabulator für Textdateien verwendet. Für CSV-Dateien wird gemäß Konvention immer das Semikolon verwendet.
/MOVETO

Dateisuche: Erlaubt das Verschieben der Ergebnisse der Dateisuche in eine ZIP-Datei, ein bestimmtes Verzeichnis oder den Papierkorb. Diese Option kann nur zusammen mit der Kommandozeilen-Option /SEARCH verwendet werden. Sollen die Dateien gelöscht werden, so muss der Name des Papierkorbes oder "Recycle Bin" angegeben werden, so wie er im Windows Explorer erscheint. Das folgende Beispiel durchsucht Laufwerk C: nach Internet-Cache-Dateien und verschiebt sie in eine ZIP-Datei namens ObsoleteFiles.zip:

Treesize /SEARCH:Internet /MOVETO C:\Temp\ObsoleteFiles.zip C:\

Dieser Aufruf löscht die Dateien statt dessen:

Treesize /SEARCH:Internet /MOVETO "Recycle Bin" C:\

Das zweite Beispiel verwendet die zuletzt genutzten Such-Einstellungen und verschiebt die auf Laufwerk C: gefundenen Dateien in den Pfad E:\Obsolete Files:

Treesize /SEARCH:Start /MOVETO "E:\Obsolete Files" C:\

Dieses Beispiel verwendet zuvor unter dem Namen "ArchiveOptions.xml" gespeicherte Suchoptionen und übergibt den Pfad jeder gefundenen Datei einer Batch-Datei, die z.B. einen Archivierungsprozess anstoßen kann:

Treesize /SEARCH /NOGUI /MOVETO "Archiver.BAT" ArchiveOptions.xml

Für ZIP-Dateien kann der /DATE Kommandozeilen-Parameter genutzt werden, um das Datum zum Namen der ZIP-Datei hinzuzufügen. Siehe auch: Markierte Dateien verschieben

/NOGUI

Dieses Argument bewirkt, dass das Fenster von TreeSize Professional nicht angezeigt wird und nicht in der Taskleiste erscheint. Achtung: Verwenden Sie dieses Argument erst, wenn Sie die restlichen Kommandozeilen-Parameter ausreichend getestet haben! Auftretende Fehler werden in der Ereignisanzeige von Windows geloggt. Wenn Sie diesen Parameter verwenden, sollte er der erste Kommandozeilen-Parameter sein.

/NOHEADERS

Lässt die Kopfzeilen weg, die üblicherweise an den Anfang exportierter Dateien geschrieben werden. Dies kann die spätere Weiterverarbeitung der exportierten Daten vereinfachen.

/NOUNITS

Lässt die Einheiten weg, die sonst hinter Größenangaben stehen. Verwenden Sie zusätzlich /SIZEUNIT um die verwendete Einheit zu bestimmen, so exportiert /SIZEUNIT 0 beispielsweise reine Byte-Werte. Dies kann die spätere Weiterverarbeitung der exportierten Daten vereinfachen. Diese Option ist zur Zeit nicht auf die Dateisuche anwendbar, bitte verwenden Sie statt dessen den Export in eine Excel-Datei, bei der die Einheiten lediglich in der Zellformatierung gespeichert werden, und nicht im Zellwert.

/OPEN

Öffnet einen gespeicherten XML-Report beim Start der Anwendung. Beispiel:

Treesize /OPEN C:\Reports\Laufwerk-C.xml

/PIECHART

Speichert das Tortendiagramm des untersuchten Verzeichnisses als Bitmap- oder JPEG-Datei. Das folgende Beispiel untersucht die Laufwerke C:\ und D:\ und erstellt für jedes ein Diagramm:

Treesize /PIECHART C:\Temp\c.jpg C:\ /PIECHART C:\Temp\d.jpg D:\

/PRINT

Druckt einen Bericht auf dem Standarddrucker aus und beendet die Anwendung anschließend. Beispiel:

Treesize /PRINT C:\ D:\

/PRINT1

Druckt nur die erste Seite des Reports für jedes angegebene Verzeichnis / Laufwerk auf dem Standarddrucker aus und beendet TreeSize Professional anschließend. Beispiel:

Treesize /PRINT1 \\SERVER\USERS

/RESTRICTED

Startet TreeSize Professional in einer Art Read-only-Modus, in denen der Benutzer keinen Zugriff auf das Explorer-Kontextmenü hat, keine Dateien oder Verzeichnisse umbenennen oder löschen darf, und die Schaltflächen zum Hinzufügen von Netzwerklaufwerken und zum Deinstallieren von Software in der Symbolleiste fehlen.

/SAVE

Speichert die Ergebnisse in einer CSV- oder Textdatei, nachdem der Scan oder die Dateisuche abgeschlossen ist, und beendet das Programm. Das folgende Beispiel speichert das Ergebnis der Dateisuche in einer CSV-Datei:

Treesize /SAVE C:\Scans\c.csv C:\

/SEARCH

Dateisuche: Öffnet das Fenster zur Dateisuche von TreeSize Professional. Wenn ":Start" zu dieser Kommandozeilen-Option hinzugefügt wird, wird die Suche unmittelbar gestartet. Es werden dabei dieselben Einstellungen verwendet wie bei der letzten Benutzung der Dateisuche. Alle gefundenen Dateien werden automatisch markiert. Eine zuvor gespeicherte XML-Datei mit Sucheinstellungen kann übergeben werden, diese Einstellungen werden dann verwendet, um die Suche durchzuführen. Das folgende Beispiel führt eine Suche durch mit den Suchoptionen, die zuvor in die Datei SearchSettings.xml gespeichert wurden, und exportiert die Ergebnisse in eine Textdatei:

Treesize /SEARCH /SAVE T:\result.txt SearchSettings.xml

Findet TreeSize Professional dagegen den Zusatz ":Internet" bei dieser Option, so startet es die Suche nach temporären Internet- Dateien und löscht diese anschließend. Die Laufwerke, die bei der letzten Suche aktiv waren, werden wiederum verwendet. Es kann aber auch eine Liste von Laufwerken und Pfaden (mit Leerzeichen getrennt) am Ende der Kommandozeile übergeben werden. Beispiel:

Treesize /SEARCH:Internet

TreeSize Professional benutzt dieselben Einstellungen wie bei der zuletzt durchgeführten Dateisuche. Sie können jedoch die Suchmuster für die temporäre Dateisuche mittels der /FILTER Kommandozeilen Option angeben.

Tipp: Sie können die Ergebnisse der Dateisuche mit der /SAVE Kommandozeilen-Option in einer Text- oder CSV -Datei speichern.

/SIZEUNIT N

Mit dieser Option kann die Größeneinheit festgelegt werden, in der Größenangaben dargestellt werden sollen. N kann die Werte 0 bis 4 annehmen, wobei: 0 = Bytes, 1 = KB, 2 = MB, 3 = KB. Wird diese Option nicht verwendet, so wird der bei der letzten Benutzung von TreeSize verwendete Wert benutzt.

/TITLE

Kann genutzt werden, um den Titel des gedruckten oder exportierten Reports zu ändern und so noch zusätzliche Informationen anzugeben, wenn das Programm in einer automatisierten Umgebung genutzt wird. Beispiel:

Treesize /TITLE "Dies ist ein Report von Laufwerk C auf Server3" /PRINT \\Server3\C$

/TOPFILESLIST

Dieser Parameter erlaubt das Speichern der Top 100 Liste in einer Excel, Text- oder CSV-Datei.

treesize /TOPFILESLIST C:\temp\C_top_files.txt C:\

/USERSLIST

Diese Option schreibt die Statistik über die Verteilung der Dateigrößen auf die verschiedenen Benutzer des untersuchten Dateisystemzweiges in eine Excel, Text- oder CSV-Datei. Das folgende Beispiel untersucht Laufwerk C: und erstellt eine Excel-Datei in C:\Temp mit der Statistik der Benutzer auf diesem Laufwerk.

Treesize /USERSLIST C:\Temp\C-Users.xls C:\

/XML

Speichert die Ergebnisse in einer XML-Datei, die später wieder geladen oder für Vergleichszwecke genutzt werden kann.

Treesize /XML C:\Results\Allusers.xml H:\Users\

Directories

Am Ende der Kommandozeile können ein oder mehrere Pfade angegeben werden, die TreeSize Professional durchsuchen soll. Die Platzhalter * und ? sind erlaubt. Beispiel:

Treesize H:\Users\A*

Im Falle eines Fehlers wird der Windows Fehler-Code als Exit Code des Prozesses zurückgegeben.

Scanning Multiple Directories

Wenn Sie mehrere Verzeichnisse untersuchen wollen, kann es sinnvoll sein, mehrere Aufrufe in einer Batch-Datei zusammenzufassen, zum Beispiel:

"C:\Program Files\JAM Software\TreeSize Professional\Treesize.exe" /EXCEL D:\Share1.xls \\Server\Share1

"C:\Program Files\JAM Software\TreeSize Professional\Treesize.exe" /EXCEL D:\Share1.xls \\Server\Share1

"C:\Program Files\JAM Software\TreeSize Professional\Treesize.exe" /EXCEL D:\Share1.xls \\Server\Share1

Es ist auch möglich, die Namen der Shares in eine Textdatei zu schreiben und das Kommando FOR zu verwenden:

FOR /F "tokens=1" %%i IN (dir.txt) DO Treesize.exe /NOGUI /EXPAND 10MB /excel c:\temp\%%i.xls /exclude ~snapshot \\Server\%%i

Zeitgesteuerte Scans

Sie können den Ordner "Geplante Tasks" von Windows verwenden, um zeitgesteuerte Untersuchungen durchzuführen. Die Funktion "TreeSize-Scans planen" aus dem Extras-Menü hilft Ihnen dabei.

Sie können auch das at-Kommando verwenden, um zeitgesteuerte Untersuchungen durchzuführen. Um beispielsweise eine Untersuchung der Laufwerke C: und E: um 3:00 Uhr nachts durchzuführen, müssen Sie folgendes Kommando an der Kommandozeile eingeben:

at 03:00 "C:\Programme\JAM Software\TreeSize Professional\Treesize.exe" /EXCEL c:\Temp\Treesize.xls /EXPAND 2 c:\ e:\

Wenn Sie die Ergebnisse der Dateisuche am nächsten Morgen auf dem Monitor in Ihrem Büro sehen wollen, sollten Sie ein Kommando der folgenden Art verwenden:

at 06:00 /INTERACTIVE "C:\Programme\JAM Software\TreeSize Professional\Treesize.exe" /SEARCH:Start

Weitere Informationen zum at-Kommando finden Sie in der Windows Hilfe. Fehler bei der Ausführung werden im Ereignisprotokoll von Windows festgehalten.

Windows Scripting Host

Wenn Sie den Windows Scripting Host verwenden möchten, sieht das Kommando zum Starten wie folgt aus:

Set Shell = CreateObject("WScript.Shell")
Shell.Run """C:\Programme\TreeSize Professional\Treesize.exe"" /XML c:\Temp\Laufwerk-C.xml c:\"


Copyright & Kontakt

Navigation: »No topics above this level«

Copyright & Kontakt

 Return to chapter overview

Copyright ©1995-2009 by Joachim Marder e.K.

Kontakt:

JAM Software GmbH
Max-Planck-Str. 22
D-54296 Trier

FAX: | 0700-70707059 (max. 12,4 ct. pro Minute aus dem deutschen Festnetz)
WWW: | http://www.jam-software.de
Support: | http://www.jam-software.de/customers/contact.php
E-Mail: | treesize@jam-software.com
Handelsregister: | HRB: 4920 beim Amtsgericht Wittlich
Umsatzsteuer ID: | DE234825349
Geschäftsführer: | Joachim Marder