UltraSearch

Hilfe


Einleitung

Navigation: UltraSearch >

Einleitung

Willkommen zur Hilfe von UltraSearch!

Hier finden Sie alle wichtigen Informationen zu den Funktionen des Programms, detaillierte Anleitungen zur Nutzung der Suche sowie Tipps und Tricks, wie Sie UltraSearch komfortabel in Ihre tägliche Computernutzung integrieren.

In den Kapiteln Features, Installation und Schnellstart können Sie sich zunächst einen allgemeinen Überblick über UltraSearch verschaffen. Die nachfolgenden Kapitel werfen einen genaueren Blick auf die Benutzeroberfläche, die Möglichkeiten der Suche sowie zusätzliche Einstellungsmöglichkeiten.

Benötigen Sie weitere Informationen, bietet Ihnen unsere Knowledge Base Antworten zu den gängigsten Fragen.


Features

Features

Sie suchen nach Dateien und Ordnern auf Ihrer lokalen Festplatte oder in Ihrem Netzwerk? UltraSearch liefert Ihnen die Ergebnisse innerhalb von Sekunden.

Neben der Suche nach Dateinamen können Sie gezielt nach Dateigruppen wie Office- oder Video-Dateien suchen. Auch die Suche nach Dateiinhalten ist möglich. Daneben gibt es zahlreiche weitere Funktionen für eine zielgerichtete, schnelle Suche.

UltraSearch bietet Ihnen:

ØEine schnelle Suche nach Dateinamen.

ØEine klare, übersichtliche Benutzeroberfläche.

ØDie Suche nach Dateigruppen wie Office- oder Video-Dateien.

ØDie Suche nach Dateiinhalten in Text-, PDF-Dateien uvm.

ØSchnellfilter für Minimal- und Maximalgröße der gesuchten Dateien. (Nur Professional Edition)

ØSchnellfilter zur Eingrenzung von Änderungs-, Erstell- und Zugriffsdatum der gesuchten Dateien. (Nur Professional Edition)

ØSpeichern und Laden verschiedener Sucheinstellungen (Nur Professional Edition)

ØEin einfaches Kombinieren mehrerer Suchbegriffe durch Schlüsselwörter wie "AND" oder "OR".

ØDie Suche auf Netzlaufwerken (Alle Editionen), innerhalb von Netzwerkdomänen und auf Windows Servern. (Nur Professional Edition)

ØEine einfache Laufwerksauswahl durch simples An- und Abwählen der zu durchsuchenden Laufwerke.

ØDas Ausschließen von Dateiennamen oder Pfaden über einen Ausschlussfilter.

ØErweiterte Informationen über die Suchergebnisse wie Größe, Dateialter oder Attribute.

ØEine Dateivorschau von Bild-, Video- oder Officedateien.

ØDie Sortierung der Ergebnisse nach unterschiedlichen Kriterien wie Name, Größe oder Dateialter.

ØStapelumbenennung zur gleichzeitigen Umbenennung vieler Dateien anhand festgelegter Regeln.

ØErweiterte Operationen zum Verschieben, Kopieren oder Archivieren von Dateien. (Nur Professional Edition)

ØDen Export der Ergebnisse in eine Text- oder CSV-Datei (Alle Editionen) sowie als PDF-, Excel- oder HTML-Datei. (Nur Professional Edition)

ØHotkey- und Autostart-Unterstützung zur schnellen Nutzung des Programms.

ØDie Verwendung von regulären Ausdrücken.

ØEin automatisches Speichern der letzten Suchbegriffe. (optional)

ØDie Nutzung des Windows Explorer Kontextmenüs innerhalb der Anwendung.

ØEine portable Version zur Nutzung von einem USB-Stick.

Dank der innovativen Nutzung der MFT (Master File Table) von NTFS-Partitionen erreicht UltraSearch sehr hohe Geschwindigkeiten, ohne das System durch die Erstellung und Aktualisierung einer Index-Datei zu belasten. Zur Indizierung wird ausschließlich der systeminterne Arbeitsspeicher verwendet. UltraSearch erkennt auch NTFS-Hardlinks.


Installation

Installation

Um UltraSearch zu installieren, führen Sie das Installationsprogramm aus und folgen den Anweisungen des Installations-Assistenten.

Das Installationsprogramm kopiert alle notwendigen Dateien auf die Festplatte und legt eine neue Programmgruppe im Startmenü an.

Sie können UltraSearch in der Systemsteuerung unter "Programme und Features" wieder deinstallieren.

Eine Liste der unterstützten Betriebssysteme finden Sie auf unserer Homepage.

Portable Installation

[Professional Edition]: Die Vollversion bietet die Möglichkeit, eine eigene portable Version zu erstellen. Dazu muss UltraSearch zunächst auf einem PC installiert sein.
Starten Sie anschließend UltraSearch und wählen Sie "Optionen > Portable Installation erzeugen".

[Free Edition]: Zusätzlich zum Installationsprogramm bieten wir auf unserer WebSite die portable Version der Freeware als Zip-Datei zum Download an.
Diese speichert ihre Einstellungen lokal und lässt sich so beispielsweise von einem USB-Stick aus verwenden.


Schnellstart

Schnellstart

Nach der Installation kann UltraSearch über das Windows Start-Menü, die Verknüpfung auf dem Desktop oder das Kontextmenü eines Ordners oder Laufwerks gestartet werden.

Im Folgenden werden die wichtigsten Elemente des Hauptfensters erläutert:

1.Multifunktionsleiste: Die Multifunktionsleiste (Ribbon) von UltraSearch erlaubt den Zugriff auf alle Befehle der Anwendung. Zusammenhängende Befehle sind in sogenannten "Registerkarten" (oder kurz "Register") angeordnet. So enthält das Register "Start" die am häufigsten in UltraSearch verwendeten Funktionen, während das Register "Ansicht" Befehle bereitstellt, mit denen das Aussehen der Anwendung beeinflusst werden kann.

2.Laufwerksübersicht: Die Laufwerksübersicht zeigt alle aktuell ausgewählten Laufwerke und Suchpfade an. Ein Klick auf die Dropdown-Schaltfläche oder auf die Übersicht selbst öffnet eine erweiterte Ansicht der verfügbaren Laufwerke. Diese ermöglicht das An- und Abwählen von Laufwerken und Pfaden, die in die Dateisuche mit einbezogen werden sollen.

3.Suchfeld: Im Suchfeld können Sie das gewünschte Suchmuster beispielsweise den Dateinamen oder eine Dateiendung eingeben. Die Suche startet automatisch. Auch komplexere Suchbegriffe mit mehreren Suchkriterien sind möglich. Dazu können Sie die Suchsyntax von UltraSearch nutzen.

4.Ergebnisliste: In der Ergebnisliste werden alle Dateien und Ordner aufgelistet, die zu Ihrer Suchanfrage passen. Das Aussehen der Ergebnisliste, wie sichtbare Spalten oder Schriftgröße, können Sie unter "Ansicht" anpassen.

5.Dateivorschau: Die Dateivorschau zeigt detaillierte Informationen sowie eine Miniaturansicht des in der Ergebnisliste ausgewählten Elements an. Unter "Ansicht > Vorschaubereich" kann die Vorschau ein- oder ausgeblendet werden.

6.Statusleiste: Die Statusleiste informiert Sie über die Anzahl der Suchergebnisse und zeigt zusätzlich Informationen über ausgewählte Elemente an. Hier wird ebenfalls angezeigt, ob der Ausschlussfilter aktiv ist.


Was ist neu?

Was ist neu?

Siehe "Was ist neu?" online.


Knowledge Base

Knowledge Base

Falls Sie in dieser Hilfe nicht fündig geworden sind, können Sie über dieses Suchfeld die Knowledge Base auf unserer Webseite durchsuchen.
Beim Klick auf "Suchen" wird die entsprechende Seite in Ihrem standard Web-Browser geöffnet.

Bitte beachten Sie: Für diese Suche ist eine Internetverbindung erforderlich und die Ausführung von JavaScript muss in Ihrem Browser aktiviert sein!


Suche

Suche

Um eine Suche zu starten, geben Sie einfach das gewünschte Suchmuster, z.B. den Dateinamen in das Suchfeld ein, wahlweise mit dem Wort name: davor.

Suche nach Dateiendungen:

Möchten Sie nach einer Dateiendung suchen, stellen Sie dem Suchbegriff ext: oder extension: (Englisch für "Erweiterung") voran, beispielsweise: ext:txt.

Suche nach Dateigruppen:

Möchten Sie nach einer Dateigruppe suchen, stellen Sie dem Suchbegriff group: (Englisch für "Gruppe") voran, beispielsweise: group:Video-Dateien.

Suche nach Dateiinhalt:

Möchten Sie nach Dateiinhalten suchen, stellen Sie dem Suchbegriff cont: oder content: (Englisch für "Inhalt") voran, beispielsweise: cont:license.

Suche nach Dateigröße:

Möchten Sie die Suche auf bestimmte Dateigrößen einschränken, können Sie eine Minimal- und/oder Maximalgröße festlegen, beispielsweise: size:< 500MB oder/und : size:> 5MB

Suchbegriffe kombinieren:

Möchten Sie mehrer Suchbegriffe kombinieren, schreiben Sie in Großbuchstaben AND (Englisch für "und") oder OR (Englisch for "oder") zwischen beide Suchbegriffe, beispielsweise: readme OR manual.

Weitere Informationen und Beispiele finden Sie im nachfolgenden Kapitel Suchsyntax.

Information zur Volltextsuche:

Reine Textdateien und IFilter

UltraSearch kann reine Textdateien sehr schnell nach einem bestimmten Suchbegriff durchsuchen, indem es diese auf Dateisystemebene durchläuft und analysiert. Dabei werden alle gängigen Zeichenkodierungen wie ASCII, Unicode oder UTF-8 unterstützt.

Um darüber hinaus auch komplexe Dateigruppen, wie Microsoft Word, Excel, oder PowerPoint durchsuchen zu können, nutzt UltraSearch das sogenannte IFilter Interface, welches vom Betriebssystem bereitgestellt wird. Auch Drittanbieter-Anwendungen können eigene Behandlungsroutinen zur Verfügung stellen, mit denen bestimmte Dateiformate ausgelesen werden können. Viele Dateiformate, wie beispielsweise die üblichen Office-Formate, werden bereits durch eigene Routinen des Betriebssystems behandelt.

Andere Formate, wie zum Beispiel PDF, können mit Hilfe von Filtern ausgelesen werden, die während der Installation eines PDF-Betrachters automatisch registriert werden. Diese stehen dann auch für die Benutzung in UltraSearch zur Verfügung.

Groß- und Kleinschreibung

Bei allen Sucharten (der Suche nach Dateinamen, Dateigruppen oder Dateiinhalten) werden eventuelle Unterschiede bei der Groß- und Kleinschreibung ignoriert. Die Suche ist "case insensitiv". UltraSearch verwendet dazu die entsprechende Zeichensatztabelle, welche durch die aktuellen Regionaleinstellungen definiert wird.


Suchsyntax

Navigation: UltraSearch > Suche >

Suchsyntax

UltraSearch bietet einen Syntax, mit der Sie Ihre Suche schnell und flexibel anpassen können. Bestimmte Schlüsselwörter bieten die Möglichkeit, neben Dateinamen auch nach Dateiendungen, Dateigruppen oder Dateiinhalten zu suchen. Suchbegriffe können durch Verundung und Veroderung kombiniert werden und Dateinamen über die Syntax von der Suche ausgeschlossen werden. Auch die Verwendung von Platzhaltern und Regulären Ausdrücken ist möglich. Nachfolgend finden Sie eine Beschreibung der zulässigen Schlüsselwörter und einige Anwendungsbeispiele. Für die meisten Schlüsselwörtern gibt es eine Kurzschreibweise für eine schnellere Sucheingabe.

Die Suchsyntax ist dabei folgendermaßen aufgebaut:

<Eigenschaft> <Operator> <Wert>

beispielsweise

name: = readme

findet alle Dateien, deren Name (Eigenschaft) dem Wort readme (Wert) entspricht (Operator).

Mehrere Suchbegriffe können miteinander kombiniert werden:

name:=readme OR name:=movie

findet alle Dateien mit "readme" ODER "movie" im Namen.

In der nachfolgenden Tabelle finden Sie alle verfügbaren Eigenschaften, Operatoren und Verbindungen, die Sie in UltraSearch nutzen können.

Information: Wird nach Dateinamen gesucht, kann name: weggelassen werden. Unabhängig davon kann generell das = - Zeichen als Operator weggelassen werden. Diese Eigenschaft und dieser Operator sind die Standardwerte, die bei der Suche verwendet werden. Für einzelne Eigenschaften gibt es verkürzte Schreibweisen, die in nachstehender Tabelle zu finden sind.

Eigenschaft: | Beschreibung: | Beispiel: | Kurzschreibweise: | Erläuterung:
name: | Suche nach Dateinamen. Dies ist die Standard-Eigenschaft, die verwendet wird, wenn keine Eigenschaft explizit angegeben ist. | name:=readme | readme |
path: | Suche nach Ordnerpfad. | path:=Windows | - | Suche nach allen Dateien und Ordner im Windows-Ordner.
extension: | Suche nach Dateierweiterung. | extension:=txt | ext:txt | Suche nach allen Dateien mit der Dateiendung "txt".
group: | Suche nach Dateigruppe. | group:=Video-Dateien | group:Video-Dateien | Suche nach allen Video-Dateien. Information: Die zur Verfügung stehenden Dateigruppen können Sie unter "Optionen > Dateigruppen konfigurieren" anpassen.
content: | Suche nach Dateiinhalt. | content:=license | cont:license | Volltextsuche nach allen Dateien, in deren Dateiinhalt das Wort "license" vorkommt. Information: Die Volltextsuche ist zeitintensiv. Es wird daher empfohlen, zusätzliche Suchkriterien zu verwenden.
size: | Suche nach Dateigröße. | size:<500MB size:>5MB | - | Suche nach allen Dateien, die kleiner als 500 MB sind. Suche nach allen Dateien, die größer als 5MB sind. Information: Die Suche bezieht sich ausschließlich auf Dateigrößen, Ordnergrößen werden nicht berücksichtigt.
accessed: | Suche nach Zugriffsdatum. | accessed:<=01.11.2021 accessed:>01.11.2021 accessed:15.03.2020-15.11.2021 | - | Suche nach Dateien mit Zugriffsdatum im angegebenen Zeitintervall. Anstelle eines expliziten Zeitintervalls kann auch das Maximal- oder Minimaldatum angegeben werden.
created: | Suche nach Erstelldatum. | created:<=01.11.2021 created:>01.11.2021 created:15.03.2020-15.11.2021 | - | Suche nach Dateien mit Erstelldatum im angegebenen Zeitintervall. Anstelle eines expliziten Zeitintervalls kann auch das Maximal- oder Minimaldatum angegeben werden.
modified: | Suche nach Änderungsdatum. | modified:<=01.11.2021 modified:>01.11.2021 modified:15.03.2020-15.11.2021 | - | Suche nach Dateien mit Änderungsdatum im angegebenen Zeitintervall. Anstelle eines expliziten Zeitintervalls kann auch das Maximal- oder Minimaldatum angegeben werden.

Operator: | Beschreibung: | Beispiel: | Kurzschreibweise: | Erläuterung:
= | Die Eigenschaft muss zutreffen. Dies ist der Standard-Operator, der verwendet wird, wenn kein Operator explizit angegeben ist. | name:=readme | readme | Suche nach allen Dateien, deren Dateiname das Wort "readme" enthält.
!= | Die Eigenschaft darf nicht zufreffen. | name:!=readme | !=readme | Suche nach allen Dateien, in denen das Wort "readme" nicht vorkommt.
~ | Kann in Zusammenhang mit der Eigenschaft name:verwendet werden. Der nachfolgende Wert ist ein Regulärer Ausdruck (Regex) und muss auf die Eigenschaft zutreffen. | name:~[0-9] | ~[0-9] | Suche nach allen Dateien, die mindestens eine Ziffer im Namen haben.
!~ | Kann in Zusammenhang mit der Eigenschaft name:verwendet werden. Der nachfolgende Wert ist ein Regulärer Ausdruck (Regex) und darf nicht auf die Eigenschaft zutreffen. | name:!~[0-9] | !~[0-9] | Suche nach allen Dateien, die keine Ziffern im Namen haben.
> oder >= | Operator für Größen- oder Datumsvergleiche: Die Eigenschaft muss größer (größer gleich) dem angegebenen Wert sein. | size:>= 5MB | - | Suche nach allen Dateien, die größer oder gleich 5 MB sind. Information: Die Suche bezieht sich ausschließlich auf Dateigrößen, Ordnergrößen werden nicht berücksichtigt.
< oder <= | Operator für Größen- oder Datumsvergleiche: Die Eigenschaft muss kleiner (kleiner gleich) dem angegebenen Wert sein. | size:<= 500MB | - | Suche nach allen Dateien, die kleiner oder gleich 500 MB sind. Information: Die Suche bezieht sich ausschließlich auf Dateigrößen, Ordnergrößen werden nicht berücksichtigt.

Verbindung: | Beschreibung: | Beispiel: | Kurzschreibweise: | Erläuterung:
AND | Die verbundenen Suchmuster müssen alle zutreffen. Dies ist die Standard-Verbindung, die verwendet wird, wenn keine Verbindung explizit angegeben wird. | name:=readme AND extension:=txt | readme ext:txt | Suche nach allen Dateien deren Dateiname das Wort "readme" enthält und die die Dateiendung "txt" haben.
OR | Es muss mindestens eines der Verbundenen Suchmuster zutreffen. | name:=readme OR name:=movie | readme OR movie | Suche nach allen Dateien, deren Dateiname das Wort "readme" oder "movie" enthält.

Bei der Angabe von Werten, also dem eigentlichen Suchmuster, gibt es verschiedene reservierte Zeichen wie Platzhalter oder Anführungszeichen zur exakten Suche. Nachfolgende Tabelle listet diese Zeichen auf und erläutert sie anhand einiger Beispiele.

Beispielwert: | Beschreibung: | Beispiel: | Kurzschreibweise: | Ergebnisse:
*readme* | Suche nach readme, wobei eine beliebige Anzahl an Zeichen vor und hinter dem Wort stehen können. Das Wort enthält "readme". | name:=*readme* | *readme* | Findet: "123readme.txt", "123readme.docx" aber NICHT: "read_me.txt", "reading.docx"
readme | Entspricht *readme*. Die beiden Platzhalter können vor und hinter dem Wort können der Einfachheit halber weggelassen werden. | name:=readme | readme | Findet: "123readme.txt", "123readme.docx" aber NICHT: "read_me.txt", "reading.docx"
readme* | Suche nach readme, wobei nach dem Wort eine beliebige Anzahl an Zeichen stehen können, davor aber keine Zeichen mehr erlaubt sind. Das Wort beginnt also mit "readme". | name:=readme* | readme* | Findet: "readme.txt", "readme_c.docx" aber NICHT: "123readme.txt", "read_me.txt"
*readme | Suche nach readme, wobei vor dem Wort eine beliebige Anzahl an Zeichen stehen können, danach aber keine Zeichen mehr erlaubt sind. Das Wort endet also auf "readme". | name:=*readme | *readme | Findet: "123readme", "c_readme" aber NICHT: "readme.txt", "readme_c"
"readme" | Exakte Suche nach dem Wort "readme". Davor und danach sind keine Zeichen erlaubt. | name:="readme" | "readme" | Findet: "readme" aber NICHT: "readme.txt", "123readme"
rea?me | Suche nach Dateinamen, die mit "rea" beginnen, und auf "me" enden, und dazwischen genau ein beliebiges Zeichen beinhalten. | name:=rea?me | rea?me | Findet: "readme", "reasme", "rea1me" aber NICHT: "rea123me", "readme.txt"
\*readme* | Suche nach Dateien, in deren Pfad an einer beliebigen Stelle der Begriff "readme" vorkommt. | name:=\*readme* | \*readme* | Findet: "readme.txt" in einem beliebigen Ordner, "abc.doc" in "C:\temp\readme\local" aber NICHT: "abc.doc" in "C:\temp\local"


Query Composer

Navigation: UltraSearch > Suche >

Query Composer

Ist die Nutzung von UltraSearch neu für Sie, haben Sie Probleme, Ihre Suche zu formulieren oder finden Sie die gewünschten Ergebnisse nicht? Der Query Composer hilft Ihnen bei der Formulierung Ihrer Suchanfrage und bringt Ihnen die Möglichkeiten der Suche näher. Jedes Eingabefeld ist mit einem separaten "?"-Schaltfläche ausgestattet, der Ihnen nähere Informationen zu dem jeweiligen Feld anzeigt.

Der Query Composer untergliedert sich in vier Bereiche: Dateiname, Dateierweiterung, Dateiinhalt und Verbindung. Alle Felder sind optional, so dass nur die benötigten Felder ausgefüllt werden müssen, um eine Suche zu starten.

Dateiname: Suchen Sie nach Dateien mit einem bestimmten Dateinamen, geben Sie diesen einfach in die vorgesehenen Felder ein. Dabei lässt sich unterscheiden, ob die Datei mit dem angegebenen Namen beginnt, endet oder das angegeben Wort an einer beliebigen Stelle im Dateinamen vorhanden sein soll.

Dateiendung: Möchten Sie nach Dateien mit einer bestimmten Dateierweiterung (txt, docx, pdf, ...) oder nach einer bestimmten Dateigruppe (Video-Dateien, Audio-Dateien, ...) suchen, können Sie in diesem Bereich die genauen Kriterien festlegen, indem Sie entweder die gewünschte Dateierweiterung in das entsprechende Eingabefeld eintippen oder aus dem Dropdown-Feld die gewünschte Dateigruppe auswählen.

Dateiinhalt: Für eine Volltextsuche können Sie hier den gewünschten Text eingeben. Alle Dateien werden anschließend nach dem hier eingegebenen Inhalt durchsucht. Da das Auslesen von Dateiinhalten viel Zeit in Anspruch nehmen kann, sollten weitere Suchkriterien wie Dateiname oder Dateierweiterung verwendet werden.

Verbindung: Die "Verbindung" legt fest, ob alle angegebenen Suchkriterien (Dateiname, Dateierweiterung, Dateiinhalt) erfüllt sein müssen (UND) oder mindestens eines dieser Kriterien (ODER).

Beenden Sie Ihre Eingabe mit einem Klick auf die Schaltfläche "Ok". Der Query Composer schließt sich und fügt Ihre Suchanfrage in das Suchfeld ein. Anschließend wird automatsch eine Suche gestartet und die Ergebnisse werden in der Ergebnisliste angezeigt. Die Suchanfrage können Sie natürlich jederzeit im Suchfeld manuell anpassen, erweitern oder löschen.


Filter

Navigation: UltraSearch > Suche >

Filter

Dateigrößenfilter

Mithilfe des Dateigrößenfilters kann die Suche auf Dateien mit einer bestimmten Dateigröße eingeschränkt werden. Das zum Filter gehörende Zahlenfeld dient zur Festlegung der minimale und maximale Dateigröße. Die Größeneinheit lässt sich über die zugehörige Dropdown-Schaltfläche auswählen. Über das Kontrollkästchen auf der linken Seite kann der Filter an- oder abgewählt werden.

Datumsfilter

Über die Datumsfilter lässt sich das Zeitintervall festlegen, in dem sich die gesuchten Dateien befinden. Es können Filter für Zugriffs- Erstell- und Änderungsdatum der Dateien gesetzt werden. Durch Klick auf den jeweiligen Filtertext öffnet sich ein Dialog zur Auswahl des entsprechenden Zeitiintervalls. Neben vorgefertigten Intervallen ("Diese Woche", "Diesen Monat", "Dieses Jahr", "Letztes Jahr"), lassen sich auch individuelle Zeitintervalle festlegen.

Die Suche wird nach Änderung einer Filtereinstellung automatisch aktualisiert. Alle aktiven Filter werden auch in der unter der Multifunktionsleiste befindlichen Filterleiste angezeigt.


Multifunktionsleiste

Multifunktionsleiste

Die Multifunktionsleiste von UltraSearch bietet Zugriff auf alle Befehle der Anwendung. Zusammenhängende Befehle sind nach logischen Einheiten, auch "Registerkarten" (oder kurz "Register") genannt, geordnet.

Die folgenden Register stehen zur Verfügung:

· Datei | Erlaubt es, Laufwerke und Ordner zur Suche hinzuzufügen, die gesammelten Daten zu exportieren sowie die Suche zu aktualisieren.
· Start | Enthält die meistgenutzten Aktionen und Befehle von UltraSearch.
· Filter | Enthält unterschiedliche Filter zur Einschränkung der Suchergebnisse.
· Ansicht | Enthält Befehle und Aktionen, die das Aussehen der Anwendung beeinflussen.
· Optionen | Enthält Einstellungen zum Startverhalten, Sprachauswahl sowie die Integration in das Windows Betriessystem.
· Hilfe | Ermöglicht den Zugriff auf Hilfe-Funktionen und Versionsinformationen. Des Weiteren können Sie hier den Installationsschlüssel ändern oder den Wartungszeitraum für Ihre Lizenz verlängern.
· Operationen | Enthält Befehle und Aktionen zum Bearbeiten der Ergebnisse oder Anzeigen von Ergebnisinformationen. Anmerkung: Diese Registerkarte ist kontextbezogen und nur verfügbar, wenn sich Ergebnisse in der Ergebnisliste befinden, auf die sich die in der Registerkarte befindlichen Optionen anwenden lassen.


Registerkarte Datei

Navigation: UltraSearch > Multifunktionsleiste >

Registerkarte Datei

Datei

Verzeichnis hinzufügen

Öffnet eine Auswahldialog, um neue Laufwerke und Ordner zur Suche hinzuzufügen.

Aktualisieren

·Aktualisieren: Führt die Suche mit den aktuellen Einstellungen erneut durch. Benutzen Sie diese Option, wenn sie aktualisierte Suchergebnisse erhalten wollen, weil sich beispielsweise Dateien auf Ihrem System geändert haben.

·Cache erneuern: Liest alle Dateiinformationen der ausgewählten Suchpfade erneut in den internen Cache im Arbeitsspeicher ein. Falls Ihre Suchergebnisse unvollständig sind, weil der Cache veraltete Informationen enthält, sollten Sie diese Option nutzen.

Exportieren

·Exportieren: Erlaubt den Export der Ergebnisliste in eine Datei. Es stehen folgende Dateiformate für den Export zur Verfügung:
Alle Editionen: Textdatei (.txt), CSV-Datei (.csv).
Professional Edition: Excel-Datei (.xls/.xlsx), PDF-Datei (.pdf), HTML-Datei (.html/.htm).

·Liste kopieren: Kopiert die Ergebnisliste in die Zwischenablage. Nutzen Sie diese Option, wenn Sie die Ergebnisse in eine andere Datei oder ein anderes Programm übertragen wollen.

Information: Es werden alle aktuell sichtbaren Spalten der Ergebnisliste exportiert. Einzelne Spalten der Ergebnisliste lassen sich unter "Ansicht > Sichtbare Spalten" ein- oder ausblenden.
Sind mehrere Elemente in der Ergebnisliste ausgewählt, werden nur die ausgewählten Elemente exportiert.

Liste drucken

·Liste drucken: Öffnet einen Dialog zur Auswahl des Druckers, über den Sie die Suchergebnisse ausdrucken wollen.

·Drucker einrichten: Öffnet die Druckereinstellungen zum Einrichten Ihres Druckers.

Information: Es werden alle aktuell sichtbaren Spalten der Ergebnisliste gedruckt. Einzelne Spalten der Ergebnisliste lassen sich unter "Ansicht > Sichtbare Spalten" ein- oder ausblenden.
Sind mehrere Elemente in der Ergebnisliste ausgewählt, werden nur die ausgewählten Elemente gedruckt.

Hilfe

·Hilfe: Öffnet die Hilfedatei zu UltraSearch.

·Info: Zeigt Versionsnummer und Kontaktinformationen an. In der Professional Edition werden hier zusätzlich Kundenummer und Lizenzschlüssel angezeigt.

Beenden

Beendet das Programm.


Registerkarte Start

Navigation: UltraSearch > Multifunktionsleiste >

Registerkarte Start

Filter

Dateien einbeziehen

Aktivieren Sie diese Option, wenn Sie eine Suche nach bestimmten Dateien durchführen wollen. Diese Option kann zusätzlich zur Option "Ordner einbeziehen" aktiviert werden.

Ordner einbeziehen

Aktivieren Sie diese Option, wenn Sie eine Suche nach bestimmten Ordnern durchführen wollen. Diese Option kann zusätzlich zur Option "Dateien einbeziehen" aktiviert werden.

Ausschlussfilter

·Filter verwenden: Schaltet den Ausschlussfilter ein oder aus. Anschließend wird automatisch eine Suche mit den neuen Einstellungen gestartet. Bei eingeschaltetem Ausschlussfilter werden Dateien, die einem der festgelegten Ausschlusskriterien entsprechen, von der Suche ausgeschlossen.

·Filter anpassen: Öffnen einen Dialog zur Verwaltung der Ausschlussfilters. Hier können Sie neue Filter erstellen und löschen sowie einzelne Filter über separate Kontrollkästchen aktiv schalten.

Dateigruppennfilter

Bietet eine vorgefertigte Liste von Dateigruppen wie Office Dateien oder Video-Dateien, auf die die Suche eingeschränkt werden kann. Der obere Teil der Schaltfläche aktiviert und deaktiviert den Filter. Eine Mehrfachauswahl von Dateigruppen ist mit gedrückter Strg-Taste möglich.

Dateigruppen konfigurieren: Öffnet eine Dialog, in dem alle Dateigruppen und die zugehörigen Dateierweiterungen aufgelistet sind. Hier können Sie eigene Dateigruppen erstellen oder vorhandene Dateigruppen löschen. Daneben lassen sich die Dateierweiterungen aller Dateigruppen nach eigenen Wünschen anpassen.

Dateiinhaltssuche

Aktiviert ein separates Eingabefeld rechts neben dem Suchfeld, mittels dem nach Dateiinhalten gesucht werden kann. Mehr Informationen zur Suche nach Dateiinhalten finden Sie im Kapitel Suche.

Anmerkung: Die Suche nach Dateiinhalten kann sehr langsam sein, da der gesamte Inhalt einer Datei analysiert werden muss. Es wird daher dringend empfohlen, die Dateiinhaltssuche mit anderen Suchkriterien zu kombinieren um die Suche zu beschleunigen!

Suche

Letze Suchen

Listet die letzten 15 Sucheingaben auf. Über einen Klick auf eine der Sucheingaben wird die aktuelle Sucheingabe ersetzt und eine Suche mit dem ausgewählten Suchmuster gestartet.

Information: Diese Option ist nur sichtbar wenn "Optionen > Allgemein > Letzte Suchen speichern" aktiviert ist.

Query Composer

Öffnet ein erweitertes Suchfeld, das Ihnen dabei hilft, Ihre Suchanfrage zu formulieren. Der Query Composer bietet eine ausführliche Hilfestellung und bringt Ihnen die Möglichkeiten der Suche näher. Nutzen Sie diese Funktion, wenn Sie sich mit der erweiterten Funktionalität und der Suchsyntax von UltraSearch vertraut machen wollen.


Registerkarte Filter

Navigation: UltraSearch > Multifunktionsleiste >

Registerkarte Filter

Dateigrößenfilter

Minimale Größe

Legt die Mindestgröße für die gesuchten Dateien fest. Neben Festlegung der Mindestgröße lässt sich der Filter über ein Kontrollkätchen ein- und ausschalten.

Maximale Größe

Legt die maximale Größe für die gesuchten Dateien fest. Neben Festlegung der maximalen Größe lässt sich der Filter über ein Kontrollkätchen ein- und ausschalten.

Datumsfilter

Zugriffsdatum

Legt den Zeitrahmen des letzten Zugriffs fest, in der sich die gesuchten Dateien befinden. Neben Festlegung der Zeitintervalls für das Zugriffsdatum, lässt sich der Filter über ein Kontrollkätchen ein- und ausschalten.

Erstelldatum

Legt den Zeitrahmen fest, in dem die gesuchten Dateien erstellt wurden. Neben Festlegung des Zeitintervalls für das Erstelldatum, lässt sich der Filter über ein Kontrollkätchen ein- und ausschalten.

Änderungsdatum

Legt den Zeitrahmen fest, in dem die gesuchten Dateien zuletzt geändert wurden. Neben Festlegung des Zeitintervalls für das Änderungsdatum, lässt sich der Filter über ein Kontrollkätchen ein- und ausschalten.

Weitere Filter

Ausschlussfilter

·Filter verwenden: Schaltet den Ausschlussfilter ein oder aus. Anschließend wird automatisch eine Suche mit den neuen Einstellungen gestartet. Bei eingeschaltetem Ausschlussfilter werden Dateien, die einem der festgelegten Ausschlusskriterien entsprechen, von der Suche ausgeschlossen.

·Filter anpassen: Öffnen einen Dialog zum Verwalten der Ausschlussfilters. Hier können Sie neue Filter erstellen und löschen sowie einzelne Filter über separate Kontrollkästchen aktiv schalten.

Dateigruppenfilter

Bietet eine vorgefertigte Liste von Dateigruppen wie Office Dateien oder Video-Dateien, auf die die Suche eingeschränkt werden kann. Der obere Teil der Schaltfläche aktiviert und deaktiviert den Filter. Eine Mehrfachauswahl von Dateigruppen ist mit gedrückter Strg-Taste möglich.

Dateigruppen konfigurieren: Öffnet eine Dialog, in dem alle Dateitgruppen und die zugehörigen Dateierweiterungen aufgelistet sind. Hier können Sie eigene Dateigruppen erstellen oder vorhandene Dateigruppen löschen. Daneben lassen sich die Dateierweiterungen aller Dateigruppen nach eigenen Wünschen anpassen.

Unterordner einbeziehen

Legt fest, ob die Unterordner aller ausgewählten Suchpfade durchsucht werden sollen. Ist die Option deaktiviert, werden nur Dateien und Ordner gesucht, die sich direkt in den ausgewählten Pfande befinden.

Umlaute und Akzente ignorieren

Legt fest, ob Umlaute und Buchstaben mit Akzenten als eigenständige Buchstaben berücksichtigt werden sollen. Aktivieren Sie diese Option, wenn Sie beispielsweise über den Suchbegriff "ware" auch Dateien mit Namen "wäre" oder "warê" finden wollen.


Registerkarte Ansicht

Navigation: UltraSearch > Multifunktionsleiste >

Registerkarte Ansicht

Einheit

Automatische Einheiten

Basierend auf der Größe des anzuzeigenden Wertes wird automatisch eine passende Einheit für Größenangaben in der Ergebnisliste ausgewählt.

TB

Zeigt Größenangaben in der Ergebnisliste in Terabyte (TB).

GB

Zeigt Größenangaben in der Ergebnisliste in Gigabyte (GB).

MB

Zeigt Größenangaben in der Ergebnisliste in Megabyte (MB).

KB

Zeigt Größenangaben in der Ergebnisliste in Kilobyte (KB).

B

Zeigt Größenangaben in der Ergebnisliste in Byte (B).

Ergebnisliste

Datums-/Zeitformat

Legt das Datusmformat fest, das für Datumswerte in der Ergebnisliste verwendet wird.

Schriftgröße

Legt die in der Ergebnisliste verwendete Schriftgröße fest.

Sichtbare Spalten

Zeigt eine Liste aller verfügbarer Spalten an, die über einen Klick auf den jeweiligen Spaltennamen ein- oder ausgeblendet werden können.

Sortieren

Sortieren nach

Zeigt eine Liste aller verfügbarer Spalten an, nach denen die Ergebnisliste über einen Klick auf den jeweiligen Spaltennamen sortiert werden kann. Die Spalte wird automatisch eingeblendet, falls sie in der Ergebnisliste aktuell ausgeblendet ist. Spalten, die Größenwerte beinhalten, werden standardmäßig absteigend sortiert, alle weiteren Spalten aufsteigend.

Aufsteigend

Ordnet die Suchergebnisse in aufsteigender Reihenfolge an. Ist keine Spalte zur Sortierung ausgewählt, wird die erste sichtbare Spalte sortiert.

Absteigend

Ordnet die Suchergebnisse in absteigender Reihenfolge an. Ist keine Spalte zur Sortierung ausgewählt, wird die erste sichtbare Spalte sortiert.

Immer sortieren

Legt fest, ob die aktuelle Sortierung beibehalten werden soll, wenn eine neue Suche gestartet wird (langsamer).

Anzeigen

Elementkontrollkästchen

Blendet Kontrollkästchen neben jedem Element der Ergebnisliste ein. Aktivieren Sie diese Option um das Auswählen mehrerer Elemente zu vereinfachen.

Vorschaubereich

Aktiviert die Datei-Vorschau neben der Ergebnisliste. Ist eine Datei in der Ergebnisliste ausgewählt, wird hier ihr Inhalt angezeigt.


Registerkarte Optionen

Navigation: UltraSearch > Multifunktionsleiste >

Registerkarte Optionen

Optionen

Anwendung

·Start

oImmer als Administrator starten: Ist diese Option aktiv, startet UltraSearch bei jedem Start mit administrativen Privilegien. Dadurch ist gewährleistet, dass UltraSearch Zugriff auf die MFT (Master File Table) von NTFS-Partitionen hat, um den Suchvorgang zu beschleunigen. Daneben verhindert diese Einstellung viele der Zugriffsprobleme auf Ordner, die ohne Administrator-Privilegien nicht durchsucht werden können. Es wird empfohlen, diese Option aktiviert zu lassen.

oBenutzerkontensteuerungs-Warnung überspringen: Startet man UltraSearch als Administrator, wird beim Start der Anwendung die Benutzerkontensteuerung (UAC) angezeigt. Sie können diese Meldung unterdrücken, indem Sie diese Option aktivieren.

oMit Windows starten: Startet UltraSearch beim Systemstart automatisch im Infobereich der Taskleiste. Aktivieren Sie diese Option, um UltraSearch jederzeit aus dem Infobereich der Taskleiste aufzurufen. Über die Tastenkombination "Strg + Shift + U" lässt sich UltraSearch bei Bedarf blitzschnell in den Vordergrund bringen und Sie können ohne Verzögerung Ihre Suche starten. Die Tastenkombination zum Aufrufen von UltraSearch lässt sich unter "Hotkey auswählen" jederzeit ändern.

oSplash-Screen deaktivieren: Professional Edition: Ist diese Option aktiviert, wird der Begrüßungsbildschirm beim Start von UltraSearch nicht mehr angezeigt.

·Windows Explorer

oUltraSearch starten: Diese Option fügt dem Kontextmenü des Windows Explorers einen Eintrag hinzu, über den sie UltraSearch starten können.

oMit UltraSearch durchsuchen: Diese Option fügt dem Kontextmenü des Windows Explorers einen Eintrag hinzu, über den UltraSearch gestartet und der aktuelle Ordner automatisch durchsucht wird.

·Minimieren

oIn den Infobereich minimieren: Ist diese Option aktiviert, wird UltraSearch beim Schließen des Programms in den Infobereich minimiert. Beim Klick auf das entsprechende Symbol in der Taskleiste oder über den vergebenen Hotkey, wird UltraSearch erneut geöffnet.

oBei Doppelklick minimieren: Minimiert das Hauptfenster des Programms, wenn ein Element in der Ergebnisliste mittels Doppelklick geöffnet wird.

·Darstellung

o Dunkle Ansicht verwenden: Mit dieser Option kann das Erscheinungsbild der Anwendung geändert werden. Ist diese Option aktiviert, wird die "Dunkle Ansicht" von UltraSearch unabhängig von der aktuellen Windows-Einstellung verwendet.

oHelle Ansicht verwenden: Mit dieser Option kann das Erscheinungsbild der Anwendung geändert werden. Ist diese Option aktiviert, wird die "Helle Ansicht" von UltraSearch unabhängig von der aktuellen Windows-Einstellung verwendet.

oAutomatisch erkennen: Diese Option zur automatischen Erkennung des Themes basiert auf Ihrer aktuellen Windows-Einstellung und passt das Erscheinungsbild von UltraSearch automatisch an.

·Keyboard Hotkey

oHotkey auswählen: Öffnet einen Dialog, in dem Sie den globalen Hotkey ändern können. Über den gewählten Hotkey lässt sich UltraSearch in die Taskleiste oder den Infobereich minimieren oder in den Vordergrund bringen. Ist die Option "Mit Windows starten" aktiv, können Sie das Programm ebenfalls über diesen Hotkey aufrufen.

Sprache

Öffnet eine Liste aller verfügbaren Sprachen. Wählen Sie hier die Sprache aus, in der die Texte der Benutzeroberfläche angezeigt werden sollen.

Allgemein

·Historie

oLetzte Suchen speichern: Ist diese Option aktiviert, werden die 15 zuletzt verwendeten Suchmuster gespeichert. Die Suchmuster können unter "Suche > Letzte Suchen" oder über die Dropdown-Liste des Suchfeldes ausgewählt werden. Information: Ein Suchmuster wird erst durch Betätigung der Eingabetaste oder bei Verlassen des Suchfeldes gespeichert.

oSuchmuster vorschlagen: Ist diese Option aktiviert, werden bei Eingabe eines Suchmusters passende Suchmuster auf Basis vorheriger Suchen eingeblendet. Information: "Letzte Suchen speichern" muss aktiviert sein, um diese Option zu nutzen.

·Diverses

oSuch-Schaltflächen anzeigen: Zeigt zusätzliche Schaltfächen zum manuellen Starten und Stoppen der Suche auf der Registerkarte "Start" an. Wenn diese Option aktiv ist, wird die Suche während der Eingabe eines Suchmusters nicht mehr automatisch aktualisiert, sondern erst durch Betätigen der Schaltfläche oder Drücken der "Enter"-Taste. Eine Änderung der Filtereinstellungen startet weiterhin automatisch eine neue Suche.

oNeue Laufwerke automatisch auswählen: Bei aktivierter Option, werden neu angeschlossene Laufwerke wie USB-Sticks oder SD-Karten automatisch in der Laufwerksliste aktiviert und zur Suche ausgewählt.

oDateisystemänderungen beobachten: :Wenn Sie diese Option einschalten, überwacht UltraSearch Änderungen am Dateisystem und aktualisiert den internen Cache im Arbeitsspeicher automatisch. Die Änderungen werden bei weiteren Suchen berücksichtigt. Ist diese Option deaktiviert, ist eine Aktualisierungen des Caches unter "Suche > Aktualisieren > Cache erneuern" erforderlich, um Änderungen am Dateisystem bei der Suche zu berücksichtigen. Es ist sinnvoll, diese Option zu deaktivieren und den Cache bei Bedarf manuell zu aktualisieren, falls es auf Ihrem System permamenten Änderungen auf Dateiebene gibt.

Dateigruppen

Dateigruppen konfigurieren

Öffnet eine Dialog, in dem alle Dateigruppen und die zugehörigen Dateierweiterungen aufgelistet sind. Hier können Sie eigene Dateigruppen erstellen oder vorhandene Dateigruppen löschen. Daneben lassen sich die Dateierweiterungen aller Dateigruppen nach eigenen Wünschen anpassen.

Extras

Portable Installation erzeugen

Professional Edition: Erstellt eine portable Version der Software, die z.B. auf einem USB-Stick genutzt werden kann. Nutzen Sie diese Option, öffnet sich ein Dialog in dem Sie den Zeilordner für die portable Installation auswählen können. Alle Einstellungen der portablen Version werden ebenfalls in diesem Ordner gespeichert.


Registerkarte Hilfe

Navigation: UltraSearch > Multifunktionsleiste >

Registerkarte Hilfe

Hilfe

Hilfe

Öffnet die Hilfedatei von UltraSearch.

Häufig gestellte Fragen (FAQ)

Öffnet eine Seite mit häufig gestellten Fragen zu UltraSearch. Nutzen Sie die Suchfunktion oder durchstöbern Sie unsere Kategorien, um Antworten auf Ihre Fragen zu erhalten.

Feature Voting

Öffnet eine Seite mit unserer Feedback-Plattform. Sie können für neue Funktionen abstimmen, uns sagen, was Ihnen gefällt und was Ihnen nicht gefällt.

Version

Info

Zeigt Versionsnummer und Kontaktinformationen an. In der Professional Edition werden hier zusätzlich Kundenummer und Lizenzschlüssel angezeigt.

Auf Update überprüfen

Prüft, ob eine neuere Version der Software verfügbar ist.

Was ist neu?

Öffnet eine Seite mit den neuesten Programmänderungen.

Lizenz

Installationsschlüssel ändern

Öffnet einen Dialog, in dem Sie den Installationsschlüssel dieser Software ändern können.

Wartungszeitraum verlängern

Öffnet eine Seite, über die Sie den Wartungszeitraum für diese Software verlängern können. Updates und technischer Support sind innerhalb des Wartungszeitraums kostenlos.


Registerkarte Operationen

Navigation: UltraSearch > Multifunktionsleiste >

Registerkarte Operationen

Anmerkung:
Diese Registerkarte ist kontextbezogen und nur verfügbar, wenn sich Ergebnisse in der Ergebnisliste befinden, auf die sich die in der Registerkarte befindlichen Optionen anwenden lassen.

Öffnen

Dateipfad öffnen

Öffnet den Ordner des ausgewählten Elements im Windows Explorer.

Öffnen

Öffnet die ausgewählte Datei mit dem Standardprogram, das auf Ihrem Betriebssystem für die jeweilige Dateiendung zugewiesen ist.

Eigenschaften

Zeigt den "Eigenschaften"-Dialog des ausgewählten Elements an.

Zwischenablage

Pfad kopieren

Kopiert den Pfad der ausgewählten Elemente in die Zwischenablage.

Name kopieren

Kopiert die Namen der ausgewählten Elemente in die Zwischenablage.

Kopieren

Kopiert die ausgewählten Elemente in die Zwischenablage.

Ausschneiden

Schneidet die ausgewählten Elemente aus und kopiert sie in die Zwischenablage.

Organisieren

Löschen

Verschiebt die ausgewählten Elemente in den Papierkorb oder löscht sie endgültig.

Stapelumbenennung

Öffnet einen Dialog zur gleichzeitigen Umbenennung mehrerer Dateien anhand bestimmter Regeln.

Dateioperationen

Öffnet einen Dialog mit erweiterten Funktionen zum Verschieben, Kopieren oder Zippen der ausgewählten Dateien.

Auswählen

Alles auswählen

Selektiert alle Einträge der Ergebnisliste.

Nichts auswählen

Hebt die aktuelle Auswahl in der Ergebnisliste auf.

Auswahl umkehren

Invertiert die aktuelle Auswahl in der Ergebnisliste.

Export

Exportieren

Erlaubt den Export der Ergebnisliste in eine Datei. Es stehen folgende Dateiformate für den Export zur Verfügung:
Alle Editionen: Textdatei (.txt), CSV-Datei (.csv).
Professional Edition: Excel-Datei (.xls/.xlsx), PDF-Datei (.pdf), HTML-Datei (.html/.htm).

Anmerkung: Es werden alle aktuell sichtbaren Spalten der Ergebnisliste exportiert. Einzelne Spalten der Ergebnisliste lassen sich unter "Ansicht > Sichtbare Spalten" ein- oder ausblenden.
Sind mehrere Elemente in der Ergebnisliste ausgewählt, werden nur die ausgewählten Elemente exportiert.


Laufwerksübersicht

Laufwerksübersicht

Zu durchsuchende Pfade

Die ausklappbare Laufwerksübersicht ermöglicht die Auswahl der zu durchsuchenden Laufwerke und Pfade.

Im eingeklappten Zustand werden alle Pfade angezeigt, die aktuell für die Suche ausgewählt wurden sowie die explizit angepinnten Laufwerke und Ordner. Zusätzliche Pfade können mit Hilfe des Plus-Symbols hinzugefügt werden. Pfade, die in der Übersicht angezeigt werden, können zudem mit einem einfachen Klick editiert werden, was das schnelle Anpassen eines Pfades ohne vorheriges Ausklappen der Leiste ermöglicht.

Im ausgeklappten Zustand zeigt die Laufwerksübersicht eine Liste aller verfügbaren sowie bisher verwendeten Suchpfade an. Verwenden Sie die Elementkontrollkästchen der einzelnen Laufwerke, um auszuwählen, welche Laufwerke und Ordner UltraSearch durchsuchen soll. Einzelne Pfade können durch Klick auf die Pinspalte an die Laufwerksliste angepinnt werden, um diese dauerhaft in der eingeklappten Übersicht anzuzeigen, unabhängig davon, ob diese gerade für eine Suche aktiviert sind oder nicht. Weitere Funktionen sind über das Kontextmenü verfügbar.

Mit den darunter liegenden Schaltflächen können zusätzliche Pfade und Laufwerke hinzugefügt werden. Die linke Schaltfläche erlaubt dabei die Eingabe des Pfades über die Tastatur, die rechte öffnet einen Dialog mit einem Verzeichnis-Browser.


Dateigruppen

Dateigruppen

Die Dateigruppen, die im Dateigruppenfilter-Dropdown zur Verfügung stehen, können unter "Optionen > Dateigruppen konfigurieren..." festgelegt werden.

In den Optionen zur Festlegung der Dateigruppen, können einzelne Dateigruppen angepasst, gelöscht oder neu erstellt werden.

Eine neue Dateigruppe hinzufügen

1.Legen Sie den Namen der neuen Dateigruppe (zum Beispiel "Textdateien") im Textfeld "Dateigruppendefinitionen" fest.

2.Klicken Sie auf "Gruppe hinzufügen".

3.Klicken Sie in das Textfeld im Bereich "Zugeordnete Dateiendungen" und definieren Sie die gewünschten Dateiendungen, die dieser Dateigruppe angehören sollen (bspw. "*.txt).

4.Klicken Sie auf "Hinzufügen".

5.Wiederholen Sie die Schritte 3 und 4, bis alle gewünschten Dateiendungen hinzugefügt wurden.

6.Klicken Sie auf "OK", um die Änderungen zu speichern.

Eine Dateiendung einer existierenden Dateigruppe hinzufügen/entfernen/editieren

1.Klicken Sie auf die gewünschte Dateigruppe in der oberen Liste.

2.Fügen Sie eine neue Dateiendung hinzu, indem Sie die Schritte 3 und 4, wie oben beschrieben, befolgen
oder
benutzen Sie die Schaltfläche "Löschen", um eine existierende Dateiendung aus der Liste zu entfernen
oder
klicken Sie mit der rechten Maustaste auf eine existierende Dateiendung und wählen Sie "Muster bearbeiten", um die Definition einer Dateiendung zu bearbeiten.

3.Klicken Sie auf "Ok", um die Änderungen zu speichern.

Titel oder Beschreibung einer existierenden Dateigruppe ändern

Klicken Sie mit der rechten Maustaste auf die gewünschte Dateigruppe und wählen Sie entweder "Titel bearbeiten" oder "Beschreibung ändern".

Exportieren/Importieren einer Liste von Dateiendungen

Sie können die für einee Dateigruppe definierten Dateiendungen in eine Text-, CSV-, oder XML-Datei exportieren, indem Sie mit der rechten Maustaste in die untere Liste klicken und auf die Schaltfläche "Export" klicken. Auf die gleiche Weise kann auch eine bestehende Definition importiert werden.


Ausschlussfilter

Ausschlussfilter

Über den Ausschlussfilter können Ordner, Dateien oder Dateigruppen von den Suchergebnissen ausgeschlossen werden.

Der Ausschlussfilter-Dialog kann über das Menü "Suche > Ausschlussfilter > Filter anpassen" geöffnet werden und über den an der gleichen Stelle befindlichen Menüpunkt "Filter verwenden" aktiviert werden. Ist der Filter aktiv, wird eine entsprechende Meldung in der Statusleiste angezeigt.

Einen Filter definieren

Um einen neuen Filter zu definieren, befolgen Sie bitte folgende Schritte:

1.Klicken Sie auf "Hinzufügen". Für den neuen Filter wird ein Eintrag in der Filter-Liste erzeugt.

2.Nun können Sie in der Spalte "Muster" einen Ausschlussfilter definieren. Sie können entweder ein einfaches Platzhalter-Muster wie "*.exe", einen regulären Ausdruck wie ".+\.exe$" oder ein Muster, das auf den gesamten Namen wie zum Beispiel "notepad.exe" prüft, verwenden. Ein Ausschlussfilter mit dem Muster "*.exe" sorgt beispielsweise dafür, dass UltraSearch sämtliche Dateien mit der Dateiendung ".exe" von der Suche ausschließt. Dadurch werden Dateien dieses Typs weder in den Suchergebnissen berücksichtigt, noch aufgelistet. Bitte stellen Sie sicher, dass der zu Ihrem Muster passende Typ in der gleichnamigen Spalte ausgewählt wurde.

3.Über die Spalte "Vergleichen mit" legen Sie fest, gegen welche Datei- oder Ordnereigenschaft das Muster geprüft wird. Muster können entweder gegen Datei- oder Ordnernamen, absolute Pfade, Name des direkten übergeordneten Ordners oder Name eines beliebigen übergeordneten Ordners geprüft werden. Mit Hilfe des Attributs "Absoluter Pfad" lassen sich beispielsweise Ordner, die einem bestimmten Muster wie "Program Files" entsprechen, vom Scan ausschließen. Das Attribut "Datei- oder Ordnername" sollten Sie dann verwenden, wenn Sie eine bestimmte Dateigruppe ein- oder ausschließen wollen.

Platzhalter, die zum Bau von Namensmustern für Dateien verwendet werden können:

* | Ersetzt kein oder beliebig viele alphanumerische Zeichen.
? | Ersetzt genau ein alphanumerisches Zeichen.

Muster dürfen nicht nur Namen von Dateien oder Ordnern enthalten, sondern auch ganze Pfade. Es können mehrere Suchmuster mit Semikolon getrennt werden. Um einen exakten Vergleich (also ohne Platzhalter) zu erzwingen, wählen Sie bitte "Gesamter Name" in der Spalte "Typ" für dieses Muster aus. Reguläre Ausdrücke können ebenfalls als Suchmuster verwendet werden indem Sie in der Spalte "Typ" "RegEx" auswählen.

Nachfolgende Tabelle veranschaulicht die unterschiedlichen Arten von Mustern anhand von Beispielen:

Muster | Vergleichen mit | Typ | Ergebnis
*.doc | Datei- oder Ordnername | Platzhalter | Ausschluss aller Dateien mit der Endung ".doc".
*\Windows\System32\*.exe | Absoluter Pfad | Platzhalter | Ausschluss aller Anwendungen (Dateien mit der Endung ".exe") unter dem Pfad "Windows\System32".
"Neues Textdokument.txt" | Datei- oder Ordnername | Gesamter Name | Ausschluss aller Dateien mit dem Namen "Neues Textdokument.txt".
C:\\([a-z]*\\){2,4}[^\\]*\.[^\\]*$ | Absoluter Pfad | RegEx | Ausschluss aller Dateien auf Laufwerk C: mit einer Verzeichnistiefe von mindestens 2 und höchstens 4.

Wählen Sie einen definierten Ausschlussfilter aus und klicken Sie auf "Vorschau...", um eine Explorer-Ansicht zu öffnen, die anzeigt, welche Dateien und Ordner durch diesen Filter von der Suche ausgeschlossen werden. Ausgeschlossene Ordner und Dateien werde in rot angezeigt, grün dargestellte Dateien und Ordner werden weiterhin in der Suche berücksichtigt.

Über die Schaltfläche "Standardfilter hinzufügen" werden vordefinierte Filter zum Ausschluss von speziellen Systemordnern (wie z.B. dem Papierkorb) erstellt.


Suche speichern/laden

Suche speichern/laden

Sucheinstellungen lassen sich über den Menüpunkt "Start > Suche speichern/laden" speichern, laden und verwalten. Das angezeigt Dropdown bietet zudem eine Übersicht über bereits abgespeicherte Suchen.

Speichern einer Suche

Um Ihre aktuellen Sucheinstellungen zu speichern, befolgen Sie bitte folgende Schritte:

1.Wählen Sie das Dropdown "Suche speichern/laden" aus.

2.Klicken Sie auf "Aktuelle Suche speichern".

3.Im nachfolgenden Dialog-Fenster können Sie der Suche einen aussagekräftigen Namen geben.

Anschließend sind die abgespeicherten Sucheinstellungen im Dropdown-Menü unter dem vergebenen Namen verfügbar.

Hinweis: Es werden folgende Einstellungen gespeichert:

·Suchmuster im Sucheingabefeld

·Volltextsuche im Eingabefeld für den Dateiinhalt

·Filtereinstellung: Dateien oder Ordner einbeziehen

·Verwendete Ausschlussfilter

·Ausgewählte Dateigruppen im Dateigruppenfilter

·Einstellungen der Größenfilter

·Einstellungen der Datumsfilter

Nicht gespeichert werden:

·Zu durchsuchende Ordner oder Laufwerke.

·Dateiendungen, die zu einem Dateigruppe im Dateigruppenfilter gehören.
Beim Laden einer Suche, bei der der Dateigruppenfilter aktiv ist, werden immer die aktuell im Dateigruppenfilter einer Dateigruppen zugewiesenen Dateiendungen verwendet. Existiert eine Dateigruppe, die beim Speichern einer Suche vorhanden war aktuell nicht mehr, wird diese beim Laden der Sucheinstellungen ignoriert.

Laden einer Suche

Das Laden von bereits abgespeicherte Sucheinstellungen erfolgt ebenfalls über die Auswahl des Dropdown-Menüs "Suche speichern/laden".

Anschließen genügt ein Klick auf den Namen der gewünschten Sucheinstellungen, um diese zu laden.

Tipp: Die genauen Einstellungen einer gespeicherten Suche sehen Sie, indem Sie den Mauszeiger über die gewünschte Suche bewegen, deren Einstellungen Sie sich anzeigen lassen wollen.

Suchen verwalten / löschen

Über "Suche speichern/laden > Gespeicherte Suchen verwalten" können Sie die Liste der gespeicherten Suchen bearbeiten. Sie können die Reihenfolge ändern, oder nicht benötigte Suchen löschen.

Wählen Sie eine oder mehrere Suchen aus der Liste aus, und verwenden Sie die Schaltflächen "Hoch", "Runter" und "Entfernen", um die Liste nach Ihren Bedürfnissen anzupassen.

Bestätigen Sie die Änderungen mit "OK" oder verwerfen Sie diese mit "Abbrechen".


Stapelumbenennung

Stapelumbenennung

Anmerkung:
Die Registerkarte "Operationen", auf der sich die Stapelumbenennung befindet, ist kontextbezogen und nur verfügbar, wenn sich Ergebnisse in der Ergebnisliste befinden, auf die sich die in der Registerkarte befindlichen Optionen anwenden lassen.

Dieser Dialog erlaubt das gleichzeitige Umbenennen mehrerer Dateien, unter Verwendung verschiedener Umbenennungs-Regeln.

Um eine neue Umbenennungs-Regel zu erstellen, klicken Sie auf das "+" Icons und wählen eine der verfügbaren Regeltypen aus. Die Liste der verfügbaren Regeln zeigt alle bisher erzeugten Regeln. Jede Regel kann einzeln aktiviert, oder deaktiviert werden. Alle aktivierten Regeln werden schließlich in der hier dargestellten Reihenfolge angewendet. Die Reihenfolge der Regeln kann über die Symbole oberhalb der Liste, oder via Drag & Drop innerhalb der Liste einfach angepasst werden. Bestehende Regeln können nachträglich auch wieder geändert werden. Dazu wählen Sie einfach eine der Regeln aus der Liste aus und passen die entsprechende Konfiguration an. Änderungen werden in Echtzeit in der Vorschau Liste angezeigt.

Die rechte Seite des Dialogs zeigt eine Vorschau der aktuellen Regelsammlung. Sie verdeutlicht die Dateinamen vor und nach der Umbenennen-Operation und bietet einen schnellen Überblick welche Dateinamen geändert werden, und welche gleich bleiben.

Verfügbare Regeln

Diese Liste zeigt alle zuvor erstellten Umbenennungs-Regeln. Ein Klick auf "Ausführen" führt nacheinander die verschiedenen Regeln in der Reihenfolge dieser Liste aus. Um die Reihenfolge zu ändern, können Sie die Regeln entweder mit Drag & Drop an die gewünschte Position verschieben, oder über die Schaltflächen oberhalb der Liste, oder über das Rechtsklickmenü und die darin enthaltenen Funktionen "Nach oben" bzw. "Nach unten".

Bestehende Regeln können mit Hilfe der Kontrollkästen auf der linken Seite vorübergehend deaktiviert werden. Inaktive Regeln werden bei der Ausführung der Umbenennungs-Operation ignoriert.

Ersetzen

Eine einfache Suchen & Ersetzen Operation innerhalb von Dateinamen. Unter "Einstellungen" können der Suchbegriff, sowie der Text der für die Ersetzung verwendet werden soll, festgelegt werden. Aktivieren Sie die Option "Regulären Ausdruck verwenden", um den Suchtext als regulären Ausdruck zu interpretieren, anstatt als festen Suchbegriff. Zusätzliche Informationen über reguläre Ausdrücke finden Sie hier.

Einfügen

Fügt den ausgewählten Text an der angegebenen Position im Dateinamen ein. Die Position kann unter "Einstellungen" festgelegt werden. Der Text wird entweder als Präfix, Suffix, oder an einer bestimmten Position eingefügt.

Nummerieren

Fügt den Dateinamen eine fortlaufende Nummerierung an. Der Startwert kann unter "Einstellungen" festgelegt werde. Die Nummerierung kann zudem als Präfix, als Suffix, oder an einer beliebigen Stelle eingefügt werden. Darüber hinaus erlaubt die Option "Auffüllen auf Länge" das Anpassen angefügten Nummerierung mit führenden Nullen, sodass eine Einheitliche Länge der Zahlenwerte sichergestellt werden kann.

Löschen

Die Löschregel beinhaltet zwei Optionen: Einen bestimmten Text innerhalb der Dateinamen entfernen, oder das Löschen von beliebigem Text an einer bestimmten Position. "Text löschen" entfernt alle Vorkommen des angegebenen Suchwortes. "Lösche ab Position" entfernt Text ab einer bestimmten Position innerhalb der Dateinamen. Mit Hilfe des Feldes "Länge" kann bestimmt werden wie viele Zeichen entfernt werden sollen

Die Auswahl "Dateiname", "Nur Dateiendung", "Vollständiger Name" bestimmt welcher Teil des Dateinamens angepasst werden soll. Diese Auswahl kann für jede Regel separat festgelegt werden.

Vorschau

Dieser Bereich zeigt eine Vorschau der auszuführenden Umbenenn-Operation, unter Verwendung aller aktiven Regeln. Die Spalte "Name" zeigt den ursprünglichen Dateinamen, während "Neuer Name" als Vorschau für die Namen nach dem Umbenennen dient. Mit Hilfe der Spalte "Änderung" kann auf einen Blick festgestellt werden, ob sich der Dateiname der entsprechenden Datei ändern wird, oder ob er gleich bleibt. Die Spalte "Status letzte Operation" zeigt nach der Operation an, ob das Umbenennen erfolgreich war. Falls eine Datei nicht umbenannt werden konnte, zum Beispiel wegen fehlender Berechtigungen, wird dies in dieser Spalte angezeigt.

Ausführen

Startet die Umbenenn-Operation. Alle aktiven Regeln werden nacheinander auf die Dateien auf der rechten Seite angewendet. Sobald die Operation beendet wurde, wird der Status in der Spalte "Status letzte Operation" innerhalb der Vorschau-Liste angezeigt.

Rückgängig

Setzt die letzte Umbenenn-Operation auf den vorherigen Stand zurück. Das bedeutet, dass eine weitere Umbenenn-Operation ausgeführt wird, welche die Originalnamen der Dateien wiederherstellt.


Dateioperationen

Dateioperationen

Die erweiterten Dateioperationen sind nur in der Professional Edition verfügbar und ermöglichen es Ihnen, alle in der Ergebnisliste ausgewählten Dateien und Ordner an einen Ort Ihrer Wahl zu kopieren, zu verschieben, in einer ZIP-Datei zu archivieren, von der Festplatte zu löschen oder weitere Operationen durchzuführen. Sie finden diese Funktion auf der Registerkarte "Operationen".

Dank zusätzlicher Optionen können Sie die Datei-Operationen Ihren Anforderungen anpassen.

Erklärungen zu den einzelnen Funktionen finden Sie in nachstehender Tabelle:

Dateioperation:

Elemente löschen

Löscht alle markierten Dateien nach einer Sicherheitsrückfrage. Ist die Option "In den Papierkorb verschieben" aktiviert, werden die Dateien in den Papierkorb verschoben. Andernfalls werden Sie von der Festplatte gelöscht.
Information: Das Löschen ohne Setzen der oben beschreibenen Funktion kann nicht ohne weiteres rückgängig gemacht werden.

Elemente verschieben

Verschiebt markierte Dateien in den angegebenen Pfad. Optional kann an der ursprünglichen Stelle eine Verknüpfung oder ein Link erzeugt werden, die jeweils auf die neue Position des verschobenen Objekts zeigen. Auf Wunsch werden außerdem die Sicherheitsattribute mitkopiert. Geschieht dies nicht, so erben die verschobenen Dateien ihre Sicherheitsattribute (wie üblich) von den übergeordneten Elementen.

Elemente kopieren

Kopiert markierte Dateien in den angegebenen Pfad. Auf Wunsch werden außerdem die Sicherheitsattribute mitkopiert. Geschieht dies nicht, so erben die verschobenen Dateien ihre Sicherheitsattribute (wie üblich) von den übergeordneten Elementen.

Elemente zippen

Verschiebt markierte Dateien in das angegebene ZIP-Archiv.

Elemente an ausführbares Programm als Parameter übergeben

Ruft für jede markierte Datei eine frei wählbare ausführbare Datei auf und übergibt den absoluten Pfad der Datei als ersten Parameter an die Kommandozeile. Bei den ausführbaren Dateien kann es sich auch um Batch-Dateien, ein PowerShell Skript, ein VBScript o.ä. handeln. Das Windows Scripting FileSystemObject bietet leistungsfähige und einfach zu nutzende Möglichkeiten für Dateisystem- und Pfad-Operationen.

Optionen:

In den Papierkorb verschieben (falls verfügbar)

Hier können Sie festlegen, ob die gewählten Elemente in den Papierkorb verschoben oder direkt von der Festplatte gelöscht werden sollen.

Hinweis: Diese Option ist nur für die "Lösch"-Operation verfügbar.

Erhalte/Benenne um/Ersetze/Ersetze nur ältere existierende Dateien

Hier können Sie entscheiden, was passieren soll, wenn es bei einer Dateioperation zu Nameskollisionen kommt, d.h. eine Datei mit dem selben Namen bereits am Zielort existiert. Sie können die vorhandene Datei beibehalten, durch die neue Datei ersetzen, oder aber die existierende Datei umbenennen.

Hinweis: Diese Option ist nur verfügbar für die "Zip"-, "Verschiebe"- und "Kopiere"-Operation. Nicht unterstützt beim Brennen auf ein optisches Medium.

Leere Ordner nach Abschluss der Operation löschen

Entfernt automatisch alle Ordner, die aufgrund dieser Verschiebe-Operation keine Dateien oder andere Ordner mehr enthalten.

Ursprüngliche Elemente nach dem Zippen behalten

Aktivieren Sie diese Option, damit die ursprünglichen Dateien nach dem Kopieren in eine Zip-Datei nicht gelöscht werden.

Hinweis: Diese Option ist nur für die "Zip"-Operation verfügbar.

Berechtigungen für jedes Element übernehmen

Wenn diese Option aktiviert ist, werden die Zugriffsberechtigungen der Originaldateien für jede der verschobenen Dateien im Ziel übernommen.

Hinweis: Diese Option ist nur für die "Verschiebe"- und "Kopiere"-Operation verfügbar. Nicht unterstützt beim Brennen auf optisches Medium.

Verzeichnisstruktur erhalten, ab Ebene

Mit dieser Option können Sie festlegen, ab welcher Ebene die Verzeichnisstruktur der Dateien erhalten bleiben soll. Die ersten x Ebenen der Verzeichnisstruktur werden am Ziel-Ort nicht rekonstruiert.

Wenn Sie z.B. die Datei "C:\Benutzer\Mayer\Mein Dokument.doc" in den Ziel-Ordner "D:\Alte Dateien\" verschieben, erhalten Sie je nachdem, welchen Wert Sie für x wählen, folgende Ergebnisse:
x = 0 > "D:\Alte Dateien\C\Benutzer\Mayer\Mein Dokument.doc"
x = 1 > "D:\Alte Dateien\Benutzer\Mayer\Mein Dokument.doc"
x = 2 > "D:\Alte Dateien\Mayer\Mein Dokument.doc"

Hinweis: Diese Option ist nur für die "Verschiebe"- und "Kopiere"-Operation verfügbar.

Zeitstempel für jedes Element übernehmen

Wenn diese Option aktiviert ist, werden die Zeitstempel der Originaldateien für jede der verschobenen Dateien im Ziel übernommen.

Hinweis: Diese Option ist nur für die "Verschiebe"- und "Kopiere"-Operation verfügbar. Nicht unterstützt beim Brennen auf optisches Medium.

Verknüpfung/Link erstellen an ursprünglicher Stelle mit neuem Platz als Ziel

Ist diese Option aktiviert, wird eine Verknüpfung oder ein Link an der ursprünglichen Stelle erstellt, der auf den neuen Ort zeigt, an den die Datei verschoben wurde. Wurde "Link" ausgewählt und befinden sich die Dateien auf der selben Partition, so werden Hardlinks erstellt. Ist das Erstellen eines Hardlinks nicht möglich, so wird ein symbolischer Link erzeugt. Falls auch dies nicht möglich ist, so wird eine Windows-Verknüpfung erstellt.

Hinweis: Diese Option ist nur für die "Verschiebe"-Operation verfügbar.

Protokollierung:

Ausgeführte Operationen protokollieren in:

Erzeugt ein Protokoll mit einem Namen Ihrer Wahl in einem Verzeichnis Ihrer Wahl. Im Dateinamen können Umgebungsvariablen wie %DATE% oder %TIME% verwendet werden.

Undo-Skript erstellen:

Erzeugt eine Batch-Datei, die Sie nach der Verschiebe-Operation ausführen können, um die Änderungen diese Operation auf Ihrem Dateisystem rückgängig zu machen.

Hinweis: Diese Option ist nur für die "Verschiebe"- und "Kopiere"-Operation verfügbar. Nicht unterstützt beim Brennen auf optisches Medium.

Protokollierung

Tipp: Wir empfehlen Ihnen, alle Verschiebe-, Lösch- und Archivierungs-Operationen protokollieren zu lassen. Ein solches Vorgehen erhöht die Sicherheit und Übersichtlichkeit Ihres Systems.

Das von UltraSearch erzeugte Protokoll verzeichnet alle Details, die Sie benötigen, um die gewünschten Dateioperationen nachverfolgen zu können. Das Protokoll wird im Textformat abgespeichert und sieht beispielsweise folgendermaßen aus:

25.06.2020 11:39:50: Beginne Dateioperation.

25.06.2020 11:39:50: Kopiere die folgenden Objekte nach "D:\MyDocs":

25.06.2020 11:39:50: "F:\Docs\movielist.docx" => "D:\MyDocs\movielist.docx"

25.06.2020 11:39:50: "F:\Docs\log.txt" => "D:\MyDocs\log.txt"

25.06.2020 11:39:50: "F:\Docs\Screenshot.jpg" => "D:\MyDocs\Screenshot.jpg"

25.06.2020 11:39:50: Dateioperation abgeschlossen.

25.06.2020 11:39:50: Verarbeitete Objekte: 3 (125,90 KB) | Fehlerhafte Objekte: 0


Kommandozeilen-Parameter

Kommandozeilen-Parameter

Kommandozeilen-Parameter

UltraSearch unterstützt Kommandozeilen-Parameter, mit denen sich UltraSearch mit definierten Suchparametern starten lässt. Mehrere Suchparameter werden mit Leerzeichen getrennt.

Die Suchsyntax kann verwendet werden.

Suchparameter (Pfade oder Dateinamen), die bereits Leerzeichen beinhalten, müssen mit Anführungszeichen (") umschlossen werden.

Die allgemeine Syntax für Kommandozeilen-Parameter lautet wie folgt:

UltraSearch.exe Such-Pfad(e) Suchbegriff

Beispiele:

ultrasearch.exe "C:\Windows" "readme.txt"

Startet UltraSearch mit der Suche in "C:\Windows" nach allen Dateien, deren Name "readme.txt" beinhaltet.

ultrasearch.exe "C:\Windows" "readme OR license"

Startet UltraSearch mit der Suche in "C:\Windows" nach allen Dateien deren Name "readme" oder "license" beinhaltet.

ultrasearch.exe "C:\Windows" "ext:txt"

Startet UltraSearch mit der Suche in "C:\Windows" nach allen Dateien mit der Dateiendung ".txt".

ultrasearch.exe "C:\Windows\readme.txt"

Startet UltraSearch mit der Suche nach der Datei mit dem Namen "readme.txt" im Ordner "C:\Windows".

ultrasearch.exe "C:\Windows" "C:\Program Files" "readme AND cont:license"

Startet UltraSearch mit der Suche in "C:\Windows" und "C:\Program Files" nach Dateien, deren Name "readme" beinhaltet und dere Dateiinhalt das Wort "license" enthält.

ultrasearch.exe "C:\Windows" "*.exe" /CLIPBOARD

ultrasearch.exe "C:\Windows" "*.exe" /CLIPBOARD /NOGUI

Startet UltraSearch mit der Suche in "C:\Windows" nach ausführbaren Dateien mit der Dateiendung '.exe' und kopiert die Ergebnisse in die Windows Zwischenablage. Anschließend wird UltraSearch beendet.

Mit dem zusätzlichen Parameter /NOGUI wird der Vorgang im Hintergrund ohne Benutzeroberfläche ausgeführt. Nach Abschluss des Vorgangs wird eine Meldung im Benachrichtigungsbereich der Windows Taskleiste angezeigt.

Hinweis: Bei Verwendung des Kommandozeilenparameters /NOGUI können keine Nachrichten oder Fehler angezeigt werden. In diesem Fall werden alle Meldungen im Windows-Ereignisprotokoll des Systems aufgelistet.

ultrasearch.exe /minimized

Startet UltraSearch minimiert in der Taskleiste von Windows.

ultrasearch.exe /maximized

Startet UltraSearch als maximiertes Fenster.

ultrasearch.exe /tray

Startet UltraSearch minimiert im Infobereich von Windows.

ultrasearch.exe /noadmin

Startet UltraSearch ohne Administratorenrechte.

ultrasearch.exe /multi_instance

Erlaubt das Starten mehrere paralleler Programminstanzen.

Hinweis: Um parallele Instanzen generell zu erlauben, kann alternativ im "%appdata%\JAM Software\UltraSearch"-Verzeichnis in der Datei "Settings.xml" der Wert "MultipleInstances" auf "true" gesetzt werden.


Tipps & Anmerkungen

Tipps & Anmerkungen

·Nützliche Tipps und Tricks

·Hinweise zu NTFS

·Reguläre Ausdrücke

·Übersetzungen


Nützliche Tipps und Tricks

Navigation: UltraSearch > Tipps & Anmerkungen >

Nützliche Tipps und Tricks

Tipp 1: Schneller Start mit dem Betriebssystem

Wenn Sie UltraSearch direkt mit dem Betriebssystem starten lassen, haben Sie jederzeit direkten und schnellen Zugriff auf das Programm. Über "Optionen > Anwendung > Mit Windows starten" lässt sich UltraSearch direkt mit dem Betriebssystem starten. UltraSearch ist dann jederzeit über den Infobereich auf der rechten Seite der Taskleiste verfügbar.

Tipp 2: Schneller Aufruf mittels Hotkey

Über die Tastenkombination "Strg + Shift + U" lässt sich UltraSearch bei Bedarf blitzschnell in den Vordergrund bringen und Sie können ohne Verzögerung Ihre Suche starten. Die Tastenkombination zum Aufrufen von UltraSearch lässt sich unter "Optionen > Anwendung > Hotkey auswählen" jederzeit ändern.

Tipp 3: Benutzerkontensteuerungs-Warnung (UAC) überspringen

Wird Ihnen beim Start von UltraSearch die Benutzerkontensteuerung von Windows angezeigt, können Sie diese über "Optionen > Anwendung > Benutzerkontenstuerungs-Warnung überspringen" deaktivieren.

Weitere Tipps und Tricks finden Sie auch in unserer Knowledge Base.


Hinweise zu NTFS

Navigation: UltraSearch > Tipps & Anmerkungen >

Hinweise zu NTFS

Hardlinks

Ein Hardlink ist ein Verzeichniseintrag in der MFT (Master File Table) von NTFS Partitionen. Jede Datei weist mindestens einen Hardlink auf. Auf NTFS-Datenträgern kann jede Datei mehrere Hardlinks besitze und daher in mehreren Verzeichnissen (oder im selben Verzeichnis mit verschiedenen Namen) angezeigt werden. Da alle diese Verbindungen auf dieselbe Datei verweisen, können Programme einen beliebigen Hardlink öffnen und die Datei ändern. Eine Datei wird nur dann aus dem Dateisystem gelöscht, wenn alle Hardlinks zu dieser Datei gelöscht wurden. Bitte beachten Sie auch, dass sich alle Hardlinks auf eine Datei die gleichen Zugriffsberechtigungen teilen.

Existiert mehr als ein Eintrag für eine Datei, so muss beim Berechnen des belegten Speicherplatzes diese Datei lediglich einmal berücksichtigt werden, egal wie viele Hardlinks existieren. UltraSearch ist in der Lage, die Anzahl der Hardlinks die auf eine Datei verweisen zu identifizieren. Die Anzahl der Hardlinks, die auf eine Datei verweisen, wird in der Spalte Hardlinks angezeigt.


Reguläre Ausdrücke

Navigation: UltraSearch > Tipps & Anmerkungen >

Reguläre Ausdrücke

Reguläre Ausdrücke beschreiben Muster in Zeichenketten und werden u.a. dazu benutzt, um festzustellen, ob in einem Text, dem Suchtext, ein vorgegebenes Zeichenmuster vorkommt oder nicht. In UltraSearch können Reguläre Ausdrücke dazu benutzt werden, bestimmte Dateien und/oder Ordner zu finden, die den mittels Regulärer Ausdrücke festgelegten Kriterien entsprechen.

Die folgende Tabelle zeigt einige Beispiele:

Ausdruck | Syntax | Beschreibung | Beispiel
Beliebiges Zeichen | . | Entspricht einem beliebigen Zeichen mit Ausnahme des Zeilenumbruchs. | a.o findet "aro" in "around" und "abo" in "about", jedoch nicht "acro" in "across".
0 (null) oder mehr | * | Findet 0 (null) oder mehr Vorkommen des vorangehenden Ausdrucks und ergibt somit alle möglichen Übereinstimmungen. | *b findet "b" in "bat" und "ab" in "about". e.*e findet das Wort "enterprise".
Eine oder mehr | + | Findet mindestens ein Vorkommen des vorhergehenden Ausdrucks. | ac+ findet Wörter mit dem Buchstaben "a" und mindestens einer Instanz von "c", z. B. "race" und "ace". a.+s findet das Wort "access".
Wortanfang | < | Findet nur dann eine Übereinstimmung, wenn das Wort an dieser Textstelle beginnt. | <in findet Wörter wie "inside" und "into", die mit den Buchstaben "in" anfangen.
Wortende | > | Gibt eine Übereinstimmung nur zurück, wenn das Wort an dieser Textstelle endet. | ss> findet Wörter wie "across" und "loss", die mit den Buchstaben "ss" enden.
Ein beliebiges Zeichen in der Menge | [] | Findet eines der Zeichen, die in [] enthalten sind. Geben Sie zum Festlegen eines Bereichs von Zeichen das Start- und das Endzeichen durch einen Bindestrich (-) getrennt ein, wie in [a-z]. | be[n-t] findet "bet" in "between", "ben" in "beneath" und "bes" in "beside", jedoch nicht "bel" in "below".
Ein beliebiges, nicht in der Menge enthaltenes Zeichen | [^...] | Findet ein beliebiges Zeichen, das nicht im Satz von Zeichen nach ^ enthalten ist. | be[^n-t] findet "bef" in "before", "beh" in "behind" und "bel" in "below", jedoch nicht "ben" in "beneath".
Or | | | Findet entweder den Ausdruck vor oder nach dem Symbol OR (|). Wird meistens in einer Gruppe verwendet. | (sponge|mud) bath findet "sponge bath" und "mud bath".
Escape | \ | Findet das Zeichen, das dem umgekehrten Schrägstrich (\) als Literal folgt. Damit können Sie Zeichen wie { und ^ suchen, die in der Notation für reguläre Ausdrücke verwendet werden. | \^ sucht nach dem Zeichen ^.
Markierter Ausdruck | {} | Findet den Text, der mit dem in Klammern stehenden Ausdruck übereinstimmt. | zo{1} findet "zo1" in "Alonzo1" und "Gonzo1", jedoch nicht "zo" in "zone".
n Mal wiederholen. | ^n | Entspricht n Instanzen des vorhergehenden Ausdrucks. | [0-9]^4 findet alle Zeichenfolgen mit 4 Ziffern.
Gruppierung | () | Ermöglicht es Ihnen, einen Satz von Ausdrücken zu gruppieren. Wenn Sie in einer Suche nach zwei verschiedenen Ausdrücken suchen möchten, können Sie diese mit dem Gruppierungsausdruck kombinieren. | Wenn Sie nach [a-z][1-3] oder [1-10][a-z] suchen möchten, würden Sie diese Ausdrücke wie folgt kombinieren: ([a-z][1-3]) | ([1-10][a-z]).

Weitere Beispiele:

[0-9] oder /\d | Findet alle Dateien/Ordner, die mindesten eine Ziffer im Namen enthalten.
a|b | Findet alle Dateien/Ordner, die "a" oder "b" im Namen enthalten.
(?=.*a)(?=.*b) | Findet alle Dateien/Ordner, die mindestens sowohl ein "a" als auch ein "b" enthalten.
((?=.*help)|(?=.*online))(?=.*readme) | Findet alle Dateien/Ordner, die die Wörter "help" und "readme" oder "online" und "readme" beinhalten.
[^(A-Za-z)] | Findet alle Dateien/Ordner, die mindestens ein Zeichen enthalten, das kein Buchstabe ist.
^E[0-9]{7}$ | Findet alle Dateien/Ordner, die mit einem "E" beginnen an das sich genau sieben Ziffern anschließen.
C:\\Windows\\[^\\]*\.[^\\]*$ | Findet alle Dateien/Ordner, deren direkter übergeordneter Ordner C:\Windows ist.
[A-Za-z]:\\([^\\]+\\){2,4}[^\\]+$ | Findet alle Dateien/Ordner mit einer Verzeichnistiefe von mindestens 2 und höchstens 4.
[^\x00-\x7F] | Findet alle Dateien/Ordner mit ungültigen ASCII-Zeichen (nur 7Bit ASCII erlaubt).
[^\P{C}] | Findet alle Dateien/Ordner mit nicht-druckbaren Unicode-Zeichen.
[\xA0] | Findet alle Dateien/Ordner mit dem non-breakable-Space Zeichen (Unicode NOBR, U+00A0)
[~\"#%&\*\:<>\?\/\\{|}] | Findet alle Dateien und Ordner, die in ihrem Namen Zeichen enthalten, die auf einem SharePoint Server nicht erlaubt sind.

Mehr Informationen zu regulären Ausdrücken sowie Beispiele finden Sie hier.

Eine Liste spezieller Zeichen, die innerhalb Regulärer Ausdrücke benutzt werden können finden Sie hier.

Zur weiteren Hilfe beim Bilden Regulärer Ausdrücke können folgende Tools verwendet werden:

http://gskinner.com/RegExr/ (online)

http://regexpal.com/ (online)

http://sourceforge.net/projects/regexpeditor/ (download)

http://sourceforge.net/projects/regextester/ (download)

http://sourceforge.net/projects/regaxe/ (download)


Übersetzungen

Navigation: UltraSearch > Tipps & Anmerkungen >

Übersetzungen

Übersetzungen

Wir sind stolz auf die Popularität unserer Freeware UltraSearch und würden es den Nutzern gerne in Ihrer jeweiligen Sprache anbieten. Auf diese Weise können unsere Nutzer weltweit UltraSearch lokalisiert und einfach nutzen. UltraSearch ist bereits auf Deutsch und Englisch verfügbar. Dank der großartigen Hilfe unserer freiwilligen Übersetzer können wir auch folgende Übersetzungen bereitstellen:

Chinesisch (Vereinfacht): Dank an streambun, Adrian Zhang, 偶爱偶家, CJKCHINA, Neptune, Zhihao Wang und 4 anonyme Übersetzer

Dänisch: Dank an Svend Heinesen, Thomas Vedel und 3 anonyme Übersetzer

Französisch: Dank an Alexandre Mongin, Simon Martin, Ignace Le Roux, David Dissard, Gaillard S-G und 5 anonyme Übersetzer

Griechisch: Dank an GeoVasi69, Prodromos Makridis und 2 anonyme Übersetzer

Italienisch: Dank an Spigolo, Luciano Paravella, Fabrizio Picconi, Lionello Ferrazzini, Daniele Caputo, David Coen, Gioele Mattioli, bovirus, Andrea "Echo" Zoppi , Mario Corrado, Alberto Donzelli, Ivan Vaselli, Filippo Rubulotta und 6 anonyme Übersetzer

Japanisch: Dank an Kyotaro Iijima, Tetsuro Shimazaki und Sriram Iyer

Koreanisch: Dank an Seungsoo Choi und 8 anonyme Übersetzer

Niederländisch: Dank an Jaap Kramer, Kees Bakker, Linda Bijlsma, Leroux und 4 anonyme Übersetzer

Norwegisch: Dank an Simen Andreas Skogheim, Isaac Daasnes und 2 anonyme Übersetzer

Polnisch: Dank an Franciszek, Your Majesty Bartłomiej Rakowiecki, Bartosz Małolepszy (Grodków), Arkadiusz Kurzawa, Łukasz K. und 8 anonyme Übersetzer

Portugiesisch: Dank an Ricardo Freitas, Ian Lima Souza, Maria Pombo, Carlos Figueiredo und 2 anonyme Übersetzer

Russisch: Dank an kopejkin, Polina Morgan, Vladimir Skovoroda, Alexander Vorfolomeev, Temtaime, Gennady Morozov und 2 anonyme Übersetzer

Slowenisch: Dank an Jadran Rudec, Boštjan Pečovnik und einen anonymen Übersetzer

Spanisch: Dank an J. M. Fustero, MS-PC, Fabián C. Rodríguez und 4 anonyme Übersetzer

Tschechisch: Dank an Trasak Jiri, Lukáš Francálek, Azuráč, Fishbone und 3 anonyme Übersetzer

Ungarisch: Dank an Peter Bartfai und 5 anonyme Übersetzer

Vietnamesisch: Dank an Vu Le, Minh Tuyen Nguyen, Đăng Huy und einen anonymen Übersetzer


Copyright & Contact

Copyright & Contact

Copyright © 2022 Joachim Marder e.K.

JAM Software GmbH
Am Wissenschaftspark 26
54296 Trier

WWW: | https://www.jam-software.de
Support: | https://customers.jam-software.de/contact.php
E-Mail: | ultrasearch@jam-software.de
Handelsregister: | HRB: 4920 beim Amtsgericht Wittlich
Umsatzsteuer ID: | DE234825349
Geschäftsführer: | Joachim Marder