Willkommen

SpeedCommander
Willkommen

Willkommen zu SpeedCommander 15!

SpeedCommander hilft Ihnen bei der Verwaltung Ihrer Dateien in bewährter Zweifenstertechnik, die für jedermann einfach zu bedienen ist und dennoch auch dem erfahrenen Anwender mit ihrer Leistungsfähigkeit dient. SpeedCommander integriert Dateimanagement, Dateibetrachter, Datenkomprimierung, Verschlüsselung, das Starten von Anwendungen, Funktionen zur Festplattenverwaltung sowie den Zugriff auf Netzwerk, Internet und FTP unter einer einfachen und einheitlichen Benutzeroberfläche.

Was ist neu?

SpeedCommander 15 bietet gegenüber älteren Versionen viele nützliche Funktionen an, die Sie schon bald nicht mehr missen möchten.

Schnelleinstieg

Der Schnelleinstieg beschreibt den direkten Weg zu den einzelnen Funktionen von SpeedCommander.

Alle Funktionen im Detail

Egal, was Sie schon über SpeedCommander gehört haben - er kann noch viel mehr.

SpeedCommander im Web

Aktuelle Informationen und neue Versionen finden Sie auf unserer Website.

Feedback

Vermissen Sie eine Funktion? Schreiben Sie Ihren Wunsch direkt an den Entwickler.

Technische Unterstützung

Bei Problemen oder Fragen wenden Sie sich bitte an den Kundendienst.

Anwenderforum

Diskutieren Sie mit anderen Anwendern in unserem Forum.


Neue Funktionen

SpeedCommander
Neue Funktionen

Diese Seite listet die wesentlichen Änderungen und Erweiterungen der verschiedenen SpeedCommander-Versionen auf.

SpeedCommander 15.00

  • Aktualisierung von MFC/Compiler auf VS2012 - Update 3
  • Visuelle Designs für Office 2010/2013 und Visual Studio 2010/2012
  • Neue Symbole für Menüs und Symbolleisten im Office 2010-Stil
  • Neue Symbole für Menüs und Symbolleisten im Office 2013-Stil
  • Schärfere Darstellung auf Bildschirmen mit hoher DPI-Auflösung
  • Anzeige eines Einstellungsassistenten beim ersten Start
  • Plattformübergreifender Import von Einstellungsdateien früherer Versionen
  • Anzeige des aktuellen Ordners und anderen Elementen in der Titelzeile des Hauptfensters
  • Dateierweiterungen für Multimediadateien im Statuszeilen-Dialog konfigurierbar
  • Umgebungsvariablen und editierbarer Pfadname für QuickDrop-Symbole
  • Neue auf englische Menübefehle abgestimmte Tastenkürzelvorlage
  • Optionale Darstellung der Größenangaben (2er-Potenzen) mit SI-Einheiten (Einstellungsdialog 'Erweitert - Spezielles')
  • Aktualisierung zlib (Version 1.2.8)
  • Aktualisierung pnglib (Version 1.5.15)
  • Pro-Version: Anzeigen und Entpacken von ISO-Dateien
  • Pro-Version: Virtuelles Laufwerkssymbol für die Zusammenstellung von Brennprojekten (CD/DVD/Blu-Ray)
  • Pro-Version: Anzeige von detaillierten Informationen zu optischen Lese-/Schreibgeräten
  • Pro-Version: Anzeige von Medieninformationen optischer Lese-/Schreibgeräte
  • Pro-Version: Brennen von Datenträgerabbilddateien
  • Pro-Version: Erstellen von Datenträgerabbilddateien
  • Pro-Version: Löschen von wiederbeschreibbaren optischen Medien
  • Pro-Version: Menübefehl für den Aufruf von Keseling DirPrinter
  • Ordnerfenster: Darstellung der Netzwerkumgebung wie im Windows-Explorer
  • Ordnerfenster: Farbliche Kennzeichnung von Ordnerfenstern
  • Ordnerfenster: Verschieben von Ordnerfenstern mit der Maus
  • Ordnerfenster: Neues Ordnerfenster kann am Ende der Liste eingefügt werden
  • Ordnerfenster: Schaltflächen für Hinzufügen und Schließen von Ordnerfenstern
  • Ordnerfenster: Aktivierung der Ordnerfenster wahlweise mit Strg+Ziffer oder Strg+Umschalt+Ziffer
  • Ordnerfenster: Wechsel zwischen den Ordnerfenstern wahlweise auch mit Strg+Umschalt+BildAuf/BildAb oder Strg+Umschalt+Ende/Pos1
  • Listenansicht: Anzeige von Dateinamenserweiterungen in virtuellen Shellordnern (z.B. Kamera)
  • Listenansicht: Einstellung für automatische Sortierung nach dem Umbenennen eines Eintrags
  • Listenansicht: Unterbrechung und Neustart der Ordnergrößenberechnung beim Umbenennen eines Ordners
  • Listenansicht: Verbesserungen bei der Anzeigegeschwindigkeit von Ordnern im Dateisystem
  • Listenansicht: Vereinfachte Einstellung für das Ausblenden von Dateinamenserweiterungen in der Listenansicht
  • Listenansicht: Verwendung von Stellvertreterzeichen beim Ausblenden von Dateien und Ordnern möglich
  • Listenansicht: Anzeige der Anzahl von Dateien unterhalb eines Ordners in der Spalte 'Dateien' bei der Ordnergrößenberechnung
  • Laufwerksleiste: Speichern des zuletzt aktiven Ordners für das Laufwerkssymbol 'Desktop'
  • Dateioperation: Beibehaltung der lokalisierten Dateinamen beim Kopieren/Verschieben von Dateien
  • Dateioperation: Schreibschutz-Attribut beim Kopieren von CD-ROM entfernen
  • Dateioperation: Verbesserte Erkennung von UAC-geschützten Ordnern
  • Dateioperation: Zurücksetzen der Sicherheitsattribute beim Verschieben auf dem gleichen Volume
  • Schnellansicht: Anzeige von Dateien in Ordnern des Shell-Namensbereichs
  • Dateiablage: Darstellung der Dateiablage unabhängig vom Ordnerfensterlayout als virtuelles Laufwerk
  • Archive: Anzeige aller Dateierweiterungen im Einstellungsdialog für Dateiverknüpfungen
  • Archive: Anzeige und Entpacken von .zipx-Dateien
  • ZIP: Entpacken von Dateien, die mit der LZMA-Methode komprimiert sind
  • ZIP: Entpacken von Dateien, die mit der WavPack-Methode komprimiert sind
  • ZIP: Unterstützung von Dateinamen und Kommentaren in Unicode
  • RAR: Anzeige und Entpacken von RAR5-Archiven
  • sqc: Kommandozeilenprogramm für Archivoperationen
  • SpeedEdit: Aktualisierung von Scintilla (Version 3.3.2)
  • FileSearch: Automatische Sortierung der Ergebnisse nach Name/Größe bei entsprechender Doublettensuche
  • SCBackupRestore: Erstellen einer portablen Version von SpeedCommander

SpeedCommander 14.60

  • Aktualisierung des Compilers auf VS2012 - Update 2
  • Listenansicht: Optionale Deaktivierung der zusätzlicher Initialisierung für das Hintergrund-Kontextmenü eines Ordners (Einstellungsdialog 'Erweitert - Spezielles')

SpeedCommander 14.50

  • Aktualisierung von CRT/MFC/Compiler auf VS2012
  • Listenansicht: Ausführen von Programmen mit erhöhten Rechten, wenn in der Listenansicht 'Strg' und 'Umschalt' gedrückt wird
  • Schnellansicht: Anzeige der Dateieigenschaften APPCONTAINER und HIGH_ENTROPY_VA im Betrachter für Programmdateien

SpeedCommander 14.40

  • FileSync: Anzeige des Profilnamens in der Titelzeile beim Start

SpeedCommander 14.30

  • Protokollierung der Änderungen im Dateisystem zu Diagnosezwecken (z.B. über DebugView von Mark Russinovich)
  • Schnellansicht: Aktualisierung des PDF-Betrachters auf Version 2.5.201
  • FileSync: Anzeige des Dateinamens während des Inhaltsvergleichs
  • FileSync: Synchronisation in UAC-geschützten Ordnern

SpeedCommander 14.20

  • Duplizieren von Ordner- und Anwendungsfavoriten
  • Anzeige des vollständigen Pfadnamens als InfoTip bei Dialogelementen mit gekürzten Pfadelementen
  • Anzeige und Änderung der Dateiattribute 'Temporär' (T) und 'Inhalt nicht indiziert' (I)
  • Ausführung von Befehlseingabezeilen mit erhöhten Rechten durch zusätzliches Drücken der linken oder rechten Windowstaste
  • Schnellere Anzeige von über das Internet verbundenen Netzwerkordnern (Einstellungsdialog 'Aussehen - Netzwerk & Sortieren')
  • Optionale Anzeige von Overlaysymbolen für langsame Netzwerkordner (Einstellungsdialog 'Erweitert - Spezielles')
  • RAR: Aktualisierung der Unrar.dll auf Version 4.10
  • RAR: 'Beschädigte Dateien nicht löschen' für RAR-Archive

SpeedCommander 14.10

  • Kommandozeilenparameter /l und /r können virtuelle Ordner enthalten (z.B. 'Desktop\Bibliotheken' oder 'shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}')
  • Kommandozeilenparameter /noscript zur Deaktivierung der Makro-Funktionalität bei fehlerhaft installiertem Scripting-Host
  • Listenansicht: Optionale Begrenzung der Hintergrundthreads zur Ermittlung von Symbolen, Spaltentexten und Ordnergrößen (Einstellungsdialog 'Erweitert - Spezielles')
  • FileSearch: Verfolgung von Abzweigungen kann deaktiviert werden (Menü 'Extras')
  • 7z: Aktualisierung der 7za.dll auf Version 9.20
  • 7z: Erstellung von Archiven mit LZMA2-Methode
  • Änderung FileSearch: Ignorieren von Abzweigungen bei Dublettensuche

SpeedCommander 14.00

  • UAC-Aktionen ohne Systemregistrierung (portabel)
  • Erweiterung des Kontextmenüs mit Befehlen von SpeedCommander
  • Zugriff auf Editierfelder von Ordnerinformation und Laufwerksinformation per Tastatur (Tab/Strg+Tab)
  • Tastenkürzelschema für zweistufige Tastenkürzel
  • Überarbeitung der Systemordner-Funktionen (x86-Systemordner für 64-bit Version, Öffentliche Ordner, Windows 7-Ordner)
  • Schließen von Registerkarten mit der mittleren Maustaste
  • Beachtung von Sommerzeit/Normalzeit bei der Umwandlung der Zeitstempeln von UTC in lokale Zeit
  • Automatische Korrektur des Ziels einer Kompatibilitäts-Verbindung beim Ordnerwechel, wenn sie auf ein anderes Laufwerk zeigt
  • Definition von Initialisierungsordnern für XP-kompatible Spaltenerweiterungen (z.B. TortoiseSVN) im Einstellungsdialog
  • Dateisystemfunktionen für Einträge im Hauptordner einer Bibliothek
  • Umstellung des Menübefehls 'Ordner - Systemdateien anzeigen' auf drei Zustände (Reihenfolge wie Einstellungsdialog)
  • Menübefehl für temporäre Anzeige der ausgeblendeten Dateien und Ordner (Ordner - Ausgeblendete Dateien und Ordner anzeigen)
  • Menübefehl für Umschaltung der automatischen Ordnergrößenberechnung (Ordner - Ordnergrößen automatisch berechnen)
  • Bearbeiten der INI-Einstellungen im Einstellungsdialog
  • Anzeige von Archivinformationen in 'Datei - Mehr Eigenschaften'
  • Hexadezimale Darstellung von Datenströmen in 'Datei - Mehr Eigenschaften'
  • Baumansicht: Basisordner als oberster Eintrag in der Baumansicht (Registerkarten-Eigenschaften)
  • Baumansicht: Einstellung für obersten Eintrag in der Baumansicht (Desktop oder Laufwerk)
  • Listenansicht: Bessere Multicore-Auslastung bei der Anzeige von Vorschaubildern und Spaltentexten
  • Listenansicht: Ordneransichten zur Anpassung der Anzeige für bestimmte Ordner (Musik, Bilder)
  • Listenansicht: Kopieren der Informationen aus der Detailansicht in die Zwischenablage (Bearbeiten - Detailansicht als Text kopieren)
  • Listenansicht: Kennzeichnung der internen und externen Spalten in der Feldauswahl
  • Listenansicht: Sortierung der Spalten nach Namen in der Screenreader-kompatiblen Feldauswahl
  • Schnellansicht: Textbetrachter mit Syntaxhervorhebung
  • Schnellansicht: Einbindung von Windows-Vorschauhandlern
  • Schnellansicht: Verbesserung der Geschwindigkeit bei Ansicht von Programmdateien
  • Schnellansicht: Anzeige von Bildern in x64-Version ohne Systemregistrierung (portabel)
  • Archive: Komprimieren/Entpacken mit Warteschlange
  • Archive: Überarbeitung des Komprimierdialogs
  • Ordnerinformation: Anzeige von Verweisen, Hardlinks, Datenströmen und Sparse Files
  • Ordnerinformation: Korrekte Berechnung der allokierten Größe von Datenströmen, Sparse Files und komprimierten Dateien
  • Ordnerinformation: Berichterstellung (Klick mit rechter Maustaste in Ordnerinformationsfenster)
  • Dateioperation: Kopieren von Hardlinks
  • Dateioperation: Verschieben mit Fortschrittsanzeige
  • Dateioperation: Erstellen von Verbindungen, Hardlinks und symbolischen Links
  • Dateioperation: Zusätzliche Befehle für Kopieren und Verschieben mit/ohne Bestätigung
  • Dateioperation: Dateigröße wird beim sicheren Löschen auf volle Clustergröße aufgerundet
  • Dateioperation: Einzel- und Gesamtfortschritt beim sicheren Löschen
  • Dateioperation: Ermittlung der Gesamtgröße bei Dateioperationen während des Vorgangs
  • Dateioperation: Beachtung von MountPoints beim Verschieben von Ordnern auf dem gleichen logischen Laufwerk
  • Dateioperation: Anzeige von Quelle und Ziel als InfoTip im Fortschrittsfenster
  • Anwendungsfavoriten: Verwendung von CreateProcess anstelle von ShellExecuteEx, wenn die Länge der Kommandozeile 2048 Zeichen überschreitet
  • Anwendungsfavoriten: Neue Parameter für Listendateien - $(ActSelLst), $(ActSelLstU8), $(ActSelLstU16)
  • Anwendungsfavoriten: Optionales Ausführen mit angehobenen Rechten
  • FTP: Eingabe der FTP-Zugriffsrechte im Eigenschaften-Dialog als Oktalzahl
  • FTP: Farbige Darstellung im FTP-Statusfenster
  • FTP: Löschen von Dateien im Hintergrund
  • FTP: Setzen von SUID/SGID und Sticky im Eigenschaften-Dialog
  • FTP: Unterstützung für MLSD und MFMT
  • FTP: Vorgabe der Berechtigungen im Kopieren-Dialog
  • FTP: Verzeichnisübergreifendes Umbenennen auf einem FTP-Server
  • SpeedEdit: Sicherheitskopie beim Speichern erstellen (.bak)
  • FileSearch: Aufhebung der strikten Trennung von Dateiname und Erweiterung bei Suchmasken
  • FileSearch: Zusätzliche Spalten für Dateiinformationen
  • FileSearch: Miniaturansicht und Gruppierung im Ergebnisfenster
  • FileSearch: Automatische Übernahme der Einstellungen von SpeedCommander für die Listenansicht
  • FileSearch: Farbdarstellung in der Listenansicht
  • FileSearch: Erweitertes Auswählen von Dokumenten per Auswahldialog
  • FileSearch: Kopieren von Pfadnamen in die Zwischenablage bei Beachtung der Einstellungen in SpeedCommander.ini
  • FileSync: Gezieltes Löschen von Dateien nach dem Dateivergleich
  • FileSync: Farbliche Kennzeichnung von zu kopierenden Dateien
  • FileSync: Betrachten und Vergleichen von Dateien mit externen Programmen
  • FileSync: Anzeige des Fortschritts während des Synchronisiervorgangs in der Taskleiste
  • FileSync: Anzeige der Dateigröße in Bytes
  • FileSync: Kennzeichnung der neueren Dateien wahlweise in Fett/Kursiv
  • FileSync: Schriftart- und größe für Listenansicht wählbar
  • FileSync: Änderung der Kopierrichtung für einzelne Dateien nach dem Vergleich
  • SCBackupRestore: Unterstützung von Unicode-Pfaden
  • SCBackupRestore: Sicherungen können mit einem Kommentar gekennzeichnet werden
  • Änderung: Unterstützung für angepasste Symbole für Ordner und Laufwerke ohne zusätzliche Option
  • Änderung: Einstellung der U3-Version
  • Änderung Internet: Einstellung der Unterstützung für Mozilla ActiveX-Control
  • Änderung FileSearch: Entfall der Verwendung von CharSets
  • Änderung FileSearch: Maskierung von eckigen Klammern nicht mehr nötig

SpeedCommander 13.60

  • Aktualisierung von CRT/MFC/Compiler auf VS2010 SP1
  • Listenansicht: Kennzeichnung der Einträge im Ordnerfenster als aktiv, wenn SpeedCommander inaktiv ist
  • FileSearch: Automatische Korrektur der Zeitstempel, wenn der 'Von-Bis'-Zeitraum umgekehrt angegeben wird

SpeedCommander 13.50

  • Dateioperation: Anzeige des Namens der Anwendung beim Löschen von gesperrten Dateien auch bei Anwendungen, die IFileIsInUse nicht unterstützen
  • FTP: Aktualisierung OpenSSL auf Version 1.0d
  • FileSearch: Zusätzliche Felder für Angabe der Größeneinheit

SpeedCommander 13.40

  • Kennzeichnung von SpeedCommander durch 'Administrator:' im Fenstertitel, wenn er mit angehobenen Rechten läuft
  • Aktualisierung der 7z-Bibliothek 7za.dll auf Version 4.65
  • Prüfung auf Verbindungen beim Kopieren und Löschen von Ordnern
  • Zustand der Option 'Ohne Nachfrage überschreiben' für Dateioperationen wird für die laufende Sitzung gespeichert

SpeedCommander 13.30

  • Aktualisierung von CRT/MFC auf VS2010
  • Anzeige von Laufwerksbezeichnern, Ordnernamen oder Ordnernamen und Laufwerksbezeichnern auf den Registerkarten
  • Erstellen einer neuen Registerkarte durch Doppelklick in den freien Bereich
  • Listenansicht: Öffnen von Dateien optional durch Kontextmenü-Methode
  • Laufwerksleiste: Einstellbare Verzögerung bei Anzeige von InfoTips für Laufwerksfenster
  • Dateioperation: Genauere Fehlermeldung, wenn eine Datei größer 4 GiB auf ein FAT32-Laufwerk kopiert werden soll
  • FTP: Aktualisierung OpenSSL auf Version 1.0
  • RAR: Aktualisierung unrar.dll auf Version 3.93
  • SpeedEdit: Aktualisierung auf Scintilla v2.11

SpeedCommander 13.20

  • Listenansicht: Bessere Erkennbarkeit des fokussierten Eintrags bei aktiviertem Explorer-Stil für Auswahlelemente
  • Listenansicht: Erhöhung der Sortiergeschwindigkeit
  • Dateioperation: Automatisches Umbenennen bei Strg+X/V im gleichen Ordner anstatt Fehlermeldung
  • AddIn: Fehlermeldung STG_E_FILEALREADYEXISTS beim Umbenennen (Dateisystem-AddIns)

SpeedCommander 13.10

  • Ausblenden von leeren Wechseldatenträgern
  • Kompatibilitätsschalter für Ziehen & Ablegen mit rechter Maustaste
  • Option für Anzeige von Tastenkürzeln in Kontexmenüs
  • Aufruf von SHChangeNotify nach Dateioperationen
  • FileSearch: Spezielle Reparse Points unter Windows Vista/7 werden ignoriert
  • FTP: Zusätzliche Definition für Datumseintrag 'Mrz'

SpeedCommander 13.00

  • Direkter Zugriff auf Desktop, Computer und virtuelle Ordner innerhalb von SpeedCommander
  • Fortschrittsanzeige in der Taskleiste (Windows 7)
  • Anzeige von zusätzlich installierten Erweiterungen im Kontextmenü für Ordner (z.B. Tortoise SVN)
  • Verwendung von doppelten Tastenkürzeln für einen Befehl (z.B. Strg+K, Strg+W)
  • Kopieren des UNC-Dateinamens als Text (bei gemappten Netzlaufwerken)
  • Befehl für Update-Prüfung (Hilfe - Auf Aktualisierung prüfen)
  • Automatisches Einklappen von Ordnern in der Baumansicht
  • Wechsel in den Standby-Modus wird während einer Dateioperation verhindert
  • Kommandozeilenparameter für den Import von Einstellungen aus SpeedCommander 11/12
  • Listenansicht: Darstellung der Einträge wie im Vista/Windows 7-Explorer
  • Listenansicht: Hervorhebung des unter dem Mauszeiger befindlichen Eintrags
  • Listenansicht: Markierung von Dateinamen durch Aufziehen des Lassos neben dem Text für den Dateinamen
  • Listenansicht: Kennzeichnung von Dateien, die wahrscheinlich mit angehobenen Benutzerrechten gestartet werden müssen, durch ein kleines Schildsymbol (wie im Explorer)
  • Listenansicht: Verbesserte Skalierung von Dateisymbolen in der Miniaturansicht
  • Listenansicht: ".." steht in der gruppierten Ansicht immer ganz oben
  • Listenansicht: Einlesen von Verzeichnissen im Hintergrund
  • Listenansicht: Gleichzeitiges Öffnen mehrerer Dateien bei 'Enter'
  • Listenansicht: Kennzeichnung von Ordnern per Vorlage
  • Listenansicht: Verweis auf Elternordner (..) kann ausgeblendet werden
  • Listenansicht: Dynamisches Datumsformat für Spalten (ausführlicher bei breiten Spalten, kompakter bei schmalen Spalten)
  • Ziehen & Ablegen: Explorer-kompatibles Verhalten (Verschieben auf gleichem Laufwerk)
  • Ziehen & Ablegen: Anzeige von Dateisymbolen und einer Zielbeschreibung
  • Ziehen & Ablegen: Kontextmenü beim Ziehen mit der rechten Maustaste
  • Schnellsuche: Verwendung von Stellvertreterzeichen
  • Schnellsuche: Übereinstimmung von Suchbegriffen auch innerhalb von Dateinamen
  • Schnellsuche: Einstellung für das Öffnen von Dateien beim Schließen der Schnellsuche durch 'Enter'
  • Laufwerksleiste: InfoTips für Laufwerke auf Wunsch mit Gesamtspeicherplatz und freiem Speicher
  • Schnellansicht: Verbesserte Tastatursteuerung für die Schnellansicht
  • Schnellansicht: Eigener Betrachter für PDF-Dateien
  • SpeedEdit: Syntaxhervorhebung für Fortran
  • SCBackupRestore: Import von Einstellungen für SpeedCommander 11/12
  • Zusätzliche Einstellungen per INI-Datei

SpeedCommander 12.50

  • Ordnerfavoriten können relative Pfade enthalten
  • Optimierungen bei der Navigation im Netzwerk

SpeedCommander 12.40

  • Archiver können Dateinamen bis zu 32000 Zeichen verarbeiten (Ausnahme: ACE, CAB (260), RAR (1024); Begrenzung auf 260 Zeichen innerhalb von Archiven)
  • Genauere Fehlermeldungen bei Archivoperationen
  • Fenster für Fehlermeldungen bei Archivern kann vergrößert werden
  • Dateinamen werden vor dem sicheren Löschen auf "z" umbenannt
  • CAB: Detailierte Fortschrittsanzeige beim Entpacken
  • CAB: Mehrere Archivoperationen gleichzeitig möglich
  • RAR, 7z: Verbesserte Abfrage von Kennwörtern beim Entpacken von Dateien mit verschlüsseltem Archivverzeichnis
  • 7z: Aktualisieren von Solid-Archiven

SpeedCommander 12.30

  • Farben für das Vororteditierungs-Feld können angepasst werden
  • Automatisches Ausblenden des Registerkartenbereichs für einzelne Registerkarten deaktivierbar (Einstellungsdialog "Verhalten - Registerkarten")
  • SpeedEdit: Syntaxhervorhebung für PowerShell-Scripte (.ps1)

SpeedCommander 12.20

  • Alle Module unterstützten ASLR (Address Space Layout Randomization) unter Windows Vista / Windows Server 2008
  • Seriennummer im Dialog "Hilfe - Info über SpeedCommander" lässt sich markieren und in die Zwischenablage kopieren
  • Überarbeiteter Fehlerdialog bei fehlerhafter Programmbeendigung (Anzeige von Einstellungsverzeichnis/Reportdatei und optionales Senden eines Fehlerreports)
  • Anzeige von Dateigrößen in der Listenansicht in KiB für alle Dateien
  • NC-Auswahlmodus: Auswahlbalken kann bei <Leer> automatisch auf das nächste Element gesetzt werden
  • NC-Auswahlmodus: Direktes Umbenennen durch erneuten Klick auf den fokussierten Eintrag, der Eintrag muss nicht gewählt sein
  • NC-Auswahlmodus: Direktes Umbenennen per Mausklick kann deaktiviert werden
  • NC-Auswahlmodus: Bei aktivierter Option "Markieren mit rechter Maustaste" können Einträge durch Ziehen der Maus markiert/demarkiert werden
  • NC-Auswahlmodus: Kontextmenü für den Ordner (Freiflächen-Kontextmenü) wird auch angezeigt, wenn bei der Aktivierung des Kontextmenüs per Tastatur zusätzlich <Strg> gedrückt wird
  • Bei Symbolansichten wird bei <CursorLinks>/<CursorRechts> auch dann das vorherige/nächste Element markiert, wenn sich der Auswahlbalken am Anfang/Ende einer Reihe befindet
  • Vista: Markierung mit dem Lasso bei Klick in den freien Bereich der ersten Spalte möglich
  • Umbenennen von selbstdefinierten Farbschemen
  • Beim direkten Umbenennen wird der Dateiname ohne Erweiterung markiert, mit dem Umbenennen-Tastenkürzel (normalerweise F9) kann die Auswahl innerhalb des Editierfeldes umgeschaltet werden
  • Während des direkten Umbenennens einer Datei kann mit <Tab> auf den nachfolgenden und mit <Umschalt+Tab> auf den vorherigen Eintrag umgeschaltet werden
  • Hintergrund- und Textfarbe des Editierfeldes beim direkten Umbenennen entsprechen denen der Listenansicht
  • Einträge in den Listen der letzten Eingaben können einzeln durch <Entf> gelöscht werden (wie in den Formularfeldern beim Internet Explorer)
  • Dokumentvorlagen aus dem "Kontextmenü -> Neu" können in das Menü oder in die Symbolleisten eingebaut werden (Kategorie "Extras", Befehl "[Dokumentvorlagen]")
  • Dokumentvorlagen können auch per Tastaturkürzel angezeigt werden (Kategorie "Extras", Befehl "Dokumentvorlagen anzeigen")
  • Schnellansicht für Programmdateien: Anzeige von PDB 7.0-Debuginformationen
  • Schnellansicht für Programmdateien: Anzeige von Zertifikatsinformationen
  • Schnellansicht für Programmdateien: Anzeige der referenzierten Assemblies für verwalteten Code
  • Schnellansicht für Programmdateien: Anzeige des LoadConfig-Verzeichnisses
  • Installationsprogramm prüft vor der Installation, ob die zu überschreibenden Programme noch geöffnet sind
  • Aktualisierung auf OpenSSL 0.9.8g und libpng 1.2.25
  • SpeedEdit: Beim Speichern eines unbenannten Dokuments wird das aktuelle Arbeitsverzeichnis von SpeedEdit als Speicherort vorgeschlagen

SpeedCommander 12.10

  • Optimierung der Geschwindigkeit bei der Anzeige von Ordnern (Baum- und Listenansicht)
  • Optimierungen beim Speicherverbrauch der Ordneransicht und deren Sortierung
  • Unterstützung von Dateinamen mit bis zu 32760 Zeichen (außer Archive)
  • Optimiertes Design für Office 2007 (Blau), neue Designs für Office 2007 (Schwarz, Silber)
  • Office 2003/2007-Gradientfarben auch für inaktives Fenster, Einstellung findet sich nun unter "Aussehen - Farben"
  • Vordergrundfarbe für jede zweite Zeile sowie Hintergrundfarbe für komprimierte und verschlüsselte Dateien
  • Einzelne Farbelemente können auf die aktuelle Windows-Farbeinstellung zurückgesetzt werden
  • Brotkrumenansicht wird im Hintergrund zusammengestellt
  • Brotkrumenansicht enthält nun auch FTP-Standorte und AddIn-Übersicht
  • FileSync: Zu lange Ordnernamen werden in der Mitte gekürzt anstatt wie bisher am Ende
  • FileSearch: Markierte Datei wird bei "Datei - Zur Datei springen" im Explorer angezeigt, wenn SpeedCommander nicht geöffnet ist
  • FileSearch: Automatische Aktualisierung der Laufwerksliste beim Hinzufuegen bzw. Entfernen von Datenträgern
  • FileSearch: Optimierungen bei der Anzeige des Kontextmenüs und der Übertragung von Dateien in die SC-Dateiablage
  • FTP: Keep-Alive für TCP-Verbindungen (Intervall von 60 Sekunden, anpassbar in SpeedCommander.xml unter <MxFtp\Advanced>)
  • FTP/AddIn: Temporär geänderte Dateien werden auf Nachfrage nicht mehr gelöscht, wenn die Übertragung der geänderten Dateien zum FTP-Server bzw. zum AddIn fehlschlägt
  • Vista: Aktualisiertes Papierkorbsymbol

SpeedCommander 12.01

  • Manuelle Berechnung der Ordnergrößen auf Wunsch nur für markierte Ordner
  • Bei GZIP-komprimierten WMF/EMF-Dateien (WMZ/EMZ - Office 2007) wird die Dateierweiterung der komprimierten Datei automatisch auf WMF/EMF gesetzt

SpeedCommander 12.0

  • Visuelles Design für Office 2007
  • Große Programmsymbole für Vista (256x256)
  • Brotkrumen-Navigation
  • Frei konfigurierbare Statuszeile
  • Direkte Anzeige von Ordnern über "Ordner - Wechseln zu - Gehe zu" (Strg+G)
  • Binärprefixe werden nach IEC 60027-2 angezeigt (KiB, MiB, GiB)
  • Alle Statusfenster verwenden die aktuelle Systemschriftart
  • Ausschließen von bestimmten Ordnern bei Dateifiltern
  • Automatische Sortierung der Einträge im Feldauswahl-Fenster
  • Neues Symbol für Ordnerfavoriten in der Titelzeile eines Ordnerfensters
  • Neue Spalte für Detailansicht: Anzahl der zusätzlichen Datenströme (ADS)
  • Anzeige und Löschen von Datenströmen (Datei - Mehr Eigenschaften)
  • Kennzeichnung von Verbindungspunkten und symbolischen Links in der Spalte "Dateityp" sowie "Größe" (nur NC-Modus)
  • Verwendung der neuen Vista-Dateidialoge zum Öffnen und Speichern von Dateien
  • Ausblenden von Dateien und Ordnern auch für FTP und AddIns
  • Doppelte Einträge im Verlaufsmenü werden nur noch einmal angezeigt
  • Favoritenbutton im Kopierdialog zeigt auch die Ordner des inaktiven Fensters an, doppelte Einträge werden entfernt
  • Profildialog im Komprimierungsassistenten zeigt den aktuellen Profilnamen in der Titelzeile
  • Hintergrundaktualisierung für Wechseldatenträger kann deaktiviert werden
  • Automatische Hintergrundaktualisierung kann für einzelne Ordnerfenster-Tabs deaktiviert werden
  • Anzeige der Sortierspaltenköpfe für alle Ansichtmodi (ab Windows Vista)
  • Auswahl von Einträgen über dynamisch eingeblendete Kontrollkästchen (ab Windows Vista)
  • Anzeige von lokalisierten Datei- und Ordnernamen
  • Ermittlung von InfoTips im Hintergrund (ab Windows XP)
  • Miniaturansicht in Vista: Dateisymbole werden in Thumbnail-Größe gezeigt, sofern sie als 256x256 Symbol vorliegen
  • Angleichen des aktiven Fensters an den Inhalt des inaktiven Fensters (Ansicht - Darstellung), Tastenkürzel Strg+Umschalt+E
  • Vororteditierung in den Listenansichten wird deaktiviert, wenn SpeedCommander nicht im Vordergrund läuft
  • Befehle unter "Extras - Anpassen" und "Hilfe - Tastaturbelegung" werden alphabetisch sortiert
  • Tastaturkürzel für die Umschaltung zwischen Ordnerfenster und Eingabezeile ist anpassbar (Kategorie "Ansicht")
  • Tastaturkürzel für rechte/linke Laufwerksauswahl ist anpassbar (Kategorie "Datenträger")
  • Tastaturkürzel für Aktivierung des Ministatus für Ordnerfenster (Kategorie "Ordner", Strg+Umschalt+L)
  • Tastaturkürzel für Umschaltung zwischen Ordner- und Dateioperationsfenster mit (Kategorie "Ansicht", Strg+Umschalt+O)
  • Spezielle Kennzeichnung von FTP-Adressen (SFTP/FTPS) für den direkten Aufruf aus der History
  • Anzeige der Ziffern für den Schnellzugriff auf den Ordner-Registerkarten
  • Sichern und Wiederherstellen aller Einstellungen aus SpeedCommander heraus (Extras - Spezial - Einstellungen sichern/wiederherstellen)
  • Fortschrittsdialoge für Dateioperationen im Hintergrund können als Registerkarten (intern oder extern) angezeigt werden
  • Pausierte Dateioperationen werden durch einen andersfarbigen Fortschrittsbalken gekennzeichnet (ab Windows Vista)
  • Warteschlange für Dateioperationen im Hintergrund
  • Kopier- und Löschaktionen können wiederholt werden, wenn eine Datei durch eine andere Anwendung gesperrt ist
  • Beim Löschen oder Verschieben von freigegebenen Ordnern wird auch die Freigabe entfernt
  • Aktualisierung der Ordner-/Laufwerkssymbole nach dem Hinzufügen oder Entfernen von Freigaben
  • Bestätigungsdialoge bei Dateioperationen zeigen ein Vorschaubild der Datei(en) an (sofern möglich)
  • Ersetzen-Dialog: Umbenennen von Quell-/Zieldatei (auch automatisch)
  • Ersetzen-Dialog: Überspringen aller identischen Dateien
  • Ersetzen-Dialog: Dateivorschau und Anzeige der jeweiligen Ordner
  • Schnellansicht: Anzeige von PNG-komprimierten Icons
  • Schnellansicht: Anzeige von GIF, PNG und JPG bei Ressourcen von Programmdateien
  • Schnellansicht: Formatierte Ausgabe von Manifestinformationen bei Ressourcen von Programmdateien
  • Mehrfaches Umbenennen: Alle Spalten der Dateilistenansicht können aktiviert werden
  • Mehrfaches Umbenennen: Daten der zusätzlichen Spalten können beim Umbenennen verwendet werden
  • Mehrfaches Umbenennen: Unterstützung von Profilen
  • Löschen von Dateien aus Archiven im Hintergrund
  • Testen von Archiven im Hintergrund
  • Automatische Font-Registrierung beim Entpacken von Archiven in den Font-Ordner
  • Kopieren von FTP-Standorten über "Bearbeiten - Kopieren/Einfügen"
  • FTP: Unterstützung von UTF8 bei FTP (optional) und bei SFTP (fest)
  • FTP: Verschieben für Uploads und Downloads möglich
  • FTP: Idle-Timer für jede Verbindung einstellbar
  • FileSearch: Befehle zum Anzeigen und Bearbeiten von Dateien
  • FileSearch: Anzeige des Archivordners, wenn Dateien innerhalb eines Archivs gefunden werden
  • FileSync: Synchronisation wird bis zum Ende durchgeführt und nicht mehr nach dem ersten Fehler abgebrochen
  • FileSync: Verwendung von Dateifiltern statt dem Einschließen/Ausschließen von Dateien über Masken
  • FileSync: Anzeige des aktuellen Profiles in der Titelzeile
  • FileSync: Nachfrage, wenn einer der beiden Vergleichsordner nicht existiert
  • FileSync: Kontextmenü für Ordnereinträge zur Auswahl/Abwahl von Dateien
  • SpeedEdit: Unterstützung von UTF8
  • SpeedEdit: Anzeige von Zeilennummern
  • SpeedEdit: Hervorhebung der aktuellen Zeile
  • SpeedEdit: Öffnen und Anzeige von Dateien im Lesemodus (vorher Lese-/Schreibmodus)
  • SpeedEdit: Kommandozeilenoption /p zum direkten Ausdrucken von Dateien
  • SpeedEdit: Kommandozeilenoption /end zum automatischen Scrollen an das Ende der Datei
  • SpeedEdit: Dokumentenkartei wird in mehreren Reihen angezeigt
  • SpeedEdit: Nachfrage für geänderte Dateien erfolgt erst, wenn SpeedEdit wieder aktiviert wird
  • SpeedEdit: Aktualisierung des Schreibschutz-Modus, wenn das Schreibgeschützt-Attribut einer Datei extern geändert wurde

SpeedCommander 11.60

  • Vista: Die Höhe der Spaltenanzeige in der Listenansicht kann angepasst werden (Erweitert - Spezielles)
  • Vista: Nachfrage der Benutzerkontensteuerung auch für einfache Benutzer
  • RAR: Aktualisierung der unrar.dll auf Version 3.68
  • FTP: Unterstützung von OS-9000

SpeedCommander 11.50

  • Unterstützung der Benutzerkontensteuerung von Windows Vista für alle Dateioperationen und Zugriffe auf die Registry (Ausnahme: Synchronisieren und Entpacken von ACE-Archiven)
  • Unterstützung der Spaltenerweiterungen von Windows Vista
  • Start von SpeedCommander nach Abschluss der Installation mit normalen Rechten, wenn das Installations-SFX ohne Adminrechte gestartet wurde
  • Anpassung der Manifeste aller ausführbaren Dateien an Windows Vista
  • Alle ausführbaren Programmdateien sind signiert
  • Dialog "Datei - Ausführen": Aufruf des Programms/Dokuments mit erhöhten Rechten, wenn der Dialog mit <Strg+Umschalt+Enter> geschlossen wird
  • Aufruf der Kommandozeile mit erhöhten Rechten, wenn zusätzlich zu <Enter> die rechte oder linke Windows-Taste gedrückt wird
  • Auf Wunsch blaues Office 2003-Design bei aktiviertem Media Center-Stil (Erweitert - Spezielles)

SpeedCommander 11.20

  • Neue Seite im Einstellungsdialog mit speziellen Einstellungen für erfahrene Anwender (Erweitert - Spezielles)
  • Option zum Mitzählen des Elternordners in der Statuszeile (Erweitert - Spezielles)
  • Option zum Kopieren der Erstellzeit von Dateien (Erweitert - Spezielles)
  • Option zum Erstellen von Archiven in das Quellverzeichnis (Erweitert - Spezielles)
  • Option zum Entpacken von Archiven in das Quellverzeichnis (Erweitert - Spezielles)
  • Option zum Übernehmen der Erstellungszeit von Dateien beim Kopieren (Erweitert - Spezielles)
  • Screenreader-kompatibler Dialog zur Feldauswahl in Listenansichten (Aussehen - Darstellung)
  • Im Dialog "Funktion unter anderer Benutzerkennung ausführen" werden die auf dem System vorhandenen Administratoraccounts aufgelistet
  • Beim Drücken eines Tastenkürzels im QuickSearch-Dialog wird der QuickSearch-Dialog geschlossen und der Tastenkürzelbefehl ausgeführt
  • Automatisches Erstellen einer Kopie der XML-Einstellungen nach erfolgreichem Laden
  • Doppelklick-Verhalten bei Registerkarten kann angepasst werden (Verhalten - Registerkarten)
  • FileSync: Zeitdifferenzen von einer Stunde ignorieren (Profileinstellung)
  • fsc: Zeitdifferenzen von einer Stunde ignorieren (/IH)
  • RAR: Anzeige von Authentizitätsinformationen
  • SpeedEdit & SpeedView: Tooltips für Registerkarten (Anzeiger der vollständige Dateinamen)
  • Ausführen von FTP-Operationen über die Zwischenablage auf Wunsch im Hintergrund

SpeedCommander 11.10

  • Spezielle Version für U3-Sticks
  • Originalgetreuere Farben im Office 2003-Design (Deaktivierte Symbole, Hintergrund von freischwebenden Symbolleisten)
  • Anpassung des Visual Studio 2005-Designs an die endgültige Version von Visual Studio 2005
  • Einbindung von Sprachdateien möglich
  • Automatisches Entfernen von ungültigen Zeichen beim Einfügen aus der Zwischenablage in Vororteditierfelder
  • Bei aktivierter Einstellung "Ordner mit führendem Backslash kennzeichnen" wird der Backslash bei Vororteditierung herausgefiltert
  • Bei aktivierter Einstellung "Ordner in Groß- und Dateien in Kleinbuchstaben anzeigen" wird bei der Vororteditierung der unverfälschte Dateiname angezeigt
  • Kontextmenü für Archivdateien in der Baumansicht
  • Bei der Konfiguration der Anwendungsfavoriten werden die Datei/Ordner-Öffnen-Dialoge mit dem jeweiligen Dateinamen/Ordner initialisiert
  • "In einzelne Unterordner entpacken" auch beim Entpacken von einem einzelnen Archiv möglich
  • Option zur Unterdrückung der Meldung bei Datenstromverlust beim Kopieren auf nicht-NTFS-Laufwerke
  • Aktualisierung der 7z-Bibliothek auf 4.32
  • Anzeige von Dateien größer als 2GB in der Dump-Ansicht
  • Mehrfaches Umbenennen für Zweigansicht und Dateiablage
  • Unterstützung von Umgebungsvariablen bei Anwendungs- und Ordnerfavoriten, Registerkarten, Ordnergrößen und Befehlseingabezeile
  • Umgebungsvariable %SCDIR% für das SpeedCommander-Programmverzeichnis, während SpeedCommander läuft
  • Ungültige Zeichen in Dateinamen werden beim Entpacken von Archiven automatisch durch Unterstriche ersetzt

SpeedCommander 11.00

  • Native 64-Bit-Version für Windows XP x64
  • Speicherung der Einstellungen als XML
  • Optimierung der Anzeige von Symbolen/Texten/Miniaturansichten in der Listenansicht
  • Unterstützung von Explorer-Erweiterungenen für Spalten
  • Übersichtlicherer und erweiterter Konfigurationsdialog
  • Definition von eigenen Farbschemen
  • Anzeigefilter können Schriftstil und Hintergrundfarbe enthalten
  • Erweiterte Unterstützung für Ordner in Datei- und Anzeigefilter
  • Zweigansicht zur Auflistung aller untergeordneter Dateien in einem Ordnerfenster
  • Stufenweises Ausblenden von versteckten Dateien
  • Deaktivierbare Bestätigungsmeldungen beim Kopieren, Verschieben und Löschen von Dateien
  • Fortschrittsanzeige bei der Ordnergrößenberechnung
  • Differenzierte Ausnahmen bei der Ordnergrößenberechnung
  • Definierbare Maximalgrenze bei der Ordnergrößenberechnung
  • Neue Option: Bei Laufwerkswechsel immer in das Hauptverzeichnis wechseln
  • InfoTips können für bestimmte Laufwerksgruppen (z.B. Netzwerklaufwerke) abgeschaltet werden
  • Neue FTP-Engine mit Unterstützung für SFTP und FTP/SSL
  • Erweiterte FTP-Einstellungen mit Bandbreitenbegrenzung für Up- und Downloads
  • Unterstützung von MODE Z
  • Proxyserver-Unterstützung für Socks 4/4A/5 und HTTP Connect
  • FTP-Verzeichnisdaten können im Statusfenster ausgeblendet werden
  • Automatisierung über Makros
  • Erweiterungsmöglichkeiten durch AddIns
  • AddIn zur Einbindung von Total Commander Dateisystem-Plugins
  • AddIn für den Zugriff auf PDAs über Active Sync
  • Kommandozeilenparameter "/xml:<Einstellungen.xml>" für die Verwendung einer alternativen Konfigurationsdatei
  • Kommandozeilenparameter "/caption:<Fenstertitel>" für die Angabe eines eigenen Fenstertitels
  • Kommandozeilenparameter "/layout:<Layoutname>" zum Laden eines speziellen Layouts beim Start

SpeedCommander 10.50

  • Vollständige Unterstützung von SQX2
  • Unterstützung für NTFS-Streams (ZIP und SQX)
  • Archivieren von NTFS-Sicherheitsattributen (ZIP und SQX)
  • Speichern von hochauflösenden Zeitstempeln (ZIP und SQX)
  • Automatisches Archivieren von Dateikommentaren (ZIP und SQX)
  • Archivieren von Unicode-Dateinamen (SQX)
  • Setzen von Ordnerzeitstempeln beim Entpacken (ZIP, SQX und 7z)
  • Eigene Icons für SFXe und Anpassung der Versionsinformation (ZIP und SQX)
  • Übertragung der ZoneID des Archivs auf alle entpackten Dateien unter XP SP2
  • ZIP: Vollständige Unterstützung für AES 128/256
  • TAR: Longlink-Unterstützung
  • GZIP: Unterstützung für Archive > 4GB
  • Verbesserte GNU-TAR-Unterstützung
  • CAB: Erkennung von selbstentpackenden CAB-Archiven bis zu 280kb Stubgröße
  • BZ2: Beim Erstellen von Archiven wird nun explizit die Dateiendung vor die BZ2-Erweiterung gesetzt
  • RAR: Anzeige von Archivkommentaren
  • Neue Entpackmodis (Alle, Nur neuere, Auffrischen)
  • Archivattribute können beim Entpacken gelöscht werden
  • "Auf Fenstergröße einpassen" nur noch bei Bilder, die größer sind als das aktuelle Fenster
  • WMF-Grafiken werden im richtigen Seitenverhältnis angezeigt
  • Dialog "Server ist ausgelastet" beim Drag & Drop wird nicht mehr angezeigt
  • Kopieren in ein Archiv erfolgte nun multithreaded
  • FileSync: Nach einer Synchronisation wird automatisch ein neuer Vergleich gestartet
  • FileSync: Synchronisierung von verschlüsselten nach unverschlüsselten NTFS-Verzeichnissen
  • FileSync: Wenn nicht nach Dateizeit verglichen wird, dann müssen gefundene Dateien manuell zum Abgleich ausgewählt werden
  • fsc: Kommandozeilenoptionen CT, CS und CC deaktiviert, Vergleich erfolgt nun immer nach Dateizeit

SpeedCommander 10.30

  • Erweiterte Komprimierungseinstellungen für 7z
  • Mehrere Dateien können einzeln archiviert werden
  • Unterstützung für Multimediatasten "Vorwärts", "Zurück", "Aktualisieren", "Kopieren", "Ausschneiden" und "Einfügen"
  • Definition von zusätzlichen Archivdateitypen (TweakSC)
  • Neues visuelles Design: Whidbey
  • Kopieren von EFS-verschlüsselten Dateien auf Nicht-NTFS-Datenträger
  • Ordnertabs mit einem Basisordner, der auf einen nicht mehr vorhandenen Netzordner zeigt, konnten nicht gelöscht werden
  • Auf langsamen Laufwerken (z.B. VPN) wird aus Performancegründen kein InfoTip mehr angezeigt

SpeedCommander 10.20

  • Erkennung von 7z-SFXen
  • Registrierungsdaten können in INI-Datei abgelegt werden
  • Unterstützung für LZW-komprimierte TIF/GIF-Dateien
  • Einstellungen zur Speicherung der Verlaufslisten im SC gelten nun auch für alle anderen Programme (Editor, Viewer, FileSearch, FileSync)
  • Beim Öffnen von SFXen innerhalb von Archiven erfolgt eine Nachfrage, ob das SFX angezeigt oder gestartet werden soll
  • Laufwerksauswahl bei Kombinationsfeld: Wechsel in das Hauptverzeichnis, wenn bei der Laufwerksauswahl "Umschalt" gedrückt wird
  • Neuer Menübefehl: Ordner | Wechseln zu | Untergeordneter Ordner

SpeedCommander 10.10

  • Unterstützung von 7-zip (Anzeige, Entpacken, Komprimieren)
  • Anzeige von administrativen und versteckten Freigaben (TweakSC)
  • Anzeige von Netzwerkdruckern (TweakSC)
  • Unterstützung von Umlaut-Domains im FTP-Client
  • "Fokusänderung bei Laufwerkswechsel" gilt nun auch für die Navigationssymbole über dem Ordnerfenster
  • Bei der Archiverstellung kann ein Archivkommentar vergeben werden
  • Archiverkennung beim Öffnen von Archiven optimiert
  • Prozess-Umgebungsvariablen werden bei Änderung aktualisiert
  • Verlaufsmenü kann per Tastatur aufgerufen werden (Strg+H / Strg+Umschalt+H) - (Tastatureinstellungen, Kategorie "Sonstige")
  • Symboleditor importiert mehr Bitmapformate sowie Icons und Cursor
  • Betrachter für Schriftarten (Schnellansicht)
  • Funktion "Ordner | Vergleichen" erweitert
  • Symbolleisten können fixiert werden (Anpassen-Dialog)
  • Verzögerter Verlauf und Speichern des Verlaufs beim Beenden (Einstellungsdialog "Grundeinstellungen")
  • Größe der Miniaturansicht und Abstand zwischen Symbolen einstellbar (TweakSC)
  • Neue Einstellung: Ordner immer nach Namen sortieren (Einstellungsdialog "Datei- und Laufwerksansicht")
  • Menüs für Ordner- und Anwendungsfavoriten können Trennzeichen (Separatoren) enthalten
  • Anzahl der eigenen QuickDrop-Symbole von 18 auf 40 erhöht
  • Kopieren/Verschieben über die Zwischenablage erfolgt nun auch im Hintergrund
  • Mögliches Löschen der Verlaufslisten vor dem Exportieren der Einstellungen
  • Menüeintrag für "Mindestanzahl Stellen" im "Mehrfach Umbenennen"-Dialog
  • FileSearch: Dateinamen können als Text in die Zwischenablage kopiert werden
  • Beim direkten Umbenennen (Vororteditierung) wird nun auch beim Einfügen aus der Zwischenablage der Text auf ungültige Zeichen überprüft
  • Archivfunktionen im Menü "Extras" werden nur noch aktiviert, wenn die jeweiligen Dateien/Archive die entsprechende Funktion unterstützen
  • Dynamic Drop für Laufwerksleiste
  • Automatische Größenanpassung für Internet wird auch beim Ordnerfenster-Wechseln beachtet
  • Interne Archivbehandlung kann nun deaktiviert werden (Einstellungsdialog "Datei- und Laufwerksansicht")
  • Zur Anzeige von Archiven innerhalb von Archiven wird automatisch eine neue Registerkarte erstellt

SpeedCommander 10.00

  • Visuelle Designs für Office 2003, Office XP, Office 2000 und Windows XP
  • Miniaturansicht
  • Navigationssymbole in der Titelzeile des Ordnerfensters
  • Unterstützung von Overlay-Handlern für Dateisymbole
  • Spalten in der Detailansicht für Bilder/MP3/DRM (nur XP) und für Versionsinformationen
  • Schnellere Anzeige durch Ermittlung von Dateiinformationen im Hintergrund
  • Zeitstempel von Ordnern können beim Kopieren übernommen werden
  • Pausieren von Dateioperationen und Einstellen der Priorität
  • Zugriffe auf nicht existierende Netzwerkordner können mit 'Escape' abgebrochen werden
  • Scrollen im Textbetrachter mit <Leertaste>
  • Betrachter für ausführbare Programmdateien (exe;dll;obj;lib;dbg;sys;cpl;drv;ocx;ax;bpl;exp)
  • Betrachter für Delphi-Formulare (dfm)
  • Erweiterter Betrachter für Multimedia (cda;aif;aifc;aiff;asf;asx;wax;wm;wma;wmd;wmp;wmv;wmx;wpl;wvx;avi;wav; mpeg;mpg;m1v;mp2;mpa;mpe;mp2v;mpv2;mid;midi;rmi;au;snd0;mp3;vob;swf; mov;qt;rm;ram)
  • Ordnerfenster-Eigenschaften: Bei Aktivierung in Basisordner wechseln
  • Ordnerfensternamen können automatisch entsprechend des aktuellen Ordners umbenannt werden
  • Ordnerwechsel in gesperrten Ordnerfenstern können auf das erste freie Ordnerfenster umgelegt werden
  • Ordnergrößenanzeige für DVD-RAM, DVD+R/+RW und DVD-R/-RW
  • Registerkarten können oben angeordnet werden
  • QuickDrop-Symbole können auch mit kleinen Symbolen angezeigt werden
  • Anzeige der Ordnerhierarchie
  • Suchprofile für FileSearch
  • Unterstützung von Char-Sets in FileSearch und FileSync
  • FileSync zum Sychronisieren von Ordnern
  • FileSync Kommandozeile: Neuer Schalter -xd (Ordner ausschließen)
  • FileSync Kommandozeile: Neuer Schalter -dd (Leere Ordner löschen)
  • Archivoperationen im Hintergrund mit Pausieren und einstellbarer Priorität
  • LHA-, CAB-, TAR- und GZIP-Archive können auf Integrität überprüft werden
  • Unterstützung von TAR- und BZIP-Archiven, die größer als 4GB sind
  • ZIP 6.0-Archivformat
  • Entpacken von nativen ARJ-Multivolumearchiven
  • Verwendung von Kompressionsprofilen
  • Erstellen von nativen Multivolume-Archiven (SQX und ZIP)
  • Reparaturdaten können extern (ausserhalb des Archivs) erstellt werden
  • SQX-SFX-Dateien zeigen nun eine digitale Signatur an, wenn vorhanden
  • Normale SFX-Dateien können jetzt Systemvariablen benutzen
  • Normale SFX-Dateien und Installations-SFX-Dateien können jetzt Parameter an aufzurufende Programme übergeben
  • Sprachdateien für selbstentpackende Archive können mit einem normalen Texteditor angepasst bzw. übersetzt werden
  • Verbesserte Kompression und schnellere Dekompression im SQX-Format
  • Geringerer Speicherverbrauch für alle Archiver
  • Dateien mehrfach umbenennen: Neuer Platzhalter [mi]
  • Dateien mehrfach umbenennen: Es können mehrere Zeichenketten zum Suchen und Ersetzen auf einmal angegeben werden
  • Kommandozeilenoption "/reg:<Einstellungen.reg> für unterwegs
  • Kommandozeilenoption "/L:<Ordner>" und "/R:<Ordner>"
  • Reihenfolge der eigenen QuickDrop-Symbole ist änderbar

SpeedCommander 9.30

  • Anzeige einer Fehlermeldung, wenn beim Kopieren die Länge von Verzeichnisnamen 260 Zeichen überschreitet
  • Unterstützung für LZW-komprimierte TIF/GIF-Dateien
  • FileSync Kommandozeile: Neue Option -dd (Ordner, die im Zielordner aber nicht im Quellordner vorhanden sind, werden gelöscht)
  • SQX-Installations-SFX kann zusätzliche Parameter aufnehmen (setup.exe [-ss -ab -t])
  • Anpassung an das aktuelle Mozilla-ActiveX-Control

SpeedCommander 9.20

  • Unicode-Version für Windows NT/2000/XP/2003
  • Ordner und Dateinamen mit Zahlen werden anhand ihres numerischen Wertes einsortiert
  • Ordnertabs sind abschließbar und können einen festen Startordner besitzen
  • Neue Eigenschaft fuer Ordnertabs: Bei Aktivierung immer aktualisieren
  • Direkter Befehl für das Löschen des Papierkorbs
  • Neue Spalten für Besitzer, Titel, Thema, Autor und Kommentar
  • Freie Zuordnung von Tastenkürzel für die Sortierbefehle
  • Layout-Menü via 'Strg+Alt+W'
  • Layout speichern: Alle definierten Layouts werden in einem Kombinationsfeld angezeigt
  • Umbenennen von Ordnern in der Baumansicht
  • Beim Umbenennen werden ungültige Zeichen gefiltert
  • Bei der Schnellansicht von verschlüsselten Dateien wird das Kennwort wiederverwendet, wenn die Dateien mit dem gleichen Kennwort verschlüsselt sind
  • Deaktivierung der Ordnergrößenberechnung für bestimmte Ordner (TweakSC)
  • Aus defekten Zip-Archiven können beschädigte und unbeschädigte Dateien entpackt werden
  • SQX-Format: Leicht verbesserte Kompression bei allen Dateitypen und zum Teil deutlich verbesserte Kompression bei verschiedenen Typen von ausführbaren Dateien
  • SQX-Format: Schnellere Dekompression bei verschiedenen Dateitypen
  • SQX-Format: Deutlich verringerter Speicherverbrauch im Kompressor
  • Hinweis per InfoTip, wenn aus einem gesperrten Tab gewechselt werden soll
  • Hinweis per InfoTip, wenn bei der Vororteditierung eines Dateinamens ein ungültiges Zeichen eingegeben wird
  • Nach Schließen des 'Mehrfach Umbenennen'-Dialogs wird die Dateiliste neu eingelesen
  • FTP-Kennwörter werden für Ansi/Unicode-Version transparent gespeichert

SpeedCommander 9.10

  • TweakSC für weitere Einstellungen
  • Bugfixes und kleine Optimierungen

SpeedCommander 9.00

  • Vollständige Unterstützung von Windows XP
  • Darstellung von mehreren Ordnern in einem Ordnerfenster via Registerkarten
  • Einbindung der Dateiablage in das Zwei-Fenster-Layout
  • Erweiterung der QuickDrop-Symbole
  • Auswahl aller Dateien des gleichen Dateityps wie die aktuell gewählte Datei
  • Verbesserung des NC-Auswahlmodus
  • Umfangreiche Farbanpassungsmöglichkeiten
  • Ein- und Ausblenden von Spalten in der Detailansicht per Feldauswahl
  • Anzeige von Dateien in Gruppen
  • Unterstützung der Kachel-Ansicht
  • Synchronisieren von Ordnerfenstern
  • Integriertes Befehlsausgabefenster
  • Unterstützung von mehreren Layouts
  • Strg+E zum Angleichen der Fenster
  • Zugriff auf die Ordnerfavoriten durch Doppelklick auf die Titelzeile des Ordnerfensters
  • Zugriff auf die Anwendungsfavoriten durch Doppelklick bei gedrückter Umschalt-Taste auf die Titelzeile des Ordnerfensters
  • Ordner- und Anwendungsfavoriten können hierarchisch angeordnet werden
  • Ordnerfavoriten: Gleichzeitiges Wechseln von aktivem und inaktivem Fenster
  • Farbliche Kennzeichnung von Dateien
  • Mehrfaches Umbenennen von Dateien und Ordnern
  • Verwalten von Dateiverknüpfungen
  • Automatische Installation von Schriftarten beim Kopieren von Font-Dateien in den Systemordner "Schriftarten"
  • Modernes und leistungsfähiges SQX-Format
  • Erstellung von signierten Archiven
  • Vollständige Unterstützung von ZIP64 und Deflate64
  • Unterstützung für BZIP
  • Entpacken von RAR3- und ACE2-Archiven
  • Neue Volumegrößen (2 MiB - 700 MiB & frei einstellbar)
  • Anzeige von Archiven in der Baumansicht
  • Sichere Verschlüsselung von Archiven mit dem SQX-Format und AES
  • Komfortable Verwaltung der FTP-Standorte
  • FTP-Schnellverbindung
  • Angabe zusätzlicher Initialisierungsbefehle bei FTP-Servern
  • Anpassung der Zeitzone für den FTP-Server
  • Einbindung des Mozilla-Browsers
  • Unterstützung von Unicode-Dateien in der Schnellansicht
  • Einfache Konfiguration der Schnellansicht für die verschiedenen Formate
  • FileSearch: Weitere Verbesserung der Suchgeschwindigkeit
  • FileSearch: Suche nach doppelten Dateien
  • Kommandozeilen-Tool für die Synchronisierung von Ordnern
  • Synchronisierung mit Script-Dateien

SpeedCommander 8.10

  • Schnellansicht automatisch vergrößern
  • Bei aktiviertem "Markieren mit rechter Maustaste" wird das Kontextmenu der Datei(en) angezeigt, wenn zusätzlich "Strg" gedrückt wird
  • Fenster angleichen mit Strg+E, aktives Fenster ist Basis
  • Ausblenden, wenn minimiert
  • Kopieren des aktuellen vollständigen Dateinamens in die Zwischenablage über Alt-Einfg
  • Kopieren des aktuellen relativen Dateinamens in die Zwischenablage über Umschalt+Alt-Einfg
  • Kopieren des aktuellen Ordnernamens in die Zwischenablage über Strg+Alt-Einfg
  • Dokumentenkartei in SpeedEdit und SpeedView

SpeedCommander 8.00

  • NC-Auswahlmodus mit eigener Farbanpassung
  • Ausblenden der Dateisymbole
  • Strg+U zum Tauschen der Fenster
  • Office XP-Menüs
  • Dateifenster können untereinander angeordnet werden
  • Erweiterung der QuickDrop-Symbole
  • Zugriff auf die wichtigsten Systemordner
  • Favoritenleiste mit Internetfavoriten, Ordnerfavoriten und Anwendungsfavoriten
  • Dateiablage mit mehreren voneinander unabhängigen Ablagen
  • Anzeige der Kommentare in der Netzwerkumgebung
  • AutoComplete und AutoSuggest in vielen Eingabefeldern
  • Bis zu 50 frei definierbare Dateifilter
  • Einschließen und Ausschließen per Maske (*.doc;*.xls;123*.*)
  • Erweiterte Auswahl beim Datum
  • Erweiterte Funktionen zum Kopieren, Verschieben und Löschen von Dateien
  • Sicheres Löschen nach Regierungsrichtlinien
  • Automatisches Umbenennen beim Kopieren in das gleiche Verzeichnis über die Zwischenablage
  • Verwenden von Reparaturdaten
  • Datei- und Archivkommentare
  • Testen von Archiven
  • Umwandeln eines Archivs in ein SFX
  • SFX mit Listenansicht
  • Neue Volumegrößen (2 MiB - 700 MiB)
  • Ändern von Dateiattributen bei FTP
  • Idle-Timer bei FTP
  • FTP-Schnellverbindung durch Eingabe der FTP-Adresse (ftp://ftp.microsoft.com) in der Befehlseingabezeile
  • SpeedView: Viele neue Dateibetrachter für Grafikformate
  • SpeedView: Anzeige von Word-, Excel-, Works-, WordPerfect- und Lotus 123-Dokumenten bei installiertem Microsoft Office 97/2000
  • SpeedView: Anzeige von Write- und RTF-Dateien
  • SpeedView: Umschalten des Betrachters für ein gerade angezeigtes Dokument
  • SpeedEdit: Integriertes Syntaxhighlighting für: ASP, Basic, Batch, C/C++, DCL (AutoCAD), Fortran, HTML, InstallShield, Java, LISP (AutoCAD), Pascal, Perl, PHP, Python, Ressourcen, REXX, SGML, Shell Script, SIOD, SQL, TCL, TeX
  • SpeedEdit: Definition von AutoText-Einträgen
  • SpeedEdit: Lesezeichen
  • SpeedEdit: Umwandlung eines Textes in Groß- oder Kleinbuchstaben
  • SpeedEdit: Vertauschen von Groß-/Kleinbuchstaben
  • SpeedEdit: Inkrementelle Suche
  • SpeedEdit: Schreibschutzmodus
  • FileSearch: Durchsuchen von Ordnern oder mehreren Laufwerken
  • FileSearch: Suche nach Dateiinhalten (Text, Hexadezimal, Binär)
  • FileSearch: Verwendung von Suchoperatoren (UND, ODER, NICHT)
  • FileSearch: Suchen von Unicode-Text
  • FileSearch: Anzeige der gefundenen Treffer
  • FileSearch: Suchen in Archiven, in verschlüsselten Archiven und in selbstentpackenden Archiven (ACE, ARJ, CAB, GZIP, JAR, LZH, RAR, TAR, UUE, ZIP und SCB)
  • FileSearch: Übernahme der gefundenen Dateien in ein Ordnerfenster oder in die Dateiablage des SpeedCommander


Funktionsüberblick

SpeedCommander
Funktionsüberblick

Diese Seite gibt einen Überblick über die wesentlichen Funktionen von SpeedCommander.

Aufbau

  • Moderne und vielseitig anpassungsfähige Benutzeroberfläche
  • Vollständige Unterstützung von Windows 7/8/Vista/XP
  • Visuelle Designs für Office XP/2000/2003/2007/2010/2013, Visual Studio 2005/2008/2010/2012 und Windows XP
  • Symbole für Menüs und Symbolleisten im Stil von Office 2003, Office 2007/2010 und Office 2013
  • Scharfe Darstellung auf Systemen mit hoher DPI-Auflösung
  • Zwei Ordnerfenster, die nebeneinander oder untereinander angeordnet werden können
  • Darstellung von mehreren Ordnern in einem Ordnerfenster via Registerkarten
  • Direkter Zugriff auf Desktop, Computer und virtuelle Ordner
  • Einblendung einer Baumansicht für jedes Ordnerfenster
  • Laufwerksfenster (Laufwerksauswahl als Kombinationsfeld, Leiste, Gemeinsame Leiste)
  • Integrierte Schnellansicht
  • Befehlseingabezeile
  • Befehlsausgabefenster
  • QuickDrop-Symbole als Ziel für Dateioperationen
  • Unterstützung von zweistufigen Tastenkürzeln
  • Portabler Einsatz auf einem USB-Stick
  • Komfortables Sichern und Wiederherstellen der Einstellungen
  • Erweiterung durch Add-Ins
  • Verwendung von Makros
  • Einstellungsassistent beim Start

Ansicht

  • Ansicht von Dateien mit großen Symbolen, kleinen Symbolen, Details, Kacheln und Miniaturbildern
  • NC-Auswahlmodus mit eigener Farbanpassung
  • Ausblenden der Dateisymbole möglich
  • Zugriff auf die wichtigsten Systemordner
  • Laufwerksstatus und Ordnerinformation
  • Synchronisieren von Ordnerfenstern
  • Unterstützung von mehreren Layouts
  • Zugriff auf das Start- und Favoriten-Menü sowie die Elemente des Desktops
  • Definition von bis zu 50 Dateifiltern zur Anzeige und für Dateioperationen
  • Ordnerfavoriten zum schnellen Wechsel in einen Ordner, in ein Archiv oder in ein FTP-Verzeichnis
  • Einbindung zusätzlicher Programme als Anwendungsfavoriten
  • AutoComplete und AutoSuggest bei vielen Eingabefeldern
  • Unterstützung von Overlay-Handlern für Dateisymbole
  • Optionales Ausblenden von bestimmten Dateien und Ordnern im Ordnerfenster
  • Ordneransichten zur automatischen Anpassung der Anzeige für bestimmte Ordner (Bilder, Musik)

Dateimanagement

  • Anzeige und Sortierung von Dateien nach Name, Größe, Typ, Dateizeit und Attributen
  • Anzeige von Dateien in Gruppen
  • Ein- und Ausblenden von Spalten in der Detailansicht per Feldauswahl
  • Navigationssymbole in der Titelzeile des Ordnerfensters
  • Farbliche Kennzeichnung von Dateien
  • Kopieren von Dateien und Ordnern
  • Verschieben von Dateien und Ordnern
  • Löschen von Dateien und Ordnern
    • Normales Löschen
    • Löschen in den Papierkorb
    • Sicheres Löschen nach Regierungsrichtlinien
  • Erkennung von Hardlinks beim Kopieren
  • Erstellung von Abzweigungen, Hardlinks und symbolischen Links
  • Unterstützung der Benutzerkontensteuerung bei Dateioperationen in UAC-geschützten Ordnern
  • Anzeige des Explorer-Kontextmenüs und Erweiterung mit eigenen Befehlen
  • Pausieren von Dateioperationen und Einstellen der Priorität
  • Trennen von Dateien
  • Anzeige der Dateieigenschaften
  • Ermittlung von Ordnergrößen
  • Vergleichen von Ordnern
  • Ändern von Dateizeit und Dateiattributen
  • Drucken von Ordnerlisten
  • Zugriff auf die Netzwerkumgebung
  • Mehrfaches Umbenennen von Dateien und Ordnern
  • Verwalten von Dateiverknüpfungen
  • Automatische Installation von Schriftarten beim Kopieren von Font-Dateien in den Systemordner "Schriftarten"
  • Anzeige der Ordnerhierarchie
  • Dateiablagen für häufig oder regelmäßig genutzte Dateien
  • Anzeigen und Entpacken von ISO-Dateien (nur Pro-Version)

Brennfunktionen

  • Virtuelles Laufwerkssymbol für die Zusammenstellung von Brennprojekten für CD/DVD/Blu-Ray (nur Pro-Version)
  • Anzeige von detaillierten Informationen zu optischen Lese-/Schreibgeräten (nur Pro-Version)
  • Anzeige von Medieninformationen optischer Lese-/Schreibgeräte (nur Pro-Version)
  • Brennen von Datenträgerabbilddateien (nur Pro-Version)
  • Erstellen von Datenträgerabbilddateien (nur Pro-Version)
  • Löschen von wiederbeschreibbaren optischen Medien (nur Pro-Version)

Anzeige von Dateien

  • Externer Dateibetrachter (SpeedView) und integrierte Schnellansicht
  • Anzeige von Textdateien
  • Anzeige von vielen Grafikdateien
  • Anzeige der gebräuchlichsten Archivformate
  • Anzeige von Multimedia-Dateien über den integrierten Windows Media Player
  • Anzeige von Programmdateien (Allgemeine Informationen, Importierte/Exportierte Funktionen, Zertifikate, Ressourcen)
  • Anzeige von Delphi-Formulare in der Entwurfsansicht
  • Anzeige von Schriftdateien
  • Anzeige von PDF-Dateien
  • Anzeige von Metadateien
  • Syntaxhervorhebung für bekannte Textformate
  • Einbindung von Modulen für die Windows-Vorschau

Bearbeiten von Dateien

  • Komfortabler Editor zur Bearbeitung von Textdateien (SpeedEdit)
  • Integriertes Syntaxhighlighting für viele Formate
  • Definition von AutoText-Einträgen
  • Verwendung von Lesezeichen
  • Umwandlung eines Textes in Groß- oder Kleinbuchstaben
  • Vertauschen von Groß-/Kleinbuchstaben
  • Inkrementelle Suche
  • Schreibschutzmodus
  • Druckvorschau

Suchen von Dateien

  • Schnelles und komfortables Suchprogramm (FileSearch)
  • Durchsuchen von Ordnern oder mehreren Laufwerken
  • Suche nach Dateiinhalten (Text, Hexadezimal, Binär)
  • Suche nach doppelten Dateien
  • Verwendung von Suchoperatoren (UND, ODER, NICHT)
  • Suchen von Unicode-Text
  • Anzeige der gefundenen Treffer
  • Suchen in Archiven und in selbstentpackenden Archive
  • Übernahme der gefundenen Dateien in ein Ordnerfenster oder in die Dateiablage von SpeedCommander

Synchronisieren von Dateien und Ordnern

  • Komfortable Oberfläche und Kommandozeilen-Tool für die Synchronisierung von Dateien und Ordnern (FileSync)
  • Abgleich von Dateien und Ordnern nach Zeitstempel, Größe oder Inhalt
  • Verwendung von Filtern zum Ein-/Auschließen von Dateien und Ordnern
  • Farbliche Kennzeichnung der zu kopierenden Dateien
  • Kennzeichnung der neueren Dateien wahlweise in Fett/Kursiv
  • Löschen von verwaisten Dateien und Ordnern
  • Übertragung der Sicherheitsbeschreibungen
  • Erstellung eines ausführlichen Protokolls
  • Vergleichen von zwei Dateien über ein externes Vergleichsprogramm
  • Kommandozeilenprogramm für Synchronisierung mit Skriptdateien

Komprimierte Dateien

  • Direkte Unterstützung der Archivformate 7Z, ACE, ARJ, BZIP, CAB, GZIP, JAR, LZH, RAR, SQX, TAR, UUE, ZIP, ZIPX
  • Vollständige Unterstützung von ZIP64 (Keine Einschränkung hinsichtlich der Archivgröße und der Anzahl der Dateien bei ZIP)
  • Unterstützung von Deflate64 beim Packen und Entpacken (ZIP)
  • Unterstützung von LZMA und WavPack beim Entpacken (ZIP)
  • Entpacken von RAR5-Archiven
  • Archivoperationen im Hintergrund mit Pausieren und einstellbarer Priorität
  • Reparaturdaten für SQX-Archive (intern und extern)
  • Archive auf Integrität prüfen
  • Unterstützung von Archiv- und Dateikommentaren
  • Erstellen von Ordnern in Archiven
  • Verschlüsselung von Archivdaten und/oder Archivverzeichnis mit AES
  • Erstellen von signierten Archiven
  • Erstellen von nativen Multivolume-Archiven (SQX, ZIP)
  • Erstellung von selbstentpackenden Archiven (Einfaches SFX, SFX für Softwareinstallationen, SFX mit Listenansicht)
  • Kommandozeilenprogramm für Archivoperationen

Internet

  • Integration des Internet Explorers
  • Automatische Vergrößerung des Ordnerfensters bei Aktivierung des Browsers
  • Eigene Start- und Suchseite

FTP

  • Transparenter Zugriff auf FTP/SFTP-Server
  • Unterstützung von verschlüsselten SSL-Verbindungen
  • Komfortable Verwaltung der FTP-Standorte
  • Angabe zusätzlicher Initialisierungsbefehle
  • Anpassung der Zeitzone für den FTP-Server
  • Download/Upload von Dateien als ASCII, Binary oder EBCDIC
  • Automatische Konvertierung der Dateinamen nach Kleinbuchstaben
  • Setzen von Berechtigungen beim Upload
  • Übertragung von Zeitstempeln auf den FTP-Server beim Upload
  • Löschen von Dateien
  • Setzen von Dateiattributen
  • Unterstützung für Firewalls und Proxyserver
  • Automatisches Aufrechterhalten der Verbindung bei Untätigkeit
  • FTP-Kommandozeile

Datenträger

  • Formatieren von Datenträgern
  • Kopieren von Disketten
  • Umbenennen von Datenträgern
  • Verbinden und Trennen von Netzlaufwerken


Schnelleinstieg

SpeedCommander
Schnelleinstieg

Hier finden Sie einige Vorschläge zur Arbeit mit SpeedCommander.

Arbeiten mit den Fenstern

  • Laufwerk auswählen
  • Laufwerksfenster aktualisieren
  • Dateien und Ordner anzeigen
  • Detailansicht konfigurieren
  • Baumansicht verwenden
  • Statuszeile anpassen
  • Ansicht aktualisieren
  • Basisordner verwenden
  • Zweigansicht verwenden
  • Ordneransichten verwenden
  • Brotkrumen-Navigation
  • Ordnerhierarchie-Menü
  • Dateiablage verwenden
  • Laufwerksstatus anzeigen
  • Schnellansicht anzeigen
  • Ordnerinformation anzeigen
  • Befehlseingabezeile verwenden
  • Befehlsausgabefenster verwenden
  • QuickDrop-Symbole verwenden
  • Fensterteilung verändern
  • Layouts verwenden

Arbeiten mit Dateien und Ordnern

  • Dateien und Ordner auswählen
  • Dateien und Ordner kopieren
  • Dateien und Ordner verschieben
  • Dateien und Ordner löschen
  • Dateien und Ordner umbenennen
  • Dateien und Ordner suchen
  • Dateien anzeigen
  • Dateien bearbeiten
  • Dateien trennen und zusammenführen
  • Ordner erstellen
  • Ordner vergleichen
  • Ordnergrößen ermitteln
  • Ordnerlisten drucken
  • Mehrere Dateien umbenennen
  • Zeitstempel und Attribute ändern
  • Abzweigungen, Hardlinks und symbolische Links erstellen

Arbeiten mit Archiven

  • Archiv erstellen
  • Archiv entpacken
  • Multivolume-Archiv erstellen
  • Integrität prüfen
  • Kommentare vergeben
  • Reparaturdaten verwenden
  • Kompressionsprofile verwenden
  • Selbstentpackendes Archiv erstellen

Dateifilter verwenden

  • Dateifilter für die Anzeige
  • Dateifilter für Dateioperationen
  • Dateifilter einrichten
  • Farben zuordnen

Dateiablagen verwenden

  • Dateiablage erstellen
  • Dateien hinzufügen oder entfernen
  • Auswahl laden oder speichern

Brennfunktionen verwenden

  • Brennprojekte
  • Medium löschen
  • Datenträgerabbild erstellen
  • Datenträgerabbild brennen
  • Geräteinformationen anzeigen
  • Medieninformationen anzeigen

Browsen im Web

  • Webseiten anzeigen
  • Startseite festlegen
  • Suchseite festlegen

Zugriff auf FTP-Server

  • Standorte verwalten
  • Proxyserver verwenden
  • Verbindung herstellen
  • Dateien und Ordner kopieren
  • Dateien und Ordner löschen
  • Dateien und Ordner umbenennen
  • Dateiattribute ändern

Datenträger verwalten

  • Datenträger formatieren
  • Datenträger kopieren
  • Datenträger umbenennen
  • Netzlaufwerk verbinden
  • Netzlaufwerk trennen

Weitere Möglichkeiten

  • Ordnerverlauf
  • Systemordner
  • Ordnerfavoriten
  • Anwendungsfavoriten
  • Internetfavoriten-Menü
  • Startmenü
  • Desktop-Menü

Konfiguration

  • Schriftart einstellen
  • Symbolleisten und Menüs anpassen
  • Einstellungen sichern/wiederherstellen
  • Kommandozeilenparameter
  • Installation auf einem USB-Stick

FileSearch

  • Dateien suchen
  • Suchoperatoren verwenden
  • Suchergebnisse bearbeiten
  • Suchprofile verwenden

SpeedEdit

  • Datei erstellen, öffnen und speichern
  • Text kopieren, einfügen, ausschneiden und löschen
  • Text suchen und ersetzen
  • Lesezeichen verwenden
  • AutoText-Einträge verwenden

SpeedView

  • Dateien anzeigen
  • Dateibetrachter umschalten

FileSync

  • Vergleichen und Synchronisieren
  • Synchronisationsprofile verwenden

FileSync Kommandozeile

  • Kommandoschalter
  • Skriptdateien verwenden

Arbeiten mit Makros

  • Makroeditor verwenden
  • Makros ausführen
  • Externe Objekte einbinden


Hinweise zu den Versionen

SpeedCommander
Hinweise zu den Versionen

Unterschiede zwischen Standardversion und Pro-Version

SpeedCommander gibt es als Standardversion und als Pro-Version. Die Pro-Version enthält alle Funktionen der Standardversion und folgende zusätzliche Funktionen:

  • Brennen von Dateizusammenstellungen auf CD, DVD und Blu-Ray
  • Schreiben von Dateizusammenstellungen in eine Datenträgerabbild-Datei
  • Erstellen von Datenträgerabbild-Dateien optischer Medien (CD, DVD, Blu-Ray)
  • Schreiben von Datenträgerabbild-Dateien auf optische Medien (CD, DVD, Blu-Ray)
  • Löschen von wiederbeschreibbaren optischen Medien
  • Anzeige von Geräteinformationen zu optischen Schreib- und Lesegeräten
  • Anzeige von Medieninformationen beschreibbarer optischer Medien
  • Anzeige und Entpacken von Datenträgerabbild-Dateien (ISO, BIN)
  • Einzelplatzlizenz für Keseling DirPrinter

Hinweise zur 64-bit Version von SpeedCommander

SpeedCommander ist als 32-bit und 64-bit Version verfügbar. Die 64-bit Version von SpeedCommander läuft nur unter einer 64-bit Windows-Version, während die 32-bit Version von SpeedCommander sowohl unter einer 32-bit Windows-Version als auch unter einer 64-bit Windows-Version funktioniert. Für die Verwendung der 32-bit Version von SpeedCommander unter einer 64-bit Windows-Version gibt es systembedingte Einschränkungen.

Der erworbene Freischaltcode ist für beide Versionen (32-bit und 64-bit) gültig.

Für die 64-bit Version von SpeedCommander gibt es folgende Einschränkungen:

  1. Die Anzeige und das Entpacken von ACE-Archiven ist nicht möglich, da der Hersteller bisher keine 64-bit DLL zur Verfügung gestellt hat.
  2. Die Integration von Quicktime und RealPlayer ist nicht möglich, da diese Produkte derzeit nur als 32-bit Version vorliegen.
  3. 32-bit AddIns können in der 64-bit Version nicht verwendet werden.


SpeedCommander bestellen

SpeedCommander: Allgemeine Informationen
SpeedCommander bestellen

Vielen Dank für Ihr Interesse am SpeedCommander!

Telefonisch bestellen | Online bestellen
Aus Deutschland: Telefon: 04451 - 95 91 95 Telefax: 04451 - 95 91 96 Aus dem Ausland: Telefon: 0049 4451 - 95 91 95 Telefax: 0049 4451 - 95 91 96 | Bestellen Sie online unter http://shop.speedproject.de/

Preisliste SpeedCommander 15 (Standardversion)

Beschreibung | Preis
SpeedCommander 15 | 39,95 €
SpeedCommander 15 - Upgrade von SpeedCommander 13/14 | 19,95 €
SpeedCommander 15 - Upgrade von SpeedCommander 12 oder älter | 24,95 €
SpeedCommander 15 - Mehrplatzlizenz für 3 Anwender | 99,95 €
SpeedCommander 15 - Mehrplatzlizenz für 5 Anwender | 144,95 €

Preisliste SpeedCommander 15 (Pro-Version mit Keseling DirPrinter)

Beschreibung | Preis
SpeedCommander 15 Pro | 59,95 €
SpeedCommander 15 Pro - Upgrade von SpeedCommander 15 (Standardversion) | 24,95 €
SpeedCommander 15 Pro - Upgrade von SpeedCommander 13/14 | 39,95 €
SpeedCommander 15 Pro - Upgrade von SpeedCommander 12 oder älter | 44,95 €
SpeedCommander 15 Pro - Mehrplatzlizenz für 3 Anwender | 149,95 €
SpeedCommander 15 Pro - Mehrplatzlizenz für 5 Anwender | 224,95 €

Hinweise

  • Der Freischaltcode ist jeweils für die 32-bit und 64-bit Version gültig.
  • Alle Updates innerhalb der Version 15 sind kostenfrei.
  • Preise zu weiteren Mehrplatzlizenzen schicken wir Ihnen gerne auf Anfrage.
  • Die Unterschiede zwischen Standard- und Pro-Version werden hier beschrieben.


Lizenzbedingungen

SpeedCommander: Allgemeine Informationen
Lizenzbedingungen

Die mit dieser Lizenz erworbene Software (im folgenden als "Software" bezeichnet) ist Eigentum der Firma SWE Sven Ritter oder deren Lizenzgeber und ist durch nationale Gesetze und internationale Verträge urheberrechtlich geschützt. Mit der Annahme der Lizenzbedingungen erhalten Sie das Recht zur Benutzung der Software. Sofern nicht durch eine mit dieser Lizenz ausgelieferte Zusatzvereinbarung andere Regelungen getroffen werden, unterliegt die Nutzung der Software folgenden Bestimmungen:

Sie sind berechtigt:

  • eine Kopie der Software auf einem Einzelcomputer zu benutzen. eine Kopie der Software zu Archivierungszwecken anzufertigen oder die Software auf die Festplatte Ihres Computers zu kopieren und die Originaldisketten oder die Original-CD zu archivieren.
  • die Software in einem Netzwerk einzusetzen, vorausgesetzt, dass Sie über eine lizenzierte Kopie der Software für jeden Computer verfügen, der über das Netzwerk auf die Software zugreifen kann.
  • nach schriftlicher Benachrichtigung an SWE Sven Ritter die Software dauerhaft einem Dritten zu überlassen, vorausgesetzt, dass Sie alle Kopien der Software oder der Begleitdokumentation übergeben und der Empfänger der Software sich mit den Bestimmungen dieser Lizenzvereinbarung einverstanden erklärt.
  • als Einzelperson mehrere Installationen auf Ihren Computern vorzunehmen, vorausgesetzt, dass nur Sie als Lizenzinhaber die Software benutzen.

Sie sind NICHT berechtigt:

  • die mit der Software gelieferte Dokumentation zu kopieren.
  • die Software ganz oder teilweise zu verleihen oder zu vermieten oder Unterlizenzen zu vergeben.
  • die Software zurückzuentwickeln (reverse engineering), zu dekompilieren, zu disassemblieren oder auf andere Weise versuchen, den Quellcode der Software zugänglich zu machen, die Software zu ändern, zu übersetzen oder davon abgeleitete Produkte zu erstellen.
  • nach Erhalt einer Austausch-CD oder einer Upgrade- oder Update-Version als Ersatz für eine frühere Version die vorher erhaltene Kopie oder die frühere Version der Software zu benutzen oder zu verkaufen.

Beschränkte Garantie

Diese Software wird geliefert wie sie ist, ohne irgendwelche ausdrückliche oder inbegriffene Garantie. Wir machen darauf aufmerksam, dass es nach dem Stand der Technik nicht möglich ist, Computersoftware zu erstellen, die in allen Anwendungen und Kombinationen fehlerfrei arbeitet. Wir haben jedoch bei der Entwicklung dieser Software größte Sorgfalt walten lassen und werden auch künftig bemüht sein, etwaige Unstimmigkeiten oder Fehler zu beseitigen. Wir haften nicht dafür, dass die Software Ihren Bedürfnissen entspricht, oder dass die Software ohne Unterbrechung und fehlerfrei arbeitet. Wir haften jedoch dafür, dass die Datenträger, auf denen die Software geliefert wird, bei normalem Gebrauch keine Material und Verarbeitungsschäden aufweisen. Diese Haftung gilt für den gesetzlich vorgegebenen Zeitraum von 24 Monaten vom Datum der Auslieferung an. Jede weitere Haftung ist ausgeschlossen.


Systemvoraussetzungen

SpeedCommander: Allgemeine Informationen
Systemvoraussetzungen

Um SpeedCommander verwenden zu können, muss Ihr System folgende Voraussetzungen erfüllen:

  • PC mit Pentium- oder kompatiblem Prozessor
  • Windows XP oder höher
  • 40 MiB freier Festplattenspeicher
  • CD-ROM Laufwerk für die Installation (bei CD-Version)


Copyright

SpeedCommander: Allgemeine Informationen
Copyright

Copyright © 1993-2013 Sven Ritter

Einzelne Teile der Software Copyright © 1999-2013 CodeJock Software
Einzelne Teile der Software Copyright © 1998-2013 Neil Hodgson
Einzelne Teile der Software Copyright © 2001-2012 Tracker Software Products Ltd

SpeedCommander bindet dynamisch eine DLL (7za.dll) von 7-Zip ein, diese DLL steht unter der GNU LGPL-Lizenz. Der Quellcode für 7za.dll kann von http://www.7-zip.org/ heruntergeladen werden.

Warenzeichen

Alle in dieser Hilfe erwähnten Marken- und Produktnamen sind Warenzeichen der jeweiligen Rechtsinhaber und werden hiermit anerkannt.


Danksagungen

SpeedCommander: Allgemeine Informationen
Danksagungen

Ein besonderer Dank geht an folgende Personen, die mir bei der Entwicklung von SpeedCommander direkt oder indirekt geholfen haben:

Programmierung

CodeJock Software, Jan Patera, Neil Hodgson

Grafiken

Alexandra C. Kornblum, Marc Keeley

Betatester

Adrian Bircher, Alexander Möckel, Christian Otto, Dieter Schmelich, Eric Unterberg, Karlheinz Goller, Gerald Mahlmeister, Henrik Heimbürger, Joachim Händel, Klaus Schitteck, Martin Sperlich, Matthias Reissmann, Michael Baas, Ralf Kreutzmann, Rolf Lanzerath, Ulf Schikore


Technische Unterstützung

SpeedCommander: Allgemeine Informationen
Technische Unterstützung

Registrierung von SpeedCommander

Bitte nehmen Sie sich einen Moment Zeit, um Ihre Lizenz von SpeedCommander unter http://register.speedproject.de/ zu registrieren. Als registrierter Anwender werden Sie stets über neue Versionen informiert.

Support per Telefon oder Post

JDS-Software
Jens Driese
Postfach 1269
26302 Varel

Telefon: 0 44 51 - 95 91 95
Telefax: 0 44 51 - 95 91 96

Internet: http://www.jds-software.com/
E-Mail: bestell@jds-software.com

Bürozeiten:
Montag - Freitag von 10.00h bis 13.00h
und Montag - Donnerstag von 15.00h bis 18.00h

Support per Internet

Auf der Internet-Adresse http://www.speedproject.de/ finden Sie Informationen über weitere Produkte, Antworten auf technische Fragen und Probleme sowie aktualisierte Versionen von SpeedCommander. Anfragen per E-Mail richten Sie bitte an support@speedproject.de. Bitte geben Sie unbedingt Ihre Seriennummer an, ohne diese kann Ihre Anfrage nicht bearbeitet werden.

Anregungen und Verbesserungsvorschläge schreiben Sie bitte an feedback@speedproject.de.

Anwenderforum

Im Anwenderforum können Sie mit dem Entwickler und anderen Anwendern diskutieren.


Arbeiten mit den Fenstern

SpeedCommander: Arbeiten mit den Fenstern
Überblick

SpeedCommander zeigt ein Laufwerksfenster und zwei Ordnerfenster an. Sie können wählen, wie die Fenster dargestellt werden, welche Dateien in die Dateiliste aufgenommen werden und in welcher Reihenfolge sie erscheinen sollen. Diese Optionen finden Sie im Menü Ansicht.

Außerdem können Sie die Größe der Fenster ändern, indem Sie die Leiste zwischen den beiden Fenstern in die gewünschte Richtung ziehen oder eine vordefinierte Größe im Menü Ansicht | Fensterteilung wählen.

Standardmäßig werden die Ordnerfenster nebeneinander angezeigt. Möchten Sie die Ordnerfenster untereinander anzeigen, so öffnen Sie das Menü Ansicht, zeigen Sie auf Darstellung und wählen Sie den Befehl Dateifenster untereinander.

Weitere Themen

Laufwerksfenster

Ordnerfenster

Zusatzfenster

Weitere Fenster

Fensterteilung verändern

Layouts verwenden


Laufwerksfenster

SpeedCommander: Arbeiten mit den Fenstern
Laufwerksfenster

Mit Hilfe des Laufwerksfensters wählen Sie das Laufwerk aus, für das Sie eine Dateiliste anzeigen möchten. Neben den Symbolen für die lokalen Laufwerke auf Ihrem System können zusätzlich noch fünf weitere Symbole angezeigt werden. Dabei handelt es sich um virtuelle Laufwerke für den Desktop, die Netzwerkumgebung, das Internet, FTP und AddIns. Je nach Ausstattung Ihres Systems kann es sein, dass nicht alle virtuellen Laufwerke angezeigt werden. Ist Ihr Computer beispielsweise nicht an ein Netzwerk angeschlossen, wird auch kein Symbol für die Netzwerkumgebung angezeigt.

Darstellung der Laufwerksauswahl

SpeedCommander bietet Ihnen die Wahl zwischen drei verschiedenen Ansichten. Die Umschaltung zwischen den Ansichten erfolgt im Menü Ansicht über das Untermenü Darstellung.

Der Befehl Laufwerksauswahl als Kombinationsfeld zeigt die Laufwerke in einem Kombinationsfeld über den Ordnerfenstern an. Bei Laufwerksauswahl als Leiste werden alle verfügbaren Laufwerke über den Ordnerfenstern nebeneinander angezeigt. Reicht die Fensterbreite für die Laufwerke nicht aus, dann erfolgt die Darstellung in mehreren Zeilen. Beide Ansichten ordnen den Ordnerfenstern jeweils eine eigene Auswahl zu.

Bei der Wahl von Gemeinsame Laufwerksleiste werden die verfügbaren Laufwerke ebenfalls nebeneinander über den Ordnerfenstern angezeigt. Im Gegensatz zur vorherigen Option verwenden beide Ordnerfenster eine gemeinsame Leiste. Die angezeigte Auswahl bezieht sich dabei immer auf das jeweils aktive Ordnerfenster.

Ausblenden von virtuellen Laufwerken

Sie können die Symbole für den Desktop, die Netzwerkumgebung, das Internet, FTP und AddIns auch ausblenden, wenn Sie die jeweilige Funktion nicht nutzen möchten. Öffnen Sie dazu den Einstellungsdialog und deaktivieren Sie auf der Seite Aussehen - Darstellung die Symbole, die Sie nicht in der Laufwerksleiste anzeigen möchten.

Wechseldatenträger ohne eingelegte Medien

SpeedCommander kann Wechseldatenträger ohne eingelegtes Medium ausblenden und beim Einlegen eines Mediums automatisch einblenden. Dies erhöht die Übersicht in der Laufwerksleiste, wenn ein Card-Reader mehrere Laufwerke für verschiedene Medientypen im System einrichtet. SpeedCommander zeigt dann immer nur die Laufwerke mit eingelegten Medien an. Diese Funktion kann im Einstellungsdialog auf der Seite Verhalten - Ordner & Laufwerke aktiviert bzw. deaktiviert werden.

Weitere Themen

Laufwerk auswählen

Laufwerksfenster aktualisieren

Virtuelle Laufwerke ausblenden

Wechseldatenträger ohne Medien ausblenden


Laufwerk auswählen

SpeedCommander: Arbeiten mit den Fenstern
Laufwerk aufwählen

Die Auswahl eines Laufwerks kann über die Tastatur oder mit der Maus erfolgen. Um ein Laufwerk mit der Maus auszuwählen, klicken Sie einfach mit der linken Maustaste auf das gewünschte Laufwerk. Der Inhalt des Laufwerks wird dann im jeweiligen Ordnerfenster angezeigt.

SpeedCommander wechselt immer in das zuletzt angezeigte Verzeichnis des jeweiligen Laufwerks. Wenn z.B. im linken Ordnerfenster der Ordner C:\Windows angezeigt wird, dann wird bei der Auswahl des Laufwerks C für das rechte Ordnerfenster auch hier gleich nach C:\Windows gewechselt. Halten Sie beim Klicken mit der linken Maustaste die Umschalt-Taste gedrückt, wenn Sie stattdessen in das Hauptverzeichnis des Laufwerks wechseln möchten.

So wählen Sie ein Laufwerk mit der Tastatur:
  1. Drücken Sie Alt+F1, um das Laufwerk für das linke Fenster auszuwählen, oder Alt+F2, um das Laufwerk für das rechte Fenster auszuwählen.
  2. Wählen Sie das gewünschte Laufwerk mit einer der folgenden Methoden aus: Drücken Sie auf der Tastatur den Buchstaben bzw. die Zahl für das gewünschte Laufwerk oder verwenden Sie den Cursor zur Auswahl des Buchstabens, und drücken Sie Eingabe.
  3. Im Ordnerfenster werden nun die Dateien des gewählten Laufwerks angezeigt.


Laufwerksfenster aktualisieren

SpeedCommander: Arbeiten mit den Fenstern
Laufwerksfenster aktualisieren

SpeedCommander aktualisiert das Laufwerksfenster selbständig im Hintergrund. Er beobachtet, ob in Windows neue Laufwerke an- oder abgemeldet werden oder ob sich das Symbol oder der Name eines Laufwerks geändert hat.

Sollten die Informationen jedoch einmal nicht korrekt sein, so können Sie das Laufwerksfenster auch manuell aktualisieren. Klicken Sie einfach mit der rechten Maustaste in den freien Bereich des Laufwerksfensters und wählen Sie aus dem Kontextmenü den Befehl Aktualisieren.


Ordnerfenster

SpeedCommander: Arbeiten mit den Fenstern
Ordnerfenster

Das Ordnerfenster bietet die Grundlage für viele Funktionen in SpeedCommander. Es dient zur Darstellung der Dateien und Ordner eines Laufwerks. SpeedCommander erlaubt unter Beibehaltung des bewährten Zwei-Fenster-Layouts das Erstellen von beliebig vielen Ordnerfenstern als einzelne Registerkarten.

So legen Sie ein neues Ordnerfenster an:
  • Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Neues Ordnerfenster oder drücken Sie Strg+T.
So aktivieren Sie ein verdecktes Ordnerfenster:
  • Klicken Sie mit der linken Maustaste auf die Registerkarte mit dem Namen des Ordnerfensters oder
  • Drücken Sie Strg+Tab, um zum nächsten Ordnerfenster zu gelangen oder Strg+Umschalt+Tab, um zum vorherigen Ordnerfenster zu gelangen oder
  • Drücken Sie Strg+[Fensternummer].
So löschen Sie ein nicht mehr benötigtes Ordnerfenster:
  1. Aktivieren Sie das Ordnerfenster, welches Sie nicht mehr benötigen.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Ansicht schließen.
So ordnen Sie die Reihenfolge der Ordnerfenster neu:
  1. Aktivieren Sie ein Ordnerfenster.
  2. Öffnen Sie das Menü Ansicht und zeigen Sie auf Ordnerfenster.
  3. Wählen Sie den Befehl Ansicht nach rechts verschieben, um das aktive Ordnerfenster um eine Position nach rechts zu verschieben.
  4. Wählen Sie den Befehl Ansicht nach links verschieben, um das aktive Ordnerfenster um eine Position nach links zu verschieben.

Weitere Themen

Dateien und Ordnern anzeigen

Detailansicht konfigurieren

Baumansicht verwenden

Statuszeile anpassen

Ansicht aktualisieren

Ordnerfenster synchronisieren

Basisordner verwenden

Zweigansicht verwenden

Ordneransichten verwenden

Brotkrumen-Navigation

Ordnerhierarchie-Menü


Dateien und Ordner anzeigen

SpeedCommander: Arbeiten mit den Fenstern
Dateien und Ordner anzeigen

In der Listenansicht werden alle Dateien und Unterordner des aktuellen Ordners angezeigt. SpeedCommander bietet Ihnen verschiedene Ansichtsformen, die über das Menü Ansicht gewechselt werden können.

Bei der Miniaturansicht wird für jede Datei ein Vorschaubild angezeigt, welches vom Betriebssystem oder von der jeweiligen Anwendung zusammengestellt wird. Bei einem Ordnersymbol setzt sich das Vorschaubild aus den im Ordner enthaltenen Dokumenten zusammen. Der Inhalt des Ordners kann damit rasch erkannt werden. Wenn Sie z.B. Bilder in verschiedenen Ordnern gespeichert haben, können Sie in der Miniaturansicht auf einen Blick erkennen, welcher Ordner die von Ihnen gesuchten Bilder enthält. Die Größe der Vorschaubilder kann im Einstellungsdialog auf der Seite Aussehen - Details angepasst werden.

In der Ansicht Kacheln werden die Dateien und Ordner als Symbole in einer Größe von 48 Punkten angezeigt. Die Informationen zur gewählten Sortierung werden unter dem Datei- oder Ordnernamen angezeigt. Wenn Sie beispielsweise Dateien nach dem Dateityp sortieren möchten, wird bei einem Microsoft Word-Dokument "Microsoft Word-Dokument" unterhalb des Dateinamens angezeigt.

Die Ansicht Symbole zeigt die Dateien und Ordner als Symbole in einer Größe von 32 Punkten. Der Dateiname wird unterhalb des Symbols angezeigt; Informationen zur Sortierung werden hingegen nicht aufgeführt. In dieser Ansicht können Sie Dateien und Ordner in Gruppen anzeigen.

In der Ansicht Liste wird der Inhalt eines Ordners als eine Liste aus Datei- oder Ordnernamen angezeigt, denen kleine Symbole in einer Größe von 16 Punkten vorangestellt sind. Diese Ansicht empfiehlt sich dann, wenn der Ordner viele Dateien enthält und Sie die Liste nach einem bestimmten Dateinamen durchsuchen möchten. Sie können die Dateien und Ordner in dieser Ansicht sortieren, Sie können die Dateien jedoch nicht in Gruppen anzeigen.

Die Ansicht Details ist die wohl am häufigsten verwendete Ansicht. In dieser Ansicht zeigt SpeedCommander den Inhalt des geöffneten Ordners in einer Liste an und stellt ausführliche Informationen zu den Dateien, einschließlich Name, Typ, Größe und Änderungsdatum bereit. Sie können die Dateien in dieser Ansicht auch in Gruppen anzeigen.

In Gruppen anzeigen

Durch das Anzeigen in Gruppen können Sie die Dateien abhängig von jedem Detail der Datei, wie Name, Größe, Typ oder Änderungsdatum, gruppieren. Wenn Sie beispielsweise nach dem Dateityp sortieren, werden Bilddateien in einer Gruppe angezeigt, während Microsoft Word-Dateien in einer anderen Gruppe und Excel-Dateien in einer dritten Gruppe angeordnet werden. Das Anzeigen in Gruppen steht in den Ansichten Miniaturansicht, Kacheln, Symbole und Details zur Verfügung. Zur Anzeige der Dateien in Gruppen zeigen Sie im Menü Ansicht auf Symbole anordnen nach und klicken dann auf In Gruppen anzeigen.

Einträge sortieren

In der Listenansicht können Sie festlegen, wie die Dateien sortiert werden sollen. Sie können u.a. nach Name, Erweiterung, Zeit, Größe oder Attribute sortieren. Die Standardeinstellung entspricht einer Sortierung nach Namen.

Die Sortierung der Einträge erfolgt über das Menü Sortieren nach im Menü Ansicht. Die angebotenen Sortiermöglichkeiten richten sich nach den eingeblendeten Spalten in der Detailansicht. Möchten Sie nach einem Kriterium sortieren, das im Menü nicht angeboten wird, dann müssen Sie zuerst die entsprechende Spalte der Detailansicht hinzufügen.

Wenn Sie dieselbe Sortieroption zweimal wählen, wird die Reihenfolge umgekehrt. Wenn Sie also z.B. Größe wählen, erscheint zunächst die größte Datei am Anfang der Liste; nach erneuter Auswahl von Größe wird die Sortierfolge umgekehrt.

Weitere Informationen

Detailansicht konfigurieren


Detailansicht konfigurieren

SpeedCommander: Arbeiten mit den Fenstern
Detailansicht konfigurieren

In der Ansicht Details zeigt SpeedCommander zusätzliche Informationen zu jeder Datei an. Sie können selbst festlegen, welche Informationen Sie angezeigt haben möchten. Die angebotenen Informationen sind abhängig vom jeweiligen Betriebssystem, SpeedCommander bindet alle im System installierten Spaltenerweiterungen für den Windows Explorer ein. Dies sind z.B. umfangreiche Informationen zu MP3-Dateien (Titel, Interpret, Album, Dauer) und Bilddateien (Abmessungen, Aufnahmedatum und Kamera).

So ändern Sie angezeigten Details:
  1. Klicken Sie mit der rechten Maustaste auf eine Spalte im oberen Bereich des Ordnerfensters. Wählen Sie im Kontextmenü den Befehl Feldauswahl.
  2. Um eine Spalte einem Ordnerfenster hinzuzufügen, ziehen Sie die entsprechende Spalte aus dem Fenster Feldauswahl an die gewünschte Position im Ordnerfenster.
  3. Wenn Sie eine Spalte entfernen möchten, dann ziehen Sie die gewünschte Spalte einfach vom Ordnerfenster in das Fenster Feldauswahl.
So ändern Sie die Breite einer Spalte:
  1. Bewegen Sie den Mauszeiger über den Bereich des Spaltentrenners, der sich zwischen zwei Spalten befindet. Der Mauszeiger ändert sich zu einem Verschiebesymbol.
  2. Drücken Sie die linke Maustaste und bewegen Sie die Maus bei gedrückter linker Maustaste nach rechts oder links, um die Spaltenbreite zu vergrößern oder zu verkleinern.
  3. Lassen Sie die linke Maustaste los.
So ändern Sie die Reihenfolge der Spalten:
  1. Klicken Sie mit der linken Maustaste auf eine Spalte und verschieben Sie die Spalte bei gedrückter Maustaste an die gewünschte neue Position. Die Einfügeposition wird durch zwei kleine rote Pfeile gekennzeichnet.
  2. Lassen Sie die linke Maustaste los, um die Spalte an der neuen Position einzufügen.

Sie können bis auf die Spalte Name auch die Textausrichtung jeder einzelnen Spalte ändern. Dies bietet sich an, wenn Sie z.B. die Attribute einer Datei nicht links- sondern rechtsbündig angezeigt haben möchten.

So ändern Sie die Textausrichtung einer Spalte:
  1. Klicken Sie mit der rechten Maustaste auf die Spalte, deren Textausrichtung Sie ändern möchten.
  2. Zeigen Sie im Kontextmenü auf Ausrichtung und wählen Sie die gewünschte Ausrichtung.

Reaktivierung verschwundener Spalten

Manchmal kann es passieren, dass eine Spalte unbeabsichtigt so verkleinert wurde, dass sie nicht mehr zu sehen ist. Im Fenster Feldauswahl ist die Spalte auch nicht vorhanden, da hier nur Spalten angezeigt werden, die sich momentan nicht in der Listenansicht befinden. Drücken Sie in diesem Fall die Tastenkombination Strg + Umschalt + Plus (Nummernblock). Alle Spalten werden nun entsprechend der angezeigten Werte auf ihre optimale Breite eingestellt.

Feldauswahl für erleichterte Bedienung

Neben der mausorientierten Feldauswahl bietet SpeedCommander auch die Möglichkeit, die einzelnen Felder, ihre Breite und die Reihenfolge in einem klassischen Dialogfeld zu konfigurieren. Markieren Sie im Einstellungsdialog auf der Seite Aussehen - Darstellung das Kontrollkästchen Screenreader-kompatiblen Dialog zur Feldauswahl benutzen, um das klassische Dialogfeld zu verwenden.

Verfügbare Spalten

Die folgende Tabelle zeigt alle von SpeedCommander zur Verfügung gestellten Informationen für Dateien und Ordner:

Spalte | Bedeutung
Name | Name der Datei oder des Ordners
Typ | Typ der Datei
Größe | Größe der Datei
Geändert | Datum, an dem die Datei zuletzt geändert wurde
Attribute | Dateiattribute
Erweiterung | Erweiterung der Datei
Letzter Zugriff | Datum, an dem zum letzten Mal auf die Datei zugegriffen wurde
Erstellt | Datum, an dem die Datei erstellt wurde
8.3-Name | Name der Datei im 8.3-Format
Zweigordner | Name des Ordners in Bezug zum Ordner, für den die Zweigansicht aktiviert wurde
Dateien | Anzahl der Dateien unterhalb des Ordners (nach Abschluss der Ordnergrößenberechnung)

Neben den allgemeinen Dateiinformationen stellt SpeedCommander noch eigene weitere Spalten zur Verfügung, die im Feldauswahl-Fenster mit der Fußnote ¹ gekennzeichnet sind:

Spalte | Bedeutung
ADS | Anzahl der zusätzlichen Datentröme
Länge | Anzahl der Zeichen des vollständigen Dateinamens

Alle weiteren Spalten, die vom Betriebssystem oder von externen Anwendungen angeboten werden, sind mit der Fußnote ² gekennzeichnet.

Spezielle Anpassungen für einige XP-kompatible Spaltenerweiterungen

Die Initialisierung der verfügbaren Spaltenerweiterungen erfolgt beim Start von SpeedCommander. Einige Spaltenerweiterungen für Windows XP erfordern hier die Angabe eines Ordners, da sie nur in bestimmten Ordnern funktionieren. Ein Beispiel dafür ist TortoiseSVN, das seine Spaltenerweiterungen nur für Ordner unter Quellcodekontrolle anbietet.

Die entsprechenden Initialisierungsordner können im Einstellungsdialog auf der Seite Aussehen - Netzwerk & Sortierung festgelegt werden. Wenn also TortoiseSVN installiert ist und sich der Ordner C:\CVS-Projekt unter Quellcodekontrolle befindet, dann muss dieser Ordner als Initialisierungsordner eingetragen werden. Für jede Spaltenerweiterung, die einen speziellen Initialisierungsordner benötigt, muss immer nur ein Ordner angegeben werden. Bei TortoiseSVN reicht also die Angabe eines Ordners, der unter Quellcodekontrolle steht.


Baumansicht verwenden

SpeedCommander: Arbeiten mit den Fenstern
Baumansicht verwenden

Die Baumsicht zeigt eine hierarchische Struktur der Ordner auf Ihrem Computer mit dem Desktop als obersten Eintrag. Zum Einblenden der Baumansicht öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Baumansicht. Während Sie sich durch die Baumansicht bewegen, werden die Dateien und vorhandene Unterordner des jeweils ausgewählten Ordners in der Dateiliste angezeigt. Durch Doppelklicken können Sie in der Baumansicht Unterordner ein- oder ausblenden. Der in der Baumansicht hervorgehobene Ordner wird zum jeweils aktuellen Ordner.

Die Einstellung Immer 'Desktop' als obersten Eintrag in der Baumansicht anzeigen auf der Seite Aussehen - Dateien & Ordner des Einstellungsdialogs bestimmt, ob die Baumansicht immer mit dem Desktop starten soll oder ob bei der Anzeige eines Laufwerks das Hauptverzeichnis des Laufwerks als oberster Eintrag angezeigt werden soll.

Für Ordnerfenster mit einem Basisordner können Sie in den Eigenschaften des Ordnerfensters auch festlegen, dass der Basisordner als oberster Eintrag in der Baumansicht angezeigt werden soll.

Beachten Sie bitte, dass für FTP-Verbindungen keine Baumansicht verfügbar ist.


Statuszeile anpassen

SpeedCommander: Arbeiten mit den Fenstern
Statuszeile anpassen
Die am unteren Rand eines Ordnerfensters angezeigte Statuszeile besteht aus mehreren Sektionen, die im Einstellungsdialog auf der Seite Aussehen - Statuszeile & Brotkrumen angepasst werden können. Der Aufbau einer Sektion wird durch eine Zeile innerhalb des Eintragfelds bestimmt. Folgende Platzhalter können verwendet werden:
Insgesamt
{td} | Anzahl der Ordner
{tf} | Anzahl der Dateien
{ti} | Anzahl der Dateien und Ordner
{tba} | Größe aller Einträge (automatische Anzeige in Bytes, KiB, MiB, GiB und TiB)
{tbb} | Größe aller Einträge in Bytes
{tbk} | Größe aller Einträge in KiB
{tmp3} | Dauer aller Musik- und Videodateien (mp3, wav, avi, wmv)
Ausgewählt
{sd} | Anzahl der markierten Ordner
{sf} | Anzahl der markierten Dateien
{si} | Anzahl der markierten Dateien und Ordner
{sba} | Größe aller ausgewählten Einträge (automatische Anzeige in Bytes, KiB, MiB, GiB und TiB)
{sbb} | Größe aller ausgewählten Einträge in Bytes
{sbk} | Größe aller ausgewählten Einträge in KiB
{smp3} | Dauer aller ausgewählten Musik- und Videodateien (mp3, wav, avi, wmv)
Versteckt
{hi} | Anzahl der versteckten Einträge
{hba} | Größe aller versteckten Einträge (automatische Anzeige in Bytes, KiB, MiB, GiB und TiB)
{hbb} | Größe aller versteckten Einträge in Bytes
{hbk} | Größe aller versteckten Einträge in KiB
Speicherplatz
{dta} | Speicherplatz insgesamt (automatische Anzeige in Bytes, KiB, MiB, GiB und TiB)
{dtb} | Speicherplatz insgesamt in Bytes
{dtk} | Speicherplatz insgesamt in KiB
{dfa} | Freier Speicherplatz (automatische Anzeige in Bytes, KiB, MiB, GiB und TiB)
{dfb} | Freier Speicherplatz in Bytes
{dfk} | Freier Speicherblatz in KiB
{dua} | Belegter Speicherplatz (automatische Anzeige in Bytes, KiB, MiB, GiB und TiB)
{dub} | Belegter Speicherplatz in Bytes
{duk} | Belegter Speicherplatz in KiB
{pf} | Freier Speicherplatz in Prozent
{pu} | Belegter Speicherplatz in Prozent
Sonstiges
{fs} | Ordnerfenster werden synchronisiert (*)
{fi} | Aktueller Dateifilter
{ci} | Index des aktuellen Eintrags
Formatierung
{widthXX} | Vorgabe einer festen Breite für die Sektion, wobei XX für die Breite in Punkten steht
{pad} | Sektion auf XX% der Gesamtbreite vergrößern ({padXX})
{rpad} | Sektion auf XX% der restlichen Breite vergrößern ({rpadXX})
{fmtr} | Text in der Sektion rechtsbündig anzeigen
{fmtc} | Text in der Sektion zentriert anzeigen
{fmtnb} | Keine Anzeige des rechten Sektionsrandes
{h!} | Text oder Sektion ausblenden, wenn der erste Wert 0 ergibt
{h?} | Text oder Sektion ausblenden, wenn der erste Wert nicht 0 ergibt
{h:} | Text oder Sektion ausblenden, der Ordner nicht zum regulären Dateisystem (lokales Laufwerk bzw. UNC-Ordner) gehört

Beispiel für Standardvorlage

Aufgrund der Vielzahl von möglichen Platzhaltern kann der Aufbau einer Vorlage recht komplex werden. Die vordefinierte Standardvorlage besteht aus vier Sektionen und sieht wie folgt aus:

{rpad}{sd}/{td} Ordner, {sf}/{tf} Dateien markiert{h!} ({hi} versteckte Einträge){h!}{h!} ({sbb} Bytes){h!}
{h!}{fi}{h!}
{h:}{pu}% belegt, {dfa} verfügbar{fmtnb}{h:}
{h!}{fs}{h!}
1. Sektion

Das am Anfang stehende {rpad} legt fest, dass der nach der Anzeige aller Einträge noch freie Platz mit der ersten Sektion aufgefüllt wird. Die vier nachfolgenden Platzhalter zeigen die markierten sowie insgesamt vorhandenen Dateien und Ordner. Anschließend wird die Anzahl der versteckten Einträge angezeigt, aber auch nur, wenn mindestens ein versteckter Eintrag vorhanden ist. Dies wird durch den Platzhalter {h!} erreicht. Hat der erste nachfolgende Wert {hi} den Wert 0, dann wird der Text bis zum abschließenden {h!} ausgeblendet. Ist {hi} dagegen größer als 0, dann wird der Text abzüglich der beiden Platzhalter {h!} angezeigt. Das gleiche gilt für die nachfolgende Anzeige der Größe der markierten Dateien und Ordner.

2. Sektion

In der zweiten Sektion wird der Name eines gewählten Filters angezeigt. Ist kein Filter aktiv, dann wird auch kein Filtername angezeigt. Da die gesamte Sektion nur aus dem Filternamen besteht, wird sie gänzlich ausgeblendet, sofern kein Filter aktiv ist.

3. Sektion

Die dritte Sektion zeigt den verfügbaren Speicherplatz auf dem aktuellen Laufwerk sowie den prozentual belegten Anteil an. Durch {h:} wird festgelegt, dass diese Sektion nur bei einem lokalen bzw. Netzwerklaufwerk oder bei einem UNC-Ordner im Netzwerkbereich angezeigt wird.

4. Sektion

In der vierten Sektion wird angezeigt, ob die Ordnersynchronisierung aktiviert ist. Bei aktivierter Ordnersynchronisierung wird das aus früheren SpeedCommander-Versionen bekannte *-Symbol angezeigt. Ist die Ordnersynchronisierung deaktiviert, dann wird die Sektion ausgeblendet.


Ansicht aktualisieren

SpeedCommander: Arbeiten mit den Fenstern
Ansicht aktualisieren

Die Aktualisierung der Ordnerfenster erfolgt bei Änderungen im Dateisystem weitgehend automatisch. SpeedCommander beobachtet im Hintergrund, ob im Ordner des linken und rechten Fensters Dateien erstellt, gelöscht oder umbenannt werden, und aktualisiert gegebenenfalls die entsprechende Ansicht selbstständig.

Es kann auch passieren, dass SpeedCommander bei bestimmten Änderungen im Dateisystem nicht informiert wird oder Änderungen übersieht. In diesem Fall müssen Sie den Inhalt der Fenster manuell aktualisieren.

So aktualisieren Sie die Fenster manuell:
  • Wählen Sie aus dem Menü Ansicht den Befehl Aktualisieren. Sie können stattdessen auch das Symbol Aktualisieren in der Symbolleiste verwenden.


Ordnerfenster synchronisieren

SpeedCommander: Arbeiten mit den Fenstern
Ordnerfenster synchronisieren

Alle Ordnerfenster verhalten sich in der Grundeinstellung voneinander unabhängig. Wenn Sie z.B. in einem Ordnerfenster ein neues Laufwerk wählen, so bleibt der in den anderen Fenstern aktivierte Ordner immer erhalten. Mit der Funktion Ordnerfenster synchronisieren wird der in den verschiedenen Ordnerfenstern angezeigte Ordner jedoch immer abgeglichen. Dies ermöglicht es Ihnen über das ganze Dateisystem hinweg unterschiedliche Sichten auf die gleichen Daten. Dieses Verhalten ist z.B. sehr hilfreich, wenn die Dateien eines Ordners immer wieder nach verschiedenen Kriterien sortiert oder gefiltert werden müssen.

So aktivieren Sie die Synchronisation der Ordnerfenster:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Ordnerfenster synchronisieren oder drücken Sie Strg+Umschalt+T, I.
  2. Wählen Sie den gleichen Befehl, um die Synchronisation der Ordnerfenster zu beenden.

Bitte beachten Sie, dass im Einstellungsdialog auf der Seite Verhalten - Ordner & Laufwerke die Option Ausgewählter Filter gilt für alle Ordnerfenster gleichzeitig deaktiviert werden muss, um für die verschiedenen Ordnerfenster unterschiedliche Filter einstellen zu können.


Basisordner verwenden

SpeedCommander: Arbeiten mit den Fenstern
Basisordner verwenden

Normalerweise zeigt SpeedCommander beim Start in jedem Ordnerfenster den Ordner an, der beim Beenden aktiv war. Sie können jedoch einen Basisordner definieren, wenn Sie möchten, dass beim Start immer ein bestimmter Ordner angezeigt wird.

So definieren Sie einen Basisordner:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Eigenschaften des Ordnerfensters.
  2. Aktivieren Sie das Kontrollkästchen Navigation einschränken und/oder Basisordner verwenden.
  3. Tragen Sie im Feld Basisordner den Ordner ein, den SpeedCommander bei jedem Start in diesem Ordnerfenster anzeigen soll.

Navigation einschränken

SpeedCommander bietet Ihnen auch die Möglichkeit, die Navigation in einem Ordnerfenster einzuschränken. Aktivieren Sie das Kontrollkästchen Laufwerkswechsel sperren, wenn in diesem Ordnerfenster nur Wechsel innerhalb des gleichen Laufwerks möglich sein sollen. Das Kontrollkästchen Wechsel in untergeordnete Ordner sperren legt fest, dass in diesem Ordnerfenster keine Wechsel in untergeordnete Ordner möglich sein sollen. Die Einstellung Wechsel in übergeordnete Ordner sperren deaktiviert den Wechsel in übergeordnete Ordner.

Aktivieren Sie das Kontrollkästchen Bei Aktivierung in den Basisordner wechseln, wenn bei jeder Aktivierung des Ordnerfensters in den Basisordner gewechselt werden soll. Möchten Sie in der Baumansicht den aktuellen Basisordner als obersten Eintrag anzeigen, dann aktivieren Sie die Einstellung Als obersten Eintrag in Baumansicht anzeigen.

Weitere Eigenschaften

Aktivieren Sie das Kontrollkästchen Bei Aktivierung immer aktualisieren, wenn der Inhalt des Ordnerfensters bei jeder Aktivierung neu eingelesen werden soll. Mit der Einstellung Name automatisch an aktuellen Ordner anpassen legen Sie fest, ob SpeedCommander beim Ordnerwechsel auch den Namen der Registerkarte an den neuen Ordner anpassen soll. Deaktivieren Sie dieses Kontrollkästchen, wenn Sie für die Registerkarte einen festen Namen verwenden wollen.


Zweigansicht verwenden

SpeedCommander: Arbeiten mit den Fenstern
Zweigansicht verwenden

Normalerweise werden in einem Ordnerfenster immer nur die Dateien und Unterordner eines Ordners angezeigt. Mit Hilfe der Zweigansicht kann SpeedCommander alle Dateien aus allen Unterordnern des aktuellen Ordners anzeigen. Dies ist nützlich, wenn Sie sich einen Überblick über sämtliche Dateien verschaffen möchten, die sich in bzw. unterhalb eines Ordners befinden.

Das Einlesen aller Dateien kann besonders bei größeren Ordnern etwas länger dauern, Sie sollten diese Funktion daher nicht im Hauptverzeichnis einer größeren Festplatte verwenden. Sie können das Einlesen der Dateien aber jederzeit durch Drücken von Escape abbrechen.

So aktivieren Sie die Zweigansicht:
  1. Öffnen Sie das Menü Ordner und wählen Sie den Befehl Zweigansicht oder drücken Sie Strg+Umschalt+O, Z.
  2. Wählen Sie denselben Befehl, um die Zweigansicht wieder zu deaktivieren.


Ordneransichten verwenden

SpeedCommander: Arbeiten mit den Fenstern
Ordneransichten verwenden

Bei einem Wechsel in einen anderen Ordner gleichen Typs behält SpeedCommander den Ansichtsmodus der Listenansicht, die Gruppierung und die Detailansicht bei. Ordner im Dateisystem werden so immer auf die gleiche Weise angezeigt, ohne dass die Ansicht beim Ordnerwechsel vom Anwender korrigiert werden muss.

Die Ordneransicht ermöglicht es, bestimmte Ordner automatisch in einem anderen Ansichtsmodus anzuzeigen. Beim Wechsel in einen Ordner wird geprüft, ob dieser Ordner mit einer speziellen Ansicht verbunden ist. Wenn ja, dann schaltet SpeedCommander den Ansichtsmodus der Listenansicht, die Gruppierung und die Spalten in der Detailansicht automatisch um. Beim Verlassen des Ordners werden diese Eigenschaften wieder auf die normale Ansicht zurückgesetzt.

Sie können z.B. eine Ordneransicht für Bilder definieren, die bevorzugt in der Miniaturansicht angezeigt werden sollen. Anschließend können Sie die entsprechenden Bilderordner auf Ihrem System mit einem Mausklick dieser Ansicht zuordnen, so dass beim Wechsel in den Bilderordner automatisch die Miniaturansicht aktiviert wird. Die Zuordnung kann nur für den Ordner selbst oder auch gleich für alle untergeordneten Ordner dieses Ordners erfolgen.

So erstellen Sie eine Ordneransicht:
  1. Wechseln Sie in den Ordner, für den Sie eine Ordneransicht erstellen möchten.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordneransichten und wählen Sie den Befehl Ansicht speichern.
  3. Vergeben Sie einen Namen für die neue Ansicht und schließen Sie den Dialog mit OK.
  4. Ändern Sie den Ansichtsmodus der Listenansicht, die Gruppierung und die Spalten der Detailansicht nach Ihren Wünschen.
  5. Speichern Sie die Ansicht erneut unter dem gleichen Namen.
So verknüpfen Sie einen Ordner mit einer Ansicht:
  1. Wechseln Sie in den Ordner, den Sie mit einer Ordneransicht verknüpfen möchten.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordneransichten und wählen Sie die gewünschte Ansicht im Menü aus.
  3. Wenn Sie die Ansicht auch gleich für alle Unterordner übernehmen möchten, dann bestätigen Sie die folgende Nachfrage mit Ja.
  4. Halten Sie bei der Auswahl der Ansicht die Taste Strg gedrückt, um die Ordneransicht ohne Nachfrage nur diesem Ordner zuzuordnen. Halten Sie zusätzlich die Tasten Strg und Umschalt gedrückt, um die Ordneransicht ohne Nachfrage auch allen Unterordnern zuzuordnen.
So entfernen Sie die Verknüpfung zu einer Ansicht:
  1. Wechseln Sie in den Ordner, dessen Verknüpfung Sie entfernen möchten.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordneransichten und wählen Sie den Befehl Ansicht von Ordner trennen.
So verwalten Sie die Ordneransichten:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordneransichten und wählen Sie den Befehl Ansichten verwalten.
  2. Klicken Sie neben dem Kombinationsfeld mit den vorhandenen Ansichten auf das Symbol Löschen, um die Ansicht zu löschen. Gleichzeitig werden auch alle Zuordnungen für diese Ansicht entfernt.
  3. Klicken Sie neben dem Kombinationsfeld mit den vorhandenen Ansichten auf das Symbol Umbenennen, um den Namen für die Ansicht zu ändern.
  4. Klicken Sie auf die Schaltfläche Hinzufügen, um der aktuellen Ansicht einen neuen Ordner zuzuordnen.
  5. Wählen Sie einen zugeordneten Ordner und klicken Sie auf die Schaltfläche Entfernen, um die Zuordnung zu diesem Ordner zu entfernen.
  6. Doppelklicken Sie auf einen zugeordneten Ordnereintrag, um den Status für Unterordner umzuschalten. Ein Sternchen rechts neben dem Ordner zeigt an, dass die Zuordnung auch für die untergeordneten Einträge des Ordners gilt. Andernfalls gilt die Zuordnung nur für den Ordner selbst.
  7. Wählen Sie einen zugeordneten Ordner und klicken Sie erneut mit der linken Maustaste auf den Eintrag, um die Vororteditierung zu aktivieren. Hier können Sie den Ordner manuell anpassen. Die Verwendung von Umgebungsvariablen ist ebenfalls möglich.


Brotkrumen-Navigation

SpeedCommander: Arbeiten mit den Fenstern
Brotkrumen-Navigation

Mit Hilfe der Brotkrumen-Navigation lässt es sich schnell in übergeordnete Ordner wechseln. Der in der Titelzeile eines Ordnerfensters angezeigte Ordnername wird in seine Einzelteile aufgetrennt angezeigt. Durch einen Klick mit der linken Maustaste auf ein Element wird in den jeweiligen Ordner gewechselt. Neben jedem Element wird zusätzlich ein kleiner Pfeil angezeigt, ein Klick mit der linken Maustaste auf den Pfeil öffnet ein Menü mit den Unterordnern des Elements. Nach der Auswahl eines Menüeintrags wird in den jeweiligen Unterordner gewechselt.

Ein Doppelklick auf einen freien Bereich in der Titelzeile öffnet ein Eingabefenster, das die Direkteingabe eines Ordners ermöglicht. Alternativ lässt sich die Eingabezeile auch über den Befehl Gehe zu... des Menüs Ordner - Wechseln zu öffnen.

So wechseln Sie in einen übergeordneten Ordner:
  1. Klicken Sie in der Titelzeile des Ordnerfensters mit der linken Maustaste auf einen Pfadbestandteil.
So wechseln Sie in einen Unterordner eines übergeordneten Ordners:
  1. Klicken Sie in der Titelzeile des Ordnerfensters mit der linken Maustaste auf den kleinen Pfeil rechts neben dem Pfadbestandteil.
  2. Wählen Sie aus dem Menü den Ordner aus, in den Sie wechseln möchten.
So aktivieren Sie die Eingabezeile für Ordner:
  1. Öffnen Sie das Menü Ordner, zeigen Sie auf das Untermenü Wechseln zu und wählen Sie den Befehl Gehe zu... oder drücken Sie Strg+G.


Ordnerhierarchie-Menü

SpeedCommander: Arbeiten mit den Fenstern
Ordnerhierarchie-Menü

Im Ordnerhierarchie-Menü werden alle Ebenen vom aktuellen Ordner bis zum jeweiligen Hauptordner angezeigt. Damit wird der Wechsel in übergeordnete Ordner sehr vereinfacht.

So aktivieren Sie das Ordnerhierarchie-Menü:
  1. Klicken Sie in der Titelzeile des Ordnerfensters mit der linken Maustaste auf das Symbol Ordnerhierarchie.
  2. Aktivieren Sie das Menü Ordner und zeigen Sie auf Ordnerhierarchie.
  3. Drücken Sie Strg+Umschalt+G, H.
So wechseln Sie schnell in einen Ordner:
  1. Aktivieren Sie das Ordnerhierarchie-Menü.
  2. Wählen Sie den Ordner aus, in den Sie wechseln möchten.


Zusatzfenster

SpeedCommander: Arbeiten mit den Fenstern
Zusatzfenster

Neben den Ordnerfenstern zur Anzeige von Dateien und Ordnern verwendet der SpeedCommander zusätzliche Fenster zur Darstellung bestimmter Informationen. Diese Fenster werden immer auf der gegenüberliegenden Seite des aktiven Ordnerfensters eingeblendet.

Das Ein- und Ausblenden der Zusatzfenster erfolgt über das Untermenü Ordnerfenster im Menü Ansicht. Aktivieren Sie einfach den jeweiligen Befehl, um das entsprechende Fenster einzublenden. Deaktivieren Sie den Befehl, wenn Sie das Zusatzfenster wieder ausblenden möchten.

Weitere Themen

Laufwerksstatus

Schnellansicht

Ordnerinformation


Laufwerksstatus

SpeedCommander: Arbeiten mit den Fenstern
Laufwerksstatus

Das Zusatzfenster Laufwerksstatus zeigt Informationen zum aktuellen Laufwerk. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Laufwerksstatus, um das Fenster mit dem Laufwerksstatus anzeigen. Aktivieren Sie den Befehl erneut, um das Zusatzfenster wieder auszublenden.

Folgende Informationen eines Laufwerks werden angezeigt:

  • Datenträgerbezeichnung
  • Seriennummer des Laufwerks
  • Typ des Dateisystems
  • Laufwerkstyp
  • Speicherkapazität des Laufwerks
  • Größe des verfügbaren Speichers auf dem Laufwerk
  • Informationen zur Anzahl der Cluster und Sektoren
  • Angaben zur Speicherung von Dateinamen mit Groß- und Kleinschreibung
  • Unterstützung von Unicode
  • Verwendung von Zugriffskontroll-Listen, Dateibasierte Kompression
  • Verschlüsselung, Datenträgerkontingente, Sparse-Dateien, Verbindungspunkte, Objektidentifizierer


Schnellansicht

SpeedCommander: Arbeiten mit den Fenstern
Schnellansicht

Mit dem Zusatzfenster Schnellansicht können Sie den Inhalt einer Datei ansehen, ohne dazu die Anwendung starten zu müssen, mit der die Datei erstellt wurde. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Schnellansicht, um dieses Zusatzfenster anzuzeigen. Um die Schnellansicht wieder auszublenden, wählen Sie erneut den Befehl Schnellansicht aus dem Menü Ordnerfenster.

Die Art der Anzeige in der Schnellansicht ist abhängig davon, ob sich unter dem Auswahlbalken eine Datei oder ein Ordner befindet. Befindet sich der Auswahlbalken auf einer Datei, so wird in der Schnellansicht der Inhalt dieser Datei angezeigt. Um die Dateien in einem Ordner nacheinander anzuzeigen, klicken Sie mit der linken Maustaste auf die gewünschte Datei oder drücken die Pfeiltasten Nach oben bzw. Nach unten.

Befindet sich der Auswahlbalken dagegen auf einem Ordner, so werden in der Schnellansicht Informationen zu diesem Ordner sowie allen ihm untergeordneten Ordner angezeigt.

Mit Hilfe einer Baumansicht zeigt der SpeedCommander den Namen des Ordners sowie die Größe aller Dateien und Ordner an, die sich unterhalb dieses Ordners befinden. Klicken Sie auf das Aufklappsymbol vor dem jeweiligen Ordner, um auch Informationen zu tiefergelegenen Ordnern anzuzeigen.

Weitere Informationen

Dateibetrachter umschalten


Ordnerinformation

SpeedCommander: Arbeiten mit den Fenstern
Ordnerinformation

Das Zusatzfenster Ordnerinformation zeigt Ihnen detaillierte Angaben zu den momentan gewählten Dateien und Ordnern. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Ordnerinformation, um das Fenster mit den Ordnerinformationen anzeigen. Aktivieren Sie den Befehl erneut, um das Zusatzfenster wieder auszublenden.

Allgemein

Die Einträge Ordner und Dateien zeigen die Anzahl der Ordner und Dateien an, die entweder markiert sind oder sich in untergeordneten Ordnern der markierten Einträge befinden. Unter Abzweigungen wird die Anzahl der Abzweigungspunkte (Junctions) angezeigt. Symbolische Links zeigt die Anzahl der symbolischen Verknüpfungen für Dateien und Ordner, während Hardlinks die Anzahl der Verweise auf andere Dateien angibt.

Unter Sparse-Dateien wird die Anzahl der Dateien angezeigt, die weniger Platz auf dem Datenträger belegen als durch die eigentliche Dateigröße zu vermuten ist. Komprimiert gibt die Anzahl der Dateien an, die durch Funktionen des Dateisystems komprimiert abgespeichert werden. Unter Datenströme wird die Anzahl von Dateien und Ordnern angegeben, die zusätzliche Datenströme besitzen.

Speicherplatz

Der Eintrag Dateien gibt den für alle Dateien benötigten Speicherplatz an. Datenströme zeigt den Speicherplatz an, der in zusätzlichen Datenströmen verwendet wird. Insgesamt ist die Summe beider Werte, während unter Allokiert der tatsächlich belegte Speicherplatz der markierten Dateien und Ordner angegeben wird.

Gefilterter Speicherplatz

Die Bedeutung der Einträge hier entspricht dem vorherigen Bereich, allerdings wird für untergeordnete Dateien und Ordner geprüft, ob sie den Eigenschaften des aktuell gewählten Filters entsprechen.

Medien

Hier finden Sie die Anzahl der Medien, die nötig sind, um die markierten Dateien und Ordner aufzunehmen.

Protokollierung und Berichte

Die Anzahl der angezeigten Informationen hat sich mit SpeedCommander 14 erhöht, damit verbunden ist zwangsläufig auch ein erhöhter Zeitbedarf für deren Ermittlung. Klicken Sie mit der rechten Maustaste links neben die angezeigten Ergebnisse und deaktivieren Sie im Kontextmenü den Eintrag Erweiterte Informationen, um die Analyse von Hard- und Softlinks, Sparse-Dateien und Datenströmen zu unterbinden.

Die Einstellung Abzweigungen folgen im Kontextmenü legt fest, ob SpeedCommander beim Erkennen einer Abzweigung dieser folgen und die hier abgelegten Dateien und Ordner in die Berechnung einfließen lassen soll.

Mit Hilfe des Befehl Bericht in Zwischenablage kopieren können Sie die Ergebnisse in die Zwischenablage kopieren. Ist die Einstellung Spezielle Dateien protokollieren aktiviert, dann enthält der Bericht neben der Anzahl der Dateien und der Dateigrößen auch die Dateinamen für Abzweigungen, Hardlinks, symbolische Links, Sparse-Dateien, komprimierte Dateien und zusätzliche Datenströme.

Bei einer Abzweigung wird zudem gekennzeichnet, ob es sich um eine normale Abzweigung handelt oder um eine nicht nachverfolgbare Abzweigung, die ab Windows Vista auf dem Systemlaufwerk für eine bessere Kompatibilität für ältere Programme verwendet wird. Normale Abzweigungen werden durch das Symbol => gekennzeichnet, während nicht nachverfolgbare Abzweigungen mit dem Symbol -> gekennzeichnet werden.


Weitere Fenster

SpeedCommander: Arbeiten mit den Fenstern
Weitere Fenster

Neben den Ordnerfenstern und Zusatzfenstern sind auch noch weitere Fenster für die Ein- und Ausgabe von Befehlen verfügbar.

Das Ein- und Ausblenden der Fenster erfolgt über das Untermenü Ordnerfenster im Menü Ansicht. Aktivieren Sie einfach den jeweiligen Befehl, um das entsprechende Fenster einzublenden. Deaktivieren Sie den Befehl, wenn Sie das Fenster wieder ausblenden möchten.

Weitere Themen

Befehlseingabezeile

Befehlsausgabefenster

QuickDrop-Symbole


Befehlseingabezeile

SpeedCommander: Arbeiten mit den Fenstern
Befehlseingabezeile

Die Befehlseingabezeile am unteren Rand von SpeedCommander ist eine voll funktionsfähige Befehlszeile. Verwenden Sie diese genauso, wie Sie auch sonst eine Befehlszeile verwenden, wenn SpeedCommander nicht läuft. Die Befehlseingabezeile kann für DOS- und FTP-Befehle verwendet werden.

Sie können den Dateinamen, der gerade durch den Auswahlbalken hervorgehoben wird, in die Befehlszeile kopieren. Wechseln Sie dazu mit Strg+Umschalt+B, D aus dem Ordnerfenster in die Befehlseingabezeile und drücken Sie dann Strg+Eingabe. Um den vollständigen Dateinamen in die Befehlseingabezeile zu übernehmen, drücken Sie stattdessen Strg+Umschalt+Eingabe. Diese Funktion erleichtert Ihnen das Erstellen langer Befehlszeilen, in denen Dateinamen aus dem aktiven Ordnerfenster verwendet werden.

Mit Hilfe der Befehlseingabezeile können Sie auch schnell in verschiedene Verzeichnisse wechseln. Geben Sie z.B. einfach den Befehl C:\Windows ein, um im aktiven Ordnerfenster in das Windows-Verzeichnis zu wechseln.

Durch zusätzliches Drücken der linken oder rechten Windows-Taste kann der eingegebene Befehl mit erhöhten Rechten ausgeführt werden.

So schalten Sie die Befehlseingabezeile ein oder aus:
  • Klicken Sie in der Symbolleiste auf die Schaltfläche Befehlseingabezeile oder wählen Sie im Menü Ansicht aus dem Untermenü Darstellung den Befehl Befehlseingabezeile.
So blättern Sie in der Befehlseingabezeile:
  • Drücken Sie Strg+Umschalt+Cursor nach oben bzw. Strg+Umschalt+Cursor nach unten, um in der Befehlszeile zu blättern. Cursor nach oben bzw. Cursor nach unten ändern den aktiven Eintrag im Ordnerfenster.
So wechseln Sie aus der Befehlseingabezeile wieder zurück:
  • Drücken Sie Strg+Umschalt+B, D, um wieder in das Ordnerfenster zu wechseln.


Befehlsausgabefenster

SpeedCommander: Arbeiten mit den Fenstern
Befehlsausgabefenster

Das Befehlsausgabefenster zeigt die Bildschirmausgabe von Befehlen direkt in SpeedCommander an.

So blenden Sie das Befehlsausgabefenster ein bzw. aus:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Darstellung und wählen Sie den Befehl Befehlsausgabefenster oder drücken Sie Strg+Umschalt+D, D.
  2. Aktivieren Sie den Befehl erneut, wenn Sie das Befehlsausgabefenster wieder ausblenden möchten.

Wenn das Befehlsausgabefenster aktiviert ist, wird die Ausgabe jedes in der Befehlseingabezeile eingegebenen Befehls in diesem Fenster dargestellt.

Wichtiger Hinweis

Das Befehlsausgabefenster kann nur die Ausgabe der Befehle anzeigen, die reinen Text ausgeben. Anwendungen, die direkt in den Bildschirmspeicher schreiben oder grafische Symbole ausgeben, funktionieren nicht. Das Befehlsausgabefenster ist primär dafür gedacht, die Ausgabe von Batchdateien zu beobachten bzw. einfache Tastaturkommandos auszuführen. Es ist keine vollwertige Eingabeaufforderung. Das Abbrechen von Befehlen mittels Strg+C ist nicht möglich.


QuickDrop-Symbole

SpeedCommander: Arbeiten mit den Fenstern
QuickDrop-Symbole

Zwischen den beiden Ordnerfenstern kann SpeedCommander eine Leiste mit verschiedenen Symbolen anzeigen, die als Ziel für Dateioperationen dienen können. Ziehen Sie einfach die entsprechenden Dateien aus dem Ordnerfenster auf das gewünschte QuickDrop-Symbol, um die entsprechende Aktion zu starten.

Folgende Aktionen sind möglich:

  • Komprimieren
  • Entpacken
  • Betrachten
  • Editieren
  • Drucken
  • Löschen in den Papierkorb

Neben den vordefinierten Symbolen können Sie auch bis zu 15 eigene Anwendungen in die QuickDrop-Leiste einbinden. Eine Anwendung kann durch Doppelklick mit der linken Maustaste oder durch Ziehen und Ablegen von einer oder mehreren Dateien auf das Symbol gestartet werden. Die Reihenfolge der QuickDrop-Symbole kann bis auf die sechs Standardsymbole beliebig angepasst werden.

So schalten Sie einzelne Symbole ein oder aus:
  1. Klicken Sie mit der rechten Maustaste auf die Leiste mit den QuickDrop-Symbolen.
  2. Aktivieren oder deaktivieren Sie im Dialogfeld QuickDrop-Symbole das QuickDrop-Symbol aus, welches Sie anzeigen oder ausschalten möchten.
So fügen Sie eine Anwendung als QuickDrop-Symbol hinzu:
  1. Klicken Sie mit der rechten Maustaste auf die Leiste mit den QuickDrop-Symbolen, das Dialogfeld QuickDrop-Symbole erscheint.
  2. Klicken Sie auf die Schaltfläche Neu und wählen Sie im Dialogfeld Öffnen, die Anwendung aus, die Sie als QuickDrop-Symbol hinzufügen möchten.
So sortieren Sie die QuickDrop-Symbole:
  1. Klicken Sie mit der rechten Maustaste auf die Leiste mit den QuickDrop-Symbolen, das Dialogfeld QuickDrop-Symbole erscheint.
  2. Wählen Sie den Eintrag, den Sie verschieben möchten.
  3. Klicken Sie auf die Schaltfläche Nach oben bzw. Nach unten, um die Position des QuickDrop-Symbols zu verändern.
So deaktivieren Sie die gesamte QuickDrop-Leiste:
  1. Öffnen Sie im Menü Ansicht das Untermenü Darstellung.
  2. Deaktivieren Sie den Befehl QuickDrop-Symbole.


Fensterteilung verändern

SpeedCommander: Arbeiten mit den Fenstern
Fensterteilung verändern

Sie können die beiden Ordnerfenster in SpeedCommander Ihren Anforderungen entsprechend vergrößern oder verkleinern. Das Menü Ansicht enthält ein Untermenü Fensterteilung mit den Befehlen 0%, 25%, 50%, 75% und 100%.

Befehl | Ergebnis
0 % | Verbirgt das linke Fenster
25 % | Stellt das linke Fenster auf 25% und das rechte Fenster auf 75% der verfügbaren Fensterbreite
50% | Stellt beide Fenster auf gleiche Größe
75 % | Stellt das linke Fenster auf 75% und das rechte Fenster auf 25% der verfügbaren Fensterbreite
100 % | Verbirgt das rechte Fenster

Neben diesen festen Positionen können Sie die Fenstergröße mit der Maus auf jeden beliebigen Wert setzen. Bewegen Sie den Mauszeiger auf das Verschiebesymbol zwischen den beiden Fenstertiteln. Sobald der Mauszeiger das Aussehen eines Fadenkreuzes annimmt, können Sie die Leiste in die gewünschte Richtung ziehen.

Wenn Sie mit der linken Maustaste auf das Verschiebesymbol doppelklicken, werden die beiden Ordnerfenster wieder auf die gleiche Größe gesetzt.


Layouts verwenden

SpeedCommander: Arbeiten mit den Fenstern
Layouts verwenden

In einem Layout können Sie ihre aktuelle Arbeitsumgebung mit allen Ordnerfenstern und allen Anzeigeeinstellungen speichern, so dass Sie schnell zwischen verschiedenen häufig genutzten Einstellungen umschalten können.

So speichern Sie ein Layout:
  1. Konfigurieren Sie die Ansicht, die Sie speichern möchten.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Layout und wählen Sie den Befehl Speichern.
  3. Geben Sie im Dialogfeld Layout speichern einen Namen für das neue Layout ein, und klicken Sie auf OK.
So löschen Sie ein gespeichertes Layout:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Layout und wählen Sie den Befehl Löschen.
  2. Markieren Sie im Dialog Layout löschen das zu löschende Layout, und klicken Sie auf OK.
So aktivieren Sie ein Layout:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Layout und wählen Sie das Layout aus, welches Sie aktivieren möchten.
  2. Sie können auch das Symbol Layout aus der Symbolleiste verwenden oder im Anpassen-Dialog auf der Seite Tastatur jedem Layout ein eigenes Tastenkürzel zuordnen.

Weitere Hinweise

Tastenkürzel anpassen


Arbeiten mit Dateien und Ordnern

SpeedCommander: Arbeiten mit Dateien und Ordnern
Überblick

In SpeedCommander ist das Sortieren und Organisieren Ihrer Dateien und Ordner eine einfache Angelegenheit. Sie können Dateien und Ordner kopieren, bewegen, komprimieren, löschen und umbenennen.

Weitere Themen

Dateien und Ordner auswählen

Dateien und Ordner kopieren

Dateien und Ordner verschieben

Dateien und Ordner löschen

Dateien und Ordner umbenennen

Dateien und Ordner suchen

Dateien anzeigen

Dateien bearbeiten

Dateien trennen und zusammenführen

Ordner erstellen

Ordner vergleichen

Ordnergrößen ermitteln

Ordnerlisten drucken

Mehrere Dateien umbenennen

Zeitstempel und Attribute ändern

Abzweigungen, Hardlinks und symbolische Links erstellen


Dateien und Ordner auswählen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner auswählen

SpeedCommander bietet mehrere Möglichkeiten an, Dateien und Ordner auszuwählen. Die Methoden dazu gleichen in der Standardkonfiguration denen, die auch der Windows-Explorer verwendet. Alternativ können Sie im Einstellungsdialog auf der Seite NC-Kompatibilität den NC-Auswahlmodus aktivieren, bei dem die Auswahl von Dateien und Ordnern wie im damaligen DOS-Commander funktioniert.

Möglichkeiten zum Markieren von Dateien und Ordnern

  • Markieren von Dateien und Ordnern mit der Maus
  • Markieren von Dateien und Ordnern mit der Maus (NC-Auswahlmodus)
  • Markieren von Dateien und Ordnern mit der Tastatur
  • Markieren von Dateien und Ordnern mit der Tastatur (NC-Auswahlmodus)
  • Auswahl von Dateien und Ordnern erweitern
  • Auswahl von Dateien und Ordnern reduzieren
  • Dateityp unter dem Auswahlbalken auswählen
  • Umkehrung der aktuellen Auswahl
  • Wiederherstellung der vorherigen Auswahl
Markieren von Dateien und Ordnern mit der Maus
  • Klicken Sie mit der linken Maustaste auf eine Datei, um diese auszuwählen. Zum Auswählen einer Gruppe aufeinander folgender Dateien oder Ordner klicken Sie auf das erste Element, halten Sie die Umschalt-Taste gedrückt und klicken Sie dann auf das letzte Element. Wenn Sie Dateien oder Ordner markieren möchten, die nicht aufeinander folgen, dann halten Sie die Strg-Taste gedrückt und klicken Sie nacheinander auf jedes Element, welches Sie auswählen möchten.
  • Zum Abwählen einzelner Elemente halten Sie die Strg-Taste gedrückt und klicken anschließend auf die Elemente, die Sie nicht mehr in die Auswahl einschließen möchten. Zur Abwahl aller Dateien und Ordner können Sie mit der linken Maustaste auch in einen freien Bereich der Listenansicht klicken.
  • Sie können Dateien und Ordner auch mit Hilfe eines Lassos markieren. Klicken Sie dazu mit der linken Maustaste in einen freien Bereich der Listenansicht und ziehen Sie die Markierung um alle Elemente, die Sie markieren möchten. Halten Sie dabei die Umschalt-Taste gedrückt, wenn Sie die Markierung erweitern möchten. Durch gleichzeitiges Halten der Strg-Taste wird die Markierung der betroffenen Elemente umgekehrt.
Markieren von Dateien und Ordnern mit der Maus (NC-Auswahlmodus)
  • Ein Klick mit der linken Maustaste auf ein Element setzt den Auswahlbalken auf dieses Element, ohne allerdings das Element zu markieren bzw. die Markierung von anderen Elementen aufzuheben. Zum Auswählen einer Gruppe aufeinander folgender Dateien oder Ordner klicken Sie auf das erste Element, halten Sie die Umschalt-Taste gedrückt und klicken Sie dann auf das letzte Element.
  • Sie können Dateien und Ordner auch mit Hilfe eines Lassos markieren. Klicken Sie dazu mit der linken Maustaste in einen freien Bereich der Listenansicht und ziehen Sie die Markierung um alle Elemente, die Sie markieren möchten. Halten Sie dabei die Umschalt-Taste gedrückt, wenn Sie die Markierung erweitern möchten. Durch gleichzeitiges Halten der Strg-Taste wird die Markierung der betroffenen Elemente umgekehrt.
  • Wenn Sie die Option Markieren mit rechter Maustaste aktiviert haben, können Sie mit der rechten Maustaste Dateien und Ordner auswählen. Klicken Sie dazu mit der rechten Maustaste auf das Element, welches Sie aus bzw. abwählen möchten. Zum Auswählen von aufeinanderfolgenden Dateien und Ordner klicken Sie mit der rechten Maustaste auf das erste Element und ziehen Sie die Maus bei gedrückter rechter Maustaste über die zu markierenden Elemente. Wurde das erste Element markiert, dann werden auch alle folgenden Elemente markiert. Ist das erste Element bereits markiert, dann wird es inklusive aller anderen Elemente demarkiert.
  • Um beim Markierungsmodus mit der rechten Maustaste das Kontextmenü anzuzeigen, halten Sie die rechte Maustaste etwas länger gedrückt. Eine Drag & Drop-Aktion wird gestartet, wenn während des Klicks mit der rechten Maustaste zusätzlich die Umschalt-Taste gehalten wird.
Markieren von Dateien und Ordnern mit der Tastatur
  • Der Auswahlbalken zum Auswählen von Dateien und Ordnern wird mit Hilfe der Cursortasten gesteuert. Halten Sie die Umschalt-Taste gedrückt, um eine zusammenhängende Gruppe von Dateien und Ordnern zu markieren. Durch Drücken der Strg-Taste wird der Auswahlbalken bewegt, ohne die bereits bestehende Auswahl zu ändern. Drücken Sie bei gehaltener Strg-Taste die Leer-Taste, um das Element unter dem Auswahlbalken aus- oder abzuwählen.
Markieren von Dateien und Ordnern mit der Tastatur (NC-Auswahlmodus)
  • Auch im NC-Auswahlmodus wird der Auswahlbalken mit Hilfe der Cursortasten gesteuert. er markiert aber keine Elemente und ändert auch nichts an einer bestehenden Auswahl. Durch gleichzeitiges Halten der Umschalt-Taste können zusammenhängende Dateien und Ordner ausgewählt werden.
  • Mit Hilfe der Leer-Taste wird ein Element aus- bzw. wieder abgewählt. Mit der Einfg-Taste wird der Auswahlstatus eines Elements ebenfalls geändert, zudem wird der Auswahlbalken auf den nächsten Eintrag gesetzt. Durch Aktivieren der Option 'Leer' setzt den Auswahlbalken auf den nächsten Eintrag (wie 'Einfg') lässt sich auch mit der Leer-Taste der Auswahlbalken auf den nächsten Eintrag setzen.
Auswahl von Dateien und Ordnern erweitern
  1. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Einige auswählen.
  2. Geben Sie im angezeigten Dialogfeld Auswahl erweitern an, welche Dateien Sie auswählen wollen. Um z.B. alle Dateien mit der Endung .exe auszuwählen, geben Sie *.exe ein. Geben Sie *.* ein, um alle im Fenster angezeigten Dateien auszuwählen.
  3. Drücken Sie Eingabe. Alle Dateien mit der Endung .exe werden markiert.
  4. Wenn Sie auch Ordner in die Auswahl mit aufnehmen möchten, aktivieren Sie im Menü Bearbeiten oder im Auswahldialog die Option Ordner in Auswahl einbeziehen. Nun werden neben Dateien auch Ordner mit in die Auswahl aufgenommen.
Auswahl von Dateien und Ordnern reduzieren
  1. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Einige abwählen.
  2. Geben Sie im angezeigten Dialogfeld Auswahl reduzieren an, für welche Dateien Sie die Auswahl aufheben wollen. Um z.B. die Auswahl für alle Dateien mit der Dateierweiterung .exe aufzuheben, geben Sie *.exe ein. Geben Sie *.* ein, um alle im Fenster angezeigten Dateien abzuwählen.
  3. Drücken Sie Eingabe. Die Auswahl alle Dateien mit der Dateierweiterung .exe wird aufgehoben.
  4. Wenn Sie auch die Auswahl von Ordnern entfernen möchten, aktivieren Sie im Menü Bearbeiten oder im Auswahldialog die Option Ordner in Auswahl einbeziehen. Nun werden neben Dateien auch Ordner abgewählt.
Dateityp unter dem Auswahlbalken auswählen
  1. Klicken Sie im Ordnerfenster auf eine Datei, deren Dateityp Sie auswählen möchten.
  2. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Dateityp unter Cursor auswählen.
Umkehrung der aktuellen Auswahl
  1. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Auswahl umkehren.
  2. Ihre Auswahl ist nun umgekehrt: Die Auswahl aller vorher ausgewählten Elemente ist rückgängig gemacht, und die vorher nicht ausgewählten Elemente sind ausgewählt.
Wiederherstellung der vorherigen Auswahl
  1. Aktivieren Sie das Menü Bearbeiten, zeigen Sie auf Auswählen und wählen Sie den Befehl Auswahl wiederherstellen.
  2. Nun sind alle Elemente markiert, die vor der Dateioperation ausgewählt waren.


Dateien und Ordner kopieren

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner kopieren

Mit SpeedCommander können Sie Dateien und Ordner an eine andere Stelle der Festplatte, des Netzwerks oder auf eine Diskette kopieren.

So kopieren Sie Dateien und Ordner:
  1. Wählen Sie die gewünschten Dateien und Order aus.
  2. Wählen Sie im Menü Datei den Befehl Kopieren oder klicken Sie in der Symbolleiste auf das Symbol Kopieren.
  3. Der Ordner im anderen Fenster wird im Dialogfeld Kopieren angezeigt. Um schnell eine andere Zieladresse zu finden, können Sie auf Suchen klicken.
  4. Wenn Sie nur neuere Dateien kopieren möchten, aktivieren Sie das Kontrollkästchen Nur neuere Dateien kopieren.
  5. Existiert im Zielverzeichnis bereits eine Datei gleichen Namens, so fragt SpeedCommander vor dem Überschreiben nach, ob die Datei ersetzt werden soll. Bei Aktivierung des Kontrollkästchens Dateien automatisch umbenennen wird der Dateiname ohne Nachfrage automatisch auf Dateiname [1].ext geändert.
  6. Mit Hilfe des Kontrollkästchens Dateiattribut 'Schreibgeschützt' entfernen wird das Schreibgeschützt-Attribut bei der Zieldatei entfernt. Dies ist zweckmäßig beim Kopieren von CD-ROM.
  7. Aktivieren Sie das Kontrollkästchen Sicherheitsattribute übernehmen (NTFS), wenn auch die Sicherheitsattribute der Datei kopiert werden sollen.
  8. Durch Aktivierung des Kontrollkästchens Alle Dateien ohne Nachfrage überschreiben verhindern Sie die Anzeige eines Warndialoges, falls die Zieldatei bereits existiert. Dies ist zweckmäßig, wenn Sie während des Kopiervorgangs nicht am PC sitzen.
  9. Drücken Sie Eingabe oder wählen Sie OK.

Kopieren von Hardlinks

SpeedCommander prüft beim Kopieren einer Datei, ob es sich um einen Hardlink zu einer bereits kopierten Datei handelt. Wenn ja, dann erstellt SpeedCommander im Zielordner ebenfalls einen Hardlink zum Ziel der bereits kopierten Datei, sofern das Zielsystem die Erstellung von Hardlinks ermöglicht.

Tipps

  • Sie können den Dateinamen der zu kopierenden Dateien auch ändern. Tragen Sie z.B. im Eingabefeld Nach das Ziel D:\*.txt ein, um die Dateien beim Kopieren gleich nach *.txt umzubenennen.
  • Mit Hilfe von Ziehen & Ablegen können Sie die ausgewählten Dateien und Ordner kopieren, indem Sie diese auf das andere Ordnerfenster, auf den Windows-Desktop oder in ein anderes Fenster ziehen.
  • Sie können auch einen Filter angeben. Es werden dann nur Dateien kopiert, die der Filtereigenschaft entsprechen.
  • Wenn Sie eine Schriftart-Datei in den Systemordner 'Schriftarten' kopieren, dann wird die Schriftart automatisch registriert.

Weitere Informationen

Dateien und Ordner auswählen

Dateifilter einrichten


Dateien und Ordner verschieben

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner verschieben

Mit SpeedCommander können Sie Dateien und Ordner an eine andere Stelle der Festplatte, des Netzwerks oder auf eine Diskette verschieben.

So verschieben Sie Dateien und Ordner:
  1. Wählen Sie die gewünschten Dateien und Order aus.
  2. Wählen Sie im Menü Datei den Befehl Verschieben oder klicken Sie in der Symbolleiste auf das Symbol Verschieben.
  3. Der Ordner im anderen Fenster wird im Dialogfeld Verschieben angezeigt. Um schnell eine andere Zieladresse zu finden, können Sie auf Suchen klicken.
  4. Wenn Sie nur neuere Dateien verschieben möchten, aktivieren Sie das Kontrollkästchen Nur neuere Dateien kopieren.
  5. Existiert im Zielverzeichnis bereits eine Datei gleichen Namens, so fragt SpeedCommander vor dem Überschreiben nach, ob die Datei ersetzt werden soll. Bei Aktivierung des Kontrollkästchens Dateien automatisch umbenennen wird der Dateiname ohne Nachfrage automatisch auf Dateiname [1].ext geändert.
  6. Mit Hilfe des Kontrollkästchens Dateiattribut 'Schreibgeschützt' entfernen wird das Schreibgeschützt-Attribut bei der Zieldatei entfernt.
  7. Aktivieren Sie das Kontrollkästchen Sicherheitsattribute übernehmen (NTFS), wenn auch die Sicherheitsattribute der Datei kopiert werden sollen.
  8. Durch Aktivierung des Kontrollkästchens Alle Dateien ohne Nachfrage überschreiben verhindern Sie die Anzeige eines Warndialoges, falls die Zieldatei bereits existiert. Dies ist zweckmäßig, wenn Sie während des Kopiervorgangs nicht am PC sitzen.
  9. Drücken Sie Eingabe oder wählen Sie OK.
Tipps
  • Sie können den Dateinamen der zu verschiebenden Dateien auch ändern. Tragen Sie z.B. im Eingabefeld Nach das Ziel D:\*.txt ein, um die Dateien beim Verschieben gleich nach *.txt umzubenennen.
  • Mit Hilfe von Ziehen & Ablegen können Sie die ausgewählten Dateien und Ordner verschieben, indem Sie diese auf das andere Ordnerfenster, auf den Windows-Desktop oder in ein anderes Fenster ziehen und dabei die Umschalt-Taste drücken.
  • Sie können auch einen Filter angeben. Es werden dann nur Dateien verschoben, die der Filtereigenschaft entsprechen.

Weitere Informationen

Dateien und Ordner auswählen

Dateifilter einrichten


Dateien und Ordner löschen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner löschen

Sie können Dateien und Ordner aus dem aktuellen Laufwerk löschen, in den Papierkorb verschieben oder auch sicher löschen. Trifft SpeedCommander beim Löschen eines Ordners auf eine Abzweigung, dann wird nur die Abzweigung gelöscht und nicht der Inhalt des Ordners, auf den die Abzweigung verweist.

So löschen Sie Dateien und Ordner:
  1. Wählen Sie die gewünschten Dateien und Ordner aus.
  2. Wählen Sie im Menü Datei den Befehl Löschen oder klicken Sie in der Symbolleiste auf das Symbol Löschen.
  3. Drücken Sie Eingabe oder wählen Sie Ja.
So löschen Sie Dateien und Ordner in den Papierkorb:
  1. Wählen Sie die gewünschten Dateien und Ordner aus.
  2. Wählen Sie im Menü Datei den Befehl Löschen in den Papierkorb oder klicken Sie in der Symbolleiste auf das Symbol Löschen in den Papierkorb.
  3. Drücken Sie Eingabe oder wählen Sie Ja.
So löschen Sie sicher nach Regierungsrichtlinien:
  1. Wählen Sie die gewünschten Dateien und Ordner aus.
  2. Wählen Sie im Menü Datei den Befehl Sicheres Löschen.
  3. Klicken Sie auf Schnelles Löschen, wenn die Dateien mit einem Wert überschrieben werden sollen.
  4. Klicken Sie auf Löschen nach Regierungsrichtlinien, wenn die Dateien mehrmals überschrieben werden sollen.
  5. Geben Sie an, wie oft der Löschvorgang wiederholt werden soll.
  6. Drücken Sie Eingabe oder wählen Sie Ja.

Weitere Informationen

Dateien und Ordner auswählen


Dateien und Ordner umbenennen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner umbenennen

Sie können Dateien und Ordner direkt in der Dateiliste umbenennen.

So benennen Sie eine Datei oder einen Ordner um:
  1. Markieren Sie die gewünschte Datei oder den Ordner.
  2. Wählen Sie im Menü Datei den Befehl Umbenennen oder drücken Sie F9.
  3. Geben Sie den neuen Namen ein und drücken Sie Eingabe.
So benennen Sie Dateien und Ordner mit Hilfe der Maus um:
  1. Klicken Sie mit der rechten Maustaste auf die Datei oder den Ordner, die/den sie umbenennen möchten.
  2. Wählen Sie im Kontextmenü den Befehl Umbenennen.
  3. Geben Sie den neuen Namen ein und drücken Sie Eingabe.
Tipps
  • Mit F9 (oder dem angepassten Tastenkürzel für den Befehl Datei - Umbenennen) kann während des Bearbeitungsvorgangs der Dateiname, die Erweiterung oder der gesamte Text markiert werden.
  • Während des Editiervorgangs kann mit Tab automatisch zur nächsten Datei gewechselt werden.
  • Sie können im Einstellungsdialog auf der Seite Erweitert - Verschiedenes festlegen, ob bei der Anzeige des Editierfeldes der Dateiname, die Erweiterung oder der gesamte Text markiert werden soll.

Weitere Informationen

Dateien und Ordner auswählen


Dateien und Ordner suchen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien und Ordner suchen

Auf einer großen Festplatte mit zahlreichen Ordnern kommt es leicht vor, dass Sie eine Datei "verlegen". Sie haben vielleicht den Dateinamen vergessen oder Sie wissen nicht mehr, in welchem Ordner Sie die Datei abgelegt haben. Mit dem Befehl Suchen aus dem Menü Datei können Sie die Datei leicht wiederfinden und außerdem nach einer Gruppe von Dateien suchen.

SpeedCommander verwendet zur Suche das Programm FileSearch, welches zum Lieferumfang von SpeedCommander gehört. Mit Hilfe von FileSearch können Sie nach Dateien suchen, die einen bestimmten Namen haben, eine bestimmte Größe haben oder innerhalb eines bestimmten Zeitraums liegen. Sie können nach Textvorkommen suchen und sich die Suchstellen anzeigen lassen. FileSearch kann auch Archivdateien nach bestimmten Textvorkommen zu durchsuchen.

FileSearch ist ebenfalls dazu in der Lage, doppelte Dateien zu finden. Oftmals ist es so, dass ein und dieselbe Datei an verschiedenen Orten gespeichert ist und so auf dem Datenträger viel Platz verschwendet wird. Das Auffinden von doppelten Dateien ist ohne Hilfsmittel nur sehr schwer möglich. FileSearch bietet Ihnen hier die Möglichkeit, doppelte Dateien nach verschiedenen Kriterien zu suchen:

  • Gleicher Name
  • Gleiche Größe
  • Gleicher Dateiinhalt

Weitere Informationen

FileSearch

Zusätzliche Programme einrichten


Dateien anzeigen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien anzeigen

SpeedCommander verwendet zur Anzeige von Dateien das Programm SpeedView, welches zum Lieferumfang von SpeedCommander gehört. Mit SpeedView können Sie Dateien der gängigen Textverarbeitungs- und Grafikprogramme anzeigen, ohne die Anwendung starten zu müssen, mit der sie erstellt wurde.

So zeigen Sie eine Datei an:
  1. Markieren Sie die Dateien, die Sie anzeigen möchten.
  2. Wählen Sie im Menü Datei den Befehl Betrachten oder klicken Sie in der Symbolleiste auf das Symbol Betrachten.
  3. Der Dateibetrachter wird gestartet und zeigt die Datei an.

Weitere Informationen

SpeedView

Dateien und Ordner auswählen

Zusätzliche Programme einrichten


Dateien bearbeiten

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien bearbeiten

Sie können mit SpeedCommander auch Textdateien bearbeiten. SpeedCommander verwendet dazu das Pogramm SpeedEdit, welches zum Lieferumfang von SpeedCommander gehört.

So bearbeiten Sie eine Datei an:
  1. Markieren Sie die Datei, die Sie bearbeiten möchten.
  2. Wählen Sie im Menü Datei den Befehl Editieren oder klicken Sie in der Symbolleiste auf das Symbol Editieren.
  3. Der Dateibearbeiter wird gestartet und zeigt die Datei an.

Weitere Informationen

SpeedEdit

Dateien und Ordner auswählen

Zusätzliche Programme einrichten


Dateien trennen und zusammenführen von Dateien

SpeedCommander: Arbeiten mit Dateien und Ordnern
Dateien trennen und zusammenführen

Sie werden oft feststellen, dass manche Dateien zu groß sind, um sie auf eine Diskette zu kopieren. Mit Hilfe der Funktion Trennen können Sie die Datei in mehrere Segmente trennen, diese dann auf Disketten kopieren und zu einem späteren Zeitpunkt wieder zusammenzuführen. Um Diskettenplatz zu sparen, wird die zu teilende Datei komprimiert. Zusätzlich können Sie die aufgeteilte Datei mit einem Kennwort schützen, das Zusammenführen ist dann nur unter Angabe dieses Kennwortes möglich.

So trennen Sie eine Datei:
  1. Wählen Sie die zu trennende Datei.
  2. Wählen Sie im Menü Datei den Befehl Trennen oder klicken Sie in der Symbolleiste auf das Symbol Trennen.
  3. Geben Sie im Dialogfeld Trennen einen Namen für die getrennte Datei an.
  4. Wählen Sie das Zielsystem, unter dem Sie die Datei später wieder zusammenfügen möchten.
  5. Wählen Sie die Größe der Segmente.
  6. Drücken Sie Eingabe oder klicken Sie auf OK.

Für das Zusammenführen von Dateien werden keinerlei Hilfsprogramme benötigt, auch SpeedCommander ist dazu nicht erforderlich. Im ersten Segment der geteilten Datei ist ein kleines Programm enthalten, das die erforderlichen Arbeiten selbstständig durchführt.

So führen Sie getrennte Dateien zusammen:
  1. Wählen Sie das erste Segment der aufgeteilten Datei.
  2. Drücken Sie Eingabe oder doppelklicken Sie auf den Eintrag.
  3. Die einzelnen Segmente werden nun automatisch zu einer Datei zusammengeführt.

Wichtiger Hinweis

Wenn Sie beim Trennen der Datei ein Kennwort angegeben haben, müssen Sie es zum Zusammenführen erneut eingeben. Wenn Sie das Kennwort nicht kennen, können Sie die Dateien nicht zusammenführen.


Ordner erstellen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Ordner erstellen

Sie können an einer beliebigen Stelle auf Ihrem Laufwerk einen neuen Ordner erstellen.

So erstellen Sie einen Ordner:
  1. Wählen Sie im Menü Ordner den Befehl Ordner erstellen.
  2. Geben Sie im darauf erscheinenden Eingabefeld den Namen des zu erstellenden Ordners ein.
  3. Drücken Sie Eingabe.


Ordner vergleichen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Ordner vergleichen

Oft ist es sinnvoll, die Dateien in einem Ordner zu vergleichen, bevor Sie diese kopieren oder löschen. So können Sie feststellen, welche Dateien Sie behalten wollen.

So vergleichen Sie Ordner:
  1. Wechseln Sie im linken und rechten Ordnerfenster in die Ordner, die Sie vergleichen wollen.
  2. Wählen Sie im Menü Ordner den Befehl Ordner vergleichen oder klicken Sie in der Symbolleiste auf das Symbol Ordner vergleichen.
  3. Wählen Sie im Dialogfeld Ordner vergleichen die Kriterien aus, nach denen verglichen werden soll.
  4. Wählen Sie aus, welche Dateien SpeedCommander nach dem Vergleich markieren soll.
  5. Drücken Sie Eingabe oder klicken Sie auf OK.


Ordnergrößen ermitteln

SpeedCommander: Arbeiten mit Dateien und Ordnern
Ordnergrößen ermitteln

Mit diesem Befehl lässt sich der Speicherbedarf aller Ordner innerhalb des aktiven Ordners ermitteln. Die Größe der vorhandenen Ordner wird im Ordnerfenster in der Spalte Größe angezeigt. Diese Funktion ist nützlich, wenn zum Zweck eines Kopiervorgangs geprüft werden soll, wie viel Platz bestimmte Ordner auf dem Datenträger belegen. Die Anzeige der ermittelten Ordnergrößen wird wieder gelöscht, wenn auf eine über- oder untergeordnete Ordnerebene gewechselt wird.

Zusätzlich zur Berechnung der Größe kann in der Spalte Dateien auch die Gesamtanzahl aller Dateien unterhalb eines Ordner angezeigt werden.

So ermitteln Sie die Ordnergrößen:
  1. Wählen Sie im Menü Ansicht den Befehl Details, um die Detailansicht für das aktive Ordnerfenster einzuschalten.
  2. Wählen Sie im Menü Ordner den Befehl Ordnergrößen ermitteln oder klicken Sie in der Symbolleiste auf das Symbol Ordnergrößen ermitteln.

SpeedCommander kann die Ordnergrößen auch automatisch im Hintergrund berechnen. Diese Funktion kann im Einstellungsdialog auf der Seite Ordnergrößen aktiviert werden. Während der Berechnung der Ordnergrößen zeigt SpeedCommander ein visuelles Feedback der aktuellen Operation:

Symbol | Bedeutung
[.o|o.] | Die Ordnergrößen werden gerade berechnet.
[xxxx] | Für diesen Ordner sollen keine Ordnergrößen berechnet werden.
[----] | Die Ordnergrößen müssen noch berechnet werden.


Ordnerlisten drucken

SpeedCommander: Arbeiten mit Dateien und Ordnern
Ordnerlisten drucken

Für Archivierungszwecke ist es manchmal erforderlich, sich einen genauen Überblick über die auf einem Datenträger oder in einem Ordner befindlichen Dateien zu machen. SpeedCommander bietet Ihnen die Möglichkeit, eine übersichtliche und formatierte Liste mit allen Dateien eines Ordners zu erstellen und auszudrucken.

So drucken Sie eine Ordnerliste aus:
  1. Wechseln Sie in den Ordner, dessen Inhalt Sie ausdrucken möchten.
  2. Wählen Sie im Menü Ordner den Befehl Ordnerliste drucken.
  3. Geben Sie im darauf erscheinenden Dialog an, ob Sie nur den aktuellen Ordner oder auch alle untergeordneten Ordner ausdrucken möchten.


Mehrere Dateien umbenennen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Mehrere Dateien umbenennen

Die Funktion Mehrfaches Umbenennen ist ein leistungsfähiges Werkzeug, mit dem ganze Dateilisten in einem einzigen Arbeitsgang nach bestimmten Kriterien umbenannt werden können.

Es gibt ingesamt neun verschiedene Platzhalter, die ganz individuell zum Umbenennen von Dateien kombiniert werden können. Jeder Platzhalter außer dem Platzhalter [s] kann noch weitere Argumente enthalten, welche die Eigenschaften eines Platzhalters weiter beeinflussen. Neben den Platzhaltern gibt es weitere Optionen, mit denen die Schreibweise der Dateinamen beeinflusst werden kann.

Dateinamen und -erweiterung

Die Platzhalter [p], [n] und [e] stehen für einen übergeordneten Ordner, den Dateinamen und der Dateierweiterung. Jeder der vorgenannten Platzhalter kann weitere Argumente für Index und Länge enthalten. Index ist das Zeichen, ab dem aus dem alten Ordner, dem Dateinamen oder der Dateierweiterung die Zeichen in den neuen Namen eingefügt werden sollen. Länge gibt die maximale Anzahl der Zeichen an, die übernommen werden sollen.

Dateiname | Platzhalter | Neuer Dateiname | Erklärung
Urlaubsbild | [n] | Urlaubsbild | Es werden alle Zeichen übernommen.
Urlaubsbild | [n,1,6] | Urlaub | Es werden die ersten sechs Zeichen übernommen.
Urlaubsbild | [n,-1,4] | bild | Es werden die letzten vier Zeichen übernommen.
Urlaubsbild | [n,-7,2] | au | Es werden zwei Zeichen ab dem siebten Zeichen (gezählt vom Ende des Namens) übernommen.

Zähler

Der Platzhalter [c] steht für einen Zähler, mit dem Dateien z.B. durchnummeriert werden könnten. Dieser Platzhalter kann weitere Argumente wie Startwert, Schrittweite und Mindestbreite (in Zeichen) enthalten. Als Startwert sind 0 - 9 bzw. ein numerischer Wert, a - z und A - Z möglich. Als Schrittweite und Mindestbreite sind nur numerische Werte möglich.

In folgenden Beispiel gibt Wert 1 den Zählerwert für die erste Datei an, entsprechend gibt Wert 2 den Zählerwert für die zweite Datei an. Man könnte die Liste hier beliebig weiterführen:

Dateiname | Wert 1 | Wert 2 | Erklärung
[c] | 1 | 2 | Startwert und Schrittweite sind 1, für jede Datei wird der Zähler um 1 erhöht.
[c,2,2] | 2 | 4 | Startwert und Schrittweite sind 2, für jede Datei wird der Zähler um 2 erhöht.
[c,2,2,3] | 002 | 004 | Startwert und Schrittweite sind 2, für jede Datei wird der Zähler um 2 erhöht. Da die Mindestbreite für den Zähler drei ist, wird der Wert von links mit Nullen aufgefüllt.
[c,a,1] | a | b | Startwert ist a, Schrittweite ist 1, für jede Datei wird der Zähler um 1 erhöht.
[c,a,2,3] | aaa | aac | Startwert ist a, Schrittweite ist 2, für jede Datei wird der Zähler um 2 erhöht. Da die Mindestbreite für den Zähler drei ist, wird der Wert von links mit a aufgefüllt.

Datums- und Zeitangaben

Der Platzhalter [dt] steht für Datums- und Zeitangaben. Dieser Platzhalter kann mit weiteren Argumenten ganz speziellen Anforderungen angepasst werden. Je nachdem, ob die Option Aktuelle Systemzeit für [dt] benutzen aktiviert ist, wird als aktuelle Zeit entweder der Zeitstempel der jeweiligen Dateien oder die Systemzeit angenommen. Die Argumentliste für [dt] kann folgende Datums- bzw. Zeitangaben enthalten:

Platzhalter | Bedeutung
YYYY | Jahr, vierstellig
YY | Jahr, zweistellig
MMMM | Voller Monatsname, wie z.B. Januar, Februar usw.
MMM | Abgekürzter Monatsname, wie z.B. Jan, Feb usw.
MM | Monat. Monate kleiner als 10 werden mit führender 0 eingefügt
M | Monat. Monate kleiner als 10 werden ohne führende 0 eingefügt
DDDD | Voller Wochentag, wie z.B. Montag, Dienstag usw.
DDD | Abgekürzter Wochentag, wie z.B. Mon, Di usw.
DD | Tag des Monats. Tage kleiner als 10 werden mit führender 0 eingefügt
D | Tag des Monats. Tage kleiner als 10 werden ohne führende 0 eingefügt
hh | Stunde. Stunden kleiner als 10 werden mit führender 0 eingefügt
h | Stunde. Stunden kleiner als 10 werden ohne führende 0 eingefügt
mm | Minute. Minuten kleiner als 10 werden mit führender 0 eingefügt
m | Minute. Minuten kleiner als 10 werden ohne führende 0 eingefügt
ss | Sekunde. Sekunden kleiner als 10 werden mit führender 0 eingefügt
s | Sekunde. Sekunden kleiner als 10 werden ohne führende 0 eingefügt
oo | Tag des Jahres, wie z.B. 1, 2, 3 usw. Tage kleiner 10 werden mit zwei führenden Nullen erweitert, Tage kleiner als 100 werden mit einer führenden Null erweitert.
o | Tag des Jahres, wie z.B. 1, 2, 3 usw.
SS | Vordefinierte Maske: YYYY-MM-DD-hh-mm-ss
S | Vordefinierte Maske: YYYYMMDDhhmmss
U | Vordefinierte Maske: MM-DD-YYYY
E | Vordefinierte Maske: DD-MM-YYYY

Bitte beachten Sie unbedingt die Schreibweise in den einzelnen Argumenten, SS hat eine andere Bedeutung als ss. Die Argumentliste kann neben den oben aufgeführten Zeichen auch weitere Zeichen enthalten. Diese werden dann unverändert in den Dateinamen bzw. die Dateierweiterung übernommen. Wird [dt] ohne Argumente angegeben, so werden Datumsangaben als YYYY-MM-DD formatiert.

Dateiname | Zeitstempel | Anweisung | Neuer Dateiname
Backup.sqx | 05.05.2002, 23:41:30 | [n]_[dt,E].[e] | Backup_05-05-2002.sqx
Urlaubsbild.bmp | 10.08.2002, 02:29:00 | [n] vom [dt,DDDD, DD.MM.YYYY].[e] | Urlaubsbild vom Samstag, 10.08.2002.bmp

Gesamtanzahl der Dateien

Der Platzhalter [mi] steht für einen Zähler, der die Gesamtanzahl der markierten Dateien angibt. Dieser Platzhalter kann als weiteres Argument die Mindestbreite (in Zeichen) enthalten. Wären z.B. die Dateien text1.txt, text2.txt, text3.txt und text4.txt markiert, dann würde der Platzhalter [mi] beim Umbenennen durch 4 ersetzt werden, weil vier Dateien markiert sind.

Dateiname | Anweisung | Neuer Dateiname
Bild1.bmp | Bild, Teil [c] von [mi].[e] | Bild, Teil 1 von 4.bmp
Bild2.bmp |  | Bild, Teil 2 von 4.bmp
Bild3.bmp |  | Bild, Teil 3 von 4.bmp
Bild4.bmp |  | Bild, Teil 4von 4.bmp

Großschreibung für einzelne Zeichen

Der Platzhalter [u] ist eine Anweisung, um die Schreibweise des Dateinamens ab der aktuellen Position zu beeinflussen. Enthält der Platzhalter [u] keine weiteren Argumente, so wird ab der aktuellen Position der gesamte Dateiname in Großbuchstaben umgewandelt. Die Schreibweise in Großbuchstaben gilt solange, bis der Platzhalter [u] vom Platzhalter [k] oder Platzhalter [s] ersetzt bzw. aufgehoben wird oder für die Anzahl der Zeichen, die dem Platzhalter [u] als Argument übergeben worden ist.

Dateiname | Platzhalter | Neuer Dateiname | Erklärung
Urlaubsbild | [u][n] | URLAUBSBILD | Es werden alle Zeichen übernommen und in Großbuchstaben umgewandelt.
Urlaubsbild | [u,7][n] | URLAUBSbild | Es werden alle Zeichen übernommen. Die ersten sieben Zeichen werden in Großbuchstaben umgewandelt.
Urlaubsbild | [n,1,6][u][n,7] | UrlaubSBILD | Es werden die ersten sechs Zeichen unverändert übernommen. Der Rest der Zeichen wird in Großbuchstaben umgewandelt.
Urlaubsbild | [u][n,-1,4] | BILD | Es werden die letzten vier Zeichen übernommen, alle Zeichen werden in Großbuchstaben umgewandelt.

Kleinschreibung für einzelne Zeichen

Der Platzhalter [k] ist ebenfalls eine Anweisung, um die Schreibweise des Dateinamens ab der aktuellen Position zu beeinflussen. Enthält der Platzhalter [k] keine weiteren Argumente, so wird ab der aktuellen Position der gesamte Dateiname in Kleinbuchstaben umgewandelt. Die Schreibweise in Kleinbuchstaben gilt solange, bis der Platzhalter [k] vom Platzhalter [u] oder Platzhalter [s] ersetzt bzw. aufgehoben wird oder für die Anzahl der Zeichen, die dem Platzhalter [k] als Argument übergeben worden ist.

Dateiname | Platzhalter | Neuer Dateiname | Erklärung
URLAUBSBILD | [k][n] | urlaubsbild | Es werden alle Zeichen übernommen und in Kleinbuchstaben umgewandelt.
URLAUBSBILD | [k,7][n] | urlaubsBILD | Es werden alle Zeichen übernommen. Die ersten sieben Zeichen werden in Kleinbuchstaben umgewandelt.
URLAUBSBILD | [n,1,6][k][n,7] | URLAUBsbild | Es werden die ersten sechs Zeichen unverändert übernommen. Der Rest der Zeichen wird in Kleinbuchstaben umgewandelt.
URLAUBSBILD | [k][n,-1,4] | bild | Es werden die letzten vier Zeichen übernommen, alle Zeichen werden in Kleinbuchstaben umgewandelt.

Der Platzhalter [s] hebt den Platzhalter [u] bzw. den Platzhalter [k] ab der aktuellen Position auf.

Suchen und Ersetzen

Mit Suchen und Ersetzen können verschiedene Teile der Dateinamen ausgetauscht bzw. entfernt werden. Die Zeichenkette, nach der gesucht werden soll, darf die Wildcards * und ? enthalten. Es können mehrere Zeichenketten zum Suchen und Ersetzen auf einmal angegeben werden. Die Zeichenketten müssen jeweils durch das Pipe-Zeichen | voneinander getrennt werden.

Dateiname | Suchen nach | Ersetzen durch | Neuer Dateiname
Urlaubsbild | bild |  | Urlaubs
Urlaubsbild | bi* |  | Urlaubs
Urlaubsbild | bi?? |  | Urlaubs
Urlaubsbild | bild | photo | Urlaubsphoto
Urlaubsbild | bi* | reise | Urlaubsreise

Groß-/Kleinschreibung für den ganzen Namen

Mit der Option Groß-/Kleinschreibung kann die Schreibweise der Dateinamen beeinflusst werden.
Dateiname | Option | Neuer Dateiname
Urlaubsbild.bmp | Keine Änderung | Urlaubsbild.bmp
Urlaubsbild.bmp | Alles groß | URLAUBSBILD.BMP
Urlaubsbild.bmp | Alles klein | urlaubsbild.bmp
Das ist ein Text.txt | Wortanfang groß | Das Ist Ein Text.Txt
urlaubsbild.bmp | Erster Buchstabe groß | Urlaubsbild.bmp
Das ist ein Text.txt | Erstes Wort groß | Das ist ein text.Txt

Hinweis zur Verwendung von eckigen Klammern

Da im Prinzip alle Platzhalter in eckigen Klammern [] stehen, müssen eckige Klammern selbst in eckigen Klammern stehen, wenn sie den Dateinamen hinzugefügt werden sollen.

Dateiname | Platzhalter | Neuer Dateiname | Hinweis
Mein Buch | [n], [Auflage 1] | Fehler! | Die Kombination der Platzhalter und Zeichen ist fehlerhaft!
Mein Buch | [n], [[]Auflage 1[]] | Mein Buch, [Auflage 1] |

Regeln für die Zusammensetzung

Die neuen Dateinamen werden nach den folgenden Regeln zusammengesetzt: Zuerst werden die neuen Dateinamen aus den Platzhaltern [p], [n], [e], [c], [dt], [u], [k] und [s] gebildet. Danach wird überprüft, ob entsprechend der Parameter Suchen nach und Ersetzen durch Teile der Dateinamen ersetzt werden müssen. Ganz zum Schluss wird entsprechend der Option Groß-/Kleinschreibung die Schreibweise unabhängig von den Platzhaltern [u] und [k] angepasst.

So benennen Sie mehrere Dateien um:
  1. Wählen Sie die gewünschten Dateien und Ordner aus.
  2. Wählen Sie im Menü Datei den Befehl Mehrfaches Umbenennen, der Dialog Mehrfaches Umbenennen erscheint.
  3. Setzen Sie mit Hilfe der Platzhalter die neuen Dateinamen zusammen.
  4. Drücken Sie Eingabe, oder wählen Sie Umbenennen.
  5. Wenn Sie die zuletzt durchgeführte Umbenenn-Aktion wieder rückgängig machen möchten, dann wählen Sie Rückgängig.

Weitere Informationen

Dateien und Ordner auswählen


Zeitstempel und Attribute ändern

SpeedCommander: Arbeiten mit Dateien und Ordnern
Zeitstempel und Attribute ändern

Alle Dateien auf Ihrer Festplatte haben bestimmte Dateiattribute. Die Attribute geben an, ob eine Datei nur gelesen werden darf, ob sie versteckt ist, ob sie archiviert werden soll, oder ob sie eine Systemdatei ist. Der Zeitstempel einer Datei zeigt an, wann sie erstellt oder zum letzten Mal bearbeitet wurde. Mit SpeedCommander können Sie diese Informationen für eine Datei, eine Gruppe von Dateien oder sogar für gesamte Ordner ändern.

So ändern Sie die Dateiattribute und den Zeitstempel für Dateien und Ordner:
  1. Wählen Sie die Dateien und Ordner aus.
  2. Wählen Sie im Menü Datei den Befehl Mehr Eigenschaften.
  3. Stellen Sie den gewünschten Zeitstempel ein. Sie können die Zeit der Erstellung, die Zeit des letzten Zugriffs oder die Zeit des letzten Schreibzugriffes setzen.
  4. Sie können für die ausgewählten Dateien und Ordner Attribute setzen oder löschen. Wählen Sie die gewünschten Attribute aus.
  5. Markieren Sie das Kontrollkästchen Dateien in Unterordnern einschließen, wenn Sie die Dateien in den ausgewählten Unterordnern ändern möchten.
  6. Drücken Sie Eingabe oder klicken Sie auf OK.


Abzweigungen, Hardlinks und symbolische Links erstellen

SpeedCommander: Arbeiten mit Dateien und Ordnern
Abzweigungen, Hardlinks und symbolische Links erstellen

SpeedCommander erleichtert das Erstellen von Abzweigungen, symbolischen Links und Hardlinks. Abzweigungen und Hardlinks lassen sich auf jedem NTFS-Datenträger erstellen. Die Verwendung von symbolischen Links wird erst ab Windows Vista unterstützt.

Abzweigungen können nur für Ordner erstellt werden, während Hardlinks nur für Dateien erstellt werden können. Symbolische Links können für Dateien und Ordner erstellt werden, allerdings ist hierfür die Berechtigung Create Symbolic Link erforderlich. Diese steht normalerweise nur Administratoren zur Verfügung. Sie müssen daher bei der Erstellung von symbolischen Links über Administratorrechte verfügen, andernfalls erscheint eine Bestätigungsmeldung der Benutzerkontensteuerung.

Hardlinks können nur auf dem gleichen Datenträger bzw. der gleichen Partition erstellt werden, während Abzweigungen und symbolische Links datenträgerübergreifend verwendet werden können.

So erstellen Sie eine neue Abzweigung:
  1. Markieren Sie den Ordner, zu dem die Abzweigung führen soll.
  2. Öffnen Sie das Menü Bearbeiten, zeigen Sie auf Verbindungen und wählen Sie den Befehl Linkquelle auswählen.
  3. Wechseln Sie in den Ordner, in dem die Abzweigung erstellt werden soll.
  4. Öffnen Sie das Menü Bearbeiten, zeigen Sie auf Verbindungen und wählen Sie den Befehl Abzweigung erstellen.
So erstellen Sie einen neuen Hardlink:
  1. Markieren Sie die Dateien, für welche Sie die Hardlinks erstellen möchten.
  2. Öffnen Sie das Menü Bearbeiten, zeigen Sie auf Verbindungen und wählen Sie den Befehl Linkquelle auswählen.
  3. Wechseln Sie in den Ordner, in dem die Hardlinks eingefügt werden sollen.
  4. Öffnen Sie das Menü Bearbeiten, zeigen Sie auf Verbindungen und wählen Sie den Befehl Hardlink erstellen.
So erstellen Sie einen neuen symbolischen Link:
  1. Markieren Sie die Ordner und/oder Dateien, für welche Sie die symbolischen Links erstellen möchten.
  2. Öffnen Sie das Menü Bearbeiten, zeigen Sie auf Verbindungen und wählen Sie den Befehl Linkquelle auswählen.
  3. Wechseln Sie in den Ordner, in dem die symbolischen Links erstellt werden sollen.
  4. Öffnen Sie das Menü Bearbeiten, zeigen Sie auf Verbindungen und wählen Sie den Befehl Symbolischen Link erstellen.
So löschen Sie eine Verbindung:
  1. Markieren Sie die Verbindung, die Sie löschen möchten.
  2. Wählen Sie im Menü Datei den Befehl Löschen.


Arbeiten mit Archiven

SpeedCommander: Arbeiten mit Archiven
Überblick

SpeedCommander macht die Arbeit mit komprimierten Dateien einfach, da sie wie Ordner behandelt werden. Er bietet direkte Unterstützung für eine Vielzahl von Archivformaten, so dass Sie die wichtigsten Formate in SpeedCommander ohne externe Programme verarbeiten können.

So öffnen Sie eine Archivdatei:
  1. Wählen Sie die Archivdatei in der Dateiliste aus.
  2. Doppelklicken Sie auf die Datei oder drücken Sie Eingabe.
  3. Eine Liste der in der Archivdatei enthaltenen Dateien und Ordner wird angezeigt. Die Liste können Sie genauso wie ein anderes Ordnerfenster verwenden.
  4. Wenn Sie aus dem Inhalt einer Archivdatei eine Datei auswählen und kopieren, wird sie vor dem Kopieren automatisch dekomprimiert.

Weitere Themen

Archiv erstellen

Archiv entpacken

Multivolume-Archiv erstellen

Integrität prüfen

Kommentare vergeben

Reparaturdaten verwenden

Kompressionsprofile verwenden

Selbstentpackendes Archiv erstellen


Archiv erstellen

SpeedCommander: Arbeiten mit Archiven
Archiv erstellen

Komprimierte Dateien sparen Festplattenspeicher, da sie sehr viel weniger Platz einnehmen als nicht komprimierte Dateien. Wenn Sie mit den Dateien wieder arbeiten wollen, entpacken Sie diese einfach wieder.

So erstellen Sie ein neues Archiv:
  1. Markieren Sie die Dateien und Ordner, welche Sie komprimieren möchten.
  2. Wählen Sie im Menü Datei den Befehl Komprimieren oder klicken Sie in der Symbolleiste auf das Symbol Komprimieren.
  3. Geben Sie im Dialogfeld Komprimieren im Eingabefeld Name einen Namen für die komprimierte Datei an.
  4. Wählen Sie das gewünschte Format und im Kombinationsfeld Typ die Einstellung Normales Archiv.
  5. Aktivieren Sie das Kontrollkästchen Ordnerstruktur beibehalten, wenn die Dateien im Archiv in der gleichen Struktur abgelegt werden sollen wie im Quellverzeichnis.
  6. Aktivieren Sie das Kontrollkästchen Untergeordnete Ordner einbeziehen, wenn Sie auch alle untergeordneten Dateien und Ordner komprimieren möchten.
  7. Die Einstellung Separates Archiv für jede Datei erstellen legt fest, dass jede Datei in einem einzelnen Archiv abgelegt werden soll. Sie kann nur bei der Erstellung von normalen Archiven aktiviert werden.
  8. Wählen Sie im Kombinationsfeld Methode eine Verschlüsselungsmethode, wenn Sie die Dateien im Archiv verschlüsseln möchten. Geben Sie im Eingabefeld Kennwort das Kennwort für die Dateiverschlüsselung an. Möchten Sie auch das Inhaltsverzeichnis des Archivs schützen, dann tragen Sie im Eingabefeld Verzeichnis das entsprechende Kennwort ein.
  9. Klicken Sie auf die Schaltfläche Optionen, um weitere Komprimierungseinstellungen anzupassen.
  10. Schließen Sie das Dialogfeld Komprimieren mit OK, um das Archiv zu erstellen.
So fügen Sie einer komprimierten Datei weitere Dateien hinzu:
  1. Öffnen Sie die komprimierte Datei zur Anzeige in einem Ordnerfenster. Die darin enthaltenen Dateien werden aufgelistet.
  2. Wählen Sie im anderen Ordnerfenster die Dateien aus, die Sie der komprimierten Datei hinzufügen wollen.
  3. Sie können die Dateien in das Ordnerfenster mit der komprimierten Datei kopieren, indem Sie den Befehl Kopieren aus dem Menü Datei wählen.

Erweiterte Möglichkeiten für ZIP und SQX

Bei Verwendung der Archivformate ZIP und SQX können weitere Einstellungen aktiviert werden. Klicken Sie im Dialogfeld Komprimieren auf die Schaltfläche Optionen und wählen Sie im Dialogfeld Komprimierungseinstellungen die Seite Erweitert.

Mit Hilfe von Sicherheitsattributen wird im NTFS-Dateisystem festgelegt, wer Zugriff auf eine Datei erhalten darf und wer nicht. Diese Informationen gehen beim Erstellen eines Archivs in der Regel verloren. Wählen Sie die Option Sicherheitsattribute erhalten, wenn SpeedCommander die Sicherheitsattribute in das Archiv übernehmen soll.

Eine weitere Eigenschaft vom NTFS-Dateisystem ist die Möglichkeit, Informationen zu einer Datei in einem alternativen Datenstrom zu speichern. Die meisten Archivformate komprimieren nur den Dateiinhalt, die erweiterten Informationen gehen verloren. Wählen Sie die Option Alternative Datenströme erhalten, wenn SpeedCommander die alternativen Datenströme in das Archiv übernehmen soll.

Im Dateisystem NTFS ist es auch möglich, Dateien mit Kommentaren zu versehen. Diese Kommentare werden ebenfalls in einem alternativen Datenstrom gespeichert. Bei den Archivformaten SQX und ZIP ist es möglich, diese Kommentare auszulesen und automatisch als Dateikommentare für die jeweiligen Dateien in das Archiv zu übernehmen. Wählen Sie die Option OLE/NTFS-Kommentare automatisch übernehmen, wenn SpeedCommander diese Kommentare automatisch in Archivkommentare umwandeln soll.

Unmittelbar nach dem Komprimieren kann das Archiv automatisch mit einem besonderen Testverfahren geprüft werden. Das Archiv wird auf Integrität geprüft und die Dateiinhalte im Archiv werden mit den Dateiinhalten auf der Festplatte verglichen. Der Test gilt dann als bestanden, wenn sich das Archiv ohne Fehler testen lässt und die Dateiinhalte des Archives mit den Dateiinhalten der Festplatte übereinstimmen. Wählen Sie die Option Erweitertes Testen nach dem Archivieren, wenn SpeedCommander diesen Vergleich automatisch durchführen soll.

Es ist auch möglich, Dateinamen in Unicode abzuspeichern. Dies ist dann sinnvoll, wenn im Dateinamen Zeichen vorkommen, die in üblichen Zeichensätzen nicht vorhanden sind (z.B. osteuropäische und asiatische Sprachen). Wählen Sie die Option Unicode-Dateinamen speichern, wenn SpeedCommander zusätzlich Unicode-Dateinamen abspeichern soll. Unicode-Dateinamen können nur mit dem SQX-Format abgespeichert werden.

Wichtiger Hinweis

Sie können für das Komprimieren von Dateien ein Kennwort festlegen. Vor dem Dekomprimieren dieser Dateien werden Sie aufgefordert, das Kennwort anzugeben. Wenn Sie das Kennwort vergessen, können Sie die Dateien nicht mehr dekomprimieren.


Archiv entpacken

SpeedCommander: Arbeiten mit Archiven
Archiv entpacken

Beim Entpacken werden die Dateien aus einem Archiv in ihren unkomprimierten Zustand wiederhergestellt und in einem von Ihnen angegebenen Ordner gespeichert, so dass Sie mit der Datei arbeiten können. Sie werden feststellen, dass das Dekomprimieren einer oder mehrerer Dateien aus einem Archiv eine der häufigsten Tätigkeiten beim Umgang mit Archivdateien ist. Sie können mit SpeedCommander eine Datei, eine Auswahl von Dateien oder sämtliche Dateien eines Archivs dekomprimieren.

So entpacken Sie Dateien aus einer Archivdatei:
  1. Markieren Sie im Ordnerfenster die Archivdatei, welche Sie entpacken möchten. Sie können auch mehrere Archivdateien markieren.
  2. Wählen Sie im Menü Datei den Befehl Entpacken. Das Dialogfeld Entpacken wird angezeigt.
  3. Geben Sie im Feld Entpacken nach den Ordner ein, in dem die dekomprimierten Dateien gespeichert werden sollen. Sie können auch im Feld Ordner auf den gewünschten Ordner klicken.
  4. Wählen Sie Ordnerstruktur wiederherstellen, um auf Ihrer Festplatte die ursprüngliche Ordnerstruktur wiederherzustellen und die Dateien aus dem Archiv in Ordnern abzulegen, die den gleichen Namen haben wie die Ordner im Archiv.
  5. Wählen Sie Nachfrage vor dem Überschreiben, wenn SpeedCommander Sie vor dem Überschreiben einer bereits existierenden Datei um Erlaubnis fragen soll.
  6. Wählen Sie Beschädigte Dateien nicht löschen, wenn fehlerhaft entpackte Dateien nach dem Entpacken nicht gelöscht werden sollen.
  7. Drücken Sie Eingabe oder wählen Sie OK.

Weitere Einstellungen

Mit Hilfe von Sicherheitsattributen wird im NTFS-Dateisystem festgelegt, wer Zugriff auf eine Datei erhalten darf und wer nicht. Diese Informationen gehen beim Erstellen eines Archivs in der Regel verloren. SpeedCommander kann jedoch bei SQX- und ZIP-Archiven die Sicherheitsattribute mit in das Archiv übernehmen. Wählen Sie im Dialog Entpacken die Option Sicherheitsattribute wiederherstellen, wenn SpeedCommander die gespeicherten Sicherheitsattribute nach dem Entpacken wiederherstellen soll.

Eine weitere Eigenschaft vom NTFS-Dateisystem ist die Möglichkeit, Informationen zu einer Datei in einem alternativen Datenstrom zu speichern. Die meisten Archivformate komprimieren nur den Dateiinhalt, die erweiterten Informationen gehen verloren. Mit dem SQX- und dem ZIP-Format ist es aber möglich, auch diese zusätzlichen Informationen mit in das Archiv aufzunehmen. Wählen Sie im Dialog Entpacken die Option Alternative Datenströme wiederherstellen, wenn SpeedCommander die alternativen Datenströme beim Entpacken wiederherstellen soll.

Im Dateisystem NTFS ist es auch möglich, Dateien mit Kommentaren zu versehen. Diese Kommentare werden ebenfalls in einem alternativen Datenstrom gespeichert. Bei den Archivformaten SQX und ZIP ist es möglich, diese Kommentare auszulesen und automatisch als Dateikommentare für die jeweiligen Dateien in das Archiv zu übernehmen. Wählen Sie im Dialog Entpacken die Option OLE/NTFS-Kommentare wiederherstellen, wenn SpeedCommander Archivkommentare automatisch auf die entpackten Dateien übertragen soll.

Beim Download von Archivdateien mit dem Internet Explorer wird in einem alternativen Datenstrom vermerkt, dass die Datei aus dem Internet stammt. Beim Ausführen einer solchen Datei zeigt der Windows-Explorer einen Warnhinweis an. Wählen Sie im Dialog Entpacken die Option Zone ID auf entpackte Dateien übertragen, wenn SpeedCommander auch alle entpackten Dateien entsprechend markieren soll. Diese Funktion erfordert das Dateisystem NTFS.

Wichtiger Hinweis

Wenn Sie beim Komprimieren der Dateien ein Kennwort angegeben haben, müssen Sie es zum Entpacken erneut eingeben. Wenn Sie das Kennwort nicht kennen, können Sie die Dateien nicht entpacken.

SQX-Archive mit fehlerhafter Textkompression

SQX-Archive mit aktivierter Textkompression (PPMd), die von einer 64-bit Version von SpeedCommander (bis einschließlich 14.00.6600) erzeugt wurden, können aufgrund eines Fehlers in der Komprimierfunktion unter Umständen nicht mit einer 32-bit Version von SpeedCommander entpackt werden. Der Fehler wurde mit der Version 14.10.6700 behoben. SQX-Archive, die mit einer 32-bit Version erzeugt wurden, sind von diesem Fehler nicht betroffen.

Aufgrund der Fehlerbehebung lassen sich diese Archive nun aber auch nicht mehr mit der normalen Entpackfunktion der 64-bit Version von SpeedCommander entpacken. Bitte benutzen Sie zum Entpacken der fehlerhaften Archive den Befehl Fehlerhaftes SQX-Archiv entpacken aus dem Menü Extras - Archiv, wenn die entsprechende Fehlermeldung angezeigt wird. In der 32-bit Version ist dieser Menübefehl deaktiviert.


Multivolume-Archiv erstellen

SpeedCommander: Arbeiten mit Archiven
Multivolume-Archiv erstellen

Bei Datensicherungen kann es passieren, dass das zu erstellende Archiv größer als eine Diskette oder eine bestimmte Datenträgergröße ist. SpeedCommander bietet Ihnen die Möglichkeit, ein Archiv über mehrere Disketten oder Datenträger zu erstellen.

So erstellen Sie ein Multivolume-Archiv:
  1. Wählen Sie den Ordner oder die Dateien aus, die Sie komprimieren möchten.
  2. Wählen Sie im Menü Datei den Befehl Komprimieren oder klicken Sie in der Symbolleiste auf das Symbol Komprimieren.
  3. Geben Sie im Dialogfeld Komprimieren im Eingabefeld Name einen Namen für die komprimierte Datei an.
  4. Wählen Sie das gewünschte Format (SQX oder ZIP) und aktivieren Sie im Kombinationsfeld Typ die Einstellung Multivolume-Archiv.
  5. Klicken Sie auf die Schaltfläche Optionen, um das Dialogfeld Komprimierungseinstellungen anzuzeigen.
  6. Wählen Sie auf der Seite Multivolume die gewünschte Größe für die Aufteilung des Archivs an.
  7. Schließen Sie beide Dialogfelder mit OK, um das Multivolume-Archiv zu erstellen.

Wenn für das spätere Entpacken von Archiven über mehrere Disketten keinerlei Hilfsprogramme benötigt werden sollen, so können Sie auch ein selbstentpackendes Archiv erstellen. Im ersten Segment des Archivs ist ein kleines Programm enthalten, das die erforderlichen Arbeiten selbstständig durchführt.

So erstellen Sie ein selbstentpackendes Multivolume-Archiv über mehrere Disketten:
  1. Wählen Sie den Ordner oder die Dateien aus, die Sie komprimieren möchten.
  2. Wählen Sie im Menü Datei den Befehl Komprimieren oder klicken Sie in der Symbolleiste auf das Symbol Komprimieren.
  3. Geben Sie im Dialogfeld Komprimieren im Eingabefeld Name einen Namen für die komprimierte Datei an.
  4. Wählen Sie das Format SQX und aktivieren Sie im Kombinationsfeld Typ die Einstellung Selbstentpackend.
  5. Klicken Sie auf die Schaltfläche Optionen, um das Dialogfeld Komprimierungseinstellungen anzuzeigen.
  6. Wählen Sie auf der Seite Selbstentpackendes Archiv im Kombinationsfeld Typ den Eintrag Einfaches SFX und im Kombinationsfeld Größe die gewünschte Größe für die Aufteilung des Archivs an.
  7. Schließen Sie beide Dialogfelder mit OK, um das selbstentpackende Multivolume-Archiv zu erstellen.


Integrität prüfen

SpeedCommander: Arbeiten mit Archiven
Integrität prüfen

Mit Hilfe dieser Funktion können Sie die Integrität eines Archivs testen und damit die Vollständigkeit der im Archiv enthaltenen Daten überprüfen. SpeedCommander simuliert dazu einen Entpackvorgang, schreibt dabei aber keinerlei Daten auf die Festplatte. Für den Test eines Archivs ist somit kein zusätzlicher Speicherplatz erforderlich. Wenn beim Testvorgang Probleme auftreten, zeigt SpeedCommander Ihnen nach dem Prüfvorgang eine Fehlermeldung bzw. bestätigt die Integrität des Archivs.

So überprüfen Sie die Integrität eines Archivs:
  1. Markieren Sie die Archivdatei, deren Integrität Sie testen möchten.
  2. Aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Auf Integrität prüfen.


Kommentare vergeben

SpeedCommander: Arbeiten mit Archiven
Kommentare vergeben

Kommentare sind Notizen zum Archiv bzw. zu den Dateien, die sich im Archiv befinden. Im Gegensatz zum normalen Dateisystem können Sie sich so bestimmte Bemerkungen zu den Archiven oder sogar zu einzelnen Dateien im Archiv machen. Die Kommentare werden im Archiv abgespeichert und von SpeedCommander automatisch angezeigt.

Mit SpeedCommander ist es auch möglich, in einem Arbeitsschritt mehreren Dateien im Archiv den gleichen Kommentar zuzuweisen. Die Archiv- oder Dateikommentare können geändert oder gelöscht werden.

So vergeben Sie einen Archivkommentar:
  1. Öffnen Sie die Archivdatei, der Sie einen Kommentar hinzufügen möchten.
  2. Aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Hauptkommentar setzen.
  3. Tragen Sie im Dialogfeld Hauptkommentar ändern Ihren neuen Archivkommentar ein und klicken Sie auf OK.
So vergeben Sie einen Dateikommentar:
  1. Öffnen Sie die Archivdatei, der Sie einen Dateikommentar hinzufügen möchten.
  2. Aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Dateikommentar setzen.
  3. Tragen Sie im Dialogfeld Eigenschaften im Feld Kommentar Ihren Dateikommentar ein und klicken Sie auf OK.


Reparaturdaten verwenden

SpeedCommander: Arbeiten mit Archiven
Reparaturdaten verwenden

Mit SpeedCommander ist es möglich, SQX-Archiven Reparaturdaten hinzuzufügen. Diese Reparaturdaten dienen als zusätzlicher Schutz gegen Beschädigungen von Archiven, da sie wesentlich empfindlicher auf Beschädigungen reagieren, als normale Dateien. Wird z.B. in einem Word-Dokument ein einziges Byte verändert, so hat man unter Umständen einen falschen Buchstaben oder eine falsche Formatierung an einer Stelle des Dokumentes. Ein Archiv kann in der Regel schon nicht mehr korrekt dekomprimiert werden, wenn ein einziges Byte (oder Zeichen) verändert wurde, da ein falsches Byte das gesamte Archiv beeinflussen kann.

Funktionsweise von Reparaturdaten

Sämtliche Daten auf bzw. in einem PC werden in der Regel blockweise zwischen der Hard- und Software ausgetauscht, und genau hierbei kann es zu Problemen kommen, wenn z.B. ein Datenträger (Festplatte, Diskette, CD) beschädigt ist. Kann ein bestimmter Sektor auf einem Datenträger nicht gelesen werden, dann werden letztendlich falsche bzw. ungültige Daten übertragen. Die Datei behält zwar an sich die gleiche Größe, enthält aber trotzdem falsche Daten. Genau hier setzt SpeedCommander an und erzeugt mit einem speziellen Verfahren Prüf- und Reparaturblöcke, mit denen beschädigte Blöcke wieder korrekt hergestellt werden können. Hierbei wird jede Datei in einem Archiv einzeln für sich geschützt. Es können selbstverständliche auch verschlüsselten bzw. mit einem Kennwort geschützten SQX-Archiven Reparaturdaten hinzugefügt werden. Die Prüf- und Reparaturblöcke lassen keine Rückschlüsse auf die unverschlüsselten Daten zu.

SpeedCommander kann einem SQX-Archiv ein Prozent bis fünf Prozent Reparaturdaten hinzufügen und könnte entsprechend SQX-Archive mit einem bis zu fünf Prozent Beschädigungen (bezogen auf die Archivgröße) wiederherstellen. Enthält z.B. ein SQX-Archiv mit der Größe von einem MiB fünf Prozent Reparaturdaten, so könnten bis zu ca. 50 KiB eines Archivs beschädigt sein und SpeedCommander könnte das Archiv immer noch reparieren. Immerhin entsprechen 50 KiB rund 100 Sektoren einer Diskette bzw. bis zu sechs Clustern einer Festplatte.

In der Praxis haben sich zwei Prozent Reparaturdaten bewährt, sie fallen bezogen auf die Archivgröße kaum auf und bieten schon einen deutlichen Schutz gegenüber Beschädigungen. Aber trotzdem sollten Sie mit Ihren Daten niemals leichtsinnig umgehen. Ist ein Archiv inklusive der Reparaturdaten beschädigt, kann SpeedCommander auch nicht mehr helfen. Sie sollten stets darauf achten, dass Ihre Datenträger wie Disketten, CDs und DVDs in Ordnung sind, um jedes Risiko zu minimieren.

Reparaturdaten hinzufügen

Sie können SpeedCommander veranlassen, gleich bei der Erstellung eines Archivs Reparaturdaten in das Archiv einzubauen. Klicken Sie dazu im Komprimierungsdialog auf die Schaltfläche Optionen und wählen Sie im Dialogfeld Komprimierungseinstellungen auf der Seite Komprimierung im Kombinationsfeld Reparaturdaten die gewünschte Dichte der Reparaturdaten. Je höher der Prozentsatz von Reparaturdaten ist, desto größer können die Beschädigungen an einem Archiv sein, das SpeedCommander wiederherstellen kann.

SpeedCommander kann einem Archiv aber auch nachträglich Reparaturdaten hinzufügen. So müssen bestehende Archive nicht erst dekomprimiert und dann wieder neu erstellt werden. Markieren Sie dazu im Ordnerfenster einfach das entsprechende Archiv, aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Reparaturdaten hinzufügen.

Reparaturdaten entfernen

SpeedCommander bietet Ihnen auch die Möglichkeit, vorhandene Reparaturdaten aus einem Archiv zu entfernen. Markieren Sie dazu im Ordnerfenster das entsprechende Archiv, aktivieren Sie das Menü Extras, zeigen Sie auf Archiv und wählen Sie den Befehl Reparaturdaten entfernen.

Archive reparieren

Mit Hilfe des Befehls Defektes Archiv reparieren aus dem Untermenü Archiv des Menüs Extras können beschädigte SQX-Archive mit Reparaturdaten ganz oder teilweise wiederhergestellt werden. Der Grad der möglichen Wiederherstellung hängt hier von der Art und dem Umfang der Beschädigung des Archivs ab. Beim Reparieren des Archivs wird zusammen mit dem reparierten Archiv eine Logdatei im Textformat erzeugt, in der aufgeführt wird, welche Dateien gerettet werden konnten.


Kompressionsprofile verwenden

SpeedCommander: Arbeiten mit Archiven
Kompressionsprofile verwenden

In einem Kompressionsprofil werden alle Einstellungen für die Erstellung eines Archivs gespeichert. Wenn Sie z.B. immer ZIP-Archive als eMail-Anhang verschicken und zur Archivierung Ihrer Daten das SQX-Format verwenden, so können Sie für beide Einsatzzwecke ein eigenes Profil definieren. Im Dialogfeld Komprimieren kann schnell zwischen den Profilen umgeschaltet werden und die Archive werden mit wenigen Mausklicks erstellt.

So erstellen Sie ein neues Kompressionsprofil:
  1. Öffnen Sie das Dialogfeld Komprimieren.
  2. Klicken Sie im Abschnitt Profile auf die Schaltfläche Bearbeiten, der Einstellungsdialog Profile erscheint.
  3. Klicken Sie auf die Schaltfläche Neu, um ein neues Profil zu erstellen.
  4. Aktivieren Sie die gewünschten Komprimiereinstellungen und schließen Sie das Dialogfeld mit OK.
So wählen Sie ein Kompressionsprofil:
  1. Öffnen Sie das Dialogfeld Komprimieren.
  2. Wählen Sie im Kombinationsfeld Profil das gewünschte Kompressionsprofil.
  3. Klicken Sie auf OK, um das Archiv zu erzeugen.
So löschen Sie ein Kompressionsprofil:
  1. Öffnen Sie das Dialogfeld Komprimieren.
  2. Klicken Sie im Abschnitt Profile auf die Schaltfläche Bearbeiten, der Einstellungsdialog Profile erscheint.
  3. Wählen Sie im Listenfeld Profile das Profil, welches Sie löschen möchten.
  4. Klicken Sie auf die Schaltfläche Löschen, um das Profil zu löschen.


Selbstentpackendes Archiv erstellen

SpeedCommander: Arbeiten mit Archiven
Selbstentpackendes Archiv erstellen

SpeedCommander kann normale Archive und selbstentpackende Archive (SFX) erzeugen. Normale Archive können in der Regel nur von SpeedCommander bzw. von dem entsprechenden Dateikomprimierer gelesen, bearbeitet oder dekomprimiert werden. Ohne zusätzliche Hilfsprogramme ist der Zugriff auf ein normales Archiv daher nicht möglich.

Selbstentpackende Archive dekomprimieren sich selbstständig: Ein Doppelklick unter Windows startet das Archiv und dieses Archiv dekomprimiert sich dann selbst, ohne dass ein entsprechender Dateikomprimierer benötigt wird. SpeedCommander kann selbstentpackende Archive erzeugen, die sich ab Windows XP und höher (32-bit und 64-bit) ausführen lassen. Selbstentpackende Archive sind so optimal für die Weitergabe von Software an Computerneulinge, die mit dem Konzept der Archive noch nicht so vertraut sind.

Zur Erstellung eines selbstentpackenden Archivs wählen Sie im Dialogfeld Komprimieren im Kombinationsfeld Typ den Eintrag Selbstentpackendes Archiv. Klicken Sie anschließend auf die Schaltfläche Optionen, das Dialogfeld Komprimierungseinstellungen wird geöffnet. Auf der Seite Selbstentpackendes Archiv und deren Unterseiten können Sie die Einstellungen für das selbstentpackende Archiv festlegen.

Auf der Seite Versionsinformationen können Sie eine Symboldatei angeben, mit der das SFX gekennzeichnet werden soll. Sie können auch einzelne Versionsangaben vorgeben.

Einfaches SFX

Ein einfaches SFX ist optimal zur Weitergabe von Dokumenten, Grafiken und anderen Dateien an Mitarbeiter und andere Personen geeignet. Es ist auch möglich, ein einfaches SFX für einfache Softwareinstallationen zu verwenden.

Das einfache SFX enthält eine optionale Begrüßungsmeldung. Es kann bei der Erstellung ein Ordner festgelegt werden, in dem die Dateien auf dem Zielsystem dekomprimiert werden. Bei der Angabe des Ordners können folgende Systemvariablen angegeben werden, die zur Laufzeit auf dem Zielsystem aufgelöst werden:

Systemvariable | Beschreibung
%Programs% | Wird durch Ordner für Programmdateien ersetzt
%CommonFiles% | Wird durch den Ordner für gemeinsame Programmdateien ersetzt
%AppData% | Wird durch den Anwendungsdaten-Ordner des jeweiligen Benutzers ersetzt
%LocalAppData% | Wird durch den lokalen Anwendungsdaten-Ordner des jeweiligen Benutzers ersetzt
%Documents% | Wird durch den Dokumenten-Ordner des jeweiligen Benutzers ersetzt
%Windows% | Wird durch den Windows-Ordner ersetzt
%System% | Wird durch den System-Ordner ersetzt
%Temp% | Wird durch den temporären Ordner des jeweiligen Benutzers ersetzt

Mit der Option Überschreiben ohne Nachfrage werden vorhandene Dateien ohne Nachfrage überschrieben. Zusätzlich kann ein Programm direkt nach dem Dekomprimieren aufgerufen werden. Dem aufzurufenden Programm können weitere Parameter beim Start übergeben werden. Die Parameter müssen mit dem Pipe-Zeichen (|) vom Programmnamen getrennt werden. Zum Beispiel würde Backup.exe|/as /t /i das SFX anweisen, nach dem Entpacken das Programm Backup.exe zu starten und die Parameter /as /t /i an Backup.exe zu übergeben.

Die Einstellung Automatisches Dekomprimieren legt fest, dass nach dem Aufruf des selbstentpackenden Archivs sofort mit dem Entpacken begonnen wird, ohne dass der Anwender den Zielordner ändern kann. Verwenden Sie diese Option äußerst vorsichtig, da der Empfänger des selbstentpackenden Archivs keinerlei Meldungen auf dem Bildschirm erhält.

Der Bereich Hinweisdialog legt fest, ob nach dem Start des SFX ein Hinweisdialog angezeigt wird. Geben Sie hier den Dialogtext sowie den Titel des Dialoges ein. Sie können auch wählen, welche Schaltflächenkombination verwendet werden soll. Wenn Sie keinen Hinweisdialog anzeigen möchten, lassen Sie einfach die Textfelder leer.

Jedes selbstextrahierende Archiv enthält einen Informationsdialog, der Programminformationen, Versionsnummer und Copyright anzeigt. Im Bereich Informationsdialog können Sie einen Text eingeben, der zusätzlich angezeigt wird.

SFX mit Listenansicht

Das SFX mit Listenansicht deckt die gleichen Anwendungsbereiche wie das einfache SFX ab. Im Unterschied zum einfachen SFX werden die im Archiv enthaltenen Dateien nach dem Start in einem Fenster mit Listenansicht angezeigt. Die Dateien können so einzeln oder zusammen per Ziehen & Ablegen oder per Menübefehl entpackt werden.

Ein SFX mit Listenansicht ist grundsätzlich zweisprachig (Deutsch und Englisch) aufgebaut. Das System, worauf das SFX gestartet wird, entscheidet darüber, welche Sprache verwendet wird.

SFX für Softwareinstallationen

Das SFX für Softwareinstallationen hilft bei der Verteilung von Software, die ein Installationsprogramm enthält. Es erstellt beim Aufruf einen temporären Ordner, entpackt die im Archiv enthaltenen Dateien, startet Ihr Installationsprogramm und wartet, bis dieses beendet ist. Danach werden alle Dateien im temporären Ordner und der Ordner selbst wieder entfernt.

Dem Installationsprogramm können beim Start weitere Parameter übergeben werden. Die Parameter müssen mit dem Pipe-Zeichen (|) vom Programmnamen getrennt werden. Zum Beispiel würde Setup.exe|/as /t /i das SFX anweisen, nach dem Entpacken das Programm Setup.exe zu starten und die Parameter /as /t /i an Setup.exe zu übergeben.

Im Bereich SFX für Softwareinstallationen geben Sie den Text an, der im Dialogfeld erscheinen soll, sowie das nach dem Entpacken auszuführende Installationsprogramm. Beide Angaben sind zwingend erforderlich. Das Eingabefeld Warten auf wird nur verwendet, wenn das Installationsprogramm gleich nach dem Start ein weiteres Programm ausführt und sich sofort wieder beendet. In diesem Fall wird hier der Name des zweiten Programms eingetragen.


Dateifilter verwenden

SpeedCommander: Dateifilter verwenden
Überblick

Dateifilter können dazu verwendet werden, bestimmte Dateien von der Anzeige in SpeedCommander auszublenden. Sie können bestimmten Dateien auch verschiedene Farben oder Schriftstile zuordnen, um diese in einer Dateiliste schnell zu finden.

Es ist auch möglich, Dateifilter beim Kopieren zu verwenden, um nur bestimmte Dateien zu kopieren oder diese beim Kopieren auszulassen.

Weitere Themen

Dateifilter für die Anzeige

Dateifilter für Dateioperationen

Dateifilter einrichten

Farben zuordnen


Dateifilter für die Anzeige

SpeedCommander: Dateifilter verwenden
Dateifilter für die Anzeige

Sie können in jedem Ordnerfenster einen anderen Filter verwenden oder für alle Ordnerfenster den gleichen Filter aktivieren. Um auf die Filter zuzugreifen, öffnen Sie das Menü Ordner und zeigen Sie auf Filter.

So aktivieren Sie einen Filter:
  1. Öffnen Sie das Menü Ordner und zeigen Sie auf Filter.
  2. Wählen Sie den Filter aus, den Sie verwenden möchten oder wählen Sie den Befehl Filter auswählen.
  3. Wählen Sie im Dialogfeld Filter auswählen den gewünschten Filter aus.
  4. Möchten Sie schnell Dateien mit bestimmten Erweiterungen filtern, wählen Sie Einschließen und tragen die entsprechende Maske im daneben liegenden Eingabefeld ein. Wenn Sie z.B. nur Dateien mit den Erweiterungen EXE und DLL anzeigen möchten, tragen Sie *.EXE;*.DLL ein.
  5. Drücken Sie Eingabe oder klicken Sie auf OK.
So schalten Sie einen Filter aus:
  1. Öffnen Sie das Menü Ordner und zeigen Sie auf Filter.
  2. Wählen Sie den Befehl Alle Dateien.

Wichtige Hinweise

  • Sie können auch mit der rechten Maustaste auf die Titelzeile des linken oder rechten Ordnerfensters klicken, um einen anderen Filter auszuwählen.
  • Wenn Sie für jedes Fenster einen unterschiedlichen Filter verwenden möchten, so deaktivieren Sie im Einstellungsdialog auf der Seite Ordner und Laufwerke das Kontrollkästchen Ausgewählter Filter gilt für alle Ordnerfenster gleichzeitig.


Dateifilter für Dateioperationen

SpeedCommander: Dateifilter verwenden
Dateifilter für Dateioperationen

Sie können Dateifilter auch dazu verwenden, um bestimmte Dateien beim Kopieren/Verschieben ein- oder auszuschließen. SpeedCommander prüft dann vor dem Kopieren/Verschieben einer Datei, ob diese Datei den Filterbedingungen genügt. Entspricht sie den Bedingungen nicht, so wird sie beim Kopieren/Verschieben übersprungen.

So benutzen Sie einen Dateifilter beim Kopieren:
  1. Wählen Sie die Dateien aus, die Sie kopieren möchten.
  2. Wählen Sie Kopieren aus dem Menü Datei, oder klicken Sie in der Symbolleiste auf das Symbol Kopieren.
  3. Wählen Sie im Eingabefeld Filter den Filter aus, den Sie verwenden möchten oder klicken Sie auf die Schaltfläche Filter, um einen neuen Dateifilter zu erstellen oder einen bestehenden Dateifilter anzupassen.
  4. Drücken Sie Eingabe oder wählen Sie OK.


Dateifilter einrichten

SpeedCommander: Dateifilter verwenden
Dateifilter einrichten

Die Verwaltung der Dateifilter erfolgt im Dialogfeld Filter konfigurieren. Hier können Sie bis zu 50 angepasste Dateifilter erstellen. Das Dialogfeld Filter konfigurieren erreichen Sie über die Dialoge

  • Filter auswählen
  • Auswahl erweitern und Auswahl reduzieren
  • Seite Aussehen - Farben im Einstellungsdialog

Zur Definition eines Dateifilters können Sie folgende Dateieigenschaften verwenden:

  • Dateiname
  • Dateiattribute
  • Datum
  • Größe
Dateiname

Mit der Kategorie Dateiname können Sie Dateien aufgrund Ihres Namens filtern. Sie können Dateien einschließen oder auch von der Ansicht ausschließen.

  • Tragen Sie im Eingabefeld Einschließen die Dateimasken ein, die Sie anzeigen möchten.
  • Tragen Sie im Eingabefeld Ausschließen die Dateimasken ein, die Sie von der Anzeige ausschließen möchten. Zum Ausschließen von bestimmten Ordnern (z.B. temp) geben Sie den Ordnernamen gefolgt von einem \ ein (z.B. temp\)
Dateiattribute

Mit der Kategorie Dateiattribute können Sie Dateien aufgrund Ihrer Dateiattribute filtern. Wenn Sie mehrere Kontrollkästchen aktivieren, werden Dateien nur berücksichtigt, wenn für diese Dateien alle markierten Attribute gesetzt oder gelöscht sind.

  • Aktivieren Sie ein Kontrollkästchen, um Dateien anzuzeigen, die das entsprechende Attribut besitzen.
  • Deaktivieren Sie ein Kontrollkästchen, um Dateien anzuzeigen, die das entsprechende Attribut nicht besitzen.
  • Stellen Sie das Kontrollkästchen auf Grau, wenn das entsprechende Attribut nicht beachtet werden soll.
Datum

Mit der Kategorie Datum können Sie Dateien aufgrund des Datums, zu der sie erstellt, zuletzt geändert oder zuletzt geöffnet wurden, filtern. Sie können entweder eine Zeitspanne vom aktuellen Zeitpunkt hergesehen angeben (Stunden, Minuten, Tage, Wochen, Monate, Jahre) oder einen Zeitraum mit Anfangs- und Enddatum festlegen.

Größe

Mit der Kategorie Größe können Sie Dateien aufgrund ihrer Größe (in Bytes) filtern. Aktivieren Sie die Kontrollkästchen Größer als und/oder Kleiner als, um die Dateigröße festlegen zu können. Wenn Sie eine bestimmte Größe nur als obere bzw. untere Grenze festlegen möchten, deaktivieren Sie das eine oder andere Kontrollkästchen.


Farben zuordnen

SpeedCommander: Dateifilter verwenden
Farben zuordnen

Neben der Filterung von Dateien bei der Anzeige können Dateifilter noch benutzt werden, um bestimmte Dateien im Ordnerfenster farblich hervorzuheben. So ist es z.B. möglich, alle Dateien, die am heutigen Tag geändert wurden, in rot darzustellen. So fallen diese Dateien in großen Dateilisten schneller auf.

So ordnen Sie einem Filter eine Farbe und/oder einen Schriftstil zu:
  1. Öffnen Sie das Menü Extras und wählen Sie den Befehl Einstellungen.
  2. Aktivieren Sie das Dialogfeld Farben aus der Kategorie Darstellung.
  3. Wählen Sie im Kombinationsfeld Filter den Filter aus, dem Sie eine Farbe zuweisen möchten.
  4. Klicken Sie auf die Farbauswahl-Schaltflächen unter dem Kombinationsfeld und wählen Sie eine Farbe für den Text und/oder für den Hintergrund aus.
  5. Wählen Sie einen Schriftstil, wenn Sie den Text z.B. kursiv oder fett anzeigen möchten.
  6. Drücken Sie Eingabe oder klicken Sie auf OK.
So entfernen Sie die Farb- und Schriftstilzuordnung für einen Filter:
  1. Öffnen Sie das Menü Extras und wählen Sie den Befehl Einstellungen.
  2. Aktivieren Sie das Dialogfeld Farben aus der Kategorie Darstellung.
  3. Wählen Sie im Kombinationsfeld Filter den Filter aus, dessen Farbzuordnung Sie entfernen möchten.
  4. Klicken Sie auf die Farbauswahl-Schaltflächen unter dem Kombinationsfeld und wählen Sie Automatisch.
  5. Setzen Sie den Schriftstil auf Standard.
  6. Drücken Sie Eingabe oder klicken Sie auf OK.


Dateiablagen verwenden

SpeedCommander: Dateiablagen verwenden
Überblick

Oftmals sind häufig bzw. regelmäßig benötigte Dateien über alle Laufwerke und in den verschiedensten Ordnern verstreut. Gerade wenn häufig Dateien aus tief verschachtelten Ordnern oder aus Ordnern mit sehr vielen Dateien benötigt werden ist die typische Dateiauswahl ein wenig umständlich.

Die Dateiablage von SpeedCommander ist im Prinzip ein Container, mit dem häufig oder regelmäßig benutzte Dateien verwaltet werden können. In der Dateiablage werden nicht die Dateien selbst sondern nur Verweise auf die entsprechenden Dateien gespeichert, damit nicht unnötig Festplattenplatz verschwendet und damit vor allen Dingen immer auf die aktuelle Version einer Datei zugegriffen wird.

Die Dateiablage verhält sich wie ein ganz normales Ordnerfenster, d.h. die Einträge in der Dateiablage können gefiltert, gelöscht, kopiert, komprimiert usw. werden. Entsprechend universell kann die Dateiablage genutzt werden.

So aktivieren Sie die Dateiablagen-Ansicht:
  • Wählen Sie im Laufwerksfenster das Symbol Dateiablagen mit der Laufwerkskennung 5, um die Dateiablagen anzuzeigen. Wird das Symbol nicht angezeigt, dann muss es zuerst im Einstellungsdialog auf der Seite Aussehen - Darstellung aktiviert werden.
So fügen Sie eine neue Dateiablage hinzu:
  1. Aktivieren Sie die Dateiablagen-Ansicht.
  2. Öffnen Sie das Menü Ordner und wählen Sie den Befehl Ordner erstellen.
  3. Geben Sie im darauf erscheinenden Eingabefeld den Namen der zu erstellenden Dateiablage ein.
  4. Drücken Sie Eingabe.
So entfernen Sie eine nicht mehr benötigte Dateiablage:
  1. Aktivieren Sie die Dateiablagen-Ansicht.
  2. Markieren Sie die Dateiablage, die Sie nicht mehr benötigen.
  3. Öffnen Sie das Menü Datei und wählen Sie den Befehl Löschen.

Weitere Themen

Dateien hinzufügen oder entfernen

Auswahl laden oder speichern


Dateien hinzufügen oder entfernen

SpeedCommander: Dateiablagen verwenden
Dateien hinzufügen oder entfernen

Bevor Sie mit einer Dateiablage arbeiten können, müssen Sie die Dateiablage mit Dateien füllen. Wählen Sie dazu im Ordnerfenster die Dateien aus, die Sie in die Dateiablage übernehmen möchten und wählen Sie aus dem Menü Datei den Befehl Kopieren. Sie können die Dateien auch mit Ziehen und Ablegen in die Dateiablage übertragen. Da die Dateiablage nicht auf Dateien eines Ordners begrenzt ist, können Sie diesen Schritt auch beliebig oft wiederholen.

Wenn Sie die Dateiverknüpfungen nicht mehr benötigen, können Sie diese auch wieder aus der Dateiablage entfernen.

So entfernen Sie Dateiverknüpfungen aus der Dateiablage:
  1. Markieren Sie die Dateien, die Sie entfernen möchten.
  2. Wählen Sie im Menü Datei den Befehl Löschen.


Auswahl laden oder speichern

SpeedCommander: Dateiablagen verwenden
Auswahl laden oder speichern

Mit Hilfe der Befehle Auswahl laden und Auswahl speichern können die markierten Einträge einer Dateiablage in eine Datei speichern bzw. die Auswahl aus einer Datei wiederherstellen.

So speichern Sie eine Auswahl in eine Datei:
  1. Markieren Sie die Dateien, deren Auswahl Sie speichern möchten.
  2. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Auswahl der Dateiablage speichern.
  3. Geben Sie im Dialogfeld Auswahl speichern einen Dateinamen an, in den Sie die Auswahl speichern möchten.
So laden Sie eine Auswahl aus einer Datei:
  1. Öffnen Sie das Menü Ansicht, zeigen Sie auf Ordnerfenster und wählen Sie den Befehl Auswahl in Dateiablage laden.
  2. Wählen Sie im Dialogfeld Auswahl laden den Dateinamen, der die zu ladende Auswahl enthält.


Brennfunktionen verwenden

SpeedCommander: Brennfunktionen verwenden
Überblick

Mit der Pro-Version von SpeedCommander können Sie Dateien und Ordner zusammenstellen und diese auf CD, DVD oder Blu-Ray brennen. Sie können auch Datenträgerabbilder (Imagedateien) erstellen oder bereits vorhandene Imagedateien auf CD, DVD oder Blu-Ray schreiben. SpeedCommander zeigt auch Informationen zu Brenngeräten und eingelegten Medien an. Wiederbeschreibbare optische Medien können gelöscht werden.

Weitere Themen

Brennprojekte

Medium löschen

Datenträgerabbild erstellen

Datenträgerabbild brennen

Geräteinformationen anzeigen

Medieninformationen anzeigen


Brennprojekte

SpeedCommander: Brennfunktionen verwenden
Brennprojekte

Mit der Pro-Version von SpeedCommander können Sie Zusammenstellungen von Dateien und Ordnern auf CD, DVD und Blu-Ray brennen. Wählen Sie im Laufwerksfenster das Symbol Brennprojekte mit der Laufwerkskennung 6, um die Brennprojekte-Übersicht anzuzeigen. Wird das Symbol nicht angezeigt, dann muss es zuerst im Einstellungsdialog auf der Seite Aussehen - Darstellung aktiviert werden.

Projekt zusammenstellen

Öffnen Sie die Brennprojekte-Übersicht und rufen Sie aus dem Menü Ordner den Befehl Neuer Ordner auf. Alternativ können Sie auch mit der rechten Maustaste in den freien Fensterbereich der Brennprojekte-Übersicht klicken und den Befehl Neues Projekt auswählen. Geben Sie im Editierfeld den Namen des Projekts ein und drücken Sie Enter.

Im Dialogfeld Neues Brennprojekt wird der Projekttyp ausgewählt. Folgende Projekttypen werden unterstützt.

Projekttyp | Beschreibung
CD/DVD mit ISO-Dateisystem | Erstellt eine CD/DVD mit einem ISO 9660-Dateisystem
CD/DVD mit UDF-Dateisystem | Erstellt eine CD/DVD mit einem UDF-Dateisystem
CD/DVD mit ISO/UDF-Dateisystem | Erstellt eine CD/DVD mit einem ISO 9660-Dateisystem und einem UDF-Dateisystem (Bridge)
Video-DVD | Erstellt eine Video-DVD mit den Ordnern AUDIO_TS und VIDEO_TS
Blu-Ray | Erstellt eine Blu-Ray

Der Projekttyp kann später nicht mehr geändert werden.

Im Feld Session importieren können Sie festlegen, ob eine neue CD/DVD/Blu-Ray erstellt oder ob ein früher erstelltes Medium fortgesetzt werden soll. Legen Sie vor der Auswahl von Letzte Session importieren oder Bestimmte Session importieren das fortzuführende Medium in das Brenngerät ein, das im Einstellungsdialog auf der Seite Erweitert - Brennprojekte gewählt ist.

Nach der Erstellung des Projekts und dem optionalen Import einer früheren Session können in das Projekt wechseln und mit dem Befehl Kopieren aus dem Menü Datei oder mit Ziehen & Ablegen neue Dateien und Ordner hinzufügen. Nicht mehr benötigte Dateien und Ordner können mit dem Befehl Löschen entfernt werden.

Projekteigenschaften ändern

Klicken Sie in der Brennprojekte-Übersicht mit der rechten Maustaste auf das Projekt und wählen Sie Eigenschaften, um die Projekteigenschaften anzuzeigen. Alternativ können Sie auch in einem Projekt mit der rechten Maustaste in den freien Fensterbereich klicken und den Befehl Projekteigenschaften auswählen.

Im Dialogfeld Projekteigenschaften können Sie den Namen des Mediums vorgeben, verschiedene Einstellungen zum ISO- und UDF-Dateisystem festlegen und das Medium bootfähig machen.

Projekt brennen

Nach der erfolgreichen Zusammenstellung der Dateien und Ordner können die Daten auf CD/DVD/Blu-Ray gebrannt werden. Klicken Sie dazu in der Brennprojekte-Übersicht mit der rechten Maustaste auf das Projekt und wählen Sie Brennen. Alternativ können Sie auch in einem Projekt mit der rechten Maustaste in den freien Fensterbereich klicken und den Befehl Projekt brennen auswählen.

Wählen Sie im Dialogfeld Brennen das Laufwerk aus, mit dem der Brennvorgang erfolgen soll. Wenn Sie die Daten direkt in eine Imagedatei schreiben möchten, dann wählen Sie # Image-Device. Im Kombinationsfeld Geschwindigkeit können Sie die Geschwindigkeit festlegen, mit der die Daten geschrieben werden sollen. Wenn Sie mehrere Kopien erstellen möchten, dann tragen Sie im Eingabefeld Anzahl der Kopien die gewünschte Anzahl ein.

Aktivieren Sie das Kontrollkästchen Puffer-Schutz aktivieren, wenn die Buffer-Underrun-Protection des Brenners verwendet werden soll. Mit der Einstellung Brennvorgang simulieren lässt sich vor dem Brennvorgang testen, ob sich die Daten fehlerfrei brennen lassen. Die Einstellung Optimum Power Calibration (OPC) ermöglicht eine automatische Anpassung der Laserstärke an die speziellen Eigenschaften des aktuellen Rohlings.

Das Kontrollkästchen Medium abschließen legt fest, ob das Medium nach dem Schreiben finalisiert werden soll. Ein weiteres Beschreiben des Mediums ist anschließend nicht mehr möglich. Mit der Einstellung Daten nach dem Brennen überprüfen wird festgelegt, ob die geschriebenen Daten nach dem Brennvorgang noch einmal mit den zu schreibenden Daten verglichen werden sollen. Die Einstellung Medium nach dem Brennen auswerfen legt fest, ob der Brenner das aktuelle Medium nach Abschluss des Brennvorgangs selbstständig auswirft.

Klicken Sie auf Brennen, um den Brennvorgang zu starten. Wenn die Daten direkt in eine Imagedatei geschrieben werden sollen, dann erscheint noch ein Dialogfeld zur Eingabe des Dateinamens der neuen Imagedatei.

Zusammenstellung beibehalten oder aktualisieren

Nach dem erfolgreichen Abschluss des Brennvorgangs können Sie entscheiden, ob die Zusammenstellung beibehalten oder aktualisiert werden soll. Wählen Sie Zusammenstellung beibehalten, wenn die referenzierten Dateinamen der neu hinzugefügten Dateien in der Zusammenstellung erhalten bleiben sollen. Dies ermöglicht es, die Zusammenstellung mehrfach hintereinander zu brennen. Entscheiden Sie sich für Zusammenstellung aktualisieren, wenn die Dateinamen in der Zusammenstellung zurückgesetzt werden sollen. Vor dem erneuten Brennen der Zusammenstellung müssen Sie dann die gewünschten Dateinamen neu hinzufügen.


Medium löschen

SpeedCommander: Brennfunktionen verwenden
Medium löschen

Mit der Pro-Version von SpeedCommander können Sie wiederbeschreibbare optische Medien löschen.

So löschen Sie ein wiederbeschreibbares Medium:
  1. Wählen Sie im Menü Pro den Befehl Medium löschen.
  2. Wählen Sie im Dialogfeld Medium löschen das Gerät, in dem sich das zu löschende Medium befindet.
  3. Aktivieren Sie das Kontrollkästchen Schnelles Löschen, wenn nur die Verzeichnisinformationen auf dem Medium gelöscht werden sollen.
  4. Aktivieren Sie das Kontrollkästchen Medium nach dem Löschen auswerfen, wenn das Medium nach dem Löschvorgang ausgeworfen werden soll.
  5. Klicken Sie auf Löschen.


Datenträgerabbild erstellen

SpeedCommander: Brennfunktionen verwenden
Datenträgerabbild erstellen

Mit der Pro-Version von SpeedCommander können Sie Datenträgerabbild-Dateien (Imagedateien) erstellen.

So erstellen Sie ein Datenträgerabbild:
  1. Wählen Sie im Menü Pro den Befehl Datenträgerabbild erstellen.
  2. Wählen Sie das Gerät mit dem Medium, für das ein Datenträgerabbild erstellt werden soll.
  3. Wählen Sie im Kombinationsfeld Aktion die Option Abbild erstellen und im Kombinationsfeld Format das gewünschte Format.
  4. Wenn das Abbild nach dem Erstellen überprüft werden soll, dann wählen Sie als Aktion Abbild erstellen und überprüfen.
  5. Tragen Sie im Eingabefeld Abbild den Pfad zur Imagedatei ein, die erstellt werden soll.
  6. Aktivieren Sie das Kontrollkästchen Fehlerkorrektur verwenden, wenn Lesefehler automatisch korrigiert werden sollen.
  7. Aktivieren Sie das Kontrollkästchen Schlechte Sektoren auffüllen, wenn schlechte Sektoren in der Imagedatei mit Nullbytes aufgefüllt werden sollen.
  8. Aktivieren Sie das Kontrollkästchen Schlechte Sektoren protokollieren, wenn ein Protokoll mit den fehlerhaft gelesene Sektoren erstellt werden soll.
  9. Klicken Sie auf Erstellen.
So überprüfen Sie ein Datenträgerabbild:
  1. Wählen Sie im Menü Pro den Befehl Datenträgerabbild erstellen.
  2. Wählen Sie das Gerät mit dem Medium, für das ein Datenträgerabbild erstellt werden soll.
  3. Wählen Sie im Kombinationsfeld Aktion die Option Abbild überprüfen und im Kombinationsfeld Format das gewünschte Format.
  4. Tragen Sie im Eingabefeld Abbild den Pfad zur Imagedatei ein, die überprüft werden soll.
  5. Aktivieren Sie das Kontrollkästchen Fehlerkorrektur verwenden, wenn Lesefehler automatisch korrigiert werden sollen.
  6. Aktivieren Sie das Kontrollkästchen Schlechte Sektoren auffüllen, wenn schlechte Sektoren in der Imagedatei mit Nullbytes aufgefüllt werden sollen.
  7. Aktivieren Sie das Kontrollkästchen Schlechte Sektoren protokollieren, wenn ein Protokoll mit den fehlerhaft gelesene Sektoren erstellt werden soll.
  8. Klicken Sie auf Überprüfen.

Weitere Themen

Datenträgerabbild brennen


Datenträgerabbild brennen

SpeedCommander: Brennfunktionen verwenden
Datenträgerabbild brennen

Mit der Pro-Version von SpeedCommander können Sie Datenträgerabbild-Dateien (Imagedateien) auf CD, DVD oder Blu-Ray brennen.

So brennen Sie ein Datenträgerabbild:
  1. Wählen Sie im Menü Pro den Befehl Datenträgerabbild brennen.
  2. Wählen Sie das Laufwerk, das zum Brennen verwendet werden soll.
  3. Wählen Sie die Geschwindigkeit und die Anzahl der Kopien.
  4. Tragen Sie im Eingabefeld Pfadname den vollständigen Dateinamen des zu brennenden Datenträgerabbilds ein.
  5. Wählen Sie im Kombinationsfeld Methode die gewünschte Brennmethode. Unterstützt werden TAO, DAO und DAO96.
  6. Aktivieren Sie das Kontrollkästchen Puffer-Schutz aktivieren, wenn die Buffer-Underrun-Protection des Brenners verwendet werden soll.
  7. Aktivieren Sie das Kontrollkästchen Brennvorgang simulieren, wenn vor dem Brennvorgang ein Probelauf durchgeführt werden soll.
  8. Aktivieren Sie das Kontrollkästchen Optimum Power Calibration (OPC), wenn vor dem Brennvorgang eine automatische Anpassung der Laserstärke an die speziellen Eigenschaften des aktuellen Rohlings durchgeführt werden soll.
  9. Aktivieren Sie das Kontrollkästchen Medium abschließen, wenn das Medium nach dem Schreiben finalisiert werden soll.
  10. Aktivieren Sie das Kontrollkästchen Daten nach dem Brennen überprüfen, wenn die geschriebenen Daten nach dem Brennvorgang noch einmal mit den zu schreibenden Daten verglichen werden sollen.
  11. Aktivieren Sie das Kontrollkästchen Medium nach dem Brennen auswerfen, wenn der Brenner das aktuelle Medium nach Abschluss des Brennvorgangs selbstständig auswerfen soll.
  12. Klicken Sie auf Brennen.

Weitere Themen

Datenträgerabbild erstellen


Geräteinformationen anzeigen

SpeedCommander: Brennfunktionen verwenden
Geräteinformatinen anzeigen

Mit der Pro-Version von SpeedCommander können Sie Informationen zu optischen Lese- und Schreibgeräten anzeigen.

So zeigen Sie Geräteinformationen an:
  1. Wählen Sie im Menü Pro den Befehl Geräteinformationen anzeigen.
  2. Wählen Sie im Dialogfeld Geräteinformationen das Gerät aus, für das Sie Informationen anzeigen möchten.
  3. In der Detailansicht werden nun detaillierte Informationen zum gewählten Gerät angezeigt.

Weitere Themen

Medieninformationen anzeigen


Medieninformationen anzeigen

SpeedCommander: Brennfunktionen verwenden
Medieninformationen anzeigen

Mit der Pro-Version von SpeedCommander können Sie detaillierte Informationen zu beschreibbaren und beschriebenen optischen Medien anzeigen.

So zeigen Sie Medieninformationen an:
  1. Wählen Sie im Menü Pro den Befehl Medieninformationen anzeigen.
  2. Wählen Sie im Dialogfeld Medieninformationen das entsprechende Gerät.
  3. In der Detailansicht werden nun detaillierte Informationen zum eingelegten Medium angezeigt.

Weitere Themen

Geräteinformationen anzeigen


Browsen im Web

SpeedCommander: Browsen im Web
Überblick

Mit dem Laufwerkssymbol Internet können Sie im Internet stöbern, ohne SpeedCommander dabei verlassen zu müssen.

Sie können die Option Internetansicht vergrößern im Einstellungsdialog auf der Seite Aussehen - Darstellung nutzen, um bei Aktivierung der Internetansicht das jeweilige Ordnerfenster automatisch auf eine bestimmte Größe zu erweitern. Nach dem Schließen der Internetansicht schaltet SpeedCommander das Ordnerfenster wieder auf die vorherige Größe zurück.

Weitere Themen

Webseiten anzeigen

Startseite festlegen

Suchseite festlegen


Webseiten anzeigen

SpeedCommander: Browsen im Web
Webseiten anzeigen

SpeedCommander bietet Ihnen mehrere Möglichkeiten, einzelne Webseiten anzuzeigen.

So wechseln Sie zu einer Seite, deren Adresse Sie wissen:
  • Geben Sie in der Adressleiste über dem Dateifenster die komplette Adresse ein.
So wechseln Sie zu einer Seite, die bereits in Ihrer Favoritenliste abgespeichert ist:
  1. Klicken Sie in der Symbolleiste auf die Schaltfläche Favoriten.
  2. Wählen Sie die gewünschte Seite aus.
So gelangen Sie zu Webseiten, die Sie vor kurzem besucht haben:
  • Um zu der zuletzt angezeigten Seite zu wechseln, klicken Sie auf die Schaltfläche Zurück.
  • Um eine Seite anzuzeigen, die Sie vor dem Klicken auf Zurück besucht haben, klicken Sie auf die Schaltfläche Vorwärts.
  • Um eine Liste der zuletzt besuchten Seiten anzuzeigen, klicken Sie auf die kleinen, abwärts gerichteten Pfeile neben den Schaltflächen Zurück oder Vorwärts.


Startseite festlegen

SpeedCommander: Browsen im Web
Startseite festlegen

Die Startseite ist die Seite, die bei jeder Aktivierung der Internetansicht in SpeedCommander angezeigt wird. Sie können jederzeit zur Startseite zurückkehren, indem Sie im Menü Datenträger den Befehl Internet - Startseite wählen oder in der Symbolleiste auf die Schaltfläche Internet Startseite klicken.

So ändern Sie die Startseite:
  1. Öffnen Sie mit dem Befehl Einstellungen aus dem Menü Extras den Einstellungsdialog.
  2. Wählen Sie die Seite Erweitert - Anwendungen & Internet.
  3. Geben Sie im Eingabefeld Startseite Ihre gewünschte Startseite ein.

Verwandte Themen

Suchseite festlegen


Suchseite festlegen

SpeedCommander: Browsen im Web
Suchseite festlegen

Die Suchseite ist die Seite, die Sie verwenden, um im Internet nach Informationen zu suchen. Sie können die Suchseite jederzeit aktivieren, indem Sie im Menü Datenträger den Befehl Internet - Suchen aufrufen oder in der Symbolleiste auf die Schaltfläche Internet Suchen klicken.

So ändern Sie die Suchseite:
  1. Öffnen Sie mit dem Befehl Einstellungen aus dem Menü Extras den Einstellungsdialog.
  2. Wählen Sie die Seite Erweitert - Anwendungen & Internet.
  3. Geben Sie im Eingabefeld Suchseite Ihre gewünschte Suchseite ein.

Verwandte Themen

Startseite festlegen


Zugriff auf FTP-Server

SpeedCommander: Zugriff auf FTP-Server
Überblick

Sie können mit Hilfe von SpeedCommander einfach auf FTP-Server zugreifen. Das Kopieren, Verschieben und Löschen von Dateien erfolgt dabei so, wie Sie es vom Arbeiten mit lokalen Laufwerken kennen. Die Voraussetzung für das Arbeiten mit einem FTP-Server ist eine aktive TCP/IP-Verbindung über die Winsock-Schnittstelle. Sollten Sie nicht ständig mit dem Internet verbunden sein, müssen Sie sich vor dem Zugriff auf einen FTP-Server mit dem Internet verbinden.

Sichere Verbindungen

SpeedCommander kann einfache und verschlüsselte Verbindungen zu FTP-Servern aufbauen. SFTP-Server werden ebenfalls unterstützt.

Unterstützung von Firewalls und Proxyserver

Neben der direkten Verbindung zu einem FTP-Server unterstützt SpeedCommander auch Verbindungen über Firewalls und Proxyserver.

Automatisches Aufrechterhalten der Verbindung

Viele FTP-Server beenden die Verbindung, wenn in einer bestimmten Zeit kein Datenfluss auftritt. Die Verbindung muss dann vor einem Einlesen eines Ordners oder dem Übertragen einer Datei neu aufgebaut werden. SpeedCommander hält die Verbindung im Hintergrund aufrecht, so dass kein neuer Verbindungsaufbau notwendig ist.

Weitere Themen

Standorte verwalten

Proxyserver verwenden

Verbindung herstellen

Dateien und Ordner kopieren

Dateien und Ordner löschen

Dateien und Ordner umbenennen oder verschieben

Dateiattribute ändern

Einstellungen anpassen


Standorte verwalten

SpeedCommander: Zugriff auf FTP-Server
Standorte verwalten

Mit Hilfe der Standortansicht können Sie eine Liste mit FTP-Servern verwalten, zu denen Sie mit SpeedCommander eine Verbindung aufnehmen möchten. Wählen Sie im Laufwerksfenster das Symbol FTP mit der Laufwerkskennung 3, um die Standortansicht anzuzeigen. Wird das Symbol nicht angezeigt, dann muss es zuerst im Einstellungsdialog auf der Seite Aussehen - Darstellung aktiviert werden.

So erstellen Sie einen neuen Standort:
  1. Klicken Sie mit der rechten Maustaste in den freien Bereich der FTP-Standortansicht, um das Kontextmenü anzuzeigen. Halten Sie die rechte Maustaste etwas länger gedrückt, wenn bei gewähltem NC-Auswahlmodus die Option Markieren mit rechter Maustaste aktiviert ist.
  2. Wählen Sie im Kontextmenü den Befehl Neue Verbindung, der Dialog Neuen FTP-Standort erstellen erscheint.
  3. Tragen Sie einen Namen und optional eine Beschreibung für den Standort ein.
  4. Wählen Sie das zu verwendende Protokoll und geben Sie im Eingabefeld Server die Adresse des FTP-Servers sowie im Eingabefeld Port die entsprechende Portnummer ein.
  5. Tragen Sie die entsprechenden Benutzerinformationen für die Anmeldung ein.
So ändern Sie die Eigenschaften für einen Standort:
  1. Markieren Sie in der FTP-Standortansicht den Standort, den Sie bearbeiten möchten.
  2. Klicken Sie mit der rechten Maustaste auf den gewählten Standort, um das Kontextmenü anzuzeigen. Halten Sie die rechte Maustaste etwas länger gedrückt, wenn bei gewähltem NC-Auswahlmodus die Option Markieren mit rechter Maustaste aktiviert ist.
  3. Wählen Sie im Kontextmenü den Befehl Eigenschaften, der Dialog FTP-Standort bearbeiten erscheint.
  4. Ändern Sie die gewünschten Eigenschaften und schließen Sie den Dialog mit OK.
So löschen Sie einen Standort:
  1. Markieren Sie in der FTP-Standortansicht den Standort, den Sie löschen möchten.
  2. Klicken Sie mit der rechten Maustaste auf den gewählten Standort, um das Kontextmenü anzuzeigen. Halten Sie die rechte Maustaste etwas länger gedrückt, wenn bei gewähltem NC-Auswahlmodus die Option Markieren mit rechter Maustaste aktiviert ist.
  3. Wählen Sie im Kontextmenü den Befehl Standort löschen.

Adresse und Protokoll

SpeedCommander unterstützt mehrere Protokolle, die für den Anwender weitgehend transparent implementiert sind. FTP (Standard) sollte von jedem FTP-Server unterstützt werden, bietet aber die geringste Sicherheit. Empfohlen wird der Verbindungsaufbau über das Protokoll SFTP (Secure FTP über SSH). Hier werden sämtliche Daten sicher übertragen, zudem gibt es mit diesem Protokoll die geringsten Kompatibilitätsprobleme.

Stellen Sie bitte vor der Wahl des Protokolls sicher, dass der FTP-Server dieses auch unterstützt. Ansonsten kann keine Verbindung zum FTP-Server aufgebaut werden. Die folgende Tabelle enthält eine Übersicht der verschiedenen Protokolle zusammen mit dem jeweiligen Standardport.

Protokoll | Beschreibung | Port
FTP (Standard) | FTP-Verbindung ohne Verschlüsselung | 21
FTP+SSL (Explizit) | FTP-Verbindung mit verschlüsselter Kontrollverbindung nach Verbindungsaufbau | 21
FTP+SSL (Explizit mit verschlüsseltem Datenkanal) | FTP-Verbindung mit verschlüsselter Kontrollverbindung und verschlüsseltem Datenkanal nach Verbindungsaufbau | 21
FTP+SSL (Implizit) | Vollständig verschlüsselte FTP-Verbindung | 990
SFTP (Secure FTP über SSH) | Vollständig verschlüsselte FTP-Verbindung über SSH-Tunnel | 22

Geben Sie im Eingabefeld Server den Namen des FTP-Servers oder dessen IP-Adresse und im Eingabefeld Port die zu benutzende Portnummer ein. Achten Sie bitte darauf, dass keine führenden Protokollspezifikationen verwendet werden. Gültige Einträge sind z.B.

  • www.servername.de
  • ftp.servername.de
  • 192.168.0.230

Ungültige Einträge wären

  • ftp://www.servername.de
  • ftp://192.168.0.230

Das Kontrollkästchen Passiver Modus legt fest, ob der FTP-Server oder SpeedCommander die Datenverbindungen für das Anzeigen von Verzeichnisinhalten sowie für das Hoch-/Herunterladen initiieren soll. Aktivieren Sie das Kontrollkästchen, wenn SpeedCommander die Datenverbindungen herstellen soll. Dies ist vorteilhaft bei bestimmten Firewall-Konfigurationen, die keinen Verbindungsaufbau von außen erlauben.

Benutzerinformationen

Beim Zugriff auf öffentliche FTP-Server wählen Sie im Kombinationsfeld Anmeldung den Eintrag Benutzername und Kennwort und lassen die Eingabefelder Benutzername und Kennwort leer. In diesem Fall stellt SpeedCommander die Verbindung mit dem Benutzernamen anonymous und dem Kennwort anonymous@anonymous.com her.

Der Zugriff auf private FTP-Server ist dagegen nur mit den entsprechenden Benutzerinformationen möglich. In den meisten Fällen sind dies Benutzername und Kennwort, beim Protokoll SFTP (Secure FTP über SSH) kann alternativ auch ein Benutzername in Verbindung mit einem privaten Schlüssel verwendet werden. Zur Verwendung eines privaten Schlüssels geben Sie im Feld Dateiname den vollständigen Pfadnamen der entsprechenden Schlüsseldatei an. SpeedCommander unterstützt Schlüsseldateien in den folgenden Formaten:

  • Putty
  • SSH1
  • SSHcom
  • van Dyke

Wenn die Schlüsseldatei mit einem Kennwort geschützt ist, fragt SpeedCommander vor dem Verbindungsaufbau das Kennwort ab.

Erweiterte Standorteigenschaften

Zusätzlich zu den bisher gezeigten Einstellungen bietet SpeedCommander noch eine Reihe von erweiterten Einstellungen. Klicken Sie beim Bearbeiten des Standorts auf die Schaltfläche Erweitert, um die erweiterten Einstellungen anzuzeigen und zu bearbeiten.

Proxy-Server

Bei Verwendung eines Proxy-Servers geben Sie hier den gewünschten Proxy-Server an. Mit Globale Einstellung verwenden wird der im Einstellungsdialog gesetzte Standardwert verwendet.

Lokales Startverzeichnis

Der Verbindungsaufbau zu einem FTP-Server steht meist im Zusammenhang mit der Aktualisierung einer Website, die auf dem lokalen Computer bearbeitet wird. Durch Angabe eines lokalen Ordners kann SpeedCommander beim Herstellen der Verbindung zum FTP-Server automatisch in den Ordner wechseln, in dem sich die lokale Website befindet.

Idle-Timer

Viele FTP-Server trennen nach einer gewissen Zeit der Untätigkeit automatisch die Verbindung. SpeedCommander versucht dies zu verhindern, indem automatisch nach einer bestimmten Zeitspanne ohne Benutzeraktion ein LIST-Befehl an den FTP-Server geschickt wird. In der Standardeinstellung geschieht dies alle 180 Sekunden. Bei einigen FTP-Servern ist diese Zeitspanne allerdings zu lang, hier empfiehlt sich die Anpassung des Wertes auf 120 Sekunden. Sollte dies immer noch nicht reichen, muss der Wert weiter verringert werden.

Zeitzone

In der Regel gibt ein FTP-Server die Zeitstempel für Dateien und Ordner in seiner lokalen Zeit zurück. Entsprechend der Zeitzone, in der sich der FTP-Server befindet, kann sich der Zeitstempel von der lokalen Zeit des Client-Computers unterscheiden. SpeedCommander bietet daher in den erweiterten Standorteigenschaften die Möglichkeit, die Zeitzone für den FTP-Server anzupassen.

Initialisierung

Manchmal ist es erforderlich, dass der FTP-Server bei der Einwahl einen bestimmten Initialisierungsbefehl ausführt. Tragen Sie hier den Befehl ein, mehrere Befehle werden jeweils durch ein Semikolon getrennt. Beachten Sie bitte, dass hier nur Befehle verwendet werden können, die keine eigene Datenverbindung erfordern. Befehle zum Auflisten von Ordnern bzw. zum Übertragen von Dateien sind nicht möglich.

Parameter für LIST-Befehl

Beim Auflisten von Ordnern geben FTP-Server, die unter Unix laufen, nur die sichtbaren Ordner und Dateien zurück. Dateinamen mit einem führenden Punkt gelten als versteckt und werden normalerweise nicht angezeigt. Für die Anzeige dieser Dateien lässt sich der von SpeedCommander verwendete LIST-Befehl mit einem zusätzlichen Parameter versehen. Unter den gängigen Unix-Systemen lautet dieser Parameter -la.

UTF-8 Modus

Für die Kodierung von Dateinamen im vom FTP-Server zurückgegebenen Verzeichnislisting wird in der Regel die auf dem FTP-Server aktivierte Codetabelle verwendet. Dies ist unproblematisch, sofern der FTP-Server und der Client-Computer mit der gleichen Codetabelle arbeiten. Bei unterschiedlichen Codetabellen können die Dateinamen nicht mehr richtig dargestellt werden. Bei Aktivierung der Option UTF-8 Modus verwenden werden die Dateinamen beim Austausch von Informationen zwischen FTP-Server und SpeedCommander in UTF-8 kodiert, wenn der FTP-Server diese Möglichkeit unterstützt. Bei Verwendung des Protokolls SFTP (Secure FTP über SSH) werden die Dateinamen immer in UTF-8 kodiert, da dies Teil der Spezifikation ist.

MLSD-Befehl

Mit der Verwendung des MLSD-Befehls zum Auflisten von Ordnern anstelle des LIST-Befehls verwendet der FTP-Server für die Rückgabe des Verzeichnislistings ein standardisiertes Format, welches das Parsen der Dateinamen sowie der Dateiinformationen erheblich vereinfacht. Die Zeitstempel werden zudem immer im UTC-Format zurückgegeben, eine manuelle Anpassung der Zeitzone erübrigt sich. Zudem werden auch versteckte Dateien automatisch ohne zusätzliche Parameter aufgelistet.

MODE Z-Befehl

Einige FTP-Server bieten eine Datenkomprimierung an, antworten aber fehlerhaft auf die Befehle zur Aktivierung der Datenkomprimierung. Dies führt zu einer fehlerhaften Anzeige von Verzeichnislistings. Deaktivieren Sie in diesem Fall das Kontrollkästchen Komprimierung (MODE Z) verwenden für den betroffenen Standort.


Proxyserver verwenden

SpeedCommander: Zugriff auf FTP-Server
Proxyserver verwenden

Neben der direkten Verbindung zu einem FTP-Server kann SpeedCommander die Verbindung auch über einen Proxyserver herstellen. Unterstützt werden die universellen Protokolle

  • Socks 4
  • Socks 4a
  • Socks 5
  • HTTP Connect
  • Transparent

sowie die speziellen FTP-Protokolle

  • SITE remoteHost
  • OPEN remoteHost
  • USER remoteHost
So erstellen Sie einen neuen Proxyserver:
  1. Klicken Sie im Einstellungsdialog auf der Seite Erweitert - FTP-Client auf die Schaltfläche Erweitert, um die erweiterten Einstellungen für die FTP-Funktionen anzuzeigen.
  2. Wählen Sie die Schaltfläche Neu, das Dialogfeld Neuen Proxyserver einrichten erscheint.
  3. Geben Sie im Eingabefeld Name eine Bezeichnung für den Proxyserver ein und wählen Sie im Kombinationsfeld Typ das zu verwendende Protokoll.
  4. Tragen Sie im Eingabefeld Server den Namen des Proxyservers bzw. seine IP-Adresse und im Eingabefeld Port den entsprechenden Port ein.
  5. Füllen Sie die Eingabefelder Benutzername und Kennwort aus, wenn der Proxyserver Anmeldeinformationen benötigt.
  6. Schließen Sie das Dialogfeld mit OK.
So wählen Sie einen Proxyserver für eine Verbindung:
  1. Öffnen Sie die erweiterten Einstellungen des FTP-Standorts.
  2. Wählen Sie im Kombinationsfeld Proxyserver den gewünschten Proxyserver.
So wählen Sie einen Proxyserver als Standard für alle Verbindungen:
  1. Klicken Sie im Einstellungsdialog auf der Seite Erweitert - FTP-Client auf die Schaltfläche Erweitert, um die erweiterten Einstellungen für die FTP-Funktionen anzuzeigen.
  2. Wählen Sie im Kombinationsfeld Standard den entsprechenden Proxyserver.
  3. Öffnen Sie die erweiterten Einstellungen des FTP-Standorts.
  4. Wählen Sie im Kombinationsfeld Proxyserver den Eintrag Globale Einstellung verwenden.


Verbindung herstellen

SpeedCommander: Zugriff auf FTP-Server
Verbindung herstellen

Um die Verbindung mit einem FTP-Server herzustellen, wählen Sie in der FTP-Standortansicht den Server aus, zu dem Sie eine Verbindung aufnehmen möchten. Doppelklicken Sie auf den Eintrag oder wählen Sie im Menü Datenträger den Befehl FTP-Verbindung herstellen.

Unterhalb der Dateiliste wird ein Statusfenster angezeigt. In diesem Fenster werden alle Befehle, die an den FTP-Server geschickt werden, sowie die Reaktionen des FTP-Servers dargestellt. Sie können die Größe des Statusfensters ändern, indem Sie mit der linken Maustaste auf die Trennlinie zwischen Ordnerfenster und Statusfenster klicken, und diese verschieben.

Über den Befehl FTP-Verbindung trennen aus dem Menü Datenträger kann die Verbindung wieder getrennt werden. Hierbei wird nur die Verbindung zum FTP-Server getrennt, die Internetverbindung bleibt bestehen.

Sie können auch schnell eine Verbindung aufbauen, indem Sie in der Befehlseingabezeile einfach die FTP-Adresse (ftp://ftp.microsoft.com) eingeben.

Weitere Informationen

Standorte verwalten


Dateien und Ordner kopieren

SpeedCommander: Zugriff auf FTP-Server
Dateien und Ordner kopieren

Mit SpeedCommander können Sie Dateien von einem FTP-Server auf ein lokales Laufwerk oder ein Netzlaufwerk kopieren. SpeedCommander kann auch abgebrochene Downloads wieder aufnehmen, wenn der FTP-Server dies unterstützt.

Natürlich können Sie auch Dateien von einem lokalen Laufwerk oder einem Netzlaufwerk auf einen FTP-Server kopieren.

So kopieren Sie Dateien von einem FTP-Server:
  1. Stellen Sie eine Verbindung zum FTP-Server her und wechseln Sie in den Ordner, in dem sich die zu übertragenen Dateien befinden.
  2. Markieren Sie die Dateien, die Sie kopieren möchten.
  3. Wählen Sie aus dem Menü Datei den Befehl Kopieren.
  4. Geben Sie im Dialogfeld Kopieren das Ziel des Kopiervorgangs an.
  5. Aktivieren Sie die gewünschten zusätzlichen Einstellungen.
  6. Drücken Sie Eingabe oder klicken Sie auf OK, um die Operation sofort zu starten. Wählen Sie Später, wenn die Operation in die Warteschlange eingereiht werden soll.
So kopieren Sie Dateien auf einen FTP-Server:
  1. Stellen Sie eine Verbindung zum FTP-Server her und wechseln Sie in den Ordner, in dem die Dateien abgelegt werden sollen.
  2. Markieren Sie im anderen Ordnerfenster die Dateien und Ordner, die Sie auf den FTP-Server kopieren möchten.
  3. Wählen Sie aus dem Menü Datei den Befehl Kopieren.
  4. Aktivieren Sie die gewünschten zusätzlichen Einstellungen.
  5. Drücken Sie Eingabe oder klicken Sie auf OK, um die Operation sofort zu starten. Wählen Sie Später, wenn die Operation in die Warteschlange eingereiht werden soll.

Zusätzliche Einstellungen beim Kopieren von oder auf einen FTP-Server

Im folgenden werden die zusätzlichen Einstellungen beschrieben. Einige Einstellungen gelten nur für eine Übertragungsrichtung.

Filter

Mit Hilfe eines Dateifilters können Sie bestimmte Dateien und Ordner von der Datenübertragung ausschließen. Mehr zur Verwendung von Dateifiltern finden Sie hier.

Übertragungsmodus

Der Übertragungsmodus legt fest, ob die Zeilenendezeichen in Textdateien bei der Übertragung automatisch zwischen dem Windows-Format (\r\n) und dem Unix-Format (\n) umgewandelt werden sollen. Die Auswahl ASCII konvertiert die Zeilenendezeichen in alle Dateien, mit Binär werden alle Dateien ohne Konvertierung übertragen. Bei Verwendung von Automatisch werden nur die Dateien konvertiert, deren Dateierweiterungen im Einstellungsdialog auf der Seite Erweitert - FTP-Client eingetragen sind. Die Standardvorgabe für diese Einstellung wird ebenfalls im Einstellungsdialog festgelegt.

Dateizeit vom FTP-Server übernehmen

Mit der Aktivierung des Kontrollkästchens Dateizeit vom FTP-Server übernehmen wird der Zeitstempel der Datei auf dem FTP-Server nach dem Herunterladen auf die lokale Datei übertragen.

Automatische Konvertierung nach Kleinbuchstaben

Aktivieren Sie das Kontrollkästchen Automatische Konvertierung nach Kleinbuchstaben, wenn mögliche Großbuchstaben in Dateinamen beim Kopieren auf einen FTP-Server automatisch in Kleinbuchstaben umgewandelt werden sollen.

Zeitstempel auf FTP-Server übertragen

Mit Aktivierung des Kontrollkästchens Zeitstempel auf FTP-Server übertragen wird der Zeitstempel der lokalen Datei nach dem Upload auf die Zieldatei übertragen. Voraussetzung hierfür ist die Verwendung des Protokolls SFTP (Secure FTP über SSH) oder die Untersützung des MFMT-Befehls durch den FTP-Server.

Berechtigungen für Dateien setzen

Diese Option bietet die Möglichkeit, nach der Übertragung der Dateien auf den FTP-Server gleich die entsprechenden Berechtigungen zu setzen. Aktivieren Sie das Kontrollkästchen Berechtigung für Dateien nach Übertragung setzen auf und geben Sie im Eingabefeld eine dreistellige Zahl für die gewünschten Attribute ein. Die Attribute werden nur für Dateien gesetzt und nicht für Ordner.

Dateiübertragung im Hintergrund

Die Aktivierung des Kontrollkästchens Dateiübertragung im Hintergrund erlaubt das Weiterarbeiten während der Übertragung der Dateien von oder auf einen FTP-Server. Für jede Kopieraktion wird eine neue Verbindung zum FTP-Server erstellt. Stellen Sie sicher, dass der FTP-Server mehrere gleichzeitige Anmeldevorgänge unterstützt. Einige FTP-Server erlauben nur einen Anmeldevorgang pro IP-Adresse, die Dateiübertragung kann dann nicht im Hintergrund erfolgen.

Alle Dateien ohne Nachfrage überschreiben

SpeedCommander zeigt eine Bestätigungsmeldung an, wenn eine zu übertragene Datei im Zielordner bereits existiert. Mit Aktivierung des Kontrollkästchens Alle Dateien ohne Nachfrage überschreiben werden alle Dateien ohne Nachfrage überschrieben. Nach dem Programmstart ist diese Einstellung immer deaktiviert. Der Zustand dieser Einstellung wird während der Programmlaufzeit gespeichert und kann bei folgenden Operationen auch wieder deaktiviert werden.


Dateien und Ordner löschen

SpeedCommander: Zugriff auf FTP-Server
Dateien und Ordner löschen

Sie können Dateien und Ordner auf einem FTP-Server löschen.

So löschen Sie Dateien auf einem FTP-Server:
  1. Stellen Sie eine Verbindung zum FTP-Server her und wechseln Sie in den Ordner, in dem sich die zu löschenden Dateien befinden.
  2. Markieren Sie Dateien, die Sie löschen möchten.
  3. Wählen Sie aus dem Menü Datei den Befehl Löschen.
  4. Drücken Sie Eingabe, oder klicken Sie auf Ja, um die Dateien zu löschen.


Dateien und Ordner umbenennen oder verschieben

SpeedCommander: Zugriff auf FTP-Server
Dateien und Ordner umbenennen oder verschieben

Zusätzlich zum einfachen Umbenennen von Dateien und Ordnern können Sie auch Dateien und Ordner direkt auf dem FTP-Server verschieben.

So benennen Sie eine Datei oder einen Ordner um:
  1. Markieren Sie die gewünschte Datei oder den Ordner.
  2. Wählen Sie im Menü Datei den Befehl Umbenennen oder drücken Sie F9.
  3. Geben Sie den neuen Namen ein und drücken Sie Eingabe.
So verschieben Sie eine Datei oder einen Ordner auf dem FTP-Server:
  1. Markieren Sie die gewünschte Datei oder den Ordner.
  2. Wählen Sie im Menü Datei den Befehl Umbenennen oder drücken Sie F9.
  3. Geben Sie vor dem Namen den relativen Bezug zum Ordner ein, in den Sie die Datei oder den Ordner verschieben möchten. Ist das Ziel zum Beispiel der übergeordnete Ordner, dann fügen Sie vor dem Namen ../ ein.
  4. Drücken Sie Eingabe.


Dateiattributeändern

SpeedCommander: Zugriff auf FTP-Server
Dateiattribute ändern

Alle Dateien auf einem FTP-Server haben bestimmte Dateiattribute. Die Attribute geben an, ob und von wem eine Datei gelesen, ausgeführt oder beschrieben werden darf. Mit SpeedCommander können Sie diese Informationen für eine Datei, eine Gruppe von Dateien oder sogar für gesamte Ordner ändern.

So ändern Sie die Dateiattribute für Dateien und Ordner:
  1. Wählen Sie die Dateien und Ordner aus.
  2. Wählen Sie Eigenschaften aus dem Menü Datei, oder klicken Sie in der Symbolleiste auf das Symbol Eigenschaften.
  3. Sie können für die ausgewählten Dateien und Ordner Berechtigungen setzen oder löschen. Wählen Sie die gewünschten Attribute aus.
  4. Markieren Sie die Kontrollkästchen der gewünschten Lese-, Schreib- und Ausführrechte für den Besitzer, die Gruppe oder für die öffentlichen Benutzer.
  5. Drücken Sie Eingabe, oder klicken Sie auf OK.

Benutzer-ID (UID) setzen

Aktivieren Sie das Kontrollkästchen SUID, wenn eine ausführbare Datei mit den Rechten des Besitzers der Datei gestartet werden soll und nicht mit den Rechten des Benutzers, der die Datei ausführt.

Gruppen-ID (GID) setzen

Aktivieren Sie das Kontrollkästchen SGID, wenn eine ausführbare Datei mit den Rechten der Gruppe gestartet werden soll, der die Datei gehört und nicht mit den Rechten der Gruppe, welche die Datei ausführt.

Sticky-Bit setzen

Aktivieren Sie das Kontrollkästchen Sticky, wenn nur der Eigentümer einer Datei oder eines Ordners die Datei oder den Ordner löschen bzw. umbenennen darf.

Numerische Eingabe der Attribute

Zusätzlich zur Markierung der einzelnen Kontrollkästchen können Sie die Attribute auch als dreistellige Zahl eingeben. Die erste Ziffer bezieht sich dabei auf den Besitzer, die zweite auf die Gruppe und die dritte auf die öffentlichen Benutzer. Die jeweilige Ziffer wird durch Addition der Rechte ermittelt, wobei Lesen den Wert 4, Schreiben den Wert 2 und Ausführen den Wert 1 darstellt. Beispielsweise definiert die Zahl 644 Lese- und Schreibrechte für den Besitzer sowie Leserechte für die Gruppe und die öffentlichen Benutzer.

Bei Eingabe einer vierstelligen Zahl bezieht sich die erste Ziffer auf die erweiterten Flags, wobei SUID den Wert 4, SGID den Wert 2 und Sticky den Wert 1 darstellt. Die zweite Ziffer kennzeichnet dann die Rechte für den Besitzer, die dritte Ziffer die Rechte für die Gruppe und die vierte Ziffer die Rechte für die öffentlichen Benutzer.


Datenträger verwalten

SpeedCommander: Datenträger verwalten
Überblick

Dieser Abschnitt erläutert, wie Sie Daten von einer Diskette auf eine andere kopieren, Datenträger formatieren und benennen sowie Netzlaufwerke verbinden und trennen.

Weitere Themen

Datenträger formatieren

Datenträger kopieren

Datenträger umbenennen

Netzlaufwerk verbinden

Netzlaufwerk trennen


Datenträger formatieren

SpeedCommander: Datenträger verwalten
Datenträger formatieren

Bevor Sie eine Diskette oder eine Festplatte zur Speicherung von Dateien verwenden können, muss diese formatiert werden. SpeedCommander enthält ein schnelles und leistungsfähiges Hilfsprogramm zur Formatierung von Datenträgern.

So formatieren Sie einen Datenträger:
  1. Wählen Sie Datenträger formatieren aus dem Menü Datenträger.
  2. Wählen Sie das Laufwerk zur Formatierung aus. Klicken Sie auf OK. Das Dialogfeld Datenträger formatieren wird angezeigt.
  3. Wählen Sie Starten, um den Formatiervorgang zu beginnen.


Datenträger kopieren

SpeedCommander: Datenträger verwalten
Datenträger kopieren

Mit dem Befehl Datenträger kopieren können Sie Daten von einer Diskette auf eine andere kopieren. Sie können direkt von Diskette zu Diskette kopieren, ohne die Daten dazu vorher auf Ihre Festplatte kopieren zu müssen.

So kopieren Sie einen Datenträger:
  1. Wählen Sie Datenträger kopieren aus dem Menü Datenträger. Das Dialogfeld Datenträger kopieren erscheint.
  2. Wählen Sie die Quelle und das Ziel des Kopiervorgangs aus.
  3. Klicken Sie auf Starten, um den Kopiervorgang zu starten.


Datenträger umbenennen

SpeedCommander: Datenträger verwalten
Datenträger umbenennen

Sie können für jeden Datenträger Ihres Computers eine Bezeichnung festlegen.

So benennen Sie einen Datenträger:
  1. Klicken Sie in der Laufwerksleiste mit der rechten Maustaste auf den Datenträger, den Sie umbenennen möchten.
  2. Wählen Sie aus dem Kontextmenü den Befehl Eigenschaften.
  3. Geben Sie im Dialogfeld Eigenschaften in das Eingabefeld Bezeichnung den neuen Namen ein.
  4. Drücken Sie Eingabe oder klicken Sie auf OK.


Netzlaufwerk verbinden

SpeedCommander: Datenträger verwalten
Netzlaufwerk verbinden

Wenn Sie regelmäßig auf einen bestimmten Ordner auf einem Netzwerkserver zugreifen und dabei Zeit sparen möchten, können Sie diesem Ordner einen Laufwerksbuchstaben zuweisen.

So stellen Sie eine Verbindung zu einem Netzlaufwerk her:
  1. Wählen Sie den Befehl Netzlaufwerk verbinden aus dem Menü Datenträger. Das Dialogfeld Netzlaufwerk verbinden wird angezeigt.
  2. Wählen Sie den Laufwerksbuchstaben, den Sie zuordnen wollen, aus dem Kombinationsfeld Laufwerk aus. Alle bereits zugeordneten Laufwerke werden hier aufgeführt.
  3. Wählen Sie den Pfad für die Laufwerkszuordnung aus dem Kombinationsfeld Pfad aus. Wenn der gewünschte Pfad noch nicht in der Liste vorhanden ist, müssen Sie ihn manuell eingeben.
  4. Klicken Sie auf Verbindung beim Start wiederherstellen, wenn die Verbindung beim nächsten Start von Windows automatisch wiederhergestellt werden soll.
  5. Klicken Sie auf OK. Das ausgewählte Laufwerk ist nun dem gewünschten Ordner auf dem Netzwerkserver zugeordnet.

Verwandte Themen

Netzlaufwerk trennen


Netzlaufwerk trennen

SpeedCommander: Datenträger verwalten
Netzlaufwerk trennen

Sie können die Verbindung zu einem Netzlaufwerk trennen, wenn Sie nicht mehr regelmäßig auf das Netzlaufwerk zugreifen.

So trennen Sie die Verbindung zu einem Netzlaufwerk:
  1. Wählen Sie den Befehl Netzlaufwerk trennen aus dem Menü Datenträger.
  2. Das Dialogfeld Netzlaufwerk trennen wird angezeigt. Es enthält eine Liste der Laufwerke, deren Zuordnung aufgehoben werden kann.
  3. Wählen Sie das Laufwerk aus, dessen Verbindung getrennt werden soll.
  4. Drücken Sie Eingabe, oder klicken Sie auf OK.

Verwandte Themen

Netzlaufwerk verbinden


Weitere Möglichkeiten

SpeedCommander: Weitere Möglichkeiten
Überblick

Dieses Kapitel beschreibt Möglichkeiten, wie Sie SpeedCommander noch besser und effizienter zur täglichen Arbeit am Computer einsetzen können. Sie erfahren hier, wie Sie unter anderem auf den Ordnerverlauf und die verschiedenen Favoritenmenüs zugreifen sowie eigene Programme in SpeedCommander einbinden können.

Weitere Themen

Ordnerverlauf

Zugriff auf Systemordner

Ordnerfavoriten

Anwendungsfavoriten

Startmenü

Desktop-Menü

Internetfavoriten-Menü


Ordnerverlauf

SpeedCommander: Weitere Möglichkeiten
Ordnerverlauf

Der Ordnerverlauf ist eine Zusammenstellung der Ordner, die Sie während der aktuellen Sitzung mit SpeedCommander aktiviert gehabt haben. Sie können so schnell auf vorher aktivierte Ordner zugreifen, ohne sich mühselig durch die Ordnerstrukturen zu kämpfen.

In der Grundeinstellung wird ein Ordner erst dem Ordnerverlauf hinzugefügt, wenn Sie mindestens eine Sekunde in diesem Ordner aufgehalten haben. Die Zeitspanne kann im Einstellungsdialog auf der Seite Verhalten - Allgemein angepasst werden.

So greifen Sie auf den Ordnerverlauf zu:
  • Klicken Sie in der Symbolleiste auf die Schaltflächen Zurück oder Vorwärts, um den zuletzt aktivierten Ordner anzuzeigen.
  • Klicken Sie in der Symbolleiste auf die Pfeile neben den Schaltflächen Vorwärts oder Rückwärts, um eine Liste mit den zuletzt angezeigten Ordnern anzuzeigen.
So wechseln Sie schnell zum vorherigen Ordner:
  • Aktivieren Sie das Menü Ordner, zeigen Sie auf Wechseln zu und wählen Sie den Befehl Zurück; klicken Sie in der Symbolleiste auf die Schaltfläche Zurück; oder drücken Sie Alt+Cursor nach links.
So wechseln Sie schnell zum nächsten Ordner:
  • Aktivieren Sie das Menü Ordner, zeigen Sie auf Wechseln zu und wählen Sie den Befehl Vorwärts; klicken Sie in der Symbolleiste auf die Schaltfläche Vorwärts; oder drücken Sie Alt+Cursor nach rechts.


Systemordner

SpeedCommander: Weitere Möglichkeiten
Systemordner

Mit dem Systemordner-Menü gelangen Sie schnell in alle wichtigen Systemordner.

So wechseln Sie in einen Systemordner:
  1. Aktivieren Sie das Menü Ordner und zeigen Sie auf Systemordner oder klicken Sie in der Symbolleiste auf die Schaltfläche Systemordner.
  2. Wählen Sie den Systemordner aus, in den Sie wechseln möchten.

Liste der verfügbaren Systemordner

Die folgenden Tabellen zeigen die Systemordner, die SpeedCommander als Menüeinträge anbietet. Es werden nur die Ordner angezeigt, die auf dem aktuellen System auch vorhanden sind.

Ordner des Benutzers

Ordner | Bis Windows XP | Ab Windows Vista
Dokumente | %USERPROFILE%\Eigene Dateien | %USERPROFILE%\Dokumente
Bilder | %USERPROFILE%\Eigene Dateien\Eigene Bilder | %USERPROFILE%\Bilder
Musik | %USERPROFILE%\Eigene Dateien\Eigene Musik | %USERPROFILE%\Musik
Videos | %USERPROFILE%\Eigene Dateien\Eigene Videos | %USERPROFILE%\Videos
Computer | Desktop\Arbeitsplatz | Desktop\Computer
Favoriten | %USERPROFILE%\Favoriten | %USERPROFILE%\Favoriten
Desktop | %USERPROFILE%\Desktop | %USERPROFILE%\Desktop
Startmenü | %USERPROFILE%\Startmenü | %APPDATA%\Microsoft\Windows\Startmenü
Downloads | <Nicht vorhanden> | %USERPROFILE%\Downloads

Gemeinsam verwendete Ordner

Ordner | Bis Windows XP | Ab Windows Vista
Öffentliche Dokumente | %ALLUSERSPROFILE%\Eigene Dateien | %PUBLIC%\Dokumente
Öffentliche Bilder | %ALLUSERSPROFILE%\Eigene Dateien\Eigene Bilder | %PUBLIC%\Bilder
Öffentliche Musik | %ALLUSERSPROFILE%\Eigene Dateien\Eigene Musik | %PUBLIC%\Musik
Öffentliche Videos | %ALLUSERSPROFILE%\Eigene Dateien\Eigene Videos | %PUBLIC%\Videos
Öffentlicher Desktop | %ALLUSERSPROFILE%\Desktop | %PUBLIC%\Desktop
Öffentliches Startmenü | %ALLUSERSPROFILE%\Startmenü | %ALLUSERSPROFILE%\Microsoft\Windows\Startmenü

Verschiedene Ordner

Ordner | Bis Windows XP | Ab Windows Vista
Benutzerprofil | %USERPROFILE% | %USERPROFILE%
Programmdaten | %ALLUSERSPROFILE%\Anwendungsdaten | %ALLUSERSPROFILE%
Anwendungsdaten | %USERPROFILE%\Anwendungsdaten | %USERPROFILE%\AppData\Roaming
Lokale Anwendungsdaten | %USERPROFILE%\Lokale Einstellungen\Anwendungsdaten | %USERPROFILE%\AppData\Local
Cookies | %USERPROFILE%\Cookies | %LOCALAPPDATA%\Microsoft\Windows\Cookies
Verlauf | %USERPROFILE%\Lokale Einstellungen\Verlauf | %LOCALAPPDATA%\Microsoft\Windows\Verlauf
Temporäre Internetdateien | %USERPROFILE%\Lokale Einstellungen\Temporary Internet Files | %LOCALAPPDATA%\Microsoft\Windows\Temporary Internet Files
Senden an | %USERPROFILE%\SendTo | %APPDATA%\Microsoft\Windows\SendTo
Schriftarten | %WINDIR%\Fonts | %WINDIR%\Fonts
Zuletzt verwendet | %USERPROFILE%\Zuletzt verwendete Dokumente | %APPDATA%\Microsoft\Windows\Zuletzt verwendet

Windows, System und Programme

Name | Bis Windows XP | Ab Windows Vista
Windows | %WINDIR% | %WINDIR%
Systemverzeichnis | %WINDIR%\System32 | %WINDIR%\System32
Systemverzeichnis (x86) | %WINDIR%\SysWOW64 | %WINDIR%\SysWOW64
Programmdateien | %SYSTEMDRIVE%\Programme | %SYSTEMDRIVE%\Programme
Programmdateien (x86) | %SYSTEMDRIVE%\Programme (x86) | %SYSTEMDRIVE%\Programme (x86)
Gemeinsame Programmdateien | %PROGRAMFILES%\Gemeinsame Dateien | %PROGRAMFILES%\Common Files
Gemeinsame Programmdateien (x86) | %PROGRAMFILESX86%\Gemeinsame Dateien | %PROGRAMFILESX86%\Common Files


Ordnerfavoriten

SpeedCommander: Weitere Möglichkeiten
Ordnerfavoriten

Ordnerfavoriten sind Ordner, die Sie oft benutzen und die Sie schnell aktivieren möchten. Wenn Sie einen Ordnerfavoriten auswählen, wechselt SpeedCommander im aktiven Ordnerfenster in den entsprechenden Ordner. Zusätzlich können Sie auch noch einen Ordner festlegen, der gleichzeitig im inaktiven Fenster dargestellt werden soll.

So aktivieren Sie das Ordnerfavoriten-Menü:
  1. Klicken Sie mit der linken Maustaste auf das *-Symbol im Bereich über dem Ordnerfenster, in dem der Name des Ordners angezeigt wird.
  2. Aktivieren Sie das Menü Ordner und zeigen Sie auf Ordnerfavoriten.
  3. Drücken Sie Strg+Umschalt+O, O.
So fügen Sie einen Ordner den Ordnerfavoriten hinzu:
  1. Aktivieren Sie das Ordnerfavoriten-Menü.
  2. Wählen Sie im Ordnerfavoriten-Menü den Befehl Aktuellen Ordner hinzufügen.
So wechseln Sie schnell in einen Ordner:
  1. Aktivieren Sie das Ordnerfavoriten-Menü.
  2. Wählen Sie den Ordner aus, in den Sie wechseln möchten.
So verwalten Sie die Ordnerfavoriten:
  1. Wählen Sie im Ordnerfavoriten-Menü den Befehl Konfigurieren, das Dialogfeld Ordnerfavoriten konfigurieren erscheint.
  2. Klicken Sie mit der linken Maustaste einmal auf den Ordnerfavoriten, um dessen Eigenschaften zu ändern.
  3. Das Eingabefeld Aktives Fenster gibt den Ordner an, in welchen im aktiven Ordnerfenster gewechselt wird.
  4. Das Eingabefeld Inaktives Fenster gibt den Ordner an, in welchen im inaktiven Ordnerfenster gewechselt wird.
  5. Die Schaltfläche Neu erstellt unterhalb des gerade gewählten Eintrags einen neuen Ordnerfavoriten.
  6. Die Schaltfläche Untermenü erstellt unterhalb des gerade gewählten Eintrags ein neues Untermenü. Dies eröffnet Ihnen die Möglichkeit, die Ordnerfavoriten hierarchisch zu organisieren.
  7. Die Schaltfläche Löschen entfernt den gewählten Eintrag. Wenn Sie ein Untermenü löschen, wird nur das Menü gelöscht, die Einträge selbst bleiben erhalten.
  8. Zum Verschieben von Menüeinträgen klicken Sie mit der linken Maustaste auf den Eintrag, den Sie verschieben möchten und ziehen diesen durch Ziehen und Ablegen an die gewünschte Position.


Anwendungsfavoriten

SpeedCommander: Weitere Möglichkeiten
Anwendungsfavoriten

Viele Funktionen, die für die tägliche Arbeit am Computer benötigt werden, sind bereits in SpeedCommander enthalten. SpeedCommander ermöglicht es Ihnen jedoch auch, eigene Programme einzubinden, die per Menü oder Symbolleiste gestartet werden können. Sie können einem Anwendungsfavoriten beim Start auch Parameter übergeben. Diese Parameter werden dem Programm per Kommandozeile übermittelt.

So aktivieren Sie das Anwendungsfavoriten-Menü:
  1. Aktivieren Sie das Menü Extras und zeigen Sie auf Anwendungsfavoriten.
  2. Drücken Sie Strg+Umschalt+W, W.
So verwalten Sie die Anwendungsfavoriten:
  1. Aktivieren Sie das Anwendungsfavoriten-Menü und wählen Sie den Befehl Konfigurieren, das Dialogfeld Anwendungsfavoriten konfigurieren erscheint.
  2. Klicken Sie auf die Schaltfläche Neu, um einen neuen Eintrag zu erstellen, und vergeben Sie eine Bezeichnung für diesen Eintrag.
  3. Tragen Sie im Eingabefeld Anwendung den vollständigen Pfadnamen zum Programm ein.
  4. Wenn Sie möchten, dass ein bestimmter Ordner als Startordner festgelegt wird, so tragen Sie diesen im Eingabefeld Ordner ein.
  5. Im Eingabefeld Argumente können Sie der Anwendung Parameter übergeben. Die Bedeutung der einzelnen Argumente wird weiter unten beschrieben.
  6. Legen Sie im Kombinationsfeld Modus den Startmodus der Anwendung fest.
  7. Aktivieren Sie das Kontrollkästchen Dateinamen in 8.3-Notation, wenn die Anwendung eine DOS-Anwendung ist.
  8. Aktivieren Sie das Kontrollkästchen Ausführen mit angehobenen Rechten, wenn die Anwendung mit erhöhten Rechten gestartet werden soll. Die Länge des Pfadnamens der Anwendung und die Gesamtlänge der einzelnen Parameter darf in diesem Fall nicht größer als 2048 Zeichen betragen.
  9. Die Schaltfläche Untermenü erstellt unterhalb des gerade gewählten Eintrags ein neues Untermenü. Dies eröffnet Ihnen die Möglichkeit, die Ordnerfavoriten hierarchisch zu organisieren.
  10. Zum Verschieben von Menüeinträgen klicken Sie mit der linken Maustaste auf den Eintrag, den Sie verschieben möchten und ziehen diesen per Ziehen & Ablegen an die gewünschte Position.
So aktivieren Sie einen Anwendungsfavoriten:
  1. Aktivieren Sie das Anwendungsfavoriten-Menü.
  2. Wählen Sie das Programm aus, welches Sie starten möchten.

Bedeutung der einzelnen Argumente

Bezeichnung | Argument | Bedeutung
Aktiver Ordner | $(ActDir) | Vollständiger Pfadname des Ordners im aktiven Fenster
Inaktiver Ordner | $(InactDir) | Vollständiger Pfadname des Ordners im inaktiven Fenster
Linker Ordner | $(LeftDir) | Vollständiger Pfadname des Ordners im linken Fenster
Rechter Ordner | $(RightDir) | Vollständiger Pfadname des Ordners im rechten Fenster
Aktiver Auswahlbalken | $(ActCaret) | Vollständiger Pfad-/Dateiname des Eintrags unter dem Auswahlbalken im aktiven Fenster
Inaktiver Auswahlbalken | $(InactCaret) | Vollständiger Pfad-/Dateiname des Eintrags unter dem Auswahlbalken im inaktiven Fenster
Linker Auswahlbalken | $(LeftCaret) | Vollständiger Pfad-/Dateiname des Eintrags unter dem Auswahlbalken im linken Fenster
Rechter Auswahlbalken | $(RightCaret) | Vollständiger Pfad-/Dateiname des Eintrags unter dem Auswahlbalken im rechten Fenster
Aktive markierte Einträge | $(ActSel) | Vollständige Pfad-/Dateinamen der markierten Einträge im aktiven Fenster
Inaktive markierte Einträge | $(InactSel) | Vollständige Pfad-/Dateinamen der markierten Einträge im inaktiven Fenster
Linke markierte Einträge | $(LeftSel) | Vollständige Pfad-/Dateinamen der markierten Einträge im linken Fenster
Rechte markierte Einträge | $(RightSel) | Vollständige Pfad-/Dateinamen der markierten Einträge im rechten Fenster
Dateiliste in Ansi | $(ActSelLst) | Temporäre Listendatei mit den vollständigen Pfad-/Dateinamen der markierten Einträge aus dem aktiven Fenster im Ansi-Format
Dateiliste in UTF-8 | $(ActSelLstU8) | Temporäre Listendatei mit den vollständigen Pfad-/Dateinamen der markierten Einträge aus dem aktiven Fenster im UTF-8 Format
Dateiliste in UTF-16 | $(ActSelLstU16) | Temporäre Listendatei mit den vollständigen Pfad-/Dateinamen der markierten Einträge aus dem aktiven Fenster im UTF-16 Format


Internetfavoriten-Menü

SpeedCommander: Weitere Möglichkeiten
Internetfavoriten-Menü

Das Internetfavoriten-Menü dient ähnlich den Ordnerfavoriten zur schnellen Aktivierung von favorisierten Ordnern oder Internetadressen. Im Gegensatz zu den Ordnerfavoriten ist das Internetfavoriten-Menü jedoch systemweit abrufbar und wird ebenso vom Internet Explorer verwendet.

So fügen Sie einen Ordner oder eine Webseite zum Internetfavoriten-Menü hinzu:
  1. Aktivieren Sie in einem Ordnerfenster den Ordner oder die Webseite, die Sie dem Internetfavoriten-Menü hinzufügen möchten.
  2. Aktivieren Sie das Menü Extras, zeigen Sie auf Internetfavoriten und wählen Sie den Befehl Zu Favoriten hinzufügen.
  3. Geben Sie im Dialogfeld Zu Favoriten hinzufügen einen Namen an, unter dem der Favorit gespeichert werden soll.
  4. Drücken Sie Eingabe, oder klicken Sie auf OK.
So wählen Sie einen Eintrag aus dem Internetfavoriten-Menü aus:
  1. Aktivieren Sie das Menü Extras, zeigen Sie auf Internetfavoriten oder klicken Sie in der Symbolleiste auf die Schaltfläche Internetfavoriten.
  2. Wählen Sie aus dem darauf erscheinenden Menü den Favoriten aus, den Sie aktivieren möchten.


Startmenü

SpeedCommander: Weitere Möglichkeiten
Startmenü

Mit dem Startmenü können Sie sehr schnell auf alle Programme im Startmenü von Windows zugreifen, ohne SpeedCommander verlassen zu müssen.

So greifen Sie auf das Startmenü zu:
  1. Aktivieren Sie das Menü Extras und zeigen Sie auf Startmenü oder klicken Sie in der Symbolleiste auf die Schaltfläche Startmenü.
  2. Wählen Sie aus dem darauf erscheinenden Menü das Programm aus, das Sie starten möchten.


Desktop-Menü

SpeedCommander: Weitere Möglichkeiten
Desktop-Menü

Mit dem Desktop-Menü können Sie sehr schnell auf alle Symbole des Desktops von Windows zugreifen, ohne dafür alle Anwendungen minimieren zu müssen.

So greifen Sie auf die Symbole des Desktops zu:
  1. Aktivieren Sie das Menü Extras und zeigen Sie Desktop oder klicken Sie in der Symbolleiste auf die Schaltfläche Desktop.
  2. Wählen Sie aus dem darauf erscheinenden Menü das Symbol aus, das Sie aktivieren möchten. Stellt das Symbol eine Verknüpfung zu einem Programm dar, wird dieses Programm gestartet. Ist das Symbol dagegen eine Verknüpfung zu einem Ordner, wird der Order im aktiven Ordnerfenster angezeigt.


Konfiguration

SpeedCommander: Konfiguration
Überblick

Dieses Kapitel beschreibt, wie Sie SpeedCommander konfigurieren und so an Ihre persönliche Arbeitsweise anpassen können. Sie können die Anzeige auf dem Bildschirm, den Inhalt der Fenster und die Schriftarten und Farben ändern sowie auswählen, welchen Editor Sie aus dem SpeedCommander heraus aufrufen möchten.

Sie können die Symbolleisten und das Menü frei gestalten sowie vielen Befehlen in SpeedCommander eigene Tastenkürzel zuordnen.

Weitere Themen

Einstellungen

Anpassen

Schriftart anpassen

Einstellungen sichern und wiederherstellen

Installation auf einem USB-Stick

Kommandozeilenparameter


Einstellungen

SpeedCommander: Konfiguration
Einstellungen

Im Einstellungsdialog ändern Sie verschiedene Einstellungen von SpeedCommander. Sie können z.B. das Aussehen der Ordner- und Laufwerksfenster anpassen und die externen Programme zum Betrachten und Editieren von Dateien ändern. Zur Anzeige des Dialogfelds wählen Sie im Menü Extras den Befehl Einstellungen.

Mit Hilfe der Schaltfläche Übernehmen lassen sich die Auswirkungen der Änderungen auch bei noch geöffnetem Dialogfeld beobachten. Einige Einstellungen erfordern einen Neustart von SpeedCommander.

Aussehen

  • Darstellung
  • Farben
  • Dateien & Ordner
  • Netzwerk & Sortieren
  • Statuszeile & Brotkrumen
  • Details

Verhalten

  • Allgemein
  • Ordner & Laufwerke
  • NC-Kompatibilität
  • Registerkarten
  • Ordnergrößen
  • Dateioperationen
  • Archive & InfoTips

Erweitert

  • Anwendungen & Internet
  • FTP-Client
  • Schnellansicht
  • Kompression
  • Brennprojekte
  • Dateiverknüpfungen
  • Verschiedenes
  • Spezielles


Darstellung

Mit dem Dialogfeld Darstellung legen Sie die Sprache für die Benutzeroberfläche fest und blenden nicht benötigte Symbole in der Laufwerksanzeige aus. Zudem steuern Sie das grundlegende Aussehen und Verhalten der Listenansicht.

Allgemein

Im Kombinationsfeld Sprache können Sie die Sprache für die Benutzeroberfläche von SpeedCommander wählen. Unterstützt werden derzeit Deutsch und Englisch. Diese Einstellung betrifft nur die in SpeedCommander enthaltenen Ressourcen. Auf die vom Betriebssystem zur Verfügung gestellten Texte (z.B. Tastenkürzel) hat diese Einstellung keinen Einfluss. Nach einer Änderung der Spracheinstellung muss SpeedCommander neu gestartet werden.

Die beiden Einstellungen Screenreader-kompatible Menüs verwenden und Screenreader-kompatiblen Dialog zur Feldauswahl benutzen erleichtern die Bedienung für blinde Anwender oder Anwender mit Sehschwächen. Die eher traditionellen Menüs können nicht angepasst werden. Die geänderte Menüdarstellung ist erst nach einem Neustart von SpeedCommander sichtbar.

Zusätzliche Symbole für Laufwerksanzeige

SpeedCommander zeigt in der Laufwerksleiste neben den Symbolen für die einzelnen Laufwerke weitere Symbole an. Dazu gehören Symbole für den Desktop, die Netzwerkumgebung, das Internet, FTP, AddIns, die Dateiablagen und die Brennprojekte. Deaktivieren Sie die entsprechenden Kontrollkästchen, wenn die Symbole nicht in der Laufwerksansicht angezeigt werden sollen. Beachten Sie bitte, dass bei der Deaktivierung bestimmter Symbole auch die Funktionalität dieser Bereiche eingeschränkt sein kann.

Darstellung

Das Kontrollkästchen Automatische Auswahl legt fest, dass das Auswählen von Dateien und Ordnern durch Berühren mit der Maus ohne zusätzlichen Klick erfolgen soll. Durch zusätzliches Halten der Tasten Strg und Umschalt kann die Auswahl dabei verfeinert werden. Mit dieser Einstellung wird auch das Ordnerfenster unter dem Mauszeiger automatisch aktiviert.

Mit der Einstellung Trennlinien in der Detailansicht werden die einzelnen Einträge in der Detailansicht durch ein kleines Raster optisch getrennt dargestellt. Diese Option gilt nur für die Darstellung in der Detailansicht und nicht für die anderen Ansichten.

Spalten in allen Ansichten anzeigen legt fest, dass die Sortierspalten in allen Ansichten und nicht nur in der Detailansicht angezeigt werden. Mit Aktivierung dieser Einstellung kann sich auch die Anzeige von Einträgen in der Miniaturansicht verändern, wenn der angezeigte Spaltenkopf breiter ist als als die eigentliche Breite des Ordnerfensters. In diesem Fall zeigt SpeedCommander eine Scrollleiste an, damit alle Spalten erreichbar sind. Diese Einstellung ist erst ab Windows Vista verfügbar.

Die Einstellung Ganze Zeile markieren legt fest, dass ein markierter Eintrag in der Detailansicht vollständig hervorgehoben werden soll. Deaktivieren Sie dieses Kontrollkästchen, wenn nur der Bereich in der Namensspalte hervorgehoben werden soll.

Auswahl mit Kontrollkästchen legt fest, dass die Auswahl von Einträgen auch über automatisch eingeblendete Kontrollkästchen erfolgen kann. Das erleichtert das Markieren von mehreren Elementen im Windows-Auswahlmodus, weil die Modifizierungstasten Strg und Umschalt nicht mehr benötigt werden. Diese Einstellung ist erst ab Windows Vista verfügbar.

Bei Aktivierung der Einstellung Aktiven Eintrag hervorheben wird der Eintrag unter dem Mauszeiger optisch hervorgehoben. Voraussetzung dafür ist die Anzeige der Elemente im Explorer-Stil, die auf der Seite Aussehen - Farben festgelegt wird. Unter Windows XP hat diese Einstellung keine Funktion.

Fenster automatisch verbreitern

Bei Aktivierung der Schnellansicht oder der Internetansicht kann SpeedCommander die Breite der beiden Fenster automatisch vergrößern, um mehr Platz für die angezeigten Informationen zu schaffen. Zur Aktivierung dieser Funktion markieren Sie die Kontrollkästchen Schnellansicht auf bzw. Internetansicht auf und wählen Sie im entsprechenden Kombinationsfeld die gewünschte Breite. Nach Deaktivierung der Schnellansicht oder der Internetansicht stellt SpeedCommander wieder die vorherige Fensterbreite her.


Farben

SpeedCommander: Konfiguration
Farben

Das Dialogfeld Farben bietet Ihnen verschiedene Möglichkeiten, die farbliche Darstellung von Dateien und Ordnern anzupassen. Im oberen Teil befindet sich ein Vorschaubereich für das aktive und inaktive Ordnerfenster. So lassen sich Änderungen an den Farbeinstellungen sofort begutachten, ohne das Dialogfeld schließen zu müssen.

Aktivieren Sie das Kontrollkästchen Auswahlelemente im Explorer-Stil anzeigen, wenn die ausgewählten Elemente in der Listen- und Baumansicht wie im Explorer dargestellt werden sollen. Diese Funktion ist erst ab Windows Vista verfügbar.

Die Einstellung Titelzeilen mit Office 2003/2007-Farbverläufen anzeigen legt fest, dass der Hintergrund des Bereichs über den Ordnerfenstern, in dem der Name des Ordners angezeigt wird, mit einem zum jeweiligen Design passenden Farbverlauf gezeichnet wird. Deaktivieren Sie dieses Kontrollkästchen, wenn Sie die Farben für die Titelzeilen selbst festlegen möchten.

Farbschemen verwalten

Im Kombinationsfeld Schema werden die verfügbaren Farbschemen aufgelistet. Die beiden Schemen Windows-Standard und Norton Commander sind fest vorgegeben und können nicht geändert werden. Sie können aber als Vorlage für eigene Schemen verwendet werden.

Zur Erstellung eines neuen Schemas wählen Sie zuerst die gewünschte Vorlage und klicken anschließend auf das Plus-Symbol. Nach Eingabe eines Namens für das neue Schema können Sie die Farben für die einzelnen Elemente anpassen. Durch Klick auf das Minus-Symbol können einzelne nicht mehr benötigte Schemen gelöscht werden. Mit Hilfe des Umbenennen-Symbols lässt sich der Name eines Farbschemas ändern.

Farben für einzelne Elemente anpassen

Das Kombinationsfeld Element enthält alle Ansichtselemente von SpeedCommander, deren Farben angepasst werden können. Mit Hilfe der Farbauswahlfelder Text und Hintergrund wird die Text- und Hintergrundfarbe ausgewählt. Bei einigen Elementen lassen sich zwei Hintergrundfarben auswählen, dies entspricht einem Farbverlauf von links nach rechts. Die Farben für die Elemente Aktive Titelzeile und Inaktive Titelzeile können nur geändert werden, wenn die Einstellung Titelzeilen mit Office 2003/2007-Farbverläufen anzeigen deaktiviert ist.

Filter verwenden

SpeedCommander bietet die Möglichkeit, besondere Dateien farblich bzw. textlich hervorzuheben. Sie können z.B. Dateien eines bestimmten Typs mit einer speziellen Farbe kennzeichnen oder Dateien eines bestimmten Datums fett hervorheben. Die Charakterisierung dieser Dateien erfolgt mit Hilfe eines Dateifilters. Das Kombinationsfeld Filter zeigt alle definierten Dateien an. Die Schaltfläche ... neben dem Kombinationsfeld führt direkt zum Konfigurationsdialog für Dateifilter.

Wählen Sie im Kombinationsfeld Filter den Dateifilter, für welchen Sie die Farbeinstellungen anpassen möchten. Das Farbauswahlfeld Text legt die Textfarbe für den jeweiligen Eintrag fest. Im danebenliegenden Kombinationsfeld lässt sich der Schriftstil anpassen, während das Farbauswahlfeld Hintergrund die Hintergrundfarbe für den Eintrag bestimmt. Wählen Sie den Eintrag Automatisch, wenn Sie keine speziellen Farbeinstellungen festlegen möchten.

Die Reihenfolge der Filter im Konfigurationsdialog hat großen Einfluss auf die angezeigte Farbdarstellung. Bei der Ermittlung der Farben und des Schriftstils für einen Eintrag wertet SpeedCommander die Filter vom letzten bis zum ersten Eintrag aus. Das bedeutet, dass die Einstellungen eines weiter vorn befindlichen Filters eine höhere Bedeutung haben als die der nachfolgenden Filter.


Dateien & Ordner

SpeedCommander: Konfiguration
Dateien & Ordner

Das Dialogfeld Dateien & Ordner enthält Einstellungsmöglichkeiten zur Anpassung der Anzeige von Dateien und Ordnern.

Dateien

Das Kontrollkästchen Symbole für Dateien und Ordner anzeigen legt fest, ob SpeedCommander zu jedem Dateinamen auch das entsprechende Symbol anzeigen soll. Deaktivieren Sie diese Option, wenn Sie keine Symbole angezeigt haben möchten und das Anzeigen der Ordners beschleunigen wollen.

Mit der Einstellung Versteckte Dateien und Ordner anzeigen legen Sie fest, ob versteckte Dateien angezeigt oder ausgeblendet werden sollen. Versteckte Dateien sind Programm- oder Systemdateien, die nicht geändert oder gelöscht werden sollten. Das Kontrollkästchen besitzt drei Zustände. Im markierten Zustand werden alle Dateien und Ordner angezeigt. Ist es nicht markiert, dann werden alle versteckte Dateien und Ordner sowie die geschützten Systemdateien ausgeblendet. Im teilmarkierten Zustand werden versteckte Dateien und Ordner angezeigt, geschützte Systemdateien aber ausgeblendet. Dies ist die empfohlene Einstellung.

Die Einstellung Versteckte Dateien und Ordner etwas blasser anzeigen legt fest, dass die Symbole aller Dateien und Ordner mit den Dateiattributen System oder Versteckt etwas blasser angezeigt werden sollen. So lassen sich versteckte Dateien und Ordner besser von anderen unterscheiden.

Mit der Einstellung Lokalisierte Namen für Dateien und Ordner anzeigen wird festgelegt, ob SpeedCommander Datei- und Ordnernamen so anzeigen soll, wie sie auf dem Datenträger abgespeichert sind oder ob er wenn möglich die lokalisierten (deutschen) Entsprechungen anzeigen soll. Ab Windows Vista wird beispielsweise das Programmverzeichnis unter C:\Program Files auf der Festplatte gespeichert, der Windows-Explorer zeigt dieses aber als C:\Programme an. Deaktivieren Sie dieses Kontrollkästchen, wenn die Datei- und Ordnernamen in SpeedCommander unverändert angezeigt werden sollen.

Mit der Einstellung Dateinamenserweiterungen ausblenden für steuern Sie die Anzeige von Dateierweiterungen. Aktivieren Sie das Kontrollkästchen, wenn SpeedCommander die Erweiterungen von Dateien in Dateisystemordnern ausblenden soll. Im Auswahlfeld neben dem Kontrollkästchen können Sie festlegen, ob die Dateierweiterungen für alle Dateien oder nur für registrierte Dateitypen ausgeblendet werden sollen. Auch bei deaktivierter Einstellung kann es systembedingt vorkommen, dass in einigen virtuellen Ordnern die Dateierweiterung ausgeblendet wird.

Ordner

Aktivieren Sie das Kontrollkästchen Ordner besonders kennzeichnen, wenn Sie in der Listenansicht Ordner von Dateien visuell abgrenzen möchten. Dies ist z.B. sinnvoll, wenn Sie die Dateisymbole ausgeblendet haben. Der Text im Editierfeld Vorlage legt dabei fest, wie die Ordner gekennzeichnet werden sollen. %1 wird bei der Anzeige durch den Ordnernamen ersetzt, die Vorlage [%1] würde den Ordnernamen Windows z.B. als [Windows] darstellen.

Die Einstellung Leere Ordner etwas blasser anzeigen ermöglicht eine besondere Kennzeichnung von leeren Ordnern. Beachten Sie bitte, dass die Aktivierung dieser Einstellung das Einlesen der Ordnerfenster etwas verlangsamen kann, weil SpeedCommander bei jedem Unterordner prüfen muss, ob er Dateien oder Unterverzeichnisse enthält.

Das Kontrollkästchen Ordner bei Baumansicht ausblenden legt fest, dass bei aktivierter Baumansicht in der Listenansicht nur Dateien und keine Ordner angezeigt werden sollen. Dies kann die Übersichtlichkeit erhöhen, wenn ein Ordner besonders viele Unterordner enthält.

SpeedCommander zeigt in der Grundeinstellung als ersten Eintrag in der Listenansicht einen Eintrag, der immer für den übergeordneten Ordner (..) steht. Deaktivieren Sie das Kontrollkästchen Verweis auf Elternordner anzeigen, wenn Sie diesen Eintrag immer ausblenden möchten. Wenn Sie diesen Eintrag nur im Hauptverzeichnis eines Laufwerks ausblenden möchten, dann deaktivieren Sie stattdessen die Einstellung Verweis auf Elternordner im Hauptverzeichnis anzeigen.

Die Einstellung Immer 'Desktop' als obersten Eintrag in der Baumansicht anzeigen legt fest, dass die Baumansicht immer mit dem Desktop starten soll. Deaktivieren Sie dieses Kontrollkästchen, wenn stattdessen der erste Eintrag in der Baumansicht immer das Hauptverzeichnis des aktuellen Laufwerks bzw. die Netzwerkumgebung sein soll.

Spalten

Die Anzeige von Zeitstempeln in der Listenansicht folgt den Regionseinstellungen in der Systemsteuerung für Kurzes Datum und Uhrzeit. Die Einstellung Dynamisches Datumsformat ermöglicht eine flexible Formatierung der Zeitstempel in Abhängigkeit von der jeweiligen Spaltenbreite. Breitere Spalten zeigen so mehr Informationen an als schmalere:

  • Dienstag, 10. Mai 2011 16:31
  • Di, 10. Mai 2011 16:31
  • 10. Mai 2011 16:31
  • 10.05.2011 16:31
  • 10.05.11 16:31
  • 10.05.2011
  • 10.05.11
  • 10.05

Das Kombinationsfeld Dateigröße in legt fest, wie in der Detailansicht die Dateigröße angezeigt wird:

  • Wählen Sie Bytes, wenn die Dateigröße immer in Bytes angezeigt werden soll.
  • Wählen Sie KiB/Bytes, wenn die Dateigröße für Dateien größer als 1 MiB in KiB angezeigt werden soll.
  • Wählen Sie KiB, wenn die Dateigröße immer in KiB angezeigt werden soll.
  • Wählen Sie MiB/KiB/Bytes, wenn die Dateigröße jeweils in MiB, KiB oder Bytes angezeigt werden soll.
  • Wählen Sie Automatisch, wenn SpeedCommander die passende Dateigröße selbst bestimmen soll.


Netzwerk & Sortieren

SpeedCommander: Konfiguration
Netzwerk & Sortieren

Mit dem Dialogfeld Netzwerk & Sortieren passen Sie die Anzeige der Netzwerkumgebung an und legen die Sortiereinstellungen fest. Sie können auch festlegen, dass bestimmte Dateien und Ordner automatisch ausgeblendet werden sollen.

Netzwerk

Die Einstellung Freigegebene Drucker anzeigen legt fest, ob neben den Freigaben für Ordner auch die freigegebenen Drucker angezeigt werden sollen. Das bietet die Möglichkeit, Verwaltungsfunktionen für die freigegebenen Drucker (z.B. Anzeige der Druckerwarteschlange) direkt aus SpeedCommander aufzurufen.

In der Grundeinstellung zeigt SpeedCommander nur die Freigaben eines Servers an, die für alle Benutzer sichtbar sind. Aktivieren Sie das Kontrollkästchen Administrative und versteckte Freigaben anzeigen, wenn SpeedCommander in der Netzwerkumgebung auch administrative und versteckte Freigaben anzeigen soll. Solche Freigaben sind durch ein abschließendes Dollarzeichen ($) gekennzeichnet.

Das Kontrollkästchen Zusätzliche Netzwerkgeräte anzeigen (z.B. Router und Multimedia) legt fest, ob in der obersten Ebene der Netzwerkumgebung auch Einträge für Router und Multimedia-Freigaben angezeigt werden sollen. Deaktivieren Sie diese Einstellung, wenn nur Server mit Dateifreigaben angezeigt werden sollen.

Aktivieren Sie das Kontrollkästchen Bei Aktivierung der Netzwerkumgebung immer die oberste Ebene anzeigen, wenn beim Aufruf der Netzwerkumgebung über die Laufwerkleiste immer die Netzwerkumgebung mit einer Liste der verfügbaren Rechner angezeigt werden soll. Ist diese Einstellung deaktiviert, dann versucht SpeedCommander, die Verbindung zum zuletzt in der Netzwerkumgebung angezeigten Rechner wiederherzustellen. Dies kann teilweise zu Verzögerungen führen, wenn der zuletzt angezeigte Rechner nicht mehr verfügbar ist.

Sortieren

Das Kontrollkästchen Dateinamen mit Zahlen nach numerischem Wert sortieren legt fest, ob Dateinamen mit Zahlen alphabetisch sortiert werden sollen oder ob der numerische Wert der Zahlen bei der Sortierung beachtet werden soll. Die folgende Tabelle zeigt die Unterschiede zwischen alphabetischer und numerischer Sortierung:

Alphabetisch | Numerisch
10Titel 1Titel 2Titel Tit10el Tit1el Tit2el Titel1 Titel10 Titel2 | 1Titel 2Titel 10Titel Tit1el Tit2el Tit10el Titel1 Titel2 Titel10

Aktivieren Sie das Kontrollkästchen Ordner unabhängig von Sortierung immer nach Namen sortieren, wenn die Ordner immer in alphabetischer Reihenfolge angezeigt werden sollen. Deaktivieren Sie diese Einstellung, wenn auch bei Ordnern das aktuelle Sortierkriterium beachtet werden soll.

Die Einstellung Automatische Sortierung nach dem Umbenennen eines Eintrags legt fest, ob die Dateiliste nach dem Umbenennen einer Datei oder eines Ordners über das Kontextmenü bzw. den Menübefehl neu sortiert werden soll. Sie sollten diese Option deaktivieren, wenn Sie häufig mehrere aufeinanderfolgende Dateien nacheinander umbenennen.

Dateien und Ordner ausblenden

SpeedCommander kann bestimmte Dateien und Ordner automatisch von der Ansicht ausschließen. Ein Beispiel dafür ist z.B. der Ordner System Volume Information in jedem Hauptverzeichnis, in den aufgrund fehlender Rechte aber nicht gewechselt werden kann. Nach einem Klick auf die Schaltfläche Konfigurieren öffnet sich der Konfigurationsdialog, in dem die auszublendenden Ordner festgelegt werden können. Sie können hier einfache Dateinamen eintragen, die Verwendung von Pfadangaben oder Stellvertreterzeichen ist nicht möglich.

Initialisierungsordner für Spaltenerweiterungen

Einige Spaltenerweiterungen für Windows XP erfordern bei der Initialisierung die Angabe eines Ordners, da sie nur in bestimmten Ordnern funktionieren. Ein Beispiel dafür ist TortoiseSVN, das seine Spaltenerweiterungen nur für Ordner unter Quellcodekontrolle anbietet. Klicken Sie auf die Schaltfläche Konfigurieren, um den Konfigurationsdialog für die Initialisierungsordner zu öffnen. Wenn z.B. TortoiseSVN installiert ist und sich der Ordner C:\CVS-Projekt unter Quellcodekontrolle befindet, dann muss dieser Ordner als Initialisierungsordner eingetragen werden. Für jede Spaltenerweiterung, die einen speziellen Initialisierungsordner benötigt, muss immer nur ein Ordner angegeben werden. Bei TortoiseSVN reicht also die Angabe eines Ordners, der unter Quellcodekontrolle steht.

Langsame Netzwerkordner

Wenn beim Einlesen von Netzwerkordnern, die über das Internet verbunden sind, Verzögerungen auftreten, dann können Sie diese Ordner in die Liste der langsamen Netzwerkordner eintragen. SpeedCommander verzichtet dann beim Einlesen dieser Ordner auf die Ermittlung von speziellen Dateisymbolen und die automatische Berechnung von Ordnergrößen. Klicken Sie auf die Schaltfläche Konfigurieren, um den Konfigurationsdialog zu öffnen. Fügen Sie dann die betroffenen Ordner der Liste hinzu (z.B. N:\ oder \\SERVER).


Statuszeile & Brotkrumen

SpeedCommander: Konfiguration
Statuszeile & Brotkrumen

Mit Hilfe des Dialogfelds Statuszeile & Brotkrumen können Sie die Titel- und Statuszeile eines Ordnerfensters sowie die Brotkrumenanzeige anpassen.

Titelzeile für Ordnerfenster

In diesem Bereich können Sie festlegen, welche zusätzlichen Symbole in der Titelzeile über dem Ordnerfenster angezeigt werden sollen. Mit Verweis auf den Hauptordner anzeigen kann schnell in den Hauptordner eines Laufwerks gewechselt werden, Verweis auf den Elternordner anzeigen ermöglicht den schnellen Wechsel in den übergeordneten Ordner. Mit der Einstellung Ordnerhierarchie anzeigen kann ein Menü mit allen übergeordneten Ordnern bis zum Hauptordner eingeblendet werden. Ordnerfavoriten anzeigen fügt ein Symbol für den schnellen Zugriff auf die Ordnerfavoriten ein.

Brotkrumen-Navigation

Mit Hilfe des Kontrollkästchens Brotkrumen-Navigation aktivieren kann die Brotkrumen-Navigation ein- bzw. ausgeschaltet werden. Bei aktivierter Brotkrumen-Navigation werden die einzelnen Bestandteile eines Ordnernamens getrennt durch ein kleines Dreieck angezeigt. Durch Klick auf einen Namensteil kann schnell in den entsprechenden Ordner gewechselt werden. Klicken Sie auf das Dreieck, um die anderen Unterordner dieses Ordners anzuzeigen und in einen dieser Unterordner zu wechseln.

Die Einstellung 'Desktop' im Dateisystem anzeigen legt fest, ob bei Dateisystempfaden der vollständige Pfad bis zum Desktop angezeigt werden soll oder nur der Pfad bis zum Hauptverzeichnis des Laufwerks. Deaktivieren Sie diese Option, wenn die Brotkrumen-Navigation für Dateisystemordner erst im Hauptverzeichnis des Laufwerks starten soll.

Mit Laufwerksnamen anzeigen legen Sie fest, dass bei Hauptverzeichnissen von Datenträgern die vollständige Laufwerksbezeichnung angezeigt werden soll. Deaktivieren Sie diese Option, wenn Sie stattdessen nur den Laufwerksbuchstaben anzeigen möchten.

Statuszeile

In diesem Bereich können Sie Ihre eigene persönliche Statuszeile zusammenstellen. Jede Zeile im mehrzeiligen Editierfeld steht für eine Sektion. Es stehen verschiedene Platzhalter für die einzelnen Elemente sowie für die Formatierung zur Verfügung. Unterhalb des Editierfelds wird ein Vorschaubereich angezeigt, der nach jeder Änderung im Editierfeld sofort aktualisiert wird. Die Schaltfläche Vorlagen stellt einige fertig konfigurierte Statuszeilen zur Verfügung.

Im Eingabefeld Dateierweiterungen für Multimediadateien können Sie Dateierweiterungen festlegen, für welche die Dauer {tmp3} und {smp3} berechnet werden soll. Die Dauer kann aber nur berechnet werden, wenn für den Dateityp der entsprechende Codec im System installiert ist. In der Grundeinstellung ist hier mp3;avi;wmv;wav eingetragen.

Die Einstellung Ministatus anzeigen, wenn ein Element ausgewählt ist legt fest, dass bei der Fokussierung (NC-Auswahlmodus) bzw. Markierung (Windows-Auswahlmodus) eines Elements einige Informationen zum Element selbst (Name, Größe und Datum der letzten Änderung) angezeigt werden.


Details

SpeedCommander: Konfiguration
Details

Im Dialogfeld Details finden Sie verschiedene Einstellungen zum Hauptfenster sowie zur Miniaturansicht.

Erweitert

Mit der Einstellung In Infobereich minimieren wird festgelegt, dass SpeedCommander nach dem Minimieren des Hauptfensters als Symbol im Infobereich neben der Uhr angezeigt werden soll und nicht wie üblich in der Taskleiste. Beachten Sie bitte, dass nach Aktivierung dieser Option bei der Reaktivierung des Hauptfensters aus dem Infobereich mit Alt+Tab anschließend noch die Enter-Taste gedrückt werden muss.

Das Kontrollkästchen Startbildschirm anzeigen legt fest, ob beim Start von SpeedCommander ein kleiner Startbildschirm angezeigt werden soll. Deaktivieren Sie diese Option, wenn Sie SpeedCommander ohne Startbildschirm starten möchten.

Die Einstellung Basecap-Icon benutzen legt fest, dass SpeedCommander anstelle seines Programmsymbols das in früheren Versionen verwendete Basecap-Symbol verwenden soll. Nach Änderung dieser Option muss SpeedCommander neu gestartet werden.

Miniaturansicht

In diesem Bereich legen Sie die Größe und den Abstand der Symbole in der Miniaturansicht fest. Geben Sie im Feld Größe die gewünschte Symbolgröße ein. Die Eingabefelder Abstand (X) und Abstand (Y) legen den horizontalen bzw. vertikalen Abstand zwischen den einzelnen Symbolen fest. Alle drei Werte werden in Pixeln angegeben.

Titelzeile des Hauptfensters

Das Kombinationsfeld Elemente enthält die Einträge, die in der Titelzeile des Hauptfensters angezeigt werden können. Öffnen Sie das Kombinationsfeld und aktivieren Sie die Elemente, die in der Titelzeile angezeigt werden sollen. Folgende Elemente stehen zur Auswahl:

Element | Beschreibung
Programmname | Standardtitelzeile von SpeedCommander oder vom Anwender über den Kommandozeilenparameter /caption übergebene Titelzeile
Aktueller Ordnername | Name des gerade angezeigten Ordners (z.B. Windows)
Aktueller Pfadname | Vollständiger Name des gerade angezeigten Ordners (z.B. C:\Windows)
Aktuelles Layout | Name des Layouts, das zuletzt geladen wurde
Aktueller Filter | Name des Filters, der gerade verwendet wird
Benutzername | Name des angemeldeten Benutzers (z.B. Benutzer)
Computer- und Benutzername | Name des Computers und Name des angemeldeten Benutzers (z.B. Computer\Benutzer)
Lizenzinhaber | Name des Lizenzinhabers von SpeedCommander
Plattform (32/64-bit) | Zeigt an, ob die verwendete SpeedCommander-Version 32-bit oder 64-bit ist

Die einzelnen Elemente werden in der im Kombinationsfeld angezeigten Reihenfolge angezeigt, eine benutzerdefinierte Sortierung ist nicht möglich. Markieren Sie das Kontrollkästchen Ordner- und Pfadnamen am Anfang der Titelzeile anzeigen, wenn der aktuelle Ordner- oder Pfadname vor dem Programmnamen angezeigt werden soll. Mit Hilfe des Eingabefelds Pfadnamen auf eine Breite von xxx Pixeln kürzen können Sie eine Maximalbreite für längere Pfadnamen festlegen.


Allgemein

SpeedCommander: Konfiguration
Allgemein

Im Dialogfeld Allgemein finden Sie Konfigurationsoptionen zum Ordnerverlauf, zum Ziehen und Ablegen sowie zur Schnellsuche.

Programmstart und -ende

Die Einstellung Ordner- und Layout-Einstellungen beim Beenden speichern legt fest, ob beim Beenden von SpeedCommander die aktuellen Einstellungen der Ordnerfenster (aktueller Ordner, Sortierung, Sortierrichtung, Anzeige in der Listenansicht, Spalten in der Detailansicht, Filter) gespeichert werden sollen. SpeedCommander startet dann beim nächsten Mal mit den zuvor angezeigten Ordnerfenstern.

Aktivieren Sie das Kontrollkästchen Nur eine Programminstanz von SpeedCommander gleichzeitig erlaubt, wenn beim Start von SpeedCommander geprüft werden soll, ob SpeedCommander schon einmal gestartet wurde. In diesem Fall wird das bereits aktive SpeedCommander-Fenster in den Vordergrund gebracht.

Mit der Einstellung Speicherung der letzten Einträge in Eingabefeldern wird festgelegt, ob sich SpeedCommander die zuletzt getätigten Eingaben in den Dialogfeldern merken soll. Geben Sie im Eingabefeld die Anzahl der Einträge an, die sich SpeedCommander merken soll. Zum Löschen der bisher gespeicherten Eingaben deaktivieren Sie diese Option und klicken anschließend auf Übernehmen.

Ordnerverlauf

Markieren Sie das Kontrollkästchen Ordnerverlauf beim Beenden speichern, wenn die Liste der besuchten Ordner beim Beenden von SpeedCommander gespeichert werden soll. Der Ordnerverlauf wird für jedes Ordnerfenster separat gespeichert.

Die Einstellung Ordner verzögert in Verlauf aufnehmen nach legt fest, dass beim Wechsel in einen Ordner dieser erst zum Verlauf hinzugefügt wird, wenn Sie sich für eine bestimmte Zeit in diesem Ordner aufgehalten haben. Dies erhöht die Übersichtlichkeit des Ordnerverlaufs, da die Durchgangsordner auf dem Weg zu einem Ordner nicht in den Ordnerverlauf aufgenommen werden.

Ziehen & Ablegen

Mit der Einstellung Dateisymbole und Zielbeschreibung beim Ziehen anzeigen wird festgelegt, dass beim Ziehen von Einträgen mit der Maus das Dateisymbol sowie eine Beschreibung der Aktion und des aktuellen Zielordners angezeigt werden sollen. Diese Funktion steht erst ab Windows Vista zur Verfügung.

Aktivieren Sie die Einstellung Explorer-kompatibles Verhalten (Verschieben auf dem gleichen Laufwerk), wenn Sie wie im Explorer Dateien auf dem gleichen Laufwerk vorzugsweise verschieben und über Laufwerksgrenzen hinweg kopieren möchten. Deaktivieren Sie diese Option, wenn beim Ziehen und Ablegen mit der linken Maustaste immer kopiert werden soll.

Beim Ziehen und Ablegen von Dateien und Ordnern mit der rechten Maustaste wird ein Kontextmenü angezeigt, aus dem Sie eine mögliche Operation auswählen (Kopieren / Verschieben / Verknüpfung erstellen) oder den Vorgang abbrechen können. Aktivieren Sie das Kontrollkästchen Beim Ziehen mit der rechten Maustaste immer verschieben, wenn Sie die Dateien und Ordner ohne Anzeige eines Menüs gleich verschieben wollen.

Aktivieren Sie die Einstellung Automatisches Öffnen von Ordnern nach, wenn beim Ziehen und Ablegen auf einen Ordner dieser automatisch geöffnet und angezeigt werden soll. Im daneben liegenden Kombinationsfeld können Sie die Zeitspanne einstellen, nach welcher der Ordner geöffnet wird.

Schnellsuche

Im Kombinationsfeld Schnellsuche im aktuellen Ordner wird festgelegt, ob bei der Schnellsuche in der Listenansicht ein kleines Dialogfeld angezeigt und wie es aktiviert werden soll. Wählen Sie Deaktiviert, wenn kein Dialogfeld angezeigt und die Schnellsuche durch schnelles Eintippen der Anfangsbuchstaben durchgeführt werden soll. Die Auswahl Buchstabe legt fest, dass das Eingabefeld für die Schnellsuche mit der Eingabe eines beliebigen Buchstabens aktiviert wird. Wählen Sie Alt + Buchstabe, um das Eingabefeld durch Drücken eines Buchstabens zusammen mit der Alt-Taste zu aktivieren. Die Eingabe eines Buchstabens ohne das Halten der Alt-Taste führt dann dazu, dass der Buchstabe direkt in die Eingabezeile weitergeleitet wird.

Aktivieren Sie das Kontrollkästchen Übereinstimmung vom ersten Buchstaben an, wenn Dateien gesucht werden sollen, die mit dem Suchtext vom Anfang an übereinstimmen. Ansonsten kann der Suchtext auch inmitten eines Dateinamens auftauchen.

Die Einstellung 'Enter' öffnet Dateien legt fest, dass beim Schließen der Schnellsuche mit der Enter-Taste die markierten Dateien oder Ordner geöffnet werden sollen.


Ordner & Laufwerke

SpeedCommander: Konfiguration
Ordner & Laufwerke

Im Dialogfeld Ordner & Laufwerke legen Sie das Verhalten von Ordnerfenstern und Laufwerksfenster fest und passen die Einstellungen zur Aktualisierung an.

Listenansicht

Die Einstellung Ausgewählter Filter gilt für alle Ordnerfenster gleichzeitig legt fest, ob die Auswahl eines Filters gleichzeitig für alle Ordnerfenster gelten soll. Deaktivieren Sie diese Option, wenn Sie für jedes Ordnerfenster einen eigenen Filter verwenden möchten.

Aktivieren Sie das Kontrollkästchen Spalten zwischen Ordnerfenstern bei Änderungen synchronisieren, wenn SpeedCommander bei einer Änderung der Spaltengröße oder der Reihenfolge der einzelnen Spalten in der Detailansicht gleichzeitig die Spalten in den anderen Ordnerfenstern angleichen soll. Die Angleichung erfolgt nur, wenn in beiden Fenstern der gleiche Ordnertyp angezeigt wird (z.B. C:\Windows und D:\). Sie erfolgt nicht, wenn zum Beispiel auf einer Seite ein lokaler Ordner und auf der anderen Seite ein Archiv angezeigt werden.

Mit der Einstellung Bei Wechsel in übergeordnetes Verzeichnis aktuellen Ordner markieren wird festgelegt, ob nach einem Wechsel in das Elternverzeichnis der zuvor angezeigte Ordner markiert werden soll. Deaktivieren Sie diese Einstellung, wenn der Ordner nur fokussiert aber nicht markiert dargestellt werden soll.

Aktivieren Sie das Kontrollkästchen Beim Drücken von 'Enter' alle markierten Dateien öffnen, wenn beim Drücken von Enter in der Listenansicht alle gewählten Dateien geöffnet werden sollen. Deaktivieren Sie diese Option, wenn Sie immer nur die fokussierte Datei öffnen möchten.

Die Einstellung Ordnerinhalt im Hintergrund einlesen legt fest, ob das Einlesen von Dateisystemordnern im Hintergrund erfolgen soll. SpeedCommander wird so während des Einlesevorgangs nicht blockiert und bleibt damit auch beim Einlesen größerer Ordner reaktionsfähig.

Baumansicht

Die Einstellungen Bei Änderung des Laufwerks alle anderen Einträge zuklappen und Bei Änderung des Ordners alle anderen Einträge zuklappen legen fest, dass bei der Auswahl eines anderen Laufwerks bzw. eines Ordner in der Baumansicht dessen Unterordner automatisch angezeigt und alle anderen Ordner geschlossen werden sollen. Klicken Sie auf das Plus- oder Minuszeichen, um andere Ordner und ihre Inhalte anzuzeigen oder auszublenden, ohne zuvor geöffnete Ordner zu schließen.

Laufwerksauswahl

Mit der Einstellung Bei Laufwerksauswahl zugehöriges Ordnerfenster aktivieren wird festgelegt, dass nach der Auswahl eines Laufwerksbuchstabens im Laufwerksfenster das dazugehörige rechte oder linke Ordnerfenster auch aktiviert wird. Deaktivieren Sie diese Option, wenn stattdessen immer das bisherige Ordnerfenster aktiv bleiben soll.

Aktivieren Sie das Kontrollkästchen Bei Laufwerksauswahl immer in dessen Hauptverzeichnis wechseln, wenn bei der Aktivierung eines Laufwerks immer in dessen Hauptverzeichnis gewechselt werden soll. Bei deaktivierter Einstellung merkt sich SpeedCommander für jedes Laufwerk das zuletzt angezeigte Verzeichnis und wechselt bei Aktivierung eines Laufwerks in dieses.

Die Einstellung Wechseldatenträger ohne eingelegte Medien ausblenden legt fest, dass Wechseldatenträger ausgeblendet werden sollen, wenn kein Medium eingelegt ist. Nach dem Einlegen eines Mediums wird das Laufwerk in der Laufwerksleiste automatisch eingeblendet und nach dem Entfernen wieder ausgeblendet. Dies kann die Übersichtlichkeit in der Laufwerksleiste erhöhen, wenn z.B. ein Speicherkarten-Lesegerät mit mehreren Laufwerken installiert ist. Diese Option hat keine Auswirkungen auf leere Disketten-, CD- oder DVD-Laufwerke.

Aktualisierung

Mit der Einstellung Wechseldatenträger nach dem Einlegen automatisch einlesen wird festgelegt, dass der Inhalt eines Ordnerfensters nach dem Einlegen eines Wechseldatenträgers (Speicherkarte, CD/DVD) automatisch aktualisiert wird.

SpeedCommander aktualisiert seine Ordnerfenster selbständig im Hintergrund, sofern dies möglich ist. Die neuen Dateien werden dabei an das Ende der Dateiliste angefügt. Aktivieren Sie das Kontrollkästchen Nach automatischer Aktualisierung sortieren, wenn SpeedCommander die Ordnerfenster nach einer Änderung im Dateisystem automatisch sortieren soll.


NC-Kompatibilität

SpeedCommander: Konfiguration
NC-Kompatibilität

Im Dialogfeld NC-Kompatibilität können Sie den NC-Kompatibilitätsmodus aktivieren und dessen Einstellungen anpassen.

Allgemein

Die Auswahl von Dateien und Ordnern in der Listenansicht funktioniert in der Grundeinstellung in der Art und Weise, die Sie vom Windows Explorer kennen. Einzelne Elemente werden durch einen Klick der linken Maustaste ausgewählt. Drücken Sie dazu die Modifizierungstaste Strg, wenn die aktuelle Auswahl beibehalten werden soll. Eine Mehrfachauswahl ist durch Halten der Modifizierungstaste Umschalt möglich. Ein Klick in den freien Bereich des Ordnerfensters hebt die Auswahl aller Elemente auf. Bei der Auswahl von Elementen mit der Tastatur können die beiden Modifizierungstasten ebenfalls verwendet werden.

Wählen Sie das Kontrollkästchen NC-Auswahlmodus aktivieren, wenn die Auswahl von Dateien und Ordnern stattdessen in der aus dem Norton Commander bekannten Art und Weise erfolgen soll. Im Unterschied zum Explorer-Auswahlmodus geht die Auswahl nicht verloren, wenn mit der Maustaste auf ein Element oder in den freien Bereich geklickt wird, ohne dabei eine Modifizierungstaste zu halten.

Die Einstellung Erweiterte Auswahl mit den Steuerungstasten 'Strg' und 'Umschalt' erlaubt die Auswahl von mehreren Elementen durch Halten der beiden Modifizierungstasten. Aktivieren Sie die Einstellung Direktes Umbenennen des fokussierten Beitrags durch Mausklick, wenn SpeedCommander nach einem Klick mit der linken Maustaste auf ein fokussiertes Element automatisch in den Vororteditierungsmodus wechseln soll. Beide Einstellungen sind eine Erweiterung des aus dem Norton Commander bekannten Verhaltens.

Aktivieren Sie das Kontrollkästchen 'Leer' setzt den Auswahlbalken auf den nächsten Eintrag (wie 'Einfg'), wenn nach der Auswahl eines Elements mit der Leertaste der Auswahlbalken automatisch auf das nächste Element gesetzt werden soll. Dies entspricht dem Markierungsverhalten der Taste Einfg.

Mit der Einstellung Markieren mit rechter Maustaste wird festgelegt, dass die Markierung von Dateien und Ordnern entgegen dem Windows-Standard mit der rechten Maustaste erfolgen soll und nicht mit der linken Maustaste. Halten Sie die rechte Maustaste etwas länger gedrückt, um das Kontextmenü anzuzeigen.

Die Einstellung Ordner in Groß- und Dateinamen in Kleinbuchstaben anzeigen legt fest, dass unabhängig von der Groß-/Kleinschreibung eines Datei- oder Ordnernamens alle Ordnernamen in Großbuchstaben und alle Dateinamen in Kleinbuchstaben angezeigt werden sollen.

Erweitert

Markieren Sie das Kontrollkästchen Hauptmenü mit 'F9' anzeigen, wenn das Hauptmenü von SpeedCommander mit der Taste F9 aktiviert werden soll. Die Einstellung SpeedCommander mit 'F10' schließen legt fest, ob SpeedCommander zusätzlich zu Alt+F4 auch mit F10 beendet werden kann. Beachten Sie bitte, dass beide Einstellungen Vorrang vor allen anderen Aktionen mit den Tastenkürzeln F9 und F10 haben.


Registerkarten

SpeedCommander: Konfiguration
Registerkarten

Im Dialogfeld Registerkarten legen Sie Einstellungen für die Registerkarten sowie deren Anordnung und Beschriftung fest.

Allgemein

Die Einstellung Karteireiter immer anzeigen legt fest, ob der Registerkartenbereich immer angezeigt oder automatisch ausgeblendet werden soll, wenn nur eine Registerkarte angezeigt wird.

Mit der Einstellung Neues Ordnerfenster rechts neben dem aktiven einfügen wird festgelegt, dass ein neues Ordnerfenster immer rechts neben dem aktiven Fenster angezeigt werden soll. Deaktivieren Sie dieses Kontrollkästchen, wenn ein neues Ordnerfenster immer am Ende angezeigt werden soll.

SpeedCommander zeigt einen Hinweis an, wenn Sie in einem Ordnerfenster, dessen Navigation eingeschränkt ist, in einen anderen Ordner wechseln möchten. Aktivieren Sie das Kontrollkästchen Bei Ordnerwechsel in gesperrten Registerkarten in freies Fenster wechseln, wenn SpeedCommander stattdessen in das erste freie Ordnerfenster wechseln und dort den neuen Ordner anzeigen soll.

Mit der Einstellung Registername automatisch an aktuellen Ordner anpassen wird festgelegt, ob SpeedCommander beim Wechsel in einen anderen Ordner den Namen des Karteireiters entsprechend des neuen Ordners aktualisieren soll. Sie können die automatische Anpassung des Namens auch im Eigenschaftendialog einer Registerkarte deaktivieren.

Die Einstellung Ordnerfenster für temporäre Archive automatisch schließen legt fest, ob temporär erzeugte Registerkarten bei der Anzeige von Archiven in Archiven automatisch geschlossen werden sollen, wenn das temporär entpackte Archiv verlassen wird.

Anordnung & Beschriftung

Im Kombinationsfeld Anordnung legen Sie fest, ob die Registerkarten oben oder unten angezeigt werden sollen.

Im Kombinationsfeld Ziffern für Schnellzugriff können Sie auswählen, ob und wie die Ziffern für den Schnellzugriff (Strg + 1 bis Strg + 9) angezeigt werden sollen. Der Schnellzugriff funktioniert unabhängig davon, ob die Ziffern angezeigt werden oder nicht.

Das Kombinationsfeld Beschriftung für Ordnerfenster legt fest, ob auf den Registerkarten nur der Laufwerksbuchstabe, der Ordnername oder Ordnername und Laufwerksbuchstabe in Kombination angezeigt werden sollen.

Mit dem Kombinationsfeld Schließen-Schaltfläche anzeigen wird festgelegt, ob eine Schließen-Schaltfläche angezeigt werden soll und ob sich diese auf der aktiven Registerkarte oder rechts neben den Registerkarten befinden soll.

Im Kombinationfeld Farbliche Kennzeichnung legen Sie fest, mit welcher Farbe Registerkarten mit gesetztem Basisordner, gesperrter Navigation oder einem Dateifilter gekennzeichnet werden sollen. Wählen Sie im zugehörigen Farbauswahlfeld die gewünschte Farbe oder klicken Sie auf die Schaltfläche Zurücksetzen, wenn der jeweilige Zustand nicht farblich hervorgehoben werden soll. Obere Einträge haben eine höhere Priorität als Einträge weiter unten. Das heißt, dass eine Registerkarte mit gesetztem Basisordner und aktivem Dateifilter in der Farbe des Dateifilters angezeigt wird. Wird der Dateifilter entfernt, dann bekommt diese Registerkarte automatisch die Farbe für einen gesetzten Basisordner.

Aktionen

Das Kombinationsfeld Doppelklick mit linker Maustaste legt fest, welche Aktion beim Doppelklick mit der linken Maustaste auf den Namen einer Registerkarte durchgeführt werden soll. Die Registerkarte kann umbenannt oder geschlossen werden.

Mit dem Kombinationsfeld Wechsel zwischen den Fenstern können Sie die Tastenkombination festlegen, mit der zwischen den Registerkarten gewechselt werden soll.

Im Kombinationsfeld Aktivierung der Fenster wird festgelegt, mit welcher Tastenkombination die ersten 10 Fenster aktiviert werden sollen.


Ordnergrößen

Im Dialogfeld Ordnergrößen legen Sie Einstellungen zur Ordnergrößenberechnung fest.

Ordnergrößen

Die Einstellung Dateigröße bei Ordnern automatisch berechnen legt fest, ob SpeedCommander in der Detailansicht neben der Größe der einzelnen Dateien auch die Gesamtgröße eines Ordners mit allen darin enthaltenen Dateien anzeigen soll. Die Berechnung der Ordnergrößen erfolgt zwar im Hintergrund, sie kann die Reaktionsfähigkeit von SpeedCommander auf schwächeren Rechnern aber etwas beeinträchtigen.

Aktivieren Sie das Kontrollkästchen Berechnete Ordnergrößen automatisch im Hintergrund aktualisieren, wenn SpeedCommander auf Änderungen in Unterordnern reagieren und die berechneten Ordnergrößen selbstständig aktualisieren soll.

Die Einstellung Ordnergrößen automatisch berechnen bis maximal xxx MiB ermöglicht es, die Berechnung der Ordnergrößen abzubrechen, wenn eine bestimmte Größe erreicht ist. Geben Sie im Eingabefeld das Limit ein, nach dessen Überschreiten die Berechnung abgebrochen werden soll.

Mit der Einstellung Manuelle Ordnergrößenberechnung nur für markierte Ordner durchführen wird festgelegt, ob bei der Berechnung der Ordnergrößen über den Befehl Ordner | Ordnergrößen ermitteln die Größen aller Unterordner des aktuellen Ordners berechnet werden oder nur die der markierten Ordner. Deaktivieren Sie dieses Kontrollkästchen, wenn die Ordnergrößen immer für alle Ordner berechnet werden sollen.

Ordnergrößenberechnung deaktivieren

Die Schaltfläche Konfigurieren öffnet ein Dialogfeld, in dem Sie Ordner eintragen können, für welche die automatische Ordnergrößenberechnung deaktiviert werden soll. Die Angabe eines Ordnernamens deaktiviert nur die Berechnung für den jeweiligen Ordner, nicht aber für seine Unterordner. Verwenden Sie Stellvertreterzeichen, wenn Sie die Berechnung für einen Ordner und seine Unterordner deaktivieren möchten. Die Ordnernamen müssen vollständig sein, relative Ordnernamen werden ignoriert.


Dateioperationen

SpeedCommander: Konfiguration
Dateioperationen

Im Dialogfeld Dateioperationen finden Sie Konfigurationsoptionen zu Dateioperationen und zum Ausschalten von Bestätigungen.

Fortschrittsfenster

Hier legen Sie fest, wie die Fortschrittsfenster von Dateioperationen angezeigt werden sollen. Wählen Sie Fortschrittsfenster als einzelne Dialoge anzeigen, wenn die Fortschrittsfenster wie in früheren Versionen als einzelne Dialogfenster angezeigt werden sollen. Für diese Anzeigeform ist keine Warteschlangen-Funktion möglich.

Mit der Aktivierung von Fortschrittsfenster in Registerkarten anzeigen (angedockt) werden die Fortschrittsfenster als Karteireiter vorzugsweise am unteren Rand des rechten Ordnerfensters eingeblendet. Ist das rechte Fenster zu schmal, dann können sie auch im linken Fenster angezeigt werden.

Die Einstellung Fortschrittsfenster in Registerkarten anzeigen (freischwebend) zeigt die Fortschrittsfenster ebenfalls als Karteireiter an, allerdings in einem Fenster außerhalb der Anwendung. Sie können dieses Fenster frei positionieren.

Bestätigungen

Markieren Sie die Kontrollkästchen Kopieren von Dateien und Ordnern und Verschieben von Dateien und Ordnern, wenn SpeedCommander vor dem Kopieren oder Verschieben einen Bestätigungsdialog mit verschiedenen Einstellungen zum Kopier- bzw. Verschiebevorgang anzeigen soll.

Die beiden Einstellungen Verschieben von Systemdateien und -ordnern und Verschieben von schreibgeschützten Dateien und Ordnern legen fest, ob SpeedCommander vor dem Verschieben von Dateien und Ordnern mit den Attributen System oder Schreibgeschützt eine Bestätigung einholen soll.

Möchten Sie vor dem Löschen von Dateien und Ordnern mit den Attributen System oder Schreibgeschützt ebenfalls um Erlaubnis gefragt werden, dann markieren Sie die beiden Kontrollkästchen Löschen von Systemdateien und -ordnern und Löschen von schreibgeschützten Dateien und Ordnern.

Die Einstellung Ersetzen von Ordnern beim Kopieren oder Verschieben legt fest, ob SpeedCommander eine Bestätigung einholen soll, wenn im Zielordner bereits ein Ordner vorhanden ist, der den gleichen Namen wie der zu kopierende oder zu verschiebende Ordner besitzt.

SpeedCommander zeigt einen Hinweis an, wenn Dateien mit zusätzlichen Datenströmen (z.B. Metainformationen) auf ein Laufwerk kopiert werden sollen, dessen Dateisystem keine zusätzlichen Datenströme unterstützt (z.B. FAT32). Deaktivieren Sie das Kontrollkästchen Verlust von Datenströmen beim Kopieren auf nicht-NTFS-Laufwerke, wenn diese Meldung nicht angezeigt werden soll. Beachten Sie bitte, dass nur die Metainformationen verloren gehen können, der eigentliche Dateiinhalt bleibt beim Kopieren immer erhalten.

Warteschlange

Die Einstellung Neue Dateioperationen in Warteschlange einfügen legt fest, ob Dateioperationen sofort gestartet oder in die Warteschlange eingereiht werden sollen. Aktivieren Sie dieses Kontrollkästchen, wenn Sie Dateioperationen nacheinander durchführen möchsten. Auch bei aktivierter Einstellung können Dateioperationen sofort gestartet werden, wenn im Bestätigungsdialog die Schaltfläche Jetzt geklickt wird. Ist die Einstellung deaktiviert, dann können Dateioperationen im Bestätigungsdialog durch Klick auf die Schaltfläche Später in die Warteschlange eingefügt werden.


Archive & InfoTips

SpeedCommander: Konfiguration
Archive & InfoTips

Im Dialogfeld Archive & InfoTips finden Sie Konfigurationsoptionen zur Darstellung von InfoTips und zum Öffnen von Archiven.

InfoTips

Markieren Sie das Kontrollkästchen Bei Laufwerken Gesamtgröße und freien Speicherplatz anzeigen, wenn beim Zeigen auf einen Eintrag im Laufwerksfenster neben dem Namen des Laufwerks auch die Gesamtgröße und der freie Speicherplatz angezeigt werden sollen. Beachten Sie bitte, dass diese Einstellung insbesondere bei Netzlaufwerken die Anzeige verlangsamen kann.

Im Kombinationsfeld Dateiinformation als InfoTip anzeigen für können Sie festlegen, ob beim Zeigen auf einen Eintrag in der Listenansicht ein Infofenster mit den wichtigsten Dateieigenschaften erscheinen soll. Diese Funktion kann für lokale Laufwerke, verbundene Netzlaufwerke und Einträge in der Netzwerkumgebung separat aktiviert werden.

Archive

Die Einstellung Archive wie Ordner behandeln legt fest, ob SpeedCommander beim Doppelklick oder Enter auf Archivdateien den Inhalt der Archivdateien in einer Verzeichnisstruktur anzeigen soll. Sie können damit Archive durchstöbern, als ob sie normale Ordner wären. Deaktivieren Sie diese Option, wenn Sie Archive lieber mit einem externen Archivprogramm öffnen möchten.

Markieren Sie das Kontrollkästchen Ausführbare Archive anzeigen, wenn SpeedCommander beim Doppelklick auf eine ausführbare Datei prüfen soll, ob diese ein selbstentpackendes Archiv ist. Bei erfolgreicher Prüfung können Sie jeweils entscheiden, ob das selbstentpackende Archiv angezeigt oder ausgeführt werden soll.

Im Eingabefeld Zusätzliche Archivtypen können Sie weitere Dateierweiterungen für von SpeedCommander unterstützte Archive angeben, die eine vom Standard abweichende Dateierweiterung verwenden. Mehrere Erweiterungen werden durch ein Semikolon getrennt (z.B. xpi;sxw).

Erweitert

Markieren Sie das Kontrollkästchen Dateien und Ordner durch einfachen Klick öffnen, wenn Sie Ordner und Dateien anstelle eines Doppelklicks mit einem einfachen Mausklick öffnen möchten.

Normalerweise werden die Menüs mit den Ordner- und Anwendungsfavoriten immer unterhalb der Titelzeile des aktiven Ordnerfensters angezeigt. Markieren Sie das Kontrollkästchen Favoriten-Menü immer an Mausposition anzeigen, wenn diese Menüs stattdessen an der aktuellen Mauszeigerposition angezeigt werden sollen.

Die Einstellung Eingabeaufforderung nach Befehlsverarbeitung automatisch schließen legt fest, ob das Eingabeaufforderungsfenster, das durch den Aufruf von Befehlen über die integrierte Eingabebefehlszeile geöffnet wird, automatisch wieder geschlossen wird. Deaktivieren Sie diese Option, wenn Sie die Statusmeldungen der Befehle sehen möchten.


Anwendungen & Internet

SpeedCommander: Konfiguration
Anwendungen & Internet

Mit dem Dialogfeld Anwendungen & Internet legen Sie fest, welche Zusatzprogramme SpeedCommander für bestimmte Funktionen verwenden soll.

Anwendungen

Die Eingabefelder Editor, Betrachter, DiskFormat, DiskCopy, Dateisuche und DirPrinter legen die Anwendungen fest, die SpeedCommander beim Aufruf der Befehle Bearbeiten, Betrachten und Suchen aus dem Menü Datei, Datenträger formatieren und Datenträger kopieren aus dem Menü Datenträger sowie Keseling DirPrinter aus dem Menü Pro aufrufen soll. Tragen Sie hier die vollständigen Pfadnamen zu den jeweiligen Programmen ein. Sie können auch relative Pfadangaben verwenden, wenn sich diese auf das Ausführungsverzeichnis von SpeedCommander beziehen.

Lassen Sie die Eingabefelder DiskFormat, DiskCopy und Dateisuche leer, wenn SpeedCommander die von Windows bereitgestellten Module aufrufen soll.

Internet

Geben Sie im Eingabefeld Startseite die Adresse an, die SpeedCommander bei der Aktivierung des Laufwerkssymbols Internet bzw. beim Aufruf des Befehls Datenträger | Internet - Startseite anzeigen soll. Im Eingabefeld Suchseite wird die Adresse einer Suchseite festgelegt, welche bei Ausführung des Befehls Datenträger | Internet - Suchen angezeigt werden soll.

Bei Aktivierung des Kontrollkästchens DFÜ-Verbindung trennen erinnert SpeedCommander beim Schließen der Internetansicht oder beim Trennen der Verbindung zu einem FTP-Server an das Trennen einer lokalen Wählverbindung. Internetverbindungen, die über einen Router aufgebaut werden, sind von dieser Einstellung nicht betroffen.

Die Schaltfläche Erweitert öffnet die Internetoptionen des Systems.


FTP-Client

SpeedCommander: Konfiguration
FTP-Client

Mit Hilfe des Dialogfeldes FTP-Client passen Sie die grundlegenden FTP-Einstellungen an. Sie können den Übertragungsmodus festlegen, Angaben zum Timeout machen sowie einen Proxyserver festlegen, der für alle FTP-Verbindungen gelten soll.

Übertragungsmodus

Der Übertragungsmodus legt fest, ob die Zeilenendezeichen in Textdateien bei der Übertragung automatisch zwischen dem Windows-Format (\r\n) und dem Unix-Format (\n) umgewandelt werden sollen. Die Auswahl ASCII konvertiert die Zeilenendezeichen in alle Dateien, mit Binär werden alle Dateien ohne Konvertierung übertragen. Die Auswahl Automatisch ermöglicht, die Konvertierung der Zeilenendezeichen in Abhängigkeit vom jeweiligen Dateityp automatisch durchzuführen. Geben Sie im Eingabefeld Erweiterungen die Dateierweiterungen an, für die eine Konvertierung durchgeführt werden soll.

Der hier ausgewählte Übertragungsmodus wird als Standardeinstellung im Bestätigungsdialog vor dem Kopieren gewählt und kann dort für die jeweilige Dateioperation angepasst werden.

Timeout & Wiederholung

Die Einstellung Verbindungsfehler, wenn keine Antwort nach xx Sekunden legt fest, nach welcher Zeitspanne SpeedCommander den Verbindungsaufbau abbrechen soll. Sollte der FTP-Server besetzt sein und keine weiteren Verbindungen zulassen, dann lässt sich unter xx Wiederholungen, wenn ein FTP-Server besetzt ist vorgeben, wie oft SpeedCommander den Versuch wiederholen soll. Die Einstellung xx Sekunden Pause zwischen den Versuchen legt die Wartezeit zwischen zwei Versuchen fest.

Bei Dateiübertragungen von größeren Dateien kann es passieren, dass die Kontrollverbindung zwischen SpeedCommander und FTP-Server nach einer gewissen Zeitspanne durch eine Firewall getrennt wird. Mit der Einstellung Keep-Alive Pings für TCP-Verbindungen alle xx Sekunden lässt sich festlegen, dass SpeedCommander in gewissen Zeitabständen ein Signal über die Kontrollverbindung schickt, damit diese nicht als untätig eingeordnet wird. Geben Sie hier 0 ein, um diese Funktion zu deaktivieren.

Sonstiges

Das Kontrollkästchen Verzeichnisdaten im Statusfenster anzeigen legt fest, ob SpeedCommander die vom FTP-Server erhaltenen Verzeichnisinformationen im Rohformat anzeigen soll. Die Aktivierung dieser Einstellung verzögert den Verzeichniswechsel in größere Verzeichnisse etwas und sollte daher nur erfolgen, wenn SpeedCommander die Verzeichnisinformationen nicht korrekt auswertet.

Mit der Aktivierung des Kontrollkästchens Ausführliche Logdatei für jede Verbindung erstellen protokolliert SpeedCommander alle Statusinformationen in einer Textdatei. Die Logdateien werden im Einstellungsverzeichnis von SpeedCommander abgelegt und können je nach Aktionsumfang recht groß werden. Diese Einstellung sollte nur bei Problemen mit einer Verbindung aktiviert werden.

Einige FTP-Server bieten die Möglichkeit, Verzeichnisinformationen und Dateiinhalte komprimiert zu übertragen. Besonders bei langsamen Verbindungen bringt das Vorteile, da weniger Daten übertragen werden müssen. Aktivieren Sie das Kontrollkästchen Kompression (MODE Z) bei Dateitransfers aktivieren, Level x, wenn SpeedCommander diese Möglichkeit nutzen soll. Der Wert gibt dabei die Stärke der Kompression an, wobei 1 für die geringste Kompression und 9 für die höchste Kompression steht.

Geschwindigkeitsbeschränkung

Je nach Auslastung Ihrer Internetverbindung kann es nötig sein, die Übertragungsgeschwindigkeit für eine Datentransfer in SpeedCommander zu limitieren. So bleibt anderen Anwendungen mehr Kapazität, um zum Beispiel während eines Downloads von einem FTP-Server noch ein Video im Internetbrowser zu schauen.

Geben Sie in den Eingabefeldern Upload auf bzw. Download auf die für SpeedCommander zugelassene Geschwindigkeit für Datentransfers ein. Tragen Sie eine 0 ein, um die Geschwindigkeitsbeschränkungen zu deaktivieren.


Schnellansicht

SpeedCommander: Konfiguration
Schnellansicht

Im Dialogfeld Schnellansicht legen Sie fest, welchen Dateibetrachter SpeedCommander in der Schnellansicht für einen bestimmten Dateityp verwenden soll. Sie können eine neue Zuordnung erstellen sowie eine Zuordnung bearbeiten und löschen.

Folgende Betrachter können verwendet werden:

Betrachter | Beschreibung
Dump | Zeigt den Dateiinhalt in Byteform als Text- oder Heximalansicht und kann für alle unbekannten Formate verwendet werden.
Text | Zeigt den Dateiinhalt als lesbaren Text und bietet eine Syntaxhervorhebung für bekannte Dateierweiterungen.
Grafik | Zeigt den Dateiinhalt von Bilddateien.
Archiv | Zeigt die wesentlichen Informationen zu einem Archiv (Format, Anzahl der Dateien, Kommentar).
Multimedia | Spielt eine Musik- oder Videodatei mit Hilfe des integrierten Windows Media Player ab.
Metafile | Zeigt eine vektorbasierte Metadatei an.
Internet Explorer | Zeigt die Datei im integrierten Internet Explorer an.
Programmdateien | Zeigt die in einer Programmdatei enthaltenen Informationen (Allgemeine Informationen, importierte und exportierte Funktionen, Ressourcen, Zertifikate).
Delphi-Formulare | Zeigt ein Delphi-Formular in der Entwurfsansicht an.
Schriftart | Zeigt Informationen zu einer Schriftdatei an.
PDF-Dateien | Zeigt den Inhalt einer PDF-Datei an.
Windows-Vorschau | Zeigt den Dateiinhalt mit Hilfe der Windows-Vorschau an (sofern verfügbar).
So ändern Sie die Zuordnung eines Betrachters:
  1. Wählen Sie die gewünschte Dateierweiterung in der Liste Registrierte Dateierweiterungen aus und klicken Sie auf Bearbeiten.
  2. Wählen Sie im Dialogfeld Dateierweiterung bearbeiten den gewünschten Betrachter aus und klicken Sie auf OK.
So erstellen Sie eine neue Zuordnung:
  1. Klicken Sie auf die Schaltfläche Neu.
  2. Tragen Sie im Dialogfeld Neue Dateierweiterung im Eingabefeld Dateierweiterung die Dateierweiterung ohne führenden Punkt ein.
  3. Wählen Sie im Kombinationsfeld Betrachter den gewünschten Betrachter aus und klicken Sie auf OK.
So entfernen Sie eine Zuordnung:
  1. Wählen Sie die zu löschende Dateierweiterung in der Liste Registrierte Dateierweiterungen aus.
  2. Klicken Sie auf die Schaltfläche Löschen und bestätigen Sie die Sicherheitsabfrage.

Standardbetrachter

Für unbekannte Dateierweiterungen, die nicht in der Liste Registrierte Dateierweiterungen angezeigt werden, wird ein Standardbetrachter verwendet. Dieser kann im Kombinationsfeld Standardbetrachter ausgewählt werden. Empfohlen wird der Betrachter Dump.

Der Dateibetrachter Windows-Vorschau kann nur für Dateien verwendet werden, für die im System ein Windows-Vorschaumodul installiert ist. Die Zuordnung erfolgt automatisch beim Programmstart, wenn für die jeweilige Dateierweiterung kein Betrachter zugeordnet ist. Die Dateierweiterungen, für welche ein Windows-Vorschaumodul verfügbar ist, werden mit ¹ gekennzeichnet. Die Windows-Vorschaufunktion ist erst ab Windows Vista verfügbar.

Anzeige von HTML-Dateien

Bei Anzeige von HTML-Dateien werden auch entsprechend der eingestellten Sicherheitsstufe für Lokales Intranet Skripte ausgeführt. Wenn Sie dies nicht wünschen, müssen Sie die Anzeige für HTML-Dateien deaktivieren, indem Sie die Zuordnung für die Dateierweiterungen html, htm, ihtml und shtml löschen.


Kompression

SpeedCommander: Konfiguration
Kompression

Mit Hilfe des Dialogfelds Kompression können Sie die Einstellungen für die einzelnen Archivformate festlegen, die im Komprimierungsdialog bei der Auswahl eines Archivformats als Standardeinstellungen vorgeschlagen werden sollen.

Allgemein

Wählen Sie das gewünschte Archivformat, für das Sie die Voreinstellungen festlegen möchten. Die Kompressionsrate bestimmt, wie stark die Dateien komprimiert werden sollen. Eine höhere Kompressionsrate sorgt in der Regel für kleinere Archivdateien, eine geringere Komprimierungsrate verkürzt die für die Erstellung einer Archivdatei benötigte Zeit. Die Speichergröße legt fest, wieviel Speicher zum Komprimieren der Daten verwendet werden soll. Ein hoher Wert bewirkt eine bessere Komprimierung.

Das Kombinationsfeld Reparaturdaten legt fest, ob dem Archiv Reparaturdaten hinzugefügt werden sollen. Ein Archiv, das Reparaturdaten enthält, kann mit hoher Wahrscheinlichkeit wieder repariert werden, wenn es beschädigt wurde. Die Reparaturdaten können entweder im Archiv abgelegt werden oder in einer zusätzlichen externen Datei.

Die Schaltfläche Details öffnet bei den Formaten SQX 2.0 und 7z ein Dialogfeld mit erweiterten Einstellungen.

Erweitert

Die Einstellung Multimedia-Kompression legt fest, dass bei der Kompression spezielle Algorithmen verwendet werden sollen, die besonders bei Multimediadateien die Kompressionsrate verbessern. Für eine verbesserte Kompression von Programmdateien sorgt die Einstellung EXE-Kompression.

Mit der Einstellung Solid-Archiv erstellen wird festgelegt, dass bei der Komprimierung die Statistiken aller Dateien berücksichtigt werden soll, was zu einer erheblichen Steigerung der Komprimierungsrate und damit zu kleineren Archivdateien führen kann. Mit Aktivierung der Einstellung AV-Signatur erzeugen kann das erstellte Archiv mit einer Signatur versehen werden. Voraussetzung dafür ist eine vorhandene Signaturdatei für SQX-Archive. Neue Signaturdateien werden nicht mehr ausgestellt, ältere Signaturdateien können aber weiterhin verwendet werden.

Sonstiges

Die Einstellung Originaldateien nach dem Archivieren löschen legt fest, dass das gleichnamige Kontrollkästchen im Komprimierungsdialog beim Aufruf des Komprimierungsdialogs immer aktiviert werden soll. Die Einstellung Immer den Ordnernamen als Archivnamen vorschlagen sorgt dafür, dass der vorgeschlagene Name für die Archivdatei im Komprimierungsdialog auch bei Auswahl einer einzelnen Datei oder eines einzelnen Ordners immer aus dem übergeordneten Ordnernamen abgeleitet werden soll.

Erweiterte Einstellungen für SQX 2.0

Die erweiterten Einstellungen für SQX 2.0 ermöglichen eine feinere Abstimmung des SQX-Archivers für verschiedene Einsatzfälle.

Transformatoren

Das Kombinationsfeld Multimedia aktiviert, deaktiviert oder erzwingt den Multimedia-Transformator. Der Multimedia-Transformator kann die Kompression bei Dateien mit multimedialen Elementen deutlich verbessern (Bilder, Ressourcen). Mit dem Kombinationsfeld EXE wird der EXE-Transformator aktiviert, deaktiviert oder erzwungen. Der EXE-Transformator kann die Kompression bei ausführbaren Dateien, dynamischen Programmbibliotheken und Gerätetreibern deutlich verbessern. Das Kombinationsfeld RGB aktiviert, deaktiviert oder erzwingt den RGB-Transformator. Der RGB-Transformator kann die Kompression bei unkomprimierten RGB-Bilddateien deutlich verbessern (BMP, TGA, TIFF, PSD).

Kompressoren

Das Kombinationsfeld Audio aktiviert, deaktiviert oder erzwingt den Audio-Kompressor. Der Audio-Kompressor kann die Kompressionsrate und Geschwindigkeit bei Audiodateien deutlich verbessern (WAV, PCM). Im Eingabefeld Kanäle wird die Anzahl der Kanäle festgelegt, in welche die Audiodateien aufgeteilt werden sollen. Das Eingabefeld Kanalbreite legt die Breite der Kanäle fest, die der Kompressor für die Audiodateien benutzen soll. Wenn der Audiokompressor die Anzahl der Kanäle und die Kanalbreite automatisch ermitteln soll, dann muss die Einstellung des Audiokompressors auf Automatisch gesetzt werden.

Mit dem Kombinationsfeld Text wird der Text-Kompressor aktiviert, deaktiviert oder erzwungen. Der Text-Kompressor kann die Kompressionsrate und Geschwindigkeit bei textartigen Dateien deutlich verbessern (TXT, HTML, RTF, CPP, PAS). Das Eingabefeld Speicher legt die Größe des Speichers für den Text-Kompressor fest. Je größer der Speicher ist, desto größer ist auch die Kompressionsrate. Im Eingabefeld Ordnung wird die Ordnung für den Text-Kompressor festgelegt. Je höher die Ordnung, desto besser ist auch die Kompression und desto mehr Speicher sollte dem Kompressor zur Verfügung stehen. Ein guter Mittelwert ist hier 6-8.

Ultra-Kompression

Der Schieberegler legt die feinere Abstimmung für den Kompressor fest, wenn als Kompressionsrate Ultra gewählt ist. Der Wert Schneller ist die beste Synthese aus Kompressionsrate und Geschwindigkeit. Der Wert Besser erreicht in der Regel die maximale Kompression, der Kompressor wird dabei aber deutlich langsamer. Mit den einzelnen Zwischenstufen lässt sich dieses variieren.

Erweiterte Einstellungen für 7z

Die erweiterten Einstellungen für 7z ermöglichen eine feinere Abstimmung des 7z-Archivers für verschiedene Einsatzfälle.

Kompressor

Das Kombinationsfeld Methode legt die zu verwendende Kompressionsmethode fest. LZMA ist eine universelle Kompressionsmethode und für alle Dateien geeignet, während PPMD sich besser für Textdateien eignet. LZMA2 ist eine Erweiterung von LZMA.

LZMA

Das Kombinationsfeld Modus legt den Kompressionsmodus für den LZMA-Kompressor fest. Mit dem Kombinationsfeld Matchfinder wird der zu verwendende Matchfinder festgelegt. Binary Tree ist die beste Synthese aus Kompressionsrate und Geschwindigkeit. Patricia Tree ist etwas schneller als Binary Tree, braucht aber deutlich mehr Speicher. Hash Chain ist hinsichtlich des Speicherverbrauchs am sparsamsten und am schnellsten bei fast allen Dateitypen, bietet aber dafür die schlechteste Kompression aller drei Varianten.

Fast Bytes legt die maximale Länge der Matches fest, deren Qualität verglichen werden soll. Je höher der Wert, desto besser (und langsamer) ist die Kompression. Literal Context Bits bestimmt die Ordnung des Literal-Kompressors. Position Bits legt die Anzahl der Bits fest, die von den absoluten Distanzwerten komprimiert werden sollen. Literal Position Bits bestimmt die Anzahl der Extra-Bits für die Literale.

PPMD

Das Eingabefeld Speicher legt die Größe des Speichers für den Text-Kompressor fest. Je größer der Speicher ist, desto größer ist auch die Kompressionsrate. Im Eingabefeld Ordnung wird die Ordnung für den Text-Kompressor festgelegt. Je höher die Ordnung, desto besser ist auch die Kompression und desto mehr Speicher sollte dem Kompressor zur Verfügung stehen. Ein guter Mittelwert ist hier 6-8.


Dateiverknüpfungen

Im Dialogfeld Dateiverknüpfungen legen Sie fest, welche Archivformate mit SpeedCommander verknüpft werden sollen.

Dateiverknüpfungen

Markieren Sie die Dateierweiterungen, für welche SpeedCommander in der Registrationsdatenbank als Bearbeitungsprogramm eingetragen werden soll. Auf diese Weise können Sie Archive im Explorer oder in Outlook öffnen, ohne ein zusätzliches Archivprogramm installieren zu müssen. Nach dem Klick auf Übernehmen kann eine Bestätigungsmeldung der Benutzerkontensteuerung erscheinen, da die Zuordnung für alle Anwender des Systems vorgenommen wird.

Erweitertes Kontextmenü

Aktivieren Sie das Kontrollkästchen Erweitertes Kontextmenü anzeigen, wenn SpeedCommander das vom System zur Verfügung gestellte Kontextmenü von Dateien und Ordnern mit zusätzlichen Befehlen erweitern soll. Die Befehle werden am Anfang des Kontextmenüs im Untermenü SpeedCommander angezeigt.

In den Kombinationsfeldern Komprimieren und Komprimieren & E-Mail können Sie Ihr bevorzugtes Format beim Erstellen von Archiven über das erweiterte Kontextmenü festlegen. Achten Sie darauf, dass Sie zum Versenden eines Archivs ein Archivformat verwenden, das der Empfänger auch entpacken kann. Ein weit verbreitetes Format ist ZIP 2.0.


Verschiedenes

SpeedCommander: Konfiguration
Verschiedenes

Im Dialogfeld Verschiedenes finden Sie erweiterte Einstellungen zu weniger gebräuchlichen Konfigurationsoptionen.

Listenansicht

Mit Windows Vista wurde die Höhe des Spaltenkopfes in der Detailansicht erheblich vergrößert. Zur Reduzierung der Größe geben Sie unter Höhe der Spaltenanzeige verringern an, um wieviel Punkte die Höhe des Spaltenkopfes verringert werden soll.

Die Einstellung Sekunden anzeigen legt fest, dass die Zeitangaben in der Detailansicht inklusive Sekunden angezeigt werden sollen. Dies gilt nur für die internen Spalten von SpeedCommander. Auf das Format einiger vom System zur Verfügung gestellten Spalten hat SpeedCommander keinen Einfluss.

Mit der Einstellung Markierungsmodus beim direkten Umbenennen legen Sie fest, ob beim direkten Umbenennen einer Datei oder eines Ordners der gesamte Text, der Dateiname ohne Erweiterung oder nur die Erweiterung markiert werden soll. Sie können auch während des Umbenennens innerhalb des Editierfeldes mit dem Tastenkürzel für das Umbenennen zwischen den einzelnen Elementen wechseln.

Farben

In diesem Bereich können Sie weitere Farben für bestimmte Elemente definieren. Für das Dialogfeld Mehrfaches Umbenennen können Sie die Farben für doppelt vorkommende Dateinnamen sowie für bereits existierende Dateinamen festlegen. Wählen Sie die gewünschte Farbe mit Hilfe des Farbauswahldialogs oder geben Sie den entsprechenden RGB-Wert direkt ein.

Archive

Die Einstellung Archive im Quellverzeichnis erstellen legt fest, ob beim Erstellen eines neuen Archivs anstelle des Zielordners das Quellverzeichnis vorgeschlagen wird. Aktivieren Sie die Option Archive im Quellverzeichnis entpacken, wenn Sie Archive vorzugsweise immer in das Verzeichnis entpacken möchten, in dem sich das Archiv befindet.

Dateioperationen

Hier können Sie die Standardeinstellungen für die verschiedenen Optionen in den Bestätigungsdialogen vor dem Kopieren oder Verschieben festlegen. Diese Einstellungen werden auch verwendet, wenn die Anzeige der Bestätigungsdialoge deaktiviert wurde. Nur neuere Dateien kopieren legt fest, dass nur Dateien kopiert werden, die neuer sind als bereits existierende Dateien. Ist eine Zieldatei jünger als die Quelldatei, dann wird sie beim Kopieren übersprungen. Aktivieren Sie Dateien automatisch umbenennen, wenn bei Namenskonflikten eine bereits existierende Datei erhalten bleiben und an die neue Datei automatisch ein Kürzel angehangen werden soll.

Mit Aktivierung der Einstellung Dateiattribut 'Schreibgeschützt' entfernen wird beim Kopieren einer schreibgeschützten Datei das entsprechende Dateiattribut nicht übertragen werden soll. Sicherheitsattribute übernehmen (NTFS) legt fest, ob die NTFS-Sicherheitsattribute beim Kopieren von Dateien explizit auf die Zieldateien übertragen werden oder ob die Zieldateien automatisch die Sicherheitsattribute des Zielordners erhalten sollen. Im Regelfall sollten Sie diese Einstellung deaktiviert lassen.

Mit der Einstellung Zeitstempel von Ordnern übernehmen wird festgelegt, dass beim Kopieren von Ordnern der Zeitstempel des Quellordners auf den Zielordner übertragen werden soll. So lässt sich auch nach dem Kopieren feststellen, wann die letzte Änderung im Ordner erfolgt ist. Aktivieren Sie die Einstellung Erstellzeit von Dateien übernehmen, wenn beim Kopieren von Dateien die Erstellzeit der Quelldatei übernommen werden soll. Andernfalls entspricht die Erstellzeit der Zieldatei dem aktuellen Zeitpunkt.

Warteschlange

Die Einstellung Immer die zuletzt gestartete Dateioperation aktivieren legt fest, dass im Fortschrittsfenster immer die zuletzt gestartete Dateioperation aktiviert werden soll. Lassen Sie die Einstellung deaktiviert, wenn Sie die Umschaltung zwischen den gestarteten Dateioperationen manuell durchführen möchten. Mit Pausierte Dateioperationen automatisch fortsetzen wird festgelegt, dass pausierte Dateioperationen automatisch fortgesetzt werden sollen, nachdem die vorherige Operation abgeschlossen wurde.

FTP

Aktivieren Sie Automatische Konvertierung nach Klein, wenn beim Kopieren von Dateien auf einen FTP-Server alle Dateinamen so umgewandelt werden sollen, dass sie nur noch Kleinbuchstaben enthalten. Die Einstellung Dateiübertragung im Hintergrund legt fest, dass SpeedCommander für die Übertragung auf oder von einem FTP-Server eine neue Verbindung aufbauen soll. Sie können so während der Dateiübertragung in SpeedCommander weiterarbeiten. Deaktivieren Sie diese Einstellung, wenn Ihr FTP-Server nur eine gleichzeitige Verbindung erlaubt.

Mit der Einstellung Dateizeit vom FTP-Server übernehmen wird festgelegt, dass der Zeitstempel der Quelldatei auf dem FTP-Server auf die lokale Zieldatei übertragen werden soll. Deaktivieren Sie diese Option, wenn die kopierte Datei die aktuelle Uhrzeit erhalten soll.


Spezielles

SpeedCommander: Konfiguration
Spezielles

Das Dialogfeld Spezielles enthält größtenteils Kompatibilitätseinstellungen, die in einer Konfigurationsdatei abgelegt werden. Ort und Name der Konfigurationsdatei richten sich nach der XML-Einstellungsdatei. In der Regel heißt sie SpeedCommander.ini und liegt im Einstellungsverzeichnis unterhalb der Anwendungsdaten.

Die folgenden Tabellen zeigen die Sektionen und Optionen innerhalb der Konfigurationsdatei. Der Wert 0 entspricht bei der Anzeige im Dialogfeld dem Ausdruck Nein, während der Wert 1 dem Ausdruck Ja entspricht. Der Wert in der ersten Spalte zeigt den Standardwert.

[General]
CopyPathAddBackslash=0 | Hängt beim Kopieren von Ordnernamen in die Zwischenablage einen Backslash an. 0 - Ordnername ohne zusätzlichen Backslash 1 - Ordnername mit zusätzlichem Backslash
CopyPathUncAddBrackets=0 | Bettet den UNC-Namen beim Kopieren in die Zwischenablage in Klammern ein. 0 - Keine Klammern 1 - Runde Klammern () 2 - Eckige Klammern [] 3 - Geschweifte Klammern {} 4 - Eckige Klammern <>
RefreshTree=1 | Automatische Aktualisierung der Baumansicht 0 - Baumansicht wird nicht automatisch aktualisiert 1 - Baumansicht wird automatisch aktualisiert
CoFreeUnusedLibraries=0 | Entladen von Shell-Erweiterungen 0 - Shell-Erweiterungen werden während der Laufzeit nicht entladen 1 - Nicht mehr benötigte Shell-Erweiterungen werden während der Laufzeit entladen (Abstürze bei fehlerhaften Erweiterungen möglich!)
SizeUnitMode=1 | Modus für die Darstellung der Dateigrößen 0 - SE-Präfixe als Vielfaches von 1024 (KB, MB, GB) 1 - IEC-Präfixe als Vielfaches von 1024 (KiB, MiB, GiB)
[FrameWnd]
ShowProInCaption=1 Programmname mit Pro-Kennung in Titelzeile anzeigen
0 - Programmname ohne Pro-Kennung anzeigen
1 - Programmname mit Pro-Kennung anzeigen
[FrameStatusWnd]
Alpha=95 | Hinweisfenster bei doppelten Tastenkürzeln - Alphawert für Transparenz zwischen 0 und 100 0 - Transparent 100 - Undurchsichtig
HideTimer=1500 | Hinweisfenster bei doppelten Tastenkürzeln - Zeit für das automatische Ausblenden in ms
Position=1 | Hinweisfenster bei doppelten Tastenkürzeln - Position des Fensters 0 - oben 1 - unten
TextColor=0,0,0 | Hinweisfenster bei doppelten Tastenkürzeln - Textfarbe als RGB
TextBkColor=255,255,225 | Hinweisfenster bei doppelten Tastenkürzeln - Hintergrundfarbe als RGB
[FolderWnd]
DoubleRoot=1 | Zweistufiger Wechsel in den Hauptordner (Ordner - Wechseln zu - Hauptordner) 0 - Immer nur in den Hauptordner des Laufwerks wechseln 1 - Erster Befehl wechselt in den Hauptordner des Laufwerks, der zweite in den Desktop
ChangeToParentInRoot=1 | Wechsel aus dem Hauptordner nach oben per Backspace, Strg+BildAuf oder [..] 0 - Wechsel ist gesperrt 1 - Wechsel ist erlaubt
FilterInTreeWnd=1 | Anzeigefilter wird auch in der Baumansicht beachtet 0 - Anzeigefilter gilt nicht in der Baumansicht 1 - Anzeigefilter gilt in der Baumansicht
[FolderWndShell]
OpenWithContextMenu=0 | Öffnen von Dateien in der Listenansicht beim Doppelklick 0 - Einträge werden mit der Windows-Funktion ShellExecuteEx geöffnet 1 - Einträge werden mit Hilfe der Kontextmenü-Funktionen geöffnet
ShowOverlaysForSlowFolders=0 | Anzeige von Overlaysymbolen für langsame Netzlaufwerke 0 - Overlaysymbole werden nicht angezeigt 1 - Overlaysymbole werden angezeigt
[Drag&Drop]
ShellRightDrop=1 Anzeige des Kontextmenüs der Shell beim Ziehen und Ablegen mit der rechten Maustaste
0 - Kontextmenü wird von SpeedCommander angezeigt (wie in früheren Versionen bis einschließlich SpeedCommander 12)
1 - Kontextmenü wird von der Shell angezeigt (ermöglicht die Einbindung zusätzlicher Erweiterungen)
[ShellContextMenu]
BackgroundInit=1

Zusätzliche Initialisierung für das Hintergrund-Kontextmenü eines Ordnerfensters
0 - Keine zusätzliche Initialisierung
1 - Zusätzliche Initialisierung (IShellExtInit::Initialize) mit dem aktuellen Ordner. Nötig für die Anzeige des Untermenüs Freigeben für.
[MinimizeToTray]
RestoreKey2=32 Zusätzliche Taste für die Aktivierung aus dem Infobereich nach Alt-Tab, Zahl steht für ASCII-Wert der Taste (z.B.32 = Leerzeichen)
[TreeWnd]
FadeInOutExpandos=1 | Automatisches Ausblenden der Aufklappen-Schaltflächen in der Baumansicht (ab Windows Vista) 0 - Schaltflächen sind immer sichtbar 1 - Schaltflächen werden ausgeblendet, wenn die Baumansicht den Fokus verliert
AutoHorzScroll=1 | Automatisches horizontales Scrollen in der Baumansicht (ab Windows Vista) 0 - Kein Scrollen 1 - Automatisches horizontales Scrollen für bessere Lesbarkeit eines Eintrags
[ListWnd]
GroupCompareCaseSensitive=0 | Vergleich der Gruppennamen beim Sortieren nach Groß-/Kleinschreibung 0 - Gruppennamen werden unabhängig von der Groß-/Kleinschreibung sortiert 1 - Gruppennamen werden abhängig von der Groß-/Kleinschreibung sortiert
ShowAppState=1 | Darstellung der Einträge im aktiven Ordnerfenster, wenn SpeedCommander inaktiv ist 0 - Einträge im aktiven Ordnerfenster werden als aktiv gekennzeichnet 1 - Einträge im aktiven Ordnerfenster werden als inaktiv gekennzeichnet
MaxImageThreads=0 | Begrenzung der Hintergrundthreads zur Ermittlung von Dateisymbolen und Vorschaubildern 0 - Anzahl der Threads automatisch entsprechend der verfügbaren Prozessoren (4 Threads pro Prozessor, höchstens 32) 1-31 - Anzahl der Threads limitieren
MaxSubItemThreads=0 | Begrenzung der Hintergrundthreads zur Ermittlung von Spaltentexten 0 - Anzahl der Threads automatisch entsprechend der verfügbaren Prozessoren (4 Threads pro Prozessor, höchstens 32) 1-31 - Anzahl der Threads limitieren
MaxFolderSizeThreads=0 | Begrenzung der Hintergrundthreads zur Ermittlung von Ordnergrößen 0 - Anzahl der Threads automatisch (derzeit 5) 1-4 - Anzahl der Threads limitieren
[FilePreviewWnd]
EnablePreview=1 | Anzeige von Vorschaubildern in Bestätigungsdialogen für diverse Dateioperationen 0 - Vorschaubilder werden nicht angezeigt 1 - Vorschaubilder werden angezeigt 2 - Vorschaubilder werden angezeigt (Ermittlung im Hintergrund, eventuelle Fehlermeldung beim Ersetzen von bestimmten Dateitypen)
ExcludeExtensions=ext1;ext2 | Deaktivierung von Vorschaubildern für bestimmte Dateitypen (durch Semikolon getrennt)
[QuickSearch]
ForwardDeleteToList=0 Weiterleiten von Entf aus der Schnellsuche in die Listenansicht
0 - Entf in der Schnellsucht wird ignoriert
1 - Entf in der Schnellsucht wird an die Listenansicht weitergeleitet (direktes Löschen von Dateien aus der Schnellsuche)
[Accels]
AllowSingleCircumflex=0 | Erlaubt die Verwendung von Zirkumflex ohne zusätzliche Modifizierungstasten 0 - Zirkumflex ohne Modifizierungstasten gesperrt 1 - Zirkumflex ohne Modifizierungstasten möglich
ShowContextMenuAccelerators=0 | Anzeige von Tastenkürzeln in Kontextmenüs 0 - Kontextmenüs werden ohne Tastenkürzel angezeigt 1 - Kontextmenüs werden mit Tastenkürzeln angezeigt
[DriveWnd]
InfoTipDelayInitial=0 Verzögerung bei der Anzeige von InfoTips im Laufwerksfenster
0 - Systemeinstellung
1 - Verzögerung in Millisekunden
[FileOperation]
MoveOnSameName=0 | Verschieben, wenn Quell- und Zielname identisch sind 0 - Fehlermeldung 1 - Datei wird umbenannt von 'dateiname.ext' nach 'dateiname [1].ext'
CalcSizeInBackground=0 | Ermittlung der Gesamtgröße der zu kopierenden/löschenden Dateien 0 - Ermittlung vor dem Start des Kopier-/Löschvorgangs 1 - Ermittlung während des Kopier-/Löschvorgangs im Hintergrund
[Debug]
ChangeNotifyList=0 | Protokollierung der Änderungen im Dateisystem für die Listenansicht 0 - Keine Ausgabe 1 - Debugausgabe (z.B. über DebugView)
ChangeNotifyTree=0 | Protokollierung der Änderungen im Dateisystem für die Baumansicht 0 - Keine Ausgabe 1 - Debugausgabe (z.B. über DebugView)
ChangeNotifyDrives=0 | Protokollierung der Änderungen im Laufwerksfenster 0 - Keine Ausgabe 1 - Debugausgabe (z.B. über DebugView)
ChangeNotifyFolderSizes=0 | Protokollierung der Änderungen im Dateisystem für die Aktualisierung der Ordnergrößen 0 - Keine Ausgabe 1 - Debugausgabe (z.B. über DebugView)


Anpassen

SpeedCommander: Konfiguration
Anpassen

Mit dem Dialogfeld Anpassen können Sie das Menü und die Symbolleisten frei gestalten und häufig verwendeten Befehlen eigene Tastenkürzel zuordnen. Zur Anzeige des Dialogfelds wählen Sie im Menü Extras den Befehl Anpassen.

Mit der Anzeige des Dialogsfeld schaltet SpeedCommander in einen speziellen Anpassungsmodus um, der nach dem Schließen des Dialogfelds wieder beendet wird.

Weitere Themen

Symbolleisten und Menü anpassen

Tastenkürzel definieren

Visuelles Design ändern


Symbolleisten und Menü

SpeedCommander: Konfiguration
Symbolleisten und Menü

Mit Hilfe der Registerkarten Symbolleisten und Befehle können Sie die Symbolleisten und das Menü nach Ihren Wünschen gestalten. So können einzelne Symbolleisten ein- und ausgeblendet werden, eigene Symbolleisten erstellt, umbenannt und wieder gelöscht werden. Sie können sogar einzelne Menüeinträge ausblenden.

Befehlsnamen in eckigen Klammern sind Platzhalter für die entsprechenden Funktionsgruppen. Sie werden bei der Anzeige durch die aktuellen Werte ersetzt. Beim Befehl [Anwendungsfavoriten] sind das z.B. die vorhandenen Anwendungsfavoriten.

So fügen Sie einer Symbolleiste eine Schaltfläche hinzu:
  1. Aktivieren Sie die Registerkarte Befehle.
  2. Wählen Sie im Listenfeld Kategorien das Menü, das den entsprechenden Befehl enthält.
  3. Ziehen Sie die entsprechende Schaltfläche mit der linke Maustaste aus dem Listenfeld Befehle an die gewünschte Stelle in der Symbolleiste.
So entfernen Sie eine Schaltfläche aus einer Symbolleiste:
  1. Klicken Sie mit der linken Maustaste auf die Schaltfläche, die Sie entfernen möchten, und ziehen Sie die Schaltfläche aus der Symbolleiste heraus.
  2. Lassen Sie die linke Maustaste los.
So erstellen Sie eine neue Symbolleiste:
  1. Aktivieren Sie die Registerkarte Symbolleisten.
  2. Klicken Sie auf die Schaltfläche Neu.
  3. Geben Sie im Dialog Name der Symbolleiste einen Namen ein.
  4. Drücken Sie Eingabe oder klicken Sie auf OK.
So fügen Sie zwischen zwei Symbolen ein Trennzeichen ein:
  1. Klicken Sie in der Symbolleiste mit der rechten Maustaste auf das Symbol, vor dem Sie ein Trennzeichen einfügen möchten.
  2. Wählen Sie aus dem Kontextmenü den Befehl Gruppierung beginnen.
So passen Sie ein Symbol an:
  1. Klicken Sie in der Symbolleiste mit der rechten Maustaste auf das Symbol, das Sie anpassen möchten.
  2. Wählen Sie aus dem Kontextmenü den Befehl Schaltflächensymbol bearbeiten, der Dialog Symboleditor erscheint.
  3. Im Dialogfeld Symboleditor können Sie das Symbol anpassen.


Tastenkürzel

SpeedCommander: Konfiguration
Tastenkürzel

Die Registerkarte Tastatur ermöglicht es Ihnen, jedem Befehl in SpeedCommander ein eigenes Tastenkürzel zuzuordnen. Sie können das Tastaturschema auch auf eine Windows-kompatible Vorlage zurücksetzen.

So ordnen Sie einem Befehl ein Tastenkürzel zu:
  1. Wählen Sie in der Listenansicht den gewünschten Befehl. Sie können den Inhalt der Listenansicht auch durch Eingabe eines Filters im Eingabefeld Befehle mit folgendem Inhalt anzeigen einschränken.
  2. Geben Sie im Feld Neue Tastenkombination drücken das Tastenkürzel ein, welches Sie verwenden möchten.
  3. Klicken Sie auf Zuweisen.
  4. Das Tastenkürzel erscheint im Kombinationsfeld Tastenkombinationen für den ausgewählten Befehl.
So entfernen Sie ein zugeordnetes Tastenkürzel:
  1. Wählen Sie in der Listenansicht den gewünschten Befehl.
  2. Wählen Sie im Kombinationsfeld Tastenkombinationen für den ausgewählten Befehl das Tastenkürzel aus, welches Sie entfernen möchten.
  3. Klicken Sie auf Entfernen.
So setzen Sie alle Tastenkürzel zurück:
  1. Klicken Sie auf die Schaltfläche Zurücksetzen.
  2. Wählen Sie die gewünschte Tastenkürzelvorlage und klicken Sie auf OK.

Doppelte Tastenkürzel

Anwender von Visual Studio 2005/2008 kennen bereits die Möglichkeit, Befehle über ein doppeltes Tastenkürzel aufrufen zu können. Doppeltes Tastenkürzel heißt, dass man z.B. durch aufeinanderfolgendes Drücken von Strg+K und Strg+W das Lesezeichen-Fenster öffnet. Im Menü wird diese Tastenkombination als Strg+K, Strg+W dargestellt. Möglich sind auch Kombinationen mit unterschiedlichen Zusatztasten wie Strg+K, W oder Strg+K, Strg+Umschalt+W. Allerdings darf Strg+K dabei nicht als einfaches Tastenkürzel einem Befehl zugewiesen sein.

SpeedCommander gestattet ebenfalls die Verwendung von doppelten Tastenkürzeln. Geben Sie bei der Zuordnung einfach zwei Tastenkürzel nacheinander ein und klicken Sie dann auf Zuweisen.

Fest eingebaute Tastenkürzel

SpeedCommander enthält zusätzlich fest eingebaute Tastenkürzel, die nicht angepasst werden können.

Ordnerfenster
Enter | Wechseln in Ordner oder Ausführen einer Datei
Backspace | Wechsel in übergeordneten Ordner
Strg+BildAuf | Wechsel in übergeordneten Ordner
Tab | Wechsel zwischen den beiden Ordnerfenstern
Strg+Tab | Wechsel zwischen den Registerkarten eines Ordnerfensters
Umschalt+Tab | Wechsel zwischen Baum- und Listenansicht
Strg+<#> | Aktivierung des/der #. Ordnerfensters
Listenansicht
Leertaste | Auswählen einer Datei
Strg+Leertaste | Auswahl einer Datei aufheben
Cursortasten | Bewegung des Auswahlbalkens
Strg+Cursortasten | Bewegung des Auswahlbalkens ohne Änderung der Auswahl
Umschalt+Cursortasten | Auswählen einer zusammenhängenden Gruppe
Strg+Umschalt+ZehnerPlus | Optimale Spaltenbreite
Listenansicht NC-Auswahlmodus
Leertaste | Datei auswählen / Auswahl einer Datei aufheben
Einfg | Datei auswählen / Auswahl einer Datei aufheben und Auswahlbalken auf die nächste Datei setzen
Cursortasten | Bewegung des Auswahlbalkens
Pos1 | Auswahlbalken auf ersten Eintrag
Ende | Auswahlbalken auf letzten Eintrag
BildAb | Auswahlbalken seitenweise nach unten
BildAuf | Auswahlbalken seitenweise nach oben
Umschalt+Positionstasten | Zusammenhängende Dateien seitenweise auswählen
Umschalt+Cursortasten | Zusammenhängende Dateien einzeln auswählen
Listenansicht NC-Auswahlmodus mit "Markieren mit rechter Maustaste"
Rechte Maustaste | Datei auswählen / Auswahl einer Datei aufheben
Strg+Kontextmenu | Kontextmenü für ausgewählte Dateien
Baumansicht
Cursor-nach-unten | Nächster Eintrag auf gleicher Ebene
Cursor-nach-oben | Vorheriger Eintrag auf gleicher Ebene
Cursor-nach-rechts | Eintrag aufklappen oder bei aufgeklappten Eintrag in nächste Ebene
Cursor-nach-links | Eintrag zuklappen oder bei zugeklappten Eintrag in vorherige Ebene
Umschalt+ZehnerPlus | Eintrag aufklappen
Umschalt+ZehnerMinus | Eintrag zuklappen
Umschalt+ZehnerStern | Eintrag vollständig aufklappen
Eingabezeile
Tab | Wechsel zwischen den Ordnerfenstern
Enter | Befehl ausführen
Strg+Enter | Dateinamen einfügen
Strg+Umschalt+Enter | Vollständigen Dateinamen einfügen
Cursortasten | Änderung des Auswahlbalkens in der Listenansicht
Strg+Cursortasten | Nächstes / Vorheriges Wort
Umschalt+Cursortasten | Text markieren


Visuelle Designs

SpeedCommander: Konfiguration
Visuelle Designs

Mit Hilfe der Registerkarte Erweitert können Sie schnell zwischen verschiedenen Designs wechseln, die Art und Größe der Symbole festlegen und einige Einstellungen für die Darstellung von Symbolleisten anpassen.

Visuelles Design

Die Programmoberfläche von SpeedCommander kann in verschiedenen visuellen Designs angezeigt werden. Das visuelle Design bestimmt dabei die Darstellung von Menüs und Symbolleisten.

Folgende Designs werden angeboten:

  • Windows XP
  • Office 2000
  • Office XP
  • Office 2003
  • Office 2007 (Blau, Schwarz und Silber)
  • Office 2010 (Blau, Schwarz und Silber)
  • Office 2013
  • Visual Studio 2005
  • Visual Studio 2008
  • Visual Studio 2010
  • Visual Studio 2012 (Hell und Dunkel)

Wählen Sie im Kombinationsfeld Design einfach das gewünschte Design aus, die Änderungen werden sofort sichtbar. Die Einstellung Office 2007-Design im Ribbon-Stil legt fest, dass der Hintergrund der Symbolleisten wie in den Ribbons von Office 2007 gezeichnet werden soll. Klicken Sie mit der Maus auf das Kontrollkästchen und schalten Sie die Option ein bzw. aus, um den Unterschied zwischen den beiden Darstellungsformen zu sehen. Mit der Einstellung Rahmenfenster im Design-Stil können Sie festlegen, ob der Rahmen des Hauptfensters von SpeedCommander ebenfalls im entsprechenden Design-Stil dargestellt werden soll.

Im Kombinationsfeld Symbole legen Sie den Stil der Symbole fest, die im Menü und in den Symbolleisten angezeigt werden. Die Kombinationsfelder Menü und Symbolleiste legen die gewünschte Größe der Symbole fest. Die Symbole für Office 2003 liegen in den Größen Klein und Mittel vor, die Symbole für Office 2010/2013 in Klein, Mittel und Groß.

Andere

Die Einstellung QuickInfo auf Symbolleisten anzeigen legt fest, ob beim Überstreichen von Symbolleisten mit der Maus die Funktion des jeweiligen Symbols angezeigt werden soll. Aktivieren Sie das Kontrollkästchen Tastenkombinationen in QuickInfo anzeigen, wenn zur Funktion auch noch die vergebene Tastenkombination angezeigt werden soll.

Mit dem Kombinationsfeld Menüanimation können Sie festlegen, ob SpeedCommander das Öffnen von Menüs animieren soll. Mit der Auswahl (Systemstandard) wird die in Windows festgelegte Einstellung verwendet. Entfalten, Abrollen und Einblenden sind verschiedene Effekte, mit Abwechselnd wird einer dieser Effekte zufällig verwendet. Wählen Sie Keine, wenn das Öffnen von Menüs nicht animiert werden soll.


Schriftart einstellen

SpeedCommander: Konfiguration
Schriftart einstellen

Mit Hilfe des Dialogfelds Schriftart können Sie die in den Ordnerfenstern von SpeedCommander verwendete Schriftart und -größe ändern. In den Grundeinstellungen verwendet SpeedCommander unter Windows XP die Schriftart Tahoma sowie unter Windows Vista und neuer die Schriftart Segoe UI, beide in der Größe 8.

So ändern Sie die Schriftart:
  1. Aktivieren Sie im Menü Extras den Befehl Schriftart.
  2. Wählen Sie im Kombinationsfeld Schriftart die gewünschte Schriftart und im Kombinationsfeld Schriftgrad die gewünschte Schriftgröße.


Einstellungen sichern/wiederherstellen

SpeedCommander: Konfiguration
Einstellungen sichern/wiederherstellen

SpeedCommander speichert seine Einstellungen in einer XML-Datei. Die angepassten Menüs und Symbolleisten werden aufgrund ihrer Größe in externen Dateien abgelegt. In der Registrationsdatenbank wird lediglich der Freischaltcode gespeichert.

Alle Einstellungsdateien werden unterhalb des Anwendungsdatenordners in SpeedProject\SpeedCommander 15 gespeichert. Der Speicherort für die Anwendungsdaten ist abhängig vom Betriebssystem:

Betriebssystem | Speicherort für Anwendungsdaten
Windows XP | C:\Dokumente und Einstellungen\<Benutzername>\Anwendungsdaten
Windows Vista | C:\Benutzer\<Benutzername>\AppData\Roaming
Windows 7 | C:\Benutzer\<Benutzername>\AppData\Roaming

Mit Hilfe des Befehls Einstellungen sichern/wiederherstellen können Sie Ihre angepassten Einstellungen bequem sichern oder wiederherstellen. Dies vereinfacht den Umzug auf einen neuen Rechner oder das Zurücksetzen auf eine zuletzt funktionierende Konfiguration.

So sichern Sie Ihre Einstellungen:
  1. Öffnen Sie das Menü Extras und w ählen Sie den Befehl Einstellungen sichern/wiederherstellen.
  2. Beim ersten Aufruf müssen Sie einen Basisordner festlegen, in dem die Konfigurationen gespeichert werden. Wählen Sie entweder einen lokalen Ordner oder einen Netzwerkordner, wenn die Konfigurationen zentral abgelegt werden sollen.
  3. Wechseln Sie im Dialogfeld SC Backup & Restore auf die Seite Sichern.
  4. Aktivieren Sie das Kontrollkästchen Registrierungsdaten sichern, wenn auch Ihr Freischaltcode gesichert werden soll. Sie können auch einen Kommentar für die zu sichernde Konfiguration eingeben.
  5. Klicken Sie auf die Schaltfläche Sicherung starten.
So stellen Sie Ihre Einstellungen wieder her:
  1. Öffnen Sie das Menü Extras und wählen Sie den Befehl Einstellungen sichern/wiederherstellen.
  2. Wechseln Sie im Dialogfeld SC Backup & Restore auf die Seite Sichern.
  3. Wählen Sie die Konfiguration, welche Ihre gesicherten Einstellungen enthält.
  4. Aktivieren Sie das Kontrollkästchen Registrierungsdaten wiederherstellen, wenn auch Ihr Freischaltcode wieder in die Registrationsdatenbank eingetragen werden soll.
  5. Klicken Sie auf die Schaltfläche Wiederherstellung starten.


Kommandozeilenparameter

SpeedCommander: Konfiguration
Kommandozeilenparameter

Beim Aufruf von SpeedCommander können einige Optionen über Kommandozeilenparameter gewählt werden. Sie können auf diese Weise die Ordner festlegen, die nach dem Start angezeigt werden. Durch Vorgabe einer Einstellungsdatei können Sie SpeedCommander auch mit verschiedenen Konfigurationen betreiben.

Befehl | Bedeutung
<Ordner> | Pfad für das linke Ordnerfenster, in welchen nach dem Start gewechselt wird
/l:<Ordner> | Pfad für das linke Ordnerfenster, in welchen nach dem Start gewechselt wird
/r:<Ordner> | Pfad für das rechte Ordnerfenster, in welchen nach dem Start gewechselt wird
/xml:<Einstellungen.xml> | Vorgabe einer speziellen Einstellungsdatei (z.B. SpeedCommander.exe /xml:C:\Test\SpeedCommander.xml)
/caption:<Fenstertitel> | Vorgabe eines Fenstertitels für das Hauptfenster
/layout:<Layoutname> | Laden eines vordefinierten Layouts beim Start
/register | Registrierung von Dateiverknüpfungen (keine Zuordnung) und Typenbibliothek
/unregister | Registrierung von Dateiverknüpfungen und Typenbibliothek entfernen
/noaddins | Programmstart ohne AddIns
/noscript | Programmstart ohne Skripting-Funktionen
/import11:<Einstellungsordner> | Importiert Einstellungen von SpeedCommander 11 aus dem angegebenen Ordner. Die importierten Einstellungen werden im Anwendungsdaten-Verzeichnis abgelegt.
/import12:<Einstellungsordner> | Importiert Einstellungen von SpeedCommander 12 aus dem angegebenen Ordner. Die importierten Einstellungen werden im Anwendungsdaten-Verzeichnis abgelegt.
/import13:<Einstellungsordner> | Importiert Einstellungen von SpeedCommander 13 aus dem angegebenen Ordner. Die importierten Einstellungen werden im Anwendungsdaten-Verzeichnis abgelegt.
Hinweis

Der Platzhalter <Ordner> steht für einen Pfad im Dateisystem, ein Archiv oder einen virtuellen Ordner. Mögliche Anwendungen sind:

  • C:\Windows
  • \\SERVER\\Freigabe\Musik
  • D:\Beispiel.zip
  • Desktop\Bibliotheken
  • shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}


Installation auf einem USB-Stick

SpeedCommander: Konfiguration
Installation auf einem USB-Stick

SpeedCommander verwendet für seine Einstellungen eine XML-Datei und ist daher nicht auf die Registrationsdatenbank angewiesen. Daher ist es besonders einfach, SpeedCommander auf einen USB-Stick zu kopieren und überall einzusetzen.

Einrichtung auf einem USB-Stick

Kopieren Sie einfach das Programmverzeichnis von SpeedCommander und die Einstellungsdateien auf Ihren USB-Stick. Alle Einstellungsdateien werden unterhalb des Anwendungsdatenordners in SpeedProject\SpeedCommander 15 gespeichert. Der Speicherort für die Anwendungsdaten ist abhängig vom Betriebssystem:

Betriebssystem | Speicherort für Anwendungsdaten
Windows XP | C:\Dokumente und Einstellungen\<Benutzername>\Anwendungsdaten
Windows Vista | C:\Benutzer\<Benutzername>\AppData\Roaming
Windows 7 | C:\Benutzer\<Benutzername>\AppData\Roaming

Wenn SpeedCommander beim Start erkennt, dass sich im Programmverzeichnis auch die Einstellungsdatei SpeedCommander.xml befindet, dann sucht SpeedCommander alle Einstellungsdateien im Programmverzeichnis.

Freischaltcode verwenden

Bei der Standardinstallation auf einem Computer wird der Freischaltcode von SpeedCommander in der Registrationsdatenbank eingetragen. Beim Start von einem USB-Stick an einem fremden Rechner ist dies aber problematisch, da der Freischaltcode auch nach dem Abziehen des USB-Sticks auf dem Computer verbleiben würde.

Erstellen Sie deshalb im SpeedCommander-Verzeichnis auf dem USB-Stick eine Textdatei register.ini mit folgendem Inhalt:

[register]
RegOwner=Ihr Name
KeyCode=Ihr Freischaltcode
Verschlüsselten Freischaltcode verwenden

Sie können Ihren Freischaltcode auch mit einem Kennwort verschlüsselt ablegen, SpeedCommander fragt dann beim Start nach dem Kennwort. Ohne das richtige Kennwort startet SpeedCommander lediglich als Testversion. Zur Verschlüsselung benutzen Sie bitte das Programm EncryptKeyCode.exe aus dem SpeedCommander-Programmverzeichnis. Tragen Sie den verschlüsselten Freischaltcode anschließend wie folgt in der register.ini ein:

[register]
RegOwner=Ihr Name
KeyCode2=Ihr verschlüsselter Freischaltcode
Ordner für zusätzliche Anwendungen

Um die Zusatzprogramme SpeedEdit, SpeedView und FileSearch auf dem USB-Stick nutzen zu können, müssen Sie im Einstellungsdialog auf der Seite Anwendungen & Internet noch den Pfad zu den Programmen anpassen. Da der Pfad bzw. der Laufwerksbuchstaben für den USB-Stick von System zu System verschieden ist, sollte hier einfach nur den Namen der Programmdatei angegeben werden (z.B. SpeedView.exe). SpeedCommander sucht das Programm dann in seinem Programmverzeichnis.

Alternativ können Sie hier auch die Umgebungsvariable %SCDIR% verwenden. Diese Umgebungsvariable wird beim Start von SpeedCommander gesetzt und zeigt immer auf das jeweilige Programmverzeichnis. Der Eintrag für SpeedView sähe dann wie folgt aus: %SCDIR%\SpeedView.exe

Anpassen der AddIn-Einstellungens

AddIns müssen im System registriert sein, bevor SpeedCommander sie verwenden kann. Im mobilen Einsatz kann SpeedCommander AddIns automatisch beim Programmstart registrieren und beim Programmende wieder aus der Registrationsdatenbank austragen. Dazu muss in der register.ini eine Sektion AddIns erstellt werden, in der alle AddIns mit ihrem relativen Pfad in Bezug zur register.ini eingetragen werden. Der Wert Items gibt die Anzahl an, die AddIns werden unter den Werten Item0 ... Item99 aufgeführt:

[AddIns]
Items=2
Item0=AddIns\WfxWrapper.dll
Item1=AddIns\WinCeFS.dll


FileSearch
Überblick

FileSearch ist ein schnelles und komfortables Suchprogramm. Sie können mit FileSearch Ordner oder ganze Laufwerke nach Dateien durchsuchen. FileSearch bietet Ihnen folgende Möglichkeiten:

  • Suche nach Dateiinhalten (Text, Hexadezimal, Binär)
  • Verwendung von Suchoperatoren (UND, ODER, NICHT)
  • Suchen von Unicode-Text
  • Suchen von doppelten Dateien
  • Anzeige der gefundenen Treffer
  • Suchen in Archiven und in selbstentpackenden Archiven
  • Übernahme der gefundenen Dateien in ein Ordnerfenster oder in die Dateiablage des SpeedCommander
  • Speichern von Sucheinstellungen in einem Suchprofil

Weitere Themen

Dateien suchen

Suchoperatoren verwenden

Suchergebnisse bearbeiten

Suchprofile verwenden


Suchen von Dateien

FileSearch
Suchen von Dateien

Mit FileSearch können Sie einfach nach Dateien auf lokalen Datenträgern, im Netzwerk oder sogar in Archiven suchen. FileSearch ermöglicht Ihnen die Verwendung von verschiedene Suchkriterien. Sie können z.B. bei der Suche nach Dateien deren Namen, Datum und Größe angeben. Sie können auch nach Dateien suchen, die einen bestimmten Text enthalten.

Die einzelnen Suchkriterien werden auf drei Registerkarten definiert.

Name und Ort

Die Registerkarte Name und Ort legt fest, nach welchen Dateinamen Sie suchen möchten und wo FileSearch suchen soll. Die Eingabefelder Einschließen und Ausschließen bieten die Möglichkeit, nur nach bestimmten Dateimasken zu suchen oder bestimmte Dateimasken von der Suche auszuschließen. Die Dateimasken können auch Stellvertreterzeichen enthalten. Gültige Stellvertreterzeichen das Fragezeichen ? für ein unbestimmtes Zeichen sowie das Sternchen * für mehrere unbestimmte Zeichen.

Aktivieren Sie das Kontrollkästchen Ordner suchen, wenn in der Ergebnisliste auch Ordner angezeigt werden sollen, die den Suchkriterien entsprechen. Deaktivieren Sie diese Einstellung, wenn FileSearch in der Ergebnisliste nur Dateien anzeigen soll. Die Einstellung Archive durchsuchen legt fest, dass auch Archivdateien nach Übereinstimmungen durchsucht werden sollen. Insbesondere bei der Textsuche kann dies den Suchvorgang verlangsamen, da die Archivdateien jedesmal temporär entpackt werden müssen.

Die Auswahlfelder Ordner und Laufwerke legen fest, ob die Suche in einem einzelnen Ordner oder über mehrere Laufwerke erfolgen soll.

Datum, Größe und Attribute

Im Bereich Datum können Sie den Zeitraum der gesuchten Dateien einschränken. Die möglichen Zeitstempel sind Zuletzt geänderte Dateien, Erstellte Dateien und Auf zuletzt zugegriffene Dateien. Sie können einen Zeitraum angeben oder nach einem bestimmten Datum suchen.

Der Bereich Größe gibt Ihnen die Möglichkeit, die Dateigröße der gesuchten Dateien einzuschränken. Aktivieren Sie beispielsweise das Kontrollkästchen Kleiner als und geben Sie als Suchwert 1 Byte an, um alle leeren Dateien zu ermitteln.

Im Bereich Dateiattribute können Sie festlegen, ob nach Dateien mit einem oder mehreren bestimmten Attributen gesucht werden soll. Aktivieren Sie ein Kontrollkästchen, um Dateien zu suchen, die das entsprechende Attribut besitzen. Deaktivieren Sie ein Kontrollkästchen, um Dateien zu suchen, die das entsprechende Attribut nicht besitzen. Schalten Sie ein Kontrollkästchen auf den teilmarkierten Zustand, wenn das entsprechende Attribut nicht beachtet werden soll.

Erweitert - Suche nach enthaltenem Text

Die Auswahlfelder Text und Hex legen fest, ob nach einem angegebenen Suchtext oder einem Hexadezimalwert bzw. Binärwert gesucht werden soll. Bei Aktivierung des Kontrollkästchens Groß-/Kleinschreibung beachten wird nach Textzeichenfolgen gesucht, die der Groß-/Kleinschreibung des Suchtextes genau entsprechen. Andernfalls wird die Groß-/Kleinschreibung des Suchtextes ignoriert.

Aktivieren Sie das Kontrollkästchen Nur ganze Wörter, wenn nach Textzeichenfolgen gesucht werden soll, die dem angegebenen Suchtext entsprechen, und denen ein Leerzeichen, ein Tabulatorzeichen oder ein Worttrennzeichen nach- bzw. vorangestellt ist oder die sich am Anfang oder am Ende einer Zeile befinden. Andernfalls werden durch die Suche alle entsprechenden Zeichenfolgen ermittelt, unabhängig davon, ob es sich um Teile einer längeren Zeichenfolge handelt oder nicht. Gültige Worttrennzeichen sind die Zeichen .!?,;:-_()[]{}=*"+§$'#%\^/~<>|@\n\r\t.

Bei Aktivierung des Kontrollkästchens Alle Vorkommen ermitteln werden alle Vorkommen des angegebene Suchtextes ermittelt. Andernfalls wird nach dem ersten Auffinden des angegebenen Suchtextes die Suche abgebrochen. Aktivieren Sie diese Einstellung nur, wenn die genaue Anzahl der Fundstellen benötigt wird.

Das Kontrollkästchen ASCII legt fest, dass der angegebene Suchtext vor der Suche in den IBM-ASCII-Zeichensatz umgewandelt werden soll. Aktivieren Sie diese Einstellung, wenn Dateien durchsucht werden sollen, die noch mit DOS-Programmen erzeugt wurden.

Bei Aktivierung des Kontrollkästchens Unicode wird der angegebene Suchtext vor der Suche in den Unicode-Zeichensatz umgewandelt. Aktivieren Sie diese Einstellung, wenn Dateien durchsucht werden, die Unicode-Text enthalten.

Erweitert - Suche nach doppelten Dateien

Aktivieren Sie das Kontrollkästchen Gleicher Name, um nach doppelten Dateien mit dem gleichen Namen zu suchen. Die doppelten Einträge werden in der Ergebnisliste entsprechend gruppiert und abwechselnd fett dargestellt. Das Kontrollkästchen Gleiche Größe legt fest, dass bei der Gruppierung auch die Größe der Dateien beachtet werden soll.

Mit dem Kontrollkästchen Gleicher Inhalt wird festgelegt, dass Dateien mit gleichem Inhalt gesucht werden sollen. Diese Einstellung impliziert automatisch die Einstellung Gleiche Größe. Die gefundenen Dateien sind dann 100% identisch, können aber unterschiedliche Dateinamen haben.


Suchoperatoren verwenden

FileSearch
Suchoperatoren verwenden

FileSearch kennt grundsätzlich zwei verschiedene Suchmodi: Das Suchen nach reinem Text wie z.B. Schiff oder Hafen und die Suche nach Hexadezimalzeichen bzw. binären Bitmustern.

Suchen nach Text

Die einzelnen Worte, nach denen gesucht werden soll, können mit den booleschen Operatoren ODER bzw. OR, UND bzw. AND und NICHT bzw. NOT verknüpft werden. Zusätzlich können Teile des Suchausdruckes einzeln und mehrfach in Klammern gesetzt werden, um die eigentliche Rangfolge der booleschen Operatoren zu übergehen. Suchworte können das Jokerzeichen * für eine unbestimmte Anzahl von unbestimmten Zeichen und den Platzhalter ? für ein unbestimmtes Zeichen enthalten. Die Suche nach Str*e würde z.B. Strasse und Straße finden, die Suche nach M*er würde Maier, Meier, Meyer, Müller, und Möller finden, die Suche nach M?ller würde Müller, Möller und Miller finden.

Hexadezimal-Suche bzw. das Suchen nach binären Bitmustern

Bei der Hexadezimal-Suche werden die Suchworte in hexadezimaler Notation angegeben (z.B. F0FAFE), entsprechend werden die Suchworte bei der Suche nach binären Bitmustern in binärer Notation angegeben (z.B. 11101101). Mit der Hexadezimal-Suche bzw. mit der Suche nach binären Bitmustern könnte man z.B. ausführbare Dateien (EXE-Dateien) nach ganz bestimmtem Codeteilen wie virulentem Code durchsuchen.

Rangfolge der Booleschen Operatoren

Die natürliche Rangfolge der booleschen Operatoren lautet: NICHT UND ODER. Ein geklammerter Ausdruck in runden Klammern übergeht die natürliche Rangfolge.

  • Schiff ODER Hafen UND Hamburg findet alle Dokumente, in denen Hafen und Hamburg oder Schiff vorkommt.
  • (Schiff ODER Hafen) UND Hamburg findet alle Dokumente, in denen Schiff oder Hafen und Hamburg vorkommt.

Suchausdrücke können nahezu beliebig miteinander verknüpft werden und es können beliebig viele Klammerebenen gesetzt werden, z.B. ((Schiff ODER Hafen) UND Hamburg) UND Fracht. Suchworten dürfen sogenannte Selbstoperatoren zugewiesen werden (obwohl es nicht notwendig ist), zwischen Klammerpaaren hingegen darf jeweils nur ein Operator vorhanden sein.

Der Suchausdruck Schiff UND NICHT Hafen z.B. ist korrekt, es würden alle Dokumente gefunden werden, die Schiff und nicht Hafen enthalten. Der Suchausdruck (Schiff UND Hafen) UND NICHT (Fracht ODER Hamburg) würde mit einem Syntax-Fehler quittiert werden, weil zwischen den Klammerpaaren die beiden Operatoren UND und NICHT stehen. Die korrekte Schreibweise für den vorgenannten Ausdruck wäre (Schiff UND Hafen) NICHT (Fracht ODER Hamburg).

Reservierte Worte und Zeichen

Aufgrund der booleschen Ausdrücke als Abfragesprache sowie der erweiterten Joker- und Wildcardsuche sind einige Worte und Zeichen für den internen Gebrauch von FileSearch reserviert. Die Worte

  • ODER
  • UND
  • NICHT
  • OR
  • AND
  • NOT

sowie die Zeichen

  • | (für ODER)
  • + (für UND)
  • - (für NICHT)
  • (
  • )
  • *
  • ?
  • "

können nur in Suchausdrücken verwendet werden, wenn sie durch hochgestellte Anführungszeichen eingeschlossen werden.

"UND" ODER "NICHT" würde z.B. alle Dokumente finden, die UND oder NICHT enthalten. Ohne die Anführungszeichen würde der Suchausdruck nicht ausgewertet werden können. Müller"?" würde alle Dokumente finden, die Müller? enthalten. Ohne die Anführungszeichen würde Müllers gefunden werden.

Die Groß-/Kleinschreibung der booleschen Operatoren ist nicht wichtig, UND erfüllt dieselbe Aufgabe wie und, Und oder uNd.


Suchergebnisse bearbeiten

FileSearch
Suchergebnisse bearbeiten

Alle gefundenen Dateien werden in einem Listenfeld angezeigt. Sie können

  • die Suchergebnisse anzeigen
  • eine Datei öffnen
  • eine Datei in SpeedCommander anzeigen
  • Dateien zur Dateiablage in SpeedCommander hinzufügen
  • Dateien löschen

Suchergebnisse anzeigen

Wenn Sie erfahren möchten, wo genau sich in der Datei der Suchtext befindet, können Sie sich von FileSearch die Fundstellen anzeigen lassen.

So zeigen Sie die Fundstellen an:
  1. Markieren Sie im Listenfeld die Datei, deren Fundstellen Sie sich anzeigen lassen möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Fundstellen anzeigen.
  3. FileSearch öffnet ein Fenster und zeigt die Fundstellen an.
  4. Sie können mit Nächster Treffer und Vorheriger Treffer zur nächsten/vorherigen Fundstelle wechseln.

Datei öffnen

Mit Hilfe des Befehls Öffnen können Sie eine gefundene Datei öffnen. Die Anwendung, mit der die Datei verknüpft ist, wird gestartet und zeigt die Datei an.

So öffnen Sie eine Datei:
  1. Markieren Sie im Listenfeld die Datei, die Sie öffnen möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Öffnen.
  3. FileSearch startet die Anwendung, mit der die Datei verknüpft ist.

Datei in SpeedCommander anzeigen

Mit Hilfe des Befehls Zur Datei springen können Sie in SpeedCommander zu einer gefundenen Datei wechseln, wenn dieser im Hintergrund geöffnet ist. SpeedCommander wechselt dazu im aktiven Ordnerfenster in den Ordner, in dem sich die Datei befindet und setzt den Auswahlbalken auf die Datei.

So zeigen Sie eine Datei in SpeedCommander an:
  1. Markieren Sie im Listenfeld die Datei, zu der Sie in SpeedCommander wechseln möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Zur Datei springen.
  3. SpeedCommander wird aktiviert und setzt den Auswahlbalken auf die Datei.

Dateien zur Dateiablage in SpeedCommander hinzufügen

Mit Hilfe des Befehls Zur Dateiablage hinzufügen können Sie eine oder mehrere Dateien der aktiven Dateiablage von SpeedCommander hinzufügen, wenn dieser im Hintergrund geöffnet ist. Dies ermöglicht es Ihnen zum Beispiel, alle gefundenen Dateien zu komprimieren.

So fügen Sie eine oder mehrere Dateien der Dateiablage in SpeedCommander hinzu:
  1. Markieren Sie im Listenfeld die Dateien, die Sie der Dateiablage hinzufügen möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Zur Dateiablage hinzufügen, wenn Sie die Dateien der aktiven Dateiablage hinzufügen möchten. Wählen Sie den Befehl Zur neuen Dateiablage hinzufügen, wenn SpeedCommander für die gewählten Dateien eine neue Dateiablage erstellen soll.
  3. SpeedCommander wird aktiviert und die Datei(en) werden der aktiven Dateiablage hinzugefügt.

Dateien löschen

Sie können gefundene Dateien löschen oder in den Papierkorb verschieben. Sie können so zum Beispiel alle überflüssigen Dateien (*.tmp; *.bak) schnell von Ihrer Festplatte entfernen.

So löschen Sie eine oder mehrere Dateien:
  1. Markieren Sie im Listenfeld die Dateien, die Sie löschen möchten.
  2. Wählen Sie aus dem Menü Datei den Befehl Löschen, wenn Sie die Datei löschen möchten; oder den Befehl Löschen in den Papierkorb, wenn Sie die Dateien in den Papierkorb verschieben möchten.


Suchprofile verwenden

FileSearch
Suchprofile verwenden

In einem Suchprofil können Sie Ihre aktuellen Sucheinstellungen speichern, so dass Sie schnell zwischen verschiedenen häufig genutzten Einstellungen umschalten können.

So speichern Sie ein Profil:
  1. Konfigurieren Sie die Einstellungen, die Sie speichern möchten.
  2. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie den Befehl Speichern.
  3. Geben Sie im Dialogfeld Profil speichern einen Namen für das neue Profil ein und klicken Sie auf OK.
So löschen Sie ein gespeichertes Profil:
  1. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie den Befehl Löschen.
  2. Markieren Sie im Dialog Profil löschen das zu löschende Profil und klicken Sie auf OK.
So aktivieren Sie ein Profil:
  1. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie das Profil aus, welches Sie aktivieren möchten.
  2. Sie können auch das Symbol Profile aus der Symbolleiste verwenden oder im Einstellungsdialog Anpassen jedem Profil ein eigenes Tastenkürzel zuordnen.


Einstellungen

FileSearch
Einstellungen

Die Grundeinstellungen von FileSearch werden im Menü Extras festgelegt. Öffnen Sie das Menü Extras und wählen Sie die Einstellung, die Sie ändern möchten.

Aktivieren Sie die Einstellung Selbstentpackende Archive durchsuchen, wenn ausführbare Programmdateien auch als Archive betrachtet werden und diese gegebenenfalls durchsucht werden sollen. Die Einstellung Verschlüsselte Archive überspringen legt fest, dass bei kennwortgeschützten Archivdateien nicht nach dem Kennwort zum Auflisten des Archivinhalts bzw. zum Entpacken der Dateien gefragt werden soll.

Mit der Einstellung Nur eine Instanz erlauben wird festgelegt, dass beim Start von FileSearch geprüft werden soll, ob bereits eine Programmkopie von FileSearch aktiv ist. Bei erfolgreicher Prüfung wird die bereits laufende Programmkopie aktiviert und der Start der neuen Programmkopie beendet. Die Einstellung FileSearch bei Anzeige im SC schließen legt fest, dass FileSearch beendet werden soll, wenn eine Datei in SpeedCommander angezeigt wird.

Im Untermenü Aktion bei Doppelklick können Sie festlegen, welche Aktion ausgeführt werden soll, wenn Sie in der Ergebnisliste auf einen gefundenen Eintrag doppelklicken. Mit Öffnen wird die Datei mit dem Programm ausgeführt, mit dem sie verknüpft ist. Wählen Sie Fundstellen anzeigen, wenn der Dateiinhalt mit den gefundenen Treffern angezeigt werden soll. Zur Datei springen legt fest, dass die Datei im aktiven Fenster von SpeedCommander markiert werden soll, wenn dieser im Hintergrund geöffnet ist.

Der Befehl Alle Verlaufslisten löschen entfernt alle alle in FileSearch gespeicherten Eingaben.


SpeedEdit
Überblick

SpeedEdit ist ein komfortabler Editor zur Bearbeitung von Textdateien und bietet zusätzlich folgende Funktionen:

  • Integriertes Syntaxhighlighting für: ASP, Basic, Batch, C/C++, DCL (AutoCAD), Fortran, HTML, InstallShield, Java, LISP (AutoCAD), Pascal, Perl, PHP, Python, Ressourcen, REXX, SGML, Shell Script, SIOD, SQL, TCL, TeX
  • Definition von AutoText-Einträgen
  • Einsatz von Lesezeichen
  • Umwandlung eines Textes in Groß- oder Kleinbuchstaben
  • Vertauschen von Groß-/Kleinbuchstaben
  • Inkrementelle Suche
  • Schreibschutzmodus
  • Druckvorschau

Weitere Themen

Datei erstellen, öffnen und speichern

Text kopieren, einfügen, ausschneiden und löschen

Text suchen und ersetzen

Lesezeichen verwenden

AutoText-Einträge verwenden

Einstellungen


Datei erstellen,öffnen und speichern

SpeedEdit
Datei erstellen, öffnen und speichern

Sie können mit SpeedEdit ein neues Dokument erstellen, ein bereits vorhandenes Dokument öffnen und die vorgenommen Änderungen speichern.

So erstellen Sie ein neues Dokument:
  1. Wählen Sie im Menü Datei den Befehl Neu oder klicken Sie in der Symbolleiste auf die Schaltfläche Neu.
  2. SpeedEdit erzeugt ein neues Fenster und Sie können mit der Eingabe des Textes beginnen.
So öffnen Sie ein bereits vorhandenes Dokument:
  1. Wählen Sie im Menü Datei den Befehl Öffnen oder klicken Sie in der Symbolleiste auf die Schaltfläche Öffnen.
  2. Das Dialogfeld Öffnen erscheint.
  3. Klicken Sie im Feld Suchen in auf das Laufwerk, auf dem das zu öffnende Dokument gespeichert ist.
  4. Wechseln Sie zum gewünschten Dokument, klicken Sie auf den Namen des Dokuments und klicken Sie auf Öffnen.
So speichern Sie Ihre Änderungen:
  1. Wählen Sie im Menü Datei den Befehl Speichern.
  2. Um das Dokument unter einem anderen Namen zu speichern, wählen Sie im Menü Datei den Befehl Speichern unter, geben im Eingabefeld Dateiname den gewünschten Namen ein und klicken dann auf Speichern.


Text kopieren, einfügen, ausschneiden und löschen

SpeedEdit
Text kopieren, einfügen, ausschneiden und löschen

So können Sie Text ausschneiden, kopieren, einfügen und löschen.

So kopieren Sie einen Text in die Zwischenablage:
  1. Markieren Sie den Text, den Sie kopieren möchten.
  2. Wählen Sie im Menü Bearbeiten den Befehl Kopieren, oder klicken Sie in der Symbolleiste auf die Schaltfläche Kopieren.
So fügen Sie einen Text aus der Zwischenablage ein:
  1. Platzieren Sie die Einfügemarke an die Stelle, an der Sie den Text einfügen möchten.
  2. Wählen Sie im Menü Bearbeiten den Befehl Einfügen, oder klicken Sie in der Symbolleiste auf die Schaltfläche Einfügen.
So schneiden Sie einen Text aus:
  1. Markieren Sie den Text, den Sie ausschneiden möchten.
  2. Wählen Sie im Menü Bearbeiten den Befehl Ausschneiden, oder klicken Sie in der Symbolleiste auf die Schaltfläche Ausschneiden.
So löschen Sie einen Text:
  1. Markieren Sie den Text, den Sie löschen möchten.
  2. Wählen Sie im Menü Bearbeiten den Befehl Löschen, oder klicken Sie in der Symbolleiste auf die Schaltfläche Löschen.


Text suchen und ersetzen

SpeedEdit
Text suchen und ersetzen

Sie können das Dokument nach Wörtern oder Zeichen durchsuchen. Darüber hinaus können Sie Wörter und Zeichen durch einen bestimmten Text ersetzen lassen.

So suchen Sie nach einem Text:
  1. Wählen Sie aus dem Menü Bearbeiten den Befehl Suchen.
  2. Das Dialogfeld Suchen erscheint.
  3. Geben Sie im Feld Suchen nach den Suchtext (Zeichen oder Wörter) ein, und klicken Sie anschließend auf Weitersuchen.
  4. Um eine weitere Stelle zu finden, an welcher der Text vorkommt, klicken Sie noch einmal auf Weitersuchen. Wenn Sie das Dialogfeld Suchen bereits geschlossen haben, können Sie die Suche nach dem Text mit der Taste F3 fortsetzen.
So ersetzen Sie einen Text durch einen anderen:
  1. Wählen Sie aus dem Menü Bearbeiten den Befehl Ersetzen.
  2. Das Dialogfeld Ersetzen erscheint.
  3. Geben Sie im Feld Suchen nach die zu suchenden Zeichen oder Wörter ein. Geben Sie im Feld Ersetzen durch den Text ein, durch den der Suchtext ersetzt werden soll.

  4. Klicken Sie auf Weitersuchen und dann auf Ersetzen. Wenn Sie alle Textstellen auf einmal ersetzen möchten, klicken Sie auf Alles ersetzen.


Lesezeichen verwenden

SpeedEdit
Lesezeichen verwenden

Bei größeren Textdokumenten empfiehlt sich der Einsatz von Lesezeichen, um schneller im Text navigieren zu können. SpeedEdit kann bis zu 10 benannte und beliebig viele unbenannte Lesezeichen erstellen. Der Vorteil bei einem benannten Lesezeichen ist, dass das Lesezeichen direkt angesprungen werden kann.

So erstellen Sie ein benanntes Lesezeichen:
  1. Wechseln Sie in die Zeile, für die Sie ein Lesezeichen erstellen möchten.
  2. Drücken Sie Strg+1, um das Lesezeichen 1 zu erstellen. Sie können auch die Ziffern 2-0 verwenden, um die Lesezeichen 2-10 zu erstellen.
  3. Ein erneutes Drücken von Strg+1 (bzw. Strg+2 ... Strg+0) schaltet das Lesezeichen wieder aus.
So aktivieren Sie ein benanntes Lesezeichen:
  1. Drücken Sie Alt+1, um das Lesezeichen 1 zu aktivieren. Sie können auch die Ziffern 2-0 verwenden, um die Lesezeichen 2-10 zu aktivieren.
  2. Die entsprechende Zeile im Textdokument wird angezeigt.

Unbenannte Lesezeichen können nicht direkt angesprungen werden, man kann nur direkt zwischen ihnen hin- und herwechseln. Ein unbenanntes Lesezeichen wird mit Strg+F2 erstellt. Drücken Sie F2 oder Umschalt+F2, um zwischen den Lesezeichen zu wechseln.


AutoText-Einträge verwenden

SpeedEdit
AutoText-Einträge verwenden

Mit SpeedEdit können Sie AutoText-Einträge definieren. SpeedEdit ersetzt dann das eingegebene Kürzel durch den ihm zugeordneten Eintrag. Wenn Sie z.B. dem Kürzel mfg den Eintrag Mit freundlichen Grüßen zuordnen, wird bei der Eingabe mfg durch Mit freundlichen Grüßen ersetzt.

So definieren Sie einen AutoText-Eintrag:
  1. Wählen Sie aus dem Menü Extras den Befehl Einstellungen und wechseln Sie auf die Seite Automatisches Ersetzen.
  2. Tragen Sie in das Eingabefeld Kürzel den Begriff ein, den SpeedEdit bei der Eingabe ersetzen soll.
  3. Tragen Sie in das Eingabefeld Text den Text ein, den SpeedEdit anstelle des Begriffs oder der Abkürzung im Eingabefeld Kürzel einfügen soll.
  4. Klicken Sie auf Hinzufügen.
So verwenden Sie einen AutoText-Eintrag:
  1. Geben Sie im Textdokument das entsprechende Kürzel ein.
  2. Öffnen Sie das Menü Bearbeiten, zeigen Sie auf Weitere Optionen und wählen Sie den Befehl Automatisch ersetzen; oder drücken Sie Strg+Enter, um das Kürzel durch den zugeordneten Text zu ersetzen.


Einstellungen

SpeedEdit
Einstellungen

Im Einstellungsdialog nehmen Sie die Grundeinstellungen für SpeedEdit vor. Zur Anzeige des Einstellungsdialogs wählen Sie den Befehl Einstellungen aus dem Menü Extras.

Der Einstellungsdialog besteht aus mehreren Dialogseiten:

  • Allgemein
  • Editor
  • Drucken
  • Syntaxhervorhebung
  • Automatisches Ersetzen

Allgemein

Hier definieren Sie allgemeine Einstellungen von SpeedEdit.

Programmstart

Aktivieren Sie das Kontrollkästchen Hauptfenster beim Start maximieren, wenn das Hauptfenster von SpeedEdit beim Start in voller Größe dargestellt werden soll. Möchten Sie die einzelnen Dokumentenfenster innerhalb des Hauptfensters in voller Größe anzeigen, dann aktivieren Sie die Einstellung Dokumentenfenster beim Start maximieren. Aktivieren Sie das Kontrollkästchen Zuletzt geladene Dokumente öffnen, wenn SpeedEdit beim Start alle Dokumente laden soll, die beim Beenden der letzten SpeedEdit-Sitzung angezeigt wurden.

Programmende

Das Kontrollkästchen Position der Einfügemarke und aktuelle Auswahl speichern legt fest, dass SpeedEdit die Position der Einfügemarke sowie die aktuelle Auswahl für eine Datei speichern soll. Wird die Datei das nächste Mal geöffnet, dann wird die letzte Position der Einfügemarke sowie die vorherige Auswahl wiederhergestellt. Aktivieren Sie das Kontrollkästchen SpeedEdit mit Escape beenden, wenn Sie SpeedEdit auch durch Drücken der Taste Escape beenden möchten.

Überwachung

Die Einstellung Erkennung von extern geänderten Dateien legt fest, ob SpeedEdit darauf achten soll, ob die gerade geöffneten Dokumente von anderen Anwendungen verändert werden. Bei einer Änderung werden Sie von SpeedEdit informiert und gefragt, ob die geänderte Datei neu geladen werden soll. Aktivieren Sie das Kontrollkästchen Extern geänderte Dateien automatisch neu laden, wenn SpeedEdit extern geänderte Dateien, die vom Editor geladen (jedoch noch nicht geändert) wurden, automatisch aktualisiert.

Speichern

Aktivieren Sie das Kontrollkästchen Sicherungsdatei automatisch erstellen, wenn SpeedEdit beim Speichern einer Datei eine Sicherungsdatei (.bak) erstellen soll.

Editor

Hier legen Sie fest, wie einzelne Textdokumente angezeigt werden sollen.

Gliederungsansicht

Das Kontrollkästchen Gliederung für Kommentare legt fest, dass die automatische Gliederung für Kommentare aktiviert werden soll. Die Einstellung Gliederung für Präprozessor aktiviert die automatische Gliederung für Präprozessor-Anweisungen. Kompakte Anzeige legt fest, dass die automatische Gliederung nachfolgende Leerzeilen mit einschließen soll.

Tabulatoren

Aktivieren Sie das Auswahlfeld Tabulatoren einfügen, wenn beim Drücken der Tabulatortaste ein Tabulatorzeichen eingefügt werden soll. Das Auswahlfeld Leerzeichen einfügen legt fest, dass beim Drücken der Tabulatortaste dagegen eine bestimmte Anzahl von Leerzeichen eingefügt werden soll. Die Anzahl der Leerzeichen wird im Eingabefeld Tab-Länge festgelegt.

Automatischer Einzug

In diesem Bereich wird festgelegt, ob beim Drücken von Enter die nächste Zeile automatisch eingezogen werden soll. Einzug wie vorherige Zeile legt fest, dass die neue Zeile den gleichen Einzug haben soll wie die aktuelle. Mit Einzug bei Klammern wird festgelegt, die neue Zeile automatisch so eingezogen werden soll wie die vorherige Zeile und dass bei Klammern ein zusätzlicher Einzug erfolgen soll. Wählen Sie Kein automatischer Einzug, um diese Funktion zu deaktivieren.

Einzug

Aktivieren Sie das Kontrollkästchen Einzug erstellen mit 'Tab', wenn beim Drücken der Tabulatortaste ein Einzug erstellt werden soll, ohne dabei ein Tabulatorzeichen in den Text einzufügen. Einzug entfernen mit 'Rück' legt fest, dass beim Drücken der Rücktaste ein Einzug entfernt werden soll.

Erweitert

Aktivieren Sie das Kontrollkästchen Markierung für Zeilenendebegrenzung bei Spalte XX anzeigen, wenn an einer bestimmten Spaltenposition eine Begrenzungslinie angezeigt werden soll. Die Einstellung Unterstrich als Wort-Trennzeichen behandeln legt fest, ob der Unterstrich beim Navigieren zwischen einzelnen Wörtern als Trennzeichen behandelt werden soll.

Drucken

Hier können Sie verschiedene Einstellungen für den Ausdruck festlegen.

Kopf- und Fußzeile

Geben Sie eim Eingabefeld Kopfzeile den Text ein, der am Anfang jeder Seite ausgedruckt werden soll. Der Text im Eingabefeld Fußzeile legt den Text fest, der am Ende jeder Seite ausgedruckt werden soll. Klicken Sie auf den Pfeil neben dem Eingabefeld, um die zur Verfügung stehenden Platzhalter anzuzeigen. Deaktivieren Sie die Kontrollkästchen, wenn Sie keine besondere Kopf- oder Fußzeile ausdrucken möchten.

Druckmodus

Aktivieren Sie das Auswahlfeld Wie auf dem Bildschirm, wenn der Ausdruck wie die Bildschirmanzeige erfolgen soll. Helle Farben invertieren legt fest, dass bei Verwendung einer sehr dunklen Hintergrundfarbe helle Farben invertiert ausgedruckt werden sollen. Mit der Auswahl von Schwarzer Text auf weißem Hintergrund erfolgt der gesamte Ausdruck mit schwarzer Farbe, während bei Farbiger Text auf weißem Hintergrund die jeweilige Textfarbe verwendet wird. Wählen Sie Farbiger Text auf weißem Hintergrund mit Ausnahme der Zeilennummern, der gesamte Ausdruck mit der jeweiligen Textfarbe auf weißem Hintergrund erfolgen soll und die Zeilennummern so ausgedruckt werden sollen, wie sie auf dem Bildschirm dargestellt werden.

Syntaxhervorhebung

Hier können Sie die Syntaxhervorhebung für die verschiedenen Sprachen anpassen.

Das Kombinationsfeld Sprache legt die Sprache fest, für welche die Syntaxhervorhebung geändert werden soll. Geben Sie im Eingabefeld Erweiterungen die Dateierweiterungen ein, für welche die Syntaxhervorhebung angewendet werden soll.

Im Auswahlfeld Stile werden die verschiedenen Stile angezeigt, die von der gewählten Sprache angeboten werden. Wählen Sie den entsprechenden Stil aus und ändern Sie die Farben nach Ihren Vorstellungen. Aktivieren Sie die Kontrollkästchen Fett, Unterstrichen und Kursiv, wenn der Text mit diesen Attributen angezeigt werden soll. Aktivieren Sie das Kontrollkästchen Aufgefüllt, wenn die Hintergrundfarbe bis zum Zeilenende aufgefüllt werden soll.

Automatisches Ersetzen

Hier legen Sie fest, welche Begriffe bei der Eingabe durch andere ersetzt werden sollen. Geben Sie im Eingabefeld Kürzel den Begriff ein, den SpeedEdit bei der Eingabe ersetzen soll. Im Eingabefeld Text tragen Sie den Text, der anstelle des Begriffs eingefügt werden soll. Klicken Sie auf Hinzufügen, um eine neue Zuordnung zu erstellen oder auf Löschen, um eine Zuordnung zu entfernen.


SpeedView
Überblick

SpeedView ist ein Programm zur Anzeige von Dateien. Es kann direkt aus SpeedCommander heraus aufgerufen werden, Sie können SpeedView aber auch separat starten.

SpeedView zeigt folgende Dokumente an:

  • Textdateien
  • Grafikdateien
  • Archive
  • Multimedia-Dateien
  • Programmdateien
  • Delphi-Formulare
  • Schriftdateien
  • PDF-Dateien
  • Metadateien

SpeedView nutzt auch die mit Windows Vista eingeführten Module für die Windows-Vorschau.

Weitere Themen

Dateien anzeigen

Dateibetrachter umschalten

Dateibetrachter konfigurieren


Dateien anzeigen

SpeedView
Dateien anzeigen

Sie können in SpeedView eine oder mehrere Dateien anzeigen.

Aktivieren Sie im Menü Ansicht den Befehl Dokumentenkartei, um für jedes geöffnete Dokument eine Registerkarte anzuzeigen. Der Befehl MDI-Fenster maximieren legt fest, dass alle Dokumente innerhalb von SpeedView maximiert angezeigt werden. Deaktivieren Sie diese Einstellung, wenn Sie Dokumente zum besseren Vergleich nebeneinander anzeigen möchten.

Aktivieren Sie den Befehl Mit Escape beenden, wenn das Programmfenster von SpeedView nach dem Drücken von Escape geschlossen werden soll.

So zeigen Sie eine Datei an:
  1. Starten Sie das Programm SpeedView.
  2. Wählen Sie im Menü Datei den Befehl Öffnen.
  3. Wählen Sie im Dateiauswahldialog die Datei(en) aus, die Sie anzeigen möchten.


Dateibetrachter umschalten

SpeedView
Dateibetrachter umschalten

In einigen Fällen kann es vorkommen, dass Sie eine Datei mit einem anderen Betrachter anzeigen möchten. Dies ist z.B. nötig, wenn Sie den binären Aufbau einer Datei analysieren möchten.

So schalten Sie den Dateibetrachter um:
  1. Wählen Sie die Datei aus, die Sie betrachten möchten.
  2. Klicken Sie in der Symbolleiste über der angezeigten Datei auf das Symbol Betrachter ändern .
  3. Wählen Sie aus dem darauf erscheinenden Menü den Betrachter aus, mit dem Sie die Datei anzeigen möchten.


FileSync
Überblick

FileSync ist ein Synchronisationsprogramm, mit dem sich der Inhalt zweier Ordner schnell abgleichen lässt. FileSync bietet Ihnen folgende Möglichkeiten:

  • Inhaltsvergleich zweier Ordner in drei verschiedene Richtungen
  • Einbeziehen von Unterordnern
  • Ein- und Ausschließen von bestimmten Dateien
  • Löschen verwaister Dateien und Ordner
  • Übernahme von Sicherheitsattributen (NTFS)
  • Speichern von Synchronisationseinstellungen in einem Profil

Weitere Themen

Vergleichen und Synchronisieren

Synchronisationsprofile verwenden


Vergleichen und Synchronisieren

FileSync
Vergleichen und Synchronisieren

Das Abgleichen von Ordnern geschieht in drei Schritten:

  1. Festlegen der Einstellungen
  2. Vergleichen
  3. Synchronisieren

Sofern nach einem Vergleich ein Vergleichskriterium geändert wird, ist vor dem Synchronisieren ein neuer Vergleich notwendig.

Festlegen der Einstellungen

FileSync synchronisiert immer zwei Ordner miteinander. Die Ordner werden mit den Befehlen Linken Ordner auswählen und Rechten Ordner auswählen aus dem Menü Extras festgelegt. Für die Synchronisierung gibt es drei verschiedene Methoden, die ebenfalls im Menü Extras aktiviert werden:

Methode | Beschreibung | Wann anwenden?
Synchronisation von links nach rechts | Der rechte Ordner wird auf den Stand des linken Ordners gebracht | Bei Änderungen im linken Ordner
Synchronisation von rechts nach links | Der linke Ordner wird auf den Stand des rechten Ordners gebracht | Bei Änderungen im rechten Ordner
Synchronisation in beide Richtungen | Der Abgleich erfolgt in beide Richtungen | Bei Änderungen im linken und rechten Ordner

Mit Hilfe des Dialogfelds Profileinstellungen werden weitere Einstellungen festgelegt:

Einstellung | Beschreibung
Zeitstempel beachten | Beim Vergleich wird der Zeitstempel der Dateien beachtet. Diese Einstellung kann nicht deaktiviert werden.
Dateigröße beachten | Beim Vergleich wird die Dateigröße beachtet.
Dateiinhalt beachten | Beim Vergleich wird der Dateiinhalt beachtet.
Unterordner einbeziehen | FileSync vergleicht auch alle Unterordner von Quell- und Zielordner.
Auf gerade Sekunden aufrunden | Vor dem Vergleich wird der Zeitstempel aller Dateien auf gerade Sekunden aufgerundet. Dies ist wichtig, wenn zwischen FAT/FAT32 und NTFS synchronisiert wird. Der Zeitstempel bei FAT/FAT32 kann nur gerade Sekunden speichern, während NTFS auch ungerade Sekunden speichert.
Zeitdifferenz von 1h ignorieren | Legt fest, dass beim Vergleichen Zeitdifferenzen von genau einer Stunde ignoriert werden sollen (Sommer-/Winterzeit).
Sicherheitsattribute für Dateien | Die Zieldatei erhält nach dem Synchronisieren die Sicherheitsattribute der Quelldatei (nur NTFS).
Sicherheitsattribute für Ordner | Der Zielordner erhält nach dem Synchronisieren die Sicherheitsattribute des Quellordners (nur NTFS).
Verwaiste Dateien löschen | Im Normalfall wird von Quellordner nach Zielordner synchronisiert, d.h. im Zielordner werden gegebenenfalls Dateien ersetzt. Aktivieren Sie diese Option, wenn Sie zusätzlich alle Dateien im Zielordner löschen möchten, die im Quellordner nicht vorhanden sind. Diese Einstellung wird automatisch deaktiviert, wenn in beide Richtungen synchronisiert wird.
Verwaiste Ordner löschen | Im Normalfall wird von Quellordner nach Zielordner synchronisiert, d.h. im Zielordner werden gegebenenfalls Dateien ersetzt. Aktivieren Sie diese Option, wenn Sie zusätzlich alle leeren Ordner im Zielordner löschen möchten, die im Quellordner nicht vorhanden sind. Diese Einstellung wird automatisch deaktiviert, wenn in beide Richtungen synchronisiert wird oder wenn das Kontrollkästchen 'Verwaiste Dateien löschen' deaktiviert ist.

Mit Hilfe des Kombinationsfeldes Dateimaske wird festgelegt, welche Dateien in den Vergleich eingeschlossen werden bzw. welche Dateien FileSync ignorieren soll. Das Kombinationsfeld befindet sich zwischen Quell- und Zielordner. Einzelne Dateimasken werden durch ein Semikolon voneinander getrennt, die Trennung zwischen Ein- und Ausschließen-Maske erfolgt durch einen Bindestrich (z.B. ' *.*-*.tmp;*.~tm').

Vergleichen

Nachdem alle Einstellungen vorgenommen wurden, kann der Vergleich mit dem Befehl Vergleichen aus dem Menü Datei gestartet werden. FileSync vergleicht nun anhand der oben vorgenommen Einstellungen die beiden Ordner und stellt anschließend alle Dateien in einer Übersicht dar. Das Symbol zwischen der linken und rechten Datei zeigt die vorgeschlagene Aktion:

Darstellung | Bedeutung | Aktion
== Beide Dateien sind entsprechend der gewählten Vergleichskriterien identisch Keine Aktion notwendig
=> Die linke Datei ist neuer als die rechte Datei Die Datei wird von links nach rechts kopiert
<= Die rechte Datei ist neuer als die linke Datei Die Datei wird von rechts nach links kopiert
-- Die Datei im Zielordner ist aktueller als die Datei aus dem Quellordner Keine Aktion notwendig
?? Beide Dateien besitzen zwar den gleichen Zeitstempel, unterscheiden sich aber in der Größe oder im Inhalt Die Aktion muss vom Anwender festgelegt werden
XX | Die Datei wurde bereits im Quellordner gelöscht, existiert aber noch im Zielordner | Die Datei im Zielordner wird gelöscht

Mit Hilfe der Befehle Von links nach rechts kopieren, Von rechts nach links kopieren und Links und rechts unverändert lassen aus dem Menü Bearbeiten können Sie die von FileSync vorgeschlagene Aktion ändern. Der Befehl Auf ursprüngliche Aktion zurücksetzen setzt die Änderungen wieder auf die von FileSync vorgeschlagene Standardaktion zurück. Eine geänderte Aktion wird durch ein kleines Sternchen links in der Listenansicht gekennzeichnet.

Die Befehle Linke Datei löschen, Rechte Datei löschen sowie Linke und rechte Datei löschen ermöglichen das Löschen von Dateien vor dem späteren Synchronisieren. Das Löschen erfolgt dabei in den Papierkorb.

Die Dateien können auch über die Befehle Linke Datei betrachten und Rechte Datei betrachten aus dem Menü Datei in einem externen Programm angezeigt werden. Der Befehl Linke und rechte Datei vergleichen öffnet die linke und rechte Datei in einem Vergleichsprogramm. Beide Programme werden im Einstellungsdialog festgelegt.

Synchronisieren

Nach dem Vergleich wird mit dem Befehl Synchronisieren aus dem Menü Datei die Synchronisation gestartet. FileSync kopiert die Dateien in die entsprechenden Ordner und löscht (sofern angegeben) verwaiste Dateien und Ordner. Der Verlauf der Synchronisation wird in der Statuszeile angezeigt.


Synchronisationsprofile verwenden

FileSync
Synchronisationsprofile verwenden

In einem Synchronisationsprofil können Sie Ihre aktuellen Einstellungen speichern, so dass Sie schnell zwischen verschiedenen häufig genutzten Einstellungen umschalten können.

So speichern Sie ein Profil:
  1. Konfigurieren Sie die Einstellungen, die Sie speichern möchten.
  2. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie den Befehl Speichern.
  3. Geben Sie im Dialogfeld Profil speichern einen Namen für das neue Profil ein und klicken Sie auf OK.
So löschen Sie ein gespeichertes Profil:
  1. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie den Befehl Löschen.
  2. Markieren Sie im Dialog Profil löschen das zu löschende Profil und klicken Sie auf OK.
So aktivieren Sie ein Profil:
  1. Öffnen Sie das Menü Datei, zeigen Sie auf Profile und wählen Sie das Profil aus, welches Sie aktivieren möchten.
  2. Sie können auch das Symbol Profile aus der Symbolleiste verwenden oder im Einstellungsdialog Anpassen jedem Profil ein eigenes Tastenkürzel zuordnen.


FileSync Kommandozeile
Überblick

FileSync Kommandozeile (FSC) ist die Kommandozeilenversion von FileSync. Beide Programme dienen dazu, Ordner bzw. Dateien miteinander abzugleichen. Gerade bei den heute üblichen Daten- bzw. Dateimengen kann der Abgleich von Ordnern (z.B. von Laptop und stationärem Rechner) sehr zeitaufwendig sein.

FileSync Kommandozeile kann diese Aufgabe für Sie automatisiert durchführen und Ordner bzw. Dateien nach verschiedenen Kriterien abgleichen. Das Programm unterstützt außerdem einfache Skriptdateien, die mit einem üblichen Texteditor (z.B. dem Windows-Editor oder SpeedEdit) angelegt und bearbeitet werden können. Es sind keinerlei Programmierkenntnisse notwendig, um diese Skriptdateien zu erstellen.

Weitere Themen

Kommandoschalter

Skriptdateien verwenden


Kommandoschalter

FileSync Kommandozeile
Kommandoschalter

FileSync Kommandozeile nutzt eine ganze Reihe von Kommandoschaltern, um den Ablauf von Sicherungsaufgaben zu steuern. Soweit nicht anders angegeben, spielt die Schreibweise (groß/klein) der Kommandoschalter keine Rolle: fsc -r erzeugt das gleiche Ergebnis wie fsc -R.

FileSync Kommandozeile muss wie folgt aufgerufen werden:

fsc.exe -sd Quellordner -td Zielordner [-Schalter...] [Dateien...] [@Scriptdatei]

oder

fsc.exe @Skriptdatei

Mit [Dateien...] werden alle diejenigen Dateien angegeben, die beim Synchronisieren eingeschlossen werden sollen. Erlaubt sind hier neben Dateinamen auch Dateimasken, die Platzhalter enthalten. Platzhalter sind die Zeichen * und ?, wobei * für eine beliebige Anzahl von beliebigen Zeichen und ? für ein beliebiges Zeichen steht.

Die Dateimaske *.doc würde z.B. alle Dateien mit der Dateierweiterung doc finden, wie z.B. Brief.doc oder Beschwerde.doc. Die Dateimaske M?ller.doc würde Dateien wie Müller.doc, Möller.doc oder Miller.doc finden.

Verschiedene Schalter benötigen ein weiteres Argument. Diese Schalter werden wie folgt in der Kommandozeile angegeben

-Schalter Argument

Zwischen dem Schalter und dem Argument befindet sich ein Leerzeichen. In Skriptdateien werden solche Schalter in zwei Zeilen angegeben. Argumente, die Leerzeichen enthalten, müssen in der Kommandozeile als auch in Skriptdateien in Anführungszeichen angegeben werden, z.B.:

fsc.exe -sd C:\Dokumente -td "D:\Gesicherte Dokumente"

Grundsätzlich können die Kommandoschalter untereinander kombiniert werden. Es müssen jedoch immer die Kommandoschalter für den Quellordner (-sd) und für den Zielordner (-td) mit den entsprechenden Argumenten angegeben werden.

FileSync Kommandozeile durchsucht im Normalfall im Quellordner nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen. Danach wird der Zielordner auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

-af
Sicherheitsbeschreibungen der Dateien mitkopieren (nur für NTFS-Laufwerke).

-ad
Sicherheitsbeschreibungen der Ordner mitkopieren (nur für NTFS-Laufwerke).

-am Attribute

Nur Dateien mit bestimmten Attributen in die Dateiliste(n) einschließen. Attribute ist eine Zeichenkette mit den Abkürzungen für die Attribute, die Abkürzungen sind wie folgt:

A | Archivattribut
H | Attribut für versteckte Dateien
R | Schreibschutz-Attribut
S | Attribut für System-Dateien
E | Attribut für vom System verschlüsselte Dateien (nur NTFS)
C | Attribut für vom System komprimierte Dateien (nur NTFS)
fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -am AR

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, bei denen das Archivattribut und das Schreibschutzattribut gesetzt ist.

-as

Nur Dateien mit gesetztem Archivattribut in die Dateiliste(n) einschließen.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -as

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, bei denen das Archivattribut gesetzt ist.

-d

Dieser Schalter legt fest, dass verwaiste Dateien gelöscht werden sollen. Sind z.B. im Zielordner Dateien vorhanden, die nicht im Quellordner enthalten sind, so werden die entsprechenden Dateien im Zielordner gelöscht.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -s -d

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. FileSync durchsucht C:\Dokumente nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen. Danach wird D:\Dokumente auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

Werden keine weiteren Vorgaben für den Vergleich bzw. das Ersetzen der Dateien gemacht, dann ersetzt FileSync in D:\Dokumente alle Dateien, die einen älteren Zeitstempel als die entsprechenden Dateien in C:\Dokumente haben. Mit Angabe des Schalters -d löscht FileSync Kommandozeile aus D:\Dokumente alle, die nicht in C:\Dokumente enthalten sind.

-dd

Leere Ordner löschen. Dieser Schalter wird automatisch deaktiviert, wenn der Schalter -d (Verwaiste Dateien löschen) *nicht* gesetzt ist oder wenn in beide Richtungen synchronisiert wird.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -s -d -dd

-fb Dateigröße

Nur Dateien größer als Dateigröße in die Dateiliste(n) einschließen.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -fb 100000

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die größer als 100000 Bytes sind.

-fs Dateigröße

Nur Dateien kleiner als Dateigröße in die Dateiliste(n) einschließen.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -fs 100000

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die kleiner als 100000 Bytes sind.

-it

Sekundenanteil der Dateizeitstempel auf gerade Sekunden abrunden. Verschiedene Dateisysteme wie z.B. FAT und FAT32 haben eine maximale Auflösung von zwei Sekunden, Dateisysteme wie z.B. NTFS (Windows XP und höher) haben eine wesentlich höhere Auflösung. Werden nur Dateizeitstempel von Dateien auf gleichen Dateisystemen verglichen (z.B. FAT32 <-> FAT32, oder NTFS <->NTFS), so ist der Vergleich der Zeitstempel immer eindeutig.

Werden aber Dateizeitstempel von Dateien auf verschiedenen Dateisystemen (z.B. FAT32 <-> NTFS) verglichen, so könnte ein Vergleich im schlechtesten Fall fehlschlagen. Der Schalter -it sorgt im Prinzip für gleiche Auflösungen unter den verschiedenen Dateisystemen.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -it

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. Vor dem Vergleichen der Dateilisten bzw. Ersetzen der Dateien werden die Sekundenanteile der Zeitstempel auf gerade Sekunden abgerundet.

-ih

Zeitdifferenzen von exakt einer Stunde ignorieren. Durch die Zeitverschiebung zwischen Sommerzeit und Winterzeit entstehen unter Umständen Zeitunterschiede von genau einer Stunde.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -it -ih

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. Vor dem Vergleichen der Dateilisten bzw. Ersetzen der Dateien werden die Sekundenanteile der Zeitstempel auf gerade Sekunden abgerundet. Dateien, die genau eine Stunde jünger oder älter sind, werden als gleich betrachtet.

-log[n]

Automatisches Protokoll aktivieren bzw. deaktivieren. Der Wert n wird direkt an den Schalter -log angefügt. Möglich sind

-log0 | Automatisches Protokoll deaktivieren.
-log1 | Automatisches Protokoll aktivieren. Es werden nur jeweils die Uhrzeit und der Statuscode für jede Aktion protokolliert.
-log2 | Automatisches Protokoll aktivieren. Es werden jeweils die komplette Kommandozeile mit allen Parametern sowie die Uhrzeit und der Statuscode für jede Aktion protokolliert.
-log3 | Automatisches Protokoll aktivieren. Es werden jeweils die komplette Kommandozeile mit allen Parametern sowie die Uhrzeit und der Statuscode für jede Aktion protokolliert. Außerdem werden für jede Aktion alle Dateien mitprotokolliert, die kopiert oder gelöscht wurden.

Sämtliche Meldungen, Statuscodes usw. werden per Voreinstellung in die Datei fsc_log.txt geschrieben, die sich im gleichen Ordner wie fsc.exe befindet.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -log3

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. In die Protokolldatei werden sämtliche Meldungen, Statuscodes sowie die Namen aller kopierten bzw. gelöschten Dateien geschrieben.

-loge Dateiname

Dateiname ist der Name der Datei, in die alle Meldungen, Statuscodes usw. geschrieben werden sollen.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -log3 -loge D:\Protokoll.txt

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. In die Protokolldatei D:\Protokoll.txt werden sämtliche Meldungen, Statuscodes sowie die Namen aller kopierten bzw. gelöschten Dateien geschrieben.

-q

Alle Bildschirmausgaben unterdrücken.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -q

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. Es werden aber nicht die normalerweise üblichen Statusmeldungen am Bildschirm ausgegeben.

-r

Dateien aus Unterordnern in die Dateiliste einschließen.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -r

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente sowie deren Unterordner einbezogen. Würde der Schalter -r weggelassen werden, so würden alle Dateien aus C:\Dokumente einbezogen werden, nicht aber die Dateien aus C:\Dokumente\Briefe.

-s

Dieser Schalter wird automatisch von FileSync gesetzt und legt fest, dass die Dateien aus dem Quellordner in den Zielordner kopiert werden bzw. im Zielordner gelöscht werden.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -s

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. FileSync durchsucht C:\Dokumente nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen. Danach wird D:\Dokumente auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

Werden keine weiteren Vorgaben für den Vergleich bzw. das Ersetzen der Dateien gemacht, dann ersetzt FileSync in D:\Dokumente alle Dateien, die einen älteren Zeitstempel als die entsprechenden Dateien in C:\Dokumente haben. Wird noch der Schalter -d angegeben, dann löscht FileSync aus D:\Dokumente alle Dateien, die nicht in C:\Dokumente enthalten sind.

-sb

Dieser Schalter legt fest, dass zuerst die entsprechenden Dateien aus dem Quellordner in den Zielordner kopiert werden, danach werden die entsprechenden Dateien aus dem Zielordner in den Quellordner kopiert. Es werden also beide Ordner auf einmal miteinander synchronisiert.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -sb

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. FileSync durchsucht C:\Dokumente nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen. Danach wird D:\Dokumente auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

Werden keine weiteren Vorgaben für den Vergleich bzw. das Ersetzen der Dateien gemacht, dann ersetzt FileSync in D:\Dokumente alle Dateien, die einen älteren Zeitstempel als die entsprechenden Dateien in C:\Dokumente haben. Danach werden in C:\Dokumente alle Dateien ersetzt, die einen älteren Zeitstempel als die entsprechenden Dateien in D:\Dokumente haben.

Der Schalter -d wird ignoriert, wenn der Schalter -sb angegeben wurde.

-sd Quellordner

Dieser Schalter legt den Quellordner fest.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.*

Der Ordner C:\Dokumente wird als Quellordner festgelegt.

-st

Dieser Schalter kehrt die Zielrichtung des Vergleichs um und legt fest, dass die Dateien aus dem Zielordner in den Quellordner kopiert werden bzw. im Quellordner gelöscht werden.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -st

Es werden im Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen. FileSync durchsucht C:\Dokumente nach Dateien, die auf die in der Kommandozeile angegebene Dateiliste passen. Danach wird D:\Dokumente auf die gleiche Art durchsucht und die Dateien werden entsprechend der Vorgaben miteinander verglichen und ersetzt.

Werden keine weiteren Vorgaben für den Vergleich bzw. das Ersetzen der Dateien gemacht, dann ersetzt FileSync in C:\Dokumente alle Dateien, die einen älteren Zeitstempel als die entsprechenden Dateien in D:\Dokumente haben. Wird zusätzlich noch der Schalter -d angegeben, dann löscht FileSync aus C:\Dokumente alle Dateien, die nicht in D:\Dokumente enthalten sind.

-ta DatumZeit

Nur Dateien jünger als DatumZeit in die Dateiliste(n) einschließen. Die Angabe von DatumZeit muss immer in der Form yyyymmddhhmmss erfolgen. Die einzelnen Formatzeichen haben folgende Bedeutungen:

yyyy | Jahr, vierstellig
mm | Monat (1 - 12)
dd | Tag im Monat (1 - 31)
hh | Stunde
mm | Minute
ss | Sekunde

Formatzeichen am Ende der Formatangabe können ausgelassen werden.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -ta 201010

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die nach dem 1.10.2010 erzeugt oder geändert wurden.

Hinweis: Der besseren Übersichtlichkeit halber kann die Formatangabe auch in der Form yyyy-mm-ddhh-mm-ss oder in der Form yyyy:mm:dd:hh:mm:ss erfolgen.

-tb DatumZeit

Nur Dateien älter als DatumZeit in die Dateiliste(n) einschließen. Die Angabe von DatumZeit muss immer in der der Form yyyymmddhhmmss erfolgen. Die einzelnen Formatzeichen haben folgende Bedeutungen:

yyyy | Jahr, vierstellig
mm | Monat (1 - 12)
dd | Tag im Monat (1 - 31)
hh | Stunde
mm | Minute
ss | Sekunde

Formatzeichen am Ende der Formatangabe können ausgelassen werden.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -tb 201010

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, die vor dem 1.10.2010 erzeugt oder geändert wurden.

Hinweis: Der besseren Übersichtlichkeit halber kann die Formatangabe auch in der Form yyyy-mm-dd hh-mm-ss oder in der Form yyyy:mm:dd:hh:mm:ss erfolgen.

-td Zielordner

Dieser Schalter legt den Zielordner fest.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.*

Der Ordner D:\Dokumente wird als Zielordner festgelegt.

-x Dateimaske

Dateien, die Dateimaske entsprechen, nicht in die Dateiliste(n) einschließen.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -x *.bak

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente *außer* BAK-Dateien einbezogen.

Dieser Schalter kann mehrfach in der Kommandozeile oder in Skriptdateien angegeben werden.

-xd Ordnername

Ordner, die Ordnername entsprechen, nicht in die Dateiliste(n) einschließen.

Mit dem Schalter -xd Ordnername können Ordner beim Synchronisieren ausgeschlossen werden. Ordnername kann Wildcards enthalten. Genauso wie der Schalter -x muss -xd einmal für jeden Ordner angegeben werden.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -xd *\System* -xd *\Temp

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente *außer* Dateien in den Ordnern Temp und System einbezogen.

Dieser Schalter kann mehrfach in der Kommandozeile oder in Skriptdateien angegeben werden.

-y

Bei Nachfragen automatisch immer mit Ja antworten.

fsc.exe -sd C:\Dokumente -td D:\Dokumente *.* -y

Es werden in den Vergleich alle Dateien aus den Ordnern C:\Dokumente und D:\Dokumente einbezogen, alle eventuellen Nachfragen werden automatisch mit Ja beantwortet.


Skriptdateien verwenden

FileSync Kommandozeile
Skriptdateien verwenden

FileSync Kommandozeile unterstützt einfache Skriptdateien, die mit einem üblichen Texteditor (z.B. dem Windows-Editor oder SpeedEdit) angelegt und bearbeitet werden können. Es sind keinerlei Programmierkenntnisse notwendig, um diese Skriptdateien zu erstellen.

Jede Zeile in einer Skriptdatei darf ein Kommando, einen Kommandoschalter oder ein Argument enthalten. Um das Skript abzuarbeiten, muss FileSync Kommandozeile wie folgt aufgerufen werden:

 fsc.exe @Skriptdatei

Skriptdatei ist der vollständige Dateiname der Datei, in der Sie das Skript gespeichert haben. Ist der Name z.B. D:\Sicherung.job, dann würde der korrekte Aufruf so lauten:

fsc.exe @D:\Sicherung.job

Bitte beachten Sie das führende @-Zeichen vor dem Namen der Skriptdatei. Dieses Zeichen muss beim Aufruf dem eigentlichen Dateinamen direkt vorangestellt werden, damit FileSync Kommandozeile erkennen kann, dass diese Datei als Skript abgearbeitet werden soll.

Skriptdateien dürfen auch Kommentare enthalten. Die Zeichenfolge // wird als Einleitung eines Kommentars interpretiert. So können komplexe Skriptdateien auch dokumentiert werden.

Beispiel für eine einfache Skriptdatei:
-sd           // Quellordner
C:\Dokumente  // Argument für Quellordner
-td           // Zielordner festlegen
D:\Dokumente  // Argument für Zielordner
*.doc         // DOC-Dateien in den Vergleich einbeziehen
*.xls         // XLS-Dateien in den Vergleich einbeziehen


Squeez Kommandozeile
Squeez Kommandozeile

Squeez Kommandozeile (SQC) ist ein Kommandozeilenprogramm für die Arbeit mit Archiven. Genauso wie SpeedCommander unterstützt SQC mehr als 10 verschiedene Archivformate, ohne dass weitere Programme benötigt werden. Einer der wesentlichen Vorteile von SQC gegenüber den Kommandozeilenmodulen vieler anderer Archivprogramme ist die Unterstützung für mehrere verschiedene Archivformate mit einem einzigen Satz von Kommandos, Kommandoschaltern und Skriptdateien.

Vorteile von Squeez Kommandozeile

SQC bietet immer dann Vorteile, wenn regelmäßig komplexe Sicherungsaufgaben abgearbeitet werden sollen. Zwar bietet auch SpeedCommander alle Funktionen, um entsprechende Aufgaben effizient abzuarbeiten, allerdings ist hier immer die Interaktion des Anwenders notwendig. Dateien müssen ausgewählt und verschiedene Einstellungen vorgenommen werden.

Squeez Kommandozeile werden einfach verschiedene Argumente oder eine Skriptdatei übergeben, danach wird die Sicherungsaufgabe automatisch und selbständig abgearbeitet. SQC könnte z.B. auch zeitgesteuert aufgerufen werden, so kann ein sehr hoher Automatisierungsgrad erreicht werden.

Weitere Informationen

Kommandos

Kommandoschalter

Zusätzliche Kommandoschalter (SQX, ZIP und 7z)

Zusätzliche Kommandoschalter (SFX)

Skriptdateien verwenden

Fehlerrückgabecodes

Erweiterte Konfiguration

Beispiele für Datensicherungen


Kommandos

Squeez Kommandozeile
Kommandos

SQC nutzt eine ganze Reihe von Kommandos, um den Ablauf von Archivierungsaufgaben zu steuern. Soweit nicht anders angegeben, spielt die Schreibweise (groß/klein) der Kommandos bzw. Kommandoschalter keine Rolle: sqc a erzeugt das gleiche Ergebnis wie sqc A.

Die meisten Kommandos können mit Kommandoschaltern kombiniert werden, so dass eine höchst flexible Steuerung des Arbeitsablaufes möglich ist. Verschiedene Dateien können z.B. vom Komprimieren ausgenommen werden, Dateien können als gesichert markiert werden und die Namen der Backuparchive können automatisch in Abhängigkeit von Zeit und Datum erzeugt werden.

SQC muss wie folgt aufgerufen werden:

sqc <Kommando> [-Schalter...] <Archiv_Name> [Dateien...] [@Skriptdatei]

oder

sqc @Skriptdatei

Wenn <Kommando> nicht angegeben wird, dann nimmt SQC an, dass das Hinzufügen-Kommando (A, ADD) ausgeführt werden soll. Wird das Entpacken-Kommando (E oder X) ohne <Archiv_Name> angegeben, so durchsucht SQC das aktuelle Verzeichnis und filtert aus den gefundenen Dateien alle unterstützten Archive heraus, die dann entpackt werden.

Archiv- oder Dateinamen, die Leerzeichen enthalten müssen in der Kommandozeile und in Skriptdateien in Anführungszeichen angegeben werden, z.B.:

sqc a D:\Daten.sqx "D:\Eigene Dateien\*.*"

Es stehen folgende Kommandos bzw. Befehle zur Auswahl:

A, ADD SQX, ZIP, ARJ, LZH, CAB, RAR, BZIP, GZIP, TAR, ACE, 7z

Dateien zu einem Archiv hinzufügen bzw. neues Archiv erzeugen.

sqc a D:\Backup.zip D:\Daten\*.doc

Es werden zum Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt.
F, FRESHEN SQX, ZIP, ARJ, LZH, CAB, RAR, TAR, ACE, 7z

Nur neuere Dateien zu einem Archiv hinzufügen. SQC vergleicht die Zeitstempel und die Dateinamen der Dateien im Archiv mit den Zeitstempeln und den Dateinamen der Dateien, die in der Dateiliste zum Archivieren angegeben sind. Es werden nur diejenigen Dateien im Archiv aktualisiert, die seit der Erstellung des Archivs verändert wurden.

sqc f D:\Backup.zip D:\Daten\*.doc

Es werden im Archiv D:\Backup.zip alle DOC-Dateien erneuert, die seit der Erstellung des Archivs in D:\Daten geändert wurden.
U, UPDATE SQX, ZIP, ARJ, LZH, CAB, RAR, TAR, ACE, 7z

Dateien im Archiv vervollständigen. SQC vergleicht die Zeitstempel und die Dateinamen der Dateien im Archiv mit den Zeitstempeln und den Dateinamen der Dateien, die in der Dateiliste zum Archivieren angeben sind. Es werden nur diejenigen Dateien im Archiv aktualisiert oder hinzugefügt, die seit der Erstellung des Archivs verändert wurden bzw. die noch nicht im Archiv vorhanden sind.

sqc u D:\Backup.zip D:\Daten\*.doc

Es werden im Archiv D:\Backup.zip alle DOC-Dateien erneuert, die seit der Erstellung des Archivs in D:\Daten geändert wurden. Außerdem werden dem Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt, die sich noch nicht in dem Archiv befinden.
M, MOVE SQX, ZIP, ARJ, LZH, CAB, RAR, BZIP, GZIP, TAR, ACE, 7z

Dateien in ein Archiv verschieben. Das Verschieben von Dateien und Verzeichnissen hat zur Folge, dass nach erfolgreicher Archiverstellung die Quelldateien gelöscht werden.

sqc m D:\Backup.zip D:\Daten\*.doc

Es werden zum Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt und anschließend alle DOC-Dateien aus dem Ordner D:\Daten gelöscht.
E, EXTRACT SQX, ZIP, ARJ, LZH, CAB, RAR, BZIP, GZIP, TAR, ACE, 7z

Dateien aus einem Archiv entpacken. Die Dateien werden ohne Ordnernamen entpackt. Ist der Dateiname einer Datei im Archiv z.B. Daten\Brief1.doc, so wird der Dateiname beim Entpacken zu Brief1.doc umgeformt. Optional kann ein Zielordner zum Entpacken angegeben werden.

Wenn kein Dateiname zum Entpacken angegeben wird, so nimmt SQC implizit *.* als Dateinamen an. Dies bedeutet, dass alle Archive im aktuellen Ordner entpackt werden.

sqc e D:\Daten.zip *.doc D:\Daten

Es werden alle DOC-Dateien des Archivs D:\Daten.zip in den Ordner D:\Daten entpackt.
X, EXTRACTX SQX, ZIP, ARJ, LZH, CAB, RAR, BZIP, GZIP, TAR, ACE, 7z

Dateien aus einem Archiv entpacken. Die Dateien werden mit Ordnernamen entpackt. Optional kann ein Zielordner zum Entpacken angegeben werden.

Wenn kein Dateiname zum Entpacken angegeben wird, so nimmt SQC implizit *.* als Dateinamen an. Dies bedeutet, dass alle Archive des aktuellen Ordners entpackt werden.

sqc x D:\Daten.zip *.doc D:\Daten

Es werden alle DOC-Dateien des Archivs D:\Daten.zip in den Ordner D:\Daten entpackt.
D, DELETE SQX, ZIP, ARJ, LZH, CAB, RAR, TAR, ACE, 7z

Dateien aus einem Archiv löschen.

sqc d D:\Daten.zip *.doc

Es werden alle DOC-Dateien aus dem Archiv D:\Daten.zip gelöscht.
T, TEST SQX, ZIP, ARJ, LZH, RAR, ACE, 7z

Archiv auf Integrität überprüfen. Es wird überprüft, ob sich die im Archiv enthaltenen Dateien fehlerfrei entpacken lassen würden.

Wenn kein Dateiname zum Testen angegeben wird, so nimmt SQC implizit *.* als Dateinamen an. Dies bedeutet, dass alle Archive des aktuellen Ordners auf Integrität geprüft werden.

sqc t D:\Daten.zip

Das Archiv D:\Daten.zip wird auf Integrität geprüft.
L, LIST SQX, ZIP, ARJ, LZH, CAB, RAR, BZIP, GZIP, TAR, ACE, 7z

Archivinhalt anzeigen. Es werden alle im Archiv enthaltenen Dateien mit Namen, Größe und dem Zeitpunkt der letzten Änderung am Bildschirm aufgelistet.

Beispiel: sqc l D:\Daten.zip

Hinweis: Archive, deren Inhaltsverzeichnisse verschlüsselt sind, können nur nach Eingabe des korrekten Kennwortes aufgelistet werden.
R, REPAIR SQX

Defektes Archiv reparieren. Es wird überprüft, ob das angegebene Archiv Reparaturdaten enthält bzw. ob externe Reparaturdaten (nur SQX) für das Archiv vorhanden sind. Diese Reparaturdaten werden dann genutzt, um den Inhalt des ursprünglichen Archivs zu berechnen. Wenn der/die beschädigte(n) Archivbereiche kleiner als die Reparaturdaten selbst sind, dann besteht eine recht große Chance auf eine erfolgreiche Wiederherstellung des Archivs.

Rechenbeispiel: Einem Archiv mit der Größe von 5 MiB wurden 2 Prozent Reparaturdaten hinzugefügt, das Archiv enthält also rund 100 KiB an Reparaturdaten. Sofern weniger als 100 KiB bei diesem Archiv beschädigt werden, kann das Archiv mit einer recht hohen Wahrscheinlichkeit wiederhergestellt werden. Dabei ist es völlig egal, welcher Teil bzw. welche Teile des Archivs beschädigt sind bzw. werden.

sqc r D:\Daten.sqx D:\Restore.sqx
Das Archiv D:\Daten.sqx wird repariert und als D:\Restore.sqx gespeichert.
H, ?, HELP

Es wird ein Hilfe-Bildschirm angezeigt.

sqc h


Kommandoschalter

Squeez Kommandozeile
Kommandoschalter

Kommandoschalter werden in Verbindung mit einem Kommando bzw. einem Befehl eingesetzt und können in den meisten Fällen untereinander kombiniert werden. Verschiedene Schalter benötigen ein weiteres Argument. Diese Schalter werden wie folgt in der Kommandozeile angegeben

-Schalter Argument

Zwischen dem Schalter und dem Argument befindet sich ein Leerzeichen. In der Konfigurationsdatei und in Skriptdateien werden solche Schalter in zwei Zeilen angegeben. Argumente, die Leerzeichen enthalten, müssen in der Kommandozeile und in Skriptdateien in Anführungszeichen angegeben werden, z.B.:

sqc a D:\Daten.sqx D:\Daten\*.* -td "c:\Eigene Dateien\Temp"
-AC Alle Formate

Das Archivattribut wird nach dem Packen bzw. Entpacken gelöscht.

sqc a -ac D:\Backup.zip D:\Daten\*.doc

Es werden dem Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt. Nach dem erfolgreichen Erzeugen des Archivs werden von den entsprechenden DOC-Dateien aus dem Ordner D:\Daten das Archivattribut gelöscht.

Hinweis: Das Bearbeiten der Archivattribute einer Datei ändert diese Datei nicht. Das Betriebssystem verwaltet die Attribute einer Datei, um so verschiedene Eigenschaften oder auch einer Datei festzulegen. Nach jeder Bearbeitung einer Datei setzt das Betriebssystem das Archivattribut dieser Datei um anzuzeigen, dass diese Datei geändert wurde. So können Archivprogramme und Backupprogramme leicht erkennen, dass eine Datei geändert wurde. Wird das Archivattribut nach dem Komprimieren gelöscht, so wird dem Betriebssystem oder auch anderen Programmen angezeigt, dass bereits eine Sicherungskopie dieser Datei erzeugt wurde.

Sie können diesen Schalter mit den Kommandos A, F, U, M, E und X verwenden.
-AD Alle Formate

Jedes Archiv wird in einen separaten Ordner entpackt. Werden z.B. mehrere Archive auf einmal entpackt, dann kann es sinnvoll sein, jedes Archiv der Übersichtlichkeit halber in einen Extra-Ordner zu entpacken.

sqc x -ad *.sqx D:\Entpacken

Alle SQX-Archive des aktuellen Ordners werden in jeweils separate Unterordner in D:\Entpacken ausgepackt. Der Name der Unterordner entspricht dabei den Namen der jeweiligen Archive.

Sie können diesen Schalter mit den Kommandos E und X verwenden.
-AM Attribute Alle Formate

Nur Dateien mit bestimmten Attributen in die Dateiliste(n) einschließen. Attribute ist eine Zeichenkette mit den Abkürzungen für die Attribute, die Abkürzungen sind wie folgt:

A | Archivattribut
H | Attribut für versteckte Dateien
R | Schreibschutz-Attribut
S | Attribut für System-Dateien
sqc a -am AR D:\Daten.sqx D:\Daten\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt, die das Archivattribut und das Schreibschutzattribut gesetzt haben.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, E und X verwenden.
-AS Alle Formate

Nur Dateien mit gesetztem Archivattribut in die Dateiliste(n) einschließen.

sqc a -as D:\Daten.sqx D:\Daten\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt, die das Archivattribut gesetzt haben.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, E und X verwenden.
-BC Alle Formate

Setzt den aktuellen Ordner als Basisordner. Siehe auch -bp.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-BP Basisordner Alle Formate

Basisordner festlegen. Bisweilen ist es notwendig oder sinnvoll, nicht die gesamten Ordnerinformationen einer Datei mitzuarchivieren.

sqc a -bp D:\Daten D:\Daten.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt. Die Dateinamen werden so umgeformt, dass der führende Ordnerteil "Basisordner" aus den Dateinamen entfernt wird. Aus D:\Daten\Briefe\Brief1.doc würde im Archiv Briefe\Brief1.doc werden.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-DN Alle Formate

Das Erstellungsdatum des Archivs auf das Erstellungsdatum der jüngsten Datei im Archiv setzen.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-DO Alle Formate

Das Erstellungsdatum des Archivs auf das Erstellungsdatum der ältesten Datei im Archiv setzen.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-DT Maske Alle Formate

Es wird der Archivname aus Dateiname und dem aktuellen Datum und oder der aktuellen Zeit gebildet. Das Format für das Datum bzw. die Zeit wird im Argument Maske festgelegt.

Die Formatbeschreibung kann folgende Datums- bzw. Zeitangaben enthalten:

YYYY | Jahr, vierstellig
YY | Jahr, zweistellig
MMMM | Voller Monatsname, wie z.B. Januar, Februar usw.
MMM | Abgekürzter Monatsname, wie z.B. Jan, Feb usw.
MM | Monat. Monate kleiner als 10 werden mit führender 0 eingefügt
M | Monat. Monate kleiner als 10 werden ohne führende 0 eingefügt
DDDD | Voller Wochentag, wie z.B. Montag, Dienstag usw.
DDD | Abgekürzter Wochentag, wie z.B. Mon, Di usw.
DD | Tag des Monats. Tage kleiner als 10 werden mit führender 0 eingefügt
D | Tag des Monats. Tage kleiner als 10 werden ohne führende 0 eingefügt
hh | Stunde. Stunden kleiner als 10 werden mit führender 0 eingefügt
h | Stunde. Stunden kleiner als 10 werden ohne führende 0 eingefügt
mm | Minute. Minuten kleiner als 10 werden mit führender 0 eingefügt
m | Minute. Minuten kleiner als 10 werden ohne führende 0 eingefügt
ss | Sekunde. Sekunden kleiner als 10 werden mit führender 0 eingefügt
s | Sekunde. Sekunden kleiner als 10 werden ohne führende 0 eingefügt
oo | Tag des Jahres, wie z.B. 1, 2, 3 usw. Tage kleiner 10 werden mit zwei führenden Nullen erweitert, Tage kleiner als 100 werden mit einer führenden Null erweitert
O | Tag des Jahres, wie z.B. 1, 2, 3 usw.
SS | vordefinierte Maske: yyyy-MM-dd-hh-mm-ss
S | vordefinierte Maske: yyyyMMddhhmmss
U | vordefinierte Maske: MM-dd-yyyy
E | vordefinierte Maske: dd-MM-yyyy

Bitte beachten Sie unbedingt die Schreibweise in der Formatbeschreibung, SS hat eine andere Bedeutung als ss. Die Formatbeschreibung kann neben den oben aufgeführten Zeichen auch weitere Zeichen enthalten. Diese werden dann unverändert in den Archivnamen übernommen. Ist das erste Zeichen in der Formatbeschreibung ein Bindestrich bzw. Minuszeichen (-), so wird die Datums-Zeitangabe vor dem Dateinamen eingefügt, ansonsten wird die Datums-Zeitangabe dem Dateinamen angehängt.

Beispiele: (Das aktuelle Datum ist 03.05.2012, die Uhrzeit ist 15:27:30)

sqc a D:\Backup_.sqx D:\Daten\*.doc -dt E

Es werden dem Archiv alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt. Der endgültige Name des Archivs wäre entsprechend des oben genannten Datums D:\Backup_03-05-2012.sqx

sqc a D:\Backup_.sqx D:\Daten\*.doc -dt SS

Es werden dem Archiv alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt. Der endgültige Name des Archivs wäre entsprechend des oben genannten Datums D:\Backup_2012-05-03-15-27-30.sqx

sqc a D:\_Backup.sqx D:\Daten\*.doc -dt -dd-MM-yyyy

Es werden dem Archiv alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt. Der endgültige Name des Archivs wäre dann entsprechend des oben genannten Datums D:\03-05-2012_Backup.sqx

Sie können diesen Schalter mit den Kommando A verwenden.

Hinweis: Dieser Schalter eignet sich besonders zur Erstellung von automatisch ablaufenden Sicherungsaufgaben. Mit diesem Schalter kann sichergestellt werden, dass jedes Archiv automatisch einen eigenen Dateinamen bekommt.
-EP Alle Formate

Ordnerinformation aus Dateinamen entfernen

 sqc a -ep D:\Daten.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt. Die Dateinamen werden so umgeformt, dass der führende Ordnerteil D:\Daten\Briefe aus den Dateinamen entfernt wird. Aus D:\Daten\Briefe\Brief1.doc würde im Archiv Brief1.doc werden.

Sie können diesen Schalter mit den Kommandos A, F, U, M und X verwenden.
-FB Dateigröße Alle Formate

Nur Dateien größer als Dateigröße in die Dateiliste(n) einschließen.

sqc a -fb 100000 D:\Daten.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt, die größer als 100000 Bytes sind.

sqc x -fb 100000 D:\Daten.sqx *.doc

Es werden aus dem Archiv D:\Daten.sqx alle DOC-Dateien entpackt, die größer als 100000 Bytes sind.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, L, E und X verwenden.
-FMT Archivformat

Legt das Archivformat fest. Wurde kein Archivformat festgelegt, so wird automatisch das SQX2-Format verwendet bzw. angenommen. Archivformat kann folgende Werte annehmen:

SQX1 | SQX 1.1-Format
SQX2 oder SQX | SQX 2.0-Format
ZIP | ZIP 2.0-Format
ZIP4 | ZIP 4.5-Format
ZIP6 | ZIP 4.6-Format
CABZIP | CAB MS-ZIP-Format
CABLZX oder CAB | CAB MS-LZX-Format
RAR | RAR 2.x-Format
RAR15 | RAR 1.5-Format
ACE | ACE 1.x-Format
ARJ | ARJ-Format
LHA | LHA 2.0-Format
LHA6 | LHA 2.6-Format
LHA7 | LHA 2.7-Format
GZIP | GZIP-Format
BZIP | BZIP-Format
TAR | TAR-Format
TGZ | TAR-Format mit GZIP komprimiert
TBZ | TAR-Format mit BZIP komprimiert
UUE | UUE-Format
JAR | JAR-Format
7Z | 7z-Format
sqc a D:\Daten D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt.

sqc a -fmt zip D:\Daten D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.zip alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, L, E und X verwenden.

Hinweis: Sie können in der Konfigurationsdatei oder in der Umgebungsvariable ein Vorgabeformat festlegen. Wenn der Archivname ohne Dateierweiterung angegeben wird, so hängt SQC automatisch entsprechend des gewählten oder voreingestellten Archivformats die richtige Erweiterung an. Ist als Archivformat z.B. SQX eingestellt, so wird aus D:\Daten automatisch D:\Daten.sqx
-FS Dateigröße Alle Formate

Nur Dateien kleiner als Dateigröße in die Dateiliste(n) einschließen.

sqc a -fs 100000 D:\Daten.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt, die kleiner als 100000 Bytes sind.

sqc x -fs 100000 D:\Daten.sqx *.doc

Es werden aus dem Archiv D:\Daten.sqx alle DOC-Dateien entpackt, die kleiner als 100000 Bytes sind.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, L, E und X verwenden.
-K SQX, ZIP, RAR, ARJ, LHA, 7z

Beschädigte Dateien beim Entpacken nicht löschen. Normalerweise werden Dateien, die mit einem CRC-Fehler entpackt werden, automatisch gelöscht.
-LOG[n] Alle Formate

Automatisches Protokoll aktivieren bzw. deaktivieren. Der Wert n wird direkt an den Schalter -LOG angefügt. Möglich sind

-LOG0 | Automatisches Protokoll deaktivieren.
-LOG1 | Automatisches Protokoll aktivieren. Es werden nur jeweils die Uhrzeit und der Statuscode für jede Aktion protokolliert.
-LOG2 | Automatisches Protokoll aktivieren. Es werden jeweils die komplette Kommandozeile mit allen Parametern sowie die Uhrzeit und der Statuscode für jede Aktion protokolliert.
-LOG3 | Automatisches Protokoll aktivieren. Es werden jeweils die komplette Kommandozeile mit allen Parametern sowie die Uhrzeit und der Statuscode für jede Aktion protokolliert. Außerdem werden für jede Aktion alle Dateien mitprotokolliert, die komprimiert, entpackt oder gelöscht wurden.

Sämtliche Meldungen, Statuscodes usw. werden per Voreinstellung in die Datei log.txt geschrieben, die sich im gleichen Ordner wie sqc.exe befindet.

sqc x -log3 D:\Backup.sqx *.doc

Es werden aus dem Archiv D:\Backup.sqx alle DOC-Dateien entpackt. In die Protokolldatei werden sämtliche Meldungen, Statuscodes sowie alle entpackten Dateien geschrieben.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, E und X verwenden.
-LOGE Dateiname Alle Formate

Dateiname ist der Name der Datei, in die alle Meldungen, Statuscodes usw. geschrieben werden sollen.

sqc x -log3 -loge D:\Protokoll.txt D:\Backup.sqx *.doc

Es werden aus dem Archiv D:\Backup.sqx alle DOC-Dateien entpackt. In die Protokolldatei D:\Protokoll.txt werden sämtliche Meldungen, Statuscodes sowie alle entpackten Dateien geschrieben.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, E und X verwenden.
-M[n] Alle Formate

Legt die Kompressionsmethode fest. Der Wert n wird direkt an den Schalter -M angefügt. Möglich sind

-M0 | Keine Kompression
-M1 | Schnelle Kompression
-M2 | Normale Kompression
-M3 | Hohe Kompression
-M4 | Maximale Kompression
-M5 | Ultra-Kompression
sqc a -m4 -fmt zip D:\Backup D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Backup.zip mit maximaler Kompression alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden. Nicht alle Archivformate unterstützen jede Kompressionsmethode.

-MD[n] SQX, ZIP, RAR, ACE, 7z

Größe des Kompressionsspeichers (in Kilobytes) festlegen. Der Wert n wird direkt an den Schalter -MD angefügt. Möglich sind

-MD32 | SQX und ZIP20
-MD64 | SQX, ZIP45, RAR und ACE
-MD128 | SQX, RAR, ACE und 7z
-MD256 | SQX, RAR, ACE und 7z
-MD512 | SQX, RAR, ACE und 7z
-MD1024 | SQX, ZIP60, RAR, ACE und 7z
-MD2048 | SQX und 7z
-MD4096 | SQX und 7z
-MD8192 | SQX2 und 7z
-MD16384 | SQX2 (Ultra-Kompression) und 7z
-MD32768 | SQX2 (Ultra-Kompression) und 7z
sqc a -md4096 D:\Backup.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Backup.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt. Beim Komprimieren wird eine Speichergröße von 4096 Kilobytes benutzt.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-ME SQX, 7z

Speziellen Kompressionsalgorithmus für ausführbare Dateien (EXE, DLL, DRV, SYS usw.) aktivieren. Dieser intelligente Kompressionsalgorithmus kann die Kompression deutlich verbessern, wenn ausführbare Dateien komprimiert werden sollen. Der Kompressor erkennt selbständig, auf welche Dateien diese spezielle Kompression angewendet werden sollte.

sqc a -me D:\Backup D:\Programme\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Programme hinzugefügt. Beim Komprimieren von ausführbaren Dateien schaltet der Kompressor automatisch ein spezielles Verfahren zu, welches die Kompression verbessert.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-MM SQX, RAR

Speziellen Kompressionsalgorithmus für Multimedia-Dateien (Bilddateien, Klangdateien wie WAV usw., DOC-Dateien, die Bilder enthalten usw.) aktivieren. Dieser intelligente Kompressionsalgorithmus kann die Kompression deutlich verbessern, wenn Multimedia-Dateien komprimiert werden sollen. Der Kompressor erkennt selbständig, auf welche Dateien diese spezielle Kompression angewendet werden sollte.

sqc a -mm D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Beim Komprimieren von Multimedia-Dateien schaltet der Kompressor automatisch ein spezielles Verfahren zu, welches die Kompression verbessert.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-MOV Alle Formate

Dateien in ein Archiv verschieben. Das Verschieben von Dateien und Verzeichnissen hat zur Folge, dass bei nach erfolgreicher Archiverstellung die Quelldateien gelöscht werden.

sqc a -mov D:\Backup.zip D:\Daten\*.doc

Es werden dem Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt und anschließend alle DOC-Dateien aus dem Ordner D:\Daten gelöscht.

Sie können diesen Schalter mit den Kommandos A, F und U verwenden.
-MOVX Alle Formate

Dateien in ein Archiv verschieben und leere Ordner löschen.

sqc a -movx D:\Backup.zip D:\Daten\*.doc

Es werden dem Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt und anschließend alle DOC-Dateien aus dem Ordner D:\Daten gelöscht. Alle in der Dateiliste angegebenen Ordner werden gelöscht, sofern sie leer sind.

Sie können diesen Schalter mit den Kommandos A, F und U verwenden.
-MV Volumegröße SQX, ZIP

Es wird ein Multivolumearchiv erzeugt, wobei jedes Volume die Größe Volumegröße hat. Folgende Angaben sind möglich:

Volumegröße | Volumegröße in Bytes
Volumegrößek | Volumegröße mal 1000 Bytes
VolumegrößeK | Volumegröße in Kilobytes
Volumegrößem | Volumegröße mal 1000000 Bytes
VolumegrößeM | Volumegröße in Megabytes
sqc a -mv 1024K D:\Backup.zip D:\Daten\*.doc

Es werden dem Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt. Sofern die Gesamtgröße des Archivs 1024 Kilobytes überschreiten würden so würde das Archiv in einzelne Teilarchive aufgeteilt werden, von denen keines größer als 1024 Kilobytes ist.

Sie können diesen Schalter mit den Kommando A verwenden.
-MX SQX, ZIP, RAR, ACE, 7z

Legt die bestmögliche Kompression für die Archiver fest. Da neben der Kompressionsmethode noch weitere Einstellungen die Kompression beeinflussen, fasst dieser Schalter alle für die Kompression relevanten Schalter zusammen. Der Schalter -MX legt für die Archivformate die folgenden Einstellungen fest:

SQX1 | -M4 -ME -MM -MD4096
SQX2 | -M4 -MD4096 -AU1 -FME1 -FMM1
RAR | -M4 -MM -MD1024
ACE | -M4 -MD1024
7z | -M4 -ME -MD8192 -LZMAM2 -LZMAMF2 -LZMAFB64
sqc a -mx D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Es wird bei den entsprechenden Dateien automatisch ein spezieller Kompressor für ausführbare Dateien oder Multimedia-Dateien zugeschaltet. Beim Komprimieren wird eine Speichergröße von 4096 Kilobytes benutzt.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-NEW Alle Formate

Vor dem Erzeugen eines Archivs wird überprüft, ob bereits ein Archiv mit dem gleichen Namen existiert. Falls ein solches Archiv existiert, so wird es vor dem Erzeugen des neuen Archivs gelöscht.

sqc a -new D:\Backup.zip D:\Daten\*.*

Es wird überprüft, ob das Archiv D:\Backup.zip bereits existiert. Falls es existiert wird es gelöscht. Dann wird das Archiv D:\Backup.zip neu erzeugt und alle Dateien aus dem Ordner D:\Daten hinzugefügt.

Sie können diesen Schalter mit den Kommando A verwenden. Sofern Multivolumearchive erzeugt werden, so können Sie diesen Schalter nur mit SQX- und ZIP-Archiven verwenden.
-O Alle Formate

Dateien immer ohne Nachfrage überschreiben.

sqc a -o D:\Backup.zip D:\Daten\*.*

Es werden dem Archiv D:\Backup.zip alle Dateien aus dem Ordner D:\Daten hinzugefügt. Sofern im Archiv schon Dateien enthalten sind,
die sich in D:\Daten befinden, so werden die Dateien im Archiv ohne Nachfrage überschrieben.

Sie können diesen Schalter mit den Kommandos A, M, E und X verwenden.
-P Kennwort SQX, ZIP, RAR, 7z

Archive mit einem Kennwort verschlüsseln. Kennwort ist eine beliebige Zeichenfolge.

sqc a -p RabenLiebenGlänzendeDinge D:\Backup.sqx D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Die Dateien im Archiv werden mit dem Kennwort RabenLiebenGlänzendeDinge verschlüsselt.

Sie können diesen Schalter mit den Kommandos A, F, U, M, L, E und X verwenden.

Hinweis: SQX-Archive werden mit dem internationalen Verschlüsselungsstandard AES verschlüsselt. Wenn Sie sensible Daten bzw. Dateien archivieren und verschlüsseln wollen, dann sollten Sie nach Möglichkeit das SQX-Format auswählen.
-PH Kennwort SQX

Die Inhaltsverzeichnisse eines Archivs mit einem Kennwort verschlüsseln. Kennwort ist eine beliebige Zeichenfolge.

sqc a -p RabenLieben -ph GlänzendeDinge D:\Daten.sqx D:\Daten\*.*

Es werden dem Archiv D:\Daten.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Die Dateien im Archiv werden mit dem Kennwort RabenLieben verschlüsselt. Das Inhaltsverzeichnis des Archivs wird mit dem Kennwort GlänzendeDinge verschlüsselt. Ohne dem richtigen Kennwort kann das Archiv nicht geöffnet werden.

Sie können diesen Schalter mit den Kommandos A, F, U, M, L, E und X verwenden.

Hinweis: SQX-Archive werden mit dem internationalen Verschlüsselungsstandard AES verschlüsselt. Wenn Sie sensible Daten bzw. Dateien archivieren und verschlüsseln wollen, dann sollten Sie nach Möglichkeit das SQX-Format auswählen.
-Q Alle Formate

Alle Bildschirmausgaben unterdrücken.

sqc a D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Es werden aber nicht die normalerweise üblichen Statusmeldungen am Bildschirm ausgegeben.

Sie können diesen Schalter mit den Kommandos A, F, U, M, E und X verwenden.
-R Alle Formate

Dateien aus Unterordnern in die Dateiliste einschließen.

sqc a -r D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten sowie dessen Unterordner hinzugefügt. Würde der Schalter -r weggelassen werden, so würden alle Dateien aus D:\Daten dem Archiv hinzugefügt werden, nicht aber die Dateien aus D:\Daten\Briefe.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-R0 Alle Formate

Dateien aus Unterordnern in die Dateiliste einschließen, wenn der/die Dateiname(n) Stellvertreterzeichen enthalten. Die gültigen Stellvertreterzeichen (* und ?) sind Platzhalter, die für ein beliebiges Zeichen (?) oder mehrere beliebige Zeichen (*) stehen.

Daten\*.doc würde z.B. alle DOC-Dateien in D:\Daten finden. Daten\M?ller.doc würde z.B. alle DOC Dateien in D:\Daten finden, die mit m anfangen und mit ller aufhören und zwischen m und ller ein einziges beliebiges anderes Zeichen enthalten. Als mögliche Suchergebnisse kämen hier z.B. Müller, Möller oder Miller in Frage.

sqc a -r0 D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten sowie dessen Unterordner hinzugefügt, weil D:\Daten\*.* Stellvertreterzeichen enthält.

sqc a -r0 D:\Backup D:\Daten\Brief.doc

Es werden dem Archiv D:\Backup.sqx lediglich die Datei D:\Daten\Brief.doc hinzugefügt, weil D:\Daten\Brief.doc keine Stellvertreterzeichen enthält.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-RP Relativer Ordner Alle Formate

Relativen bzw. aktuellen Ordner im Archiv festlegen. Bisweilen ist es notwendig oder sinnvoll, die Ordnerinformationen der Dateien in einem Archiv zu erweitern oder zu kürzen. Beim Hinzufügen von Dateien zu Archiven wird Relativer Ordner den Dateinamen vorangestellt. Beim Entpacken von Dateien aus Archiven wird Relativer Ordner aus den Dateinamen gekürzt.

sqc a -rp Finanzen D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Den Dateinamen wird dabei Finanzen vorangestellt, aus [D:\]Daten\Finanzamt.doc würde im Archiv Daten\Finanzen\Finanzamt.doc werden.

sqc x -rp Daten D:\Backup *.*

Es werden aus dem Archiv D:\Backup.sqx alle Dateien entpackt. Aus den Dateinamen wird dabei Daten gekürzt, aus Daten\Finanzen\Finanzamt.doc würde Finanzen\Finanzamt.doc werden.

Sie können diesen Schalter mit den Kommandos A, F, U, M und X verwenden.
-RR[n] SQX

Größe der Reparaturdaten in Prozent bezogen auf die Archivgröße festlegen. Der Wert n wird direkt an den Schalter -RR angefügt. Möglich sind

-RR1 | Ein Prozent Reparaturdaten
-RR2 | Zwei Prozent Reparaturdaten
-RR3 | Drei Prozent Reparaturdaten
-RR4 | Vier Prozent Reparaturdaten
-RR5 | Fünf Prozent Reparaturdaten
sqc a -rr2 D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Dem Archiv werden zwei Prozent Reparaturdaten hinzugefügt.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden.
-RRE SQX

Externe Reparaturdaten erzeugen. Normalerweise werden Reparaturdaten direkt in das entsprechende Archiv eingefügt. Das Setzen dieses Schalters bewirkt, dass die Reparaturdaten in separaten Dateien gespeichert werden. So können die eigentlichen Daten auch getrennt von den Reparaturdaten aufbewahrt werden.

sqc a -rr2 -rre D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Es werden zwei Prozent Reparaturdaten erzeugt und in der Datei D:\Backup.sqr gespeichert.

Sie können diesen Schalter mit den Kommando A verwenden.

Hinweis: Externe Reparaturdaten werden immer in Archivname.sqr gespeichert.
-S SQX, RAR, ACE, 7z

Solidarchiv erzeugen. Beim Erzeugen von Solidarchiven berücksichtigt der Kompressor die Statistiken aller Dateien, um so die Kompression zu verbessern. Besonders beim Komprimieren von großen Datenmengen bzw. von ähnlichen Dateien kann dieser Schalter die Kompression deutlich verbessern.

Solidarchive können aber nicht so schnell wie Nicht-Solidarchive aktualisiert werden, weil der Kompressor auch beim Hinzufügen zu Solidarchiven die Statistiken der bereits im Archiv vorhandenen Dateien rekonstruieren muss, d.h. die Dateien müssen temporär entpackt werden. Dieser Vorgang ist zwar transparent für den Anwender, nimmt aber je nach Archivgröße auch ein wenig Zeit in Anspruch. Sie sollten Solidarchive erzeugen, wenn die Größe des Archiv wesentlich ist.

sqc a -rr2 -s D:\Backup D:\Daten\*.*

Es werden dem Archiv D:\Backup.sqx alle Dateien aus dem Ordner D:\Daten hinzugefügt. Dem Archiv werden zwei Prozent Reparaturdaten hinzugefügt. Das Archiv D:\Backup.sqx wird als Solidarchiv erzeugt.

Sie können diesen Schalter mit den Kommando A verwenden.
-SE Alle Formate

Dateien nach dem Komprimieren sicher löschen. Normalerweise werden gelöschte Dateien vom Betriebssystem nur als gelöscht markiert, die Daten der Dateien sind aber tatsächlich noch auf Ihrem System vorhanden, mit den geeigneten Werkzeugen könnte man diese Dateien entsprechend auch wiederherstellen.

Setzen Sie diesen Schalter, wenn die Dateien nach Regierungsrichtlinien sicher gelöscht werden sollen. Bei diesem Vorgang werden die Dateien entsprechend mehrfach mit Nullen, Einsen und zufälligen Daten überschrieben. Dieser Vorgang dauert ein wenig länger als das einfache Löschen.

sqc m -se D:\Backup.zip D:\Daten\*.doc

Es werden dem Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt und anschließend alle DOC-Dateien aus dem Ordner D:\Daten sicher gelöscht.

Sie können diesen Schalter mit den Kommando M oder mit dem Schalter -MOV bzw. -MOVX verwenden.
-SFX SQX

Selbstentpackendes Archiv (SFX) erzeugen

sqc a -sfx D:\Daten D:\Daten\Briefe\*.doc

Es werden zum selbstentpackenden Archiv D:\Daten.exe alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt.

Sie können diesen Schalter mit den Kommando A verwenden.
-T Alle Formate

Archiv auf Integrität überprüfen. Es wird überprüft, ob sich die im Archiv enthaltenen Dateien fehlerfrei entpacken lassen würden.

Es ist z.B. sinnvoll diesen Schalter zusammen mit dem Schalter -MOV oder dem Kommando M zu verwenden. Nach dem Erzeugen eines Archivs wird dieses noch einmal auf Integrität überprüft, erst dann werden die entsprechenden Dateien gelöscht.

sqc m -se -t D:\Backup.zip D:\Daten\*.doc

Es werden dem Archiv D:\Backup.zip alle DOC-Dateien aus dem Ordner D:\Daten hinzugefügt. Anschließend wird das Archiv auf Integrität überprüft. Wenn das Archiv keine Fehler enthält, dann werden alle DOC-Dateien aus dem Ordner D:\Daten sicher gelöscht.

Sie können diesen Schalter mit den Kommandos A, F, U und M verwenden
-TA DatumZeit Alle Formate

Nur Dateien jünger als DatumZeit in die Dateiliste(n) einschließen. Die Angabe von DatumZeit muss immer in der Form yyyymmddhhmmss erfolgen. Die einzelnen Formatzeichen Haben folgende Bedeutungen:

yyyy | Jahr, vierstellig
mm | Monat (1 - 12)
dd | Tag im Monat (1 - 31)
hh | Stunde
mm | Minute
ss | Sekunde

Formatzeichen am Ende der Formatangabe können ausgelassen werden.

sqc a -ta 20120503 D:\Daten.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt, die nach dem 03.05.2012 erzeugt oder geändert wurden.

sqc a -ta 2012050312 D:\Daten.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt, die nach dem 03.05.2012 und später als 12:00 Uhr erzeugt oder geändert wurden.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, L, E und X verwenden.

Hinweis: Der besseren Übersichtlichkeit halber kann die Formatangabe auch in der Form yyyy-mm-ddhh-mm-ss oder in der Form yyyy:mm:dd:hh:mm:ss erfolgen.
-TB DatumZeit Alle Formate

Nur Dateien älter als DatumZeit in die Dateiliste(n) einschließen. Die Angabe von DatumZeit muss immer in der der Form yyyymmddhhmmss erfolgen. Die einzelnen Formatzeichen Haben folgende Bedeutungen:

yyyy | Jahr, vierstellig
mm | Monat (1 - 12)
dd | Tag im Monat (1 - 31)
hh | Stunde
mm | Minute
ss | Sekunde

Formatzeichen am Ende der Formatangabe können ausgelassen werden.

sqc a -tb 20120503 D:\Daten.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt, die vor dem 03.05.2012 erzeugt oder geändert wurden.

sqc a -tb 2012050312 D:\Daten.sqx D:\Daten\Briefe\*.doc

Es werden dem Archiv D:\Daten.sqx alle DOC-Dateien aus dem Ordner D:\Daten\Briefe hinzugefügt, die vor dem 03.05.2012 und früher als 12:00 Uhr erzeugt oder geändert wurden.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, L, E und X verwenden.

Hinweis: Der besseren Übersichtlichkeit halber kann die Formatangabe auch in der Form yyyy-mm-dd hh-mm-ss oder in der Form yyyy:mm:dd:hh:mm:ss erfolgen.
-TD Ordner Alle Formate

Temporären Ordner festlegen. Per Voreinstellung wird der temporäre Ordner von Windows genutzt. Mit diesem Schalter können Sie einen anderen Ordner als temporären Ordner festlegen

sqc a D:\Daten.sqx D:\Daten\Briefe\*.doc -td D:\Daten\Temp

Der Ordner D:\Daten\Temp wurde als temporärer Ordner festgelegt.

Sie können diesen Schalter mit allen Kommandos verwenden.
-UX SQX2, 7z

Aktiviert die Ultra-Kompression. Da neben der Kompressionsmethode noch weitere Einstellungen die Kompression beeinflussen, fasst dieser Schalter alle für die Kompression relevanten Schalter zusammen. Der Schalter -UX legt für die Archivformate die folgenden Einstellungen fest:

SQX2 | -M5 -MD8192 -AU1 -FME1 -FMM1
7z | -M5 -ME -MD32768 -LZMAM2 -LZMAMF3 -LZMAFB64
-X Dateimaske Alle Formate

Dateien, die Dateimaske entsprechen nicht in die Dateiliste(n) einschließen.

sqc a -x *.bak D:\Daten D:\Daten\*.*

Es werden dem Archiv D:\Daten.sqx alle Dateien außer BAK-Dateien aus dem Ordner D:\Daten hinzugefügt.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, E und X verwenden.

Hinweis: Dieser Schalter kann in der Kommandozeile oder in Skriptdateien mehrfach angegeben werden.
-Y Alle Formate

Bei Nachfragen automatisch immer mit Ja antworten.

sqc x -y D:\Daten.sqx D:\Daten

Es werden aus dem Archiv D:\Daten.sqx alle Dateien nach D:\Daten entpackt. Vorhandene Dateien werden ohne Nachfrage überschrieben.

Sie können diesen Schalter mit den Kommandos A, F, U, M, D, E und X verwenden.
-ZID Alle Formate

Ab Windows XP SP2 werden aus dem Internet heruntergeladene Archive mit einer Kennung (Zone-ID) versehen. Dieser Schalter legt fest, dass die Kennung auch auf alle entpackten Dateien übertragen werden soll.


Zusätzliche Kommandoschalter (SQX, ZIP und 7z)

Squeez Kommandozeile
Zusätzliche Kommandoschalter (SQX, ZIP und 7z)

Diese Seite beschreibt die zusätzlichen Kommandoschalter für die Archivformate SQX, ZIP und 7z.

Erweiterte Schalter für SQX und ZIP

-AES[n] SQX, ZIP

Legt fest, dass die Verschlüsselung der Dateien im Archiv mit dem AES-Algorithmus erfolgen soll. Der Wert n wird direkt an den Schalter -AES angefügt. Möglich sind

-AES1 | Die Verschlüsselung erfolgt in AES 128bit.
-AES2 | Die Verschlüsselung erfolgt in AES 256bit.

Der Schalter -AES wird nur beachtet, wenn auch der Schalter -P gesetzt ist.
-AV SQX (nur registrierte Version)

Ein Archiv mit einer digitalen Signatur versehen. Diese Option steht nur in der registrierten Version zur Verfügung. Registrierte Anwender können ihre persönliche digitale Signatur unter http://signature.speedproject.de/ anfordern.

Bitte beachten Sie, dass beim Hinzufügen von Dateien zu einem bestehenden Archiv eine vorhandene Signatur wieder gelöscht wird.
-SC SQX, ZIP

Legt fest, dass NTFS-Dateikommentare automatisch in das Archiv übernommen werden bzw. beim Entpacken wieder gesetzt werden sollen.
-SHT SQX, ZIP

Legt fest, dass zusätzlich zu den normalen DOS-kompatiblen Zeitangaben auch die hochauflösenden Zeitstempel der Dateien archiviert bzw. hergestellt werden sollen.
-SSD SQX, ZIP

Legt fest, dass auch die NTFS-Sicherheitsattribute archiviert bzw. wiederhergestellt werden sollen.

-SST SQX, ZIP

Legt fest, dass neben dem Dateiinhalt auch alternative Datenströme (NTFS) archiviert bzw. wiederhergestellt werden sollen.

-SU SQX

Legt fest, dass zusätzlich auch Unicode-Dateinamen (NTFS) archiviert bzw. wiederhergestellt werden sollen.
-TX SQX, ZIP

Legt fest, dass nach dem Komprimieren ein ausführlicher Test der komprimierten Daten erfolgen soll. Hierbei werden die komprimierten Daten aus dem erstellten Archiv gelesen und mit den Daten der zu komprimierenden Dateien verglichen.

Der Schalter -TX setzt einen gültigen Basisordner voraus, der durch den Schalter -BP gesetzt wird.

Erweiterte Schalter für SQX2-Kompression

-AU[n] SQX2

Deaktiviert, aktiviert oder erzwingt den Audio-Kompressor. Der Audio-Kompressor kann die Kompressionsrate und Geschwindigkeit bei Audiodateien deutlich verbessern (WAV, PCM). Der Wert n wird direkt an den Schalter -AU angefügt, mögliche Wert sind

-AU0 | Deaktiviert den Audio-Kompressor.
-AU1 | Aktiviert den Audio-Kompressor automatisch.
-AU2 | Erzwingt den Audio-Kompressor unabhängig davon, ob die zu komprimierenden Dateien auch Audiodateien sind.
-AUC[n] SQX2

Legt die Anzahl der Kanäle fest, in welche die Audiodateien aufgeteilt werden sollen. Wenn der Audio-Kompressor die Anzahl der Kanäle automatisch ermitteln soll, so muss die Einstellung des Audio-Kompressors auf Automatisch gesetzt werden. Der Wert n wird direkt an den Schalter -AUC angefügt, mögliche Wert liegen zwischen 1 und 31.

-AUW[n] SQX2

Legt die Kanalbreite fest, die der Kompressor für die Audiodateien benutzen soll. Wenn der Audio-Kompressor die Kanalbreite automatisch ermitteln soll, so muss die Einstellung des Audio-Kompressors auf Automatisch gesetzt werden. Der Wert n wird direkt an den Schalter -AUW angefügt, mögliche Wert sind 8 und 16.

-FME[n] SQX2

Deaktiviert, aktiviert oder erzwingt den EXE-Transformator. Der EXE-Transformator kann die Kompression bei ausführbaren Dateien, dynamischen Programmbibliotheken und Gerätetreibern deutlich verbessern. Der Wert n wird direkt an den Schalter -FME angefügt, mögliche Wert sind

-FME0 | Deaktiviert den EXE-Transformator.
-FME1 | Aktiviert den EXE-Transformator automatisch.
-FME2 | Erzwingt den EXE-Transformator unabhängig davon, ob die zu komprimierenden Dateien auch ausführbare Dateien sind.
-FMM[n] SQX2

Deaktiviert, aktiviert oder erzwingt den Multimedia-Transformator. Der Multimedia-Transformator kann die Kompression bei Dateien mit multimedialen Elementen deutlich verbessern (Bilder, Ressourcen). Der Wert n wird direkt an den Schalter -FMM angefügt, mögliche Wert sind

-FMM0 | Deaktiviert den Multimedia-Transformator.
-FMM1 | Aktiviert den Multimedia-Transformator automatisch.
-FMM2 | Erzwingt den Multimedia-Transformator unabhängig davon, ob die zu komprimierenden Dateien auch multimediale Elemente enthalten.
-PPM[n] SQX2

Deaktiviert, aktiviert oder erzwingt den Text-Kompressor. Der Text.Kompressor kann die Kompressionsrate und Geschwindigkeit bei textartigen Dateien deutlich verbessern (TXT, HTML, RTF, CPP, PAS). Der Wert n wird direkt an den Schalter -PPM angefügt, mögliche Wert sind

-PPM0 | Deaktiviert den Text-Kompressor.
-PPM1 | Aktiviert den Text-Kompressor automatisch.
-PPM2 | Erzwingt den Text-Kompressor unabhängig davon, ob die zu komprimierenden Dateien auch textartige Elemente enthalten.
-PPMM[n] SQX2

Legt die Größe des Speichers für den Text-Kompressor in MB fest. Je größer der Speicher ist, desto größer ist auch die Kompressionsrate. Der Wert n wird direkt an den Schalter -PPMM angefügt und kann zwischen 1 und 1024 liegen, ein guter Mittelwert ist 32.
-PPMO[n] SQX2

Legt die Ordnung für den Text-Kompressor fest. Je höher die Ordnung, desto besser ist auch die Kompression und desto mehr Speicher sollte dem Kompressor zur Verfügung stehen. Der Wert n wird direkt an den Schalter -PPMO angefügt und kann zwischen 1 und 32 liegen, ein guter Mittelwert ist 6 bis 8.
-RGB[n] SQX2

Deaktiviert, aktiviert oder erzwingt den RGB-Transformator. Der RGB-Transformator kann die Kompression bei unkomprimierten RGB-Bilddateien deutlich verbessern (BMP, TGA, TIFF, PSD).

-RGB0 | Deaktiviert den RGB-Transformator.
-RGB1 | Aktiviert den RGB-Transformator automatisch.
-RGB2 | Erzwingt den RGB-Transformator unabhängig davon, ob die zu komprimierenden Dateien auch RGB-Bilddateien sind.
-UXX[n] SQX2

Legt die feinere Abstimmung für den Kompressor fest, wenn als Kompressionsrate Ultra gewählt ist. Der Wert n wird direkt an den Schalter -UXX angefügt und kann zwischen 1 und 9 liegen. 1 ist die beste Synthese aus Kompressionsrate und Geschwindigkeit. 9 erreicht in der Regel die maximale Kompression, der Kompressor wird dabei aber deutlich langsamer. Mit den einzelnen Zwischenstufen lässt sich dieses variieren.

Erweiterte Schalter für 7z-Kompression

-SZM[n] 7z

Legt die zu verwendende Kompressionsmethode fest. Der Wert n wird direkt an den Schalter -SZM angefügt, mögliche Wert sind

-SZM0 | Verwendet die LZMA-Methode für die Kompression.
-SZM1 | Verwendet die PPMD-Methode für die Kompression.

Die LZMA-Methode ist eine universelle Kompressionsmethode und für alle Dateien geeignet. Die PPMD-Methode ist am besten für Textdateien geeignet.
-LZMAM 7z

Legt den Kompressionsmodus für den LZMA-Kompressor fest. Der Wert n wird direkt an den Schalter -LZMAM angefügt, mögliche Wert sind

-LZMAM0 | Schnell
-LZMAM1 | Normal
-LZMAM2 | Maximal
-LZMAMF 7z

Legt den zu verwendenden Matchfinder fest. Der Wert n wird direkt an den Schalter -LZMAMF angefügt, mögliche Wert sind

-LZMAMF0 | Binary Tree with 2 bytes hashing
-LZMAMF1 | Binary Tree with 2-3 (full) bytes hashing
-LZMAMF2 | Binary Tree with 2-3-4 bytes hashing
-LZMAMF3 | Binary Tree with 2-3-4 (big) bytes hashing
-LZMAMF4 | Patricia Tree with 2-bits nodes
-LZMAMF5 | Patricia Tree with 2-bits nodes, removing
-LZMAMF6 | Patricia Tree with 2-bits nodes, 2-3 bytes hashing
-LZMAMF7 | Patricia Tree with 3-bits nodes, 2-3 bytes hashing
-LZMAMF8 | Patricia Tree with 4-bits nodes, 2-3 bytes hashing
-LZMAMF9 | Hash Chain with 2-3 bytes hashing
-LZMAMF10 | Hash Chain with 2-3-4 bytes hashing

Binary Tree ist die beste Synthese aus Kompressionsrate und Geschwindigkeit. Patricia Tree ist etwas schneller als Binary Tree, braucht aber deutlich mehr Speicher. Hash Chain ist hinsichtlich des Speicherverbrauchs am sparsamsten und am schnellsten bei fast allen Dateitypen, bietet aber dafür die schlechteste Kompression aller drei Varianten.
-LZMAFB 7z

Legt die maximale Länge der Matches fest, deren Qualität verglichen werden soll. Je höher der Wert, desto besser (und langsamer) ist die Kompression. Der Wert n wird direkt an den Schalter -LZMAFB angefügt. Mögliche Wert liegen zwischen 5 und 255, ein guter Mittelwert ist 64.

-LZMALCB 7z

Legt die Ordnung des Literal-Kompressors fest. Der Wert n wird direkt an den Schalter -LZMALCB angefügt. Mögliche Wert liegen zwischen 0 und 8, ein guter Mittelwert ist 3.

-LZMPB 7z

Legt die Anzahl der Bits fest, die von den absoluten Distanzwerten komprimiert werden sollen. Der Wert n wird direkt an den Schalter -LZMAPB angefügt, mögliche Wert liegen zwischen 0 und 4.

-LZMLPB 7z

Legt die Anzahl der Extra-Bits für die Literale fest. Der Wert n wird direkt an den Schalter -LZMALPB angefügt, mögliche Wert liegen zwischen 0 und 4.

-PPMM[n] 7z

Legt die Größe des Speichers für den Text-Kompressor in MB fest. Je größer der Speicher ist, desto größer ist auch die Kompressionsrate. Der Wert n wird direkt an den Schalter -PPMM angefügt und kann zwischen 1 und 1024 liegen, ein guter Mittelwert ist 32.
-PPMO[n] 7z

Legt die Ordnung für den Text-Kompressor fest. Je höher die Ordnung, desto besser ist auch die Kompression und desto mehr Speicher sollte dem Kompressor zur Verfügung stehen. Der Wert n wird direkt an den Schalter -PPMO angefügt und kann zwischen 1 und 32 liegen, ein guter Mittelwert ist 6 bis 8.


Zusätzliche Kommandoschalter (SFX)

Squeez Kommandozeile
Zusätzliche Kommandoschalter (SFX)

Diese Seite beschreibt die Kommandoschalter, welche für das Erstellen von selbstentpackenden Archive benutzt werden können.

-SFX-TYP[n] SQX

Gibt den Typ des zu erstellenden selbstentpackenden Archivs an. Der Wert n wird direkt an den Schalter -SFX-TYP angefügt. Möglich sind

-SFX-TYP0 | Einfaches SFX
-SFX-TYP1 | SFX mit Listenansicht
-SFX-TYP2 | SFX für Softwareinstallationen
-SFX-OS[n] SQX

Gibt das Betriebssystem an, für welches das selbstentpackende Archiv erstellt werden soll. Der Wert n wird direkt an den Schalter -SFX-OS angefügt. Möglich sind

-SFX-OS1 | Windows 32-bit
-SFX-OS2 | Windows 64-bit

Selbstentpackende Archive für Windows 32-bit lassen sich sowohl unter einem 32-bit System als auch unter einem 64-bit System entpacken. Selbstentpackende Archive für Windows 64-bit lassen sich nur unter einem 64-bit System entpacken.

-SFX-HIT SQX

Gibt den Titel für einen optional anzuzeigenden Hinweisdialog nach dem Start des selbstentpackenden Archivs an. Der Hinweisdialog kann nur bei einem einfachen SFX und einem SFX für Softwareinstallationen angezeigt werden.

-SFX-HIM SQX

Gibt den Dialogtext für einen optional anzuzeigenden Hinweisdialog nach dem Start des selbstentpackenden Archivs an. Der Hinweisdialog kann nur bei einem einfachen SFX und einem SFX für Softwareinstallationen angezeigt werden.

-SFX-IA SQX

Gibt einen optional anzuzeigenden Text für den Informationsdialog an.

-SFX-HIB[n] SQX

Gibt die Art der Schaltflächen an, welche im Hinweisdialog angezeigt werden sollen. Der Wert n wird direkt an den Schalter -SFX-HIB angefügt. Möglich sind

-SFX-HIB0 | Es wird eine Schaltfläche OK angezeigt.
-SFX-HIB1 | Es werden die Schaltflächen Ja und Nein angezeigt.
-SFX-HIB2 | Es werden die Schaltflächen OK und Abbrechen angezeigt.

Wenn der Anwender im Hinweisdialog Nein oder Abbrechen wählt, dann wird das SFX wieder beendet.

-SFX-E SQX

Gibt einen Ordner an, in den das Archiv entpackt werden soll. Zusätzlich können folgende Systemvariablen angegeben werden, die zur Laufzeit auf dem Zielsystem aufgelöst werden:

%Programs% | Wird durch den Ordner "Programme" ersetzt.
%CommonFiles% | Wird durch den Ordner "Gemeinsame Dateien" ersetzt.
%AppData% | Wird durch den Ordner "Anwendungsdaten" des jeweiligen Benutzers ersetzt.
%LocalAppData% | Wird durch den Ordner "Lokale Anwendungsdaten" des jeweiligen Benutzers ersetzt.
%Documents% | Wird durch den Ordner "Eigene Dateien" des jeweiligen Benutzers ersetzt.
%Windows% | Wird durch den Ordner "Windows" ersetzt.
%System% | Wird durch den Ordner "Windows\System" ersetzt.
%Temp% | Wird durch den Ordner "Temp" des jeweiligen Benutzers ersetzt.

Dieser Schalter kann nur bei einem normalen SFX verwendet werden.

-SFX-C SQX

Gibt einen Befehl an, der nach dem erfolgreichen Entpacken des Archivs ausgeführt werden soll. Dem aufzurufenden Programm können beim Start weitere Parameter übergeben werden. Die Parameter müssen mit dem Pipe-Zeichen (|) vom Programmnamen getrennt werden. Zum Beispiel würde Backup.exe|/as /t /i das SFX anweisen, nach dem Entpacken das Programm Backup.exe zu starten und die Parameter /as /t /i an Backup.exe zu übergeben.

Dieser Schalter kann nur bei einem einfachen SFX verwendet werden.

-SFX-OW SQX

Legt fest, dass eventuell vorhandene Dateien beim Entpacken des Archivs ohne Nachfrage überschrieben werden sollen.

Dieser Schalter kann nur bei einem einfachen SFX verwendet werden.

-SFX-AE SQX

Legt fest, dass das selbstentpackende Archiv nach dem Start ohne Rückfrage dekomprimiert wird. Verwenden Sie diese Option äußerst vorsichtig, da der Empfänger des selbstentpackenden Archivs keinerlei Meldungen auf dem Bildschirm erhält.

Dieser Schalter kann nur bei einem einfachen SFX verwendet werden.

-SFX-IM SQX

Legt den Text fest, der im Dialogfeld des Installationsarchivs angezeigt werden soll.

Dieser Schalter kann nur bei einem SFX für Softwareinstallationen verwendet werden und ist hier zwingend erforderlich.

-SFX-IC SQX

Gibt das Installationsprogramm an, welches nach dem Entpacken des Archivs gestartet werden soll. Dem Installationsprogramm können beim Start weitere Parameter übergeben werden. Die Parameter müssen mit dem Pipe-Zeichen (|) vom Programmnamen getrennt werden. Zum Beispiel würde Setup.exe|/as /t /i das SFX anweisen, nach dem Entpacken das Programm Setup.exe zu starten und die Parameter /as /t /i an Setup.exe zu übergeben.

Dieser Schalter kann nur bei einem SFX für Softwareinstallationen verwendet werden und ist hierbei zwingend erforderlich. Bitte beachten Sie, dass der Name des SFX sich von den Namen des Installationsprogramms unterscheiden muss.
-SFX-IW SQX

Gibt den Modulnamen an, auf dessen Beendigung das SFX warten soll. Dieser Wert sollte nur verwendet werden, wenn das Installationsprogramm gleich nach dem Start ein weiteres Programm ausführt und sich dann sofort wieder beendet.

Dieser Schalter kann nur bei einem SFX für Softwareinstallationen verwendet werden.

-SFX-ICO SQX

Gibt den vollständigen Dateinamen für ein angepasstes Programmsymbol (ICO-Datei) an. Das Programmsymbol sollte folgende Größen und Auflösungen enthalten:

  • 16x16 (16 Farben, 256 Farben und TrueColor mit Alpha-Kanal)
  • 32x32 (16 Farben, 256 Farben und TrueColor mit Alpha-Kanal)
  • 48x48 (16 Farben, 256 Farben und TrueColor mit Alpha-Kanal)
-SFX-LNG SQX

Gibt den vollständigen Dateinamen der zu verwendenden Sprachdatei an.

-SFX-VC SQX

Gibt den Firmennamen an. Die Länge des Firmennamens ist auf 40 Zeichen begrenzt.

-SFX-VLC SQX

Gibt die Copyright-Information an. Die Länge der Copyright-Information ist auf 40 Zeichen begrenzt.

-SFX-VFD SQX

Gibt die Dateibeschreibung an. Die Länge der Dateibeschreibung ist auf 40 Zeichen begrenzt.

-SFX-VFV SQX

Gibt die Versionsnummer für die Datei in der Form 1.2.3.4 an, wobei gilt

  • 1 - Hauptversion
  • 2 - Nebenversion
  • 3 - Buildnummer
  • 4 - Revision

Nicht zu verwendende Abschnitte können auch weggelassen werden, sie werden dann auf 0 gesetzt. Ein gültiger Wert wäre zum Beispiel 10.30.4230.
-SFX-VPN SQX

Gibt den Produktnamen an. Die Länge des Produktnamens ist auf 40 Zeichen begrenzt.

-SFX-VPV SQX

Gibt die Versionsnummer für das Produkt in der Form 1.2.3.4 an, wobei gilt

  • 1 - Hauptversion
  • 2 - Nebenversion
  • 3 - Buildnummer
  • 4 - Revision

Nicht zu verwendende Abschnitte können auch weggelassen werden, sie werden dann auf 0 gesetzt. Ein gültiger Wert wäre zum Beispiel 10.30.4230.


Skriptdateien verwenden

Squeez Kommandozeile
Skriptdateien verwenden

SQC unterstützt einfache Skriptdateien, die mit einem üblichen Texteditor angelegt und bearbeitet werden können. Es sind keinerlei Programmierkenntnisse notwendig, um diese Skriptdateien zu erstellen.

Jede Zeile in einer Skriptdatei darf ein Kommando, einen Kommandoschalter oder ein Argument enthalten. Um das Skript abzuarbeiten, müsste SQC wie folgt aufgerufen werden:

sqc.exe @NameDerSkriptdatei

NameDerSkriptdatei ist der vollständige Dateiname der Datei, in der Sie das Skript gespeichert haben. Ist der Name z.B. D:\Sicherung.job, so würde der korrekte Aufruf

sqc.exe @D:\Sicherung.job

lauten. Bitte beachten Sie das führende @-Zeichen am Anfang. Dieses Zeichen muss beim Aufruf dem eigentlichen Dateinamen direkt vorangestellt werden, damit SQC erkennt, dass diese Datei als Skript abgearbeitet werden soll.

Skriptdateien dürfen Kommentare enthalten, die der C-Notation folgen. Die Zeichenfolge // wird als Einleitung eines Kommentars interpretiert. So können komplexe Skriptdateien auch dokumentiert werden.

Beispiel für eine Skriptdatei:
a                            // Kommando a, Dateien hinzufügen oder neues Archiv erzeugen
-fmt                         // Kommandoschalter für das Archivformat
sqx                          // Argument für den vorherigen Kommandoschalter
D:\Backup\Dokumente.sqx      // Archiv, dem die Dateien hinzugefügt werden
D:\Daten\Dokumente\*.*       // Dateien, die dem Archiv hinzugefügt werden


Fehlerrückgabecodes

Squeez Kommandozeile
Fehlerrückgabecodes

Der Fehlerrückgabecode jeder Aktion, die von SQC ausgeführt wird, kann in Batchdateien mit dem Errorlevel-Code abgefragt werden. SQC gibt folgende Fehlercodes zurück:

0	Es trat kein Fehler auf und das Kommando wurde erfolgreich ausgeführt.
1	Es wurden keine Kommandos bzw. Argumente übergeben.
2	Es wurden ungültige Kommandos bzw. Argumente übergeben.
3	SQC konnte den Archivtyp nicht erkennen.
4 	Das bzw. ein Archiv ist beschädigt.
5 	Eine Lese- oder Schreibaktion ist fehlgeschlagen.
6 	Das Ziellaufwerk ist voll.
7	Es steht nicht genügend Speicher zur Verfügung.
8 	Ein anderer Fehler ist aufgetreten.
9 	Die Aktion wurde durch den Anwender abgebrochen.


Erweiterte Konfiguration

Squeez Kommandozeile
Erweiterte Konfiguration

Obwohl SQC komplett mit den in der Kommandozeile übergebenen Parametern gesteuert werden kann, ist es durchaus sinnvoll, verschiedene bevorzugte Einstellungen dauerhaft zu speichern. Diese Einstellungen können entweder in einer Konfigurationsdatei oder in der SQC-Umgebungsvariable abgelegt werden.

Die Einstellungen der Konfigurationsdatei bzw. der SQC-Umgebungsvariablen können bei Bedarf auch überschrieben werden. Die in der Kommandozeile gesetzten Schalter haben immer Vorrang vor den Schaltern in der Konfigurationsdatei bzw. Umgebungsvariablen. SQC arbeitet zuerst die Konfigurationsdatei, danach die Umgebungsvariable und dann die Kommandozeile ab.

Die Konfigurationsdatei

SQC liest die Konfigurationseinstellungen aus der Datei sqc.ini, die sich im gleichen Ordner wie sqc.exe befindet. In dieser Konfigurationsdatei können die gewünschten Einstellungen dauerhaft abgespeichert werden. Die Datei kann mit einem Texteditor angelegt und bearbeitet werden.

Pro Zeile wird jeweils ein Kommandoschalter angegeben. Kommandoschalter, die ein weiteres Argument benötigen, werden entsprechend in zwei Zeilen angegeben. In der Konfigurationsdatei können alle SQC-Kommandoschalter angegeben werden:

-fmt
SQX

Eine Konfigurationsdatei, die als Archivformat das SQX-Format und als Vorgabeeinstellung maximale Kompression und ein Prozent Reparaturdaten festlegt, würde z.B. so aussehen:

-fmt       // Formatschalter
SQX        // Argument für Formatschalter
-m4        // Maximale Kompression
-rr1       // Dem Archiv ein Prozent Reparaturdaten hinzufügen.

SQC erkennt in den Konfigurations- und Skriptdateien Kommentare, die der C-Notation folgen. Die Zeichenfolge // wird als Einleitung eines Kommentars interpretiert. So können komplexe Konfigurations- und Skriptdateien auch dokumentiert werden.

Die SQC-Umgebungsvariable

Kommandoschalter können zur Windows-Umgebungsvariablen SQC_ENV_KEY mit dem SET-Befehl hinzugefügt werden.

SET SQC_ENV_KEY=-m4 -rr1 -md4096

SQC würde entsprechend der oben gesetzten Kommandoschalter jeweils die beste Kompression (-m4), ein Prozent Reparaturdaten (-rr1) und 4096 Kilobytes Kompressionsspeicher (-md4096) als Voreinstellung annehmen.


Beispiele für Datensicherungen

Squeez Kommandozeile
Beispiele für Datensicherungen

Auf dieser Seite finden Sie einige Beispiele zur Erstellung von automatischen Datensicherungen.

Erstellen und Aktualisieren

Folgende Ordner und Dateien sollen gesichert werden:

  • Alle Dateien des Ordners D:\Eigene Dateien
  • Alle Word-Dokumente des Ordners D:\Daten\Texte
  • Alle Tabellen des Ordners D:\Daten\Tabellen
  • Alle Datenbanken des Ordners D:\Buchhaltung
  • *.tmp und *.bak Dateien sollen von der Sicherung ausgeschlossen werden.

Das Sicherungsarchiv soll einmal erstellt werden und später nur noch mit neuen bzw. geänderten Dateien aktualisiert werden. Außerdem soll das Archiv gegen Beschädigungen geschützt werden und deshalb Reparaturdaten enthalten. Es werden zwei Skriptdateien für die Datensicherung erstellt, damit das Erstellen und Aktualisieren des Sicherungsarchivs zügig und selbstständig ablaufen kann. Das Sicherungsarchiv soll D:\Sicherungen\Daten.sqx heißen.

Inhalt der ersten Skriptdatei
a                          // Archiv erzeugen
-fmt                       // Kommandoschalter für Archivformat
sqx                        // Argument für Archivformat
-md32                      // 32 KiB Kompressionsspeicher
-m1                        // Normale Kompression
D:\Sicherungen\Daten.sqx   // Archivname
-rr2                       // 2% Reparaturdaten
"D:\Eigene Dateien\*.*"    // Alle Dateien aus D:\Eigene Dateien
D:\Daten\Texte\*.doc       // Alle DOC-Dateien aus D:\Daten\Texte
D:\Daten\Tabellen\*.xls    // Alle Tabellen aus D:\Daten\Tabellen
D:\Buchhaltung\*.dbf       // Datenbankdateien aus D:\Buchhaltung
D:\Buchhaltung\*.ndx       // Datenbankdateien aus D:\Buchhaltung
D:\Buchhaltung\*.dbt       // Datenbankdateien aus D:\Buchhaltung
-r                         // Alle Unterordner einschließen
-x                         // Schalter zum Ausschließen von Dateien
*.bak                      // Alle BAK-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.tmp                      // Alle TMP-Dateien ausschließen
Inhalt der zweiten Skriptdatei
u                          // Archiv aktualisieren
-fmt                       // Kommandoschalter für Archivformat
sqx                        // Argument für Archivformat
-md32                      // 32 KiB Kompressionsspeicher
-m1                        // Normale Kompression
D:\Sicherungen\Daten.sqx   // Archivname
-rr2                       // 2% Reparaturdaten
"D:\Eigene Dateien\*.*"    // Alle Dateien aus D:\Eigene Dateien
D:\Daten\Texte\*.doc       // Alle DOC-Dateien aus D:\Daten\Texte
D:\Daten\Tabellen\*.xls    // Alle Tabellen aus D:\Daten\Tabellen
D:\Buchhaltung\*.dbf       // Datenbankdateien aus D:\Buchhaltung
D:\Buchhaltung\*.ndx       // Datenbankdateien aus D:\Buchhaltung
D:\Buchhaltung\*.dbt       // Datenbankdateien aus D:\Buchhaltung
-r                         // Alle Unterordner einschließen
-x                         // Schalter zum Ausschließen von Dateien
*.bak                      // Alle BAK-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.tmp                      // Alle TMP-Dateien ausschließen

Der Inhalt der ersten Skriptdatei wird nun in der Datei D:\Datensicherung_Erstellen.job und der Inhalt der zweiten Skriptdatei in der Datei D:\Datensicherung_Aktualisieren.job abgespeichert.

Das Sicherungsarchiv wird nun mit dem folgenden Aufruf einmalig erzeugt:

sqc @D:\Datensicherung_Erstellen.job

Zum Aktualisieren des Sicherungsarchivs wird folgendes Kommando ausgeführt:

sqc @D:\Datensicherung_Aktualisieren.job

Beim Aktualisieren des Archivs geht SQC wie folgt vor: Es wird überprüft, ob sich in der Dateiliste Dateien befinden, die noch nicht in dem Archiv vorhanden sind. Falls dem so ist, werden diese Dateien dem Archiv hinzugefügt. Weiterhin wird überprüft, ob sich in der Dateiliste Dateien befinden, die sich schon im Archiv befinden, aber einen neueren Zeitstempel als die Dateien im Archiv besitzen. Diese Dateien wurden seit der Erstellung bzw. letzten Aktualisierung geändert und werden dem Archiv eingefügt.

Tägliche Sicherung

Für ein weiteres Beispiel soll angenommen werden, dass die Programmquellen des Ordners F:\Delphi\Projekte regelmäßig gesichert werden sollen. Für jeden Wochentag soll automatisch ein neues Archiv angelegt werden. Ferner sollen die Sicherungsarchive möglichst klein sein, weil sie dem Projektleiter täglich über das Internet zugesendet werden müssen. Die Sicherungsarchive sollen in D:\Sicherungen erstellt werden. Die von Delphi erzeugten temporären Dateien sowie alle eventuell erzeugten DCU-, EXE- und DLL-Dateien sollen von der Datensicherung ausgeschlossen werden. Für diese Aufgabe wird wieder eine Skriptdatei angelegt.

Inhalt der Skriptdatei
a                          // Archiv erzeugen
-fmt                       // Kommandoschalter für Archivformat
sqx                        // Argument für Archivformat
-md4096                    // 4096 KB Kompressionsspeicher
-mx                        // Maximale Kompression
-s                         // Solid-Archiv erzeugen
D:\Sicherungen\Backup_     // Archivname
-dt                        // Schalter für Archivname aus Zeit & Datum
dddd                       // Argument für Archivname aus Zeit & Datum
F:\Delphi\Projekte\*.*     // Alle Dateien aus f:\Delphi\Projekte
-r                         // Alle Unterordner einschließen
-x                         // Schalter zum Ausschließen von Dateien
*.bak                      // Alle BAK-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.~pas                     // Alle ~PAS-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.~dpr                     // Alle ~DPR-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.~dfm                     // Alle ~DFM-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.~dsk                     // Alle ~DSK-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.~dcu                     // Alle ~DCU-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.~exe                     // Alle ~EXE-Dateien ausschließen
-x                         // Schalter zum Ausschließen von Dateien
*.~dll                     // Alle ~DLL-Dateien ausschließen
-new                       // Schon vorhandenes Archiv löschen

Der Inhalt dieser Skriptdatei wird nun in der Datei D:\Projekte.job gespeichert. Die Sicherungsarchive werden mit dem folgenden Aufruf jeweils erzeugt:

sqc @D:\Projekte.job

Je nach Wochentag wird im Ordner D:\Sicherungen ein Archiv mit dem Namen

  • Backup_Montag.sqx
  • Backup_Dienstag.sqx
  • Backup_Mittwoch.sqx
  • Backup_Donnerstag.sqx
  • Backup_Freitag.sqx
  • Backup_Samstag.sqx
  • Backup_Sonntag.sqx

erzeugt.


Automatisierung von Aufgaben

SpeedCommander: Automatisierung
Automatisierung von Aufgaben

Im SpeedCommander führen Sie viele Aufgaben manuell durch. Sie verwenden beispielsweise Menübefehle, um Dateien auszuwählen, zu kopieren und umzubenennen. Wenn es sich um Routine-Aufgaben handelt oder solche, die sich wiederholen, dann ist es von Vorteil, diese zu automatisieren. Durch die Automatisierung können Sie die für diese Aufgaben verwendete Zeit reduzieren und Fehler vermeiden, die häufig durch die manuelle Durchführung von Aufgaben entstehen.

Automatisierung bedeutet, dass Sie Aufgaben programmtechnisch durchführen, indem Sie VBScript-Makros oder AddIns schreiben. AddIns sind prozessintegrierte ActiveX-Komponenten (DLLs), die Sie in jeder gebräuchlichen Programmiersprache (C++, Delphi, Visual Basic.NET) entwickeln können.

Mit Makros oder AddIns führen Sie Aufgaben durch, indem Sie die SpeedCommander-Umgebung und die zugehörigen Komponenten als Objekte verwenden. Mit dieser Vorgehensweise markieren Sie z.B. Dateien, erstellen neue Fenster oder führen bestimmte Aktionen mit Dateien aus.

Ein Objekt stellt eine Komponente der SpeedCommander-Umgebung oder eine Auflistung von verwandten Komponenten dar. Ein FolderFavorite-Objekt repräsentiert z.B. einen Ordnerfavoriten, während das Objekt FolderFavorites alle Ordnerfavoriten darstellt. Entsprechend repräsentiert ein UserTool-Objekt einen Anwendungsfavoriten, während das Objekt UserTools alle Anwendungsfavoriten darstellt. Die Objekte FolderFavorites und UserTools werden als Auflistungsobjekte bezeichnet, da sie Auflistungen von verwandten Objekten enthalten.

Sie verarbeiten Objekte, indem Sie die mit den Objekten verbundene Methoden, Eigenschaften und Ereignisse verwenden. Methoden stellen Aktionen dar, die Sie an den Objekten durchführen. Eigenschaften stellen Merkmale der Objekte dar, wie beispielsweise deren Typ oder Größe. Ereignisse stellen Bedingungen dar, unter denen Aktionen an den Objekten durchgeführt werden.

Wenn Sie beispielsweise durch einfaches Klicken auf eine Schaltfläche alle png- und jpg-Dateien in einem Ordnerfenster markieren möchten, schreiben Sie zunächst ein Makro, das die Dateien markiert:

  Set Workspace = Application.GetObject(scObjectWorkspace)
  Set FolderWindow = Workspace.ActiveWindow.FolderWindows.Active

  FolderWindow.Selection.Select("*.png")
  FolderWindow.Selection.Select("*.jpg")

Dieses Makro führt die folgenden Aktionen durch:

  • Die erste Zeile ruft das Objekt für den Arbeitsbereich ab, die zweite Zeile das Objekt für das aktive Ordnerfenster.
  • In der dritten und vierten Zeile wird die Methode Select vom Selection-Objekt des Ordnerfensters aufgerufen, mit welcher die gewünschten Dateien markiert werden.

Nachdem Sie das Makro geschrieben haben, können Sie es einer Symbolleistenschaltfläche oder einem Tastenkürzel zuweisen. Führen Sie anschließend das Makro aus, indem Sie auf die Schaltfläche klicken oder das Tastenkürzel aktivieren.

Weitere Informationen zu Objekten, welche in SpeedCommander zur Durchführung von Aufgaben verwendet werden können, finden Sie in der Objektreferenz. Informationen zur Erstellung von AddIns finden Sie iim Kapitel Erweiterung durch AddIns.


Arbeiten mit Makros

Arbeiten mit Makros

Ein Makro ist ein Satz von VBScript-Anweisungen, der in einer Datei gespeichert ist und zu einem späteren Zeitpunkt ausgeführt werden kann. Sie können Makros verwenden, um sich die Arbeit in SpeedCommander zu erleichtern. Mit Hilfe eines Makros können z.B. mehrere Befehle zusammengefasst werden, welche die Bearbeitung von Routinen beschleunigen oder eine komplexe Abfolge von Aufgaben automatisieren.

Weiterführende Themen

Arbeiten mit dem Makroeditor

Ausführen von Makros

Externe Objekte einbinden

Zuweisen von Makros zu Symbolleisten und Tastenkürzeln

Exportieren und Importieren von Makros

Unterschiede zwischen Makros und AddIns


Arbeiten mit dem Makroeditor

Arbeiten mit dem Makroeditor

Mit Hilfe des Makroeditors können Sie Makros schreiben, ausführen und testen. Öffnen Sie das Menü Extras, zeigen Sie auf Makros und wählen Sie den Befehl Makroeditor, um den Makroeditor anzuzeigen.

So erstellen Sie ein neues Makro:
  1. Wählen Sie im Menü Datei den Befehl Neu.
  2. Tragen Sie im Dialogfeld Neues Makro einen Namen für das Makro ein.
  3. Geben Sie im Makroeditor den Programmtext ein.
  4. Wählen Sie im Menü Datei den Befehl Speichern, um das neue Makro zu speichern.
So benennen Sie ein Makro um:
  1. Wählen Sie im Makroeditor das Makro, welches Sie umbenennen möchten.
  2. Wählen Sie im Menü Datei den Befehl Umbenennen.
  3. Tragen Sie im Dialogfeld Makro umbenennen einen neuen Namen für das Makro ein.
So löschen Sie ein Makro:
  1. Wählen Sie im Makroeditor das Makro, welches Sie löschen möchten.
  2. Wählen Sie im Menü Datei den Befehl Löschen.


Ausführen von Makros

Ausführen von Makros

SpeedCommander zeigt alle Makros im Menü Makros an, welches über das Menü Extras aktiviert werden kann. Zum Ausführen eines Makros öffnen Sie einfach dieses Menü und wählen dann das gewünschte Makro aus. Alternativ können Sie ein Makro auch über eine Schaltfläche in einer Symbolleiste oder über ein Tastenkürzel ausführen.

So führen Sie ein Makro über das Menü aus:
  1. Öffnen Sie das Menü Extras und zeigen Sie auf Makros.
  2. Wählen Sie das Makro aus, welches Sie ausführen möchten.


Externe Objekte einbinden

Externe Objekte einbinden

In einem Makro kann nicht nur auf das Objektmodell von SpeedCommander zugegriffen werden, auch die Einbindung aller skriptfähigen COM-Module ist möglich. Wenn Sie bestimmte Objekte häufiger benötigen, dann können diese automatisch für alle Makros verwendet werden. Zusätzlich kann der Makroeditor auch IntelliSense-Informationen zu den einzelnen Funktionen der Objekte anzeigen.

So binden Sie ein externes Objekt ein:
  1. Öffnen Sie den Makroeditor.
  2. Wählen Sie im Menü Extras den Befehl Externe Objekte.
  3. Tragen Sie im Eingabefeld Name den Namen ein, den Sie für das Objekt verwenden möchten.
  4. Geben Sie im Eingabefeld CLSID oder ProgID die CLSID oder ProgID des Objekts ein.
  5. Klicken Sie auf die Schaltfläche Hinzufügen.
So entfernen Sie ein externes Objekt:
  1. Öffnen Sie den Makroeditor.
  2. Wählen Sie im Menü Extras den Befehl Externe Objekte.
  3. Wählen Sie im Listenfeld das Objekt, welches Sie entfernen möchten und klicken Sie auf Entfernen.

Die folgende Tabelle enthält die wichtigsten externen Objekte, die viele nützliche Funktionen anbieten. Der Name der Objekte ist frei wählbar.

Name | CLSID oder ProgID | Beschreibung
fso | Scripting.FileSystemObject | Zugriff auf Dateien, Ordner und Laufwerke
net | WScript.Network | Zugriff auf Anmeldeinformationen, Freigaben und Netzwerkdrucker
shell | WScript.Shell | Zugriff auf Registry, Ausführung externer Programme, Senden von Tastatureingaben
shellapp | Shell.Application | Steuerung von Startmenü, Desktop und Explorer-Ansichten


Zuweisen von Makros zu Symbolleisten und Tastenkürzeln

Zuweisen von Makros zu Symbolleisten und Tastenkürzeln

Sie können ein Makro auch einer Symbolleistenschaltfläche oder einem Tastenkürzel zuweisen, damit Sie es schneller ausführen können.

So weisen Sie ein Makro einer Symbolleistenschaltfläche zu:
  1. Wählen Sie im Menü Extras den Befehl Anpassen.
  2. Aktivieren Sie die Registerkarte Befehle.
  3. Wählen Sie im Listenfeld Kategorien den Eintrag Makros.
  4. Ziehen Sie das entsprechende Makro aus dem Listenfeld Befehle an die gewünschte Stelle in der Symbolleiste.
So ordnen Sie einem Makro ein Tastenkürzel zu:
  1. Wählen Sie im Menü Extras den Befehl Anpassen.
  2. Aktivieren Sie die Registerkarte Tastatur.
  3. Wählen Sie im Kombinationsfeld Kategorie den Eintrag Makros.
  4. Klicken Sie im Listenfeld Befehle auf das gewünschte Makro.
  5. Geben Sie im Feld Neue Tastenkombination das Tastenkürzel ein, welches Sie verwenden möchten, und klicken Sie auf Zuweisen.
  6. Das Tastenkürzel erscheint im Listenfeld Aktuelle Tastenkürzel.


Exportieren und Importieren von Makros

Exportieren und Importieren von Makros

SpeedCommander speichert alle Makros in der Datei Macros.spm, diese Datei befindet sich im Einstellungsverzeichnis. Um ein Makro mit anderen Anwendern auszutauschen, müssen sie das Makro exportieren bzw. importieren.

So exportieren Sie ein Makro:
  1. Öffnen Sie den Makroeditor und wählen Sie das Makro aus, welches Sie exportieren möchten.
  2. Wählen Sie im Menü Datei den Befehl Exportieren.
  3. Geben Sie einen Namen für die Textdatei ein, in welche das Makro gespeichert werden soll.
So importieren Sie ein Makro:
  1. Öffnen Sie den Makroeditor.
  2. Erstellen Sie mit dem Befehl Neu aus dem Menü Datei ein neues Makro.
  3. Wählen Sie im Menü Datei den Befehl Importieren.
  4. Wählen Sie die Textdatei mit dem Makro aus, welches Sie importieren möchten.


Unterschiede zwischen Makros und AddIns

Unterschiede zwischen Makros und AddIns

Zwischen VBScript-Makros und AddIns gibt es eine Reihe von Unterschieden. Der Hauptunterschied besteht darin, dass Makros Prozeduren sind, die in VBScript geschrieben werden; während AddIns prozessintegrierte COM-Module sind, die in C++, Visual Basic.NET oder Delphi geschrieben werden.

Makros können schneller und einfacher erstellt werden als AddIns. Zum Erstellen und Ausführen von Makros können Sie den eingebauten Makroeditor von SpeedCommander verwenden. Nach dem ausführlichen Test kann das Makro dann in ein Menü oder in eine Symbolleiste eingebunden werden. Ein AddIn wird normalerweise in einer Entwicklungsumgebung erstellt, kompiliert und dann in SpeedCommander eingebunden.

Makros sind nicht so vielseitig wie AddIns. Makros können nur in VBScript geschrieben werden und können nur auf das Objektmodell von SpeedCommander sowie auf alle skriptfähigen COM-Objekte zugreifen. In AddIns können Sie dagegen eine beliebige Sprache verwenden und auf alle Ressourcen des Computersystems zugreifen.

Die folgende Tabelle zeigt die Unterschiede zwischen VBScript-Makros und AddIns:

VBScript-Makros | AddIns
Werden interpretiert. | Werden kompiliert.
Leichter zu erstellen. | Schwieriger zu erstellen.
Können nur in VBScript geschrieben werden. | Können in verschiedenen Sprachen geschrieben werden (z.B. C++, VB.NET, Delphi).
Können auf das Objektmodell von SpeedCommander und auf alle skriptfähigen COM-Objekte zugreifen. | Können auf das Objektmodell von SpeedCommander und auf alle lokalen Computerressourcen zugreifen.
Können nur Dialogfelder verwenden, die mit den VBScript-Befehlen InputBox und MsgBox erstellt werden. | Können beliebige modale Dialogfelder verwenden.
Können nicht auf die Win32-API zugreifen. | Können auf die Win32-API zugreifen.
Können keine frühe Bindung verwenden. | Können eine frühe Bindung für eine höhere Laufzeitleistung verwenden.


Erweiterung mit AddIns

Erweiterung mit AddIns

SpeedCommander lässt sich mit AddIns beliebig erweitern. Ein AddIn ist ein Inprozess-COM-Server und kann mit jeder Programmiersprache erstellt werden, die COM-Komponenten erzeugen kann. Dazu gehören u.a. Visual C++, Delphi, Visual Basic und Visual Studio.NET. Das AddIn kann über das Objektmodell auf viele Elemente innerhalb von SpeedCommander zugreifen.

SpeedCommander und das AddIn kommunizieren über festgelegte Schnittstellen miteinander. Eine Schnittstelle, deren Name mit IDT beginnt (z.B. IDTCommandTarget), wird vom AddIn implementiert. Alle anderen Schnittstellen (z.B. IFileOpProgress) werden von SpeedCommander implementiert.

Folgende Schnittstellen können vom AddIn implementiert werden:

Schnittstelle | Beschreibung
IDTExtensibility2 | Basisschnittstelle, die von jedem AddIn implementiert werden muss.
IDTCommandTarget | Auswahl eines Menübefehls oder Klick auf eine Schaltfläche in der Symbolleiste.
IDTFileSystem | Abfrage der verfügbaren Dateisystemobjekte.
IDTFileSystemSite | Schnittstelle für Dateisystemobjekte, die im Fenster Dateisystem-AddIns angezeigt werden.
IDTFileSystemItem | Datei oder Ordner innerhalb eines Dateisystemobjektes.
IDTContextMenu | Erweiterung des Kontextmenüs für Dateisystemobjekte.
IDTConfigDialog | Einstellungsdialog für das AddIn.

Registrierung eines AddIns

Das AddIn muss als COM-Objekt registriert werden, bevor es verwendet werden kann. Die Registrierung kann entweder in der Funktion DllRegisterServer erfolgen, die beim Hinzufügen des AddIns über den Einstellungsdialog Anpassen aufgerufen wird oder (falls das AddIn die Funktion DllRegisterServer nicht exportiert) manuell durch eine vom Hersteller des AddIns erstellte REG-Datei.

Zusätzlich zur COM-Registrierung muss das AddIn sich auch als Erweiterungskomponente für SpeedCommander registrieren. Dies erfolgt durch einen Schlüssel, wobei {CLSID_ADDIN} stellvertretend für die CLSID des AddIns steht:

[HKEY_CLASSES_ROOT\CLSID\{CLSID_ADDIN}\Implemented Categories\{C9B33781-A4F1-11D8-ACBB-000C6E33EB97}].

Weiterhin sollte das AddIn im Schlüssel {CLSID_ADDIN} folgende Werte definieren:

Wert | Beschreibung
FriendlyName | Benutzerfreundliche Bezeichnung für das AddIn.
Description | Beschreibung für das AddIn.

AddIn installieren

Ein AddIn muss installiert und aktiviert werden, bevor es von SpeedCommander verwendet werden kann. Die Verwaltung der AddIns erfolgt über die Registerkarte AddIns des Einstellungsdialogs Anpassen.

So installieren Sie ein AddIn:
  1. Öffnen Sie den Einstellungsdialog Anpassen und wechseln Sie auf die Registerkarte AddIns.
  2. Wählen Sie Hinzufügen, um ein neues AddIn zu installieren und wählen Sie das AddIn aus.
  3. SpeedCommander versucht nun, das AddIn zu registrieren. Wenn er die dafür nötigen Funktionen nicht findet, wird eine Fehlermeldung ausgegeben.

AddIn deinstallieren

Wenn Sie ein AddIn nicht mehr einsetzen möchten, dann können Sie es ganz einfach deinstallieren.

So deinstallieren Sie ein AddIn:
  1. Öffnen Sie den Einstellungsdialog Anpassen und wechseln Sie auf die Registerkarte AddIns.
  2. Wählen Sie das AddIn, welches Sie deinstallieren möchten.
  3. Klicken Sie auf die Schaltfläche Entfernen.

Weitere Informationen

IDTExtensibility2, IDTCommandTarget, IDTFileSystem, IDTFileSystemSite, IDTFileSystemItem


IDTExtensibility2

IDTExtensibility2

Die Schnittstelle IDTExtensibility2 ist die Basisschnittstelle, die ein AddIn anbieten muss. Wenn ein AddIn geladen wird, sucht SpeedCommander nach IDTExtensibility2. Schlägt die Suche fehl, dann wird das AddIn wieder entladen. Bei erfolgreicher Suche kommuniziert SpeedCommander über diese Schnittstelle mit dem AddIn.

Methoden

OnConnection | Wird aufgerufen, wenn das AddIn mit SpeedCommander verbunden wird.
OnDisconnection | Wird aufgerufen, bevor die Verbindung zu SpeedCommander getrennt wird.
OnStartupComplete | Wird aufgerufen, wenn der Startvorgang von SpeedCommander abgeschlossen wurde.
OnBeginShutdown | Wird aufgerufen, bevor SpeedCommander beendet wird.
OnAddInsUpdate | Wird aufgerufen, wenn ein AddIn geladen oder entladen wurde.

Siehe auch

IDTExtensibility2, IDTCommandTarget


IDTCommandTarget

IDTCommandTarget

Mit IDTCommandTarget kann das AddIn auf den Aufruf eigener Befehle reagieren, die es über das AddInCommands-Objekt erstellt hat. IDTCommandTarget wird vom AddIn zusätzlich zu IDTExtensibility2 implementiert.

Methoden

Exec | Führt den angegebenen Befehl aus.
QueryStatus | Gibt den aktuellen Status für den angegebenen Befehl zurück.

IDTExtensibility2


IDTConfigDialog

IDTConfigDialog

Mit IDTConfigDialog kann das AddIn einen eigenen Einstellungsdialog anzeigen. IDTConfigDialog wird vom AddIn zusätzlich zu IDTExtensibility2 implementiert.

Methoden

ShowConfigDialog Ruft den Konfigurationsdialog auf.

IDTExtensibility2


IDTContextMenu

IDTContextMenu

Mit IDTContextMenu kann ein AddIn dem Kontextmenü für Dateisystemerweiterungen eigene Befehle hinzufügen.

Methoden

QueryContextMenu | Erweitert das Kontextmenü um eigene Befehle.
InvokeCommand | Führt den ausgewählten Befehl aus.

IDTFileSystemSite


IDTFileSystem

IDTFileSystem

Mit IDTFileSystem kann ein AddIn eigene Dateisysteme implementieren. IDTFileSystem wird vom AddIn zusätzlich zu IDTExtensibility2 implementiert.

Ein Dateisystemobjekt besteht aus einer IDTFileSystemSite-Schnittstelle, die vom AddIn implementiert werden muss. SpeedCommander zeigt alle Dateisystemobjekte im Fenster Dateisystem-AddIns an. Dazu wird jedes AddIn gefragt, ob es die IDTFileSystem-Schnittstelle unterstützt. Wenn ja, ruft SpeedCommander die Funktion IDTFileSystem::GetFileSystemSites auf, in der alle vom AddIn angebotenen IDTFileSystemSite-Objekte in eine Liste eingetragen werden.

Nach erfolgreicher Abfrage erfolgt dann die Kommunikation zwischen SpeedCommander und den Dateisystemobjekten über die IDTFileSystemSite-Schnittstelle. Das Dateisystemobjekt kann auch eigene Spalten für die Listenansicht definieren sowie vordefinierte Spalten ausblenden.

Methoden

GetFileSystemSites Wird aufgerufen, um die vom AddIn angebotenen Dateisystemobjekte abzufragen.

IDTExtensibility2, IDTFileSystemSite


IDTFileSystemSite

IDTFileSystemSite

Mit Hilfe der IDTFileSystemSite-Schnittstelle kann ein AddIn ein virtuelles Dateisystem anbieten. Alle Objekte, die IDTFileSystemSite implementieren, werden im Dateisystem-AddIns-Fenster angezeigt. Die Navigation in SpeedCommander innerhalb der AddIns erfolgt durch eine URL in der Form AddIn://HostName/Ordner1/Datei. Der HostName wird durch das AddIn festgelegt und sollte möglichst eindeutig sein. Alle Pfadangaben werden in der Form \Ordner1\Datei an IDTFileSystemSite übergeben.

Jedes Dateisystem kann eigene zusätzliche Spalten für die Detailansicht implementieren. SpeedCommander speichert die jeweilige Spaltenanordnung selbständig, das AddIn muss nur Informationen über die angebotenen Spalten liefern.

Es ist auch möglich, für verschiedene Ordner unterschiedliche Spalten anzuzeigen, z.B. getrennt für den Hauptordner und für alle anderen Unterordner. Als Unterscheidung wird hier die Spalten-ID verwendet, die über GetColumnID abgefragt wird. Die Spaltenanordnung wird unter GUID:ColumnID gespeichert und bei jedem Wechsel in einen Ordner entsprechend der letzten Konfiguration wiederhergestellt.

Eigenschaften

Capabilities | Legt die Fähigkeiten des AddIns fest.
Comment | Gibt einen Kommentar für das Dateisystem-Objekt zurück. Der Kommentar wird in der Dateisystem-AddIn-Ansicht angezeigt.
Guid | Gibt eine eindeutige Kennzeichnung für das Dateisystem-Objekt zurück (GUID).
HostName | Gibt den Namen für das Dateisystem-Objekt zurück.
Image | Gibt das Symbol zurück, welches SpeedCommander für das Dateisystem-Objekt anzeigen soll.

Methoden

CreateDirectory | Erstellt einen Ordner.
DeleteFile | Löscht eine Datei.
DownloadFile | Kopiert eine Datei vom AddIn-Dateisystem in das lokale Dateisystem oder in einen UNC-Pfad.
EnumObjects | Listet alle Elemente auf, die sich in einem Ordner befinden.
ExecCommand | Führt einen Befehl aus der Kommandozeile aus.
FileOpStatusInfo | Wird aufgerufen, wenn eine Dateioperation gestartet oder beendet wird.
GetColumnID | Legt die Spalten-ID für einen Ordner fest.
GetColumnInfo | Zählt die Spalten auf, die SpeedCommander für einen Ordner anzeigen soll.
GetCurrentDirectory | Gibt den aktuellen Ordner zurück.
GetDefaultColumns | Gibt an, welche Spalten bei der ersten Initialisierung einer Ansicht aktiviert werden sollen.
GetTargetFileName | Gibt den Zieldateinamen vor einer Dateioperation (UploadFile/DownloadFile) zurück.
GetUIObjectOf | Erstellt ein UI-Objekt für die angegebenen Dateien und Ordner.
GetVolumeInformation | Gibt Informationen zum Laufwerksstatus zurück.
MoveFile | Verschiebt eine Datei oder einen Ordner bzw. nennt eine Datei oder einen Ordner um.
RemoveDirectory | Entfernt einen Ordner.
SetCurrentDirectory | Setzt den aktuellen Ordner.
SetFileAttributes | Setzt die Attribute für eine Datei oder einen Ordner.
SetFileTime | Setzt Datum und Uhrzeit für eine Datei oder einen Ordner.
UploadFile | Kopiert eine Datei vom lokalen Dateisystem oder einem UNC-Pfad in das AddIn-Dateisystem.

IDTFileSystemItem


IDTFileSystemItem

IDTFileSystemItem

Ein IDTFileSystemItem liefert alle Informationen über einen Eintrag im Dateisystem des AddIns.

Eigenschaften

Name | Gibt den Namen der Datei oder des Ordners zurück.
Attributes | Gibt die Dateiattribute zurück.
DateCreated | Gibt den Zeitpunkt der Erstellung zurück.
DateLastAccessed | Gibt den Zeitpunkt des letzten Zugriffs zurück.
DateLastModified | Gibt den Zeitpunkt der letzten Änderung zurück.
Size | Gibt die Größe der Datei zurück.
Image | Gibt den Index des Symbols in der Systemimageliste zurück.

Methoden

GetItemData Liefert erweiterte Informationen für zusätzliche Spalten.

IDTFileSystemSite


Objektreferenz

Objektreferenz

Jedes SpeedCommander-Objekt implementiert eine duale Schnittstelle, über die Sie das Objekt bearbeiten können. Die duale Schnittstelle besteht aus einer IDispatch-Schnittstelle für die Automatisierung und einer COM-Schnittstelle für den direkten Zugriff auf die Objektelemente (Eigenschaften, Methoden und Ereignisse).

Makros nutzen die IDispatch-Schnittstelle, während AddIns unter Verwendung der COM-Schnittstelle eine frühe Bindung eingegen können. Frühes Binden beschleunigt zur Laufzeit alle Aufrufe in Schnittstellenelemente.

Übersicht über die Objekte von SpeedCommander

AddIn | Einzelnes AddIn.
AddInCommand | Einzelner Befehl eines AddIns.
AddInCommands | Auflistung aller AddIn-Befehle.
AddIns | Auflistung aller AddIns.
AddInSettings | Laden und Speichern von Einstellungen für AddIns.
AppFolder | Ordner innerhalb eines Ordnerfensters.
Application | SpeedCommander-Anwendung.
CommandBar | Einzelne Symbolleiste.
CommandBarControl | Einzelnes Symbol oder Menübefehl.
CommandBarControls | Auflistung aller Symbole oder Menübefehle in einer Symbolleiste.
CommandBars | Auflistung des Menüs und aller anderen Symbolleisten.
FileContainer | Einzelne Dateiablage.
FileContainers | Auflistung aller Dateiablagen im rechten oder linken Teil des Arbeitsbereiches.
FolderFavorite | Einzelner Ordnerfavorit.
FolderFavorites | Auflistung aller Ordnerfavoriten.
FolderWindow | Einzelnes Ordnerfenster.
FolderWindows | Auflistung aller Ordnerfenster im rechten oder linken Teil des Arbeitsbereiches.
ListItem | Einzelner Eintrag in einem Ordnerfenster oder in einer Dateiablage.
ListItems | Auflistung aller Einträge in einem Ordnerfenster oder in einer Dateiablage.
ListSelection | Auswahl in einem Ordnerfenster oder in einer Dateiablage.
MainWindow | Hauptfenster von SpeedCommander.
MultiRename | Umbenennen von mehreren Dateien.
TabWindow | Linkes oder rechtes Fenster in der Zweifenster-Ansicht.
UserTool | Einzelner Anwendungsfavoriten.
UserTools | Auflistung aller Anwendungsfavoriten.
Workspace | Arbeitsbereich, welcher die Zweifenster-Ansicht, die Laufwerkssymbole und die QuickDrop-Symbole einschließt.

Die Objekthierarchie von SpeedCommander für die Automatisierung

Um SpeedCommander-Objekte zu bearbeiten, müssen Sie die Beziehungen zwischen den Objekten kennen. Das Application-Objekt ist das höchstrangige Objekt, dem alle anderen Objekte untergeordnet sind. Dies ermöglicht es, durch Verwendung der Eigenschaften und Methoden des Objekts Application direkt auf Objekte zuzugreifen, die dem Application-Objekt untergeordnet sind.

Jedes Objekt hat zudem die Eigenschaft Parent, welche stets auf das übergeordnete Objekt verweist, und die Eigenschaft Application, die immer auf das Application-Objekt zurückführt.

Die Beziehungen zwischen den Objekten ist nachfolgend dargestellt.

Application
  MainWindow
  CommandBars
    CommandBar
      CommandBarControls
        CommandBarControl
  Workspace
    TabWindow
      FolderWindows
        FolderWindow
          ListSelection
          ListItems
            ListItem
      FileContainers
        FileContainer
          ListSelection
          ListItems
            ListItem
  AddIns
    AddIn
    AddInSettings
  UserTools
    UserTool
  FolderFavorites
    FolderFavorite
  MultiRename


AddIn-Objekt

AddIn-Objekt

Das AddIn-Objekt enthält alle Informationen über ein AddIn und ermöglicht so anderen AddIns, mit ihm zu kommunizieren. Über die Eigenschaft Connect kann das AddIn aktiviert oder deaktiviert werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das AddIns-Objekt.
Connect | Gibt den Aktivierungszustand des AddIns an oder legt ihn fest.
Description | Gibt eine Beschreibung für das AddIn zurück.
Guid | Gibt die Guid (Klassenbezeichnung) des AddIns zurück.
ProgID | Gibt die ProgID des AddIns zurück.
Extensibility2 | Gibt einen Verweis auf die Basisschnittstelle des AddIns zurück.

AddIns-Objekt


AddInCommand-Objekt

AddInCommand-Objekt

Das AddInCommand-Objekt repräsentiert einen von einem AddIn erstellten Befehl. Die verfügbaren AddIn-Befehle werden im Einstellungsdialog Anpassen verwaltet, sie können von dort aus in Symbolleisten oder Menüs integriert werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das AddInCommands-Objekt.
CommandID | Gibt die Befehls-ID zurück.
Description | Gibt die Beschreibung des Befehls zurück oder legt sie fest.
ImageLarge | Legt das große Symbol (24x24) für diesen Befehl fest, welches in der Symbolleiste angezeigt wird.
ImageSmall | Legt das kleine Symbol (16x16) für diesen Befehl fest, welches in der Symbolleiste oder im Menü angezeigt wird.
Name | Gibt den Namen des Befehls zurück.
ProgID | Gibt die ProgID des AddIns zurück, welches das AddInCommand-Objekt erstellt hat.

AddInCommands-Objekt


AddInCommands-Objekt

AddInCommands-Objekt

Das AddInCommands-Objekt enthält eine Liste der Befehle, die von den AddIns zur Verfügung gestellt werden. Mit seiner Hilfe können neue Befehle hinzugefügt oder nicht mehr benötigte Befehle gelöscht werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das AddIns-Objekt.
Count | Gibt die Anzahl der verfügbaren Befehle zurück.

Methoden

Add | Erstellt einen neuen Befehl.
Item | Gibt eine bestimmtes Objekt (AddInCommand-Objekt) innerhalb der Auflistung zurück.
Remove | Löscht einen Befehl.

AddIns-Objekt, AddInCommand-Objekt


AddIns-Objekt

AddIns-Objekt

Das AddIns-Objekt enthält eine Liste der installierten AddIns. Ein AddIn kann so überprüfen, ob andere AddIns installiert sind oder mit anderen AddIns kommunizieren.

Eigenschaften

Application | Gibt einen Verweis auf das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Commands | Gibt ein AddInCommands-Objekt zurück, welches die Befehle der AddIns enthält.
Count | Gibt die Anzahl der installierten AddIns zurück.
Settings | Gibt ein AddInSettings-Objekt zurück, welches zum Speichern von Einstellungen genutzt werden kann.

Methoden

Item | Gibt eine bestimmtes Objekt (AddIn-Objekt) innerhalb der Auflistung zurück.
Update | Aktualisiert die AddIn-Liste.

Siehe auch

AddIn-Objekt, AddInCommands-Objekt, AddInSettings-Objekt, Application-Objekt


AddInSettings-Objekt

AddInSettings-Objekt

Das AddInSettings-Objekt wird von einem AddIn zum Laden und Speichern von Einstellungen genutzt. Alle Einstellungen werden in der XML-Datei von SpeedCommander abgelegt.

Eigenschaften

Application | Gibt einen Verweis auf das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das AddIns-Objekt.

Methoden

EmptySection | Löscht eine Sektion.
Read | Liest eine AddIn-Einstellung.
SaveSettings | Schreibt alle gespeicherten Einstellungen in die XML-Datei.
Write | Speichert eine AddIn-Einstellung.

AddIns-Objekt


AppFolder-Objekt

AppFolder-Objekt

Das AppFolder-Objekt ermöglicht die Abfrage und das Setzen des aktuellen Ordners in einem Ordnerfenster.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
DisplayName | Gibt den Anzeigenamen des Ordners zurück.
Folder | Gibt den vollständigen Ordnernamen zurück oder setzt ihn.
FolderType | Gibt den Typ des Ordners zurück.
IsAddInSite | Gibt an, ob der Ordner die oberste Ebene in der AddIn-Dateisystemansicht ist.
IsArchive | Gibt an, ob der Ordner ein Archiv ist.
IsFtpSite | Gibt an, ob der Ordner die FTP-Standortansicht ist.
IsRoot | Gibt an, ob der Ordner ein Hauptverzeichnis ist.
LocalOrUncFolder | Gibt den vollständigen Ordnernamen zurück, wenn der Ordner ein lokaler Ordner oder ein Netzwerkordner ist.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das FolderWindow-Objekt.
UrlHostName | Gibt den Namen des Servers zurück, wenn der Ordner eine Internet- oder AddIn-Adresse ist.
UrlPath | Gibt den Pfadanteil zurück, wenn der Ordner eine Internet- oder AddIn-Adresse ist.

Methoden

FolderWindow-Objekt


Application-Objekt

Application-Objekt
Das Application-Objekt ist das oberste Objekt im SpeedCommander-Objektmodell. Ausgehend vom Application-Objekt können Sie auf alle anderen Objekte zugreifen.

Eigenschaften

AppDataFolder | Gibt den Pfad zurück, in dem die Einstellungen gespeichert werden.
FullName | Gibt den vollständigen Dateinamen der Anwendung zurück.
LocaleID | Gibt die Sprache der Benutzeroberfläche zurück.
Name | Gibt den Namen der Anwendung zurück.
Path | Gibt den Pfad zurück, in dem die Anwendung installiert ist.
Version | Gibt die Versionsnummer vom SpeedCommander zurück.

Methoden

AddImage | Fügt das angegebene Symbol zur Systemimageliste hinzu.
ExecuteCommand | Führt den angegebenen Befehl aus.
GetEvents | Ermöglicht den Zugriff auf alle Ereignisse des Erweiterungsmodells.
GetObject | Gibt ein bestimmtes Objekt zurück.
Help | Zeigt die Onlinehilfe an.
Quit | Beendet die Anwendung.

Siehe auch

AddIns-Objekt, Workspace-Objekt, FolderFavorites-Objekt, MainWindow-Objekt, UserTools-Objekt


CommandBar-Objekt

CommandBar-Objekt

Das CommandBar-Objekt stellt eine Symbolleiste in SpeedCommander dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das CommandBars-Objekt.
BarID | Gibt die eindeutige ID der Symbolleiste zurück.
BarType | Gibt den Typ der Symbolleiste zurück.
BuiltIn | Gibt an, ob die Symbolleiste eine fest eingebaute Symbolleiste ist.
Controls | Gibt eine Auflistung von Elementen (CommandBarControls-Objekt) in der Symbolleiste zurück.
Position | Setzt die Position der Symbolleiste oder gibt diese zurück.
Title | Setzt den Titel der Symbolleiste oder gibt diesen zurück.
Visible | Setzt die Sichtbarkeit der Symbolleiste oder gibt diese zurück.
Width | Setzt die Breite der Symbolleiste oder gibt diese zurück.

Methoden

Delete | Löscht eine Symbolleiste.
EnableDocking | Legt fest, ob und wie eine Symbolleiste angedockt werden kann.
FindControl | Sucht ein Element (CommandBarControl-Objekt) in der Symbolleiste.

Siehe auch

CommandBar-Objekt, CommandBarControl-Objekt, CommandBarControls-Objekt


CommandBarControl-Objekt

CommandBarControl-Objekt

Das CommandBarControl-Objekt stellt ein Element in einer Symbolleiste dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das CommandBar-Objekt.
BeginGroup | Gibt an, ob das Element der Beginn einer neuen Gruppe ist.
Caption | Setzt den Text für das Element oder gibt ihn zurück.
Checked | Gibt an, ob das Element gewählt ist.
CmdId | Gibt die Befehls-ID des Elements zurück.
CommandBar | Gibt das CommandBar-Objekt für untergeordnete Elemente zurück.
Controls | Gibt ein CommandBarControls-Objekt zurück, welches die benachbarten Elemente enthält.
ControlType | Gibt den Typ des Elements zurück.
DefaultItem | Gibt an, ob das Element das Standardelement im Menü ist.
Description | Setzt den Beschreibungstext für das Element oder gibt ihn zurück.
Enabled | Gibt an, ob das Element aktiv oder deaktiviert ist.
IconId | Gibt die ID des Icons zurück, welches für das Element gezeichnet werden soll, oder legt sie fest.
Index | Gibt den Index des Elements in der CommandBarControls-Auflistung zurück.
Tooltip | Setzt den Text für ein anzuzeigendes InfoTip-Fenster oder gibt ihn zurück.
Visible | Gibt an oder legt fest, ob das Element sichtbar ist.

Methoden

Delete Löscht das Element.

CommandBar-Objekt, CommandBarControls-Objekt


CommandBarControls-Objekt

CommandBarControls-Objekt

Das CommandBarControls-Objekt stellt eine Auflistung dar, die alle CommandBarControl-Objekte innerhalb einer Symbolleiste enthält.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das CommandBar-Objekt.
Count | Gibt die Anzahl der Elemente zurück.

Methoden

Add | Erstellt ein neues Objekt und fügt es in die Symbolleiste ein.
FindControl | Sucht ein Element (CommandBarControl-Objekt) in der Auflistung.
Item | Gibt ein bestimmtes Objekt (CommandBarControl-Objekt) innerhalb der Auflistung zurück.

CommandBarControl-Objekt, CommandBar-Objekt


CommandBars-Objekt

CommandBars-Objekt

Das CommandBars-Objekt enthält alle CommandBar-Objekte innerhalb von SpeedCommander, von denen jedes eine Symbolleiste darstellt.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Count | Gibt die Anzahl der Symbolleisten zurück.

Methoden

Add | Erstellt eine neue Symbolleiste.
Item | Gibt eine bestimmte Symbolleiste (CommandBar-Objekt) innerhalb der Auflistung zurück.

Siehe auch

CommandBar-Objekt, CommandBarControl-Objekt, CommandBarControls-Objekt


FileContainer-Objekt

FileContainer-Objekt

Das FileContainer-Objekt ermöglicht den Zugriff auf eine Dateiablage.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das FileContainers-Objekt.
FocusedItem | Gibt den fokussierten Eintrag zurück oder legt ihn fest.
Index | Gibt den Index des Objekts innerhalb der FileContainers-Auflistung zurück.
IsVisible | Gibt an, ob die Dateiablage sichtbar ist.
Items | Gibt die Objekte einer Dateiablage in einer ListItems-Aufzählung zurück.
Name | Setzt den Namen der Dateiablage oder gibt ihn zurück.
SelectedItems | Gibt die ausgewählten Objekte einer Dateiablage in einer ListItems-Aufzählung zurück.
Selection | Gibt ein ListSelection-Objekt zum Auswählen von Objekten in der Dateiablage zurück.

Methoden

Close | Schließt die Dateiablage.
MoveLeft | Verschiebt die Dateiablage in der FileContainers-Auflistung um eine Position nach links.
MoveRight | Verschiebt die Dateiablage in der FileContainers-Auflistung um eine Position nach rechts.

FileContainers-Objekt, ListSelection-Objekt


FileContainers-Objekt

FileContainers-Objekt

Das FileContainers-Objekt ermöglicht den Zugriff auf einzelne Dateiablagen des linken oder rechten Fensters.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das TabWindow-Objekt.
Active | Gibt ein FileContainer-Objekt für die aktive Dateiablage zurück.
Count | Gibt die Anzahl der Dateiablagen zurück.
IsVisible | Gibt an, ob die Dateiablagen sichtbar sind.

Methoden

Activate | Aktiviert die Dateiablagen.
Add | Erstellt eine neue Dateiablage.
CloseAll | Entfernt alle Dateiablagen bis auf die aktive Dateiablage.
Item | Gibt eine bestimmte Dateiablage (FileContainer-Objekt) innerhalb der Auflistung zurück.

TabWindow-Objekt, FileContainer-Objekt


FolderFavorite-Objekt

FolderFavorite-Objekt

Das FolderFavorite-Objekt stellt einen einzelnen Ordnerfavoriten dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das FolderFavorites-Objekt.
CmdId | Gibt die Befehls-ID des Ordnerfavoriten zurück.
Folder | Setzt den Namen des Ordners, in den im aktiven Fenster gewechselt werden soll, oder gibt ihn zurück.
Folder2 | Setzt den Namen des Ordners, in den im inaktiven Fenster gewechselt werden soll, oder gibt ihn zurück.
Index | Gibt den Index des Ordnerfavoriten innerhalb des FolderFavorites-Objekts zurück.
IsFavorite | Gibt an, ob der Eintrag ein Ordnerfavorit ist.
IsSeparator | Gibt an, ob der Eintrag ein Trennzeichen ist.
IsSubMenu | Gibt an, ob der Eintrag ein Untermenü ist.
IsSubMenuEnd | Gibt an, ob der Eintrag der Abschluss eines Untermenüs ist.
Name | Setzt den Anzeigenamen des Ordnerfavoriten oder gibt ihn zurück.

Methoden

Invoke | Aktiviert den Ordnerfavoriten.
Remove | Löscht den Ordnerfavoriten.

FolderFavorites-Objekt


FolderFavorites-Objekt

FolderFavorites-Objekt

Mit Hilfe des FolderFavorites-Objekts erfolgt der Zugriff auf die Ordnerfavoriten.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Count | Gibt die Anzahl der Ordnerfavoriten-Einträge zurück.

Methoden

Add | Fügt dem Ordnerfavoriten-Menü einen neuen Ordnerfavoriten hinzu.
AddMenu | Fügt dem Ordnerfavoriten-Menü ein neues Untermenü hinzu.
AddSeparator | Fügt dem Ordnerfavoriten-Menü ein Trennzeichen an.
Item | Gibt einen bestimmten Ordnerfavoriten (FolderFavorite-Objekt) innerhalb der Auflistung zurück.
RemoveAll | Entfernt alle Ordnerfavoriten-Einträge.
Save | Speichert die Änderungen an den Ordnerfavoriten.


FolderWindow-Objekt

FolderWindow-Objekt

Das FolderWindow-Objekt ermöglicht den Zugriff auf ein einzelnes Ordnerfenster.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das FolderWindows-Objekt.
BaseFolder | Setzt den Basisordner für das Ordnerfenster oder fragt ihn ab.
FocusedItem | Gibt den fokussierten Eintrag zurück oder legt ihn fest.
Folder | Gibt ein AppFolder-Objekt für den aktuellen Ordner zurück.
GroupView | Aktiviert bzw. deaktiviert die Gruppenansicht oder fragt sie ab.
Index | Gibt den Index des Objekts innerhalb der FolderWindows-Auflistung zurück.
IsVisible | Gibt an, ob das Ordnerfenster sichtbar ist.
Items | Gibt die Objekte im Ordnerfenster in einer ListItems-Aufzählung zurück.
ListView | Setzt den Modus für die Listenansicht oder fragt ihn ab.
Name | Setzt den Namen des Ordnerfensters oder gibt ihn zurück.
SelectedItems | Gibt die ausgewählten Objekte im Ordnerfenster in einer ListItems-Aufzählung zurück.
Selection | Gibt ein ListSelection-Objekt zum Auswählen von Objekten im Ordnerfenster zurück.
Splitter1 | Setzt die Splitterposition zwischen Listenansicht und Baumansicht bzw. fragt sie ab.
Splitter2 | Setzt die Splitterposition zwischen Listenansicht und Statusfenster bzw. fragt sie ab.
StatusWindow | Aktiviert oder deaktiviert das Statusfenster.
TabProperties | Setzt verschiedene Registerkarten-Eigenschaften für das Ordnerfenster oder fragt sie ab.
TreeView | Aktiviert oder deaktiviert die Baumansicht.

Methoden

Activate | Aktiviert das Ordnerfenster.
Close | Schließt das Ordnerfenster.
MoveLeft | Verschiebt das Ordnerfenster in der FolderWindows-Auflistung um eine Position nach links.
MoveRight | Verschiebt das Ordnerfenster in der FolderWindows-Auflistung um eine Position nach rechts.
Refresh | Aktualisiert das Ordnerfenster.

ListItems-Objekt, FolderWindows-Objekt


FolderWindows-Objekt

FolderWindows-Objekt

Das FolderWindows-Objekt ermöglicht den Zugriff auf einzelne Ordnerfenster des linken oder rechten Fensters.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das TabWindow-Objekt.
Active | Gibt ein FolderWindow-Objekt für das aktive Ordnerfenster zurück.
Count | Gibt die Anzahl der Ordnerfenster zurück.
IsVisible | Gibt an, ob die Ordnerfenster sichtbar sind.

Methoden

Activate | Aktiviert die Ordnerfenster.
Add | Erstellt ein neues Ordnerfenster.
CloseAll | Entfernt alle Ordnerfenster bis auf das aktive Ordnerfenster.
Item | Gibt ein bestimmtes Ordnerfenster (FolderWindow-Objekt) innerhalb der Auflistung zurück.

TabWindow-Objekt, FolderWindow-Objekt


ListItem-Objekt

ListItem-Objekt

Das ListItem-Objekt stellt einen einzelnen Eintrag in einem Ordnerfenster oder in einer Dateiablage dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das ListItems-Objekt.
Attributes | Gibt die Dateiattribute zurück.
DateCreated | Gibt das Datum zurück, an dem die Datei oder der Ordner erstellt wurde.
DateLastAccessed | Gibt das Datum zurück, an dem auf die Datei oder den Ordner zuletzt zugegriffen wurde.
DateLastModified | Gibt das Datum zurück, an dem die Datei oder der Order zuletzt geändert wurde.
FileName | Gibt den relativen Dateinamen (ohne Pfad) zurück.
Folder | Gibt den Ordner zurück.
PathName | Gibt den vollständigen Dateinamen zurück.
Selected | Setzt den Auswahlzustand eines Eintrags oder gibt ihn zurück.
ShortFileName | Gibt den relativen Dateinamen (ohne Pfad) in 8.3-Konvention zurück.
ShortPathName | Gibt den vollständigen Dateinamen in 8.3-Konvention zurück.
Size | Gibt die Größe der Datei zurück.

Methoden

ListItems-Objekt


ListItems-Objekt

ListItems-Objekt

Das ListItems-Objekt enthält alle Objekte in einem Ordnerfenster oder in einer Dateiablage.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt einen Verweis auf das Elternobjekt zurück.
Count | Gibt die Anzahl der Einträge zurück.

Methoden

Item Gibt einen Eintrag (ListItem-Objekt) innerhalb der Auflistung zurück.

ListItem-Objekt


ListSelection-Objekt

ListSelection-Objekt

Mit Hilfe des ListSelection-Objektes kann die Auswahl in einem Ordnerfenster oder in einer Dateiablage manipuliert werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück.

Methoden

Invert | Invertiert die Auswahl.
Restore | Stellt die zuletzt gespeicherte Auswahl wieder her.
Save | Speichert eine Auswahl.
Select | Wählt Dateien und Ordner anhand einer Maske aus.
SelectAll | Wählt alle Dateien und Ordner aus.
SelectAllFiles | Wählt alle Dateien aus.
Unselect | Entfernt die Auswahl für bestimmte Dateien anhand einer Maske.
UnselectAll | Entfernt die Auswahl für alle Dateien und Ordner.
UnselectAllFiles | Entfernt die Auswahl für alle Dateien.

ListItems-Objekt


MainWindow-Objekt

MainWindow-Objekt

Das MainWindow-Objekt repräsentiert das Hauptfenster im SpeedCommander.

Eigenschaften

Eigenschaft | Beschreibung
Application | Gibt einen Verweis auf das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Caption | Setzt den Fenstertext des Hauptfensters oder gibt diesen zurück.
Height | Gibt die Höhe des Hauptfensters zurück oder legt sie fest.
HWnd | Gibt das Fensterhandle des Hauptfensters zurück.
Left | Gibt den Abstand zwischen dem linken Rand des Bildschirmes und dem linken Rand des Hauptfensters zurück oder legt ihn fest.
Top | Gibt den Abstand zwischen dem oberen Rand des Bildschirmes und dem oberen Rand des Hauptfensters zurück oder legt ihn fest.
Width | Gibt die Breite des Hauptfensters zurück oder legt sie fest.
Visible | Setzt die Sichtbarkeit des Hauptfensters oder gibt diese zurück.

Application-Objekt


MultiRename-Objekt

MultiRename-Objekt

Mit Hilfe des MultiRename-Objekts können Dateien nach bestimmten Kriterien umbenannt werden.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
BaseFolder | Legt den Basisordner fest oder gibt ihn zurück.
CharCase | Legt den Modus für die Groß-/Kleinschreibung fest oder gibt ihn zurück.
DateTime | Legt den Modus für die Datums- und Zeitangaben fest oder gibt ihn zurück.
FileExtToken | Legt das Token für die Dateierweiterung fest oder gibt es zurück.
FileNameToken | Legt das Token für den Dateinamen fest oder gibt es zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
ParentFolder | Legt den Elternordner fest oder gibt ihn zurück.
SearchFor | Legt den zu suchenden Text fest oder gibt ihn zurück.
Replace | Legt den Modus für das Ersetzen von Text fest oder gibt ihn zurück.
ReplaceWith | Legt den Text fest, der den zu suchenden Text ersetzen soll oder gibt ihn zurück.

Methoden

Add | Fügt der aktuellen Auswahl einen Dateinamen oder alle Dateinamen eines ListItems-Objekts hinzu.
RemoveAll | Entfernt alle Dateien aus der Liste der umzubenennenden Dateien.
Rename | Benennt alle Dateien, die sich in der Dateiliste befinden, entsprechend den gewählten Einstellungen um.

Application-Objekt


TabWindow-Objekt

TabWindow-Objekt

Das TabWindow-Objekt repräsentiert das linke oder rechte Fenster in der Zweifenster-Ansicht.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Window-Objekt.
FileContainers | Gibt eine Auflistung der Dateicontainer als FileContainers-Objekt zurück.
FolderWindows | Gibt eine Auflistung der Ordnerfenster als FolderWindows-Objekt zurück.
IsActive | Gibt an, ob das Fenster aktiv ist.
ShowFileContainers | Gibt an, ob die Dateiablagen als Registerkarte angezeigt werden sollen.
SynchronizeFolderWindows | Gibt an, ob die Ordnerfenster untereinander abgeglichen werden sollen.

Methoden

Activate Aktiviert das Fenster.

Siehe auch

Window-Objekt, FolderWindow-Objekt, FolderWindows-Objekt, FileContainer-Objekt, FileContainers-Objekt


UserTool-Objekt

UserTool-Objekt

Das UserTool-Objekt stellt einen einzelnen Anwendungsfavoriten dar.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das UserTools-Objekt.
Arguments | Setzt die Argumente, die der Anwendung beim Start übergeben werden, oder gibt sie zurück.
CmdId | Gibt die Befehls-ID des Anwendungsfavoriten zurück.
Command | Setzt den vollständiger Pfadnamen der Anwendung oder gibt ihn zurück.
Index | Gibt den Index des Anwendungsfavoriten innerhalb des UserTools-Objekts zurück.
InitialDir | Setzt den Startordner der Anwendung oder gibt ihn zurück.
IsSeparator | Gibt an, ob der Eintrag ein Trennzeichen ist.
IsSubMenu | Gibt an, ob der Eintrag ein Untermenü ist.
IsSubMenuEnd | Gibt an, ob der Eintrag ein Abschluss eines Untermenüs ist.
IsUserTool | Gibt an, ob der Eintrag ein Anwendungsfavorit ist.
Name | Setzt den Anzeigenamen des Anwendungsfavoriten oder gibt ihn zurück.
ShowCmd | Setzt den Startmodus der Anwendung oder gibt ihn zurück.
ShortPathNames | Legt fest, dass die der Anwendung übergebenen Objekte im 8.3-Format erfolgen soll.

Methoden

Invoke | Startet den Anwendungsfavoriten.
Remove | Löscht den Anwendungsfavoriten.

UserTools-Objekt


UserTools-Objekt

UserTools-Objekt

Mit Hilfe des UserTools-Objekts erfolgt der Zugriff auf die Anwendungsfavoriten.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
Count | Gibt die Anzahl der Anwendungsfavoriten-Einträge zurück.

Methoden

Add | Fügt dem Anwendungsfavoriten-Menü einen neuen Anwendungsfavoriten hinzu.
AddMenu | Fügt dem Anwendungsfavoriten-Menü ein neues Untermenü hinzu.
AddSeparator | Fügt dem Anwendungsfavoriten-Menü ein Trennzeichen an.
Item | Gibt einen bestimmten Anwendungsfavoriten (UserTool-Objekt) innerhalb der Auflistung zurück.
RemoveAll | Entfernt alle Anwendungsfavoriten-Einträge.
Save | Speichert die Änderungen an den Anwendungsfavoriten.

UserTool-Objekt


Workspace-Objekt

Workspace-Objekt

Das Workspace-Objekt ermöglicht den Zugriff auf den Arbeitsbereich in SpeedCommander. Dazu gehören die beiden Fenster der Zweifenster-Ansicht und das Laufwerksfenster.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Parent | Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.
ActiveWindow | Gibt ein TabWindow-Objekt für das aktive Fenster zurück.
DosCommandWindow | Gibt an oder legt fest, ob das Befehlseingabefenster angezeigt wird.
DosPrompt | Gibt an oder legt fest, ob die Befehlseingabezeile angezeigt wird.
DriveSymbols | Setzt die Ansicht für das Laufwerksfenster oder gibt sie zurück.
FolderLayout | Gibt an, ob die Ordnerfenster nebeneinander oder übereinander angezeigt werden sollen.
InactiveWindow | Gibt ein TabWindow-Objekt für das inaktive Fenster zurück.
Splitter | Setzt die Splitterposition zwischen den beiden Fenstern bzw. fragt sie ab.
Swapped | Gibt an, ob die beiden Fenster getauscht sind. Im Normalfall ist erste Fenster links bzw. oben und zweite Fenster rechts bzw. unten.
TabWindow1 | Gibt ein TabWindow-Objekt für das erste Fenster zurück.
TabWindow2 | Gibt ein TabWindow-Objekt für das zweite Fenster zurück.

Methoden

TabWindow-Objekt


Active (FileContainers-Objekt)

Active (FileContainers-Objekt)

Gibt ein FileContainer-Objekt für die aktive Dateiablage zurück.

[C++]
HRESULT get_Active(
  /*[out, retval]*/ IFileContainer** ppFileContainer
);
[C#]
FileContainer Active {get;}
[Visual Basic .NET]
Public ReadOnly Property Active() As FileContainer
[Delphi]
property Active: IFileContainer read Get_Active;

FileContainers-Objekt, FileContainer-Objekt


Active (FolderWindows-Objekt)

Active (FolderWindows-Objekt)

Gibt ein FolderWindow-Objekt für das aktive Ordnerfenster zurück.

[C++]
HRESULT get_Active(
  /*[out, retval]*/ IFolderWindow** ppFolderWindow
);
[C#]
FolderWindow Active {get;}
[Visual Basic .NET]
Public ReadOnly Property Active() As FolderWindow
[Delphi]
property Active: IFolderWindow read Get_Active;

FolderWindows-Objekt, FolderWindow-Objekt


ActiveWindow (Workspace-Objekt)

ActiveWindow (Workspace-Objekt)

Gibt ein TabWindow-Objekt für das aktive Fenster zurück.

[C++]
HRESULT get_ActiveWindow(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow ActiveWindow {get;}
[Visual Basic .NET]
Public ReadOnly Property ActiveWindow() As TabWindow
[Delphi]
property ActiveWindow: ITabWindow read Get_ActiveWindow;

Workspace-Objekt, TabWindow-Objekt


AppDataFolder (Application-Objekt)

AppDataFolder (Application-Objekt)

Gibt den Pfad zurück, in dem die Einstellungen gespeichert werden.

[C++]
HRESULT get_AppDataFolder(
  /*[out, retval]*/ BSTR* pAppDataFolder
);
[C#]
public string AppDataFolder {get;}
[Visual Basic .NET]
Public ReadOnly Property AppDataFolder() As String
[Delphi]
property AppDataFolder: WideString read Get_AppDataFolder;

Application-Objekt


Arguments (UserTool-Objekt)

Arguments (UserTool-Objekt)

Setzt die Argumente, die der Anwendung beim Start übergeben werden, oder gibt sie zurück. Mehrere Argumente werden durch ein Leerzeichen getrennt.

[C++]
HRESULT get_Arguments(
  /*[out, retval]*/ BSTR* pbstrArguments
);
HRESULT put_Arguments(
  /*[in]*/ BSTR bstrArguments
);
[C#]
string Arguments {get; set;}
[Visual Basic .NET]
Public Property Arguments() As String
[Delphi]
property Arguments: WideString read Get_Arguments write Set_Arguments;

UserTool-Objekt


Attributes (ListItem-Objekt)

Attributes (ListItem-Objekt)

Gibt die Dateiattribute zurück.

[C++]
HRESULT get_Attributes(
  /*[out, retval]*/ long* pAttributes
);
[C#]
int Attributes {get;}
[Visual Basic .NET]
Public ReadOnly Property Attributes() As Integer
[Delphi]
property Attributes: Integer read Get_Attributes;

ListItem-Objekt


BarID (CommandBar-Objekt)

BarID (CommandBar-Objekt)

Gibt die eindeutige ID der Symbolleiste zurück.

[C++]
HRESULT get_BarID(
  /*[out, retval]*/ long* pBarID
);
[C#]
int BarID {get;}
[Visual Basic .NET]
Public ReadOnly Property BarID() As Integer
[Delphi]
property BarID: Integer read Get_BarID;

CommandBar-Objekt


BarType (CommandBar-Objekt)

BarType (CommandBar-Objekt)

Gibt den Typ der Symbolleiste als scCommandBarType-Konstante zurück.

[C++]
HRESULT get_BarType(
  /*[out, retval]*/ enum scCommandBarType* pBarType
);
[C#]
scCommandBarType BarType {get;}
[Visual Basic .NET]
Public ReadOnly Property BarType() As scCommandBarType
[Delphi]
property BarType: scCommandBarType read Get_BarType;

CommandBar-Objekt, scCommandBarType-Konstanten


BaseFolder (FolderWindow-Objekt)

BaseFolder (FolderWindow-Objekt)

Setzt den Basisordner für das Ordnerfenster oder fragt ihn ab.

[C++]
HRESULT get_BaseFolder(
  /*[out, retval]*/ BSTR* pbstrBaseFolder
);
HRESULT put_BaseFolder(
  /*[in]*/ BSTR bstrBaseFolder
);
[C#]
string BaseFolder {get; set;}
[Visual Basic .NET]
Public Property BaseFolder() As String
[Delphi]
property BaseFolder: WideString read Get_BaseFolder write Set_BaseFolder;

FolderWindow-Objekt


BaseFolder (MultiRename-Objekt)

BaseFolder (MultiRename-Objekt)

Legt den Basisordner fest oder gibt ihn zurück.

[C++]
HRESULT get_BaseFolder(
  /*[out, retval]*/ BSTR* pbstrBaseFolder
);
HRESULT put_BaseFolder(
  /*[in]*/ BSTR bstrBaseFolder
);
[C#]
string BaseFolder {get; set;}
[Visual Basic .NET]
Public Property BaseFolder() As String
[Delphi]
property BaseFolder: WideString read Get_BaseFolder write Set_BaseFolder;

MultiRename-Objekt


BeginGroup (CommandBarControl-Objekt)

BeginGroup (CommandBarControl-Objekt)

Gibt an, ob das Element der Beginn einer neuen Gruppe ist.

[C++]
HRESULT get_BeginGroup(
  /*[out, retval]*/ VARIANT_BOOL* pBeginGroup
);
HRESULT put_BeginGroup(
  /*[in]*/ VARIANT_BOOL fBeginGroup
);
[C#]
bool BeginGroup {get; set;}
[Visual Basic .NET]
Public Property BeginGroup() As Boolean
[Delphi]
property BeginGroup: WordBool read Get_BeginGroup write Set_BeginGroup;

CommandBarControl-Objekt


BuiltIn (CommandBar-Objekt)

BuiltIn (CommandBar-Objekt)

Gibt an, ob die Symbolleiste eine fest eingebaute Symbolleiste ist.

[C++]
HRESULT get_BuiltIn(
  /*[out, retval]*/ VARIANT_BOOL* pBuiltIn
);
[C#]
bool BuiltIn {get;}
[Visual Basic .NET]
Public ReadOnly Property BuiltIn() As Boolean
[Delphi]
property BuiltIn: WordBool read Get_BuiltIn;

CommandBar-Objekt


Caption (CommandBarControl-Objekt)

Caption (CommandBarControl-Objekt)

Setzt den Text für das Element oder gibt ihn zurück.

[C++]
HRESULT get_Caption(
  /*[out, retval]*/ BSTR* pbstrCaption
);
HRESULT put_Caption(
  /*[in]*/ BSTR bstrCaption
);
[C#]
string Caption {get; set;}
[Visual Basic .NET]
Public Property Caption() As String
[Delphi]
property Caption: WideString read Get_Caption write Set_Caption;

CommandBarControl-Objekt, CommandBar-Objekt


Caption (MainWindow-Objekt)

Caption (MainWindow-Objekt)

Setzt den Fenstertext des Hauptfensters oder gibt diesen zurück.

[C++]
HRESULT get_Caption(
  /*[out, retval]*/ BSTR* pbstrCaption
);
HRESULT put_Caption(
  /*[in]*/ BSTR bstrCaption
);
[C#]
string Caption {get; set;}
[Visual Basic .NET]
Public Property Caption() As String
[Delphi]
property Caption: WideString read Get_Caption write Set_Caption;

MainWindow-Objekt


CharCase (MultiRename-Objekt)

CharCase (MultiRename-Objekt)

Legt den Modus für die Groß-/Kleinschreibung fest oder gibt ihn zurück.

[C++]
HRESULT get_CharCase(
  /*[out, retval]*/ scMrtCharCase* eCharCase
);
HRESULT put_CharCase(
  /*[in]*/ scMrtCharCase eCharCase
);
[C#]
scMrtCharCase CharCase {get; set;}
[Visual Basic .NET]
Public Property CharCase() As scMrtCharCase
[Delphi]
property CharCase: scMrtCharCase read Get_CharCase write Set_CharCase;

MultiRename-Objekt, scMrtCharCase-Konstanten


Checked (CommandBarControl-Objekt)

Checked (CommandBarControl-Objekt)

Gibt an, ob das Element gewählt ist.

[C++]
HRESULT get_Checked(
  /*[out, retval]*/ VARIANT_BOOL* pChecked
);
HRESULT put_Checked(
  /*[in]*/ VARIANT_BOOL fChecked
);
[C#]
bool Checked {get; set;}
[Visual Basic .NET]
Public Property Checked() As Boolean
[Delphi]
property Checked: WordBool read Get_Checked write Set_Checked;

CommandBarControl-Objekt, CommandBar-Objekt


CmdId (CommandBarControl-Objekt)

CmdId (CommandBarControl-Objekt)

Gibt die Befehls-ID des Elements zurück.

[C++]
HRESULT get_CmdId(
  /*[out, retval]*/ long* pCmdId
);
[C#]
int CmdId {get;}
[Visual Basic .NET]
Public ReadOnly Property CmdId() As Integer
[Delphi]
property CmdId: Integer read Get_CmdId write Set_CmdId;

CommandBarControl-Objekt, CommandBar-Objekt


CmdId (FolderFavorite-Objekt)

CmdId (FolderFavorite-Objekt)

Gibt die Befehls-ID des Ordnerfavoriten zurück.

[C++]
HRESULT get_CmdId(
  /*[out, retval]*/ long* pCmdId
);
[C#]
int CmdId {get;}
[Visual Basic .NET]
Public ReadOnly Property CmdId() As Integer
[Delphi]
property CmdId: Integer read Get_CmdId;

FolderFavorite-Objekt


CmdId (UserTool-Objekt)

CmdId (UserTool-Objekt)

Gibt die Befehls-ID des Anwendungsfavoriten zurück.

[C++]
HRESULT get_CmdId(
  /*[out, retval]*/ long* pCmdId
);
[C#]
int CmdId {get;}
[Visual Basic .NET]
Public ReadOnly Property CmdId() As Integer
[Delphi]
property CmdId: Integer read Get_CmdId;

UserTool-Objekt


Command (UserTool-Objekt)

Command (UserTool-Objekt)

Setzt den vollständiger Pfadnamen der Anwendung oder gibt ihn zurück.

[C++]
HRESULT get_Command(
  /*[out, retval]*/ BSTR* pbstrCommand
);
HRESULT put_Command(
  /*[in]*/ BSTR bstrCommand
);
[C#]
string Command {get; set;}
[Visual Basic .NET]
Public Property Command() As String
[Delphi]
property Command: WideString read Get_Command write Set_Command;

UserTool-Objekt


CommandBar (CommandBarControl-Objekt)

CommandBar (CommandBarControl-Objekt)

Gibt das CommandBar-Objekt für untergeordnete Elemente zurück.

[C++]
HRESULT get_CommandBar(
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
CommandBar CommandBar {get;}
[Visual Basic .NET]
Public ReadOnly Property CommandBar() As CommandBar
[Delphi]
property CommandBar: ICommandBar read Get_CommandBar;

CommandBarControl-Objekt, CommandBar-Objekt


CommandID (AddInCommand-Objekt)

CommandID (AddInCommand-Objekt)

Gibt die Befehls-ID zurück.

[C++]
HRESULT get_CommandID(
  /*[out, retval]*/ long* pCommandID
);
[C#]
int CommandID {get;}
[Visual Basic .NET]
Public ReadOnly Property CommandID() As Integer
[Delphi]
property CommandID: Integer read Get_CommandID;

AddInCommand-Objekt


Commands (AddIns-Objekt)

Commands (AddIns-Objekt)

Gibt ein AddInCommands-Objekt zurück, welches die Befehle der AddIns enthält.

[C++]
HRESULT get_Commands(
  /*[out, retval]*/ IAddInCommands** ppAddInCommands
);
[C#]
AddInCommands Commands {get;}
[Visual Basic .NET]
Public ReadOnly Property Commands() As AddInCommands
[Delphi]
property Commands: IAddInCommands read Get_Commands;

AddIns-Objekt, AddInCommands-Objekt


Connect (AddIn-Objekt)

Connect (AddIn-Objekt)

Gibt den Aktivierungszustand des AddIns an oder legt ihn fest.

[C++]
HRESULT get_Connect(
  /*[out, retval]*/ VARIANT_BOOL* pConnect
);
HRESULT put_Connect(
  /*[in]*/ VARIANT_BOOL fConnect
);
[C#]
bool Connect {get; set;}
[Visual Basic .NET]
Public Property Connect() As Boolean
[Delphi]
property Connect: WordBool read Get_Connect write Set_Connect;

AddIn-Objekt


Controls (CommandBar-Objekt)

Controls (CommandBar-Objekt)

Gibt eine Auflistung von Elementen in der Symbolleiste zurück.

[C++]
HRESULT get_Controls(
  /*[out, retval]*/ ICommandBarControls** ppCommandBarControls
);
[C#]
CommandBarControls Controls {get;}
[Visual Basic .NET]
Public ReadOnly Property Controls() As CommandBarControls
[Delphi]
property Controls: ICommandBarControls read Get_Controls;

CommandBar-Objekt, CommandBarControls-Objekt


Controls (CommandBarControl-Objekt)

Controls (CommandBarControl-Objekt)

Gibt ein CommandBarControls-Objekt zurück, welches die benachbarten Elemente enthält.

[C++]
HRESULT get_Controls(
  /*[out, retval]*/ ICommandBarControls** ppCommandBarControls
);
[C#]
CommandBarControls Controls {get;}
[Visual Basic .NET]
Public ReadOnly Property Controls() As CommandBarControls
[Delphi]
property Controls: ICommandBarControls read Get_Controls;

CommandBarControl-Objekt, CommandBar-Objekt


ControlType (CommandBarControl-Objekt)

ControlType (CommandBarControl-Objekt)

Gibt den Typ des Elements als scCommandBarControlType-Konstante zurück.

[C++]
HRESULT get_ControlType(
  /*[out, retval]*/ enum scCommandBarControlType* pType
);
[C#]
scCommandBarControlType ControlType {get;}
[Visual Basic .NET]
Public ReadOnly Property ControlType() As scCommandBarControlType
[Delphi]
property ControlType: scCommandBarControlType read Get_ControlType;

Siehe auch

CommandBarControl-Objekt, CommandBar-Objekt, scCommandBarControlType-Konstanten


Count (AddInCommands-Objekt)

Count (AddInCommands-Objekt)

Gibt die Anzahl der verfügbaren Befehle zurück.

[C++]
HRESULT get_Count(
  /*[out, retval]*/ long* pCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

AddInCommands-Objekt


Count (AddIns-Objekt)

Count (AddIns-Objekt)

Gibt die Anzahl der installierten AddIns zurück.

[C++]
HRESULT get_Count(
  /*[out, retval]*/ long* pCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

AddIns-Objekt


Count (CommandBarControls-Objekt)

Count (CommandBarControls-Objekt)

Gibt die Anzahl der vorhandenen Elemente innerhalb der Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* plCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

CommandBarControls-Objekt


Count (CommandBars-Objekt)

Count (CommandBars-Objekt)

Gibt die Anzahl der vorhandenen Symbolleisten innerhalb der CommandBars-Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* nCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Long
[Delphi]
property Count: Integer read Get_Count;

CommandBars-Objekt


Count (FileContainers-Objekt)

Count (FileContainers-Objekt)

Gibt die Anzahl der Dateiablagen zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* pnCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

FileContainers-Objekt


Count (FolderFavorites-Objekt)

Count (FolderFavorites-Objekt)

Gibt die Anzahl der vorhandenen Anwendungsfavoriten innerhalb der FolderFavorites-Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* nCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Long
[Delphi]
property Count: Integer read Get_Count;

FolderFavorites-Objekt


Count (FolderWindows-Objekt)

Count (FolderWindows-Objekt)

Gibt die Anzahl der Ordnerfenster zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* pnCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Integer
[Delphi]
property Count: Integer read Get_Count;

FolderWindows-Objekt


Count (ListItems-Objekt)

Count (ListItems-Objekt)

Gibt die Anzahl der Einträge innerhalb der ListItems-Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* nCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Long
[Delphi]
property Count: Integer read Get_Count;

ListItems-Objekt


Count (UserTools-Objekt)

Count (UserTools-Objekt)

Gibt die Anzahl der vorhandenen Anwendungsfavoriten innerhalb der UserTools-Auflistung zurück.

[C++]
HRESULT get_Count(
  [out, retval] long* nCount
);
[C#]
int Count {get;}
[Visual Basic .NET]
Public ReadOnly Property Count() As Long
[Delphi]
property Count: Integer read Get_Count;

UserTools-Objekt


DateCreated (ListItem-Objekt)

Attributes (ListItem-Objekt)

Gibt das Datum zurück, an dem die Datei oder der Ordner erstellt wurde.

[C++]
HRESULT get_DateCreated(
  /*[out, retval]*/ DATE* pDateCreated
);
[C#]
DateTime DateCreated {get;}
[Visual Basic .NET]
Public ReadOnly Property DateCreated() As Date
[Delphi]
property DateCreated: TDateTime read Get_DateCreated;

ListItem-Objekt


DateLastAccessed (ListItem-Objekt)

DateLastAccessed (ListItem-Objekt)

Gibt das Datum zurück, an dem auf die Datei oder den Ordner zuletzt zugegriffen wurde.

[C++]
HRESULT get_DateLastAccessed(
  /*[out, retval]*/ DATE* pDateLastAccessed
);
[C#]
DateTime DateLastAccessed {get;}
[Visual Basic .NET]
Public ReadOnly Property DateLastAccessed() As Date
[Delphi]
property DateLastAccessed: TDateTime read Get_DateLastAccessed;

ListItem-Objekt


DateLastModified (ListItem-Objekt)

DateLastModified (ListItem-Objekt)

Gibt das Datum zurück, an dem die Datei oder der Order zuletzt geändert wurde.

[C++]
HRESULT get_DateLastModified(
  /*[out, retval]*/ DATE* pDateLastModified
);
[C#]
DateTime DateLastModified {get;}
[Visual Basic .NET]
Public ReadOnly Property DateLastModified() As Date
[Delphi]
property DateLastModified: TDateTime read Get_DateLastModified;

ListItem-Objekt


DateTime (MultiRename-Objekt)

DateTime (MultiRename-Objekt)

Legt den Modus für die Datumsangaben fest oder gibt ihn zurück.

[C++]
HRESULT get_DateTime(
  /*[out, retval]*/ scMrtDateTime* eDateTime
);
HRESULT put_DateTime(
  /*[in]*/ scMrtDateTime eDateTime
);
[C#]
scMrtDateTime DateTime {get; set;}
[Visual Basic .NET]
Public Property DateTime() As scMrtDateTime
[Delphi]
property DateTime: scMrtDateTime read Get_DateTime write Set_DateTime;

MultiRename-Objekt, scMrtDateTime-Konstanten


DefaultItem (CommandBarControl-Objekt)

DefaultItem (CommandBarControl-Objekt)

Gibt an, ob das Element das Standardelement im Menü ist.

[C++]
HRESULT get_DefaultItem(
  /*[out, retval]*/ VARIANT_BOOL* pDefaultItem
);
HRESULT put_DefaultItem(
  /*[in]*/ VARIANT_BOOL* fDefaultItem
);
[C#]
bool DefaultItem {get; set;}
[Visual Basic .NET]
Public Property DefaultItem() As Boolean
[Delphi]
property DefaultItem: WordBool read Get_DefaultItem write Set_DefaultItem;

CommandBarControl-Objekt, CommandBar-Objekt


Description (AddIn-Objekt)

Description (AddIn-Objekt)

Gibt eine Beschreibung für das AddIn zurück.

[C++]
HRESULT get_Description(
  /*[out, retval]*/ BSTR* pbstrDescription
);
[C#]
string Description {get;}
[Visual Basic .NET]
Public ReadOnly Property Description() As String
[Delphi]
property Description: WideString read Get_Description;

AddIn-Objekt, AddIns-Objekt


Description (AddInCommand-Objekt)

Description (AddInCommand-Objekt)

Gibt die Beschreibung des Befehls zurück oder legt sie fest.

[C++]
HRESULT get_Description(
  /*[out, retval]*/ BSTR* pbstrDescription
);
HRESULT put_Description(
  /*[in]*/ BSTR bstrDescription
);
[C#]
string Description {get; set;}
[Visual Basic .NET]
Public Property Description() As String
[Delphi]
property Description: WideString read Get_Description write Set_Description;

AddInCommand-Objekt


Description (CommandBarControl-Objekt)

Description (CommandBarControl-Objekt)

Setzt den Beschreibungstext für das Element oder gibt ihn zurück.

[C++]
HRESULT get_Description(
  /*[out, retval]*/ BSTR* pbstrDescription
);
HRESULT put_Description(
  /*[in]*/ BSTR bstrDescription
);
[C#]
string Description {get; set;}
[Visual Basic .NET]
Public Property Description() As String
[Delphi]
property Description: WideString read Get_Description write Set_Description;

CommandBarControl-Objekt, CommandBar-Objekt


DisplayName (AppFolder-Objekt)

DisplayName (AppFolder-Objekt)

Gibt den Anzeigenamen des Ordners zurück.

[C++]
HRESULT get_DisplayName(
  /*[out, retval]*/ BSTR* pbstrDisplayName
);
[C#]
string DisplayName {get;}
[Visual Basic .NET]
Public ReadOnly Property DisplayName() As String
[Delphi]
property DisplayName: WideString read Get_DisplayName;

AppFolder-Objekt


DosCommandWindow (Workspace-Objekt)

DosCommandWindow (Workspace-Objekt)

Gibt an oder legt fest, ob das Befehlsausgabefenster angezeigt wird.

[C++]
HRESULT get_DosCommandWindow(
  /*[out, retval]*/ VARIANT_BOOL* pfDosCommandWindow
);
HRESULT put_DosCommandWindow(
  /*[in]*/ VARIANT_BOOL fDosCommandWindow
);
[C#]
bool DosCommandWindow {get; set;}
[Visual Basic .NET]
Public Property DosCommandWindow() As Boolean
[Delphi]
property DosCommandWindow: WordBool read Get_DosCommandWindow write Set_DosCommandWindow;

Workspace-Objekt


DosPrompt (Workspace-Objekt)

DosPrompt (Workspace-Objekt)

Gibt an oder legt fest, ob die Befehlseingabezeile angezeigt wird.

[C++]
HRESULT get_DosPrompt(
  /*[out, retval]*/ VARIANT_BOOL* pfDosPrompt
);
HRESULT put_DosPrompt(
  /*[in]*/ VARIANT_BOOL fDosPrompt
);
[C#]
bool DosPrompt {get; set;}
[Visual Basic .NET]
Public Property DosPrompt() As Boolean
[Delphi]
property DosPrompt: WordBool read Get_DosPrompt write Set_DosPrompt;

Workspace-Objekt


DriveSymbols (Workspace-Objekt)

DriveSymbols (Workspace-Objekt)

Setzt die Ansicht für das Laufwerksfenster oder gibt sie zurück.

[C++]
HRESULT get_DriveSymbols(
  /*[out, retval]*/ enum scDriveSymbols* peDriveSymbols
);
HRESULT put_DriveSymbols(
  /*[in]*/ enum scDriveSymbols eDriveSymbols
);
[C#]
scDriveSymbols DriveSymbols {get; set;}
[Visual Basic .NET]
Public Property DriveSymbols() As scDriveSymbols
[Delphi]
property DriveSymbols: scDriveSymbols read Get_DriveSymbols write Set_DriveSymbols;

Workspace-Objekt, scDriveSymbols-Konstanten


Enabled (CommandBarControl-Objekt)

Enabled (CommandBarControl-Objekt)

Gibt an, ob das Element aktiv oder deaktiviert ist.

[C++]
HRESULT get_Enabled(
  /*[out, retval]*/ VARIANT_BOOL* pEnabled
);
HRESULT put_Enabled(
  /*[in]*/ VARIANT_BOOL fEnabled
);
[C#]
bool Enabled {get; set;}
[Visual Basic .NET]
Public Property Enabled() As Boolean
[Delphi]
property Enabled: WordBool read Get_Enabled write Set_Enabled;

CommandBarControl-Objekt, CommandBar-Objekt


Extensibility2 (AddIn-Objekt)

Extensibility2 (AddIn-Objekt)

Gibt einen Verweis auf die Basisschnittstelle des AddIns zurück.

[C++]
HRESULT get_Extensibility2(
  /*[out, retval]*/ IDTExtensibility2** ppObject
);
[C#]
IDTExtensibility2 Extensibility2 {get;}
[Visual Basic .NET]
Public ReadOnly Property Extensibility2() As IDTExtensibility2
[Delphi]
property Extensibility2: IDTExtensibility2 read Get_Extensibility2;

AddIn-Objekt, IDTExtensibility2


FileContainers (TabWindow-Objekt)

FileContainers (TabWindow-Objekt)

Gibt eine Auflistung der Dateicontainer als FileContainers-Objekt zurück.

[C++]
HRESULT get_FileContainers(
  /*[out, retval]*/ IFileContainers** ppFileContainers
);
[C#]
FileContainers FileContainers {get;}
[Visual Basic .NET]
Public ReadOnly Property FileContainers() As FileContainers
[Delphi]
property FileContainers: IFileContainers read Get_FileContainers;

TabWindow-Objekt, FileContainers-Objekt


FileExtToken (MultiRename-Objekt)

FileExtToken (MultiRename-Objekt)

Legt das Token für die Dateierweiterung fest oder gibt es zurück.

[C++]
HRESULT get_FileExtToken(
  /*[out, retval]*/ BSTR* pbstFileExtToken
);
HRESULT put_FileExtToken(
  /*[in]*/ BSTR bstrFileExtToken
);
[C#]
string FileExtToken {get; set;}
[Visual Basic .NET]
Public Property FileExtToken() As String
[Delphi]
property FileExtToken: WideString read Get_FileExtToken write Set_FileExtToken;

MultiRename-Objekt


FileName (ListItem-Objekt)

FileName (ListItem-Objekt)

Gibt den relativen Dateinamen (ohne Pfad) zurück.

[C++]
HRESULT get_FileName(
  /*[out, retval]*/ BSTR* pbstrFileName
);
[C#]
string FileName {get;}
[Visual Basic .NET]
Public ReadOnly Property FileName() As String
[Delphi]
property FileName: WideString read Get_FileName;

ListItem-Objekt


FileNameToken (MultiRename-Objekt)

FileNameToken (MultiRename-Objekt)

Legt das Token für den Dateinamen fest oder gibt es zurück.

[C++]
HRESULT get_FileNameToken(
  /*[out, retval]*/ BSTR* pbstrFileNameToken
);
HRESULT put_FileNameToken(
  /*[in]*/ BSTR bstrFileNameToken
);
[C#]
string FileNameToken {get; set;}
[Visual Basic .NET]
Public Property FileNameToken() As String
[Delphi]
property FileNameToken: WideString read Get_FileNameToken write Set_FileNameToken;

MultiRename-Objekt


FocusedItem (FileContainer-Objekt)

FocusedItem (FileContainer-Objekt)

Gibt den fokussierten Eintrag zurück oder legt ihn fest.

[C++]
HRESULT get_FocusedItem(
  /*[out, retval]*/ long* pnFocusedItem
);
HRESULT put_FocusedItem(
  /*[in]*/ long nFocusedItem
);
[C#]
int FocusedItem {get; set;}
[Visual Basic .NET]
Public Property FocusedItem() As Integer
[Delphi]
property FocusedItem: Integer read Get_FocusedItem write Set_FocusedItem;

FileContainer-Objekt


FocusedItem (FolderWindow-Objekt)

FocusedItem (FolderWindow-Objekt)

Gibt den fokussierten Eintrag zurück oder legt ihn fest.

[C++]
HRESULT get_FocusedItem(
  /*[out, retval]*/ long* pnFocusedItem
);
HRESULT put_FocusedItem(
  /*[in]*/ long nFocusedItem
);
[C#]
int FocusedItem {get; set;}
[Visual Basic .NET]
Public Property FocusedItem() As Integer
[Delphi]
property FocusedItem: Integer read Get_FocusedItem write Set_FocusedItem;

FolderWindow-Objekt


Folder (AppFolder-Objekt)

Folder (AppFolder-Objekt)

Gibt den vollständigen Ordnernamen zurück oder setzt ihn.

[C++]
HRESULT get_Folder(
  /*[out, retval]*/ BSTR* pbstrFolder
);
HRESULT put_Folder(
  /*[in]*/ BSTR bstrFolder
);
[C#]
string Folder {get; set;}
[Visual Basic .NET]
Public Property Folder() As String
[Delphi]
property Folder: WideString read Get_Folder write Set_Folder;

AppFolder-Objekt


Folder (FolderFavorite-Objekt)

Folder (FolderFavorite-Objekt)

Setzt den Namen des Ordners, in den im aktiven Fenster gewechselt werden soll, oder gibt ihn zurück.

[C++]
HRESULT get_Folder(
  /*[out, retval]*/ BSTR* pbstrFolder
);
HRESULT put_Folder(
  /*[in]*/ BSTR bstrFolder
);
[C#]
string Folder {get; set;}
[Visual Basic .NET]
Public Property Folder() As String
[Delphi]
property Folder: WideString read Get_Folder write Set_Folder;

FolderFavorite-Objekt


Folder (FolderWindow-Objekt)

Folder (FolderWindow-Objekt)

Gibt ein AppFolder-Objekt für den aktuellen Ordner zurück.

[C++]
HRESULT get_Folder(
  /*[out, retval]*/ IAppFolder** ppAppFolder
);
[C#]
AppFolder Folder {get;}
[Visual Basic .NET]
Public ReadOnly Property Folder() As AppFolder
[Delphi]
property AppFolder: IAppFolder read Get_Folder;

FolderWindow-Objekt, AppFolder-Objekt


Folder (ListItem-Objekt)

Folder (ListItem-Objekt)

Gibt den Ordner zurück.

[C++]
HRESULT get_Folder(
  /*[out, retval]*/ BSTR* pbstrFolder
);
[C#]
string Folder {get;}
[Visual Basic .NET]
Public ReadOnly Property Folder() As String
[Delphi]
property Folder: WideString read Get_Folder;

ListItem-Objekt


Folder2 (FolderFavorite-Objekt)

Folder2 (FolderFavorite-Objekt)

Setzt den Namen des Ordners, in den im inaktiven Fenster gewechselt werden soll, oder gibt ihn zurück.

[C++]
HRESULT get_Folder2(
  /*[out, retval]*/ BSTR* pbstrFolder
);
HRESULT put_Folder2(
  /*[in]*/ BSTR bstrFolder
);
[C#]
string Folder2 {get; set;}
[Visual Basic .NET]
Public Property Folder2() As String
[Delphi]
property Folder2: WideString read Get_Folder2 write Set_Folder2;

FolderFavorite-Objekt


FolderType (AppFolder-Objekt)

FolderType (AppFolder-Objekt)

Gibt den Typ des Ordners als scAppFolder-Konstante zurück.

[C++]
HRESULT get_FolderType(
  /*[out, retval]*/ scAppFolder* peAppFolder
);
[C#]
scAppFolder FolderType {get;}
[Visual Basic .NET]
Public ReadOnly Property FolderType() As scAppFolder
[Delphi]
property FolderType: scAppFolder read Get_FolderType;

AppFolder-Objekt, scAppFolder-Konstanten


FolderLayout (Workspace-Objekt)

FolderLayout (Workspace-Objekt)

Gibt an, ob die Ordnerfenster nebeneinander oder übereinander angezeigt werden sollen.

[C++]
HRESULT get_FolderLayout(
  /*[out, retval]*/ enum scFolderLayout* peFolderLayout
);
HRESULT put_FolderLayout(
  /*[in]*/ enum scFolderLayout eFolderLayout
);
[C#]
scFolderLayout FolderLayout {get; set;}
[Visual Basic .NET]
Public Property FolderLayout() As scFolderLayout
[Delphi]
property FolderLayout: scFolderLayout read Get_FolderLayout write Set_FolderLayout;

Workspace-Objekt, scFolderLayout-Konstanten


FolderWindows (TabWindow-Objekt)

FolderWindows (TabWindow-Objekt)

Gibt eine Auflistung der Ordnerfenster als FolderWindows-Objekt zurück.

[C++]
HRESULT get_FolderWindows(
  /*[out, retval]*/ IFolderWindows** ppFolderWindows
);
[C#]
FolderWindows FolderWindows {get;}
[Visual Basic .NET]
Public ReadOnly Property FolderWindows() As FolderWindows
[Delphi]
property FolderWindows: IFolderWindow2 read Get_FolderWindows;

TabWindow-Objekt, FolderWindows-Objekt


FullName (Application-Objekt)

FullName (Application-Objekt)

Gibt den vollständigen Dateinamen der Anwendung zurück.

[C++]
HRESULT get_FullName(
  /*[out, retval]*/ BSTR* pbstrFullName
);
[C#]
public string FullName {get;}
[Visual Basic .NET]
Public ReadOnly Property FullName() As String
[Delphi]
property FullName: WideString read Get_FullName;

Application-Objekt


GroupView (FolderWindow-Objekt)

GroupView (FolderWindow-Objekt)

Aktiviert bzw. deaktiviert die Gruppenansicht oder fragt sie ab.

[C++]
HRESULT get_GroupView(
  /*[out, retval]*/ VARIANT_BOOL* pfGroupView
);
HRESULT put_Folder(
  /*[in]*/ VARIANT_BOOL fGroupView
);
[C#]
bool GroupView {get; set;}
[Visual Basic .NET]
Public Property GroupView() As Boolean
[Delphi]
property GroupView: WordBool read Get_GroupView write Set_GroupView;

FolderWindow-Objekt


Guid (AddIn-Objekt)

Guid (AddIn-Objekt)

Gibt die Guid (Klassenbezeichnung) des AddIns zurück.

[C++]
HRESULT get_Guid(
  /*[out, retval]*/ BSTR* pbstrGuid
);
[C#]
string Guid {get;}
[Visual Basic .NET]
Public ReadOnly Property Guid() As String
[Delphi]
property Guid: WideString read Get_Guid;

AddIn-Objekt


Height (MainWindow-Objekt)

Height (MainWindow-Objekt)

Gibt die Höhe des Hauptfensters zurück oder legt sie fest.

[C++]
HRESULT get_Height(
  /*[out, retval]*/ long* pHeight
);
HRESULT put_Height(
  /*[in]*/ long nHeight
);
[C#]
int Height {get; set;}
[Visual Basic .NET]
Public Property Height() As Integer
[Delphi]
property Height: Integer read Get_Height write Set_Height;

MainWindow-Objekt


Parent (MainWindow-Objekt)

Parent (MainWindow-Objekt)

Gibt das Fensterhandle des Hauptfensters zurück.

[C++]
HRESULT get_HWnd(
  /*[out, retval]*/ HANDLE_PTR* ppApplication
);
[C#]
IntPtr Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property HWnd() As IntPtr
[Delphi]
property HWnd: LongWord read Get_HWnd;

MainWindow-Objekt


IconId (CommandBarControl-Objekt)

IconId (CommandBarControl-Objekt)

Gibt die ID des Icons zurück, welches für das Element gezeichnet werden soll, oder legt sie fest.

[C++]
HRESULT get_IconId(
  /*[out, retval]*/ long* pIconId
);
HRESULT put_IconId(
  /*[in]*/ long nIconId
);
[C#]
Integer IconId {get; set;}
[Visual Basic .NET]
Public Property IconId() As Integer
[Delphi]
property IconId: Integer read Get_IconId write Set_IconId;

CommandBarControl-Objekt, CommandBar-Objekt


ImageLarge (AddInCommand-Objekt)

ImageLarge (AddInCommand-Objekt)

Legt das große Symbol (24x24) für diesen Befehl fest, welches in der Symbolleiste angezeigt wird.

[C++]
HRESULT put_ImageLarge(
  /*[in]*/ IPictureDisp* pImage
);
[C#]
IPictureDisp ImageLarge {set;}
[Visual Basic .NET]
Public WriteOnly Property ImageLarge() As IPictureDisp
[Delphi]
property ImageLarge: IPictureDisp write Set_ImageLarge;

AddInCommand-Objekt


ImageSmall (AddInCommand-Objekt)

ImageSmall (AddInCommand-Objekt)

Legt das kleine Symbol (16x16) für diesen Befehl fest, welches in der Symbolleiste oder im Menü angezeigt wird.

[C++]
HRESULT put_ImageSmall(
  /*[in]*/ IPictureDisp* pImage
);
[C#]
IPictureDisp ImageSmall {set;}
[Visual Basic .NET]
Public WriteOnly Property ImageSmall() As IPictureDisp
[Delphi]
property ImageSmall: IPictureDisp write Set_ImageSmall;

AddInCommand-Objekt


InactiveWindow (Workspace-Objekt)

InactiveWindow (Workspace-Objekt)

Gibt ein TabWindow-Objekt für das inaktive Fenster zurück.

[C++]
HRESULT get_InactiveWindow(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow InactiveWindow {get;}
[Visual Basic .NET]
Public ReadOnly Property InactiveWindow() As TabWindow
[Delphi]
property InactiveWindow: ITabWindow read Get_InactiveWindow;

Workspace-Objekt, TabWindow-Objekt


Index (CommandBarControl-Objekt)

Index (CommandBarControl-Objekt)

Gibt den Index des Elements in der CommandBarControls-Auflistung zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pIndex
);
[C#]
Integer Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

CommandBarControl-Objekt, CommandBar-Objekt


Index (FileContainer-Objekt)

Index (FileContainer-Objekt)

Gibt den Index des Objekts innerhalb der FileContainers-Auflistung zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pnIndex
);
[C#]
int Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

FileContainer-Objekt, FileContainers-Objekt


Index (FolderFavorite-Objekt)

Index (FolderFavorite-Objekt)

Gibt den Index des Ordnerfavoriten innerhalb des FolderFavorites-Objekts zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pIndex
);
[C#]
int Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

FolderFavorite-Objekt, FolderFavorites-Objekt


Index (FolderWindow-Objekt)

Index (FolderWindow-Objekt)

Gibt den Index des Objekts innerhalb der FolderWindows-Auflistung zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pnIndex
);
[C#]
int Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

FolderWindow-Objekt, FolderWindows-Objekt


Index (UserTool-Objekt)

Index (UserTool-Objekt)

Gibt den Index des Anwendungsfavoriten innerhalb des UserTools-Objekts zurück.

[C++]
HRESULT get_Index(
  /*[out, retval]*/ long* pIndex
);
[C#]
int Index {get;}
[Visual Basic .NET]
Public ReadOnly Property Index() As Integer
[Delphi]
property Index: Integer read Get_Index;

UserTool-Objekt, UserTools-Objekt


InitialDir (UserTool-Objekt)

InitialDir (UserTool-Objekt)

Setzt den Startordner der Anwendung oder gibt ihn zurück.

[C++]
HRESULT get_InitialDir(
  /*[out, retval]*/ BSTR* pbstrInitialDir
);
HRESULT put_InitialDir(
  /*[in]*/ BSTR bstrInitialDir
);
[C#]
string InitialDir {get; set;}
[Visual Basic .NET]
Public Property InitialDir() As String
[Delphi]
property InitialDir: WideString read Get_InitialDir write Set_InitialDir;

UserTool-Objekt


IsActive (TabWindow-Objekt)

IsActive (TabWindow-Objekt)

Gibt an, ob das Fenster aktiv ist.

[C++]
HRESULT get_IsActive(
  /*[out, retval]*/ VARIANT_BOOL* pfIsActive
);
[C#]
bool IsActive {get;}
[Visual Basic .NET]
Public ReadOnly Property IsActive() As Boolean
[Delphi]
property IsActive: WordBool read Get_IsActive;

TabWindow-Objekt


IsAddInSite (AppFolder-Objekt)

IsAddInSite (AppFolder-Objekt)

Gibt an, ob der Ordner die oberste Ebene in der AddIn-Dateisystemansicht ist.

[C++]
HRESULT get_IsAddInSite(
  /*[out, retval]*/ VARIANT_BOOL* pfIsAddInSite
);
[C#]
bool IsAddInSite {get;}
[Visual Basic .NET]
Public ReadOnly Property IsAddInSite() As Boolean
[Delphi]
property IsAddInSite: WordBool read Get_IsAddInSite;

AppFolder-Objekt


IsArchive (AppFolder-Objekt)

IsArchive (AppFolder-Objekt)

Gibt an, ob der Ordner ein Archiv ist.

[C++]
HRESULT get_IsArchive(
  /*[out, retval]*/ VARIANT_BOOL* pfIsArchive
);
[C#]
bool IsArchive {get;}
[Visual Basic .NET]
Public ReadOnly Property IsArchive() As Boolean
[Delphi]
property IsArchive: WordBool read Get_IsArchive;

AppFolder-Objekt


IsFavorite (FolderFavorite-Objekt)

IsFavorite (FolderFavorite-Objekt)

Gibt an, ob der Eintrag ein Ordnerfavorit ist.

[C++]
HRESULT get_IsFavorite(
  /*[out, retval]*/ VARIANT_BOOL* pIsFavorite
);
[C#]
bool IsFavorite {get;}
[Visual Basic .NET]
Public ReadOnly Property IsFavorite() As Boolean
[Delphi]
property IsFavorite: WordBool read Get_IsFavorite;

FolderFavorite-Objekt


IsFtpSite (AppFolder-Objekt)

IsFtpSite (AppFolder-Objekt)

Gibt an, ob der Ordner die FTP-Standortansicht ist.

[C++]
HRESULT get_IsFtpSite(
  /*[out, retval]*/ VARIANT_BOOL* pfIsFtpSite
);
[C#]
bool IsFtpSite {get;}
[Visual Basic .NET]
Public ReadOnly Property IsFtpSite() As Boolean
[Delphi]
property IsFtpSite: WordBool read Get_IsFtpSite;

AppFolder-Objekt


IsRoot (AppFolder-Objekt)

IsRoot (AppFolder-Objekt)

Gibt an, ob der Ordner ein Hauptverzeichnis ist.

[C++]
HRESULT get_IsRoot(
  /*[out, retval]*/ VARIANT_BOOL* pfIsRoot
);
[C#]
bool IsRoot {get;}
[Visual Basic .NET]
Public ReadOnly Property IsRoot() As Boolean
[Delphi]
property IsRoot: WordBool read Get_IsRoot;

AppFolder-Objekt


IsSeparator (FolderFavorite-Objekt)

IsSeparator (FolderFavorite-Objekt)

Gibt an, ob der Eintrag ein Trennzeichen ist.

[C++]
HRESULT get_IsSeparator(
  /*[out, retval]*/ VARIANT_BOOL* pIsSeparator
);
[C#]
bool IsSeparator {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSeparator() As Boolean
[Delphi]
property IsSeparator: WordBool read Get_IsSeparator;

FolderFavorite-Objekt


IsSeparator (UserTool-Objekt)

IsSeparator (UserTool-Objekt)

Gibt an, ob der Eintrag ein Trennzeichen ist.

[C++]
HRESULT get_IsSeparator(
  /*[out, retval]*/ VARIANT_BOOL* pIsSeparator
);
[C#]
bool IsSeparator {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSeparator() As Boolean
[Delphi]
property IsSeparator: WordBool read Get_IsSeparator;

UserTool-Objekt


IsSubMenu (FolderFavorite-Objekt)

IsSubMenu (FolderFavorite-Objekt)

Gibt an, ob der Eintrag ein Untermenü ist.

[C++]
HRESULT get_IsSubMenu(
  /*[out, retval]*/ VARIANT_BOOL* pIsSubMenu
);
[C#]
bool IsSubMenu {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSubMenu() As Boolean
[Delphi]
property IsSubMenu: WordBool read Get_IsSubMenu;

FolderFavorite-Objekt


IsSubMenu (UserTool-Objekt)

IsSubMenu (UserTool-Objekt)

Gibt an, ob der Eintrag ein Untermenü ist.

[C++]
HRESULT get_IsSubMenu(
  /*[out, retval]*/ VARIANT_BOOL* pIsSubMenu
);
[C#]
bool IsSubMenu {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSubMenu() As Boolean
[Delphi]
property IsSubMenu: WordBool read Get_IsSubMenu;

UserTool-Objekt


IsSubMenuEnd (FolderFavorite-Objekt)

IsSubMenuEnd (FolderFavorite-Objekt)

Gibt an, ob der Eintrag der Abschluss eines Untermenüs ist.

[C++]
HRESULT get_IsSubMenuEnd(
  /*[out, retval]*/ VARIANT_BOOL* pIsSubMenuEnd
);
[C#]
bool IsSubMenuEnd {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSubMenuEnd() As Boolean
[Delphi]
property IsSubMenuEnd: WordBool read Get_IsSubMenuEnd;

FolderFavorite-Objekt


IsSubMenuEnd (UserTool-Objekt)

IsSubMenuEnd (UserTool-Objekt)

Gibt an, ob der Eintrag der Abschluss eines Untermenüs ist.

[C++]
HRESULT get_IsSubMenuEnd(
  /*[out, retval]*/ VARIANT_BOOL* pIsSubMenuEnd
);
[C#]
bool IsSubMenuEnd {get;}
[Visual Basic .NET]
Public ReadOnly Property IsSubMenuEnd() As Boolean
[Delphi]
property IsSubMenuEnd: WordBool read Get_IsSubMenuEnd;

UserTool-Objekt


IsUserTool (UserTool-Objekt)

IsUserTool (UserTool-Objekt)

Gibt an, ob der Eintrag ein Anwendungsfavorit ist.

[C++]
HRESULT get_IsUserTool(
  /*[out, retval]*/ VARIANT_BOOL* pIsUserTool
);
[C#]
bool IsUserTool {get;}
[Visual Basic .NET]
Public ReadOnly Property IsUserTool() As Boolean
[Delphi]
property IsUserTool: WordBool read Get_IsUserTool;

UserTool-Objekt


IsVisible (FileContainer-Objekt)

IsVisible (FileContainer-Objekt)

Gibt an, ob die Dateiablage sichtbar ist.

[C++]
HRESULT get_IsVisible(
  [out, retval] VARIANT_BOOL* pfIsVisible
);
[C#]
bool IsVisible {get;}
[Visual Basic .NET]
Public ReadOnly Property IsVisible() As Boolean
[Delphi]
property IsVisible: WordBool read Get_IsVisible;

FileContainer-Objekt


IsVisible (FileContainers-Objekt)

IsVisible (FileContainers-Objekt)

Gibt an, ob die Dateiablagen sichtbar sind.

[C++]
HRESULT get_IsVisible(
  [out, retval] VARIANT_BOOL* pfIsVisible
);
[C#]
bool IsVisible {get;}
[Visual Basic .NET]
Public ReadOnly Property IsVisible() As Boolean
[Delphi]
property IsVisible: WordBool read Get_IsVisible;

FileContainers-Objekt


IsVisible (FolderWindow-Objekt)

IsVisible (FolderWindow-Objekt)

Gibt an, ob das Ordnerfenster sichtbar ist.

[C++]
HRESULT get_IsVisible(
  [out, retval] VARIANT_BOOL* pfIsVisible
);
[C#]
bool IsVisible {get;}
[Visual Basic .NET]
Public ReadOnly Property IsVisible() As Boolean
[Delphi]
property IsVisible: WordBool read Get_IsVisible;

FolderWindow-Objekt


IsVisible (FolderWindows-Objekt)

IsVisible (FolderWindows-Objekt)

Gibt an, ob die Ordnerfenster sichtbar sind.

[C++]
HRESULT get_IsVisible(
  [out, retval] VARIANT_BOOL* pfIsVisible
);
[C#]
bool IsVisible {get;}
[Visual Basic .NET]
Public ReadOnly Property IsVisible() As Boolean
[Delphi]
property IsVisible: WordBool read Get_IsVisible;

FolderWindows-Objekt


Items (FileContainer-Objekt)

Items (FileContainer-Objekt)

Gibt die Objekte einer Dateiablage in einer ListItems-Aufzählung zurück.

[C++]
HRESULT get_Items(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems Items {get;}
[Visual Basic .NET]
Public ReadOnly Property Items() As ListItems
[Delphi]
property Items: IListItems read Get_Items;

FileContainer-Objekt, ListItems-Objekt


Items (FolderWindow-Objekt)

Items (FolderWindow-Objekt)

Gibt die Objekte im Ordnerfenster in einer ListItems-Aufzählung zurück.

[C++]
HRESULT get_Items(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems Items {get;}
[Visual Basic .NET]
Public ReadOnly Property Items() As ListItems
[Delphi]
property Items: IListItems read Get_Items;

FolderWindow-Objekt, ListItems-Objekt


Left (MainWindow-Objekt)

Left (MainWindow-Objekt)

Gibt den Abstand zwischen dem linken Rand des Bildschirmes und dem linken Rand des Hauptfensters zurück oder legt ihn fest.

[C++]
HRESULT get_Left(
  /*[out, retval]*/ long* pLeft
);
HRESULT put_Left(
  /*[in]*/ long nLeft
);
[C#]
int Left {get; set;}
[Visual Basic .NET]
Public Property Left() As Integer
[Delphi]
property Left: Integer read Get_Left write Set_Left;

MainWindow-Objekt


ListView (FolderWindow-Objekt)

ListView (FolderWindow-Objekt)

Setzt den Modus für die Listenansicht oder fragt ihn ab.

[C++]
HRESULT get_ListView(
  /*[out, retval]*/ enum scListView* peListView
);
HRESULT put_ListView(
  /*[in]*/ enum scListView eListView
);
[C#]
scListView ListView {get; set;}
[Visual Basic .NET]
Public Property ListView() As scListView
[Delphi]
property ListView: scListView read Get_ListView write Set_ListView;

FolderWindow-Objekt, scListView-Konstanten


LocaleID (Application-Objekt)

LocaleID (Application-Objekt)

Gibt die Sprache der Benutzeroberfläche zurück.

[C++]
HRESULT get_LocaleID(
  /*[out, retval]*/ long* pLocaleID
);
[C#]
public int LocaleID {get;}
[Visual Basic .NET]
Public ReadOnly Property LocaleID() As Integer
[Delphi]
property LocaleID: Integer read Get_LocaleID;

Application-Objekt


LocalOrUncFolder (AppFolder-Objekt)

LocalOrUncFolder (AppFolder-Objekt)

Gibt den vollständigen Ordnernamen zurück, wenn der Ordner ein lokaler Ordner oder ein Netzwerkordner ist.

[C++]
HRESULT get_LocalOrUncFolder(
  /*[out, retval]*/ BSTR* pbstrLocalOrUncFolder
);
[C#]
string LocalOrUncFolder {get;}
[Visual Basic .NET]
Public ReadOnly Property LocalOrUncFolder() As String
[Delphi]
property LocalOrUncFolder: WideString read Get_LocalOrUncFolder;

AppFolder-Objekt


Name (AddInCommand-Objekt)

Name (AddInCommand-Objekt)

Gibt den Namen des Befehls zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
[C#]
string Name {get;}
[Visual Basic .NET]
Public ReadOnly Property Name() As String
[Delphi]
property Name: WideString read Get_Name;

AddInCommand-Objekt


Name (Application-Objekt)

Name (Application-Objekt)

Gibt den Namen der Anwendung zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
[C#]
public string Name {get;}
[Visual Basic .NET]
Public ReadOnly Property Name() As String
[Delphi]
property Name: WideString read Get_Name;

Application-Objekt


Name (FileContainer-Objekt)

Name (FileContainer-Objekt)

Setzt den Namen der Dateiablage oder gibt ihn zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
HRESULT put_Name(
  /*[in]*/ BSTR bstrName
);
[C#]
string Name {get; set;}
[Visual Basic .NET]
Public Property Name() As String
[Delphi]
property Name: WideString read Get_Name write Set_Name;

FileContainer-Objekt


Name (FolderFavorite-Objekt)

Name (FolderFavorite-Objekt)

Setzt den Anzeigenamen des Ordnerfavoriten oder gibt ihn zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
HRESULT put_Name(
  /*[in]*/ BSTR bstrName
);
[C#]
string Name {get; set;}
[Visual Basic .NET]
Public Property Name() As String
[Delphi]
property Name: WideString read Get_Name write Set_Name;

FolderFavorite-Objekt


Name (FolderWindow-Objekt)

Name (FolderWindow-Objekt)

Setzt den Namen des Ordnerfensters oder gibt ihn zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
HRESULT put_Name(
  /*[in]*/ BSTR bstrName
);
[C#]
string Name {get; set;}
[Visual Basic .NET]
Public Property Name() As String
[Delphi]
property Name: WideString read Get_Name write Set_Name;

FolderWindow-Objekt


Name (UserTool-Objekt)

Name (UserTool-Objekt)

Setzt den Anzeigenamen des Anwendungsfavoriten oder gibt ihn zurück.

[C++]
HRESULT get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
HRESULT put_Name(
  /*[in]*/ BSTR bstrName
);
[C#]
string Name {get; set;}
[Visual Basic .NET]
Public Property Name() As String
[Delphi]
property Name: WideString read Get_Name write Set_Name;

UserTool-Objekt


ParentFolder (MultiRename-Objekt)

ParentFolder (MultiRename-Objekt)

Legt den Elternordner fest oder gibt ihn zurück.

[C++]
HRESULT get_ParentFolder(
  /*[out, retval]*/ BSTR* pbstrParentFolder
);
HRESULT put_ParentFolder(
  /*[in]*/ BSTR bstrParentFolder
);
[C#]
string ParentFolder {get; set;}
[Visual Basic .NET]
Public Property ParentFolder() As String
[Delphi]
property ParentFolder: WideString read Get_ParentFolder write Set_ParentFolder;

MultiRename-Objekt


Path (Application-Objekt)

Path (Application-Objekt)

Gibt den Pfad zurück, in dem die Anwendung installiert ist.

[C++]
HRESULT get_Path(
  /*[out, retval]*/ BSTR* pbstrPath
);
[C#]
public string Path {get;}
[Visual Basic .NET]
Public ReadOnly Property Path() As String
[Delphi]
property Path: WideString read Get_Path;

Application-Objekt


PathName (ListItem-Objekt)

PathName (ListItem-Objekt)

Gibt den vollständigen Dateinamen zurück.

[C++]
HRESULT get_PathName(
  /*[out, retval]*/ BSTR* pbstrPathName
);
[C#]
string PathName {get;}
[Visual Basic .NET]
Public ReadOnly Property PathName() As String
[Delphi]
property PathName: WideString read Get_PathName;

ListItem-Objekt


Position (CommandBar-Objekt)

Position (CommandBar-Objekt)

Setzt die Position der Symbolleiste oder gibt diese zurück.

[C++]
HRESULT get_Position(
  /*[out, retval]*/ enum scCommandBarPosition* pPosition
);
HRESULT put_Position(
  /*[in]*/ enum scCommandBarPosition ePosition
);
[C#]
scCommandBarPosition Position {get; set;}
[Visual Basic .NET]
Public Property Position() As scCommandBarPosition
[Delphi]
property Position: scCommandBarPosition read Get_Position write Set_Position;

CommandBar-Objekt, scCommandBarPosition-Konstanten


ProgID (AddIn-Objekt)

ProgID (AddIn-Objekt)

Gibt die ProgID des AddIns zurück.

[C++]
HRESULT get_ProgID(
  /*[out, retval]*/ BSTR* pbstrProgID
);
[C#]
string ProgID {get;}
[Visual Basic .NET]
Public ReadOnly Property ProgID() As String
[Delphi]
property ProgID: WideString read Get_ProgID;

AddIn-Objekt


ProgID (AddInCommand-Objekt)

ProgID (AddInCommand-Objekt)

Gibt die ProgID des AddIns zurück, welches das AddInCommand-Objekt erstellt hat.

[C++]
HRESULT get_ProgID(
  /*[out, retval]*/ BSTR* pbstrProgID
);
[C#]
string ProgID {get;}
[Visual Basic .NET]
Public ReadOnly Property ProgID() As String
[Delphi]
property ProgID: WideString read Get_ProgID;

AddInCommand-Objekt


Replace (MultiRename-Objekt)

Replace (MultiRename-Objekt)

Legt den Modus für das Ersetzen von Text fest oder gibt ihn zurück.

[C++]
HRESULT get_Replace(
  /*[out, retval]*/ scMrtReplace* eReplace
);
HRESULT put_Replace(
  /*[in]*/ scMrtReplace eReplace
);
[C#]
scMrtReplace Replace {get; set;}
[Visual Basic .NET]
Public Property Replace() As scMrtReplace
[Delphi]
property Replace: scMrtReplace read Get_Replace write Set_Replace;

MultiRename-Objekt, scMrtReplace-Konstanten


ReplaceWith (MultiRename-Objekt)

ReplaceWith (MultiRename-Objekt)

Legt den Text fest, der den zu suchenden Text ersetzen soll oder gibt ihn zurück.

[C++]
HRESULT get_ReplaceWith(
  /*[out, retval]*/ BSTR* pbstrReplaceWith
);
HRESULT put_ReplaceWith(
  /*[in]*/ BSTR bstrReplaceWith
);
[C#]
string ReplaceWith {get; set;}
[Visual Basic .NET]
Public Property ReplaceWith() As String
[Delphi]
property ReplaceWith: WideString read Get_ReplaceWith write Set_ReplaceWith;

MultiRename-Objekt


SearchFor (MultiRename-Objekt)

SearchFor (MultiRename-Objekt)

Legt den zu suchenden Text fest oder gibt ihn zurück.

[C++]
HRESULT get_SearchFor(
  /*[out, retval]*/ BSTR* pbstrSearchFor
);
HRESULT put_SearchFor(
  /*[in]*/ BSTR bstrSearchFor
);
[C#]
string SearchFor {get; set;}
[Visual Basic .NET]
Public Property SearchFor() As String
[Delphi]
property SearchFor: WideString read Get_SearchFor write Set_SearchFor;

MultiRename-Objekt


Selected (ListItem-Objekt)

Selected (ListItem-Objekt)

Setzt den Auswahlzustand eines Eintrags oder gibt ihn zurück.

[C++]
HRESULT get_Selected(
  /*[out, retval]*/ VARIANT_BOOL* pSelected
);
HRESULT put_Selected(
  /*[in]*/ VARIANT_BOOL fSelected
);
[C#]
bool Selected {get; set;}
[Visual Basic .NET]
Public Property Selected() As Boolean
[Delphi]
property Selected: WordBool read Get_Selected write Set_Selected;

ListItem-Objekt


SelectedItems (FileContainer-Objekt)

SelectedItems (FileContainer-Objekt)

Gibt die ausgewählten Objekte einer Dateiablage in einer ListItems-Aufzählung zurück.

[C++]
HRESULT get_SelectedItems(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems SelectedItems {get;}
[Visual Basic .NET]
Public ReadOnly Property SelectedItems() As ListItems
[Delphi]
property SelectedItems: IListItems read Get_SelectedItems;

FileContainer-Objekt, ListItems-Objekt


SelectedItems (FolderWindow-Objekt)

SelectedItems (FolderWindow-Objekt)

Gibt die ausgewählten Objekte im Ordnerfenster in einer ListItems-Aufzählung zurück.

[C++]
HRESULT get_SelectedItems(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems SelectedItems {get;}
[Visual Basic .NET]
Public ReadOnly Property SelectedItems() As ListItems
[Delphi]
property SelectedItems: IListItems read Get_SelectedItems;

FolderWindow-Objekt, ListItems-Objekt


Selection (FileContainer-Objekt)

Selection (FileContainer-Objekt)

Gibt ein ListSelection-Objekt zum Auswählen von Objekten in der Dateiablage zurück.

[C++]
HRESULT get_Selection(
  /*[out, retval]*/ IListSelection** ppListSelection
);
[C#]
ListSelection Selection {get;}
[Visual Basic .NET]
Public ReadOnly Property Selection() As ListSelection
[Delphi]
property Selection: IListSelection read Get_Selection;

FileContainer-Objekt, ListSelection-Objekt


Selection (FolderWindow-Objekt)

Selection (FolderWindow-Objekt)

Gibt ein ListSelection-Objekt zum Auswählen von Objekten im Ordnerfenster zurück.

[C++]
HRESULT get_Selection(
  /*[out, retval]*/ IListSelection** ppListSelection
);
[C#]
ListSelection Selection {get;}
[Visual Basic .NET]
Public ReadOnly Property Selection() As ListSelection
[Delphi]
property Selection: IListSelection read Get_Selection;

FolderWindow-Objekt, ListSelection-Objekt


Settings (AddIns-Objekt)

Settings (AddIns-Objekt)

Gibt AddInSettings-Objekt zurück, welches zum Speichern von Einstellungen genutzt werden kann.

[C++]
HRESULT get_Settings(
  /*[out, retval]*/ IAddInSettings** ppAddInSettings
);
[C#]
AddInSettings Settings {get;}
[Visual Basic .NET]
Public ReadOnly Property Settings() As AddInSettings
[Delphi]
property Settings: IAddInSettings read Get_Settings;

AddIns-Objekt, AddInSettings-Objekt


ShortFileName (ListItem-Objekt)

ShortFileName (ListItem-Objekt)

Gibt den relativen Dateinamen (ohne Pfad) in 8.3-Konvention zurück.

[C++]
HRESULT get_ShortFileName(
  /*[out, retval]*/ BSTR* pbstrShortFileName
);
[C#]
string ShortFileName {get;}
[Visual Basic .NET]
Public ReadOnly Property ShortFileName() As String
[Delphi]
property ShortFileName: WideString read Get_ShortFileName;

ListItem-Objekt


ShortPathName (ListItem-Objekt)

ShortPathName (ListItem-Objekt)

Gibt den vollständigen Dateinamen in 8.3-Konvention zurück.

[C++]
HRESULT get_ShortPathName(
  /*[out, retval]*/ BSTR* pbstrShortPathName
);
[C#]
string ShortPathName {get;}
[Visual Basic .NET]
Public ReadOnly Property ShortPathName() As String
[Delphi]
property ShortPathName: WideString read Get_ShortPathName;

ListItem-Objekt


ShortPathNames (UserTool-Objekt)

ShortPathNames (UserTool-Objekt)

Legt fest, dass die der Anwendung übergebenen Objekte im 8.3-Format erfolgen soll.

[C++]
HRESULT get_ShortPathNames(
  /*[out, retval]*/ VARIANT_BOOL* pShortPathNames
);
HRESULT put_ShortPathNames(
  /*[in]*/ VARIANT_BOOL fShortPathNames
);
[C#]
bool ShortPathNames {get; set;}
[Visual Basic .NET]
Public Property ShortPathNames() As Boolean
[Delphi]
property ShortPathNames: WordBool read Get_ShortPathNames write Set_ShortPathNames;

UserTool-Objekt


ShowCmd (UserTool-Objekt)

ShowCmd (UserTool-Objekt)

Setzt den Startmodus der Anwendung oder gibt ihn zurück. Gültige Werte sind SW_SHOWNORMAL (1), SW_SHOWMINIMIZED (2) und SW_SHOWMAXIMIZED (3).

[C++]
HRESULT get_ShowCmd(
  /*[out, retval]*/ long* pShowCmd
);
HRESULT put_ShowCmd(
  /*[in]*/ long iShowCmd
);
[C#]
int ShowCmd {get; set;}
[Visual Basic .NET]
Public Property ShowCmd() As Integer
[Delphi]
property ShowCmd: Integer read Get_ShowCmd write Set_ShowCmd;

UserTool-Objekt


ShowFileContainers (TabWindow-Objekt)

ShowFileContainers (TabWindow-Objekt)

Gibt an, ob die Dateiablagen als Registerkarte angezeigt werden sollen.

[C++]
HRESULT get_ShowFileContainers(
  /*[out, retval]*/ VARIANT_BOOL* pfShowFileContainers
);
HRESULT put_ShowFileContainers(
  /*[in]*/ VARIANT_BOOL fShowFileContainers
);
[C#]
bool ShowFileContainers {get; set;}
[Visual Basic .NET]
Public Property ShowFileContainers() As Boolean
[Delphi]
property ShowFileContainers: WordBool read Get_ShowFileContainers write Set_ShowFileContainers;

TabWindow-Objekt


Size (ListItem-Objekt)

Size (ListItem-Objekt)

Gibt die Größe der Datei zurück.

[C++]
HRESULT get_Attributes(
  /*[out, retval]*/ VARIANT* pvSize
);
[C#]
object Size {get;}
[Visual Basic .NET]
Public ReadOnly Property Size() As Object
[Delphi]
property Size: OleVariant read Get_Size;

ListItem-Objekt


Splitter (Workspace-Objekt)

Splitter (Workspace-Objekt)

Setzt die Splitterposition zwischen den beiden Fenstern bzw. fragt sie ab.

[C++]
HRESULT get_Splitter(
  /*[out, retval]*/ VARIANT_BOOL* pnSplitter
);
HRESULT put_Splitter(
  /*[in]*/ VARIANT_BOOL nSplitter
);
[C#]
int Splitter {get; set;}
[Visual Basic .NET]
Public Property Splitter() As Integer
[Delphi]
property Splitter: Integer read Get_Splitter write Set_Splitter;

Workspace-Objekt


Splitter1 (FolderWindow-Objekt)

Splitter1 (FolderWindow-Objekt)

Setzt die Splitterposition zwischen Listenansicht und Baumansicht bzw. fragt sie ab.

[C++]
HRESULT get_Splitter1(
  /*[out, retval]*/ long* pnSplitter1
);
HRESULT put_Splitter1(
  /*[in]*/ long nSplitter1
);
[C#]
int Splitter1 {get; set;}
[Visual Basic .NET]
Public Property Splitter1() As Integer
[Delphi]
property Splitter1: Integer read Get_Splitter1 write Set_Splitter1;

FolderWindow-Objekt


Splitter2 (FolderWindow-Objekt)

Splitter2 (FolderWindow-Objekt)

Setzt die Splitterposition zwischen Listenansicht und Baumansicht bzw. fragt sie ab.

[C++]
HRESULT get_Splitter2(
  /*[out, retval]*/ long* pnSplitter2
);
HRESULT put_Splitter2(
  /*[in]*/ long nSplitter2
);
[C#]
int Splitter2 {get; set;}
[Visual Basic .NET]
Public Property Splitter2() As Integer
[Delphi]
property Splitter2: Integer read Get_Splitter2 write Set_Splitter2;

FolderWindow-Objekt


StatusWindow (FolderWindow-Objekt)

StatusWindow (FolderWindow-Objekt)

Aktiviert oder deaktiviert das Statusfenster.

[C++]
HRESULT get_StatusWindow(
  /*[out, retval]*/ VARIANT_BOOL* pfStatusWindow
);
HRESULT put_Folder(
  /*[in]*/ VARIANT_BOOL fStatusWindow
);
[C#]
bool StatusWindow {get; set;}
[Visual Basic .NET]
Public Property StatusWindow() As Boolean
[Delphi]
property StatusWindow: WordBool read Get_StatusWindow write Set_StatusWindow;

FolderWindow-Objekt


Swapped (Workspace-Objekt)

Swapped (Workspace-Objekt)

Gibt an, ob die beiden Fenster getauscht sind. Im Normalfall ist erste Fenster links bzw. oben und zweite Fenster rechts bzw. unten.

[C++]
HRESULT get_Swapped(
  /*[out, retval]*/ VARIANT_BOOL* pSwapped
);
HRESULT put_Swapped(
  /*[in]*/ VARIANT_BOOL fSwapped
);
[C#]
bool Swapped {get; set;}
[Visual Basic .NET]
Public Property Swapped() As Boolean
[Delphi]
property Swapped: WordBool read Get_Swapped write Set_Swapped;

Workspace-Objekt


SynchronizeFolderWindows (TabWindow-Objekt)

SynchronizeFolderWindows (TabWindow-Objekt)

Gibt an, ob die Ordnerfenster untereinander abgeglichen werden sollen.

[C++]
HRESULT get_SynchronizeFolderWindows(
  /*[out, retval]*/ VARIANT_BOOL* pfSynchronizeFolderWindows
);
HRESULT put_SynchronizeFolderWindows(
  /*[in]*/ VARIANT_BOOL fSynchronizeFolderWindows
);
[C#]
bool SynchronizeFolderWindows {get; set;}
[Visual Basic .NET]
Public Property SynchronizeFolderWindows() As Boolean
[Delphi]
property SynchronizeFolderWindows: WordBool read Get_SynchronizeFolderWindows write Set_SynchronizeFolderWindows;

TabWindow-Objekt


TabProperties (FolderWindow-Objekt)

TabProperties (FolderWindow-Objekt)

Setzt verschiedene Registerkarten-Eigenschaften für das Ordnerfenster oder fragt sie ab.

[C++]
HRESULT get_TabProperties(
  /*[out, retval]*/ enum scTabProperties* peTabProperties
);
HRESULT put_TabProperties(
  /*[in]*/ enum scTabProperties eTabProperties
);
[C#]
scTabProperties TabProperties {get; set;}
[Visual Basic .NET]
Public Property TabProperties() As scTabProperties
[Delphi]
property TabProperties: scTabProperties read Get_TabProperties write Set_TabProperties;

FolderWindow-Objekt, scTabProperties-Konstanten


Window1 (Workspace-Objekt)

Window1 (Workspace-Objekt)

Gibt ein TabWindow-Objekt für das erste Fenster zurück.

[C++]
HRESULT get_Window1(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow Window1 {get;}
[Visual Basic .NET]
Public ReadOnly Property Window1() As TabWindow
[Delphi]
property Window1: ITabWindow read Get_Window1;

Workspace-Objekt, TabWindow-Objekt


Window2 (Workspace-Objekt)

Window2 (Workspace-Objekt)

Gibt ein TabWindow-Objekt für das zweite Fenster zurück.

[C++]
HRESULT get_Window2(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow Window2 {get;}
[Visual Basic .NET]
Public ReadOnly Property Window2() As TabWindow
[Delphi]
property Window2: ITabWindow read Get_Window2;

Workspace-Objekt, TabWindow-Objekt


Title (CommandBar-Objekt)

Title (CommandBar-Objekt)

Setzt den Titel der Symbolleiste oder gibt diesen zurück.

[C++]
HRESULT get_Title(
  /*[out, retval]*/ BSTR* pbstrTitle
);
HRESULT put_Title(
  /*[in]*/ BSTR bstrTitle
);
[C#]
public string Title {get; set;}
[Visual Basic .NET]
Public Property Title() As String
[Delphi]
property Title: WideString read Get_Title write Set_Title;

CommandBar-Objekt


Top (MainWindow-Objekt)

Top (MainWindow-Objekt)

Gibt den Abstand zwischen dem oberen Rand des Bildschirmes und dem oberen Rand des Hauptfensters zurück oder legt ihn fest.

[C++]
HRESULT get_Top(
  /*[out, retval]*/ long* pTop
);
HRESULT put_Top(
  /*[in]*/ long nTop
);
[C#]
int Top {get; set;}
[Visual Basic .NET]
Public Property Top() As Integer
[Delphi]
property Top: Integer read Get_Top write Set_Top;

MainWindow-Objekt


Tooltip (CommandBarControl-Objekt)

Tooltip (CommandBarControl-Objekt)

Setzt den Text für ein anzuzeigendes InfoTip-Fenster oder gibt ihn zurück.

[C++]
HRESULT get_Tooltip(
  /*[out, retval]*/ BSTR* pbstrTooltip
);
HRESULT put_Tooltip(
  /*[in]*/ BSTR bstrTooltip
);
[C#]
string Tooltip {get; set;}
[Visual Basic .NET]
Public Property Tooltip() As String
[Delphi]
property Tooltip: WideString read Get_Tooltip write Set_Tooltip;

CommandBarControl-Objekt, CommandBar-Objekt


TreeView (FolderWindow-Objekt)

TreeView (FolderWindow-Objekt)

Aktiviert oder deaktiviert die Baumansicht.

[C++]
HRESULT get_TreeView(
  /*[out, retval]*/ VARIANT_BOOL* pfTreeView
);
HRESULT put_Folder(
  /*[in]*/ VARIANT_BOOL fTreeView
);
[C#]
bool TreeView {get; set;}
[Visual Basic .NET]
Public Property TreeView() As Boolean
[Delphi]
property TreeView: WordBool read Get_TreeView write Set_TreeView;

FolderWindow-Objekt


UrlHostName (AppFolder-Objekt)

UrlHostName (AppFolder-Objekt)

Gibt den Namen des Servers zurück, wenn der Ordner eine Internet- oder AddIn-Adresse ist.

[C++]
HRESULT get_UrlHostName(
  /*[out, retval]*/ BSTR* pbstrUrlHostName
);
[C#]
string UrlHostName {get;}
[Visual Basic .NET]
Public ReadOnly Property UrlHostName() As String
[Delphi]
property UrlHostName: WideString read Get_UrlHostName;

AppFolder-Objekt


UrlPath (AppFolder-Objekt)

UrlPath (AppFolder-Objekt)

Gibt den Pfadanteil zurück, wenn der Ordner eine Internet- oder AddIn-Adresse ist.

[C++]
HRESULT get_UrlPath(
  /*[out, retval]*/ BSTR* pbstrUrlPath
);
[C#]
string UrlPath {get;}
[Visual Basic .NET]
Public ReadOnly Property UrlPath() As String
[Delphi]
property UrlPath: WideString read Get_UrlPath;

AppFolder-Objekt


Version (Application-Objekt)

Version (Application-Objekt)

Gibt die Versionsnummer vom SpeedCommander zurück.

[C++]
HRESULT get_Version(
  /*[out, retval]*/ BSTR* pbstrVersion
);
[C#]
public string Version {get;}
[Visual Basic .NET]
Public ReadOnly Property Version() As String
[Delphi]
property Version: WideString read Get_Version;

Application-Objekt


Visible (CommandBar-Objekt)

Visible (CommandBar-Objekt)

Setzt die Sichtbarkeit der Symbolleiste oder gibt diese zurück.

[C++]
HRESULT get_Visible(
  /*[out, retval]*/ VARIANT_BOOL* pVisible
);
HRESULT put_Visible(
  /*[in]*/ VARIANT_BOOL fVisible
);
[C#]
bool Visible {get; set;}
[Visual Basic .NET]
Public Property Visible() As Boolean
[Delphi]
property Visible: WordBool read Get_Visible write Set_Visible;

CommandBar-Objekt


Visible (CommandBarControl-Objekt)

Visible (CommandBarControl-Objekt)

Gibt an oder legt fest, ob das Element sichtbar ist.

[C++]
HRESULT get_Visible(
  /*[out, retval]*/ VARIANT_BOOL* pVisible
);
HRESULT put_Visible(
  /*[in]*/ VARIANT_BOOL fVisible
);
[C#]
bool Visible {get; set;}
[Visual Basic .NET]
Public Property Visible() As Boolean
[Delphi]
property Visible: WordBool read Get_Visible write Set_Visible;

CommandBarControl-Objekt, CommandBar-Objekt


Visible (MainWindow-Objekt)

Visible (MainWindow-Objekt)

Setzt die Sichtbarkeit des Hauptfensters oder gibt diese zurück.

[C++]
HRESULT get_Visible(
  /*[out, retval]*/ VARIANT_BOOL* pVisible
);
HRESULT put_Visible(
  /*[in]*/ VARIANT_BOOL fVisible
);
[C#]
bool Visible {get; set;}
[Visual Basic .NET]
Public Property Visible() As Boolean
[Delphi]
property Visible: WordBool read Get_Visible write Set_Visible;

MainWindow-Objekt


Width (CommandBar-Objekt)

Width (CommandBar-Objekt)

Setzt die Breite der Symbolleiste oder gibt diese zurück.

[C++]
HRESULT get_Width(
  /*[out, retval]*/ long* pWidth
);
HRESULT put_Width(
  /*[in]*/ long nWidth
);
[C#]
int Width {get; set;}
[Visual Basic .NET]
Public Property Width() As Integer
[Delphi]
property Width: Integer read Get_Width write Set_Width;

CommandBar-Objekt


Width (MainWindow-Objekt)

Width (MainWindow-Objekt)

Gibt die Breite des Hauptfensters zurück oder legt sie fest.

[C++]
HRESULT get_Width(
  /*[out, retval]*/ long* pWidth
);
HRESULT put_Width(
  /*[in]*/ long nWidth
);
[C#]
int Width {get; set;}
[Visual Basic .NET]
Public Property Width() As Integer
[Delphi]
property Width: Integer read Get_Width write Set_Width;

MainWindow-Objekt


Activate (FileContainer-Objekt)

Activate (FileContainer-Objekt)
Aktiviviert die Dateiablage.
[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainer-Objekt


Activate (FileContainers-Objekt)

Activate (FileContainers-Objekt)
Aktiviviert die Dateiablagen.
[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainers-Objekt


Activate (FolderWindow-Objekt)

Activate (FolderWindow-Objekt)

Aktiviert das Ordnerfenster.

[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt


Activate (FolderWindows-Objekt)

Activate (FolderWindows-Objekt)

Aktiviert die Ordnerfenster.

[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindows-Objekt


Activate (TabWindow-Objekt)

Activate (TabWindow-Objekt)
Aktiviert das Fenster.
[C++]
HRESULT __stdcall Activate();
[C#]
public void Activate();
[Visual Basic .NET]
Public Sub Activate()
[Delphi]
procedure Activate(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

TabWindow-Objekt


Add (AddInCommands-Objekt)

Add (AddInCommands-Objekt)

Erstellt einen neuen Befehl. Wenn bereits ein Befehl mit diesem Namen existiert, so wird der Befehl nicht neu erstellt. Stattdessen wird der existierende Befehl zurückgegeben.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ IAddIn* pAddIn,
  /*[in]*/ BSTR bstrCommandName,
  /*[out, retval]*/ IAddInCommand** ppAddInCommand
);
[C#]
public AddInCommand Add(
  AddIn pAddIn,
  string bstrCommandName
);
[Visual Basic .NET]
Public Function Add( _
  ByVal pAddIn As AddIn, _
  ByVal bstrCommandName As String _
) As AddInCommand
[Delphi]
function Add(
  const pAddIn: IAddIn;
  const bstrCommandName: WideString
): IAddInCommand; safecall;

Parameter

pAddIn
Erforderlich. AddIn-Objekt, welches den Befehl erstellt.
bstrCommandName
Erforderlich. Der Name des neuen Befehls. Der Name muss eindeutig sein, empfohlen wird, den Kurznamen des AddIns voranzustellen (z.B. SampleAddIn.NeuerBefehl).

Rückgabewert

Gibt ein AddInCommand-Objekt zurück.

AddInCommands-Objekt


Add (CommandBarControls-Objekt)

Add (CommandBarControls-Objekt)

Erstellt ein neues Objekt und fügt es in die Symbolleiste ein.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ long nId,
  /*[in]*/ BSTR bstrCaption,
  /*[in, optional]*/ VARIANT varType,
  /*[in, optional]*/ VARIANT varBefore,
  /*[in, optional]*/ VARIANT varTemporary,
  /*[out, retval]*/ ICommandBarControl** ppCommandBarControl
);
[C#]
public CommandBarControl Add(
  int nId,
  string bstrCaption,
  object varType,
  object varBefore,
  object varTemporary
);
[Visual Basic .NET]
Public Function Add( _
  ByVal nId As Integer, _
  ByVal bstrCaption As String, _
  Optional ByVal varType As Object, _
  Optional ByVal varBefore As Object, _
  Optional ByVal varTemporary As Object _
) As CommandBarControl
[Delphi]
function Add(
  nId: Integer;
  const bstrCaption: WideString;
  varType: OleVariant;
  varBefore: OleVariant;
  varTemporary: OleVariant
): ICommandBarControl; safecall;

Parameter

nId
Erforderlich. Die ID für das hinzuzufügende Element.
bstrCaption
Erforderlich. Der Name für das hinzuzufügende Element.
varType
Optional. Der Typ für das hinzuzufügende Element (siehe scCommandBarControlType-Konstanten).
varBefore
Optional. Der Index eines existierenden Elements, vor dem das neue Element eingefügt werden soll.
varTemporary
Optional. Legt fest, ob das neue Element nur temporär ist oder beim Beenden von SpeedCommander gespeichert werden soll.

Rückgabewert

Gibt ein CommandBarControl-Objekt zurück.

CommandBarControls-Objekt, CommandBarControl-Objekt


Add (CommandBars-Objekt)

Add (CommandBars-Objekt)

Erstellt eine neue Symbolleiste.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ BSTR bstrTitle,
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
public CommandBar Add(
  string bstrTitle
);
[Visual Basic .NET]
Public Function Add( _
  ByVal bstrTitle As String _
) As CommandBar
[Delphi]
function Add(
  const bstrTitle: WideString
): ICommandBar; safecall;

Parameter

bstrTitle
Erforderlich. Der Name für die zu erstellende Symbolleiste.

Rückgabewert

Gibt ein CommandBar-Objekt zurück.

CommandBars-Objekt, CommandBar-Objekt


Add (FileContainers-Objekt)

Add (FileContainers-Objekt)

Erstellt eine neue Dateiablage.

[C++]
HRESULT __stdcall Add(
  /*[out, retval]*/ IFileContainer** ppFileContainer
);
[C#]
public FileContainer Add();
[Visual Basic .NET]
Public Function Add() As FileContainer
[Delphi]
function Add(): IFileContainer; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Gibt ein FileContainer-Objekt zurück.

FileContainers-Objekt, FileContainer-Objekt


Add (FolderFavorites-Objekt)

Add (FolderFavorites-Objekt)

Fügt dem Ordnerfavoriten-Menü einen neuen Ordnerfavoriten hinzu.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ BSTR bstrName,
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IFolderFavorite** ppFolderFavorite
);
[C#]
public FolderFavorite Add(
  string bstrName,
  object iInsertAt
);
[Visual Basic .NET]
Public Function Add( _
  ByVal bstrName As String, _
  ByVal iInsertAt As Object _
) As FolderFavorite
[Delphi]
function Add(
  const bstrName: WideString;
  iInsertAt: OleVariant
): IFolderFavorite; safecall;

Parameter

bstrName
Erforderlich. Der Name des neuen Ordnerfavoriten.
iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein FolderFavorite-Objekt zurück.

FolderFavorites-Objekt, FolderFavorite-Objekt


Add (FolderWindows-Objekt)

Add (FolderWindows-Objekt)

Erstellt ein neues Ordnerfenster.

[C++]
HRESULT __stdcall Add(
  /*[out, retval]*/ IFolderWindow** ppFolderWindow
);
[C#]
public FolderWindow Add();
[Visual Basic .NET]
Public Function Add() As FolderWindow
[Delphi]
function Add(): IFolderWindow; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Gibt ein FolderWindow-Objekt zurück.

FolderWindows-Objekt, FolderWindow-Objekt


Add (MultiRename-Objekt)

Add (MultiRename-Objekt)

Fügt der aktuellen Auswahl einen Dateinamen oder alle Dateinamen eines ListItems-Objekts hinzu.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ VARIANT varFileName
);
[C#]
public void Add(
  object varFileName
);
[Visual Basic .NET]
Public Sub Add( _
  ByVal varFileName As Object _
)
[Delphi]
procedure Add(
  varFileName: OleVariant
); safecall;

Parameter

varName
Erforderlich. Dateiname als String oder ein ListItems-Objekt.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

MultiRename-Objekt, ListItems-Objekt


Add (UserTools-Objekt)

Add (UserTools-Objekt)

Fügt dem Anwendungsfavoriten-Menü einen neuen Anwendungsfavoriten hinzu.

[C++]
HRESULT __stdcall Add(
  /*[in]*/ BSTR bstrName,
  /*[in]*/ BSTR bstrCommand,
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IUserTool** ppUserTool
);
[C#]
public UserTool Add(
  string bstrName,
  string bstrCommand,
  object iInsertAt
);
[Visual Basic .NET]
Public Function Add( _
  ByVal bstrName As String, _
  ByVal bstrCommand As String, _
  ByVal iInsertAt As Object _
) As UserTool
[Delphi]
function Add(
  const bstrName: WideString;
  const bstrCommand: WideString;
  iInsertAt: OleVariant
): IUserTool; safecall;

Parameter

bstrName
Erforderlich. Der Name des neuen Anwendungsfavoriten.
bstrCommand
Erforderlich. Der auszuführende Befehl des neuen Anwendungsfavoriten.
iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein UserTool-Objekt zurück.

UserTools-Objekt, UserTool-Objekt


AddImage (Application-Objekt)

AddImage (Application-Objekt)

Fügt das angegebene Symbol zur Systemimageliste hinzu.

[C++]
HRESULT __stdcall AddImage(
  /*[in]*/ BSTR bstrIconPath,
  /*[in]*/ long iIconIndex,
  /*[in]*/ long dwFlags,
  /*[out, retval] long* pIndex
);
[C#]
public int AddImage(
  string bstrIconPath,
  int iIconIndex,
  int dwFlags
);
[Visual Basic .NET]
Public Function AddImage( _
  ByVal bstrIconPath As String, _
  ByVal iIconIndex As Integer, _
  ByVal dwFlags As Integer _
) As Integer
[Delphi]
procedure AddImage(
  const bstrIconPath: WideString;
  iIconIndex: Integer;
  dwFlags: Integer
): Integer; safecall;

Parameter

bstrIconPath
Erforderlich. Der Name des ausführbaren Moduls, welches das Symbol enthält.
iIconIndex
Erforderlich. Der Index des Symbols im ausführbaren Modul oder der Ressourcenname als negativer Wert.
dwFlags
Erforderlich. Flags für die Funktion Shell_GetCachedImageIndex (GIL_DONTCACHE und/oder GIL_COMPARE).

Rückgabewert

Index des Symbols in der Systemimageliste oder -1 bei einem Fehler.

Application-Objekt


AddMenu (FolderFavorites-Objekt)

AddMenu (FolderFavorites-Objekt)

Erstellt einen neuen Menüeintrag.

[C++]
HRESULT __stdcall AddMenu(
  /*[in]*/ BSTR bstrName,
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IFolderFavorite** ppFolderFavorite
);
[C#]
public FolderFavorite AddMenu(
  string bstrName,
  object iInsertAt
);
[Visual Basic .NET]
Public Function AddMenu( _
  ByVal bstrName As String, _
  ByVal iInsertAt As Object _
) As FolderFavorite
[Delphi]
function AddMenu(
  const bstrName: WideString;
  iInsertAt: OleVariant
): IFolderFavorite; safecall;

Parameter

bstrName
Erforderlich. Der Name des neuen Menüeintrages.
iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein FolderFavorite-Objekt zurück.

FolderFavorites-Objekt, FolderFavorite-Objekt


AddMenu (UserTools-Objekt)

AddMenu (UserTools-Objekt)

Erstellt einen neuen Menüeintrag.

[C++]
HRESULT __stdcall AddMenu(
  /*[in]*/ BSTR bstrName,
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IUserTool** ppUserTool
);
[C#]
public UserTool AddMenu(
  string bstrName,
  object iInsertAt
);
[Visual Basic .NET]
Public Function AddMenu( _
  ByVal bstrName As String, _
  ByVal iInsertAt As Object _
) As UserTool
[Delphi]
function AddMenu(
  const bstrName: WideString;
  iInsertAt: OleVariant
): IUserTool; safecall;

Parameter

bstrName
Erforderlich. Der Name des neuen Menüeintrages.
iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein UserTool-Objekt zurück.

UserTools-Objekt, UserTool-Objekt


AddSeparator (FolderFavorites-Objekt)

AddSeparator (FolderFavorites-Objekt)

Fügt dem Ordnerfavoriten-Menü ein neues Trennzeichen hinzu.

[C++]
HRESULT __stdcall AddSeparator(
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IFolderFavorite** ppFolderFavorite
);
[C#]
public FolderFavorite AddSeparator(
  object iInsertAt
);
[Visual Basic .NET]
Public Function AddSeparator( _
  ByVal iInsertAt As Object _
) As FolderFavorite
[Delphi]
function AddSeparator(
  iInsertAt: OleVariant
): IFolderFavorite; safecall;

Parameter

iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein FolderFavorite-Objekt zurück.

FolderFavorites-Objekt, FolderFavorite-Objekt


AddSeparator (UserTools-Objekt)

AddSeparator (UserTools-Objekt)

Fügt dem Anwendungsfavoriten-Menü ein neues Trennzeichen hinzu.

[C++]
HRESULT __stdcall AddSeparator(
  /*[in, optional]*/ VARIANT iInsertAt,
  /*[out, retval]*/ IUserTool** ppUserTool
);
[C#]
public UserTool AddSeparator(
  object iInsertAt
);
[Visual Basic .NET]
Public Function AddSeparator( _
  ByVal iInsertAt As Object _
) As UserTool
[Delphi]
function AddSeparator(
  iInsertAt: OleVariant
): IUserTool; safecall;

Parameter

iInsertAt
Optional. Legt die Einfügeposition fest.

Rückgabewert

Gibt ein UserTool-Objekt zurück.

UserTools-Objekt, UserTool-Objekt


Close (FileContainer-Objekt)

Close (FileContainer-Objekt)

Schließt die Dateiablage.

[C++]
HRESULT __stdcall Close();
[C#]
public void Close();
[Visual Basic .NET]
Public Sub Close()
[Delphi]
procedure Close(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainer-Objekt


Close (FolderWindow-Objekt)

Close (FolderWindow-Objekt)

Schließt das Ordnerfenster.

[C++]
HRESULT __stdcall Close();
[C#]
public void Close();
[Visual Basic .NET]
Public Sub Close()
[Delphi]
procedure Close(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt


CloseAll (FileContainers-Objekt)

CloseAll (FileContainers-Objekt)

Entfernt alle Dateiablagen bis auf die aktive Dateiablage.

[C++]
HRESULT __stdcall CloseAll();
[C#]
public void CloseAll();
[Visual Basic .NET]
Public Sub CloseAll()
[Delphi]
procedure CloseAll(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainers-Objekt


CloseAll (FolderWindows-Objekt)

CloseAll (FolderWindows-Objekt)

Entfernt alle Ordnerfenster bis auf das aktive Ordnerfenster.

[C++]
HRESULT __stdcall CloseAll();
[C#]
public void CloseAll();
[Visual Basic .NET]
Public Sub CloseAll()
[Delphi]
procedure CloseAll(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindows-Objekt


Delete (CommandBar-Objekt)

Delete (CommandBar-Objekt)

Löscht eine Symbolleiste.

[C++]
HRESULT __stdcall Delete();
[C#]
public void Delete();
[Visual Basic .NET]
Public Sub Delete()
[Delphi]
procedure Delete; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandBar-Objekt


Delete (CommandBarControl-Objekt)

Delete (CommandBarControl-Objekt)

Löscht ein Element.

[C++]
HRESULT __stdcall Delete();
[C#]
public void Delete();
[Visual Basic .NET]
Public Sub Delete()
[Delphi]
procedure Delete; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandBarControl-Objekt


EmptySection (AddInSettings-Objekt)

EmptySection (AddInSettings-Objekt)

Löscht eine Sektion aus der XML-Datei von SpeedCommander.

[C++]
HRESULT __stdcall EmptySection(
  /*[in]*/ BSTR bstrProgID,
  /*[in]*/ BSTR bstrSection
);
[C#]
public void EmptySection(
  string bstrProgID,
  string bstrSection
);
[Visual Basic .NET]
Public Sub EmptySection( _
  ByVal bstrProgID As String, _
  ByVal bstrSection As String _
)
[Delphi]
procedure EmptySection(
  const bstrProgID: WideString;
  const bstrSection: WideString
); safecall;

Parameter

bstrProgID
Erforderlich. ProgID des AddIns, für welches die Sektion gelöscht werden soll..
bstrSection
Erforderlich. Die zu löschende Sektion.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddInSettings-Objekt


EnableDocking (CommandBar-Objekt)

EnableDocking (CommandBar-Objekt)

Legt fest, ob und wie eine Symbolleiste angedockt werden kann.

[C++]
HRESULT __stdcall EnableDocking(
  /*[in]*/ enum scCommandBarFlags dwFlags
);
[C#]
public void EnableDocking(
  scCommandBarFlags dwFlags
);
[Visual Basic .NET]
Public Sub EnableDocking( _
  ByVal dwFlags As scCommandBarFlags _
)
[Delphi]
procedure EnableDocking(
  dwFlags: scCommandBarFlags
); safecall;

Parameter

dwFlags
Erforderlich. Gibt die Seiten an, an denen die Symbolleiste angedockt werden kann.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandBar-Objekt, scCommandBarFlags-Konstanten


ExecuteCommand (Application-Objekt)

ExecuteCommand (Application-Objekt)

Führt den angegebenen Befehl aus.

[C++]
HRESULT __stdcall ExecuteCommand(
  /*[in]*/ enum scCommand eCommand
);
[C#]
public void ExecuteCommand(
  scCommand eCommand
);
[Visual Basic .NET]
Public Sub ExecuteCommand( _
  ByVal eCommand As scCommand _
)
[Delphi]
procedure ExecuteCommand(
  eCommand: scCommand
); safecall;

Parameter

eCommand
Erforderlich. Gibt den aufzurufenden Befehl an.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

Application-Objekt, scCommand-Konstanten


FindControl (CommandBar-Objekt)

FindControl (CommandBar-Objekt)

Sucht ein Element in der Symbolleiste.

[C++]
HRESULT __stdcall FindControl(
  /*[in]*/ long nId,
  /*[in, optional]*/ VARIANT varType,
  /*[in, optional]*/ VARIANT varVisible,
  /*[in, optional]*/ VARIANT varRecursive,
  /*[out, retval]*/ ICommandBarControl** ppCommandBarControl
);
[C#]
public CommandBarControl FindControl(
  System.Int32 nId,
  System.Object varType,
  System.Object varVisible,
  System.Object varRecursive
);
[Visual Basic .NET]
Public Function FindControl( _
  ByVal nId As Integer, _
  Optional ByVal varType As Object, _
  Optional ByVal varVisible As Object, _
  Optional ByVal varRecursive As Object _
)
[Delphi]
function FindControl(
  nId: Integer;
  varType: OleVariant;
  varVisible: OleVariant;
  varRecursive: OleVariant
): ICommandBarControl; safecall;

Parameter

nID
Erforderlich. Gibt die ID des gesuchten Elements an.
varType
Optional. Gibt den Typ des gesuchten Elements an (siehe scCommandBarControlType-Konstanten).
varVisible
Optional. Gibt an, ob das Element sichtbar sein soll.
varRecursive
Optional. Gibt an, ob auch in den untergeordneten CommandBar-Objekten gesucht werden soll.

Rückgabewert

Gibt ein CommandBarControl-Objekt zurück.

CommandBar-Objekt, CommandBarControl-Objekt


FindControl (CommandBarControls-Objekt)

FindControl (CommandBarControls-Objekt)

Sucht ein Element in der Symbolleiste.

[C++]
HRESULT __stdcall FindControl(
  /*[in]*/ long nId,
  /*[in, optional]*/ VARIANT varType,
  /*[in, optional]*/ VARIANT varVisible,
  /*[in, optional]*/ VARIANT varRecursive,
  /*[out, retval]*/ ICommandBarControl** ppCommandBarControl
);
[C#]
public CommandBarControl FindControl(
  System.Int32 nId,
  System.Object varType,
  System.Object varVisible,
  System.Object varRecursive
);
[Visual Basic .NET]
Public Function FindControl( _
  ByVal nId As Integer, _
  Optional ByVal varType As Object, _
  Optional ByVal varVisible As Object, _
  Optional ByVal varRecursive As Object _
)
[Delphi]
function FindControl(
  nId: Integer;
  varType: OleVariant;
  varVisible: OleVariant;
  varRecursive: OleVariant
): ICommandBarControl; safecall;

Parameter

nID
Erforderlich. Gibt die ID des gesuchten Elements an.
varType
Optional. Gibt den Typ des gesuchten Elements an (siehe scCommandBarControlType-Konstanten).
varVisible
Optional. Gibt an, ob das Element sichtbar sein soll.
varRecursive
Optional. Gibt an, ob auch in den untergeordneten CommandBar-Objekten gesucht werden soll.

Rückgabewert

Gibt ein CommandBarControl-Objekt zurück.

CommandBarControls-Objekt, CommandBarControl-Objekt


GetEvents (Application-Objekt)

GetEvents (Application-Objekt)

Ermöglicht den Zugriff auf alle Ereignisse des Erweiterungsmodells.

[C++]
HRESULT __stdcall GetEvents(
  /*[in]*/ enum scEvents eEvents,
  /*[out, retval] IDispatch** ppInterface
);
[C#]
public object GetEvents(
  scEvents eEvents
);
[Visual Basic .NET]
Public Function GetEvents( _
  ByVal eEvents As scEvents _
) As Object
[Delphi]
function GetEvents(
  eEvents: scEvents
): IDispatch; safecall;

Parameter

eObject
Erforderlich. Gibt das Ereignisobjekt an, welches abgefragt werden soll.

Rückgabewert

Gibt das gewünschte Ereignisobjekt zurück.

Application-Objekt, scEvents-Konstanten


GetObject (Application-Objekt)

GetObject (Application-Objekt)

Gibt ein bestimmtes Anwendungsobjekt zurück.

[C++]
HRESULT __stdcall GetObject(
  /*[in]*/ enum scObject eObject,
  /*[out, retval] IDispatch** ppInterface
);
[C#]
public object GetObject(
  scObject eObject
);
[Visual Basic .NET]
Public Function GetObject( _
  ByVal eObject As scObject _
) As Object
[Delphi]
function GetObject(
  eObject: scObject
): IDispatch; safecall;

Parameter

eObject
Erforderlich. Gibt das Objekt an, welches abgefragt werden soll.

Rückgabewert

Gibt das gewünschte Objekt zurück.

Application-Objekt, scObject-Konstanten


Help (Application-Objekt)

Help (Application-Object)

Ruft die Hilfedatei auf.

[C++]
HRESULT __stdcall Help();
[C#]
public void Help();
[Visual Basic .NET]
Public Sub Help()
[Delphi]
procedure Help; safecall;

Parameter

Diese Methode benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

Application-Objekt


Invert (ListSelection-Objekt)

Invert (ListSelection-Objekt)

Invertiert die Auswahl.

[C++]
HRESULT __stdcall Invert();
[C#]
public void Invert();
[Visual Basic .NET]
Public Sub Invert()
[Delphi]
procedure Invert; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Invoke (FolderFavorite-Objekt)

Invoke (FolderFavorite-Objekt)

Aktiviert den Ordnerfavoriten. Entsprechend der gesetzten Eigenschaften werden die Ordner im aktiven und/oder inaktiven Ordnerfenster geändert.

[C++]
HRESULT __stdcall Invoke();
[C#]
public void Invoke();
[Visual Basic .NET]
Public Sub Invoke()
[Delphi]
procedure Invoke; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderFavorite-Objekt


Invoke (UserTool-Objekt)

Invoke (UserTool-Objekt)

Startet den Anwendungsfavoriten.

[C++]
HRESULT __stdcall Invoke();
[C#]
public void Invoke();
[Visual Basic .NET]
Public Sub Invoke()
[Delphi]
procedure Invoke; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

UserTool-Objekt


Item (AddInCommands-Objekt)

Item (AddInCommands-Objekt)

Gibt eine bestimmtes Objekt (AddInCommand-Objekt) innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IAddInCommand** ppAddInCommand
);
[C#]
public AddInCommand Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As AddInCommand
[Delphi]
function Item(
  nIndex: Integer
): IAddInCommand; safecall;

Parameter

nIndex
Erforderlich. Der Index des Elements in der Auflistung.

Rückgabewert

Gibt ein AddInCommand-Objekt zurück.

AddInCommands-Objekt


Item (AddIns-Objekt)

Item (AddIns-Objekt)

Gibt eine bestimmtes Objekt (AddIn-Objekt) innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ VARIANT nIndex,
  /*[out, retval]*/ IAddIn** ppAddIn
);
[C#]
public AddIn Item(
  object nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Object _
) As AddIn
[Delphi]
function Item(
  nIndex: OleVariant
): IAddIn; safecall;

Parameter

nIndex
Erforderlich. Die ProgID des AddIns (String) oder der Index innerhalb der AddIn-Liste.

Rückgabewert

Gibt ein AddIn-Objekt zurück.

AddIns-Objekt, AddIn-Objekt


Item (CommandBarControls-Objekt)

Item (CommandBarControls-Objekt)

Gibt ein bestimmtes CommandBarControl-Objekt innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ ICommandBarControl** ppCommandBarControl
);
[C#]
public CommandBarControl Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As CommandBarControl
[Delphi]
function Item(
  nIndex: Integer
): ICommandBarControl; safecall;

Parameter

nIndex
Erforderlich. Der Index des Elements in der Auflistung.

Rückgabewert

Gibt ein CommandBarControl-Objekt zurück.

CommandBarControl-Objekt, CommandBarControls-Objekt


Item (CommandBars-Objekt)

Item (CommandBars-Objekt)

Gibt ein bestimmtes CommandBar-Objekt innerhalb der CommandBars-Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
public CommandBar Item(
  System.Int32 nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As CommandBar
[Delphi]
function Item(
  nIndex: Integer
): ICommandBar; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index der Symbolleiste.

Rückgabewert

Gibt ein CommandBar-Objekt zurück.

CommandBars-Objekt, CommandBar-Objekt


Item (FileContainers-Objekt)

Item (FileContainers-Objekt)

Gibt eine bestimmte Dateiablage innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IFileContainer** ppFileContainer
);
[C#]
public FileContainer Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As FileContainer
[Delphi]
function Item(
  nIndex: Integer
): IFileContainer; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index der Dateiablage.

Rückgabewert

Gibt ein FileContainer-Objekt zurück.

FileContainers-Objekt, FileContainer-Objekt


Item (FolderFavorites-Objekt)

Item (FolderFavorites-Objekt)

Gibt ein bestimmtes FolderFavorite-Objekt innerhalb der FolderFavorites-Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IFolderFavorite** ppFolderFavorite
);
[C#]
public FolderFavorite Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As FolderFavorite
[Delphi]
function Item(
  nIndex: Integer
): IFolderFavorite; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index des Ordnerfavoriten.

Rückgabewert

Gibt ein FolderFavorit-Objekt zurück.

FolderFavorites-Objekt, FolderFavorit-Objekt


Item (FolderWindows-Objekt)

Item (FolderWindows-Objekt)

Gibt ein bestimmtes Ordnerfenster innerhalb der Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IFolderWindow** ppFolderWindow
);
[C#]
public FolderWindow Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As FolderWindow
[Delphi]
function Item(
  nIndex: Integer
): IFolderWindow; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index des Ordnerfensters.

Rückgabewert

Gibt ein FolderWindow-Objekt zurück.

FolderWindows-Objekt, FolderWindow-Objekt


Item (ListItems-Objekt)

Item (ListItems-Objekt)

Gibt ein bestimmtes ListItem-Objekt innerhalb der ListItems-Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IListItem** ppListItem
);
[C#]
public ListItem Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As ListItem
[Delphi]
function Item(
  nIndex: Integer
): IListItem; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index des Eintrages.

Rückgabewert

Gibt ein ListItem-Objekt zurück.

ListItems-Objekt, ListItem-Objekt


Item (UserTools-Objekt)

Item (UserTools-Objekt)

Gibt ein bestimmtes UserTool-Objekt innerhalb der UserTools-Auflistung zurück.

[C++]
HRESULT __stdcall Item(
  /*[in]*/ long nIndex,
  /*[out, retval]*/ IUserTool** ppUserTool
);
[C#]
public UserTool Item(
  int nIndex
);
[Visual Basic .NET]
Public Function Item( _
  ByVal nIndex As Integer _
) As UserTool
[Delphi]
function Item(
  nIndex: Integer
): IUserTool; safecall;

Parameter

nIndex
Erforderlich. Der absolute Index des Anwendungsfavoriten.

Rückgabewert

Gibt ein UserTool-Objekt zurück.

UserTools-Objekt, UserTool-Objekt


MoveLeft (FileContainer-Objekt)

MoveLeft (FileContainer-Objekt)

Verschiebt die Dateiablage in der FileContainers-Auflistung um eine Position nach links.

[C++]
HRESULT __stdcall MoveLeft();
[C#]
public void MoveLeft();
[Visual Basic .NET]
Public Sub MoveLeft()
[Delphi]
procedure MoveLeft(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainer-Objekt , FileContainers-Objekt


MoveLeft (FolderWindow-Objekt)

MoveLeft (FolderWindow-Objekt)

Verschiebt das Ordnerfenster in der FolderWindows-Auflistung um eine Position nach links.

[C++]
HRESULT __stdcall MoveLeft();
[C#]
public void MoveLeft();
[Visual Basic .NET]
Public Sub MoveLeft()
[Delphi]
procedure MoveLeft(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt, FolderWindows-Objekt


MoveRight (FileContainer-Objekt)

MoveRight (FileContainer-Objekt)

Verschiebt die Dateiablage in der FileContainers-Auflistung um eine Position nach rechts.

[C++]
HRESULT __stdcall MoveRight();
[C#]
public void MoveRight();
[Visual Basic .NET]
Public Sub MoveRight()
[Delphi]
procedure MoveRight(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainer-Objekt, FileContainers-Objekt


MoveRight (FolderWindow-Objekt)

MoveRight (FolderWindow-Objekt)

Verschiebt das Ordnerfenster in der FolderWindows-Auflistung um eine Position nach rechts.

[C++]
HRESULT __stdcall MoveRight();
[C#]
public void MoveRight();
[Visual Basic .NET]
Public Sub MoveRight()
[Delphi]
procedure MoveRight(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt, FolderWindows-Objekt


Quit (Application-Objekt)

Quit (Application-Objekt)

Beendet die Anwendung.

[C++]
HRESULT __stdcall Quit();
[C#]
public void Quit();
[Visual Basic .NET]
Public Sub Quit()
[Delphi]
procedure Quit; safecall;

Parameter

Diese Methode benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

Application-Objekt


Read (AddInSettings-Objekt)

Read (AddInSettings-Objekt)

Liest eine AddIn-Einstellung aus der XML-Datei von SpeedCommander.

[C++]
HRESULT __stdcall Read(
  /*[in]*/ BSTR bstrProgID,
  /*[in]*/ BSTR bstrSection,
  /*[in]*/ BSTR bstrProp,
  /*[in]*/ VARTYPE varType,
  /*[out, retval]*/ VARIANT* pData
);
[C#]
public object Read(
  string bstrProgID,
  string bstrSection,
  string bstrProp,
  ushort varData
);
[Visual Basic .NET]
Public Function Read( _
  ByVal bstrProgID As String, _
  ByVal bstrSection As String, _
  ByVal bstrProp As String, _
  ByVal varData As UInt16 _
) As Object
[Delphi]
function Read(
  const bstrProgID: WideString;
  const bstrSection: WideString;
  const bstrProp: WideString;
  varData: Word
): OleVariant; safecall;

Parameter

bstrProgID
Erforderlich. ProgID des AddIns, für welches die Einstellung gelesen werden soll.
bstrSection
Erforderlich. Die Sektion, in welche die Einstellung gespeichert ist. Mehrere Sektionsnamen werden durch einen Backslash getrennt.
bstrProp
Erforderlich. Der Name der Eigenschaft.
varType
Erforderlich. Der Datentyp für die zu lesende Einstellung. Gültige Werte sind VT_BSTR, VT_DATE, VTI4 und VTI8.

Rückgabewert

Gibt eine VARIANT-Struktur zurück.

AddInSettings-Objekt


Refresh (FolderWindow-Objekt)

Refresh (FolderWindow-Objekt)

Aktualisiert das Ordnerfenster.

[C++]
HRESULT __stdcall Refresh();
[C#]
public void Refresh();
[Visual Basic .NET]
Public Sub Refresh()
[Delphi]
procedure Refresh(); safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindow-Objekt


Remove (AddInCommands-Objekt)

Remove (AddInCommands-Objekt)

Löscht einen Befehl.

[C++]
HRESULT __stdcall Remove(
  /*[in]*/ BSTR bstrCommandName
);
[C#]
public void Remove(
  string bstrCommandName
);
[Visual Basic .NET]
Public Sub Remove( _
  ByVal bstrCommandName As String _
)
[Delphi]
procedure Remove(
  const bstrCommandName: WideString
); safecall;

Parameter

bstrCommandName
Erforderlich. Der Name des Befehls.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddInCommands-Objekt


Remove (FolderFavorite-Objekt)

Remove (FolderFavorite-Objekt)

Löscht den Ordnerfavoriten.

[C++]
HRESULT __stdcall Remove();
[C#]
public void Remove();
[Visual Basic .NET]
Public Sub Remove()
[Delphi]
procedure Remove; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderFavorite-Objekt


Remove (UserTool-Objekt)

Remove (UserTool-Objekt)

Löscht den Anwendungsfavoriten.

[C++]
HRESULT __stdcall Remove();
[C#]
public void Remove();
[Visual Basic .NET]
Public Sub Remove()
[Delphi]
procedure Remove; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

UserTool-Objekt


RemoveAll (FolderFavorites-Objekt)

RemoveAll (FolderFavorites-Objekt)

Löscht alle Ordnerfavoriten.

[C++]
HRESULT __stdcall RemoveAll();
[C#]
public void RemoveAll();
[Visual Basic .NET]
Public Sub RemoveAll()
[Delphi]
procedure RemoveAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderFavorites-Objekt


RemoveAll (MultiRename-Objekt)

RemoveAll (MultiRename-Objekt)

Entfernt alle Dateien aus der Liste der umzubenennenden Dateien.

[C++]
HRESULT __stdcall RemoveAll();
[C#]
public void RemoveAll();
[Visual Basic .NET]
Public Sub RemoveAll()
[Delphi]
procedure RemoveAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

MultiRename-Objekt


RemoveAll (UserTools-Objekt)

RemoveAll (UserTools-Objekt)

Löscht alle Anwendungsfavoriten.

[C++]
HRESULT __stdcall RemoveAll();
[C#]
public void RemoveAll();
[Visual Basic .NET]
Public Sub RemoveAll()
[Delphi]
procedure RemoveAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

UserTools-Objekt


Rename (MultiRename-Objekt)

Rename (MultiRename-Objekt)

Benennt alle Dateien, die sich in der Dateiliste befinden, entsprechend den gewählten Einstellungen um.

[C++]
HRESULT __stdcall Rename(
  /*[out, retval]*/ scMrtResult eResult
);
[C#]
public scMrtResult Rename();
[Visual Basic .NET]
Public Function Rename() As scMrtResult
[Delphi]
function Rename: scMrtResult; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Das Ergebnis der Aktion als scMrtResult-Konstante.

MultiRename-Objekt, scMrtResult-Konstanten


Restore (ListSelection-Objekt)

Restore (ListSelection-Objekt)

Stellt die zuletzt gespeicherte Auswahl wieder her.

[C++]
HRESULT __stdcall Restore();
[C#]
public void Restore();
[Visual Basic .NET]
Public Sub Restore()
[Delphi]
procedure Restore; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Save (FolderFavorites-Objekt)

Save (FolderFavorites-Objekt)

Speichert die Ordnerfavoriten.

[C++]
HRESULT __stdcall Save();
[C#]
public void Save();
[Visual Basic .NET]
Public Sub Save()
[Delphi]
procedure Save; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderFavorites-Objekt


Save (ListSelection-Objekt)

Save (ListSelection-Objekt)

Speichert eine Auswahl.

[C++]
HRESULT __stdcall Save();
[C#]
public void Save();
[Visual Basic .NET]
Public Sub Save()
[Delphi]
procedure Save; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Save (UserTools-Objekt)

Save (UserTools-Objekt)

Speichert die Anwendungsfavoriten.

[C++]
HRESULT __stdcall Save();
[C#]
public void Save();
[Visual Basic .NET]
Public Sub Save()
[Delphi]
procedure Save; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

UserTools-Objekt


SaveSettings (AddInSettings-Objekt)

SaveSettings (AddInSettings-Objekt)

Schreibt alle gespeicherten Einstellungen in die XML-Datei.

[C++]
HRESULT __stdcall SaveSettings();
[C#]
public void SaveSettings();
[Visual Basic .NET]
Public Sub SaveSettings()
[Delphi]
procedure SaveSettings; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddInSettings-Objekt


Select (ListSelection-Objekt)

Select (ListSelection-Objekt)

Wählt Dateien und Ordner anhand einer Maske aus.

[C++]
HRESULT __stdcall Select(
  /*[in]*/ BSTR bstrMask
);
[C#]
public void Select(
  string bstrMask
);
[Visual Basic .NET]
Public Sub Select(
  ByVal bstrMask As String
)
[Delphi]
procedure Select(
  const bstrMask: WideString
); safecall;

Parameter

bstrMask
Erforderlich. Dateimaske, nach welcher die Dateien markiert werden soll. Die Dateimaske kann auch Stellvertreterzeichen enthalten.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


SelectAll (ListSelection-Objekt)

SelectAll (ListSelection-Objekt)

Wählt alle Dateien und Ordner aus.

[C++]
HRESULT __stdcall SelectAll();
[C#]
public void SelectAll();
[Visual Basic .NET]
Public Sub SelectAll()
[Delphi]
procedure SelectAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


SelectAllFiles (ListSelection-Objekt)

SelectAllFiles (ListSelection-Objekt)

Wählt alle Dateien aus.

[C++]
HRESULT __stdcall SelectAllFiles();
[C#]
public void SelectAllFiles();
[Visual Basic .NET]
Public Sub SelectAllFiles()
[Delphi]
procedure SelectAllFiles; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Unselect (ListSelection-Objekt)

Unselect (ListSelection-Objekt)

Entfernt die Auswahl für bestimmte Dateien anhand einer Maske.

[C++]
HRESULT __stdcall Unselect(
  /*[in]*/ BSTR bstrMask
);
[C#]
public void Unselect(
  string bstrMask
);
[Visual Basic .NET]
Public Sub Unselect(
  ByVal bstrMask As String
)
[Delphi]
procedure Unselect(
  const bstrMask: WideString
); safecall;

Parameter

bstrMask
Erforderlich. Dateimaske, nach welcher die Markierung aufgehoben werden soll. Die Dateimaske kann auch Stellvertreterzeichen enthalten.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


UnselectAll (ListSelection-Objekt)

UnselectAll (ListSelection-Objekt)

Entfernt die Auswahl für alle Dateien und Ordner.

[C++]
HRESULT __stdcall UnselectAll();
[C#]
public void UnselectAll();
[Visual Basic .NET]
Public Sub UnselectAll()
[Delphi]
procedure UnselectAll; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


UnselectAllFiles (ListSelection-Objekt)

UnselectAllFiles (ListSelection-Objekt)

Entfernt die Auswahl für alle Dateien.

[C++]
HRESULT __stdcall UnselectAllFiles();
[C#]
public void UnselectAllFiles();
[Visual Basic .NET]
Public Sub UnselectAllFiles()
[Delphi]
procedure UnselectAllFiles; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

ListSelection-Objekt


Write (AddInSettings-Objekt)

Write (AddInSettings-Objekt)

Speichert eine AddIn-Einstellung.

[C++]
HRESULT __stdcall Write(
  /*[in]*/ BSTR bstrProgID,
  /*[in]*/ BSTR bstrSection,
  /*[in]*/ BSTR bstrProp,
  /*[in]*/ VARIANT varData
);
[C#]
public void Write(
  string bstrProgID,
  string bstrSection,
  string bstrProp,
  object varData
);
[Visual Basic .NET]
Public Sub Write( _
  ByVal bstrProgID As String, _
  ByVal bstrSection As String, _
  ByVal bstrProp As String, _
  ByVal varData As Object _
)
[Delphi]
procedure Write(
  const bstrProgID: WideString;
  const bstrSection: WideString;
  const bstrProp: WideString;
  varData: OleVariant
); safecall;

Parameter

bstrProgID
Erforderlich. ProgID des AddIns, für welches die Einstellung gespeichert werden soll.
bstrSection
Erforderlich. Die Sektion, in welcher die Einstellung gespeichert wird. Mehrere Sektionsnamen werden durch einen Backslash getrennt.
bstrProp
Erforderlich. Der Name der zu speichernden Eigenschaft.
varData
Erforderlich. Der Wert für die zu speichernde Eigenschaft als Variant. Gültige Werte für die Variant-Struktur sind VT_BSTR, VT_DATE, VTI4 und VTI8.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddInSettings-Objekt


AfterExecute (CommandEvents-Objekt)

AfterExecute (CommandEvents-Objekt)

Tritt nach der Ausführung eines Befehls ein.

[C++]
HRESULT __stdcall AfterExecute(
  /*[in]*/ enum scCommand eCommand
);
[C#]
public void AfterExecute(
  scCommand eCommand
);
[Visual Basic .NET]
Public Sub AfterExecute( _
  ByVal eCommand As scCommand _
)
[Delphi]
procedure AfterExecute(
  eCommand: scCommand
); safecall;

Parameter

eCommand
Erforderlich. Gibt den aufzurufenden Befehl an.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandEvents-Objekt, scCommand-Konstanten


BeforeExecute (CommandEvents-Objekt)

BeforeExecute (CommandEvents-Objekt)

Tritt vor der Ausführung eines Befehls ein.

[C++]
HRESULT __stdcall BeforeExecute(
  /*[in]*/ enum scCommand eCommand,
  /*[out]*/ VARIANT_BOOL* pfCancelDefault
);
[C#]
public void BeforeExecute(
  scCommand eCommand,
  ref bool pfCancelDefault
);
[Visual Basic .NET]
Public Sub BeforeExecute( _
  ByVal eCommand As scCommand, _
  ByRef pfCancelDefault As Boolean _
)
[Delphi]
procedure BeforeExecute(
  eCommand: scCommand,
  var pfCancelDefault: WordBool
); safecall;

Parameter

eCommand
Erforderlich. Gibt den aufzurufenden Befehl an.
pfCancelDefault
Erforderlich. Gibt VARIANT_FALSE zurück, wenn der Standardbefehl nicht aufgerufen werden soll.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

CommandEvents-Objekt, scCommand-Konstanten


WindowActivated (FileContainerEvents-Objekt)

WindowActivated (FileContainerEvents-Objekt)

Tritt ein, wenn eine Dateiablage den Fokus erhält.

[C++]
HRESULT __stdcall WindowActivated(
  /*[in]*/ IFileContainer* pWndGotFocus,
  /*[in]*/ IFileContainer* pWndLostFocus
);
[C#]
public void WindowActivated(
  FileContainer pWndGotFocus,
  FileContainer pWndLostFocus
);
[Visual Basic .NET]
Public Sub WindowActivated( _
  ByVal pWndGotFocus As FileContainer, _
  ByVal pWndLostFocus As FileContainer _
)
[Delphi]
procedure WindowActivated(
  pWndGotFocus: IFileContainer;
  pWndLostFocus: IFileContainer
); safecall;

Parameter

pWndGotFocus
Erforderlich. Die Dateiablage, welche den Fokus erhalten hat.
pWndLostFocus
Erforderlich. Die Dateiablage, welche zuvor über den Fokus verfügt hat.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainerEvents-Objekt, FileContainer-Objekt


WindowActivated (FolderWindowEvents-Objekt)

WindowActivated (FolderWindowEvents-Objekt)

Tritt ein, wenn ein Ordnerfenster den Fokus erhält.

[C++]
HRESULT __stdcall WindowActivated(
  /*[in]*/ IFolderWindow* pWndGotFocus,
  /*[in]*/ IFolderWindow* pWndLostFocus
);
[C#]
public void WindowActivated(
  FolderWindow pWndGotFocus,
  FolderWindow pWndLostFocus
);
[Visual Basic .NET]
Public Sub WindowActivated( _
  ByVal pWndGotFocus As FolderWindow, _
  ByVal pWndLostFocus As FolderWindow _
)
[Delphi]
procedure WindowActivated(
  pWndGotFocus: IFolderWindow;
  pWndLostFocus: IFolderWindow
); safecall;

Parameter

pWndGotFocus
Erforderlich. Das Ordnerfenster, welches den Fokus erhalten hat.
pWndLostFocus
Erforderlich. Das Ordnerfenster, welches zuvor über den Fokus verfügt hat.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindowEvents-Objekt, FolderWindow-Objekt


WindowActivated (TabWindowEvents-Objekt)

WindowActivated (TabWindowEvents-Objekt)

Tritt ein, wenn ein Fenster den Fokus erhält.

[C++]
HRESULT __stdcall WindowActivated(
  /*[in]*/ ITabWindow* pWndGotFocus,
  /*[in]*/ ITabWindow* pWndLostFocus
);
[C#]
public void WindowActivated(
  TabWindow pWndGotFocus,
  TabWindow pWndLostFocus
);
[Visual Basic .NET]
Public Sub WindowActivated( _
  ByVal pWndGotFocus As TabWindow, _
  ByVal pWndLostFocus As TabWindow _
)
[Delphi]
procedure WindowActivated(
  pWndGotFocus: ITabWindow;
  pWndLostFocus: ITabWindow
); safecall;

Parameter

pWndGotFocus
Erforderlich. Das Fenster, welches den Fokus erhalten hat.
pWndLostFocus
Erforderlich. Das Fenster, welches zuvor über den Fokus verfügt hat.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

TabWindowEvents-Objekt, TabWindow-Objekt


WindowClosing (FileContainerEvents-Objekt)

WindowClosing (FileContainerEvents-Objekt)

Tritt unmittelbar vor dem Schließen einer Dateiablage ein.

[C++]
HRESULT __stdcall WindowClosing(
  /*[in]*/ IFileContainer* pWndClosing
);
[C#]
public void WindowClosing(
  FileContainer pWndClosing
);
[Visual Basic .NET]
Public Sub WindowClosing( _
  ByVal pWndClosing As FileContainer _
)
[Delphi]
procedure WindowClosing(
  pWndClosing: IFileContainer
); safecall;

Parameter

pWndClosing
Erforderlich. Die Dateiablage, welche geschlossen wird.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainerEvents-Objekt, FileContainer-Objekt


WindowClosing (FolderWindowEvents-Objekt)

WindowClosing (FolderWindowEvents-Objekt)

Tritt unmittelbar vor dem Schließen eines Ordnerfensters ein.

[C++]
HRESULT __stdcall WindowClosing(
  /*[in]*/ IFolderWindow* pWndClosing
);
[C#]
public void WindowClosing(
  FolderWindow pWndClosing
);
[Visual Basic .NET]
Public Sub WindowClosing( _
  ByVal pWndClosing As FolderWindow _
)
[Delphi]
procedure WindowClosing(
  pWndClosing: IFolderWindow
); safecall;

Parameter

pWndClosing
Erforderlich. Das Ordnerfenster, welches geschlossen wird.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindowEvents-Objekt, FolderWindow-Objekt


WindowCreated (FileContainerEvents-Objekt)

WindowCreated (FileContainerEvents-Objekt)

Tritt beim Erstellen einer neuen Dateiablage ein.

[C++]
HRESULT __stdcall WindowCreated(
  /*[in]*/ IFileContainer* pWndCreated
);
[C#]
public void WindowCreated(
  FileContainer pWndCreated
);
[Visual Basic .NET]
Public Sub WindowCreated( _
  ByVal pWndCreated As FileContainer _
)
[Delphi]
procedure WindowCreated(
  pWndCreated: IFileContainer
); safecall;

Parameter

pWndCreated
Erforderlich. Die Dateiablage, welche erstellt wurde.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileContainerEvents-Objekt, FileContainer-Objekt


WindowCreated (FolderWindowEvents-Objekt)

WindowCreated (FolderWindowEvents-Objekt)

Tritt beim Erstellen eines neuen Ordnerfensters ein.

[C++]
HRESULT __stdcall WindowCreated(
  /*[in]*/ IFolderWindow* pWndCreated
);
[C#]
public void WindowCreated(
  FolderWindow pWndCreated
);
[Visual Basic .NET]
Public Sub WindowCreated( _
  ByVal pWndCreated As FolderWindow _
)
[Delphi]
procedure WindowCreated(
  pWndCreated: IFolderWindow
); safecall;

Parameter

pWndCreated
Erforderlich. Das Ordnerfenster, welches erstellt wurde.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FolderWindowEvents-Objekt, FolderWindow-Objekt


scAppFolder-Konstanten

scAppFolder-Konstanten

Diese Konstanten stellen den Typ eines Ordners dar.

Eigenschaften

Konstante | Wert | Beschreibung
scAppFolderUnknown | -1 | Der Typ des Ordners ist unbekannt.
scAppFolderLocal | 0 | Der Ordner befindet sich auf einem lokalen Laufwerk oder auf einem gemappten Netzwerklaufwerk.
scAppFolderNetwork | 1 | Der Ordner befindet sich innerhalb der Netzwerkumgebung.
scAppFolderHttp | 2 | Der Ordner stellt eine Web-Adresse dar.
scAppFolderFtp | 3 | Der Ordner befindet sich auf einem FTP-Server.
scAppFolderAddIn | 4 | Der Ordner befindet sich auf einem Dateisystem-AddIn.
scAppFolderShell | 5 | Der Ordner befindet sich im Shell-Namensbereich.

AppFolder-Objekt


scCommand-Konstanten

scCommand-Konstanten

Diese Konstanten definieren die Menübefehle.

Eigenschaften

Menü "Datei"
scCommandFileView | 30103 | Startet den Dateibetrachter, um die gewählten Objekte anzuzeigen.
scCommandFileEdit | 30104 | Startet den Editor, um die gewählten Objekte zu editieren.
scCommandFileCopy | 30105 | Kopiert die gewählten Objekte.
scCommandFileMove | 30106 | Verschiebt die gewählten Objekte.
scCommandFileDelete | 30107 | Löscht die markierten Elemente.
scCommandFileDeleteRecycleBin | 30108 | Löscht die markierten Elemente in den Papierkorb.
scCommandFileDeleteSecure | 30109 | Löscht die gewählten Objekte sicher nach Regierungsrichtlinien.
scCommandFileRename | 30110 | Nennt das gewählte Objekt um.
scCommandFileSaveAs | 57604 | Speichert die Internetseite unter neuem Namen.
scCommandFileMultiRename | 30120 | Nennt eine Liste von gewählten Objekten um.
scCommandFileCompress | 30117 | Komprimiert die gewählten Objekte.
scCommandFileExtract | 30118 | Entpackt die gewählten Objekte.
scCommandFileSplit | 30116 | Trennt die gewählte Datei in mehrere Teile.
scCommandFileExecute | 30111 | Führt ein Programm aus.
scCommandFileExecuteDos | 30112 | Startet die Eingabeaufforderung.
scCommandFileProperties | 30113 | Zeigt die Eigenschaften der gewählten Objekte an.
scCommandFileMoreProperties | 30119 | Zeigt die erweiterten Eigenschaften der gewählten Objekte an.
scCommandFileSearch | 30114 | Startet ein Suchprogramm, um nach Dateien zu suchen.
scCommandFilePrint | 30115 | Druckt das gewählte Dokument.
scCommandFileAppExit | 57665 | Beendet die Anwendung.
Menü "Bearbeiten"
scCommandEditCopy | 57634 | Kopiert die Markierung und überträgt sie in die Zwischenablage.
scCommandEditCut | 57635 | Entfernt die Markierung und überträgt sie in die Zwischenablage.
scCommandEditPaste | 57637 | Fügt den Inhalt der Zwischenablage ein.
scCommandEditPasteAsShortcut | 30201 | Erstellt Verknüpfungen mit Objekten, die an die gewählte Stelle kopiert bzw. an dieser ausgeschnitten wurden.
scCommandEditSelectAll | 57642 | Wählt alle Objekte im Fenster aus.
scCommandEditSelectAllFiles | 30210 | Wählt alle Dateien im Fenster aus.
scCommandEditSelectSome | 30211 | Wählt einige Objekte im Fenster aus.
scCommandEditSelectCurrentExt | 30214 | Wählt alle Dateien, die den gleichen Dateityp haben wie die aktuelle Datei.
scCommandEditUnselectAll | 30215 | Entfernt die gesamte Auswahl.
scCommandEditUnselectAllFiles | 30216 | Entfernt die Auswahl aller Dateien im Fenster.
scCommandEditUnselectSome | 30217 | Entfernt einen Teil der Auswahl.
scCommandEditUnselectCurrentExt | 30218 | Wählt alle Dateien ab, die den gleichen Dateityp haben wie die aktuelle Datei.
scCommandEditSelectInvert | 30212 | Kehrt die Auswahl um.
scCommandEditSelectRestore | 30213 | Stellt die Auswahl wieder her.
scCommandEditIncludeFolders | 30209 | Schließt die Ordner bei der Auswahl ein bzw. aus.
scCommandEditCopyNameAsText | 30202 | Kopiert den Dateinamen als Text in die Zwischenablage.
scCommandEditCopyFullPathAsText | 30204 | Kopiert den vollständigen Dateinamen als Text in die Zwischenablage.
scCommandEditCopyFullNameAsText | 30203 | Kopiert den Ordnernamen als Text in die Zwischenablage.
Menü "Ordner"
scCommandFolderFilterShowAllFiles | 33797 | Zeigt alle Dateien an.
scCommandFolderFilterInclude | 33798 | Zeigt alle Dateien an, die der Maske entsprechen.
scCommandFolderFilterExclude | 33799 | Schließt alle Dateien aus, die der Maske entsprechen.
scCommandFolderFilterFilter1 | 33800 | Aktiviert den ersten benutzerdefinierten Filter.
scCommandFolderFilterFilter100 | 33899 | Aktiviert den letzten benutzerdefinierten Filter.
scCommandFolderFilterSetFilter | 30347 | Setzt Filter, um bestimmte Dateien auszublenden.
scCommandFolderCreateFolder | 30302 | Erstellt einen neuen Ordner.
scCommandFolderCreateShortcut | 30304 | Erstellt eine neue Verknüpfung.
scCommandFolderCompare | 30303 | Prüft zwei Ordner auf Unterschiede.
scCommandFolderSynchronize | 30307 | Synchronisiert zwei Ordner.
scCommandFolderPrint | 30306 | Druckt eine Dateiliste des Ordners aus.
scCommandFolderCalcFolderSize | 30305 | Ermittelt die Größe aller Unterordner.
scCommandFolderFavoritesShowMenu | 30308 | Zeigt ein Menü mit den Ordnerfavoriten.
scCommandFolderFavoritesConfigure | 33999 | Öffnet einen Dialog zur Verwaltung der Ordnerfavoriten.
scCommandFolderFavoritesAddCurrentFolder | 33997 | Fügt den aktuellen Ordner den Ordnerfavoriten hinzu.
scCommandFolderFavoritesRemoveCurrentFolder | 33998 | Entfernt den aktuellen Ordner aus den Ordnerfavoriten.
scCommandFolderFavorites1 | 34000 | Aktiviert den ersten Ordnerfavoriten.
scCommandFolderFavorites200 | 34199 | Aktiviert den letzten Ordnerfavoriten.
scCommandFolderBranchView | 30352 | Aktiviert oder deaktiviert die Zweigansicht.
scCommandFolderGotoBack | 30313 | Öffnet das vorherige Objekt in der Liste der letzten 20 Elemente, die zuletzt angezeigt wurden.
scCommandFolderGotoForward | 30314 | Öffnet das nächste Objekt in der Liste der letzten 20 Elemente, die zuletzt angezeigt wurden.
scCommandFolderGotoHierarchyShowMenu | 30310 | Zeigt ein Menü mit der Ordnerhierarchie an.
scCommandFolderGotoHierarchy1 | 31200 | Wechselt in den obersten Hierarchie-Eintrag.
scCommandFolderGotoHierarchy50 | 31249 | Wechselt in den untersten Hierarchie-Eintrag.
scCommandFolderGotoUpOneLevel | 30315 | Wechselt in den übergeordneten Ordner.
scCommandFolderGotoUpToRoot | 30316 | Wechselt in das Hauptverzeichnis.
scCommandFolderGotoBaseFolder | 30317 | Wechselt in das Basisverzeichnis.
scCommandFolderHistory1 | 31150 | Wechselt zum ersten History-Eintrag.
scCommandFolderHistory50 | 31199 | Wechselt zum letzten History-Eintrag.
scCommandKnownFolderDesktop | 35400 | Wechselt nach 'Desktop'.
scCommandKnownFolderPublicDesktop | 35401 | Wechselt nach 'Öffentlicher Desktop'.
scCommandKnownFolderStartMenu | 35402 | Wechselt nach 'Startmenü'.
scCommandKnownFolderPublicStartMenu | 35403 | Wechselt nach 'Öffentliches Startmenü'.
scCommandKnownFolderFavorites | 35404 | Wechselt nach 'Favoriten'.
scCommandKnownFolderFonts | 35405 | Wechselt nach 'Schriftarten'.
scCommandKnownFolderCookies | 35406 | Wechselt nach 'Cookies'.
scCommandKnownFolderHistory | 35407 | Wechselt nach 'Verlauf'.
scCommandKnownFolderInternetCache | 35408 | Wechselt nach 'Temporäre Internetdateien'.
scCommandKnownFolderAppData | 35409 | Wechselt nach 'Anwendungsdaten'.
scCommandKnownFolderLocalAppData | 35410 | Wechselt nach 'Lokale Anwendungsdaten'.
scCommandKnownFolderProgramData | 35411 | Wechselt nach 'Programmdaten'.
scCommandKnownFolderDocuments | 35412 | Wechselt nach 'Dokumente'.
scCommandKnownFolderPictures | 35413 | Wechselt nach 'Bilder'.
scCommandKnownFolderMusic | 35414 | Wechselt nach 'Musik'.
scCommandKnownFolderVideos | 35415 | Wechselt nach 'Videos'.
scCommandKnownFolderPublicDocuments | 35416 | Wechselt nach 'Öffentliche Dokumente'.
scCommandKnownFolderPublicPictures | 35417 | Wechselt nach 'Öffentliche Bilder'.
scCommandKnownFolderPublicMusic | 35418 | Wechselt nach 'Öffentliche Musik'.
scCommandKnownFolderPublicVideos | 35419 | Wechselt nach 'Öffentliche Videos'.
scCommandKnownFolderRecentItems | 35420 | Wechselt nach 'Zuletzt verwendet'.
scCommandKnownFolderSendTo | 35421 | Wechselt nach 'Senden an'.
scCommandKnownFolderProgramFiles | 35422 | Wechselt nach 'Programmdateien'.
scCommandKnownFolderProgramFilesX86 | 35423 | Wechselt nach 'Programmdateien (x86)'.
scCommandKnownFolderProgramFilesCommon | 35424 | Wechselt nach 'Gemeinsame Programdateien'.
scCommandKnownFolderProgramFilesCommonX86 | 35425 | Wechselt nach 'Gemeinsame Programmdateien (x86)'.
scCommandKnownFolderWindows | 35426 | Wechselt nach 'Windows'.
scCommandKnownFolderSystem | 35427 | Wechselt nach 'System'.
scCommandKnownFolderSystemX86 | 35428 | Wechselt nach 'System (x86)'.
scCommandKnownFolderProfile | 35429 | Wechselt nach 'Benutzerprofil'.
scCommandKnownFolderDownloads | 35430 | Wechselt nach 'Downloads'.
scCommandKnownFolderLibraries | 35431 | Wechselt nach 'Bibliotheken'.
Menu "Datenträger"
scCommandDiskFormat | 30401 | Startet das Programm zum Formatieren von Datenträgern.
scCommandDiskCopy | 30402 | Startet das Programm zum Kopieren von Datenträgern.
scCommandDiskMapNetworkDrive | 30403 | Ordnet einem Netzlaufwerk einen Laufwerksbuchstaben zu.
scCommandDiskDisconnectNetworkDrive | 30404 | Trennt ein Netzlaufwerk.
scCommandDiskFtpConnect | 30405 | Stellt eine Verbindung zu einem FTP-Server her.
scCommandDiskFtpDisconnect | 30406 | Trennt die Verbindung zu einem FTP-Server.
scCommandDiskFtpQuickConnect | 30411 | Stellt eine Schnellverbindung zu einem FTP-Server her.
scCommandDiskInternetStart | 30407 | Öffnet die Internet-Startseite.
scCommandDiskInternetSearch | 30408 | Öffnet die Internet-Suchseite.
scCommandDiskInternetProperties | 30409 | Öffnet die Internet-Eigenschaften.
scCommandDiskRefresh | 30410 | Aktualisiert die Laufwerkssymbole.
scCommandDiskSelectLeftDrive | 30421 | Wählt das Laufwerk für das linke Fenster.
scCommandDiskSelectRightDrive | 30422 | Wählt das Laufwerk für das rechte Fenster.
Menü "Ansicht"
scCommandViewAppearanceDrivesCombo | 30515 | Zeigt die Laufwerksfenster als Kombinationsfeld über jedem Ordnerfenster an.
scCommandViewAppearanceDrivesList | 30516 | Stellt das Laufwerksfenster als Leiste über jedem Ordnerfenster dar.
scCommandViewAppearanceDrivesDual | 30517 | Stellt das Laufwerksfenster als gemeinsame Leiste über beiden Ordnerfenstern dar.
scCommandViewAppearanceTileHorizontally | 30510 | Ordnet die Dateifenster untereinander an.
scCommandViewAppearanceDosPrompt | 30518 | Blendet die Befehlseingabezeile ein bzw. aus.
scCommandViewAppearanceDosCommandWindow | 30520 | Blendet das integrierte Befehlsausgabefenster ein bzw. aus.
scCommandViewAppearanceQuickDropSymbols | 30519 | Blendet die QuickDrop-Symbole ein bzw. aus.
scCommandViewAppearanceSwap | 30522 | Tauscht die beiden Ordnerfenster.
scCommandViewAppearanceAdjust | 30523 | Gleicht die beiden Fenster aneinander an.
scCommandViewAppearanceStop | 30501 | Bricht die Seitenanzeige ab.
scCommandViewAppearanceAlwaysOnTop | 30502 | Stellt den SpeedCommander so dar, daß er nicht durch andere Anwendungen überlagert wird.
scCommandViewFolderWindowVolumeInfo | 30530 | Schaltet den Laufwerksstatus an bzw. aus.
scCommandViewFolderWindowQuickView | 30531 | Schaltet die integrierte Schnellansicht an bzw. aus.
scCommandViewFolderWindowFolderInfo | 30532 | Schaltet die Ordnerinformationen an bzw. aus.
scCommandViewFolderWindowTreeView | 30538 | Aktiviert bzw. deaktiviert die Baumansicht.
scCommandViewFolderWindowStatusView | 30539 | Aktiviert bzw. deaktiviert das Statusfenster.
scCommandViewFolderWindowTabNew | 30540 | Erstellt ein neues Ordnerfenster.
scCommandViewFolderWindowTabProperties | 30548 | Zeigt die Eigenschaften der Registerkarte an.
scCommandViewFolderWindowTabSynchronize | 30547 | Schaltet die Synchronisation der Ordnerfenster ein oder aus.
scCommandViewFolderWindowFileContainerNew | 30541 | Erstellt eine neue Dateiablage.
scCommandViewFolderWindowFileContainerShow | 30555 | Zeigt die Dateiablage als Registerkarte an.
scCommandViewFolderWindowFileContainerLoadSel | 30556 | Lädt eine zuvor gespeicherte Auswahl.
scCommandViewFolderWindowFileContainerSaveSel | 30557 | Speichert eine Auswahl.
scCommandViewFolderWindowTabRename | 30546 | Benennt die aktuelle Ansicht um.
scCommandViewFolderWindowTabShiftLeft | 30545 | Verschiebt die aktuelle Ansicht nach links.
scCommandViewFolderWindowTabShiftRight | 30544 | Verschiebt die aktuelle Ansicht nach rechts.
scCommandViewFolderWindowTabClose | 30542 | Schließt die aktuelle Ansicht.
scCommandViewFolderWindowTabCloseAll | 30542 | Schließt alle Ansichten bis auf die aktuelle Ansicht.
scCommandViewLayoutShowMenu | 30580 | Zeigt ein Menü mit den gespeicherten Layouts.
scCommandViewLayoutSave | 33598 | Speichert das aktuelle Layout.
scCommandViewLayoutRemove | 33599 | Entfernt ein gespeichertes Layout.
scCommandViewLayout1 | 33600 | Aktiviert das erste benutzerdefinierte Layout.
scCommandViewLayout100 | 33699 | Aktiviert das letzte benutzerdefinierte Layout.
scCommandViewSplitter0 | 30595 | Versteckt das linke Fenster.
scCommandViewSplitter25 | 30596 | Vergrößert das rechte Fenster.
scCommandViewSplitter50 | 30597 | Stellt das linke und rechte Fenster auf gleiche Größe.
scCommandViewSplitter75 | 30598 | Vergrößert das linke Fenster.
scCommandViewSplitter100 | 30599 | Versteckt das rechte Fenster.
scCommandViewIcons | 19950 | Zeigt Elemente mit großen Symbolen an.
scCommandViewList | 19953 | Zeigt Elemente in Listenform an.
scCommandViewDetails | 19951 | Zeigt Informationen über die Elemente im Fenster an.
scCommandViewTiles | 19954 | Zeigt Informationen über jedes Fensterelement im Kachelformat an.
scCommandViewThumbnails | 19955 | Zeigt Elemente in der Miniaturansicht an.
scCommandViewArrangeShowInGroups | 19959 | Gruppiert die Elemente im Fenster nach der Sortiereigenschaft.
scCommandViewArrangeAuto | 19956 | Ordnet die Symbole automatisch an.
scCommandViewArrangeAlignToGrid | 19957 | Richtet die Symbole am Raster aus.
scCommandViewRefresh | 30503 | Aktualisiert den Inhalt des aktuellen Fensters.
scCommandViewSortName | 25000 | Sortiert alle Elemente nach Name.
scCommandViewSortType | 25001 | Sortiert alle Elemente nach Typ.
scCommandViewSortModified | 25002 | Sortiert alle Elemente nach dem Datum der letzten Änderung.
scCommandViewSortSize | 25003 | Sortiert alle Elemente nach Größe.
scCommandViewSortAttributes | 25004 | Sortiert alle Elemente nach Attribute.
scCommandViewSortExtension | 25005 | Sortiert alle Elemente nach Erweiterung.
scCommandViewSortLastAccess | 25006 | Sortiert alle Elemente nach dem Datum des letzten Zugriffs.
scCommandViewSortCreated | 25007 | Sortiert alle Elemente nach dem Erstelldatum.
scCommandViewSortRatio | 25008 | Sortiert alle Elemente nach Einsparung.
scCommandViewSortCompressedSize | 25009 | Sortiert alle Elemente nach komprimierter Größe.
scCommandViewSortComment | 25010 | Sortiert alle Elemente nach Kommentar.
scCommandViewSortCRC | 25011 | Sortiert alle Elemente nach CRC.
scCommandViewSortSystem | 25012 | Sortiert alle Elemente nach System.
scCommandViewSortMethod | 25013 | Sortiert alle Elemente nach Komprimiermethode.
scCommandViewSortFolder | 25014 | Sortiert alle Elemente nach Ordner.
scCommandViewSortServer | 25015 | Sortiert alle Elemente nach Server.
scCommandViewSortLastVisit | 25016 | Sortiert alle Elemente nach letztem Besuch.
scCommandViewSort83Name | 25017 | Sortiert alle Elemente nach 8.3-Name.
scCommandViewSortBranchFolder | 25018 | Sortiert alle Elemente nach Zweigordner.
scCommandscCommandViewSortAddInColumn1 | 25100 | Sortiert alle Elemente nach der ersten zusätzlichen AddIn-Spalte.
scCommandscCommandViewSortAddInColumn200 | 25199 | Sortiert alle Elemente nach der letzten zusätzlichen AddIn-Spalte.
scCommandscCommandViewSortColumnHandler1 | 25200 | Sortiert alle Elemente nach der ersten Shell-Spaltenerweiterung.
scCommandscCommandViewSortColumnHandler700 | 25999 | Sortiert alle Elemente nach der letzten Shell-Spaltenerweiterung.
Menü "Extras"
scCommandExtraSettings | 30601 | Ändert die Einstellungen.
scCommandExtraCustomize | 35001 | Ermöglicht das Anpassen von Symbolleisten, Menüs und Tastenkürzel.
scCommandExtraFont | 30603 | Ändert die Schriftart.
scCommandExtraFontIncrease | 30604 | Vergrößert die Schriftart.
scCommandExtraFontDecrease | 30605 | Verkleinert die Schriftart.
scCommandExtraFileTypes | 30619 | Zeigt einen Dialog zur Bearbeitung der Dateiverknüpfungen an.
scCommandExtraArchiveMainComment | 30623 | Ändert den Hauptkommentar des Archivs.
scCommandExtraArchiveFileComment | 30624 | Ändert den Dateikommentar für die gewählten Objekte im Archiv.
scCommandExtraArchiveAddRecoveryData | 30621 | Fügt einem Archiv Reparaturdaten hinzu.
scCommandExtraArchiveStripRecoveryData | 30622 | Entfernt die Reparaturdaten aus einem Archiv.
scCommandExtraArchiveRepair | 30620 | Repariert ein defektes Archiv.
scCommandExtraArchiveTest | 30625 | Testet das Archiv auf Fehler.
scCommandExtraArchiveCreateSfx | 30626 | Erzeugt aus dem Archiv ein selbstentpackendes Archiv.
scCommandExtraSpecialEmptyRecycleBin | 30640 | Löscht alle Objekte im Papierkorb.
scCommandExtraMacrosEditor | 23928 | Öffnet den Makroeditor.
scCommandExtraUserToolsShowMenu | 30608 | Zeigt ein Menü mit den Anwendungsfavoriten.
scCommandExtraUserToolsConfig | 34299 | Öffnet einen Dialog zur Verwaltung der Anwendungsfavoriten.
scCommandExtraUserTools1 | 34300 | Startet den ersten Anwendungsfavoriten.
scCommandExtraUserTools300 | 34599 | Startet den letzten Anwendungsfavoriten.
scCommandExtraSaveSetup | 30606 | Speichert die aktuellen Einstellungen.
Menü "Hilfe"
scCommandHelpTopics | 57667 | Listet die Hilfethemen auf.
scCommandHelpKeyboardMap | 30701 | Zeigt alle Tastaturbefehle an.
scCommandHelpWebHomepage | 19921 | Wechselt zur SpeedProject-Homepage.
scCommandHelpWebSupport | 19922 | Wechselt zur Support- und Updateseite.
scCommandHelpWebForum | 19923 | Wechselt zum Anwenderforum.
scCommandHelpWebFeedback | 19924 | Sendet ein Feedback an das SpeedProject-Team.
scCommandHelpInfoAbout | 57664 | Zeigt Programminformationen, Versionsnummer und Copyright an.

Application-Objekt


scCommandBarControlType-Konstanten

scCommandBarControlType-Konstanten

Diese Konstanten stellen den Typ eines Kontrollelements in einer Symbolleiste dar.

Eigenschaften

Konstante | Wert | Beschreibung
scCommandBarControlTypeAny | 0 | Wird bei der Suche verwendet, um Elemente unabhängig vom Typ zu finden.
scCommandBarControlTypeButton | 1 | Normale Schaltfläche.
scCommandBarControlTypePopup | 2 | Popup-Fenster mit Text ohne Symbol.
scCommandBarControlTypeButtonPopup | 3 | Popup-Fenster mit Symbol ohne Text.
scCommandBarControlTypeSplitButtonPopup | 4 | Popup-Fenster mit Symbol ohne Text und einem Pfeil rechts.
scCommandBarControlTypeComboBox | 5 | Kombinationsfeld.
scCommandBarControlTypeEdit | 6 | Eingabefeld.
scCommandBarControlTypeCustom | 7 | Benutzerdefiniertes Element.
scCommandBarControlTypeLabel | 8 | Einfaches Textfeld zur Informationsanzeige.

CommandBarControl-Objekt


scCommandBarFlags-Konstanten

scCommandBarFlags-Konstanten

Diese Konstanten stellen die verschiedenen Möglichkeiten für das Andocken von Symbolleisten dar.

Eigenschaften

Konstante | Wert | Beschreibung
scCommandBarFlagAlignTop | 1 | Die Symbolleiste kann am oberen Rand angedockt werden.
scCommandBarFlagAlignBottom | 2 | Die Symbolleiste kann am unteren Rand angedockt werden.
scCommandBarFlagAlignLeft | 4 | Die Symbolleiste kann am linken Rand angedockt werden.
scCommandBarFlagAlignRight | 8 | Die Symbolleiste kann am rechten Rand angedockt werden.
scCommandBarFlagAlignAny | 15 | Die Symbolleiste kann an jedem Rand angedockt werden.
scCommandBarFlagFloating | 16 | Die Symbolleiste kann freischwebend angezeigt werden.
scCommandBarFlagHideWrap | 32 | Elemente, für die kein Platz mehr ist, können ausgeblendet werden.
scCommandBarFlagStretched | 64 | Die Symbolleiste nimmt die ganze zur Verfügung stehende Breite/Höhe ein.

CommandBar-Objekt


scCommandBarPosition-Konstanten

scCommandBarPosition-Konstanten

Diese Konstanten stellen die aktuelle Position einer Symbolleiste dar.

Eigenschaften

Konstante | Wert | Beschreibung
scCommandBarPositionTop | 0 | Die Symbolleiste ist am oberen Rand angedockt.
scCommandBarPositionBottom | 1 | Die Symbolleiste ist am unteren Rand angedockt.
scCommandBarPositionLeft | 2 | Die Symbolleiste ist am linken Rand angedockt.
scCommandBarPositionRight | 3 | Die Symbolleiste ist am rechten Rand angedockt.
scCommandBarPositionFloating | 4 | Die Symbolleiste ist freischwebend.
scCommandBarPositionPopup | 5 | Die Symbolleiste ist ein Popup-Fenster innerhalb einer anderen Symbolleiste.
scCommandBarPositionListBox | 6 | Nicht benutzt.
scCommandBarPositionNone | 7 | Nicht benutzt.

CommandBar-Objekt


scCommandBarType-Konstanten

scCommandBarType-Konstanten

Diese Konstanten stellen den Typ einer Symbolleiste dar.

Eigenschaften

Konstante | Wert | Beschreibung
scCommandBarTypeMenuBar | 0 | Die Symbolleiste ist eine Menüleiste.
scCommandBarTypeNormal | 1 | Die Symbolleiste ist eine Toolbar.
scCommandBarTypePopup | 2 | Die Symbolleiste ist ein Popup-Fenster.

CommandBar-Objekt


scDriveSymbols-Konstanten

scDriveSymbols-Konstanten

Diese Konstanten legen fest, wie die Laufwerkssymbole angezeigt werden sollen.

Eigenschaften

Konstante | Wert | Beschreibung
scDriveSymbolsCombo | 0 | Die Anzeige der Laufwerkssymbole erfolgt in zwei Kombinationsfeldern.
scDriveSymbolsSingleList | 1 | Die Anzeige der Laufwerkssymbole erfolgt als Liste gemeinsam für beide Ordnerfenster.
scDriveSymbolsDualList | 2 | Die Anzeige der Laufwerkssymbole erfolgt als Liste getrennt für beide Ordnerfenster.

Window-Objekt


scEvents-Konstanten

scEvents-Konstanten

Diese Konstanten legen das Ereignisobjekt fest, das abgefragt werden soll.

Eigenschaften

Konstante | Wert | Beschreibung
scEventsCommand | 0 | Gibt ein CommandEvents-Objekt zurück, über welches auf Befehlsereignisse reagiert werden kann.
scEventsTabWindow | 1 | Gibt ein TabWindowEvents-Objekt zurück, über welches auf Ereignisse für die Zweifenster-Ansicht reagiert werden kann.
scEventsFolderWindow | 2 | Gibt ein FolderWindowEvents-Objekt zurück, über welches auf Ereignisse für Ordnerfenster reagiert werden kann.
scEventsFileContainer | 3 | Gibt ein FileContainerEvents-Objekt zurück, über welches auf Ereignisse für Dateiablagen reagiert werden kann.

Application-Objekt


scFolderLayout-Konstanten

scFolderLayout-Konstanten

Diese Konstanten legen fest, wie die Ordnerfenster angezeigt werden sollen.

Eigenschaften

Konstante | Wert | Beschreibung
scFolderLayoutVertical | 0 | Die Anzeige der Ordnerfenster erfolgt nebeneinander.
scFolderLayoutHorizontal | 1 | Die Anzeige der Ordnerfenster erfolgt untereinander.

Window-Objekt


scListView-Konstanten

scListView-Konstanten

Diese Konstanten legen fest, wie die Dateien und Ordner innerhalb der Listenansicht angezeigt werden.

Eigenschaften

Konstante | Wert | Beschreibung
scListViewIcon | 0 | Dateien und Ordner werden mit großen Symbolen angezeigt.
scListViewDetails | 1 | Dateien und Ordner werden mit Detailinformationen angezeigt.
scListViewSmallIcon | 2 | Dateien und Ordner werden mit kleinen Symbolen angezeigt.
scListViewList | 3 | Dateien und Ordner werden mit kleinen Symbolen als Liste angezeigt.
scListViewTile | 4 | Dateien und Ordner werden mit sehr großen Symbolen angezeigt.
scListViewThumbnails | 5 | Dateien und Ordner werden mit Vorschaubildern angezeigt.

FolderWindow-Objekt


scMrtCharCase-Konstanten

scMrtCharCase-Konstanten

Diese Konstanten legen den Modus für die Groß-/Kleinschreibung für das MultiRename-Objekt fest.

Eigenschaften

Konstante | Wert | Beschreibung
scMrtCharCaseUnchanged | 0 | Es erfolgt keine Änderung der Groß-/Kleinschreibung.
scMrtCharCaseAllUpper | 1 | Alle Zeichen werden in Großbuchstaben umgewandelt.
scMrtCharCaseAllLower | 2 | Alle Zeichen werden in Kleinbuchstaben umgewandelt.
scMrtCharCaseWordUpper | 3 | Jeder Wortanfang wird in Großbuchstaben umgewandelt.
scMrtCharCaseFirstNameUpper | 4 | Der erste Buchstabe wird in Großbuchstaben umgewandelt.
scMrtCharCaseFirstWordUpper | 5 | Das jeweils erste Wort (Dateiname und -erweiterung) wird in Großbuchstaben umgewandelt.

MultiRename-Objekt


scMrtDateTime-Konstanten

scMrtDateTime-Konstanten

Diese Konstanten legen den Modus für die Datums- und Zeitangaben für das MultiRename-Objekt fest.

Eigenschaften

Konstante | Wert | Beschreibung
scMrtDateTimeFile | 0 | Für Datums- und Zeitangaben wird die Zeit der letzten Änderung der jeweiligen Datei verwendet.
scMrtDateTimeSystem | 1 | Für Datums- und Zeitangaben wird die aktuelle Systemzeit verwendet.

MultiRename-Objekt


scMrtReplace-Konstanten

scMrtReplace-Konstanten

Diese Konstanten legen den Suchen- und Ersetzen-Modus für das MultiRename-Objekt fest.

Eigenschaften

Konstante | Wert | Beschreibung
scMrtReplaceFirstMatch | 0 | Es wird nur das erste Vorkommen ersetzt.
scMrtReplaceAllMatches | 1 | Es werden alle Vorkommen ersetzt.

MultiRename-Objekt


scMrtResult-Konstanten

scMrtResult-Konstanten

Diese Konstanten geben das Ergebnis einer Umbenennen-Aktion zurück.

Eigenschaften

Konstante | Wert | Beschreibung
scMrtResultOk | 0 | Die Dateien wurden mit Erfolg umbenannt.
scMrtResultSyntaxError | 1 | Die Parameter können nicht ausgewertet werden.
scMrtResultDoublesPresent | 2 | Das Umbenennen hätte zu doppelten Dateinamen geführt.

MultiRename-Objekt


scObject-Konstanten

scObject-Konstanten

Diese Konstanten legen das Anwendungsobjekt fest, das abgefragt werden soll.

Eigenschaften

Konstante | Wert | Beschreibung
scObjectMainWindow | 0 | Gibt ein MainWindow-Objekt zurück, über welches auf das Hauptfenster zugegriffen werden kann.
scObjectCommandBars | 1 | Gibt ein CommandBars-Objekt zurück, über welches auf die Symbolleisten und das Menü zugegriffen werden kann.
scObjectWorkspace | 2 | Gibt ein Workspace-Objekt zurück, über welches auf den Arbeitsbereich zugegriffen werden kann.
scObjectAddIns | 3 | Gibt ein AddIns-Objekt zurück, über welches auf die installierten AddIns zugegriffen werden kann.
scObjectUserTools | 4 | Gibt ein UserTools-Objekt zurück, über welches auf die Anwendungsfavoriten zugegriffen werden kann.
scObjectFolderFavorites | 5 | Gibt ein FolderFavorites-Objekt zurück, über welches auf die Ordnerfavoriten zugegriffen werden kann.
scObjectMultiRename | 6 | Gibt ein MultiRename-Objekt zurück, über welches Mehrfachumbenennungen erfolgen können.

Application-Objekt


scTabProperties-Konstanten

scTabProperties-Konstanten

Diese Konstanten stellen verschiedene Eigenschaften für Ordnerfenster dar.

Eigenschaften

Konstante | Wert | Beschreibung
scTabPropertiesUseBaseFolder | 1 | Das Ordnerfenster besitzt einen gültigen Basisordner, der beim Start von SpeedCommander automatisch angezeigt wird.
scTabPropertiesLockDrives | 2 | Der Wechsel auf andere Laufwerke ist gesperrt.
scTabPropertiesLockChilds | 4 | Der Wechsel in untergeordnete Verzeichnisse ist gesperrt.
scTabPropertiesLockParent | 8 | Der Wechsel in übergeordnete Verzeichnisse ist gesperrt.
scTabPropertiesBaseFolderOnActivate | 16 | Bei jeder Aktivierung des Ordnerfensters wird in den Basisordner gewechselt.
scTabPropertiesRefreshOnActivate | 256 | Bei jeder Aktivierung des Ordnerfensters wird der aktuelle Ordner neu eingelesen.
scTabPropertiesAutoRename | 512 | Der Name des Ordnerfensters wird automatisch aus dem jeweils aktuellen Ordner ermittelt.
scTabPropertiesTempArchive | 65536 | Das Ordnerfenster ist ein temporäres Archiv und wird bei einem Wechsel automatisch geschlossen.

FolderWindow-Objekt


Exec (IDTCommandTarget)

Exec (IDTCommandTarget)

Führt den angegebenen Befehl aus.

[C++]
HRESULT __stdcall Exec(
  /*[in]*/ BSTR bstrCmdName,
  /*[in]*/ vsCommandExecOption eExecuteOption,
  /*[in]*/ VARIANT* pVariantIn,
  /*[out]*/ VARIANT* pVariantOut,
  /*[out]*/ VARIANT_BOOL* pfHandled
);
[C#]
public void Exec(
  string bstrCmdName,
  vsCommandExecOption eExecuteOption,
  ref object pVariantIn,
  out object pVariantOut,
  out bool pfHandled
);
[Visual Basic .NET]
Public Sub Exec( _
  ByVal bstrCmdName As String, _
  ByVal eExecuteOption As vsCommandExecOption, _
  ByRef pVariantIn As Object, _
  ByRef pVariantOut As Object, _
  ByRef pfHandled As Boolean _
)
[Delphi]
procedure Exec(
  const bstrCmdName: WideString;
  eExecuteOption: vsCommandExecOption;
  var pVariantIn: OleVariant;
  out pVariantOut: OleVariant;
  out pfHandled: WordBool
); safecall;

Parameter

bstrCmdName
[in] Name des auszuführenden Befehls (z.B. SampleAddIn.Befehl1).
eExecuteOption
[in] Legt die Ausführungsoptionen fest und ist einer der folgenden Werte:
Ausführung | Wert | Bedeutung
vsCommandExecOptionDoDefault | 0 | Führt den Befehl aus (mit oder ohne Benutzereingabe).
vsCommandExecOptionPromptUser | 1 | Führt den Befehl nach Benutzereingabe aus.
vsCommandExecOptionDoPromptUser | 2 | Führt den Befehl aus, ohne den Benutzer zur Eingabe aufzufordern.
vsCommandExecOptionShowHelp | 3 | Zeigt eine Hilfe zum Befehl an, ohne ihn auszuführen.
pVariantIn
[in] Benutzerdefinierter Wert, der an einen Befehl übergeben wird.
pVariantOut
[out] Wert, der nach dem Ausführen des Befehls an den Aufrufer zurückgegeben wird.
pfHandled
[out] Gibt zurück, ob der Befehl ausgeführt wurde (VARIANT_TRUE) oder nicht (VARIANT_FALSE).

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTCommandTarget


QueryStatus (IDTCommandTarget)

QueryStatus (IDTCommandTarget)

Mit QueryStatus wird geprüft, ob der jeweilige Befehl verfügbar oder deaktiviert ist.

[C++]
HRESULT __stdcall QueryStatus(
  /*[in]*/ BSTR bstrCmdName,
  /*[in]*/ vsCommandStatusTextWanted eNeededText,
  /*[out]*/ vsCommandStatus* pStatusOption,
  /*[out]*/ VARIANT* pCommandText
);
[C#]
public void QueryStatus(
  string bstrCmdName,
  vsCommandStatusTextWanted eNeededText,
  ref vsCommandStatus pStatusOption,
  out object pCommandText
);
[Visual Basic .NET]
public Sub QueryStatus( _
  ByVal bstrCmdName As String, _
  ByVal eNeededText As vsCommandStatusTextWanted, _
  ByRef pStatusOption As vsCommandStatus, _
  ByRef pCommandText As Object _
)
[Delphi]
procedure QueryStatus(
  const bstrCmdName: WideString;
  eNeededText: vsCommandStatusTextWanted;
  var pStatusOption: vsCommandStatus;
  out pCommandText: OleVariant
); safecall;

Parameter

bstrCmdName
[in] Name des auszuführenden Befehls (z.B. SampleAddIn.Befehl1).
eNeededText
[in] Gibt an, ob die Überprüfung Informationen zurückgeben soll und ist einer der folgenden Werte:
Status | Wert | Bedeutung
vsCommandStatusTextWantedNone | 0 | Es werden keine Informationen zurückgegeben.
vsCommandStatusTextWantedName | 1 | Der Name des Befehls wird zurückgegeben.
vsCommandStatusTextWantedStatus | 2 | Der Status des Befehls wird zurückgebeben.
pStatusOption
[out] Legt den aktuellen Status des Befehls fest und ist eine Kombination der folgenden Werte:
Status | Wert | Bedeutung
vsCommandStatusUnsupported | 0 | Der Befehl wird momentan nicht unterstützt.
vsCommandStatusSupported | 1 | Der Befehl wird momentan unterstützt.
vsCommandStatusEnabled | 2 | Der Befehl ist momentan aktiviert.
vsCommandStatusLatched | 4 | Derzeit nicht implementiert.
vsCommandStatusNinched | 8 | Derzeit nicht implementiert.
vsCommandStatusInvisible | 16 | Der Befehl ist momentan ausgeblendet.
pCommandText
[out] Gibt den Befehlstext zurück, wenn vsCommandStatusTextWantedName angegeben wurde.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTCommandTarget


ShowConfigDialog (IDTConfigDialog)

ShowConfigDialog (IDTConfigDialog)

Zeigt den Einstellungsdialog des AddIns an.

[C++]
HRESULT __stdcall ShowConfigDialog(
  /*[in]*/ HANDLE_PTR hWndOwner
);
[C#]
public void ShowConfigDialog(
  uint hWndOwner
);
[Visual Basic .NET]
Public Sub ShowConfigDialog( _
  ByVal hWndOwner As System.UInt32 _
)
[Delphi]
function ShowConfigDialog(
  hWndOwner: LongWord
): HResult; stdcall;

Parameter

hWndOwner
[in] Handle (HWND) des aktuellen Fensters, welches als Elternfenster für den Dialog genutzt werden kann.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTConfigDialog


OnAddInsUpdate (IDTExtensibility2)

OnAddInsUpdate (IDTExtensibility2)

OnAddInsUpdate wird aufgerufen, wenn sich der Zustand eines AddIns (aktiviert oder deaktiviert) geändert hat.

[C++]
HRESULT __stdcall OnAddInsUpdate(
  /*[in, out]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnAddInsUpdate(
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnAddInsUpdate( _
  ByRef ppCustom As System.Array _
)
[Delphi]
procedure OnAddInsUpdate(
  var ppCustom: PSafeArray
); safecall;

Parameter

ppCustom
[in, out] Array von Variants für benutzerdefinierte Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


OnBeginShutdown (IDTExtensibility2)

OnBeginShutdown (IDTExtensibility2)

OnBeginShutdown wird aufgerufen, bevor SpeedCommander beendet wird. Das AddIn kann hier seine Einstellungen sichern, bevor die Benutzeroberfläche von SpeedCommander geschlossen wird.

[C++]
HRESULT __stdcall OnBeginShutdown(
  /*[in]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnBeginShutdown(
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnBeginShutdown( _
  By Ref ppCustom As System.Array _
)
[Delphi]
procedure OnBeginShutdown(
  var ppCustom: PSafeArray
); safecall;

Parameter

ppCustom
[in] Array von Variants für benutzerdefinierte Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


OnConnection (IDTExtensibility2)

OnConnection (IDTExtensibility2)

OnConnection wird aufgerufen, wenn das AddIn mit SpeedCommander verbunden wird. Dies kann zum einen beim Start von SpeedCommander erfolgen als auch zu einem späteren Zeitpunkt durch den Anwender. Ein Rückgabewert von NOERROR zeigt an, dass das AddIn geladen werden kann. Jeder andere Rückgabewert lässt SpeedCommander das AddIn wieder freigeben.

[C++]
HRESULT __stdcall OnConnection(
  /*[in]*/ IDispatch* pApplication,
  /*[in]*/ ext_ConnectMode eConnectMode,
  /*[in]*/ IDispatch* pAddInInst,
  /*[in]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnConnection(
  object pApplication,
  ext_ConnectMode eConnectMode,
  object pAddInInst,
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnConnection( _
  ByVal pApplication As Object, _
  ByVal eConnectMode As ext_ConnectMode, _
  ByVal pAddInInst As Object, _
  ByRef ppCustom As System.Array _
)
[Delphi]
procedure OnConnection(
  const pApplication: IDispatch;
  eConnectMode: ext_ConnectMode;
  const pAddInInst: IDispatch;
  var ppCustom: PSafeArray
); safecall;

Parameter

pApplication
[in] Verweis auf das Application-Objekt von SpeedCommander.
ConnectMode
[in] Gibt an, wie das AddIn geladen wurde und ist einer der folgenden Werte:
Status | Wert | Bedeutung
ext_cm_AfterStartup | 0 | Das AddIn wurde zu einem späteren Zeitpunkt geladen.
ext_cm_Startup | 1 | Das AddIn wurde beim Start von SpeedCommander geladen.
ext_cm_External | 2 | Das AddIn wurde durch ein anderes AddIn geladen.
pAddInInst
[in] Verweis auf ein AddIn-Objekt, welches das AddIn innerhalb der AddIns-Liste präsentiert.
ppCustom
[in] Array von Variants für benutzerdefinierte Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


OnDisconnection (IDTExtensibility2)

OnDisconnection (IDTExtensibility2)

OnDisconnection wird aufgerufen, bevor die Verbindung zu SpeedCommander getrennt wird. Mit dem Parameter DisconnectMode kann das AddIn ermitteln, ob es durch den Anwender entladen wird. In diesem Fall sollte es alle seine Befehle und Einstellungen entfernen. Im anderen Fall sollten alle Anpassungen erhalten bleiben, so dass mögliche Befehle beim nächsten Start wieder zur Verfügung stehen.

[C++]
HRESULT __stdcall OnDisconnection(
  /*[in]*/ ext_DisconnectMode eDisconnectMode,
  /*[in]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnDisconnection(
  ext_DisconnectMode eDisconnectMode,
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnDisconnection( _
  ByVal eDisconnectMode As ext_DisconnectMode, _
  ByRef ppCustom As System.Array _
)
[Delphi]
procedure OnDisconnection(
  eDisconnectMode: ext_DisconnectMode;
  var ppCustom: PSafeArray
); safecall;

Parameter

eDisconnectMode
[in] Gibt an, wie das AddIn entladen wurde und ist einer der folgenden Werte:
Ausführung | Wert | Bedeutung
ext_dm_HostShutdown | 0 | Das AddIn wurde entladen, weil SpeedCommander beendet wurde.
ext_dm_UserClosed | 1 | Das AddIn wurde vom Anwender entfernt.
ppCustom
[in] Benutzerdefinierter Wert für zusätzliche Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


OnStartupComplete (IDTExtensibility2)

OnStartupComplete (IDTExtensibility2)

OnStartupComplete wird aufgerufen, wenn der Startvorgang von SpeedCommander abgeschlossen wurde und die Benutzeroberfläche einsatzbereit ist. Das AddIn kann dieses Ereignis z.B. auch dazu nutzen, um zu überprüfen, ob andere AddIns geladen sind.

[C++]
HRESULT __stdcall OnStartupComplete(
  /*[in, out]*/ SAFEARRAY** ppCustom
);
[C#]
public void OnStartupComplete(
  ref System.Array ppCustom
);
[Visual Basic .NET]
public Sub OnStartupComplete( _
  ByRef ppCustom As System.Array _
)
[Delphi]
procedure OnStartupComplete(
  var ppCustom: PSafeArray
); safecall;

Parameter

ppCustom
[in, out] Array von Variants für benutzerdefinierte Daten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTExtensibility2


FileOpProgress-Objekt

FileOpProgress-Objekt

Mit Hilfe des FileOpProgress-Objektes kann die Fortschrittsanzeige für die aktuelle Operation beeinflusst werden. Für bestimmte Aktionen vor oder nach einer Dateioperation kann das AddIn auch eigene Aktionen (z.B. Konvertieren von Dateien) definieren.

Eigenschaften

Application | Gibt das Anwendungsobjekt zurück.
Cancelled | Ermittelt, ob die aktuelle Operation durch den Anwender abgebrochen wurde.

Methoden

SetProgress | Setzt den Fortschritt für die aktuelle Operation.
StartJob | Startet einen neuen Job.
EndJob | Beendet den aktuellen Job.
SetJobProgress | Setzt den Fortschritt für den aktuellen Job.

IDTFileSystemSite


Application (FileOpProgress-Objekt)

Application (FileOpProgress-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FileOpProgress-Objekt, Application-Objekt


Cancelled (FileOpProgress-Objekt)

Cancelled (FileOpProgress-Objekt)

Ermittelt, ob die aktuelle Operation durch den Anwender abgebrochen wurde.

[C++]
HRESULT get_Cancelled(
  /*[out, retval]*/ VARIANT_BOOL* pCancelled
);
[C#]
bool Cancelled {get;}
[Visual Basic .NET]
Public ReadOnly Property Cancelled() As Boolean
[Delphi]
property Cancelled: WordBool read Get_Cancelled;

FileOpProgress-Objekt


EndJob (FileProgress-Objekt)

EndJob (FileProgress-Objekt)

Beendet eine Aktion.

[C++]
HRESULT __stdcall EndJob();
[C#]
public void EndJob();
[Visual Basic .NET]
Public Sub EndJob()
[Delphi]
procedure EndJob; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileOpProgress-Objekt


SetJobProgress (FileOpProgress-Objekt)

SetJobProgress (FileOpProgress-Objekt)

Setzt den Fortschritt für die aktuelle Aktion.

[C++]
HRESULT __stdcall SetJobProgress(
  /*[in]*/ long nPercentDone
);
[C#]
public void SetJobProgress(
  int nPercentDone
);
[Visual Basic .NET]
Public Sub SetJobProgress( _
  ByVal nPercentDone As Integer _
)
[Delphi]
procedure SetJobProgress(
  nPercentDone: Integer
); safecall;

Parameter

nPercentDone
Erforderlich. Fortschritt in Prozent (von 0 bis 100).

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileOpProgress-Objekt


SetProgress (FileOpProgress-Objekt)

SetProgress (FileOpProgress-Objekt)

Setzt eine Fortschritt für die aktuelle Dateioperation.

[C++]
HRESULT __stdcall SetProgress(
  /*[in]*/ long nPercentDone
);
[C#]
public void SetProgress(
  int nPercentDone
);
[Visual Basic .NET]
Public Sub SetProgress( _
  ByVal nPercentDone As Integer _
)
[Delphi]
procedure SetProgress(
  nPercentDone: Integer
); safecall;

Parameter

nPercentDone
Erforderlich. Fortschritt in Prozent (von 0 bis 100).

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileOpProgress-Objekt


StartJob (FileOpProgress-Objekt)

StartJob (FileOpProgress-Objekt)

Startet eine neue Aktion.

[C++]
HRESULT __stdcall StartJob(
  /*[in]*/ BSTR bstrJobName
);
[C#]
public void StartJob(
  string bstrJobName
);
[Visual Basic .NET]
Public Sub StartJob( _
  ByVal bstrJobName As String _
)
[Delphi]
procedure StartJob(
  const bstrJobName: WideString
); safecall;

Parameter

bstrJobName
Erforderlich. Aktionsname, der in der Titelzeile des Fortschrittdialogs angezeigt wird.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

FileOpProgress-Objekt


DTINVOKECOMMANDINFO (IDTContextMenu)

DTINVOKECOMMANDINFO (IDTContextMenu)

Enthält Informationen zum auszuführenden Befehl.

[C++]
typedef struct tagDTINVOKECOMMANDINFO {
  DWORD cbSize;
  HWND hWndOwner;
  DWORD dwFlags;
  UINT nCommand;
  UINT nExtendedCommand;
} DTINVOKECOMMANDINFO, *LPDTINVOKECOMMANDINFO;
[Delphi]
DTINVOKECOMMANDINFO = packed record
  cbSize: LongWord;
  hWndOwner: HWnd;
  dwFlags: LongWord;
  nCommand: LongWord;
  nExtendedCommand: LongWord;
end;

Strukturwerte

cbSize
Gibt die Größe der Struktur an.
hWndOwner
Handle des aktuellen Fensters, das für Bildschirmausgaben (z.B. eine Dialogbox) genutzt werden kann.
dwFlags
Legt erweiterte Informationen fest und ist eine Kombination von:
Flag | Wert | Bedeutung
DTICIFLAG_EXTENDEDCOMMAND | 1 | Es wird ein vordefinierter Befehl in nExtendedCommand angegeben.
nCommand
Gibt den auszuführenden Befehl an.
nExtendedCommand
Gibt einen vordefinierten Befehl an. Mögliche Werte sind:
Flag | Wert | Bedeutung
DTICIEXTENDED_OPEN | 1 | Die gewählten Objekte sollen geöffnet werden.
DTICIEXTENDED_PROPERTIES | 2 | Die Eigenschaften der gewählten Objekte sollen angezeigt werden.

IDTContextMenu


InvokeCommand (IDTContextMenu)

InvokeCommand (IDTContextMenu)

Führt einen ausgewählten Befehl aus.

[C++]
HRESULT InvokeCommand(
  LPCDTINVOKECOMMANDINFO pInvokeCommandInfo
);
[C#]
public void InvokeCommand(
  ref DTINVOKECOMMANDINFO pInvokeCommandInfo
);
[Visual Basic .NET]
public Sub InvokeCommand( _
  ByRef pInvokeCommandInfo As DTINVOKECOMMANDINFO _
)
[Delphi]
function InvokeCommand(
  var pInvokeCommandInfo: DTINVOKECOMMANDINFO
): HResult; stdcall;

Parameter

pInvokeCommandInfo
[in] Zeigt auf eine DTINVOKECOMMANDINFO-Struktur mit Informationen zum auszuführenden Befehl.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_NOTIMPL, E_OUTOFMEMORY sowie:

S_OK
Der Befehl wurde erfolgreich ausgeführt.

IDTContextMenu


QueryContextMenu (IDTContextMenu)

QueryContextMenu (IDTContextMenu)

Fügt einem Kontextmenü Befehle für Dateisystemobjekte hinzu.

[C++]
HRESULT QueryContextMenu(
  HMENU hMenu,
  UINT nIndexMenu,
  UINT nCmdFirst,
  UINT nCmdLast,
  DWORD dwFlags
);
[C#]
public void QueryContextMenu(
  ref RemotableHandle hMenu,
  uint nIndexMenu,
  uint nCmdFirst,
  uint nCmdLast,
  uint dwFlags
);
[Visual Basic .NET]
public Sub QueryContextMenu( _
  ByRef hMenu As RemotableHandle, _
  ByVal nIndexMenu As System.UInt32, _
  ByVal nCmdFirst As System.UInt32, _
  ByVal nCmdLast As System.UInt32, _
  ByVal dwFlags As System.UInt32 _
)
[Delphi]
function QueryContextMenu(
  var hMenu: RemotableHandle;
  nIndexMenu: LongWord;
  nCmdFirst: LongWord;
  dwFlags: LongWord
): HResult; stdcall;

Parameter

hMenu
[in] Menü, welches erweitert werden soll.
nIndexMenu
[in] Index, an welchem der erste Befehl in das Menü eingefügt werden kann.
nCmdFirst
[in] Befehls-ID für den ersten Befehl.
nCmdLast
[in] Befehls-ID für den letzten Befehl.
dwFlags
[in] Momentan nicht genutzt.

Rückgabewert

Gibt bei Erfolg die Anzahl der eingefügten Menüpunkte zurück oder E_FAIL bei einem Fehler.

IDTContextMenu


GetFileSystemSites (IDTFileSystemSites)

GetFileSystemSites (IDTFileSystemSites)

GetFileSystemSites wird aufgerufen, um die vom AddIn angebotenen Dateisystemobjekte abzufragen.

[C++]
HRESULT GetFileSystemSites(
  /*[out]*/ SAFEARRAY(IDTFileSystemSite*)* ppFileSystemSites
);
[C#]
public void GetFileSystemSites(
  out Array ppFileSystemSites
);
[Visual Basic .NET]
public Sub GetFileSystemSites( _
  ByRef ppFileSystemSites As Array _
)
[Delphi]
function GetFileSystemSites(
  out ppFileSystemSites: PSafeArray
): HResult; stdcall;

Parameter

ppFileSystemSites
[out] Zeiger auf ein Array mit IDTFileSystemSite-Objekten.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystem


Attributes (IDTFileSystemItem)

Attributes (IDTFileSystemItem)

Gibt die Attribute für den Dateisystemeintrag zurück.

[C++]
HRESULT __stdcall get_Attributes(
  /*[out, retval]*/ long* pAttributes
);
[C#]
public int Attributes {get;}
[Visual Basic .NET]
Public ReadOnly Property Attributes() As Integer
[Delphi]
function Get_Attributes(
  out pAttributes: Integer
): HResult; stdcall;

Parameter

pAttributes
[out] Attribute des Dateisystemeintrages. Der Wert ist eine Kombination von:
Attribut | Wert | Bedeutung
FILE_ATTRIBUTE_READONLY | 0x0001 (1) | Der Dateisystemeintrag ist schreibgeschützt.
FILE_ATTRIBUTE_HIDDEN | 0x0002 (2) | Der Dateisystemeintrag ist versteckt.
FILE_ATTRIBUTE_SYSTEM | 0x0004 (4) | Der Dateisystemeintrag ist Teil des Betriebssystems.
FILE_ATTRIBUTE_DIRECTORY | 0x0010 (16) | Der Dateisystemeintrag ist ein Ordner.
FILE_ATTRIBUTE_ARCHIVE | 0x0020 (32) | Der Dateisystemeintrag muss gesichert werden.
FILE_ATTRIBUTE_COMPRESSED | 0x1000 (4096) | Der Dateisystemeintrag ist komprimiert.
FILE_ATTRIBUTE_ENCRYPTED | 0x4000 (16384) | Der Dateisystemeintrag ist verschlüsselt.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


DateCreated (IDTFileSystemItem)

DateCreated (IDTFileSystemItem)

Gibt den Zeitpunkt der Erstellung für den Dateisystemeintrag zurück.

[C++]
HRESULT __stdcall get_DateCreated(
  /*[out, retval]*/ DATE* pDateCreated
);
[C#]
public DateTime DateCreated {get;}
[Visual Basic .NET]
Public ReadOnly Property DateCreated() As Date
[Delphi]
function Get_DateCreated(
  out pDateCreated: TDateTime
): HResult; stdcall;

Parameter

pDateCreated
[out] Zeitpunkt der Erstellung.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


DateLastAccessed (IDTFileSystemItem)

DateLastAccessed (IDTFileSystemItem)

Gibt den Zeitpunkt des letzten Zugriffs für den Dateisystemeintrag zurück.

[C++]
HRESULT __stdcall get_DateLastAccessed(
  /*[out, retval]*/ DATE* pDateLastAccessed
);
[C#]
public DateTime DateLastAccessed {get;}
[Visual Basic .NET]
Public ReadOnly Property DateLastAccessed() As Date
[Delphi]
function Get_DateLastAccessed(
  out pDateLastAccessed: TDateTime
): HResult; stdcall;

Parameter

pDateLastAccessed
[out] Zeitpunkt des letzten Zugriffs.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


DateLastModified (IDTFileSystemItem)

DateLastModified (IDTFileSystemItem)

Gibt den Zeitpunkt der letzten Änderung für den Dateisystemeintrag zurück.

[C++]
HRESULT __stdcall get_DateLastModified(
  /*[out, retval]*/ DATE* pDateLastModified
);
[C#]
public DateTime DateLastModified {get;}
[Visual Basic .NET]
Public ReadOnly Property DateLastModified() As Date
[Delphi]
function Get_DateLastModified(
  out pDateLastModified: TDateTime
): HResult; stdcall;

Parameter

pDateLastModified
[out] Zeitpunkt der letzten Änderung.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


GetItemData (IDTFileSystemItem)

GetItemData (IDTFileSystemItem)

Gibt die Daten für eine erweiterte Spalte zurück.

[C++]
HRESULT __stdcall GetItemData(
  /*[in]*/ LPSHCOLUMNID pColumnID,
  /*[out]*/ VARIANT* pVarData
);
[C#]
public void GetItemData(
  ref SHCOLUMNID pColumnID,
  out object pVarData
);
[Visual Basic .NET]
public Sub GetItemData( _
  ByRef pColumnID As SHCOLUMNID, _
  ByRef pVarData As Object_
)
[Delphi]
function GetItemData(
  var pColumnID: SHCOLUMNID;
  out pVarData: OleVariant
): HResult; stdcall;

Parameter

pColumnID
[in] Eindeutige Spaltenkennung.
pVarData
[out] Zeigt auf eine VARIANT-Struktur und enthält die angeforderten Daten für die Spalte.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


Image (IDTFileSystemItem)

Image (IDTFileSystemItem)

Gibt den Index des Symbols in der Systemimageliste zurück, welches SpeedCommander zur Anzeige des Eintrages verwenden soll. Das AddIn kann der Systemimageliste mit Hilfe der Funktion IApplication::AddImage eigene Symbole hinzufügen.

[C++]
HRESULT __stdcall get_Image(
  /*[out, retval]*/ long* pImage
);
[C#]
public int Image {get;}
[Visual Basic .NET]
Public ReadOnly Property Image() As Integer
[Delphi]
function Get_Image(
  out pImage: Integer
): HResult; stdcall;

Parameter

pImage
[out] Index des Symbols in der Systemimageliste oder -1, wenn SpeedCommander das Symbol über die Dateierweiterung selbst bestimmen soll.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


Name (IDTFileSystemItem)

Name (IDTFileSystemItem)

Gibt den Namen des Dateisystemeintrages zurück.

[C++]
HRESULT __stdcall get_Name(
  /*[out, retval]*/ BSTR* pbstrName
);
[C#]
public string Name {get;}
[Visual Basic .NET]
Public ReadOnly Property Name() As String
[Delphi]
function Get_Name(
  out pbstrName: WideString
): HResult; stdcall;

Parameter

pbstrName
[out] Name des Eintrages.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


Size (IDTFileSystemItem)

Size (IDTFileSystemItem)

Gibt die Größe des Dateisystemeintrages zurück.

[C++]
HRESULT __stdcall get_Size(
  /*[out, retval]*/ VARIANT* pSize
);
[C#]
public object Size {get;}
[Visual Basic .NET]
Public ReadOnly Property Size() As Object
[Delphi]
function Get_Size(
  out pSize: OleVariant
): HResult; stdcall;

Parameter

pSize
[out] Größe des Dateisystemeintrages.

Rückgabewert

Der Rückgabewert ist NOERROR oder ein bekannter OLE-Fehlercode.

IDTFileSystemItem


Capabilities (IDTFileSystemSite)

Capabilities (IDTFileSystemSite)

Gibt die Eigenschaften des AddIn-Dateisystemobjekts zurück.

[C++]
HRESULT __stdcall get_Capabilities(
  /*[out, retval]*/ long* pCapabilities
);
[C#]
public int Capabilities {get;}
[Visual Basic .NET]
public ReadOnly Property Capabilities() As Integer
[Delphi]
function Get_Capabilities(
  out pCapabilities: Integer
): HResult; stdcall;

Parameter

pCapabilities
[out] Gibt die Eigenschaften des Dateisystemobjekts zurück. Der Wert ist 0 oder eine Kombination folgender Eigenschaften:
Flag | Wert | Bedeutung
FSSCAP_FILEOP_BACKGROUND | 0x001 (1) | Die Dateioperationen können im Hintergrund ablaufen, die Schnittstelle ist multithreadfähig.
FSSCAP_FILEOP_SUSPEND | 0x0002 (2) | Die Dateioperationen können angehalten/fortgesetzt werden.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL sowie:

S_OK
Die Eigenschaften wurden erfolgreich zurückgegeben.

IDTFileSystemSite


Comment (IDTFileSystemSite)

Comment (IDTFileSystemSite)

Gibt einen Kommentar für das Dateisystem-Objekt zurück. Der Kommentar wird in der Dateisystem-AddIn-Ansicht angezeigt.

[C++]
HRESULT __stdcall get_Comment(
  /*[out, retval]*/ BSTR* pbstrComment
);
[C#]
public string Comment {get;}
[Visual Basic .NET]
Public ReadOnly Property Comment() As String
[Delphi]
function Get_Comment(
  out pbstrComment: WideString
): HResult; stdcall;

Parameter

pbstrComment
[out] Gibt den Kommentar für das Dateisystemobjekt zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_OUTOFMEMORY sowie:

S_OK
Der Kommentar wurde erfolgreich zurückgegeben.
E_NOTIMPL
Die Funktion ist nicht implementiert.

IDTFileSystemSite


CreateDirectory (IDTFileSystemSite)

CreateDirectory (IDTFileSystemSite)

Erstellt einen neuen Ordner.

[C++]
HRESULT __stdcall CreateDirectory(
  /*[in]*/ BSTR bstrFolder,
  /*[out]*/ IFileSystemItem** pFileSystemItem
);
[C#]
public void CreateDirectory(
  string bstrFolder,
  out IFileSystemItem pFileSystemItem
);
[Visual Basic .NET]
public Sub CreateDirectory( _
  ByVal bstrFolder As String, _
  ByRef pFileSystemItem As IFileSystemItem _
)
[Delphi]
function CreateDirectory(
  const bstrFolder: WideString;
  out pFileSystemItem: IFileSystemItem
): HResult; stdcall;

Parameter

bstrFolder
[in] Ordner, der erstellt werden soll.
pFileSystemItem
[out] Adresse eines Zeigers, der ein IDTFileSystemItem-Objekt für den neuerstellten Ordner empfängt.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Ordner wurde erfolgreich erstellt.

IDTFileSystemSite


DeleteFile (IDTFileSystemSite)

DeleteFile (IDTFileSystemSite)

Löscht eine Datei.

[C++]
HRESULT __stdcall DeleteFile(
  /*[in]*/ BSTR bstrPathName
);
[C#]
public void DeleteFile(
  string bstrPathName
);
[Visual Basic .NET]
public Sub DeleteFile( _
  ByVal bstrPathName As String _
)
[Delphi]
function DeleteFile(
  const bstrPathName: WideString
): HResult; stdcall;

Parameter

bstrPathName
[in] Datei, die gelöscht werden soll.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Datei wurde erfolgreich gelöscht.

IDTFileSystemSite


DownloadFile (IDTFileSystemSite)

DownloadFile (IDTFileSystemSite)

Kopiert eine Datei vom AddIn-Dateisystem in einen lokalen Ordner oder UNC-Pfad.

[C++]
HRESULT __stdcall DownloadFile(
  /*[in]*/ BSTR bstrRemoteFileName,
  /*[in]*/ BSTR bstrLocalFileName,
  /*[in]*/ DWORD dwFlags,
  /*[in]*/ IFileOpProgress* pFileOpProgress
);
[C#]
public void DownloadFile(
  string bstrRemoteFileName,
  string bstrLocalFileName,
  uint dwFlags,
  IFileOpProgress pFileOpProgress
);
[Visual Basic .NET]
public Sub DownloadFile( _
  ByVal bstrRemoteFileName As String, _
  ByVal bstrLocalFileName As String, _
  ByVal dwFlags As System.UInt32, _
  ByVal pFileOpProgress As IFileOpProgress _
)
[Delphi]
function DownloadFile(
  const bstrRemoteFileName: WideString;
  const bstrLocalFileName: WideString;
  dwFlags: LongWord;
  const pFileOpProgress: IFileOpProgress
): HResult; stdcall;

Parameter

bstrRemoteFileName
[in] Quelldateiname für die zu kopierende Datei.
bstrLocalFileName
[in] Zieldateiname für die zu kopierende Datei.
dwFlags
[in] Momentan nicht benutzt.
pFileOpProgress
[in] Schnittstelle zu IFileOpProgress zum Setzen des Fortschritts.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Datei wurde erfolgreich kopiert.
STG_E_FILENOTFOUND
Die Quelldatei wurde nicht gefunden.
STG_E_READFAULT
Fehler beim Lesen.
STG_E_WRITEFAULT
Fehler beim Schreiben.
STG_E_ACCESSDENIED
Zugriff verweigert.
E_ABORT
Die Aktion wurde abgebrochen.

IDTFileSystemSite


DTCOLUMNINFO (IDTFileSystemSite)

DTCOLUMNINFO (IDTFileSystemSite)

Enthält Eigenschaften für eine Spalte.

[C++]
typedef struct tagDTCOLUMNINFO {
  SHCOLUMNID scid;
  DWORD dwFormat;
  UINT cChars;
  DTCOLSTATEF dwFlags;
  BSTR bstrTitle;
} DTCOLUMNINFO, *LPDTCOLUMNINFO;
[Delphi]
DTCOLUMNINFO = packed record
  scid: SHCOLUMNID;
  dwFormat: LongWord;
  cChars: SYSUINT;
  dwFlags: LongWord;
  bstrTitle: WideString;
end;

Strukturwerte

scid
Legt die eindeutige Spaltenkennung mit der Struktur SHCOLUMNID fest.
dwFormat
Legt die Ausrichtung der Spalte fest. Mögliche Wert sind:
Ausrichtung | Wert | Bedeutung
LVCFMT_LEFT | 0 | Die Werte in der Spalte sind nach links ausgerichtet.
LVCFMT_RIGHT | 1 | Die Werte in der Spalte sind nach rechts ausgerichtet.
LVCFMT_CENTER | 2 | Die Werte in der Spalte sind zentriert ausgerichtet.
cChars
Breite der Spalte in Zeichen.
dwFlags
Legt bestimmte Eigenschaften für die Spalte fest.
Flag | Wert | Bedeutung
DTCOLSTATE_TYPE_STR | 1 | Die Werte in der Spalte sind Strings.
DTCOLSTATE_TYPE_INT | 2 | Die Werte in der Spalte sind Zahlen.
DTCOLSTATE_TYPE_DATE | 3 | Die Werte in der Spalte sind Datumsangaben.
DTCOLSTATE_SLOW | 16 | Die Abfrage der Spaltenwerte für die einzelen Dateieinträge erfolgt asynchron im Hintergrund.
DTCOLSTATE_HIDDEN | 32 | Die Spalte ist versteckt und nicht aktivierbar.
DTCOLSTATE_PREFER_VARCMP | 64 | SpeedCommander soll bei einer Sortierung die Werte dieser Spalte direkt vergleichen und nicht den Spaltentext (String) verwenden.
bstrTitle
Legt den Spaltentitel fest.

IDTFileSystemSite


DTVOLUMEINFORMATION (IDTFileSystemSite)

DTVOLUMEINFORMATION (IDTFileSystemSite)

Enthält Informationen zum Laufwerksstatus.

[C++]
typedef struct tagDTVOLUMEINFORMATION {
  BSTR bstrVolumeName;
  BSTR bstrVolumeSerial;
  BSTR bstrFileSystemName;
  VARIANT varBytesTotal;
  VARIANT varBytesFree;
  DWORD dwTotalClusters;
  DWORD dwFreeClusters;
  DWORD dwSectorsPerCluster;
  DWORD dwBytesPerSector;
  DTVOLINFOF dwFlags;
} DTVOLUMEINFORMATION, *LPDTVOLUMEINFORMATION;
[Delphi]
DTCOLUMNINFO = packed record
  bstrVolumeName: WideString;
  bstrVolumeSerial: WideString;
  bstrFileSystemName: WideString;
  varBytesTotal: OleVariant;
  varBytesFree: OleVariant;
  dwTotalClusters: LongWord;
  dwFreeClusters: LongWord;
  dwSectorsPerCluster: LongWord;
  dwBytesPerSector: LongWord;
  dwFlags: LongWord;
end;

Strukturwerte

bstrVolumeName
Gibt den Namen des Datenträgers an.
bstrVolumeSerial
Gibt die Seriennummer des Laufwerks an.
bstrFileSystemName
Gibt den Namen des Dateisystems an.
varBytesTotal
Gibt den insgesamt zur Verfügung stehenden Speicherplatz an.
varBytesFree
Gibt den freien Speicherplatz an.
dwTotalClusters
Gibt die insgesamt zur Verfügung stehenden Cluster an.
dwFreeClusters
Gibt die freien Cluster an.
dwSectorsPerCluster
Gibt an, wieviel Sektoren zu einem Cluster gehören.
dwBytesPerSector
Gibt an, wieviele Bytes ein Sektor umfasst.
dwFlags
Gibt zusätzliche Eigenschaften des Datenträgers an und ist eine Kombination von:
Flag | Wert | Bedeutung
DTVOLINFO_CASE_PRESERVEDNAMES | 0x0001 (1) | Speicherung von Dateinamen mit Groß- und Kleinschreibung.
DTVOLINFO_CASE_SENSITIVESEARCH | 0x0002 (2) | Unterscheidung von Dateinamen mit Groß- und Kleinschreibung.
DTVOLINFO_SUPPORTS_UNICODE | 0x0004 (4) | Unterstützung von Dateinamen in Unicode.
DTVOLINFO_SUPPORTS_PERSISTENTACLS | 0x0008 (8) | Unterstützung von Zugriffskontroll-Listen (ACLs).
DTVOLINFO_SUPPORTS_COMPRESSION | 0x0010 (16) | Unterstützung von dateibasierter Kompression.
DTVOLINFO_SUPPORTS_ENCRYPTION | 0x0020 (32) | Unterstützung von Verschlüsselung (EFS).
DTVOLINFO_SUPPORTS_QUOTAS | 0x0040 (64) | Unterstützung von Disk-Quotas.
DTVOLINFO_SUPPORTS_REPARSEPOINTS | 0x0080 (128) | Unterstützung von Reparse-Points.
DTVOLINFO_SUPPORTS_SPARSEFILES | 0x0100 (256) | Unterstützung von Sparse-Streams.
DTVOLINFO_SUPPORTS_OBJECTIDS | 0x0200 (512) | Unterstützung von Objekt-Identifiers.

IDTFileSystemSite


EnumObjects (IDTFileSystemSite)

EnumObjects (IDTFileSystemSite)

Ermittelt alle Elemente in einem Ordner. Für jedes Element erstellt EnumObjects ein IDTFileSystemItem-Objekt und fügt es der Kollektion hinzu.

[C++]
HRESULT __stdcall EnumObjects(
  /*[in]*/ BSTR bstrFolder,
  /*[out]*/ SAFEARRAY** ppFileSystemItems
);
[C#]
public void EnumObjects(
  string bstrFolder,
  out System.Array ppFileSystemItems
);
[Visual Basic .NET]
public Sub EnumObjects( _
  ByVal bstrFolder As String, _
  ByRef ppFileSystemItems As System.Array _
)
[Delphi]
function EnumObjects(
  const bstrFolder: WideString;
  out ppFileSystemItems: PSafeArray
): HResult; stdcall;

Parameter

bstrFolder
[in] Gibt den Ordner an, für welchen die Elemente abgerufen werden sollen.
ppFileSystemItems
[out] Zeiger auf ein Array mit IDTFileSystemItem-Objekten.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Auflistung war erfolgreich.

IDTFileSystemSite


ExecCommand (IDTFileSystemSite)

ExecCommand (IDTFileSystemSite)

Führt einen Befehl aus, den der Anwender in der Kommandozeile eingegeben hat.

[C++]
HRESULT __stdcall ExecCommand(
  /*[in]*/ BSTR bstrCommand
);
[C#]
public void ExecCommand(
  string bstrCommand
);
[Visual Basic .NET]
public Sub ExecCommand( _
  ByVal bstrCommand As String _
)
[Delphi]
function ExecCommand(
  const bstrCommand: WideString
): HResult; stdcall;

Parameter

bstrCommand
[in] Auszuführender Befehl.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Befehl wurde erfolgreich ausgeführt .
S_FALSE
Der Befehl wurde erfolgreich ausgeführt und das aktuell angezeigte Verzeichnis soll aktualisiert werden.

IDTFileSystemSite


FileOpStatusInfo (IDTFileSystemSite)

FileOpStatusInfo (IDTFileSystemSite)

Wird aufgerufen, wenn eine Dateioperation gestartet oder beendet wird.

[C++]
HRESULT __stdcall FileOpStatusInfo(
  /*[in]*/ BSTR bstrRemotePath,
  /*[in]*/ enum scFileOpStatus eStatus,
  /*[in]*/ enum scFileOpAction eAction
);
[C#]
public void FileOpStatusInfo(
  string bstrRemotePath,
  scFileOpStatus eStatus,
  scFileOpAction eAction
);
[Visual Basic .NET]
public Sub FileOpStatusInfo( _
  ByVal bstrRemotePath As String, _
  ByVal eStatus As scFileOpStatus, _
  ByVal eAction As scFileOpAction _
)
[Delphi]
function FileOpStatusInfo(
  const bstrRemotePath: WideString;
  eStatus: scFileOpStatus;
  eAction: scFileOpAction
): HResult; stdcall;

Parameter

bstrRemotePath
[in] Ordner, in dem die Aktion durchgeführt wird.
scFileOpStatus
[in] Gibt an, ob die Aktion gestartet wird oder beendet wurde.
Konstante | Wert | Bedeutung
scFileOpStatusStart | 0 | Die Aktion wird gestartet.
scFileOpStatusEnd | 1 | Die Aktion wurde beendet.
scFileOpAction
[in] Legt die Aktion fest.
Konstante | Wert | Bedeutung
scFileOpActionList | 1 | Ein Ordner wird aufgelistet.
scFileOpActionDownload | 2 | Eine oder mehrere Dateien werden vom AddIn-Dateisystem in einen lokalen Ordner oder UNC-Pfad kopiert.
scFileOpActionDownloadSingle | 3 | Eine einzelne Datei wird vom AddIn-Dateisystem in einen lokalen Ordner oder UNC-Pfad kopiert.
scFileOpActionUpload | 4 | Eine oder mehrere Dateien werden von einem lokalen Ordner oder einem UNC-Pfad in das AddIn-Dateisystem kopiert.
scFileOpActionUploadSingle | 5 | Eine einzelne Datei wird von einem lokalen Ordner oder einem UNC-Pfad in das AddIn-Dateisystem kopiert.
scFileOpActionDelete | 6 | Dateien oder Ordner werden gelöscht.
scFileOpActionCreateDirectory | 7 | Ein neuer Ordner wird erstellt.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

IDTFileSystemSite


GetColumnID (IDTFileSystemSite)

GetColumnID (IDTFileSystemSite)

Ermittelt die Spalten-ID für einen bestimmten Ordner und ermöglicht damit dem AddIn, verschiedene Spaltenlayouts für unterschiedliche Ordner anzubieten. Vor jeder Anzeige eines Ordners fragt SpeedCommander die Spalten-ID ab und benutzt diese dann, um das jeweilige gespeicherte Layout wiederherzustellen. Das AddIn sollte als Spalten-ID 0 zurückgeben, wenn es für alle Ordner ein und dieselbe Spaltenanordnung anbietet.

[C++]
HRESULT __stdcall GetColumnID(
  /*[in]*/ BSTR bstrFolder,
  /*[out]*/ long* plColumnID
);
[C#]
public void GetColumnID(
  string bstrFolder,
  out int plColumnID
);
[Visual Basic .NET]
public Sub GetColumnID( _
  ByVal bstrFolder As String, _
  ByRef plColumnID As Integer, _
)
[Delphi]
function GetColumnID(
  const bstrFolder: WideString;
  out plColumnID: Integer
): HResult; stdcall;

Parameter

bstrFolder
[in] Gibt den Ordner an, für welchen die Spalten-ID abgefragt werden soll.
plColumnID
[out] Gibt die Spalten-ID zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Spalten-ID wurde erfolgreich zurückgegeben.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


GetColumnInfo (IDTFileSystemSite)

GetColumnInfo (IDTFileSystemSite)

Fragt Informationen zu verfügbaren Spalten ab. SpeedCommander ruft GetColumnInfo solange auf, bis GetColumnInfo entweder einen Fehlercode oder S_FALSE zurückgibt.

[C++]
HRESULT __stdcall GetColumnInfo(
  /*[in]*/ DWORD dwIndex,
  /*[in]*/ BSTR bstrFolder,
  /*[out]*/ LPDTCOLUMNINFO pColumnInfo
);
[C#]
public void GetColumnInfo(
  uint dwIndex,
  string bstrFolder,
  ref DTCOLUMNINFO pColumnInfo
);
[Visual Basic .NET]
public Sub GetColumnInfo( _
  ByVal dwIndex As System.UInt32, _
  ByVal bstrFolder As String, _
  ByRef pColumnInfo As DTCOLUMNINFO _
)
[Delphi]
function GetColumnInfo(
  dwIndex: LongWord;
  const bstrFolder: WideString;
  out pColumnInfo: DTCOLUMNINFO
): HResult; stdcall;

Parameter

dwIndex
[in] Null-basierter Zähler, der von SpeedCommander zur Auflistung genutzt wird. Mit jedem Aufruf wird der Zähler um eins erhöht.
bstrFolder
[in] Gibt den Ordner an, für welchen die Spalteninformationen abgerufen werden.
pColumnInfo
[out] Gibt die Spalteninformationen in einer DTCOLUMNINFO-Struktur zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Spalten-ID wurde erfolgreich zurückgegeben.
S_FALSE
Es sind keine weiteren Spalten verfügbar.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


GetCurrentDirectory (IDTFileSystemSite)

GetCurrentDirectory (IDTFileSystemSite)

Fragt den aktuell gesetzten Ordner im AddIn-Dateisystem ab.

[C++]
HRESULT __stdcall GetCurrentDirectory(
  /*[out]*/ BSTR* pbstrFolder
);
[C#]
public void GetCurrentDirectory(
  out string pbstrFolder
);
[Visual Basic .NET]
public Sub GetCurrentDirectory( _
  ByRef pbstrFolder As String _
)
[Delphi]
function GetCurrentDirectory(
  out pbstrFolder: WideString
): HResult; stdcall;

Parameter

pbstrFolder
[out] Gibt den aktuell gesetzten Ordner zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Ordner wurde erfolgreich ermittelt.

IDTFileSystemSite


GetDefaultColumns (IDTFileSystemSite)

GetDefaultColumns (IDTFileSystemSite)

Gibt an, welche Spalten bei der ersten Initialisierung einer Ansicht aktiviert werden sollen.

[C++]
HRESULT __stdcall GetDefaultColumns(
  /*[in]*/ long nColumnID,
  /*[out]*/ DWORD* pdwDefaultColumns
);
[C#]
public void GetDefaultColumns(
  int nColumnID,
  out uint pdwDefaultColumns
);
[Visual Basic .NET]
public Sub GetDefaultColumns( _
  ByVal nColumnID As Integer, _
  ByRef pdwDefaultColums As System.UInt32 _
)
[Delphi]
function GetDefaultColumns(
  nColumnID: Integer;
  out pdwDefaultColumns: LongWord
): HResult; stdcall;

Parameter

nColumnID
[in] Spalten-ID, für welche die Standardinitialisierung abgefragt wird.
pdwDefaultColumns
[out] Gibt zurück, welche Spalten bei der ersten Initialisierung angezeigt werden sollen und ist eine Kombination von:
Konstante | Wert | Beschreibung
scDefaultColumnSize | 1 | Die Spalte Größe soll angezeigt werden.
scDefaultColumnType | 2 | Die Spalte Typ soll angezeigt werden.
scDefaultColumnModified | 4 | Die Spalte Geändert am soll angezeigt werden.
scDefaultColumnAttributes | 8 | Die Spalte Attribute soll angezeigt werden.
scDefaultColumnExtension | 16 | Die Spalte Erweiterung soll angezeigt werden.
scDefaultColumnAddIn1 | 32 | Die erste selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn2 | 64 | Die zweite selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn3 | 128 | Die dritte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn4 | 256 | Die vierte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn5 | 512 | Die fünfte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn6 | 1024 | Die sechste selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn7 | 2048 | Die siebte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn8 | 4096 | Die achte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn9 | 8192 | Die neunte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn10 | 16384 | Die zehnte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn11 | 32768 | Die elfte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn12 | 65536 | Die zwölfte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn13 | 131072 | Die dreizehnte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn14 | 262144 | Die vierzehnte selbstdefinierte Spalte des AddIns soll angezeigt werden.
scDefaultColumnAddIn15 | 524288 | Die fünfzehnte selbstdefinierte Spalte des AddIns soll angezeigt werden.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die anzuzeigenden Spalten wurden erfolgreich zurückgegeben.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


GetTargetFileName (IDTFileSystemSite)

GetTargetFileName (IDTFileSystemSite)

Vor jeder Kopieroperation (IDTFileSystemSite::DownloadFile und IDTFileSystemSite::UploadFile) fragt SpeedCommander nach dem Zieldateinamen. SpeedCommander setzt den Zieldateinamen anhand der vom Anwender festgelegten Optionen selbst zusammen. In einigen Fällen kann es aber vorkommen, dass sich der Zieldateiname durch Konvertierungen (z.B. beim Konvertieren von Dokumenten zwischen PDA und PC) ändert. Das AddIn darf hier aber nur den Dateinamen selbst anpassen, der Pfadbestandteil muss unverändert bleiben!

[C++]
HRESULT __stdcall GetTargetFileName(
  /*[in]*/ DWORD dwFlags,
  /*[in]*/ BSTR bstrSourceFileName,
  /*[in, out]*/ BSTR* pbstrTargetFileName
);
[C#]
public void GetTargetFileName(
  uint dwFlags,
  string bstrSourceFileName,
  ref string pbstrTargetFileName
);
[Visual Basic .NET]
public Sub GetTargetFileName( _
  ByVal dwFlags As System.UInt32, _
  ByVal bstrSourceFileName As String _
  ByRef pbstrTargetFileName As String _
)
[Delphi]
function GetTargetFileName(
  dwFlags: LongWord;
  const bstrSourceFileName: WideString;
  var pbstrTargetFileName: WideString
): HResult; stdcall;

Parameter

dwFlags
[in] Flags für die Bestimmung des Zieldateinamens. Mögliche Werte sind:
Flag | Wert | Bedeutung
FSSGTFN_DOWNLOAD | 1 | Die Datei wird vom AddIn-Dateisystem in einen lokalen Ordner oder UNC-Pfad kopiert.
FSSGTFN_UPLOAD | 2 | Die Datei wird von einem lokalen Ordner oder UNC-Pfad in das AddIn-Dateisystem kopiert.
bstrSourceFileName
[in] Datei, die kopiert werden soll.
pbstrTargetFileName
[in, out] Gibt den Zieldateinamen zurück. Bei einer Änderung des Zieldateinamens muss der von SpeedCommander vorgeschlagene Zieldateiname vorher mit SysFreeString freigegeben werden.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Zieldateiname wurde geändert.
E_NOTIMPL
Die Funktion ist nicht implementiert.

IDTFileSystemSite


GetUIObjectOf (IDTFileSystemSite)

GetUIObjectOf (IDTFileSystemSite)

Erstellt ein UI-Objekt für die angegebenen Dateien und Ordner. Mögliche UI-Objekte sind

  • IDTContextMenu
[C++]
HRESULT __stdcall GetUIObjectOf(
  /*[in]*/ HANDLE_PTR hWndOwner,
  /*[in]*/ UINT nItems,
  /*[in]*/ VARIANT varItems,
  /*[in]*/ REFIID riid,
  /*[out]*/ void** ppInterface
);
[C#]
public void GetUIObjectOf(
  uint hWndOwner,
  uint nItems,
  object varItems,
  System.Guid riid,
  System.IntPtr ppInterface
);
[Visual Basic .NET]
public Sub GetUIObjectOf( _
  ByVal hWndOwner As System.UInt32, _
  ByVal nItems As System.UInt32, _
  ByVal varItems As Object, _
  ByRef riid As System.Guid, _
  ByRef ppInterface As System.IntPtr _
)
[Delphi]
function GetUIObjectOf(
  hWndOwner: LongWord;
  nItems: LongWord;
  varItems: OleVariant;
  var riid: TGuid;
  out ppInterface: Pointer
): HResult; stdcall;

Parameter

hWndOwner
[in] Handle (HWND) des aktuellen Fensters, das für Bildschirmausgaben (z.B. eine Dialogbox) genutzt werden kann.
nItems
[in] Anzahl der Einträge im Array oder null, wenn das UI-Objekt für oberste Ebene (Root) des Dateisystems angefordert wird.
varItems
[in] Array aus IDTFileSystemItem-Objekten, für die das UI-Objekt erstellt werden soll.
riid
[in] GUID für das zu erstellende UI-Objekt:
GUID | Bedeutung
IID_IDTContextMenu | Ein IDTContextMenu-Objekt soll erstellt werden.
ppInterface
[out] Zeiger auf das erstellte UI-Objekt.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_NOTIMPL, E_OUTOFMEMORY sowie:

S_OK
Das UI-Objekt wurde erfolgreich erstellt.
E_NOINTERFACE
Das Interface wird nicht unterstützt.

IDTFileSystemSite, IDTContextMenu


GetVolumeInformation (IDTFileSystemSite)

GetVolumeInformation (IDTFileSystemSite)

Gibt Informationen zum Laufwerksstatus (u.a. Name des Laufwerks, Gesamtspeicherplatz, freier Speicher) zurück.

[C++]
HRESULT __stdcall GetVolumeInformation(
  /*[in]*/ BSTR bstrPathName,
  /*[out]*/ LPDTVOLUMEINFORMATION pVolumeInformation
);
[C#]
public void GetVolumeInformation(
  string bstrPathName,
  ref DTVOLUMEINFORMATION pVolumeInformation
);
[Visual Basic .NET]
public Sub GetVolumeInformation( _
  ByVal bstrPathName As String, _
  ByRef pVolumeInformation As DTVOLUMEINFORMATION _
)
[Delphi]
function GetVolumeInformation(
  const bstrPathName: WideString;
  out pVolumeInformation: DTVOLUMEINFORMATION
): HResult; stdcall;

Parameter

bstrPathName
[in] Ordner, für den die Laufwerksinformationen ermittelt werden sollen.
pVolumeInformation
[out] Gibt die Laufwerksinformationen in einer DTVOLUMEINFORMATION-Struktur zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Laufwerksinformationen wurden erfolgreich zurückgegeben.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


Guid (IDTFileSystemSite)

Guid (IDTFileSystemSite)

Gibt die GUID für das AddIn-Dateisystemobjekt zurück. Die GUID wird von SpeedCommander u.a. bei der Speicherung der Spaltenlayouts benutzt.

[C++]
HRESULT __stdcall get_Guid(
  /*[out, retval]*/ BSTR* pbstrGuid
);
[C++]
public string Guid {get;}
[Visual Basic .NET]
Public ReadOnly Property Guid() As String
[Delphi]
function Get_Guid(
  out pbstrGuid: WideString
): HResult; stdcall;

Parameter

pbstrGuid
[out] Gibt die GUID für das Dateisystemobjekt zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_OUTOFMEMORY sowie:

S_OK
Die GUID wurde erfolgreich zurückgegeben.

IDTFileSystemSite


HostName (IDTFileSystemSite)

HostName (IDTFileSystemSite)

Gibt den Namen für das AddIn-Dateisystemobjekt zurück. Die Navigation in SpeedCommander innerhalb der AddIn-Dateisysteme erfolgt durch eine URL in der Form AddIn://HostName/Ordner1/Datei. Der Name für das Dateisystemobjekt sollte daher gut gewählt und recht eindeutig sein.

[C++]
HRESULT __stdcall get_HostName(
  /*[out, retval]*/ BSTR* pbstrHostName
);
[C#]
public string HostName {get;}
[Visual Basic .NET]
Public ReadOnly Property HostName() As String
[Delphi]
function Get_HostName(
  out pbstrHostName: WideString
): HResult; stdcall;

Parameter

pbstrHostName
[out] Gibt den Namen für das Dateisystemobjekt zurück.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_OUTOFMEMORY sowie:

S_OK
Der Name wurde erfolgreich zurückgegeben.

IDTFileSystemSite


Image (IDTFileSystemSite)

Image (IDTFileSystemSite)

Gibt das Symbol an, welches SpeedCommander für das Dateisystem-Objekt anzeigen soll. Das AddIn kann über die Funktion IApplication::AddImage eigene Symbole definieren. Das Dateisystemobjekt sollte -1 zurückgeben, wenn es kein eigenes Symbol verwendet. In diesem Fall zeigt SpeedCommander ein Standardsymbol an.

[C++]
HRESULT __stdcall get_Image(
  /*[out, retval]*/ long* pImage
);
[C#]
public int Image {get;}
[Visual Basic .NET]
Public ReadOnly Property Image() As Integer
[Delphi]
function Get_Image(
  out pImage: Integer
): HResult; stdcall;

Parameter

pImage
[out] Gibt den Index für das anzuzeigende Symbol zurück oder -1, wenn das AddIn kein eigenes Symbol verwendet.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL sowie:

S_OK
Das Symbol wurde erfolgreich zurückgegeben.

IDTFileSystemSite


MoveFile (IDTFileSystemSite)

MoveFile (IDTFileSystemSite)

Verschiebt eine Datei oder einen Ordner bzw. benennt eine Datei oder einen Ordner um.

[C++]
HRESULT __stdcall MoveFile(
  /*[in]*/ BSTR bstrExistingFileName,
  /*[in]*/ BSTR bstrNewFileName
);
[C#]
public void MoveFile(
  string bstrExistingFileName,
  string bstrNewFileName
);
[Visual Basic .NET]
public Sub MoveFile( _
  ByVal bstrExistingFileName As String, _
  ByVal bstrNewFileName As String _
)
[Delphi]
function MoveFile(
  const bstrExistingFileName: WideString;
  const bstrNewFileName: WideString
): HResult; stdcall;

Parameter

bstrExistingFileName
[in] Datei oder Ordner, die/der verschoben oder umbenannt werden soll.
bstrNewFileName
[in] Neuer Name für die Datei oder den Ordner.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Datei oder der Ordner wurde erfolgreich umbenannt bzw. verschoben.

IDTFileSystemSite


RemoveDirectory (IDTFileSystemSite)

RemoveDirectory (IDTFileSystemSite)

Löscht einen Ordner.

[C++]
HRESULT __stdcall RemoveDirectory(
  /*[in]*/ BSTR bstrFolder
);
[C#]
public void RemoveDirectory(
  string bstrFolder
);
[Visual Basic .NET]
public Sub RemoveDirectory( _
  ByVal bstrFolder As String _
)
[Delphi]
function RemoveDirectory(
  const bstrFolder: WideString
): HResult: stdcall;

Parameter

bstrFolder
[in] Ordner, der gelöscht werden soll.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der Ordner wurde erfolgreich gelöscht.

IDTFileSystemSite


SetCurrentDirectory (IDTFileSystemSite)

SetCurrentDirectory (IDTFileSystemSite)

Setzt den aktuellen Ordner im AddIn-Dateisystem.

[C++]
HRESULT __stdcall SetCurrentDirectory(
  /*[in]*/ BSTR bstrFolder
);
[C#]
public void SetCurrentDirectory(
  string bstrFolder
);
[Visual Basic .NET]
public Sub SetCurrentDirectory( _
  ByVal bstrFolder As String _
)
[Delphi]
function SetCurrentDirectory(
  const bstrFolder: WideString
): HResult; stdcall;

Parameter

bstrFolder
[in] Ordner, der gesetzt werden soll.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Der aktuelle Ordner wurde erfolgreich gesetzt.
STG_E_PATHNOTFOUND
Der Ordner ist ungültig und kann nicht gesetzt werden.

IDTFileSystemSite


SetFileAttributes (IDTFileSystemSite)

SetFileAttributes (IDTFileSystemSite)

Setzt die Attribute für eine Datei oder einen Ordner.

[C++]
HRESULT __stdcall SetFileAttributes(
  /*[in]*/ BSTR bstrPathName,
  /*[in]*/ DWORD dwFileAttributes
);
[C#]
public void SetFileAttributes(
  string bstrPathName,
  uint dwFileAttributes
);
[Visual Basic .NET]
public Sub SetFileAttributes( _
  ByVal bstrPathName As String, _
  ByVal dwFileAttributes As System.UInt32 _
)
[Delphi]
function SetFileAttributes(
  const bstrPathName: WideString;
  dwFileAttributes: LongWord
): HResult; stdcall;

Parameter

bstrPathName
[in] Datei oder Ordner, für die/den die Attribute geändert werden sollen.
dwFileAttributes
[in] Attribute des Dateisystemeintrages. Der Wert ist eine Kombination von:
Attribut | Wert | Bedeutung
FILE_ATTRIBUTE_READONLY | 1 | Der Dateisystemeintrag ist schreibgeschützt.
FILE_ATTRIBUTE_HIDDEN | 2 | Der Dateisystemeintrag ist versteckt.
FILE_ATTRIBUTE_SYSTEM | 4 | Der Dateisystemeintrag ist Teil des Betriebssystems.
FILE_ATTRIBUTE_ARCHIVE | 32 | Der Dateisystemeintrag muss gesichert werden.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Dateiattribute wurden erfolgreich gesetzt.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


SetFileTime (IDTFileSystemSite)

SetFileTime (IDTFileSystemSite)

Setzt die Erstellungszeit, die Zeit des letzten Zugriffs sowie die Zeit der letzten Änderung für eine Datei oder einen Ordner. Wenn für eine Zeit der Wert 0 übergeben wird, dann wird diese Zeit nicht geändert.

[C++]
HRESULT __stdcall SetFileTime(
  /*[in]*/ BSTR bstrPathName,
  /*[in]*/ DATE dateCreated,
  /*[in]*/ DATE dateLastAccessed,
  /*[in]*/ DATE dateLastModified
);
[C#]
public void SetFileTime(
  string bstrPathName,
  DateTime dateCreated,
  DateTime dateLastAccessed,
  DateTime dateLastModified
);
[Visual Basic .NET]
public Sub SetFileTime( _
  ByVal bstrPathName As String, _
  ByVal dateCreated As Date, _
  ByVal dateLastAccessed As Date, _
  ByVal dateLastModified As Date _
)
[Delphi]
function SetFileTime(
  const bstrPathName: WideString;
  dateCreated: TDateTime;
  dateLastAccessed: TDateTime;
  dateLastModified: TDateTime
): HResult; stdcall;

Parameter

bstrPathName
[in] Datei oder Ordner, für die/den die Zeit geändert werden soll.
dateCreated
[in] Erstellungszeit.
dateLastAccessed
[in] Zeit des letzten Zugriffs.
dateLastModified
[in] Zeit der letzten Änderung.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Zeit wurde erfolgreich gesetzt.
E_NOTIMPL
Die Methode ist nicht implementiert.

IDTFileSystemSite


SHCOLUMNID (IDTFileSystemSite)

SHCOLUMNID (IDTFileSystemSite)

Legt die eindeutige Spaltenkennzeichnung in der Form FMTID/PID fest. SpeedCommander verwendet diese Informationen, um die verschiedenen Spalten eindeutig unterscheiden zu können.

In der Regel verwenden AddIns als FMTID immer die GUID des AddIns. Die PID kann frei gewählt werden, normalerweise erhält die erste Spalte 1, die zweite Spalte 2 usw.

[C++]
typedef struct tagSHCOLUMNID {
  GUID fmtid;
  DWORD pid;
} SHCOLUMNID, *LPSHCOLUMNID;
[Delphi]
SHCOLUMNID = packed record
  fmtid: TGUID;
  pid: LongWord;
end;
fmtid
Legt die GUID für die Spalte fest.
pid
Legt die Spaltenbezeichnung fest.

IDTFileSystemSite


UploadFile (IDTFileSystemSite)

UploadFile (IDTFileSystemSite)

Kopiert eine Datei von einem lokalen Ordner oder einem UNC-Pfad in das AddIn-Dateisystem.

[C++]
HRESULT __stdcall UploadFile(
  /*[in]*/ BSTR bstrLocalFileName,
  /*[in]*/ BSTR bstrRemoteFileName,
  /*[in]*/ DWORD dwFlags,
  /*[in]*/ IFileOpProgress* pFileOpProgress
);
[C#]
public void UploadFile(
  string bstrLocalFileName,
  string bstrRemoteFileName,
  uint dwFlags,
  IFileOpProgress pFileOpProgress
);
[Visual Basic .NET]
public Sub UploadFile( _
  ByVal bstrLocalFileName As String, _
  ByVal bstrRemoteFileName As String, _
  ByVal dwFlags As System.UInt32, _
  ByVal pFileOpProgress As IFileOpProgress _
)
[Delphi]
function UploadFile(
  const bstrLocalFileName: WideString;
  const bstrRemoteFileName: WideString;
  dwFlags: LongWord;
  const pFileOpProgress: IFileOpProgress
): HResult; stdcall;

Parameter

bstrLocalFileName
[in] Quelldateiname für die zu kopierende Datei.
bstrRemoteFileName
[in] Zieldateiname für die zu kopierende Datei.
dwFlags
[in] Momentan nicht benutzt.
pFileOpProgress
[in] Schnittstelle zu IFileOpProgress zum Setzen des Fortschritts.

Rückgabewert

Gültige Rückgabewerte sind E_FAIL, E_INVALIDARG, E_OUTOFMEMORY sowie:

S_OK
Die Datei wurde erfolgreich kopiert.
STG_E_FILENOTFOUND
Die Quelldatei wurde nicht gefunden.
STG_E_READFAULT
Fehler beim Lesen.
STG_E_WRITEFAULT
Fehler beim Schreiben.
STG_E_ACCESSDENIED
Zugriff verweigert.
E_ABORT
Die Aktion wurde abgebrochen.

IDTFileSystemSite


Application (AddIn-Objekt)

Application (AddIn-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddIn-Objekt, Application-Objekt


Parent (AddIn-Objekt)

Parent (AddIn-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das AddIns-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IAddIns** ppAddIns
);
[C#]
AddIns Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As AddIns
[Delphi]
property Parent: IAddIns read Get_Parent;

AddIn-Objekt, AddIns-Objekt


Application (AddInCommand-Objekt)

Application (AddInCommand-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddInCommand-Objekt, Application-Objekt


Parent (AddInCommand-Objekt)

Parent (AddInCommand-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das AddInCommands-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IAddCommands** ppAddInCommands
);
[C#]
AddInCommands Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As AddInCommands
[Delphi]
property Parent: IAddInCommands read Get_Parent;

AddInCommand-Objekt, AddInCommands-Objekt


Application (AddInCommands-Objekt)

Application (AddInCommands-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddInCommands-Objekt, Application-Objekt


Parent (AddInCommands-Objekt)

Parent (AddInCommands-Objekt)

Gibt das Elternobjekt zurück, in diesem Falle das AddIns-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IAddIns** ppAddIns
);
[C#]
AddIns Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As AddIns
[Delphi]
property Parent: IAddIns read Get_Parent;

AddInCommands-Objekt, AddIns-Objekt


Application (AddIns-Objekt)

Application (AddIns-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddIns-Objekt, Application-Objekt


Parent (AddIns-Objekt)

Parent (AddIns-Objekt)

Gibt das Elternobjekt zurück, in diesem Falle das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: Application read Get_Parent;

AddIns-Objekt, Application-Objekt


Update (AddIns-Objekt)

Update (AddIns-Objekt)

Aktualisiert die AddIn-Liste.

[C++]
HRESULT __stdcall Update();
[C#]
public void Update();
[Visual Basic .NET]
Public Sub Update()
[Delphi]
procedure Update; safecall;

Parameter

Diese Funktion benötigt keine Parameter.

Rückgabewert

Diese Funktion besitzt keinen Rückgabewert.

AddIns-Objekt


Application (AddInSettings-Objekt)

Application (AddInSettings-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AddInSettings-Objekt, Application-Objekt


Parent (AddInSettings-Objekt)

Parent (AddInSettings-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das AddIns-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IAddIns** ppAddIns
);
[C#]
AddIns Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As AddIns
[Delphi]
property Parent: IAddIns read Get_Parent;

AddInSettings-Objekt, AddIns-Objekt


Application (MainWindow-Objekt)

Application (MainWindow-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

MainWindow-Objekt, Application-Objekt


Parent (MainWindow-Objekt)

Parent (MainWindow-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

MainWindow-Objekt, Application-Objekt


Application (CommandBar-Objekt)

Application (CommandBar-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

CommandBar-Objekt, Application-Objekt


Parent (CommandBar-Objekt)

Parent (CommandBar-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das CommandBars-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ICommandBars** ppCommandBars
);
[C#]
CommandBars Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As CommandBars
[Delphi]
property Parent: ICommandBars read Get_Parent;

CommandBar-Objekt, CommandBars-Objekt


Application (CommandBarControl-Objekt)

Application (CommandBarControl-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

CommandBarControl-Objekt, Application-Objekt


Parent (CommandBarControl-Objekt)

Parent (CommandBarControl-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das CommandBar-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
CommandBar Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As CommandBar
[Delphi]
property Parent: ICommandBar read Get_Parent;

CommandBarControl-Objekt, CommandBar-Objekt


Application (CommandBarControls-Objekt)

Application (CommandBarControls-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

CommandBarControls-Objekt, Application-Objekt


Parent (CommandBarControls-Objekt)

Parent (CommandBarControls-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das CommandBar-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ICommandBar** ppCommandBar
);
[C#]
CommandBar Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As CommandBar
[Delphi]
property Parent: ICommandBar read Get_Parent;

CommandBarControls-Objekt, CommandBar-Objekt


Application (CommandBars-Objekt)

Application (CommandBars-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

CommandBars-Objekt, Application-Objekt


Parent (CommandBars-Objekt)

Parent (CommandBars-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

CommandBars-Objekt, Application-Objekt


CommandEvents-Objekt

CommandEvents-Objekt

Das CommandEvents-Objekt stellt Befehlsereignisse für Automatisierungsclients bereit.

Ereignisse

AfterExecute | Tritt nach der Ausführung eines Befehls ein.
BeforeExecute | Tritt vor der Ausführung eines Befehls ein.

Application-Objekt


FileContainerEvents-Objekt

FileContainerEvents-Objekt

Das FileContainerEvents-Objekt stellt Ereignisse für Änderungen an Dateiablagen bereit.

Ereignisse

WindowActivated | Tritt ein, wenn eine Dateiablage den Fokus erhält.
WindowClosing | Tritt unmittelbar vor dem Schließen einer Dateiablage ein.
WindowCreated | Tritt beim Erstellen einer neuen Dateiablage ein.

Application-Objekt


FolderWindowEvents-Objekt

FolderWindowEvents-Objekt

Das FolderWindowEvents-Objekt stellt Ereignisse für Änderungen an Ordnerfenstern bereit.

Ereignisse

WindowActivated | Tritt ein, wenn ein Ordnerfenster den Fokus erhält.
WindowClosing | Tritt unmittelbar vor dem Schließen eines Ordnerfensters ein.
WindowCreated | Tritt beim Erstellen eines neuen Ordnerfensters ein.

Application-Objekt


TabWindowEvents-Objekt

TabWindowEvents-Objekt

Das TabWindowEvents-Objekt stellt Ereignisse für Änderungen an der Zweifenster-Ansicht bereit.

Ereignisse

WindowActivated Tritt ein, wenn ein Fenster den Fokus erhält.

Application-Objekt


Application (FileContainer-Objekt)

Application (FileContainer-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FileContainer-Objekt, Application-Objekt


Parent (FileContainer-Objekt)

Parent (FileContainer-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das FileContainers-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IFileContainers** ppFileContainers
);
[C#]
FileContainers Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As FileContainers
[Delphi]
property Parent: IFileContainers read Get_Parent;

FileContainer-Objekt, FileContainers-Objekt


Application (FileContainers-Objekt)

Application (FileContainers-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FileContainers-Objekt, Application-Objekt


Parent (FileContainers-Objekt)

Parent (FileContainers-Objekt)

Gibt das Elternobjekt zurück, in diesem Falle das TabWindow-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As TabWindow
[Delphi]
property Parent: ITabWindow read Get_Parent;

FileContainers-Objekt, TabWindow-Objekt


Application (FolderFavorite-Objekt)

Application (FolderFavorite-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FolderFavorite-Objekt, Application-Objekt


Parent (FolderFavorite-Objekt)

Parent (FolderFavorite-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das FolderFavorites-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IFolderFavorites** ppFolderFavorites
);
[C#]
FolderFavorites Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As FolderFavorites
[Delphi]
property Parent: IFolderFavorites read Get_Parent;

FolderFavorite-Objekt, FolderFavorites-Objekt


Application (FolderFavorites-Objekt)

Application (FolderFavorites-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FolderFavorites-Objekt, Application-Objekt


Parent (FolderFavorites-Objekt)

Parent (FolderFavorites-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

FolderFavorites-Objekt, Application-Objekt


Application (AppFolder-Objekt)

Application (AppFolder-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

AppFolder-Objekt, Application-Objekt


Parent (AppFolder-Objekt)

Parent (AppFolder-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das FolderWindow-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IFolderWindow** ppFolderWindow
);
[C#]
FolderWindow Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As FolderWindow
[Delphi]
property Parent: IFolderWindow read Get_Parent;

AppFolder-Objekt, FolderWindow-Objekt


Application (FolderWindow-Objekt)

Application (FolderWindow-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FolderWindow-Objekt, Application-Objekt


Parent (FolderWindow-Objekt)

Parent (FolderWindow-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das FolderWindows-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IFolderWindows** ppFolderWindows
);
[C#]
FolderWindows Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As FolderWindows
[Delphi]
property Parent: IFolderWindows read Get_Parent;

FolderWindow-Objekt, FolderWindows-Objekt


Application (FolderWindows-Objekt)

Application (FolderWindows-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

FolderWindows-Objekt, Application-Objekt


Parent (FolderWindows-Objekt)

Parent (FolderWindows-Objekt)

Gibt das Elternobjekt zurück, in diesem Falle das TabWindow-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ ITabWindow** ppTabWindow
);
[C#]
TabWindow Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As TabWindow
[Delphi]
property Parent: ITabWindow read Get_Parent;

FolderWindows-Objekt, TabWindow-Objekt


Application (ListItem-Objekt)

Application (ListItem-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

ListItem-Objekt, Application-Objekt


Parent (ListItem-Objekt)

Parent (ListItem-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das ListItems-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IListItems** ppListItems
);
[C#]
ListItems Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As ListItems
[Delphi]
property Parent: IListItems read Get_Parent;

ListItem-Objekt, ListItems-Objekt


Application (ListItems-Objekt)

Application (ListItems-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

ListItems-Objekt, Application-Objekt


Parent (ListItems-Objekt)

Parent (ListItems-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IUnknown** ppParent
);
[C#]
object Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Object
[Delphi]
property Parent: IUnknown read Get_Parent;

ListItems-Objekt


Application (ListSelection-Objekt)

Application (ListSelection-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

ListSelection-Objekt, Application-Objekt


Parent (ListSelection-Objekt)

Parent (ListSelection-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IUnknown** ppParent
);
[C#]
object Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Object
[Delphi]
property Parent: IUnknown read Get_Parent;

ListSelection-Objekt


Application (MultiRename-Objekt)

Application (MultiRename-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

MultiRename-Objekt, Application-Objekt


Parent (MultiRename-Objekt)

Parent (MultiRename-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

MultiRename-Objekt, Application-Objekt


Application (TabWindow-Objekt)

Application (TabWindow-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

TabWindow-Objekt, Application-Objekt


Parent (TabWindow-Objekt)

Parent (TabWindow-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Window-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IWindow** ppWindow
);
[C#]
Window Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Window
[Delphi]
property Parent: IWindow read Get_Parent;

TabWindow-Objekt, Window-Objekt


Application (UserTool-Objekt)

Application (UserTool-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

UserTool-Objekt, Application-Objekt


Parent (UserTool-Objekt)

Parent (UserTool-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das UserTools-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IUserTools** ppUserTools
);
[C#]
UserTools Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As UserTools
[Delphi]
property Parent: IUserTools read Get_Parent;

UserTool-Objekt, UserTools-Objekt


Application (UserTools-Objekt)

Application (UserTools-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

UserTools-Objekt, Application-Objekt


Parent (UserTools-Objekt)

Parent (UserTools-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

UserTools-Objekt, Application-Objekt


Application (Workspace-Objekt)

Application (Workspace-Objekt)

Gibt einen Verweis auf das Anwendungsobjekt zurück.

[C++]
HRESULT get_Application(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Application {get;}
[Visual Basic .NET]
Public ReadOnly Property Application() As Application
[Delphi]
property Application: IApplication read Get_Application;

Workspace-Objekt, Application-Objekt


Parent (Workspace-Objekt)

Parent (Workspace-Objekt)

Gibt einen Verweis auf das Elternobjekt zurück, in diesem Fall das Application-Objekt.

[C++]
HRESULT get_Parent(
  /*[out, retval]*/ IApplication** ppApplication
);
[C#]
Application Parent {get;}
[Visual Basic .NET]
Public ReadOnly Property Parent() As Application
[Delphi]
property Parent: IApplication read Get_Parent;

Workspace-Objekt, Application-Objekt


Brennprojekte

SpeedCommander: Konfiguration
Brennprojekte

Im Dialogfeld Brennprojekte legen Sie das Standardgerät zum Brennen von CDs, DVDs und Blu-Rays sowie die Voreinstellungen für neue Brennprojekte fest.

Allgemein

Mit dem Kombinationsfeld Standardgerät wird das Gerät festgelegt, mit dem CDs, DVDs und Blu-Rays hauptsächlich gebrannt werden sollen. Sind mehrere Brenngeräte verfügbar, dann können Sie im jeweiligen Brenndialog direkt vor dem Brennvorgang auch ein anderes Gerät wählen.

Brenneinstellungen

Hier können Sie die Standardvorgaben für die Einstellungen in den Brenndialogen festlegen. Aktivieren Sie das Kontrollkästchen Puffer-Schutz aktivieren, wenn die Buffer-Underrun-Protection des Brenners verwendet werden soll. Mit der Einstellung Brennvorgang simulieren lässt sich vor dem Brennvorgang testen, ob sich die Daten oder das Abbild fehlerfrei brennen lassen. Die Einstellung Optimum Power Calibration (OPC) ermöglicht eine automatische Anpassung der Laserstärke an die speziellen Eigenschaften des aktuellen Rohlings.

Das Kontrollkästchen Medium abschließen legt fest, ob das Medium nach dem Schreiben finalisiert werden soll. Ein weiteres Beschreiben des Mediums ist anschließend nicht mehr möglich. Mit der Einstellung Daten nach dem Brennen überprüfen wird festgelegt, ob die geschriebenen Daten nach dem Brennvorgang noch einmal mit den zu schreibenden Daten verglichen werden sollen. Die Einstellung Medium nach dem Brennen auswerfen legt fest, ob der Brenner das aktuelle Medium nach Abschluss des Brennvorgangs selbstständig auswirft.