RegCool Übersicht

RegCool

Erweiterter Registry-Editor: RegCool ist ein äußerst flexibler Editor für die Windows-Registrierungsdatenbank. Das Programm bietet ein attraktives Interface, komfortable Kontextmenüs und eine praktische Tool-Leiste, mit der umfangreiche Editierfunktionen griffbereit zur Verfügung stehen. RegCool liefert die komplette Funktionalität des Windows-eigenen Regedit, fügt aber etliche Ergänzungen hinzu. Ein Bookmark-Editor hebt Schlüssel hervor und ermöglicht es, diese mit kurzen Notizen zu versehen - so ist es ein leichtes, zu schwer erreichbaren Schlüsseln zurückzukehren. Suchen und Ersetzen, Remote-Bearbeitung, Schlüssel-Import und-Export, Vergleich von Registrierungssschlüsseln, RegShot-Funktion, Sicherung und Wiederherstellung sowie eine mehrstufige Undo-Funktion gehören zu den zahlreichen Ergänzungen, die RegCool bereithält.

  • Undofunktion - Mehrfaches Rückgängig und Wiederherstellen der letzen Aktion. Undo-History wird auf der Festplatte gespeichert.

  • Suchen & ersetzen - Suchen und ersetzen von Registrierungsschlüsseln, Werte und Daten mit einem sehr schnellen Suchalgorithmus.

  • Vergleichen - Sehr schneller Vergleich von Registrierungsschlüsseln verschiedener Computer.
  • RegShot-Funktion- Vergleich zweier Schnappschüsse von Registrierungen.

  • Cut, Copy & Paste - Ausschneiden, kopieren und einfügen von Registrierungsschlüsseln und Werten.

  • Drag und Drop - Mit der Drag und Drop Funktion verschieben kopieren Sie besonders schnell Registrierungsschlüssel und Werte.
  • Backup & Restore - Komplettsicherung und Wiederherstellen der Registrierung.

  • Defragmentierung - Repariert strukturelle Defekte, gibt ungenutzten Speicher wieder frei und steigert die Systemleistung.

  • Favoritenverwaltung - Einfaches und effektive Verwaltung der Favoriten.
  • Mehrmaliges Öffnen- Mehrmaliges Öffnen lokaler Registrierungen.

  • Versteckte Schlüssel - Öffnen von versteckten Schlüsseln.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierung Einführung

Registrierung

Die Registrierung ist eine Datenbank, die Informationen zur Systemkonfiguration für das Betriebssystem enthält und besteht aus zwei Teilen: Der erste Teil umfasst Konfigurationsdaten für die gesamte Windows-Installation, der zweite Teil beinhaltet alle benutzerspezifischen Informationen und Einstellungen.. Registrierungs-Einträge werden in einer Baumstruktur in Schlüsseln angelegt, die alle von einigen Hauptschlüsseln abstammen.

Die Registrierung ist in fünf logische Abschnitte gegliedert, die weiter in Unterabschnitte und Schlüssel unterteilt sind. Abschnitte der Registrierung: HKEY_CLASSES_ROOT, HKEY_LOCAL_MACHINE, HKEY_CURRENT_USER, HKEY_USERS und HKEY_CURRENT_CONFIG.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Hive-Dateien

Übersicht der Schlüssel

Schlüsselname | Abkürzung | Berechtigungen | Beschreibung
HKEY_CLASSES_ROOT | HKCR |  | Informationen über die verschiedenen Com-Objekte sowie Dateitypen. Darunter fallen die Beschreibung, das Symbol und die verknüpfte Anwendung. Zusammenführung von Unterschlüsseln in HKEY_LOCAL_MACHINE\Software\Classes und HKEY_CURRENT_USER\Software\Classes
HKEY_CURRENT_USER | HKCU | Admins: Vollzugriff, User: Vollzugriff (auf eigenen) | Benutzerprofil des aktuell angemeldeten Benutzers, Verknüpfung mit Unterschlüssel von HKEY_USERS
HKEY_LOCAL_MACHINE | HKLM | Admins: Vollzugriff, User: nur Lesen | Hier werden von allen Benutzern geteilte Einstellungen und Informationen gespeichert.
HKEY_USERS | HKU | Admins: Vollzugriff, User: Zugriff nur auf eigenes | Enthält den Stamm aller Benutzerprofile auf dem Computer. Hier werden Einstellungen und Informationen gespeichert, die nur für den jeweiligen Windows-Benutzer gelten.
HKEY_CURRENT_CONFIG | HKCC | Admins: Vollzugriff, User: Keiner | aktuell verwendetes Hardwareprofil, Verknüpfung mit Unterschlüssel von HKEY_LOCAL_MACHINE.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierungsdatentypen

REG_BINARY

Unformatierte Binärdaten. Die meisten Informationen zu Hardwarekomponenten werden als binäre Daten gespeichert und im Registrierungs-Editor im Hexadezimalformat angezeigt.

REG_DWORD

Daten, die durch eine Zahl dargestellt werden.

REG_EXPAND_SZ

Erweiterbare Zeichenfolge.

REG_MULTI_SZ

Mehrteilige Zeichenfolge. Werte, die Listen enthalten oder mehrere Werte in normal lesbarem Text sind in der Regel von diesem Typ.

REG_SZ

Dies ist eine Folge von Zeichen, die normal lesbaren Text darstellen.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierungsschlüssel hinzufügen

So fügen Sie einen Registrierungsschlüssel hinzu

  1. Klicken Sie auf dem Registrierungsbaum (links) auf den Registrierungsschlüssel, unter dem Sie einen neuen Schlüssel hinzufügen möchten..

  2. Zeigen Sie im Menü Bearbeiten auf Neuer Schlüssel

  3. Geben Sie einen Namen für den neuen Schlüssel ein, und drücken Sie die EINGABETASTE.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Wert hinzufügen

So fügen Sie einem Registrierungsschlüsseleintrag einen Wert hinzu

  1. Klicken Sie auf den Schlüssel oder Eintrag, dem der neue Wert hinzugefügt werden soll.

  2. Zeigen Sie im Menü Bearbeiten auf Neuer Wert, und klicken Sie dann auf den Werttyp, den Sie hinzufügen möchten: Zeichenfolge, Binärwert, DWORD-Wert, Wert der mehrteiligen Zeichenfolge oder Wert der erweiterbaren Zeichenfolge.

  3. Geben Sie einen Namen für den neuen Wert ein, und drücken Sie die EINGABETASTE.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierungsschlüssel oder -wert umbennen

So benennen Sie einen Registrierungsschlüssel oder -wert um

  1. Klicken Sie auf den Schlüssel oder Eintrag, den Sie umbenennen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Umbenennen

  3. .Geben Sie den neuen Namen ein, und drücken Sie die EINGABETASTE.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierungsschlüssel löschen

So löschen Sie einen Registrierungsschlüssel oder -wert

  1. Klicken Sie auf den Schlüssel oder Eintrag, den Sie löschen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Löschen.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Wert ändern

So ändern Sie einen Wert

  1. Wählen Sie den Eintrag aus, den Sie ändern möchten..

  2. Klicken Sie im Menü Bearbeiten auf Ändern.

  3. Geben Sie im Feld Wert die neuen Daten für den Wert ein, und klicken Sie auf OK

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Favoriten

So fügen Sie einen Registrierungsschlüssel zu den Favoriten hinzu

  1. Bestimmen Sie den Registrierungsschlüssel, den Sie zu den Favoriten hinzufügen möchten.

  2. Klicken Sie im Menü Favoriten auf Zu Favoriten hinzufügen.

  3. Der Registrierungsschlüssel wird der Liste Favoriten hinzugefügt.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierungsschlüsselnamen kopieren

So kopieren Sie einen Registrierungsschlüsselnamen

  1. Öffnen Sie den Registrierungs-Editor.

  2. Klicken Sie in der Registrierungsstruktur (links) auf einen Registrierungsschlüssel.

  3. Klicken Sie im Menü Bearbeiten auf Schlüsselnamen kopieren.

  4. Fügen Sie den Namen des Registrierungsschlüssels in ein anderes Programm oder Dokument ein.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierung durchsuchen

Suchen nach Daten in der Registrierung

  1. Klicken Sie im Menü Bearbeiten auf Suchen.

  2. Geben Sie im Feld Suchen nach die Zeichenfolge, den Wert oder den Schlüssel ein, die bzw. der gesucht werden soll.

  3. Aktivieren Sie die für die Suche gewünschten Kontrollkästchen, wie Schlüssel, Werte, Daten und Ganze Zeichenfolge vergleichen, und klicken Sie dann auf Suchen.

  4. Nach Abschuß des Suchvorgangs werden alle Ergebnisse in einer Liste aufgelistet, die Sie nach Belieben nach Name, Schlüssel oder Typ sortieren können.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierung verbinden

So stellen Sie über das Netzwerk eine Verbindung mit einer Registrierung her

  1. Klicken Sie im Menü Datei auf Mit Netzwerkregistrierung verbinden.

  2. Geben Sie im Dialogfeld Computer auswählen den Namen des Computers ein, mit dessen Registrierung eine Verbindung hergestellt werden soll.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Netzwerkregistrierung trennen

So trennen Sie die Verbindung zu einer Netzwerkregistrierung

  1. Schließen Sie das zugehörige Fenster.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Schlüssel vergleichen

So vergleichen Sie die Inhalte zweier Schlüssel

  1. Bestimmen Sie die geöffnete Registrierung des ersten Schlüssels.

  2. Bestimmen Sie den ersten zu vergleichenden Schlüssel.

  3. Bestimmen Sie die geöffnete Registrierung des zweiten Schlüssels.

  4. Bestimmen Sie den zweiten zu vergleichenden Schlüssel.

  5. Klicken Sie auf Registrierungen vergleichen.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Schnappschuss der Registrierung

So erstellen Sie einen Schnappschuss der Registrierung

  1. Bestimmen Sie die geöffnete Registrierung.

  2. Legen Sie fest, ob die gesamte Registrierung oder nur ein Teilzweig berücksicht werden soll.

  3. Klicken Sie auf Shot 1 erstellen.

  4. Nach Änderungen in der Registrierung (z.b. Installation) klicken Sie auf Shot 2 erstellen.

  5. Klicken Sie Registrierungen vergleichen.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Sicherung der Registrierung

So erstellen Sie eine Sicherung der Registrierung

  1. Klicken Sie im Menü Tools auf Sichern & Wiederherstellen der lokalen Registrierung.

  2. Klicken Sie auf Sicherung anlegen.

  3. Bestimmen Sie die zu sichernden Hives und klicken Sie auf OK.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.


Registrierung wiederherstellen

So stellen Sie die Registrierung wieder her

  1. Klicken Sie im Menü Tools auf Sichern & Wiederherstellen der lokalen Registrierung.

  2. Markieren Sie die zuvor angelegte Sicherung.

  3. Klicken Sie auf Wiederherstellen und folgen Sie den Anweisungen.

Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung können ernsthafte Computerschäden verursacht werden. Erstellen Sie vor Änderungen in der Registrierung eine Sicherungskopie aller wichtigen Computerdaten.