Overview

 Top Next

Easy ScreencastRecorder

v1.17.01 - May 30, 2017

Easily record simple screencast videos of your desktop.

Features:

· Record audio+video
· Choose your own video format.


Basic Usage

 Top Previous Next


Basic Options

 Top Previous Next


Websites and Downloads

 Top Previous Next

For ASF/WMV recording you may need to install the Windows Media Encoder SDK (if it's not already installed on your pc):

· http://www.microsoft.com/en-us/download/details.aspx?id=17792

For AVI recording, try the free lossless screen capture specialized codec (excellent quality):

· http://www.compression.ru/video/ls-codec/screen_capture_codec_en.html

Or request a non-watermarked version of the iSCC codec:

· http://www.innoheim.com/iscc.php

For WebM recording you need a few things. Following instructions on http://www.webmproject.org/tools/ do:

· Run install_webmdshow.exe from webmdshow-*.zip obtained via: https://code.google.com/p/webm/downloads/list
· Run opencodecs_*.exe obtained via: https://www.xiph.org/dshow/
· Choose "WebM" as recording file type, then Compress on the Fly, then Video Codec Engine="Webm/google" (this may not be important), Audio Compression Engine="Xiph Org Vorbis". You *may* also have to set the custom Multiplexer to "WebM Muxer Filter".


Version History and ToDo List

 Top Previous

Version History

v1.17.01 - May 30, 2017

· [BugFix] Rewrote redbox overlay code to hopefully eliminate spurious displays of red on some recordings.
· [BugFix] Repeated calls to select window to capture might not work if dll hooks are disabled in options.
· [BugFix] Better error reporting.

v1.15.01 - May 27, 2017

· [Improvement] High-DPI Windows (text size > 100%) is now supported well.
· [Improvement] Installer now offers to run app after installation.
· [Improvement] Options now accessible from system tray.
· [BugFix] On windows 10 a remnant red overlay was seen when changing capture modes.
· [BugFix] Another attempt to fix bug where Red region was stuck on screen for some people during recording; new kludge option that should absolutely solve it if you still see it.

v1.13.01 - Sep 6, 2016

· [BugFix] Red region was stuck on screen for some people during recording.

v1.12.01 - April 22, 2015

· [Feature] You can now set whether the main dialog stays on top of other windows or not.
· [MinorFeature] Hotkey configuration box is now larger.

v1.11.01 - Sep 26, 2014

· [BugFix] Trying to capture videos larger than about 2000x1014 could sometimes result in final output being resized to very small dimensions.
· [BugFix] About box was going to wrong homepage.

v1.10.01 - May 19, 2013

· [BugFix] Minor typos.
· [Feature] Added option to check for updates on startup.

v1.09.01 - March 10, 2013

· [BugFix] Recording from a selected window was capturing a region that was too short and narrow by one pixel.

v1.08.01 - November 26, 2012

· [Feature] You can now pass the commandline option -dir "directory path" to open ESR and set its video saving directory for the current run (will default back to previous on ext); useful when driving ESR from another tool like Screenshot Captor.

v1.07.01 - November 12, 2012

· [Improvement] The program now parses a text file (DefaultCodecOverides.dat, customizable from options) that specifies explicit playback codecs; can be used to workaround failures to play certain recorded codecs properly. This is used to workaround a problem playing .webm files. New option on Operations Log tab in options to list all registered playback codecs.
· [Improvement] Errors in playback are now also show in popup error log.
· [Improvement] WebM format now supported well (requires 3rd party codec downloads).
· [Improvement] Better error handling/recovery.
· [BugFix] When no audio device is configured, it was reporting errors even if audio recording was disabled.

v1.06.01 - November 11, 2012

· [Improvement] You can now set an option on Capture tab that will let you move the region window during capture.

v1.05.01 - November 11, 2012

· [Improvement] Will now remember your last chosen audio device+mode, and restore it even if it is plugged in after program starts.
· [Improvement] More tweak options for advanced users.
· [Improvement] You can now save and load settings into named files.

v1.04.01 - November 10, 2012

· [Improvement] Improved help on Compression settings, made recommendation to use ASF and set that as default.
· [Documentation] Added some links to codec downloads in help file.
· [Improvement] Various improvements to user interface and bugfixes.
· [NewFeature] Added support for ".tool" files which are now shown in the "With last recorded video do.."; they provide a more shareable way to configure tools.

v1.03.01 - November 9, 2012

· [BugFix] Compression and non-AVI recording types were not working (was always creating AVI containers despite filename extension).
· [Feature] Popup error/warning log shows common problems with recording settings.
· [Improvement] Improvements to some video options (multiplexer).
· [BugFix] On errors sometimes recording button would not update to stopped state.
· [BugFix] Miscelaneous bug fixes.

v1.01.01 - November 8, 2012

· [Info] First beta release.