DiskSmartView

DiskSmartView v1.02
Copyright (c) 2010 Nir Sofer
Web site: http://www.nirsoft.net

Description

DiskSmartView is a small utility that retrieves the S.M.A.R.T information (S.M.A.R.T = Self-Monitoring, Analysis, and Reporting Technology) from IDE/SATA disks. This information includes the disk model/firmware/serial number, cylinders/heads, power-on hours (POH), internal temperature, disk errors rate, and more. You can use the S.M.A.R.T information retrieved by DiskSmartView to find out whether there is any significant problem in your disk drive.

System Requirements

  • Any version of Windows, starting from Windows 2000, and up to Windows 7.
  • IDE/SATA disk.

Versions History

  • Version 1.02 - Fixed DiskSmartView to work properly with multiple disks.
  • Version 1.01 - Fixed bug: the letters in model, serial number, firmware displayed in the wrong order.
  • Version 1.00 - First release.

Using DiskSmartView

DiskSmartView doesn't require any installation process or additional dll files. In order to start using it, simply run the executable file - DiskSmartView.exe
After running it, DiskSmartView displays all S.M.A.R.T information and attributes retrieved from your IDE disks. You can select one or more lines and then save them to HTML/text/xml/csv file (Ctrl+S) or copy them to the clipboard (Ctrl+C) and paste them to Excel or other spreadsheet.
If you want to learn more about how to analyze the S.M.A.R.T information displayed by DiskSmartView, You can read the S.M.A.R.T page in Wikipedia Web site.

Command-Line Options

/stext <Filename> | Save the S.M.A.R.T information into a regular text file.
/stab <Filename> | Save the S.M.A.R.T information into a tab-delimited text file.
/scomma <Filename> | Save the S.M.A.R.T information into a comma-delimited text file (csv).
/stabular <Filename> | Save the S.M.A.R.T information into a tabular text file.
/shtml <Filename> | Save the S.M.A.R.T information into HTML file (Horizontal).
/sverhtml <Filename> | Save the S.M.A.R.T information into HTML file (Vertical).
/sxml <Filename> | Save the S.M.A.R.T information into XML file.

Translating DiskSmartView to other languages

In order to translate DiskSmartView to other language, follow the instructions below:
  1. Run DiskSmartView with /savelangfile parameter:
    DiskSmartView.exe /savelangfile
    A file named DiskSmartView_lng.ini will be created in the folder of DiskSmartView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run DiskSmartView, and all translated strings will be loaded from the language file.
    If you want to run DiskSmartView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com