Scribble Papers

Scribble Papers ist ein "Zettelkasten", in dem Sie schnell und unkompliziert Daten aller Art ablegen - und vor allen Dingen wiederfinden - können. Dazu brauchen Sie nicht im Dateisystem Ihres Rechners bzw. Netzwerkes umherzuirren. Das Laden und Speichern der Daten wird Ihnen vollständig abgenommen.

Scribble Papers nimmt Daten aller Art entgegen, sowohl eingegebene Texte als auch Grafiken (z.B. Screenshots), ganze Dokumente (z.B. Word- oder Excel-Dokumente), Verknüpfungen und Hyperlinks. Die Daten werden in Ordnern und Seiten organisiert. Für die Textformatierung stehen Ihnen die üblichen Funktionen wie freie Schriftwahl, Schriftfarbe, Textausrichtung und -einrückung, Aufzählungszeichen etc. zur Verfügung.

Scribble Papers ist Freeware, d.h. Sie können es kostenlos benutzen. Die Weitergabe des Programms ist ausdrücklich erwünscht! Dennoch möchte ich Sie im Gegenzug für die Verwendung des Programms um eine Spende für einen guten Zweck bitten. Näheres dazu finden Sie hier .

In den folgenden Abschnitten finden Sie Informationen zu diesen Themen:

Wofür kann ich Scribble Papers verwenden?

Das Hauptfenster

Ordner und Seiten

Editierbereich einer Seite

Inhalt einer Seite

Objekte

Hyperlinks

Einstellungen

Eigenschaften einer Seite

Eigenschaften eines Ordners

Verknüpfungen

Vorlagen

Lesezeichen

Stichwörter

Drucken

Importieren und Exportieren von Dateien

Suchen

Suchergebnisse

Textformate

Absatz

Datensicherung

Tastaturkuerzel

Tipps

Technische / administrative Hinweise

Anmerkungen zur vorliegenden Version:

Scribble Papers wird weiterentwickelt. Wenn Sie über die Verfügbarkeit einer neuen Programmversion informiert werden möchten, können Sie sich in einen Newsletter auf meiner Homepage eintragen. Sobald eine neue Version auf der Homepage bereitsteht, erhalten Sie eine Mail.

Versionshistorie der bisher erschienenen Versionen.

Anregungen und Kritik sind jederzeit willkommen (vorzugsweise per Mail ).

Autor:

Jens Hötger

Försterstr. 11A

31275 Hämelerwald

Mit dem Personal Edition von HelpNDoc erstellt: Gratis PDF-Dokumentationsgenerator

Copyright © by Jens Hötger. All Rights Reserved.


Wofür kann ich Scribble Papers verwenden?

Scribble Papers ››

Verwenden Sie Scribble Papers z.B. folgendermaßen:

• als Wissensdatenbank: ständig stößt man auf Informationen und Daten, die viel zu schade zum Wegwerfen sind. Erfassen Sie mit Scribble Papers alle interessanten oder wieder benötigten Informationen, geordnet nach Themengebieten. Legen Sie für jedes Themengebiet einen Ordner an, in dem Sie die einzelnen Seiten ablegen. Die frei gestaltbare Ordnerstruktur sowie die flexiblen Funktionen zum Suchen , Auflisten von Lesezeichen und Stichwörtern ermöglichen ein schnelles Wiederfinden der in Scribble Papers erfassten Informationen. Über Hyperlinks können Sie mit einem Mausklick zu Dateien, Verzeichnissen, Web-Adressen und auch zu anderen Seiten und Ordnern innerhalb von Scribble Papers springen.
Mit einem einfachen Mausklick auf eine Seite wird Ihnen der Inhalt angezeigt, ohne dass erst zugeordnete Programme wie umfangreiche Textverarbeitungs- oder Tabellenkalkulationsprogramme gestartet werden müssen. Durch die OLE-Unterstützung können Seiten nicht nur Text, sondern auch Objekte anderer Anwendungen enthalten.
Arbeitsgruppen innerhalb eines Netzwerkes können mit Scribble Papers allgemein nützliche Informationen gemeinsam aufbauen und nutzen, z.B. für Lösungsdatenbanken. Hinweise zum Einrichten und Verwalten von Daten, die von mehreren Anwendern genutzt werden, finden Sie hier .
Gleichgültig, welche Themen Ihnen wichtig sind: mit Scribble Papers gelangen Sie schnell an Ihre Informationen.

• für Sammeldokumente: speichern Sie z.B. alles, was Sie für die Erledigung einer bestimmten Aufgabe benötigen, in einer Seite. Das können Notizen, aber auch Verweise auf andere Dateien, ganze Dokumente, Tabellen oder Ausschnitte daraus, Grafiken (Screenshots), Mails und vieles andere sein. Durch die Fähigkeit, Objekte und Hyperlinks in einer Seite zu speichern, können Sie alle Informationen, die Sie für eine Aufgabe benötigen, dicht zusammen halten. Die oft langwierige Suche im Dateisystem nach benötigten Dateien und Dokumenten können Sie sich so ersparen.

• als "Verlängerung" der Zwischenablage: über die Integration der Zwischenablage-Funktionen können Sie auf einfachste Weise den aktuellen Inhalt der Zwischenablage in einer Seite festhalten. Wenn Sie diese Daten nach kurzer Zeit wieder benötigen, können Sie ihn aus der Seite wieder in die Zwischenablage kopieren und verwenden.

• als Schmierzettel für alles mögliche: Daten und Notizen, die Sie nur für kurze Zeit benötigen, aber nicht erst umständlich über ein Textverarbeitungsprogramm inkl. Wahl eines Ordners und Festlegung eines Dateinamens im Dateisystem speichern möchten. In Scribble Papers funktioniert die Ablage beliebiger Daten unkompliziert und schnell, ebenso wie das Löschen nicht mehr benötigter Informationen.

• für die Abwicklung Ihrer Aufgaben und Aktivitäten: Sie können einzelne Seiten dazu mit einem Status wie unerledigt / in Bearbeitung / erledigt / wichtig / unkritisch / kritisch ... versehen. Im Navigationsbaum wird der Status jeder Seite durch ein Symbol optisch dargestellt. Über die Suchfunktion können Sie sich eine Übersicht von Seiten mit gleichem Status zusammenstellen.

• als universellen Zettelkasten, z.B. für

✓ immer wieder verwendete Textbausteine

✓ Informationssammlungen aller Art (Rezepte, Buch- und CD-Tipps u.v.m.)

✓ Passwörter (können innerhalb Scribble Papers geschützt und verschlüsselt werden!)

✓ Ideen, Verbesserungsvorschläge etc.

✓ Programmentwicklung (Sourcecode-Fragmente, Lösungsansätze etc.)

✓ Tagebuch

✓ Logbücher, Chroniken

✓ Gesprächsnotizen

✓ wichtige Dokumente (Anleitungen, Protokolle, Mails etc.)

✓ GTD ("Getting things done", http://www.zeitzuleben.de/artikel/persoenlichkeit/getting-thins-done-david-allen.html )

✓ und vieles mehr...

Experimentieren Sie ruhig ein wenig mit Scribble Papers herum. Sie werden sehen, dass Ihnen damit ein einfach zu handhabendes, aber sehr effizientes Werkzeug für die Arbeit am Computer zur Verfügung steht.

Und: "strapazieren" Sie Scribble Papers ruhig. Auch Tausende von Ordnern und Seiten überfordern das Programm nicht. Eine Seite wird erst dann geladen, wenn Sie benötigt wird und freigegeben (bzw. aus dem Hauptspeicher entfernt), wenn sie nicht mehr benötigt wird. Die Geschwindigkeit Ihres Systems wird also nicht bzw. nur in absolut vernachlässigbarem Ausmaß von der Masse der mit Scribble Papers verwalteten Daten beeinflußt.

Mit dem Personal Edition von HelpNDoc erstellt: Kindle eBooks einfach herstellen


Hauptfenster

Scribble Papers ››

Klicken Sie auf den Bereich, zu dem Sie Informationen haben möchten:

historyoftenusedfunctions

Die Abbildung zeigt eine exemplarische Ordner- und Seitenstruktur. Einzelne Seiten wurden mit bestimmten Status versehen. Im rechten Editorbereich befinden sich Textnotizen, ein eingebettetes Tabellenkalkulationsblatt (siehe Objekte ) und Hyperlinks auf Dateien. Darunter befinden sich Suchergebnisse der letzten Suche bzw. gespeicherte Suchergebnisse .

Mit dem Personal Edition von HelpNDoc erstellt: HTML-Hilfedokumente einfach erstellen


Ordner und Seiten

Scribble Papers ››

Sie können - und sollten - Ihre Daten in Ordnern organisieren. Die Struktur ist dabei ganz Ihren persönlichen Vorstellungen überlassen. Ein Ordner kann Seiten sowie weitere Ordner enthalten.

Ordner und Seiten können in andere Ordner verschoben werden:

• Innerhalb des Navigationsbaums mit der Maus: klicken Sie mit der linken Maustaste auf den Ordner oder die Seite, die verschoben werden soll, halten Sie die Maustaste gedrückt und ziehen Sie den Mauszeiger auf den Ziel-Ordner. Nach dem Loslassen der Maustaste wird der Ordner bzw. die Seite verschoben.

• Das gleiche Verfahren können Sie auch anwenden, um eine Seite über den zugehörigen Reiter nach links in den Navigationsbaum in einen Ordner zu verschieben.

• Oder Sie nutzen die Menübefehle Datei -> Verschieben -> in anderen Ordner bzw. Ordner -> Verschieben -> in anderen Ordner. In dem daraufhin erscheinenden Dialogfenster können Sie den Zielordner auswählen.

Die Funktionalität des Verschiebens in einen anderen Ordner ist abhängig von den Einstellungen , mit denen das Verhalten von Scribble Papers angepaßt werden kann. In der Rubrik Schreibschutz können Sie festlegen, ob und wie schreibgeschützte Seiten verschoben werden können.

Über die Menübefehle Datei -> Kopieren bzw. Ordner -> Kopieren können Sie Seiten bzw. Ordner auch in einen anderen Ordner kopieren. Im Zielordner wählen Sie dann bitte Ordner -> Einfügen. Im Zielordner wird dann eine exakte Kopie der Seite bzw. des Ordners mit allen untergeordneten Elementen erzeugt.

Sie können auch Verknüpfungen zu Seiten erstellen, z.B. um eine Seite auch in einem anderen Ordner zur Verfügung zu haben, in den diese thematisch auch passt. Im Gegensatz zu einer kopierten Seite, die völlig unabhängig von ihrem ursprünglichen Original bearbeitet wird, enthalten eine verknüpfte Seite und ihr Original immer die gleichen Daten und die gleichen Eigenschaften. Änderungen an einer verknüpften Seite wirken sich genauso auf ihr Original aus wie auch Änderungen am Original sich auf ihre verknüpften Seiten auswirken.

Die Funktionen zum Kopieren bzw. Einfügen und zum Erstellen von Verknüpfungen stehen auch im Kontextmenü (rechte Maustaste) des Navigationsbaumes zur Verfügung.

Nutzen Sie die Organisation in Ordnern, um Informationen zu strukturieren und übersichtlicher darzustellen. Eine gut durchdachte Strukturierung verschafft Ihnen einen besseren Überblick über die Daten und Informationen und hilft Ihnen, sowohl Unterschiede als auch Gemeinsamkeiten zu entdecken. Auch der Zugriff bzw. das Wiederfinden benötigter Daten wird dadurch beschleunigt. Die Funktionen zum Verschieben ermöglichen ein schnelles, unkompliziertes und komfortables Verfahren zur (Um)Strukturierung Ihrer Daten.

Die Reihenfolge der Elemente eines Ordners können Sie frei bestimmen. Auch eine alphabetische Sortierfunktion steht zur Verfügung. In den Eigenschaften eines Ordners können Sie auch festlegen, dass die Elemente automatisch sortiert werden sollen (z.B. bei Neuanlage oder Umbenennung von Seiten oder Ordnern).

Die wesentlichen Funktionen finden Sie dazu in den Menüs Datei (für Seiten) und Ordner sowie auf der Symbolleiste.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis HTML-Hilfedokumentationsgenerator


Editierbereich einer Seite

Scribble Papers ››

In diesem Editierbereich können Sie Texte, Dokumente, Objekte , Hyperlinks etc. ablegen. Für die Textformatierung stehen Ihnen in der Symbolleiste etliche Funktionen zur Verfügung. Durch vordefinierte Textformate können Sie die Formatierung auch vereinfachen und vereinheitlichen.

Unmittelbar nach Wechsel der Seite, beispielsweise durch Anwahl einer anderen Seite im Navigationsbaum, wird die Seite gespeichert. Sie müssen dazu nichts tun, weder ein Verzeichnis im Dateisystem Ihres Rechners auswählen noch einen Dateinamen bestimmen.

Wenn Sie Seiten vor versehentlicher Änderung oder Löschung schützen möchten, können Sie die Seite mit einem Schreibschutz versehen. Wählen Sie dazu Datei -> Eigenschaften... oder die Funktion Eigenschaften im Kontextmenü (rechte Maustaste).

Tipp: Sie können den Schreibschutz sehr schnell durch einen Doppelklick mit der Maus auf den rechten Bereich der Statuszeile umschalten.

Inhalt einer Seite

Mit dem Personal Edition von HelpNDoc erstellt: Vorteile eines Hilfe-Entwicklungstools


Inhalt einer Seite

Scribble Papers ››

Neben einfachem Text können Sie in einer Seite in Scribble Papers folgendes ablegen:

• Grafiken, z.B. Screenshots. Wenn Sie es bisher immer zu umständlich fanden, einen Ausdruck des aktuellen Bildschirminhaltes auszudrucken, sollten Sie es mit Scribble Papers versuchen.

• ganze Dateien, wie z.B. Textdateien oder auch Word- oder Excel-Dateien. Um eine Datei in eine Seite einzufügen, können Sie entweder die Datei über die Zwischenablage einfügen (im Windows- / NT-Explorer die Datei über die rechte Maustaste kopieren und in Scribble Papers wieder einfügen) oder aber die Datei über Bearbeiten -> Objekt einfügen einfügen. Näheres finden Sie unter Objekte .

• Verknüpfungen auf bestehende Dateien. Näheres finden Sie unter Objekte .

• Hyperlinks auf bestehende Dateien, Verzeichnisse, WWW- oder FTP-Adressen oder auf andere Seiten und Ordner in Scribble Papers. Näheres finden Sie unter Hyperlinks .

Mit dem Personal Edition von HelpNDoc erstellt: EPub-Bücher für das iPad verfassen


Objekte

Scribble Papers ›› Inhalt einer Seite ››

Menü: Bearbeiten -> Objekt einfügen

Tastaturkürzel : Strg + P

Sie können in einer Scribble Papers Seite Objekte aus anderen Anwendungen ablegen. Diese Objekte können beispielsweise Tabellen einer Tabellenkalkulation wie Microsoft Excel, Zeichnungen, Grafiken etc. sein. Objekte zeichnen sich dadurch aus, dass sie innerhalb von Scribble Papers weiterhin mit der Anwendung bearbeitet werden können, mit der sie erstellt wurden. Fügen Sie beispielsweise eine Excel-Tabelle als Objekt in eine Seite von Scribble Papers ein, können Sie diese Tabelle durch Doppelklicken mit der Maus wieder mit Microsoft Excel bearbeiten. Sie erhalten die volle Funktionalität der Anwendung, die für das Objekt zuständig ist.

Eine Einschränkung muß dennoch genannt werden: die Funktionalität der Anzeige eines eingebetteten Objektes hängt von der mit dem Objekt verbundenen Anwendung ab. Microsoft Excel, Word etc. stellen diese Funktionalität zur Verfügung. Wenn Sie jedoch z.B. eine .txt-Datei einbetten wollen, kann dieses Objekt nur als Symbol dargestellt werden, da die mit .txt-Dateien verbundene Anwendung (üblicherweise der Editor "Notepad") die Funktion der Anzeige von eingebetteten Objekten nicht anbietet.

So fügen Sie ein Objekt in eine Seite von Scribble Papers ein:

• Wählen Sie den Menüpunkt Bearbeiten -> Objekt einfügen...

• Wählen Sie zwischen einem neu zu erstellenden Objekt oder einer bestehenden Datei.

• Wenn Sie ein neues Objekt erstellen möchten, müssen Sie aus der Liste die zuständige Anwendung auswählen. Das Objekt wird dann zwangsläufig auch physisch in Ihrer Scribble Papers Seite gespeichert. In der Auswahlliste werden Sie nicht alle auf Ihrem Rechner vorhandenen Anwendungen finden, sondern nur diejenigen, die diesen Objekt-Dienst zur Verfügung stellen. Nur mit diesen Anwendungen funktioniert das Einfügen eines neuen Objektes.

• Wenn Sie ein Objekt aus einer bestehenden Datei einfügen möchten, müssen Sie die Datei entweder direkt angeben oder über das Dateisystem auswählen. Sie können bestimmen, ob Sie lediglich einen Verweis (Link) auf diese Datei oder aber eine komplette Kopie der gewählten Datei in Ihre Seite einfügen möchten. Ein Verweis führt dazu, dass Ihnen in Scribble Papers immer der aktuelle Stand der Datei - also inkl. zwischenzeitlicher Änderungen - zur Verfügung steht. Wird die Datei jedoch von ihrem physikalischen Standort im Dateisystem verschoben oder gelöscht, ist auch das Objekt in Scribble Papers verloren. Das kann Ihnen beim Einfügen einer Kopie der Datei (durch Entfernen einer Markierung bei "Link") nicht passieren, allerdings bekommen Sie dann evtl. Änderungen an der Datei nicht nachgeliefert. Außerdem erhöht sich der Speicherbedarf für ihre Seite.

• Wählen Sie die Darstellungsform: das Objekt kann entweder als Symbol oder in der von der zuständigen Anwendung präsentierten Form angezeigt werden. Letzteres ist allerdings von der zuständigen Anwendung abhängig! Einfache Text-Dateien beispielsweise sind ausschließlich in Symbolform darstellbar, da die reguläre zuständige Anwendung (der Windows-Editor "NotePad") eine "korrekte" Darstellung eingebetteter Objekte nicht unterstützt.

Experimentieren Sie ruhig ein wenig mit dieser Funktion herum, Sie werden sehen, dass Ihnen damit eine praktische Funktion zur Verfügung steht, mit der Sie Ihre Seiten in Scribble Papers sowohl optisch als auch funktional erheblich aufwerten können. Alternativ für eine Verknüpfung auf ein Objekt (als Symbol dargestellt) können Sie auch einen Hyperlink verwenden.

In Verbindung mit einem möglichen Schreibschutz einer Seite in Scribble Papers ist dieser Hinweis zu beachten!

Mit dem Personal Edition von HelpNDoc erstellt: Einfacher CHM- und Dokumentationseditor


Eingebettete Objekte in schreibgeschützten Seiten

Scribble Papers ›› Inhalt einer Seite ›› Objekte ››

Scribble Papers gibt Ihnen über einen in den Einstellungen einer Seite setzbaren Schreibschutz die Möglichkeit, eine Seite vor versehentlicher Änderung oder Löschung zu schützen.

Das Editierfenster erlaubt Ihnen bei schreibgeschützten Seiten keine Änderung am Inhalt der Seite. Es gibt jedoch eine Ausnahme: eingebettete Objekte können über die zuständige Anwendung dennoch verändert werden! Die Ursache liegt darin, daß die für das Objekt zuständige Anwendung keine Kenntnis über einen in einer Seite in Scribble Papers gesetzten Schreibschutz hat und die volle - also auch ändernde - Funktionalität zur Verfügung stellt.

Beachten Sie, daß die Seite - und damit auch das eingebettete Objekt - dennoch nicht erneut gespeichert wird, d.h. Änderungen am eingebetteten Objekt gehen verloren!

Mit dem Personal Edition von HelpNDoc erstellt: Webhilfe-Seiten einfach erstellen


Hyperlinks

Scribble Papers ›› Inhalt einer Seite ››

Menü: Bearbeiten -> Hyperlink einfügen

Tastaturkürzel : Strg + H

Ebenso praktisch wie Objekte sind Hyperlinks. Hyperlinks sind lediglich Verweise auf Adressen. Das kann eine Datei oder ein Verzeichnis im Dateisystem (oder im Netzwerk), eine WWW- oder FTP-Adresse, aber auch eine andere Seite oder ein Ordner in Scribble Papers sein. Hyperlinks haben gegenüber Verknüpfungen auf Objekte auch Vorteile: die Adresse ist ersichtlich und für die Ablage eines Hyperlinks in Ihrer Seite wird genauso wenig Speicherplatz wie für normalen Text benötigt. Hier sind ein paar Beispiele für Hyperlinks:

Eine andere Seite in Scribble Papers:

<file://*Page0000147*(Nützliche Links)>

Einen Eintrag in der Stichwortliste :

<file://*Keyword:SAPConnect*>

Eine WWW-Adresse:

<http://www.myelin.de>

Eine Datei:

<file://C:\Eigene Dateien\Beschreibung_SAPConnect.doc>

Ein Verzeichnis:

<file://C:\Eigene Dateien\>

Oder aber, wenn auch etwas "seltener" verwendet:

Eine Mail-Adresse:

<mailto:Jens.Hoetger@gmx.de>

Eine FTP-Adresse:

<ftp://143.4.1.88/ftpdaten/upload/sample.exe>

Start einer Telnet-Sitzung auf einem anderen Rechner:

<telnet://filesrv4>

Start einer Netmeeting-Sitzung mit einem anderen Rechner:

<callto:10.48.13.127>

Sobald Sie die Maus über einem solchen Hyperlink in einer Scribble Papers Seite bewegen, verändert sich der Mauszeiger in ein Handsymbol, und ein einfacher Mausklick führt diesen Hyperlink aus.

Bei Hyperlinks auf eine Seite oder einen Ordner in Scribble Papers wird die jeweilige Seite bzw. der Ordner aufgerufen.

Bei anderen Hyperlinks wird die in Ihrem Windows-System zugeordnete Standardfunktion aufgerufen. Beispielsweise wird bei

• einer WWW-Adresse Ihr Standard-Internetbrowser aufgerufen,

• einer Datei diese Datei bzw. die über die Dateiendung verbundene Anwendung ausgeführt, die diese Datei dann lädt,

• einem Verzeichnis der Windows- / NT-Explorer aufgerufen, der das Verzeichnis dann anzeigt.

• einer Mail-Adresse Ihr Standard-Mailprogramm aufgerufen und eine neue Mail mit der Mail-Adresse im Empfängerfeld erzeugt.

Wenn Sie viel mit Dokumenten und Dateien aller Art in den verschiedensten Verzeichnissen - womöglich auch im Netzwerk - arbeiten, können Ihnen Hyperlinks in einer Scribble Papers Seite viel Zeit ersparen. Auch für die Favoriten- oder Bookmarks-Funktionen der gängigen Internet-Browser ist die Verwaltung von Hyperlinks in Scribble Papers eine Alternative. Die Funktionalität des Hyperlinks steht Ihnen aber erst zur Verfügung, wenn in Ihrem System das RichEdit-Control mit Version 2 (oder höher) installiert ist.

Hyperlinks können zwar direkt eingegeben werden, einfacher - und vor allen Dingen auch zuverlässiger - ist die Funktion Bearbeiten -> Hyperlink einfügen.... Diese Funktion bietet Ihnen für Seiten, Ordner, Dateien und Verzeichnisse über die Schaltfläche neben dem Eingabefeld eine Suchfunktion. Ein über die Suchfunktion erstellter Hyperlink ist "zuverlässiger" als ein eingetippter, da Tippfehler ausgeschlossen sind.

Hyperlinks auf Seiten oder Ordner in Scribble Papers haben eine spezielle Schreibweise und erfordern die Kenntnis der technischen Identifikation. Die manuelle Eingabe wäre daher sehr fehleranfällig. Aus diesem Grund steht das Eingabefeld in diesem Fall nicht zur Verfügung, und es ist ausschließlich die Suchfunktion für die Angabe des Hyperlinks zu verwenden. Daher wird auch - im Gegensatz zu Hyperlinks auf Dateien oder Verzeichnisse - automatisch die Suchfunktion gestartet, wenn Sie den entsprechenden Auswahlknopf betätigen.

Eine weitere praktische Möglichkeit für die Verknüpfung Ihrer Seiten untereinander ist über die Funktion Bearbeiten -> Hyperlink in Zwischenablage möglich. Durch diese Funktion wird ein Hyperlink zur aktuellen Seite in die Zwischenablage gestellt, der über die Einfügen-Funktion in die Seite eingefügt werden kann.Diese Funktion steht auch im Kontextmenü (rechte Maustaste) im Navigationsbaum zur Verfügung, so dass Sie nicht zwangsläufig erst zu der Seite wechseln müssen, für die Sie einen Hyperlink erzeugen möchten.

Auch Hyperlinks auf Einträge in der Stichwortliste haben eine spezielle Notation, und auch hier wird bei Betätigung des entsprechenden Auswahlknopfes automatisch die Suchfunktion (in diesem Fall die Stichwortliste) gestartet.

Hyperlinks auf Dateien und Verzeichnisse können Sie alternativ zur absoluten Pfadangabe (Laufwerksbuchstabe:) auch mit relativem Pfad oder aber mit UNC-Notation einfügen.

Ein relativer Pfad ist nur dann möglich, wenn sich das Ziel des Hyperlinks im oder unterhalb des verwendeten Datenverzeichnisses befindet. Anstelle der gesamten Pfadinformation wird ein Platzhalter "*RelPath*" eingesetzt, der beim Aufruf des Hyperlinks wieder durch das aktuelle Datenverzeichnis ersetzt wird. Diese Funktion ist dann nützlich, wenn Sie Ihre Daten auf ein anderes Laufwerk oder einen anderen Rechner transferieren wollen. In solchen Fällen ändert sich oft das Laufwerk und / oder das Verzeichnis. Bei relativer Pfadangabe müssen Sie lediglich dafür sorgen, dass die verlinkten Dokumente in oder unterhalb des Datenverzeichnisses an gleicher Stelle bleiben, unabhängig von einem Laufwerkwechsel oder einer anderen Verzeichnistiefe.

Die UNC-Notation ist in Netzwerken sinnvoll. Anstelle des Laufwerkes wird der Netzwerkname des Servers bzw. des Serververzeichnisses eingesetzt. Dadurch ist ein derartiger Hyperlink auch für andere Mitarbeiter verwendbar, die zwar auf den gleichen Server Zugang haben, aber nicht den gleichen Laufwerksbuchstaben dafür verwenden.

Anmerkung: Wenn Sie Hyperlinks direkt eingeben, müssen Sie - sofern die Adresse Leerstellen enthält - den Hyperlink in spitze Klammern <> fassen.

Mit dem Personal Edition von HelpNDoc erstellt: Plattformübergreifende Qt Help-Dateien erstellen


Einstellungen

Scribble Papers ››

Menü: Bearbeiten -> Einstellungen

Tastaturkürzel : Strg + O

Über die Einstellungen können Sie das Verhalten von Scribble Papers Ihren Wünschen anpassen.

PC-Administratoren: bitte auch diese Hinweise beachten.

• Reiter Allgemein

Start-Modus: Sie können festlegen, wie Scribble Papers beim Starten erscheinen soll: minimiert (Schaltfläche in der Taskleiste), als Vollbild, normal (Größe und Position wie bei letzter Beendigung) oder als Symbol in der TNA (Taskbar Notification Area, das ist der Bereich rechts in der Taskleiste, in dem u.a. die Uhrzeit angezeigt wird).

Minimieren in TNA: ist diese Einstellung markiert, wird Scribble Papers beim Minimieren nur durch ein Symbol in der TNA (Taskbar Notification Area) angezeigt. Eine Schaltfläche in der Taskleiste wird nicht angezeigt.

Papierkorb beim Beenden leeren: ist diese Einstellung markiert, wird der Papierkorb beim Verlassen des Programms automatisch geleert. Im Papierkorb enthaltene Ordner und Seiten werden dann unwiderbringlich gelöscht!

Cursorposition speichern: ist diese Einstellung markiert, werden für jede Seite die aktuelle Position des Cursors sowie ein ggf. markierter Bereich gespeichert und wiederhergestellt (Standardeinstellung).

Verlauf speichern: ist diese Einstellung markiert, wird der Verlauf der bisherigen Seiten gespeichert und steht beim nächsten Programmstart wieder zur Verfügung.

Symbolleisten automatisch ausrichten: ist diese Einstellung markiert, werden die Symbolleisten bei einer Größenänderung des Hauptfensters möglichst optimal platziert. Passt eine Symbolleiste nicht mehr vollständig in den sichtbaren Bereich, wird sie in eine Folgezeile verschoben. Wenn eine Symbolleiste dagegen noch vollständig in eine vorige Zeile passt, wird sie dorthin verschoben.

Funktion 'Datum/Zeit einfügen': Legen Sie hier fest, ob bei Ausführung dieser Funktion (Menü Bearbeiten / Taste F5) nur das Datum oder nur die Zeit eingefügt werden soll.

Funktion 'Ordner sortieren': Hier können Sie die Sortierfunktion anpassen.

"Ordner zuerst": Die Ordner erscheinen in sortierter Reihenfolge vor den Seiten.

"Ordner zuletzt": Die Ordner erscheinen in sortierter Reihenfolge nach den Seiten.

Wenn keine der beiden Optionen markiert ist (entspricht der Standardeinstellung), werden Ordner und Seiten gemeinsam sortiert.

Verzeichnis für Daten: Sie können hier das Verzeichnis bestimmen, in dem Ihre Daten abgelegt werden. Über die Schaltfläche rechts vom Eingabefeld können Sie ein anderes Verzeichnis anlegen und auswählen. Dabei können Sie auch bestimmen, ob Sie auf die Daten des Verzeichnisses vollständig oder nur lesend zugreifen möchten (bei Datenverzeichnissen für Arbeitsgruppen relevant).

Sofern Sie unterschiedliche Datenverzeichnisse verwenden, ist die Markierung der Option "In Titelleiste anzeigen" sowie ggf. die Eingabe mit einer sprechenden Bezeichnung im Eingabefeld darunter für den Inhalt des Verzeichnisses empfehlenswert. Wenn Sie mit mehreren Instanzen von Scribble Papers mit jeweils unterschiedlichen Datenverzeichnissen parallel arbeiten möchten, können Sie ein Desktop-Symbol zu einem Datenverzeichnis anlegen. Bei Start von Scribble Papers über dieses Desktop-Symbol wird dann das ausgewählte Verzeichnis verwendet, unabhängig von dem zuletzt verwendeten Verzeichnis. Beachten Sie in diesem Zusammenhang die möglichen Programm-Parameter .

Wenn neben Ihnen auch noch andere Mitarbeiter das Verzeichnis verwenden, sollten Sie die Option "Gruppenverzeichnis" markieren. Dadurch wird der letzte Änderer der Seite gespeichert. Sie sehen den letzten Änderer dann bei Ansprung der Seite in der Statuszeile sowie im Dialogfenster Eigenschaften einer Seite .

Über die Option "Ordner zugeklappt" können Sie steuern, ob beim erstmaligen Anzeigen der Daten die Ordner so wie beim letzten Verlassen (= Standardeinstellung) oder ob nur die oberste Ordnerebene angezeigt werden soll.

• Reiter Layout

Die von Scribble Papers verwendeten Schriftarten sind für den Navigationsbaum, die Reiter, die Listen für die Lesezeichen und Suchergebnisse sowie neue Seiten frei wählbar. Mit einem Mausklick auf den entsprechenden Bereich erhalten Sie den Auswahldialog für die Schriftfarbe. Für eine deutlichere Darstellung des aktiven Knotens im Navigationsbaum können Sie dessen Hintergrundfarbe auswählen.

Für die Reiter können Sie außerdem bestimmen, ob die Anzeige mehrzeilig oder in einer einzelnen Zeile erfolgen soll bzw. ob die Reiter überhaupt angezeigt werden sollen (bei Ordnern mit vielen Elementen reduziert sich der Nutzen der Reiter und verlangsamt die Anzeige des Ordners).

Weiterhin können Sie festlegen, dass die Elemente innerhalb der Ordner automatisch sortiert werden sollen bzw. (wenn die automatische Sortierung nicht aktiviert ist) ob neue Elemente am Anfang oder am Ende des Ordners eingefügt werden sollen.

Diese Einstellungen sowie die Layout-Einstellungen für neue Seiten können pro Ordner unterschiedlich festgelegt werden.

Für neue Seiten des Papierkorbes gelten diese Einstellungen nicht.

Sie können außerdem andere als die Standard-Icons verwenden. Bitte lesen Sie für Details hier weiter.

• Reiter Meldungen

Hier können Sie einstellen, in welchen Fällen vor dem endgültigen Durchführen einer Aktion Abfragen vorgenommen werden sollen. Zur Wahl stehen Abfragen vor dem Leeren des Papierkorbes, vor dem Löschen und Verschieben von Seiten oder Ordnern sowie vor dem Löschen gespeicherter Suchergebnisse und vor der Sortierung eines Ordners.

Die Abfragen vor einem Löschvorgang können auch eingeschränkt werden. Wenn Sie beispielsweise bei "Löschen einer Seite" die einschränkenden Optionen aktivieren, erfolgt die Abfrage nur vor der Löschung einer schreibgeschützten Seite und / oder einer als Vorlage für neue Seiten eines Ordners verwendeten Seite. Analog dazu verhalten sich die Einstellungen zum Löschen eines Ordners.

• Reiter Schreibschutz

Wenn Sie Seiten vor unbeabsichtigter Löschung oder Änderung schützen wollen, können Sie sie mit einem Schreibschutz versehen. Für schreibgeschützte Seiten bzw. Ordner, die schreibgeschützte Seiten enthalten, können Sie festlegen, ob diese löschbar oder verschiebbar (wahlweise generell oder lediglich auf das Verschieben durch Ziehen mit der Maus beschränkt) sind und ob der Passwortschutz änderbar ist.

Das Unterbinden des Verschiebens bezieht sich dabei auf das Verschieben in einen anderen Ordner. Die Möglichkeit der Anordnung (höher / tiefer) ist weiterhin gegeben.

In Verbindung mit eingebetteten Objekten ist dieser Hinweis zu beachten!

Mit dem Personal Edition von HelpNDoc erstellt: Gratis iPhone-Dokumentationsgenerator


Verzeichnis

Scribble Papers ›› Einstellungen ››

Menü: Bearbeiten -> Einstellungen

Tastaturkürzel : Strg + O

Sie können das Verzeichnis (gemeint ist das physikalische Verzeichnis im Dateisystem), in dem Scribble Papers die Daten speichert, frei wählen. Es können auch mehrere Verzeichnisse verwendet werden.

Standardmäßig werden Ihre Daten im Verzeichnis für "Eigene Dateien" abgelegt, wo ein eigenes Unterverzeichnis für die Daten von Scribble Papers angelegt wird (in früheren Programmversionen wurden die Daten in einem Unterverzeichnis "data" im Installationsverzeichnis verwendet).

So können Sie ein anderes Verzeichnis für Ihre Daten verwenden:

Um Ihre Daten in ein anderes Verzeichnis zu verschieben gehen Sie bitte folgendermaßen vor:

1. Beenden Sie Scribble Papers.

2. Verwenden Sie den Windows-/NT-Explorer oder ein anderes Dateimanagement-Programm, um alle Dateien des aktuellen Datenverzeichnisses in das von Ihnen für die Daten vorgesehene Verzeichnis zu verschieben.

3. Starten Sie Scribble Papers. Da die Daten des vorher verwendeten Verzeichnisses nun verschoben sind, zeigt Ihnen die Anwendung lediglich den obersten Ordner sowie den Papierkorb. Wählen Sie nun den Menüpunkt Bearbeiten -> Einstellungen und wählen Sie im Eingabefeld für Verzeichnis für Daten der Registerkarte "Allgemein" das von Ihnen vorgesehene Verzeichnis. Über die Schaltfläche neben dem Eingabefeld können Sie ein Verzeichnis aus dem Dateisystem bzw. dem Netzwerk wählen. Nach Betätigen der OK-Schaltfläche schaltet Scribble Papers auf das gewählte Verzeichnis um und stellt die dort vorhandenen Ordner und Seiten dar.

So können Sie ein weiteres Verzeichnis für Ihre Daten verwenden:

Geben Sie entweder direkt im Eingabefeld Verzeichnis für Daten ein anderes Verzeichnis an oder wählen Sie ein Verzeichnis aus dem Dateisystem oder dem Netzwerk über die Schaltfläche neben dem Eingabefeld. Über die Schaltfläche neben dem Eingabefeld können Sie auch ein neues Verzeichnis erstellen.

Nach Betätigen der OK-Schaltfläche schaltet Scribble Papers auf das gewählte Verzeichnis um und stellt die dort vorhandenen Ordner und Seiten dar.

Einmal verwendete Verzeichnisse werden in die Liste des Eingabefeldes eingetragen und können durch das Aufklappen der Liste schnell ausgewählt werden.

Ein Verzeichnis für die Daten von Scribble Papers kann sich entweder lokal auf Ihrem Rechner oder irgendwo im Netzwerk befinden.

Wenn Sie Scribble Papers und die mit Scribble Papers verwalteten Daten auf einem USB-Stick oder einer Wechselfestplatte verwenden, erhalten Sie ggf. beim Programmstart eine Fehlermeldung, dass das Datenverzeichnis nicht existiert. Die Ursache dafür liegt in einer sich ändernden Zuordnung eines Laufwerkbuchstaben für den USB-Stick bzw. die Wechselfestplatte.

Scribble Papers ist auch bei wechselnden Laufwerkbuchstaben auf einem USB-Stick oder einer Wechselfestplatte lauffähig. Geben Sie dazu das Datenverzeichnis ohne Laufwerkbuchstaben an, also z.B. anstatt "E:\Scribble Papers Daten\" nur "\Scribble Papers Daten\". Durch die Auslassung des Laufwerkbuchstabens wird auf das entsprechende Verzeichnis auf dem Laufwerk zugegriffen, auf dem auch das Programm installiert ist.

Beispielkonfiguration:

1. Richten Sie zwei Verzeichnisse auf dem USB-Stick bzw. auf der Wechselfestplatte ein:

\Scribble Papers\

\SP Daten\

2. In das erste Verzeichnis kopieren Sie alle Programmdateien. In das zweite Verzeichnis kopieren Sie Ihre Daten (falls Sie bereits Daten verwaltet haben), also alle Dateien des bisher verwendeten Datenverzeichnisses (ohne die Datei "lockdir.dat").

3.: Starten Sie Scribble Papers auf dem USB-Stick bzw. auf der Wechselfestplatte im Verzeichnis \Scribble Papers\.

4. Wählen Sie Bearbeiten -> Einstellungen und geben Sie im Eingabefeld für Verzeichnis für Daten der Registerkarte "Allgemein" das Datenverzeichnis ohne Laufwerksbuchstaben ein, also in diesem Fall \SP Daten\.

Für die Erstellung und Änderung von Ordnern und Seiten ist es erforderlich, dass Sie "schreibenden" Zugriff auf das gewählte Verzeichnis haben, d.h. Sie müssen die erforderlichen Rechte besitzen, um Dateien erstellen / überschreiben / löschen zu können. Empfehlenswerterweise sollten Sie Scribble Papers auch ein "eigenes" Verzeichnis spendieren. Das Verzeichnis sollte also nicht für weitere Daten von anderen Anwendungen verwendet werden.

Sofern Sie keinen "schreibenden" Zugriff auf das gewählte Verzeichnis haben (das ist z.B. zwangsläufig bei einem Verzeichnis auf einer CD-ROM oder DVD der Fall):

• wenn sich in dem Verzeichnis Scribble Papers-Daten befinden, können diese lesend verwendet werden,

• wenn sich in dem Verzeichnis keine Scribble Papers-Daten befinden, kann das Verzeichnis nicht verwendet werden. Sie müssen dann ein anderes Verzeichnis wählen.

Sie können die Zugriffsart in den Einstellungen auch selbst festlegen: wenn die Option "Vollzugriff" markiert ist, können Sie Ordner und Seiten verwalten und anlegen (entsprechende Berechtigungen bzw. einen geeigneten Datenträger vorausgesetzt). Ist die Option nicht markiert, wird das Datenverzeichnis nur mit lesendem Zugriff verwendet.

Standardmäßig wird der Vollzugriff verwendet. Wenn Sie jedoch innerhalb einer Arbeitsgruppe (mehrere Anwender in einem Netzwerk) ein gemeinsames Datenverzeichnis für die Ablage allgemein interessanter Informationen nutzen, empfiehlt sich der lesende Zugriff. Hinweise zum Einrichten und Verwalten von Daten, die von mehreren Anwendern genutzt werden, finden Sie hier . Beachten Sie in diesem Zusammenhang die möglichen Programm-Parameter .

Die Einstellung der Zugriffsart auf ein Verzeichnis wird gespeichert. Wenn Sie ein Datenverzeichnis auswählen, wird das Markierungsfeld für den Vollzugriff gemäß der vormals gewählten Einstellung für dieses Verzeichnis versorgt. Dadurch vereinfacht sich die Handhabung gemeinsamer Datenverzeichnisse. Wenn Sie die Einstellung für ein Datenverzeichnis ändern wollen, müssen Sie zunächst das Datenverzeichnis wählen, dann die Einstellung verändern und die "OK"-Schaltlfäche betätigen.

Tipp: sofern Sie mehrere Datenverzeichnisse gleichzeitig verwenden möchten, können Sie über Ansicht -> Neues Fenster ein weiteres Fenster erzeugen und dort auf das gewünschte Datenverzeichnis umschalten. Oder Sie verwenden ein Desktop-Symbol (im Einstellungs-Dialog erzeugbar), das beim Programmstart von Scribble Papers das Datenverzeichnis spezifiziert.

Anmerkung: strapazieren Sie die Möglichkeit, mehrere Verzeichnisse zu verwenden nicht über die Maßen. Einerseits beeinflußt das Volumen der verwaltbaren Daten sowie die Anzahl der Ordner und Seiten die Geschwindigkeit und den Hauptspeicherbedarf des Programms nur in vernachlässigbarem Ausmaß. Andererseits arbeitet die Suchfunktion von Scribble Papers nur mit den Daten des aktuellen Verzeichnisses, d.h. wenn Sie Ihre Daten über verschiedene Verzeichnisse verteilen, kann sich Ihre Suche nach einer bestimmten Seite aufwendiger gestalten: Seiten im aktuellen Verzeichnis durchsuchen, ggf. zu einem anderen verwendeten Verzeichnis wechseln, Seiten durchsuchen... Die Nutzung mehrerer Datenverzeichnisse ist hauptsächlich für Arbeitsgruppen im Netzwerk von Vorteil.

Mit dem Personal Edition von HelpNDoc erstellt: Plattformübergreifende Qt Help-Dateien erstellen


Datenverzeichnisse für Arbeitsgruppen

Scribble Papers ›› Einstellungen ››

Menü: Bearbeiten -> Einstellungen

Tastaturkürzel : Strg + O

Arbeitsgruppen innerhalb eines Netzwerkes können mit Scribble Papers allgemein nützliche Informationen gemeinsam aufbauen und nutzen, z.B. für Lösungsdatenbanken.

Eine einfache Netzwerkfunktion sorgt dafür, dass nur jeweils ein Anwender die Daten des Datenverzeichnisses ändern kann. Alle anderen Anwender, die das Datenverzeichnis verwenden, erhalten "lesenden" Zugriff. Der exklusive Vollzugriff auf die Daten betrifft alle Daten des Verzeichnisses, also nicht einzelne Ordner oder Seiten.

Gehen Sie folgendermaßen vor, um mit anderen Mitgliedern Ihrer Arbeitsgruppe gemeinsame Datenverzeichnisse zu nutzen:

• Wählen bzw. erstellen Sie in einem für alle Mitglieder Ihrer Arbeitsgruppe verfügbaren Netzlaufwerk ein Dateiverzeichnis.

• Teilen Sie den anderen Mitgliedern den Pfad des Dateiverzeichnisses mit.

• Um festzuhalten, wer eine Seite zuletzt geändert hat, sollten alle auf das Verzeichnis zugreifenden Personen in den Einstellungen zum Datenverzeichnis die Option "Gruppenverzeichnis" markieren.

• "Füllen" Sie das Datenverzeichnis gemeinsam mit den anderen Mitgliedern mit Daten von allgemeinem Interesse. Wer Informationen einbringen möchte, muß das Datenverzeichnis im "Vollzugriff" verwenden (Menü Bearbeiten -> Einstellungen...). Nach Ablage der Informationen sollte wieder auf lesenden Zugriff umgeschaltet werden, um anderen Mitgliedern die Möglichkeit des Vollzugriffs zur Verfügung zu stellen. Die Einstellung der Zugriffsart wird gespeichert und bei Wahl eines Datenverzeichnisses entsprechend vorbelegt.

Anmerkung: bedenken Sie, dass Scribble Papers in erster Linie eine Einzelplatzanwendung ist. Es ist keine abgesicherte Workgroup-Anwendung mit der Möglichkeit der differenzierten Vergabe von Zugriffsrechten auf die verwalteten Daten. Dazu wäre eine ausgefeilte Datenbanktechnik erforderlich, wodurch Scribble Papers nicht mehr länger eine kleine, schlanke und einfach zu handhabende Anwendung bliebe. Die Verwendung gemeinsamer Datenverzeichnisse basiert daher auf der Bereitschaft der kooperativen Zusammenarbeit der zugreifenden Personen und dem dazu erforderlichen Vertrauen untereinander, genauso wie es für die gemeinsame Nutzung von Dateien und Verzeichnissen im Netzwerk - ohne Scribble Papers - erforderlich ist.

Mit dem Personal Edition von HelpNDoc erstellt: Funktionsreicher Kindle eBooks Generator


Technische / administrative Hinweise

Scribble Papers ›› Einstellungen ››

1.: Benutzerbezogene Einstellungen

Scribble Papers speichert standardmäßig die Programmeinstellungen, Formularpositionen und weitere anwendungsspezifische Informationen in der Datei "scpapers.stg" im Verzeichnis, in dem sich auch die Anwendung selbst befindet (typischerweise "C:\Program Files\Scribble Papers\"). Das kann in folgenden Fällen unerwünscht sein:

a) In einem Firmennetzwerk wird häufig die Strategie verfolgt, dem PC-Benutzer keinen Schreibzugriff auf die Verzeichnisse einzuräumen, in denen sich die Anwendungen befinden. In einem solchen Fall würde Scribble Papers ständig Fehlermeldungen beim Schreibversuch in die Datei ausgeben ("In die Datei ....scpapers.stg kann nicht geschrieben werden.").

b) Wenn mehrere Anwender den Rechner verwenden (und die gleiche Installation von Scribble Papers), "teilen" sich alle Anwender die gleichen Einstellungen bzw. werden die vom vorigen Anwender eingestellten Einstellungen durch die des aktuellen Anwenders wieder überschrieben.

Ein relativ einfacher Weg zur Vermeidung dieser Mißstände wäre die Nutzung der sogenannten "Registry" gewesen. Die Registry leidet jedoch unter dem Umstand, dass dort viele Anwendungen alle möglichen Daten abladen, was zum Aufblähen der Registry mit allerlei Datenmüll führt.

Stattdessen können Sie die Einstellungen von Scribble Papers aus dem Anwendungsverzeichnis heraus verlagern bzw. jedem einzelnen Anwender seine eigenen Einstellungen ermöglichen, indem Sie die Datei "scpapers.stg" im Programmverzeichnis mit einem Texteditor auf folgende Art und Weise ergänzen:

[All Users]

SettingsDir=U:\Dateien\SP Settings\

Dieser Eintrag bewirkt, dass für alle Anwender das Verzeichnis "U:\Dateien..." für die Einstellungen verwendet wird. Ein derartiger Eintrag ist sinnvoll, wenn für jeden Anwender ein eigenes Netzwerkverzeichnis verbunden wird, was für alle gleich lautet, aber dennoch auf physikalisch jeweils unterschiedliche Verzeichnisse zeigt.

[jhoetger]

SettingsDir=U:\Dateien\SP Settings\

[mmaier]

SettingsDir=C:\Documents and Settings\mmaier\Anwendungsdaten\ScribblePapers\

Diese Einträge bewirken, dass für den Anwender mit dem Benutzernamen "jhoetger" das Verzeichnis "U:\Dateien..." und für den Anwender mit dem Benutzernamen"mmaier" das Verzeichnis "C:\Documents and Settings..." für die Einstellungen verwendet wird.

Bei der Ermittlung des zu verwendenden Verzeichnisses hat ein benutzerspezifischer Eintrag Vorrang vor einem Eintrag für "All Users". Wird kein solcher Eintrag gefunden, oder aber existiert das angegebene Verzeichnis nicht, wird weiterhin das Verzeichnis verwendet, in dem sich die Anwendung befindet.

Folgende Dateien sollten Sie beim "Umzug" in ein anderes Verzeichnis für die Einstellungen kopieren:

scpapers.stg | (Programmeinstellungen, Fensterpositionen ...)
dirprps.* | (Einstellungen der Datenverzeichnisse)
Styles.* | (Textformate)
prnthead.rtf | (Definition der Seiteninfos im Ausdruck)

2.: Änderung der Dateinamenserweiterung

Scribble Papers verwendet für die Speicherung der Seiteninhalte das "Rich Text Format" und speichert die Daten in Dateien mit der Namenserweiterung "scp".

Dateien mit dieser Namenserweiterung werden von Desktop-Suchprogrammen (z.B. "Copernicus Desktop Search" oder "Google Desktop Search") i.d.R. nicht berücksichtigt.

Sofern Sie ein Desktop-Suchprogramm verwenden, das Dateien im RichText-Format verarbeiten kann, und die Inhalte eines Scribble Papers Datenverzeichnisses vom Desktop-Suchprogramm berücksichtigt werden sollen, können Sie ab Scribble Papers Version 2.6.1 die Dateinamenserweiterung auf "rtf" ändern. Dazu müssen Sie die von Scribble Papers verwendeten Einstellungen für das Datenverzeichnis manuell mit einem Texteditor ergänzen. Gehen Sie dazu folgendermaßen vor:

1.: Beenden Sie Scribble Papers.

2.: Benennen Sie alle Dateien mit der Dateiendung "scp" in dem Datenverzeichnis so um, dass sie die Dateiendung "rtf" erhalten (Hinweis: über die Windows-Eingabeaufforderung können alle entsprechenden Dateien mit einem einzigen "ren"-Befehl schnell umbenannt werden).

3.: Öffnen Sie mit einem Texteditor die Datei "dirprps.001".

4.: Suchen Sie innerhalb dieser Datei die Stelle, die die Einstellungen für das Datenverzeichnis enthält. Pro Datenverzeichnis gibt es jeweils einen eigenen Abschnitt, dieser beginnt mit einer Zeile, in der der Pfad des Verzeichnisses eingefasst in eckigen Klammern steht.

Beispiel: Sie möchten für das Verzeichnis "C:\Daten\SP_Arbeit\" die Dateinamenserweiterung auf "rtf" ändern:

[C:\Daten\SP_Arbeit\]

FullAccess=1

GroupDir=1

CollapseFldrAtStart=0

Name=Arbeit

Ergänzen Sie diesen Abschnitt um folgende Zeile:

FileExt=rtf

Wenn Sie Scribble Papers neu starten, wird für das Datenverzeichnis die Dateiendung "rtf" verwendet.

Beachten Sie folgendes:

Bei jedem Anwender, der das Datenverzeichnis verwendet, muss

• Scribble Papers in der Version 2.6.1 oder höher verwendet werden,

• der Eintrag für die geänderte Dateinamenserweiterung in der Datei "dirprps.001" vorgenommen werden.

Andernfalls würde Scribble Papers bei einigen Anwendern Dateien mit der Endung "scp", bei anderen mit der Endung "rtf" erwarten und dementsprechend leere Seiten anzeigen.

Passwort-geschützte Seiten werden in verschlüsselter Form gespeichert, die Daten sind daher - unabhängig von der Dateinamenserweiterung - für Desktop-Suchprogramme kryptisch und unbrauchbar.

Das Desktop-Suchprogramm, dass die Inhalte des Scribble Papers Datenverzeichnisses anzeigt, wird beim Öffnen der jeweiligen Datei die für die Dateiendung "rtf" zuständige Anwendung starten. In der Regel ist das "WordPad" bzw. bei einem installierten MS-Office "Word" oder andere Programme, die das RichText-Format verarbeiten können. Eine Änderung der Daten sollten Sie jedoch nur in Scribble Papers vornehmen!

Ein anderes Programm speichert die Daten ggf. in einem abgeänderten RichText-Format (ggf. in einem neueren oder älteren und/oder inkompatiblen Format), so dass die Daten in Scribble Papers nicht mehr oder nicht mehr fehlerfrei verarbeitet werden können. Eine Bearbeitung von passwort-geschützte n Seiten außerhalb Scribble Papers führt unweigerlich zu Datenverlust!

Ab Version 2.6.1 ist es möglich, Scribble Papers mit der verwendeten Dateinamenserweiterung zu verknüpfen, so dass die entsprechenden Dateien standardmäßig mit Scribble Papers geöffnet werden (-> über den Windows-Explorer, -> Ordneroptionen -> Dateitypen).

3.: Anzeige eines (Firmen-)Logos

Im Start-Bildschirm sowie im Info-Bildschirm (Hilfe -> Info) können Sie ein Logo einbinden, z.B. ein Firmen-Logo. Speichern Sie dazu im Programmverzeichnis das Logo als Bitmap-Datei mit dem Namen "c_logo.bmp" ab.

Für dieses Logo können Sie auch eine Zieladresse definieren, die beim Mausklick auf das Logo aufgerufen wird (z.B. eine Web-Adresse o.ä.). Dazu muss die Adresse in der Datei für die Programmeinstellungen "scpapers.stg" mit einem Texteditor im Abschnitt [Globals] ergänzt werden.

Beispiel:

[Globals]

...

LogoURL=http://www.homepage-unserer-firma.de

Mit dem Personal Edition von HelpNDoc erstellt: Webhilfe-Seiten einfach erstellen


Eigenschaften einer Seite

Scribble Papers ››

Menü: Datei -> Eigenschaften

Tastaturkürzel : F4

Sie können eine Seite mit folgenden Eigenschaften versehen (erreichbar im Menü über Datei / Eigenschaften oder der rechten Maustaste über dem Editierfenster oder dem Navigationsbaum):

Layout

Standardschriftart

Für den in der Seite enthaltenen Text können Sie die Standardschriftart bestimmen. Die Standardschriftart wird jedoch nicht auf Text angewendet, den Sie bereits explizit mit einer abweichenden Schriftart versehen haben. Beachten Sie dazu auch die Möglichkeit, in den Einstellungen das Layout von neuen Seiten festzulegen.

Hintergrundfarbe

Sie können die Seite mit einer Hintergrundfarbe versehen. Beachten Sie, dass im Zusammenhang mit der Standardschriftart nicht jede Kombination sinnvoll ist, weder aus ergonomischer Sicht noch im Hinblick auf den Ausdruck der Seite. Die Hintergrundfarbe wird beim Drucken nicht berücksichtigt! Sollten Sie also für eine Seite eine schwarze Hintergrundfarbe mit weißer Schrift gewählt haben, erhalten Sie beim Drucken der Seite ein leeres Blatt. Beachten Sie auch diesen Hinweis zum Drucken.

Schutz

Sensible Daten können Sie mit einem Passwort schützen. Ohne Eingabe des korrekten Passwortes kann die Seite nicht angezeigt werden. Die Datei, in der der Inhalt der Seite gespeichert wird, wird mit dem verwendeten Passwort verschlüsselt, so dass die Daten auch nicht außerhalb von Scribble Papers im Dateisystem eingesehen werden können.

Ein Passwort-Schutz verhindert aber nicht die Möglichkeit, die Seite zu löschen.

Achtung: wenn Sie ein verwendetes Passwort vergessen bzw. verlieren, gibt es keine Möglichkeit, die Daten der Seite wiederherzustellen!

Das Passwort kann 1 - 100 Zeichen enthalten. Ein "gutes" Passwort erfüllt folgende Kriterien:

Es umfasst mindestens sieben Zeichen.

Es enthält sowohl Buchstaben als auch Ziffern.

Es unterscheidet sich deutlich von früheren Passwörtern.

Es enthält weder Ihren Namen noch Ihren Benutzernamen.

Es ist kein allgemein gebräuchliches Wort oder ein Name.

Die Passwort-Abfrage kann wahlweise für jeden Aufruf der Seite oder nur für den ersten Aufruf der Seite aktiviert werden. Eine Abfrage beim "ersten Aufruf" wird dann in folgenden Fällen vorgenommen:

• der erste Aufruf der Seite nach dem Start von Scribble Papers (auch bei Start über Ansicht -> Neues Fenster),

• der erste Aufruf der Seite nach einem Wechsel des Datenverzeichnisses.

Tipp: In den meisten Fällen ist die Aktivierung der Passwort-Abfrage nur beim ersten Aufruf ausreichend. Eine Passwort-Abfrage bei jedem Aufruf ist nur dann angebracht, wenn Sie Ihren Computer während des Betriebs unbeaufsichtigt und ungeschützt zurücklassen, so dass er während Ihrer Abwesenheit auch von anderen Anwendern genutzt werden kann.

Über eine Markierung bei "Passwortliste verwenden" besteht die Möglichkeit, die bisher in der aktuellen Sitzung eingegebenen korrekten Passwörter zu verwenden. Nur wenn das richtige Passwort nicht dabei ist, erscheint das Dialogfenster für die Passwort-Abfrage.

Sie können außerdem zwischen zwischen zwei Schutzklassen wählen:

Schutzklasse 1: Scribble Papers kann die Seite selbständig entschlüsseln und kann daher auch die Seite für die Suchfunktion verwenden. Nachteil: wenn Scribble Papers die Seite entschlüsseln kann, besteht die theoretische Möglichkeit, dass auch ein Hacker durch Analyse der Verarbeitungsschritte in Scribble Papers dazu in der Lage ist.

Schutzklasse 2: Scribble Papers kann die Seite nicht selbständig entschlüsseln. Fällt die Seite in den Suchbereich der Suchfunktion , wird die Eingabe des Passwortes verlangt. Auch ein Hacker kann die Seite nicht entschlüsseln.

Verschlüsselte Seiten aus Scribble Papers Version 1.5.1 und 1.6.1 fallen in die Schutzklasse 1. Diese können mit der vorliegenden Version in Schutzklasse 2 umgesetzt werden.

Hinweis: Schutzklasse 1 ist theoretisch nicht 100% sicher. Entscheiden Sie anhand der Sensibilität der Daten und der gewünschten Berücksichtigung der Seite in der Suchfunktion , welche Schutzklasse Sie verwenden wollen. Hochsensible Daten sollten über Schutzklasse 2 geschützt werden. Für weniger sensible Daten, die zudem ohne eigene Passworteingabe in der Suchfunktion berücksichtigt werden sollen, bietet sich Schutzklasse 1 an.

Eine Markierung bei "Passwortschutz kopieren" sorgt dafür, dass neu angelegte Seiten auf Basis dieser Seite (z.B. beim Kopieren / Einfügen und bei Verwendung der Seite als Vorlage für neue Seiten eines Ordners) mit den gleichen Schutzeigenschaften versehen werden.

Stichwörter

Seiten und Ordner können mit Stichwörtern versehen werden. Die Vergabe von passenden Stichwörtern bietet viele Vorteile !

Tipp: Die Stichwörter zu einer Seite können Sie sich schnell und komfortabel über das Markieren des Stichwortes im Text (ein Doppelklick markiert ein ganzes Wort) und die Funktion "Als Stichwort aufnehmen" im Kontextmenü (rechter Mausklick) zusammenstellen.

Info

Der mit "Info" betitelte Reiter liefert Ihnen Informationen zu physikalischen Eigenschaften der Seite (Dateiname und -größe). Außerdem wird der Bearbeitungsstatus angezeigt. Wenn Sie Veränderungen an der Seite vorgenommen haben und die Seite noch nicht gespeichert wurde, ist der Status "überarbeitet". Die Seite wird generell beim Wechsel zu einer anderen Seite gespeichert (bzw. beim Beenden des Programms). Auf Wunsch können Sie die Seite durch Drücken der Speichern-Schaltfläche auch sofort speichern.

Sofern der letzte Änderer der Seite in den Einstellungen bei dem Datenverzeichnis die Option "Gruppenverzeichnis" markiert hat, wird auch der letzte Änderer der Seite hier ausgewiesen.

Verknüpfung(en)

Dieser Reiter wird nur angezeigt, wenn zu dieser Seite Verknüpfungen vorhanden sind bzw. wenn die Seite eine Verknüpfung zu einer anderen ist.

Hinweistext "Zu dieser Seite sind folgende Seiten verknüpft:"

In diesem Fall ist diese Seite die Original-Seite. In der Liste unter dem Text werden die vorhandenen Verknüpfungen angezeigt.

Hinweistext "Diese Seite ist eine Verknüpfung zu folgender Seite:"

In diesem Fall ist diese Seite eine Verknüpfung. In der Liste unter dem Text wird auf die Original-Seite verwiesen.

Schreibschutz

Wenn Sie eine Seite vor versehentlicher Änderung oder Löschung schützen wollen, können Sie sie mit einem Schreibschutz versehen. Das Editierfenster ist dann für verändernde Vorgänge gesperrt, so dass der Inhalt der Seite nicht mehr veränderbar ist. Über die Einstellungen können Sie das Verhalten von Scribble Papers in Bezug auf das Verschieben oder Löschen schreibgeschützter Seiten Ihren Wünschen anpassen.

Tipp: Sie können den Schreibschutz für eine Seite schnell umschalten, wenn Sie in der Statuszeile des Hauptfensters im rechten Bereich doppelt mit der Maus klicken (das ist der Bereich, in dem bei geschützten Seiten "Schreibschutz" angezeigt wird).

In Verbindung mit eingebetteten Objekten ist dieser Hinweis zu beachten!

Lesezeichen

Besonders bei umfangreichen Strukturen mit vielen Ordnern und Seiten können Sie über Lesezeichen direkter und schneller auf häufig verwendete Seiten zugreifen. Als Lesezeichen definierte Ordner und Seiten werden im Dialogfenster Lesezeichen aufgelistet.

Status

Sie können Ihre Seiten mit einem Status versehen, um Sie differenziert zu kennzeichnen. Im Navigationsbaum wird ein dem Status entsprechendes Symbol angezeigt.

Der Status dient vorrangig der unterschiedlichen Darstellung und Visualisierung im Navigationsbaum. Sie können durch unterschiedliche Status beispielsweise

- wichtige Seiten hervorheben

- Aufgaben mit niedriger / mittlerer / hoher Priorität kennzeichen

- Aufgaben als unerledigt / in Bearbeitung / erledigt kennzeichnen

- Vorgänge als unkritisch / problematisch / kritisch klassifizieren.

Es kann nur einer der aufgeführten Status vergeben werden, Mehrfachzuordnungen sind nicht möglich. Über die Suchfunktion können Sie sich eine Liste von Seiten mit einem bestimmten Status erzeugen lassen.

Scribble Papers enthält einige vordefinierte Status. Sie können die vordefinierten Status und die Icons folgendermaßen erweitern bzw. ändern:

Verwendung anderer Icons

Verwendung zusätzlicher Status

Tipp: Sie können den Status für eine Seite schnell verändern, wenn Sie in der Statuszeile des Hauptfensters im Anzeigefeld des Status doppelt mit der Maus klicken.

Wenn Sie das Layout neuer Seiten (eines Ordners) bestimmen, stehen die Einstellungen bzgl. Schreibschutz, Lesezeichen, Status sowie die Reiter "Schutz", "Stichwörter", "Info" und "Verknüpfung(en)" nicht zur Verfügung.

Mit dem Personal Edition von HelpNDoc erstellt: Einfacher EPub und Dokumentationseditor


Eigenschaften eines Ordners

Scribble Papers ››

Menü: Ordner -> Eigenschaften

Tastaturkürzel : F6

Sie können einen Ordner mit folgenden Eigenschaften (erreichbar im Menü über Ordner / Eigenschaften oder der rechten Maustaste über dem Navigationsbaum) versehen:

Layout neuer Seiten

Hier können Sie Standardschriftart sowie Hintergrundfarbe für neue Seiten bestimmen.

Hier können Sie auch festlegen, dass neue Seiten mit dem Inhalt bereits bestehender Seiten vorbelegt werden sollen. Markieren Sie dazu "Vorbelegung mit Seite" und wählen Sie dann über die unter dem Markierungsfeld erscheinende Schaltfläche eine Vorlage aus.

Wenn Sie dann neue Seiten innerhalb des Ordners (bzw. darunterliegenden, die die gleichen Ordnereigenschaften verwenden) anlegen, wird die neue Seite mit dem Inhalt der Vorlage-Seite gefüllt. Lesen Sie bitte auch diesen Hinweis zum Arbeiten mit Vorlagen .

Reiter

Für die Reiter können Sie bestimmen, ob die Anzeige mehrzeilig oder in einer einzelnen Zeile erfolgen soll bzw. ob die Reiter überhaupt angezeigt werden sollen.

Standardmäßig werden die Reiter mehrzeilig angezeigt. Bei Ordnern mit sehr vielen Seiten reduziert sich der Nutzen der Reiter jedoch: eine mehrzeilige Anzeige der Reiter verringert den verfügbaren Editierbereich, bei einer einzeiligen Anzeige der Reiter sind nicht mehr alle Seiten über die Reiter unmittelbar selektierbar, da nur ein Teil der Reiter Platz in der Zeile findet. Auch die Anzeigegeschwindigkeit der Elemente des Ordners wird durch die Darstellung der Reiter bei umfangreichen Ordnern verlangsamt.

In dem Fall empfiehlt es sich, die Reiter entweder durch Entfernen der Markierung "Mehrzeilig" in einer einzelnen Zeile anzuzeigen (um wieder einen größeren Editierbereich zu haben) bzw. die Anzeige der Reiter ganz auszuschalten.

Bei einer einzeiligen Anzeige der Reiter stehen Schaltflächen für das Blättern nach links und rechts zur Verfügung.

Reihenfolge untergeordneter Elemente

Sie können festlegen, dass die Elemente im Ordner automatisch sortiert werden sollen. Wenn innerhalb des Ordners neue Ordner oder Seiten angelegt oder bestehende Ordner oder Seiten umbenannt werden, werden die Elemente automatisch alphabetisch (unter Berücksichtigung der Einstellung für die Funktion 'Ordner sortieren' in den Einstellungen ) sortiert.

Wenn die automatische Sortierung nicht markiert ist, können Sie festlegen, ob neue Elemente am Anfang oder am Ende des Ordners eingefügt werden sollen.

Für diese Einstellungsmöglichkeiten werden standardmäßig die Einstellungen des übergeordneten Ordners bzw. die unter Bearbeiten -> Einstellungen -> Layout vorgenommenen Einstellungen verwendet. Ausnahme: für den Papierkorb gelten die unter Bearbeiten -> Einstellungen -> Layout vorgenommenen Einstellungen nicht!

Deaktivieren Sie das Markierungsfeld "wie übergeordneter Ordner", um davon abweichende Einstellungen vorzunehmen.

Info

Der mit "Info" betitelte Reiter liefert Ihnen Informationen zu den untergeordneten Elementen des Ordners, insbesondere den Speicherplatzbedarf auf dem Datenträger. Außerdem können Sie hier den Ordner mit Stichwörtern versehen.

Die Vergabe von passenden Stichwörtern bietet viele Vorteile !

Lesezeichen

Besonders bei umfangreichen Strukturen mit vielen Ordnern und Seiten können Sie über Lesezeichen direkter und schneller auf häufig verwendete Seiten und Ordner zugreifen. Als Lesezeichen definierte Ordner und Seiten werden im Dialogfenster Lesezeichen aufgelistet.

Status

Sie können Ihre Ordner mit einem Status versehen, um Sie differenziert zu kennzeichnen. Im Navigationsbaum wird ein dem Status entsprechendes Symbol angezeigt.

Der Status eines Ordners dient lediglich der unterschiedlichen Darstellung und Visualisierung im Navigationsbaum. Weitere Funktionen sind damit nicht verbunden. Sie können durch unterschiedliche Status beispielsweise

- Wichtiges hervorheben

- Ordner mit niedriger / mittlerer / hoher Priorität kennzeichen

- ...

Es kann nur einer der aufgeführten Status vergeben werden, Mehrfachzuordnungen sind nicht möglich. Für den obersten Ordner sowie für den Papierkorb kann kein Status vergeben werden. Über die Suchfunktion können Sie sich eine Liste von Ordnern mit einem bestimmten Status erzeugen lassen.

Scribble Papers enthält einige vordefinierte Status. Sie können die vordefinierten Status und die Icons folgendermaßen erweitern bzw. ändern:

Verwendung anderer Icons

Verwendung zusätzlicher Status

Mit dem Personal Edition von HelpNDoc erstellt: Qt Help-Dokumentation leicht gemacht


Verknüpfungen

Scribble Papers ››

Menü: Datei -> Neue Verknüpfung...

Datei -> Verknüpfung erstellen

Ordner -> Einfügen

Sie können Verknüpfungen zu einer Seite erstellen. Das Prinzip ist ähnlich den Datei-Verknüpfungen, wie sie z.B. im Windows-Dateisystem angelegt werden können. Eine verknüpfte Seite und ihr Original verfügen immer über die gleichen Daten und die gleichen Eigenschaften. Änderungen an einer verknüpften Seite wirken sich genauso auf ihr Original aus wie auch Änderungen am Original sich auf ihre verknüpften Seiten auswirken.

Verknüpfungen sind sinnvoll, wenn eine Seite thematisch in mehrere Ordner passt und in mehreren Ordnern verfügbar sein soll. Gegenüber der anderen denkbaren Vorgehensweise dafür (dem Anlegen von Kopien der Seite in weiteren Ordnern) bietet Ihnen das folgende Vorteile:

• Erforderliche Aktualisierungen bzw. Änderungen müssen nur einmal vorgenommen werden und sind dann sowohl bei der Original-Seite als auch bei allen Verknüpfungen ersichtlich. Dabei ist unerheblich, ob die Änderung an der Original-Seite oder an einer Verknüpfung vorgenommen wird.

• Sie sparen Speicherplatz auf dem Datenträger, da nur von der Original-Seite Inhalt und Eigenschaften gespeichert werden. Für die Verknüpfungen wird lediglich der Verweis auf die Original-Seite gespeichert.

Anders als bei Verknüpfungen im Windows-Dateisystem "kennen" sich verknüpfte Seiten und ihre jeweiligen Originale (im Windows-Dateisystem kennen Verknüpfungen zwar ihr Original, aber das Original kennt die Verknüpfungen nicht - was im Windows-Dateisystem zu "toten" Verknüpfungen und einer Fehlermeldung beim Zugriff auf diese Verknüpfung führt, wenn das Original umbenannt, verschoben oder gelöscht wurde).

Beachten Sie folgendes Verhalten beim Löschen von Verknüpfungen bzw. Originalen:

• Wenn Sie eine Verknüpfung löschen, wird nur die Verknüpfung, nicht aber das Original gelöscht.

• Wenn Sie ein Original löschen, werden auch alle Verknüpfungen zu diesem Original gelöscht (bzw. zunächst in den Papierkorb verschoben). Je nach Markierung in den Einstellungen erfolgt bei vorhandenen Verknüpfungen eine Sicherheitsabfrage.

Sowohl bei Verknüpfungen als auch bei der Original-Seite finden Sie im Dialog-Fenster für die Eigenschaften einer Seite einen Reiter "Verknüpfung(en)", der auf die Original-Seite bzw. auf vorhandene Verknüpfungen zu dieser Seite verweist.

Beim Kopieren von Verknüpfungen werden Sie gefragt, ob die Kopie eine weitere Verknüpfung oder aber eine Kopie der Original-Seite sein soll.

Wichtig: wenn Sie Scribble Papers gemeinsam mit anderen Anwendern mit gemeinsam genutzten Datenverzeichnissen nutzen, müssen bei der Verwendung von Verknüpfungen alle Anwender die Version 2.4.1 (bzw. neuere Versionen) verwenden. Versionen vor 2.4.1 kennen Verknüpfungen nicht, würden beim Speichern dieser verknüpften Seiten den Verweis auf die Original-Seite löschen und die Verknüpfung dadurch unbrauchbar machen.

Tipp: Nutzen Sie Verknüpfungen, wenn die Entscheidung für den "richtigen" Ordner für eine Seite schwierig erscheint. Verwenden Sie einen der in Frage kommenden Ordner für die Seite und legen Sie in den anderen in Frage kommenden Ordnern jeweils eine Verknüpfung ab. Nutzen Sie dazu die Menüfunktionen Datei -> Verknüpfung erstellen und Ordner -> Einfügen. Die Funktion zum Einfügen können Sie nacheinander in den Zielordnern verwenden ohne dass jedesmal erneut die Funktion Datei -> Verknüpfung erstellen verwendet werden muss. Die Funktionen stehen auch in den Kontext-Menüs (rechte Maustaste) zur Verfügung.

Mit dem Personal Edition von HelpNDoc erstellt: Vorteile eines Hilfe-Entwicklungstools


Programm-Parameter

Scribble Papers ››

Scribble Papers unterstützt folgende Programm-Parameter:

1.: /d <Verzeichnis>

Start mit dem angegebenen Datenverzeichnis, unabhängig von dem zuletzt verwendeten Datenverzeichnis.

2.: /dw <Verzeichnis>

Wie 1., jedoch grundsätzlich mit "Vollzugriff"

3.: /dr <Verzeichnis>

Wie 1., jedoch grundsätzlich mit nur lesendem Zugriff.

4.: /id <ID einer Seite oder eines Ordners>

Im Anschluß an die Parameter für ein Datenverzeichnis möglich, bewirkt den Start mit Anzeige einer bestimmten Seite oder eines bestimmten Ordners.

5.: Dateiname einer Scribble Papers Seite, z.B. "C:\SP-Daten\Page0001234.scp"

Diese Form wird implizit beim Start von Scribble Papers beim Öffnen einer Datei im Windows-Explorer verwendet. Voraussetzung ist, dass es sich um eine Datei handelt, die für die Speicherung einer einzelnen Seite verwendet wird und der Dateityp dieser Datei mit Scribble Papers verknüpft ist (im Windows-Explorer: Ordneroptionen -> Dateitypen). Diese Zuordnung wird nicht bei der Installation vorgenommen, sondern ist bei Bedarf selbst einzutragen (über den Windows-Explorer, -> Ordneroptionen -> Dateitypen); sinnvoll kann sie im Zusammenhang mit der Verwendung eines Desktop-Suchprogramms wie z.B. "Copernicus Desktop Search" oder "Google Desktop Search" sein. Beachten Sie dazu auch die technischen / administrativen Hinweise , Abschnitt 2 (Änderung der Dateinamenserweiterung).

Die Programm-Parameter können Sie in einer Verknüpfung auf Scribble Papers im Eingabefeld für "Ziel" angeben.

Beispiel: Scribble Papers wurde ins Verzeichnis "C:\Program Files\Scribble Papers" installiert. Sie möchten beim Start immer das Verzeichnis "H:\SP-Daten\" verwenden, wobei die Zugriffsart "nur lesend" sein soll. Als Wert für das Feld "Ziel" in der Verknüpfung zu Scribble Papers würden Sie folgendes eintragen:

"C:\Program Files\Scribble Papers\ScPapers.exe" /dr "H:\SP-Daten\"

Beispiele:

"C:\Program Files\Scribble Papers\ScPapers.exe" /dw "H:\SP-Daten\"

bewirkt den Start des Programms mit Schreibzugriff auf Verzeichnis "H:\SP-Daten\".

"C:\Program Files\Scribble Papers\ScPapers.exe" /d "H:\SP-Daten\" /id Page0000067

bewirkt den Start des Programms mit Verzeichnis "H:\SP-Daten\" und zeigt die Seite mit der ID Page0000067 an.

"C:\Program Files\Scribble Papers\ScPapers.exe" /d "H:\SP-Daten\" /id Fldr0000032

bewirkt den Start des Programms mit Verzeichnis "H:\SP-Daten\" und zeigt den Ordner mit der ID Fldr0000032 an.

"C:\Program Files\Scribble Papers\ScPapers.exe" "H:\SP-Daten\Page0001234.scp"

bewirkt den Start des Programms mit Verzeichnis "H:\SP-Daten\" und zeigt die Seite mit der ID Page0001234 an.

Tipp: Verwenden Sie die Funktionen für das Erzeugen von Desktop-Verknüpfungen im Dialog für die Programmeinstellungen (für Verknüpfungen auf Verzeichnisse) bzw. im Eigenschafts-Dialog für Ordner und Seiten (Menü Datei -> Eigenschaften bzw. Ordner -> Eigenschaften, Reiter "Info"). Die Zugriffsart (/dw oder /dr) können Sie bei Bedarf anschließend in der Verknüpfung anpassen.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis CHM-Hilfedokumentationsgenerator


Vorlagen

Scribble Papers ››

Menü: Ordner -> Eigenschaften

Tastaturkürzel : F6

Über die Funktion der Vorlage für neue Seiten können Sie neue Seiten beispielsweise mit einem einheitlichen Aufbau gestalten und häufig wiederkehrende Arbeiten innerhalb Scribble Papers vereinfachen und automatisieren. Eine mit Vorlage erzeugte neue Seite ist eine exakte Kopie mit allen Inhalten aus dieser Vorlage, inklusive Cursor-Position, Status und Stichwörtern.

Hier nur ein paar Anregungen für das Arbeiten mit Vorlagen:

• Verwenden Sie Scribble Papers als Datenbank für Adressen, CD's, Videokassetten etc. Legen Sie dafür eine Vorlage an, die eine Art Formular mit den wesentlichen Daten (z.B. "Interpret", "Titel", "Laufzeit", "Erscheinungsjahr" ...) enthält, so dass bei neuen Seiten nur noch die Daten eingegeben werden müssen.

• Verwalten und dokumentieren Sie anfallende Aufgaben auf Basis einer Vorlage, die als Formular für die Angaben zu "Beschreibung", "Kontaktpersonen", "Fälligkeit", "Links und Dokumente", "erledigt/offen", "Fertigstellung" etc. dient.

Wenn Sie verschiedenste Vorlagen für verschiedene Ordner verwenden, kann es sinnvoll sein, diese in einem eigenen Ordner ("Vorlagen") ablegen.

Sie können in der Vorlage Variablen definieren, die bei der Anlage einer neuen Seite auf Basis dieser Vorlage durch die entsprechenden Werte ersetzt werden. Folgende Variablen stehen zur Verfügung:

&TITLE | Titel der Seite (Text im Navigationsbaum bzw. auf dem Reiter
&USER | Benutzername
&STATE | Status der Seite
&FOLDER | Titel des Ordners
&PATH | Titel aller übergeordneten Ordner
&DAY | Wochentag
&DATE | Aktuelles Datum
&TIME | Aktuelle Uhrzeit
&KEYWORDS | Stichwörter

Mit dem Personal Edition von HelpNDoc erstellt: Elektronische Bücher einfach verfassen


Lesezeichen

Scribble Papers ››

Menü: Bearbeiten -> Lesezeichen

Tastaturkürzel : Strg + L

Seiten oder Ordner können als Lesezeichen definiert werden. Besonders bei umfangreichen Strukturen mit vielen Ordnern und Seiten können Sie über Lesezeichen direkter und schneller auf häufig verwendete oder wichtige Seiten oder Ordner zugreifen.

Es gibt zwei verschiedene Möglichkeiten, eine Seite oder einen Ordner als Lesezeichen zu definieren oder die Definition wieder zu löschen.

1.: Über die Schaltflächen "Neu" bzw. "Entfernen" im Dialogfenster Lesezeichen.

2.: In dem Dialogfenster Eigenschaften einer Seite oder eines Ordners über das Markierungsfeld "Lesezeichen".

Die Anordnung der Lesezeichen kann über die rechts neben dem Listenfeld verfügbaren Schaltflächen "Höher" und "Tiefer" variiert werden.

Die Aktivierung des Markierungsfeldes "Spalte 'Ordner': alle übergeordneten Ordner anzeigen?" bewirkt, daß für ein Lesezeichen der Name des kompletten Ordner-Pfades, also inklusive aller übergeordneten Ordner ausgewiesen wird. Ist das Markierungsfeld deaktiviert, wird nur der Name des direkt übergeordneten Ordners (bzw. bei einem Ordner als Lesezeichen nur der jeweilige Ordnername) ausgewiesen.

Die als Lesezeichen markierte Seite (bzw. Ordner) kann über die Schaltfläche "Anzeigen" oder über einen Doppelklick mit der Maus in der Liste angezeigt werden.

Mit dem Personal Edition von HelpNDoc erstellt: Kostenloser Qt Help-Dokumentationsgenerator


Stichwörter

Scribble Papers ››

Menü: Ansicht -> Stichwörter

Tastaturkürzel : Strg + W

Seiten und Ordner können mit Stichwörtern versehen werden. Die Zuordnung von Stichwörten zu Seiten und Ordnern kann in den Seiteneigenschaften bzw. den Ordnereigenschaften vorgenommen werden.

Die Vergabe von passenden Stichwörtern bietet folgende Vorteile:

1. Zeitersparnis bei der Suche nach Ihren Daten.

Oft ist es schneller, ein Ihnen bekanntes Stichwort einzugeben und darüber zu einer entsprechenden Seite oder einem Ordner zu navigieren als die Seite bzw. den Ordner im Navigationsbaum zu suchen und zu selektieren.

Bei der Suche nach Seiten und Ordnern ist die Suche über die Seiten- und Ordnernamen oft nicht ausreichend, so dass auch oft noch die Seiteninhalte durchsucht werden müssen. Diese Volltextsuche ist insbesonders bei großen Datenbeständen zeitaufwändig. Die Suche nach Stichwörtern ist erheblich schneller.

2. Eine andere Sichtweise auf Ihre Daten.

Über die Stichwörterliste oder die Suchfunktion können Sie sich eine andere Sichtweise auf Ihre Daten verschaffen, z.B. bei thematischer Überschneidung von Daten, die in unterschiedlichen Ordnerstrukturen angesiedelt sind. Über gemeinsame Stichwörter erhalten Sie so schnell eine Zusammenstellung dieser Daten.

Im Übersichts-Dialog sehen Sie im linken Bereich alle bisher verwalteten Stichwörter und im rechten Bereich eine Auflistung der Elemente, denen das selektierte Stichwort zugeordnet ist.

Die Liste der Stichwörter können Sie über Eingabe der ersten Zeichen eines Stichwortes positionieren. Wenn Sie nach einem Stichwort suchen, von dem Ihnen nur der "Mittelteil" bekannt ist, können Sie als erstes Zeichen im Eingabefeld ein * eingeben. Eine rote Einfärbung des Editierfeldes zeigt an, dass der eingegebene Begriff nicht in den Stichwörtern gefunden wurde.

Markierungsfeld "Verknüpfungen ausblenden?": Verknüpfungen haben immer dieselben Stichwörter wie die Originale, auf die sie verweisen. Hinsichtlich der Übersichtlichkeit der einem Stichwort zugeordneten Elemente kann es daher sinnvoll sein, die Verknüpfungen auszublenden.

Tipp: Die Stichwörter zu einer Seite können Sie sich schnell und komfortabel über das Markieren des Stichwortes im Text (ein Doppelklick markiert ein ganzes Wort) und die Funktion "Als Stichwort aufnehmen" im Kontextmenü (rechter Mausklick) zusammenstellen.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis Kindle-Hersteller


Drucken

Scribble Papers ››

Menü: Datei -> Drucken

Tastaturkürzel : Strg + D

Über diesen Button können Sie die aktuelle Seite ausdrucken. Die Einstellung des Druckers können Sie über Datei -> Drucker einrichten... , die Einstellung von Seitenrändern und Papierformat über Datei -> Seite einrichten... vornehmen.

Druckeroptionen wie z.B. die Wahl eines anderen Druckers oder Angabe einer Kopienanzahl können Sie über den Druckdialog nach Wahl des Menüpunktes Datei -> Drucken... einstellen. Bei Verwendung des Druck-Symbols in der Symbolleiste wird dieser Druckdialog nicht verwendet, sondern sofort auf den eingestellten Drucker gedruckt.

Weiterhin können Sie über Datei -> Seiteninfos im Ausdruck festlegen, ob Infos zur Seite in den Ausdruck mit aufgenommen werden sollen.

Den Umfang der Infos sowie das Layout können Sie über Veränderung der Datei "prnthead.rtf" selbst bestimmen (beachten Sie dazu auch die technischen / administrativen Hinweise ).

Die gleiche Datei wird auch verwendet, wenn die Seiteninfos beim Export in die exportierten Dateien aufgenommen werden sollen (Menü Datei -> Seiteninfos in Export-Datei).

Folgende Variablen für den Ausdruck stehen zur Verfügung:

&TITLE | Titel der Seite (Text im Navigationsbaum bzw. auf dem Reiter
&USER | Benutzername
&STATE | Status der Seite
&FOLDER | Titel des Ordners
&PATH | Titel aller übergeordneten Ordner
&DAY | Wochentag
&DATE | Aktuelles Datum
&TIME | Aktuelle Uhrzeit
&MODDATETIME | Datum und Uhrzeit der letzten Änderung
&KEYWORDS | Stichwörter

Wenn trotz markiertem Menüpunkt Datei -> Seiteninfos im Ausdruck keine Seiteninfos im Ausdruck erscheinen, ist die Datei "prnthead.rtf" nicht im Verzeichnis enthalten, in dem die Programmeinstellungen gespeichert werden. Gleiches gilt auch für die exportierten Dateien bei markiertem Menüpunkt Datei -> Seiteninfos in Export-Datei.

Mit dem Personal Edition von HelpNDoc erstellt: Plattformübergreifende Qt Help-Dateien erstellen


Importieren und Exportieren von Dateien

Scribble Papers ››

Menü: Datei -> Import/Export

Über die Importfunktion können Sie eine oder mehrere Dateien als neue Seiten in Scribble Papers importieren.

Standardmäßig werden Textdateien (Dateiendung TXT) und Dateien im RichText-Format (Dateiendung RTF) unterstützt. Weiterhin werden im System vorhandene Konverter verwendet, z.B. für Dateien vom Typ HTML oder DOC (Microsoft Word Dokumente). Umfang und Qualität der vorhandenen Konverter variieren innerhalb der einzelnen Windows-Versionen sowie in Abhängigkeit von einem vorhandenen MS-Office-Produkt.

Prinzipiell können aber auch Dateien mit anderen Dateiendungen importiert werden, sofern sie darstellbare bzw. lesbare Zeichen enthalten.

Verwenden Sie die Shift- und/oder Strg-Taste in Verbindung mit der Maus zum Markieren mehrerer Dateien.

Beachten Sie jedoch folgendes: um eine Konvertierung z.B. von einer HTML-Seite in eine Seite innerhalb Scribble Papers zu bewirken, müssen Sie den passenden Dateityp ausgewählt haben. Die Auswahl von "Alle Dateien (*.*)" bewirkt ein direktes Laden ohne Konvertierung, auch wenn eine oder mehrere HTML-Dateien selektiert wurden.

Über die Exportfunktion können Sie die aktuelle Seite oder alle Seiten eines Ordners als Datei(en) im Dateisystem ablegen. Auch hier werden standardmäßig Text- und RTF-Format unterstützt sowie im System vorhandene Konverter.

Die Exportfunktion ist dafür bestimmt, Ihnen die Weitergabe oder Weiterverarbeitung Ihrer Daten in einem der üblichen Standardformate zu ermöglichen. Für die Datensicherung ist sie nicht geeignet. Um Ihre Daten zu sichern, muß das gesamte Datenverzeichnis gesichert werden! Ausnahme: die Dateien "Readme.txt" und eine ggf. vorhandene Datei "lockdir.dat" müssen nicht gesichert werden.

Generell gilt für die Import- und Exportfunktion: nur in wenigen Fällen ist eine "verlustfreie" Konvertierung von oder in ein von RTF abweichendem Dateiformat möglich. Die Dateiformate sind dafür zu unterschiedlich. Während in dem in Scribble Papers verwendeten RTF-Format Grafiken und andere Objekte "eingebettet" werden, ist dieses z.B. in HTML nicht möglich. Dort werden derartige Objekte über Links auf weitere Dateien gehandhabt.

Die Konvertierung wird komplett durch die im System vorhandenen Konverter vorgenommen. Je nach "Ausstattung" (Aktualität und Qualität dieser Konverter) ist das Ergebnis mehr oder weniger zufriedenstellend. Beispielsweise ist das Ergebnis des Exports einer Seite mit einer Grafik ins HTML-Format auf einem Windows-2000-System mit installiertem MS-Office recht ordentlich (die Grafiken werden ins GIF-Format konvertiert und in die HTML-Seite verlinkt), auf einem System ohne MS-Office werden die Grafiken jedoch nicht konvertiert und fehlen dadurch in der erzeugten HTML-Seite.

Mit dem Personal Edition von HelpNDoc erstellt: Kindle eBooks mit Leichtigkeit generieren


Suchen

Scribble Papers ››

Menü: Datei -> Suchen

Tastaturkürzel : Strg + Alt + F

Mit diesem Dialog können Sie nach Seiten suchen, die einen von Ihnen gesuchten Text entweder im Namen, in den Stichwörtern oder im Inhalt der Seite enthalten. Zusätzlich können Sie nach Änderungsdatum oder Status suchen.

Ein Mausklick auf die einzelnen Bereiche des Dialogs zeigt weitere Informationen.

Ein Doppelklick mit der Maus auf einen Eintrag in der Ergebnisliste bewirkt die Anzeige der Seite.

Anmerkung: die Suche berücksichtigt - leider - nicht eingebettete Objekte .

Das Suchergebnis wird Ihnen auch im Hauptfenster angezeigt. Sie haben die Möglichkeit, während der Suche Ihre Arbeit in Scribble Papers fortzusetzen. Drücken Sie dazu die Schaltfläche "Schließen".

Die Suche nach Namen benötigt am wenigsten Zeit, dicht gefolgt von der Suche nach Stichwörtern . Das Durchsuchen des Inhaltes von Seiten benötigt am meisten Zeit. Bei großen Datenmengen kann sich daher eine sorgfältige Vergabe von Stichwörtern in den Seiteneigenschaften bzw. Ordnereigenschaften lohnen! Über die Stichwörter können Sie sich auch eine andere Sichtweise auf ihre Daten verschaffen, z.B. wenn die Daten zwar in unterschiedlichen Ordnerstrukturen angesiedelt sind aber trotzdem einen Bezug zueinander haben. So können Sie sich im Suchergebnis alle Seiten und Ordner auflisten lassen, denen ein gemeinsames Stichwort zugeordnet ist.

Mit dem Personal Edition von HelpNDoc erstellt: Hilfedokumente einfach erstellen


Suchergebnisse

Scribble Papers ››

Menü: Ansicht -> Suchergebnisse

Hier werden die gefundenen Seiten der letzten Suche angezeigt. Durch einen Doppelklick auf eine Zeile wird die jeweilige Seite angezeigt. Im Kontextmenü (rechte Maustaste) stehen weitere Funktionen wie Löschen, Verschieben, Umbenennen etc. zur Verfügung.

Suchergebnisse können auch gespeichert, gelöscht und umbenannt werden. Gespeicherte Suchergebnisse können über die Auswahlliste wieder angezeigt werden.

Die Funktionen dazu finden Sie im Menü Bearbeiten sowie über die Schaltflächen rechts von der Auswahlliste.

Tipp: In der Liste der gefundenen Seiten und Ordner haben Sie die Möglichkeit, Funktionen wie Löschen, Verschieben etc. für mehrere Seiten / Ordner gleichzeitig durchzuführen (das ist im Navigationsbaum nicht möglich). Markieren Sie dazu die entsprechenden Seiten / Ordner. Mehrfachmarkierungen sind mit während des Mausklicks gehaltener Strg-Taste (zusätzliche Selektion einzelner Einträge) bzw. gehaltener Shift-Taste (Selektion ganzer Bereiche) möglich. Drücken Sie anschließend die rechte Maustaste zur Auswahl der Funktion.

Mit dem Personal Edition von HelpNDoc erstellt: Einfacher CHM- und Dokumentationseditor


Textformate

Scribble Papers ››

Menü: Bearbeiten -> Textformat

Sie können die Textformatierung vereinfachen, indem Sie immer wiederkehrende Textformatierungen definieren und bei Bedarf wieder anwenden. Ein Textformat kann Textattribute (Schriftart, -größe, -farbe, Hintergrundfarbe) sowie Absatz attribute (Abstände und Einzüge, Ausrichtung, Nummerierung...) enthalten.

Anwenden: das aktuell gewählte Textformat wird auf den aktuell markierten Bereich in der Seite übertragen, d.h. Schriftart, -größe, Attribute wie fett, kursiv und unterstrichen werden so geändert, wie es im Textformat definiert wurde.

Anlegen: ein neues Textformat wird auf Basis des aktuell markierten Bereiches bzw. der Cursor-Position angelegt.

Ändern: das aktuell gewählte Textformat wird auf Basis des aktuell markierten Bereiches bzw. der Cursor-Position geändert.

Weitere Funktionen: Umbenennen und Löschen.

Scribble Papers enthält bereits einige vordefinierte Textformate. Diese können Sie nach Belieben ändern bzw. weitere Textformate anlegen.

Mit dem Personal Edition von HelpNDoc erstellt: CHM, PDF, DOC und HTML Hilfeerstellung von einer einzigen Quelle aus


Absatz

Scribble Papers ››

Menü: Bearbeiten -> Absatz...

Hier können Sie Einstellungen zur Absatzformatierung des aktuellen Absatzes vornehmen.

Einzug (in cm):

Erste Zeile: Abstand der ersten Zeile des Absatzes vom linken Rand.
Folgende: Absatz der folgenden Zeilen des Absatzes vom linken Rand. Sofern der Absatz mit einer Aufzählung oder Nummerierung versehen wurde, ist dieses der Abstand zwischen dem Aufzählungs-/Nummerierungszeichen und dem Text.

Rechts: Abstand der Zeilen des Absatzes vom rechten Rand.

Abstand (in cm):

Vor: Abstand vor dem Absatz

Nach: Abstand nach dem Absatz

Weiterhin können Sie den Zeilenabstand, die Ausrichtung (linksbündig / rechtsbündig / zentriert) einstellen sowie den Absatz mit einer Aufzählung oder Nummerierung versehen.

Hinweis: diese Funktion steht Ihnen nur zur Verfügung, wenn die Version des auf Ihrem System installierten RichEdit-Control > 1 ist. Die Versionsnummer wird Ihnen bei Wahl von Hilfe -> Info angezeigt.

Mit dem Personal Edition von HelpNDoc erstellt: Vorteile eines Hilfe-Entwicklungstools


Datensicherung

Scribble Papers ››

Wie auch Daten anderer Anwendungen sollten Sie Ihre Scribble Papers-Daten regelmäßig sichern!

Für die Daten wird ein Unterverzeichnis „\Scribble Papers“ beim ersten Start der Anwendung in Ihrem Verzeichnis für „Eigene Dateien“ angelegt. Sollten Sie den vollständigen Pfad nicht kennen, können Sie ihn sich in den Einstellungen (Bearbeiten -> Einstellungen -> Reiter „Allgemein“ -> „Verzeichnis für Daten“) anzeigen lassen. Sofern Sie noch weitere Datenverzeichnisse verwendet haben, können Sie diese in dem Listenfeld einsehen. Sichern Sie folgende Dateien des Verzeichnisses:

objprps.* | (Inhaltsverzeichnis aller Ordner und Seiten inkl. der Struktur)
Fldrprps.* | ( Ordnereigenschaften )
Page*.* | ( Inhalte der Seiten und Seiteneigenschaften )
bookmark*.* | ( Lesezeichen )
srchres.* | (gespeicherte Suchergebnisse )
keywords.* | ( Stichwörter von Seiten und Ordnern)
history.* | (Speicherung des Verlaufs der angezeigten Seiten, sofern in den Einstellungen markiert)

Außer den genannten Dateien sollten in dem Verzeichnis - sofern Sie keine anderen Dateien dort abgelegt haben, wozu ich nicht rate - lediglich noch die Datei „Readme.txt“ und, falls eine laufende Scribble Papers Anwendung gerade das Verzeichnis verwendet, eine Datei „lockdir.dat“ enthalten. Diese Dateien müssen nicht gesichert werden.

Im Programmverzeichnis existieren neben den Programmdateien noch folgende Dateien, deren Sicherung ratsam, aber nicht unbedingt erforderlich ist:

scpapers.stg | ( Programmeinstellungen , Fensterpositionen ...)
dirprps.* | (Einstellungen der Datenverzeichnisse )
Styles.* | ( Textformate )
prnthead.rtf | (Definition der Seiteninfos im Ausdruck )

Sofern Sie explizit ein anderes Verzeichnis für die Ablage der Einstellungen definiert haben (siehe Technische / administrative Hinweise ), werden diese Dateien in dem spezifizierten Verzeichnis abgelegt.

Mit dem Personal Edition von HelpNDoc erstellt: Hilfedateien für das Qt Help-Framework erstellen


Tipps

Scribble Papers ››

Verwenden Sie den Schreibschutz , um den Inhalt von Seiten vor unbeabsichtigter Änderung oder Löschung zu schützen. Wenn Sie die Seite dennoch gelegentlich ändern, können Sie den Schreibschutz schnell durch einen Doppelklick mit der Maus auf den rechten Bereich der Statuszeile umschalten.

Verwenden Sie Objekte in Ihren Seiten, um beispielsweise kleinere Tabellen in einer Seite darzustellen. Ihre Seiten gewinnen dadurch erheblich an Funktionalität.

Wenn Sie häufig auf dieselben Dokumente oder Dateien zugreifen, sollten Sie Hyperlinks auf diese Dateien in einer Seite ablegen statt sie immer über den Windows-/NT-Explorer mühsam zu suchen. Sie können Hyperlinks auch nutzen, um Querverweise innerhalb Ihrer Seiten und Ordner zu erzeugen. Dabei ist die Funktion Hyperlink in Zwischenablage im Kontextmenü (rechte Maustaste) des Navigationsbaumes sehr nützlich.

Verwenden Sie Textformate , um die Formatierung Ihres Textes zu vereinfachen und zu vereinheitlichen.

Versehen Sie ihre Seiten mit einem Status , um Wichtiges hervorzuheben, Vorgänge und Aufgaben zu klassifizieren und Ihre Seiten in differenzierter Form übersichtlich darzustellen.

Arbeiten Sie mit Kollegen in einem Netzwerk? Verwenden Sie gemeinsame Datenverzeichnisse, um Daten von allgemeinem Interesse zur Verfügung zu stellen, beispielsweise für Lösungsdatenbanken. Näheres finden Sie hier .

Wenn Sie mit mehreren Instanzen von Scribble Papers mit jeweils unterschiedlichen Datenverzeichnissen parallel arbeiten möchten, können Sie im Dialogfenster zu den Einstellungen ein Desktop-Symbol zu einem Datenverzeichnis anlegen. Bei Start von Scribble Papers über dieses Desktop-Symbol wird dann das ausgewählte Verzeichnis verwendet, unabhängig von dem zuletzt verwendeten Verzeichnis.

Schützen Sie Seiten mit sensiblen und vertraulichen Daten mit einem Passwort . Die zugrundeliegende Datei wird dadurch auch verschlüsselt, so dass die Daten absolut sicher sind. Die Verwendung eines Passwort-Schutzes können Sie in den Eigenschaften einer Seite festlegen.

Verwenden Sie die Kontextmenüs (rechte Maustaste!) im Navigationsbaum und im Editorbereich einer Seite, um einfacher auf häufig benutzte Funktionen zuzugreifen.

Sie können auch vorhandene Dateien als neue Seiten importieren . Wählen Sie dazu Datei -> Import/Export -> Seite(n) importieren. Im daraufhin erscheinenden Dialogfenster können Sie eine oder mehrere Dateien markieren, die dann als neue Seite in Scribble Papers angelegt werden.

Verwenden Sie die Shift- und/oder Strg-Taste in Verbindung mit der Maus zum Markieren mehrerer Dateien.

Auch der Export von Seiten ist möglich.

Sind Sie eingefleischter Tastaturfreund? Folgende Tastenkürzel sollten Sie unbedingt für die Navigation kennen:

F9 Wechsel zwischen Seiten und Navigationsbaum

Num+ Im Navigationsbaum: Ordner aufklappen

Num- Im Navigationsbaum: Ordner zuklappen

Cursor-Tasten: Wechsel im Navigationsbaum zu anderen Ordnern und Seiten

Alle Tastaturkürzel

Verwenden Sie Lesezeichen für einen direkten und schnellen Zugriff auf häufig verwendete Seiten und Ordner, besonders bei umfangreichen Strukturen mit vielen Ordnern und Seiten.

Über die Eigenschaften eines Ordners können neue Seiten von Ordnern unterschiedlich gestaltet und die Übersichtlichkeit verbessert werden.

Legen Sie ganze Dateien oder Verknüpfungen darauf in einer Seite ab. Das geht auch über den Windows-/NT-Explorer: markieren und ziehen Sie eine Datei oder eine Verknüpfung per Drag'n Drop in eine Scribble Papers Seite.

Das Datenverzeichnis kann an beliebiger Stelle irgendwo im Netzwerk liegen. Es können auch mehrere Verzeichnisse verwendet werden, beispielsweise für Laptop-Benutzer: ein lokales Datenverzeichnis auf der Festplatte des Laptops, ein Datenverzeichnis in einem Netzlaufwerk. Für Arbeitsgruppen ist es möglich, Verzeichnisse im Netzwerk für gemeinsame Daten zu nutzen. Eine einfache Netzwerkfunktion sorgt dafür, dass zeitgleich nur jeweils ein Benutzer die Daten verändern kann. Andere zeitgleich über Scribble Papers auf das Verzeichnis zugreifende Benutzer haben nur lesenden Zugriff.

Über Bearbeiten -> Einstellungen können Layout und Verhalten des Programms angepaßt werden.

Scribble Papers kann auch während Ihrer gesamten Arbeitszeit am PC permanent aktiv sein. Starten Sie das Programm über eine Verknüpfung in Ihrer Autostart-Gruppe automatisch beim Starten von Windows. Über die Einstellungen können Sie auch festlegen, wie Scribble Papers beim Starten dargestellt werden soll (minimiert, normal, Vollbild oder nur durch ein Symbol in der TNA (der Bereich in der Taskleiste, in dem u.a. die Uhrzeit angezeigt wird)).

Wenn Sie Daten einer anderen Anwendung in die Zwischenablage kopiert haben und das Einfügen in eine Seite nicht das gewünschte Ergebnis bringt, versuchen Sie es über Bearbeiten -> Inhalte einfügen. Vermutlich hat die andere Anwendung die Daten in verschiedenen Formaten in die Zwischenablage gestellt. Über Bearbeiten -> Inhalte einfügen können Sie dann das geeignetste Format auswählen.

Sie können bedenkenlos viele Ordner und Seiten verwalten. Die Menge der verwalteten Seiten hat so gut wie keinen Einfluß auf Ausführungsgeschwindigkeit und Speicherbedarf von Scribble Papers. Hunderte oder auch Tausende von Seiten stellen kein Problem dar.

Über Datei -> Suchen können Sie Ihre Seiten nach einem Text durchsuchen. Durch die Suchmöglichkeiten nach Status und / oder Änderungsdatum können Sie auch ohne Textangabe Seiten finden, die Sie erst kürzlich (z.b. heute oder am Vortag) geändert haben. Die Suchergebnisse können Sie speichern, so dass sie auch später noch verfügbar sind.

Die Suche nach Namen benötigt am wenigsten Zeit, dicht gefolgt von der Suche nach Stichwörtern. Das Durchsuchen des Inhaltes von Seiten benötigt am meisten Zeit. Bei großen Datenmengen kann sich daher eine sorgfältige Vergabe von Stichwörtern in den Seiteneigenschaften bzw. Ordnereigenschaften lohnen! Über die Stichwörter können Sie sich auch mittels der Suchfunktion eine andere Sichtweise auf ihre Daten verschaffen, z.B. wenn die Daten zwar in unterschiedlichen Ordnerstrukturen angesiedelt sind aber trotzdem einen Bezug zueinander haben.

Die Stichwörter zu einer Seite können Sie sich schnell und komfortabel über das Markieren des Stichwortes im Text (Doppelklick markiert ein ganzes Wort) und die Funktion "Als Stichwort aufnehmen" im Kontextmenü (rechter Mausklick) zusammenstellen.

In den Suchergebnissen haben Sie die Möglichkeit, Funktionen wie Löschen, Verschieben etc. für mehrere Seiten / Ordner gleichzeitig durchzuführen (das ist im Navigationsbaum nicht möglich). Markieren Sie dazu die entsprechenden Seiten / Ordner. Mehrfachmarkierungen sind mit während des Mausklicks gehaltener Strg-Taste (zusätzliche Selektion einzelner Einträge) bzw. gehaltener Shift-Taste (Selektion ganzer Bereiche) möglich. Drücken Sie anschließend die rechte Maustaste zur Auswahl der Funktion.

Nutzen Sie Verknüpfungen , wenn die Entscheidung für den "richtigen" Ordner für eine Seite schwierig erscheint. Verwenden Sie einen der in Frage kommenden Ordner für die Seite und legen Sie in den anderen in Frage kommenden Ordnern jeweils eine Verknüpfung ab. Nutzen Sie dazu die Menüfunktionen Datei -> Verknüpfung erstellen und Ordner-> Einfügen. Die Funktion zum Einfügen können Sie nacheinander in den Zielordnern verwenden ohne dass jedesmal erneut die Funktion Datei -> Verknüpfung erstellen verwendet werden muss. Die Funktionen stehen auch in den Kontext-Menüs (rechte Maustaste) zur Verfügung.

Technische Informationen (physikalische Datei einer Seite, Speicherbedarf) können über Eigenschaften, Reiter "Info" eingesehen werden, sowohl bei einzelnen Seiten als auch bei Ordnern.

Und zu guter Letzt: bitte denken Sie an die Spende für den guten Zweck , wenn Sie das Programm verwenden. Die Spende ist steuerlich voll absetzbar, d.h. Sie können den Erwerb dieser Software steuerlich geltend machen, auch wenn Ihnen das sonst nicht möglich sein sollte.

Mit dem Personal Edition von HelpNDoc erstellt: Hilfedateien für das Qt Help-Framework erstellen


Verwendung anderer Icons

Scribble Papers ››

Scribble Papers kann anstelle der standardmäßig enthaltenen Icons auch andere Icons für Schaltflächen und Status verwenden. Voraussetzung dafür ist

• pro Schaltfläche / Status eine Grafikdatei im BMP-Format (Bitmap)

• eine Icon-Definitionsdatei, in der die Zuordnung einer Grafikdatei zu einer Schaltfläche bzw. einem Status getroffen wird.

Die Aktivierung auf Basis einer Icon-Definitionsdatei wird in den Einstellungen im Reiter "Layout" vorgenommen. Dort ist das Markierungsfeld "Andere Icons verwenden" zu aktivieren und im darunter angeordneten Eingabefeld die Icon-Definitionsdatei anzugeben. Die Datei kann auch über die rechts vom Eingabefeld angeordnete Schaltfläche im Dateisystem ausgewählt werden.

Die Schaltflächen bieten Platz für Grafiken bis zu einer Größe von 25x25 Pixel. Bei dieser Größe bleibt dann allerdings kein Rand mehr über, so daß die Grafik die Schaltfläche vollständig ausfüllt, was die Übersichtlichkeit verschlechtert. Ich empfehle eine maximale Größe von 20x20 Pixel.

Die Farbtiefe kann frei gewählt werden, wobei jedoch eine Farbtiefe größer als 256 Farben wenig sinnvoll ist und zudem unnötig Speicherplatz benötigt.

Die Grafiken können mit geeigneten Bildbearbeitungsprogrammen erstellt werden. Damit die Grafiken sich in die Benutzeroberfläche störungsfrei einfügen, sollten sie "transparent" gezeichnet werden können. Nur so bleibt der übliche Hintergrund hinter der Grafik auf den Schaltflächen, auf den Reitern und im Navigationsbaum erhalten. Die Farbe, die für die Transparenz verwendet werden soll, wird in der Grafikdatei im unteren linken Pixel definiert. Alle Pixel, die die gleiche Farbe enthalten, werden dadurch transparent.

Die Icon-Definitionsdatei muß lesbaren Text enthalten, die Dateiendung .spi haben und nach folgendem Schema aufgebaut sein:

[Icons]

Symbol-ID=Grafikdatei

Symbol-ID=Grafikdatei

...

Hier ein Beispiel:

[Icons]

OK=OKAY.bmp

CANCEL=CANCEL.bmp

HELP=HELP.bmp

INFO=INFO.bmp

EXIT=EXIT.bmp

...

Wenn die Grafikdatei ohne Pfad angegeben ist, wird das Verzeichnis verwendet, in dem sich auch die Icon-Definitionsdatei befindet. Um auf Grafikdateien in anderen Verzeichnissen zu verweisen, muß der vollständige Pfad mit angegeben werden.

Wird eine Grafikdatei nicht gefunden, wird die Schaltfläche bzw. das Symbol weiterhin mit der vorigen Einstellung angezeigt. Es erfolgt keine Fehlermeldung zu der nicht gefundenen Grafikdatei. Es besteht nicht die Notwendigkeit, jede Schaltfläche in der Icon-Definitionsdatei zu spezifizieren. In dem Fall wird die Schaltfläche weiterhin mit dem vorigen Icon bzw. dem Standard-Icon angezeigt.

Um von eigenen Icons wieder auf die Standard-Icons des Programms zurückzuschalten, muß die Markierung bei "Andere Icons verwenden" deaktiviert und das Programm beendet und neu gestartet werden.

Für die Definition zusätzlicher Status und zugehöriger Icons lesen Sie bitte diesen Abschnitt:

Verwendung zusätzlicher Status

Liste aller Symbol-Id's:

Symbol-ID | Standard-Symbol | Bedeutung
OK |  | OK
CANCEL |  | Abbrechen
HELP |  | Hilfe
DOCU |  | Programmdokumentation
INFO |  | Info
EXIT |  | Schließen
SHOW |  | Anzeigen
BACK |  | Vorige Seite
FORWARD |  | Nächste Seite
NEWPAGE |  | Neue Seite
RENAME |  | Umbenennen
DELETE |  | Löschen
SEARCH |  | Suchen (von Seiten / Ordnern)
UP |  | Höher
DOWN |  | Tiefer
COPYPAGE |  | Seite kopieren
PRINT |  | Drucken
NEWFOLDER |  | Neuer Ordner
COPYFOLDER |  | Ordner kopieren
SORT |  | Sortieren
UNDO |  | Rückgängig
REDO |  | Wiederherstellen
CUT |  | Ausschneiden
COPY |  | Kopieren
PASTE |  | Einfügen
FIND |  | Suchen (innerhalb einer Seite)
OBJECT |  | Objekt einfügen
LINK |  | Hyperlink einfügen
BOOKMARKS |  | Lesezeichen
KEYWORDS |  | Stichwörter
TRAY |  | Schließen, -> TNA
SWITCHACCESS |  | Umschalten Voll-/Lesezugriff
BOLD |  | Fett
ITALIC |  | Kursiv
UNDERLINE |  | Unterstreichen
STRIKETHROUGH |  | Durchstreichen
FORMATCOPY |  | Format übertragen
ALIGNLEFT |  | Linksbündig
ALIGNRIGHT |  | Rechtsbündig
ALIGNCENTER |  | Zentriert
INDENTLEFT |  | Einzug verkleinern
INDENTRIGHT |  | Einzug vergrößern
BULLET |  | Aufzählungszeichen
RESET |  | Hintergrundfarbe zurücksetzen
STYLEAPPLY |  | Textformat anwenden
ADDBOOKMARK |  | Neues Lesezeichen einfügen
SAVE |  | Speichern
TOPFOLDER |  | Oberster Ordner
TRASHFOLDER |  | Papierkorb
LOCK |  | Schreibschutz
STAT_UNDEF_PAGE |  | Status "unbestimmt" (Seite)
STAT_UNDEF_FOLDER |  | Status "unbestimmt" (Ordner)
STAT_NOTFINISHED |  | Status "unerledigt"
STAT_INPROCESS |  | Status "in Bearbeitung"
STAT_FINISHED |  | Status "erledigt"
STAT_NOTCRITICAL |  | Status "unkritisch"
STAT_PROBLEMATIC |  | Status "problematisch"
STAT_CRITICAL |  | Status "kritisch"
STAT_LOWPRIO |  | Status "niedrige Priorität"
STAT_NORMPRIO |  | Status "normale Priorität"
STAT_HIGHPRIO |  | Status "hohe Priorität"
STAT_IMPORTANT |  | Status "Wichtig!"
STAT_CONCLUSION |  | Status "Zusammenfassung"
STAT_QUESTION |  | Status "Frage"
STAT_INFORMATION |  | Status "Information"

Mit dem Personal Edition von HelpNDoc erstellt: Qt Help-Dateien auf einfache Weise erstellen


Verwendung zusätzlicher Status

Scribble Papers ››

Scribble Papers enthält einige vordefinierte Status. Sie können die Status und deren Icons jedoch erweitern. Dazu müssen die gewünschten zusätzlichen Status manuell mit einem Texteditor in der Datei "scpapers.stg" eingetragen werden. Für jeden zusätzlichen Status sollten Sie ein entsprechendes Icon in Form einer Grafikdatei im BMP-Format (Bitmap) angeben. Die Grafikdatei sollte bzgl. Größe und Farbtiefe den vordefinierten (bzw. bei Verwendung anderer Icons den jeweiligen Grafikdateien) entsprechen.

Empfehlung: Größe 16x16 - 20x20 Pixel, Farbtiefe 16 - 256 Farben.

Die Grafiken können mit geeigneten Bildbearbeitungsprogrammen erstellt werden. Damit die Grafiken sich in die Benutzeroberfläche störungsfrei einfügen, sollten sie "transparent" gezeichnet werden können. Nur so bleibt der übliche Hintergrund hinter der Grafik auf den Schaltflächen, auf den Reitern und im Navigationsbaum erhalten. Die Farbe, die für die Transparenz verwendet werden soll, wird in der Grafikdatei im unteren linken Pixel definiert. Alle Pixel, die die gleiche Farbe enthalten, werden dadurch transparent.

Die Definition in der Datei "scpapers.stg" muß dem folgenden Schema entsprechen:

[AdditionalStatus]

Statustext=Grafikdatei

...

Hier ein Beispiel:

[AdditionalStatus]

Notiz / Anmerkung=annotation.bmp

Positiv=positive.bmp

Negativ=negative.bmp

Eingang=in.bmp

Ausgang=out.bmp

Geprüft / Fehlerfrei=checked.bmp

Fehlerhaft=failure.bmp

...

Durch die Speicherung einer Datei "scpapers.stg" mit der Definition zusätzlicher Status im jeweiligen Datenverzeichnis können pro Datenverzeichnis auch unterschiedliche Status verwendet werden. Ist im Datenverzeichnis eine Datei "scpapers.stg" vorhanden, wird die Definition der zusätzlichen Status daraus verwendet, ansonsten gelten die Definitionen der "allgemeinen" Datei.

Wenn die Grafikdatei ohne Pfad angegeben ist, wird das Verzeichnis verwendet, in dem sich auch die Datei "scpapers.stg" befindet. Um auf Grafikdateien in anderen Verzeichnissen zu verweisen, muß der vollständige Pfad mit angegeben werden.

Wird eine Grafikdatei nicht gefunden, wird kein Icon für den entsprechenden Status angezeigt. Es erfolgt keine Fehlermeldung zu der nicht gefundenen Grafikdatei.

Mit dem Personal Edition von HelpNDoc erstellt: Einfacher CHM- und Dokumentationseditor


Tastaturkürzel

Scribble Papers ››

Den meisten Funktionen ist ein Tastaturkürzel zugeordnet, so daß die Funktionen auch während der Textbearbeitung direkt und ohne Verwendung der Maus ausgeführt werden können.

Menü "Datei"
Strg+N | Neue Seite anlegen
F2 | Seite umbenennen
Strg + Alt + F | Suchen von Seiten / Ordnern
F4 | Eigenschaften der Seite
Strg + D | Seite drucken
Strg + T | Schließen, -> TNA
Menü "Ordner"
Umschalt + F2 | Neuen Ordner anlegen
Strg + F2 | Ordner umbenennen
F6 | Eigenschaften des Ordners
Menü "Bearbeiten"
Strg + Z | Rückgängig
Strg + Y | Wiederherstellen
Strg + X | Ausschneiden
Strg + C | Kopieren
Strg + V | Einfügen
Strg + I | Inhalte einfügen
Strg + A | Alles markieren
Strg + Umschalt + S | Textformat anwenden
Strg + H | Hyperlink einfügen
Strg + P | Objekt einfügen
F5 | Datum / Zeit einfügen
Strg + L | Lesezeichen
Strg + F | Suchen
Strg + G | Ersetzen
Strg + O | Einstellungen
Menü "Ansicht"
F7 | Vorige Seite
F8 | Nächste Seite
Strg + W | Stichwörter
Menü "Hilfe"
F1 | Programmdokumentation / Hilfe
Weitere
Strg + Umschalt + F | Fettschrift an/aus
Strg + Umschalt + K | Kursivschrift an/aus
Strg + Umschalt + U | Unterstreichen an/aus
Strg + Umschalt + D | Durchstreichen an/aus
Entf | Ordner bzw. Seite löschen *
F9 | Wechsel zwischen Navigationsbaum -> Seite -> Suchergebnisliste
Strg + Tab | Wechsel zum nächsten Reiter
Strg + Umschalt + Tab | Wechsel zum vorigen Reiter
F12 | Speichern der aktuellen Seite
ESC | Schließt ein geöffnetes Dialogfenster (entspricht dem Abbrechen)
Num+ | Im Navigationsbaum: Aufklappen des selektierten Ordners
Num- | Im Navigationsbaum: Zuklappen des selektierten Ordners
Nur bei RichEdit-Control ab Version 3:
Strg + Umschalt + A | Umschalten Groß-/Kleinschrift
Strg + Umschalt + L | Umschalten des Aufzählungszeichens
Strg + 1 | Zeilenabstand 1-fach
Strg + 2 | Zeilenabstand 2-fach
Strg + 5 | Zeilenabstand 1,5-fach
Strg + Umschalt + , | Schriftart verkleinern
Strg + Umschalt + . | Schriftart vergrößern
Strg + + | Umschalten tiefgestellte Zeichen
Strg + Umschalt + + | Umschalten hochgestellte Zeichen

Tastaturfunktionen innerhalb einer Tabelle

Nur bei RichEdit-Control ab Version 3. Scribble Papers ermöglicht selbst nicht die Erstellung von Tabellen, jedoch lassen sich für aus anderen Anwendungen eingefügte Tabellen Tastaturfunktionen des RichEdit-Control verwenden. Für die Navigation innerhalb einer Tabelle werden die Cursortasten bzw. die TAB-Taste verwendet.

Tabellenzeile am Ende hinzufügen | In die letzte Zelle wechseln und TAB drücken
Tabellenzeile hinzufügen | Hinter das Ende der Zeile klicken und ENTER drücken
Zeile löschen | Zeile mit der Maus markieren (über den Tabellenrand hinaus) und Entf drücken
Tabellen teilen | Gesamte Zeile markieren und ENTER drücken. Dabei wird allerdings die markierte Zeile gelöscht!
Tabellen zusammenführen | Text zwischen den zwei Tabellen löschen
Text oberhalb einer Tabelle hinzufügen, die am Seitenanfang beginnt | In die erste Zelle wechseln und ENTER drücken

*) Dazu muß der "Fokus" im Navigationsbaum liegen, d.h. Sie müssen ggf. mit F9 zwischen Seite bzw. Suchergebnis in den Navigationsbaum wechseln.

Mit dem Personal Edition von HelpNDoc erstellt: Einfacher CHM- und Dokumentationseditor


Versionshistorie

Scribble Papers ››

2.10.2 (11.03.2018)

Fehlerbehebung:

  • bei der Verwendung anderer Icons für die Ordner-/Seitenstatus .

Detailverbesserungen:

  • Variable &MODDATETIME (Datum und Uhrzeit der letzten Änderung) in der Druckfunktion

2.10.1 (14.12.2017)

Fehlerbehebung:

  • beim Wechsel von einer laufenden Suche zur Stichwortliste traten ggf. Fehler auf.

Detailverbesserungen:

  • Automatische Ausrichtung der Symbolleisten bei einer Größenänderung des Hauptfensters (in den Einstellungen an-/abschaltbar)

2.9.2 (26.03.2016)

Fehlerbehebung:

  • in Zusammenhang mit der Wiederherstellung von Verknüpfungen aus dem Papierkorb
  • bzgl. Anlage neuer Seiten im falschen Ordner

Detailverbesserungen:

  • Deutlichere Erkennung des aktiven Knotens im Navigationsbaum (Hintergrundfarbe in den Einstellungen wählbar)
  • Variable &DAY (Wochentag) in Vorlagen und beim Drucken

2.9.1 (18.03.2015)

Neue Funktionen:

• Anzeige der Zeichentabelle für das Einfügen von Sonderzeichen

• "Format übertragen"-Funktion für mehrere Textpassagen verwendbar

Fehlerbehebung:

• im Zusammenhang mit "Schutzklasse 1" geschützter Seiten

• im Zusammenhang mit der Auswahl eines Datums in der Suchfunktion.

2.8.3 (29.05.2014)

Fehlerbehebung:

• Fehler in der "Ersetzen"-Funktion

2.8.2 (10.04.2014)

Fehlerbehebung:

• Fehler beim Anordnen (höher/tiefer) von Elementen

2.8.1 (22.02.2014)

Mit der Version 2.8.1 wurde Scribble Papers in eine neuere Entwicklungsumgebung überführt.

Neue Funktionen:

• Die Anzeige der Reiter ist in den Einstellungen bzw. Ordnereigenschaften deaktivierbar.

• Die Symbolleisten können jetzt flexibel (oben / unten / rechts / zwischen Navigationsbaum und dem Editierbereich) platziert werden.

• Passwortschutz : wiederholte Eingaben gleicher Passwörter können durch ein Markierungsfeld "Passwortliste verwenden" vermieden werden.

Detailverbesserungen. U.a.:

• Definition zusätzlicher Status individuell für die einzelnen Datenverzeichnisse möglich.

Fehlerbehebung

• im Zusammenhang mit der Löschung von Verknüpfungen

• im Zusammenhang mit der Vermeidung konkurrierender Zugriffe bei Betrieb unter Windows Terminal Server

2.7.1 (01.01.2012)

Neue Funktionen:

• Erweiterung der Textformate (können wahlweise Text- und/oder Absatz attribute enthalten)

• Zusätzliche Einstellung : Speichermöglichkeit des Verlaufs der angezeigten Seiten

Detailverbesserungen (u.a. keine Beschränkung mehr auf max. 900 Seiten in einem Ordner)

2.6.1 (25.07.2010)

Neue Funktionen:

• Für Absätze können Einzüge, Abstände und verschiedene Nummerierungsformen eingestellt werden.

• Popup-Menü in der Verlaufsliste mit Funktionen "Anzeigen" und "Hyperlink in Zwischenablage"

• Erweiterung der Einstellungen um eine Sicherheitsabfrage vor Sortierung eines Ordners

• Alternative Dateinamenserweiterung für Scribble Papers - Dateien möglich (z.B. ".rtf", um die Dateien Desktop-Suchmaschinen zugänglich zu machen), siehe Technische / administrative Hinweise , Abschnitt 2.

• Einbindung eines (Firmen-)Logos möglich, siehe Technische / administrative Hinweise , Abschnitt 3.

Fehlerbehebung:

• Beim Einfügen von Hyperlinks zu Verzeichnissen funktionierte die Verwendung relativer Pfade nicht.

2.5.1 (27.08.2009)

Neue Funktionen:

• " Format übertragen " zum schnellen Übertragen von Textattributen auf einen anderen Textbereich

• " Ansicht -> Verlauf " listet die vorher angezeigten Seiten an, ein Klick auf eine dieser Seiten zeigt sie an

• Option "Verknüpfungen ausblenden" in der Stichwörterliste

Fehlerbehebung:

• die Festlegung einer als Vorlage zu verwendenden Seite in den Ordnereigenschaften ging beim Verschieben der Seite verloren.

Verwendung anderer Standard-Icons im Programm

2.4.1 (30.11.2008)

Neue Funktionen:

• Verknüpfungen

Fehlerbehebung:

• die "Drucken"-Funktion im Kontextmenü des Editorbereiches funktionierte nicht;

• beim Anzeigen einer Seite über die Suchergebnisliste wurde ggf. nicht der Suchbegriff markiert.

2.3.2 (16.03.2008)

Fehlerbehebung:

• irreführende Fehlermeldung beim Einfügen von Hyperlinks

2.3.1 (02.03.2008)

Neue Funktionen:

• Neue Seiteneigenschaft : Passwortschutz kopieren

• Neuer Hyperlink -Typ: Eintrag in der Stichwortliste

Fehlerbehebung:

• Ggf. fehlerhafte Positionierung des Hauptfensters nach einer Änderung der Bildschirmauflösung sowie bei Betrieb mehrerer Monitore

• Beim Kopieren von Ordnern und Seiten wurden die Stichwörter nicht mitkopiert.

Detailverbesserungen

2.2.1 (16.10.2007)

Neue Funktionen:

• Text der Titelleiste des Hauptfensters verwaltbar (für verschiedene genutzte Datenverzeichnisse )

• Neue Ordnereigenschaft : Neue Elemente am Anfang des Ordners einfügen

• Erweiterung der Stichwörter -Funktionen (Übersichts-/Auswahlliste)

• Erweiterung der Vorlagen -Funktion (Variablen für Seiteninformationen)

Detailverbesserungen

2.1.2 (08.06.2007)

Fehlerbehebung:

• Der Programmstart unter Windows XP mit installiertem Servicepack 2 und den Patches KB925902 und KB928893 scheitert mit der Fehlermeldung "Die System-Dll "user32.dll" wurde im Speicher verschoben...".
Der Fehler wird durch den Patch KB935448 von Microsoft behoben. Neben Scribble Papers sind von dieser Patch-Konstellation auch andere Programme betroffen. Die Version 2.1.2 umgeht diesen Fehler.

• Bei RichEdit-Vers ion >= 10 waren einige von der RichEdit-Version abhängige Funktionen nicht verfügbar.

2.1.1 (06.06.2007)

Neue Funktionen:

• Stichwörter : Seiten und Ordner können mit Stichwörtern versehen werden, Erweiterung der Suchfunktion

Programmdokumentation jetzt im CHM-Format (vorher: HLP-Format)

Detailverbesserungen

2.0.1 (27.01.2007)

Neue Funktionen:

• Definition zusätzlicher Status möglich

• Ansicht vergrößern / verkleinern

Detailverbesserungen

1.9.1 (27.02.2006)

Neue Funktionen:

• Suchfunktion erweitert (Suche in Ordnernamen, Option für Berücksichtigung Passwort-geschützter Seiten, Speichermöglichkeit der Suchergebnisse)

• Mehrfachselektion von Ordnern und/oder Seiten im Suchergebnis für Löschen / Verschieben / Drucken in einem Schritt möglich

• Import-/Export-Funktionen: Berücksichtigung der mit MS-Word 2003 installierten Konverter

• Statusleiste ausblendbar

• Erweiterung der Programmparameter (für Start mit einer bestimmten Seite o. einem bestimmten Ordner)

• Verwendung anderer Icons anstelle der Standard-Icons möglich

• Neue Ordnereigenschaft: Automatisches Sortieren

• Erweiterung bei den Programmeinstellungen

Fehlerbehebung:

• bei Verwendung von Scribble Papers auf einem USB-Stick / einer Wechselfestplatte

Detailverbesserungen

1.8.1 (09.06.2004)

Neue Funktionen:

• Kopieren von Ordnern und Seiten

• Seiteninfos im Ausdruck (optional, Menüfunktion Datei -> Seiteninfos im Ausdruck)

Fehlerbehebung:

• im Zusammenhang mit der Sortierung von Suchergebnissen

• bei Hyperlinks auf den obersten Ordner bzw. den Papierkorb

Detailverbesserungen

1.7.2 (15.04.2004)

Fehlerbehebung:

• Größe und Position des Suchformulars wurden nicht gespeichert

1.7.1 (25.03.2004)

• Erweiterung der Export -Möglichkeiten (Export aller Seiten eines Ordners)

• Frei definierbare Textformate für die Vereinfachung und Vereinheitlichung bei der Textformatierung

• Erweiterung der Suchfunktion :

• Suche nach Änderungsdatum und / oder Status

• Suchen im Suchergebnis (Verfeinern der Suche)

• Sortierung des Suchergebnisses (alphabetisch auf-/absteigend)

• Integration des Suchergebnisses ins Hauptfenster

Kleinere Optimierungen und Funktionserweiterungen:

• Neue Funktion "Inhalte einfügen" im Kontextmenü des Editierbereiches

• Als (nur lesbares) Datenverzeichnis kann auch eine CD / DVD verwendet werden.

• Neue Funktion Hyperlink in Zwischenablage

• Passwortschutz "Schutzklasse 2"

• Kleinere Änderungen der Tastaturkürzel

• Benutzerspezifische Einstellungen

1.6.1 (06.05.2003)

Neue Funktionen:

• Verbesserung der Import-/Export-Möglichkeiten (HTML, DOC, ..., abhängig von der Windows-Systemumgebung)

• Ordner können jetzt ebenfalls mit einem Status versehen werden.

Behebung kleinerer Fehler sowie kleinere Optimierungen.

1.5.1 (06.04.2003)

Neue Funktionen:

• Schutz von Seiten mit Passwort und Datei-Verschlüsselung.

• Hyperlinks auf Dateien und Verzeichnisse können alternativ zur absoluten Pfadangabe mit relativem Pfad oder UNC-Notation eingefügt werden.

• Der Start des Programms wurde beschleunigt (erheblich schnellerer Start besonders bei vielen Ordnern und Seiten)

• Programmstart mit fixem Datenverzeichnis (Desktop-Symbol bei Verzeichnisangabe)

• Verbesserung der Druckfunktion (einstellbare Seitenränder, keine Verwendung mehr von "WordPad")

• Erweiterung der Suchfunktion (nach Seiten) um Einstellungen für "Ganzes Wort" und "Groß-/Kleinschreibung"

• Neue Einstellungsmöglichkeit "Gruppenverzeichnis", bewirkt die Protokollierung des letzten Änderers einer Seite

• Neue Funktion "Ordner | Alle zuklappen"

• Importfunktion ermöglicht den Import mehrerer Dateien

1.4.2 (19.07.2002)

Fehlerbehebung:

• im Dialogfenster für Seiten-Eigenschaften bei der Festlegung des Layout neuer Seiten

• in der „Lesezeichen"-Funktion

Weiterhin wurden das Verschieben von Seiten mit der Maus verbessert (jetzt auch „Drag'n Drop" eines 'Reiters' in den Navigationsbaum hinein) sowie kleinere Optimierungen durchgeführt.

1.4.1 (24.05.2002)

Neue Funktionen:

• Seiten können als Vorlage für neue Seiten verwendet werden.

• „Lesezeichen"-Funktion für schnellen Zugriff auf häufig benutzte Seiten oder Ordner

• Erweiterung der Suchfunktion für Seiten: logische Verknüpfung über "und / oder" mit einem zweiten (optionalen) Suchbegriff

• Zusätzliche Einstellungsmöglichkeit: "Minimieren in TNA (Taskbar Notification Area)"

• Neue Funktion "Alles aufklappen" (Aufklappen eines Ordners inkl. aller untergeordneten Ordner)

• Zusätzliche Schaltflächen auf der Symbolleiste für: "Datei | Suchen", "Bearbeiten | Lesezeichen" und "Ansicht | Navigationsbaum"

• Verwendung des Dateinamens als Seitenname beim Import / Export

• Tastaturkürzel erweitert („F9" für Wechsel zwischen Seiten und Navigationsbaum, „ESC" für Schliessen von Dialogfenstern).

1.3.1 (03.01.2002)

Neue Funktion:

• In den Einstellungen kann festgelegt werden, ob die Cursorposition und -markierung gespeichert / wiederhergestellt werden soll.

Fehlerbehebung:

• in Verbindung mit der Festlegung des Layout neuer Seiten.

1.2.1 (18.12.2001)

Neue Funktion:

• Seiten können bereits bei der Anlage mit einem Status versehen werden.

Fehlerbehebung:

• in Verbindung mit der Suchen- / Ersetzen-Funktion.

• bei Verwaltung großer Ordnerstrukturen (nur bei Windows 9x)

1.1.1 (26.01.2007)

Neue Funktionen:

• Seiten können zur unterschiedlichen Darstellung und Klassifizierung mit einem Status versehen werden.

• Auf Datenverzeichnisse kann (zwecks Vereinfachung der Handhabung gemeinsamer Datenverzeichnisse für Arbeitsgruppen) wahlweise verändernd oder nur lesend zugegriffen werden.

1.0.3 (06.11.2001)

Diese Version behebt lediglich einen Programmfehler, sie enthält keine neuen Funktionen gegenüber der Version 1.0.2. Die Programmgröße wurde geringfügig reduziert, bedingt durch das Entfallen von Programmcode für den Upgrade von alten Versionen (bis Vers. 0.8.2.). Sofern vorher Scribble Papers Version 0.9.1 oder höher verwendet wurde, ist das Installieren dieser Version über die vorher installierte Version problemlos möglich.

1.0.2 (25.10.2001)

Diese Version behebt im Wesentlichen geringfügige Fehler der Version 1.0.1 (teilweise auch in älteren Versionen vorhanden). Die Kontextmenüs zum Navigationsbaum und zu einer Seite wurden geringfügig erweitert, ebenso wie die Online-Hilfe. Die Version 1.0.2 enthält keine neuen Funktionen gegenüber der Version 1.0.1.

1.0.1 (01.10.2001)

Neue Funktionen:

• Funktion für Einfügen von Datum und / oder Uhrzeit.

• Funktion „Alles markieren".

• Funktion „Ordner sortieren".

• Hyperlinks sind jetzt auch auf Ordner und Seiten innerhalb von Scribble Papers möglich.

• Tastaturkürzel überarbeitet.

• Symbolleiste erweitert.

0.9.2 (29.08.2001)

Behebung folgender Fehler (keine neuen Funktionen):

• Kontextmenüs haben Anlage von Ordner und Seiten erlaubt, auch wenn das Datenverzeichnis nur zum Lesen zur Verfügung stand.

• Löschen eines Eintrages im Listenfeld für verwendete Datenverzeichnisse war wirkungslos.

• Fehlermeldung beim Herunterfahren des Systems, wenn die Anwendung noch aktiv ist (nur Windows 95 / 98).

• Programmfehler im Zusammenhang mit Ländereinstellungen in Windows (Änderungen an den Ländereinstellungen in Windows während laufender Anwendung / Nutzung gemeinsames Verzeichnis mit anderen Anwendern, deren System anders eingestellt ist).

0.9.1

Neue / geänderte Funktionen:

• Verzeichnis für Datenablage frei wählbar, mehrere Verzeichnisse möglich. Zugriffsmöglichkeit mehrerer Anwender auf ein zentrales Datenverzeichnis.

• Ordnereigenschaften (Layout neue Seiten, Zeilenumbruch Reiter)

• Import / Export einzelner Seiten

• Erweiterungen der Einstellungen (Meldungen, Schreibschutz)

• „Wiederherstellen"-Funktion

• Besseres Installationsprogramm

0.8.2

Erste öffentliche Version

Mit dem Personal Edition von HelpNDoc erstellt: EPub-Bücher für das iPad verfassen


RichEdit-Control

Scribble Papers ››

Scribble Papers nutzt das sogenannte "RichEdit-Control" zum Editieren und Speichern der Seiten. Dieses RichEdit-Control ist ein im Windows-System vorhandenes Objekt zur Interaktion mit dem Benutzer, (fast) genauso wie Menüs, Buttons, Editierfelder, Listboxen etc.

In einem Punkt allerdings unterscheidet sich das RichEdit-Control von den anderen Windows-Objekten. Es ist in einer separaten "DLL" enthalten, die je nach Versionsstand ein mehr oder weniger funktionsreiches RichEdit-Control mit sich bringt. Sollte auf Ihrem Rechner ein älteres Windows 95 installiert sein, liegt das RichEdit-Control vermutlich in Version 1 vor. Diese Version hat gegenüber der Version 2 (Windows 98, Windows NT 4.0 oder höhere Windows-Versionen) folgende Einschränkungen:

• Veränderungen zurücknehmen (Menü: Bearbeiten / Rückgängig) funktioniert nur für die letzte Veränderung. Änderungen an der Seite davor können nicht zurückgenommen werden. Mit der Version 2 wurde diese Beschränkung aufgehoben.

• Der praktische Nutzen durch Ausführen eines Hyperlink über einen einfachen Mausklick entfällt. Hyperlinks werden vom RichEdit-Control Version 1 weder erkannt noch andersfarbig gekennzeichnet.

• Text kann nicht mit einer Hintergrundfarbe (Textmarker) versehen werden. Das entsprechende Symbol steht Ihnen daher in der Symbolleiste für Textformatierung nicht zur Verfügung.

Mit Version 3 wurde der Funktionsumfang noch erweitert, z.B. um eine " Zoom "-Funktion.

Beachten Sie dazu auch den Abschnitt " Tastaturkürzel ".

Im Menüpunkt Hilfe -> Info wird Ihnen die Version des in Ihrem System vorhandenen RichEdit-Controls angezeigt.

Mit dem Personal Edition von HelpNDoc erstellt: Funktionsreicher EBook-Editor


Menüleiste

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

In der Menüleiste sind die vorhandenen Funktionen aufgeführt. Nicht in jeder Situation sind alle Funktionen verfügbar: ist beispielsweise keine Seite ausgewählt, stehen die Funktionen zum Löschen, Umbenennen etc. einer Seite nicht zur Verfügung.

Mit dem Personal Edition von HelpNDoc erstellt: Funktionsreicher EPub-Generator


Verlauf

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Ansicht -> Vorige Seite / Nächste Seite / Verlauf

Tastaturkürzel : F7 / F8

Die angezeigten Seiten werden in einem Verlauf festgehalten. Über diese Schaltflächen können Sie innerhalb des Verlaufs zur vorigen / zur nächsten / zu einer anderen Seite springen.

Mit dem Personal Edition von HelpNDoc erstellt: EBooks einfach erstellen


Seiten: häufig benutzte Funktionen

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Datei

Über diese Buttons können Sie eine neue Seite anlegen, eine bestehende Seite umbenennen oder löschen. Die Löschung einer Seite bewirkt zunächst das Verschieben in den Papierkorb. Erst wenn sie auch aus dem Papierkorb gelöscht wird, ist die Seite unwiderruflich entfernt.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis EBook und Dokumentationsgenerator


Suchen

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Bearbeiten -> Suchen

Tastaturkürzel : F3

Hiermit können Sie die aktuelle Seite nach einem Text durchsuchen.

Wenn Sie mehrere Seiten durchsuchen wollen - beispielsweise, um eine bestimmte Seite wiederzufinden -, verwenden Sie bitte die Funktion Datei -> Suchen... in der Menüleiste.

Mit dem Personal Edition von HelpNDoc erstellt: Qt Help-Dokumentation leicht gemacht


Reihenfolge

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Datei -> Verschieben / Ordner -> Verschieben

Über diese Buttons können Sie im aktuellen Ordner die Reihenfolge der Elemente verändern.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis EPub-Hersteller


Neuen Ordner anlegen

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Ordner -> Neu...

Tastaturkürzel : Umschalt + F2

Mit dieser Funktion können Sie einen neuen Ordner anlegen.

Mit dem Personal Edition von HelpNDoc erstellt: Funktionsreicher EPub-Generator


Sortieren

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Ordner -> Sortieren

Über diese Funktion können die Elemente des aktuellen Ordners alphabetisch sortiert werden. In den Einstellungen kann die Behandlung von Ordnern in der Sortierung definiert werden: Ordner können zuerst oder zuletzt einsortiert werden. Sie können in den Ordnereigenschaften auch definieren, daß die Elemente des jeweiligen Ordners immer sortiert werden sollen.

Mit dem Personal Edition von HelpNDoc erstellt: Was ist ein Hilfe-Entwicklungstool?


Ansicht vergrößern / verkleinern

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Ansicht -> Zoom

Über diese Schaltfläche können Sie die Ansicht des Editorfensters vergrößern oder verkleinern. Die Schriftgrößen werden dabei nicht verändert (d.h. das Ergebnis eines Ausdrucks bleibt unverändert), lediglich der Maßstab der Anzeige verändert sich.

Alternativ zu den vorgegebenen Werten können Sie einen beliebigen Wert im Bereich von 5 - 1000 (%) eingeben.

Die Funktionalität steht Ihnen aber erst zur Verfügung, wenn in Ihrem System das RichEdit-Control mit Version 3 (oder höher) installiert ist.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis HTML-Hilfedokumentationsgenerator


Rückgängig / Wiederherstellen

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Bearbeiten -> Rückgängig / Wiederherstellen

Tastaturkürzel : Strg + Z / Strg + Y

Solange die aktuelle Seite nicht gespeichert wurde, können Sie mit dieser Funktion die zuletzt in einer Seite vorgenommene Änderung wieder rückgängig machen bzw. wiederherstellen.

Diese Funktionen verhalten sich unterschiedlich, abhängig davon, welche Version des RichEdit-Controls in Ihrem System installiert ist. Die Versionsnummer wird Ihnen bei Wahl von Hilfe -> Info angezeigt. Das RichEdit-Control der Version 1 ermöglicht Ihnen lediglich, den letzten Vorgang zurückzunehmen bzw. wiederherzustellen, ab Version 2 können Sie nahezu beliebig viele Veränderungen rückgängig machen. Beachten Sie dazu auch den Abschnitt RichEdit-Control .

Mit dem Personal Edition von HelpNDoc erstellt: eBooks für den Kindle verfassen


Textformat anwenden

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Bearbeiten -> Textformat -> Anwenden

Klicken Sie auf diese Schaltfläche, um das angezeigte Textformat auf den aktuell markierten Bereich anzuwenden.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis CHM-Hilfedokumentationsgenerator


Zwischenablage

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Bearbeiten

Tastaturkürzel : Strg + X / C / V / I

Hier finden Sie die Funktionen, mit denen Sie Daten in die Zwischenablage kopieren bzw. ausschneiden oder den Inhalt der Zwischenablage in ihre Seite einfügen können. Wenn Ihre Seite mit einem Schreibschutz versehen ist, stehen die Funktionen Ausschneiden und Einfügen nicht zur Verfügung.

Wenn das Einfügen aus der Zwischenablage nicht das gewünschte Ergebnis mit sich bringt, liegen die Daten in der Zwischenablage in verschiedenen Formaten vor. Wählen Sie Bearbeiten -> Inhalte einfügen... aus der Menüleiste, um den Inhalt der Zwischenablage in einem von Ihnen wählbaren Format einzufügen.

Mit dem Personal Edition von HelpNDoc erstellt: Plattformübergreifende Qt Help-Dateien erstellen


Fenster schließen und in TNA platzieren

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Menü: Datei -> Schließen, -> TNA

Tastaturkürzel : Strg + T

Mit dieser Funktion schließen Sie das Hauptfenster von Scribble Papers. Das Programm wird jedoch nicht beendet, sondern in der sogenannten "Taskbar Notification Area" durch ein Symbol präsentiert. Die TNA ist der rechte Bereich der Taskleiste, in dem u.a. die Uhrzeit angezeigt wird. Durch einen Doppelklick auf das Scribble Papers Symbol wird das Hauptfenster wieder hergestellt.

Mit dem Personal Edition von HelpNDoc erstellt: Kostenloser Qt Help-Dokumentationsgenerator


Symbolleiste für Textformatierung

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

In dieser Symbolleiste stehen Ihnen die gängigsten Funktionen zur Textformatierung zur Verfügung. Sie können:

  1. die Schriftart, Schriftgröße und -farbe ändern,
  2. die Schriftstile Fett, Kursiv, Unterstrichen ändern,
  3. Textattribute auf andere Textbereiche übertragen,
  4. den Absatz links, rechts oder zentriert ausrichten,
  5. den Einzug des Absatzes verändern,
  6. Absätze mit Aufzählungszeichen versehen,
  7. die Hintergrundfarbe des selektierten Textabschnitts verändern,
  8. Textformate verwenden, um die Formatierung zu vereinfachen.

Hinweis zur Hintergrundfarbe: diese Funktion steht Ihnen nur zur Verfügung, wenn die Version des auf Ihrem System installierten RichEdit-Control > 1 ist. Die Versionsnummer wird Ihnen bei Wahl von Hilfe -> Info angezeigt.

Mit dem Personal Edition von HelpNDoc erstellt: Funktionsreicher Multiformat-Hilfsgenerator


Umschalten Voll-/Lesezugriff

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Diese Schaltfläche steht nur zur Verfügung, wenn in den Einstellungen für das verwendete Datenverzeichnis die Markierung "Gruppenverzeichnis" aktiviert ist. Über diese Schaltfläche kann auf einfachste Weise zwischen Vollzugriff und nur lesendem Zugriff umgeschaltet werden, ohne dass dafür jedesmal die Programmeinstellungen aufgerufen werden müssen.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis iPhone-Dokumentationsgenerator


Navigationsbaum

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

In dieser Baumstruktur sehen Sie Ihre Ordner und Seiten. Mit der Maus können Sie andere Ordner oder Seiten anwählen. Sofern Sie Seiten mit einem Status versehen haben, wird ein entsprechendes Symbol angezeigt.

Ordner können mit der Maus auf- und zugeklappt werden. Sie können Ordner und Seiten auf einfache Weise folgendermaßen in einen anderen Ordner verschieben:

  1. Wählen Sie mit der Maus im Navigationsbaum das Objekt aus, das Sie verschieben möchten.
  2. Halten Sie die Maustaste gedrückt und ziehen Sie das Objekt über den Ordner, in den Sie verschieben möchten.
  1. Lassen Sie die Maustaste los. Der verschobene Ordner bzw. die verschobene Seite wird jetzt als letztes Element im gewählten Ordner angezeigt.

Für Seiten, die mit einem Schreibschutz versehen sind sowie für Ordner, die schreibgeschützte Seiten enthalten, kann das Verschieben deaktiviert werden (wahlweise auch nur das Verschieben mit der Maus). Beachten Sie dazu den Abschnitt Einstellungen .

Mit dem Personal Edition von HelpNDoc erstellt: Webhilfe-Seiten einfach erstellen


Reiter der einzelnen Seiten

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

Alternativ zur Wahl der Seiten über den Navigationsbaum können Sie auch durch Klicken mit der Maus auf einen Reiter zu einer anderen Seite springen. Hier werden jedoch nur die im aktuellen Ordner enthaltenen Seiten aufgeführt.

Mit dem Personal Edition von HelpNDoc erstellt: iPhone-Dokumentation einfach erstellen


Statusleiste

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Hauptfenster ››

In der Statusleiste werden Ihnen folgende Informationen angezeigt:

  1. zusätzliche Beschreibungen zu von Ihnen angewählten Funktionen,
  2. der Zeitpunkt der letzten Änderung der Seite,
  3. der Status der Seite,
  4. die momentane Position des Cursors in Ihrer Seite,
  5. der Status der "Einfg"-Taste,
  6. ein ggf. gesetzter Schreibschutz der aktuellen Seite.

Mit dem Personal Edition von HelpNDoc erstellt: iPhone-Dokumentation einfach erstellen


Suchtext

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Suchfenster ››

Hier ist der Text anzugeben, nach dem gesucht werden soll. Das kann sowohl ein Seitenname als auch Text aus dem Inhalt einer Seite sein. Die letzten Suchtexte können Sie durch Aufklappen der Liste und Auswahl eines Eintrages erneut verwenden. Über den Button rechts neben dem Eingabfeld können Sie Text aus der Zwischenablage einfügen.

Sie können Ihren Suchbegriff auch mit einem zweiten Suchbegriff ueber eine logische Bedingung verknüpfen.

Mit dem Personal Edition von HelpNDoc erstellt: eBooks für den Kindle verfassen


Suchen in

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Suchfenster ››

Hier wird der Ordner angezeigt, der durchsucht werden soll. Über die Schaltfläche rechts vom Ordnernamen können Sie einen anderen Ordner auswählen.

Über das Markierungsfeld unterhalb des Ordnernamens können Sie die Suche auf untergeordnete Ordner ausdehnen.

Sie können die Ergebnisse einer durchgeführten Suche weiter "verfeinern", indem Sie die Schaltfläche "Suchergebnis" markieren. Es werden dann nicht erneut alle Seiten des Ordners durchsucht, sondern nur die Seiten der Ergebnisliste.

Markierungsfelder "Seitennamen", "Ordnernamen", "Stichwörter" und "Seiteninhalte": markieren Sie hier, ob Sie lediglich nach einer Seite bzw. einem Ordner mit einem bestimmten Namen und/oder Stichwörtern suchen wollen oder ob auch der Inhalt der Seite auf den Suchtext überprüft werden soll. Weiterhin können Sie über das Markierungsfeld "auch mit Passwort geschützte" bestimmen, ob passwort-geschützte Seiten in die Suche einbezogen werden sollen.

Tip: Die Suche nach Namen benötigt am wenigsten Zeit, dicht gefolgt von der Suche nach Stichwörtern. Das Durchsuchen des Inhaltes von Seiten benötigt am meisten Zeit. Bei großen Datenmengen kann sich daher eine sorgfältige Vergabe von Stichwörtern in den Seiteneigenschaften bzw. Ordnereigenschaften lohnen! Über die Stichwörter können Sie sich auch mittels der Suchfunktion eine andere Sichtweise auf ihre Daten verschaffen, z.B. wenn die Daten zwar in unterschiedlichen Ordnerstrukturen angesiedelt sind aber trotzdem einen Bezug zueinander haben.

Mit dem Personal Edition von HelpNDoc erstellt: EPub-EBooks mit Leichtigkeit generieren


Weitere Suchkriterien

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Suchfenster ››

Sie können auch Seiten mit einem bestimmten Änderungsdatum und / oder mit einem bestimmten Status suchen. Wenn Sie den Suchtext und den optionalen 2. Suchtext leerlassen, wird ausschließlich nach diesen Kriterien gesucht.

Mit dem Personal Edition von HelpNDoc erstellt: EPub-EBooks mit Leichtigkeit generieren


Ergebnisliste

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Suchfenster ››

In dieser Liste werden die Seiten angezeigt, in denen der Suchtext gefunden wurde. Durch Doppelklick auf einen Eintrag wird auf die Seite verzweigt. Nach dem Schließen des Suchfensters wird die Ergebnisliste ins Hauptfenster übernommen, wo sie gespeichert werden kann.

Mit dem Personal Edition von HelpNDoc erstellt: Kostenloser Qt Help-Dokumentationsgenerator


Suche starten

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Suchfenster ››

Klicken Sie auf diesen Button, um die Suche zu starten.

Mit dem Personal Edition von HelpNDoc erstellt: CHM-Hilfedokumente einfach erstellen


Suche abbrechen

Scribble Papers ›› Einzelne Bildschirmelemente ›› Das Suchfenster ››

Klicken Sie auf diesen Button, um die Suche abzubrechen.

Mit dem Personal Edition von HelpNDoc erstellt: Gratis Kindle-Hersteller