Syncovery

Diese Software ermöglicht die Synchronisation von Dateien und Ordnern und wird zur Datensicherung und zum Abgleich von PCs, Macs, Servern und Laptops eingesetzt. Sie verwaltet beliebig viele Profile in Profilgruppen, die manuell oder per Timer gestartet werden. Die Professional-Edition unterstützt Zugriff auf FTP, SSH, WebDAV, Azure und Amazon S3 sowie ZIP-Komprimierung und Verschlüsselung. Es stehen also zahlreiche Möglichkeiten für Online-Backup zur Verfügung. Bei der Professional-Edition kann der Timer auch als Dienst laufen, sodass die Synchronisation auch stattfindet, wenn kein Benutzer unter Windows angemeldet ist. Durch zahlreiche Einstellmöglichkeiten im Fortgeschrittenen Modus wird die Software einer Vielzahl an Aufgabenstellungen gerecht.

Das Programm kann im Assistentenmodus oder im Fortgeschrittenen Modus verwendet werden.

Die wichtigsten Themen:

Profilübersicht

Profileinstellungen

Synchronisationsvorschau

Der Timer

Schlüsselfunktionen

(siehe http://www.syncovery.com/overview/ um eine detaillierte Aufstellung zu sehen):

  • Dateien synchronisieren (zum Beispiel zwischen PC und Laptop)
  • Unterstützung beliebig vieler Profile (Jobs)
  • mit FTP, SSH, WebDAV, HTTP, Azure und Amazon-S3 *
  • SmartTracking (erkennt z. B. Dateilöschungen seit dem letzten Abgleich)
  • Komprimierung (ZIP) und Verschlüsselung (AES) *
  • Erkennt verschobene Dateien (z. B. bei Neuorganisation der Ordnerstruktur)
  • Timer (für automatische Datensicherungen)
  • Echtzeit-Synchronisation *
  • Versionierung
  • datenbanksicher (z. B. durch Verwendung der Volumenschattenkopie)
  • kann Papierkorb verwenden (für ältere Versionen ersetzter Dateien)
  • Email-Benachrichtigung (über die Sync-Ergebnisse)
  • Timer kann als Dienst laufen *
  • u.v.m.

* = nur in der Professional-Version verfügbar

Lizensierung

Sie können diese Shareware 30 Tage lang testen. Bitte erwägen Sie den Kauf einer Lizenz. Falls Sie weitere Funktionen benötigen, bitte senden Sie Ihre Wünsche an mich!


Assistentenmodus

Syncovery

Diese Software ermöglicht die Synchronisation von Dateien und Ordnern und wird zur Datensicherung und zum Abgleich von PCs, Macs, Servern und Laptops eingesetzt. Sie verwaltet beliebig viele Profile in Profilgruppen, die manuell oder per Timer gestartet werden. Die Professional-Edition unterstützt Zugriff auf FTP, SSH, WebDAV, Azure und Amazon S3 sowie ZIP-Komprimierung und Verschlüsselung. Es stehen also zahlreiche Möglichkeiten für Online-Backup zur Verfügung. Bei der Professional-Edition kann der Timer auch als Dienst laufen, sodass die Synchronisation auch stattfindet, wenn kein Benutzer unter Windows angemeldet ist. Durch zahlreiche Einstellmöglichkeiten im Fortgeschrittenen Modus wird die Software einer Vielzahl an Aufgabenstellungen gerecht.

Sie verwenden gerade den Assistentenmodus. Falls Sie mehr Optionen benötigen, können Sie in den Fortgeschrittenen Modus wechseln.

Die wichtigsten Themen:

Synchronisations-Vorschau

Profilübersicht

Der Timer

Schlüsselfunktionen

(siehe http://www.superflexible.de/features.htm um eine detaillierte Aufstellung zu sehen):

  • Dateien synchronisieren (zum Beispiel zwischen PC und Laptop)
  • Unterstützung beliebig vieler Profile (Jobs)
  • mit FTP, SSH, WebDAV, HTTP, Azure und Amazon-S3 *
  • SmartTracking (erkennt z. B. Dateilöschungen seit dem letzten Abgleich)
  • Komprimierung (ZIP) und Verschlüsselung (AES) *
  • Erkennt verschobene Dateien (z. B. bei Neuorganisation der Ordnerstruktur)
  • Timer (für automatische Datensicherungen)
  • Echtzeit-Synchronisation *
  • Versionierung
  • datenbanksicher (z. B. durch Verwendung der Volumenschattenkopie)
  • kann Papierkorb verwenden (für ältere Versionen ersetzter Dateien)
  • Email-Benachrichtigung (über die Sync-Ergebnisse)
  • Timer kann als Dienst laufen *
  • u.v.m.

* = nur in der Professional-Version verfügbar

Lizensierung

Sie können diese Shareware 30 Tage lang testen. Bitte erwägen Sie den Kauf einer Lizenz. Falls Sie weitere Funktionen benötigen, bitte senden Sie Ihre Wünsche an mich!


Funktionsumfang

Den aktuellen Funktionsumfang entnehmen Sie bitte unserer Web-Site.

Siehe auch:

Syncovery

Lizensierung


Profileinstellungen - Oberer Teil

In diesem Bereich können Sie

  • den Profilnamen angeben
  • die zu synchronisierenden Ordner bzw. Pfade wählen
  • die Kopierrichtung angeben
  • Unterordner und Dateien wählen
  • den Synchronisationsmodus angeben

Siehe auch: Weitere Einstellungen

Profilname

Hier können Sie den Profilnamen eingeben und ändern. Um Profilgruppen zu erhalten, erstellen Sie einfach mehrere Profile, deren Namen mit demselben Wort beginnen, z. B.

Backup Dokumente

Backup Musik

Backup SQL-Datenbanken

Wenn der Name eines bereits bestehenden Profils hier geändert wird und Sie auf OK klicken, dann werden Sie gefragt, ob die alte Version des Profils unter dem ursprünglichen Namen weiter bestehen soll. Der Knopf Speichern unter... ist eine weitere Möglichkeit, eine geänderte oder identische Kopie eines Profils zu erzeugen.

Pfade für die Synchronisation

Links

In diesem Feld geben Sie den linken Ordner für den Vergleich an. Klicken Sie auf das Ordnersymbol, um den Ordner aus einer Liste auszuwählen. In der Professional Edition können Sie den Internet-Knopf verwenden, um auf FTP, SSH, WebDAV- und andere Server zuzugreifen.

Rechts

In diesem Feld geben Sie den rechten Ordner für den Vergleich an. Klicken Sie auf das Ordnersymbol, um den Ordner aus einer Liste auszuwählen. In der Professional Edition können Sie den Internet-Knopf verwenden, um auf FTP, SSH, WebDAV- und andere Server zuzugreifen.

Richtungen der Synchronisation

Links nach Rechts / Rechts nach Links

Es ist sehr wichtig, die korrekte(n) Richtung(en) für die Synchronisation anzugeben. Sie können in zwei Richtungen gleichzeitig synchronisieren, sodass nach dem Durchlauf beide Seiten die aktuellen Dateien haben. Oder Sie schränken die Kopierrichtung von vornherein ein. Die verfügbaren Synchronisations-Modi hängen von den Richtungen ab. Manche Einstellungen sind nur verfügbar, wenn Sie nur in einer Richtung synchronisieren.

Unterordner

Mit dieser Option bestimmen Sie, ob bzw. welche Unterverzeichnisse der ausgewählten Pfade verarbeitet werden sollen. Nach Klick auf "Ordner/Dateien wählen..." erscheint ein weiteres Dialogfenster, in dem Sie Unterordner und Dateien auswählen können. Um einzelne Dateien auszuwählen, müssen Sie dort mit der rechten Maustaste auf den jeweiligen Ordner klicken. Es ist aber ratsam, möglichst mit Filtern zu arbeiten anstatt einzelne Dateien auszuwählen. Siehe Profileinstellungen - Masken und die weiteren Seiten dort.

Synchronisations-Modus

Die Synchronisationsmodi werden auch im Dialogfenster kurz erläutert.

Standard

Im Modus Standard werden die Ordner und Dateien beider Seiten verglichen unter Berücksichtigung der Dateinamen, des Datums der letzten Änderung sowie der Größe jeder Datei. Neuere Dateien und Dateien, die noch nicht auf beiden Seiten existieren, werden zur jeweils anderen Seite kopiert. Es werden keine Dateien gelöscht (außer wenn Sie die Echtzeit-Synchronisation wählen und dies bei den Echtzeit-Optionen angeben).

SmartTracking

SmartTracking wird verwendet, wenn Sie regelmäßig dieselben Ordner in beiden Richtungen synchronisieren, und nicht nur neue und geänderte Dateien synchronisieren möchten, sondern auch Löschungen, Verschiebungen und Konflikte erkennen lassen möchten. SmartTracking kann feststellen, auf welcher Seite eine Datei verschoben oder gelöscht worden ist, und ob die Datei evtl. auf beiden Seiten bearbeitet wurde (Konflikt).

SmartTracking bewahrt Informationen in einer Datenbank, die mit dem Profilnamen verknüpft ist. Beim ersten Start speichert die Software den Status der Dateien. Ab dem zweiten Mal werden die Einstellungen des SmartTracking-Dialogfensters aktiv. Benennen Sie das Profil nicht um, da es sonst die Datenbank nicht wiederfindet. Verwenden Sie nicht mehr als ein Profil für die Synchronisation derselben Ordner.

Exakte Spiegelung

Diese Option stehte nur zur Verfügung, wenn Sie nur in eine Richtung synchronisieren. Es wird dann eine exakte Kopie der Quellseite auf der Zielseite erstellt, wobei ggf. auch Dateien gelöscht werden oder neuere Dateien durch ältere Dateien ersetzt werden. Wenn das Profil unbeaufsichtigt läuft, verhindern allerdings etliche Sicherheitseinstellungen das Löschen von Dateien. Sie müssen daher zum Registerblatt Sicherheit/Unbeaufsichtigt und die Löschungen und ggf. das Überschreiben neuerer Dateien mit älteren dort freischalten.

Verschieben

Die normale Synchronisation kopiert Dateien mit dem Ziel, die rechte und die linke Seite einander anzugleichen. Im Unterschied dazu dient das Verschieben dem Archivieren von Dateien, die von einer Seite zur anderen geschoben werden.

Siehe auch: Weitere Einstellungen


Weitere Einstellungen

Alle weiteren Einstellungen befinden sich im unteren Teil des Dialogfensters auf zahlreichen Registerblättern, die wiederum über die Kategorienauswahl auf der linken Seite aufgerufen werden können.

Der Knopf Standardwerte setzt diese Einstellungen zurück, beeinflusst aber nicht die Angaben in der oberen Hälfte des Dialogfensters.

Termin

  • Profileinstellungen - Termin
  • Profileinstellungen - Termin/Mehr
  • Profileinstellungen - Wochentage und Zeitfenster
  • Profileinstellungen - Überwachen / Echtzeit-Synchronisation

Zugriff & Wdhlg.

  • Profileinstellungen - Dateizugriff
  • Profileinstellungen - Warten und erneut versuchen

Vergleich

  • Profileinstellungen - Vergleich
  • Profileinstellungen - Vergleich/Weitere

Dateien

  • Profileinstellungen - Dateien
  • Profileinstellungen - Gelöschte Dateien
  • Profileinstellungen - Dateien/Weitere

Ordner

  • Profileinstellungen - Ordner

Allgemein

  • Profileinstellungen - Allgemein

Masken & Filter

  • Profileinstellungen - Masken
  • Profileinstellungen - Ausnahmen
  • Profileinstellungen - Allgemeine Filter
  • Profileinstellungen - Dateialter und Größe

Sicherheit

  • Profileinstellungen - Sicherheit/Beaufsichtigt
  • Profileinstellungen - Spezielle Sicherheitsabfragen
  • Profileinstellungen - Sicherheit/Unbeaufsichtigt

Spezial

  • Profileinstellungen - Spezial
  • Profileinstellungen - Datenbank

Versionierung

  • Profileinstellungen - Versionierung
  • Profileinstellungen - Synthetische Backups
  • Profileinstellungen - Versionierung/Erweitert

ZIP & Verschlüsselung

  • Profileinstellungen - Zip-Komprimierung
  • Profileinstellungen - Verschlüsselung

Siehe auch: Profileinstellungen - Oberer Teil


Profileinstellungen - Termin

Auf diesem Registerblatt geben Sie an, ob das Profil automatisch starten soll, wenn der Timer in Betrieb ist.

Termin

Dieses Kontrollkästchen muss angekreuzt sein, damit der Timer das Profil berücksichtigt. Sie können in den weiteren Optionen angeben, wann und wie oft das Profil laufen soll. Auf dem Registerblatt Mehr können Sie ggf. weitere Uhrzeiten angeben.

Nächsten Termin angeben

Normalerweise errechnet der Timer den nächsten Termin selbständig. Falls Sie einen bestimmtem Termin angeben möchten, können Sie dies hier tun.

Das Zeitintervall bezieht sich auf die Leerlaufzeit zwischen Profilausführungen

Diese Option ist besonders für relativ kurze Intervalle wie 1 Minute interessant. Sie legen damit fest, dass das angegebenene Intervall die Pause zwischen den Profilen bestimmen soll. Wenn die Option nicht angekreuzt ist, dann kann es passieren, dass das Profil nach Fertigstellung sofort wieder gestartet wird, wenn die Ausführungszeit so lang wie oder länger als das Intervall war.

Siehe auch

  • Profileinstellungen - Oberer Teil
  • Weitere Einstellungen


Profileinstellungen - Termin/Mehr

Hier finden Sie weitere Einstellungen zum Termin. Sie können das Profil z. B. bei Anmeldung oder Abmeldung und Herunterfahren ausführen lassen.

Die Option Verpasste tägliche Starts sofort nachholen bezieht sich auf den Fall, dass ein Profil jeden Tag zu einer bestimmten Uhrzeit ausgeführt werden soll. Wenn der Timer zu diesem Zeitpunkt nicht läuft, dann wird die Ausführung sofort nachgeholt, wenn der Timer später noch gestartet wird. Ohne diese Option würde der Termin ausfallen und der nächste Start wäre erst wieder am nächsten Tag.

Eine Zufallsverzögerung kann ebenfalls angegeben werden, z. B. wenn Sie die Zugriffe auf einen Server durch viele Clients zufällig über einen bestimmten Zeitraum verteilen möchten.

Weitere Uhrzeiten können angegeben werden, falls die Haupt-Terminangaben auf dem Registerblatt Termin nicht genügen.

Siehe auch

  • Profileinstellungen - Termin


Profileinstellungen - Wochentage und Zeitfenster

Hier können Sie die Wochentage angeben, an denen das Profil laufen soll.

Außerdem kann ein Zeitfenster angegeben werden, innerhalb dessen das Profil laufen darf.

  • Profileinstellungen - Termin


Profileinstellungen - Überwachen / Echtzeit-Synchronisation

Hier können Sie angeben, dass das Profil bei Dateiänderungen oder bei Verfügbarkeit der Laufwerke gestartet werden soll. Der Überwachungsmodus ersetzt das regelmäßige Ausführen des Profils über die Einstellungen auf dem Registerblatt Termin.

Echtzeit-Synchronisation *

Wenn Sie die Echtzeit-Synchronisation verwenden, dann werden Änderungen an Dateien und Ordnern mit kurzer Verzögerung gespiegelt. Das Profil wird dazu nicht komplett gestartet, sondern es werden nur die Änderungen durchgeführt, über die das Programm von Windows benachrichtigt wurde. Nur Windows-kompatible Laufwerke und Netzwerk-Ordner können überwacht werden, keine Ordner, die über FTP oder andere Internet-Protokolle angesprochen werden. Über VPN allerdings ist die Überwachung in der Regel möglich.

Profil ausführen, sobald die Laufwerke verfügbar sind *

Mit dieser Option können Sie erreichen, dass das Profil läuft, sobald die beteiligten Laufwerke verfügbar sind. Dadurch kann zum Beispiel ein USB-Stick synchronisiert werden, sobald er angeschlossen wird. Ferner kann dadurch ein Notebook-Computer synchronisiert werden, sobald er an Ihr LAN angeschlossen ist.

* = nur in der Professional-Version verfügbar

  • Profileinstellungen - Termin


Profileinstellungen - Dateizugriff

Volumenschattenkopie

Die Volumenschattenkopie ermöglicht den Zugriff auf Dateien, die in Verwendung sind und daher eigentlich gesperrt sind. Die Software verwendet diese Technik normalerweise automatisch, sobald der Zugriff auf einige Dateien nicht anders möglich ist. Um eine hundertprozentige Konsistenz der gesamten Datensicherung über mehrere Dateien hinweg zu erreichen, kann es in manchen Fällen ratsam sein, die Volumenschattenkopie für alle Dateien zu verwenden.

Die Erweiterten VSS-Optionen sollten in aller Regel nicht verwendet werden!

Datenbanksicher: exklusiven Zugriff sicherstellen

Der datenbanksicherere Modus achtet darauf, dass keine andere Anwendung eine Datei mit Schreibzugriff geöffnet haben kann oder öffnen kann, die gerade kopiert wird. Dies garantiert konsistente Datensicherungen von Datenbanken. Diese Option kann auch bewirken, dass die Volumenschattenkopie eingesetzt wird (falls nicht abgeschaltet), um eine konsistente Kopie erstellen zu können.

Zieldateien vorübergehend als Administrator in Besitz nehmen falls notwendig

In Unternehmensumgebungen mit vielen Benutzern ist es manchmal noch nicht einmal dem Administrator gestattet, Dateien zu ersetzen. In diesem Fall kann das Programm auf dem Ziellaufwerk die Datei vorübergehend in Besitz nehmen, um sie zu ersetzen. Danach werden die originalen Besitzereinstellungen wiederhergestellt.

Zugriff vor Ausführung testen

Diese Einstellung wird selten verwendet. Sie bewirkt, dass vor dem eigentlichen Kopiervorgang alle Dateien kurz geöffnet werden, um den Zugriff zu testen. Nur wenn alle Dateien kopiert werden können, wird der gesamte Kopiervorgang gestartet. Anderenfalls wird überhaupt keine Datei kopiert.


Profileinstellungen - Warten und erneut versuchen

Wenn Zugriffe auf Ordner oder Dateien scheitern, versucht die Software den Zugriff in der Regel nach einer gewissen Zeit erneut. Auf dieser Seite können Sie die Details zum Neuversuch regeln.


Profileinstellungen - Vergleich

Normalerweise werden die Dateien hauptsächlich aufgrund ihrer Datums- und Uhrzeitangaben der letzten Änderung verglichen. In einigen Fällen kann es aber sein, dass die Uhrzeit unterschiedlich ist, obwohl die Dateien wirklich dieselben sind. Daher kann Syncovery folgende Fälle erkennen:

Wenn die Größe identisch ist:

Kleine Sekunden-Unterschiede ignorieren (wenn die Größe identisch ist)

Wenn diese Option ausgewählt ist, werden Dateien, deren Uhrzeiten z. B. nur um 2 Sekunden oder weniger voneinander abweichen, als identisch betrachtet (falls die Dateigröße gleich ist). Das ist nötig, um Unterschiede zu ignorieren, die beim Kopieren zwischen verschiedenen Dateisystemen entstehen können, da nicht alle Dateisysteme dieselbe Genauigkeit bei der Uhrzeit haben.

Exakte Stunden-Unterschiede ignorieren (wenn die Größe identisch ist)

Diese Einstellung hilft, die unterschiedliche Behandlung der Sommerzeit bei verschiedenen Computern und/oder Dateisystemen auszugleichen. Manchmal werden von zwei Computern Uhrzeiten genannt, die exakt eine Stunde auseinanderliegen, obwohl die Dateien dieselben sind. Wenn diese Option angekreuzt ist, spielen solche Abweichungen keine Rolle mehr. Es ist dabei egal, welche der beiden Seiten eine Stunde vor der anderen liegt.

Sekunden ignorieren (wenn die Größe identisch ist)

Diese Option kann manchmal hilfreich sein, wird jedoch selten benötigt. Wenn Server angesprochen werden, die keine Sekunden angeben, wie z. B. FTP-Server, dann werden die Sekunden automatisch auf der anderen Seite ignoriert.

Dateidatum ganz ignorieren (wenn die Größe identisch ist)

Diese Option sollte nur selten und mit Vorsicht verwendet werden. Sie führt dazu, dass Dateien unterschiedlichen Datums mit derselben Größe als identisch angesehen werden.

Wenn die Größe unterschiedlich ist

Seltener kommt es vor, dass der Zeitstempel zweite Dateien gleichen Namens übereinstimmt, aber die Größe unterschiedlich ist. Hier können Sie angeben, was dann geschehen soll.


Profileinstellungen - Vergleich/Weitere

Immer kopieren, auch wenn Zeitstempel unverändert

Diese Einstellung bewirkt, dass alle Dateien immer kopiert werden, auch wenn die Größe und Zeitstempel bereits bei Quelle und Ziel identisch ist. Diese Option setzt voraus, dass Sie nur in einer Richtung synchronisieren.

Binärvergleich existierender Dateien beim Eilesen der Dateiliste

Wenn Sie überprüfen möchten, ob die Dateien auf beiden Seiten 100%ig identisch sind, dann können Sie diese Einstellung verwenden. Dateien, die anhand der Größe und des Zeitstempels identisch aussehen, werden nun noch auf den Inhalt hin überprüft. Wenn der Binärvergleich zeigt, dass eine Datei unterschiedlich ist, dann wird sie als zu kopieren markiert (in der Synchronisations-Richtung des Profils). Falls im Profil beide Richtungen ausgewählt sind, dann erscheint die Datei in der Synchronisationsvorschau als KONFLIKT und wird standardmäßig nicht kopiert. Sie müssen dann die Kopierrichtung selbst angeben.

Eine verwandte Option lautet "Kopierte Dateien verifizieren". Diese finden Sie unter Profileinstellungen - Dateien . Diese andere Option überprüft den Inhalt der Dateien, nachdem sie kopiert worden sind, während der Binärvergleich die Dateien vergleicht, die schon auf beiden Seiten existieren. Der Binärvergleich liest bei jedem Lauf alle Dateien komplett ein, während die andere Option nur die Dateien nochmal einliest, die gerade kopiert worden sind.

Durch Remote Service generierte MD5-Prüfsummen verwenden

Die beiden oben beschriebenen Vergleichsoptionen können MD5-Prüfsummen verwenden, um den Vergleich zu beschleunigen. Auf einer oder beiden Seiten der Synchronisation kann die Erstellung der Prüfsummen an den Syncovery Remote Service delegiert werden, der diese dann lokal erstellt und in einer separaten Datei zum Abruf durch das Hauptprogramm bereitstellt. Siehe auch http://www.syncovery.com/remoteservice/

Attributvergleich

Hierdurch können die Dateiattribute angeglichen werden, wenn der Inhalt der Dateien bereits identisch ist. Ein separates Kontrollkästchen aktiviert den Vergleich auch für Ordner.

Schreibweise gr./kl. angleichen

Die Groß- und Kleinschreibung spielt bei Windows-Dateien normalerweise keine Rolle. Die Datei meinedatei.doc ist also dieselbe wie MeineDatei.DOC - beide Schreibweisen führen zur selben Datei. Wenn Sie jedoch auf der einen Seite der Synchronisation die Schreibweise einiger Dateien abweicht, dann kann diese Einstellung Ihnen helfen, die Schreibweise anzugleichen. Dafür dürfen Sie nur eine Synchronisations-Richtung auswählen.

Ordnerzeitstempel angleichen

Diese Einstellung bewirkt, dass die Zeitstempel von Ordnern angeglichen werden.

Ergebniszustand statistisch überprüfen

Diese Option bewirkt, dass nach Abschluss des Profils alle Ordner nochmals neu eingelesen werden und statistisch miteinander verglichen werden. Sie erhalten eine Liste aller Unterordner und Dateien, die trotz Synchronisation jeweils nur auf einer Seite vorhanden sind. Im allgemeinen ist dies unnötig und kostet nur extra Zeit und wird daher nicht empfohlen.

Hard-Link-Erkennung

Ein Hard Link ist eine Verknüpfung, die bewirkt, dass eine physikalisch nur einmal vorhandene Datei in mehreren Ordnern aufgeführt wird. Beim normalen Kopieren würden aus solch einer Datei am Ziel mehrere unabhängige Kopien der Datei. Durch die Hard-Link-Erkennung kann die Verknüpfung auch am Ziel hergestellt werden, sodass die Zieldatei ebenfalls nur einmal existiert. Sie wird innerhalb des Ziellaufwerks zwischen verschiedenen Ordnern verknüpft - aber sie wird nicht mit der Quellseite verknüpft.

Bei existierenden Dateien forcieren

Diese Option bewirkt, dass die Hard Links auch dann am Ziel hergestellt werden, wenn die Dateien dort bereits existieren und noch nicht verknüpft sind.


Profileinstellungen - Dateien

Verschobene Dateien & Ordner erkennen

Wenn Dateien auf einer Seite der Vergleichsoperation in andere Ordner verschoben worden sind, oder wenn die Ordnerstruktur auf einer Seite neu organisiert wurde, dann kann Syncovery dies erkennen. Anstatt Dubletten zu erzeugen, indem einfach alle Dateien in ihren aktuellen Ordnern auf die jeweils andere Seite kopiert werden, kann die Software dieselben Verschiebungen, die Sie auf einer Seite durchgeführt haben, auf der anderen Seite realisieren. Kreuzen Sie diese Option an, um die Erkennung von Dateiverschiebungen anzuschalten.

Eine Einschränkung dieser Funktion ist, dass verschobene Dateien nur erkannt werden können, wenn sie nicht außerdem noch verändert worden sind.

Sie müssen außerdem angeben, auf welcher Seite die Anpassung vorgenommen werden soll. Wenn Sie nicht eine feste Seite angeben möchten, an der die Verschiebung passieren soll, dann sollten Sie das SmartTracking verwenden (automatisch).

Umbenannte Dateien erkennen

Auch umbenannte Dateien können unter bestimmten Umständen erkannt werden. Es müssen die Dateigröße und die Uhrzeit der letzten Änderung noch genau übereinstimmen. Außerdem muss das Profil die Exakte Spiegelung oder SmartTracking verwenden unter Berücksichtigung von Dateilöschungen. Umbenannte Dateien resultieren dann normalerweise in einer Kopier- und einer Löschaktion. Diese Kontrollkästchen bewirkt, dass die Kopier- und die Löschaktion als zusammengehörig erkannt werden und in eine Umbenennungsaktion verwandelt werden.

Kopierte Dateien verifizieren

Die Option bewirkt, dass die Zieldatei nach dem Kopieren noch einmal mit der Quelldatei verglichen wird. Dadurch wird sichergestellt, dass sie eine vollständig lesbare und identische Kopie ist. In den seltenen Fällen, wo die Kopie nicht identisch ist, wird sie wieder gelöscht. Man kann dann einen erneuten Versuch machen lassen. Solche Fehler können eventuell bei Hardwareproblemen, Netzwerkproblemen oder Transferproblemen über das Internet auftauchen.

Auto-Resume und Transfer mit temporärem Dateinamen

Falls der Kopiervorgang unterbrochen wird, können unvollständige Kopien bzw. Downloads und Uploads mit der Dateiendung .$syncovery auf der Festplatte belassen werden, sodass der Transfer beim nächsten Profildurchlauf fortgesetzt werden kann. Die Datei erhält erst dann auf der Zielseite ihren endgültigen Namen (ohne .$syncovery-Erweiterung), wenn der Transfer vollständig ist.

Diese Option ist in vielen Fällen sinnvoll, denn Sie vermeiden dadurch auch, dass unvollständige Kopien bereits verwendet oder von anderen Jobs weiterkopiert werden.

Ersetzen von Dateien mit leeren Dateien verhindern

Dies verhindert, dass eine Datei durch eine leere Datei (0-Byte Größe) ersetzt wird. Unter manchen Umständen können leere Dateien existieren, die eigentlich einen Inhalt haben sollten und durch einen Fehler leer geworden sind. Solche Dateien würden dann nicht kopiert, auch wenn sie ein neueres Datum haben als die größere Datei auf der anderen Seite.

Zielordner nicht einlesen

Mit dieser Einstellung werden die Dateien immer kopiert, ohne dass die Existenz auf der Zielseite überprüft würde. Dies kann das Erstellen der Dateiliste sehr beschleunigen, es ist aber nur in bestimmten Fällen wünschenswert. Damit keine Dateien überflüssigerweise mehrmals kopiert werden, kann man die Option mit dem Archiv-Filtern kombinieren, siehe Profileinstellungen - Allgemeine Filter .

Gleichzeitig zu kopierende Dateien

Durch das gleichzeitige Kopieren mehrerer Dateien können Sie evtl. die Bandbreite der Verbindung stärker ausnutzen. Es kann aber auch die Fragmentierung der Zielfestplatte erhöht werden. Andererseits ist es für heutige Betriebssysteme Routine, viele Dateien parallel zu verarbeiten.

Windows-Dateipuffer umgehen

Besonders bei sehr großen Dateien kann der Windows-Dateipuffer gelegentlich zu Speichermangel führen. Daher wurde diese Option eingeführt, die die Speicherprobleme behebt und auch zu einer Geschwindigkeitssteigerung führen kann.


Profileinstellungen - Gelöschte Dateien

Papierkorb verwenden für überschriebene / gelöschte Dateien

Diese Optionen veranlassen Syncovery dazu, zu versuchen, den Papierkorb für überschriebene und zu löschende Dateien zu verwenden. Dadurch haben Sie die Möglichkeit, bei Bedarf ältere Versionen, die überschrieben oder gelöscht wurden, wiederherzustellen. Leider steht der Papierkorb nicht immer zur Verfügung, insbesondere nicht bei Netzwerklaufwerken und FTP-Servern.

Gelöschte Dateien in Ordner verschieben...

Diese Einstellung ist eine zuverlässigere Alternative zum Papierkorb. Anstatt Dateien wirklich zu löschen, werden sie in einen speziellen Ordner verschoben, welchen Sie angeben müssen. Das funktioniert auch mit Netzwerklaufwerken oder FTP-Servern.

Ältere Versionen sofort löschen

Falls Sie mit Versionierung arbeiten, existieren am Ziel eventuell mehrere Versionen einer Datei. Wenn diese Datei nun an der Quelle gelöscht wurde, gibt es mehrere Möglichkeiten bzgl. des Löschens am Ziel, wenn der Papierkorb verwendet wird oder ein Ordner für gelöschte Dateien. Legen Sie hier fest, ob nur die letzte Version durch den Papierkorb oder den Ordner für gelöschte Dateien geschützt wird, oder ob alle Versionen dorthin verschoben werden sollen, anstatt sofort gelöscht zu werden.

Die Nichtexistenz zu löschender Dateien auf der anderen Seite doppelt überprüfen

Je nach Einstellungen werden Dateien von einer Seite gelöscht, wenn sie auf der anderen Seite nicht mehr existieren. In manchen Fällen (z. B. FTP, Internetverbindung) könnte aber das Auflisten der Dateien nicht 100%ig zuverlässig sein. Dieser Haken bewirkt, dass vor dem Löschen noch einmal auf zwei verschiedene Weisen überprüft wird, ob die Datei wirklich nicht mehr vorhanden ist. Dies kann allerdings eine Weile dauern, wenn viele Dateien zu löschen sind.

Keine Dateien löschen (nur Ordner)

Eine sehr selten gebrauchte Option. Unter bestimmten Umständen soll das Programm eventuell nur leere Ordner löschen, aber keine Dateien.

Erst löschen, dann kopieren

Dieser Haken bewirkt, dass zunächst Dateien gelöscht werden, bevor neue Dateien kopiert werden. Dies ist standardmäßig der Fall, um am Ziel Platz zu sparen. Aus Sicherheitsgründen könnten Sie jedoch die umgekehrte Reihenfolge bevorzugen und den Haken entfernen.


Profileinstellungen - Dateien/Weitere

Windows-API-Kopierfunktion verwenden

Zum Kopieren der einzelnen Dateien steht eine integrierte hocheffiziente Kopierfunktion zur Verfügung. Alternativ kann die Windows-API-Kopierfunktion verwendet werden, die auch der Windows Explorer verwendet. Die Windows-API-Funktion ist manchmal langsamer, aber gelegentlich auch kompatibler mit manchen Geräten wie z. B. USB-Festplatten. Beim Kopieren über das Netzwerk schaltet sich diese Option beim ersten Profilstart automatisch an, kann danach jedoch wieder ausgeschaltet werden.

Nur X Dateien kopieren

Hier können Sie die Anzahl der kopierten Dateien begrenzen. Die restlichen Dateien werden dann erst beim nächsten Durchlauf kopiert, solange, bis alle Dateien kopiert worden sind.

Bandbreite max: ... MegaBytes/sec

Hier kann zur Rücksichtnahme auf Netzwerkbandbreiten oder langsamere Wechseldatenträger eine Begrenzung der pro Sekunde zu kopierenden Megabytes angegeben werden. Diese Beschränkung kann während des Kopiervorganges aus- und eingeschaltet werden.

Globale und Gruppenlimits ignorieren

Dieser Haken bewirkt, dass die weiteren Bandbreiten-Limits für dieses Profil ignoriert werden. Das Globale Bandbreitenlimit geben Sie auf dem Dialogfenster Programm-Optionen unter Erweitert an. Gruppen-Limits können Sie in der Profilübersicht mit der rechten Maustaste angeben.

Keine Dateien ersetzen

Eine selten benutzte Einstellung. Dateien werden im Rahmen der Synchronisation zwar hinzugefügt, aber ältere Dateien werden nicht aktualisiert.

Keine Dateien hinzufügen

Dies bewirkt, dass nur bereits auf beiden Seiten existierende Dateien aktualisiert werden, aber keine neuen Dateien kopiert werden, die noch nicht auf der anderen Seite existieren.

An bestehende kleinere Dateien immer hinten anfügen

Diese Option wird selten verwendet, ein Anwendungsfall wird bei der folgenden Option beschrieben, mit welcher dieses Kontrollkästchen meistens kombiniert wird.

Größere Dateien immer als neuer ansehen (Dateidatum ignorieren)

Diese Option wird selten verwendet, sie kann zum Beispiel sinnvoll sein, wenn eine immer größer werdende Log-Datei laufend gespiegelt werden soll. Dabei steht fest, dass die größere Datei auch die neuere ist und somit zur anderen Seite kopiert werden muss. Dies ist bei großen Logdateien insbesondere in Kombination mit der vorherigen Option sinnvoll.

Zieldateiexistenz beim Kopieren nochmals überprüfen

Normalerweise wird beim Start des Kopiervorgangs nochmals überprüft, ob die Datei am Ziel bereits existiert. Da dies bei einigen NAS-Laufwerken langsam sein kann, kann die Option abgeschaltet werden.

Zeit/Größe erneut vergleichen

Mit diesem Haken wird direkt vor dem Kopieren noch einmal verglichen, ob die Kopierrichtung stimmt und die Datei kopiert werden muss. Das kann sinnvoll sein, wenn sich zwischen dem Einlesevorgang der Ordner und dem Kopieren der Datei noch etwas geändert hat.

Datei-Zeitangaben nicht spiegeln

Diese Einstellung bewirkt, dass die kopierten Dateien auf der Zielseite die aktuelle Systemzeit erhalten und nicht die Originalzeit der Quelldatei.

Letzte Zugriffszeit bei Quelldateien erhalten

Diese Option bewirkt, dass der Zeitstempel des letzten Zugriffs der Quelldateien nach dem Zugriff durch diese Software wieder zurückgesetzt wird, dass keinerlei Veränderung an der Quellseite zu bemerken ist.


Profileinstellungen - Ordner

Leere Ordner erzeugen

Hier können Sie angeben, ob leere Ordner, die auf einer Seite existieren, auf der anderen erzeugt werden sollen.

Leer gewordene Ordner entfernen

Diese Einstellung bestimmt, ob Ordner gelöscht werden sollen, die durch die Synchronisation geleert worden sind. Dies kann z. B. beim Verschieben von Dateien oder (im Modus Exakte Spiegelung) durch das Löschen von Dateien geschehen.

Rechts pro Lauf neuen Ordner erstellen

Wenn Sie das Profil für die Datensicherung verwenden, können Sie auch für jede Datensicherung einen eigenen Zielordner erstellen lassen. Der Ordnername beinhaltet das Datum der Sicherung. Diese Einstellung muss zusammen mit den beiden "Archiv"-Attribut-Filtern verwendet werden (siehe Filter ). Da sämtliche Backups in verschiedenen Ordnern verteilt sind, kann die Software nicht selbständig feststellen, ob eine Datei schon früher gesichert worden ist. Daher muss sie sich auf das "Archiv"-Attribut verlassen, mit welchem Windows signalisiert, dass eine Datei verändert oder neu erstellt worden ist und gesichert werden sollte.

Rechts keine Ordner verwenden

Mit dieser Option werden alle Dateien aus jedweden Unterordnern der linken Seite in den Ausgangsordner der rechten Seite kopiert. Auf der rechten Seite werden keine Ordner erstellt, und der Inhalt von etwaigen bereits vorhandenen Ordnern wird ignoriert.

Zwischenspeicherziel verwenden

Hier kann ein Interims-Ordner angegeben werden, in den die zu kopierenden Dateien zuerst kopiert werden. Erst wenn alle Dateien dort angekommen sind, werden sie in den endgültigen Zielordner verschoben.


Profileinstellungen - Allgemein

Ausführen vorher/nachher

Über dieses Kontrollkästchen können Sie Batch-Dateien oder Skripte festlegen, die vor und/oder nach Ausführung des Profils gestartet werden.

Email-Einstellungen

Mit dieser Option können die globalen Benachrichtigungseinstellungen profilspezifisch abgewandelt werden.

Benutzer *

Hier können Sie angeben, dass das Profil unter einem anderen Benutzerkonto laufen soll. Dafür benötigen Sie Benutzernamen und Passwort des gewünschten Kontos. Dadurch können Sie auf die Ordner des entsprechenden Benutzers zugreifen.

Netzwerkverbindungen *

Falls Sie bemerken, dass der Timer nicht immer Zugriff auf Netzwerklaufwerke hat, können Sie hier die Angaben hinterlegen, damit der Synchronizer vor dem Ausführen des Profils die Netzwerkverbindung herstellen kann.

Datenträgerbezeichnung rechts überprüfen

Diese Einstellung wird benutzt, wenn Sie sichergehen wollen, dass das Profil nur läuft, wenn sich in dem Laufwerk das richtige Backup-Medium befindet. Wenn diese Option angewählt ist, wird die Volume-Bezeichnung des Laufwerks eingelesen. Sie können auch mehrere Backupmedien mit derselben Volume-Bezeichnung verwenden.

Vorschau mit Häkchen

Hier können Sie angeben, dass die Dateiauswahl in der Synchronisations-Vorschau mit Kontrollkästchen gemacht werden soll. Dies wird hauptsächlich vom Wiederherstellungs-Assistenten verwendet.

Speicherplatz überprüfen

Normalerweise überprüft das Programm vor dem Kopieren, ob genügend Speicherplatz am Ziel vorhanden ist. Falls es hier zu irgendwelchen Problemen kommt, können Sie das abschalten.

Nach diesem Job herunterfahren

Hier können Sie angeben, in welchen Situationen der Rechner nach Ausführen des Jobs heruntergefahren werden soll.

* = nur in der Professional-Version verfügbar


Profileinstellungen - Masken

Dateimaske(n)

Geben Sie an, welche Dateien verarbeitet werden sollen, (all) oder * bedeutet: alle Dateien. Alternativ können Sie Dateimasken wie *.doc oder *.xl? angeben. Sie können auch vollständige Dateinamen hier angeben, aber keine Ordner.

Die Liste der Masken oder der zu kopierenden Dateien kann auch von einer Textdatei eingelesen werden. Hierzu geben Sie am Anfang einer Zeile einen Doppelpunkt gefolgt vom vollständigen Dateipfad der Textdatei an.

Ordnermasken...

Hier erscheint ein zweites Dialogfenster, in welchem Sie Masken für Ordnernamen angeben können (ähnlich den Dateimasken). Zusätzliche Optionen in dem Dialogfenster machen diese Möglichkeit besonders vielseitig.

Einschränkungen...

Diese selten verwendete Option ermöglicht es Ihnen, durch weitere Masken zu festzulegen, dass in einer Kopierrichtung nur bestimmte Dateitypen kopiert werden sollen, während in der anderen Kopierrichtung alle in dem Hauptfeld Dateimask(en) angegebenen Dateien kopiert werden.

Backupdateien kopieren (*.$?$.*)

Wenn die Einstellung, mehrere ältere Versionen zu erhalten, verwendet wird (siehe Mehr ), dann erstellt die Software Sicherungsdateien mit Namen wie MeineDatei.$1$.doc. Damit diese Dateien bei der nächsten Synchronisation nicht zurückkopiert werden, werden Dateien mit solchen Namen automatisch ausgeschlossen, auch ohne dass Sie dies als Dateimaske angeben. Wenn Sie aber diesen fest eingebauten Ausschluss abschalten möchten, dann machen Sie hier ein Häkchen.


Profileinstellungen - Ausnahmen

Ausnahmen

Hier können bestimmte Dateien oder Ordner ausgeschlossen werden, wie z. B. *.tmp oder *.bak. Sie können auch vollständige Dateinamen oder Ordnernamen angeben.

Beispiel: *.bak; *Archiv* (alle Dateien und Ordner mit Endung ".bak" oder dem Word "Archiv" im Namen werden ausgeschlossen)

Sie können auch vollständige Pfade angeben. Wenn Sie zum Beispiel den Ordner mit Namen "Archiv" immer ausschließen wollen, egal an welcher Stelle der Ordnerhierarchie er auftaucht, dann geben Sie nur an:

Archiv

Wollen Sie jedoch nur einen bestimmten Archiv-Ordner ausschließen, dann geben Sie z. B. an:

\Archiv

C:\Archiv

Dokumente\Archiv

Die Liste der Masken oder der zu kopierenden Dateien kann auch von einer Textdatei eingelesen werden. Hierzu geben Sie am Anfang einer Zeile einen Doppelpunkt gefolgt vom vollständigen Dateipfad der Textdatei an.

Nicht kopieren oder Komplett ignorieren

Diese Optionen sind nur relevant, wenn Ihr Profil auch gelöschte Dateien verarbeitet. Nicht kopieren bedeutet dann, dass Dateien, die von den Ausschlussmasken erfasst werden, zwar nicht kopiert werden, aber sehr wohl vom Ziel gelöscht werden, wenn sie an der Quelle fehlen. Umgekehrt bedeutet Komplett ignorieren, dass solche Dateien nicht vom Ziel gelöscht werden, selbst wenn sie an der Quelle nicht mehr existieren.

Globale Ausschlussmasken beachten

Zusätzlich zu den Ausschlussmasken im Profil gibt es auch Globale Ausschlussmasken, die für alle Profile gelten. Diese können bei den Programm-Einstellungen eingesehen und verändert werden. Sie können diesen Haken entfernen, wenn die Globalen Ausschlussmasken nicht gelten sollen.


Profileinstellungen - Allgemeine Filter

Versteckte Dateien verarbeiten

Diese Option bestimmt, ob versteckte Dateien von der Software gesehen und verarbeitetet werden sollen.

Versteckte Ordner verarbeiten

Diese Option bestimmt, ob versteckte Ordner von der Software gesehen und verarbeitetet werden sollen.

Nur Dateien mit Archiv-Attribut kopieren

Diese Einstellung wird nur für die Datensicherung verwendet. Wannimmer eine Datei verändert oder erstellt wird, setzt Windows das Archiv-Dateiattribut. Dies signalisiert, dass die Datei gesichert werden sollte. Bei normalen Synchronisationen ist dies nicht nötig, da sich aus dem Vergleich der linken und rechten Seite automatisch ergibt, welche Dateien kopiert werden müssen. Wenn aber das Backup-Medium nicht immer alle älteren gesicherten Dateien noch enthält, dann kann durch Beachtung des Archiv-Attributs verhindert werden, dass Dateien überflüssigerweise nochmals gesichert werden. Diese Einstellung wird mit der folgenden kombiniert:

Archiv-Attribute zurücksetzen

Diese Einstellung wird in Verbindung mit der vorherigen verwendet. Damit die vorherige Option sinnvoll ist, muss der letzte oder einzige Backup-Job eines Datenordners die Archiv-Attribute der gesicherten Dateien zurücksetzen.

Links zu Dateien folgen

Diese Option ist notwendig, damit das Programm auch Dateien sieht, die über Symbolische Links verknüpft sind. Dies kommt besonders beim Windows Home Server häufig vor.

Links zu Ordnern folgen

Hier wird angegeben, ob Symbolische Links zu Ordnern wie normale Ordner behandelt werden (es wird ihnen also gefolgt).

Auch wenn die Option angeschaltet ist, werden nicht erreichbare Ordner-Abzweigpunkte ignoriert. Diese kommen unter Vista als Stellvertreter für alte Windows-Programme vor, z. B. C:\Users\Default\Anwendungsdaten


Profileinstellungen - Dateialter und Größe

Nur Dateigrößen von min. ... Bytes bis max ... Bytes

Diese Option ermöglicht es, nur Dateien mit bestimmten Größen zu kopieren. Beispiele für Größenangaben: 512, 2.125k, 5M, 2G.

Änderungsdatum von min. ... bis max ... / Dateialter

Mit diesen Angaben wird die Auswahl auf Dateien beschränkt, deren Datum der letzten Änderung mindestens auf einer Seite des Vergleichs innerhalb des angegebenen Zeitraums ist.

Dateialter

Alternativ können Sie hier das gewünschte Dateialter angeben.

Zeitfilter gelten auch für Ordner

Diese Option findet nur selten Anwendung, da die Zeitangabe der letzten Änderung bei Ordnern unter Windows oft nicht so zuverlässig ist wie bei Dateien.

Zieldatum für die Wiederherstellung

Dieses Feld wird vom Wiederherstellungsassistenten verwendet, wenn Sie angeben, dass Sie nicht den Stand der letzten Sicherung wiederherstellen möchten, sondern einen älteren.


Profileinstellungen - Sicherheit/Beaufsichtigt

Auf diesem Registerblatt geben Sie an, welche Warnungen und Sicherheitsabfragen während des beaufsichtigten Kopiervorganges erfolgen sollen.


Profileinstellungen - Spezielle Sicherheitsabfragen

Diese Sicherheitsabfragen erscheinen zusätzlich zu den Standard-Warnungen, um Situationen zu erkennen, in denen ungewöhnlich viele Dateien gelöscht werden könnten.

Die speziellen Sicherheitsabfragen können sogar auch im unbeaufsichtigten Modus verwendet werden. Dann erscheinen die Warnungen mit einem Timeout, und wenn der Benutzer nicht innerhalb der Timeout-Zeit die Löschungen bestätigt, wird das

Profil ohne Löschungen durchgeführt.


Profileinstellungen - Sicherheit/Unbeaufsichtigt

Diese Optionen geben an, wie die Software sich im unbeaufsichtigten Modus verhält.

Schreibgeschützte Dateien überschreiben

Wenn diese Option angewählt ist, überschreibt die Software auch schreibgeschützte Dateien im unbeaufsichtigten Modus. Im beaufsichtigten Modus wäre dafür eine Bestätigung des Benutzers notwendig. Wenn diese Option ausgeschaltet ist und das Profil unbeaufsichtigt läuft, werden solche Dateien ohne weiteren Hinweis übersprungen.

Größere mit kleineren überschreiben (falls erforderlich)

Bei Auswahl dieser Einstellung überschreibt die Software bei Bedarf größere Dateien mit kleineren im unbeaufsichtigten Modus. Im beaufsichtigten Modus wäre dafür eine Bestätigung des Benutzers notwendig. Wenn diese Option ausgeschaltet ist und das Profil unbeaufsichtigt läuft, werden solche Dateien ohne weiteren Hinweis übersprungen.

Bei exakter Spiegelung neuere Dateien überschreiben (falls erforderlich)

Um eine exakte Kopie zu erzeugen, muss der Modus Exakte Spiegelung ggf. neuere Dateien mit älteren überschreiben. Im beaufsichtigten Modus wäre dafür eine Bestätigung des Benutzers notwendig. Wenn diese Option ausgeschaltet ist und das Profil unbeaufsichtigt läuft, werden solche Dateien ohne weiteren Hinweis übersprungen.

Dateilöschung erlaubt

Um eine exakte Kopie zu erzeugen, muss der Modus Exakte Spiegelung ggf. auch Dateien löschen. Im beaufsichtigten Modus wäre dafür eine Bestätigung des Benutzers notwendig. Damit das Löschen unbeaufsichtigt durchgeführt wird, muss es hier freigeschaltet werden.

Spezielle Sicherheitsabfragen aktivieren

Hier geben Sie an, ob die Grenzen der Speziellen Sicherheitsabfragen auch im unbeaufsichtigten Modus gelten sollen. Da dies häufig dazu führt, dass Dateien nicht gelöscht werden, obwohl sie es sollen, ist diese Option standardmäßig aus.

Siehe Spezielle Sicherheitsabfragen .


Profileinstellungen - Spezial

Cache für Ziel-Dateiliste

Durch den Cache können Sie vermeiden, dass die Order der Zielseite bei jedem Durchlauf eingelesen werden müssen. Stattdessen schaut der Synchronizer im Cache nach, welche Dateien bereits zum Ziel kopiert wurden. Diese Funktion eignet sich gut für Backup-Profile. Sie eignet sich nicht, wenn auch andere Benutzer oder Programme auf der Zielseite Veränderungen vornehmen. Da das Profil die Ordner der Zielseite nach dem ersten Durchlauf nicht mehr anschaut, erkennt es keine Veränderungen am Ziel, die von Dritten gemacht werden.

Rechte und Freigaben verarbeiten *

Es erscheint ein separates Dialogfenster mit Einstellungen, die es ermöglichen, die Sicherheitseinstellungen der Ordner und Dateien zu erhalten sowie Ordnerfreigaben auf einen anderen Computer zu übertragen.

Partielles Aktualisieren von Dateien *

Diese Option ermöglicht es, größere Dateien nicht bei jedem Durchlauf komplett zu kopieren, sondern nur die geänderten Teile zu aktualisieren. Dies funktioniert gut bei Datenbanken wie SQL oder Outlook. Es hat keine Wirkung bei Dateien, wo bereits bei einer kleinen Veränderung sich die Inhalte verschieben, wie z. B. Word-Dateien.

Beim partiellen Aktualisieren müssen die beteiligten Ordner auf einem lokalen Laufwerk oder einem Laufwerk im LAN oder VPN sein oder auf einem SSH-Server. Weitere Dokumentation existiert momentan nur auf Englisch:

http://www.superflexible.com/partial.htm

Alternate Data Streams

Alternate Data Streams von Dateien werden mitkopiert, wenn Sie die Windows-API-Kopierfunktion verwenden (siehe Profileinstellungen - Dateien/Weitere ). Dafür brauchen Sie also hier kein Häkchen zu setzen! Die Option auf diesem Registerblatt dient einem sehr seltenen Fall, nämlich dem, dass Sie in Ihrem Windows Server einen Macintosh-Share angelegt haben, wo die Macintosh Resource Forks und Finder Infos in einem Alternate Data Stream abgelegt haben. Um diese Daten auf NAS-Laufwerken oder über Internet-Protokolle zu sichern, muss der Stream in separaten AppleDouble-Dateien abgelegt werden. Das können Sie mit dieser Option erreichen.

Cache für Quellseite verwenden

Diese Option wird vom Wiederherstellungsassistenten verwendet, wenn die Liste der verfügbaren Dateien für die Wiederherstellung aus der Datenbank gelesen werden soll anstatt direkt von den Backup-Ordnern. Für regelmäßig ausgeführte Profile kann diese Option nicht verwendet werden, da das Profil dann keine Veränderungen auf der Quellseite mehr sieht!

Listing links/rechts via Remote Service *

Diese Option ermöglicht es, den Remote Service zu benutzen, um das Einlesen der Ordner zu beschleunigen. Dazu wird der Remote Service auf dem entfernten Computer installiert und konfiguriert. Er übernimmt dann das Einlesen der Dateiliste und stellt sie in einer einzelnen Datei zum Download zur Verfügung. Der Synchronizer wiederum wartet auf den Download und lädt dann selbständig das Listing herunter, wodurch der Vorgang stark beschleunigt werden kann.

Falls das Zielsystem empfangene Dateien verändert und die Größe ändert, diese Dateien sofort wieder zurückkopieren

Diese selten verwendete Option kann hilfreich sein z. B. bei Sharepoint-Ordnern, wo der Server empfangene Dateien sofort nach Erhalt mit zusätzlichen Tags versieht und dadurch die Größe ändert. Um Schwierigkeiten bei weiteren Synchronisationsdurchläufen zu vermeiden, kann diese Option verwendet werden, um diese veränderten Dateien sofort wieder zurückzukopieren, damit auf beiden Seiten dieselben Dateien vorhanden sind.

* = nur in der Professional-Version verfügbar


Profileinstellungen - Datenbank

Diese Felder werden automatisch ausgefüllt und müssen vom Anwender nicht geändert werden. Den Speicherort für die Datenbank können Sie in den Programmoptionen festlegen.


Profileinstellungen - Versionierung

Beim Ersetzen Versionen erhalten

Wenn Dateien auf einer Seite durch neuere Versionen von der anderen Seite ersetzt werden, kann Syncovery die älteren Versionen erhalten, indem er sie umbenennt und auf Wunsch in spezielle Ordner für ältere Versionen verschiebt.

Es stehen verschiedene Einstellungen zur Verfügung, um das Verhalten genau zu steuern.

Dateinamenkodierung

Die Dateinamenkodierung bewirkt, dass alle Dateien, die von links nach rechts kopiert werden, einen kodierten Dateinamen erhalten. Dieser besteht aus dem normalen Dateinamen, in den zusätzlich das Datum und die Uhrzeit der letzten Änderung eingebaut wird. Auf diese Weise kann der Zeitstempel der Datei auch bei Servern erhalten bleiben, die ihn normalerweise verlieren.

Beim Einlesen der Dateiliste und beim Kopieren von rechts nach links werden die originalen Dateinamen wiederhergestellt, und es wird der kodierte Zeitstempel verwendet.

Die Dateinamenkodierung kann auch mit der Option "Beim Ersetzen Versionen erhalten" kombiniert werden. Der Unterschied zur normalen Umbenennung mit Zeitstempel ist, dass bei der Dateinamenkodierung alle Dateien kodiert werden, auch die neuesten.


Profileinstellungen - Synthetische Backups

Das Synthetische Backup kombiniert Partielles Aktualisieren, Versionierung, Dateinamenkodierung und Zippen. Es kann mit jeder Art Backup-Speicher verwendet werden, einschließlich FTP und anderer Internetprotokolle. Die Zip-Dateien können verschlüsselt werden. Das Synthetische Backup kann auch als Differenzielle Versionierung beschrieben werden.

Es werden dabei an jedem Backuptermin nur die geänderten Blöcke jeder Datei gezippt und hochgeladen. Am Ziel entstehen also im Lauf der Zeit immer mehr kleine Backupdateien für jede Originaldatei. Alle diese inkrementellen Versionen müssen in demselben Ordner aufbewahrt werden, damit die Wiederherstellung funktioniert.

Um jedoch die Anzahl der benötigten Dateien am Ziel ein wenig zu beschränken, wurden die Prüfpunkte eingeführt. Prüfpunkte fassen jeweils die Änderungen mehrerer kleinerer inkrementeller Dateien zusammen, sodass nach einer gewissen Zeit einige der älteren Dateien gelöscht werden können. Dies macht das Programm automatisch unter Berücksichtigung der jeweiligen Abhängigkeiten der Versionen und der Einstellungen für das Synthetische Backup.


Profileinstellungen - Versionierung/Erweitert

Dateinamen links / rechts nicht dekodieren

Wenn Sie Ordner kopieren möchten, die von der Software erstellte kodierte Dateinamen enthalten, dann benötigen Sie eventuell diese Option. Sie ermöglicht es, Ordner mit solchen Dateien komplett zu kopieren, ohne dass der Synchronizer die Namen dekodieren würde. Obwohl seit der Version 6 auch kodierte Dateinamen auf der linken Seite korrekt verarbeitet werden, kann diese Option notwendig sein, wenn Sie komplette 1:1 Kopien eines Backupordners erstellen möchten, der kodierte Dateinamen enthält. Dies trifft auch zu, wenn die Dateien vom Synchronizer einzeln gezippt worden sind, denn auch dabei wird der Dateiname kodiert (nämlich die Originaldateigröße wird in den Dateinamen eingefügt).

Kodierte Dateinamen dürfen normalerweise nur auf der rechten Seite einer Synchronisation vorkommen. Kommen sie auch links vor, sollte diese Option angekreuzt werden.

Versionsnummern in Klammern entfernen

Diese selten benötigte Option entfernt beim Kopieren von rechts nach links Versionsnummern in Klammern, z. B. wird aus der Datei Dokument(2).doc die Datei Dokument.doc. Diese Funktion hat nichts mit den Versionierungsarten zu tun, die der Synchronizer selbst verwendet.


Profileinstellungen - Zip-Komprimierung

Dateien einzeln zippen / komprimieren *

Mit dieser Einstellung werden Dateien, die von links nach rechts kopiert werden, komprimiert, während Dateien, die von rechts nach links kopiert werden, dekomprimiert werden. Der Dateiname wird auf der rechten Seite verlängert: die Originalgröße der Datei sowie die Endung .zip werden hinzugefügt. Bei dieser Methode kann der Synchronizer die beiden Seiten immer transparent vergleichen und er sieht genau, welche Dateien mit welcher Originalgröße auf der Zielseite bereits existieren. Daher ist dies die empfohlene Methode für Datensicherungen.

ZIP-Archive mit mehreren Dateien *

Sie können auch mehrere Dateien in ein ZIP-Archiv packen lassen, allerdings kann der Synchronizer bei zukünftigen Durchläufen nicht in diese Zip-Archive hineinschauen und kann daher den Inhalt nicht bei der Erstellung der Dateiliste und bei der Synchronisationsvorschau berücksichtigen. Die Auswahl der zu kopierenden Dateien kann dann z. B. über Filter erfolgen. Die Archiv-Attributsfilter eignen sich hierfür in der Regel gut.

ZIP-Archive können auch an einen Server oder anderen Computer gesandt werden, wo sie dann vom Syncovery Remote Service entpackt werden. Dies ist eine selten verwendete Funktion, die dazu dient, die Bandbreite langsamerer Netzwerkverbindung oder VPNs besser auszunutzen. Die zum entfernten Computer zu übertragenen Dateien werden in ZIP-Packages verpackt, wobei die Anzahl der Dateien pro ZIP-Package festgelegt werden kann. Auf dem Zielcomputer muss der Syncovery Remote Service laufen, um die ankommenden ZIP-Packages zu entpacken.

Direkt in die Zieldatei zippen

Diese Option verhindert, dass zunächst eine temporäre Datei im TEMP-Ordner erstellt wird.

Immer entzippen

Diese Option bewirkt, dass beim Kopieren von rechts nach links auch ZIP-Dateien entpackt werden, die nicht vom Synchonizer stammen.

* = nur in der Professional-Version verfügbar


Profileinstellungen - Verschlüsselung

Rechts Dateien verschlüsseln *

Für die optimale Verschlüsselung sollte der Passwortsatz etwa 32 Zeichen umfassen. Dateien, die von links nach rechts kopiert werden, werden verschlüsselt, während Dateien, die von rechts nach links kopiert werden, entschlüsselt werden.

Es sollte möglichst die ZIP-kompatible AES-Verschlüsselung verwendet werden. Dies bedeutet, dass die Dateien auch gezippt werden. Trotzdem ist dies die schnellste Verschlüsselungsmethode und den anderen verfügbaren Methoden weit überlegen.

* = nur in der Professional-Version verfügbar


SmartTracking

SmartTracking wird verwendet, wenn Sie regelmäßig dieselben Ordner in beiden Richtungen synchronisieren, und nicht nur neue und geänderte Dateien synchronisieren möchten, sondern auch Löschungen, Verschiebungen und Konflikte erkennen lassen möchten. SmartTracking kann feststellen, auf welcher Seite eine Datei verschoben oder gelöscht worden ist, und ob die Datei evtl. auf beiden Seiten bearbeitet wurde (Konflikt).

SmartTracking bewahrt Informationen in einer Datenbank, die mit dem Profilnamen verknüpft ist. Beim ersten Start speichert die Software den Status der Dateien. Ab dem zweiten Mal werden die Einstellungen des SmartTracking-Dialogfensters aktiv. Benennen Sie das Profil nicht um, da es sonst die Datenbank nicht wiederfindet. Verwenden Sie nicht mehr als ein Profil für die Synchronisation derselben Ordner.

Dies sind die Funktionen des SmartTracking:

Verschobene Dateien

Wenn eine Datei nicht verändert, sondern nur verschoben worden ist, dann kann SmartTracking durch Vergleich des aktuellen Zustandes mit der Datenbank herausfinden, auf welcher Seite die Verschiebung vorgenommen worden ist und die gleiche Verschiebung auf der anderen Seite vornehmen.

Gelöschte Dateien

Wenn auf einer Seite Dateien gelöscht worden sind, kann SmartTracking dies in der Regel erkennen. Solche Dateien können Sie dann auf der anderen Seite ebenfalls löschen lassen. Zur Sicherheit wird empfohlen, die Datei nicht endgültig zu löschen, sondern nur in einen speziellen Ordner für gelöschte Dateien verschieben zu lassen, welchen Sie unten in dem SmartTracking-Dialogfenster angeben können. Bitte geben Sie für beide Seiten der Synchronisation eigene Ordner an, um zu vermeiden, dass gelöschte Dateien auf eine andere Festplatte verschoben werden müssen.

Konflikte

Bei der normalen Synchronisation ohne SmartTracking würde bei Dateien, die auf beiden Seiten bearbeitet worden sind, einfach die jüngste Datei zur anderen Seite kopiert. Das ist meistens korrekt, aber es kann auch ein Problem sein, wenn die Datei auf den beiden Seiten z.B. von verschiedenen Personen verändert worden ist. Mittels SmartTracking können Sie solche Dateien als KONFLIKT markieren lassen. Danach müssen Sie in der Synchronisationsvorschau selbst die gewünschte Kopierrichtung angeben.

Oder Sie bestimmen, dass Konflikt-Dateien auf einer Seite umbenannt werden und dann beide Versionen synchronisiert werden. Eine Datei erhält dann eine Versionsnummer, z. B. Datei-1.txt, Datei-2.txt usw.

Unterschiedliche Dateien (gleicher Name) nicht in Datenbank sind Konflikt

Diese Option betrifft Dateien, die noch nicht in der SmartTracking-Datenbank vorhanden sind. Normalerweise werden bei solchen Dateien keine Konflikte erkannt, sondern es wird einfach die neuere Datei zur anderen Seite kopiert. Wenn Sie diesen Haken setzen, dann werden solche Dateien wie Konflikte behandelt. Dies ist jedoch nur selten ratsam.

Optionen

Erkennung unveränderter Dateien trotz abweichendem Zeitstempel

Die Einstellungen auf dem Registerblatt Optionen werden nur selten verwendet. Sie können Sie unter anderem nutzen, um mit Servern umzugehen, bei denen die Dateien immer das aktuelle Systemdatum erhalten. Bei älteren FTP-Servern und bei vielen WebDAV-Servern ist es nämlich so, dass der Synchronizer das Datum der Dateien nicht angleichen kann. Um daraus resultierende Unterschiede ignorieren zu können, können Sie hier das Häkchen für die entsprechende Seite setzen.

Siehe auch:

Weitere Einstellungen

Syncovery

Haupt-Dialogfenster


Synchronisationsvorschau

Dieses Fenster zeigt alle Dateien auf beiden Seiten. Sie können sehen, auf welchen Seiten eine bestimmte Datei existiert, indem Sie in die Spalten Datum und Größe schauen. Im linken Teil haben Sie verschiedene Optionen, um zu bestimmen, welche Arten von Dateien angezeigt werden. Wenn Sie den Knopf Start betätigen, werden nur die Dateien verarbeitet, die in der angezeigten Liste enthalten sind, und nur, wenn sie eine Aktion in der entsprechenden Spalte angegeben haben (siehe Screenshot). Um die Aktionen für bestimmte Dateien zu verändern, markieren Sie die Dateien und verwenden Sie den Knopf Menü oder rufen Sie das Menü mit der rechten Maustaste auf.

Mögliche Aktionen

è : nach rechts kopieren

ç : nach links kopieren

VERSCH

Die Datei wird auf einer Seite in einen anderen Ordner verschoben. Benutzen Sie die "Verschieben"-Optionen links unten, um zu bestimmen, auf welcher Seite die Dateipositionen dem Vorbild der gegenüberliegenden Seite nach angepasst werden.

LÖSCH

Die Datei wird gelöscht. Dies kann nur im Modus Exakte Spiegelung geschehen, oder wenn das Löschen der Datei manuell ausgewählt wurde.

Siehe auch:

Syncovery

Haupt-Dialogfenster


Menü zur Dateiliste

Dieses Menü können Sie verwenden, um die Aktion markierter Dateien festzulegen. Markieren Sie einfach eine oder mehrere Dateien oder Ordner und betätigen Sie die rechte Maustaste im markierten Bereich, oder betätigen Sie den Menü Knopf..

Siehe auch:

Dateiliste (Synchronisationsstatus)

Vorteile

Kauf


Profilübersicht

Dies ist die Hauptansicht im fortgeschrittenen Modus. Sie sehen alle Profile mit den wichtigsten Eigenschaften und können sie bearbeiten und starten.

Es stehen Ihnen die wichtigsten Funktionen über die Symbolleiste zur Verfügung. Sehr praktisch sind jedoch die Befehle, die Sie über das Kontextmenü durch Klick mit der rechten Maustaste in der Profilliste erhalten.

Neu

Hiermit erzeugen Sie ein neues Profil.

Umbennen

Ändert den Namen des markierten Profils.

Löschen

Löscht das Profil.

Bearbeiten

Um ein Profil zu bearbeiten, wählen Sie es aus und betätigen Sie den Bearbeiten Knopf.

Starten

Der einfache Play-Knopf startet das markierte Profil. Alternativ können Sie mehrere angekreuzte Profile mit dem doppelten Play-Knopf starten. Noch flexibler sind die Start-Befehle, die Sie über das Kontextmenü durch Klick mit der rechten Maustaste in der Profilliste erhalten.

Wenn der unbeaufsichtigte Modus nicht angewählt ist, erscheint als nächstes die Synchronisationsvorschau , in welcher Sie sehen können, welche Dateien kopiert, verschoben, oder gelöscht werden müssen. Dort haben Sie die Möglichkeit, Anpassungen vorzunehmen und dann den eigentlichen Kopiervorgang zu starten.

Es gibt folgende Startmöglichkeiten:

Beaufsichtigt ausführen

Das Profil läuft im Vordergrund und bleibt bei der Synchronisationsvorschau stehen. Sie können die vorgesehenen Aktionen überprüfen und dann den eigentlichen Kopiervorgang starten.

Unbeaufsichtigt ausführen

Das Profil startet ohne Rückfragen im Vordergrund. Nach dem Einlesen der Ordner wird sofort mit dem Kopieren fortgefahren.

Im Hintergrund ausführen

Das Profil startet unsichtbar im Hintergrund. Sie sehen den Fortschritt in der Profilübersicht. Sie können das Profil jederzeit mit dem Stopp-Knopf anhalten. Sie sehen jedoch keine Synchronisationsvorschau. Der Vorteil hierbei ist, dass die Benutzeroberfläche nicht blockiert ist und Sie sofort mit der Arbeit an anderen Profilen fortfahren können. Außerdem können Sie mehrere Profile gleichzeitig laufen lassen.

  • Der Timer


Der Timer

Um Profile automatisch zu bestimmten Zeiten starten zu lassen, muss der Timer laufen. Es gibt drei verschiedene Timer:

Hintergrundtimer

Dies ist der Standard-Timer, der unsichtbar im Hintegrund läuft. Er ist unabhängig von der Benutzeroberfläche. Die Status- und Fortschrittsinformationen des Timers werden jedoch in der Benutzeroberfläche angezeigt. Der Hintergrundtimer kann nur laufen, wenn ein Benutzer unter Windows angemeldet ist. Sie können den Hintergrundtimer sogar sichtbar machen, indem Sie mit der rechten Maustaste auf das Symbol im Infobereich recht unten am Bildschirm klicken und den Befehl Hintergrundfenster zeigen auswählen.

Vordergrundtimer

Der Vordergrundtimer läuft direkt in der Benutzeroberfläche, und es können keine Profile bearbeitet werden, solange er läuft. Daher wird er in der Regel nicht verwendet. Zu Testzwecken kann sein Einsatz interessant sein, wenn Sie die Vorgänge genau beobachten möchten.

Dienst

Der Timer kann auch als Dienst laufen. Die Einrichtung des Dienstes ist etwas komplizierter als die Verwendung des Hintergrundtimers. Beachten Sie, dass das Wort "Installieren" bei Diensten für zwei verschiedene Handlungen verwendet wird. Zum einen können Sie Software installieren, dabei werden die ausführbaren Dateien der Software auf Ihre Festplatte kopiert. Zum anderen können Sie einen Dienst, der bereits als Software auf Ihrem Computer existiert, "installieren", was dann soviel bedeutet wie dass der Dienst unter Windows registriert wird und das Laufen des Timers als Dienst vorbereitet wird.

Weitere Informationen zum Einrichten des Dienstes finden Sie unter

http://www.superflexible.de/docup.htm


Der ExtremeSync-Dienst für Windows NT/2000/XP/2003

Der Syncovery-Dienst für Windows

Der Timer kann als Dienst laufen. Die Einrichtung des Dienstes ist etwas komplizierter als die Verwendung des Hintergrundtimers. Beachten Sie, dass das Wort "Installieren" bei Diensten für zwei verschiedene Handlungen verwendet wird. Zum einen können Sie Software installieren, dabei werden die ausführbaren Dateien der Software auf Ihre Festplatte kopiert. Zum anderen können Sie einen Dienst, der bereits als Software auf Ihrem Computer existiert, "installieren", was dann soviel bedeutet wie dass der Dienst unter Windows registriert wird und das Laufen des Timers als Dienst vorbereitet wird.

Weitere Informationen zum Einrichten des Dienstes finden Sie unter

http://www.superflexible.de/docup.htm

Der Timer


Programm-Optionen

Hier machen Sie allgemeine Vorgaben für die Verhaltensweise des Programms.


Datensicherung und Abgleich gemeinsamer Dateien einer Arbeitsgruppe

Syncovery ist eine solide Lösung zur Dateisicherung und zur Synchronisation gemeinsamer Dateien einer Arbeitsgruppe - auch über das Internet. Zur Zeit erfordert dies ein Medium, das über Laufwerksbuchstaben oder als Netzwerkpfad zur Verfügung steht, oder einen FTP, SSH, WebDAV, oder Amazon S3-Server.

Falls Sie gemeinsame Dateien einer Arbeitsgruppe über einen zentralen Umschlagsplatz synchronisieren möchten, können Sie die Synchronisationssoftware einfach auf jedem PC unabhängig voneinander ausführen. Bitte lesen Sie diese Seite vollständig, um alle Einstellungen korrekt vornehmen zu können.

Für einige Funktionen ist es erforderlich, dass das Sicherungsmedium (oder der zentrale Umschlagsplatz für gemeinsame Dateien) die rechte Seite der Synchronisation darstellt, während die lokale Festplatte auf der linken Seite ist.

Direkter Zugriff auf das Medium

Wenn Sie direkten Zugriff auf den Speicherort für die Datensicherung (bzw. den zentralen Umschlagsplatz für gemeinsame Dateien) haben, dann können Sie einfach eine normale Datei-Synchronisation ablaufen lassen, um Ihre Dateien und/oder den Ort der Datensicherung bzw. den zentralen Umschlagsplatz zu aktualisieren.

FTP-Server als Backup-Medium bzw. zentralen Umschlagsplatz

Wenn Sie einen FTP-Server benutzen wollen, dann aktivieren Sie bitte die Einstellung "Dateinamenkodierung" , welche Datum und Uhrzeit der Dateien in den Dateinamen übernimmt (siehe auch den letzten Hinweis weiter unten).

ZIP-Komprimierung

Um den Dateitransfer zu beschleunigen, können Sie die ZIP-Komprimierung auf der rechten Seite der Synchronisation aktivieren. Dies geschieht unter Profileinstellungen - Zip-Komprimierung . Dateien, die von links nach rechts kopiert werden, werden komprimiert, während Dateien, die von rechts nach links kopiert werden, dekomprimiert werden. Der Dateiname wird auf der rechten Seite verlängert: die Originalgröße der Datei sowie die Endung .zip werden hinzugefügt.

Verschlüsselung Ihrer Daten

Vor allem auf FTP-Servern sollten Sie Ihre Daten verschlüsseln. Diese Funktion wird unter Profileinstellungen - Verschlüsselung eingeschaltet. Für optimale Verschlüsselung sollte der Passwortsatz etwa 32 Zeichen umfassen. Dateien, die von links nach rechts kopiert werden, werden verschlüsselt, während Dateien, die von rechts nach links kopiert werden, entschlüsselt werden. Siehe auch Profileinstellungen - Verschlüsselung

Datum und Uhrzeit der Dateien via FTP

Datum und Uhrzeit einer Datei können nun auch auf FTP-Servern erhalten bleiben, indem diese Angaben in den Dateinamen integriert werden (Dateinamenkodierung). Dies ist für die Datensicherung und den Datenaustausch via zentralen FTP-Server nützlich. Siehe auch Profileinstellungen - Versionierung .


Kommandozeile

/RUN=xyz und /RUNX=xyz Kommandozeilenoptionen

Mit diesen Optionen können Sie per Kommandozeile ein bestimmtes Profil sofort ausführen lassen. Der Name des Profils wird anstelle von xyz angegeben. Der Name darf keine Leerzeichen beinhalten. Bei /RUN=xyz wird das Profil gestartet, und das Programm bleibt geöffnet. Bei /RUNX=xyz wird das Profil gestartet, und das Programm nach Ausführung wieder beendet.

Diese weiteren Optionen sind dazu verfügbar:

/U = unbeaufsichtigter Modus. Das Profil wird gestartet und läuft ohne weitere Bestätigung ab. Falls diese Option nicht angegeben ist, wird nur die Dateiliste angezeigt, und der eigentliche Synchronisationsvorgang muss manuell gestartet werden.

/M = minimieren. Während der Ausführung versteckt sich das Programm im System-Tray. Diese Option impliziert /U.

/INI=xxx Kommandozeilenoption

Zusätzlich zu den INI-Optionen auf dem Registerblatt Optionen , können Sie auf der Kommandozeile eine andere INI-Datei angeben, zum Beispiel /INI=C:\MyIniFile.ini. Diese INI-Datei wird benutzt unabhängig von den Angaben auf dem Registerblatt Optionen. Sie können auch eine INI-Datei angeben, die sich auf einem Netzwerkpfad befindet, zum Beispiel, wenn Sie in einem Unternehmen eine genormte INI-Datei für viele Arbeitsplätze verwenden möchten. Die INI-Datei oder der Netzwerkpfad dürfen auch Nur-Lese-Zugriff haben.

Weitere Informationen finden Sie unter http://www.superflexible.de/docprofi.htm sowie http://www.superflexible.com/docprofi.htm .


Lizensierung

Bitte besuchen Sie unsere Website, um Lizenzen für Syncovery zu erwerben:

www.syncovery.de

Falls Sie Fragen haben, schreiben Sie an info@syncovery.com

Siehe auch:

Syncovery

Vorteile

Superflexible Software


Super Flexible Software

Firmeninformationen

Super Flexible Software Ltd. & Co. KG

Tobias Giesen

Eingetragen beim Amtsgericht Münster, HRA 9716

Internet Site: www.superflexible.de

eMail: tobias@superflexible.de

Telefon: +49 251/20897745

FAX: +49 251/9520-9011

Anschrift

Super Flexible Software Ltd. & Co. KG

Buddenstr. 29-31

48143 Münster

Deutschland

Siehe auch:

Syncovery

Lizensierung