Sicherheit
Zurück Weiter

Sicherheit

XP Home: Administrator-Passwort fehlt
Eingeschränktes Konto: So bremsen Sie Schädlinge aus
Windows-Firewall: Wer darf was?
Prozessdatenbank: Wissen, was läuft
Autostart: Startrampen aufspüren und sperren
Datei-Erweiterungen: Systemweit sichtbar machen
PC Nutzung kontrollieren: Check von Logons und Systemlaufzeit
XP Prome: Fast ein Pro mit zwei Klicks
Ausführ-Sperre: Alle Programme bis auf eine Auswahl verbieten
Lokaler PC: Ordner sperren oder unzugänglich machen
Zurück |  | Weiter
Die 50 wichtigsten Tipps und Tools | Zum Anfang | XP Home: Administrator-Passwort fehlt


XP Home: Administrator-Passwort fehlt
Zurück Sicherheit Weiter

XP Home: Administrator-Passwort fehlt

Problem: Windows XP bietet Sicherheit – vorausgesetzt, das System ist entsprechend konfiguriert. Die Home-Version versäumt aber beim Setup eine wesentliche Abfrage: Anders als XP Professional fragt Sie XP Home bei der Installation nicht nach einem Kennwort für das fest eingebaute Administrator-Konto. Das Admin-Passwort bleibt daher standardmäßig leer. Wer das weiß, erhält beim Start im abgesicherten Modus oder über die Wiederherstellungskonsole jederzeit Zutritt zum System und den Daten.

Lösung: Sie sollten auch in der Home-Version sofort nach der Installation ein Passwort für den Administrator einrichten. Der übliche, dokumentierte Weg führt über den abgesicherten Modus, denn nur hier taucht der Administrator unter „Benutzerkonten“ in der Systemsteuerung auf. Komfortabler setzen Sie ein Passwort für das Administrator-Konto über ein Kommando auf der Befehlszeile. Diese Methode funktioniert auch im normalen Betrieb, umständliche Neustarts sind überflüssig. Öffnen Sie eine Eingabeaufforderung, und geben Sie diesen Befehl ein:

net user administrator <Kennwort>

Für den Platzhalter <Kennwort> geben Sie das gewünschte Passwort an. Damit der Befehl funktioniert, müssen Sie allerdings Administrator-Rechte besitzen – alle anderen Benutzer können das Kommando nicht ausführen.

-dw

Zurück | Nach oben | Weiter
Sicherheit | Zum Anfang | Eingeschränktes Konto: So bremsen Sie Schädlinge aus


Eingeschränktes Konto: So bremsen Sie Schädlinge aus
Zurück Sicherheit Weiter

Eingeschränktes Konto: So bremsen Sie Schädlinge aus

Problem: Sie sind der einzige Benutzer Ihres nicht vernetzten PCs. Allerdings gehen Sie mit dem Rechner ins Internet. Sie wollen verhindern, dass Ihr System sich einen Virus oder Wurm aus dem Web einfängt.

Lösung: Wenn Windows XP auf einer NTFS-Partition installiert ist, besitzt es ein sauberes Konten- und Rechtesystem. Darüber lassen sich die Zugriffsrechte auf Dateien und Ordner für die einzelnen Benutzer steuern. Die Rechte eines Benutzerkontos gelten für alle Anwendungen und folglich auch für Viren, die aus diesem Kontext heraus aktiv werden. Sie können sich also wirksam gegen Eindringlinge und Malware schützen, wenn Sie als eingeschränkter Benutzer surfen. Dann bestehen nämlich beispielsweise keine Schreibrechte auf den „Windows“- und den „Programme“-Ordner oder auf zentrale Registry-Schlüssel. Viren und Würmer scheitern also beim Zugriff auf ihre typischen Ziele. Diesen Schutz bekommen Sie aber nicht umsonst: Er kostet Sie unter anderem das Recht, Anwendungen zu installieren. Solche Einschränkungen führen dazu, dass Anwender aus Bequemlichkeit lieber ständig mit Administrator-Rechten arbeiten und damit Schädlingen Tür und Tor öffnen. Desktop-Firewalls und Virenwächter können das Risiko einer Infektion zwar verringern, aber nicht ausschalten. Ein idealer Kompromiss zwischen Sicherheit und Benutzerkomfort besteht darin, als Administrator zu arbeiten, den Web-Browser jedoch mit eingeschränkten Rechten zu starten. Grundvoraussetzung ist zunächst, dass Sie unter „Systemsteuerung, Benutzerkonten“ einen eingeschränkten User angelegt haben. Für alles Weitere verwenden Sie am besten unser Tool pcwRunas. Damit lassen sich Verknüpfungen anlegen, über die Sie den Browser im eingeschränkten Benutzerkontext starten können, ohne dass das die Rechte der anderen laufenden Anwendungen berührt. Nach der Installation des Tools rufen Sie die pcwRunAsGui.EXE aus dem Programmverzeichnis auf. Im Dialog wählen Sie hinter„Dateiname“ das Programm, das Sie künftig mit eingeschränkten Rechten starten wollen (zum Beispiel „C:\Programme\Internet Explorer\Iexplore.EXE“ oder „C:\Programme\Mozilla Firefox\Firefox.EXE“). Weiter unten geben Sie neben „Benutzername“ und „Kennwort“ die Daten des eingeschränkten Benutzerkontos an und setzen neben „Verknüpfung“ einen beliebigen Namen für den neuen Link ein. Nach einem Klick auf „Übernehmen“ erscheinen die Parameter für pcwRunas noch einmal durch Strichpunkte getrennt – wenn nötig, können Sie sie hier noch korrigieren. Ein letzter Klick auf „Shortcut“ legt die neue Verknüpfung auf dem Desktop an. Zur Kontrolle der Rechte installiert das Setup Programm von pcwRunAs eine Toolbar für den Internet Explorer und den Windows-Explorer (pcwPrivilegien.DLL), die Sie über „Ansicht Symbolleisten, pcwPrivilegien“ einblenden Wenn Sie als Admin arbeiten, sehen Sie ein rotes Warnsignal und die Schaltfläche „Administrator“. Eine kleine Bequemlichkeitseinbuße: Beim Download aus dem Web gelten natürlich die Windows-Ordner des eingeschränkten Kontos: Wenn Sie Daten etwa auf den Desktop laden, landen diese nicht auf dem sichtbaren Admin-Desktop, sondern im Desktop-Ordner des jeweiligen Kontos. Am besten wählen Sie deshalb ein für alle Konten zugängliches Download-Ziel.

-cl

Zurück | Nach oben | Weiter
XP Home: Administrator-Passwort fehlt | Zum Anfang | Windows-Firewall: Wer darf was?


Windows-Firewall: Wer darf was?
Zurück Sicherheit Weiter

Windows-Firewall: Wer darf was?

Problem: Mit SP 2 für Windows XP kam eine neue Firewall zum Einsatz. Standardmäßig ist sie für alle verfügbaren Adapter aktiv und lässt keine ankommenden Verbindungsversuche aus dem Netz zu. Was das bedeutet und wie Sie die Firewall ideal konfigurieren, ist jedoch nicht immer ganz klar.

Lösung: Die Windows-Firewall schützt, wie jede andere Software-Firewall, das System nicht zuverlässig vor Angriffen aus dem Netz, selbst wenn sie richtig eingerichtet ist. Sie verringert aber die Angriffsfläche. In der Standardkonfiguration lässt sie Verbindungen von Ihrem System nach außen zu, blockiert aber Zugriffe von außen. Sie können also zum Beispiel im Internet surfen, jedoch nicht Filesharing betreiben. Einzige Ausnahme sind Zugriffe auf freigegebene Dateien und Drucker über das lokale Netzwerk. Um mehr Verbindungen zuzulassen, legen Sie eine „White List“ mit allen Anwendungen an, auf die über das Netz zugegriffen werden darf. Beim ersten Start eines solchen Programms meldet sich die Firewall per Dialogbox und fragt nach, ob die Verbindung zu diesem weiterhin blockiert werden soll. Wenn Sie diese Frage verneinen, wird die Anwendung in die Liste aufgenommen und darf fortan mit dem Netz kommunizieren. Die erforderlichen Kanäle (Ports) werden beim Starten und Beenden der Anwendung automatisch geöffnet und wieder geschlossen. Um die Firewall manuell zu konfigurieren, klicken Sie in der Systemsteuerung auf „Windows Firewall“. Auf der Registerkarte „Allgemein“ können Sie die Firewall aktivieren oder deaktivieren. Ist sie aktiv, können Sie zusätzlich die Option „Keine Ausnahmen zulassen“ wählen. Das ist zum Beispiel sinnvoll, wenn Sie sich mit Ihrem Notebook am Netz des Flughafens anmelden. So verhindern Sie, dass auf die Anwendungen aus Ihrer Ausnahme-Liste zugegriffen werden kann. Unter „Ausnahmen“ können Sie Ihre „White List“ einsehen. Nach einem Klick auf „Programm“ können Sie eine Anwendung hinzufügen. Über die Schaltfläche „Port“ können Sie einzelne Ports freischalten. Diese bleiben offen, bis Sie sie wieder aus der Liste entfernen. Das ist natürlich ein Sicherheitsrisiko, so dass Sie Ports nur bewusst freigeben sollten. Klicken Sie dazu auf die Schaltfläche „Bereich ändern“. Wenn jeder weltweit den Kanal nutzen darf, wie es etwa beim Filesharing üblich ist, dann wählen Sie „Alle Computer“. Sollen nur PCs im lokalen Netz zugreifen, dann aktivieren Sie „Nur für eigenes Netzwerk“. Es ist sogar möglich, dass nur einzelne PCs mit festen IP-Adressen zugreifen dürfen. In diesem Fall geben Sie die Adressen, jeweils durch ein Komma getrennt, einzeln in die „Benutzerdefinierte Liste“ ein.

Individuelle Brandmauer: Bestimmte Ports können Sie in der Windows-Firewall öffnen, hier zu dem Halflife Spiele Server „Steam“

Abbildung 1. Individuelle Brandmauer: Bestimmte Ports können Sie in der Windows-Firewall öffnen, hier zu dem Halflife Spiele Server „Steam“

-cl

Zurück | Nach oben | Weiter
Eingeschränktes Konto: So bremsen Sie Schädlinge aus | Zum Anfang | Prozessdatenbank: Wissen, was läuft


Prozessdatenbank: Wissen, was läuft
Zurück Sicherheit Weiter

Prozessdatenbank: Wissen, was läuft

Problem: Sie brauchen eine zuverlässige Quelle, die Ihnen genauere Informationen über die vorgefundenen Tasks im Taskmanager gibt, etwa um Schädlinge zu identifizieren.

Lösung: Wir haben für Sie eine Datenbank aufgebaut, die genau diesen Job erledigt. Dazu haben ein Tool entwickelt, das Ihnen helfen, unerwünschte Prozesse zu identifizieren und gezielt abzuschießen. In der Prozessdatenbank finden Sie die Infos, die Ihnen den Durchblick im Prozess-Dschungel verschaffen. Viren und Würmer tarnen sich gern mit den Namen von Windows Standardprozessen, andere tragen nichts sagende und harmlos klingende Namen. Um Schädlinge zu entlarven, brauchen Sie die Programmpfade. Die echten Systemprozesse sind nämlich zu 95 Prozent im Pfad %windir%\system32 anzutreffen und nirgends sonst. Den aber erfährt man im Taskmanager nicht. Jetzt wäre es hilfreich, die Datei-Eigenschaften des jeweiligen Tasks aufzurufen – oft finden sich hier Erstelldatum und Herstellerangaben. Nur: An diese Infos kommen Sie jeweils nur sehr umständlich heran. pcwProcess liefert per Mausklick auf einen Task genau diese Informationen – und mehr: Unser scriptbasiertes Tool ist ein verbesserter Taskmanager und Taskkiller mit Anbindung an die PC-WELT-Prozessdatenbank und erlaubt zusätzlich eine Recherche im Web. Sie starten das Tool für Windows XP ohne Installation einfach per Doppelklick. Nach einer kurzen Analyse zeigt es in einer Tabelle die laufenden Prozesse an. Standardmäßig sehen Sie den Namen und den Pfad der zugrunde liegenden Programmdatei. Ein Klick auf den Button „Eigenschaften“ bringt die Datei-Eigenschaften eines Prozesses auf den Bildschirm. Über die Schaltfläche „PC-WELT“ recherchieren Sie zusätzliche Infos in der PC-WELT-Prozessdatenbank. Bei bestehender Internet-Verbindung öffnet ein Klick darauf ein neues Browser-Fenster mit der Beschreibung. Sollte es noch keine geben, können Sie eine neue Seite im Wiki anlegen. Die Schaltfläche „Google“ funktioniert ähnlich: Sie startet eine Suche nach dem Prozessnamen bei Google. Ein Klick auf den Button „Prozess Beenden“ schießt den ausgewählten Task per Mausklick ab. Bei System-kritischen Prozessen, die nicht beendet werden dürfen, ist die Schaltfläche ausgeblendet. Voraussetzung für „Prozess Beenden“ ist unter Windows XP, dass Sie mit Administratorrechten angemeldet sind. Ein Druck auf <F5> aktualisiert die Taskliste – praktisch, wenn Sie mittlerweile ein paar Prozesse beendet haben. Mit der Tastenkombination <Strg>-<F> rufen Sie einen Dialog auf, über den Sie in der Liste nach einem Prozessnamen suchen können.

Besserer Taskmanager: Mit pcwProcess erfahren Sie schnell ob ein laufender Prozess schädlich ist oder nicht

Abbildung 2. Besserer Taskmanager: Mit pcwProcess erfahren Sie schnell ob ein laufender Prozess schädlich ist oder nicht

-te

Zurück | Nach oben | Weiter
Windows-Firewall: Wer darf was? | Zum Anfang | Autostart: Startrampen aufspüren und sperren


Autostart: Startrampen aufspüren und sperren
Zurück Sicherheit Weiter

Autostart: Startrampen aufspüren und sperren

Problem: Sie haben auf Ihrem Rechner einen Schädling aufgespürt, der nach jedem Systemstart hartnäckig wieder auftaucht. Sie möchten diesen Schädling dauerhaft los werden.

Lösung: Jeder Schädling versucht, automatisch beim Systemstart in den Speicher zu gelangen. Um einen Schädling dauerhaft loszuwerden, müssen Sie dessen Laderampe finden und deaktivieren. Manche Schädlinge schreiben sich vorsichtshalber gleich in mehrere dieser Startrampen. Übersieht man nur eine der Möglichkeiten, sind sie umgehend wieder im RAM. Mit unserem Tool pcwAutostart für alle Windows-Versionen erfahren Sie nach ein paar Klicks, welche Anwendung von wo aus startet, und können jeden Eintrag bei Bedarf ganz einfach löschen. Nach dem Aufruf prüft es alle bekannten Windows-Startrampen – 22 Registry-Schlüssel, fünf Dateien und drei Ordner – auf Einträge oder Verknüpfungen zu Anwendungen, die automatisch aufgerufen werden. Wird es fündig, zeigt es zunächst die Quellen an. Wenn Sie eine dieser Quellen anklicken, erhalten Sie im unteren Fensterbereich die Programme, die von hier aus gestartet werden. Um Autostarts abzuschalten, aktivieren Sie die Klickbox neben der jeweiligen Anwendung und klicken auf „Entfernen“. Unter Windows XP können Sie über unser Script auch einfach verbieten, dass sich Prozesse künftig in irgendeine der Startrampen eintragen. Voraussetzungen dafür sind Administratorrechte, eine mit NTFS formatierte Systempartition und das englischsprachige Microsoft-Tool Subinacl. Dieses holen Sie sich nach einem Klick auf „?“ aus dem Web. Ist das alles gegeben, entzieht ein Klick auf die Schaltfläche „Berechtigungen“ dem Benutzer und dem System das Schreibrecht auf alle Registry- und Datei-Autostarts. Das ist ein schwerwiegender Eingriff, den Sie sich gut überlegen sollten. Vor allem sollten Sie sich daran erinnern, wenn es bei der Installation einer Software Probleme gibt. Gegebenenfalls nehmen Sie die Einstellung auf demselben Weg wieder zurück. Der Button „Definieren“ verlinkt zur PC-WELT- Prozessdatenbank. Dazu markieren Sie zunächst einen Startprozess im unteren Dialogbereich. „Definieren“ übergibt den Dateinamen dann direkt an unser Prozess-Wiki.

-te

Zurück | Nach oben | Weiter
Prozessdatenbank: Wissen, was läuft | Zum Anfang | Datei-Erweiterungen: Systemweit sichtbar machen


Datei-Erweiterungen: Systemweit sichtbar machen
Zurück Sicherheit Weiter

Datei-Erweiterungen: Systemweit sichtbar machen

Problem: Dass der Windows-Explorer standardmäßig bestimmte Datei-Erweiterungen nicht anzeigt, ist ein bekanntes Ärgernis. Genauso ist es aber auch bei den Attachments von Mails, die Sie über Outlook und Outlook Express empfangen. Dadurch erscheint eine Datei mit etwa dem Namen Clickme.TXT.VBS als harmlose TXT-Datei.

Lösung: Die Darstellung der Dateinamen in Outlook und Outlook Express richten sich nach den Einstellungen im Windows-Explorer. Wählen Sie im Explorer das Menü „Extras, Ordneroptionen, Ansicht“, und entfernen Sie das Häkchen neben der Option „Erweiterungen bei bekannten Dateitypen ausblenden“. Abgesehen von LNK- und PIF-Dateien sehen Sie nun sämtliche Dateien mit der Namenserweiterung – und zwar sowohl im Explorer als auch in den Mailprogrammen Outlook und Outlook Express.

-jt

Zurück | Nach oben | Weiter
Autostart: Startrampen aufspüren und sperren | Zum Anfang | PC Nutzung kontrollieren: Check von Logons und Systemlaufzeit


PC Nutzung kontrollieren: Check von Logons und Systemlaufzeit
Zurück Sicherheit Weiter

PC Nutzung kontrollieren: Check von Logons und Systemlaufzeit

Problem: Sie haben den Verdacht, dass Ihre Logon-Daten allgemein bekannt sind. Oder: Ihr Sohn behauptet, er spiele erst seit 20 Minuten am PC, doch Sie haben Zweifel. Sie wollen feststellen, ob sich seit Ihrer letzten Windows-Anmeldung ein Kollege oder Admin an Ihrem Bürorechner vergriffen hat beziehungsweise wie lange das System läuft.

Lösung: Auch für diese Aufgabe bietet sich die Wmic.EXE an. Sie kann sowohl die Uptime des Systems – die Laufzeit seit dem Systemstart – ermitteln als auch die Anzahl der Logons, und zwar für alle Systemkonten oder für ein bestimmtes. Unsere Batchdatei pcw_Uptime liefert die Systemlaufzeit in Sekunden und – der besseren Übersicht halber – auch abgerundet in weiteren Zeiteinheiten. Außerdem zeigt die Batchdatei die Gesamtzahl aller bisherigen lokalen Anmeldungen des aktuellen Benutzers. Bei Zweifeln über die lokale Logon-Sicherheit genügt es also, sich diese Zahl zu notieren. Wenn die Zahl bei Ihrem nächsten Logon um mehr als eins höher ist, hat sich in der Zwischenzeit ein anderer Benutzer mit Ihren Kontodaten angemeldet. Hinweise zur Batch: pcw_Uptime ist wie jede interaktive Batchdatei auf der Kommandozeile zu starten. Zur bequemen systemweiten Nutzung sollten Sie sie in ein Verzeichnis im Systempfad kopieren. Die Rundung der Uptime beim Umrechnen in Minuten, Stunden und Tage ist in der Standard-Kommandozeile Cmd.EXE zwingend, da diese bei Rechen-Operationen immer auf Ganzzahlen abrundet. Die exakte Uptime ist daher nur bei den Sekunden abzulesen. Diese Ungenauigkeit betrifft nur die Cmd.EXE: Im alternativen Befehlsinterpreter 4NT.EXE etwa liefert die gleiche Batch ein exaktes Ergebnis für alle Zeitwerte.

-ha

Systemlaufzeit auslesen: Mit der Batchdatei ermitteln Sie Zeitdiskrepanzen zwischen Log-Ons

Abbildung 3. Systemlaufzeit auslesen: Mit der Batchdatei ermitteln Sie Zeitdiskrepanzen zwischen Log-Ons

Zurück | Nach oben | Weiter
Datei-Erweiterungen: Systemweit sichtbar machen | Zum Anfang | XP Prome: Fast ein Pro mit zwei Klicks


XP Prome: Fast ein Pro mit zwei Klicks
Zurück Sicherheit Weiter

XP Prome: Fast ein Pro mit zwei Klicks

Problem: Stellen Sie sich vor, ein Kfz-Hersteller bringt in einem Auto einen Klotz hinter Gas- und Bremspedal an. Der Wagen fährt zwar noch, verfügt aber nur über die halbe Beschleunigungs- und Bremskraft – dafür ist er günstiger. Bei der Home-Version von Windows XP ist es ähnlich. Viele Funktionen aus der Pro-Fassung sind hier standardmäßig deaktiviert, beispielsweise die Registerkarte „Sicherheit“, die Dateiverschlüsselung (EFS – Encrypting File System) oder der Einsatz von Benutzerrechten in Freigaben. Alle bisher veröffentlichten Möglichkeiten, diese freizuschalten, sind entweder Teillösungen oder erfordern erhebliches Know-how.

Lösung: Windows speichert seine Identität im Registry-Schlüssel „Hkey_Local_Machine\System\CurrentControlSet\Control\ProductOptions“. Steht dort in der mehrteiligen Zeichenfolge „ProductSuite“ der Wert „Personal“, dann handelt es sich um eine Home-Version: Ist hier nichts eingetragen, ist es XP Pro. Um einem XP Home klarzumachen, es sei ein Pro, müsste es also genügen, den Wert „Personal“ aus dem genannten Eintrag zu löschen. Da es sich dabei aber um eine Veränderung der Lizenz handelt, überwacht das System diesen Schlüssel und sperrt jede Änderung. Mit unserem Tool pcwXPProme können Sie den Wert trotzdem löschen – und zwar im laufenden Betrieb. Dazu entpacken Sie das Tool und die ebenfalls im Archiv enthaltene Datei „Hilfe – Bitte ausdrucken.TXT“ in ein beliebiges leeres Verzeichnis, in dem sie auch bleiben sollen. Achtung: Wenn Sie den genannten Registry-Schlüssel anpassen, ändert sich die Lizenz. Deshalb dürfen Sie die folgenden Schritte nur ausführen, wenn Sie über eine entsprechende XP-Pro-Lizenz verfügen. Das Tool greift tief in das System ein. Lesen Sie vor dem ersten Aufruf unbedingt die Hilfe-Datei, und schaffen Sie eine der darin beschriebenen Voraussetzungen, um im unwahrscheinlichen Fall eines GAUs Ihr System wiederherstellen zu können. Nach dem ersten Aufruf legt das Tool zunächst eine Sicherung des genannten Schlüssels an. In einer weiteren Kopie entfernt es den Eintrag „Personal“ und liest den geänderten Schlüssel wieder in die Registry ein. Ferner wird im Schlüssel „Hkey_Local_Machine\System\CurrentControlSet\Control\Lsa“ der DWORD-Eintrag „ForceGuest“ auf „0“ gesetzt, damit Sie die NTFS-Rechte nutzen und setzen können. Stimmen Sie dann dem Neustart zu – fertig ist XP Prome. Klicken Sie nun mit der rechten Maustaste auf eine Datei, die auf einer NTFS-Partition liegt, und wählen Sie „Eigenschaften“. Ihnen wird die neue Registerkarte „Sicherheit“ auffallen, auf der Sie Zugriffsrechte setzen können. Über die Eigenschaften von Ordnern vergeben Sie Freigabe-Berechtigungen. Um Dateien zu verschlüsseln, klicken Sie in deren „Eigenschaften“-Dialog auf „Erweitert“ und aktivieren die Klickbox vor „Inhalt verschlüsseln, um Daten zu schützen“. Schwierigkeiten kann ein umgewandeltes Home beim Update machen. Deshalb sollten Sie am Patch Day jeden zweiten Dienstag im Monat den schizophrenen Zustand temporär zurücksetzen. Führen Sie das Tool einfach noch einmal aus. Dadurch wird das zuvor angelegte Backup eingelesen, Neustart, fertig. Nun können Sie updaten und danach wieder auf Prome umschalten.

-cl

Zurück | Nach oben | Weiter
PC Nutzung kontrollieren: Check von Logons und Systemlaufzeit | Zum Anfang | Ausführ-Sperre: Alle Programme bis auf eine Auswahl verbieten


Ausführ-Sperre: Alle Programme bis auf eine Auswahl verbieten
Zurück Sicherheit Weiter

Ausführ-Sperre: Alle Programme bis auf eine Auswahl verbieten

Problem: Sie sind Administrator eines Mehrbenutzersystems. Aus Sicherheitsgründen möchten Sie einigen Anwendern das Ausführen von Programmen verbieten – bis auf wenige, explizit freigegebene.

Lösung: Mit unserem Script pcwRestrictRun können Sie von Ihrem Administratorkonto aus die erlaubten Anwendungen für alle anderen auf dem System vorhandenen Benutzerkonten steuern. Dabei geht es um alle Anwendungen, die aus dem Explorer heraus aufgerufen werden. Programme, die das System selbst startet, bleiben unangetastet. Um neue Berechtigungen zu vergeben, rufen Sie das Script auf. Der Dialog listet alle Benutzerkonten inklusive Ihres eigenen auf. Markieren Sie alle Konten, für die neue Einschränkungen gelten sollen, und klicken Sie dann auf „Verbieten“. Ein Ausrufezeichen neben dem Kontonamen kennzeichnet dann, dass Restriktionen vorliegen. Im nächsten Schritt legen Sie für jedes Konto eine eigene „Whitelist“ an. Darin stehen die Anwendungen, die weiterhin ausgeführt werden dürfen. Geben Sie also in der Befehlszeile den Namen der ausführbaren Datei an, die erlaubt werden soll, beispielsweise „iexplore.exe“ für den Internet Explorer oder „winword.exe“ für Word. Danach markieren Sie die Konten welche diese Programme ausführen dürfen, und klicken auf „Anwendung erlauben“. Wiederholen Sie diesen Vorgang so oft, bis jedem eingeschränkten Konto die erlaubten Anwendungen zugewiesen sind. Profile, denen Sie bereits mindestens eine erlaubte Anwendung zugeordnet haben, werden beim Markieren ausgeklappt damit Sie deren „Whitelist“ einsehen können. Wenn Sie mehreren Konten dieselben Anwendungen zuweisen möchten, aktivieren Sie am besten die Klickbox „Zu Hinzufügen von Anwendungen in der Profil-Ansicht bleiben“ – das verhindert das Ausklappen. Beenden Sie das Script immer mit „Quit“, da sonst die Registry-Dateien der anderen Benutzerprofile nicht richtig entladen werden und die Benutzer sich nicht mehr anmelden können. Natürlich können Sie erlaubte Anwendungen auch wieder verbieten. Dazu markieren Sie zunächst das gewünschte Konto, dann die zu verbietenden Anwendungen und klicken auf „Löschen“. Um die Einschränkungen komplett aufzuheben markieren Sie wieder die einzelnen Konten und klicken auf „Erlauben“. Achtung: Sie können in der oben beschriebenen Weise auch Einschränkungen für Ihr eigenes Konto treffen. Dabei besteht die Gefahr, dass Ihr System unbrauchbar wird. Schränken Sie Ihr Konto, wenn überhaupt, nur mit größter Vorsicht ein. -cl

Erlauben, was läuft: Mit dem Tool pcwRestrictRun erlauben Sie Anwendern nur ausgewählte Programme zu starten

Abbildung 4. Erlauben, was läuft: Mit dem Tool pcwRestrictRun erlauben Sie Anwendern nur ausgewählte Programme zu starten

Zurück | Nach oben | Weiter
XP Prome: Fast ein Pro mit zwei Klicks | Zum Anfang | Lokaler PC: Ordner sperren oder unzugänglich machen


Lokaler PC: Ordner sperren oder unzugänglich machen
Zurück Sicherheit Weiter

Lokaler PC: Ordner sperren oder unzugänglich machen

Problem: An einem PC arbeiten mehrere Personen. Sie wollen einen oder mehrere Dateiordner so einrichten, dass bestimmte PC-Benutzer nicht darauf zugreifen können.

Lösung: Zunächst einmal darf es nur ein Benutzerkonto Administrator-Rechte existieren – Ihres. Für Administratoren sind Zugriffsbeschränkungen hinfällig, da sie sie jederzeit selbst ändern können. Überprüfen Sie also zuerst, welche Konten auf dem Rechner existieren und welche Rechte die User jeweils haben. Dazu gehen Sie in der Systemsteuerung auf „Benutzerkonten“. Im Beispielfall soll der Benutzer „Anna“, der keine Administrator-Rechte besitzt, nicht auf den Ordner D:\Vertraulich zugreifen dürfen. Für alle weiteren Benutzerkonten – außer für Ihres – gehen Sie analog vor.

XP Pro: Das System unterschlägt zunächst einen wichtigen Punkt im Kontextmenü – die Möglichkeit nämlich, abgestufte Rechte zu vergeben. Gehen Sie deshalb im Windows-Explorer auf „Extras, Orderoptionen, Ansicht“, und entfernen Sie den Haken vor der Option „Einfache Dateifreigabe verwenden (empfohlen)“. Jetzt gelangen Sie über die Eigenschaften des Ordners C:\Vertraulich auf „Sicherheit“. Den Beispiel-User „Anna“ nehmen Sie auf, indem Sie auf „Hinzufügen“ und im nächsten Menü auf „Erweitert“ klicken. Nach einem Klick auf „Jetzt suchen“ wählen Sie in der angezeigten Liste „Anna“ aus, gehen auf „OK“ und kehren damit zum vorherigen Menü zurück. Hier ist noch mal ein „OK“ fällig, damit die Auswahl übernommen wird. Für „Anna“ klicken Sie in der Tabelle der Berechtigungen den Punkt „Vollzugriff“ unter „Verweigern“ an. Nach einem weiteren „OK“ haben Sie „Anna“ von C:\Vertraulich ausgesperrt. Wiederholen Sie die Aktion nun für „Bernd“, „Claudia“ bis „Zuzana“ ...

XP Home: XP Home bietet scheinbar keine „Sicherheit“ in den Kontextmenüs von Ordnern und Dateien. Doch ist die NTFS-Rechtevergabe im normalen Betrieb nur ausgeblendet, um den Preisunterschied gegenüber der Pro-Variante zu rechtfertigen. Das merken Sie, sobald Sie XP Home im abgesicherten Modus starten. Dort unterscheidet sich die Vorgehensweise nicht von der eben für XP Pro beschriebenen. Mit unserem Tool pcwXPProme rüsten Sie Ihre Windows XP Home um genau diese Funktionen auch im Normalbetrieb auf (siehe Tipp „Fast ein Pro mit zwei Klicks“). Alternativ verwenden Sie eine dritte, wesentlich komfortablere Alternative – den Dateimanager Winfile.EXE von NT 4, mit dem sich ebenfalls Zugriffsrechte auf NTFS-Partitionen setzen lassen: Unter XP Home erweist sich Winfile.EXE als unentbehrliches Tool, das zum aktuellen System völlig kompatibel ist. Wenn Sie keine alte Windows-NT-4-CD besitzen, besorgen Sie sich das letzte Service Pack 6a für NT 4 – auch hier ist Winfile.EXE enthalten. Das deutschsprachige Pack schlägt gleich mit 86 MB zu Buche – der Download empfiehlt sich nur bei einer flotten Internet-Verbindung. Egal, welche Version Sie herunterladen, die folgenden Schritte gelten für beide: Das Service Pack liegt als EXE-Datei vor, die Sie mit dem Parameter -x (nach einem Leerzeichen) aufrufen. Geben Sie ein Verzeichnis an, in das die Dateien entpackt werden sollen. In diesem Ordner finden Sie die Winfile.EXE, die Sie in das Windows-Verzeichnis kopieren. Im alten Dateimanager klicken Sie das gewünschte Laufwerk an, markieren den Beispielordner D:\Vertraulich und wählen in der Menüleiste über „Sicherheit“ („Security“) den Unterpunkt „Berechtigungen“ („Permissions“). Ab dieser Menüebene arbeitet Winfile.EXE mit Standardschaltflächen in der Sprache des installierten Systems. Damit die neu definierten Rechte auch ausdrücklich für Unterordner gelten, aktivieren Sie die Option „Berechtigungen für Unterverzeichnisse ersetzen“. Über den Button „Hinzufügen“ geht es zum Auswahlmenü, wo Sie sich mit „Benutzer anzeigen“ alle Benutzerkonten auf dem Rechner anzeigen lassen. Wählen Sie nun den Benutzer „Anna“ aus, und stellen Sie ganz unten die Zugriffsart auf „Kein Zugriff“. Noch zwei mal mit „OK“ bestätigen – fertig. Wieder holen Sie die Aktion für alle weiteren Benutzer, die Sie ausschließen möchten.

-ha/dw

Benutzer aussperren: Unter XP-Pro und XPProme schränken Sie den Zugriff auf ausgewählte Ordner für andere User ein

Abbildung 5. Benutzer aussperren: Unter XP-Pro und XPProme schränken Sie den Zugriff auf ausgewählte Ordner für andere User ein

Zurück | Nach oben | Weiter
Ausführ-Sperre: Alle Programme bis auf eine Auswahl verbieten | Zum Anfang | System


System
Zurück Weiter

System

XP-Comics: Die lästigen Infos abschalten
Partitonsverwaltung: Ordner als Laufwerk - Laufwerk als Ordner
MMC: Alles unter einer Haube
Überflüssige Zubehör: Versteckte De-Installationseinträge anzeigen
Geräte-Manager: Mehr Infos mit Umgebungsvariable
Dateiverwaltung: Kompletter Umzug des eigenen Profils
Backups: Wege zur Sicherung Ihres Systems
Systemabsturz: Kein Blue Screen - keine Infos
Systemrettung: Wiederherstellung ohne Oberfläche erreichen
USB-Datenträger: Ordnung ohne Laufwerksbuchstaben
Zurück |  | Weiter
Lokaler PC: Ordner sperren oder unzugänglich machen | Zum Anfang | XP-Comics: Die lästigen Infos abschalten


XP-Comics: Die lästigen Infos abschalten
Zurück System Weiter

XP-Comics: Die lästigen Infos abschalten

Problem: Das redselige Windows XP nervt Sie ständig mit Hinweisen, Tipps oder ähnlichen Belanglosigkeiten in Form von gelben Sprechblasen. Sie möchten diese störende Funktion abschalten.

Lösung: Nicht umsonst gehört dieser Tipp zu den aller Populärsten weltweit. Die nervigen Hinweise lenken ständig von der Arbeit ab und stören die Konzentration. Ein einfacher Eintrag in der Registry beendet das Geblubber: Suchen Sie mit Regedit den Schlüssel „Hkey_Current_User\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced“. Legen Sie hier den DWORD-Eintrag „EnableBalloonTips“ an, und geben Sie ihm den Wert „0“.

Nie wieder Sprechblasen: Mit diesem Registry-Hack schalten Sie die nervigen Ballon-Tipps aus

Abbildung 6. Nie wieder Sprechblasen: Mit diesem Registry-Hack schalten Sie die nervigen Ballon-Tipps aus

-cl

Zurück | Nach oben | Weiter
System | Zum Anfang | Partitonsverwaltung: Ordner als Laufwerk - Laufwerk als Ordner


Partitonsverwaltung: Ordner als Laufwerk - Laufwerk als Ordner
Zurück System Weiter

Partitonsverwaltung: Ordner als Laufwerk - Laufwerk als Ordner

Problem: Mitunter ist die Aufteilung der Festplatten nicht optimal. In einigen Fällen ist es beispielsweise wünschenswert einem Programm vorzugaukeln, das bestimmte Dateien auf einen Laufwerk, statt in einem Ordner liegen oder umgekehrt.

Lösung: Windows bietet eine Reihe von Optionen, dies unkompliziert zu korrigieren, ohne erneut zu partitionieren.

Ordner als Laufwerk: Mit dem Kommandozeilen-Tool Subst.EXE holen Sie jeden tief vergrabenen Unterordner als Pseudo-Laufwerk auf die oberste Explorer-Ebene:

subst v: <beliebiger Pfad>

Um den Befehl nicht bei jedem Start eingeben zu müssen, schreiben Sie ihn in eine Textdatei mit der Endung BAT und speichern die Batchdatei im Autostart-Ordner.

Laufwerk als Ordner: Über die Datenträgerverwaltung (oder mit Mountvol.EXE) können Sie unter Windows XP eine komplette Platte in einen Ordner einer zweiten Festplatte einhängen. Das Ziellaufwerk muss mit NTFS formatiert sein, als eingehängtes Laufwerk ist auch ein FAT32-Datenträger möglich. Diese Aktion kann logisch sinnvoll sein – der Explorer einschließlich Dateisuche behandelt die eingehängte Platte so, als handle es sich um einen Ordner der anderen Platte. Wenn Sie eine zu kleine Platte nachträglich erweitern wollen, taugt diese Maßnahme aber nicht. Die Speicherplatzberechnung bei Installationen versteht diesen Mechanismus nicht: Wenn Sie also etwa eine leere 200-GB-Platte als Ordner unter C:\ einhängen, wird trotzdem jede Installation scheitern, die auf C: nicht genügend Platz vorfindet.

-ha

Nach oben: Tief verborgene Ordner bringen Sie mit Subst.EXE als Laufwerk direkt in den Arbeitsplatz

Abbildung 7. Nach oben: Tief verborgene Ordner bringen Sie mit Subst.EXE als Laufwerk direkt in den Arbeitsplatz

Zurück | Nach oben | Weiter
XP-Comics: Die lästigen Infos abschalten | Zum Anfang | MMC: Alles unter einer Haube


MMC: Alles unter einer Haube
Zurück System Weiter

MMC: Alles unter einer Haube

Problem: Was ist wo unter Windows? Die Windows XP Einstellungen sind so komplex, dass auch kundige Benutzer oft erst im dritten Anlauf die richtige Stelle finden. Manche Optionen tauchen an mehreren Orten auf. Das macht Zufallsfunde wahrscheinlicher, erschwert aber die Orientierung.

Lösung: Abhilfe lässt sich mit der „Microsoft Management Console“ schaffen. Die MMC präsentiert üblicherweise die von Microsoft vorgegebenen Snap-ins oder Snap-in-Sammlungen, erkennbar an der Endung MSC. So führt Services.MSC zu den installierten Diensten und Dfrg.MSC zur Platten-Defragmentierung. Compmgmt.MSC bietet unter dem Titel „Computerverwaltung“ eine größere Sammlung von Snap-ins an, die unter anderem auch die Dienste und die Defragmentierung enthält. Die MMC ist aber ein offenes Instrument: Sie können sie so einrichten, dass sie zur umfassenden Windows-Zentrale wird – ein Doppelklick, und Sie haben Zugriff auf alle Windows-Einstellungen. Das Prinzip ist einfach: Sie beginnen entweder mit einer leeren Konsole durch Aufruf von „mmc.exe“, oder Sie bauen eine vorhandene Sammlung wie Compmgmt.MSC weiter aus. Dazu wählen Sie „Datei, Snap-In hinzufügen/entfernen“ und im Folgedialog „Hinzufügen“. Wenn Sie eine Komponente nicht im Hauptzweig („Konsolenstamm“) unterbringen möchten, sondern in einem bereits vorhandenen Unterordner, aktivieren Sie vor dem „Hinzufügen“ zunächst diesen Eintrag per Doppelklick. Danach wählen Sie das gewünschte Snap-in aus der Liste, klicken erneut auf „Hinzufügen“, dann auf „Schließen“ und im verbleibenden Hauptdialog auf „OK“. Nun erscheint das gewählte Snap-in in der Konsole. Speichern Sie eine selbst erstellte Konsole mit „Datei, Speichern unter“ unter einem Ort und Namen Ihrer Wahl . Unter den angebotenen Snap-ins taucht ein so interessantes Instrument wie der Leistungsmonitor (Perfmon.MSC) nicht auf. Es handelt sich um ein Active-X-Control. Klicken Sie daher in der Liste zunächst auf „ActiveX-Steuerelement“; ein Assistent zeigt dann die alphabetische Liste der Active-X-Komponenten. Markieren Sie hier gegen Ende der Liste das „System Monitor Control“, und klicken Sie dann auf „Weiter“ und „Fertig stellen“. Auf diese Weise integrieren Sie die wichtigsten oder alle verfügbaren Komponenten in Ihre individuelle Konsole. Über das Snap-in „Ordner“ können Sie die Struktur der Konsole mitbestimmen. Beispielsweise ist es möglich, zunächst einen „Ordner“ anzulegen, diesen in „Disks“ umzubenennen und dort die Snap-ins „Defragmentieren“, „Datenträgerverwaltung“, „Indexdienst“ und „Wechselmedienverwaltung“ zu integrieren.

-ha

Systemverwaltung nach Maß: Mit Snap-Ins in der Management-Konsole stricken Sie Ihr eigenes Administrator-Werkzeug

Abbildung 8. Systemverwaltung nach Maß: Mit Snap-Ins in der Management-Konsole stricken Sie Ihr eigenes Administrator-Werkzeug

Zurück | Nach oben | Weiter
Partitonsverwaltung: Ordner als Laufwerk - Laufwerk als Ordner | Zum Anfang | Überflüssige Zubehör: Versteckte De-Installationseinträge anzeigen


Überflüssige Zubehör: Versteckte De-Installationseinträge anzeigen
Zurück System Weiter

Überflüssige Zubehör: Versteckte De-Installationseinträge anzeigen

Problem: Windows XP bringt Zusatzprogramme mit, die zum Betrieb des Systems nicht nötig sind. Sie finden Sie unter „Start, Programme, Zubehör“. Mit von der Partie ist bei XP etwa der MSN Explorer. Das Setup lässt Ihnen keine Wahl und installiert alles ungefragt mit. So einfach wieder los werden Sie die Programme nicht, da sie in der Liste der installierten Windows-Komponenten unter „Systemsteuerung, Software“ nicht auftauchen.

Lösung: Die Installationseinträge sind lediglich versteckt. Um Windows zu veranlassen, sie in der Systemsteuerung anzuzeigen, müssen Sie eine Systemdatei editieren – diese ist ebenfalls versteckt. Falls Sie den Windows-Explorer noch nicht so eingestellt haben, dass er auch versteckte Systemdateien und Ordner anzeigt, sollten Sie das jetzt nachholen. Die entsprechende Einstellung finden Sie im Windows-Explorer unter „Extras, Ordneroptionen, Ansicht“. Außerdem benötigen Sie Administratorrechte. Öffnen Sie dann die Datei %windir%\Inf\SYSOC.INF mit Notepad. Die SYSOC.INF steuert, welche Komponenten im Menü „Windows-Komponenten hinzufügen/entfernen“ zu sehen sind. Einträge, die dort nicht auftauchen sollen, sind in der INF-Datei mit dem Parameter „hide“ als versteckt markiert. Theoretisch könnten Sie diese Zeichenkette nun überall löschen. Das ist allerdings nicht bei allen Einträgen sinnvoll, da sich einige Komponenten trotzdem nicht de-installieren lassen – so etwa COM+. Besser ist, nur die relevanten Einträge sichtbar zu machen, die tatsächlich für einen wirksamen De-Installationseintrag stehen. Bei Windows XP ist der erste Kandidat der Messenger, dessen Eintrag Sie in Zeile 16 der INF-Datei finden. Löschen Sie „hide“ – danach sollte in der Zeile nur noch

msmq=msmqocm.dll,msmqOcm,msmqocm.inf,,6

stehen. Überspringen Sie die nächsten Zeilen, und gehen Sie zum nächsten Absatz mit der Zeile „Games=“. Die dort folgenden Einträge sind mit „hide“ versehen. In diesem Bereich können Sie alle „hide“ entfernen – es handelt sich durchgehend um Zubehör und Dienstprogramme, die für das System verzichtbar sind. Speichern Sie die Datei; die Änderungen sind dann ohne Neustart wirksam. Danach öffnen Sie unter „Systemsteuerung, Software“ das Menü „Windows-Komponenten hinzufügen/entfernen“. Jetzt können Sie den Besen schwingen und nicht benötigte Zubehörprogramme deinstallieren. Falls Sie später doch mal wieder darauf zurückgreifen möchten, können Sie das Zubehör wieder über dieses Menü installieren, wobei Sie die Setup-CD greifbar haben müssen.

-dw

Nutzlose Komponenten deinstallieren: Mit veränderter Datei „sysoc.inf“ können Sie überflüssige Programme problemlos löschen

Abbildung 9. Nutzlose Komponenten deinstallieren: Mit veränderter Datei „sysoc.inf“ können Sie überflüssige Programme problemlos löschen

Zurück | Nach oben | Weiter
MMC: Alles unter einer Haube | Zum Anfang | Geräte-Manager: Mehr Infos mit Umgebungsvariable


Geräte-Manager: Mehr Infos mit Umgebungsvariable
Zurück System Weiter

Geräte-Manager: Mehr Infos mit Umgebungsvariable

Problem: Der Geräte-Manager von Windows XP zeigt die Liste der installierten Hardware an, allerdings sind die Informationen gefiltert: Es zeigen sich keine mittlerweile ausgebauten Geräte, von denen noch Treiberreste vorhanden sind – auch nicht, wenn Sie im Menü „Ansicht“ die Option „Ausgeblendete Geräte anzeigen“ aktivieren.

Lösung: Um Ressourcenkonflikten auf die Spur zu kommen, ist die Umgebungsvariable unerlässlich. Wenn Sie ISDN- und

Netzwerkkarten ausbauen, ohne den zugehörigen Treiber über den Geräte-Manager zu löschen, dann bleiben Treiberleichen übrig. Dank des freigeschalteten Zugriffs auf diese ausgeblendeten Komponenten können Sie die Komponente auch später noch komplett de-installieren. Melden Sie sich mit Administratorrechten an, und klicken Sie bei gedrückter <Alt>-Taste den „Arbeitsplatz“ doppelt an, um die Systemeigenschaften zu öffnen. Gehen Sie auf „Erweitert, Umgebungsvariablen“, und klicken Sie in die Liste der „Systemvariablen“. Nach einem Klick auf „Neu“ legen Sie eine neue Variable mit dem Namen „devmgrshow_nonpresent_devices“ an und weisen ihr den Wert „1“ zu. Anschließend ist ein Neustart nötig, damit die Variable aktiv wird. Im Geräte-Manager aktivieren Sie dann unter „Ansicht“ die Option „Ausgeblendete Geräte anzeigen“. Jetzt kommt die ausgebaute Hardware ins Blickfeld, deren Treiberreste unnötigerweise noch vorhanden sind. Sie erkennen diese Geräte an einem blassen, fast durchsichtigen Icon.

-dw

Zurück | Nach oben | Weiter
Überflüssige Zubehör: Versteckte De-Installationseinträge anzeigen | Zum Anfang | Dateiverwaltung: Kompletter Umzug des eigenen Profils


Dateiverwaltung: Kompletter Umzug des eigenen Profils
Zurück System Weiter

Dateiverwaltung: Kompletter Umzug des eigenen Profils

Problem: Windows XP legt alle Daten eines bestimmten Benutzers in seinem lokalen Profil-Ordner ab. Standardmäßig liegt der auf der Systempartition im Verzeichnis „\Dokumente und Einstellungen“ und trägt jeweils den Namen des Benutzerkontos. Neben Benutzerdaten wie „Eigene Dateien“, Favoriten, Desktop oder Startmenü erhält er unter anderem die Registry des Benutzers sowie weitere Einstellungen für System und Anwendungen. Mit der Zeit wächst der Profil-Ordner zu einem Monstrum heran, das die Systempartition ausfüllen kann. Außerdem sollten nach alter Schule Daten und System immer auf unterschiedlichen Partitionen liegen. So könnten Sie Ihr System beispielsweise ohne Datenverlust neu aufsetzen.

Lösung: Jeder Profil-Ordner ist über eine Vielzahl von Verweisen aus der Registry an das System angekoppelt. Zudem greift ein laufendes Windows ständig auf die Registry des Benutzers zu. Deshalb bricht der Vorgang auf halber Strecke ab, wenn Sie den Profil-Ordner einfach mit dem Explorer an eine andere Stelle verschieben. Aus diesem Grund würde ein Teil der Verweise ins Leere deuten, so dass Windows nicht mehr läuft. Mit unserem Script pcwProfileMove ziehen Sie den Profil-Ordner mit ein paar Klicks um. Nach dem Aufruf ermittelt die HTA-Anwendung zunächst das Profil-Verzeichnis des aktuell angemeldeten Benutzers. Wählen Sie dann über die Schaltfläche „»“ den neuen Zielordner für das Profil aus. Beachten Sie dabei, dass der Inhalt des bestehenden Profil-Ordners in das neue Zielverzeichnis kopiert wird und nicht etwa der Profil-Ordner selbst. Wenn Sie außerdem die Klickbox vor „Registry-Zweige sichern“ aktiviert lassen, werden die bisher geltenden Verweise aus der Registry vor deren Änderung gesichert. So können Sie den Urzustand wiederherstellen, falls etwas schief geht. Schließen Sie spätestens jetzt alle offenen Anwendungen und klicken Sie auf „Kopieren“, um den Vorgang zu starten. Unser Tool kopiert zunächst alle ungesperrten Dateien und legt für die gesperrte Registry parallel eine Batchdatei an, die Sie später in der Wiederstellungskonsole aufrufen. Dann passt das Script die Verweise in der Registry an. Dabei ermittelt es unter anderem den SID (Security Identifier) des Benutzers und passt im Schlüssel „Hkey_Local_Machine\Software\Microsoft\Windows NT\CurrentVersion\ProfileList\<SID>“ den Eintrag „ProfileImagePath“ an, um dem Benutzer seinen neuen Ordner zuzuweisen. Sobald das Script seine Arbeit erledigt hat, legen Sie Ihre Windows-CD ein und klicken im Script auf „Ja“, um das System von CD zu starten. Nach dem Booten wählen Sie im Setup-Dialog <R>, um die Wiederherstellungskonsole zu aktivieren. Nachdem Sie das Kennwort des Administrator-Kontos eingegeben haben, gelangen Sie auf den Prompt. Hier geben Sie den Befehl

batch c:\windows\pcwMProf.bat

ein. Mit der vom HTA-Script vorbereiteten Batchdatei wird in den meisten Fällen die Benutzer-Registry kopiert. Falls Sie hier jedoch vier Mal die Fehlermeldung „Zugriff verweigert“ erhalten, müssen Sie die Dateien „<Quelle>\Dokumente und Einstellungen\<Benutzername>\ntuser.dat“ sowie „<Quelle>\Dokumente und Einstellungen\<Benutzername>\LokaleEinstellungen\Anwendungsdaten\Microsoft\Windows\Usrclass.dat“ von Hand ins Zielverzeichnis kopieren. Danach geben Sie „exit“ ein, um das System neu zu starten. Benennen Sie nun Ihren alten Profil-Ordner um, und probieren Sie anhand von Anwendungen wie Office und Internet Explorer aus ob die Verweise zu den neuen „Eigenen Dateien“ und Favoriten stimmen. Außerdem können Sie ein Kommandozeilen-Fenster öffnen und dort den Befehl „set“ eingeben. Hinter der Variable „Userprofile“ sollte der neue Profil-Ordner stehen. Nachdem Sie einige Zeit fehlerfrei mit Ihrem neuen Profil gearbeitet, können Sie den alten Profil-Ordner komplett löschen. Es treten Probleme auf, und Sie möchten Ihr altes Profil wiederherstellen? Dann geben Sie dem alten Ordner wieder den ursprünglichen Namen und importieren jeweils per Doppelklick die drei REG-Dateien, die das Script zuvor im eigenen Ordner gesichert hat.

-cl

Zurück | Nach oben | Weiter
Geräte-Manager: Mehr Infos mit Umgebungsvariable | Zum Anfang | Backups: Wege zur Sicherung Ihres Systems


Backups: Wege zur Sicherung Ihres Systems
Zurück System Weiter

Backups: Wege zur Sicherung Ihres Systems

Problem: Sie möchten sicherstellen, dass Ihr zuverlässig laufendes XP-System auch nach Benutzerfehlern oder Software-Pannen schnell wieder so aussieht wie gewohnt. Inzwischen gibt es eine Reihe von Varianten, sein System zu sichern.

Lösung: Wir zeigen die interessantesten Optionen und sortieren von der sichersten und aufwendigsten bis hin zur einfachsten.

1. Komplettsicherung durch Zweitsystem: Sie kopieren den kompletten Windows-Ordner oder die komplette Windows-Partition auf einen physikalisch unabhängigen Datenträger mit demselben Dateisystem. Das geht mit Bart PE, Windows PE, Knoppix oder mit einer zweiten Windows-Installation. Diese Methode funktioniert immer – auch wenn Windows komplett streikt, kostet aber Zeit.

2. Systemsicherung mit Ntbackup: Sie kopieren Windows einschließlich aller Systemkomponenten sowie aktueller Registry mit folgender Befehlszeile oder Minibatch:

ntbackup.exe backup systemstate /F e:\%DATE%.bfk

Mit e:\ geben wir nur ein Beispiel für den gewünschten Zielpfad. Als Ergebnis erhalten Sie eine große, binäre Sicherungsdatei mit der Endung BFK. Das Verfahren ist einfach und lässt sich automatisieren. Allerdings setzt die Wiederherstellung ein funktionierendes Windows mit Ntbackup voraus.

3. Dokumente und Einstellungen sichern: Der „Assistent zum Übertragen von Dateien und Einstellungen“ (Migwiz.EXE unter \System32\Usmt) kann Desktop-Icons, Symbolleisten, Anzeigeoptionen, Software-Einstellungen und Benutzerdaten aus dem persönlichen Profil sichern und später auf den selben PC zurückschreiben. Diese Methode ist einfach, erfasst aber nur einen Teil des Systems. Außerdem ist ein laufendes Windows mit Migwiz nötig, um die Daten aus der Binärdatei IMG0000<n>.DAT zurückzuholen.

4. Systemwiederherstellung: Die unter „Systemeigenschaften, Systemwiederherstellung“ aktivierte Überwachung sichert die Registry sowie die von Patches und Installationen betroffenen Systemdateien. Dieser Dienst lässt sich automatisch oder manuell starten und verschafft Ihnen vollständige und lauffähige Versionen der Registry. Er ist aber extrem redundant – die Daten werden mehrfach gesichert, da sich der Daten-Pool aller Wiederherstellungspunkte überschneidet. Außerdem setzt er ein noch lauffähiges Windows voraus, damit Sie einen Restore-Punkt zurückspielen können.

5. pcwRegSaveRestore: Mit unserem Tool pcwRegSaveRestore sichern Sie die Windows-Registry im laufenden Betrieb. Vorteil gegenüber der Systemwiederherstellung ist, dass sich die Dateien der Registry auch bei einem nicht mehr startenden System zurückschreiben lassen, und zwar auf der Wiederherstellungskonsole mit der automatisch erzeugten ConsoleBackup.BAT.

-ha

Registry sichern: Unser spezielles Tool sichert die gesamte Registry, die Sie im Notfall über die Wiederherstellungskonsole zurückspielen

Abbildung 10. Registry sichern: Unser spezielles Tool sichert die gesamte Registry, die Sie im Notfall über die Wiederherstellungskonsole zurückspielen

Zurück | Nach oben | Weiter
Dateiverwaltung: Kompletter Umzug des eigenen Profils | Zum Anfang | Systemabsturz: Kein Blue Screen - keine Infos


Systemabsturz: Kein Blue Screen - keine Infos
Zurück System Weiter

Systemabsturz: Kein Blue Screen - keine Infos

Problem: „Verlassen Sie sich auf die stabilste Windows-Architektur“, preist Microsoft die XP-Systeme an. Aber auch wenn System Crashs unter XP tatsächlich nicht mehr zum Alltag gehören – unter ungünstigen Bedingungen stürzt auch Windows XP ab, etwa bei Problemen mit schlecht programmierten Treibern. Es zeigt Ihnen dann allerdings keinen Blue Screen mehr, sondern startet sofort erneut. Die ohnehin nicht einfache Fehlersuche wird durch das Fehlen der dort gebotenen Infos noch erschwert.

Lösung: Eine Hand voll Optionen steuert das Verhalten von Windows XP im Falle eines Systemcrashs. Sie finden die Einstellungen gut versteckt in der Systemsteuerung unter „System“ und dort auf der Registerkarte „Erweitert“. Klicken Sie hier auf die „Einstellungen“ im Feld „Starten und Wiederherstellen“, und deaktivieren Sie die Option „Automatisch Neustart durchführen“. Mit dem nächsten Neustart machen Sie die Änderungen wirksam. Bei einem Absturz bietet XP statt eines simplen Reboots wieder den blauen Bildschirm, der zumindest weitere Informationen zum Verursacher des Absturzes preisgibt. Die Fehlersuche kann beginnen.

-dw

Absturz-Infos: Wenn Sie diese Option de-aktivieren, haben Sie Zeit bei einem Bluescreen den Fehlercode zu notieren

Abbildung 11. Absturz-Infos: Wenn Sie diese Option de-aktivieren, haben Sie Zeit bei einem Bluescreen den Fehlercode zu notieren

Zurück | Nach oben | Weiter
Backups: Wege zur Sicherung Ihres Systems | Zum Anfang | Systemrettung: Wiederherstellung ohne Oberfläche erreichen


Systemrettung: Wiederherstellung ohne Oberfläche erreichen
Zurück System Weiter

Systemrettung: Wiederherstellung ohne Oberfläche erreichen

Problem: Wenn Windows nicht mehr startet, wäre die Systemwiederherstellung von größtem Nutzen. Diese funktioniert aber nur, solange das System noch auf irgendeine Weise hochfährt. Die Wiederherstellungskonsole hilft nicht weiter: Trotz aller automatischen oder manuellen Restore-Punkte bleibt oft nur eine Reparatur- oder Neu-Installation.

Lösung: Solange wenigstens der „Abgesicherte Modus“ funktioniert, können Sie die Systemwiederherstellung auf diesem Weg aufrufen und den letzten Wiederherstellungspunkt laden. Die Lage ist selbst dann aussichtsreich, wenn nur noch der „Abgesicherte Modus mit Eingabeaufforderung“ arbeitet und fundamentale Komponenten der grafischen Oberfläche fehlen oder kaputt sind. Der Befehl

%windir%\system32\restore\rstrui /v

startet die Systemwiederherstellung nämlich ohne grafische Oberfläche. Warten Sie nach dem Befehl einfach einige Zeit ab, das System fährt nach einer längeren Pause automatisch herunter. Während dieser Pause scheint nichts zu passieren, tatsächlich wird aber der letzte Wiederherstellungspunkt kopiert.

Retten mit der Konsole: Erfahrene Anwender können eine Neu-Installation trotz der mageren Wiederherstellungskonsole vermeiden, sofern ein Registry-Problem den Systemcrash verursacht hat. Eine weitere wichtige Voraussetzung ist, dass Sie in der Konsole wenigstens in alle Ordner wechseln dürfen. Den dafür nötigen Registry-Eintrag können Sie – im noch funktionierenden System (am besten jetzt sofort!) – mit unserem Tool pcwAnnoyances aktivieren. Ist „SetCommand“ unter „Hkey_Local_Machine\Software\Microsoft\Windows NT\CurrentVersion\Setup\RecoveryConsole“ auf „1“ gesetzt, kommen Sie in der Wiederherstellungskonsole nach der Eingabe des Befehls

set AllowAllPaths = true

in jeden Pfad. Die letzte Registry-Sicherung befindet sich unter „\System Volume Information\_Restore{...}“ im Ordner „RP<n>“ mit der höchsten Ziffer <n>, und hier im weiteren Unterordner „Snapshot“. Hier liegen unter geänderten, aber eindeutig erkennbaren Namen die fünf Dateien Sam, Security, Software, System und Default, die Sie nach „%windir%\System32\Config“ kopieren müssen. Ferner finden Sie in diesem Unterordner diverse Ntuser-Dateien mit der Security-ID im Namen. Diese Dateien müssen Sie in den jeweiligen Profilordner kopieren und dann in „Ntuser.DAT“ umbenennen. Ohne Kenntnis der Security-ID hilft auch ein Größenvergleich. Insbesondere können Sie davon ausgehen, dass die größte, dort angetroffene Ntuser-Datei zu jenem Konto gehört, das auf diesem PC am meisten genutzt wird. Übrigens: Eine veraltete, aber immerhin funktionierende Registry befindet sich auch noch im Ordner %windir%\Repair.

-ha

Zurück | Nach oben | Weiter
Systemabsturz: Kein Blue Screen - keine Infos | Zum Anfang | USB-Datenträger: Ordnung ohne Laufwerksbuchstaben


USB-Datenträger: Ordnung ohne Laufwerksbuchstaben
Zurück System Weiter

USB-Datenträger: Ordnung ohne Laufwerksbuchstaben

Problem: Beim Anstecken eines USB-Datenträgers kann ich mich nie darauf verlassen, dass der Stick oder die Festplatte unter einem bestimmten Laufwerksbuchstaben auftaucht. Schlimmstenfalls erscheint der Datenträger überhaupt nicht – nämlich wenn der auf die lokalen Laufwerke folgende Buchstabe durch ein Netzlaufwerk belegt ist.

Lösung: Sie umgehen das Gerangel um die Laufwerksbuchstaben, wenn Sie Netzlaufwerke (oder virtuelle Subst-Laufwerke) grundsätzlich von Z: über Y: und so fort verbinden. USB-Geräte nehmen immer den nächsten freien Buchstaben nach den lokalen Laufwerken. Die nach Festplatten und DVD-Laufwerken folgenden Buchstaben sollten also möglichst für USB frei bleiben. Mit einer interessanten Alternative machen Sie sich völlig unabhängig vom Buchstabensalat: Sofern Sie mindestens eine mit NTFS formatierte Partition verwenden, können Sie USB-Speicher auch in einen Ordner mounten. Starten Sie dazu nach dem Anschließen des USB-Geräts über „Arbeitsplatz, Verwalten“ die „Computerverwaltung“ und dort die „Datenträgerverwaltung“. Nach Rechtsklick auf das betreffende Laufwerk entfernen Sie über „Laufwerkbuchstaben und -pfade ändern“ erst den Buchstaben und legen dann nach „Hinzufügen“ einen NTFS-Ordner fest.

-ha

Zurück | Nach oben | Weiter
Systemrettung: Wiederherstellung ohne Oberfläche erreichen | Zum Anfang | Netzwerk


Netzwerk
Zurück Weiter

Netzwerk

Sicherheit: Versteckte Zugriffe aufspüren
Freigaben: Keine Gastfreundschaft unter Windows XP Pro
Freigaben: Rechte zum Lesen und Schreiben gezielt regeln
Fernwartung: Rechner gezielt fernsteuern lassen
Freigaben: Netzfreigaben und NTFS-Rechte
Unsichtbar: Windows-PCs im Netz verstecken
Kommandozeile: Mit Netsh.exe das Netzwerk konfigurieren
Fernsteuerung I: Start und Remote-Shutdown
Fernsteuerung II: Von außen Programme starten
Netzwerkumgebung: Langsame Anzeige
Zurück |  | Weiter
USB-Datenträger: Ordnung ohne Laufwerksbuchstaben | Zum Anfang | Sicherheit: Versteckte Zugriffe aufspüren


Sicherheit: Versteckte Zugriffe aufspüren
Zurück Netzwerk Weiter

Sicherheit: Versteckte Zugriffe aufspüren

Problem: Sie arbeiten in einem Firmennetz und möchten kontrollieren, wer in den letzten Tagen auf Ihren PC zugegriffen hat.

Lösung: Das Ereignisprotokoll sammelt eine Menge nützlicher Informationen, unter anderem auch die lokalen und die Netzwerkanmeldungen. Rufen Sie das Protokoll mit „eventvwr“ auf, und klicken Sie auf die Rubrik „Sicherheit“. Die Netzzugriffe können Sie schnell aussondern, wenn Sie nach der Spalte „Ereignis“ sortieren lassen und dann alle Einträge mit der Kennziffer „680“ durchgehen. Dabei werden sowohl die Anmelde- als auch die PC-Namen angezeigt. Gescheiterte lokale Anmeldungen (direkt am PC) finden Sie unter der Kennziffer „529“. Windows XP Pro bietet zusätzlich das VB-Script Eventquery.VBS, das gezielt bestimmte Ereignisse filtern kann:

cscript eventquery.vbs /fi „id Q 680“ /v /fo list

Dieser Befehl listet nur Ereignisse mit der Event-ID „680“ auf. -ha

Zurück | Nach oben | Weiter
Netzwerk | Zum Anfang | Freigaben: Keine Gastfreundschaft unter Windows XP Pro


Freigaben: Keine Gastfreundschaft unter Windows XP Pro
Zurück Netzwerk Weiter

Freigaben: Keine Gastfreundschaft unter Windows XP Pro

Problem: Sie möchten im Büro auf Ihren PC unter Windows XP Pro ein Verzeichnis im lokalen Netz freigeben, auf das jeder zugreifen darf. Im Kontextmenü unter „Freigabe und Sicherheit“ haben Sie den Ordner freigegeben und unter „Berechtigungen“ den Vollzugriff für die Benutzergruppe „Jeder“ aktiviert. Trotzdem können Benutzer ohne eigenes Konto – sprich: Gäste – auf Ihren Rechner nicht auf die Freigabe zugreifen.

Die Lösung: Windows XP Pro hat eine zusätzliche Barriere eingebaut. Es genügt nun nicht mehr wie noch unter Windows 2000, in den Berechtigungen für die Benutzergruppe „Gast“ die gewünschten Zugriffsrechte zu setzen. Zusätzlich ist ein Eingriff in den „Lokalen Sicherheitseinstellungen“ notwendig. Die erreichen Sie über den Aufruf der Datei „secpol.msc“ unter „Start, Ausführen“. Hier findet sich unter „Lokale Richtlinien, Zuweisen von Benutzerrechten“ die Richtlinie „Zugriff vom Netzwerk auf diesen Computer verweigern“. Erst wenn der „Gast“ dort explizit aus der Liste entfernt ist, kann wirklich jeder die Freigabe erreichen.

-cl

Gäste einladen: Standardmäßig verweigert Windows XP Pro den Zugriff bis Sie den Benutzer hier entfernen

Abbildung 12. Gäste einladen: Standardmäßig verweigert Windows XP Pro den Zugriff bis Sie den Benutzer hier entfernen

Zurück | Nach oben | Weiter
Sicherheit: Versteckte Zugriffe aufspüren | Zum Anfang | Freigaben: Rechte zum Lesen und Schreiben gezielt regeln


Freigaben: Rechte zum Lesen und Schreiben gezielt regeln
Zurück Netzwerk Weiter

Freigaben: Rechte zum Lesen und Schreiben gezielt regeln

Problem: Eine Netzwerkfreigabe auf Ihrem PC soll nicht allen, sondern nur bestimmten Benutzern den Zugriff über das Netz gewähren.

Lösung: Unter XP-Pro müssen Sie als Administrator für jeden einzelnen Benutzer, dem Sie den Zugriff erlauben wollen, zunächst ein eigenes Konto auf Ihrem PC einrichten und dann die entsprechenden Rechte vergeben. Ein Beispiel: Nur der Benutzer „prx“ soll auf die Freigabe „Transfer“ mit vollen Rechten zugreifen dürfen. Zunächst legen Sie dazu in der Systemsteuerung unter „Benutzerkonten“ das neue Konto „prx“ an, und geben Sie das Passwort ein, mit dem sich „prx“ auf seinem eigenen Rechner anmeldet. Wenn Sie es nicht kennen, müssen Sie die Person bitten, es einzugeben. Danach gehen Sie dann im Kontextmenü des betroffenen Ordners unter „Freigabe“ auf „Berechtigungen“, und fügen Sie den Benutzer „prx“ hinzu. Setzen Sie die gewünschten Schreib-/Leserechte, indem Sie in den „Berechtigungen“ die jeweiligen Klickboxen aktivieren. Unter XP Home existiert nur ein Konto „Jeder“ (also „Gast“). Folglich ist eine Freigabe immer eine Freigabe für alle – ohne Kennwortprüfung.

-dw/ha

Gezielte Freigaben: Mit einem eigenen Benutzerkonto geben Sie Ordner nur für bestimmte Benutzer im Netzwerk frei

Abbildung 13. Gezielte Freigaben: Mit einem eigenen Benutzerkonto geben Sie Ordner nur für bestimmte Benutzer im Netzwerk frei

Zurück | Nach oben | Weiter
Freigaben: Keine Gastfreundschaft unter Windows XP Pro | Zum Anfang | Fernwartung: Rechner gezielt fernsteuern lassen


Fernwartung: Rechner gezielt fernsteuern lassen
Zurück Netzwerk Weiter

Fernwartung: Rechner gezielt fernsteuern lassen

Problem: Sie haben Schwierigkeiten mit Ihrem System und brauchen Hilfe von einem versierten Bekannten. Das Problem am Telefon zu erörtern, ist kompliziert, für beide Parteien anstrengend und stellt, wenn Verständigungsprobleme auf Zeitnot treffen, die Freundschaft arg auf die Probe.

Lösung: Wenn Sie ein Problem mit Ihrem System haben, können Sie einen fachkundigen Freund direkt auf Ihren Rechner einladen. Er kann Ihr System dann bequem von seinem PC aus fernwarten. Unter XP Pro ist die Fernwartung über eine Remote-Desktop-Verbindung relativ unproblematisch, sofern auf etwaig zwischengeschalteten Firewalls der Port 3389 geöffnet ist. Bei der Windows-Firewall öffnen Sie dazu einfach die Registerkarte „Ausnahmen“ und aktivieren die Klickboxen vor „Remoteunterstützung“ und „Remotedesktop“. Um diese herzustellen, müssen Sie zunächst die Funktion aktivieren: Klicken Sie mit der rechten Maustaste auf den „Arbeitsplatz“, und öffnen Sie dessen „Eigenschaften“. Öffnen Sie odrt die Registerkarte „Remote“, und aktivieren Sie die Klickbox vor „Benutzern erlauben, eine Remotedesktopverbindung herzustellen“. Im nächsten Schritt klicken Sie auf „Remotebenutzer auswählen“ und fügen einen Benutzer hinzu, über den die Fernsteuerung laufen soll. Nun kann sich der Helfer mit Ihrem Rechner verbinden. Falls er ebenfalls Windows XP nutzt, klickt er einfach auf „Start, Programme, Zubehör, Kommunikation, Remotedesktopverbindung“. Bei einer älteren Windows-Version kann er sich den deutschsprachigen Client für die Remotedesktopverbindung herunterladen (3,4 MB) und installieren. Die Verbindung erfolgt dann einfach über den Computernamen oder dessen IP-Adresse mit einem Benutzerkonto, das auf dem Remote-Rechner vorhanden sein muss.

Unter XP Home aktivieren Sie als Erstes die Remote-Unterstützung. Klicken Sie dazu mit der rechten Maustaste auf den Arbeitsplatz wählen Sie „Eigenschaften, Remote“, und aktivieren Sie die Klickbox vor „Ermöglicht das Senden von Remoteunterstützungsangeboten“. Im selben Dialog klicken Sie auf „Erweitert“, aktivieren die Klickbox vor „Remote steuern dieses Computers zulassen“ und legen eine maximale Dauer fest, für die der Remote-Zugriff gelten soll. Nun müssen Sie ein Support-Ticket ausstellen und Ihrem Helfer per Mail zukommen lassen. Klicken Sie dazu auf „Start, Programme, Remoteunterstützung“. Sollte der Link nicht vorhanden sein, funktioniert auch dieser Befehl

rcimlby.exe -LaunchRA

unter „Start, Ausführen“. Nach etwas Wartezeit klicken Sie im automatisch gestarteten Hilfe- und Supportcenter auf „Jemanden einladen, Ihnen zu helfen“. Im nächsten Schritt tragen Sie die Mailadresse des Bekannten in das Feld ein und klicken auf „Diese Person einladen“. Im nächsten Fenster können Sie Ihren Namen und eine Nachricht eingeben, die in der Mail erscheinen soll. Im letzten Dialog bestimmen Sie eine Gültigkeitsdauer für dieses Support-Ticket – die mögliche Zeitspanne reicht von einer Minute bis zu 99 Tagen. Während dieses Zeitraums ist über das Ticket ein Zugriff auf Ihr System möglich. Im Dialog unten vergeben Sie ein Kennwort, das der Helfer wissen muss, um sich verbinden zu können. Dieses Kennwort sollten Sie ihm separat, zum Beispiel per Telefon, durchgeben. Ein Klick auf „Einladung senden“ verschickt das Ticket. Sollte das nicht automatisch klappen, senden Sie einfach selbst eineMail mit der eben gespeicherten Datei RAInvitation.msrcincident als Anhang. Verbindung aufnehmen: Der Empfänger der Mail ruft die Datei auf seinem XP-System einfach per Doppelklick auf und gibt im nachfolgenden Dialog das zuvor festgesetzte Kennwort ein. Nun wird die Verbindung hergestellt. Bevor es jedoch losgehen kann, müssen Sie noch mit „Ja“, bestätigen, dass Ihr Helfer tatsächlich in Ihr System einsteigen darf. Dieser klickt dann auf „Steuerung übernehmen“, Sie bestätigen erneut – fertig. Ihr System wird ferngesteuert, und Sie können auf dem Bildschirm verfolgen, was gerade passiert. Um die Verbindung zu kappen, reicht es, wenn eine der beiden Parteien auf <Esc> drückt. Über den Dialog zur Remote-Unterstützung können Sie sich außerdem gegenseitig Nachrichten zuschicken, Dateien austauschen und sogar miteinander sprechen.

Mögliche Probleme: Wenn sich der Bekannte nicht mit Ihrem Rechner verbinden kann, befindet sich Ihr System wahrscheinlich hinter einem Router. Schalten Sie dort zunächst mit Hilfe der Bedienungsanleitung den Port 3398 frei (Port Forwarding), damit die Anfrage Sie überhaupt erreichen kann. Dann müssen Sie gegebenenfalls noch Ihre lokale IP-Adresse durch die Online-IP Ihres Routers ersetzen, mit der Sie im Internet vertreten sind. Um diese zu ermitteln, gehen Sie auf Dyndns. Öffnen Sie dann die oben erwähnte Msrcincident-Datei mit Notepad, und ersetzen Sie im Bereich „RCTICKET=“65538,1,<Adresse>“ die eingetragene Nummer durch die eben ermittelte. Speichern Sie die Datei, und schicken Sie das Ticket erneut ab.

-cl

Fremdunterstützung: Mit dem Remote-Desktop können Sie Benutzer von außerhalb Zugriff auf Ihren Rechner gewähren

Abbildung 14. Fremdunterstützung: Mit dem Remote-Desktop können Sie Benutzer von außerhalb Zugriff auf Ihren Rechner gewähren

Zurück | Nach oben | Weiter
Freigaben: Rechte zum Lesen und Schreiben gezielt regeln | Zum Anfang | Freigaben: Netzfreigaben und NTFS-Rechte


Freigaben: Netzfreigaben und NTFS-Rechte
Zurück Netzwerk Weiter

Freigaben: Netzfreigaben und NTFS-Rechte

Problem: Sie möchten auf Ihren Netzwerk-Freigaben gezielt einigen Dateien die Schreibrechte entziehen. Die globalen Berechtigungen helfen Ihnen hier nicht weiter.

Lösung: Unter Windows XP gibt es zwei Ebenen, auf denen Sie festlegen, wer welche Rechte für welche Dateien besitzt: Zunächst gibt es die NTFS-Rechte im lokalen Dateisystem, außerdem können Sie für eine Netzwerkfreigabe Rechte vergeben. Lokale User auf demselben PC dürfen nur auf eine Datei zugreifen, wenn sie die entsprechenden NTFS-Rechte haben. Wer über das Netzwerk anklopft, muss sowohl diese Rechte als auch die Erlaubnis über eine Netzwerkfreigabe besitzen. Ein Windows XP Home müssen Sie vorher fit machen, um die NTFS-Rechte überhaupt verwalten zu dürfen (siehe  Tipp „Ordner sperren oder unzugänglich machen“). Lokale Rechte: Sie ändern als Administrator die lokalen Rechte, indem Sie mit der rechten Maustaste jeweils auf eine Datei oder einen Ordner klicken und aus dem Kontextmenü „Eigenschaften“ wählen. Auf der Registerkarte „Sicherheit“ sehen Sie alle Benutzer und Gruppen, denen für das Objekt Rechte erteilt wurden. Um welche Rechte es sich genau handelt, sehen Sie im unteren Teil des Dialogs, sobald Sie einen Benutzer oder eine Gruppe markieren. Genaues erfahren Sie nach einem Klick auf „Erweitert“: Nun sehen Sie auch den Besitzer der Datei oder des Ordners und können die aus den Einstellungen effektiv resultierenden Rechte für Benutzer und Gruppen abfragen. Netzfreigaben: Den Zugriff auf eine solche Freigabe regeln Sie über die Registerkarte „Freigabe“ und die Schaltfläche „Berechtigungen“. Fügen Sie hier alle Benutzer hinzu, denen Sie den Zugriff erlauben wollen, und erteilen Sie ihnen in der unteren Fensterhälfte die dafür nötigen Rechte. Bestätigen Sie die Änderungen per Klick auf „Übernehmen“. Nun können Sie die Registerkarte „Freigabe“ öffnen und über die Schaltfläche „Berechtigungen“ das Ergebnis prüfen und gegebenenfalls ändern. Nach zwei Klicks auf „OK“ ist der Zugriff auf die Freigabe möglich. Beachten Sie, dass NTFS-Zugriffsrechte für „Jeden“ und eine entsprechende Netzfreigabe keineswegs für alle gelten, sondern nur für sämtliche lokalen Konten Ihres Rechners. Wenn der PC also nur die zwei Konten „Hans“ und „Fritz“ besitzt, dann wirkt sich eine Freigabe für „Jeden“ gerade mal für Hans und Fritz aus.

Alles für den Gast? Wirklich für alle gilt lediglich eine Freigabe für den „Gast“, wenn dieser auch die entsprechenden NTFS-Rechte besitzt. Das eventuell deaktivierte Gast-Konto können Sie unter XP Pro(me) über den Dialog „controluserpasswords2“ einschalten. Übrigens: Wenn Sie das Konto, mit dem Sie normalerweise unterwegs sind, wie im beschrieben, mit eingeschränkten Rechten versehen haben, dürfen Sie Freigaben nur noch als „Administrator“ verwalten. Auch wenn das unbequem scheint, sollten Sie es in Kauf nehmen – die Netzfreigabe ist ein Systemdienst, dessen Konfiguration nicht von der normalen Software, die mit Benutzerrechten läuft, beeinflusst werden sollte.

-akr

. Gezielte Freigabe-Berechtigungen: Hier geben Sie Verzeichnisse nur für bestimmte Benutzer frei im Netzwerk frei

Abbildung 15. . Gezielte Freigabe-Berechtigungen: Hier geben Sie Verzeichnisse nur für bestimmte Benutzer frei im Netzwerk frei

Zurück | Nach oben | Weiter
Fernwartung: Rechner gezielt fernsteuern lassen | Zum Anfang | Unsichtbar: Windows-PCs im Netz verstecken


Unsichtbar: Windows-PCs im Netz verstecken
Zurück Netzwerk Weiter

Unsichtbar: Windows-PCs im Netz verstecken

Problem: Sie möchten nicht, dass sich Ihr PC in der Netzwerkumgebung von Windows zeigt. Nur Eingeweihte, die den Rechnernamen kennen, sollen bei Bedarf darauf zugreifen können.

Lösung: Mit einem einzigen Befehl in der Eingabeaufforderung machen Sie Ihren PC in der Netzwerkumgebung unsichtbar. Geben Sie mit Administratorrechten das Kommando

net config server/hidden:yes

ein. Ab jetzt stellt sich der Rechner nicht mehr höflich im Netzwerk vor, sondern führt ein Schattendasein. Nach der nächsten Aktualisierung der Netzwerkumgebung ist der Rechner aus der Liste verschwunden. Die Liste der PCs wird nicht dauernd aktualisiert, sondern in einem bestimmten Intervall. Der unsichtbare PC ist nach wie vor erreichbar, wenn ihn jemand etwa im Windows-Explorer direkt mit „\\<Rechnername>“ anspricht. Ob ein PC als versteckter Server konfiguriert ist, erfährt ein Benutzer mit Administratorrechten über die Ausgabe des Befehls „net config server“ in der Zeile „Unsichtbarer Server“. Sie machen den Rechner wieder sichtbar, indem Sie den Schalter „yes“ durch „no“ ersetzen.

-dw

Zurück | Nach oben | Weiter
Freigaben: Netzfreigaben und NTFS-Rechte | Zum Anfang | Kommandozeile: Mit Netsh.exe das Netzwerk konfigurieren


Kommandozeile: Mit Netsh.exe das Netzwerk konfigurieren
Zurück Netzwerk Weiter

Kommandozeile: Mit Netsh.exe das Netzwerk konfigurieren

Problem: Die Netzwerkeinstellungen nehmen Sie unter Windows für gewöhnlich in den Eigenschaften der „Netzwerkumgebung“ vor. Für einige gezielte Aufgaben suchen Sie einen schnelleren Weg.

Lösung: Das Utility Netsh.exe bietet kompletten Zugriff auf alle Netzwerkeinstellungen, sei es zu Diagnosezwecken oder zur Neukonfiguration der Netzwerkkarte. Wer sich mit dem Befehl „netsh.exe help“ die Einstiegsseite zur Hilfe anzeigen lässt, wird zunächst über die Syntax stolpern, die keinem anderen Befehlszeilen-Tool von Windows gleicht. Die Netsh-Kommandos verästeln sich in Unterbefehle und bilden ein wahres Labyrinth, in dem sich einige komfortable Funktionen verbergen. Beispiel: Mit Ihrem Notebook hängen Sie zu Hause in einem anderen Netzwerk als im Büro. Mit Netsh schalten Sie die Netzwerkkonfiguration bei Bedarf um. Melden Sie sich mit Administratorrechten an, und nehmen Sie über die Eigenschaften der „LAN-Verbindung“ alle Netzwerkeinstellungen für den Betrieb im heimischen Netz vor. Speichern Sie diese Konfiguration in eine Textdatei:

netsh.exe interface dump >%windir%\heimnetz.txt

Gehen Sie dann wieder in die Netzwerkeinstellungen, und stellen Sie dort alles für den Betrieb des PCs im Büronetzwerk ein. Speichern Sie auch diese Konfiguration mit

netsh.exe interface dump >%windir%\büronetz.txt

Ab sofort können Sie je nach benötigten Einstellungen die Konfiguration flott umschalten. Das Kommando

netsh.exe -f %windir%\heimnetz.txt

aktiviert beispielsweise die Einstellungen für das Heimnetz. Damit Sie sich nicht immer auf die Kommandozeile begeben müssen, richten Sie sich mit Hilfe von Links einen komfortablen Umschalter ein. Erstellen Sie auf dem Desktop eine Verknüpfung, und tragen Sie als Ziel das komplette Kommando „netsh.exe -f %windir%\heimnetz.txt“ ein. Geben Sie dem Link einen aussagekräftigen Namen, etwa „Heimnetz“. Erstellen Sie dann eine weitere Verknüpfung, der Sie als Ziel den Befehl „netsh.exe -f %windir%\büronetz.txt“ und den Namen „Büronetz“ geben. Ein Doppelklick auf einen der Links aktiviert die jeweils angegebenen Netzwerkeinstellungen, ohne dass Sie die Konfiguration noch selbst bearbeiten müssen. Es dauert lediglich einige Sekunden, bis die Einstellungen aktiv sind. Achtung: Wenn Sie nur in einer der beiden Netzwerkkonfigurationen ein „Standard-Gateway“ nutzen, müssen Sie die betreffende Konfigurationsdatei nachbearbeiten. Falls Sie beispielsweise im Heimnetz kein Gateway verwenden öffnen Sie die Datei Heimnetz.TXT mit einem Text-Editor und tragen unterhalb von „# Schnittstellen-IP-Konfiguration für LAN Verbindung“ diese neue Zeile ein:

set address name = "LAN Verbindung" gateway = none

Sie bewirkt,dass das Standard-Gateway beim Einlesen geleert wird. Es gibt noch etwas zu beachten: Ab Service Pack 1 (SP1) für Windows XP wurde ein Bug im Datei-Export von Netsh.exe behoben. Wenn Sie Windows XP ohne Service Pack betreiben, müssen Sie die gesicherten Konfigurationsdateien für Ihre Netzwerke nachbearbeiten: Öffnen Sie die Dateien Büronetz.txt und Heimnetz.txt mit einem Text-Editor, und suchen Sie die Zeilen die mit „set dns“ und „add dns“ beginnen. Löschen Sie am Ende der Zeilen jeweils den Eintrag „register=PRIMARY“, denn „PRIMARY“ ist kein gültiger Scriptbefehl.

-dw

. Netzwerkeinstellungen per Kommandozeile: Mit Netsh.exe speichern Sie aktuelle Netzwerkeinstellungen und laden Sie später wieder

Abbildung 16. . Netzwerkeinstellungen per Kommandozeile: Mit Netsh.exe speichern Sie aktuelle Netzwerkeinstellungen und laden Sie später wieder

Zurück | Nach oben | Weiter
Unsichtbar: Windows-PCs im Netz verstecken | Zum Anfang | Fernsteuerung I: Start und Remote-Shutdown


Fernsteuerung I: Start und Remote-Shutdown
Zurück Netzwerk Weiter

Fernsteuerung I: Start und Remote-Shutdown

Problem: Nach dem Kauf eines neuen PCs stellt sich oft die Frage „Was tun mit dem alten?“. Weiterverkaufen lohnt sich selten. Als Druck- oder Datei-Server könnte er noch gute Dienste leisten. Sie möchten aber weder Platz noch Geld für einen zusätzlichen Monitor investieren.

Lösung: Einfache Aufgaben kann der alte Rechner schon allein über die üblichen Windows-Netzwerkdienste übernehmen. Damit der PC dann ohne Eingabegeräte auskommt, müssen Sie zuerst im Bios jeglichen „Halt on“-Befehl deaktivieren, sprich: alles, was zum Hochfahren eine Eingabe erfordert. Das geschieht meist mit der Einstellung „No Errors“. Dann ein automatisches Windows-Logon ein

richten. Dazu greifen Sie direkt in die Registry ein. Das geschieht im Schlüssel „Hkey_Local_Machine\Software\Microsoft\Windows NT\CurrentVersion\Winlogon“. Legen Sie dort die Zeichenfolge „DefaultUserName“ an, und geben Sie ihr als Wert den gewünschten Benutzernamen. In die zweite neue Zeichenkette „DefaultPassword“ tragen Sie das Kennwort ein. Dann richten Sie einen Remote-Shutdown ein. Dazu brauchen Sie als einfachste Lösung nur ein Script im Autostart-Ordner, das so lange „loopt“, bis es eine bestimmte Datei auf der Freigabe des anderen PCs nicht mehr findet – weil der heruntergefahren wurde. Wenn Sie den Haupt-PC abschalten, fährt so auch der andere herunter. Das Prinzip sehen Sie in der unten stehenden Abbildung. Schließlich müssen Sie noch genau prüfen, ob der PC nach diesen Maßnahmen vielleicht doch noch auf Benutzereingaben wartet. Kontrollieren Sie dazu noch einmal den kompletten Startvorgang.

-ha

. Simples Shutdown-Prinzip: Der Remote-PC dreht so lange Schleifen, bis er eine bestimmte Datei auf dem Hauptrechner nicht mehr findet.

Abbildung 17. . Simples Shutdown-Prinzip: Der Remote-PC dreht so lange Schleifen, bis er eine bestimmte Datei auf dem Hauptrechner nicht mehr findet.

Zurück | Nach oben | Weiter
Kommandozeile: Mit Netsh.exe das Netzwerk konfigurieren | Zum Anfang | Fernsteuerung II: Von außen Programme starten


Fernsteuerung II: Von außen Programme starten
Zurück Netzwerk Weiter

Fernsteuerung II: Von außen Programme starten

Problem: Soll der ferngesteuerte Altrechner mehr leisten, als nur Datei- und Drucker-Dienste anzubieten, reicht der vorherige Tipp nicht mehr aus. Sie brauchen dann eine Art Server-Script, das ständig auf Jobs lauert und diese ausführt.

Lösung: Für den Hausgebrauch genügen zwei Scripts – eines für den sendenden Haupt-PC und eines für den Altrechner. Die Scripts kommunizieren über eine Netzwerkfreigabe. Das Prinzip veranschaulichen die Scripts im Archiv pcwRemote prüft laufend, ob in einem bestimmten Verzeichnis eine Job.TXT auftaucht. Wird es fündig, führt es die dort enthaltenen Befehle aus. Die gewünschten Befehle können Sie beispielsweise auf dem Hauptrechner mit Notepad so in die Datei schreiben, wie sie auf der Kommandozeile oder unter „Start, Ausführen“ einzugeben wären, und dann auf die Freigabe des Alt-PCs als Job.TXT speichern. Noch bequemer wird die Bedienung mit einem Sende-Script wie pcwJobs.VBS: Nach Doppelklick geben Sie in die Box den gewünschten Befehl ein, das Ablegen auf der Freigabe erfolgt dann automatisch. Bei der Übergabe von Pfaden an den Remote-PC müssen Sie stets darauf achten, dass dieser damit etwas anfangen kann: Entweder machen Sie das Server-Script so intelligent, dass es einen lokalen Pfad wie „d:\daten“ automatisch in den zutreffenden UNC-Netzpfad umwandelt, oder Sie übergeben statt der lokalen gleich UNC-Pfade – zum Beispiel „\\computername\daten“. Beachten Sie, dass Sie laufende Programme auf dem Remote-PC mangels Tastatur und Monitor nicht einfach beenden können. Im Systempfad muss daher auf diesem PC auf jeden Fall ein Task-Killer wie Kill.EXE sein. Auch die Beispiel-Scripts pcwServer und pcwJobs sind darauf angewiesen – etwa der eingebaute Befehl „showtasks“, der auf dem Hauptrechner die Tasks des anderen PCs auflistet. Der Shutdown des Altrechners erfolgt in dieser Lösung automatisch nach einer erfolglosen „Ping“-Abfrage an den Hauptrechner. Weitere Infos bietet der kommentierte Code der beiden VB-Scripts. Er weist auch auf nötige Anpassungen hin.

-ha

Zurück | Nach oben | Weiter
Fernsteuerung I: Start und Remote-Shutdown | Zum Anfang | Netzwerkumgebung: Langsame Anzeige


Netzwerkumgebung: Langsame Anzeige
Zurück Netzwerk Weiter

Netzwerkumgebung: Langsame Anzeige

Problem: Nach einem Klick auf die Arbeitsgruppe in der Netzwerkumgebung kann die Anzeige der Server und Freigaben unter Windows 2000 und XP sehr lange dauern. Das gerade aktive Windows-Explorer-Fenster reagiert vorübergehend nicht mehr, manchmal ist sogar das gesamte System während dieser Zeit blockiert.

Lösung: Bei der Suche nach Computern über die Netzwerkumgebung sendet Windows Netzwerknachrichten an alle Arbeitsgruppen, Domänen und Computer (Broadcast), um die verfügbaren Netzwerk-Ressourcen zu ermitteln. Je nach Konfiguration des Netzwerks und der vorhandenen Server kann dieser Vorgang längere Zeit dauern. Mit den folgenden Maßnahmen lässt sich der Zugriff auf das Netzwerk beschleunigen:

1. Gehen Sie in der Systemsteuerung auf „Netzwerkverbindungen“, und rufen Sie die Eigenschaften der Netzwerkkarte auf. De-installieren Sie alle Protokolle, die Sie nicht verwenden. In der Regel benötigen Sie nur „Internetprotokoll (TCP/IP)“.

2. Wenn Sie kein WLAN haben, gehen Sie in den Eigenschaften einer Netzwerkverbindung auf „Authentifizierung“ und deaktivieren die Klickbox vor „IEEE 802.1X-Authentifizierung für dieses Netzwerk aktivieren“.

3. Starten Sie die Computerverwaltung, und gehen Sie auf „Dienste und Anwendungen, Dienste“. Rufen Sie die Eigenschaften von „Webclient“ auf, und ändern Sie den „Starttyp“ auf „Manuell“. Sie benötigen diesen Dienst nur, wenn Sie auf Speicherplätze im Web über WebDAV zugreifen wollen.

4. Wenn sich im Netzwerk auch Windows-98/ME-Rechner befinden, starten Sie Regedit.EXE und gehen auf „Hkey_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace“. Löschen Sie den Schlüssel „{D6277990-4C6A-11CF-8D87-00AA0060F5BF}“. Dies verhindert die Suche nach geplanten Vorgängen auf dem Fremdrechner. Die Änderung tritt ohne Neustart in Kraft. Konsequenterweise finden Sie auch den Ordner „Geplante Tasks“ in der Netzwerkumgebung nicht mehr.

5. Passen Sie an, wie lang Windows auf Antworten aus dem Netzwerk wartet. Gehen Sie dazu in der Registry auf „Hkey_Local_Machine\System\CurrentControl

Set\Services\NetBT\Parameters“, und ändern Sie die Werte in:

BcastNameQueryCount 0x00000001
BcastQueryTimeout    0x00000020
NameSrvQueryCount    0x00000001
NameSrvQueryTimeout 0x00000020

Starten Sie danach den Rechner neu. Wenn Windows in größeren oder langsamen Netzen nun nicht mehr alle Server findet, weisen Sie den geänderten Einträgen schrittweise höhere Werte zu. Die Timeout-Werte sind in der Registry als 1/100-Sekunden-Intervalle angegeben. Der Hex-Wert „20“ (Dezimal: 32) entspricht also 0,32 Sekunden.

-te

Zurück | Nach oben | Weiter
Fernsteuerung II: Von außen Programme starten | Zum Anfang | Desktop


Desktop
Zurück Weiter

Desktop

Superleiste: Ordnerstruktur in der Symbolleiste
Übersichtlicher Desktop: Multifunktionale Desktop-Icons
Windows Explorer: Suchen und Filtern im Explorer-Fenster
Infotipps ausbauen: Schnelle Maus-Infos
Aufräumen: Nie wieder gelbe Zettel am Monitor
Scharfe Schrift: Bessere Darstellung mit dem Cleartype Tuner
Datei-Indizierung: Schlagwortsuche über NTFS-Streams
Anwendungen schneller starten: Schlauerer „Ausführen“-Dialog
Archivierung: Ordnerlisten bearbeiten und ausdrucken
Flotte Verzeichnis-Erstellung: Quick-Ordner
Zurück |  | Weiter
Netzwerkumgebung: Langsame Anzeige | Zum Anfang | Superleiste: Ordnerstruktur in der Symbolleiste


Superleiste: Ordnerstruktur in der Symbolleiste
Zurück Desktop Weiter

Superleiste: Ordnerstruktur in der Symbolleiste

Problem: Zu einem Verzeichnis zu navigieren ist mitunter ein klickreiches Unterfangen: Arbeitsplatz oder Explorer öffnen, Baumstruktur anzeigen lassen und den Ordner suchen.

Lösung: Mit einem undokumentierten Schlüssel in der Registry verpflanzen Sie die gesamte Ordnerhierarchie als Baumstruktur als unabhängige Symbolleiste auf den Desktop. Dort reagiert sie wie im Explorer: Per Klick auf „+“ und „–“ klappen Sie Unterverzeichnisse ein und aus. Ein einfacher Mausklick auf einen Ordner öffnet diesen mit dem Windows-Explorer. Und so geht’s: Zuerst ergänzen Sie die Windows-Registry um einen undokumentierten Schlüssel. Kopieren Sie dazu unsere vorbereitete REG-Datei Exbar in ein beliebiges Verzeichnis, und importieren Sie sie per Doppelklick in die Registry. Damit die Veränderung in Kraft tritt, genügt „Aktualisieren“ im Kontextmenü des Desktops. Jetzt können Sie die Leiste einsetzen: Klicken Sie mit der rechten Maustaste auf die Taskleiste, und gehen Sie unter „Symbolleiste“ auf den neuen Eintrag „Explorer Band“. Die Baumstruktur ist jetzt mit dem Titel „Ordner“ in der Taskleiste zu sehen, hier allerdings viel zu klein. Ziehen Sie deshalb die Leiste „Ordner“ auf einen freien Bereich oder an den Rand des Desktops, um sie dort permanent einzurichten. Ist dort schon eine Symbolleiste vorhanden, lässt sich die neue Leiste problemlos damit kombinieren. Übrigens: Bevor Sie unter Win XP neue Symbolleisten in der Taskleiste zu sehen bekommen, müssen Sie den Punkt „Taskleiste fixieren“ im Kontextmenü abschalten.

-dw

. Schneller Ordner-Zugriff: Mit einem Mini-Explorer auf dem Desktop haben Sie Ihre Verzeichnis-Struktur sofort parat

Abbildung 18. . Schneller Ordner-Zugriff: Mit einem Mini-Explorer auf dem Desktop haben Sie Ihre Verzeichnis-Struktur sofort parat

Zurück | Nach oben | Weiter
Desktop | Zum Anfang | Übersichtlicher Desktop: Multifunktionale Desktop-Icons


Übersichtlicher Desktop: Multifunktionale Desktop-Icons
Zurück Desktop Weiter

Übersichtlicher Desktop: Multifunktionale Desktop-Icons

Problem: Viele Anwender packen alles, was wichtig ist, auf den Desktop. Hier sind dann die Verknüpfungen jederzeit spätestens nach <Win>-<D> zugänglich – somit schneller als über jeden Startmenü-Eintrag. Bei zu vielen Links geht jedoch die Übersicht schnell verloren.

Lösung: Mit einer kleinen Registry-Erweiterung realisieren Sie multifunktionale Icons die im Kontextmenü eine ganze Palette von Programmen, Ordnern oder Benutzerdateien anbieten. Sinnvoll ist es, wenn ein solches Icon immer thematisch zusammengehörige Objekte versammelt – also etwa ein Icon „Office“ die Einzelkomponenten einer OfficeSuite. Welche Registry-Einträge im Wesentlichen nötig sind, zeigt die 2 Abbildung unten. Wenn Sie unser Script pcwMultilink.V2 einsetzen, brauchen Sie sich um diese Einträge allerdings nicht zu kümmern. Nach einem Doppelklick auf das Script öffnet sich ein Ordner, in dem Sie einfach die gewünschten Links anlegen. Einen davon müssen Sie am Ende noch als Hauptlink definieren – das wird dann jenes Linkziel, das Sie per Doppelklick erreichen und dessen Icon am Desktop erscheinen wird. Unser Script legt das Icon mit den gewünschten Kontextmenüpunkten am Desktop und in der Registry den dafür verantwortlichen Dateityp an. Anders als die Vorgängerversion kann pcwMultilink.V2 auch Links zu Ordnern und Benutzerdateien verarbeiten. Außerdem entsteht für jedes Icon der zusätzliche Menüpunkt „{Notizen}“ für Textnotizen. Nicht mehr benötigte Multilinks löschen Sie per Drag & Drop auf pcwMultilink.V2 bequem vom Desktop und aus der Registry. Noch zwei Hinweise:

1. Das Script benötigt keine Installation. Außerdem kann es in jeden beliebigen Ordner kopiert werden.

2. Unmittelbar nach dem Erstellen eines neuen Multilinks zeigt der Explorer eventuell noch nicht das korrekte Icon am Desktop. Zuverlässig erscheint das Symbol erst nach der nächsten Anmeldung oder nach einem Explorer-Neustart.

-ha

. Schnellzugriff: Über das Kontext-Menü eines beliebigen Icons starten Sie Ihre Lieblings-Programme

Abbildung 19. . Schnellzugriff: Über das Kontext-Menü eines beliebigen Icons starten Sie Ihre Lieblings-Programme

Zurück | Nach oben | Weiter
Superleiste: Ordnerstruktur in der Symbolleiste | Zum Anfang | Windows Explorer: Suchen und Filtern im Explorer-Fenster


Windows Explorer: Suchen und Filtern im Explorer-Fenster
Zurück Desktop Weiter

Windows Explorer: Suchen und Filtern im Explorer-Fenster

Problem: Wenn sich in einem Ordner zahlreiche Dateien befinden, fällt es meist schwer, spezielle Dateien herauszusuchen.

Lösung: Unser Tool pcwBand2 bietet eine Filterfunktion für den Windows-Explorer. Zur Installation von schließen Sie alle Explorer- sowie Internet-Explorer-Fenster und starten das Setup-Programm von CD. Öffnen Sie danach ein Explorer-Fenster (<Win>-<E>), und gehen Sie auf „Ansicht, Symbolleisten, PC-WELT“. Windows blendet die neue Symbolleiste zunächst fast unsichtbar ein, meist am rechten Rand der letzten angezeigten Symbolleiste. Ziehen Sie die PC-WELT-Leiste mit der Maus an die gewünschte Position. Sollte sie noch nicht sichtbar sein, schließen Sie das Explorer-Fenster und wiederholen den Vorgang.

Benutzung des Filters: Die neue Explorer-Leiste enthält ein Eingabefeld für den Suchbegriff. Tippen Sie hier beispielsweise „doc“ ein, und klicken Sie auf „Filter“. Der Explorer zeigt dann nur noch die Einträge, in denen „doc“ an beliebiger Position vorkommt. Die Schaltfläche „Select“ dient dazu, alle Dateien zu markieren, die diesem Filterkriterium entsprechen. Damit der Explorer wieder alle Dateien anzeigt, klicken Sie auf „Refresh“ oder drücken <F5>. Das Programm durchsucht und filtert grundsätzlich alles, was im Fenster steht. Im Allgemeinen bietet die Ansicht „Details“ die besten Voraussetzungen. Hier ist es bei bestimmten Dateitypen sinnvoll, noch zusätzliche Spalten über „Ansicht, Details auswählen“ einzublenden. So stehen etwa für MP3-Dateien Spalten wie „Albumtitel“ oder „Interpret“ zur Verfügung. Für die Suche nach Zahlen gibt es besondere Funktionen. Der Suchbegriff „>100“ sucht in allen Einträgen nach Zahlen über 100. Entsprechend gibt es auch kleiner („<“) und gleich („=“). Beachten Sie auch hier, dass das Programm alle aktiven Spalten durchsucht. Wenn in der Detail-Ansicht die Datumsspalte „Geändert am“ aktiv ist, dann ist ein Filter „>100“ aufgrund der Jahreszahlen funktionslos.

Erweiterte Funktionen: pcwBand2 verwendet standardmäßig eine einfache Suchfunktion. Es unterscheidet dabei nicht zwischen Groß- und Kleinschreibung und berücksichtigt auch nicht die Position in der Zeichenkette. Um das zu ändern, aktivieren Sie über die Schaltfläche „PC-Welt, Optionen“ den Punkt „Regex-Suche“. „K*“ findet beispielsweise alle Dateien, die mit „K“ beginnen. „[K;k]*“ liefert Dateien, die mit „K“ oder „k“ beginnen. Genauere Informationen zu diesen erweiterten Funktionen finden Sie in der Hilfedatei. pcwBand2 bietet auch Möglichkeiten, die mit der Suche im Explorer nicht direkt im Zusammenhang stehen. Sie können die Leiste über „Ansicht, Symbolleisten“ auch im Internet Explorer einblenden. Dort sucht das Programm Text in der aktuell angezeigten Web-Seite und markiert die Fundstellen mit der Farbe, die Sie in den Optionen eingestellt haben. Die Schaltflächen „Filter“ und „Select“ haben hier dieselbe Funktion. Über „PC-WELT, Text einfügen“ lassen sich vorher in den Optionen festgelegte Begriffe in Web-Formulare einfügen – das ist besonders beim Chatten oder in Web-Foren nützlich.

-te

. Filtern im Explorer: Mit diesem praktischen PC-WELT-Tool können Sie sich Dateien nach bestimmten Kriterien anzeigen lassen

Abbildung 20. . Filtern im Explorer: Mit diesem praktischen PC-WELT-Tool können Sie sich Dateien nach bestimmten Kriterien anzeigen lassen

Zurück | Nach oben | Weiter
Übersichtlicher Desktop: Multifunktionale Desktop-Icons | Zum Anfang | Infotipps ausbauen: Schnelle Maus-Infos


Infotipps ausbauen: Schnelle Maus-Infos
Zurück Desktop Weiter

Infotipps ausbauen: Schnelle Maus-Infos

Problem: An jeder Datei und an jedem Ordner haften eine ganze Reihe informativer Attribute. Im Explorer von Windows XP können Sie sich jedes einzelne dieser Attribute in einer eigenen Spalte anzeigen lassen. Bei den bis zu 37 Spalten in der Detail-Ansicht geht jedoch die Übersicht vollständig verloren.

Lösung: Eine praktische und häufig unterbewertete Funktion von Windows ist der „Infotip“. Er erscheint, wenn Sie im Explorer mit der Maus auf eine Datei oder einen Ordner zeigen. Standardmäßig wird jedoch nur ein Bruchteil aller 37 verfügbaren Attribute angezeigt. Mit unserem Script pcwInfotip erweitern Sie den Infotipp auf immerhin 32 Einträge. Kopieren Sie unser Script zunächst in ein leeres Verzeichnis, und rufen Sie es auf. Im ersten Schritt legt das Script ein Backup der zu modifizierenden Registry-Schlüssel in Form der Datei Infotip.REG im Script-Verzeichnis an. Danach schreibt es die Schlüssel neu. Die Änderungen greifen sofort. Wenn Sie mit dem Mauszeiger im aktiven Fenster auf eine Datei oder einen Ordner zeigen, erscheinen alle in der Datei vergebenen Attribute. Dazu gehören beispielsweise die Abtastrate von Videos, die Seitenzahl von Dokumenten, das Genre von MP3-Dateien und vieles mehr. Grundsätzlich gilt: Wenn ein Attribut nicht angezeigt wird, wurde es nicht vergeben. Um den Ausgangszustand wiederzuherstellen, rufen Sie die Infotip.REG auf oder starten das Script noch einmal.

Für Profis: Der Infotipp für lokale Dateien und Ordner wird je nach Dateityp in der Registry-Zeichenfolge „Infotip“ gespeichert. Zum Beispiel finden Sie diesen Eintrag im Schlüssel „Hkey_Classes_Root\*“. Hier können Sie festlegen, welche Attribute im Infotipp aller Dateien – mit Ausnahme von System- und Multimedia-Dateien – erscheinen sollen. Im selben Schlüssel befindet sich auch die Zeichenfolge „QuickTip“. Hier gibt der Benutzer die Attribute an, die bei Infotipps zu Dateien aus einer Netzwerkressource zu sehen sein sollen. Um speziell für System- oder Multimedia-Dateien Infotipp-Attribute zu vergeben, müssen Sie den Schlüssel „Hkey_Classes_Root\SystemFileAssociations“ öffnen und den gewünschten Dateityp finden. Für Musikstücke ist das etwa der Unterschlüssel „Audio“, für Filme „Video“ und für Bilder „Image“. Die einzelnen Attribute werden als Zeichenfolge „Infotip“ oder „Quicktip“ durch Semikolon „;“ getrennt eingetragen, wobei die Zeile immer mit „prop:Type“ beginnen muss.Wenn Sie beispielsweise den Namen, die Größe und den Besitzer der Datei anzeigen möchten, geben Sie als Wert von Infotipp

prop:Type;Name;Size;Owner

ein. Eine vollständige Liste aller Attribute und deren Beschreibung finden Sie in der Datei pcwInfotip-Attribute.

-cl

Zurück | Nach oben | Weiter
Windows Explorer: Suchen und Filtern im Explorer-Fenster | Zum Anfang | Aufräumen: Nie wieder gelbe Zettel am Monitor


Aufräumen: Nie wieder gelbe Zettel am Monitor
Zurück Desktop Weiter

Aufräumen: Nie wieder gelbe Zettel am Monitor

Problem: Das papierlose Büro gibt es nicht. Immer noch kleben jede Menge gelbe Notizzettel am Monitor oder auf der Tastatur – das ist nicht unbedingt praktisch. Es gibt zwar zahlreiche Free- und Shareware-Lösungen, die die Zettelsammlung auf den Desktop verlagern sollen. Doch die sind Ihnen zu aufwendig.

Lösung: Es geht einfacher. Windows bringt selbst alle Voraussetzungen für eine digital Zettelsammlung mit. Am besten legen Sie für die Desktop-Notizen einen speziellen Dateityp an. Dabei handelt es sich um simple Textdateien – mit dem Unterschied, dass Sie ihnen eine eigene Endung und ein spezielle Icon spendieren, die sie von normalen Textdateien unterscheiden. Dateityp anlegen: Diese Aufgabe erledigt die Registry-Datei pcwNotiz. Entpacken Sie die Datei in ein beliebiges Verzeichnis, und importieren Sie den Inhalt der Datei per Doppelklick in die Registry. Anschließend kennt Windows den neuen Dateityp „Notiz“ mit der Endung NOTE. Die Datei-Endung haben wir standardmäßig auf „immer versteckt“ gesetzt damit sie nicht von der Notiz ablenkt. Desktop-Notizen verwenden: Wenn Sie eine Notiz erstellen wollen, klicken Sie mit der rechten Maustaste auf den Desktop und wählen aus dem Kontextmenü „Neu“ den Punkt „Notiz“. Daraufhin erscheint ein neues Icon mit der Bezeichnung „Neu Notiz“, das Sie gleich entsprechend umbenennen, etwa in „Blumen gießen“ oder „Backup nicht vergessen“. Auf diesem Weg kann Ihnen auch ein Kollege etwas mitteilen, der in Ihrer Abwesenheit an Ihren PC kommt. Das kleine Pfeilsymbol unserer Notizdateien wird sonst für keinen Dateityp verwendet. Außerdem lenkt es durch seine geringe Größe nicht von der Icon-Beschriftung ab, die ja den eigentlichen Inhalt ausmacht. Falls die Icon-Beschriftung nicht für die gesamte Notiz aus-reicht, macht das nichts – eine Notizdatei ist ja nichts anderes als eine abgewandelte Textdatei. Sie können sie per Doppelklick öffnen und den ausführlichen Inhalt als Text hinterlegen. Als Icon-Beschriftung wählen Sie lediglich eine Kurzbeschreibung. Sie müssen Notizen auch nicht unbedingt auf dem Desktop hinterlegen. In jedem Ordnerfenster können Sie über „Neu, Notiz“ eine Erinnerungsstütze hinterlassen, die Sie auf etwas hinweist, sobald Sie diesen Ordner öffnen. Falls Sie die Desktop-Notizfunktion eines Tages wieder loswerden wollen, rufen Sie einfach die pcwRemNotiz.REG aus dem Archiv per Doppelklick auf.

-akr

. Schicke gelbe Zettel: Als neuer Dateityp mit kleinem Icon können Sie Erinnerungen auf dem Desktop oder in bestimmten Ordner hinterlassen

Abbildung 21. . Schicke gelbe Zettel: Als neuer Dateityp mit kleinem Icon können Sie Erinnerungen auf dem Desktop oder in bestimmten Ordner hinterlassen

Zurück | Nach oben | Weiter
Infotipps ausbauen: Schnelle Maus-Infos | Zum Anfang | Scharfe Schrift: Bessere Darstellung mit dem Cleartype Tuner


Scharfe Schrift: Bessere Darstellung mit dem Cleartype Tuner
Zurück Desktop Weiter

Scharfe Schrift: Bessere Darstellung mit dem Cleartype Tuner

Problem: Ihr TFT-Display gibt Text verschwommen wieder, obwohl Sie die korrekte Auflösung gewählt haben. Auch die Tuning-Maßnahmen über die Monitortasten haben nicht weitergeholfen.

Lösung: Cleartype dient dazu, den Kontrast von Buchstaben auf TFT-Displays zu erhöhen. Das geht mit einem Kantenglättungsverfahren. Sie aktivieren Cleartype folgendermaßen: Hangeln Sie sich durch „Systemsteuerung, Anzeige, Darstellung, Effekte“. Setzen Sie ein Häkchen vor „Folgende Methode zum Kantenglätten von Bildschirmschriften verwenden“. Wählen Sie aus der Pulldown-Liste „ClearType“. Zum Schluss speichern Sie mit „OK“. Übrigens: Gelegentlich kann es bei TFTs in Verbindung mit großen Schriftgrößen vorkommen, dass Cleartype die Ursache für verschwommene Zeichen ist. Sie sehen dann meist farbige Kanten an den Rändern. Stellen Sie fest, dass Cleartype bereits aktiviert ist, dann wählen Sie stattdessen „Standard“. Cleartype ist dann außer Kraft gesetzt. Microsoft bietet auf seiner Website das Zusatz-Tool Cleartype Tuner, mit dem Sie Schriften bei aktiviertem Cleartype optimieren können. Cleartype Tuner können Sie online nutzen. Alternativ speichern Sie das englischsprachige Gratis-Tool erst auf Festplatte (2,6 MB). Gleich nach der Installation erscheinen die „ClearType Settings“. Unter „Advanced“ muss „ClearType“ aktiviert sein. Per Regler können Sie in diesem Fenster zudem den Kontrast verändern. „Übernehmen“ Sie die Einstellungen. Wechseln Sie auf die Registerkarte „Introduction und klicken Sie auf „Start Wizard“. Wählen Sie in den beiden folgenden Fenstern jeweils denjenigen Schriftkasten, der Ihnen am angenehmsten erscheint. Im letzten Fenster sehen Sie Textbeispiele verschiedener Schriften. Sind Sie damit einverstanden, klicken Sie auf „Fertig stellen“.

-mak

. Online-Tuner: Über eine Microsoft-Webseite können Sie die Darstellung von Fonts auf TFT-Bildschirmen aktivieren und optimieren

Abbildung 22. . Online-Tuner: Über eine Microsoft-Webseite können Sie die Darstellung von Fonts auf TFT-Bildschirmen aktivieren und optimieren

Zurück | Nach oben | Weiter
Aufräumen: Nie wieder gelbe Zettel am Monitor | Zum Anfang | Datei-Indizierung: Schlagwortsuche über NTFS-Streams


Datei-Indizierung: Schlagwortsuche über NTFS-Streams
Zurück Desktop Weiter

Datei-Indizierung: Schlagwortsuche über NTFS-Streams

Problem: Sie haben immer größere Datenmengen auf Ihrer Platte. Sie suchen nach einer formatübergreifenden Methode, Dateien mit Schlagwörtern auszustatten und zielsicher aufzufinden.

Lösung: Es gibt mehrere Ansätze, um die wachsenden Dateimengen für die Suche in den Griff zu bekommen. Dazu zählen etwa ID3-Tags in Musikdateien, Exif-Header in Bilddaten, Metadaten in Office-Dokumenten und das geplante Dateisystem Win-FS. Sie haben aber den Nachteil, dass sie nur jeweils ein Dateiformat erfassen. Eine seit Jahren brachliegende Technik ist der Weg über NTFS-Streams, die der Datei als Info anhängen. Streams haben gegenüber formatspezifischen Lösungen den großen Vorteil, bei jeder beliebigen Datei zu funktionieren. Eine echte Integration dieser Streams in die normale Dateisuche nach Name, Größe und sonstigen Attributen sollte irgendwann von Microsoft kommen. Wir bieten hier mit unserem VB-Script pcwDescribe eine Lösung mit Experiment-Charakter an, die aber fix und bequem arbeitet und durchaus alltagstauglich ist. Über den neuen Kontextmenüpunkt „Describe“ im Windows-Explorer hängen Sie an die Datei einen Stream mit dem Namen „:pcwDescription“ an, in den Sie beliebige Kommentare und Stichwörter schreiben können. Als Stream-Editor dient ein automatisch startendes Notepad-Fenster. Beim Eingeben der Stichwörter müssen Sie keine bestimmte Struktur beachten, bei späteren Suchläufen arbeitet eine einfache Volltextsuche. Auch Groß- und Kleinschreibung spielt keine Rolle: Wenn Sie also „wichtig budget wiedervorlage“ eintragen, finden Sie die Datei später mit jedem der drei Stichwörter wieder. Eine Kombination mehrerer, durch Leerzeichen getrennter Suchwörter entspricht immer einem logischen „UND“. Das heißt: Mit „wiedervor bud“ finden Sie den oben angelegten Stream und die zugehörige Datei, mit „wiedervor bilanz“ jedoch nicht. Eine Suche starten Sie, indem Sie das Kontextmenü „Description_Find“ wählen und ein Stichwort oder eine Wortkombination eingeben. Die Suche geht immer von der angeklickten Datei oder dem angeklickten Ordner aus und läuft dann rekursiv durch alle untergeordneten Ebenen. Wenn Sie kein Stichwort angeben, sucht das Script sämtliche Dateien mit dem Stream „:pcwDescription“. Die Treffer gibt das Script in Form von temporären Links im Ordner %windir%\LinkMe aus. Zur Installation: Das Script benötigt die Active-X-Komponente pcwFMan, die Sie am einfachsten mit Doppelklick auf FMan_Reg (beide Dateien im Archiv pcwDescribe) am System anmelden. Danach genügt ein Doppelklick auf pcwDescribe, um das Script in den Windows-Ordner zu kopieren und seine beiden Kontextmenüs in der Registry einzurichten. Um Script und Active-X-Komponente zu de-installieren, gehen Sie analog vor – ein Doppelklick auf das Script, ein weiterer auf FMan_Unreg.BAT (im Archiv pcwDescribe). Übrigens: Streams belegen erst dann einen eigenen Cluster, wenn sie nicht mehr in den letzten Cluster der Hauptdatei passen. Bei der hier anfallenden geringen Textmenge einiger Schlagwörter werden selbst Tausende solcher Streams gar nicht oder nur mit wenigen KB zu Buche schlagen.

-ha/te

Zurück | Nach oben | Weiter
Scharfe Schrift: Bessere Darstellung mit dem Cleartype Tuner | Zum Anfang | Anwendungen schneller starten: Schlauerer „Ausführen“-Dialog


Anwendungen schneller starten: Schlauerer „Ausführen“-Dialog
Zurück Desktop Weiter

Anwendungen schneller starten: Schlauerer „Ausführen“-Dialog

Problem: Der Dialog „Start, Ausführen“ durchsucht nach der Eingabe eines Programmnamens alle Ordner im Systempfad. Wird er dort (und in der Registry unter „Hkey_Local_Machine\Software\Microsoft\ Windows\CurrentVersion\App Paths“) nicht fündig, erscheint eine Fehlermeldung.

Lösung: Den Dialog können Sie mit einfachen Mitteln so tunen, dass er pfadunabhängig arbeitet. Die simple Idee besteht darin, mit der Batchdatei pcwStartRun bei Bedarf eine Suche auf der gesamten Platte zu veranlassen. Da der Dialog diesen Schritt nicht von sich aus unternimmt, geben Sie ihm als Signal lediglich einen Bindestrich vor: „- excel” startet alle Dateien, die im Namen „excel“ enthalten, die präzisere Eingabe „- excel.exe“ nur Programme mit dem Namen „Excel“. Sie können – etwa mit „- telefon“ – auch Benutzerdateien mit der zugehörigen Anwendung starten. Die Batchdatei müssen Sie nur auf Festplatte kopieren und per Doppelklick installieren. Übrigens hat die kleine Erweiterung noch einen Nebeneffekt: Nach einem Befehl wie „net use“ unter „Start, Ausführen“ erscheint die Ausgabe im Kommandointerpreter, schließt sich aber zu schnell, um sie lesen zu können. Geben Sie das Kommando in der Form „- net use“ ein, verhindert ein Pause-Befehl das vorzeitige Schließen.

-ha

Zurück | Nach oben | Weiter
Datei-Indizierung: Schlagwortsuche über NTFS-Streams | Zum Anfang | Archivierung: Ordnerlisten bearbeiten und ausdrucken


Archivierung: Ordnerlisten bearbeiten und ausdrucken
Zurück Desktop Weiter

Archivierung: Ordnerlisten bearbeiten und ausdrucken

Problem: Sie möchten den Inhalt eines Verzeichnisses möglichst bequem ausdrucken, um zum Beispiel einen Katalog Ihres Video-Archivs anzulegen. Leider stellt Windows keine derartige Funktion zur Verfügung.

Lösung: Ein neuer Kontextmenüpunkt erledigt den Job. Zunächst brauchen Sie dazu eine Batchdatei, die den Ausdruck besorgt. Diese Batch binden Sie im zweiten Schritt in das Kontextmenü ein.

1. Legen Sie im Windows-Ordner eine Datei mit dem Namen VerzDrucken.BAT an, und öffnen Sie diese mit Notepad. Tragen Sie die beiden Zeilen

dir %1 /-p /o:gn > "%temp%\VerzListe.txt"
start /w notepad /p "%temp%\VerzListe.txt"

in die neue Batchdatei ein.

2. Nun starten Sie Regedit und öffnen den Schlüssel „Hkey_Classes_Root\Directory\shell“. Legen Sie einen neuen Unterschlüssel „Verzeichnis drucken“ und darunter den Schlüssel „Command“ an. Geben Sie der „(Standard)“-Zeichenfolge den Wert

cmd.exe /c c:\windows\verzdrucken.bat "%L"

Passen Sie gegebenenfalls den Pfad des Windows-Ordners an. Jetzt können Sie mit „Verzeichnis drucken“ im Kontextmenü eines Ordners eine Liste auf dem Standarddrucker ausgeben. Übrigens: Sie können die gleiche Aufgabe natürlich auch einer Makro-fähigen Textverarbeitung übergeben. Das bietet Ihnen die Vorteile, dass Sie die auszugebenden Informationen frei wählen können und mehr Möglichkeiten bei der Darstellung haben. Ein Beispiel für Word 97-2003 finden Sie in der Datei pcwDateiliste. Um das dort enthaltene Makro „Dateiliste“ in Word zu integrieren, öffnen Sie mit <Alt>-<F11> den Visual-Basic-Editor, gehen auf „Datei, Datei importieren“ und suchen dann die Code-Datei, die Sie mit „Öffnen“ importieren. Nach dem Start des neuen Makros über „Extras, Makro, Makros“ können Sie in einem Dialog den gewünschten Ordner anklicken, dessen Dateien dann einschließlich aller Unterordner in einer neuen Word-Datei dargestellt werden.

-cl/-ha

Zurück | Nach oben | Weiter
Anwendungen schneller starten: Schlauerer „Ausführen“-Dialog | Zum Anfang | Flotte Verzeichnis-Erstellung: Quick-Ordner


Flotte Verzeichnis-Erstellung: Quick-Ordner
Zurück Desktop Weiter

Flotte Verzeichnis-Erstellung: Quick-Ordner

Problem: Sie möchten eine komplexe Ordnerstruktur neu anlegen. Der Explorer macht Ihnen das Leben schwer: Sie müssen mit Rechtsklick und „Neu“ jeden Ordner einzeln anlegen. Mit einem PC-WELT-Script geht das ganz einfach.

Lösung: pcwTreeBuilder installieren Sie einfach per Doppelklick. Danach finden Sie im Kontextmenü von Ordnern den neuen Eintrag „Ordnerbaum anlegen“. Damit erstellen Sie die gewünschte Ordnerstruktur im aktuellen Verzeichnis. Das Script öffnet eine Dialogbox, die zwei Möglichkeiten anbietet. Mehrere Ordner parallel: Wenn Sie im Verzeichnis C:\Archiv\ die Unterordner Musik, Bilder und Filme auf derselben Ebene anlegen möchten, dann klicken Sie den Ordner C:\Archiv mit der rechten Maustaste an, wählen „Ordnerbaum anlegen“ und tragen „Musik/Bilder/Filme“ (ohne Anführungszeichen) ein. Der Slash („/“) zwischen den Namen informiert das Script, dass es die Ordner alle auf der Ebene C:\Archiv einrichten soll. Hierarchische Struktur: Möchten Sie stattdessen das Verzeichnis „C:\Archiv\Musik\Gluecifer\Automatic Thrill\“ schaffen, dann tragen Sie nach „Ordnerbaum anlegen“ in die Eingabezeile „Musik\Gluecifer\Automatic Thrill“ ein. Der Backslash („\“) signalisiert unserem Script, dass die Ordner untereinander angelegt werden sollen.

Tipp – Inhalte entfernen: Wenn Sie aus einer Ordnerstruktur alle Daten löschen möchten, ohne die Verzeichnisse selbst zu entfernen, hilft folgender Trick: Starten Sie Regedit, und öffnen Sie den Schlüssel „Hkey_Classes_Root\Directory\Shell“. Legen Sie hier den neuen Schlüssel „Ordnerinhalte löschen“ und darunter den Unterschlüssel „Command“ an. Der Standardzeichenfolge des „Command“-Schlüssels geben Sie folgenden Wert:

cmd.exe /k cd /d %1 && del /s /f *.*

Wenn Sie danach mit der rechten Maustaste auf einen Ordner klicken und „Ordnerinhalte löschen“ wählen, entfernen Sie alle Dateien aus dem ausgewählten Ordner und dessen Unterordnern. Wenn Sie sämtliche Rückfragen unterdrücken wollen, ergänzen Sie den Löschbefehl „del /s /f *.*“ durch den Schalter /q – also: „del /s /f /q *.*“ „q“ steht für „quiet“, „s“ für „rekursiv“ durch alle Ordner und „f“ für „force“ – damit werden auch schreibgeschützte Dateien entfernt.

-cl

. Verzeichnisse: Über diesen Dialog erstellen Sie schnell komplexe Ordnerstrukturen

Abbildung 23. . Verzeichnisse: Über diesen Dialog erstellen Sie schnell komplexe Ordnerstrukturen

Zurück | Nach oben | Weiter
Archivierung: Ordnerlisten bearbeiten und ausdrucken | Zum Anfang | Tools


Tools
Zurück Weiter

Tools

pcwAnnoyances: XP optimal anpassen
pcwPatchloader: Praktischer Update-Manager
pcwMegaLoader: Gratis Tools von Microsoft
pcwNetBookmarks 0.1.6: Mobile Lesezeichen
pcwTypCheck: Dateizuordnungen sichern und reparieren
pcwPDF2HTML: PDF-Dateien ins HTML-Format konvertieren
pcw1-1.v06: Daten synchronisieren
pcwArbeitsplatzErweitern1.1: Eigene Links Im Arbeitsplatz
pcwCleaner: Radikal aufräumen
pcwPDF: PDF-Konvertierer
Zurück |  | Weiter
Flotte Verzeichnis-Erstellung: Quick-Ordner | Zum Anfang | pcwAnnoyances: XP optimal anpassen


pcwAnnoyances: XP optimal anpassen
Zurück Tools Weiter

pcwAnnoyances: XP optimal anpassen

Problem: Das nervt: Windows XP präsentiert sich optisch zunächst einmal wie eine gut ausgestattete Spielwarenabteilung. An jeder Ecke zappelt und blinkt, was das System gerade für wichtig befindet. Standardmäßig versteckt der Windows-Explorer Systemdateien und die Vergabe von NTFS-Rechten, da die einfache Dateifreigabe aktiviert ist. Bei jedem neuen Link erscheint der überflüssige Text „Verknüpfung mit“. Wenn Sie nicht registrierte Dateien anklicken, wird dem „Öffnen mit“-Dialog ein WebDienst vorgeschaltet. Er soll online ein passendes Programm finden – tut es aber nicht . Wenn Sie die Windows-Optik und den Explorer optimiert haben, nervt das System immer noch mit der Fehlerberichterstattung und einer Desktopbereinigung. Auf der anderen Seite fehlen wichtige Einstellmöglichkeiten. Wenn das System alle Viere von sich streckt und Sie nur noch in die Wiederherstellungskonsole kommen, dürfen Sie dort standardmäßig kaum einen Ordner öffnen.

Lösung: Weg mit den Gimmicks! Am besten setzen Sie dafür unser Script pcwAnnoyances ein. Es erspart Ihnen das Aufsuchen vieler verstreuter Systemeinstellungen und macht nach wenigen Mausklicks Schluss mit einer Vielzahl von Windows-Plagen. Um das Tool zu nutzen, starten Sie es per Doppelklick. Falls der Aufruf nicht klappt, stimmt wahrscheinlich die Dateizuordnung für HTA-Dateien zur Mshta.EXE nicht. Sie können das mit pcwHTAFix per Doppelklick korrigieren. Nach dem Aufruf von pcwAnnoyances 1.1 sehen Sie einen Dialog mit 44 Klickboxen. Sie sind unterteilt in die drei Rubriken „Visuelle Stile für optimale Leistung anpassen“, „Funktionalität des Explorer verbessern“ und „Weitere Funktionen konfigurieren“. Das Script zeigt den Stand der Optionen durch aktivierte oder deaktivierte Klickboxen an. Sie können diese Statusanzeige jederzeit manuell aktualisieren, indem Sie auf die Schaltfläche „Aktuellen Zustand anzeigen“ klicken. Das Script beschränkt sich keineswegs nur auf unzugängliche und undokumentierte Funktionen, sondern dient als Konfigurationszentrale für allen möglichen Windows-Schnickschnack. Neben dokumentierten und im Explorer schwer zugänglichen Optionen erfasst es auch Einstellungen, die sich sonst nur in der Registry setzen lassen. Ein Beispiel unter vielen ist die Aktivierung der klassischen Suche, die den zappelnden Spürhund in die Hütte schickt und wieder einen funktionalen Dialog herstellt. Das PC-WELT-Tool erkennt, ob Sie es mit Administratorrechten ausführen oder als eingeschränkter Benutzer. Im zweiten Fall sind alle Optionen ausgegraut, die Sie nicht setzen können. Der aktuelle Benutzerkontext steht auch in der Titelzeile. Um Einstellungen zu verändern, setzen oder entfernen Sie einfach ein Häkchen in den Klickboxen. Alle Optionen einer Rubrik können Sie auf einmal auswählen, indem Sie die Klickbox neben einem Rubriktitel aktivieren (zum Beispiel „Visuelle Stile für optimale Leistung anpassen“). Wenn Sie eine Option aktivieren, wird die beschriebene Einstellung in der Registry festgelegt. Auf Wunsch zeigt ein Infotipp an, welchen Registry-Eintrag Sie verändern. Damit Sie ihn zu sehen bekommen, lassen Sie einfach den Mauszeiger einige Sekunden über der jeweiligen Klickbox stehen, ohne zu klicken. Nachdem Sie Ihre Auswahl getroffen haben, klicken Sie auf „Einstellungen übernehmen“, um die Werte zu setzen. Nachdem das Script seine Arbeit erledigt hat, wird der Explorer automatisch neu aufgerufen. Zusätzlich startet das Script automatisch den Befehl

rundll32 user32,UpdatePerUserSystemParameters

Er bewirkt, dass die meisten Einstellungen sofort aktiviert werden. Einige gelten jedoch erst nach dem nächsten Neustart.

Der Bereich „Visuelle Stile für optimale Leistung anpassen“ listet das Script übersichtlich 21 Nervereien auf, damit Sie diese schnell abschalten können. Die wichtigsten im Überblick: Die Option „Klassischen Desktop aktivieren“ versachlicht das Spielzeug-XP schlagartig: Hier lässt sich die klassische Suche aktivieren und das gelbe Gequassel der Infoblasen im Systray abschalten. Jede Menge Schatten unter Menüs oder Maus können Sie sich genauso sparen wie Animationen beim Minimieren von Fenstern. Am einfachsten und schnellsten ist es, gleich die Klickbox für die ganze Rubrik zu aktivieren. Wenn Sie allerdings einen Röhrenmonitor verwenden, sollten Sie auf die letzte Option („Cleartype aktivieren“) verzichten. Diese Funktion verbessert die Lesbarkeit nur auf TFT-Displays. Lassen Sie sich vom Windows-Explorer möglichst alle Informationen anzeigen. In der zweiten Rubrik finden Sie die wichtigsten Einstellungen zum Explorer. Auch hier gilt: Wenn Sie die Klickbox neben dem Rubriktitel aktivieren, schalten Sie die aus unserer Sicht ideale Einstellung ein. Sie können alle Datei- Erweiterungen, alle versteckten sowie sämtliche Systemdateien anzeigen lassen, die normale Dateifreigabe aktivieren (nur unter XP Pro) und den nutzlosen Web-Dienst deaktivieren. Unser Tool erlaubt es Ihnen, mit einem Klick Verknüpfungen ohne Pfeil und „Verknüpfung mit“ anzulegen, die Ordneransicht systemweit auf Detailansicht und alle speziell gespeicherten Ordner-Ansichten auf den „Standard“ zu setzen (in unserem Fall „Detail“). Ein Klick auf „Einstellungen übernehmen“ setzt die Werte. Übrigens: Wenn Sie die Detailansicht eingeschaltet haben, können Sie sie über unser Script nicht wieder zurücksetzen. Eine andere systemweite Ordner-Ansicht definieren Sie auf diesem Weg: Sie öffnen ein Explorer-Fenster, wählen über „Ansicht“ einen Typ aus, gehen dann auf „Extras, Ordneroptionen“ und klicken auf der Registerkarte „Ansicht“ auf „Für alle übernehmen“.

Mit unserem Script können Sie unter anderem die Assistenten zur Desktop-Bereinigung und Fehlerberichterstattung deaktivieren sowie die Warnungen bei Gerätefehlern und bei Speicherplatz unter 200 MB unterdrücken. Außerdem können Sie in den Eigenschaften jedes Geräts im Geräte-Manager eine Registerkarte „Details“ einbinden, auf der genauere Informationen hinterlegt werden. Im Internet Explorer machen Sie www.google.de zur Standard-Suchmaschine und entsorgen nachhaltig den überflüssigen „Links“-Ordner in den Favoriten. Zu guter Letzt können Sie den internen PC-Lautsprecher deaktivieren und das – unter Umständen wichtige – SET-Command in der Wiederherstellungskonsole freischalten. Übrigens: Wenn Sie Google als Standard-Suchmaschine definieren, können Sie auch das im Script nicht zurücksetzen.

-cl/-te

. pcwAnnoyances: Mit diesem Tool korrigieren Sie die nervigsten XP-Schwächen und -Einstellungen

Abbildung 24. . pcwAnnoyances: Mit diesem Tool korrigieren Sie die nervigsten XP-Schwächen und -Einstellungen

Zurück | Nach oben | Weiter
Tools | Zum Anfang | pcwPatchloader: Praktischer Update-Manager


pcwPatchloader: Praktischer Update-Manager
Zurück Tools Weiter

pcwPatchloader: Praktischer Update-Manager

Problem: Nach einem Systemkollaps folgt häufig eine Neu-Installation, und was dann? Ihr XP-System ist danach auf dem Stand von 2001 – oder bestenfalls Mitte 2004, wenn Sie eine CD mit integriertem Service Pack 2 besitzen. Bei Ihrem ersten Besuch im Internet fangen Sie sich wahrscheinlich in wenigen Sekunden den ersten Wurm ein, selbst wenn Sie nur die Windows-Update-Site ansteuern.

Lösung: Das Tool pcwUltimateLoader speichert alle sicherheitsrelevanten Updates und Patches auf die Festplatte und erlaubt somit eine Neu-Installation mit dem aktuellsten Sicherheitsstand. Installation: Entpacken Sie das gleichnamige Archiv zunächst in ein beliebiges Verzeichnis. Falls Sie eine Vorgängerversion des Tools verwenden, können Sie diese einfach mit dem Inhalt des neuen Archivs überschreiben. Rufen Sie dann die pcwUltimateLoader.HTA per Doppelklick auf, um das Script zu starten. Sollte das nicht klappen, liegt wohl ein Fehler in der Dateizuordnung der Erweiterung HTA vor. Dieser Eintrag findet sich in der Mshta.EXE im Verzeichnis \Windows\System32. Um das zu reparieren, rufen Sie einfach die pcwHtafix.REG per Doppelklick auf. Ordner für Updates wählen: Läuft das Script, müssen Sie zunächst über die obere Schaltfläche „»“ ein Haupt-Zielverzeichnis für Ihre Updates auswählen. Achten Sie darauf, dass genügend freier Platz auf der Partition vorhanden ist (wir empfehlen etwa 1 GB) und dass sich der Ordner nicht auf der Systempartition befindet. Im nächsten Schritt können Sie ein „alternatives Zielverzeichnis“ angeben – etwa wenn Ihr System an einem Netzwerk hängt und ein Teil der Updates auf einem Server bereitsteht. Der PatchLoader berücksichtigt die dort liegenden Dateien beim Überprüfen des Systems und liest sie zum Installieren ein. Neue Downloads werden in diesem Ordner nicht gespeichert. Updates herunterladen: Über die ersten zwei Klickboxen im Dialog können Sie festlegen, ob das aktuelle Service Pack sowiekritische Updates für „Nicht-Windows-Anwendungen“ (zum Beispiel Office 2003 oder IE 6) ebenfalls heruntergeladen werden sollen. Mit der dritten Klickbox aktivieren Sie (falls nötig) den Download über einen Proxy. Nach dem ersten Klick auf „Überprüfen“ holt sich unser Tool zunächst einige Hilfsprogramme von Microsoft aus dem Netz und installiert sie gegebenenfalls. Danach wird das System überprüft. Da beim ersten Aufruf etwa 15 MB an Daten heruntergeladen und installiert werden müssen, kann es etwas dauern. Die nächsten Male geht es schneller. Über die Schaltfläche „Laden“ können Sie die gelisteten Patches dann in den Haupt-Zielordner herunterladen. Überprüfen Sie Ihr System am besten jeden Monat, und aktualisieren Sie dabei die Patch-Datenbank. Übrigens: Neu ist auch die Schaltfläche „Hilfe“. Falls Sie Probleme mit dem PatchLoader haben, klicken Sie hierauf , um die Hilfe-Datei anzuzeigen. Sie wird in regelmäßigen Abständen von uns aktualisiert und automatisch jedesmal auf Ihr System geladen, wenn Sie die Patch-Datenbank auf den neuesten Stand bringen.

Am komfortabelsten ist es natürlich, Windows gleich inklusive aller Patches zu installieren. Kein Problem: Mit unserem Tool brennen Sie aus dem Update-Archiv und Ihrer XP-Setup-CD oder -Recovery-CD eine XP-Setup-CD, auf der Service Pack2 und alle Updates integriert sind. Wenn Sie nur über eine Recovery-CD oder -Partition verfügen, müssen Sie die Systemdateien zunächst aufbereiten. Wie Sie das tun, erfahren Sie im Artikel „Vollwertiges XP aus einer Recovery-CD“ (PC-WELT 3/2007, Seite 52, Punkt 1). Den Abschnitt „Setup-Ordner vorbereiten“ können Sie ignorieren – unser Tool erledigt die dort beschriebenen Anpassungen für Sie. Wenn Sie zuvor die Brenn-Tools heruntergeladen haben, wählen Sie nun über die Drop-down-Liste neben „CD/DVD-Brenner“ den Laufwerksbuchstaben Ihres Brenners aus. Dann legen Sie die XP-CD ein und klicken auf „Setup-CD/DVD anlegen“. Wenn Sie den „i386“-Ordner aus Ihren Recovery-Medium extrahiert haben, legen Sie das Medium nicht ein, sondern klicken gleich auf „Setup-CD/DVD anlegen“. Im ersten Dialog tragen Sie dann den Pfad zu Ihrem Ordner \RealXP ein. Nachdem das Tool alle Setup-Dateien kopiert und das Service Pack 2 und die Updates eingebunden hat, legt es ein bootfähiges Image an und brennt es.

-cl

. pcwUltimateLoader: Mit unserem Tool laden Sie aktuelle Patches von Microsoft um Sie später bei Bedarf zu installieren

Abbildung 25. . pcwUltimateLoader: Mit unserem Tool laden Sie aktuelle Patches von Microsoft um Sie später bei Bedarf zu installieren

Zurück | Nach oben | Weiter
pcwAnnoyances: XP optimal anpassen | Zum Anfang | pcwMegaLoader: Gratis Tools von Microsoft


pcwMegaLoader: Gratis Tools von Microsoft
Zurück Tools Weiter

pcwMegaLoader: Gratis Tools von Microsoft

Problem: Sie benötigen ein Gratis-Tool von Microsoft für Ihr System. Dieses auf den Microsoft-Webseiten zu finden ist allerdings ein mühseliges Unterfangen, meist liegen Sie verborgen oder unerreichbar in den Tiefen der Server.

Lösung: pcwMegaLoader holt Ihnen alles von der Microsoft-Website, was nützlich und gratis ist – ohne Rumsuchen und viel Geklicke. Dafür haben wir ein nagelneues Tool und ein bewährtes in aktueller Version zusammengefasst. Es ist Teil des Paketes pcwUltimateLoader. Microsoft hat im Web jede Menge kostenlose Programme für die unterschiedlichsten Aufgaben versteckt. Bloß: Kaum jemand hat einen Überblick, welche und wo. Sie brauchen das auch nicht zu wissen: Aktuell können Sie damit 150 Programme und Systemerweiterungen aus den Tiefen der Microsoft-Server an die Oberfläche angeln – und es werden laufend mehr. pcwMegaLoader weiß, wo das Zeug liegt, und präsentiert alles auf einer übersichtlichen Oberfläche – zusammen mit kurzen Beschreibungen. Sie müssen nur noch das Passende auswählen. Dabei entfällt übrigens die WGA-Prüfung, die normalerweise für fast alle Tools erforderlich ist.

1. MegaLoader-Modul starten: Klicken Sie im pcwUltimateLoader rechts oben auf „MegaLoader öffnen“. Der Aufruf kann einen Moment dauern, da zunächst die Liste mit derzeit 150 Microsoft-Tools eingelesen wird.

2. Verzeichnis wählen: Klicken Sie auf „»“, um ein Download-Verzeichnis für die Microsoft-Tools zu wählen. Wenn Sie alle zusammen herunterladen möchten, brauchen Sie etwa 1,5 GB Platz.

3. Liste aktualisieren: Wenn Sie auf „Aktualisieren“ klicken, wird die aktuellste Tool-Liste von unserem Server geholt. Das sollten Sie vor allem bei Erscheinen jeder neuen PC-WELT machen, da wir die Liste der Microsoft-Tools Monat für Monat erweitern.

4. Tools auswählen: Nun wählen Sie alle oder einzelne Angebote, indem Sie die entsprechende(n) Klickbox(en) aktivieren Eine kurze Erläuterung zu jedem Tool erhalten Sie, wenn Sie die Maus auf die Schaltfläche „?“ ziehen oder direkt draufklicken Wenn Sie wissen, was Sie suchen, können Sie auch gezielt vorgehen: Ganz unten finden Sie die Schaltfläche „Filtern“. In das Feld daneben tippen Sie etwa „Sysinternals“ (ohne Anführungszeichen) ein, dann klicken Sie auf „Filtern“. Nun zeigt die Tool-Liste nur noch die Administrations-Werkzeuge von Sysinternals an. Ein Klick auf „Alle“ lädt die gesamte Liste.

5. Tools laden: Nachdem Sie Ihre Auswahl getroffen haben, klicken Sie auf „Herunterladen“. Zu jedem Programm wird nun ein Unterverzeichnis mit dem Namen des Tools angelegt, das die Setup-Datei und eine Kurzbeschreibung enthält.

-cl

. pcwUltimateLoader: Mit dem Tool wählen Sie aus einer umfangreichen Liste Gratis-Tools, nicht nur von Microsoft

Abbildung 26. . pcwUltimateLoader: Mit dem Tool wählen Sie aus einer umfangreichen Liste Gratis-Tools, nicht nur von Microsoft

Zurück | Nach oben | Weiter
pcwPatchloader: Praktischer Update-Manager | Zum Anfang | pcwNetBookmarks 0.1.6: Mobile Lesezeichen


pcwNetBookmarks 0.1.6: Mobile Lesezeichen
Zurück Tools Weiter

pcwNetBookmarks 0.1.6: Mobile Lesezeichen

Problem: Sie arbeiten an mehreren PCs und mit unterschiedlichen Browsern, beispielsweise zu Hause, in der Firma und von unterwegs, etwa im Zug oder im Hotel. Auf Ihre Lesezeichen wollen Sie immer Zugriff haben, sie aber selbst verwalten, ohne auf einen Online-Dienst angewiesen zu sein.

Lösung: Informationen sind meist gerade dort nicht verfügbar, wo man sie braucht – das gilt auch für Browser-Lesezeichen. Ein komfortables, komplett überarbeitetes PC-WELT-Tool schafft Abhilfe. Mit pcwNetBookmarks verwalten Sie Ihre Lesezeichen unabhängig vom Browser. Das Programm arbeitet mit Firefox dem Internet Explorer und eingeschränkt auch mit Opera zusammen. Es ist für den mobilen Betrieb konzipiert, also zum Mitnehmen auf einer externen Festplatte oder einem USB-Stick. Besonders praktisch: Wenn Sie das Tool auf mehreren Rechnern nutzen, lassen sich die Lesezeichen übers Internet laden (Server mit FTP-Zugriff erforderlich). pcwNetBookmarks einrichten: Installieren Sie das Programm von der CD in ein beliebiges Verzeichnis auf einer internen oder externen Festplatte oder einem USB-Stick. Wenn Sie das Programm später auf einen Wechseldatenträger übertragen, kopieren Sie immer das komplette Verzeichnis mit allen DLL- und Konfigurations-Dateien. Der Anwender muss Schreibrechte für das Zielverzeichnis besitzen, da das Programm die von ihm verwendeten Dateien hier ablegt. Zum schnellen Aufruf erstellen Sie am besten eine Verknüpfung auf dem Desktop. Ziehen Sie die Datei pcwNetBookmarks.exe bei gedrückter rechter Maustaste dorthin, und wählen Sie „Verknüpfungen hier erstellen“ aus dem Kontextmenü. Wenn Sie den Link im Start-Menü haben wollen, ziehen Sie die EXE-Datei auf den „Start“-Knopf und dann weiter in den gewünschten Ordner. Legen Sie den Link unter „Autostart“ an, wird das Programm automatisch bei jeder Windows-Anmeldung aufgerufen. Individuell konfigurieren: Nach dem ersten Start sehen Sie das Programmfenster mit einigen vordefinierten Lesezeichen. Über „Optionen, Einstellungen“ gelangen Sie zum Konfigurationsdialog unseres Tools. Auf der Registerkarte „Allgemein“ bestimmen Sie das Aussehen des Fensters sowie den Speichermodus. Sie können beispielsweise festlegen, ob das PC-WELT-Logo im Titel und die Bookmark-Daten (URL und Beschreibung) am unteren Fensterrand erscheinen sollen. Unter „Alles Speichern“ wählen Sie die gewünschten Formate, etwa HTML. Ist die Option „Im Systray (nach Neustart)“ aktiv, startet die Anwendung beim nächsten Mal als Systray-Icon. Mit einem Doppelklick darauf öffnen und schließen Sie das Programmfenster. Ist „Immer im Vordergrund (nach Neustart)“ aktiv, bleibt das Fenster nach dem nächsten Start auch dann im Vordergrund, wenn Sie auf ein anderes Fenster klicken. Auf den Registerkarten „Internet“ und „Proxy“ nehmen Sie die Einstellungen für die Verbindung zu einem FTP-Server vor. Achten Sie hier auf Groß-/Kleinschreibung, sonst schlägt die Verbindung fehl, oder das Programm findet das angegebene Verzeichnis nicht. Die FTP-Übertragung führt pcwNetBookmarks nur durch, wenn dieOption „Online-Speicherort verwenden“ aktiv ist. Standardmäßig überträgt das Programm nur die Datei pcwBookmarks.XML mit den Lesezeichen-Daten. Wenn die Optionen „HTML-Datei zusätzlich speichern“ und/oder „RSS-Datei speichern“ aktiv sind, legt es auch die Dateien pcwBookmarks.HTML und/oder pcwBookmarks_rss.XML auf dem Server ab. Neue Lesezeichen hinzufügen: Sie können neue Lesezeichen auf vier Arten ergänzen.

1. Per Drag & Drop ziehen Sie das Icon links neben der URL aus der Adresszeile des Browsers auf die gewünschte Position im Programmfenster. Das Ziel kann entweder ein Ordner oder der Bereich ober- oder unterhalb eines Lesezeichens sein.

2. Ebenfalls mit der Maus können Sie eine Internet-Verknüpfung (URL-Datei) auf die gewünschte Position im Programmfenster ziehen.

3. Sie markieren im Programm zuerst durch Klick mit der linken Maustaste die gewünschte Position und wählen dann im Kontextmenü „Ordner hinzufügen“ oder „Lesezeichen hinzufügen“. Einer Internet-Adresse müssen Sie ein „http://“ oder „ftp://“ voranstellen.

4. Über „Optionen, IE-Favoriten importieren“ holen Sie die Favoriten aus dem Internet Explorer in das Programm, mit „Optionen, Bookmark-Datei importieren“ eine Bookmark-Datei von Netscape, Mozilla oder Firefox. Im zweiten Fall müssen Sie den Ort der Datei angeben. Sie befindetsich mit großer Wahrscheinlichkeit unter „C:\Dokumente und Einstellungen\<Benutzer>\Anwendungsdaten\Mozilla\Profiles\default\<Verzeichnis>“. Lesezeichen und Ordner bearbeiten: Namen und Inhalte von Lesezeichen und Ordnern ändern Sie über den Kontextmenüpunkt „Bearbeiten“. Nehmen Sie die gewünschten Änderungen vor, und klicken Sie auf „OK“. Den Namen eines Ordners oder Lesezeichens können Sie auch ändern, indem Sie den Eintrag markieren und <F2> drücken oder länger darauf klicken und den Mauszeiger dabei darüber stehen lassen. Bei Lesezeichen ist es auch möglich, die URL oder Beschreibung direkt in den Feldern unter der Baumdarstellung zu ändern. Um einen Ordner oder ein Lesezeichen loszuwerden, wählen Sie „Löschen“ aus dem Kontextmenü oder markieren den Eintrag und drücken auf <Entf>. Suche in den gespeicherten Daten: Die einfache und die erweiterte Suche sind in der aktuellen Version 0.1.6 neu. Die einfache Suche funktioniert ähnlich wie im Windows-Explorer: Sie klicken auf einen Eintrag im Baum und tippen einen oder mehrere Buchstaben ein. Die Suche unterscheidet nicht zwischen Groß-/Kleinschreibung. Die Markierung springt zum nächsten Eintrag, der mit dem oder den eingetippten Buchstaben beginnt. Wenn Sie den Buchstaben oder die Zeichenfolgeerneut eingeben, springt die Markierung zur nächsten Fundstelle. An die erweiterte Suche kommen Sie über das Feld unter der Menüleiste. Geben Sie den Begriff ein, und klicken Sie auf „Suchen“. Auch diese Funktion ignoriert Groß-/Kleinschreibung und findet die Zeichenfolge überall, egal, ob sie am Anfang oder innerhalb eines Wortes steht. Über das Kontextmenü der Schaltfläche „Suchen“ können Sie die Aktion auf bestimmte Bereiche einschränken. Zur Wahl stehen „Name“, „URL“ und „Beschreibung“. Sind alle drei Optionen aktiv, durchsucht das Programm alle drei Felder. Lesezeichen und Ordner sortieren: Im Kontextmenü eines Ordners sehen Sie denneuen Menüpunkt „Sortieren“. Nach einem Klick darauf ordnet unser Tool den Inhalt des ausgewählten Ordners alphabetisch in aufsteigender Reihenfolge an. Wenn Sie den Befehl auf den obersten Ordner anwenden, sortieren Sie alle Ordner und Lesezeichen alphabetisch. Die De-Installation von pcwNetBookmarks ist denkbar einfach: Löschen Sie den Programmordner. pcwNetBookmarks greift weder in die Windows-Registry noch ins Dateisystem ein.

-te

Zurück | Nach oben | Weiter
pcwMegaLoader: Gratis Tools von Microsoft | Zum Anfang | pcwTypCheck: Dateizuordnungen sichern und reparieren


pcwTypCheck: Dateizuordnungen sichern und reparieren
Zurück Tools Weiter

pcwTypCheck: Dateizuordnungen sichern und reparieren

Problem: Nach der Installation oder De-Installation einer Software startet Windows nicht mehr das erwartete Programm, wenn Sie auf eine Datei doppelklicken. Stattdessen hat entweder ein anderes Programm diesen Dateityp übernommen, oder Sie sehen die Dialogbox „Öffnen mit“.

Lösung: Schuld an diesem Fehler sind vor allem die Installationsroutinen der jeweiligen Software. Normalerweise sollten sie Ihnen die Wahl lassen, ob sich das zu installierende Programm Dateizuordnungen schnappt. Und wenn Sie das zugelassen haben, sollten bei der De-Installation die vorigen Dateizuordnungen wiederhergestellt werden. Die Zuordnungen manuell wieder auf den ursprünglichen Stand zu bringen ist mühsam. Windows verwaltet sie in zwei Stufen: Zuerst ordnet es die Datei-Endungen intern bestimmten Dateitypen zu, dann diesen Dateitypen die Programme, die dafür zuständig sind. Wenn sich eine Software, die Sie installieren, als voreingestelltes Programm etwa für TXT-Dateien anmelden möchte, kann sie das deshalb auf zwei Arten tun: Entweder übernimmt sie das Öffnen des Dateityps, den Windows den TXT-Dateien zugeordnet hat. Das ist standardmäßig der Dateityp „txtfile“. Sie kann aber auch Dateien mit der Endung TXT einen neuen Typ verpassen, etwa „Editor.textfile“, und sich für diesen als voreingestelltes Programm eintragen. Wenn Sie mehrere Anwendungen installieren und de-installieren, die das beim gleichen Dateityp unterschiedlich handhaben, sind die Zuordnungen irgendwann fast zwangsläufig kaputt. Um die Verwirrung zu komplettieren, gibt es die Zuordnungen auch noch mehrfach: einmal systemweit und jeweils pro Benutzer. Software-Installationen ändern die Zuordnungen normalerweise auf Systemebene. Wenn Sie jedoch ein Programm aufrufen und in dessen Einstellungen festlegen, dass es bestimmte Dateitypen standardmäßig öffnen soll, gilt das meist nur für den aktuellen Benutzer. Es ist umständlich, die aktuelle Einstellung für das Öffnen eines bestimmten Dateityps zu ermitteln und festzustellen, woher sie stammt – aus den System- oder aus den Benutzereinstellungen. Entsprechend mühsam ist ein Fehler zu orten und zu korrigieren. In einem beliebigen Ordnerfenster können Sie es über „Extras, Ordneroptionen“ auf der Registerkarte „Dateitypen“ oder direkt in der Registry versuchen. Komfortabler geht es mit unserem Tool pcwTypCheck. Beim ersten Start speichert es alle Dateizuordnungen – das dauert einige Minuten. Bei seinem nächsten Start erfasst es alle Änderungen. Diese können Sie durch jeweils einen Klick auf die Kategorien „Dateityp-Zuordnung“, „Doppelklick-Befehle“ und „Spezielle Befehle“ anschauen. Sobald Sie das Kästchen vor einer angezeigten Änderung aktivieren und auf „Übernehmen“ klicken,macht das Tool diese rückgängig. Wenn Sie mit den durch ein Installationsprogramm geänderten Dateizuordnungen zufrieden sind und sie endgültig übernehmen wollen, klicken Sie auf „Neue Backup-Listen“.

-cl/-akr

Zurück | Nach oben | Weiter
pcwNetBookmarks 0.1.6: Mobile Lesezeichen | Zum Anfang | pcwPDF2HTML: PDF-Dateien ins HTML-Format konvertieren


pcwPDF2HTML: PDF-Dateien ins HTML-Format konvertieren
Zurück Tools Weiter

pcwPDF2HTML: PDF-Dateien ins HTML-Format konvertieren

Problem: Sie möchten PDF-Dokumente in ein anderes Format konvertieren, beispielsweise nach HTML. Dabei soll das Layout so weit wie möglich erhalten bleiben.

Lösung: Adobe Reader bietet mit „Datei, Als Text speichern“ bereits eine Funktion zum Speichern von Dokumenten als TXT-Dateien. Bei komplexen Dokumenten mit mehrspaltigem Satz und Bildern kann das Ergebnis damit jedoch nicht befriedigen. Zeilen geraten durcheinander, und Bilder exportiert der Reader überhaupt nicht. Eine bessere Lösung bietet das kostenlose Tool Pdftohtml für die Kommandozeile. Es exportiert PDF-Dateien nach HTML und erzeugt dabei mit Hilfe von GNU Ghostscript 7.07 aus den grafischen Elementen ein Hintergrundbild, über das es den Text legt. Dadurch bleiben auch Texturen, Linien und Abbildungen erhalten. Kleinere Fehler müssen Sie allerdings auch bei Pdftohtml in Kauf nehmen: Die Schriftgrößen stimmen nicht immer, senkrecht laufender Text erscheint meist waagerecht, und komplexe Tabellen sind anders als das Original formatiert und so mitunter schwer lesbar. Im Allgemeinen erzielt das Tool jedoch ansehnliche Ergebnisse im HTML-Format. Um den Umgang mit Pdftohtml so komfortabel wie möglich zu gestalten, haben wir ein eigenes Front-End namens pcwPdf2html erstellt. Damit exportieren Sie einzelne oder mehrere Dateien, aber auch ganze Ordner mit PDF-Dokumenten nach HTML. Pdftohtml und GNU Ghostscript 7.07 sind in dieses PC-WELT-Programm bereits integriert. Nach der Installation starten Sie das Programm standardmäßig über das Start- Menü und „PC-WELT, pcwPDF2HTML“. Über „Hinzufügen“ wählen Sie die Dateien zum Konvertieren aus. Die Dateinamen lassen sich auch per Drag & Drop aus dem Windows-Explorer in die Liste ziehen. Legen Sie dann die Exportoptionen fest. Bei mehrspaltigen Dokumenten mit Bildern aktivieren Sie beispielsweise „komplexe Dokumente“. Klicken Sie dann auf „Konvertieren“. Die HTML- und PNG-Dateien legt das Programm im Ordner „Out“ im Installationsverzeichnis ab. Wenn Sie ein anderes Zielverzeichnis wünschen, aktivieren Sie die Klickbox vor „Ausgabe in“ und geben dahinter einen anderen Ordner an. Infos zu den einzelnen Exportoptionen finden Sie nach einem Klick auf „Hilfe“ in der beigelegten Dokumentation.

. pcwPDF2HTML: Unser Tool verwandelt blitzschnell PDF-Dateien ins HTML- oder XML-Format

Abbildung 27. . pcwPDF2HTML: Unser Tool verwandelt blitzschnell PDF-Dateien ins HTML- oder XML-Format

-te

Zurück | Nach oben | Weiter
pcwTypCheck: Dateizuordnungen sichern und reparieren | Zum Anfang | pcw1-1.v06: Daten synchronisieren


pcw1-1.v06: Daten synchronisieren
Zurück Tools Weiter

pcw1-1.v06: Daten synchronisieren

Problem: Archive mit Tausenden von Dateien auf mehreren Datenträgern auf identischem Stand zu halten, ist eine knifflige Aufgabe. Mit dem Kopieren allein ist es nicht getan – alle Änderungen wie Löschen oder Umbenennen sollen exakt übernommen werden.

Lösung: Die Aufgabe große Datenbestände schnell und exakt zu synchronisieren – also auf dem Ziel Fehlendes zu kopieren und Überzähliges zu löschen erledigt zuverlässig unsere Batch-Datei pcw1-1.v06. Sie erhalten nach dem Durchlauf der Batch einen identischen Datenbestand auf Quelle und Ziel. Wichtig: pcw1-1.v06.BAT synchronisiert die Ordner nur in eine Richtung. Maßgeblich ist nur der Datenbestand des Quellordners. Als Kopier-Software dient das Standardprogramm Xcopy mit diversen Schaltern, die alle fehlenden und neueren Dateien berücksichtigen. Die Batchdatei kann auf zwei Arten arbeiten: interaktiv und automatisch. Voraussetzung für den automatischen Ablauf ist, dass die drei notwendigen Argumente (Quellordner, Zielordner und Modus) bereits auf der Kommandozeile, per Batchdatei oder in einer Verknüpfung übergeben werden. Aus technischen Gründen fragt pcw1-1.v06.BAT auch beim interaktiven Ablauf nicht mehr nach, ob überzählige Datei-Objekte gelöscht werden sollen. Gelöscht und kopiert wird grundsätzlich nur auf dem Zielordner. -ha

Zurück | Nach oben | Weiter
pcwPDF2HTML: PDF-Dateien ins HTML-Format konvertieren | Zum Anfang | pcwArbeitsplatzErweitern1.1: Eigene Links Im Arbeitsplatz


pcwArbeitsplatzErweitern1.1: Eigene Links Im Arbeitsplatz
Zurück Tools Weiter

pcwArbeitsplatzErweitern1.1: Eigene Links Im Arbeitsplatz

Problem: Im Arbeitsplatz finden sich neben den lokalen Datenträgern und Netzlaufwerken Verknüpfungen zur Systemsteuerung oder zu bestimmten Ordnern und Anwendungen. Sie möchten an dieser prominenten Stelle eigene Links zu Ordnern und Anwendungen erzeugen.

Lösung: Beim Arbeitsplatz handelt es sich nicht um einen Dateiordner, sondern um einen Systemordner mit „Namespace“-Einträgen. Das bedeutet, dass die hier enthaltenen Objekte nicht normale Ordner und Verknüpfungen sind, sondern Shell-Erweiterungen – virtuelle Objekte, die ausschließlich in der Registry festgelegt werden. Über Registry- Einträge können Sie also auch eigene „Namespace“-Einträge im Arbeitsplatz anlegen. Manuell ist das jedoch mühsam, da Sie für jeden neuen Eintrag eine umfangreiche Schlüsselstruktur inklusive eindeutiger Class-ID definieren müssen. Viel einfacher geht’s mit unserem Script pcwArbeitsplatzErweitern1.1. Das HTA-Tool unterstützt neben Ordnern auch Programme. Rufen Sie es auf, und tragen Sie im obersten Feld den gewünschten Namen der neuen Verknüpfung ein, darunter den Pfad zum Ordner oder zur Anwendung. Im letzten Feld definieren Sie ein beliebiges Icon für den neuen Eintrag. Beim vorgegebenen Standardwert handelt es sich um das übliche Ordner-Icon. Wenn Sie einen Link zu einer EXE-Datei anlegen und deren Icon übernehmen möchten, geben Sie als „Pfad zum Icon“ einfach den Pfad zur EXE-Datei ein, gefolgt von „,0“ – also etwa „c:\windows\system32\calc. exe,0“.Nachdem Sie alles richtig eingetippt haben, klicken Sie auf „Neuer Eintrag“. Das Tool zeigt den neuen Namespace-Eintrag nun im Programmfenster an. Beim nächsten Aufruf des Arbeitsplatzes ist er zu sehen. Sie können bis zu 30 Verknüpfungen über unser Script anlegen und wieder einzeln entfernen. Zum Löschen eines Eintrags rufen Sie das Tool auf, aktivieren die Klickbox neben dem betreffenden Eintrag und klicken auf„Löschen“. Sie können über unser Script auch Internet-Verknüpfungen anlegen. Tragen Sie dazu in die Pfad-Zeile einfach <Pfad>\iexplore.exe <URL> ein, wenn Sie mit dem Internet Explorer surfen. Statt <URL> setzen Sie die gewünschte

Adresse ein.

-cl

. pcwArbeitsplatzErweitern1.1: Mit diesem Tool fügen Sie dem Ordner „Arbeitsplatz“ wichtige Verknüpfungen hinzu.

Abbildung 28. . pcwArbeitsplatzErweitern1.1: Mit diesem Tool fügen Sie dem Ordner „Arbeitsplatz“ wichtige Verknüpfungen hinzu.

Zurück | Nach oben | Weiter
pcw1-1.v06: Daten synchronisieren | Zum Anfang | pcwCleaner: Radikal aufräumen


pcwCleaner: Radikal aufräumen
Zurück Tools Weiter

pcwCleaner: Radikal aufräumen

Problem: Sie wollen überflüssige Dateien loswerden, um Übersicht und Platz zu schaffen – und Sie wollen die zahllosen Benutzerspuren entfernen. Dabei sind etliche Stellen im Dateisystem und der Registry zu berücksichtigen.

Lösung: Unser pcwCleaner erspart es Ihnen, alle Speicherorte manuell aufzusuchen. Es beseitigt in einem Aufwasch den Großteil des Mülls. Sie starten das Script und wählen die Löschoptionen aus. Hilfetexte können Sie über die jeweiligen Buttons aufrufen. Klicken Sie dann auf „Clean-Vorgang starten“. Aus Ihren Einstellungen baut das Script eine Säuberungsbatch, die zur nächsten vollen Minute startet. Die Arbeit der Batchdatei können Sie im Kommandozeilen-Fenster nachvollziehen. Voraussetzung für das Ausführen der HTA sind Admin-Rechte.

-ha

Zurück | Nach oben | Weiter
pcwArbeitsplatzErweitern1.1: Eigene Links Im Arbeitsplatz | Zum Anfang | pcwPDF: PDF-Konvertierer


pcwPDF: PDF-Konvertierer
Zurück Tools

pcwPDF: PDF-Konvertierer

Problem: Sie möchten Dateien in das PDF-Format konvertieren und suchen hierfür eine Freeware-Lösung. Ihnen ist bekannt das Open Office Paket eine solche Lösung anbietet, wollen aber auf die Installation des Gesamt-Pakets verzichten.

Lösung: Unsere Script-Lösung wandelt Text- und Tabellendokumente (DOC, ODT, XLS, ODS), Präsentationen (PPT, ODP) sowie die Bildformate JPG und PNG in das PDF-Format um (pcwPDFServer und pcwPDFKonverter zusammen im Paket pcwPDF). Text- und Tabellendokumente lassen sich außerdem als HTML, DOC oder RTF speichern. Sie können die Tools durch eigene Anpassungen auf alle Im- und Exportformate erweitern, die Open Office anbietet.

Konvertieren über den Browser: pcwPDFServer besteht aus einem Webserver und einigen Scripts, die die Konvertierung steuern. Entpacken Sie das Programmpaket von der CD in ein Verzeichnis, dessen Namen keine Leer- oder Sonderzeichen enthält, beispielsweise nach C:\pcwPDF. Open Office ist in der Portable-Variante bereits enthalten. So lässt sich die Anwendung auch auf Rechnern einsetzen, auf denen das Paket nicht eingerichtet ist. Bereits installierte Open-Office-Versionen können Sie parallel betreiben. Starten Sie die Batchdatei C:\pcwPDF\pcwPDFServer.BAT mit administrativen Rechten. Die Batchdatei aktiviert sowohl Open Office als Server als auch den mitgelieferten Webserver. Starten Sie dann einen Browser, und geben Sie als Adresse „http://localhost:8000“ ein. Über die Web-Oberfläche wählen Sie eine Datei zum Konvertieren aus und klicken auf „Absenden“. Die konvertierte Datei können Sie über den Browser speichern oder mit der zugehörigen Anwendung öffnen. Bei PDF-Dateien sind zusätzliche Optionen möglich, etwa die Vergabe eines Kennworts fürs Öffnen oder die Beschränkung auf eine bestimmte Seitenzahl. Automatisches Konvertieren: Die Web-Oberfläche ist zwar bequem zu bedienen, Sie können dabei aber immer nur eine Datei auf einmal konvertieren. Diese Begrenzung besitzt pcwPDFKonverter nicht, dafür können Sie hier aber keine Optionen übergeben. Nach dem Start von pcwPDFKonverter.BAT überwacht das Tool den Ordner „\in“ im Installations-Verzeichnis. Wenn Sie eine oder mehrere Dateien in diesen Ordner kopieren, konvertiert pcwPDFKonverter diese automatisch und legt die PDF-Dateien im Ordner „\out“ ab. Die Quelldateien werden anschließend gelöscht. Nutzen im Netz: Wenn Sie die Ordner „in“ und „out“ im Netzwerk freigeben, können auch Anwender an anderen PCs den Dienst nutzen. Das Gleiche gilt auch für pcwPDF- Server. Hier müssen Sie allerdings in der Firewall den Port 8000 für den Zugriff auf den Webserver freischalten.

So funktionieren die Tools: Für pcwPDF-Server und pcwPDFKonverter haben wir die Programmiersprache Python gewählt, weil es sich dabei um eine Scriptsprache handelt und die Programme sich dadurch leicht anpassen lassen. Der Python-Interpreter ist in aktuellen Open-Office-Versionen (bei einer vollständigen Installation) und Portable Open Office bereits enthalten, so dass keine zusätzliche Software nötig ist. Die Verbindung zu Open Office erfolgt über die plattformunabhängige Python-Uno-Bridge PyUNO (Universal Network Objects). Die Scripts laufen deshalb unter allen Betriebssystemen, für die Python und Open Office zur Verfügung stehen: Windows, Linux, Mac-OS X, Solaris und FreeBSD.

Open Office als Server starten: Grundlage für beide Programme ist Open Office im Server-Modus. Der Start erfolgt über die Kommandozeile und den Befehl

soffice.exe "-accept=socket,host=localhost,port=2002;urp;"

Damit haben wir das Programm angewiesen, Verbindungen auf Port 2002 zu akzeptieren. Bei Übergabe der zusätzlichen Parameter „-nologo -headless“ startet Open Office ohne sichtbares Programmfenster. Der Prozess lässt sich danach nur über den Taskmanager beenden. Wenn Sie ein bereits installiertes Open Office verwenden möchten, kopieren Sie den Inhalt der pcwPDF-Version ohne Open Office in das Installationsverzeichnis. Passen Sie danach die Pfadangaben in den Batchdateien so an, dass sie denen in Ihrer Installation entsprechen. Öffnen Sie die Datei „OpenOffice.org 2.0\share\registry\data\org\openoffice\Setup.xcu“, und suchen Sie die Zeile „<node oor:name=“Office“>“ Tragen Sie direkt dahinter die folgenden Zeilen ein.

<prop oor:name="ooSetupConnectionURL">
<value>socket,host=0,port=2002;urp; StarOffice.ServiceManager</value>
</prop>

Beenden Sie anschließend den Open-Office-Schnellstarter im Systray, und starten Sie Open Office über „Start, Programme, Autostart, OpenOffice.org 2.0“ neu.

Server steuern: Der Start der Python-Scripts muss mit dem in Open Office enthaltenen Python erfolgen. Dazu dient die Batchdatei „OpenOfficeorgPortable\App\openoffice\program\python.bat“. Die Zeile „python.bat spyce.py -l“ startet den Webserver Spyce (http://spyce.sourceforge.net, in Open Office nicht standardmäßig enthalten). Der Programmcode liegt in der Datei „spyce-2.1\www\index.spy“. Per Browser aufgerufen, stellt diese – nach einem Klick auf „Absenden“ – über die Zeile

ctx = resolver.resolve(„uno:socket,host=localhost,port=2002;urp;StarOffice.ComponentContext“)

eine Verbindung mit dem Server her. Exportfilter verwenden: Je nach Dateinamensendung ermittelt Index.SPY dann den erforderlichen Exportfilter. Dieser hängt vom Programm-Modul ab, in dem Open Office die Datei öffnet. Der Filter für die Textverarbeitung heißt „writer_pdf_Export“, der für Bilder „draw_pdf_Export“. Eine Liste aller möglichen Filternamen finden Sie in der Datei OoFilter.ODT im Installationsverzeichnis von pcwPDFServer. Die Zuweisung erfolgt im Script über die Listen „extlist_doc“ und „extlist_html“. Um hier beispielsweise die Umwandlung von TIF-Dateien nach PDF zu ermöglichen, brauchen Sie das zusätzliche Listenelement „‚.tif‘: ‚draw_html_Export‘“. Bei nicht in der Liste enthaltenen Dateitypen versucht das Skript immer die Konvertierung über das Modul der Textverarbeitung. Schlägt diese fehl, gibt es eine Fehlermeldung aus. Dateien konvertieren: Beim PDF-Export verwendet Index.SPY den folgenden Python-Code nur, wenn keine zusätzlichen Optionen vorhanden sind. Über die Zeile

doc = desktop.loadComponentFromURL(‚file:///‘+url, „_blank“, 0,tuple(loadproperties))

öffnet Open Office das Dokument, und über die Zeile

doc.storeToURL(url_save,outproperties)

legt es das konvertierte Dokument im TMP-Verzeichnis des Webservers ab. Die restlichen Programmzeilen sorgen für die Übermittlung des Dokuments an den Browser. Hat der Benutzer im Formular Optionen ausgewählt, leitet Index.SPY das Dokument über die Funktion „executeScript“ an das Basic-Makro „Standard.pdf.ExPortDoc“ weiter. Grund für diesen Umweg ist ein Fehler in PyUNO, der die Übergabe von zusätzlichen Parametern für die PDF-Konvertierung verhindert. Aus diesem Grund mussten wir bei pcwPDFServer zusätzlich ein Basic-Makro verwenden. Dieses steht in Sachen Geschwindigkeit dem Python-Skript zwar in nichts nach, erschwert jedoch das Abfangen von Fehlern. Schlägt die Verarbeitung fehl, etwa durch Aufruf eines unpassenden Export-Filters, findet das Python-Script die konvertierte Datei nicht und bricht die Aktion ab.

-te

Zurück | Nach oben
pcwCleaner: Radikal aufräumen | Zum Anfang


Die 50 wichtigsten Tipps und Tools
Weiter

Die 50 wichtigsten Tipps und Tools

Tipps und Tricks zu Sicherheit, System, Netzwerk und Desktop

PC- WELT

Copyright © 2002-2007 IDG Magazine Media GmbH

2007-11-08

Zusammenfassung

Über die Jahre haben unsere Redakteure so einige Geheimnisse über das verbreitetste Microsoft-Betriebssystem aufgedeckt, Unzulänglichkeiten mit Tools behoben, Sicherheitslücken offenbart und geschlossen oder einfach den alltäglichen Umgang mit XP erleichtert. Im Bereich Sicherheit beispielsweise finden sich immer Laptops oder Rechner mit installiertem XP-Home, bei denen das Administrator-Passwort nicht gesetzt ist, eine gravierende Sicherheitslücke. Einige Anwender haben sich schon daran gewöhnt, intuitiv die Ballon-Tipps weg zu klicken, die alle Nase lang in der Taskleiste auftauchen. Dabei bringen Sie die nervigen Meldungen mit einem kleinen Eingriff für immer zum Verstummen. Auch der Desktop lässt sich so umgestalten, das Sie beim Aufruf wichtiger Funktionen durch übermäßiger Maus-Nutzung keine Sehnenscheiden-Entzündung mehr befürchten müssen. Und für den Umgang mit XP-Freigaben im Netzwerk brauchen Sie keine Administrator-Prüfung mehr ablegen, unsere Tipps machen Sie blitzschnell zum Experten. Das Resultat Ihrer Lektüre: Ein sicheres, bequemes, persönliches und funktionales Windows, das Ihnen ohne lästige Neuinstallation noch einige Jahre intensiver Nutzung beschert.

Inhaltsverzeichnis

Sicherheit
XP Home: Administrator-Passwort fehlt
Eingeschränktes Konto: So bremsen Sie Schädlinge aus
Windows-Firewall: Wer darf was?
Prozessdatenbank: Wissen, was läuft
Autostart: Startrampen aufspüren und sperren
Datei-Erweiterungen: Systemweit sichtbar machen
PC Nutzung kontrollieren: Check von Logons und Systemlaufzeit
XP Prome: Fast ein Pro mit zwei Klicks
Ausführ-Sperre: Alle Programme bis auf eine Auswahl verbieten
Lokaler PC: Ordner sperren oder unzugänglich machen
System
XP-Comics: Die lästigen Infos abschalten
Partitonsverwaltung: Ordner als Laufwerk - Laufwerk als Ordner
MMC: Alles unter einer Haube
Überflüssige Zubehör: Versteckte De-Installationseinträge anzeigen
Geräte-Manager: Mehr Infos mit Umgebungsvariable
Dateiverwaltung: Kompletter Umzug des eigenen Profils
Backups: Wege zur Sicherung Ihres Systems
Systemabsturz: Kein Blue Screen - keine Infos
Systemrettung: Wiederherstellung ohne Oberfläche erreichen
USB-Datenträger: Ordnung ohne Laufwerksbuchstaben
Netzwerk
Sicherheit: Versteckte Zugriffe aufspüren
Freigaben: Keine Gastfreundschaft unter Windows XP Pro
Freigaben: Rechte zum Lesen und Schreiben gezielt regeln
Fernwartung: Rechner gezielt fernsteuern lassen
Freigaben: Netzfreigaben und NTFS-Rechte
Unsichtbar: Windows-PCs im Netz verstecken
Kommandozeile: Mit Netsh.exe das Netzwerk konfigurieren
Fernsteuerung I: Start und Remote-Shutdown
Fernsteuerung II: Von außen Programme starten
Netzwerkumgebung: Langsame Anzeige
Desktop
Superleiste: Ordnerstruktur in der Symbolleiste
Übersichtlicher Desktop: Multifunktionale Desktop-Icons
Windows Explorer: Suchen und Filtern im Explorer-Fenster
Infotipps ausbauen: Schnelle Maus-Infos
Aufräumen: Nie wieder gelbe Zettel am Monitor
Scharfe Schrift: Bessere Darstellung mit dem Cleartype Tuner
Datei-Indizierung: Schlagwortsuche über NTFS-Streams
Anwendungen schneller starten: Schlauerer „Ausführen“-Dialog
Archivierung: Ordnerlisten bearbeiten und ausdrucken
Flotte Verzeichnis-Erstellung: Quick-Ordner
Tools
pcwAnnoyances: XP optimal anpassen
pcwPatchloader: Praktischer Update-Manager
pcwMegaLoader: Gratis Tools von Microsoft
pcwNetBookmarks 0.1.6: Mobile Lesezeichen
pcwTypCheck: Dateizuordnungen sichern und reparieren
pcwPDF2HTML: PDF-Dateien ins HTML-Format konvertieren
pcw1-1.v06: Daten synchronisieren
pcwArbeitsplatzErweitern1.1: Eigene Links Im Arbeitsplatz
pcwCleaner: Radikal aufräumen
pcwPDF: PDF-Konvertierer

Version 1.9

Weiter
Sicherheit